%%ItemTitle%%

M-Files API
Introduction

M-Files API provides an application programming interface for M-Files. The API makes it possible to access M-Files from within scripting environments. For example, you can use it to generate reports based on the contents of a document vault or to integrate M-Files into your application. The object model of the M-Files API is easier to understand if you are familiar with the key concepts of M-Files. Please refer to the user guide and other software documentation for generic information on M-Files concepts.

With the M-Files API, you can access and manage objects contained in an M-Files document vault. This means that you can create, view, modify and destroy objects as well as control their visibility. M-Files API is an ActiveX/COM DLL and can be used with Visual Basic, VBScript, C++, and all .NET languages such as C#.

For M-Files API samples, visit https://www.m-files.com/api.


%%phrase%%

M-Files API 22.9.11757.0
Overview
Send comments

Glossary Item Box

Description

M-Files API is a collection of classes and operation interfaces. Each class represents a feature or data item of the M-Files system. With the API, you can access, modify and create documents stored in an M-Files vault. You can also perform searches and display documents and other objects, access and modify the metadata associated with documents, access and modify document workflows, and much more.

You can also make use of the M-Files Web Service API for programmatic access to M-Files through a REST-like interface, or the M-Files UI Extensibility Framework for developing external add-ins (M-Files Applications) to modify M-Files Desktop behavior.

Follow these links for the documentation:

  • M-Files Web Service API (REST API)
  • M-Files UI Extensibility Framework

The operation mode of the M-Files API is chosen by the top-level access class; environments with the M-Files client application installed can use the M-Files API in the client mode and access the MFilesClientApplication interface. If the M-Files API is used in an environment without the M-Files client application, the M-Files server can be accessed directly by using the MFilesServerApplication interface.

The main functionality is built around the vault object, which can be acquired by using either application interface. The vault object contains various operation interfaces, which can be used to perform operations or to access other support objects.

Navigability among the M-Files API classes. The diagram does not contain all of the classes and has been simplified for clarity.

For M-Files API samples, visit https://www.m-files.com/api.

Objects and Methods for Administrative Operations

Objects and methods that have their name postfixed with "Admin" (such as ObjTypeAdmin and VaultWorkflowOperations.AddWorkflowAdmin) provide functionality specifically available in M-Files Admin.

Classes

Class Module | Description
AccessControlEntry | The AccessControlEntry class represents an access control entry (ACE).
AccessControlEntryContainer | The AccessControlEntryContainer class represents a collection of access control entries (ACEs).
AccessControlEntryData | The AccessControlEntryData class represents the permissions part in an access control entry.
AccessControlEntryKey | The AccessControlEntryKey class specifies the user or user group for an access control entry.
AccessControlEntryKeys | The AccessControlEntryKeys class represents a collection of access control entry (ACE) keys.
AccessControlList | The AccessControlList class represents an access control list (ACL).
AccessControlListComponent | The AccessControlListComponent specifies a set of entries within an access control list. The entries within the component have a common source such as the object itself in the case of a custom component or a property value in the case of automatic components.
AccessControlListComponentContainer | The AccessControlListComponentContainer class represents a collection of access control list (ACL) components.
AccessControlListComponentKey | The AccessControlListComponentKey class identifies a component by it's source.
AccessControlListComponentKeys | The AccessControlListComponentKeys class represents a collection of automatic access control list (ACL) component sources.
AccessControlLists | AccessControlLists is a collection AccessControlList objects.
ActionConvertToPDF | The ActionConvertToPDF class represents a convert to PDF action in a workflow state.
ActionCreateAssignment | The ActionCreateAssignment class represents a create assignment action in a workflow state.
ActionDefinition | The 'ActionDefinition' class contains type-specific action details.
ActionDefinitions | The 'ActionDefinitions' class represents a collection of action descriptions.
ActionSendNotification | The ActionSendNotification class represents a send notification action in a workflow state.
ActionSetPermissions | The ActionSetPermissions class represents a set permissions action in a workflow state.
ActionSetProperties | The ActionSetProperties class represents a set properties action in a workflow state.
AdditionalClassInfo | The 'AdditionalClassInfo' class contains type-specific details of an object class.
AdditionalFolder | The AdditionalFolder class represents a separate location for the vault's file data.
AdditionalFolders | A collection of additional folders.
ApplicationBroadcastMessage | A data object for storing broadcast message data.
ApplicationBroadcastMessages | "ApplicationBroadcastMessagess" is a collection of "ApplicationBroadcastMessage" objects.
ApplicationTaskInfo | A data object for storing task data.
ApplicationTaskInfos | "ApplicationTaskInfos" is a collection of "ApplicationTaskInfo" objects.
ApprovalAssignmentClassInfo | The 'ApprovalAssignmentClassInfo' class contains assignment-specific details of an approval assignment object class.
ArchiveOldVersionsJob | The ArchiveOldVersionsJob class represents a job that moves old versions of objects to a content package.
AssignmentClassInfo | The 'AssignmentClassInfo' class contains assignment-specific details of an assignment object class.
AssociatedPropertyDef | The AssociatedPropertyDef class represents the property definition of a class.
AssociatedPropertyDefs | A collection of property definitions associated with the class.
AttachVaultOptions | The 'AttachVaultOptions' class represents options for attaching vaults.
AuthenticationResult | The 'AuthenticationResult' class represents the description for an authentication attempt's result.
AuthenticationResultIntermediate | The 'AuthenticationResultIntermediate' class represents the description for an authentication attempt's intermediate result.
AuthenticationResultServerFinal | The 'AuthenticationResultServerFinal' class represents the description for a server authentication attempt's final result.
AuthenticationResultVaultFinal | The 'AuthenticationResultVaultFinal' class represents the description for a vault authentication attempt's final result.
AutomaticMetadataResult | The 'AutomaticMetadataResult' class represents the output data from the automatic metadata retrieval operation.
AutomaticPermissions | Specifies the automatic ACL for a value list item.
AutomaticValue | The AutomaticValue class represents an automatic value specification.
BackupJob | A class that represents a backup job.
BooleanValue | A class that represents a simple boolean value.
ClassGroup | A class group contains a set of classes.
ClassGroups | A collection of ClassGroup objects.
ClientCapabilities | A data object for specifying the capabilities of an M-Files client instance.
ConnectionData | A data object for specifying the M-Files server connection details.
CopyVaultJob | The CopyVaultJob class represents a copy vault job.
CopyVaultJobOutputInfo | The CopyVaultJobOutputInfo class represents the results of a copy vault job.
CustomApplication | The CustomApplication class represents an application installed in the vault.
CustomApplications | CustomApplications is a collection of CustomApplication objects.
DailyTrigger | The DailyTrigger class represents daily trigger.
DataFunctionCall | An object for managing Expression object data functions.
DataSet | The DataSet class represents a set of data that can be exported from a vault.
DataSetExportingStatus | The DataSetExportingStatus class represents the current state of a data set export operation.
DataSets | A collection of data sets.
DefaultProperties | DefaultProperties is a collection of DefaultProperty objects.
DefaultProperty | The DefaultProperty class represents a default property specification.
EmailMessageInformation | A class that represents information collected from an e-mail message.
EventHandler | The EventHandler class represents an event handler.
EventHandlers | A collection of event handlers.
ExportContentJob | The ExportContentJob class represents a content export job.
ExportStructureItem | The ExportStructureItem class represents a metadata structure element that is exported from the vault.
ExportStructureItems | The ExportStructureItems class represents a collection of metadata structure elements that are exported from the vault.
Expression | The Expression class represents an expression that can be evaluated.
ExpressionEx | The ExpressionEx class represents an extended expression.
ExpressionExs | ExpressionExs is a collection of ExpressionEx objects.
Expressions | Expressions is a collection of Expression objects.
ExtensionAuthenticationResponse | The 'ExtensionAuthenticationResponse' class represents an extension authentication response.
ExtensionAuthenticationStatus | The 'ExtensionAuthenticationStatus' class represents an extension authentication status.
ExtensionAuthenticationStatuses | The 'ExtensionAuthenticationStatuses' class represents extension authentication statuses.
ExtensionAuthenticationTarget | The 'ExtensionAuthenticationTarget' class represents an extension authentication target.
ExtensionAuthenticationTargets | The 'ExtensionAuthenticationTargets' class represents extension authentication targets.
ExternalObjectTypePluginInfo | A data object for storing information about external object type plugin.
ExternalObjectTypePluginInfos | "ExternalObjectTypePluginInfos" is a collection of "ExternalObjectTypePluginInfo" objects.
ExternalView | The 'ExternalView' class represents an external view.
ExternalViewID | The 'ExternalViewID' class represents an external view.
FileClass | The FileClass class represents a creatable file type in Windows.
FileClasses | FileClasses is a collection of FileClass objects.
FileDownloadSession | The FileDownloadSession class represents a file download session.
FileInformation | A class that represents information extracted from a file.
FileSize | The FileSize class represents the size of an object file.
FileVer | The FileVer class represents a single file version.
FileVers | The FileVers class represents the collection of FileVer objects.
FolderContentItem | A class that represents a single folder content item.
FolderContentItems | A collection of folder content items.
FolderData | The FolderData class represents a folder data.
FolderDef | A class that represents a folder definition.
FolderDefs | Collection of folder definitions.
FolderID | The FolderID class represents a folder ID.
FolderListingColumn | The 'FolderListingColumn' class represents a single column setting of a folder listing.
FolderListingColumns | The 'FolderListingColumns' collection represents a set of column settings for a folder listing.
FolderListingColumnSorting | The 'FolderListingColumnSorting' class represents a single column sorting setting for a folder listing.
FolderListingColumnSortings | The 'FolderListingColumnSortings' collection represents a set of column sorting settings for a folder listing.
FolderListingUIState | The 'FolderListingUIState' class represents the UI settings for a listing within the settings for an M-Files folder.
FolderNameListing | The FolderNameListing class represents a folder name collection.
FolderUIState | The 'FolderUIState' class represents the UI settings of a single M-Files folder.
IDRange | The IDRange class represents minimum and maximum IDs of the range
IDs | IDs is a collection of IDs of any type.
Impersonation | A class that defines an impersonation.
ImportContentJob | The ImportContentJob class represents a content import job.
IndirectPropertyID | The IndirectPropertyID class represents a multi-level property ID.
IndirectPropertyIDLevel | The IndirectPropertyIDLevel class represents a single level of a multi-level property ID.
IServerDataPushSink | An interface that implements data sink for server requests.
KeyNamePair | The KeyNamePair class represents a key name pair.
KeyNamePairs | The KeyNamePairs class is a collection of KeyNamePair objects.
Language | The Language class represents a single vault language.
LanguageDetectionResult | The "LanguageDetectionResult" class contains the results of a call used for detecting the language of plain text content.
Languages | A collection of languages.
LicenseStatus | A class that represents the status of the license.
LoginAccount | The LoginAccount class represents a login in the server.
LoginAccountPersonalInformation | The LoginAccountPersonalInformation class represents the personal information of a login account.
LoginAccounts | The LoginAccounts class is a collection of LoginAccount objects.
Lookup | Lookup specifies a single lookup value.
Lookups | Lookups is a collection of lookups and can represent the values of a multi-select lookup.
MetadataStructureAliases | The StructureAliases class.
MetadataStructureSelector | The 'MetadataStructureSelector' class represents a metadata structure element selection rule for the content to be exported from the vault.
MetadataStructureSelectors | The 'MetadataStructureSelectors' class represents a collection of metadata structure selection elements.
MFilesClientApplication | The MFilesClientApplication class represents an M-Files Client application. The MFilesClientApplication class is the high-level object of the M-Files API component. This is the first object you create when writing an application that interacts with Windows Explorer using M-Files API.
MFilesServerApplication | The MFilesServerApplication class represents an M-Files API interface for the M-Files server. The MFilesServerApplication class is the high-level object of the M-Files API component. This is the first object you create when writing an application that interacts directly with the M-Files server.
MFilesVersion | The MFilesVersion class.
MonthlyDateTrigger | The MonthlyDateTrigger class represents monthly date trigger.
MonthlyDOWTrigger | The MonthlyDOWTrigger class represents a monthly day-of-the-week trigger.
NamedACL | The NamedACL class encapsulates the data of a named access control list (ACL).
NamedACLAdmin | The NamedACL class encapsulates the data of a named access control list (ACL) (for administrative operations).
NamedACLs | NamedACLs is a collection of NamedACL objects.
NamedACLsAdmin | NamedACLsAdmin is a collection of NamedACLAdmin objects.
NamedValueNamespace | The 'NamedValueNamespace' class represents the namespace and its named values.
NamedValueNamespaces | The 'NamedValueNamespaces' class represents a collection of namespaces.
NamedValues | A collection of named values.
Number | A class that represents a simple integer value.
ObjectClass | Object classes are used for categorizing objects. The class of an object determines which metadata should be specified for the object. An object class automatically provides the object with certain properties that have been specified for the object class. Some of these properties are obligatory and must be filled in while creating a new M-Files object of this class, whereas others accept an empty (NULL) value.
ObjectClassAdmin | The ObjectClassAdmin class represents an object class (for administrative operations).
ObjectClasses | ObjectClassCollection is a collection of ObjectClass objects.
ObjectClassesAdmin | ObjectClassesAdmin is a collection of ObjectClassAdmin objects.
ObjectCreationInfo | The ObjectCreationInfo class is used for specifying the initial state of the new metadata card.
ObjectFile | The ObjectFile class represents an object file.
ObjectFileAndObjVer | The ObjectFileAndObjVer class represents a reference to an object file and an object version.
ObjectFileAndObjVerOfMultipleFiles | ObjectFileAndObjVerOfMultipleFiles is a collection of ObjectFileAndObjVer objects.
ObjectFiles | ObjectFiles is a collection of ObjectFile objects.
ObjectSearchResults | ObjectSearchResults is a collection of search results represented by ObjectVersion objects.
ObjectTypeTargetForBrowsing | The ObjectTypeTargetForBrowsing class represents the target object for showing objects related to another object.
ObjectTypeTargetsForBrowsing | ObjectTypeTargetsForBrowsing is a collection of ObjectTypeTargetForBrowsing objects.
ObjectVersion | The ObjectVersionData class represents object version data.
ObjectVersionAndProperties | The ObjectVersionAndProperties class is collection of properties and information on the object.
ObjectVersionAndPropertiesOfMultipleObjects | ObjectVersionAndPropertiesOfMultipleObjects is a collection of ObjectVersionAndProperties collections. Each ObjectVersionAndProperties collection represents the property values of one object version.
ObjectVersionData | The "ObjectVersionData" class contains the object version data.
ObjectVersionDataRequest | "ObjectVersionDataRequest" class contains the information about which data of the object version is requested.
ObjectVersionDataResult | "ObjectVersionDataResult" class contains the results of call used to get object data.
ObjectVersionDataResults | ObjectVersionDataResults is a collection of ObjectVersionDataResult objects.
ObjectVersionFile | The ObjectVersionFile class represents a file of an object.
ObjectVersionPermissions | The ObjectVersionPermissions class represents the permissions for an object version.
ObjectVersions | ObjectVersions is a collection of ObjectVersionData objects.
ObjectVersionWorkflowState | The ObjectVersionWorkflowState class represents the state of a workflow for an object version.
ObjectWindowResult | The ObjectWindowResult class encapsulates the return values of showing the metadata card.
ObjID | The ObjID class represents an object ID.
ObjIDs | ObjIDs is a collection of ObjID objects.
ObjOrFileVer | The ObjOrFileVer class represents an object version or file version of an object.
ObjOrFileVers | The ObjOrFileVers class represents the collection of ObjOrFileVer objects.
ObjType | The ObjectType class represents an object type.
ObjTypeAdmin | The ObjTypeAdmin class represents an object type (for administrative operations).
ObjTypeColumnMapping | The ObjTypeColumnMapping class represents a column mapping in an object type definition.
ObjTypeColumnMappings | ObjTypeColumnMappings is a collection of ObjTypeColumnMapping objects.
ObjTypes | ObjTypes is a collection of ObjType objects.
ObjTypesAdmin | ObjTypesAdmin is a collection of ObjTypeAdmin objects.
ObjVer | The ObjVer class represents an object version.
ObjVers | ObjVers is a collection of ObjVer objects.
ObjVerVersion | The 'ObjVerVersion' class represents an object objVerVersion.
OCROptions | The OCROptions class represents customizable options for OCR operation.
OCRPage | The OCRPage class represents a single page that contains OCR zones to be recognized.
OCRPageResult | The OCRPageResult class represents the result for a single page in OCR operation, containing results for all recognized zones on the page.
OCRPageResults | A collection of OCR page results.
OCRPages | A collection of OCR pages.
OCRZone | The OCRZone class represents a single recognition zone in OCR operation.
OCRZoneResult | The OCRZoneResult class represents the result for single recognized OCR zone.
OCRZoneResults | A collection of OCR zone results.
OCRZones | A collection of OCR zones.
OptimizeVaultJob | The OptimizeVaultJob class represents an optimize vault job on the server.
OwnerPropertyDef | The OwnerPropertyDef class represents an owner property definition of an object type.
PluginInfo | The PluginInfo class represents description of a plugin.
PluginInfos | The PluginInfos class represents a collection of plugin descriptions.
PropertyDef | The PropertyDef class represents a property definition.
PropertyDefAdmin | The PropertyDefAdmin class represents a property definition (for administrative operations).
PropertyDefOrObjectType | PropertyDefOrObjectTypes object that defines an ID of a property def or object type.
PropertyDefOrObjectTypes | PropertyDefOrObjectTypes is a collection PropertyDefOrObjectType objects.
PropertyDefs | PropertyDefs is a collection of PropertyDef objects.
PropertyDefsAdmin | PropertyDefsAdmin is a collection of PropertyDefAdmin objects.
PropertyValue | The PropertyValue class represents a property value.
PropertyValueForDisplay | The PropertyValueForDisplay class represents a property value for display purposes.
PropertyValueIconClue | PropertyValueIconClue object indicates a property value of an object that has an icon associated with the selected value list item.
PropertyValueIconClues | PropertyValueIconClues is a collection of PropertyValueIconClue objects.
PropertyValues | PropertyValues is a collection of PropertyValue objects.
PropertyValuesForDisplay | PropertyValuesForDisplay is a collection of PropertyValueForDisplay objects.
PropertyValuesOfMultipleObjects | PropertyValuesOfMultipleObjects is a collection of PropertyValues collections. Each PropertyValues collection represents the property values of one object version. Use PropertyValuesOfMultipleObjectsEx for more options.
PropertyValuesOfMultipleObjectsEx | PropertyValuesOfMultipleObjectsEx is a collection of PropertyValues collections. Each PropertyValues collection represents the property values of one object version.
PropertyValuesOfMultipleObjectsForDisplay | 'PropertyValuesOfMultipleObjectsForDisplay' is a collection of 'PropertyValuesForDisplay' collections.
PropertyValueSuggestion | The 'PropertyValueSuggestion' class represents the single property value that is a candidate for object metadata.
PropertyValueSuggestions | The 'PropertyValueSuggestions' class represents a collection of property values that are candidates for object metadata.
PropertyValuesWithIconClues | Property values with their icon clues.
PropertyValuesWithIconCluesOfMultipleObjects | Property values with their icon clues of multiple objects.
ReportAccessCredentials | The ReportAccessCredentials contains the credentials that are used when accessing reports using M-Files user account.
RestoreJob | A class that represents a restore job.
ScheduledJob | A class that represents a single scheduled job.
ScheduledJobOutputInfo | A class that represents the results of a scheduled job.
ScheduledJobRunInfo | The ScheduledJobRunInfo class represents the state of a scheduled job.
ScheduledJobs | The ScheduledJobs class represents a collection of scheduled jobs.
ScheduledJobTrigger | The ScheduledJobTrigger class represents a trigger of a scheduled job.
ScheduledJobTriggers | The ScheduledJobTriggers class represents a collection of triggers of a scheduled job.
SearchCondition | The SearchCondition class is used for accessing and setting a single search condition.
SearchConditionEx | The SearchConditionEx class represents an extended search condition.
SearchConditionExs | SearchConditionExs is a collection of SearchConditionEx objects.
SearchConditions | SearchConditions is a collection of SearchCondition objects.
SearchCriteria | The SearchCriteria class represents search conditions used in searches in Windows Explorer.
SearchDef | A class that represents a search definition.
SemanticAliases | The SemanticAliases class represents the semantic aliases of a metadata structure element.
ServerLicenseManagementOperations | A group of methods for administering license on the server.
ServerLoginAccountOperations | The ServerLoginAccountOperations class represents the available login account operations.
ServerManagementOperations | A group of methods for administering server.
ServerScheduledJobManagementOperations | The ServerScheduledJobManagementOperations class represents the available scheduled job management operations.
ServerVaultCapabilities | A data object for specifying the capabilities of an M-Files server and a vault on server.
ServerVaultManagementOperations | A group of methods for administering vaults.
ServerWOPIOperations | Methods for accessing the server WOPI operations.
SessionInfo | The SessionInfo class.
SetPropertiesParams | SetPropertiesParams collection represents the parameters for setting the properties of one object version.
SetPropertiesParamsOfMultipleObjects | SetPropertiesParamsOfMultipleObjects is a collection of SetPropertiesParams collections. Each SetPropertiesParams collection represents the parameters for setting the properties of one object version.
SharedFileInfo | The 'SharedFileInfo' class represents a description of a public file.
SharedLinkInfo | The 'SharedLinkInfo' class represents a description of a public link.
SharedLinkInfos | The 'SharedLinkInfos' class represents a collection of public link descriptions.
SharedLinkPublicOperations | A group of methods for accessing publicly shared files.
SignaturePromptInfo | The 'SignaturePromptInfo' class contains fixed prompt details of an electronic signature.
SignaturePromptInfoMetadataBased | The 'SignaturePromptInfoMetadataBased' class contains metadata-based prompt details of an electronic signature.
SignaturePromptInfos | The 'SignaturePromptInfos' class represents a collection of electronic signature prompt information descriptions.
SignaturePromptInfoSelectable | The 'SignaturePromptInfoSelectable' class contains user-selectable prompt details of an electronic signature.
SignatureSettings | The SignatureSettings class represents signature settings for a state transition in a workflow.
SourceObjectFile | The SourceObjectFile class encapsulates information that is needed when adding a new file to an object.
SourceObjectFiles | SourceObjectFiles is a collection of SourceObjectFile objects.
SQLDatabase | The SQLDatabase class represents the SQL Database.
State | The State class represents a workflow state.
StateAdmin | The StateAdmin class represents a workflow state (for administrative operations).
StateConditions | The StateConditions class represents the conditions of a workflow state.
States | States is a collection of State objects.
StatesAdmin | StatesAdmin is a collection of StateAdmin objects.
StateTransition | The StateTransition class represents a state transition in a workflow.
StateTransitionForClient | The 'StateTransitionForClient' class represents a state transition in a workflow.
StateTransitions | StateTransitions is a collection of StateTransition objects.
StateTransitionsForClient | The 'StateTransitionsForClient' class is a collection of 'StateTransitionForClient' objects.
StringData | A class that represents structured JSON or XML data as a string.
Strings | The Strings class represents a collection of strings.
StructureAlias | The StructureAlias class.
StructureAliases | The StructureAliases class.
TaskAssignmentClassInfo | The 'TaskAssignmentClassInfo' class contains assignment-specific details of a task assignment object class.
TemporarySearchView | The TemporarySearchView class represents a temporary search view.
Timestamp | The Timestamp class represents the Timestamp.
TimeZoneInformation | The TimeZoneInformation class.
TraditionalFolder | The TraditionalFolder class represents a traditional folder.
TraditionalFolderContents | The TraditionalFolderContents class represents the contents of a traditional folder.
TraditionalFolders | TraditionalFolders is a collection of TraditionalFolder objects.
TriggerType | The TriggerType class represents the type of a trigger.
TypedValue | A 'typed value' represents a value, such as text, number, date or a lookup item.
TypedValues | The TypedValue class represents a typed value collection.
UserAccount | The UserAccount class represents a user account.
UserAccounts | UserAccounts is a collection of UserAccount objects.
UserGroup | A user group can contain users and other user groups.
UserGroupAdmin | A user group can contain users and other user groups (for administrative operations).
UserGroups | UserGroups is a collection of UserGroup objects.
UserOrUserGroupID | The UserOrUserGroupID class represents a user or user group ID.
UserOrUserGroupIDEx | The UserOrUserGroupIDEx class represents a user or user group ID.
UserOrUserGroupIDExs | The UserOrUserGroupIDExs class represents a collection of user or user group IDs.
UserOrUserGroupIDs | The UserOrUserGroupIDs class represents a collection of user or user group IDs.
Validation | The Validation class represents the validation specification for, e.g., a property definition.
ValueListItem | A value list item is one item in a value list.
ValueListItems | ValueListItems is a collection of ValueListItem objects.
ValueListItemSearchResults | The ValueListItemSearchResults class represents value list item search results.
ValueListItemSearchResultsWithPermissions | ValueListItemSearchResultsWithPermissions encapsulates value list item search results and their permissions.
ValueListItemsWithPermissions | ValueListItemsWithPermissions encapsulates value list items and their permissions.
Vault | The Vault class represents the document vault.
VaultApplicationTaskOperations | The "VaultApplicationTaskOperations" class is an interface for accessing the application task queue operations on the server.
VaultAutomaticMetadataOperations | 'VaultAutomaticMetadataOperations' is an interface for working with automatically detected metadata.
VaultClassGroupOperations | The VaultClassGroupOperations class represents the available class group operations.
VaultClassOperations | The VaultClassOperations class represents the available class operations.
VaultClientOperations | The VaultClientOperations class represents the available client operations.
VaultConnection | The VaultConnection class represents a document vault connection that is available to the current Windows user.
VaultConnections | VaultConnections is a collection of VaultConnection objects.
VaultCustomApplicationManagementOperations | VaultCustomApplicationManagementOperations is an interface for managing custom applications in a vault.
VaultDataSetOperations | VaultDataSetOperations is an interface to get, trigger the refreshing of, and monitor data sets.
VaultDocumentComparisonOperations | The "VaultDocumentComparisonOperations" class is an interface for accessing the document comparison operations on the server.
VaultElectronicSignatureOperations | VaultElectronicSignatureOperations is an interface for working with electronic signatures.
VaultEventLogOperations | VaultEventLogOperations is an interface to access event logs.
VaultExtensionAuthenticationOperations | The 'VaultExtensionAuthenticationOperations' class represents the available extension authentication operations.
VaultExtensionMethodOperations | The 'VaultExtensionMethodOperations' is an interface for executing vault extension methods.
VaultExternalObjectOperations | A group of methods for handling external objects.
VaultLoginAccountOperations | The 'VaultLoginAccountOperations' class represents the available login account operations for a vault.
VaultManagementOperations | A group of methods for administering the vault.
VaultManagementOperationsAccess | A group of methods for administering vaults.
VaultNamedACLOperations | The VaultNamedACLOperations class represents the available named access control list operations.
VaultNamedValueStorageOperations | VaultNamedValueStorageOperations is an interface to get, set and remove stored named values.
VaultNotificationOperations | The 'VaultNotificationOperations' is an interface for sending notifications to the users of the vault.
VaultObjectFileOperations | A group of methods for creating and modifying object files.
VaultObjectOperations | A group of methods for creating and modifying objects.
VaultObjectPropertyOperations | A group of methods for updating and modifying the properties of an object.
VaultObjectSearchOperations | The VaultObjectSearchOperations class represents the available object search operations.
VaultObjectTypeOperations | A group of methods for creating and modifying object types.
VaultOnServer | The VaultOnServer class represents a vault in the server.
VaultProperties | A class that represents a vault on server.
VaultPropertyDefOperations | A group of methods for creating and modifying property definitions.
VaultScheduledJobManagementOperations | VaultScheduledJobManagementOperations is an interface for managing scheduled jobs in a vault.
VaultServerAttachment | A data object for storing information about which servers the vault is attached to.
VaultServerAttachments | "VaultServerAttachments" is a collection of "VaultServerAttachment" objects.
VaultServerDataPushOperations | The 'VaultServerDataPushOperations' class is an interface for establishing a communication channel to M-Files server that enables the server data push.
VaultSharedLinkOperations | The 'VaultSharedLinkOperations' class represents the available public link operations.
VaultsOnServer | ventlog
VaultTraditionalFolderOperations | The VaultTraditionalFolderOperations class represents the available traditional folder operations.
VaultUserGroupOperations | The VaultUserGroupOperations class represents the available user group operations.
VaultUserOperations | The VaultUserOperations class represents the available user operations.
VaultUserOperationsEx | The VaultUserOperationsEx class represents additional user operations.
VaultUserSettingOperations | The VaultUserSettingOperations class represents the user setting operations available for the current user.
VaultValueListItemOperations | The VaultValueListItemOperations class represents the available value list item operations.
VaultValueListOperations | The VaultValueListOperations class represents the available value list operations.
VaultViewOperations | The VaultViewOperations class represents the available view operations.
VaultWOPIOperations | Methods for accessing the vault WOPI operations.
VaultWorkflowOperations | The VaultWorkflowOperations class represents the available workflow operations.
VerifyVaultJob | The VerifyVaultJob class represents a vault verification job.
VerifyVaultJobOutput | The VerifyVaultJobOutput class represents the output of a vault verification job.
VersionComment | The VersionComment class represents a version comment of an object.
VersionComments | VersionComments is a collection of VersionComment objects.
View | The View class represents a view.
ViewLocation | A class representing the location of a view in folder structure.
Views | Views is a collection of View objects.
WeeklyTrigger | The WeeklyTrigger class represents weekly trigger.
WOPIClientAdditionalData | The WOPI client additional data object.
WOPILock | The WOPI lock object.
WOPIUserSession | The WOPI user session object.
Workflow | A class that represents a single workflow.
WorkflowAdmin | The WorkflowAdmin class represents a single workflow (for administrative operations).
Workflows | A collection of workflows.
WorkflowsAdmin | WorkflowsAdmin is a collection of WorkflowAdmin objects.
XMLSearchResult | The XMLSearchResult class represents search results in XML format.

Interfaces

Class Module | Description
IObjectComparer | An interface for providing a comparison function for sorting object collections.
IObjectFileComparer | An interface for providing a comparison function for sorting object file collections.

Public Enumerations

Enumeration | Description
MFACLComponentOverrideAccess | ACL component override access privileges.
MFACLEnforcingMode | Defines how the provided ACL is selected as input for ACL enforcing.
MFACLMode | Available ACL modes.
MFActionType | Action type values.
MFAdditionalClassInfoType | Additional class information type values.
MFApplicationLicenseStatus | Vault application license status values.
MFAssignmentType | Assignment types.
MFAttachVaultOptionsFlag | Bit flags that provide information about attach vault options.
MFAuthType | Available authentication types for logging into the document vault.
MFAutomaticPermissionsOperationOptions | Options for change automatic permissions operation.
MFAutomaticValueType | Available automatic value types.
MFAutoStateTransitionMode | Automatic state transition modes.
MFBackupType | Available backup types.
MFBuiltInDocumentClass | Document classes readily available in the system.
MFBuiltInMetadataStructureItemID | Metadata structure item IDs readily available in the system.
MFBuiltInObjectClass | Generic class identification codes.
MFBuiltInObjectType | Object types readily available in the system.
MFBuiltInPropertyDef | Property definitions readily available in the system.
MFBuiltInUserGroup | User groups readily available in the system.
MFBuiltInValueList | Value lists readily available in the system.
MFBuiltInView | Views that are readily available in the system.
MFClientType | M-Files client application type identifier.
MFConditionType | Available condition types.
MFContentType | Content type definitions.
MFCustomApplicationType | Custom application type.
MFDataFunction | Functions that operate on a property value.
MFDataType | Data type definitions.
MFDBEngine | Database engine type.
MFDefaultPropertyType | Available default property types when importing objects from external sources.
MFDependencyRelation | Dependency relation types.
MFEmailField | E-mail field types.
MFEmailImportance | E-mail importance values.
MFEmailSensitivity | E-mail sensitivity values.
MFEventHandlerType | Event handler type.
MFExportContentFlag | Bit flags that provide information about a content export job.
MFExpressionExFlag | Flags that provide additional information on the expression in the context of a view definition.
MFExpressionType | Expression type definitions.
MFExtApplicationPlatform | Extension application platform values.
MFExtensionAuthenticationSpecialUserType | Special user type for extension authentication.
MFExternalDBRefreshType | Available refresh methods for refreshing external value lists and object types.
MFFacetFilterStatusFlags | Facet filter status flags (bitfield flags). Affects facet searching.
MFFacetSearchFlags | Facet search flags (bitfield flags). Affects facet searching.
MFFileDataStorage | File data storage type of a vault.
MFFileFormat | File format for download.
MFFileInformationType | File information type values.
MFFileOpenMethod | Available methods for opening an object file in an application.
MFFileProperty | Windows file properties.
MFFileSizePrecision | File size precision.
MFFileValueType | Available conditions regarding file information.
MFFileVerVersionType | Indirect file version type enumeration.
MFFolderColumnId | Reserved IDs for folder columns. If the columns represents a true property definition value, the property definition is is used as column id.
MFFolderContentItemType | Folder content item types.
MFFolderDefType | Folder definition types.
MFFolderListingAlgorithm | Folder listing algorithm. Used to optimize property folder listings on intermediate view levels.
MFFolderListingColumnFlags | Folder listing column flags.
MFFolderListingItemGroupingMode | Folder listing item grouping mode. Some modes can be combined.
MFFolderListingViewMode | Folder listing view modes.
MFFolderUIStateLocationType | Folder location types for UI state settings.
MFFormattingType | Available formatting types.
MFFullTextSearchFlags | Full-text search flags (bitfield flags).
MFHistoryRetrievalMode | The mode of operation while retrieving history information.
MFilesURLType | Available M-Files URL types.
MFImpersonationType | Enumeration for the impersonation types.
MFImportContentFlag | Bit flags that provide information about a content import job.
MFIndirectPropertyIDLevelType | Indirect property ID level types.
MFLatestSpecificBehavior | Specifies how the object version parameter is treated.
MFLicenseType | Available license types.
MFLoginAccountType | Available account types of logins.
MFLoginServerRole | Flags for various user roles in server operations.
MFMetadataStructureItem | Types of metadata structure elements.
MFMetadataStructureSelectorFlags | Metadata structure selector flags.
MFMetadataSyncFormat | Property formats in synchronizing file content with current metadata.
MFNamedACLType | Named ACL types.
MFNamedValueType | Named value types in named value storage operations.
MFObjectAccess | Available object access privileges.
MFObjectCapabilityFlag | Bit flags that describe the capabilities of an object.
MFObjectDataRequestErrorTolerance | The available error tolerance modes for object data requests.
MFObjectDataRequestFlags | Object data request flags (bitfield flags) describe what type of object data is requested.
MFObjectDataRequestVersionType | The available version types for object data requests.
MFObjectOperationFlags | Object operation flags.
MFObjectTypeAccess | Available object type access privileges.
MFObjectVersionFlag | Bit flags that provide additional information on the object version.
MFObjectWindowMode | Available metadata card modes.
MFObjectWindowResultCode | The user's response to the metadata card.
MFObjVerVersionType | Indirect version type enumeration.
MFOCRDimensionUnit | Dimension units in optical character recognition (OCR) operation.
MFOCRLanguage | Language hints in optical character recognition (OCR) operation.
MFOCRZoneRecognitionMode | Zone recognition modes in optical character recognition (OCR) operation.
MFOfflineTransitionResultFlags | Status flags for an offline transition.
MFOnlineTransitionResultFlags | Status flags for an online transition.
MFParentChildBehavior | Parent-child behavior enumeration (affects searching and view levels).
MFPasswordHashAlgorithm | Password hash algorithm identifier.
MFPermission | Access control entry rights.
MFPermissionsExpressionType | Available types of permission expressions.
MFPredefinedSearchFilterType | Definition for various predefined filters that the user can select on the search bar.
MFProductMode | Available product modes.
MFPropertyDefAccess | Available property definition access privileges.
MFRelationshipsMode | Available relationships modes.
MFScheduledJobType | Types of scheduled jobs available for server maintenance.
MFSearchFlags | Search flags (bitfield flags). Affects searching and view levels.
MFServerConnection | States of the server connection and authentication.
MFSharedLinkType | The type of the shared link pointing to a document.
MFSignaturePromptInfoType | Electronic signature prompt information type values.
MFSoftwarePlatformType | Platform indicators for the API.
MFSpecialObjectFlag | Bit flags that indicate special objects such as shortcuts and conflicts.
MFStatusType | Available conditions related to status information.
MFStringDataType | String data type values.
MFTaskQueueProcessingBehavior | Specifies how tasks are processed in a task queue.
MFTaskState | The possible states of an asynchronous task.
MFTextContentExtractionFlags | Bitfield flags for the content extraction process when retrieving the text content of a file.
MFTriggerMonth | Defines the months as used in triggers.
MFTriggerType | Defines the types of triggers associated with a scheduled job.
MFTriggerWeekDay | Defines the weekdays as used in triggers.
MFTriggerWeekOfMonth | Defines a week of a month as used in triggers.
MFUpdateType | Available update types for property definitions.
MFUserAccountVaultRole | Flags for the various user roles for accessing a vault.
MFUserOrUserGroupType | Types of users or user groups.
MFValidationType | Available validation types.
MFValueListItemPropertyDef | Pseudo property definitions of the value list items.
MFValueListSortingType | Available sort modes for value lists.
MFVaultAccess | Available vault access rights.
MFVaultConnectionTestResult | Result codes of a vault connection test.
MFViewCategory | Available view categories.
MFViewFlag | Flags that provide additional information about the view.
MFViewType | View types.
MFWOPIActionType | The WOPI action type.
MFWOPITokenType | The WOPI Token type.

© 2022 M-Files Corporation


%%ItemTitle%%

M-Files API
Getting Started

Getting Started with M-Files API

Before you start creating an M-Files API application, make sure you are familiar with M-Files concepts and features. Install the M-Files Desktop and M-Files Server components and examine operations in both the M-Files Desktop and the M-Files Admin applications. Always use a dedicated server for prototyping, developing and testing your application. Do not use production environment for development purposes.

Various development environments and languages can be used to develop M-Files API applications. The main requirement is to have support for COM/ActiveX components. For example, Microsoft's .NET based development tools like C# and Visual Basic .NET can be used, as well as managed and standard C++.

Creating M-Files API Applications

The M-Files API interface needs to be included in your application project in order for you to be able to utilize it. The API is implemented as a COM DLL file, which is placed in the M-Files installation directory. If your computer has M-Files software installed, the M-Files API component should also be installed along with it.

Because the API is registered as a COM component, many application development environments provide a direct reference to the file via their user interface. The picture below shows how to add the M-Files API component to a Visual Basic project. With other languages and environments, refer to the language documentation for details.

Adding M-Files API as a reference to a Visual Basic project.

Choosing Between the Client and the Server Interfaces

You can use the M-Files API to access the M-Files client application, or you can choose to use the API to access the M-Files server directly. By using the client application, you can use client-side features like the Windows-integrated user interface. With the client interface, you will also gain a performance benefit, because the client application has local caches for documents. On the other hand, by using the M-Files Server interface directly you can write applications without the requirement of having the M-Files client application installed.

Getting Started with the M-Files Client Interface

The main high-level object of the M-Files API component is the MFilesClientApplication Object. This is the first object you create when writing an application that uses the M-Files API.

Creating an MFilesClientApplication Object (Visual Basic) Copy Code
' Initialize the MFilesClientApplication object.
Dim oClientApp As New MFilesAPI.MFilesClientApplication
Having created the MFilesClientApplication object, you can bind it to the document vault connection in order to receive the Vault Object. In the client component, the document vault connections are identified by the connection name. To log in to a document vault, an appropriate document vault connection must be obtained through the MFilesClientApplication object. You can connect to a known vault connection identified by a connection name, or you can loop through all the available vault connections to find the proper one.
Logging into a Known Document Vault (Visual Basic) Copy Code

' Log into a vault through a document vault connection "Demo".
Dim oVaultConnection As MFilesAPI.VaultConnection = oClientApp.GetVaultConnection("Demo")
Dim oVault As MFilesAPI.Vault = oVaultConnection.BindToVault(Me.Handle, true, false)
If you do not know which vault to use, but you have a file and a path, you can use the client interface to locate the file in any vault accessible on the client computer.
Locating a File in M-Files (Visual Basic) Copy Code

' Locate the object by path from M-Files.
Dim oObjVerAndProp As MFilesAPI.ObjectVersionAndProperties = oClientApp.FindObjectVersionAndProperties( _
      "M:\Sample\1. Documents\By Class\Agenda\Agenda - Project Meeting 4{2}2006 (ID 249).doc")

Getting Started with the M-Files Server Interface

The main M-Files component for accessing the server interface is the MFilesServerApplication Object. After creating the application object, you need to connect it to the server.

Creating an MFilesServerApplication and Connecting it to the Server (Visual Basic) Copy Code
' Create the server component.
Dim oServerApp As New MFilesAPI.MFilesServerApplication

' Connect to M-Files server computer "mfserv" by using M-Files user's credentials.
oServerApp.Connect(MFilesAPI.MFAuthType.MFAuthTypeSpecificMFilesUser, "UserA", "passw0rd", , , "mfserv")

After the application component has been connected to the server, you can log in to the document vault. If you know the GUID of the vault, you can log in directly to the vault. Alternatively, you can loop through all the vaults to find the one you need.

Logging into the Vault (Visual Basic) Copy Code
' Get and loop through all vaults.
Dim oVaultsOnServer As MFilesAPI.VaultsOnServer = oServerApp.GetVaults()
Dim oVault As MFilesAPI.Vault
For Each oVaultOnServer As MFilesAPI.VaultOnServer In oVaultsOnServer

    ' Check the vault's name and log into Sample Vault.
    If oVaultOnServer.Name = "Sample Vault" Then

        oVault = oVaultOnServer.LogIn()
        Exit For

    End If

Next

Using the Vault

Regardless of whether you are accessing M-Files through the client or server interface, operations on the vault are performed with the help of the Vault Object. It is the most important high-level object available in the M-Files API.

The vault object itself has just a few vault-related methods and properties. The actual interaction with the contents of a vault is achieved via the operation interfaces provided by the vault object.

Examples of operation interfaces:

  • VaultClientOperations Object
  • VaultManagementOperations Object
  • VaultObjectOperations Object
  • VaultObjectFileOperations Object
  • VaultViewOperations Object
  • VaultObjectSearchOperations Object
  • VaultLoginAccountOperations Object
  • VaultUserOperations Object
  • VaultUserGroupOperations Object
  • VaultClassOperations Object
  • VaultClassGroupOperations Object
  • VaultValueListOperations Object
  • VaultObjectTypeOperations Object
  • VaultObjectPropertyOperations Object
  • VaultWorkflowOperations Object

As a rule of thumb, all vault modifications are performed directly via the operation interfaces. Other objects, obtained via the operation interfaces, are data container objects only. Either they are stateless or they gain their state when they are created without maintaining a connection to the vault. Therefore, modifying the state of a container object does not create a change in the vault.

Identifying Objects, Versions and Files

Each document or other vault object is identified in the vault by an object identifier. At its simplest, this is just an ID number, which is unique for all vault objects within the object type. API methods use ObjID Objects consisting of the object identifier number and the object type identifier number.

However, most vault operations are not targeted for the object as a whole, but rather for one particular object version. For example, documents seen in the user interface or referred to in applications are actually versions of vault objects. In order to identify a particular version of an object, we need to add a version number to the identifier. An ObjVer Object consists of the ObjID object and the object version number. The version number has a special value of -1, which identifies the latest version available.

Getting the Latest Object Version Identifier (Visual Basic) Copy Code
Dim oObjID As MFilesAPI.ObjID = New MFilesAPI.ObjID
oObjID.SetIDs(MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument, 123)
Dim oObjVer As MFilesAPI.ObjVer = oVault.ObjectOperations.GetLatestObjVer(oObjID)

Each document or other vault object can have zero or more files. Files have identifiers (unique within the object) and version numbers encapsulated in the FileVer Object. The version number of the file is independent of the version number of the vault object.

Working with Vault Objects

Most of the version-related operations and properties of the vault objects are available via the ObjectVersion Object. The metadata-related operations and properties of the objects can be accessed via the ObjectVersionAndProperties Object. References to these objects can be accessed by using the VaultObjectOperations Object.

Working with Object Metadata

The ObjectVersionAndProperties Object contains a set of the property values of the object as PropertyValue Objects. These objects contain a link to the property definition declaring the actual type of the metadata property as a PropertyDef Object as well as a TypedValue Object that determines the actual value of the property.

The property value can be one of the basic types or any of the lookup types listed in the MFDataType Enumeration. Basic types represent a standalone text or a number as seen in the interface. Lookup or multi-select lookup types are reference types, meaning that they are used to refer to other objects or value list items. See the TypedValue Object for more details.

The object class is also listed among the metadata properties of the object. It can be resolved by using the lookup reference of a class property value. The object class has its own interface object, ObjectClass Object. See ObjectClass and VaultClassOperations Object for more details.

Working with Object Files

An object may contain multiple object files, each represented by the ObjectFile Object. An ObjectFile object actually represents just a single version of the object file. To encapsulate both the file version and the parent object version, use the ObjectVersionFile Object.

The VaultObjectFileOperations Object provides methods for adding and removing object files.

Working with Workflows and Assignments

The VaultWorkflowOperations Object provides access to workflow items and states. Because the workflow and assigment settings of a vault object are part of the metadata of the object, changes in workflows and assignments can be performed by using the VaultObjectPropertyOperations Object.

Working with Views and Searches

Searches can be performed by using the VaultObjectSearchOperations Object. In most cases, the results are provided as an ObjectSearchResults Collection. The search is defined by using a SearchCondition Object or a SearchConditions Collection. The SearchCondition object is defined by using an Expression Object as an operator and a TypedValue Object as a right operand. The search results consist of vault objects for which the search conditions are evaluated as true.

Views behave like searches. They consist of a condition for getting the result set and some additional parameters for displaying the result. The View Object represents a single view. Views can be managed by using the VaultViewOperations Object.

Using User Interface Components

If the MFiles API is used with a client interface connection (the MFilesClientApplication Object), several UI components can be used via the API. Most of these methods are contained in the VaultObjectOperations Object. The VaultViewOperations Object contains some view-related UI methods. Most of the UI-related operations need to have a parent window handle (HWND) to show a child window.

Deploying M-Files API Applications

In order to use applications utilizing the M-Files API in client mode, the M-Files client software must be installed on the computer and the M-Files Client service must be running.

To use applications with the M-Files API in the server interface mode, the M-Files API component must be installed, which is included in any M-Files software installation. The M-Files client or server services do not need to run on the client computer.

Code Samples

For M-Files API samples, visit https://www.m-files.com/api.


%%PageItemTitle%%

AccessControlEntry Object
Members See Also Send comments

Glossary Item Box

Description

The AccessControlEntry class represents an access control entry (ACE).

Remarks

Note

This class has been deprecated. Please use the AccessControlEntryData and AccessControlEntryKey classes instead.

The access control entry declares an individual user's or group's permissions to access an object (such as a document). The AccessControlList defines the set of access control entries as complete access rights to an object.

An access control entry (highlighted with the green rectangles) as seen in the user interface of M-Files Desktop.

See Also

AccessControlEntry Members


%%PageItemTitle%%

AccessControlEntryContainer Object
Members See Also Send comments

Glossary Item Box

Description

The AccessControlEntryContainer class represents a collection of access control entries (ACEs).

Public Methods

Public Method Add | Adds a new access control entry.
Public Method At | Accesses the specified access control entry.
Public Method Clear | Removes all access control entries.
Public Method Clone | Creates a copy of the object.
Public Method GetKeys | Gets copies of the source keys of the access control entries. Pseudo-user definitions are not included.
Public Method GetKeysWithPseudoUserDefinitions | Gets copies of the source keys of the access control entries.
Public Method HasKey | Checks whether an entry with the provided key exists.
Public Method Remove | Removes an access control entry.

Public Properties

Public Property IsEmpty Specifies whether the collection is empty.

Remarks

Supported in M-Files 20.4.8986.4 and later.

See Also

AccessControlEntryContainer Members


%%PageItemTitle%%

Add Method
See Also Send comments
AccessControlEntryKey
The key of the component to be added.
AccessControlEntryData
The component to be added as a copy.
AccessControlEntryContainer Object : Add Method

Glossary Item Box

Description

Adds a new access control entry.

Syntax

Visual Basic
Public Sub Add( _
   ByVal AccessControlEntryKey As AccessControlEntryKey, _
   ByVal AccessControlEntryData As AccessControlEntryData _
)

Parameters

AccessControlEntryKey
The key of the component to be added.
AccessControlEntryData
The component to be added as a copy.

Remarks

Supported in M-Files 20.4.8986.4 and later.

See Also

AccessControlEntryContainer Object | AccessControlEntryContainer Members


%%PageItemTitle%%

At Method
AccessControlEntryKey
The key of the accessed component.
AccessControlEntryContainer Object : At Method

Glossary Item Box

Description

Accesses the specified access control entry.

Syntax

Visual Basic
Public Function At( _
   ByVal AccessControlEntryKey As AccessControlEntryKey _
) As AccessControlEntryData

Parameters

AccessControlEntryKey
The key of the accessed component.

Remarks

Supported in M-Files 20.4.8986.4 and later.

See Also

AccessControlEntryContainer Object | AccessControlEntryContainer Members


%%PageItemTitle%%

Clear Method
AccessControlEntryContainer Object : Clear Method

Glossary Item Box

Description

Removes all access control entries.

Syntax

Visual Basic
Public Sub Clear()

Remarks

Supported in M-Files 20.4.8986.4 and later.

See Also

AccessControlEntryContainer Object | AccessControlEntryContainer Members


%%PageItemTitle%%

Clone Method
AccessControlEntryContainer Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AccessControlEntryContainer

Remarks

Supported in M-Files 20.4.8986.4 and later.

See Also

AccessControlEntryContainer Object | AccessControlEntryContainer Members


%%PageItemTitle%%

GetKeys Method
AccessControlEntryContainer Object : GetKeys Method

Glossary Item Box

Description

Gets copies of the source keys of the access control entries. Pseudo-user definitions are not included.

Syntax

Visual Basic
Public Function GetKeys() As AccessControlEntryKeys

Remarks

Supported in M-Files 20.4.8986.4 and later.

See Also

AccessControlEntryContainer Object | AccessControlEntryContainer Members


%%PageItemTitle%%

GetKeysWithPseudoUserDefinitions Method
AccessControlEntryContainer Object : GetKeysWithPseudoUserDefinitions Method

Glossary Item Box

Description

Gets copies of the source keys of the access control entries.

Syntax

Visual Basic
Public Function GetKeysWithPseudoUserDefinitions() As AccessControlEntryKeys

Remarks

Supported in M-Files 20.4.8986.4 and later.

See Also

AccessControlEntryContainer Object | AccessControlEntryContainer Members


%%PageItemTitle%%

HasKey Method
AccessControlEntryKey
The key of the component to be inspected.
AccessControlEntryContainer Object : HasKey Method

Glossary Item Box

Description

Checks whether an entry with the provided key exists.

Syntax

Visual Basic
Public Function HasKey( _
   ByVal AccessControlEntryKey As AccessControlEntryKey _
) As Boolean

Parameters

AccessControlEntryKey
The key of the component to be inspected.

Return Type

Supported in M-Files 20.4.8986.4 and later.

See Also

AccessControlEntryContainer Object | AccessControlEntryContainer Members


%%PageItemTitle%%

Remove Method
AccessControlEntryKey
The key of the component to be removed.
AccessControlEntryContainer Object : Remove Method

Glossary Item Box

Description

Removes an access control entry.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal AccessControlEntryKey As AccessControlEntryKey _
)

Parameters

AccessControlEntryKey
The key of the component to be removed.

Remarks

Supported in M-Files 20.4.8986.4 and later.

See Also

AccessControlEntryContainer Object | AccessControlEntryContainer Members


%%PageItemTitle%%

IsEmpty Property
AccessControlEntryContainer Object : IsEmpty Property

Glossary Item Box

Description

Specifies whether the collection is empty.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsEmpty As Boolean

Remarks

Supported in M-Files 20.4.8986.4 and later.

See Also

AccessControlEntryContainer Object | AccessControlEntryContainer Members


%%PageItemTitle%%

AccessControlEntryData Object
Members See Also Send comments

Glossary Item Box

Description

The AccessControlEntryData class represents the permissions part in an access control entry.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetAllPermissions | Sets all permissions of an access control entry to the specified state.

Public Properties

Public Property AttachObjectsPermission | The attach objects permission of an ACE.
Public Property ChangePermissionsPermission | The change permissions permission of an ACE.
Public Property DeletePermission | The delete permission of an ACE.
Public Property EditPermission | The edit permission of an ACE.
Public Property ReadPermission | The read permission of an ACE.

Remarks

AccessControlListComponent consists of multiple access control entries. These entries are split into a key and the data. The data portion of an entry specifies the permissions for the entry while the key specifies the user or user group to which the data applies.

An access control list component with an entry key (top) and entry data (bottom) highlighted with the green rectangles as seen in the user interface of M-Files Desktop.

See Also

AccessControlEntryData Members


%%PageItemTitle%%

Clone Method
AccessControlEntryData Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AccessControlEntryData

See Also

AccessControlEntryData Object | AccessControlEntryData Members


%%PageItemTitle%%

SetAllPermissions Method
Permission
AccessControlEntryData Object : SetAllPermissions Method

Glossary Item Box

Description

Sets all permissions of an access control entry to the specified state.

Syntax

Visual Basic
Public Sub SetAllPermissions( _
   ByVal Permission As MFPermission _
)

Parameters

Permission
Value | Description
MFPermissionAllow | Allowed.
MFPermissionDeny | Denied.
MFPermissionNotSet | Not set.

See Also

AccessControlEntryData Object | AccessControlEntryData Members


%%PageItemTitle%%

AttachObjectsPermission Property
AccessControlEntryData Object : AttachObjectsPermission Property

Glossary Item Box

Description

The attach objects permission of an ACE.

Property type

Read-write property

Syntax

Visual Basic
Public Property AttachObjectsPermission As MFPermission

See Also

AccessControlEntryData Object | AccessControlEntryData Members


%%PageItemTitle%%

ChangePermissionsPermission Property
AccessControlEntryData Object : ChangePermissionsPermission Property

Glossary Item Box

Description

The change permissions permission of an ACE.

Property type

Read-write property

Syntax

Visual Basic
Public Property ChangePermissionsPermission As MFPermission

See Also

AccessControlEntryData Object | AccessControlEntryData Members


%%PageItemTitle%%

DeletePermission Property
AccessControlEntryData Object : DeletePermission Property

Glossary Item Box

Description

The delete permission of an ACE.

Property type

Read-write property

Syntax

Visual Basic
Public Property DeletePermission As MFPermission

See Also

AccessControlEntryData Object | AccessControlEntryData Members


%%PageItemTitle%%

EditPermission Property
AccessControlEntryData Object : EditPermission Property

Glossary Item Box

Description

The edit permission of an ACE.

Property type

Read-write property

Syntax

Visual Basic
Public Property EditPermission As MFPermission

See Also

AccessControlEntryData Object | AccessControlEntryData Members


%%PageItemTitle%%

ReadPermission Property
AccessControlEntryData Object : ReadPermission Property

Glossary Item Box

Description

The read permission of an ACE.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReadPermission As MFPermission

See Also

AccessControlEntryData Object | AccessControlEntryData Members


%%PageItemTitle%%

AccessControlEntryKey Object
Members See Also Send comments

Glossary Item Box

Description

The AccessControlEntryKey class specifies the user or user group for an access control entry.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetResolvedPseudoUserOrGroupIDs | Gets a copy of the collection of the user or group ID for a resolved pseudo-user access control entry key.
Public Method ResetResolvedPseudoUserOrGroupIDs | Removes the information on the resolved user or user group IDs from a access control entry key that specifies pseudo users.
Public Method SetUserOrGroupID | Sets the user or group ID of this access control entry key.

Public Properties

Public Property HasConcreteUserOrGroupID | Specifies whether this ACE represents a concrete identity, either natively or as a resolved pseudo-user.
Public Property IsGroup | Specifies whether this ACE represents a group.
Public Property IsPseudoUser | Specifies whether this ACE represents a pseudo-user.
Public Property PseudoUserID | Specifies the pseudo-user ID of this access control entry key.
Public Property UserOrGroupID | Gets the user or group ID of this access control entry key.

Remarks

AccessControlListComponent consists of multiple access control entries. These entries are split into a key and the data. The data portion of an entry specifies the permissions for the entry while the key specifies the user or user group to which the data applies.

An access control list component with an entry key (top) and entry data (bottom) highlighted with the green rectangles as seen in the user interface of M-Files Desktop.

See Also

AccessControlEntryKey Members


%%PageItemTitle%%

Clone Method
AccessControlEntryKey Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AccessControlEntryKey

See Also

AccessControlEntryKey Object | AccessControlEntryKey Members


%%PageItemTitle%%

GetResolvedPseudoUserOrGroupIDs Method
AccessControlEntryKey Object : GetResolvedPseudoUserOrGroupIDs Method

Glossary Item Box

Description

Gets a copy of the collection of the user or group ID for a resolved pseudo-user access control entry key.

Syntax

Visual Basic
Public Function GetResolvedPseudoUserOrGroupIDs() As UserOrUserGroupIDs

Remarks

This method is valid only when the AccessControlList to which this key belongs has been received from the server as a result of an operation that retrieves permissions for existing objects.

See Also

AccessControlEntryKey Object | AccessControlEntryKey Members


%%PageItemTitle%%

ResetResolvedPseudoUserOrGroupIDs Method
AccessControlEntryKey Object : ResetResolvedPseudoUserOrGroupIDs Method

Glossary Item Box

Description

Removes the information on the resolved user or user group IDs from a access control entry key that specifies pseudo users.

Syntax

Visual Basic
Public Sub ResetResolvedPseudoUserOrGroupIDs()

Remarks

When modifying ACL structures that are not tied to objects such as NamedACLs the structures do not accept resolved pseudo users. This method can be used to clear access control entry keys with resolved pseudo users before inserting them into such a structure.

See Also

AccessControlEntryKey Object | AccessControlEntryKey Members


%%PageItemTitle%%

SetUserOrGroupID Method
UserOrGroupID
User or user group ID.
IsGroup
Indicates whether the given ID refers to a group.
AccessControlEntryKey Object : SetUserOrGroupID Method

Glossary Item Box

Description

Sets the user or group ID of this access control entry key.

Syntax

Visual Basic
Public Sub SetUserOrGroupID( _
   ByVal UserOrGroupID As Long, _
   ByVal IsGroup As Boolean _
)

Parameters

UserOrGroupID
User or user group ID.
IsGroup
Indicates whether the given ID refers to a group.

See Also

AccessControlEntryKey Object | AccessControlEntryKey Members


%%PageItemTitle%%

HasConcreteUserOrGroupID Property
AccessControlEntryKey Object : HasConcreteUserOrGroupID Property

Glossary Item Box

Description

Specifies whether this ACE represents a concrete identity, either natively or as a resolved pseudo-user.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasConcreteUserOrGroupID As Boolean

See Also

AccessControlEntryKey Object | AccessControlEntryKey Members


%%PageItemTitle%%

IsGroup Property
AccessControlEntryKey Object : IsGroup Property

Glossary Item Box

Description

Specifies whether this ACE represents a group.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsGroup As Boolean

Remarks

Use SetUserOrGroupID to set this property.

See Also

AccessControlEntryKey Object | AccessControlEntryKey Members


%%PageItemTitle%%

IsPseudoUser Property
AccessControlEntryKey Object : IsPseudoUser Property

Glossary Item Box

Description

Specifies whether this ACE represents a pseudo-user.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsPseudoUser As Boolean

Return Type

True, if the key specifies a pseudo user instead of a direct user or user group.

See Also

AccessControlEntryKey Object | AccessControlEntryKey Members


%%PageItemTitle%%

PseudoUserID Property
AccessControlEntryKey Object : PseudoUserID Property

Glossary Item Box

Description

Specifies the pseudo-user ID of this access control entry key.

Property type

Read-write property

Syntax

Visual Basic
Public Property PseudoUserID As IndirectPropertyID

Remarks

Pseudo users are defined as a chain of property definitions where the last level must be a lookup property that uses user list or user group list as the value list. The earlier levels may be properties that refer to other objects.

See Also

AccessControlEntryKey Object | AccessControlEntryKey Members


%%PageItemTitle%%

UserOrGroupID Property
AccessControlEntryKey Object : UserOrGroupID Property

Glossary Item Box

Description

Gets the user or group ID of this access control entry key.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserOrGroupID As Long

Remarks

Use SetUserOrGroupID to set this property.

See Also

AccessControlEntryKey Object | AccessControlEntryKey Members


%%PageItemTitle%%

AccessControlEntryKeys Collection
Members See Also Send comments

Glossary Item Box

Description

The AccessControlEntryKeys class represents a collection of access control entry (ACE) keys.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

AccessControlEntryKeys Members


%%PageItemTitle%%

Clone Method
AccessControlEntryKeys Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AccessControlEntryKeys

See Also

AccessControlEntryKeys Collection | AccessControlEntryKeys Members


%%PageItemTitle%%

Count Property
AccessControlEntryKeys Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

AccessControlEntryKeys Collection | AccessControlEntryKeys Members


%%PageItemTitle%%

Item Property
Index
AccessControlEntryKeys Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As AccessControlEntryKey

Parameters

Index

See Also

AccessControlEntryKeys Collection | AccessControlEntryKeys Members


%%PageItemTitle%%

AccessControlList Collection
Members See Also Send comments

Glossary Item Box

Description

The AccessControlList class represents an access control list (ACL).

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method EqualTo | Checks for equality to the specified object.
Public Method HasIdenticalPermissions | Checks for the permissions identicality with the specified object.

Public Properties

Public Property AutomaticComponents | Accesses the automatic components of this ACL.
Public Property CheckedOutToUserID | Specifies the ID of the user who has extended rights because of the checkout operation performed by her.
Public Property CustomComponent | Accesses the custom component of this ACL.
Public Property HasCheckedOutToUserID | Specifies whether this component has the ID of the user who has extended rights because of the checkout operation performed by her.
Public Property IsFullyAuthoritative | Specifies whether this access control list is set to ignore the secondary permissions that come from the latest checked in version.

Remarks

An access control list (ACL) defines the access rights for an object (such as a document) through one or more components. It behaves in different ways depending on how it is acquired and used.

When examining or specifying object permissions using methods such as GetObjectPermissions or ChangePermissionsToACL the custom permissions are specified by the CustomComponent and AutomaticComponents contain information about components that result from the object's properties. The automatic components cannot be freely modified but can be deactivated if the components themselves allow it.

If AccessControlList is used to define NamedACL the automatic components are not used. Only the custom component has an effect on the definition of the NamedACL. This applies also when NamedACL is used inside AutomaticPermissions.

Note

If the M-Files document vault has not been upgraded to use extended metadata driven permissions, the automatic components collection should always be empty.

See Also

AccessControlList Members | NamedACL Object


%%PageItemTitle%%

Clone Method
AccessControlList Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AccessControlList

See Also

AccessControlList Collection | AccessControlList Members


%%PageItemTitle%%

CloneFrom Method
AccessControlList
AccessControlList Collection : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal AccessControlList As AccessControlList _
)

Parameters

AccessControlList

See Also

AccessControlList Collection | AccessControlList Members


%%PageItemTitle%%

EqualTo Method
AccessControlList
The access control list for comparison.
AccessControlList Collection : EqualTo Method

Glossary Item Box

Description

Checks for equality to the specified object.

Syntax

Visual Basic
Public Function EqualTo( _
   ByVal AccessControlList As AccessControlList _
) As Boolean

Parameters

AccessControlList
The access control list for comparison.

Return Type

A Boolean value that specifies whether the compared access control lists are equal.

See Also

AccessControlList Collection | AccessControlList Members | GetObjectPermissions Method


%%PageItemTitle%%

HasIdenticalPermissions Method
AccessControlList
The access control list for comparison.
AccessControlList Collection : HasIdenticalPermissions Method

Glossary Item Box

Description

Checks for the permissions identicality with the specified object.

Syntax

Visual Basic
Public Function HasIdenticalPermissions( _
   ByVal AccessControlList As AccessControlList _
) As Boolean

Parameters

AccessControlList
The access control list for comparison.

Return Type

A Boolean value that specifies whether the compared access control lists are identical.

Remarks

Permissions are identical if the two access control lists contain components with same keys and these components contain identical access control entry definitions.

See Also

AccessControlList Collection | AccessControlList Members


%%PageItemTitle%%

AutomaticComponents Property
AccessControlList Collection : AutomaticComponents Property

Glossary Item Box

Description

Accesses the automatic components of this ACL.

Property type

Read-only property

Syntax

Visual Basic
Public Property AutomaticComponents As AccessControlListComponentContainer

Remarks

Automatic components are based on object metadata. These are valid only when the AccessControlList specifies permissions for a concrete object.

Note

If the M-Files document vault has not been upgraded to use extended metadata driven permissions, the automatic components collection should always be empty.

See Also

AccessControlList Collection | AccessControlList Members


%%PageItemTitle%%

CheckedOutToUserID Property
AccessControlList Collection : CheckedOutToUserID Property

Glossary Item Box

Description

Specifies the ID of the user who has extended rights because of the checkout operation performed by her.

Property type

Read-only property

Syntax

Visual Basic
Public Property CheckedOutToUserID As Long

Return Type

User account ID, if HasCheckedOutToUserID is true.

Remarks

M-Files always provides the user who has checked a document out with permissions to the document. This property may be used to check which users has these implicit permissions.

See Also

AccessControlList Collection | AccessControlList Members | HasCheckedOutToUserID Property


%%PageItemTitle%%

CustomComponent Property
AccessControlList Collection : CustomComponent Property

Glossary Item Box

Description

Accesses the custom component of this ACL.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomComponent As AccessControlListComponent

Remarks

The custom component is the only component which can be freely modified.

See Also

AccessControlList Collection | AccessControlList Members


%%PageItemTitle%%

HasCheckedOutToUserID Property
AccessControlList Collection : HasCheckedOutToUserID Property

Glossary Item Box

Description

Specifies whether this component has the ID of the user who has extended rights because of the checkout operation performed by her.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasCheckedOutToUserID As Boolean

See Also

AccessControlList Collection | AccessControlList Members | CheckedOutToUserID Property


%%PageItemTitle%%

IsFullyAuthoritative Property
AccessControlList Collection : IsFullyAuthoritative Property

Glossary Item Box

Description

Specifies whether this access control list is set to ignore the secondary permissions that come from the latest checked in version.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsFullyAuthoritative As Boolean

Remarks

Normally the access control list of the latest checked in version of an object affects the permissions of the previous versions. A user is given certain permissions to the older objects only if those permissions are allowed by both access control lists: The one specified on the old version and the one specified on the latest checked in version.

This behavior can be overridden by making the access control list of the older version fully authoritative. This can be used to hide the latest checked in version while still leaving the old version visible to the users.

See Also

AccessControlList Collection | AccessControlList Members


%%PageItemTitle%%

AccessControlListComponent Object
Members See Also Send comments

Glossary Item Box

Description

The AccessControlListComponent specifies a set of entries within an access control list.

The entries within the component have a common source such as the object itself in the case of a custom component or a property value in the case of automatic components.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetACEByUserOrGroupID | Gets the AccessControlEntryData with the specified user or user group ID.
Public Method GetACEKeyByUserOrGroupID | Gets the AccessControlEntryKey with the specified user or user group ID.
Public Method ResetCurrentUserBinding | Resets the current user binding of this component.
Public Method ResetNamedACLLink | Resets the named ACL link of this component.

Public Properties

Public Property AccessControlEntries | Gets the actual ACEs of this ACL component.
Public Property CanDeactivate | Specifies whether this component can be deactivated by setting IsActive to false.
Public Property CurrentUserBinding | Specifies the user ID used for entries of type "(Current User)".
Public Property HasCurrentUser | Specifies whether this component has a current user access control entry.
Public Property HasCurrentUserBinding | Specifies whether this component has a current user binding.
Public Property HasNamedACLLink | Specifies whether this component has a named ACL link.
Public Property HasPseudoUsers | Specifies whether this component has pseudo-users in its access control entries.
Public Property IsActive | Specifies the activation status of this ACL component.
Public Property NamedACLLink | Specifies the named ACL link of this component.

Remarks

Access control list components (highlighted with the green rectangle) as seen in the user interface of M-Files Desktop. The custom component is shown with source as "This object".

See Also

AccessControlListComponent Members


%%PageItemTitle%%

Clone Method
AccessControlListComponent Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AccessControlListComponent

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

GetACEByUserOrGroupID Method
UserOrGroupID
User or user group ID.
IsGroup
Indicates whether the given ID refers to a group.
AccessControlListComponent Object : GetACEByUserOrGroupID Method

Glossary Item Box

Description

Gets the AccessControlEntryData with the specified user or user group ID.

Syntax

Visual Basic
Public Function GetACEByUserOrGroupID( _
   ByVal UserOrGroupID As Long, _
   ByVal IsGroup As Boolean _
) As AccessControlEntryData

Parameters

UserOrGroupID
User or user group ID.
IsGroup
Indicates whether the given ID refers to a group.

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

GetACEKeyByUserOrGroupID Method
UserOrGroupID
User or user group ID.
IsGroup
Indicates whether the given ID refers to a group.
AccessControlListComponent Object : GetACEKeyByUserOrGroupID Method

Glossary Item Box

Description

Gets the AccessControlEntryKey with the specified user or user group ID.

Syntax

Visual Basic
Public Function GetACEKeyByUserOrGroupID( _
   ByVal UserOrGroupID As Long, _
   ByVal IsGroup As Boolean _
) As AccessControlEntryKey

Parameters

UserOrGroupID
User or user group ID.
IsGroup
Indicates whether the given ID refers to a group.

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

ResetCurrentUserBinding Method
AccessControlListComponent Object : ResetCurrentUserBinding Method

Glossary Item Box

Description

Resets the current user binding of this component.

Syntax

Visual Basic
Public Sub ResetCurrentUserBinding()

Remarks

Components with current user binding cannot be used in structures such as NamedACLs. This method can be used to clean the access control list component before using it in such structures.

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

ResetNamedACLLink Method
AccessControlListComponent Object : ResetNamedACLLink Method

Glossary Item Box

Description

Resets the named ACL link of this component.

Syntax

Visual Basic
Public Sub ResetNamedACLLink()

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

AccessControlEntries Property
AccessControlListComponent Object : AccessControlEntries Property

Glossary Item Box

Description

Gets the actual ACEs of this ACL component.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessControlEntries As AccessControlEntryContainer

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

CanDeactivate Property
AccessControlListComponent Object : CanDeactivate Property

Glossary Item Box

Description

Specifies whether this component can be deactivated by setting IsActive to false.

Property type

Read-write property

Syntax

Visual Basic
Public Property CanDeactivate As Boolean

Remarks

Only AutomaticComponents can be deactivated. This property should not be used for CustomComponent.

Note

When modifying automatic permissions, use CanDeactivate on AutomaticPermissions instead.

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

CurrentUserBinding Property
AccessControlListComponent Object : CurrentUserBinding Property

Glossary Item Box

Description

Specifies the user ID used for entries of type "(Current User)".

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentUserBinding As Long

Remarks

Current user binding is resolved only for concrete access control lists. It is not valid for access control list components that are not set on an object such as those defined on a NamedACL.

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

HasCurrentUser Property
AccessControlListComponent Object : HasCurrentUser Property

Glossary Item Box

Description

Specifies whether this component has a current user access control entry.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasCurrentUser As Boolean

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

HasCurrentUserBinding Property
AccessControlListComponent Object : HasCurrentUserBinding Property

Glossary Item Box

Description

Specifies whether this component has a current user binding.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasCurrentUserBinding As Boolean

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

HasNamedACLLink Property
AccessControlListComponent Object : HasNamedACLLink Property

Glossary Item Box

Description

Specifies whether this component has a named ACL link.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasNamedACLLink As Boolean

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

HasPseudoUsers Property
AccessControlListComponent Object : HasPseudoUsers Property

Glossary Item Box

Description

Specifies whether this component has pseudo-users in its access control entries.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasPseudoUsers As Boolean

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

IsActive Property
AccessControlListComponent Object : IsActive Property

Glossary Item Box

Description

Specifies the activation status of this ACL component.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsActive As Boolean

Remarks

Only AutomaticComponents can be deactivated. This property should not be used for CustomComponent.

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

NamedACLLink Property
AccessControlListComponent Object : NamedACLLink Property

Glossary Item Box

Description

Specifies the named ACL link of this component.

Property type

Read-only property

Syntax

Visual Basic
Public Property NamedACLLink As Long

See Also

AccessControlListComponent Object | AccessControlListComponent Members


%%PageItemTitle%%

AccessControlListComponentContainer Object
Members See Also Send comments

Glossary Item Box

Description

The AccessControlListComponentContainer class represents a collection of access control list (ACL) components.

Public Methods

Public Method At | Accesses the specified automatic access control list component.
Public Method GetKeys | Gets copies of the source keys of the automatic components.
Public Method HasKey | Checks whether a component with the provided key exists.

Public Properties

Public Property Count The number of items in the collection.

See Also

AccessControlListComponentContainer Members


%%PageItemTitle%%

At Method
AccessControlListComponentKey
AccessControlListComponentContainer Object : At Method

Glossary Item Box

Description

Accesses the specified automatic access control list component.

Syntax

Visual Basic
Public Function At( _
   ByVal AccessControlListComponentKey As AccessControlListComponentKey _
) As AccessControlListComponent

Parameters

AccessControlListComponentKey

See Also

AccessControlListComponentContainer Object | AccessControlListComponentContainer Members


%%PageItemTitle%%

GetKeys Method
AccessControlListComponentContainer Object : GetKeys Method

Glossary Item Box

Description

Gets copies of the source keys of the automatic components.

Syntax

Visual Basic
Public Function GetKeys() As AccessControlListComponentKeys

See Also

AccessControlListComponentContainer Object | AccessControlListComponentContainer Members


%%PageItemTitle%%

HasKey Method
AccessControlListComponentKey
AccessControlListComponentContainer Object : HasKey Method

Glossary Item Box

Description

Checks whether a component with the provided key exists.

Syntax

Visual Basic
Public Function HasKey( _
   ByVal AccessControlListComponentKey As AccessControlListComponentKey _
) As Boolean

Parameters

AccessControlListComponentKey

See Also

AccessControlListComponentContainer Object | AccessControlListComponentContainer Members


%%PageItemTitle%%

Count Property
AccessControlListComponentContainer Object : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

AccessControlListComponentContainer Object | AccessControlListComponentContainer Members


%%PageItemTitle%%

AccessControlListComponentKey Object
Members See Also Send comments

Glossary Item Box

Description

The AccessControlListComponentKey class identifies a component by it's source.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ItemID | Gets the item ID of this ACL component.
Public Property PropertyDefID | Gets the property def ID of this ACL component.

Remarks

Automatic components in object access control lists are always result from the object metadata. Access control list component key distinguishes these by the property definition and the value.

See Also

AccessControlListComponentKey Members


%%PageItemTitle%%

Clone Method
AccessControlListComponentKey Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AccessControlListComponentKey

See Also

AccessControlListComponentKey Object | AccessControlListComponentKey Members


%%PageItemTitle%%

ItemID Property
AccessControlListComponentKey Object : ItemID Property

Glossary Item Box

Description

Gets the item ID of this ACL component.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemID As Long

See Also

AccessControlListComponentKey Object | AccessControlListComponentKey Members


%%PageItemTitle%%

PropertyDefID Property
AccessControlListComponentKey Object : PropertyDefID Property

Glossary Item Box

Description

Gets the property def ID of this ACL component.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyDefID As Long

See Also

AccessControlListComponentKey Object | AccessControlListComponentKey Members


%%PageItemTitle%%

AccessControlListComponentKeys Collection
Members See Also Send comments

Glossary Item Box

Description

The AccessControlListComponentKeys class represents a collection of automatic access control list (ACL) component sources.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

AccessControlListComponentKeys Members


%%PageItemTitle%%

Clone Method
AccessControlListComponentKeys Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AccessControlListComponentKeys

See Also

AccessControlListComponentKeys Collection | AccessControlListComponentKeys Members


%%PageItemTitle%%

Count Property
AccessControlListComponentKeys Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

AccessControlListComponentKeys Collection | AccessControlListComponentKeys Members


%%PageItemTitle%%

Item Property
Index
AccessControlListComponentKeys Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As AccessControlListComponentKey

Parameters

Index

See Also

AccessControlListComponentKeys Collection | AccessControlListComponentKeys Members


%%PageItemTitle%%

AccessControlLists Collection
Members See Also Send comments

Glossary Item Box

Description

AccessControlLists is a collection AccessControlList objects.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

AccessControlLists Members


%%PageItemTitle%%

Count Property
AccessControlLists Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

AccessControlLists Collection | AccessControlLists Members


%%PageItemTitle%%

Item Property
Index
AccessControlLists Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As AccessControlList

Parameters

Index

See Also

AccessControlLists Collection | AccessControlLists Members


%%PageItemTitle%%

ActionConvertToPDF Object
Members See Also Send comments

Glossary Item Box

Description

The ActionConvertToPDF class represents a convert to PDF action in a workflow state.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property FailOnUnsupportedSourceFiles | Specifies whether the operation fails if the source file is in an unsupported format.
Public Property OverwriteExistingFile | Specifies whether overwriting an existing target file with the same name is allowed.
Public Property PDFA1b | Specifies whether the resulting PDF file should comply with the PDF/A-1b standard.
Public Property StoreAsSeparateFile | Specifies whether the resulting PDF file should be stored as a separate file, with the same title as the original file but with the .pdf extension.

Remarks

Configuring an action to convert to PDF format in a workflow state (highlighted with the green rectangle) as seen in the user interface of M-Files Admin.

See Also

ActionConvertToPDF Members


%%PageItemTitle%%

Clone Method
ActionConvertToPDF Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ActionConvertToPDF

See Also

ActionConvertToPDF Object | ActionConvertToPDF Members


%%PageItemTitle%%

FailOnUnsupportedSourceFiles Property
ActionConvertToPDF Object : FailOnUnsupportedSourceFiles Property

Glossary Item Box

Description

Specifies whether the operation fails if the source file is in an unsupported format.

Property type

Read-write property

Syntax

Visual Basic
Public Property FailOnUnsupportedSourceFiles As Boolean

See Also

ActionConvertToPDF Object | ActionConvertToPDF Members


%%PageItemTitle%%

OverwriteExistingFile Property
ActionConvertToPDF Object : OverwriteExistingFile Property

Glossary Item Box

Description

Specifies whether overwriting an existing target file with the same name is allowed.

Property type

Read-write property

Syntax

Visual Basic
Public Property OverwriteExistingFile As Boolean

See Also

ActionConvertToPDF Object | ActionConvertToPDF Members


%%PageItemTitle%%

PDFA1b Property
ActionConvertToPDF Object : PDFA1b Property

Glossary Item Box

Description

Specifies whether the resulting PDF file should comply with the PDF/A-1b standard.

Property type

Read-write property

Syntax

Visual Basic
Public Property PDFA1b As Boolean

See Also

ActionConvertToPDF Object | ActionConvertToPDF Members


%%PageItemTitle%%

StoreAsSeparateFile Property
ActionConvertToPDF Object : StoreAsSeparateFile Property

Glossary Item Box

Description

Specifies whether the resulting PDF file should be stored as a separate file, with the same title as the original file but with the .pdf extension.

Property type

Read-write property

Syntax

Visual Basic
Public Property StoreAsSeparateFile As Boolean

See Also

ActionConvertToPDF Object | ActionConvertToPDF Members


%%PageItemTitle%%

ActionCreateAssignment Object
Members See Also Send comments

Glossary Item Box

Description

The ActionCreateAssignment class represents a create assignment action in a workflow state.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AssignedTo | Specifies the Assigned To users.
Public Property Class | The class to use when creating a new assignment.
Public Property Deadline | Specifies whether a deadline is specified for the assignment.
Public Property DeadlineInDays | The number of days until the deadline.
Public Property Description | The description of the assignment.
Public Property MonitoredBy | Specifies the Monitored By users.
Public Property Title | The title of the assignment.

Remarks

Configuring an action to create assignments in a workflow state (highlighted with the green rectangle) as seen in the user interface of M-Files Admin.

See Also

ActionCreateAssignment Members


%%PageItemTitle%%

Clone Method
ActionCreateAssignment Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ActionCreateAssignment

See Also

ActionCreateAssignment Object | ActionCreateAssignment Members


%%PageItemTitle%%

AssignedTo Property
ActionCreateAssignment Object : AssignedTo Property

Glossary Item Box

Description

Specifies the Assigned To users.

Property type

Read-write property

Syntax

Visual Basic
Public Property AssignedTo As UserOrUserGroupIDExs

See Also

ActionCreateAssignment Object | ActionCreateAssignment Members


%%PageItemTitle%%

Class Property
ActionCreateAssignment Object : Class Property

Glossary Item Box

Description

The class to use when creating a new assignment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Class As Long

See Also

ActionCreateAssignment Object | ActionCreateAssignment Members


%%PageItemTitle%%

Deadline Property
ActionCreateAssignment Object : Deadline Property

Glossary Item Box

Description

Specifies whether a deadline is specified for the assignment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Deadline As Boolean

See Also

ActionCreateAssignment Object | ActionCreateAssignment Members


%%PageItemTitle%%

DeadlineInDays Property
ActionCreateAssignment Object : DeadlineInDays Property

Glossary Item Box

Description

The number of days until the deadline.

Property type

Read-write property

Syntax

Visual Basic
Public Property DeadlineInDays As Long

See Also

ActionCreateAssignment Object | ActionCreateAssignment Members


%%PageItemTitle%%

Description Property
ActionCreateAssignment Object : Description Property

Glossary Item Box

Description

The description of the assignment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description As String

See Also

ActionCreateAssignment Object | ActionCreateAssignment Members


%%PageItemTitle%%

MonitoredBy Property
ActionCreateAssignment Object : MonitoredBy Property

Glossary Item Box

Description

Specifies the Monitored By users.

Property type

Read-write property

Syntax

Visual Basic
Public Property MonitoredBy As UserOrUserGroupIDExs

See Also

ActionCreateAssignment Object | ActionCreateAssignment Members


%%PageItemTitle%%

Title Property
ActionCreateAssignment Object : Title Property

Glossary Item Box

Description

The title of the assignment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Title As String

See Also

ActionCreateAssignment Object | ActionCreateAssignment Members


%%PageItemTitle%%

ActionDefinition Object
Members See Also Send comments

Glossary Item Box

Description

The 'ActionDefinition' class contains type-specific action details.

Public Methods

Public Method Clear | Clears all information.
Public Method Clone | Creates a copy of the object.

Public Properties

Public Property ActionCreateSeparateAssignment | Information about an action if 'ActionType' is 'MFActionTypeCreateSeparateAssignment'. Otherwise NULL.
Public Property ActionType | The action type.

See Also

ActionDefinition Members


%%PageItemTitle%%

Clear Method
ActionDefinition Object : Clear Method

Glossary Item Box

Description

Clears all information.

Syntax

Visual Basic
Public Sub Clear()

See Also

ActionDefinition Object | ActionDefinition Members


%%PageItemTitle%%

Clone Method
ActionDefinition Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ActionDefinition

See Also

ActionDefinition Object | ActionDefinition Members


%%PageItemTitle%%

ActionCreateSeparateAssignment Property
ActionDefinition Object : ActionCreateSeparateAssignment Property

Glossary Item Box

Description

Information about an action if 'ActionType' is 'MFActionTypeCreateSeparateAssignment'. Otherwise NULL.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionCreateSeparateAssignment As ActionCreateAssignment

See Also

ActionDefinition Object | ActionDefinition Members


%%PageItemTitle%%

ActionType Property
ActionDefinition Object : ActionType Property

Glossary Item Box

Description

The action type.

Property type

Read-only property

Syntax

Visual Basic
Public Property ActionType As MFActionType

See Also

ActionDefinition Object | ActionDefinition Members


%%PageItemTitle%%

ActionDefinitions Collection
Members See Also Send comments

Glossary Item Box

Description

The 'ActionDefinitions' class represents a collection of action descriptions.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ActionDefinitions Members


%%PageItemTitle%%

Add Method
Index
The position of the item.
ActionDefinition
The action definition to be added.
ActionDefinitions Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ActionDefinition As ActionDefinition _
)

Parameters

Index
The position of the item.
ActionDefinition
The action definition to be added.

See Also

ActionDefinitions Collection | ActionDefinitions Members


%%PageItemTitle%%

Clone Method
ActionDefinitions Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ActionDefinitions

See Also

ActionDefinitions Collection | ActionDefinitions Members


%%PageItemTitle%%

Remove Method
Index
The position of the item.
ActionDefinitions Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The position of the item.

See Also

ActionDefinitions Collection | ActionDefinitions Members


%%PageItemTitle%%

Count Property
ActionDefinitions Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ActionDefinitions Collection | ActionDefinitions Members


%%PageItemTitle%%

Item Property
Index
The position of the item.
ActionDefinitions Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ActionDefinition

Parameters

Index
The position of the item.

See Also

ActionDefinitions Collection | ActionDefinitions Members


%%PageItemTitle%%

ActionSendNotification Object
Members See Also Send comments

Glossary Item Box

Description

The ActionSendNotification class represents a send notification action in a workflow state.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Message | The message text of the notification.
Public Property RecipientsEx | The recipients of the notification.
Public Property Subject | The subject text of the notification.

Remarks

Configuring an action to create send an email notification in a workflow state (highlighted with the green rectangle) as seen in the user interface of M-Files Admin.

See Also

ActionSendNotification Members


%%PageItemTitle%%

Clone Method
ActionSendNotification Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ActionSendNotification

See Also

ActionSendNotification Object | ActionSendNotification Members


%%PageItemTitle%%

Message Property
ActionSendNotification Object : Message Property

Glossary Item Box

Description

The message text of the notification.

Property type

Read-write property

Syntax

Visual Basic
Public Property Message As String

See Also

ActionSendNotification Object | ActionSendNotification Members


%%PageItemTitle%%

RecipientsEx Property
ActionSendNotification Object : RecipientsEx Property

Glossary Item Box

Description

The recipients of the notification.

Property type

Read-write property

Syntax

Visual Basic
Public Property RecipientsEx As UserOrUserGroupIDExs

See Also

ActionSendNotification Object | ActionSendNotification Members


%%PageItemTitle%%

Subject Property
ActionSendNotification Object : Subject Property

Glossary Item Box

Description

The subject text of the notification.

Property type

Read-write property

Syntax

Visual Basic
Public Property Subject As String

See Also

ActionSendNotification Object | ActionSendNotification Members


%%PageItemTitle%%

ActionSetPermissions Object
Members See Also Send comments

Glossary Item Box

Description

The ActionSetPermissions class represents a set permissions action in a workflow state.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property DiscardsAutomaticPermissions | Specifies whether this action discards the automatic permissions.
Public Property Permissions | Specifies the access control list set by this action.

Remarks

Configuring an action to set permissions in a workflow state (highlighted with the green rectangle) as seen in the user interface of M-Files Admin.

See Also

ActionSetPermissions Members


%%PageItemTitle%%

Clone Method
ActionSetPermissions Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ActionSetPermissions

See Also

ActionSetPermissions Object | ActionSetPermissions Members


%%PageItemTitle%%

DiscardsAutomaticPermissions Property
ActionSetPermissions Object : DiscardsAutomaticPermissions Property

Glossary Item Box

Description

Specifies whether this action discards the automatic permissions.

Property type

Read-write property

Syntax

Visual Basic
Public Property DiscardsAutomaticPermissions As Boolean

See Also

ActionSetPermissions Object | ActionSetPermissions Members


%%PageItemTitle%%

Permissions Property
ActionSetPermissions Object : Permissions Property

Glossary Item Box

Description

Specifies the access control list set by this action.

Property type

Read-write property

Syntax

Visual Basic
Public Property Permissions As AccessControlList

See Also

ActionSetPermissions Object | ActionSetPermissions Members


%%PageItemTitle%%

ActionSetProperties Collection
Members See Also Send comments

Glossary Item Box

Description

The ActionSetProperties class represents a set properties action in a workflow state.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Properties Properties collection.

Remarks

In this context, you can ignore the members of the DefaultProperties Collection that begin with "DataFrom". They are used with property mapping of external file sources.

Configuring an action to set object properties in a workflowstate (highlighted with the green rectangle) as seen in the user interface of M-Files Admin.

See Also

ActionSetProperties Members


%%PageItemTitle%%

Clone Method
ActionSetProperties Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ActionSetProperties

See Also

ActionSetProperties Collection | ActionSetProperties Members


%%PageItemTitle%%

Properties Property
ActionSetProperties Collection : Properties Property

Glossary Item Box

Description

Properties collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Properties As DefaultProperties

See Also

ActionSetProperties Collection | ActionSetProperties Members


%%PageItemTitle%%

AdditionalClassInfo Object
Members See Also Send comments

Glossary Item Box

Description

The 'AdditionalClassInfo' class contains type-specific details of an object class.

Public Methods

Public Method Clear | Clears all information.
Public Method Clone | Creates a copy of the object.

Public Properties

Public Property AssignmentClassInfo | Information about an assignment class if 'InfoType' is 'MFAdditionalClassInfoTypeAssignment'. Otherwise NULL.
Public Property InfoType | The additional class info type.

See Also

AdditionalClassInfo Members


%%PageItemTitle%%

Clear Method
AdditionalClassInfo Object : Clear Method

Glossary Item Box

Description

Clears all information.

Syntax

Visual Basic
Public Sub Clear()

See Also

AdditionalClassInfo Object | AdditionalClassInfo Members


%%PageItemTitle%%

Clone Method
AdditionalClassInfo Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AdditionalClassInfo

See Also

AdditionalClassInfo Object | AdditionalClassInfo Members


%%PageItemTitle%%

AssignmentClassInfo Property
AdditionalClassInfo Object : AssignmentClassInfo Property

Glossary Item Box

Description

Information about an assignment class if 'InfoType' is 'MFAdditionalClassInfoTypeAssignment'. Otherwise NULL.

Property type

Read-write property

Syntax

Visual Basic
Public Property AssignmentClassInfo As AssignmentClassInfo

See Also

AdditionalClassInfo Object | AdditionalClassInfo Members


%%PageItemTitle%%

InfoType Property
AdditionalClassInfo Object : InfoType Property

Glossary Item Box

Description

The additional class info type.

Property type

Read-only property

Syntax

Visual Basic
Public Property InfoType As MFAdditionalClassInfoType

See Also

AdditionalClassInfo Object | AdditionalClassInfo Members


%%PageItemTitle%%

AdditionalFolder Object
Members See Also Send comments

Glossary Item Box

Description

The AdditionalFolder class represents a separate location for the vault's file data.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Folder | The path to the folder, e.g., \servernamesharenameolder.
Public Property Impersonation | Impersonation information for accessing the folder.
Public Property LimitInMB | Specifies the limit for the data in megabytes, or zero if no limit.

See Also

AdditionalFolder Members


%%PageItemTitle%%

Clone Method
AdditionalFolder Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AdditionalFolder

See Also

AdditionalFolder Object | AdditionalFolder Members


%%PageItemTitle%%

Folder Property
AdditionalFolder Object : Folder Property

Glossary Item Box

Description

The path to the folder, e.g., \servernamesharenameolder.

Property type

Read-write property

Syntax

Visual Basic
Public Property Folder As String

See Also

AdditionalFolder Object | AdditionalFolder Members


%%PageItemTitle%%

Impersonation Property
AdditionalFolder Object : Impersonation Property

Glossary Item Box

Description

Impersonation information for accessing the folder.

Property type

Read-write property

Syntax

Visual Basic
Public Property Impersonation As Impersonation

See Also

AdditionalFolder Object | AdditionalFolder Members


%%PageItemTitle%%

LimitInMB Property
AdditionalFolder Object : LimitInMB Property

Glossary Item Box

Description

Specifies the limit for the data in megabytes, or zero if no limit.

Property type

Read-write property

Syntax

Visual Basic
Public Property LimitInMB As Long

See Also

AdditionalFolder Object | AdditionalFolder Members


%%PageItemTitle%%

AdditionalFolders Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of additional folders.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

AdditionalFolders Members


%%PageItemTitle%%

Add Method
Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

AdditionalFolder
The new member to add.
AdditionalFolders Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal AdditionalFolder As AdditionalFolder _
)

Parameters

Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

AdditionalFolder
The new member to add.

See Also

AdditionalFolders Collection | AdditionalFolders Members


%%PageItemTitle%%

Clone Method
AdditionalFolders Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AdditionalFolders

See Also

AdditionalFolders Collection | AdditionalFolders Members


%%PageItemTitle%%

Remove Method
Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

AdditionalFolders Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

See Also

AdditionalFolders Collection | AdditionalFolders Members


%%PageItemTitle%%

Count Property
AdditionalFolders Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

AdditionalFolders Collection | AdditionalFolders Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

AdditionalFolders Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As AdditionalFolder

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

AdditionalFolders Collection | AdditionalFolders Members


%%PageItemTitle%%

ApplicationBroadcastMessage Object
Members See Also Send comments

Glossary Item Box

Description

A data object for storing broadcast message data.

Public Methods

Public Method Clone Makes a copy of "IApplicationBroadcastMessage" object.

Public Properties

Public Property BroadcastData | The custom broadcast message payload data. The "BroadcastType" property should indentify the format of this payload.
Public Property BroadcastMessageID | The ID of this broadcast message.
Public Property BroadcastType | The custom type of this broadcast message.
Public Property QueueID | The ID of the task queue to which this broadcast message belongs.

Remarks

Requires M-Files 19.3.7499.1 or later.

See Also

ApplicationBroadcastMessage Members


%%PageItemTitle%%

Clone Method
ApplicationBroadcastMessage Object : Clone Method

Glossary Item Box

Description

Makes a copy of "IApplicationBroadcastMessage" object.

Syntax

Visual Basic
Public Function Clone() As ApplicationBroadcastMessage

See Also

ApplicationBroadcastMessage Object | ApplicationBroadcastMessage Members


%%PageItemTitle%%

BroadcastData Property
ApplicationBroadcastMessage Object : BroadcastData Property

Glossary Item Box

Description

The custom broadcast message payload data. The "BroadcastType" property should indentify the format of this payload.

Property type

Read-write property

Syntax

Visual Basic
Public Property BroadcastData As Byte()

See Also

ApplicationBroadcastMessage Object | ApplicationBroadcastMessage Members


%%PageItemTitle%%

BroadcastMessageID Property
ApplicationBroadcastMessage Object : BroadcastMessageID Property

Glossary Item Box

Description

The ID of this broadcast message.

Property type

Read-write property

Syntax

Visual Basic
Public Property BroadcastMessageID As String

See Also

ApplicationBroadcastMessage Object | ApplicationBroadcastMessage Members


%%PageItemTitle%%

BroadcastType Property
ApplicationBroadcastMessage Object : BroadcastType Property

Glossary Item Box

Description

The custom type of this broadcast message.

Property type

Read-write property

Syntax

Visual Basic
Public Property BroadcastType As String

See Also

ApplicationBroadcastMessage Object | ApplicationBroadcastMessage Members


%%PageItemTitle%%

QueueID Property
ApplicationBroadcastMessage Object : QueueID Property

Glossary Item Box

Description

The ID of the task queue to which this broadcast message belongs.

Property type

Read-write property

Syntax

Visual Basic
Public Property QueueID As String

See Also

ApplicationBroadcastMessage Object | ApplicationBroadcastMessage Members


%%PageItemTitle%%

ApplicationBroadcastMessages Collection
Members See Also Send comments

Glossary Item Box

Description

"ApplicationBroadcastMessagess" is a collection of "ApplicationBroadcastMessage" objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

Remarks

Requires M-Files 19.3.7499.1 or later.

See Also

ApplicationBroadcastMessages Members


%%PageItemTitle%%

Add Method
Index
The position of the collection member to add.
ApplicationBroadcastMessage
The new member to add.
ApplicationBroadcastMessages Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ApplicationBroadcastMessage As ApplicationBroadcastMessage _
)

Parameters

Index
The position of the collection member to add.
ApplicationBroadcastMessage
The new member to add.

See Also

ApplicationBroadcastMessages Collection | ApplicationBroadcastMessages Members


%%PageItemTitle%%

Clone Method
ApplicationBroadcastMessages Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ApplicationBroadcastMessages

See Also

ApplicationBroadcastMessages Collection | ApplicationBroadcastMessages Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ApplicationBroadcastMessages Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ApplicationBroadcastMessages Collection | ApplicationBroadcastMessages Members


%%PageItemTitle%%

Count Property
ApplicationBroadcastMessages Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ApplicationBroadcastMessages Collection | ApplicationBroadcastMessages Members


%%PageItemTitle%%

Item Property
Index
Specifies the position of the item in the collection.
ApplicationBroadcastMessages Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ApplicationBroadcastMessage

Parameters

Index
Specifies the position of the item in the collection.

See Also

ApplicationBroadcastMessages Collection | ApplicationBroadcastMessages Members


%%PageItemTitle%%

ApplicationTaskInfo Object
Members See Also Send comments

Glossary Item Box

Description

A data object for storing task data.

Public Methods

Public Method Clone Makes a copy of the "IApplicationTaskInfo" object.

Public Properties

Public Property ActivationTimestamp | The earliest time when this task can be reserved for processing.
Public Property LatestActivityTimestamp | The last time the task was updated in the database.
Public Property Progress | Any data that describes the progress of the task thus far.
Public Property QueueID | The ID of the task queue this task belongs to or will be added to.
Public Property State | The state of this task.
Public Property TaskData | Custom task data. The task consumer should use the "TaskType" property to detect the custom data format.
Public Property TaskID | The ID of this task. The ID must be unique for all tasks within the same queue.
Public Property TaskType | A custom type for the task. The task consumer can use this information to identify the task type and decode the task data.

Remarks

Requires M-Files 19.3.7499.1 or later.

See Also

ApplicationTaskInfo Members


%%PageItemTitle%%

Clone Method
ApplicationTaskInfo Object : Clone Method

Glossary Item Box

Description

Makes a copy of the "IApplicationTaskInfo" object.

Syntax

Visual Basic
Public Function Clone() As ApplicationTaskInfo

See Also

ApplicationTaskInfo Object | ApplicationTaskInfo Members


%%PageItemTitle%%

ActivationTimestamp Property
ApplicationTaskInfo Object : ActivationTimestamp Property

Glossary Item Box

Description

The earliest time when this task can be reserved for processing.

Property type

Read-only property

Syntax

Visual Basic
Public Property ActivationTimestamp As Timestamp

See Also

ApplicationTaskInfo Object | ApplicationTaskInfo Members


%%PageItemTitle%%

LatestActivityTimestamp Property
ApplicationTaskInfo Object : LatestActivityTimestamp Property

Glossary Item Box

Description

The last time the task was updated in the database.

Property type

Read-only property

Syntax

Visual Basic
Public Property LatestActivityTimestamp As Timestamp

See Also

ApplicationTaskInfo Object | ApplicationTaskInfo Members


%%PageItemTitle%%

Progress Property
ApplicationTaskInfo Object : Progress Property

Glossary Item Box

Description

Any data that describes the progress of the task thus far.

Property type

Read-write property

Syntax

Visual Basic
Public Property Progress As String

See Also

ApplicationTaskInfo Object | ApplicationTaskInfo Members


%%PageItemTitle%%

QueueID Property
ApplicationTaskInfo Object : QueueID Property

Glossary Item Box

Description

The ID of the task queue this task belongs to or will be added to.

Property type

Read-write property

Syntax

Visual Basic
Public Property QueueID As String

See Also

ApplicationTaskInfo Object | ApplicationTaskInfo Members


%%PageItemTitle%%

State Property
ApplicationTaskInfo Object : State Property

Glossary Item Box

Description

The state of this task.

Property type

Read-write property

Syntax

Visual Basic
Public Property State As MFTaskState

See Also

ApplicationTaskInfo Object | ApplicationTaskInfo Members


%%PageItemTitle%%

TaskData Property
ApplicationTaskInfo Object : TaskData Property

Glossary Item Box

Description

Custom task data. The task consumer should use the "TaskType" property to detect the custom data format.

Property type

Read-write property

Syntax

Visual Basic
Public Property TaskData As Byte()

Remarks

The task consumer can be, for instance, an application thread or a backgroud operation carrying out tasks in the task queue.

See Also

ApplicationTaskInfo Object | ApplicationTaskInfo Members


%%PageItemTitle%%

TaskID Property
ApplicationTaskInfo Object : TaskID Property

Glossary Item Box

Description

The ID of this task. The ID must be unique for all tasks within the same queue.

Property type

Read-write property

Syntax

Visual Basic
Public Property TaskID As String

See Also

ApplicationTaskInfo Object | ApplicationTaskInfo Members


%%PageItemTitle%%

TaskType Property
ApplicationTaskInfo Object : TaskType Property

Glossary Item Box

Description

A custom type for the task. The task consumer can use this information to identify the task type and decode the task data.

Property type

Read-write property

Syntax

Visual Basic
Public Property TaskType As String

Remarks

The task consumer can be, for instance, an application thread or a backgroud operation carrying out tasks in the task queue.

See Also

ApplicationTaskInfo Object | ApplicationTaskInfo Members


%%PageItemTitle%%

ApplicationTaskInfos Collection
Members See Also Send comments

Glossary Item Box

Description

"ApplicationTaskInfos" is a collection of "ApplicationTaskInfo" objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

Remarks

Requires M-Files 19.3.7499.1 or later.

See Also

ApplicationTaskInfos Members


%%PageItemTitle%%

Add Method
Index
The position of the collection member to add.
ApplicationTaskInfo
The new member to add.
ApplicationTaskInfos Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ApplicationTaskInfo As ApplicationTaskInfo _
)

Parameters

Index
The position of the collection member to add.
ApplicationTaskInfo
The new member to add.

See Also

ApplicationTaskInfos Collection | ApplicationTaskInfos Members


%%PageItemTitle%%

Clone Method
ApplicationTaskInfos Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ApplicationTaskInfos

See Also

ApplicationTaskInfos Collection | ApplicationTaskInfos Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ApplicationTaskInfos Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ApplicationTaskInfos Collection | ApplicationTaskInfos Members


%%PageItemTitle%%

Count Property
ApplicationTaskInfos Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ApplicationTaskInfos Collection | ApplicationTaskInfos Members


%%PageItemTitle%%

Item Property
Index
Specifies the position of the item in the collection.
ApplicationTaskInfos Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ApplicationTaskInfo

Parameters

Index
Specifies the position of the item in the collection.

See Also

ApplicationTaskInfos Collection | ApplicationTaskInfos Members


%%PageItemTitle%%

ApprovalAssignmentClassInfo Object
Members See Also Send comments

Glossary Item Box

Description

The 'ApprovalAssignmentClassInfo' class contains assignment-specific details of an approval assignment object class.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AnyAssigneeApproves | True if any assignee can approve the assignment. This is valid for approval type assignments only.
Public Property SignatureForApproval | Information about signature settings for assignment approval.
Public Property SignatureForRejection | Information about signature settings for assignment rejection.

Remarks

The "Approval assignment" options in M-Files Admin.

See Also

ApprovalAssignmentClassInfo Members


%%PageItemTitle%%

Clone Method
ApprovalAssignmentClassInfo Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ApprovalAssignmentClassInfo

See Also

ApprovalAssignmentClassInfo Object | ApprovalAssignmentClassInfo Members


%%PageItemTitle%%

AnyAssigneeApproves Property
ApprovalAssignmentClassInfo Object : AnyAssigneeApproves Property

Glossary Item Box

Description

True if any assignee can approve the assignment. This is valid for approval type assignments only.

Property type

Read-write property

Syntax

Visual Basic
Public Property AnyAssigneeApproves As Boolean

See Also

ApprovalAssignmentClassInfo Object | ApprovalAssignmentClassInfo Members


%%PageItemTitle%%

SignatureForApproval Property
ApprovalAssignmentClassInfo Object : SignatureForApproval Property

Glossary Item Box

Description

Information about signature settings for assignment approval.

Property type

Read-write property

Syntax

Visual Basic
Public Property SignatureForApproval As SignatureSettings

See Also

ApprovalAssignmentClassInfo Object | ApprovalAssignmentClassInfo Members


%%PageItemTitle%%

SignatureForRejection Property
ApprovalAssignmentClassInfo Object : SignatureForRejection Property

Glossary Item Box

Description

Information about signature settings for assignment rejection.

Property type

Read-write property

Syntax

Visual Basic
Public Property SignatureForRejection As SignatureSettings

See Also

ApprovalAssignmentClassInfo Object | ApprovalAssignmentClassInfo Members


%%PageItemTitle%%

ArchiveOldVersionsJob Object
Members See Also Send comments

Glossary Item Box

Description

The ArchiveOldVersionsJob class represents a job that moves old versions of objects to a content package.

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property AtLeastNDaysOlder | Specifies whether to include only object versions at least N days older than the current version.
Public Property AtLeastNVersionsOlder | Specifies whether to include only object versions at least N versions older than the current version.
Public Property CheckedInBefore | Specifies whether to include only object versions checked in before the specified time.
Public Property Flags | Specifies additional options as bit flags. Only MFExportContentFlagDestroyAfterExport and MFExportContentFlagClearArchivalMarker are supported.
Public Property Impersonation | Impersonation information to specify the access to the target files.
Public Property MarkedForArchiving | Specifies whether to include only objects that are marked for archiving.
Public Property NoVersionTag | Specifies whether to include only object versions that have no version tag.
Public Property TargetLocation | The full path to the target location on server.
Public Property UseAtLeastNDaysOlder | Specifies whether to use the AtLeastNDaysOlder value.
Public Property UseAtLeastNVersionsOlder | Specifies whether to use the AtLeastNVersionsOlder value.
Public Property UseCheckedInBefore | Specifies whether to use the CheckedInBefore value.

See Also

ArchiveOldVersionsJob Members


%%PageItemTitle%%

Clone Method
ArchiveOldVersionsJob Object : Clone Method

Glossary Item Box

Description

Creates a clone of this object.

Syntax

Visual Basic
Public Function Clone() As ArchiveOldVersionsJob

See Also

ArchiveOldVersionsJob Object | ArchiveOldVersionsJob Members


%%PageItemTitle%%

AtLeastNDaysOlder Property
ArchiveOldVersionsJob Object : AtLeastNDaysOlder Property

Glossary Item Box

Description

Specifies whether to include only object versions at least N days older than the current version.

Property type

Read-write property

Syntax

Visual Basic
Public Property AtLeastNDaysOlder As Long

See Also

ArchiveOldVersionsJob Object | ArchiveOldVersionsJob Members


%%PageItemTitle%%

AtLeastNVersionsOlder Property
ArchiveOldVersionsJob Object : AtLeastNVersionsOlder Property

Glossary Item Box

Description

Specifies whether to include only object versions at least N versions older than the current version.

Property type

Read-write property

Syntax

Visual Basic
Public Property AtLeastNVersionsOlder As Long

See Also

ArchiveOldVersionsJob Object | ArchiveOldVersionsJob Members


%%PageItemTitle%%

CheckedInBefore Property
ArchiveOldVersionsJob Object : CheckedInBefore Property

Glossary Item Box

Description

Specifies whether to include only object versions checked in before the specified time.

Property type

Read-write property

Syntax

Visual Basic
Public Property CheckedInBefore As Timestamp

See Also

ArchiveOldVersionsJob Object | ArchiveOldVersionsJob Members


%%PageItemTitle%%

Flags Property
ArchiveOldVersionsJob Object : Flags Property

Glossary Item Box

Description

Specifies additional options as bit flags. Only MFExportContentFlagDestroyAfterExport and MFExportContentFlagClearArchivalMarker are supported.

Property type

Read-write property

Syntax

Visual Basic
Public Property Flags As MFExportContentFlag

See Also

ArchiveOldVersionsJob Object | ArchiveOldVersionsJob Members


%%PageItemTitle%%

Impersonation Property
ArchiveOldVersionsJob Object : Impersonation Property

Glossary Item Box

Description

Impersonation information to specify the access to the target files.

Property type

Read-write property

Syntax

Visual Basic
Public Property Impersonation As Impersonation

See Also

ArchiveOldVersionsJob Object | ArchiveOldVersionsJob Members


%%PageItemTitle%%

MarkedForArchiving Property
ArchiveOldVersionsJob Object : MarkedForArchiving Property

Glossary Item Box

Description

Specifies whether to include only objects that are marked for archiving.

Property type

Read-write property

Syntax

Visual Basic
Public Property MarkedForArchiving As Boolean

See Also

ArchiveOldVersionsJob Object | ArchiveOldVersionsJob Members


%%PageItemTitle%%

NoVersionTag Property
ArchiveOldVersionsJob Object : NoVersionTag Property

Glossary Item Box

Description

Specifies whether to include only object versions that have no version tag.

Property type

Read-write property

Syntax

Visual Basic
Public Property NoVersionTag As Boolean

See Also

ArchiveOldVersionsJob Object | ArchiveOldVersionsJob Members


%%PageItemTitle%%

TargetLocation Property
ArchiveOldVersionsJob Object : TargetLocation Property

Glossary Item Box

Description

The full path to the target location on server.

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetLocation As String

See Also

ArchiveOldVersionsJob Object | ArchiveOldVersionsJob Members


%%PageItemTitle%%

UseAtLeastNDaysOlder Property
ArchiveOldVersionsJob Object : UseAtLeastNDaysOlder Property

Glossary Item Box

Description

Specifies whether to use the AtLeastNDaysOlder value.

Property type

Read-write property

Syntax

Visual Basic
Public Property UseAtLeastNDaysOlder As Boolean

See Also

ArchiveOldVersionsJob Object | ArchiveOldVersionsJob Members


%%PageItemTitle%%

UseAtLeastNVersionsOlder Property
ArchiveOldVersionsJob Object : UseAtLeastNVersionsOlder Property

Glossary Item Box

Description

Specifies whether to use the AtLeastNVersionsOlder value.

Property type

Read-write property

Syntax

Visual Basic
Public Property UseAtLeastNVersionsOlder As Boolean

See Also

ArchiveOldVersionsJob Object | ArchiveOldVersionsJob Members


%%PageItemTitle%%

UseCheckedInBefore Property
ArchiveOldVersionsJob Object : UseCheckedInBefore Property

Glossary Item Box

Description

Specifies whether to use the CheckedInBefore value.

Property type

Read-write property

Syntax

Visual Basic
Public Property UseCheckedInBefore As Boolean

See Also

ArchiveOldVersionsJob Object | ArchiveOldVersionsJob Members


%%PageItemTitle%%

AssignmentClassInfo Object
Members See Also Send comments

Glossary Item Box

Description

The 'AssignmentClassInfo' class contains assignment-specific details of an assignment object class.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ApprovalAssignmentClassInfo | Information about an approval assignment if 'AssignmentType' is 'MFAssignmentTypeApproval'. Otherwise NULL.
Public Property AssignmentType | The assignment type.
Public Property TaskAssignmentClassInfo | Information about a task assignment if 'AssignmentType' is 'MFAssignmentTypeTask'. Otherwise NULL.

See Also

AssignmentClassInfo Members


%%PageItemTitle%%

Clone Method
AssignmentClassInfo Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AssignmentClassInfo

See Also

AssignmentClassInfo Object | AssignmentClassInfo Members


%%PageItemTitle%%

ApprovalAssignmentClassInfo Property
AssignmentClassInfo Object : ApprovalAssignmentClassInfo Property

Glossary Item Box

Description

Information about an approval assignment if 'AssignmentType' is 'MFAssignmentTypeApproval'. Otherwise NULL.

Property type

Read-write property

Syntax

Visual Basic
Public Property ApprovalAssignmentClassInfo As ApprovalAssignmentClassInfo

See Also

AssignmentClassInfo Object | AssignmentClassInfo Members


%%PageItemTitle%%

AssignmentType Property
AssignmentClassInfo Object : AssignmentType Property

Glossary Item Box

Description

The assignment type.

Property type

Read-only property

Syntax

Visual Basic
Public Property AssignmentType As MFAssignmentType

See Also

AssignmentClassInfo Object | AssignmentClassInfo Members


%%PageItemTitle%%

TaskAssignmentClassInfo Property
AssignmentClassInfo Object : TaskAssignmentClassInfo Property

Glossary Item Box

Description

Information about a task assignment if 'AssignmentType' is 'MFAssignmentTypeTask'. Otherwise NULL.

Property type

Read-write property

Syntax

Visual Basic
Public Property TaskAssignmentClassInfo As TaskAssignmentClassInfo

See Also

AssignmentClassInfo Object | AssignmentClassInfo Members


%%PageItemTitle%%

AssociatedPropertyDef Object
Members See Also Send comments

Glossary Item Box

Description

The AssociatedPropertyDef class represents the property definition of a class.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property PropertyDef | The ID of the associated property definition.
Public Property Required | Specifies whether the associated property definition is required.

Remarks

The AssociatedPropertyDef object connects a single property definition to an object class.

Object classes can have both required and optional property definitions. This class defines the association type and the associated property definition for an object class. The property definition is identified by its ID and the association type is a Boolean value. Use the VaultPropertyDefOperations interface to resolve the PropertyDef object for the property ID.

A single associated property definition (highlighted with the green rectangle) as seen in the user interface of M-Files Admin.

See Also

AssociatedPropertyDef Members | ObjectClass Object


%%PageItemTitle%%

Clone Method
AssociatedPropertyDef Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AssociatedPropertyDef

Return Type

A new copy of the object.

See Also

AssociatedPropertyDef Object | AssociatedPropertyDef Members


%%PageItemTitle%%

PropertyDef Property
AssociatedPropertyDef Object : PropertyDef Property

Glossary Item Box

Description

The ID of the associated property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyDef As Long

Return Type

The ID of the associated property definition.

Remarks

Use the VaultPropertyDefOperations interface to resolve the PropertyDef object for the returned property ID.

See Also

AssociatedPropertyDef Object | AssociatedPropertyDef Members


%%PageItemTitle%%

Required Property
AssociatedPropertyDef Object : Required Property

Glossary Item Box

Description

Specifies whether the associated property definition is required.

Property type

Read-write property

Syntax

Visual Basic
Public Property Required As Boolean

Return Type

Returns true if the property definition is required for objects of a class.

Remarks

If the associated property definition is required, objects of the class must define a value for the property. If the associated property definition is not required, the user may remove the property values from objects of the class, or leave them empty.

See Also

AssociatedPropertyDef Object | AssociatedPropertyDef Members


%%PageItemTitle%%

AssociatedPropertyDefs Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of property definitions associated with the class.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

AssociatedPropertyDefs Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
AssociatedPropertyDef
The new member to add.
AssociatedPropertyDefs Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal AssociatedPropertyDef As AssociatedPropertyDef _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
AssociatedPropertyDef
The new member to add.

See Also

AssociatedPropertyDefs Collection | AssociatedPropertyDefs Members


%%PageItemTitle%%

Clone Method
AssociatedPropertyDefs Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AssociatedPropertyDefs

See Also

AssociatedPropertyDefs Collection | AssociatedPropertyDefs Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
AssociatedPropertyDefs Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

AssociatedPropertyDefs Collection | AssociatedPropertyDefs Members


%%PageItemTitle%%

Count Property
AssociatedPropertyDefs Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

AssociatedPropertyDefs Collection | AssociatedPropertyDefs Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
AssociatedPropertyDefs Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As AssociatedPropertyDef

Parameters

Index
Specifies the item's position in the collection.

See Also

AssociatedPropertyDefs Collection | AssociatedPropertyDefs Members


%%PageItemTitle%%

AttachVaultOptions Object
Members See Also Send comments

Glossary Item Box

Description

The 'AttachVaultOptions' class represents options for attaching vaults.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method DisableAll | Disables all external connections and event handlers.

Public Properties

Public Property AllowOnlyVaultTempPathForContentReplication | Specifies whether attaching a vault removes working directories of cloud replication jobs and disables other replication jobs.
Public Property DisableAnonymousLogin | Specifies whether attaching a vault disables anonymous login.
Public Property DisableEventHandlers | Specifies whether vault attach disables event handlers.
Public Property DisableExportedDataSets | Specifies whether vault attach disables data set exports.
Public Property DisableExportImportJobs | Specifies whether vault attach disables scheduled export/import jobs.
Public Property DisableExternalObjectTypes | Specifies whether vault attach disables external object types.
Public Property DisableExternalSources | Specifies whether vault attach disables external sources (file/mail).
Public Property DisableExternalUserGroups | Specifies whether vault attach disables external user groups.
Public Property DisableLocalIndexes | Specifies whether attaching a vault disables local indexes if any.
Public Property DisableRemoteIndexes | Specifies whether attaching a vault disables remote indexes such as IDOL and Smart Search indexes.
Public Property DisableVaultApplications | Specifies whether attaching a vault disables vault applications.
Public Property FailAttachIfBringOnlineFails | Specifies whether attaching a vault must fail if its online operations do not start successfully.
Public Property Flags | Flags that control what is disabled with vault attach.
Public Property UpdateAttachmentGUID | Specifies whether to update vault GUID with vault attach.

See Also

AttachVaultOptions Members


%%PageItemTitle%%

Clone Method
AttachVaultOptions Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AttachVaultOptions

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

DisableAll Method
AttachVaultOptions Object : DisableAll Method

Glossary Item Box

Description

Disables all external connections and event handlers.

Syntax

Visual Basic
Public Sub DisableAll()

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

AllowOnlyVaultTempPathForContentReplication Property
AttachVaultOptions Object : AllowOnlyVaultTempPathForContentReplication Property

Glossary Item Box

Description

Specifies whether attaching a vault removes working directories of cloud replication jobs and disables other replication jobs.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowOnlyVaultTempPathForContentReplication As Boolean

Remarks

Supported in M-Files 20.10.9524.7 and later.

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

DisableAnonymousLogin Property
AttachVaultOptions Object : DisableAnonymousLogin Property

Glossary Item Box

Description

Specifies whether attaching a vault disables anonymous login.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableAnonymousLogin As Boolean

Remarks

Supported in M-Files 21.12.10943.6 and later.

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

DisableEventHandlers Property
AttachVaultOptions Object : DisableEventHandlers Property

Glossary Item Box

Description

Specifies whether vault attach disables event handlers.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableEventHandlers As Boolean

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

DisableExportedDataSets Property
AttachVaultOptions Object : DisableExportedDataSets Property

Glossary Item Box

Description

Specifies whether vault attach disables data set exports.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableExportedDataSets As Boolean

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

DisableExportImportJobs Property
AttachVaultOptions Object : DisableExportImportJobs Property

Glossary Item Box

Description

Specifies whether vault attach disables scheduled export/import jobs.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableExportImportJobs As Boolean

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

DisableExternalObjectTypes Property
AttachVaultOptions Object : DisableExternalObjectTypes Property

Glossary Item Box

Description

Specifies whether vault attach disables external object types.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableExternalObjectTypes As Boolean

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

DisableExternalSources Property
AttachVaultOptions Object : DisableExternalSources Property

Glossary Item Box

Description

Specifies whether vault attach disables external sources (file/mail).

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableExternalSources As Boolean

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

DisableExternalUserGroups Property
AttachVaultOptions Object : DisableExternalUserGroups Property

Glossary Item Box

Description

Specifies whether vault attach disables external user groups.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableExternalUserGroups As Boolean

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

DisableLocalIndexes Property
AttachVaultOptions Object : DisableLocalIndexes Property

Glossary Item Box

Description

Specifies whether attaching a vault disables local indexes if any.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableLocalIndexes As Boolean

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

DisableRemoteIndexes Property
AttachVaultOptions Object : DisableRemoteIndexes Property

Glossary Item Box

Description

Specifies whether attaching a vault disables remote indexes such as IDOL and Smart Search indexes.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisableRemoteIndexes As Boolean

Remarks

Supported in M-Files 19.5.7811.7 and later.

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

DisableVaultApplications Property
AttachVaultOptions Object : DisableVaultApplications Property

Glossary Item Box

Description

Specifies whether attaching a vault disables vault applications.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableVaultApplications As Boolean

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

FailAttachIfBringOnlineFails Property
AttachVaultOptions Object : FailAttachIfBringOnlineFails Property

Glossary Item Box

Description

Specifies whether attaching a vault must fail if its online operations do not start successfully.

Property type

Read-write property

Syntax

Visual Basic
Public Property FailAttachIfBringOnlineFails As Boolean

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

Flags Property
AttachVaultOptions Object : Flags Property

Glossary Item Box

Description

Flags that control what is disabled with vault attach.

Property type

Read-write property

Syntax

Visual Basic
Public Property Flags As MFAttachVaultOptionsFlag

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

UpdateAttachmentGUID Property
AttachVaultOptions Object : UpdateAttachmentGUID Property

Glossary Item Box

Description

Specifies whether to update vault GUID with vault attach.

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdateAttachmentGUID As Boolean

See Also

AttachVaultOptions Object | AttachVaultOptions Members


%%PageItemTitle%%

AuthenticationResult Object
Members See Also Send comments

Glossary Item Box

Description

The 'AuthenticationResult' class represents the description for an authentication attempt's result.

Public Properties

Public Property Intermediate | Intermediate authentication result. NULL if the authentication is complete.
Public Property ServerFinal | Final authentication result for a server login. NULL if a vault login, or if the authentication is not complete.
Public Property VaultFinal | Final authentication result for a vault login. NULL if a server login, or if the authentication is not complete.

See Also

AuthenticationResult Members


%%PageItemTitle%%

Intermediate Property
AuthenticationResult Object : Intermediate Property

Glossary Item Box

Description

Intermediate authentication result. NULL if the authentication is complete.

Property type

Read-only property

Syntax

Visual Basic
Public Property Intermediate As AuthenticationResultIntermediate

See Also

AuthenticationResult Object | AuthenticationResult Members


%%PageItemTitle%%

ServerFinal Property
AuthenticationResult Object : ServerFinal Property

Glossary Item Box

Description

Final authentication result for a server login. NULL if a vault login, or if the authentication is not complete.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerFinal As AuthenticationResultServerFinal

See Also

AuthenticationResult Object | AuthenticationResult Members


%%PageItemTitle%%

VaultFinal Property
AuthenticationResult Object : VaultFinal Property

Glossary Item Box

Description

Final authentication result for a vault login. NULL if a server login, or if the authentication is not complete.

Property type

Read-only property

Syntax

Visual Basic
Public Property VaultFinal As AuthenticationResultVaultFinal

See Also

AuthenticationResult Object | AuthenticationResult Members


%%PageItemTitle%%

AuthenticationResultIntermediate Object
Members See Also Send comments

Glossary Item Box

Description

The 'AuthenticationResultIntermediate' class represents the description for an authentication attempt's intermediate result.

Public Properties

Public Property AttemptIdentifier | The authentication attempt identifier.
Public Property AuthenticationData | The intermediate authentication data.

See Also

AuthenticationResultIntermediate Members


%%PageItemTitle%%

AttemptIdentifier Property
AuthenticationResultIntermediate Object : AttemptIdentifier Property

Glossary Item Box

Description

The authentication attempt identifier.

Property type

Read-only property

Syntax

Visual Basic
Public Property AttemptIdentifier As String

See Also

AuthenticationResultIntermediate Object | AuthenticationResultIntermediate Members


%%PageItemTitle%%

AuthenticationData Property
AuthenticationResultIntermediate Object : AuthenticationData Property

Glossary Item Box

Description

The intermediate authentication data.

Property type

Read-only property

Syntax

Visual Basic
Public Property AuthenticationData As NamedValues

See Also

AuthenticationResultIntermediate Object | AuthenticationResultIntermediate Members


%%PageItemTitle%%

AuthenticationResultServerFinal Object
Members See Also Send comments

Glossary Item Box

Description

The 'AuthenticationResultServerFinal' class represents the description for a server authentication attempt's final result.

Public Properties

Public Property ServerConnection The state of the server connection and authentication.

See Also

AuthenticationResultServerFinal Members


%%PageItemTitle%%

ServerConnection Property
AuthenticationResultServerFinal Object : ServerConnection Property

Glossary Item Box

Description

The state of the server connection and authentication.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerConnection As MFServerConnection

See Also

AuthenticationResultServerFinal Object | AuthenticationResultServerFinal Members


%%PageItemTitle%%

AuthenticationResultVaultFinal Object
Members See Also Send comments

Glossary Item Box

Description

The 'AuthenticationResultVaultFinal' class represents the description for a vault authentication attempt's final result.

Public Properties

Public Property Vault The vault object.

See Also

AuthenticationResultVaultFinal Members


%%PageItemTitle%%

Vault Property
AuthenticationResultVaultFinal Object : Vault Property

Glossary Item Box

Description

The vault object.

Property type

Read-only property

Syntax

Visual Basic
Public Property Vault As Vault

See Also

AuthenticationResultVaultFinal Object | AuthenticationResultVaultFinal Members


%%PageItemTitle%%

AutomaticMetadataResult Object
Members See Also Send comments

Glossary Item Box

Description

The 'AutomaticMetadataResult' class represents the output data from the automatic metadata retrieval operation.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property PropertyValueSuggestions The property value suggestions.

See Also

AutomaticMetadataResult Members


%%PageItemTitle%%

Clone Method
AutomaticMetadataResult Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AutomaticMetadataResult

See Also

AutomaticMetadataResult Object | AutomaticMetadataResult Members


%%PageItemTitle%%

PropertyValueSuggestions Property
AutomaticMetadataResult Object : PropertyValueSuggestions Property

Glossary Item Box

Description

The property value suggestions.

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyValueSuggestions As PropertyValueSuggestions

See Also

AutomaticMetadataResult Object | AutomaticMetadataResult Members


%%PageItemTitle%%

AutomaticPermissions Object
Members See Also Send comments

Glossary Item Box

Description

Specifies the automatic ACL for a value list item.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetBasedOnObjectACL | Specifies that the automatic ACL is based on the object's own ACL.
Public Method SetNamedACL | Specifies a new named ACL as the automatic ACL.

Public Properties

Public Property CanDeactivate | Specifies whether a user can deactivate this automatic component.
Public Property IsBasedOnObjectACL | Specifies whether the ACL defined by this automatic ACL is based on the ACL of the object for which it is defined.
Public Property IsDefault | Specifies whether the ACL is the default one, i.e., one that has been inherited from the object type level.
Public Property NamedACL | The named ACL specified by this automatic ACL.

Remarks

Specifies automatic permission settings. The settings may be inherited from the object type of an item or they may be specified on the item itself. Despite the source of the settings, there are two ways to specify these: Using the object's own ACL or using a NamedACL. Use the SetNamedACL or SetBasedOnObjectACL to switch between these two modes.

Configuring automatic permissions as seen in the user interface of M-Files Admin.

Example

Defining automatic permissions (Visual Basic) Copy Code
Sub SetAutomaticPermissions( _
        ByVal vault As MFilesAPI.Vault, _
        ByVal valueList As Integer, _
        ByVal itemID As Integer, _
        ByVal acl As MFilesAPI.AccessControlList)

    ' Create internal NamedACL
    Dim nacl As New MFilesAPI.NamedACL
    nacl.AccessControlList = acl
    nacl.Name = "Custom automatic permissions"

    ' Get the value list item.
    Dim listItem As MFilesAPI.ValueListItem = _
        vault.ValueListItemOperations.GetValueListItemByID(valueList, itemID)

    ' The automatic permission property has the value of Nothing if the item doesn't
    ' have automatic permissions specified.
    listItem.AutomaticPermissionsForObjects = New MFilesAPI.AutomaticPermissions()

    ' Set the NACL
    listItem.AutomaticPermissionsForObjects.SetNamedACL(nacl)

    ' Save changes
    vault.ValueListItemOperations.UpdateValueListItem(listItem)

End Sub

See Also

AutomaticPermissions Members


%%PageItemTitle%%

Clone Method
AutomaticPermissions Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AutomaticPermissions

See Also

AutomaticPermissions Object | AutomaticPermissions Members


%%PageItemTitle%%

SetBasedOnObjectACL Method
AutomaticPermissions Object : SetBasedOnObjectACL Method

Glossary Item Box

Description

Specifies that the automatic ACL is based on the object's own ACL.

Syntax

Visual Basic
Public Sub SetBasedOnObjectACL()

See Also

AutomaticPermissions Object | AutomaticPermissions Members


%%PageItemTitle%%

SetNamedACL Method
NamedACL
AutomaticPermissions Object : SetNamedACL Method

Glossary Item Box

Description

Specifies a new named ACL as the automatic ACL.

Syntax

Visual Basic
Public Sub SetNamedACL( _
   ByVal NamedACL As NamedACL _
)

Parameters

NamedACL

See Also

AutomaticPermissions Object | AutomaticPermissions Members


%%PageItemTitle%%

CanDeactivate Property
AutomaticPermissions Object : CanDeactivate Property

Glossary Item Box

Description

Specifies whether a user can deactivate this automatic component.

Property type

Read-write property

Syntax

Visual Basic
Public Property CanDeactivate As Boolean

See Also

AutomaticPermissions Object | AutomaticPermissions Members


%%PageItemTitle%%

IsBasedOnObjectACL Property
AutomaticPermissions Object : IsBasedOnObjectACL Property

Glossary Item Box

Description

Specifies whether the ACL defined by this automatic ACL is based on the ACL of the object for which it is defined.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsBasedOnObjectACL As Boolean

See Also

AutomaticPermissions Object | AutomaticPermissions Members


%%PageItemTitle%%

IsDefault Property
AutomaticPermissions Object : IsDefault Property

Glossary Item Box

Description

Specifies whether the ACL is the default one, i.e., one that has been inherited from the object type level.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsDefault As Boolean

See Also

AutomaticPermissions Object | AutomaticPermissions Members


%%PageItemTitle%%

NamedACL Property
AutomaticPermissions Object : NamedACL Property

Glossary Item Box

Description

The named ACL specified by this automatic ACL.

Property type

Read-only property

Syntax

Visual Basic
Public Property NamedACL As NamedACL

See Also

AutomaticPermissions Object | AutomaticPermissions Members


%%PageItemTitle%%

AutomaticValue Object
Members See Also Send comments

Glossary Item Box

Description

The AutomaticValue class represents an automatic value specification.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ANSIncrement | Simple automatic numbering: Increment.
Public Property ANVCode | Customized automatic numbering (VBScript): VBScript code.
Public Property CalculationOrderNumber | A number that specifies calculation order. Properties are calculated from smallest to largest calculation order number.
Public Property CVSExpression | Simple concatenation of properties: Expression.
Public Property CVVCode | Calculated value (VBScript): VBScript code.

Remarks

A property definition with an automatic value as seen in M-Files Admin.

See Also

AutomaticValue Members


%%PageItemTitle%%

Clone Method
AutomaticValue Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As AutomaticValue

See Also

AutomaticValue Object | AutomaticValue Members


%%PageItemTitle%%

ANSIncrement Property
AutomaticValue Object : ANSIncrement Property

Glossary Item Box

Description

Simple automatic numbering: Increment.

Property type

Read-write property

Syntax

Visual Basic
Public Property ANSIncrement As Long

See Also

AutomaticValue Object | AutomaticValue Members


%%PageItemTitle%%

ANVCode Property
AutomaticValue Object : ANVCode Property

Glossary Item Box

Description

Customized automatic numbering (VBScript): VBScript code.

Property type

Read-write property

Syntax

Visual Basic
Public Property ANVCode As String

See Also

AutomaticValue Object | AutomaticValue Members


%%PageItemTitle%%

CalculationOrderNumber Property
AutomaticValue Object : CalculationOrderNumber Property

Glossary Item Box

Description

A number that specifies calculation order. Properties are calculated from smallest to largest calculation order number.

Property type

Read-write property

Syntax

Visual Basic
Public Property CalculationOrderNumber As Long

See Also

AutomaticValue Object | AutomaticValue Members


%%PageItemTitle%%

CVSExpression Property
AutomaticValue Object : CVSExpression Property

Glossary Item Box

Description

Simple concatenation of properties: Expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property CVSExpression As String

See Also

AutomaticValue Object | AutomaticValue Members


%%PageItemTitle%%

CVVCode Property
AutomaticValue Object : CVVCode Property

Glossary Item Box

Description

Calculated value (VBScript): VBScript code.

Property type

Read-write property

Syntax

Visual Basic
Public Property CVVCode As String

See Also

AutomaticValue Object | AutomaticValue Members


%%PageItemTitle%%

BackupJob Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents a backup job.

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property BackupType | Backup type.
Public Property FileSizeLimitInMB | Maximum file size for individual backup files.
Public Property Impersonation | Impersonation information to specify the access to the target files.
Public Property OverwriteExistingFiles | Specifies whether existing files are overwritten.
Public Property TargetFile | Target for the backup file.
Public Property VaultGUID | GUID identifying the vault. Empty for Master backup.

Remarks

A vault backup job definition as seen in M-Files Admin.

See Also

BackupJob Members


%%PageItemTitle%%

Clone Method
BackupJob Object : Clone Method

Glossary Item Box

Description

Creates a clone of this object.

Syntax

Visual Basic
Public Function Clone() As BackupJob

See Also

BackupJob Object | BackupJob Members


%%PageItemTitle%%

BackupType Property
BackupJob Object : BackupType Property

Glossary Item Box

Description

Backup type.

Property type

Read-write property

Syntax

Visual Basic
Public Property BackupType As MFBackupType

See Also

BackupJob Object | BackupJob Members


%%PageItemTitle%%

FileSizeLimitInMB Property
BackupJob Object : FileSizeLimitInMB Property

Glossary Item Box

Description

Maximum file size for individual backup files.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileSizeLimitInMB As Long

See Also

BackupJob Object | BackupJob Members


%%PageItemTitle%%

Impersonation Property
BackupJob Object : Impersonation Property

Glossary Item Box

Description

Impersonation information to specify the access to the target files.

Property type

Read-write property

Syntax

Visual Basic
Public Property Impersonation As Impersonation

See Also

BackupJob Object | BackupJob Members


%%PageItemTitle%%

OverwriteExistingFiles Property
BackupJob Object : OverwriteExistingFiles Property

Glossary Item Box

Description

Specifies whether existing files are overwritten.

Property type

Read-write property

Syntax

Visual Basic
Public Property OverwriteExistingFiles As Boolean

See Also

BackupJob Object | BackupJob Members


%%PageItemTitle%%

TargetFile Property
BackupJob Object : TargetFile Property

Glossary Item Box

Description

Target for the backup file.

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetFile As String

See Also

BackupJob Object | BackupJob Members


%%PageItemTitle%%

VaultGUID Property
BackupJob Object : VaultGUID Property

Glossary Item Box

Description

GUID identifying the vault. Empty for Master backup.

Property type

Read-write property

Syntax

Visual Basic
Public Property VaultGUID As String

See Also

BackupJob Object | BackupJob Members


%%PageItemTitle%%

BooleanValue Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents a simple boolean value.

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property Value Value.

See Also

BooleanValue Members


%%PageItemTitle%%

Clone Method
BooleanValue Object : Clone Method

Glossary Item Box

Description

Creates a clone of this object.

Syntax

Visual Basic
Public Function Clone() As BooleanValue

See Also

BooleanValue Object | BooleanValue Members


%%PageItemTitle%%

Value Property
BooleanValue Object : Value Property

Glossary Item Box

Description

Value.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value As Boolean

See Also

BooleanValue Object | BooleanValue Members


%%PageItemTitle%%

ClassGroup Object
Members See Also Send comments

Glossary Item Box

Description

A class group contains a set of classes.

Public Methods

Public Method AddMember | Adds a member.
Public Method Clone | Creates a copy of the object.
Public Method RemoveMember | Removes the specified member.

Public Properties

Public Property ID | The ID of the class group.
Public Property Members | The members of the class group.
Public Property Name | The name of the class group.
Public Property ObjectType | The object type with which this class group is used.

See Also

ClassGroup Members | ObjectClass Object


%%PageItemTitle%%

AddMember Method
Member
The ID of the class to add.
ClassGroup Object : AddMember Method

Glossary Item Box

Description

Adds a member.

Syntax

Visual Basic
Public Sub AddMember( _
   ByVal Member As Long _
)

Parameters

Member
The ID of the class to add.

See Also

ClassGroup Object | ClassGroup Members


%%PageItemTitle%%

Clone Method
ClassGroup Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ClassGroup

Return Type

Returns the copied object.

See Also

ClassGroup Object | ClassGroup Members


%%PageItemTitle%%

RemoveMember Method
Member
The ID of the class to remove.
ClassGroup Object : RemoveMember Method

Glossary Item Box

Description

Removes the specified member.

Syntax

Visual Basic
Public Sub RemoveMember( _
   ByVal Member As Long _
)

Parameters

Member
The ID of the class to remove.

See Also

ClassGroup Object | ClassGroup Members


%%PageItemTitle%%

ID Property
ClassGroup Object : ID Property

Glossary Item Box

Description

The ID of the class group.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

ClassGroup Object | ClassGroup Members


%%PageItemTitle%%

Members Property
ClassGroup Object : Members Property

Glossary Item Box

Description

The members of the class group.

Property type

Read-write property

Syntax

Visual Basic
Public Property Members As IDs

Return Type

The return value is an array of object class IDs.

Remarks

Use the VaultClassOperations interface to resolve actual ObjectClass objects for the IDs.

See Also

ClassGroup Object | ClassGroup Members


%%PageItemTitle%%

Name Property
ClassGroup Object : Name Property

Glossary Item Box

Description

The name of the class group.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

ClassGroup Object | ClassGroup Members


%%PageItemTitle%%

ObjectType Property
ClassGroup Object : ObjectType Property

Glossary Item Box

Description

The object type with which this class group is used.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectType As Long

Remarks

Use VaultObjectTypeOperations in order to resolve the actual ObjType object for the object type ID.

See Also

ClassGroup Object | ClassGroup Members


%%PageItemTitle%%

ClassGroups Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of ClassGroup objects.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ClassGroups Members


%%PageItemTitle%%

Clone Method
ClassGroups Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ClassGroups

See Also

ClassGroups Collection | ClassGroups Members


%%PageItemTitle%%

Count Property
ClassGroups Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ClassGroups Collection | ClassGroups Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
ClassGroups Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ClassGroup

Parameters

Index
Specifies the item's position in the collection.

See Also

ClassGroups Collection | ClassGroups Members


%%PageItemTitle%%

ClientCapabilities Object
Members See Also Send comments

Glossary Item Box

Description

A data object for specifying the capabilities of an M-Files client instance.

Public Methods

Public Method Clone | Creates a clone of an object.
Public Method LoadWithBaseCapabilitiesForThisVersion | Initializes the capabilities with the base capabilities for this version.

Public Properties

Public Property PropertyDefSearchabilitySupported | Property definitions can be set to be searchable or unsearchable.
Public Property UnmanagedObjectsSupported | The client is capable of handling unmanaged objects.

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ClientCapabilities Members


%%PageItemTitle%%

Clone Method
ClientCapabilities Object : Clone Method

Glossary Item Box

Description

Creates a clone of an object.

Syntax

Visual Basic
Public Function Clone() As ClientCapabilities

See Also

ClientCapabilities Object | ClientCapabilities Members


%%PageItemTitle%%

LoadWithBaseCapabilitiesForThisVersion Method
ClientCapabilities Object : LoadWithBaseCapabilitiesForThisVersion Method

Glossary Item Box

Description

Initializes the capabilities with the base capabilities for this version.

Syntax

Visual Basic
Public Sub LoadWithBaseCapabilitiesForThisVersion()

Remarks

Requires M-Files 19.2.7378.0 or later.

See Also

ClientCapabilities Object | ClientCapabilities Members


%%PageItemTitle%%

PropertyDefSearchabilitySupported Property
ClientCapabilities Object : PropertyDefSearchabilitySupported Property

Glossary Item Box

Description

Property definitions can be set to be searchable or unsearchable.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyDefSearchabilitySupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ClientCapabilities Object | ClientCapabilities Members


%%PageItemTitle%%

UnmanagedObjectsSupported Property
ClientCapabilities Object : UnmanagedObjectsSupported Property

Glossary Item Box

Description

The client is capable of handling unmanaged objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property UnmanagedObjectsSupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ClientCapabilities Object | ClientCapabilities Members


%%PageItemTitle%%

ConnectionData Object
Members See Also Send comments

Glossary Item Box

Description

A data object for specifying the M-Files server connection details.

Public Methods

Public Method Clone Creates a clone of an object.

Public Properties

Public Property AllowAnonymousConnection | True to allow an anonymous connection. Not applicable with connections without login.
Public Property AllowUsingAuthenticationPlugins | True if authentication plugin configurations are used for authentication.
Public Property ClientCapabilities | The capabilities of the connected client.
Public Property ClientCertificateValidated | True if the client has prevalidated the client certificate. This value is trusted if the client is physically the same computer as the server (for instance with LRPC connections).
Public Property ClientCulture | The client culture.
Public Property ClientDeviceToken | The device-specific identifier of the client device. Each device should report a globally unique identifier. The identifier can be, for example, the notification push identifier.
Public Property ClientHostPlatform | A free-formatted name for the host device, OS and the platform. For example 'Firefox 56.0', 'Windows 10', 'Android 7.0'.
Public Property ClientType | The type of the client software.
Public Property ClientTypeSpecifier | A more specific and free-formatted name for the user agent, such as 'M-Files Client'.
Public Property EncryptedConnection | True if the connection is encrypted. Not applicable with connections without login.
Public Property Endpoint | The endpoint port.
Public Property LocalComputerName | The local computer name.
Public Property LogicalTargetServer | The logical target server name.
Public Property NetworkAddress | The network address.
Public Property ProtocolSequence

The supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
Public Property TimeZone | The time zone of the client.

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Members


%%PageItemTitle%%

Clone Method
ConnectionData Object : Clone Method

Glossary Item Box

Description

Creates a clone of an object.

Syntax

Visual Basic
Public Function Clone() As ConnectionData

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

AllowAnonymousConnection Property
ConnectionData Object : AllowAnonymousConnection Property

Glossary Item Box

Description

True to allow an anonymous connection. Not applicable with connections without login.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowAnonymousConnection As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

AllowUsingAuthenticationPlugins Property
ConnectionData Object : AllowUsingAuthenticationPlugins Property

Glossary Item Box

Description

True if authentication plugin configurations are used for authentication.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowUsingAuthenticationPlugins As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

ClientCapabilities Property
ConnectionData Object : ClientCapabilities Property

Glossary Item Box

Description

The capabilities of the connected client.

Property type

Read-write property

Syntax

Visual Basic
Public Property ClientCapabilities As ClientCapabilities

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

ClientCertificateValidated Property
ConnectionData Object : ClientCertificateValidated Property

Glossary Item Box

Description

True if the client has prevalidated the client certificate. This value is trusted if the client is physically the same computer as the server (for instance with LRPC connections).

Property type

Read-write property

Syntax

Visual Basic
Public Property ClientCertificateValidated As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

ClientCulture Property
ConnectionData Object : ClientCulture Property

Glossary Item Box

Description

The client culture.

Property type

Read-write property

Syntax

Visual Basic
Public Property ClientCulture As String

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

ClientDeviceToken Property
ConnectionData Object : ClientDeviceToken Property

Glossary Item Box

Description

The device-specific identifier of the client device. Each device should report a globally unique identifier. The identifier can be, for example, the notification push identifier.

Property type

Read-write property

Syntax

Visual Basic
Public Property ClientDeviceToken As String

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

ClientHostPlatform Property
ConnectionData Object : ClientHostPlatform Property

Glossary Item Box

Description

A free-formatted name for the host device, OS and the platform. For example 'Firefox 56.0', 'Windows 10', 'Android 7.0'.

Property type

Read-write property

Syntax

Visual Basic
Public Property ClientHostPlatform As String

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

ClientType Property
ConnectionData Object : ClientType Property

Glossary Item Box

Description

The type of the client software.

Property type

Read-write property

Syntax

Visual Basic
Public Property ClientType As MFClientType

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

ClientTypeSpecifier Property
ConnectionData Object : ClientTypeSpecifier Property

Glossary Item Box

Description

A more specific and free-formatted name for the user agent, such as 'M-Files Client'.

Property type

Read-write property

Syntax

Visual Basic
Public Property ClientTypeSpecifier As String

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

EncryptedConnection Property
ConnectionData Object : EncryptedConnection Property

Glossary Item Box

Description

True if the connection is encrypted. Not applicable with connections without login.

Property type

Read-write property

Syntax

Visual Basic
Public Property EncryptedConnection As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

Endpoint Property
ConnectionData Object : Endpoint Property

Glossary Item Box

Description

The endpoint port.

Property type

Read-write property

Syntax

Visual Basic
Public Property Endpoint As String

Remarks

Requires M-Files 18.10.6895.1 or later.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

LocalComputerName Property
ConnectionData Object : LocalComputerName Property

Glossary Item Box

Description

The local computer name.

Property type

Read-write property

Syntax

Visual Basic
Public Property LocalComputerName As String

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

LogicalTargetServer Property
ConnectionData Object : LogicalTargetServer Property

Glossary Item Box

Description

The logical target server name.

Property type

Read-write property

Syntax

Visual Basic
Public Property LogicalTargetServer As String

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

NetworkAddress Property
ConnectionData Object : NetworkAddress Property

Glossary Item Box

Description

The network address.

Property type

Read-write property

Syntax

Visual Basic
Public Property NetworkAddress As String

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

ProtocolSequence Property
ConnectionData Object : ProtocolSequence Property

Glossary Item Box

Description

The supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)

Property type

Read-write property

Syntax

Visual Basic
Public Property ProtocolSequence As String

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

TimeZone Property
ConnectionData Object : TimeZone Property

Glossary Item Box

Description

The time zone of the client.

Property type

Read-write property

Syntax

Visual Basic
Public Property TimeZone As TimeZoneInformation

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ConnectionData Object | ConnectionData Members


%%PageItemTitle%%

CopyVaultJob Object
Members See Also Send comments

Glossary Item Box

Description

The CopyVaultJob class represents a copy vault job.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property CopyflagAllData | Copy all data. All other flags are ignored.
Public Property CopyflagAllExceptData | Copy all except all data.
Public Property CopyflagApplications | Copy applications.
Public Property CopyflagDataSets | Copy exported data sets.
Public Property CopyflagDocumentProfiles | Copy classes and class groups.
Public Property CopyflagDocuments | Copy documents and other objects.
Public Property CopyflagEventLog | Copy event log.
Public Property CopyflagExternalLocations | Copy connections to external locations.
Public Property CopyflagFiles | Copy document file contents.
Public Property CopyflagInternalEventHandlers | Copy internal event handlers.
Public Property CopyflagLanguagesAndTranslations | Copy languages and translations.
Public Property CopyflagPropertyDefinitions | Copy property definitions.
Public Property CopyflagScheduledExportAndImportJobs | Copy scheduled export and import jobs.
Public Property CopyflagUserAccounts | Copy users and user groups.
Public Property CopyflagUseTargetGUID | Defines whether or not to use the provided target vault GUID.
Public Property CopyflagValueListContent | Copy value list contents.
Public Property CopyflagValueLists | Copy value list definitions.
Public Property CopyflagViews | Copy views.
Public Property CopyflagWorkflows | Copy workflows.
Public Property VaultGUID | The GUID of the vault to copy.
Public Property VaultProperties | The definition of the target vault. The GUID field is ignored unless CopyflagUseTargetGUID is set.

Remarks

A vault copying job definition as seen in M-Files Admin.

See Also

CopyVaultJob Members


%%PageItemTitle%%

Clone Method
CopyVaultJob Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As CopyVaultJob

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagAllData Property
CopyVaultJob Object : CopyflagAllData Property

Glossary Item Box

Description

Copy all data. All other flags are ignored.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagAllData As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagAllExceptData Property
CopyVaultJob Object : CopyflagAllExceptData Property

Glossary Item Box

Description

Copy all except all data.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagAllExceptData As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagApplications Property
CopyVaultJob Object : CopyflagApplications Property

Glossary Item Box

Description

Copy applications.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagApplications As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagDataSets Property
CopyVaultJob Object : CopyflagDataSets Property

Glossary Item Box

Description

Copy exported data sets.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagDataSets As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagDocumentProfiles Property
CopyVaultJob Object : CopyflagDocumentProfiles Property

Glossary Item Box

Description

Copy classes and class groups.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagDocumentProfiles As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagDocuments Property
CopyVaultJob Object : CopyflagDocuments Property

Glossary Item Box

Description

Copy documents and other objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagDocuments As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagEventLog Property
CopyVaultJob Object : CopyflagEventLog Property

Glossary Item Box

Description

Copy event log.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagEventLog As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagExternalLocations Property
CopyVaultJob Object : CopyflagExternalLocations Property

Glossary Item Box

Description

Copy connections to external locations.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagExternalLocations As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagFiles Property
CopyVaultJob Object : CopyflagFiles Property

Glossary Item Box

Description

Copy document file contents.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagFiles As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagInternalEventHandlers Property
CopyVaultJob Object : CopyflagInternalEventHandlers Property

Glossary Item Box

Description

Copy internal event handlers.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagInternalEventHandlers As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagLanguagesAndTranslations Property
CopyVaultJob Object : CopyflagLanguagesAndTranslations Property

Glossary Item Box

Description

Copy languages and translations.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagLanguagesAndTranslations As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagPropertyDefinitions Property
CopyVaultJob Object : CopyflagPropertyDefinitions Property

Glossary Item Box

Description

Copy property definitions.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagPropertyDefinitions As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagScheduledExportAndImportJobs Property
CopyVaultJob Object : CopyflagScheduledExportAndImportJobs Property

Glossary Item Box

Description

Copy scheduled export and import jobs.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagScheduledExportAndImportJobs As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagUserAccounts Property
CopyVaultJob Object : CopyflagUserAccounts Property

Glossary Item Box

Description

Copy users and user groups.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagUserAccounts As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagUseTargetGUID Property
CopyVaultJob Object : CopyflagUseTargetGUID Property

Glossary Item Box

Description

Defines whether or not to use the provided target vault GUID.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagUseTargetGUID As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagValueListContent Property
CopyVaultJob Object : CopyflagValueListContent Property

Glossary Item Box

Description

Copy value list contents.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagValueListContent As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagValueLists Property
CopyVaultJob Object : CopyflagValueLists Property

Glossary Item Box

Description

Copy value list definitions.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagValueLists As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagViews Property
CopyVaultJob Object : CopyflagViews Property

Glossary Item Box

Description

Copy views.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagViews As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyflagWorkflows Property
CopyVaultJob Object : CopyflagWorkflows Property

Glossary Item Box

Description

Copy workflows.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyflagWorkflows As Boolean

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

VaultGUID Property
CopyVaultJob Object : VaultGUID Property

Glossary Item Box

Description

The GUID of the vault to copy.

Property type

Read-write property

Syntax

Visual Basic
Public Property VaultGUID As String

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

VaultProperties Property
CopyVaultJob Object : VaultProperties Property

Glossary Item Box

Description

The definition of the target vault. The GUID field is ignored unless CopyflagUseTargetGUID is set.

Property type

Read-write property

Syntax

Visual Basic
Public Property VaultProperties As VaultProperties

See Also

CopyVaultJob Object | CopyVaultJob Members


%%PageItemTitle%%

CopyVaultJobOutputInfo Object
Members See Also Send comments

Glossary Item Box

Description

The CopyVaultJobOutputInfo class represents the results of a copy vault job.

Public Properties

Public Property VaultProperties VaultProperties

See Also

CopyVaultJobOutputInfo Members


%%PageItemTitle%%

VaultProperties Property
CopyVaultJobOutputInfo Object : VaultProperties Property

Glossary Item Box

Description

VaultProperties

Property type

Read-only property

Syntax

Visual Basic
Public Property VaultProperties As VaultProperties

See Also

CopyVaultJobOutputInfo Object | CopyVaultJobOutputInfo Members


%%PageItemTitle%%

CustomApplication Object
Members See Also Send comments

Glossary Item Box

Description

The CustomApplication class represents an application installed in the vault.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ApplicationType | The application type.
Public Property ChecksumHash | The checksum of the application (hash value).
Public Property Description | The description of the application.
Public Property Enabled | Specifies whether the application is enabled.
Public Property ID | The identifier for the application.
Public Property MasterApplication | The GUID for the master application (without curly braces). Empty string if there is no master application.
Public Property MultiServerCompatible | Specifies whether this application is compatible with a multi-server environment.
Public Property Name | The name of the application.
Public Property Optional | Specifies whether the application can be disabled.
Public Property Publisher | The name of the publisher of the application.
Public Property RequireSystemAccess | Specifies whether the application requires system-level access.
Public Property Version | The version of the application (set by author).

Remarks

A custom applicaton as seen in M-Files Admin.

See Also

CustomApplication Members


%%PageItemTitle%%

Clone Method
CustomApplication Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As CustomApplication

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

ApplicationType Property
CustomApplication Object : ApplicationType Property

Glossary Item Box

Description

The application type.

Property type

Read-only property

Syntax

Visual Basic
Public Property ApplicationType As MFCustomApplicationType

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

ChecksumHash Property
CustomApplication Object : ChecksumHash Property

Glossary Item Box

Description

The checksum of the application (hash value).

Property type

Read-only property

Syntax

Visual Basic
Public Property ChecksumHash As String

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

Description Property
CustomApplication Object : Description Property

Glossary Item Box

Description

The description of the application.

Property type

Read-only property

Syntax

Visual Basic
Public Property Description As String

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

Enabled Property
CustomApplication Object : Enabled Property

Glossary Item Box

Description

Specifies whether the application is enabled.

Property type

Read-only property

Syntax

Visual Basic
Public Property Enabled As Boolean

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

ID Property
CustomApplication Object : ID Property

Glossary Item Box

Description

The identifier for the application.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID As String

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

MasterApplication Property
CustomApplication Object : MasterApplication Property

Glossary Item Box

Description

The GUID for the master application (without curly braces). Empty string if there is no master application.

Property type

Read-only property

Syntax

Visual Basic
Public Property MasterApplication As String

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

MultiServerCompatible Property
CustomApplication Object : MultiServerCompatible Property

Glossary Item Box

Description

Specifies whether this application is compatible with a multi-server environment.

Property type

Read-only property

Syntax

Visual Basic
Public Property MultiServerCompatible As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

Name Property
CustomApplication Object : Name Property

Glossary Item Box

Description

The name of the application.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

Optional Property
CustomApplication Object : Optional Property

Glossary Item Box

Description

Specifies whether the application can be disabled.

Property type

Read-only property

Syntax

Visual Basic
Public Property Optional As Boolean

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

Publisher Property
CustomApplication Object : Publisher Property

Glossary Item Box

Description

The name of the publisher of the application.

Property type

Read-only property

Syntax

Visual Basic
Public Property Publisher As String

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

RequireSystemAccess Property
CustomApplication Object : RequireSystemAccess Property

Glossary Item Box

Description

Specifies whether the application requires system-level access.

Property type

Read-only property

Syntax

Visual Basic
Public Property RequireSystemAccess As Boolean

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

Version Property
CustomApplication Object : Version Property

Glossary Item Box

Description

The version of the application (set by author).

Property type

Read-only property

Syntax

Visual Basic
Public Property Version As String

See Also

CustomApplication Object | CustomApplication Members


%%PageItemTitle%%

CustomApplications Collection
Members See Also Send comments

Glossary Item Box

Description

CustomApplications is a collection of CustomApplication objects.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

CustomApplications Members


%%PageItemTitle%%

Clone Method
CustomApplications Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As CustomApplications

See Also

CustomApplications Collection | CustomApplications Members


%%PageItemTitle%%

Count Property
CustomApplications Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

CustomApplications Collection | CustomApplications Members


%%PageItemTitle%%

Item Property
Index
CustomApplications Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As CustomApplication

Parameters

Index

See Also

CustomApplications Collection | CustomApplications Members


%%PageItemTitle%%

DailyTrigger Object
Members See Also Send comments

Glossary Item Box

Description

The DailyTrigger class represents daily trigger.

Public Properties

Public Property DaysInterval Specifies the number of days between scheduled job runs.

See Also

DailyTrigger Members


%%PageItemTitle%%

DaysInterval Property
DailyTrigger Object : DaysInterval Property

Glossary Item Box

Description

Specifies the number of days between scheduled job runs.

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysInterval As Long

See Also

DailyTrigger Object | DailyTrigger Members


%%PageItemTitle%%

DataFunctionCall Object
Members See Also Example Send comments

Glossary Item Box

Description

An object for managing Expression object data functions.

Public Methods

Public Method SetDataDate | Sets the date data function.
Public Method SetDataDaysFrom | Sets the days from data function.
Public Method SetDataDaysTo | Sets the days to data function.
Public Method SetDataInitialCharGroup | Sets the integer segment data function.
Public Method SetDataIntegerSegment | Sets the integer segment data function.
Public Method SetDataLeftChars | Sets the integer segment data function.
Public Method SetDataMonth | Sets the month data function.
Public Method SetDataNoOp | Sets the no-op data function.
Public Method SetDataYear | Sets the year data function.
Public Method SetDataYearAndMonth | Sets the year and month data function.

Public Properties

Public Property DataFunction The data function of the call.

Remarks

With data function it is possible to modify how the results of expressions are evaluated. When used while making searches the result of the modified expression is directly compared with the typed value that is specified in SearchCondition Object. The interpretation of the typed value with each respective data function is described in MFDataFunction Enumeration.

Initialize the data function with one of Set methods provided.

The image below illustrates the different parts of a search condition that utilizes a data function. The search condition in the image is created in Example 1.

1. Search condition, SearchCondition Object

2. Data function, DataFunctionCall Object

3. Expression, Expression Object

4. Comparison operator, MFConditionType Enumeration

5. Typed value, TypedValue Object

Example

Example 1: Searching for objects modified in the year 2010 (Visual Basic) Copy Code
' In this example a new search condition is created that utilizes a data function
' to search for objects that have been modified in the year 2010.

' 1. Create the search condition object
Dim searchCondition As New MFilesAPI.SearchCondition

' 2. Create a new data function that that describes
' how the expression should be compared with the typed value.
' In this case we create a data function that indicates that
' the year of the last modified timestamps of the objects are compared
' to the typed value that specifies the year as an integer.
Dim dfYear As New MFilesAPI.DataFunctionCall
dfYear.SetDataYear()

' 3. Create the expression part for searching objects that have been
' been modified in the year 2010. The actual year is specified
' in the typed value part of the search condition.
Dim exprYear As New MFilesAPI.Expression
exprYear.SetPropertyValueExpression( _
        MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefLastModified, _
        MFilesAPI.MFParentChildBehavior.MFParentChildBehaviorNone, _
        dfYear)
searchCondition.Expression = exprYear  ' Set the expression to the search condition.

' 4. Define an operator for the search condition.
' With the condition '=' we indicate that we want to search
' for objects that have been modified at the specified year.
searchCondition.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeEqual

' 5. Create typed value that describes the year we want the objects
' to have been modified.
Dim tvYear2010 As New MFilesAPI.TypedValue
tvYear2010.SetValue(MFilesAPI.MFDataType.MFDatatypeInteger, 2010)
searchCondition.TypedValue = tvYear2010

See Also

DataFunctionCall Members | SearchCondition Object | Expression Object | TypedValues Object


%%PageItemTitle%%

SetDataDate Method
DataFunctionCall Object : SetDataDate Method

Glossary Item Box

Description

Sets the date data function.

Syntax

Visual Basic
Public Sub SetDataDate()

Remarks

Extracts the date from the expression.

See Also

DataFunctionCall Object | DataFunctionCall Members


%%PageItemTitle%%

SetDataDaysFrom Method
DataFunctionCall Object : SetDataDaysFrom Method

Glossary Item Box

Description

Sets the days from data function.

Syntax

Visual Basic
Public Sub SetDataDaysFrom()

Remarks

Calculates the day from the current date.

See Also

DataFunctionCall Object | DataFunctionCall Members


%%PageItemTitle%%

SetDataDaysTo Method
DataFunctionCall Object : SetDataDaysTo Method

Glossary Item Box

Description

Sets the days to data function.

Syntax

Visual Basic
Public Sub SetDataDaysTo()

Remarks

Calculates the number of days until the current date.

See Also

DataFunctionCall Object | DataFunctionCall Members


%%PageItemTitle%%

SetDataInitialCharGroup Method
Locale
DataFunctionCall Object : SetDataInitialCharGroup Method

Glossary Item Box

Description

Sets the integer segment data function.

Syntax

Visual Basic
Public Sub SetDataInitialCharGroup( _
   Optional ByVal Locale As ULong = 0 _
)

Parameters

Locale

Remarks

This data function can be used to define a virtual folder hierarchy by dividing objects by the initial character of the property value.

See Also

DataFunctionCall Object | DataFunctionCall Members


%%PageItemTitle%%

SetDataIntegerSegment Method
SegmentSize
DataFunctionCall Object : SetDataIntegerSegment Method

Glossary Item Box

Description

Sets the integer segment data function.

Syntax

Visual Basic
Public Sub SetDataIntegerSegment( _
   Optional ByVal SegmentSize As Long = 1000 _
)

Parameters

SegmentSize

See Also

DataFunctionCall Object | DataFunctionCall Members


%%PageItemTitle%%

SetDataLeftChars Method
Characters
DataFunctionCall Object : SetDataLeftChars Method

Glossary Item Box

Description

Sets the integer segment data function.

Syntax

Visual Basic
Public Sub SetDataLeftChars( _
   ByVal Characters As Long _
)

Parameters

Characters

Remarks

This data function can be used to define a virtual folder hierarchy by dividing objects by n first characters of the property value.

See Also

DataFunctionCall Object | DataFunctionCall Members


%%PageItemTitle%%

SetDataMonth Method
DataFunctionCall Object : SetDataMonth Method

Glossary Item Box

Description

Sets the month data function.

Syntax

Visual Basic
Public Sub SetDataMonth()

Remarks

Extracts the month from the expression.

See Also

DataFunctionCall Object | DataFunctionCall Members


%%PageItemTitle%%

SetDataNoOp Method
DataFunctionCall Object : SetDataNoOp Method

Glossary Item Box

Description

Sets the no-op data function.

Syntax

Visual Basic
Public Sub SetDataNoOp()

Remarks

A data function with no operation.

See Also

DataFunctionCall Object | DataFunctionCall Members


%%PageItemTitle%%

SetDataYear Method
DataFunctionCall Object : SetDataYear Method

Glossary Item Box

Description

Sets the year data function.

Syntax

Visual Basic
Public Sub SetDataYear()

Remarks

Extracts the year from the expression.

See Also

DataFunctionCall Object | DataFunctionCall Members


%%PageItemTitle%%

SetDataYearAndMonth Method
DataFunctionCall Object : SetDataYearAndMonth Method

Glossary Item Box

Description

Sets the year and month data function.

Syntax

Visual Basic
Public Sub SetDataYearAndMonth()

Remarks

Extracts the year and month from the expression.

See Also

DataFunctionCall Object | DataFunctionCall Members


%%PageItemTitle%%

DataFunction Property
DataFunctionCall Object : DataFunction Property

Glossary Item Box

Description

The data function of the call.

Property type

Read-only property

Syntax

Visual Basic
Public Property DataFunction As MFDataFunction

See Also

DataFunctionCall Object | DataFunctionCall Members


%%PageItemTitle%%

DataSet Object
Members See Also Send comments

Glossary Item Box

Description

The DataSet class represents a set of data that can be exported from a vault.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ID | The ID of the data set.
Public Property Name | The name of the data set.

Remarks

Data set properties in M-Files Admin.

See Also

DataSet Members


%%PageItemTitle%%

Clone Method
DataSet Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As DataSet

See Also

DataSet Object | DataSet Members


%%PageItemTitle%%

ID Property
DataSet Object : ID Property

Glossary Item Box

Description

The ID of the data set.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID As Long

See Also

DataSet Object | DataSet Members


%%PageItemTitle%%

Name Property
DataSet Object : Name Property

Glossary Item Box

Description

The name of the data set.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

DataSet Object | DataSet Members


%%PageItemTitle%%

DataSetExportingStatus Object
Members See Also Send comments

Glossary Item Box

Description

The DataSetExportingStatus class represents the current state of a data set export operation.

Public Properties

Public Property CurrentServerTime | The server's current time.
Public Property IsExporting | Specifies whether the data set is being exported or not.
Public Property LatestActivity | The time of the latest export operation status update.

See Also

DataSetExportingStatus Members


%%PageItemTitle%%

CurrentServerTime Property
DataSetExportingStatus Object : CurrentServerTime Property

Glossary Item Box

Description

The server's current time.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentServerTime As Timestamp

See Also

DataSetExportingStatus Object | DataSetExportingStatus Members


%%PageItemTitle%%

IsExporting Property
DataSetExportingStatus Object : IsExporting Property

Glossary Item Box

Description

Specifies whether the data set is being exported or not.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsExporting As Boolean

See Also

DataSetExportingStatus Object | DataSetExportingStatus Members


%%PageItemTitle%%

LatestActivity Property
DataSetExportingStatus Object : LatestActivity Property

Glossary Item Box

Description

The time of the latest export operation status update.

Property type

Read-only property

Syntax

Visual Basic
Public Property LatestActivity As Timestamp

See Also

DataSetExportingStatus Object | DataSetExportingStatus Members


%%PageItemTitle%%

DataSets Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of data sets.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

DataSets Members


%%PageItemTitle%%

Clone Method
DataSets Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As DataSets

See Also

DataSets Collection | DataSets Members


%%PageItemTitle%%

Count Property
DataSets Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

DataSets Collection | DataSets Members


%%PageItemTitle%%

Item Property
Index
DataSets Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As DataSet

Parameters

Index

See Also

DataSets Collection | DataSets Members


%%PageItemTitle%%

DefaultProperties Collection
Members See Also Send comments

Glossary Item Box

Description

DefaultProperties is a collection of DefaultProperty objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

DefaultProperties Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is be added. Any non-valid position implies appending.
DefaultProperty
The new member to add.
DefaultProperties Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal DefaultProperty As DefaultProperty _
)

Parameters

Index
Position at which a new collection member is be added. Any non-valid position implies appending.
DefaultProperty
The new member to add.

See Also

DefaultProperties Collection | DefaultProperties Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
DefaultProperties Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

DefaultProperties Collection | DefaultProperties Members


%%PageItemTitle%%

Count Property
DefaultProperties Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

DefaultProperties Collection | DefaultProperties Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
DefaultProperties Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As DefaultProperty

Parameters

Index
Specifies the item's position in the collection.

See Also

DefaultProperties Collection | DefaultProperties Members


%%PageItemTitle%%

DefaultProperty Object
Members See Also Send comments

Glossary Item Box

Description

The DefaultProperty class represents a default property specification.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetFixedValue | Sets the FixedValue data.
Public Method SetFromEmail | Sets the FromEmail data.
Public Method SetFromEmailHeader | Sets the FromEmailHeader data.
Public Method SetFromFile | Sets the FromFile data.
Public Method SetFromHPDSSXML | Sets the FromHPDSSXML data.
Public Method SetFromOCR | Sets the FromOCR data.
Public Method SetFromXML | Sets the FromXML data.
Public Method SetStateTransitionTime | Sets the StateTransitionTime data.

Public Properties

Public Property DataFixedValueValue | The Value field of the FixedValue specification.
Public Property DataFromEmailAddVLItemIfNotFound | Specifies whether a value list item should be added if it is not found.
Public Property DataFromEmailField | E-mail message field.
Public Property DataFromEmailHeaderAddVLItemIfNotFound | Specifies whether a value list item should be added if it is not found.
Public Property DataFromEmailHeaderField | Header field (e.g. X-Mailer).
Public Property DataFromEmailHeaderTreatLookupAsID | Specifies whether lookup values should be treated as item IDs instead of display names.
Public Property DataFromEmailTreatLookupAsID | Specifies whether lookup values should be treated as item IDs instead of display names.
Public Property DataFromFileAddVLItemIfNotFound | Specifies whether a value list item should be added if it is not found.
Public Property DataFromFileProperty | Windows file property.
Public Property DataFromFileTreatLookupAsID | Specifies whether lookup values should be treated as item IDs instead of display names.
Public Property DataFromHPDSSXMLAddVLItemIfNotFound | Specifies whether a value list item should be added if it is not found.
Public Property DataFromHPDSSXMLPromptName | The HPP DSS prompt name.
Public Property DataFromHPDSSXMLTreatLookupAsID | Specifies whether lookup values should be treated as item IDs instead of display names.
Public Property DataFromOCRAddVLItemIfNotFound | Specifies whether a value list item should be added if it is not found.
Public Property DataFromOCRTreatLookupAsID | Specifies whether lookup values should be treated as item IDs instead of display names.
Public Property DataFromOCRZone | OCR zone definition.
Public Property DataFromXMLAddVLItemIfNotFound | Specifies whether a value list item should be added if it is not found.
Public Property DataFromXMLTreatLookupAsID | Specifies whether lookup values should be treated as item IDs instead of display names.
Public Property DataFromXMLXPathExpression | XPath expression.
Public Property PropertyDefID | Property definition ID.
Public Property Type | Default property type.

Remarks

A default property for imported objects from an external source as seen in M-Files Admin.

See Also

DefaultProperty Members


%%PageItemTitle%%

Clone Method
DefaultProperty Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As DefaultProperty

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

SetFixedValue Method
TypedValue
The value to be assigned as a fixed value.
DefaultProperty Object : SetFixedValue Method

Glossary Item Box

Description

Sets the FixedValue data.

Syntax

Visual Basic
Public Sub SetFixedValue( _
   ByVal TypedValue As TypedValue _
)

Parameters

TypedValue
The value to be assigned as a fixed value.

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

SetFromEmail Method
EmailField
TreatLookupAsID
If this parameter is True, values should be treated as item IDs instead of display names. Valid only if the property represents a lookup value.
AddVLItemIfNotFound
If this parameter is True, a new value list item should be added if it is not found. Valid only if the property represents a lookup value.
DefaultProperty Object : SetFromEmail Method

Glossary Item Box

Description

Sets the FromEmail data.

Syntax

Visual Basic
Public Sub SetFromEmail( _
   ByVal EmailField As MFEmailField, _
   ByVal TreatLookupAsID As Boolean, _
   ByVal AddVLItemIfNotFound As Boolean _
)

Parameters

EmailField
Value | Description
MFEmailFieldBody | Message body.
MFEmailFieldCc | Cc.
MFEmailFieldDate | Message timestamp.
MFEmailFieldFrom | Sender.
MFEmailFieldImportance | Importance.
MFEmailFieldSensitivity | Sensitivity.
MFEmailFieldSubject | Message subject.
MFEmailFieldTo | Recipient.
MFEmailFieldUndefined | Unknown field (not initialized to any type).
TreatLookupAsID
If this parameter is True, values should be treated as item IDs instead of display names. Valid only if the property represents a lookup value.
AddVLItemIfNotFound
If this parameter is True, a new value list item should be added if it is not found. Valid only if the property represents a lookup value.

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

SetFromEmailHeader Method
Field
The header name.
TreatLookupAsID
If this parameter is True, values should be treated as item IDs instead of display names. Valid only if the property represents a lookup value.
AddVLItemIfNotFound
If this parameter is True, a new value list item should be added if it is not found. Valid only if the property represents a lookup value.
DefaultProperty Object : SetFromEmailHeader Method

Glossary Item Box

Description

Sets the FromEmailHeader data.

Syntax

Visual Basic
Public Sub SetFromEmailHeader( _
   ByVal Field As String, _
   ByVal TreatLookupAsID As Boolean, _
   ByVal AddVLItemIfNotFound As Boolean _
)

Parameters

Field
The header name.
TreatLookupAsID
If this parameter is True, values should be treated as item IDs instead of display names. Valid only if the property represents a lookup value.
AddVLItemIfNotFound
If this parameter is True, a new value list item should be added if it is not found. Valid only if the property represents a lookup value.

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

SetFromFile Method
FileProperty
The Windows file property to use.
TreatLookupAsID
True if lookup values should be treated as item IDs instead of display names.
AddVLItemIfNotFound
True if a value list item should be added in case it is not found.
DefaultProperty Object : SetFromFile Method

Glossary Item Box

Description

Sets the FromFile data.

Syntax

Visual Basic
Public Sub SetFromFile( _
   ByVal FileProperty As MFFileProperty, _
   ByVal TreatLookupAsID As Boolean, _
   ByVal AddVLItemIfNotFound As Boolean _
)

Parameters

FileProperty
Value | Description
MFFilePropertyArchive | Archive attribute.
MFFilePropertyCreatedAt | Created at time.
MFFilePropertyDirectory | Parent directory.
MFFilePropertyExtension | File extension.
MFFilePropertyHidden | Hidden attribute.
MFFilePropertyLastAccessed | Last accessed time.
MFFilePropertyLastModified | Last modified time.
MFFilePropertyName | File name.
MFFilePropertyReadOnly | Read-only attribute.
MFFilePropertySize | File size.
The Windows file property to use.
TreatLookupAsID
True if lookup values should be treated as item IDs instead of display names.
AddVLItemIfNotFound
True if a value list item should be added in case it is not found.

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

SetFromHPDSSXML Method
PromptName
The DSS prompt name.
TreatLookupAsID
If this parameter is True, values should be treated as item IDs instead of display names. Valid only if the property represents a lookup value.
AddVLItemIfNotFound
If this parameter is True, a new value list item should be added if it is not found. Valid only if the property represents a lookup value.
DefaultProperty Object : SetFromHPDSSXML Method

Glossary Item Box

Description

Sets the FromHPDSSXML data.

Syntax

Visual Basic
Public Sub SetFromHPDSSXML( _
   ByVal PromptName As String, _
   ByVal TreatLookupAsID As Boolean, _
   ByVal AddVLItemIfNotFound As Boolean _
)

Parameters

PromptName
The DSS prompt name.
TreatLookupAsID
If this parameter is True, values should be treated as item IDs instead of display names. Valid only if the property represents a lookup value.
AddVLItemIfNotFound
If this parameter is True, a new value list item should be added if it is not found. Valid only if the property represents a lookup value.

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

SetFromOCR Method
OCRZone
The OCR zone for extracting the value.
TreatLookupAsID
If this parameter is True, values should be treated as item IDs instead of display names. Valid only if the property represents a lookup value.
AddVLItemIfNotFound
If this parameter is True, a new value list item should be added if it is not found. Valid only if the property represents a lookup value.
DefaultProperty Object : SetFromOCR Method

Glossary Item Box

Description

Sets the FromOCR data.

Syntax

Visual Basic
Public Sub SetFromOCR( _
   ByVal OCRZone As OCRZone, _
   ByVal TreatLookupAsID As Boolean, _
   ByVal AddVLItemIfNotFound As Boolean _
)

Parameters

OCRZone
The OCR zone for extracting the value.
TreatLookupAsID
If this parameter is True, values should be treated as item IDs instead of display names. Valid only if the property represents a lookup value.
AddVLItemIfNotFound
If this parameter is True, a new value list item should be added if it is not found. Valid only if the property represents a lookup value.

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

SetFromXML Method
XPathExpression
The XPath expression for extracting the value.
TreatLookupAsID
If this parameter is True, values should be treated as item IDs instead of display names. Valid only if the property represents a lookup value.
AddVLItemIfNotFound
If this parameter is True, a new value list item should be added if it is not found. Valid only if the property represents a lookup value.
DefaultProperty Object : SetFromXML Method

Glossary Item Box

Description

Sets the FromXML data.

Syntax

Visual Basic
Public Sub SetFromXML( _
   ByVal XPathExpression As String, _
   ByVal TreatLookupAsID As Boolean, _
   ByVal AddVLItemIfNotFound As Boolean _
)

Parameters

XPathExpression
The XPath expression for extracting the value.
TreatLookupAsID
If this parameter is True, values should be treated as item IDs instead of display names. Valid only if the property represents a lookup value.
AddVLItemIfNotFound
If this parameter is True, a new value list item should be added if it is not found. Valid only if the property represents a lookup value.

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

SetStateTransitionTime Method
DefaultProperty Object : SetStateTransitionTime Method

Glossary Item Box

Description

Sets the StateTransitionTime data.

Syntax

Visual Basic
Public Sub SetStateTransitionTime()

Remarks

Supported in M-Files 22.8.11717.3 and later.

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFixedValueValue Property
DefaultProperty Object : DataFixedValueValue Property

Glossary Item Box

Description

The Value field of the FixedValue specification.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFixedValueValue As TypedValue

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromEmailAddVLItemIfNotFound Property
DefaultProperty Object : DataFromEmailAddVLItemIfNotFound Property

Glossary Item Box

Description

Specifies whether a value list item should be added if it is not found.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromEmailAddVLItemIfNotFound As Boolean

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromEmailField Property
DefaultProperty Object : DataFromEmailField Property

Glossary Item Box

Description

E-mail message field.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromEmailField As MFEmailField

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromEmailHeaderAddVLItemIfNotFound Property
DefaultProperty Object : DataFromEmailHeaderAddVLItemIfNotFound Property

Glossary Item Box

Description

Specifies whether a value list item should be added if it is not found.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromEmailHeaderAddVLItemIfNotFound As Boolean

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromEmailHeaderField Property
DefaultProperty Object : DataFromEmailHeaderField Property

Glossary Item Box

Description

Header field (e.g. X-Mailer).

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromEmailHeaderField As String

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromEmailHeaderTreatLookupAsID Property
DefaultProperty Object : DataFromEmailHeaderTreatLookupAsID Property

Glossary Item Box

Description

Specifies whether lookup values should be treated as item IDs instead of display names.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromEmailHeaderTreatLookupAsID As Boolean

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromEmailTreatLookupAsID Property
DefaultProperty Object : DataFromEmailTreatLookupAsID Property

Glossary Item Box

Description

Specifies whether lookup values should be treated as item IDs instead of display names.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromEmailTreatLookupAsID As Boolean

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromFileAddVLItemIfNotFound Property
DefaultProperty Object : DataFromFileAddVLItemIfNotFound Property

Glossary Item Box

Description

Specifies whether a value list item should be added if it is not found.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromFileAddVLItemIfNotFound As Boolean

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromFileProperty Property
DefaultProperty Object : DataFromFileProperty Property

Glossary Item Box

Description

Windows file property.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromFileProperty As MFFileProperty

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromFileTreatLookupAsID Property
DefaultProperty Object : DataFromFileTreatLookupAsID Property

Glossary Item Box

Description

Specifies whether lookup values should be treated as item IDs instead of display names.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromFileTreatLookupAsID As Boolean

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromHPDSSXMLAddVLItemIfNotFound Property
DefaultProperty Object : DataFromHPDSSXMLAddVLItemIfNotFound Property

Glossary Item Box

Description

Specifies whether a value list item should be added if it is not found.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromHPDSSXMLAddVLItemIfNotFound As Boolean

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromHPDSSXMLPromptName Property
DefaultProperty Object : DataFromHPDSSXMLPromptName Property

Glossary Item Box

Description

The HPP DSS prompt name.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromHPDSSXMLPromptName As String

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromHPDSSXMLTreatLookupAsID Property
DefaultProperty Object : DataFromHPDSSXMLTreatLookupAsID Property

Glossary Item Box

Description

Specifies whether lookup values should be treated as item IDs instead of display names.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromHPDSSXMLTreatLookupAsID As Boolean

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromOCRAddVLItemIfNotFound Property
DefaultProperty Object : DataFromOCRAddVLItemIfNotFound Property

Glossary Item Box

Description

Specifies whether a value list item should be added if it is not found.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromOCRAddVLItemIfNotFound As Boolean

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromOCRTreatLookupAsID Property
DefaultProperty Object : DataFromOCRTreatLookupAsID Property

Glossary Item Box

Description

Specifies whether lookup values should be treated as item IDs instead of display names.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromOCRTreatLookupAsID As Boolean

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromOCRZone Property
DefaultProperty Object : DataFromOCRZone Property

Glossary Item Box

Description

OCR zone definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromOCRZone As OCRZone

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromXMLAddVLItemIfNotFound Property
DefaultProperty Object : DataFromXMLAddVLItemIfNotFound Property

Glossary Item Box

Description

Specifies whether a value list item should be added if it is not found.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromXMLAddVLItemIfNotFound As Boolean

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromXMLTreatLookupAsID Property
DefaultProperty Object : DataFromXMLTreatLookupAsID Property

Glossary Item Box

Description

Specifies whether lookup values should be treated as item IDs instead of display names.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromXMLTreatLookupAsID As Boolean

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

DataFromXMLXPathExpression Property
DefaultProperty Object : DataFromXMLXPathExpression Property

Glossary Item Box

Description

XPath expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFromXMLXPathExpression As String

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

PropertyDefID Property
DefaultProperty Object : PropertyDefID Property

Glossary Item Box

Description

Property definition ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyDefID As Long

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

Type Property
DefaultProperty Object : Type Property

Glossary Item Box

Description

Default property type.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As MFDefaultPropertyType

See Also

DefaultProperty Object | DefaultProperty Members


%%PageItemTitle%%

EmailMessageInformation Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents information collected from an e-mail message.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.

Public Properties

Public Property Cc | The 'Cc' recipients field.
Public Property From | The 'From' field.
Public Property Importance | Email importance.
Public Property InReplyTo | The 'In-Reply-To' field.
Public Property MessageID | The message ID.
Public Property Received | The 'Received' timestamp field.
Public Property Sensitivity | Email sensitivity.
Public Property Sent | The 'Sent' timestamp field.
Public Property Subject | The subject field.
Public Property To | The 'To' recipients field.

Remarks

The "E-mail Client Integration Settings" in M-Files Admin.

See Also

EmailMessageInformation Members


%%PageItemTitle%%

Clone Method
EmailMessageInformation Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As EmailMessageInformation

See Also

EmailMessageInformation Object | EmailMessageInformation Members


%%PageItemTitle%%

CloneFrom Method
EmailMessageInformation
Message information to clone from.
EmailMessageInformation Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal EmailMessageInformation As EmailMessageInformation _
)

Parameters

EmailMessageInformation
Message information to clone from.

See Also

EmailMessageInformation Object | EmailMessageInformation Members


%%PageItemTitle%%

Cc Property
EmailMessageInformation Object : Cc Property

Glossary Item Box

Description

The 'Cc' recipients field.

Property type

Read-write property

Syntax

Visual Basic
Public Property Cc As Strings

See Also

EmailMessageInformation Object | EmailMessageInformation Members


%%PageItemTitle%%

From Property
EmailMessageInformation Object : From Property

Glossary Item Box

Description

The 'From' field.

Property type

Read-write property

Syntax

Visual Basic
Public Property From As String

See Also

EmailMessageInformation Object | EmailMessageInformation Members


%%PageItemTitle%%

Importance Property
EmailMessageInformation Object : Importance Property

Glossary Item Box

Description

Email importance.

Property type

Read-write property

Syntax

Visual Basic
Public Property Importance As MFEmailImportance

See Also

EmailMessageInformation Object | EmailMessageInformation Members


%%PageItemTitle%%

InReplyTo Property
EmailMessageInformation Object : InReplyTo Property

Glossary Item Box

Description

The 'In-Reply-To' field.

Property type

Read-write property

Syntax

Visual Basic
Public Property InReplyTo As String

See Also

EmailMessageInformation Object | EmailMessageInformation Members


%%PageItemTitle%%

MessageID Property
EmailMessageInformation Object : MessageID Property

Glossary Item Box

Description

The message ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property MessageID As String

See Also

EmailMessageInformation Object | EmailMessageInformation Members


%%PageItemTitle%%

Received Property
EmailMessageInformation Object : Received Property

Glossary Item Box

Description

The 'Received' timestamp field.

Property type

Read-write property

Syntax

Visual Basic
Public Property Received As Timestamp

See Also

EmailMessageInformation Object | EmailMessageInformation Members


%%PageItemTitle%%

Sensitivity Property
EmailMessageInformation Object : Sensitivity Property

Glossary Item Box

Description

Email sensitivity.

Property type

Read-write property

Syntax

Visual Basic
Public Property Sensitivity As MFEmailSensitivity

See Also

EmailMessageInformation Object | EmailMessageInformation Members


%%PageItemTitle%%

Sent Property
EmailMessageInformation Object : Sent Property

Glossary Item Box

Description

The 'Sent' timestamp field.

Property type

Read-write property

Syntax

Visual Basic
Public Property Sent As Timestamp

See Also

EmailMessageInformation Object | EmailMessageInformation Members


%%PageItemTitle%%

Subject Property
EmailMessageInformation Object : Subject Property

Glossary Item Box

Description

The subject field.

Property type

Read-write property

Syntax

Visual Basic
Public Property Subject As String

See Also

EmailMessageInformation Object | EmailMessageInformation Members


%%PageItemTitle%%

To Property
EmailMessageInformation Object : To Property

Glossary Item Box

Description

The 'To' recipients field.

Property type

Read-write property

Syntax

Visual Basic
Public Property To As Strings

See Also

EmailMessageInformation Object | EmailMessageInformation Members


%%PageItemTitle%%

EventHandler Object
Members See Also Send comments

Glossary Item Box

Description

The EventHandler class represents an event handler.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetID | Gets the ID of this event handler.

Public Properties

Public Property Active | True if the this event handler is active.
Public Property Description | A short description of this event handler.
Public Property EventType | Specifies the type of the event this handler is associated with.
Public Property GUID | The GUID as a string.
Public Property VBScript | VBScript code of the event handler.

See Also

EventHandler Members


%%PageItemTitle%%

Clone Method
EventHandler Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As EventHandler

See Also

EventHandler Object | EventHandler Members


%%PageItemTitle%%

GetID Method
EventHandler Object : GetID Method

Glossary Item Box

Description

Gets the ID of this event handler.

Syntax

Visual Basic
Public Function GetID() As Long

See Also

EventHandler Object | EventHandler Members


%%PageItemTitle%%

Active Property
EventHandler Object : Active Property

Glossary Item Box

Description

True if the this event handler is active.

Property type

Read-write property

Syntax

Visual Basic
Public Property Active As Boolean

See Also

EventHandler Object | EventHandler Members


%%PageItemTitle%%

Description Property
EventHandler Object : Description Property

Glossary Item Box

Description

A short description of this event handler.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description As String

See Also

EventHandler Object | EventHandler Members


%%PageItemTitle%%

EventType Property
EventHandler Object : EventType Property

Glossary Item Box

Description

Specifies the type of the event this handler is associated with.

Property type

Read-write property

Syntax

Visual Basic
Public Property EventType As MFEventHandlerType

See Also

EventHandler Object | EventHandler Members


%%PageItemTitle%%

GUID Property
EventHandler Object : GUID Property

Glossary Item Box

Description

The GUID as a string.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID As String

See Also

EventHandler Object | EventHandler Members


%%PageItemTitle%%

VBScript Property
EventHandler Object : VBScript Property

Glossary Item Box

Description

VBScript code of the event handler.

Property type

Read-write property

Syntax

Visual Basic
Public Property VBScript As String

See Also

EventHandler Object | EventHandler Members


%%PageItemTitle%%

EventHandlers Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of event handlers.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method GetIndexByGUID | Gets the index of the event handler with the specified GUID. Returns -1 if no match is found.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

EventHandlers Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
EventHandler
The new member to add.
EventHandlers Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal EventHandler As EventHandler _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
EventHandler
The new member to add.

See Also

EventHandlers Collection | EventHandlers Members


%%PageItemTitle%%

Clone Method
EventHandlers Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As EventHandlers

See Also

EventHandlers Collection | EventHandlers Members


%%PageItemTitle%%

GetIndexByGUID Method
EventHandlerGUID
The GUID of the event handler.
EventHandlers Collection : GetIndexByGUID Method

Glossary Item Box

Description

Gets the index of the event handler with the specified GUID. Returns -1 if no match is found.

Syntax

Visual Basic
Public Function GetIndexByGUID( _
   ByVal EventHandlerGUID As String _
) As Long

Parameters

EventHandlerGUID
The GUID of the event handler.

See Also

EventHandlers Collection | EventHandlers Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
EventHandlers Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

EventHandlers Collection | EventHandlers Members


%%PageItemTitle%%

Count Property
EventHandlers Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

EventHandlers Collection | EventHandlers Members


%%PageItemTitle%%

Item Property
Index
EventHandlers Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As EventHandler

Parameters

Index

See Also

EventHandlers Collection | EventHandlers Members


%%PageItemTitle%%

ExportContentJob Object
Members See Also Send comments

Glossary Item Box

Description

The ExportContentJob class represents a content export job.

Public Methods

Public Method Clone | Creates a clone of this object.
Public Method SetExportAllStructureItems | Configures the export job so that all the metadata structure items are exported.
Public Method SetReplicationViaCloud | Sets the information for replication via cloud storage.

Public Properties

Public Property CombinedConnectionString | The connection string combined from external storage location and target folder name.
Public Property ConfigurationID | The configuration ID of this export job.
Public Property ConnectionString | The external storage location access information.
Public Property ExportContent | Specifies whether to export the vault content.
Public Property ExportStructureItems | Specifies whether to export the metadata structure. The exported structure is defined with the StructureItems value.
Public Property ExternalFolderName | The target folder in the external cloud storage.
Public Property Flags | Specifies additional options as bit flags.
Public Property IgnoreChangesBefore | If not FILETIME_ZERO, any changes older than this timestamp are omitted from the content package.
Public Property Impersonation | Impersonation information to specify the access to the target files.
Public Property IncludePrivateUISettingsWithStructure | Specifies whether to include users' custom display settings when exporting the metadata structure.
Public Property IncludeValueListItemsWithStructure | Specifies whether to export the value list items with the value list structure item.
Public Property SearchConditions | The search conditions that specify the content to be exported.
Public Property StructureItems | Specifies the structure items that are exported.
Public Property TargetLocation | The full path to the target location on server.
Public Property UseIgnoreChangesBefore | Specifies whether to use the IgnoreChangesBefore value.
Public Property UseSearchConditions | Specifies whether to use the SearchConditions value.

Remarks

A content export job as seen in the user interface of M-Files Admin.

See Also

ExportContentJob Members


%%PageItemTitle%%

Clone Method
ExportContentJob Object : Clone Method

Glossary Item Box

Description

Creates a clone of this object.

Syntax

Visual Basic
Public Function Clone() As ExportContentJob

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

SetExportAllStructureItems Method
IncludeValueListItems
Set to true to include value list items with the structure.
ExportContentJob Object : SetExportAllStructureItems Method

Glossary Item Box

Description

Configures the export job so that all the metadata structure items are exported.

Syntax

Visual Basic
Public Sub SetExportAllStructureItems( _
   ByVal IncludeValueListItems As Boolean _
)

Parameters

IncludeValueListItems
Set to true to include value list items with the structure.

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

SetReplicationViaCloud Method
vbEnableReplicationViaCloud
If this is set to "true" replication via cloud storage is enabled.
bstrConnectionString
The access information of the external storage location.
bstrExternalFolderName
The target folder in the external cloud storage.
bstrEncryptionPassword
The password used for encrypting the replication packages.
ExportContentJob Object : SetReplicationViaCloud Method

Glossary Item Box

Description

Sets the information for replication via cloud storage.

Syntax

Visual Basic
Public Sub SetReplicationViaCloud( _
   ByVal vbEnableReplicationViaCloud As Boolean, _
   ByVal bstrConnectionString As String, _
   ByVal bstrExternalFolderName As String, _
   ByVal bstrEncryptionPassword As String _
)

Parameters

vbEnableReplicationViaCloud
If this is set to "true" replication via cloud storage is enabled.
bstrConnectionString
The access information of the external storage location.
bstrExternalFolderName
The target folder in the external cloud storage.
bstrEncryptionPassword
The password used for encrypting the replication packages.

Remarks

Requires the "MFExportContentFlagUseMultipleContentPackages" flag to be enabled via the Flags property.

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

CombinedConnectionString Property
ExportContentJob Object : CombinedConnectionString Property

Glossary Item Box

Description

The connection string combined from external storage location and target folder name.

Property type

Read-only property

Syntax

Visual Basic
Public Property CombinedConnectionString As String

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

ConfigurationID Property
ExportContentJob Object : ConfigurationID Property

Glossary Item Box

Description

The configuration ID of this export job.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConfigurationID As String

Remarks

Requires M-Files 18.11.7072.5 or later.

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

ConnectionString Property
ExportContentJob Object : ConnectionString Property

Glossary Item Box

Description

The external storage location access information.

Property type

Read-only property

Syntax

Visual Basic
Public Property ConnectionString As String

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

ExportContent Property
ExportContentJob Object : ExportContent Property

Glossary Item Box

Description

Specifies whether to export the vault content.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExportContent As Boolean

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

ExportStructureItems Property
ExportContentJob Object : ExportStructureItems Property

Glossary Item Box

Description

Specifies whether to export the metadata structure. The exported structure is defined with the StructureItems value.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExportStructureItems As Boolean

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

ExternalFolderName Property
ExportContentJob Object : ExternalFolderName Property

Glossary Item Box

Description

The target folder in the external cloud storage.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExternalFolderName As String

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

Flags Property
ExportContentJob Object : Flags Property

Glossary Item Box

Description

Specifies additional options as bit flags.

Property type

Read-write property

Syntax

Visual Basic
Public Property Flags As MFExportContentFlag

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

IgnoreChangesBefore Property
ExportContentJob Object : IgnoreChangesBefore Property

Glossary Item Box

Description

If not FILETIME_ZERO, any changes older than this timestamp are omitted from the content package.

Property type

Read-write property

Syntax

Visual Basic
Public Property IgnoreChangesBefore As Timestamp

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

Impersonation Property
ExportContentJob Object : Impersonation Property

Glossary Item Box

Description

Impersonation information to specify the access to the target files.

Property type

Read-write property

Syntax

Visual Basic
Public Property Impersonation As Impersonation

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

IncludePrivateUISettingsWithStructure Property
ExportContentJob Object : IncludePrivateUISettingsWithStructure Property

Glossary Item Box

Description

Specifies whether to include users' custom display settings when exporting the metadata structure.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludePrivateUISettingsWithStructure As Boolean

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

IncludeValueListItemsWithStructure Property
ExportContentJob Object : IncludeValueListItemsWithStructure Property

Glossary Item Box

Description

Specifies whether to export the value list items with the value list structure item.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncludeValueListItemsWithStructure As Boolean

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

SearchConditions Property
ExportContentJob Object : SearchConditions Property

Glossary Item Box

Description

The search conditions that specify the content to be exported.

Property type

Read-write property

Syntax

Visual Basic
Public Property SearchConditions As SearchConditions

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

StructureItems Property
ExportContentJob Object : StructureItems Property

Glossary Item Box

Description

Specifies the structure items that are exported.

Property type

Read-write property

Syntax

Visual Basic
Public Property StructureItems As ExportStructureItems

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

TargetLocation Property
ExportContentJob Object : TargetLocation Property

Glossary Item Box

Description

The full path to the target location on server.

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetLocation As String

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

UseIgnoreChangesBefore Property
ExportContentJob Object : UseIgnoreChangesBefore Property

Glossary Item Box

Description

Specifies whether to use the IgnoreChangesBefore value.

Property type

Read-write property

Syntax

Visual Basic
Public Property UseIgnoreChangesBefore As Boolean

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

UseSearchConditions Property
ExportContentJob Object : UseSearchConditions Property

Glossary Item Box

Description

Specifies whether to use the SearchConditions value.

Property type

Read-write property

Syntax

Visual Basic
Public Property UseSearchConditions As Boolean

See Also

ExportContentJob Object | ExportContentJob Members


%%PageItemTitle%%

ExportStructureItem Object
Members See Also Send comments

Glossary Item Box

Description

The ExportStructureItem class represents a metadata structure element that is exported from the vault.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property StructureItemGUID | The structure item GUID as a string.
Public Property StructureItemID | The internal ID of the exported structure item.
Public Property StructureItemType | The type of the exported structure item.

See Also

ExportStructureItem Members


%%PageItemTitle%%

Clone Method
ExportStructureItem Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ExportStructureItem

See Also

ExportStructureItem Object | ExportStructureItem Members


%%PageItemTitle%%

StructureItemGUID Property
ExportStructureItem Object : StructureItemGUID Property

Glossary Item Box

Description

The structure item GUID as a string.

Property type

Read-write property

Syntax

Visual Basic
Public Property StructureItemGUID As String

See Also

ExportStructureItem Object | ExportStructureItem Members


%%PageItemTitle%%

StructureItemID Property
ExportStructureItem Object : StructureItemID Property

Glossary Item Box

Description

The internal ID of the exported structure item.

Property type

Read-write property

Syntax

Visual Basic
Public Property StructureItemID As Long

See Also

ExportStructureItem Object | ExportStructureItem Members


%%PageItemTitle%%

StructureItemType Property
ExportStructureItem Object : StructureItemType Property

Glossary Item Box

Description

The type of the exported structure item.

Property type

Read-write property

Syntax

Visual Basic
Public Property StructureItemType As MFMetadataStructureItem

See Also

ExportStructureItem Object | ExportStructureItem Members


%%PageItemTitle%%

ExportStructureItems Collection
Members See Also Send comments

Glossary Item Box

Description

The ExportStructureItems class represents a collection of metadata structure elements that are exported from the vault.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove |

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ExportStructureItems Members


%%PageItemTitle%%

Add Method
Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

ExportStructureItem
The metadata structure item to be added.
ExportStructureItems Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ExportStructureItem As ExportStructureItem _
)

Parameters

Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

ExportStructureItem
The metadata structure item to be added.

See Also

ExportStructureItems Collection | ExportStructureItems Members


%%PageItemTitle%%

Clone Method
ExportStructureItems Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ExportStructureItems

See Also

ExportStructureItems Collection | ExportStructureItems Members


%%PageItemTitle%%

Remove Method
Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

ExportStructureItems Collection : Remove Method

Glossary Item Box

Description

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

See Also

ExportStructureItems Collection | ExportStructureItems Members


%%PageItemTitle%%

Count Property
ExportStructureItems Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ExportStructureItems Collection | ExportStructureItems Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

ExportStructureItems Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ExportStructureItem

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

ExportStructureItems Collection | ExportStructureItems Members


%%PageItemTitle%%

Expression Object
Members See Also Send comments

Glossary Item Box

Description

The Expression class represents an expression that can be evaluated.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetExpressionAsText | Gets the expression as text.
Public Method GetWholeExpressionAsIndirectionLevels | Gets the whole expression as indirection levels if possible.
Public Method SetAnyFieldExpression | Set the AnyField expression.
Public Method SetFileValueExpression | Sets the FileValue expression.
Public Method SetObjectIDSegmentExpression | Set the ObjectIDSegment expression.
Public Method SetPermissionExpression | Set the Permission expression.
Public Method SetPropertyValueExpression | Sets the PropertyValue expression.
Public Method SetStatusValueExpression | Sets the StatusValue expression.
Public Method SetTypedValueExpression

Sets the TypedValue expressions.

Only works with the data types MFDatatypeLookup and MFDatatypeMultiSelectLookup.
Public Method SetValueListItemExpression | Sets the expression for searching the value list items.

Public Properties

Public Property DataAnyFieldFTSFlags | The data associated with the AnyField expression.
Public Property DataFileValueType | The data associated with the FileValue expression.
Public Property DataObjectIDSegmentSegmentSize | The data associated with the ObjectIDSegment expression.
Public Property DataPermissionsType | The type of the Permissions expression.
Public Property DataPropertyValueDataFunction | The data function of the PropertyValue expression.
Public Property DataPropertyValueParentChildBehavior | The parent-child behavior of the PropertyValue expression.
Public Property DataPropertyValuePropertyDef | The property definition of the PropertyValue expression.
Public Property DataStatusValueDataFunction | The data function of the StatusValue expression.
Public Property DataStatusValueType | The type of the StatusValue expression.
Public Property DataTypedValueDataFunction | The data function of the TypedValue expression.
Public Property DataTypedValueDatatype | The data type of the TypedValue expression.
Public Property DataTypedValueParentChildBehavior | The parent-child behavior of the TypedValue expression.
Public Property DataTypedValueValueList | The value list part of the TypedValue expression.
Public Property IndirectionLevels | Indirection levels of this expression.
Public Property Type | The type of an expression.

Remarks

Expression objects are typically used with views and searches to define the operator for the search. A TypedValue in a SearchCondition object is used in conjunction with an expression object to define an operand for the expression. The condition operator is encapsulated in the parent SearchCondition object.

There are several types of expressions. See the MFExpressionType enumeration for the complete list. The expression is created by using one of the "Set" methods provided. The method sets the expression type and other required parameters.

A single property value expression and condition (highlighted with the green rectangle) as seen in M-Files Desktop.

See Also

Expression Members | SearchCondition Object


%%PageItemTitle%%

Clone Method
Expression Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As Expression

Return Type

Returns the copied expression.

See Also

Expression Object | Expression Members


%%PageItemTitle%%

GetExpressionAsText Method
PropertyDefinitions
ObjectTypes
Expression Object : GetExpressionAsText Method

Glossary Item Box

Description

Gets the expression as text.

Syntax

Visual Basic
Public Function GetExpressionAsText( _
   ByVal PropertyDefinitions As PropertyDefs, _
   ByVal ObjectTypes As ObjTypes _
) As String

Parameters

PropertyDefinitions
ObjectTypes

See Also

Expression Object | Expression Members


%%PageItemTitle%%

GetWholeExpressionAsIndirectionLevels Method
Expression Object : GetWholeExpressionAsIndirectionLevels Method

Glossary Item Box

Description

Gets the whole expression as indirection levels if possible.

Syntax

Visual Basic
Public Function GetWholeExpressionAsIndirectionLevels() As PropertyDefOrObjectTypes

See Also

Expression Object | Expression Members


%%PageItemTitle%%

SetAnyFieldExpression Method
FullTextSearchFlags
Expression Object : SetAnyFieldExpression Method

Glossary Item Box

Description

Set the AnyField expression.

Syntax

Visual Basic
Public Sub SetAnyFieldExpression( _
   ByVal FullTextSearchFlags As MFFullTextSearchFlags _
)

Parameters

FullTextSearchFlags
Value | Description
MFFullTextSearchFlagsLookInFileData | Looks for matches in the file data of objects.
MFFullTextSearchFlagsLookInMetaData | Looks for matches in the metadata (properties) of objects.
MFFullTextSearchFlagsNone | None (indicates a basic Boolean search).
MFFullTextSearchFlagsStemming | Enables stemming for all words in the search request. This includes inflected forms of the searched word.
MFFullTextSearchFlagsTypeAllWords | Finds all of the words in the search request.
MFFullTextSearchFlagsTypeAnyWords | Finds any of the words in the search request.

Remarks

Use this method to define an expression for a full text search. The expression contains flags for the full text search, and the SearchCondition object encapsulating the expression contains the searched text as a TypedValue object. The TypedValue needs to be MFDatatypeText.

When using a full-text search, the ConditionType in the parent SearchCondition object needs to be MFConditionTypeContains.

You can combine multiple search flags with a bitwise-OR operator.

See Also

Expression Object | Expression Members


%%PageItemTitle%%

SetFileValueExpression Method
FileValueType

A file value type identifies the evaluated file feature. Flags cannot be combined. Use only one single value at a time.

Expression Object : SetFileValueExpression Method

Glossary Item Box

Description

Sets the FileValue expression.

Syntax

Visual Basic
Public Sub SetFileValueExpression( _
   ByVal FileValueType As MFFileValueType _
)

Parameters

FileValueType
Value | Description
MFFileValueTypeChangeTime | The fileâ€™s change time.
MFFileValueTypeCreationTime | The fileâ€™s creation time.
MFFileValueTypeDuplicatesOnly | Specifies whether the object has one or more duplicates.
MFFileValueTypeFileID | File ID.
MFFileValueTypeFileName | File name (title + extension), can include DOS wildcards (such as *.txt).
MFFileValueTypeFileSize | File size in bytes.
MFFileValueTypeHasFiles | Specifies whether the object contains one or more files.
MFFileValueTypeLinkedToExtLoc | Specifies whether the file is linked to an external location (Yes/No).
MFFileValueTypeLinkedToExtLocID | The ID of the external location to which the file is linked. NULL if not linked.

A file value type identifies the evaluated file feature. Flags cannot be combined. Use only one single value at a time.

Remarks

A file value expression is used to define a condition based on the file features of the object.

The target value (the right-hand operand) is placed in the TypedValue object encapsulated in the parent SearchCondition object. The expected type of this value depends on the file value type.

Right-Hand Operand Types for File Value Types

File Value Type | Expected Typed Value Data Type | Remarks
MFFileValueTypeHasFiles | MFDatatypeBoolean |
MFFileValueTypeFileName | MFDatatypeText |
MFFileValueTypeFileSize | MFDatatypeInteger64 | File size in bytes.
MFFileValueTypeFileID | MFDatatypeInteger |
MFFileValueTypeCreationTime | MFDatatypeFILETIME | The data type is currently not supported by the API.
MFFileValueTypeChangeTime | MFDatatypeTimestamp |
MFFileValueTypeLinkedToExtLoc | MFDatatypeBoolean |
MFFileValueTypeLinkedToExtLocID | MFDatatypeLookup | Links to an external location with an external location ID.

File value conditions (highlighted with the green rectangle) as seen in M-Files Desktop. Note that most of the condition settings in the user interface actually consist of multiple search conditions, such as file size and date limits.

See Also

Expression Object | Expression Members


%%PageItemTitle%%

SetObjectIDSegmentExpression Method
Segment
The range of the ID segment.
Expression Object : SetObjectIDSegmentExpression Method

Glossary Item Box

Description

Set the ObjectIDSegment expression.

Syntax

Visual Basic
Public Sub SetObjectIDSegmentExpression( _
   ByVal Segment As Long _
)

Parameters

Segment
The range of the ID segment.

Remarks

This expression type can be used to limit the search results by object ID. The value stored in the parent SearchCondition object identifies the ID segment of the searched object. The value returned by this method identifies the segment range (i.e., if the segment range is 1,000 and the expression limits objects to segment 2, only object IDs 2,000-2,999 are returned).

The condition type of the SearchCondition object must be MFConditionTypeEqual, and the data type of the encapsulated TypedValue object must be MFDatatypeInteger.

See Also

Expression Object | Expression Members


%%PageItemTitle%%

SetPermissionExpression Method
PermissionsExpressionType
The permission expression type identifies the evaluated feature of a permission. Multiple permission expression type flags cannot be combined. Use only one single value at a time.
Expression Object : SetPermissionExpression Method

Glossary Item Box

Description

Set the Permission expression.

Syntax

Visual Basic
Public Sub SetPermissionExpression( _
   ByVal PermissionsExpressionType As MFPermissionsExpressionType _
)

Parameters

PermissionsExpressionType
Value | Description
MFACL | The access control list (ACL). Cannot be used as a search criterion.
MFDeletableBy | Deletable by the user/group.
MFEditableBy | Editable by the user/group.
MFFullControlBy | Full control by the user/group.
MFObjectsAttachableToThisItemBy | Objects attachable to this item by user/group.
MFPermissionsChangeableBy | Permissions may be changed by the user/group.
MFVisibleTo | Visible to the user/group.
The permission expression type identifies the evaluated feature of a permission. Multiple permission expression type flags cannot be combined. Use only one single value at a time.

Remarks

This expression type is used to filter objects based on their permissions.

The target value (the right-hand operand) is assigned to the TypedValue object encapsulated in the parent SearchCondition object. The expected type of the value depends on the permission expression type.

Right-Hand Operand Types for Permission Expression Types

Permission Expression Type | Expected Typed Value Data Type | Remarks
MFACL | MFDatatypeACL |
MFVisibleTo | MFDatatypeLookup | References a user or user group.
MFEditableBy | MFDatatypeLookup | References a user or user group.
MFPermissionsChangeableBy | MFDatatypeLookup | References a user or user group.
MFFullControlBy | MFDatatypeLookup | References a user or user group.

A lookup reference to a user or user group points to a corresponding built-in value list. See the UserAccount and UserGroup classes for resolving the user or group ID for the lookup reference.

A permission expression and condition as seen in M-Files Desktop.

See Also

Expression Object | Expression Members


%%PageItemTitle%%

SetPropertyValueExpression Method
PropertyDef
Identifies the searched property value.
PCBehavior
DataFunctionCall

Defines an optional data function for modifying the expression result. The data function availability depends on the evaluated data type.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Expression Object : SetPropertyValueExpression Method

Glossary Item Box

Description

Sets the PropertyValue expression.

Syntax

Visual Basic
Public Sub SetPropertyValueExpression( _
   ByVal PropertyDef As Long, _
   ByVal PCBehavior As MFParentChildBehavior, _
   Optional ByVal DataFunctionCall As DataFunctionCall = 0 _
)

Parameters

PropertyDef
Identifies the searched property value.
PCBehavior
Value | Description
MFParentChildBehaviorIncludeChildValues | Accepts matches to child values as well.
MFParentChildBehaviorIncludeParentValues | Accepts matches to parent values as well.
MFParentChildBehaviorNone | No special behavior.
DataFunctionCall

Defines an optional data function for modifying the expression result. The data function availability depends on the evaluated data type.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Remarks

The property value expression is used to evaluate the property value of an object. The evaluated property is identified by the property definition ID. The target value (the right-hand operand) is assigned to the TypedValue object encapsulated in the parent SearchCondition object. The type of the value should match the type of property definition.

See Also

Expression Object | Expression Members


%%PageItemTitle%%

SetStatusValueExpression Method
StatusType
The status type identifies the evaluated feature of an object's status. Status type flags cannot be combined. Use only one single value at a time.
DataFunctionCall

Defines an optional data function for modifying the expression result. The data function availability depends on the evaluated data type.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Expression Object : SetStatusValueExpression Method

Glossary Item Box

Description

Sets the StatusValue expression.

Syntax

Visual Basic
Public Sub SetStatusValueExpression( _
   ByVal StatusType As MFStatusType, _
   Optional ByVal DataFunctionCall As DataFunctionCall = 0 _
)

Parameters

StatusType
Value | Description
MFStatusTypeCheckedOut | The object's checked-out state.
MFStatusTypeCheckedOutAt | The date when the object was checked out.
MFStatusTypeCheckedOutTo | The user who has checked out the object.
MFStatusTypeDeleted | The deletion state of the object.
MFStatusTypeExtID | External ID.
MFStatusTypeIsLatestCheckedInVersion | The version must be the latest checked-in version.
MFStatusTypeLatestOrSpecific | The latest version / specific version indicator. For the latest version, the indicator yields 'Latest' and 'Specific'. For others, the indicator yields only 'Specific'.
MFStatusTypeObjectFlags | The object flags of the object. Does not include the deleted flag.
MFStatusTypeObjectID | The ID of the object.
MFStatusTypeObjectTypeAndID | The type and ID of the object.
MFStatusTypeObjectTypeID | The ID of the object type.
MFStatusTypeObjectVersionID | The ID of the object version.
MFStatusTypeOriginalObjectID | The ID of the object in the vault in which the object was originally created.
MFStatusTypeOriginalObjectIDSegment | The ID segment of the object in the vault in which the object was originally created. Segment size is always 1000.
MFStatusTypeOriginalObjectType | The type of the object in the vault in which the object was originally created.
MFStatusTypeOriginalVaultGUID | The GUID of the vault in which the object was originally created.
The status type identifies the evaluated feature of an object's status. Status type flags cannot be combined. Use only one single value at a time.
DataFunctionCall

Defines an optional data function for modifying the expression result. The data function availability depends on the evaluated data type.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Remarks

Status value expression is used to evaluate the status of the vault object. The evaluated status data is identified by status type parameter.

The target value (the right-hand operand) is placed to the TypedValue object encapsulated in the parent SearchCondition object. The type of this value depends on the status type.

Right-hand operand types for status types:

Permission expression type | Expected typed value data type | Remarks
MFStatusTypeCheckedOut | MFDatatypeBoolean |
MFStatusTypeCheckedOutTo | MFDatatypeLookup | Reference to built-in vault users value list. See UserAccount class for resolving the user id for the lookup reference.
MFStatusTypeCheckedOutAt | MFDatatypeTimestamp |
MFStatusTypeObjectID | MFDatatypeInteger |
MFStatusTypeObjectVersionID | MFDatatypeInteger |
MFStatusTypeDeleted | MFDatatypeBoolean |
MFStatusTypeObjectTypeID | MFDatatypeLookup | Object type id is passed as lookup target id. Version part is not used.
MFStatusTypeIsLatestCheckedInVersion | MFDatatypeBoolean |
MFStatusTypeExtID | MFDatatypeText |
MFStatusTypeLatestOrSpecific | MFDatatypeLookup or MFDatatypeMultiSelectLookup | Not used in searches.

Status-based conditions and expressions as seen in M-Files Desktop.

See Also

Expression Object | Expression Members


%%PageItemTitle%%

SetTypedValueExpression Method
DataType
Note that this method only works with the data types MFDatatypeLookup and MFDatatypeMultiSelectLookup.
ValueList
Identifies the target value list.
PCBehavior
DataFunctionCall

Defines an optional data function for modifying the expression result. The data function availability depends on the evaluated data type.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Expression Object : SetTypedValueExpression Method

Glossary Item Box

Description

Sets the TypedValue expressions.

Only works with the data types MFDatatypeLookup and MFDatatypeMultiSelectLookup.

Syntax

Visual Basic
Public Sub SetTypedValueExpression( _
   ByVal DataType As MFDataType, _
   ByVal ValueList As Long, _
   ByVal PCBehavior As MFParentChildBehavior, _
   Optional ByVal DataFunctionCall As DataFunctionCall = 0 _
)

Parameters

DataType
Value | Description
MFDatatypeACL | The access control list (ACL).
MFDatatypeBoolean | Boolean.
MFDatatypeDate | Date.
MFDatatypeFILETIME | FILETIME (a 64-bit integer). Not used in the properties.
MFDatatypeFloating | A double-precision floating point.
MFDatatypeInteger | A 32-bit integer.
MFDatatypeInteger64 | A 64-bit integer. Not used in the properties.
MFDatatypeLookup | Lookup (from a value list).
MFDatatypeMultiLineText | Multi-line text.
MFDatatypeMultiSelectLookup | Multiple selection from a value list.
MFDatatypeText | Text.
MFDatatypeTime | Time.
MFDatatypeTimestamp | Timestamp.
MFDatatypeUninitialized | Unknown type (not yet set to any type).
Note that this method only works with the data types MFDatatypeLookup and MFDatatypeMultiSelectLookup.
ValueList
Identifies the target value list.
PCBehavior
Value | Description
MFParentChildBehaviorIncludeChildValues | Accepts matches to child values as well.
MFParentChildBehaviorIncludeParentValues | Accepts matches to parent values as well.
MFParentChildBehaviorNone | No special behavior.
DataFunctionCall

Defines an optional data function for modifying the expression result. The data function availability depends on the evaluated data type.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Remarks

This expression type can be used to compare any property in an object with a right-hand value.

See Also

Expression Object | Expression Members


%%PageItemTitle%%

SetValueListItemExpression Method
PseudoPropertyDef
Identifies the evaluated feature of a value list item.
PCBehavior
DataFunctionCall

Defines an optional data function for modifying the expression result. The data function availability depends on the evaluated data type.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Expression Object : SetValueListItemExpression Method

Glossary Item Box

Description

Sets the expression for searching the value list items.

Syntax

Visual Basic
Public Sub SetValueListItemExpression( _
   ByVal PseudoPropertyDef As MFValueListItemPropertyDef, _
   ByVal PCBehavior As MFParentChildBehavior, _
   Optional ByVal DataFunctionCall As DataFunctionCall = 0 _
)

Parameters

PseudoPropertyDef
Value | Description
MFValueListItemPropertyDefDeleted | Deleted status of the value list item.
MFValueListItemPropertyDefExtID | External ID (display ID) of the value list item.
MFValueListItemPropertyDefID | Value list item ID.
MFValueListItemPropertyDefName | Value list item name.
MFValueListItemPropertyDefObjectType | Object type of the value list item.
MFValueListItemPropertyDefOwner | Owner of the value list item.
MFValueListItemPropertyDefParent | Parent of the value list item.
Identifies the evaluated feature of a value list item.
PCBehavior
Value | Description
MFParentChildBehaviorIncludeChildValues | Accepts matches to child values as well.
MFParentChildBehaviorIncludeParentValues | Accepts matches to parent values as well.
MFParentChildBehaviorNone | No special behavior.
DataFunctionCall

Defines an optional data function for modifying the expression result. The data function availability depends on the evaluated data type.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Remarks

The value list item expression is used for searching value list items. It is practical for resolving a single value list item for an item ID. See the SearchForValueListItemsEx method for more details.

The target value (the right-hand operand) is assigned to the TypedValue object encapsulated in the parent SearchCondition object. The expected type of this value depends on the selected pseudo-property value.

Right-Hand Operand Types for Evaluated Pseudo-Properties

Evaluated Pseudo-Property | Expected Typed Value Data Type | Remarks
MFValueListItemPropertyDefID | MFDatatypeLookup | ID as a lookup value.
MFValueListItemPropertyDefName | MFDatatypeText | Display name of the item.
MFValueListItemPropertyDefOwner | MFDatatypeLookup | ID of the owner item as a lookup value.
MFValueListItemPropertyDefParent | MFDatatypeInteger | ID of the parent item.
MFValueListItemPropertyDefDeleted | MFDatatypeBoolean | True or false.
MFValueListItemPropertyDefObjectType | MFDatatypeInteger | ID of the object type.
MFValueListItemPropertyDefExtID | MFDatatypeText | External ID as a text value.

See Also

Expression Object | Expression Members | SearchForValueListItemsEx Method


%%PageItemTitle%%

DataAnyFieldFTSFlags Property
Expression Object : DataAnyFieldFTSFlags Property

Glossary Item Box

Description

The data associated with the AnyField expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataAnyFieldFTSFlags As MFFullTextSearchFlags

See Also

Expression Object | Expression Members


%%PageItemTitle%%

DataFileValueType Property
Expression Object : DataFileValueType Property

Glossary Item Box

Description

The data associated with the FileValue expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataFileValueType As MFFileValueType

See Also

Expression Object | Expression Members


%%PageItemTitle%%

DataObjectIDSegmentSegmentSize Property
Expression Object : DataObjectIDSegmentSegmentSize Property

Glossary Item Box

Description

The data associated with the ObjectIDSegment expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataObjectIDSegmentSegmentSize As Long

See Also

Expression Object | Expression Members


%%PageItemTitle%%

DataPermissionsType Property
Expression Object : DataPermissionsType Property

Glossary Item Box

Description

The type of the Permissions expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataPermissionsType As MFPermissionsExpressionType

See Also

Expression Object | Expression Members


%%PageItemTitle%%

DataPropertyValueDataFunction Property
Expression Object : DataPropertyValueDataFunction Property

Glossary Item Box

Description

The data function of the PropertyValue expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataPropertyValueDataFunction As MFDataFunction

See Also

Expression Object | Expression Members


%%PageItemTitle%%

DataPropertyValueParentChildBehavior Property
Expression Object : DataPropertyValueParentChildBehavior Property

Glossary Item Box

Description

The parent-child behavior of the PropertyValue expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataPropertyValueParentChildBehavior As MFParentChildBehavior

See Also

Expression Object | Expression Members


%%PageItemTitle%%

DataPropertyValuePropertyDef Property
Expression Object : DataPropertyValuePropertyDef Property

Glossary Item Box

Description

The property definition of the PropertyValue expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataPropertyValuePropertyDef As Long

See Also

Expression Object | Expression Members


%%PageItemTitle%%

DataStatusValueDataFunction Property
Expression Object : DataStatusValueDataFunction Property

Glossary Item Box

Description

The data function of the StatusValue expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataStatusValueDataFunction As MFDataFunction

See Also

Expression Object | Expression Members


%%PageItemTitle%%

DataStatusValueType Property
Expression Object : DataStatusValueType Property

Glossary Item Box

Description

The type of the StatusValue expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataStatusValueType As MFStatusType

See Also

Expression Object | Expression Members


%%PageItemTitle%%

DataTypedValueDataFunction Property
Expression Object : DataTypedValueDataFunction Property

Glossary Item Box

Description

The data function of the TypedValue expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataTypedValueDataFunction As MFDataFunction

See Also

Expression Object | Expression Members


%%PageItemTitle%%

DataTypedValueDatatype Property
Expression Object : DataTypedValueDatatype Property

Glossary Item Box

Description

The data type of the TypedValue expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataTypedValueDatatype As MFDataType

See Also

Expression Object | Expression Members


%%PageItemTitle%%

DataTypedValueParentChildBehavior Property
Expression Object : DataTypedValueParentChildBehavior Property

Glossary Item Box

Description

The parent-child behavior of the TypedValue expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataTypedValueParentChildBehavior As MFParentChildBehavior

See Also

Expression Object | Expression Members


%%PageItemTitle%%

DataTypedValueValueList Property
Expression Object : DataTypedValueValueList Property

Glossary Item Box

Description

The value list part of the TypedValue expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataTypedValueValueList As Long

See Also

Expression Object | Expression Members


%%PageItemTitle%%

IndirectionLevels Property
Expression Object : IndirectionLevels Property

Glossary Item Box

Description

Indirection levels of this expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndirectionLevels As PropertyDefOrObjectTypes

See Also

Expression Object | Expression Members


%%PageItemTitle%%

Type Property
Expression Object : Type Property

Glossary Item Box

Description

The type of an expression.

Property type

Read-only property

Syntax

Visual Basic
Public Property Type As MFExpressionType

See Also

Expression Object | Expression Members


%%PageItemTitle%%

ExpressionEx Object
Members See Also Send comments

Glossary Item Box

Description

The ExpressionEx class represents an extended expression.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Conditions | The conditions that limit the values (property folders) of this expression.
Public Property Expression | The basic expression.
Public Property ExpressionExFlags | Bit flags that provide additional information on the expression in the context of a grouping level.
Public Property FolderListingAlgorithm | Folder listing algorithm. Used to optimize property folder listings on intermediate view levels.
Public Property NULLFolderName | The name of the folder representing NULL value. If NULL or an empty string, the default localized name is used.
Public Property ObjectTypeToGroupBy | The ID of the object type to group-by in this view level.
Public Property ReferFromViewLevel | True if the result objects are referred from this view level.
Public Property ShowContentsAsJITFolders | True if the contents of this view level should be created on-demand only.
Public Property ShowEmptyFolders | Specifies whether empty folders are shown.
Public Property ShowMatchingObjectsOnThisLevel | Specifies whether the matching objects are displayed on this level.
Public Property ShowNULLFolder | Specifies whether the NULL folder is shown.
Public Property ShowNULLFolderContentsOnThisLevel | Specifies whether the objects with NULL value are displayed on this level.

Remarks

An extended expression can be used to define the hierarchy levels of a view. One ExpressionEx object defines one level in a virtual folder hierarchy.

Defining the features of a view hierarchy level in M-Files Desktop.

See Also

ExpressionEx Members | View Object


%%PageItemTitle%%

Clone Method
ExpressionEx Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ExpressionEx

Return Type

Returns the copied object.

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

Conditions Property
ExpressionEx Object : Conditions Property

Glossary Item Box

Description

The conditions that limit the values (property folders) of this expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property Conditions As SearchConditions

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

Expression Property
ExpressionEx Object : Expression Property

Glossary Item Box

Description

The basic expression.

Property type

Read-write property

Syntax

Visual Basic
Public Property Expression As Expression

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

ExpressionExFlags Property
ExpressionEx Object : ExpressionExFlags Property

Glossary Item Box

Description

Bit flags that provide additional information on the expression in the context of a grouping level.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExpressionExFlags As MFExpressionExFlag

Remarks

Supported in M-Files 20.1.8669.3 and later.

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

FolderListingAlgorithm Property
ExpressionEx Object : FolderListingAlgorithm Property

Glossary Item Box

Description

Folder listing algorithm. Used to optimize property folder listings on intermediate view levels.

Property type

Read-write property

Syntax

Visual Basic
Public Property FolderListingAlgorithm As MFFolderListingAlgorithm

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

NULLFolderName Property
ExpressionEx Object : NULLFolderName Property

Glossary Item Box

Description

The name of the folder representing NULL value. If NULL or an empty string, the default localized name is used.

Property type

Read-write property

Syntax

Visual Basic
Public Property NULLFolderName As String

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

ObjectTypeToGroupBy Property
ExpressionEx Object : ObjectTypeToGroupBy Property

Glossary Item Box

Description

The ID of the object type to group-by in this view level.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectTypeToGroupBy As Long

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

ReferFromViewLevel Property
ExpressionEx Object : ReferFromViewLevel Property

Glossary Item Box

Description

True if the result objects are referred from this view level.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferFromViewLevel As Boolean

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

ShowContentsAsJITFolders Property
ExpressionEx Object : ShowContentsAsJITFolders Property

Glossary Item Box

Description

True if the contents of this view level should be created on-demand only.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowContentsAsJITFolders As Boolean

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

ShowEmptyFolders Property
ExpressionEx Object : ShowEmptyFolders Property

Glossary Item Box

Description

Specifies whether empty folders are shown.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowEmptyFolders As Boolean

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

ShowMatchingObjectsOnThisLevel Property
ExpressionEx Object : ShowMatchingObjectsOnThisLevel Property

Glossary Item Box

Description

Specifies whether the matching objects are displayed on this level.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowMatchingObjectsOnThisLevel As Boolean

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

ShowNULLFolder Property
ExpressionEx Object : ShowNULLFolder Property

Glossary Item Box

Description

Specifies whether the NULL folder is shown.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowNULLFolder As Boolean

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

ShowNULLFolderContentsOnThisLevel Property
ExpressionEx Object : ShowNULLFolderContentsOnThisLevel Property

Glossary Item Box

Description

Specifies whether the objects with NULL value are displayed on this level.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowNULLFolderContentsOnThisLevel As Boolean

See Also

ExpressionEx Object | ExpressionEx Members


%%PageItemTitle%%

ExpressionExs Collection
Members See Also Send comments

Glossary Item Box

Description

ExpressionExs is a collection of ExpressionEx objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ExpressionExs Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ExpressionEx
The new member to add.
ExpressionExs Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ExpressionEx As ExpressionEx _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
ExpressionEx
The new member to add.

See Also

ExpressionExs Collection | ExpressionExs Members


%%PageItemTitle%%

Clone Method
ExpressionExs Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ExpressionExs

See Also

ExpressionExs Collection | ExpressionExs Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ExpressionExs Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ExpressionExs Collection | ExpressionExs Members


%%PageItemTitle%%

Count Property
ExpressionExs Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ExpressionExs Collection | ExpressionExs Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
ExpressionExs Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ExpressionEx

Parameters

Index
Specifies the item's position in the collection.

See Also

ExpressionExs Collection | ExpressionExs Members


%%PageItemTitle%%

Expressions Collection
Members See Also Send comments

Glossary Item Box

Description

Expressions is a collection of Expression objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

Expressions Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
Expression
The new member to add.
Expressions Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal Expression As Expression _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
Expression
The new member to add.

See Also

Expressions Collection | Expressions Members


%%PageItemTitle%%

Clone Method
Expressions Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As Expressions

See Also

Expressions Collection | Expressions Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
Expressions Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

Expressions Collection | Expressions Members


%%PageItemTitle%%

Count Property
Expressions Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

Expressions Collection | Expressions Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
Expressions Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As Expression

Parameters

Index
Specifies the item's position in the collection.

See Also

Expressions Collection | Expressions Members


%%PageItemTitle%%

ExtensionAuthenticationResponse Object
Members See Also Send comments

Glossary Item Box

Description

The 'ExtensionAuthenticationResponse' class represents an extension authentication response.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AuthenticationData | The authentication data.
Public Property ConfigurationName | The authentication plugin configuration name.

See Also

ExtensionAuthenticationResponse Members


%%PageItemTitle%%

Clone Method
ExtensionAuthenticationResponse Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ExtensionAuthenticationResponse

See Also

ExtensionAuthenticationResponse Object | ExtensionAuthenticationResponse Members


%%PageItemTitle%%

AuthenticationData Property
ExtensionAuthenticationResponse Object : AuthenticationData Property

Glossary Item Box

Description

The authentication data.

Property type

Read-write property

Syntax

Visual Basic
Public Property AuthenticationData As NamedValues

See Also

ExtensionAuthenticationResponse Object | ExtensionAuthenticationResponse Members


%%PageItemTitle%%

ConfigurationName Property
ExtensionAuthenticationResponse Object : ConfigurationName Property

Glossary Item Box

Description

The authentication plugin configuration name.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConfigurationName As String

See Also

ExtensionAuthenticationResponse Object | ExtensionAuthenticationResponse Members


%%PageItemTitle%%

ExtensionAuthenticationStatus Object
Members See Also Send comments

Glossary Item Box

Description

The 'ExtensionAuthenticationStatus' class represents an extension authentication status.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AccountName | The account name in the target system.
Public Property AuthenticationDataMissing | If the value of this property is true, authentication data for the external repository is not available.
Public Property ExtensionAuthenticationSpecialUserType | The special user type.
Public Property TargetID | The target extension ID.
Public Property UserID | The user account ID.

See Also

ExtensionAuthenticationStatus Members


%%PageItemTitle%%

Clone Method
ExtensionAuthenticationStatus Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ExtensionAuthenticationStatus

See Also

ExtensionAuthenticationStatus Object | ExtensionAuthenticationStatus Members


%%PageItemTitle%%

AccountName Property
ExtensionAuthenticationStatus Object : AccountName Property

Glossary Item Box

Description

The account name in the target system.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccountName As String

See Also

ExtensionAuthenticationStatus Object | ExtensionAuthenticationStatus Members


%%PageItemTitle%%

AuthenticationDataMissing Property
ExtensionAuthenticationStatus Object : AuthenticationDataMissing Property

Glossary Item Box

Description

If the value of this property is true, authentication data for the external repository is not available.

Property type

Read-write property

Syntax

Visual Basic
Public Property AuthenticationDataMissing As Boolean

Remarks

Supported in M-Files 20.8.9339.3 and later.

See Also

ExtensionAuthenticationStatus Object | ExtensionAuthenticationStatus Members


%%PageItemTitle%%

ExtensionAuthenticationSpecialUserType Property
ExtensionAuthenticationStatus Object : ExtensionAuthenticationSpecialUserType Property

Glossary Item Box

Description

The special user type.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExtensionAuthenticationSpecialUserType As MFExtensionAuthenticationSpecialUserType

See Also

ExtensionAuthenticationStatus Object | ExtensionAuthenticationStatus Members


%%PageItemTitle%%

TargetID Property
ExtensionAuthenticationStatus Object : TargetID Property

Glossary Item Box

Description

The target extension ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetID As String

See Also

ExtensionAuthenticationStatus Object | ExtensionAuthenticationStatus Members


%%PageItemTitle%%

UserID Property
ExtensionAuthenticationStatus Object : UserID Property

Glossary Item Box

Description

The user account ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserID As Long

See Also

ExtensionAuthenticationStatus Object | ExtensionAuthenticationStatus Members


%%PageItemTitle%%

ExtensionAuthenticationStatuses Collection
Members See Also Send comments

Glossary Item Box

Description

The 'ExtensionAuthenticationStatuses' class represents extension authentication statuses.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ExtensionAuthenticationStatuses Members


%%PageItemTitle%%

Add Method
Index
The position of the collection member to add.
ExtensionAuthenticationStatus
The new member to add.
ExtensionAuthenticationStatuses Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ExtensionAuthenticationStatus As ExtensionAuthenticationStatus _
)

Parameters

Index
The position of the collection member to add.
ExtensionAuthenticationStatus
The new member to add.

See Also

ExtensionAuthenticationStatuses Collection | ExtensionAuthenticationStatuses Members


%%PageItemTitle%%

Clone Method
ExtensionAuthenticationStatuses Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ExtensionAuthenticationStatuses

See Also

ExtensionAuthenticationStatuses Collection | ExtensionAuthenticationStatuses Members


%%PageItemTitle%%

Remove Method
Index
The position of the collection member to remove.
ExtensionAuthenticationStatuses Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The position of the collection member to remove.

See Also

ExtensionAuthenticationStatuses Collection | ExtensionAuthenticationStatuses Members


%%PageItemTitle%%

Count Property
ExtensionAuthenticationStatuses Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ExtensionAuthenticationStatuses Collection | ExtensionAuthenticationStatuses Members


%%PageItemTitle%%

Item Property
Index
ExtensionAuthenticationStatuses Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ExtensionAuthenticationStatus

Parameters

Index

See Also

ExtensionAuthenticationStatuses Collection | ExtensionAuthenticationStatuses Members


%%PageItemTitle%%

ExtensionAuthenticationTarget Object
Members See Also Send comments

Glossary Item Box

Description

The 'ExtensionAuthenticationTarget' class represents an extension authentication target.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property DisplayName | The display name in the target system.
Public Property IconID | The icon ID in the target system.
Public Property ID | The target system identifier.
Public Property PluginInfos | Authentication plugin information about the available authentication types.
Public Property RequiresUserSpecificAuthentication | True if this target requires user-specific authentication.

See Also

ExtensionAuthenticationTarget Members


%%PageItemTitle%%

Clone Method
ExtensionAuthenticationTarget Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ExtensionAuthenticationTarget

See Also

ExtensionAuthenticationTarget Object | ExtensionAuthenticationTarget Members


%%PageItemTitle%%

DisplayName Property
ExtensionAuthenticationTarget Object : DisplayName Property

Glossary Item Box

Description

The display name in the target system.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayName As String

See Also

ExtensionAuthenticationTarget Object | ExtensionAuthenticationTarget Members


%%PageItemTitle%%

IconID Property
ExtensionAuthenticationTarget Object : IconID Property

Glossary Item Box

Description

The icon ID in the target system.

Property type

Read-write property

Syntax

Visual Basic
Public Property IconID As String

See Also

ExtensionAuthenticationTarget Object | ExtensionAuthenticationTarget Members


%%PageItemTitle%%

ID Property
ExtensionAuthenticationTarget Object : ID Property

Glossary Item Box

Description

The target system identifier.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As String

See Also

ExtensionAuthenticationTarget Object | ExtensionAuthenticationTarget Members


%%PageItemTitle%%

PluginInfos Property
ExtensionAuthenticationTarget Object : PluginInfos Property

Glossary Item Box

Description

Authentication plugin information about the available authentication types.

Property type

Read-write property

Syntax

Visual Basic
Public Property PluginInfos As PluginInfos

See Also

ExtensionAuthenticationTarget Object | ExtensionAuthenticationTarget Members


%%PageItemTitle%%

RequiresUserSpecificAuthentication Property
ExtensionAuthenticationTarget Object : RequiresUserSpecificAuthentication Property

Glossary Item Box

Description

True if this target requires user-specific authentication.

Property type

Read-write property

Syntax

Visual Basic
Public Property RequiresUserSpecificAuthentication As Boolean

See Also

ExtensionAuthenticationTarget Object | ExtensionAuthenticationTarget Members


%%PageItemTitle%%

ExtensionAuthenticationTargets Collection
Members See Also Send comments

Glossary Item Box

Description

The 'ExtensionAuthenticationTargets' class represents extension authentication targets.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ExtensionAuthenticationTargets Members


%%PageItemTitle%%

Add Method
Index
The position of the collection member to add.
ExtensionAuthenticationTarget
The new member to add.
ExtensionAuthenticationTargets Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ExtensionAuthenticationTarget As ExtensionAuthenticationTarget _
)

Parameters

Index
The position of the collection member to add.
ExtensionAuthenticationTarget
The new member to add.

See Also

ExtensionAuthenticationTargets Collection | ExtensionAuthenticationTargets Members


%%PageItemTitle%%

Clone Method
ExtensionAuthenticationTargets Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ExtensionAuthenticationTargets

See Also

ExtensionAuthenticationTargets Collection | ExtensionAuthenticationTargets Members


%%PageItemTitle%%

Remove Method
Index
The position of the collection member to remove.
ExtensionAuthenticationTargets Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The position of the collection member to remove.

See Also

ExtensionAuthenticationTargets Collection | ExtensionAuthenticationTargets Members


%%PageItemTitle%%

Count Property
ExtensionAuthenticationTargets Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ExtensionAuthenticationTargets Collection | ExtensionAuthenticationTargets Members


%%PageItemTitle%%

Item Property
Index
ExtensionAuthenticationTargets Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ExtensionAuthenticationTarget

Parameters

Index

See Also

ExtensionAuthenticationTargets Collection | ExtensionAuthenticationTargets Members


%%PageItemTitle%%

ExternalObjectTypePluginInfo Object
Members See Also Send comments

Glossary Item Box

Description

A data object for storing information about external object type plugin.

Public Methods

Public Method Clone Creates a copy of the "IExternalObjectTypePluginInfo" object.

Public Properties

Public Property ConfigurationDomainID | The configuration domain of the external object type plugin.
Public Property Description | The description of the external object type plugin.
Public Property InitialPageToOpen | The initial configuration page of the external object type plugin.
Public Property Name | The name of the external object type plugin.
Public Property ObjectTypes | The IDs of the object types that have a configuration for the external object type plugin.
Public Property Publisher | The publisher of the external object type plugin.
Public Property ServiceGUID | The service GUID of the external object type plugin.
Public Property Version | The version of the external object type plugin.

Remarks

Supported in M-Files 20.11.9630.6 and later.

See Also

ExternalObjectTypePluginInfo Members


%%PageItemTitle%%

Clone Method
ExternalObjectTypePluginInfo Object : Clone Method

Glossary Item Box

Description

Creates a copy of the "IExternalObjectTypePluginInfo" object.

Syntax

Visual Basic
Public Function Clone() As ExternalObjectTypePluginInfo

See Also

ExternalObjectTypePluginInfo Object | ExternalObjectTypePluginInfo Members


%%PageItemTitle%%

ConfigurationDomainID Property
ExternalObjectTypePluginInfo Object : ConfigurationDomainID Property

Glossary Item Box

Description

The configuration domain of the external object type plugin.

Property type

Read-only property

Syntax

Visual Basic
Public Property ConfigurationDomainID As String

See Also

ExternalObjectTypePluginInfo Object | ExternalObjectTypePluginInfo Members


%%PageItemTitle%%

Description Property
ExternalObjectTypePluginInfo Object : Description Property

Glossary Item Box

Description

The description of the external object type plugin.

Property type

Read-only property

Syntax

Visual Basic
Public Property Description As String

See Also

ExternalObjectTypePluginInfo Object | ExternalObjectTypePluginInfo Members


%%PageItemTitle%%

InitialPageToOpen Property
ExternalObjectTypePluginInfo Object : InitialPageToOpen Property

Glossary Item Box

Description

The initial configuration page of the external object type plugin.

Property type

Read-only property

Syntax

Visual Basic
Public Property InitialPageToOpen As String

See Also

ExternalObjectTypePluginInfo Object | ExternalObjectTypePluginInfo Members


%%PageItemTitle%%

Name Property
ExternalObjectTypePluginInfo Object : Name Property

Glossary Item Box

Description

The name of the external object type plugin.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

ExternalObjectTypePluginInfo Object | ExternalObjectTypePluginInfo Members


%%PageItemTitle%%

ObjectTypes Property
ExternalObjectTypePluginInfo Object : ObjectTypes Property

Glossary Item Box

Description

The IDs of the object types that have a configuration for the external object type plugin.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectTypes As IDs

See Also

ExternalObjectTypePluginInfo Object | ExternalObjectTypePluginInfo Members


%%PageItemTitle%%

Publisher Property
ExternalObjectTypePluginInfo Object : Publisher Property

Glossary Item Box

Description

The publisher of the external object type plugin.

Property type

Read-only property

Syntax

Visual Basic
Public Property Publisher As String

See Also

ExternalObjectTypePluginInfo Object | ExternalObjectTypePluginInfo Members


%%PageItemTitle%%

ServiceGUID Property
ExternalObjectTypePluginInfo Object : ServiceGUID Property

Glossary Item Box

Description

The service GUID of the external object type plugin.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServiceGUID As String

See Also

ExternalObjectTypePluginInfo Object | ExternalObjectTypePluginInfo Members


%%PageItemTitle%%

Version Property
ExternalObjectTypePluginInfo Object : Version Property

Glossary Item Box

Description

The version of the external object type plugin.

Property type

Read-only property

Syntax

Visual Basic
Public Property Version As String

See Also

ExternalObjectTypePluginInfo Object | ExternalObjectTypePluginInfo Members


%%PageItemTitle%%

ExternalObjectTypePluginInfos Collection
Members See Also Send comments

Glossary Item Box

Description

"ExternalObjectTypePluginInfos" is a collection of "ExternalObjectTypePluginInfo" objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

Remarks

Supported in M-Files 20.11.9630.6 and later.

See Also

ExternalObjectTypePluginInfos Members


%%PageItemTitle%%

Add Method
Index
The position of the collection member to add.
ExternalObjectTypePluginInfo
The new member to add.
ExternalObjectTypePluginInfos Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ExternalObjectTypePluginInfo As ExternalObjectTypePluginInfo _
)

Parameters

Index
The position of the collection member to add.
ExternalObjectTypePluginInfo
The new member to add.

See Also

ExternalObjectTypePluginInfos Collection | ExternalObjectTypePluginInfos Members


%%PageItemTitle%%

Clone Method
ExternalObjectTypePluginInfos Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ExternalObjectTypePluginInfos

See Also

ExternalObjectTypePluginInfos Collection | ExternalObjectTypePluginInfos Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ExternalObjectTypePluginInfos Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ExternalObjectTypePluginInfos Collection | ExternalObjectTypePluginInfos Members


%%PageItemTitle%%

Count Property
ExternalObjectTypePluginInfos Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ExternalObjectTypePluginInfos Collection | ExternalObjectTypePluginInfos Members


%%PageItemTitle%%

Item Property
Index
Specifies the position of the item in the collection.
ExternalObjectTypePluginInfos Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ExternalObjectTypePluginInfo

Parameters

Index
Specifies the position of the item in the collection.

See Also

ExternalObjectTypePluginInfos Collection | ExternalObjectTypePluginInfos Members


%%PageItemTitle%%

ExternalView Object
Members See Also Send comments

Glossary Item Box

Description

The 'ExternalView' class represents an external view.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method Set | Sets the specified information for the external view.

Public Properties

Public Property DisplayName | The name of the view.
Public Property ExternalRepositoryName | The name of the system.
Public Property IconID | The ID of the view icon.
Public Property ID | The ID of the view.
Public Property ObjectData | The object data related to the external view.

See Also

ExternalView Members


%%PageItemTitle%%

Clone Method
ExternalView Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ExternalView

See Also

ExternalView Object | ExternalView Members


%%PageItemTitle%%

Set Method
ExternalRepositoryName
The identifier of the external repository.
ID
The ID of the view.
Name
The name of the view.
IconID
The identifier of the view icon.
ExternalView Object : Set Method

Glossary Item Box

Description

Sets the specified information for the external view.

Syntax

Visual Basic
Public Sub Set( _
   ByVal ExternalRepositoryName As String, _
   ByVal ID As String, _
   ByVal Name As String, _
   ByVal IconID As String _
)

Parameters

ExternalRepositoryName
The identifier of the external repository.
ID
The ID of the view.
Name
The name of the view.
IconID
The identifier of the view icon.

See Also

ExternalView Object | ExternalView Members


%%PageItemTitle%%

DisplayName Property
ExternalView Object : DisplayName Property

Glossary Item Box

Description

The name of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayName As String

See Also

ExternalView Object | ExternalView Members


%%PageItemTitle%%

ExternalRepositoryName Property
ExternalView Object : ExternalRepositoryName Property

Glossary Item Box

Description

The name of the system.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryName As String

See Also

ExternalView Object | ExternalView Members


%%PageItemTitle%%

IconID Property
ExternalView Object : IconID Property

Glossary Item Box

Description

The ID of the view icon.

Property type

Read-write property

Syntax

Visual Basic
Public Property IconID As String

See Also

ExternalView Object | ExternalView Members


%%PageItemTitle%%

ID Property
ExternalView Object : ID Property

Glossary Item Box

Description

The ID of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As String

See Also

ExternalView Object | ExternalView Members


%%PageItemTitle%%

ObjectData Property
ExternalView Object : ObjectData Property

Glossary Item Box

Description

The object data related to the external view.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectData As ObjectVersion

See Also

ExternalView Object | ExternalView Members


%%PageItemTitle%%

ExternalViewID Object
Members See Also Send comments

Glossary Item Box

Description

The 'ExternalViewID' class represents an external view.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method Set | Sets the specified information for the external item ID.

Public Properties

Public Property ExternalRepositoryName | The name of the system.
Public Property ID | The ID of the item.

See Also

ExternalViewID Members


%%PageItemTitle%%

Clone Method
ExternalViewID Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ExternalViewID

See Also

ExternalViewID Object | ExternalViewID Members


%%PageItemTitle%%

Set Method
ExternalRepositoryName
The name of the external repository.
ID
The ID of the view.
ExternalViewID Object : Set Method

Glossary Item Box

Description

Sets the specified information for the external item ID.

Syntax

Visual Basic
Public Sub Set( _
   ByVal ExternalRepositoryName As String, _
   ByVal ID As String _
)

Parameters

ExternalRepositoryName
The name of the external repository.
ID
The ID of the view.

See Also

ExternalViewID Object | ExternalViewID Members


%%PageItemTitle%%

ExternalRepositoryName Property
ExternalViewID Object : ExternalRepositoryName Property

Glossary Item Box

Description

The name of the system.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryName As String

See Also

ExternalViewID Object | ExternalViewID Members


%%PageItemTitle%%

ID Property
ExternalViewID Object : ID Property

Glossary Item Box

Description

The ID of the item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As String

See Also

ExternalViewID Object | ExternalViewID Members


%%PageItemTitle%%

FileClass Object
Members See Also Send comments

Glossary Item Box

Description

The FileClass class represents a creatable file type in Windows.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method LoadByExtension | Loads and initializes the file class based on a file extension.
Public Method LoadByFileClass | Loads and initializes the file class based on a file class identifier name and the extension.
Public Method SetFileClassInfo | Initializes the file class with the given parameters.

Public Properties

Public Property DisplayName | Display name for the file class.
Public Property DotAndExtension | Extension for the file class. Prefixed with a dot.
Public Property Extension | Extension for the file class.
Public Property FileClass | File class identifier string.

Remarks

A FileClass object links together a file extension and an explanation of the file class. FileClass objects are typically used with user interface methods to define a selectable list of file formats (e.g., see the ShowNewObjectWindow method and the ObjectCreationInfo object).

See Also

FileClass Members | ObjectCreationInfo Object | VaultObjectOperations Object


%%PageItemTitle%%

Clone Method
FileClass Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FileClass

See Also

FileClass Object | FileClass Members


%%PageItemTitle%%

LoadByExtension Method
Extension
FileClass Object : LoadByExtension Method

Glossary Item Box

Description

Loads and initializes the file class based on a file extension.

Syntax

Visual Basic
Public Sub LoadByExtension( _
   ByVal Extension As String _
)

Parameters

Extension

Remarks

Initializes the file class.

See Also

FileClass Object | FileClass Members


%%PageItemTitle%%

LoadByFileClass Method
Extension
FileClass
FileClass Object : LoadByFileClass Method

Glossary Item Box

Description

Loads and initializes the file class based on a file class identifier name and the extension.

Syntax

Visual Basic
Public Sub LoadByFileClass( _
   ByVal Extension As String, _
   ByVal FileClass As String _
)

Parameters

Extension
FileClass

See Also

FileClass Object | FileClass Members


%%PageItemTitle%%

SetFileClassInfo Method
DotAndFileExtension
FileClass
FileClassDisplayName
FileClass Object : SetFileClassInfo Method

Glossary Item Box

Description

Initializes the file class with the given parameters.

Syntax

Visual Basic
Public Sub SetFileClassInfo( _
   ByVal DotAndFileExtension As String, _
   ByVal FileClass As String, _
   ByVal FileClassDisplayName As String _
)

Parameters

DotAndFileExtension
FileClass
FileClassDisplayName

See Also

FileClass Object | FileClass Members


%%PageItemTitle%%

DisplayName Property
FileClass Object : DisplayName Property

Glossary Item Box

Description

Display name for the file class.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayName As String

Remarks

The name as shown in the user interface.

See Also

FileClass Object | FileClass Members


%%PageItemTitle%%

DotAndExtension Property
FileClass Object : DotAndExtension Property

Glossary Item Box

Description

Extension for the file class. Prefixed with a dot.

Property type

Read-only property

Syntax

Visual Basic
Public Property DotAndExtension As String

Remarks

The file extension should include the dot (e.g., ".txt").

See Also

FileClass Object | FileClass Members


%%PageItemTitle%%

Extension Property
FileClass Object : Extension Property

Glossary Item Box

Description

Extension for the file class.

Property type

Read-only property

Syntax

Visual Basic
Public Property Extension As String

Remarks

The file extension without the dot (e.g., "txt").

See Also

FileClass Object | FileClass Members


%%PageItemTitle%%

FileClass Property
FileClass Object : FileClass Property

Glossary Item Box

Description

File class identifier string.

Property type

Read-only property

Syntax

Visual Basic
Public Property FileClass As String

Remarks

The file class identifier as seen in the Windows registry.

See Also

FileClass Object | FileClass Members


%%PageItemTitle%%

FileClasses Collection
Members See Also Send comments

Glossary Item Box

Description

FileClasses is a collection of FileClass objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

FileClasses Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
FileClass
The new member to add.
FileClasses Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal FileClass As FileClass _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
FileClass
The new member to add.

See Also

FileClasses Collection | FileClasses Members


%%PageItemTitle%%

Clone Method
FileClasses Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FileClasses

See Also

FileClasses Collection | FileClasses Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
FileClasses Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

FileClasses Collection | FileClasses Members


%%PageItemTitle%%

Count Property
FileClasses Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

FileClasses Collection | FileClasses Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
FileClasses Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As FileClass

Parameters

Index
Specifies the item's position in the collection.

See Also

FileClasses Collection | FileClasses Members


%%PageItemTitle%%

FileDownloadSession Object
Members See Also Send comments

Glossary Item Box

Description

The FileDownloadSession class represents a file download session.

Public Properties

Public Property DownloadID | The download session ID.
Public Property FileSize | The size of the file.
Public Property FileSize32 | The size of the file.
Public Property VersionData | The refreshed document version information.

Remarks

A session object for file downloads. The object can be acquired by using download methods in the VaultObjectFileOperations interface.

See Also

FileDownloadSession Members | VaultObjectFileOperations Object


%%PageItemTitle%%

DownloadID Property
FileDownloadSession Object : DownloadID Property

Glossary Item Box

Description

The download session ID.

Property type

Read-only property

Syntax

Visual Basic
Public Property DownloadID As Long

See Also

FileDownloadSession Object | FileDownloadSession Members


%%PageItemTitle%%

FileSize Property
FileDownloadSession Object : FileSize Property

Glossary Item Box

Description

The size of the file.

Property type

Read-only property

Syntax

Visual Basic
Public Property FileSize As Unknown

See Also

FileDownloadSession Object | FileDownloadSession Members


%%PageItemTitle%%

FileSize32 Property
FileDownloadSession Object : FileSize32 Property

Glossary Item Box

Description

The size of the file.

Property type

Read-only property

Syntax

Visual Basic
Public Property FileSize32 As Long

See Also

FileDownloadSession Object | FileDownloadSession Members


%%PageItemTitle%%

VersionData Property
FileDownloadSession Object : VersionData Property

Glossary Item Box

Description

The refreshed document version information.

Property type

Read-only property

Syntax

Visual Basic
Public Property VersionData As ObjectVersion

See Also

FileDownloadSession Object | FileDownloadSession Members


%%PageItemTitle%%

FileInformation Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents information extracted from a file.

Public Methods

Public Method Clear | Clears all information.
Public Method ExtractFromFile | Extracts information from the specified file. Requires .NET Framework 4.0 Client or later.

Public Properties

Public Property EmailMessage | Information about an email if 'FileType' is 'MFFileInformationTypeEmailMessage'. Otherwise NULL.
Public Property FileType | The type of the file.

See Also

FileInformation Members


%%PageItemTitle%%

Clear Method
FileInformation Object : Clear Method

Glossary Item Box

Description

Clears all information.

Syntax

Visual Basic
Public Sub Clear()

See Also

FileInformation Object | FileInformation Members


%%PageItemTitle%%

ExtractFromFile Method
PathToFile
Path to the file from which the information is to be extracted.
FileInformation Object : ExtractFromFile Method

Glossary Item Box

Description

Extracts information from the specified file. Requires .NET Framework 4.0 Client or later.

Syntax

Visual Basic
Public Sub ExtractFromFile( _
   ByVal PathToFile As String _
)

Parameters

PathToFile
Path to the file from which the information is to be extracted.

See Also

FileInformation Object | FileInformation Members


%%PageItemTitle%%

EmailMessage Property
FileInformation Object : EmailMessage Property

Glossary Item Box

Description

Information about an email if 'FileType' is 'MFFileInformationTypeEmailMessage'. Otherwise NULL.

Property type

Read-write property

Syntax

Visual Basic
Public Property EmailMessage As EmailMessageInformation

See Also

FileInformation Object | FileInformation Members


%%PageItemTitle%%

FileType Property
FileInformation Object : FileType Property

Glossary Item Box

Description

The type of the file.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileType As MFFileInformationType

See Also

FileInformation Object | FileInformation Members


%%PageItemTitle%%

FileSize Object
Members See Also Send comments

Glossary Item Box

Description

The FileSize class represents the size of an object file.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method EqualTo | Checks for equality to the specified object.

Public Properties

Public Property Precision | The precision part of the file size.
Public Property Size | The size part of the file size.

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

FileSize Members


%%PageItemTitle%%

Clone Method
FileSize Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FileSize

See Also

FileSize Object | FileSize Members


%%PageItemTitle%%

CloneFrom Method
pIFileSize
The file size of the object.
FileSize Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal pIFileSize As FileSize _
)

Parameters

pIFileSize
The file size of the object.

See Also

FileSize Object | FileSize Members


%%PageItemTitle%%

EqualTo Method
pIFileSize
The file size of the object.
FileSize Object : EqualTo Method

Glossary Item Box

Description

Checks for equality to the specified object.

Syntax

Visual Basic
Public Function EqualTo( _
   ByVal pIFileSize As FileSize _
) As Boolean

Parameters

pIFileSize
The file size of the object.

See Also

FileSize Object | FileSize Members


%%PageItemTitle%%

Precision Property
FileSize Object : Precision Property

Glossary Item Box

Description

The precision part of the file size.

Property type

Read-only property

Syntax

Visual Basic
Public Property Precision As MFFileSizePrecision

See Also

FileSize Object | FileSize Members


%%PageItemTitle%%

Size Property
FileSize Object : Size Property

Glossary Item Box

Description

The size part of the file size.

Property type

Read-only property

Syntax

Visual Basic
Public Property Size As Unknown

See Also

FileSize Object | FileSize Members


%%PageItemTitle%%

FileVer Object
Members See Also Send comments

Glossary Item Box

Description

The FileVer class represents a single file version.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method ConvertToLatestVersion | Sets this file version to represent the latest version of the file. The ID part remains intact.
Public Method EqualTo | Checks for equality to the specified object.
Public Method EqualToIgnoreVersion | Checks for equality to the specified object while ignoring the version part.
Public Method IsLatest | Specifies whether this file represents the latest version.
Public Method IsSpecific | Specifies whether this file version represents a specific version.
Public Method SetLatestExternalRepositoryFileVersion | Sets the file version to represent the latest version of the file in an external repository.
Public Method SetLatestVersion | Sets the file version to represent the latest version of the file.
Public Method SetSpecificExternalRepositoryFileVersion | Sets the file version to represent a specific version of the file in an external repository.
Public Method SetSpecificExternalRepositoryFileVersionString | Sets the file version to represent a specific version of the file in an external repository.
Public Method SetSpecificVersion | Sets the file version to represent a specific version of the file.

Public Properties

Public Property ExternalRepositoryFileID | The external repository identifier of the file.
Public Property ExternalRepositoryFileVersionID | The external repository version identifier of the file.
Public Property ExternalRepositoryFileVersionSortKey | The sort key for the external repository version.
Public Property ExternalRepositoryFileVersionSortKeyAsString | The sort key for the external repository version.
Public Property ID | The ID part of the file version.
Public Property Type | The file version type.
Public Property Version | The version part of the file version.

Remarks

The file version identifies a specific version of a file in a document vault. The file version object includes the ID and the version number of the file.

The file version does not depend on the version number of the host object.

See Also

FileVer Members


%%PageItemTitle%%

Clone Method
FileVer Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FileVer

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

CloneFrom Method
FileVer
The object that is used as the source for cloning.
FileVer Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal FileVer As FileVer _
)

Parameters

FileVer
The object that is used as the source for cloning.

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

ConvertToLatestVersion Method
FileVer Object : ConvertToLatestVersion Method

Glossary Item Box

Description

Sets this file version to represent the latest version of the file. The ID part remains intact.

Syntax

Visual Basic
Public Sub ConvertToLatestVersion()

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

EqualTo Method
FileVer
The file version to compare to.
FileVer Object : EqualTo Method

Glossary Item Box

Description

Checks for equality to the specified object.

Syntax

Visual Basic
Public Function EqualTo( _
   ByVal FileVer As FileVer _
) As Boolean

Parameters

FileVer
The file version to compare to.

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

EqualToIgnoreVersion Method
FileVer
The file version to compare to.
FileVer Object : EqualToIgnoreVersion Method

Glossary Item Box

Description

Checks for equality to the specified object while ignoring the version part.

Syntax

Visual Basic
Public Function EqualToIgnoreVersion( _
   ByVal FileVer As FileVer _
) As Boolean

Parameters

FileVer
The file version to compare to.

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

IsLatest Method
FileVer Object : IsLatest Method

Glossary Item Box

Description

Specifies whether this file represents the latest version.

Syntax

Visual Basic
Public Function IsLatest() As Boolean

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

IsSpecific Method
FileVer Object : IsSpecific Method

Glossary Item Box

Description

Specifies whether this file version represents a specific version.

Syntax

Visual Basic
Public Function IsSpecific() As Boolean

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

SetLatestExternalRepositoryFileVersion Method
ExternalRepositoryFileID
The external repository identifier.
FileVer Object : SetLatestExternalRepositoryFileVersion Method

Glossary Item Box

Description

Sets the file version to represent the latest version of the file in an external repository.

Syntax

Visual Basic
Public Sub SetLatestExternalRepositoryFileVersion( _
   ByVal ExternalRepositoryFileID As String _
)

Parameters

ExternalRepositoryFileID
The external repository identifier.

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

SetLatestVersion Method
ID
The ID part of a file version.
FileVer Object : SetLatestVersion Method

Glossary Item Box

Description

Sets the file version to represent the latest version of the file.

Syntax

Visual Basic
Public Sub SetLatestVersion( _
   ByVal ID As Long _
)

Parameters

ID
The ID part of a file version.

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

SetSpecificExternalRepositoryFileVersion Method
ExternalRepositoryFileID
The external repository identifier.
ExternalRepositoryFileVersionID
The external repository file version identifier.
ExternalRepositoryFileVersionSortKey
The sort key of the file version. It is used for comparing the file versions in order to sort them from oldest to newest.
FileVer Object : SetSpecificExternalRepositoryFileVersion Method

Glossary Item Box

Description

Sets the file version to represent a specific version of the file in an external repository.

Syntax

Visual Basic
Public Sub SetSpecificExternalRepositoryFileVersion( _
   ByVal ExternalRepositoryFileID As String, _
   ByVal ExternalRepositoryFileVersionID As String, _
   Optional ByVal ExternalRepositoryFileVersionSortKey As Unknown = 0 _
)

Parameters

ExternalRepositoryFileID
The external repository identifier.
ExternalRepositoryFileVersionID
The external repository file version identifier.
ExternalRepositoryFileVersionSortKey
The sort key of the file version. It is used for comparing the file versions in order to sort them from oldest to newest.

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

SetSpecificExternalRepositoryFileVersionString Method
ExternalRepositoryFileID
The external repository identifier.
ExternalRepositoryFileVersionID
The external repository file version identifier.
ExternalRepositoryFileVersionSortKey
The sort key of the file version. It is used for comparing the file versions in order to sort them from oldest to newest.
FileVer Object : SetSpecificExternalRepositoryFileVersionString Method

Glossary Item Box

Description

Sets the file version to represent a specific version of the file in an external repository.

Syntax

Visual Basic
Public Sub SetSpecificExternalRepositoryFileVersionString( _
   ByVal ExternalRepositoryFileID As String, _
   ByVal ExternalRepositoryFileVersionID As String, _
   Optional ByVal ExternalRepositoryFileVersionSortKey As String = 0 _
)

Parameters

ExternalRepositoryFileID
The external repository identifier.
ExternalRepositoryFileVersionID
The external repository file version identifier.
ExternalRepositoryFileVersionSortKey
The sort key of the file version. It is used for comparing the file versions in order to sort them from oldest to newest.

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

SetSpecificVersion Method
ID
The ID part of a file version.
Version
The version part of a file version.
FileVer Object : SetSpecificVersion Method

Glossary Item Box

Description

Sets the file version to represent a specific version of the file.

Syntax

Visual Basic
Public Sub SetSpecificVersion( _
   ByVal ID As Long, _
   ByVal Version As Long _
)

Parameters

ID
The ID part of a file version.
Version
The version part of a file version.

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

ExternalRepositoryFileID Property
FileVer Object : ExternalRepositoryFileID Property

Glossary Item Box

Description

The external repository identifier of the file.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryFileID As String

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

ExternalRepositoryFileVersionID Property
FileVer Object : ExternalRepositoryFileVersionID Property

Glossary Item Box

Description

The external repository version identifier of the file.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryFileVersionID As String

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

ExternalRepositoryFileVersionSortKey Property
FileVer Object : ExternalRepositoryFileVersionSortKey Property

Glossary Item Box

Description

The sort key for the external repository version.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryFileVersionSortKey As Unknown

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

ExternalRepositoryFileVersionSortKeyAsString Property
FileVer Object : ExternalRepositoryFileVersionSortKeyAsString Property

Glossary Item Box

Description

The sort key for the external repository version.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryFileVersionSortKeyAsString As String

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

ID Property
FileVer Object : ID Property

Glossary Item Box

Description

The ID part of the file version.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

Remarks

Use the VaultObjectFileOperations interface or the ObjectVersion object to access the files as ObjectFile objects.

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

Type Property
FileVer Object : Type Property

Glossary Item Box

Description

The file version type.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type As MFFileVerVersionType

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

Version Property
FileVer Object : Version Property

Glossary Item Box

Description

The version part of the file version.

Property type

Read-write property

Syntax

Visual Basic
Public Property Version As Long

See Also

FileVer Object | FileVer Members


%%PageItemTitle%%

FileVers Collection
Members See Also Send comments

Glossary Item Box

Description

The FileVers class represents the collection of FileVer objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

FileVers Members


%%PageItemTitle%%

Add Method
Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

FileVer
The file version.
FileVers Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal FileVer As FileVer _
)

Parameters

Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

FileVer
The file version.

See Also

FileVers Collection | FileVers Members


%%PageItemTitle%%

Clone Method
FileVers Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FileVers

See Also

FileVers Collection | FileVers Members


%%PageItemTitle%%

Remove Method
Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

FileVers Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

See Also

FileVers Collection | FileVers Members


%%PageItemTitle%%

Count Property
FileVers Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

FileVers Collection | FileVers Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

FileVers Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As FileVer

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

FileVers Collection | FileVers Members


%%PageItemTitle%%

FolderContentItem Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents a single folder content item.

Public Properties

Public Property ExternalView | The folder content item as an external view.
Public Property FolderContentItemType | The type of the folder content item.
Public Property ObjectVersion | The folder content item as a object version.
Public Property PropertyFolder | The folder content item as a typed value identifying a property folders.
Public Property TraditionalFolder | The folder content item as a lookup value identifying a traditional folder.
Public Property View | The folder content item as a view.

See Also

FolderContentItem Members


%%PageItemTitle%%

ExternalView Property
FolderContentItem Object : ExternalView Property

Glossary Item Box

Description

The folder content item as an external view.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExternalView As ExternalView

See Also

FolderContentItem Object | FolderContentItem Members


%%PageItemTitle%%

FolderContentItemType Property
FolderContentItem Object : FolderContentItemType Property

Glossary Item Box

Description

The type of the folder content item.

Property type

Read-only property

Syntax

Visual Basic
Public Property FolderContentItemType As MFFolderContentItemType

See Also

FolderContentItem Object | FolderContentItem Members


%%PageItemTitle%%

ObjectVersion Property
FolderContentItem Object : ObjectVersion Property

Glossary Item Box

Description

The folder content item as a object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectVersion As ObjectVersion

See Also

FolderContentItem Object | FolderContentItem Members


%%PageItemTitle%%

PropertyFolder Property
FolderContentItem Object : PropertyFolder Property

Glossary Item Box

Description

The folder content item as a typed value identifying a property folders.

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyFolder As TypedValue

See Also

FolderContentItem Object | FolderContentItem Members


%%PageItemTitle%%

TraditionalFolder Property
FolderContentItem Object : TraditionalFolder Property

Glossary Item Box

Description

The folder content item as a lookup value identifying a traditional folder.

Property type

Read-only property

Syntax

Visual Basic
Public Property TraditionalFolder As Lookup

See Also

FolderContentItem Object | FolderContentItem Members


%%PageItemTitle%%

View Property
FolderContentItem Object : View Property

Glossary Item Box

Description

The folder content item as a view.

Property type

Read-only property

Syntax

Visual Basic
Public Property View As View

See Also

FolderContentItem Object | FolderContentItem Members


%%PageItemTitle%%

FolderContentItems Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of folder content items.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.
Public Property MoreResults | Specifies whether the number of items was truncated.

See Also

FolderContentItems Members


%%PageItemTitle%%

Count Property
FolderContentItems Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

FolderContentItems Collection | FolderContentItems Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

FolderContentItems Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As FolderContentItem

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

FolderContentItems Collection | FolderContentItems Members


%%PageItemTitle%%

MoreResults Property
FolderContentItems Collection : MoreResults Property

Glossary Item Box

Description

Specifies whether the number of items was truncated.

Property type

Read-only property

Syntax

Visual Basic
Public Property MoreResults As Boolean

See Also

FolderContentItems Collection | FolderContentItems Members


%%PageItemTitle%%

FolderData Object
Members See Also Send comments

Glossary Item Box

Description

The FolderData class represents a folder data.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ExternalView | The definition of an external view.
Public Property FolderLocation | An array of folders describing the exact location of the folder that the view refers to.
Public Property FolderType | The type of the folder data.
Public Property View | The definition of an internal view.

See Also

FolderData Members


%%PageItemTitle%%

Clone Method
FolderData Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FolderData

See Also

FolderData Object | FolderData Members


%%PageItemTitle%%

ExternalView Property
FolderData Object : ExternalView Property

Glossary Item Box

Description

The definition of an external view.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalView As ExternalView

See Also

FolderData Object | FolderData Members


%%PageItemTitle%%

FolderLocation Property
FolderData Object : FolderLocation Property

Glossary Item Box

Description

An array of folders describing the exact location of the folder that the view refers to.

Property type

Read-write property

Syntax

Visual Basic
Public Property FolderLocation As FolderDefs

See Also

FolderData Object | FolderData Members


%%PageItemTitle%%

FolderType Property
FolderData Object : FolderType Property

Glossary Item Box

Description

The type of the folder data.

Property type

Read-write property

Syntax

Visual Basic
Public Property FolderType As MFFolderDefType

See Also

FolderData Object | FolderData Members


%%PageItemTitle%%

View Property
FolderData Object : View Property

Glossary Item Box

Description

The definition of an internal view.

Property type

Read-write property

Syntax

Visual Basic
Public Property View As View

See Also

FolderData Object | FolderData Members


%%PageItemTitle%%

FolderDef Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents a folder definition.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetPropertyFolder | Sets this folder definition to define a property folder.
Public Method SetSearchDef | Sets this folder definition to define a search folder.
Public Method SetTraditionalFolder | Sets this folder definition to define a traditional folder.
Public Method SetView | Sets this folder definition to define a view folder.

Public Properties

Public Property ExternalFolder | The external folder represented by this folder definition.
Public Property FolderDefType | The type of the folder definition.
Public Property PropertyFolder | The typed value of the property folder referred by this property folder definition.
Public Property SearchDef | The search definition id for this search folder definition.
Public Property TraditionalFolder | The id of the traditional folder referred by this traditional folder definition.
Public Property View | The view id referred by this view folder definition.

See Also

FolderDef Members


%%PageItemTitle%%

Clone Method
FolderDef Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FolderDef

See Also

FolderDef Object | FolderDef Members


%%PageItemTitle%%

SetPropertyFolder Method
TypedValue
The typed value representing a property folder.
FolderDef Object : SetPropertyFolder Method

Glossary Item Box

Description

Sets this folder definition to define a property folder.

Syntax

Visual Basic
Public Sub SetPropertyFolder( _
   ByVal TypedValue As TypedValue _
)

Parameters

TypedValue
The typed value representing a property folder.

See Also

FolderDef Object | FolderDef Members


%%PageItemTitle%%

SetSearchDef Method
SearchDef
The search definition of a search folder.
FolderDef Object : SetSearchDef Method

Glossary Item Box

Description

Sets this folder definition to define a search folder.

Syntax

Visual Basic
Public Sub SetSearchDef( _
   ByVal SearchDef As SearchDef _
)

Parameters

SearchDef
The search definition of a search folder.

See Also

FolderDef Object | FolderDef Members


%%PageItemTitle%%

SetTraditionalFolder Method
TraditionalFolder
The traditional folder ID.
FolderDef Object : SetTraditionalFolder Method

Glossary Item Box

Description

Sets this folder definition to define a traditional folder.

Syntax

Visual Basic
Public Sub SetTraditionalFolder( _
   ByVal TraditionalFolder As Long _
)

Parameters

TraditionalFolder
The traditional folder ID.

See Also

FolderDef Object | FolderDef Members


%%PageItemTitle%%

SetView Method
View
The view ID.
FolderDef Object : SetView Method

Glossary Item Box

Description

Sets this folder definition to define a view folder.

Syntax

Visual Basic
Public Sub SetView( _
   ByVal View As Long _
)

Parameters

View
The view ID.

See Also

FolderDef Object | FolderDef Members


%%PageItemTitle%%

ExternalFolder Property
FolderDef Object : ExternalFolder Property

Glossary Item Box

Description

The external folder represented by this folder definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalFolder As ExternalViewID

See Also

FolderDef Object | FolderDef Members


%%PageItemTitle%%

FolderDefType Property
FolderDef Object : FolderDefType Property

Glossary Item Box

Description

The type of the folder definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property FolderDefType As MFFolderDefType

See Also

FolderDef Object | FolderDef Members


%%PageItemTitle%%

PropertyFolder Property
FolderDef Object : PropertyFolder Property

Glossary Item Box

Description

The typed value of the property folder referred by this property folder definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyFolder As TypedValue

See Also

FolderDef Object | FolderDef Members


%%PageItemTitle%%

SearchDef Property
FolderDef Object : SearchDef Property

Glossary Item Box

Description

The search definition id for this search folder definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property SearchDef As SearchDef

See Also

FolderDef Object | FolderDef Members


%%PageItemTitle%%

TraditionalFolder Property
FolderDef Object : TraditionalFolder Property

Glossary Item Box

Description

The id of the traditional folder referred by this traditional folder definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property TraditionalFolder As Long

See Also

FolderDef Object | FolderDef Members


%%PageItemTitle%%

View Property
FolderDef Object : View Property

Glossary Item Box

Description

The view id referred by this view folder definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property View As Long

See Also

FolderDef Object | FolderDef Members


%%PageItemTitle%%

FolderDefs Collection
Members See Also Send comments

Glossary Item Box

Description

Collection of folder definitions.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

FolderDefs Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
FolderDef
The new member to add.
FolderDefs Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal FolderDef As FolderDef _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
FolderDef
The new member to add.

See Also

FolderDefs Collection | FolderDefs Members


%%PageItemTitle%%

Clone Method
FolderDefs Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FolderDefs

See Also

FolderDefs Collection | FolderDefs Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
FolderDefs Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

FolderDefs Collection | FolderDefs Members


%%PageItemTitle%%

Count Property
FolderDefs Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

FolderDefs Collection | FolderDefs Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
FolderDefs Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As FolderDef

Parameters

Index
Specifies the item's position in the collection.

See Also

FolderDefs Collection | FolderDefs Members


%%PageItemTitle%%

FolderID Object
Members See Also Send comments

Glossary Item Box

Description

The FolderID class represents a folder ID.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content from another object to this one.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property ExternalViewID | The ID of the external view.
Public Property FolderType | The type of the folder ID.
Public Property ViewID | The ID of the view.

See Also

FolderID Members


%%PageItemTitle%%

Clone Method
FolderID Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FolderID

See Also

FolderID Object | FolderID Members


%%PageItemTitle%%

CloneFrom Method
FolderID
The clone source.
FolderID Object : CloneFrom Method

Glossary Item Box

Description

Copies the content from another object to this one.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal FolderID As FolderID _
)

Parameters

FolderID
The clone source.

See Also

FolderID Object | FolderID Members


%%PageItemTitle%%

ToJSON Method
FolderID Object : ToJSON Method

Glossary Item Box

Description

Converts the data structure to a JSON string.

Syntax

Visual Basic
Public Function ToJSON() As String

See Also

FolderID Object | FolderID Members


%%PageItemTitle%%

ExternalViewID Property
FolderID Object : ExternalViewID Property

Glossary Item Box

Description

The ID of the external view.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalViewID As ExternalViewID

See Also

FolderID Object | FolderID Members


%%PageItemTitle%%

FolderType Property
FolderID Object : FolderType Property

Glossary Item Box

Description

The type of the folder ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property FolderType As MFFolderDefType

See Also

FolderID Object | FolderID Members


%%PageItemTitle%%

ViewID Property
FolderID Object : ViewID Property

Glossary Item Box

Description

The ID of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewID As Long

See Also

FolderID Object | FolderID Members


%%PageItemTitle%%

FolderListingColumn Object
Members See Also Send comments

Glossary Item Box

Description

The 'FolderListingColumn' class represents a single column setting of a folder listing.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Flags | Column flags.
Public Property ID | The column ID; the property definition ID or a pseudo-ID.
Public Property Name | The column display name.
Public Property Position | Specifies the position for a visible column.
Public Property Visible | Specifies whether the column is visible.
Public Property Width | Specifies the column width.

See Also

FolderListingColumn Members


%%PageItemTitle%%

Clone Method
FolderListingColumn Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FolderListingColumn

See Also

FolderListingColumn Object | FolderListingColumn Members


%%PageItemTitle%%

Flags Property
FolderListingColumn Object : Flags Property

Glossary Item Box

Description

Column flags.

Property type

Read-write property

Syntax

Visual Basic
Public Property Flags As MFFolderListingColumnFlags

See Also

FolderListingColumn Object | FolderListingColumn Members


%%PageItemTitle%%

ID Property
FolderListingColumn Object : ID Property

Glossary Item Box

Description

The column ID; the property definition ID or a pseudo-ID.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID As Long

Remarks

The column ID is either a property definition ID (positive values) or a value in the MFFolderColumnId Enumeration (negative values).

See Also

FolderListingColumn Object | FolderListingColumn Members


%%PageItemTitle%%

Name Property
FolderListingColumn Object : Name Property

Glossary Item Box

Description

The column display name.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

FolderListingColumn Object | FolderListingColumn Members


%%PageItemTitle%%

Position Property
FolderListingColumn Object : Position Property

Glossary Item Box

Description

Specifies the position for a visible column.

Property type

Read-write property

Syntax

Visual Basic
Public Property Position As Long

Remarks

Each column in the FolderListingColumns Collection should have a unique and linear position number for visible columns. The position for the leftmost column is 0.

For invisible columns, the position number is -1.

See Also

FolderListingColumn Object | FolderListingColumn Members


%%PageItemTitle%%

Visible Property
FolderListingColumn Object : Visible Property

Glossary Item Box

Description

Specifies whether the column is visible.

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible As Boolean

See Also

FolderListingColumn Object | FolderListingColumn Members


%%PageItemTitle%%

Width Property
FolderListingColumn Object : Width Property

Glossary Item Box

Description

Specifies the column width.

Property type

Read-write property

Syntax

Visual Basic
Public Property Width As Long

See Also

FolderListingColumn Object | FolderListingColumn Members


%%PageItemTitle%%

FolderListingColumns Collection
Members See Also Send comments

Glossary Item Box

Description

The 'FolderListingColumns' collection represents a set of column settings for a folder listing.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

FolderListingColumns Members


%%PageItemTitle%%

Add Method
Index
The position where the new collection member is added. The indexes of the members at and after this position will be increased by one. The first element in the collection has the index of 1. Any non-valid position (e.g. -1) implies appending.
FolderListingColumn
The folder listing column object to be added.
FolderListingColumns Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal FolderListingColumn As FolderListingColumn _
)

Parameters

Index
The position where the new collection member is added. The indexes of the members at and after this position will be increased by one. The first element in the collection has the index of 1. Any non-valid position (e.g. -1) implies appending.
FolderListingColumn
The folder listing column object to be added.

See Also

FolderListingColumns Collection | FolderListingColumns Members


%%PageItemTitle%%

Clone Method
FolderListingColumns Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FolderListingColumns

See Also

FolderListingColumns Collection | FolderListingColumns Members


%%PageItemTitle%%

Remove Method
Index
The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one. The first element in the collection has the index of 1.
FolderListingColumns Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one. The first element in the collection has the index of 1.

See Also

FolderListingColumns Collection | FolderListingColumns Members


%%PageItemTitle%%

Count Property
FolderListingColumns Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

FolderListingColumns Collection | FolderListingColumns Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection. The first element in the collection has the index of 1.
FolderListingColumns Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As FolderListingColumn

Parameters

Index
Specifies the item's position in the collection. The first element in the collection has the index of 1.

See Also

FolderListingColumns Collection | FolderListingColumns Members


%%PageItemTitle%%

FolderListingColumnSorting Object
Members See Also Send comments

Glossary Item Box

Description

The 'FolderListingColumnSorting' class represents a single column sorting setting for a folder listing.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ID | The column ID to be sorted; the property definition ID or a pseudo-ID.
Public Property Index | The 0-based column index to be sorted.
Public Property SortAscending | True to sort ascending, false to sort descending.

See Also

FolderListingColumnSorting Members


%%PageItemTitle%%

Clone Method
FolderListingColumnSorting Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FolderListingColumnSorting

See Also

FolderListingColumnSorting Object | FolderListingColumnSorting Members


%%PageItemTitle%%

ID Property
FolderListingColumnSorting Object : ID Property

Glossary Item Box

Description

The column ID to be sorted; the property definition ID or a pseudo-ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

Remarks

The column ID is either a property definition ID (positive values) or a value in MFFolderColumnId Enumeration (negative values).

See Also

FolderListingColumnSorting Object | FolderListingColumnSorting Members


%%PageItemTitle%%

Index Property
FolderListingColumnSorting Object : Index Property

Glossary Item Box

Description

The 0-based column index to be sorted.

Property type

Read-write property

Syntax

Visual Basic
Public Property Index As Long

Remarks

The index refers to associated column object location in the FolderListingColumns Collection.

See Also

FolderListingColumnSorting Object | FolderListingColumnSorting Members


%%PageItemTitle%%

SortAscending Property
FolderListingColumnSorting Object : SortAscending Property

Glossary Item Box

Description

True to sort ascending, false to sort descending.

Property type

Read-write property

Syntax

Visual Basic
Public Property SortAscending As Boolean

See Also

FolderListingColumnSorting Object | FolderListingColumnSorting Members


%%PageItemTitle%%

FolderListingColumnSortings Collection
Members See Also Send comments

Glossary Item Box

Description

The 'FolderListingColumnSortings' collection represents a set of column sorting settings for a folder listing.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

FolderListingColumnSortings Members


%%PageItemTitle%%

Add Method
Index
The position where the new collection member is added. The indexes of the members at and after this position will be increased by one. The first element in the collection has the index of 1. Any non-valid position (e.g. -1) implies appending.
FolderListingColumnSorting
The folder listing column sorting object to be added.
FolderListingColumnSortings Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal FolderListingColumnSorting As FolderListingColumnSorting _
)

Parameters

Index
The position where the new collection member is added. The indexes of the members at and after this position will be increased by one. The first element in the collection has the index of 1. Any non-valid position (e.g. -1) implies appending.
FolderListingColumnSorting
The folder listing column sorting object to be added.

See Also

FolderListingColumnSortings Collection | FolderListingColumnSortings Members


%%PageItemTitle%%

Clone Method
FolderListingColumnSortings Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FolderListingColumnSortings

See Also

FolderListingColumnSortings Collection | FolderListingColumnSortings Members


%%PageItemTitle%%

Remove Method
Index
The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one. The first element in the collection has the index of 1.
FolderListingColumnSortings Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one. The first element in the collection has the index of 1.

See Also

FolderListingColumnSortings Collection | FolderListingColumnSortings Members


%%PageItemTitle%%

Count Property
FolderListingColumnSortings Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

FolderListingColumnSortings Collection | FolderListingColumnSortings Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection. The first element in the collection has the index of 1.
FolderListingColumnSortings Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As FolderListingColumnSorting

Parameters

Index
Specifies the item's position in the collection. The first element in the collection has the index of 1.

See Also

FolderListingColumnSortings Collection | FolderListingColumnSortings Members


%%PageItemTitle%%

FolderListingUIState Object
Members See Also Send comments

Glossary Item Box

Description

The 'FolderListingUIState' class represents the UI settings for a listing within the settings for an M-Files folder.

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property Columns | The columns of the listing.
Public Property ColumnSortings | The column sorting information for the listing.
Public Property GroupingMode | The listing item grouping mode.
Public Property IconSize | The listing item icon size.
Public Property ViewMode | The listing view mode.

See Also

FolderListingUIState Members


%%PageItemTitle%%

Clone Method
FolderListingUIState Object : Clone Method

Glossary Item Box

Description

Creates a clone of this object.

Syntax

Visual Basic
Public Function Clone() As FolderListingUIState

See Also

FolderListingUIState Object | FolderListingUIState Members


%%PageItemTitle%%

Columns Property
FolderListingUIState Object : Columns Property

Glossary Item Box

Description

The columns of the listing.

Property type

Read-write property

Syntax

Visual Basic
Public Property Columns As FolderListingColumns

Remarks

The columns collection contains all columns that can be displayed in the view. The column visibility indicates if the view actually contains the column. Note that the UI state, including the column settings, does not affect the object data and properties what the server returns for this view.

See Also

FolderListingUIState Object | FolderListingUIState Members


%%PageItemTitle%%

ColumnSortings Property
FolderListingUIState Object : ColumnSortings Property

Glossary Item Box

Description

The column sorting information for the listing.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnSortings As FolderListingColumnSortings

See Also

FolderListingUIState Object | FolderListingUIState Members


%%PageItemTitle%%

GroupingMode Property
FolderListingUIState Object : GroupingMode Property

Glossary Item Box

Description

The listing item grouping mode.

Property type

Read-write property

Syntax

Visual Basic
Public Property GroupingMode As MFFolderListingItemGroupingMode

See Also

FolderListingUIState Object | FolderListingUIState Members


%%PageItemTitle%%

IconSize Property
FolderListingUIState Object : IconSize Property

Glossary Item Box

Description

The listing item icon size.

Property type

Read-write property

Syntax

Visual Basic
Public Property IconSize As Long

Remarks

The value is icon size in pixels, e.g. 32 for 32x32 icons.

See Also

FolderListingUIState Object | FolderListingUIState Members


%%PageItemTitle%%

ViewMode Property
FolderListingUIState Object : ViewMode Property

Glossary Item Box

Description

The listing view mode.

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewMode As MFFolderListingViewMode

See Also

FolderListingUIState Object | FolderListingUIState Members


%%PageItemTitle%%

FolderNameListing Collection
Members See Also Send comments

Glossary Item Box

Description

The FolderNameListing class represents a folder name collection.

Public Methods

Public Method SortWithExpression Sorts the folders based on the given expression.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.
Public Property MoreValues | Specifies whether additional folders are available on the server with the specified conditions.

See Also

FolderNameListing Members | GetFolderNameListing Method


%%PageItemTitle%%

SortWithExpression Method
Expression
The expression that identifies an initial character group.
Locale
FolderNameListing Collection : SortWithExpression Method

Glossary Item Box

Description

Sorts the folders based on the given expression.

Syntax

Visual Basic
Public Sub SortWithExpression( _
   ByVal Expression As Expression, _
   Optional ByVal Locale As ULong = 0 _
)

Parameters

Expression
The expression that identifies an initial character group.
Locale

Remarks

This method adjusts the folder listing sort order due initial character grouping.

See Also

FolderNameListing Collection | FolderNameListing Members


%%PageItemTitle%%

Count Property
FolderNameListing Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

FolderNameListing Collection | FolderNameListing Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
FolderNameListing Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As TypedValue

Parameters

Index
Specifies the item's position in the collection.

See Also

FolderNameListing Collection | FolderNameListing Members


%%PageItemTitle%%

MoreValues Property
FolderNameListing Collection : MoreValues Property

Glossary Item Box

Description

Specifies whether additional folders are available on the server with the specified conditions.

Property type

Read-only property

Syntax

Visual Basic
Public Property MoreValues As Boolean

See Also

FolderNameListing Collection | FolderNameListing Members


%%PageItemTitle%%

FolderUIState Object
Members See Also Send comments

Glossary Item Box

Description

The 'FolderUIState' class represents the UI settings of a single M-Files folder.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property BottomPaneBarMinimized | Specifies whether the bottom pane is minimized.
Public Property HitHighlightingEnabled | Specifies whether hit highlighting in file content is enabled.
Public Property ListingUIState | The listing UI state.
Public Property MetadataEditorInRightPane | Specifies whether the metadata editor is displayed in the right pane. If false, the metadata editor appears in the bottom pane.
Public Property RelativeBottomPaneHeight | Specifies the bottom pane height. The height is relative to the size of the frame window holding the bottom pane bar.
Public Property RelativeRightPaneWidth | Specifies the right pane width.
Public Property RightPaneBarMinimized | Specifies whether the right pane is minimized.
Public Property ShowBottomPaneBar | Specifies whether the bottom pane is displayed.
Public Property ShowRightPaneBar | Specifies whether the right pane is displayed.
Public Property ShowTaskPane | Specifies whether the task area is displayed.
Public Property TaskPaneMinimized | Specifies whether the task area is minimized.

See Also

FolderUIState Members


%%PageItemTitle%%

Clone Method
FolderUIState Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As FolderUIState

See Also

FolderUIState Object | FolderUIState Members


%%PageItemTitle%%

BottomPaneBarMinimized Property
FolderUIState Object : BottomPaneBarMinimized Property

Glossary Item Box

Description

Specifies whether the bottom pane is minimized.

Property type

Read-write property

Syntax

Visual Basic
Public Property BottomPaneBarMinimized As Boolean

See Also

FolderUIState Object | FolderUIState Members


%%PageItemTitle%%

HitHighlightingEnabled Property
FolderUIState Object : HitHighlightingEnabled Property

Glossary Item Box

Description

Specifies whether hit highlighting in file content is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property HitHighlightingEnabled As Boolean

See Also

FolderUIState Object | FolderUIState Members


%%PageItemTitle%%

ListingUIState Property
FolderUIState Object : ListingUIState Property

Glossary Item Box

Description

The listing UI state.

Property type

Read-only property

Syntax

Visual Basic
Public Property ListingUIState As FolderListingUIState

See Also

FolderUIState Object | FolderUIState Members


%%PageItemTitle%%

MetadataEditorInRightPane Property
FolderUIState Object : MetadataEditorInRightPane Property

Glossary Item Box

Description

Specifies whether the metadata editor is displayed in the right pane. If false, the metadata editor appears in the bottom pane.

Property type

Read-write property

Syntax

Visual Basic
Public Property MetadataEditorInRightPane As Boolean

See Also

FolderUIState Object | FolderUIState Members


%%PageItemTitle%%

RelativeBottomPaneHeight Property
FolderUIState Object : RelativeBottomPaneHeight Property

Glossary Item Box

Description

Specifies the bottom pane height. The height is relative to the size of the frame window holding the bottom pane bar.

Property type

Read-write property

Syntax

Visual Basic
Public Property RelativeBottomPaneHeight As Long

See Also

FolderUIState Object | FolderUIState Members


%%PageItemTitle%%

RelativeRightPaneWidth Property
FolderUIState Object : RelativeRightPaneWidth Property

Glossary Item Box

Description

Specifies the right pane width.

Property type

Read-write property

Syntax

Visual Basic
Public Property RelativeRightPaneWidth As Long

See Also

FolderUIState Object | FolderUIState Members


%%PageItemTitle%%

RightPaneBarMinimized Property
FolderUIState Object : RightPaneBarMinimized Property

Glossary Item Box

Description

Specifies whether the right pane is minimized.

Property type

Read-write property

Syntax

Visual Basic
Public Property RightPaneBarMinimized As Boolean

See Also

FolderUIState Object | FolderUIState Members


%%PageItemTitle%%

ShowBottomPaneBar Property
FolderUIState Object : ShowBottomPaneBar Property

Glossary Item Box

Description

Specifies whether the bottom pane is displayed.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowBottomPaneBar As Boolean

See Also

FolderUIState Object | FolderUIState Members


%%PageItemTitle%%

ShowRightPaneBar Property
FolderUIState Object : ShowRightPaneBar Property

Glossary Item Box

Description

Specifies whether the right pane is displayed.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowRightPaneBar As Boolean

See Also

FolderUIState Object | FolderUIState Members


%%PageItemTitle%%

ShowTaskPane Property
FolderUIState Object : ShowTaskPane Property

Glossary Item Box

Description

Specifies whether the task area is displayed.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowTaskPane As Boolean

See Also

FolderUIState Object | FolderUIState Members


%%PageItemTitle%%

TaskPaneMinimized Property
FolderUIState Object : TaskPaneMinimized Property

Glossary Item Box

Description

Specifies whether the task area is minimized.

Property type

Read-write property

Syntax

Visual Basic
Public Property TaskPaneMinimized As Boolean

See Also

FolderUIState Object | FolderUIState Members


%%PageItemTitle%%

IDRange Object
Members See Also Send comments

Glossary Item Box

Description

The IDRange class represents minimum and maximum IDs of the range

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetIDs | Sets the minimum and maximum IDs of the range.
Public Method SetIDs_32bit | Sets the minimum and maximum IDs of the range. Compatible with 32-bit environments.

Public Properties

Public Property MaxID | The maximum ID of the range.
Public Property MaxID_32bit | The maximum ID of the range. Compatible with 32-bit environments.
Public Property MinID | The minimum ID of the range.
Public Property MinID_32bit | The minimum ID of the range. Compatible with 32-bit environments.

See Also

IDRange Members


%%PageItemTitle%%

Clone Method
IDRange Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As IDRange

See Also

IDRange Object | IDRange Members


%%PageItemTitle%%

SetIDs Method
MinID
The minimum ID of the range.
MaxID
The maximum ID of the range.
IDRange Object : SetIDs Method

Glossary Item Box

Description

Sets the minimum and maximum IDs of the range.

Syntax

Visual Basic
Public Sub SetIDs( _
   ByVal MinID As Unknown, _
   ByVal MaxID As Unknown _
)

Parameters

MinID
The minimum ID of the range.
MaxID
The maximum ID of the range.

See Also

IDRange Object | IDRange Members


%%PageItemTitle%%

SetIDs_32bit Method
MinID
The minimum ID of the range.
MaxID
The maximum ID of the range.
IDRange Object : SetIDs_32bit Method

Glossary Item Box

Description

Sets the minimum and maximum IDs of the range. Compatible with 32-bit environments.

Syntax

Visual Basic
Public Sub SetIDs_32bit( _
   ByVal MinID As String, _
   ByVal MaxID As String _
)

Parameters

MinID
The minimum ID of the range.
MaxID
The maximum ID of the range.

See Also

IDRange Object | IDRange Members


%%PageItemTitle%%

MaxID Property
IDRange Object : MaxID Property

Glossary Item Box

Description

The maximum ID of the range.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxID As Unknown

See Also

IDRange Object | IDRange Members


%%PageItemTitle%%

MaxID_32bit Property
IDRange Object : MaxID_32bit Property

Glossary Item Box

Description

The maximum ID of the range. Compatible with 32-bit environments.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxID_32bit As String

See Also

IDRange Object | IDRange Members


%%PageItemTitle%%

MinID Property
IDRange Object : MinID Property

Glossary Item Box

Description

The minimum ID of the range.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinID As Unknown

See Also

IDRange Object | IDRange Members


%%PageItemTitle%%

MinID_32bit Property
IDRange Object : MinID_32bit Property

Glossary Item Box

Description

The minimum ID of the range. Compatible with 32-bit environments.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinID_32bit As String

See Also

IDRange Object | IDRange Members


%%PageItemTitle%%

IDs Collection
Members See Also Send comments

Glossary Item Box

Description

IDs is a collection of IDs of any type.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method IndexOf | Returns the index of the specified ID in the collection, or -1 if the specified ID does not exist in the collection.
Public Method Remove | Removes the item at the specified position from the collection.
Public Method RemoveAll | Removes all instances of the specified ID from this collection. Returns the number of items removed.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

IDs Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ID
The new member to add.
IDs Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ID As Long _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
ID
The new member to add.

See Also

IDs Collection | IDs Members


%%PageItemTitle%%

Clone Method
IDs Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As IDs

See Also

IDs Collection | IDs Members


%%PageItemTitle%%

IndexOf Method
ID
ID value to find from the collection.
IDs Collection : IndexOf Method

Glossary Item Box

Description

Returns the index of the specified ID in the collection, or -1 if the specified ID does not exist in the collection.

Syntax

Visual Basic
Public Function IndexOf( _
   ByVal ID As Long _
) As Long

Parameters

ID
ID value to find from the collection.

See Also

IDs Collection | IDs Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
IDs Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

IDs Collection | IDs Members


%%PageItemTitle%%

RemoveAll Method
ID
ID value to remove from the collection.
IDs Collection : RemoveAll Method

Glossary Item Box

Description

Removes all instances of the specified ID from this collection. Returns the number of items removed.

Syntax

Visual Basic
Public Function RemoveAll( _
   ByVal ID As Long _
) As Long

Parameters

ID
ID value to remove from the collection.

See Also

IDs Collection | IDs Members


%%PageItemTitle%%

Count Property
IDs Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

IDs Collection | IDs Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
IDs Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As Long

Parameters

Index
Specifies the item's position in the collection.

See Also

IDs Collection | IDs Members


%%PageItemTitle%%

Impersonation Object
Members See Also Send comments

Glossary Item Box

Description

A class that defines an impersonation.

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property Account | Account used in impersonation.
Public Property ImpersonationType | Impersonation type.
Public Property Password | Password used in impersonation.

Remarks

A user account setting for a privileged operation (highlighted with the green rectangle) as seen in M-Files Admin.

See Also

Impersonation Members


%%PageItemTitle%%

Clone Method
Impersonation Object : Clone Method

Glossary Item Box

Description

Creates a clone of this object.

Syntax

Visual Basic
Public Function Clone() As Impersonation

See Also

Impersonation Object | Impersonation Members


%%PageItemTitle%%

Account Property
Impersonation Object : Account Property

Glossary Item Box

Description

Account used in impersonation.

Property type

Read-write property

Syntax

Visual Basic
Public Property Account As String

See Also

Impersonation Object | Impersonation Members


%%PageItemTitle%%

ImpersonationType Property
Impersonation Object : ImpersonationType Property

Glossary Item Box

Description

Impersonation type.

Property type

Read-write property

Syntax

Visual Basic
Public Property ImpersonationType As MFImpersonationType

See Also

Impersonation Object | Impersonation Members


%%PageItemTitle%%

Password Property
Impersonation Object : Password Property

Glossary Item Box

Description

Password used in impersonation.

Property type

Write-only property

Syntax

Visual Basic
Public Property Password

See Also

Impersonation Object | Impersonation Members


%%PageItemTitle%%

ImportContentJob Object
Members See Also Send comments

Glossary Item Box

Description

The ImportContentJob class represents a content import job.

Public Methods

Public Method Clone | Creates a clone of this object.
Public Method DisableFeaturesRequiringSystemAdministratorRole | Disables all the features that require the system administrator role for importing. The number of features that are disabled may increase in the future.
Public Method SetReplicationViaCloud | Sets the information for replication via cloud storage.

Public Properties

Public Property ActivateAutomaticPermissionsForNewOrChangedDefinitions | Specifies whether to activate automatic permissions of objects due to new or changed definitions that affect them.
Public Property CombinedConnectionString | The connection string combined from external storage location and target folder name.
Public Property ConfigurationID | The configuration ID of this import job.
Public Property ConnectionString | The external storage location access information.
Public Property DisableCustomCodeInImportedPropertyDefinitions | Specifies whether all the custom code in imported property definitions is deactivated.
Public Property DisableCustomCodeInImportedWorkflows | Specifies whether all the custom code in imported workflows is deactivated.
Public Property DisableImportedExternalObjectTypeConnections | Specifies whether all the external connections of the imported object types are disabled.
Public Property DisableImportedExternalUserGroups | Specifies whether all the external connections of the imported user groups are disabled.
Public Property DisableImportedVaultEventHandlers | Specifies whether the all imported event handlers are deactivated.
Public Property ExternalFolderName | The target folder in the external cloud storage.
Public Property Flags | Specifies additional options as bit flags.
Public Property IgnoreAutomaticPermissionsDefinedByObjects | Specifies whether to ignore the automatic permissions defined by the imported objects.
Public Property Impersonation | Impersonation information to specify the access to the target files.
Public Property MetadataStructureSelectors | Specifies the metadata structure items that should be imported.
Public Property Permissions | Specifies the access control list set by this job.
Public Property SourceLocation | The full path to the source location on server.
Public Property UseDefaultObjectTypePermissions | Specifies whether to use the default permissions of object types. The UsePermissions property has precedence over this property.
Public Property UseNamesAsAliases | Specifies whether the incoming name of a structure item is used as its alias if no other alias is available.
Public Property UsePermissions | Specifies whether to use the Permissions value.

Remarks

A content import job as seen in M-Files Admin.

See Also

ImportContentJob Members


%%PageItemTitle%%

Clone Method
ImportContentJob Object : Clone Method

Glossary Item Box

Description

Creates a clone of this object.

Syntax

Visual Basic
Public Function Clone() As ImportContentJob

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

DisableFeaturesRequiringSystemAdministratorRole Method
ImportContentJob Object : DisableFeaturesRequiringSystemAdministratorRole Method

Glossary Item Box

Description

Disables all the features that require the system administrator role for importing. The number of features that are disabled may increase in the future.

Syntax

Visual Basic
Public Sub DisableFeaturesRequiringSystemAdministratorRole()

Remarks

Supported in M-Files 20.5.9099.4 and later.

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

SetReplicationViaCloud Method
vbEnableReplicationViaCloud
If this is set to "true", replication via cloud storage is enabled.
bstrConnectionString
The access information of the external storage location.
bstrExternalFolderName
The target folder in the external cloud storage.
bstrEncryptionPassword
The password that is used for encrypting the replication packages.
ImportContentJob Object : SetReplicationViaCloud Method

Glossary Item Box

Description

Sets the information for replication via cloud storage.

Syntax

Visual Basic
Public Sub SetReplicationViaCloud( _
   ByVal vbEnableReplicationViaCloud As Boolean, _
   ByVal bstrConnectionString As String, _
   ByVal bstrExternalFolderName As String, _
   ByVal bstrEncryptionPassword As String _
)

Parameters

vbEnableReplicationViaCloud
If this is set to "true", replication via cloud storage is enabled.
bstrConnectionString
The access information of the external storage location.
bstrExternalFolderName
The target folder in the external cloud storage.
bstrEncryptionPassword
The password that is used for encrypting the replication packages.

Remarks

Requires the "MFImportContentFlagUseMultipleContentPackages" flag to be enabled via the Flags property.

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

ActivateAutomaticPermissionsForNewOrChangedDefinitions Property
See Also Send comments
ImportContentJob Object : ActivateAutomaticPermissionsForNewOrChangedDefinitions Property

Glossary Item Box

Description

Specifies whether to activate automatic permissions of objects due to new or changed definitions that affect them.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActivateAutomaticPermissionsForNewOrChangedDefinitions As Boolean

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

CombinedConnectionString Property
ImportContentJob Object : CombinedConnectionString Property

Glossary Item Box

Description

The connection string combined from external storage location and target folder name.

Property type

Read-only property

Syntax

Visual Basic
Public Property CombinedConnectionString As String

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

ConfigurationID Property
ImportContentJob Object : ConfigurationID Property

Glossary Item Box

Description

The configuration ID of this import job.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConfigurationID As String

Remarks

Requires M-Files 18.11.7072.5 or later.

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

ConnectionString Property
ImportContentJob Object : ConnectionString Property

Glossary Item Box

Description

The external storage location access information.

Property type

Read-only property

Syntax

Visual Basic
Public Property ConnectionString As String

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

DisableCustomCodeInImportedPropertyDefinitions Property
ImportContentJob Object : DisableCustomCodeInImportedPropertyDefinitions Property

Glossary Item Box

Description

Specifies whether all the custom code in imported property definitions is deactivated.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableCustomCodeInImportedPropertyDefinitions As Boolean

Remarks

Supported in M-Files 20.5.9099.4 and later.

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

DisableCustomCodeInImportedWorkflows Property
ImportContentJob Object : DisableCustomCodeInImportedWorkflows Property

Glossary Item Box

Description

Specifies whether all the custom code in imported workflows is deactivated.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableCustomCodeInImportedWorkflows As Boolean

Remarks

Supported in M-Files 20.5.9099.4 and later.

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

DisableImportedExternalObjectTypeConnections Property
ImportContentJob Object : DisableImportedExternalObjectTypeConnections Property

Glossary Item Box

Description

Specifies whether all the external connections of the imported object types are disabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableImportedExternalObjectTypeConnections As Boolean

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

DisableImportedExternalUserGroups Property
ImportContentJob Object : DisableImportedExternalUserGroups Property

Glossary Item Box

Description

Specifies whether all the external connections of the imported user groups are disabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableImportedExternalUserGroups As Boolean

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

DisableImportedVaultEventHandlers Property
ImportContentJob Object : DisableImportedVaultEventHandlers Property

Glossary Item Box

Description

Specifies whether the all imported event handlers are deactivated.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableImportedVaultEventHandlers As Boolean

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

ExternalFolderName Property
ImportContentJob Object : ExternalFolderName Property

Glossary Item Box

Description

The target folder in the external cloud storage.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExternalFolderName As String

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

Flags Property
ImportContentJob Object : Flags Property

Glossary Item Box

Description

Specifies additional options as bit flags.

Property type

Read-write property

Syntax

Visual Basic
Public Property Flags As MFImportContentFlag

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

IgnoreAutomaticPermissionsDefinedByObjects Property
ImportContentJob Object : IgnoreAutomaticPermissionsDefinedByObjects Property

Glossary Item Box

Description

Specifies whether to ignore the automatic permissions defined by the imported objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property IgnoreAutomaticPermissionsDefinedByObjects As Boolean

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

Impersonation Property
ImportContentJob Object : Impersonation Property

Glossary Item Box

Description

Impersonation information to specify the access to the target files.

Property type

Read-write property

Syntax

Visual Basic
Public Property Impersonation As Impersonation

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

MetadataStructureSelectors Property
ImportContentJob Object : MetadataStructureSelectors Property

Glossary Item Box

Description

Specifies the metadata structure items that should be imported.

Property type

Read-write property

Syntax

Visual Basic
Public Property MetadataStructureSelectors As MetadataStructureSelectors

Remarks

If selectors are specified, only a selected portion of the metadata structure in the content package is imported. The selection includes explicitly pointed metadata structure elements, and optionally their dependencies.

If more than one selector is supplied, each metadata element that matches with at least one selector is imported.

The content import job imports the full content if no selectors are specified.

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

Permissions Property
ImportContentJob Object : Permissions Property

Glossary Item Box

Description

Specifies the access control list set by this job.

Property type

Read-write property

Syntax

Visual Basic
Public Property Permissions As AccessControlList

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

SourceLocation Property
ImportContentJob Object : SourceLocation Property

Glossary Item Box

Description

The full path to the source location on server.

Property type

Read-write property

Syntax

Visual Basic
Public Property SourceLocation As String

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

UseDefaultObjectTypePermissions Property
ImportContentJob Object : UseDefaultObjectTypePermissions Property

Glossary Item Box

Description

Specifies whether to use the default permissions of object types. The UsePermissions property has precedence over this property.

Property type

Read-write property

Syntax

Visual Basic
Public Property UseDefaultObjectTypePermissions As Boolean

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

UseNamesAsAliases Property
ImportContentJob Object : UseNamesAsAliases Property

Glossary Item Box

Description

Specifies whether the incoming name of a structure item is used as its alias if no other alias is available.

Property type

Read-write property

Syntax

Visual Basic
Public Property UseNamesAsAliases As Boolean

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

UsePermissions Property
ImportContentJob Object : UsePermissions Property

Glossary Item Box

Description

Specifies whether to use the Permissions value.

Property type

Read-write property

Syntax

Visual Basic
Public Property UsePermissions As Boolean

See Also

ImportContentJob Object | ImportContentJob Members


%%PageItemTitle%%

IndirectPropertyID Collection
Members See Also Send comments

Glossary Item Box

Description

The IndirectPropertyID class represents a multi-level property ID.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method EqualTo | Checks for equality to the specified object.
Public Method Remove | Removes the item at the specified position from the collection.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

IndirectPropertyID Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
IndirectPropertyIDLevel
The new member to add.
IndirectPropertyID Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal IndirectPropertyIDLevel As IndirectPropertyIDLevel _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
IndirectPropertyIDLevel
The new member to add.

See Also

IndirectPropertyID Collection | IndirectPropertyID Members


%%PageItemTitle%%

Clone Method
IndirectPropertyID Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As IndirectPropertyID

See Also

IndirectPropertyID Collection | IndirectPropertyID Members


%%PageItemTitle%%

EqualTo Method
IndirectPropertyID
IndirectPropertyID Collection : EqualTo Method

Glossary Item Box

Description

Checks for equality to the specified object.

Syntax

Visual Basic
Public Function EqualTo( _
   ByVal IndirectPropertyID As IndirectPropertyID _
) As Boolean

Parameters

IndirectPropertyID

See Also

IndirectPropertyID Collection | IndirectPropertyID Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
IndirectPropertyID Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

IndirectPropertyID Collection | IndirectPropertyID Members


%%PageItemTitle%%

ToJSON Method
IndirectPropertyID Collection : ToJSON Method

Glossary Item Box

Description

Converts the data structure to a JSON string.

Syntax

Visual Basic
Public Function ToJSON() As String

See Also

IndirectPropertyID Collection | IndirectPropertyID Members


%%PageItemTitle%%

Count Property
IndirectPropertyID Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

IndirectPropertyID Collection | IndirectPropertyID Members


%%PageItemTitle%%

Item Property
Index
IndirectPropertyID Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As IndirectPropertyIDLevel

Parameters

Index

See Also

IndirectPropertyID Collection | IndirectPropertyID Members


%%PageItemTitle%%

IndirectPropertyIDLevel Object
Members See Also Send comments

Glossary Item Box

Description

The IndirectPropertyIDLevel class represents a single level of a multi-level property ID.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property ID | Indirect property ID level reference ID.
Public Property LevelType | Indirect property ID level type.

See Also

IndirectPropertyIDLevel Members


%%PageItemTitle%%

Clone Method
IndirectPropertyIDLevel Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As IndirectPropertyIDLevel

See Also

IndirectPropertyIDLevel Object | IndirectPropertyIDLevel Members


%%PageItemTitle%%

ToJSON Method
IndirectPropertyIDLevel Object : ToJSON Method

Glossary Item Box

Description

Converts the data structure to a JSON string.

Syntax

Visual Basic
Public Function ToJSON() As String

See Also

IndirectPropertyIDLevel Object | IndirectPropertyIDLevel Members


%%PageItemTitle%%

ID Property
IndirectPropertyIDLevel Object : ID Property

Glossary Item Box

Description

Indirect property ID level reference ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

IndirectPropertyIDLevel Object | IndirectPropertyIDLevel Members


%%PageItemTitle%%

LevelType Property
IndirectPropertyIDLevel Object : LevelType Property

Glossary Item Box

Description

Indirect property ID level type.

Property type

Read-write property

Syntax

Visual Basic
Public Property LevelType As MFIndirectPropertyIDLevelType

See Also

IndirectPropertyIDLevel Object | IndirectPropertyIDLevel Members


%%PageItemTitle%%

IServerDataPushSink Object
Members See Also Send comments

Glossary Item Box

Description

An interface that implements data sink for server requests.

Public Methods

Public Method OnServerDataPush Called when M-Files server has provided data for the client.

See Also

IServerDataPushSink Members


%%PageItemTitle%%

OnServerDataPush Method
RequestID
The server-provided data push identification number. If 'RequestID' is not zero, the server expects a response from the client.
JsonDataContent
The server-provided server data push payload in JSON format.
IServerDataPushSink Object : OnServerDataPush Method

Glossary Item Box

Description

Called when M-Files server has provided data for the client.

Syntax

Visual Basic
Public Sub OnServerDataPush( _
   ByVal RequestID As Long, _
   ByVal JsonDataContent As String _
)

Parameters

RequestID
The server-provided data push identification number. If 'RequestID' is not zero, the server expects a response from the client.
JsonDataContent
The server-provided server data push payload in JSON format.

Remarks

The client may use the methods 'SendResponse', 'SendError' or 'SendCancel' in the 'VaultServerDataPushOperations' interface to provide the response. If the response is delayed (i.e. cannot be provided in 10-15 seconds) the client needs to use the 'SendHeartbeat' method in regular intervals.

See Also

IServerDataPushSink Object | IServerDataPushSink Members


%%PageItemTitle%%

KeyNamePair Object
Members See Also Send comments

Glossary Item Box

Description

The KeyNamePair class represents a key name pair.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Key | The key part.
Public Property Name | The name part.

Remarks

A general container item object for linking together a key identifier and a name string.

See Also

KeyNamePair Members


%%PageItemTitle%%

Clone Method
KeyNamePair Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As KeyNamePair

See Also

KeyNamePair Object | KeyNamePair Members


%%PageItemTitle%%

Key Property
KeyNamePair Object : Key Property

Glossary Item Box

Description

The key part.

Property type

Read-only property

Syntax

Visual Basic
Public Property Key As Long

See Also

KeyNamePair Object | KeyNamePair Members


%%PageItemTitle%%

Name Property
KeyNamePair Object : Name Property

Glossary Item Box

Description

The name part.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

KeyNamePair Object | KeyNamePair Members


%%PageItemTitle%%

KeyNamePairs Collection
Members See Also Send comments

Glossary Item Box

Description

The KeyNamePairs class is a collection of KeyNamePair objects.

Public Properties

Public Property Count | Returns the number of key name pairs in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

KeyNamePairs Members


%%PageItemTitle%%

Count Property
KeyNamePairs Collection : Count Property

Glossary Item Box

Description

Returns the number of key name pairs in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

KeyNamePairs Collection | KeyNamePairs Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
KeyNamePairs Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As KeyNamePair

Parameters

Index
Specifies the item's position in the collection.

See Also

KeyNamePairs Collection | KeyNamePairs Members


%%PageItemTitle%%

Language Object
Members See Also Send comments

Glossary Item Box

Description

The Language class represents a single vault language.

Public Properties

Public Property ID | The ID of the language.
Public Property LanguageCode | Language identifier, e.g. the ISO 639-1 or ISO 639-2 language code such as 'en' or 'eng'.
Public Property Name | The name of the language.

See Also

Language Members


%%PageItemTitle%%

ID Property
Language Object : ID Property

Glossary Item Box

Description

The ID of the language.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID As Integer

See Also

Language Object | Language Members


%%PageItemTitle%%

LanguageCode Property
Language Object : LanguageCode Property

Glossary Item Box

Description

Language identifier, e.g. the ISO 639-1 or ISO 639-2 language code such as 'en' or 'eng'.

Property type

Read-write property

Syntax

Visual Basic
Public Property LanguageCode As String

See Also

Language Object | Language Members


%%PageItemTitle%%

Name Property
Language Object : Name Property

Glossary Item Box

Description

The name of the language.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

Language Object | Language Members


%%PageItemTitle%%

LanguageDetectionResult Object
Members See Also Send comments

Glossary Item Box

Description

The "LanguageDetectionResult" class contains the results of a call used for detecting the language of plain text content.

Public Properties

Public Property Confidence | The confidence value of the detected language.
Public Property Language | The detected language.

Remarks

Requires M-Files 18.12.7201.2 or later.

See Also

LanguageDetectionResult Members


%%PageItemTitle%%

Confidence Property
LanguageDetectionResult Object : Confidence Property

Glossary Item Box

Description

The confidence value of the detected language.

Property type

Read-write property

Syntax

Visual Basic
Public Property Confidence As ULong

Remarks

Requires M-Files 18.12.7201.2 or later.

See Also

LanguageDetectionResult Object | LanguageDetectionResult Members


%%PageItemTitle%%

Language Property
LanguageDetectionResult Object : Language Property

Glossary Item Box

Description

The detected language.

Property type

Read-write property

Syntax

Visual Basic
Public Property Language As String

Remarks

Requires M-Files 18.12.7201.2 or later.

See Also

LanguageDetectionResult Object | LanguageDetectionResult Members


%%PageItemTitle%%

Languages Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of languages.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

Languages Members


%%PageItemTitle%%

Count Property
Languages Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

Languages Collection | Languages Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
Languages Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As Language

Parameters

Index
Specifies the item's position in the collection.

See Also

Languages Collection | Languages Members


%%PageItemTitle%%

LicenseStatus Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents the status of the license.

Public Methods

Public Method ClearLicenseCode Clears the license code.

Public Properties

Public Property EvaluationDaysLeft | The number of evaluation days left until expiration.
Public Property EvaluationMode | Specifies whether the license is in evaluation mode.
Public Property Expired | Specifies whether the license has expired.
Public Property LicenseCode | The license code.
Public Property NumOfConcurrentUserLicenses | The number of concurrent user licenses.
Public Property NumOfNamedUserLicenses | The number of named user licenses.
Public Property NumOfReadonlyLicenses | The number of read-only user licenses.
Public Property SerialNumber | The serial number.

See Also

LicenseStatus Members


%%PageItemTitle%%

ClearLicenseCode Method
LicenseStatus Object : ClearLicenseCode Method

Glossary Item Box

Description

Clears the license code.

Syntax

Visual Basic
Public Sub ClearLicenseCode()

See Also

LicenseStatus Object | LicenseStatus Members


%%PageItemTitle%%

EvaluationDaysLeft Property
LicenseStatus Object : EvaluationDaysLeft Property

Glossary Item Box

Description

The number of evaluation days left until expiration.

Property type

Read-only property

Syntax

Visual Basic
Public Property EvaluationDaysLeft As Long

See Also

LicenseStatus Object | LicenseStatus Members


%%PageItemTitle%%

EvaluationMode Property
LicenseStatus Object : EvaluationMode Property

Glossary Item Box

Description

Specifies whether the license is in evaluation mode.

Property type

Read-only property

Syntax

Visual Basic
Public Property EvaluationMode As Boolean

See Also

LicenseStatus Object | LicenseStatus Members


%%PageItemTitle%%

Expired Property
LicenseStatus Object : Expired Property

Glossary Item Box

Description

Specifies whether the license has expired.

Property type

Read-only property

Syntax

Visual Basic
Public Property Expired As Boolean

See Also

LicenseStatus Object | LicenseStatus Members


%%PageItemTitle%%

LicenseCode Property
LicenseStatus Object : LicenseCode Property

Glossary Item Box

Description

The license code.

Property type

Read-only property

Syntax

Visual Basic
Public Property LicenseCode As String

See Also

LicenseStatus Object | LicenseStatus Members


%%PageItemTitle%%

NumOfConcurrentUserLicenses Property
LicenseStatus Object : NumOfConcurrentUserLicenses Property

Glossary Item Box

Description

The number of concurrent user licenses.

Property type

Read-only property

Syntax

Visual Basic
Public Property NumOfConcurrentUserLicenses As Long

See Also

LicenseStatus Object | LicenseStatus Members


%%PageItemTitle%%

NumOfNamedUserLicenses Property
LicenseStatus Object : NumOfNamedUserLicenses Property

Glossary Item Box

Description

The number of named user licenses.

Property type

Read-only property

Syntax

Visual Basic
Public Property NumOfNamedUserLicenses As Long

See Also

LicenseStatus Object | LicenseStatus Members


%%PageItemTitle%%

NumOfReadonlyLicenses Property
LicenseStatus Object : NumOfReadonlyLicenses Property

Glossary Item Box

Description

The number of read-only user licenses.

Property type

Read-only property

Syntax

Visual Basic
Public Property NumOfReadonlyLicenses As Long

See Also

LicenseStatus Object | LicenseStatus Members


%%PageItemTitle%%

SerialNumber Property
LicenseStatus Object : SerialNumber Property

Glossary Item Box

Description

The serial number.

Property type

Read-only property

Syntax

Visual Basic
Public Property SerialNumber As String

See Also

LicenseStatus Object | LicenseStatus Members


%%PageItemTitle%%

LoginAccount Object
Members See Also Send comments

Glossary Item Box

Description

The LoginAccount class represents a login in the server.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method Set | Sets information for the login.

Public Properties

Public Property AccountName | The account name of the login.
Public Property AccountType | The account type of the login.
Public Property DomainName | The domain of the login.
Public Property EmailAddress | The email address of the login.
Public Property Enabled | The enabled state of the login.
Public Property FullName | The full name of the login.
Public Property LicenseType | The license type of the login.
Public Property ServerRoles | The server roles of the login.
Public Property UserName | The username of the login.

Remarks

Login account represents a single user identity in M-Files. Login account is not a vault-specific object, but common for all vaults. Login account holds user-specific information not related to the vault, like the user's name, e-mail address and license type.

In order to access vault-specific user information, see the UserAccount object.

Login accounts as seen in M-Files Admin.

See Also

LoginAccount Members


%%PageItemTitle%%

Clone Method
LoginAccount Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As LoginAccount

See Also

LoginAccount Object | LoginAccount Members


%%PageItemTitle%%

CloneFrom Method
LoginAccount
The object that is used as the source for cloning.
LoginAccount Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal LoginAccount As LoginAccount _
)

Parameters

LoginAccount
The object that is used as the source for cloning.

See Also

LoginAccount Object | LoginAccount Members


%%PageItemTitle%%

Set Method
LoginAccountType
DomainName
UserName
ServerRoles
FullName
EmailAddress
LicenseType
LoginAccount Object : Set Method

Glossary Item Box

Description

Sets information for the login.

Syntax

Visual Basic
Public Sub Set( _
   ByVal LoginAccountType As MFLoginAccountType, _
   ByVal DomainName As String, _
   ByVal UserName As String, _
   ByVal ServerRoles As MFLoginServerRole, _
   ByVal FullName As String, _
   ByVal EmailAddress As String, _
   ByVal LicenseType As MFLicenseType _
)

Parameters

LoginAccountType
Value | Description
MFLoginAccountTypeMFiles | Specifies the login with M-Files credentials.
MFLoginAccountTypeWindows | Specifies the login with Windows credentials.
DomainName
UserName
ServerRoles
Value | Description
MFLoginServerRoleBackupOperator | Backup operator.
MFLoginServerRoleLogIn | Allows login to the server.
MFLoginServerRoleNone | None.
MFLoginServerRoleSystemAdministrator | System administrator.
MFLoginServerRoleVaultCreator | Vault creator.
FullName
EmailAddress
LicenseType
Value | Description
MFLicenseTypeConcurrentUserLicense | Concurrent user license.
MFLicenseTypeNamedUserLicense | Named user license.
MFLicenseTypeNone | No license.
MFLicenseTypeReadOnlyLicense | Read-only license.

See Also

LoginAccount Object | LoginAccount Members


%%PageItemTitle%%

AccountName Property
LoginAccount Object : AccountName Property

Glossary Item Box

Description

The account name of the login.

Property type

Read-only property

Syntax

Visual Basic
Public Property AccountName As String

See Also

LoginAccount Object | LoginAccount Members


%%PageItemTitle%%

AccountType Property
LoginAccount Object : AccountType Property

Glossary Item Box

Description

The account type of the login.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccountType As MFLoginAccountType

See Also

LoginAccount Object | LoginAccount Members


%%PageItemTitle%%

DomainName Property
LoginAccount Object : DomainName Property

Glossary Item Box

Description

The domain of the login.

Property type

Read-write property

Syntax

Visual Basic
Public Property DomainName As String

See Also

LoginAccount Object | LoginAccount Members


%%PageItemTitle%%

EmailAddress Property
LoginAccount Object : EmailAddress Property

Glossary Item Box

Description

The email address of the login.

Property type

Read-write property

Syntax

Visual Basic
Public Property EmailAddress As String

See Also

LoginAccount Object | LoginAccount Members


%%PageItemTitle%%

Enabled Property
LoginAccount Object : Enabled Property

Glossary Item Box

Description

The enabled state of the login.

Property type

Read-write property

Syntax

Visual Basic
Public Property Enabled As Boolean

See Also

LoginAccount Object | LoginAccount Members


%%PageItemTitle%%

FullName Property
LoginAccount Object : FullName Property

Glossary Item Box

Description

The full name of the login.

Property type

Read-write property

Syntax

Visual Basic
Public Property FullName As String

See Also

LoginAccount Object | LoginAccount Members


%%PageItemTitle%%

LicenseType Property
LoginAccount Object : LicenseType Property

Glossary Item Box

Description

The license type of the login.

Property type

Read-write property

Syntax

Visual Basic
Public Property LicenseType As MFLicenseType

See Also

LoginAccount Object | LoginAccount Members


%%PageItemTitle%%

ServerRoles Property
LoginAccount Object : ServerRoles Property

Glossary Item Box

Description

The server roles of the login.

Property type

Read-write property

Syntax

Visual Basic
Public Property ServerRoles As MFLoginServerRole

See Also

LoginAccount Object | LoginAccount Members


%%PageItemTitle%%

UserName Property
LoginAccount Object : UserName Property

Glossary Item Box

Description

The username of the login.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserName As String

See Also

LoginAccount Object | LoginAccount Members


%%PageItemTitle%%

LoginAccountPersonalInformation Object
Members See Also Send comments

Glossary Item Box

Description

The LoginAccountPersonalInformation class represents the personal information of a login account.

Public Properties

Public Property AccountName | The login account name.
Public Property Email | The email address of the user.
Public Property FullName | The full name of the user.

Remarks

Links to the LoginAccount object by account name.

See Also

LoginAccountPersonalInformation Members | LoginAccount Object


%%PageItemTitle%%

AccountName Property
LoginAccountPersonalInformation Object : AccountName Property

Glossary Item Box

Description

The login account name.

Property type

Read-only property

Syntax

Visual Basic
Public Property AccountName As String

See Also

LoginAccountPersonalInformation Object | LoginAccountPersonalInformation Members


%%PageItemTitle%%

Email Property
LoginAccountPersonalInformation Object : Email Property

Glossary Item Box

Description

The email address of the user.

Property type

Read-only property

Syntax

Visual Basic
Public Property Email As String

See Also

LoginAccountPersonalInformation Object | LoginAccountPersonalInformation Members


%%PageItemTitle%%

FullName Property
LoginAccountPersonalInformation Object : FullName Property

Glossary Item Box

Description

The full name of the user.

Property type

Read-only property

Syntax

Visual Basic
Public Property FullName As String

See Also

LoginAccountPersonalInformation Object | LoginAccountPersonalInformation Members


%%PageItemTitle%%

LoginAccounts Collection
Members See Also Send comments

Glossary Item Box

Description

The LoginAccounts class is a collection of LoginAccount objects.

Public Properties

Public Property Count | Returns the number of login accounts in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

LoginAccounts Members


%%PageItemTitle%%

Count Property
LoginAccounts Collection : Count Property

Glossary Item Box

Description

Returns the number of login accounts in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

LoginAccounts Collection | LoginAccounts Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
LoginAccounts Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As LoginAccount

Parameters

Index
Specifies the item's position in the collection.

See Also

LoginAccounts Collection | LoginAccounts Members


%%PageItemTitle%%

Lookup Object
Members See Also Example Send comments

Glossary Item Box

Description

Lookup specifies a single lookup value.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method GetAsObjVer | Copies the lookup as an ObjVer structure.
Public Method GetFormattedDisplayValue | Gets the formatted display value.
Public Method IsUnmanagedReference | Specifies whether this lookup reference is based on unmanaged data.
Public Method SetLatestVersion | Sets the lookup value to refer to the latest version.

Public Properties

Public Property Deleted | Specifies whether the item is deleted.
Public Property DisplayID | The display ID of the item. This may differ from the numeric internal ID.
Public Property DisplayIDAvailable | Specifies whether the display ID is available.
Public Property DisplayValue | Display value. If not set the value of the lookup may appear as '(hidden)' in M-Files UI.
Public Property ExternalRepositoryIconID | The ID of the external repository icon.
Public Property ExternalRepositoryName | The external repository name of the object.
Public Property ExternalRepositoryObjectID | The external repository identifier of the object.
Public Property Hidden | Hidden.
Public Property Item | Item.
Public Property ItemGUID | The item GUID as a string.
Public Property ObjectFlags | Object flags.
Public Property ObjectType | Object type.
Public Property Version | Version. -1 always refers to the latest version of the lookup item.
Public Property VersionEx | The object version.

Remarks

The lookup class represents a reference to the object version or to the value list item. Lookup objects can be read from the TypedValue object if it has a lookup or multi-select lookup type.

In order to refer an object version, three pieces of information are needed: object type, object ID and object version. The lookup item contains the latter two items. To follow the reference, you need to know the object type for the target item.

A reference to a value list item is similar to that with an object version reference, except that the version part is not used. The lookup item contains the value list item ID, and the referee needs to know which value list is being referred to.

In some cases, the lookup target is a known, built-in value list (like the classes value list or the users value list). Elsewhere the target object type is explicitly expressed. For example, if the lookup originates from the PropertyValue object, the corresponding PropertyDef object contains the object type ID in the ValueList property.

Lookup reference as a property value (highlighted with the green rectangle) as seen in M-Files Desktop. The lookup refers to a Customer object type.

Example

Resolving the target of lookup reference (Visual Basic) Copy Code
' Identify the object and property.
Dim oObjVer As MFilesAPI.ObjVer
Dim iPropertyId As Integer
'...

' Get the value of property.
Dim oPropertyValues As MFilesAPI.PropertyValues = oVault.ObjectPropertyOperations.GetProperties(oObjVer)
Dim oPropertyValue As MFilesAPI.PropertyValue = oPropertyValues.SearchForProperty(iPropertyId)

' Resolve the target item for lookup reference.
If oPropertyValue.TypedValue.DataType = MFilesAPI.MFDataType.MFDatatypeLookup Then

    ' Get the value as lookup reference.
    Dim oLookUpRef As MFilesAPI.Lookup = oPropertyValue.TypedValue.GetValueAsLookup()

    ' Resolve the target object type for the property value.
    Dim oPropertyDef As MFilesAPI.PropertyDef = oVault.PropertyDefOperations.GetPropertyDef(oPropertyValue.PropertyDef)
    Dim oValListObjType As MFilesAPI.ObjType = oVvault.ValueListOperations.GetValueList(oPropertyDef.ValueList)

    ' Separate handling for object version and value list item references.
    If (oValListObjType.RealObjectType) Then

        ' Target type is a object type.
        ' Create object version identifier based on the reference.
        Dim oObjVerLocal As MFilesAPI.ObjVer = New MFilesAPI.ObjVer
        oObjVerLocal.SetIDs(oValListObjType.ID, oLookUpRef.Item, oLookUpRef.Version)

        ' Get the referred object version.
        Dim oObjVerAndProp As MFilesAPI.ObjectVersionAndProperties = _
            oVault.ObjectOperations.GetObjectVersionAndProperties(oObjVerLocal, False)
        ' ...

    Else

        ' Target is a value list item.

        Dim oValueListItems As MFilesAPI.ValueListItems = oVault.ValueListItemOperations.GetValueListItems(oValListObjType.ID)
        ' Search the value list item by id (oLookUpRef.Item)
        ' ...
    End If

End If

See Also

Lookup Members


%%PageItemTitle%%

Clone Method
Lookup Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As Lookup

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

CloneFrom Method
Lookup
Lookup Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal Lookup As Lookup _
)

Parameters

Lookup

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

GetAsObjVer Method
Lookup Object : GetAsObjVer Method

Glossary Item Box

Description

Copies the lookup as an ObjVer structure.

Syntax

Visual Basic
Public Function GetAsObjVer() As ObjVer

Remarks

Requires M-Files 12.0.6726.7 or later.

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

GetFormattedDisplayValue Method
Localized
EmptyLookupDispValuesAsHidden
AddDeletedSuffixIfDeleted
Lookup Object : GetFormattedDisplayValue Method

Glossary Item Box

Description

Gets the formatted display value.

Syntax

Visual Basic
Public Function GetFormattedDisplayValue( _
   ByVal Localized As Boolean, _
   ByVal EmptyLookupDispValuesAsHidden As Boolean, _
   ByVal AddDeletedSuffixIfDeleted As Boolean _
) As String

Parameters

Localized
EmptyLookupDispValuesAsHidden
AddDeletedSuffixIfDeleted

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

IsUnmanagedReference Method
Lookup Object : IsUnmanagedReference Method

Glossary Item Box

Description

Specifies whether this lookup reference is based on unmanaged data.

Syntax

Visual Basic
Public Function IsUnmanagedReference() As Boolean

Remarks

Requires M-Files 12.0.6726.7 or later.

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

SetLatestVersion Method
Lookup Object : SetLatestVersion Method

Glossary Item Box

Description

Sets the lookup value to refer to the latest version.

Syntax

Visual Basic
Public Sub SetLatestVersion()

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

Deleted Property
Lookup Object : Deleted Property

Glossary Item Box

Description

Specifies whether the item is deleted.

Property type

Read-write property

Syntax

Visual Basic
Public Property Deleted As Boolean

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

DisplayID Property
Lookup Object : DisplayID Property

Glossary Item Box

Description

The display ID of the item. This may differ from the numeric internal ID.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayID As String

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

DisplayIDAvailable Property
Lookup Object : DisplayIDAvailable Property

Glossary Item Box

Description

Specifies whether the display ID is available.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayIDAvailable As Boolean

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

DisplayValue Property
Lookup Object : DisplayValue Property

Glossary Item Box

Description

Display value. If not set the value of the lookup may appear as '(hidden)' in M-Files UI.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayValue As String

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

ExternalRepositoryIconID Property
Lookup Object : ExternalRepositoryIconID Property

Glossary Item Box

Description

The ID of the external repository icon.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryIconID As String

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

ExternalRepositoryName Property
Lookup Object : ExternalRepositoryName Property

Glossary Item Box

Description

The external repository name of the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryName As String

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

ExternalRepositoryObjectID Property
Lookup Object : ExternalRepositoryObjectID Property

Glossary Item Box

Description

The external repository identifier of the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryObjectID As String

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

Hidden Property
Lookup Object : Hidden Property

Glossary Item Box

Description

Hidden.

Property type

Read-only property

Syntax

Visual Basic
Public Property Hidden As Boolean

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

Item Property
Lookup Object : Item Property

Glossary Item Box

Description

Item.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item As Long

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

ItemGUID Property
Lookup Object : ItemGUID Property

Glossary Item Box

Description

The item GUID as a string.

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemGUID As String

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

ObjectFlags Property
Lookup Object : ObjectFlags Property

Glossary Item Box

Description

Object flags.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectFlags As MFSpecialObjectFlag

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

ObjectType Property
Lookup Object : ObjectType Property

Glossary Item Box

Description

Object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectType As Long

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

Version Property
Lookup Object : Version Property

Glossary Item Box

Description

Version. -1 always refers to the latest version of the lookup item.

Property type

Read-write property

Syntax

Visual Basic
Public Property Version As Long

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

VersionEx Property
Lookup Object : VersionEx Property

Glossary Item Box

Description

The object version.

Property type

Read-write property

Syntax

Visual Basic
Public Property VersionEx As ObjVerVersion

See Also

Lookup Object | Lookup Members


%%PageItemTitle%%

Lookups Collection
Members See Also Send comments

Glossary Item Box

Description

Lookups is a collection of lookups and can represent the values of a multi-select lookup.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method GetLookupByItem | Gets lookup by item ID.
Public Method GetLookupIndexByItem | Gets lookup index by item ID. -1 indicates that item was not found.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

Lookups Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
Lookup
Lookups Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal Lookup As Lookup _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
Lookup

See Also

Lookups Collection | Lookups Members


%%PageItemTitle%%

Clone Method
Lookups Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As Lookups

See Also

Lookups Collection | Lookups Members


%%PageItemTitle%%

CloneFrom Method
Lookups
Lookups Collection : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal Lookups As Lookups _
)

Parameters

Lookups

See Also

Lookups Collection | Lookups Members


%%PageItemTitle%%

GetLookupByItem Method
Item
Lookups Collection : GetLookupByItem Method

Glossary Item Box

Description

Gets lookup by item ID.

Syntax

Visual Basic
Public Function GetLookupByItem( _
   ByVal Item As Long _
) As Lookup

Parameters

Item

See Also

Lookups Collection | Lookups Members


%%PageItemTitle%%

GetLookupIndexByItem Method
Item
Lookups Collection : GetLookupIndexByItem Method

Glossary Item Box

Description

Gets lookup index by item ID. -1 indicates that item was not found.

Syntax

Visual Basic
Public Function GetLookupIndexByItem( _
   ByVal Item As Long _
) As Long

Parameters

Item

See Also

Lookups Collection | Lookups Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
Lookups Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

Lookups Collection | Lookups Members


%%PageItemTitle%%

Count Property
Lookups Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

Lookups Collection | Lookups Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
Lookups Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As Lookup

Parameters

Index
Specifies the item's position in the collection.

See Also

Lookups Collection | Lookups Members


%%PageItemTitle%%

MetadataStructureAliases Object
Members See Also Send comments

Glossary Item Box

Description

The StructureAliases class.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Class | The structure aliases of a class.
Public Property NamedACL | The structure aliases of a named access control list.
Public Property ObjectType | The structure aliases of an object type.
Public Property PropertyDef | The structure aliases of a property definition.
Public Property StateMetadata | The structure aliases of a workflow state.
Public Property StateTransition | The structure aliases of a workflow state transition.
Public Property UserGroup | The structure aliases of a user group.
Public Property Valuelists | The structure aliases of a value list.
Public Property Workflow | The structure aliases of a workflow.

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

MetadataStructureAliases Members


%%PageItemTitle%%

Clone Method
MetadataStructureAliases Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As MetadataStructureAliases

See Also

MetadataStructureAliases Object | MetadataStructureAliases Members


%%PageItemTitle%%

Class Property
MetadataStructureAliases Object : Class Property

Glossary Item Box

Description

The structure aliases of a class.

Property type

Read-only property

Syntax

Visual Basic
Public Property Class As StructureAliases

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

MetadataStructureAliases Object | MetadataStructureAliases Members


%%PageItemTitle%%

NamedACL Property
MetadataStructureAliases Object : NamedACL Property

Glossary Item Box

Description

The structure aliases of a named access control list.

Property type

Read-only property

Syntax

Visual Basic
Public Property NamedACL As StructureAliases

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

MetadataStructureAliases Object | MetadataStructureAliases Members


%%PageItemTitle%%

ObjectType Property
MetadataStructureAliases Object : ObjectType Property

Glossary Item Box

Description

The structure aliases of an object type.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectType As StructureAliases

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

MetadataStructureAliases Object | MetadataStructureAliases Members


%%PageItemTitle%%

PropertyDef Property
MetadataStructureAliases Object : PropertyDef Property

Glossary Item Box

Description

The structure aliases of a property definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyDef As StructureAliases

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

MetadataStructureAliases Object | MetadataStructureAliases Members


%%PageItemTitle%%

StateMetadata Property
MetadataStructureAliases Object : StateMetadata Property

Glossary Item Box

Description

The structure aliases of a workflow state.

Property type

Read-only property

Syntax

Visual Basic
Public Property StateMetadata As StructureAliases

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

MetadataStructureAliases Object | MetadataStructureAliases Members


%%PageItemTitle%%

StateTransition Property
MetadataStructureAliases Object : StateTransition Property

Glossary Item Box

Description

The structure aliases of a workflow state transition.

Property type

Read-only property

Syntax

Visual Basic
Public Property StateTransition As StructureAliases

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

MetadataStructureAliases Object | MetadataStructureAliases Members


%%PageItemTitle%%

UserGroup Property
MetadataStructureAliases Object : UserGroup Property

Glossary Item Box

Description

The structure aliases of a user group.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserGroup As StructureAliases

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

MetadataStructureAliases Object | MetadataStructureAliases Members


%%PageItemTitle%%

Valuelists Property
MetadataStructureAliases Object : Valuelists Property

Glossary Item Box

Description

The structure aliases of a value list.

Property type

Read-only property

Syntax

Visual Basic
Public Property Valuelists As StructureAliases

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

MetadataStructureAliases Object | MetadataStructureAliases Members


%%PageItemTitle%%

Workflow Property
MetadataStructureAliases Object : Workflow Property

Glossary Item Box

Description

The structure aliases of a workflow.

Property type

Read-only property

Syntax

Visual Basic
Public Property Workflow As StructureAliases

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

MetadataStructureAliases Object | MetadataStructureAliases Members


%%PageItemTitle%%

MetadataStructureSelector Object
Members See Also Send comments

Glossary Item Box

Description

The 'MetadataStructureSelector' class represents a metadata structure element selection rule for the content to be exported from the vault.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Flags | Flags that control the metadata structure selection.
Public Property ID | The selector ID.
Public Property Name | A friendly name for the selector.
Public Property StructureItemGUID | The GUID of the structure item to be selected. The primary selector.
Public Property StructureItemID | The ID of the structure item to be selected. The tertiary selector.
Public Property StructureItemSemanticAlias | The semantic alias of the structure item to be selected. The secondary selector.
Public Property StructureItemType | The type of the structure item to be selected.

See Also

MetadataStructureSelector Members


%%PageItemTitle%%

Clone Method
MetadataStructureSelector Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As MetadataStructureSelector

See Also

MetadataStructureSelector Object | MetadataStructureSelector Members


%%PageItemTitle%%

Flags Property
MetadataStructureSelector Object : Flags Property

Glossary Item Box

Description

Flags that control the metadata structure selection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Flags As MFMetadataStructureSelectorFlags

Remarks

The metadata structure selection flags control how the matching metadata structure item is selected, and how the related (dependant) metadata structure items are handled. For instance, selecting an object class metadata structure item may or may not make the associated property definitions to be selected as well. The selection is also dependent on the metadata structure of the target document vault.

See Also

MetadataStructureSelector Object | MetadataStructureSelector Members


%%PageItemTitle%%

ID Property
MetadataStructureSelector Object : ID Property

Glossary Item Box

Description

The selector ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As String

Remarks

The metadata structure selector ID can be chosen freely by the caller. It is not validated by the system.

See Also

MetadataStructureSelector Object | MetadataStructureSelector Members


%%PageItemTitle%%

Name Property
MetadataStructureSelector Object : Name Property

Glossary Item Box

Description

A friendly name for the selector.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

MetadataStructureSelector Object | MetadataStructureSelector Members


%%PageItemTitle%%

StructureItemGUID Property
MetadataStructureSelector Object : StructureItemGUID Property

Glossary Item Box

Description

The GUID of the structure item to be selected. The primary selector.

Property type

Read-write property

Syntax

Visual Basic
Public Property StructureItemGUID As String

Remarks

Use empty string if the GUID should not be used to select metadata structure items.

See Also

MetadataStructureSelector Object | MetadataStructureSelector Members


%%PageItemTitle%%

StructureItemID Property
MetadataStructureSelector Object : StructureItemID Property

Glossary Item Box

Description

The ID of the structure item to be selected. The tertiary selector.

Property type

Read-write property

Syntax

Visual Basic
Public Property StructureItemID As Long

Remarks

The "StructureItemID" is checked if the GUID nor the semantic alias did not find a matching metadata structure element.

See Also

MetadataStructureSelector Object | MetadataStructureSelector Members


%%PageItemTitle%%

StructureItemSemanticAlias Property
MetadataStructureSelector Object : StructureItemSemanticAlias Property

Glossary Item Box

Description

The semantic alias of the structure item to be selected. The secondary selector.

Property type

Read-write property

Syntax

Visual Basic
Public Property StructureItemSemanticAlias As String

Remarks

The semantic alias is checked if the GUID did not find a matching metadata structure element. Use empty string if the semantic alias should not be used to select metadata structure items.

See Also

MetadataStructureSelector Object | MetadataStructureSelector Members


%%PageItemTitle%%

StructureItemType Property
MetadataStructureSelector Object : StructureItemType Property

Glossary Item Box

Description

The type of the structure item to be selected.

Property type

Read-write property

Syntax

Visual Basic
Public Property StructureItemType As MFMetadataStructureItem

See Also

MetadataStructureSelector Object | MetadataStructureSelector Members


%%PageItemTitle%%

MetadataStructureSelectors Collection
Members See Also Send comments

Glossary Item Box

Description

The 'MetadataStructureSelectors' class represents a collection of metadata structure selection elements.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

MetadataStructureSelectors Members


%%PageItemTitle%%

Add Method
Index
The position where the new collection member is added. The indexes of the members at and after this position will be increased by one. The first element in the collection has the index of 1. Any non-valid position (e.g. -1) implies appending.
MetadataStructureSelector
The metadata structure selector object to be added.
MetadataStructureSelectors Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal MetadataStructureSelector As MetadataStructureSelector _
)

Parameters

Index
The position where the new collection member is added. The indexes of the members at and after this position will be increased by one. The first element in the collection has the index of 1. Any non-valid position (e.g. -1) implies appending.
MetadataStructureSelector
The metadata structure selector object to be added.

See Also

MetadataStructureSelectors Collection | MetadataStructureSelectors Members


%%PageItemTitle%%

Clone Method
MetadataStructureSelectors Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As MetadataStructureSelectors

See Also

MetadataStructureSelectors Collection | MetadataStructureSelectors Members


%%PageItemTitle%%

Remove Method
Index
The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one. The first element in the collection has the index of 1.
MetadataStructureSelectors Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one. The first element in the collection has the index of 1.

See Also

MetadataStructureSelectors Collection | MetadataStructureSelectors Members


%%PageItemTitle%%

Count Property
MetadataStructureSelectors Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

MetadataStructureSelectors Collection | MetadataStructureSelectors Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection. The first element in the collection has the index of 1.
MetadataStructureSelectors Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As MetadataStructureSelector

Parameters

Index
Specifies the item's position in the collection. The first element in the collection has the index of 1.

See Also

MetadataStructureSelectors Collection | MetadataStructureSelectors Members


%%PageItemTitle%%

MFilesClientApplication Object
Members See Also Send comments

Glossary Item Box

Description

The MFilesClientApplication class represents an M-Files Client application.

The MFilesClientApplication class is the high-level object of the M-Files API component. This is the first object you create when writing an application that interacts with Windows Explorer using M-Files API.

Public Methods

Public Method AddVaultConnection | Adds a new vault connection to the collection of vaults configured in M-Files Desktop.
Public Method BindToVault | Binds to a vault with the specified name (e.g., 'Sample Vault'). The default authentication method is used if the login is allowed.
Public Method FindFile | Gets a file based on the specified path.
Public Method FindObjectVersionAndProperties | Gets an object based on the specified path.
Public Method GetAPIVersion | Receives the version of the API.
Public Method GetClientLanguage | Returns the current M-Files software language.
Public Method GetClientVersion | Receives the version of the client.
Public Method GetDriveLetter | Gets the drive letter of M-Files Desktop.
Public Method GetVaultConnection | Returns the vault connection with the specified name.
Public Method GetVaultConnections | Returns a collection of vaults configured in M-Files Desktop.
Public Method GetVaultConnectionsWithGUID | Returns a collection of vaults with the specified GUID configured in M-Files Desktop.
Public Method IsObjectPathInMFiles | Checks whether the specified path refers to an object in M-Files.
Public Method LogInAs | Logs in to the vault with the specified name (e.g., 'Sample Vault'). Prompts the user for credentials.
Public Method LogInAsUser | Logs in to the vault with the specified name (e.g., 'Sample Vault') using the specified credentials.
Public Method RemoveVaultConnection | Deletes the vault connection with the specified name from the collection of vaults configured in M-Files Desktop.
Public Method ShowBalloonTip | Displays a tooltip message over M-Files status icon.
Public Method TestConnectionToServerEx | Tests the connection to the specified server.

Remarks

Accessing M-Files through this interface allows your application to use M-Files client application services. In addition, objects acquired by using this interface use the M-Files client application for their operations. Objects and actions behave similarly when accessed from the M-Files user interface (e.g., the objects use local caches and the actions performed in API are visible from the user interface).

You should use either the client or server application interface, but not both of them. Mixing objects from different interfaces may yield unpredictable results.

Example

Creating an MFilesClientApplication object and accessing the vault (Visual Basic) Copy Code

' Initialize the MFilesClientApplication object.
Dim oClientApp As New MFilesAPI.MFilesClientApplication

' Log in to a vault through document vault connection "Demo". Me refers to the current form
' of the calling application.
Dim oVaultConnection As MFilesAPI.VaultConnection = oClientApp.GetVaultConnection("Demo")
Dim oVault As MFilesAPI.Vault = oVaultConnection.BindToVault(Me.Handle, True, True)

See Also

MFilesClientApplication Members | MFilesServerApplication Object


%%PageItemTitle%%

AddVaultConnection Method
VaultConnection
MFilesClientApplication Object : AddVaultConnection Method

Glossary Item Box

Description

Adds a new vault connection to the collection of vaults configured in M-Files Desktop.

Syntax

Visual Basic
Public Sub AddVaultConnection( _
   ByVal VaultConnection As VaultConnection _
)

Parameters

VaultConnection

Remarks

In order to update an existing vault connection, the vault connection must be first removed with RemoveVaultConnection and then added again with this method.

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

BindToVault Method
VaultConnection
ParentWindow
CanLogIn
ReturnNULLIfCancelledByUser
MFilesClientApplication Object : BindToVault Method

Glossary Item Box

Description

Binds to a vault with the specified name (e.g., 'Sample Vault'). The default authentication method is used if the login is allowed.

Syntax

Visual Basic
Public Function BindToVault( _
   ByVal VaultConnection As String, _
   ByVal ParentWindow As Long, _
   ByVal CanLogIn As Boolean, _
   ByVal ReturnNULLIfCancelledByUser As Boolean _
) As Vault

Parameters

VaultConnection
ParentWindow
CanLogIn
ReturnNULLIfCancelledByUser

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

FindFile Method
Path
An absolute path to a file in M-Files.
UpdateFromServer
MFilesClientApplication Object : FindFile Method

Glossary Item Box

Description

Gets a file based on the specified path.

Syntax

Visual Basic
Public Function FindFile( _
   ByVal Path As String, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ObjectVersionFile

Parameters

Path
An absolute path to a file in M-Files.
UpdateFromServer

Return Type

The ObjectVersionFile object that contains information on the file referenced by the given file path.

Remarks

The file name must be encoded with the object ID. The object ID is automatically appended to the file name if the object is opened from M-Files (e.g., M:\Sample\1. Documents\By Class\Application\Document Template for Word (ID 84).doc).

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

FindObjectVersionAndProperties Method
Path
An absolute path to a file or object in M-Files.
UpdateFromServer
MFilesClientApplication Object : FindObjectVersionAndProperties Method

Glossary Item Box

Description

Gets an object based on the specified path.

Syntax

Visual Basic
Public Function FindObjectVersionAndProperties( _
   ByVal Path As String, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ObjectVersionAndProperties

Parameters

Path
An absolute path to a file or object in M-Files.
UpdateFromServer

Return Type

The ObjectVersionAndProperties object that contains information on the object reference by the given path.

Remarks

The file name must be encoded with the object ID. The object ID is automatically appended to the file name if the object is opened from M-Files (e.g., M:\Sample\1. Documents\By Class\Application\Document Template for Word (ID 84).doc).

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

GetAPIVersion Method
MFilesClientApplication Object : GetAPIVersion Method

Glossary Item Box

Description

Receives the version of the API.

Syntax

Visual Basic
Public Function GetAPIVersion() As MFilesVersion

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

GetClientLanguage Method
MFilesClientApplication Object : GetClientLanguage Method

Glossary Item Box

Description

Returns the current M-Files software language.

Syntax

Visual Basic
Public Function GetClientLanguage() As String

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

GetClientVersion Method
MFilesClientApplication Object : GetClientVersion Method

Glossary Item Box

Description

Receives the version of the client.

Syntax

Visual Basic
Public Function GetClientVersion() As MFilesVersion

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

GetDriveLetter Method
MFilesClientApplication Object : GetDriveLetter Method

Glossary Item Box

Description

Gets the drive letter of M-Files Desktop.

Syntax

Visual Basic
Public Function GetDriveLetter() As String

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

GetVaultConnection Method
VaultConnection
The name of the configured vault.
MFilesClientApplication Object : GetVaultConnection Method

Glossary Item Box

Description

Returns the vault connection with the specified name.

Syntax

Visual Basic
Public Function GetVaultConnection( _
   ByVal VaultConnection As String _
) As VaultConnection

Parameters

VaultConnection
The name of the configured vault.

Return Type

The VaultConnection object that can be used to log into the vault.

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

GetVaultConnections Method
MFilesClientApplication Object : GetVaultConnections Method

Glossary Item Box

Description

Returns a collection of vaults configured in M-Files Desktop.

Syntax

Visual Basic
Public Function GetVaultConnections() As VaultConnections

Return Type

A collection of the vault connections available to the current Windows user.

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

GetVaultConnectionsWithGUID Method
GUID
The GUID of the vault connections to search for.
MFilesClientApplication Object : GetVaultConnectionsWithGUID Method

Glossary Item Box

Description

Returns a collection of vaults with the specified GUID configured in M-Files Desktop.

Syntax

Visual Basic
Public Function GetVaultConnectionsWithGUID( _
   ByVal GUID As String _
) As VaultConnections

Parameters

GUID
The GUID of the vault connections to search for.

Return Type

A collection of the vault connections which match the given GUID.

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

IsObjectPathInMFiles Method
Path
An absolute path to a file or object in M-Files.
MFilesClientApplication Object : IsObjectPathInMFiles Method

Glossary Item Box

Description

Checks whether the specified path refers to an object in M-Files.

Syntax

Visual Basic
Public Function IsObjectPathInMFiles( _
   ByVal Path As String _
) As Boolean

Parameters

Path
An absolute path to a file or object in M-Files.

Return Type

True if the given path references a file or object in M-Files.

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

LogInAs Method
VaultConnection
ParentWindow
DefaultAuthType
ReturnNULLIfCancelledByUser
MFilesClientApplication Object : LogInAs Method

Glossary Item Box

Description

Logs in to the vault with the specified name (e.g., 'Sample Vault'). Prompts the user for credentials.

Syntax

Visual Basic
Public Function LogInAs( _
   ByVal VaultConnection As String, _
   ByVal ParentWindow As Long, _
   ByVal DefaultAuthType As MFAuthType, _
   ByVal ReturnNULLIfCancelledByUser As Boolean _
) As Vault

Parameters

VaultConnection
ParentWindow
DefaultAuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
ReturnNULLIfCancelledByUser

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

LogInAsUser Method
VaultConnection
AuthType
UserName
User name as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
Password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
Domain for the user. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
SPN
The Service Principal Name as a string.
MFilesClientApplication Object : LogInAsUser Method

Glossary Item Box

Description

Logs in to the vault with the specified name (e.g., 'Sample Vault') using the specified credentials.

Syntax

Visual Basic
Public Function LogInAsUser( _
   ByVal VaultConnection As String, _
   ByVal AuthType As MFAuthType, _
   ByVal UserName As String, _
   ByVal Password As String, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant _
) As Vault

Parameters

VaultConnection
AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
UserName
User name as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
Password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
Domain for the user. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
SPN
The Service Principal Name as a string.

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

RemoveVaultConnection Method
VaultConnectionName
UserSpecific
MFilesClientApplication Object : RemoveVaultConnection Method

Glossary Item Box

Description

Deletes the vault connection with the specified name from the collection of vaults configured in M-Files Desktop.

Syntax

Visual Basic
Public Sub RemoveVaultConnection( _
   ByVal VaultConnectionName As String, _
   ByVal UserSpecific As Boolean _
)

Parameters

VaultConnectionName
UserSpecific

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

ShowBalloonTip Method
Msg
The ToolTip message.
Title
The ToolTip title.
Timeout
The timeout value, in seconds, for a balloon ToolTip. The system enforces minimum and maximum timeout values (10...30 seconds).
InfoFlags
RemovePrevious
If this parameter is True, a previous balloon ToolTip must be closed before showing a new one.
MFilesClientApplication Object : ShowBalloonTip Method

Glossary Item Box

Description

Displays a tooltip message over M-Files status icon.

Syntax

Visual Basic
Public Sub ShowBalloonTip( _
   ByVal Msg As String, _
   ByVal Title As String, _
   Optional ByVal Timeout As UInt = 20, _
   Optional ByVal InfoFlags As ULong = 0, _
   Optional ByVal RemovePrevious As Boolean = True _
)

Parameters

Msg
The ToolTip message.
Title
The ToolTip title.
Timeout
The timeout value, in seconds, for a balloon ToolTip. The system enforces minimum and maximum timeout values (10...30 seconds).
InfoFlags
RemovePrevious
If this parameter is True, a previous balloon ToolTip must be closed before showing a new one.

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

TestConnectionToServerEx Method
Server
Server address as an IP number or computer name. Not used with the LPC protocol.
Port

Server port for remote protocols. Not used with the LPC protocol.

The default M-Files server port is 2266.

ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
EncryptedConnection
Specifies whether data between M-Files Client and M-Files Server must be encrypted. May apply to certain protocol sequences only.
MFilesClientApplication Object : TestConnectionToServerEx Method

Glossary Item Box

Description

Tests the connection to the specified server.

Syntax

Visual Basic
Public Function TestConnectionToServerEx( _
   Optional ByVal Server As String = "localhost", _
   Optional ByVal Port As String = 2266, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal EncryptedConnection As Boolean = False _
) As Long

Parameters

Server
Server address as an IP number or computer name. Not used with the LPC protocol.
Port

Server port for remote protocols. Not used with the LPC protocol.

The default M-Files server port is 2266.

ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
EncryptedConnection
Specifies whether data between M-Files Client and M-Files Server must be encrypted. May apply to certain protocol sequences only.

Remarks

This method tests the end-to-end RPC connection to the server. This method does not require any authentication, and it does not do anything else. It raises an error if the server connection test fail.

See Also

MFilesClientApplication Object | MFilesClientApplication Members


%%PageItemTitle%%

MFilesServerApplication Object
Members See Also Send comments

Glossary Item Box

Description

The MFilesServerApplication class represents an M-Files API interface for the M-Files server.

The MFilesServerApplication class is the high-level object of the M-Files API component. This is the first object you create when writing an application that interacts directly with the M-Files server.

Public Methods

Public Method Connect | Connects to the specified server. Use the ConnectEx7 method for additional options.
Public Method ConnectAdministrativeEx | Connects to the server in administrative mode. Allows connection without a login account if the user has administrative rights on the server computer. Use the ConnectAdministrativeEx5 method for additional options.
Public Method ConnectAdministrativeEx3 | Connects to the server in administrative mode. Allows connection without a login account if the user has administrative rights on the server computer. Use the ConnectAdministrativeEx5 method for additional options.
Public Method ConnectAdministrativeEx4 | Connects to the server in administrative mode. Allows connection without a login account if the user has administrative rights on the server computer. Use the ConnectAdministrativeEx5 method for additional options.
Public Method ConnectAdministrativeEx5 | Connects to the server in administrative mode. Allows connection without a login account if the user has administrative rights on the server computer.
Public Method ConnectAdministrativeInteractive | Connects to the specified server in administrative mode interactively. Allows connection without a login account if the user has administrative rights on the server computer. Use the ConnectAdministrativeInteractiveEx method for additional options.
Public Method ConnectAdministrativeInteractiveEx | Connects to the specified server in administrative mode interactively. Allows connection without a login account if the user has administrative rights on the server computer.
Public Method ConnectEx3 | Connects to the specified server. Use the ConnectEx7 method for additional options.
Public Method ConnectEx4 | Connects to the specified server. Use the ConnectEx7 method for additional options.
Public Method ConnectEx5 | Connects to the specified server. Use the ConnectEx7 method for additional options.
Public Method ConnectEx6 | Connects to the specified server. Use the ConnectEx7 method for additional options.
Public Method ConnectEx7 | Connects to the specified server.
Public Method ConnectInteractive | Connects to the specified server interactively.
Public Method ConnectWithAuthenticationDataEx2 | Connects to a server with the specified authentication data. Use the ConnectWithAuthenticationDataEx6 method for additional options.
Public Method ConnectWithAuthenticationDataEx3 | Connects to a server with the specified authentication data. Use the ConnectWithAuthenticationDataEx6 method for additional options.
Public Method ConnectWithAuthenticationDataEx4 | Connects to a server with the specified authentication data. Use the ConnectWithAuthenticationDataEx6 method for additional options.
Public Method ConnectWithAuthenticationDataEx5 | Connects to a server with the specified authentication data. Use the ConnectWithAuthenticationDataEx6 method for additional options.
Public Method ConnectWithAuthenticationDataEx6 | Connects to a server with the specified authentication data.
Public Method ConnectWithExistingVaultSession | Connects to the specified server with an existing vault session.
Public Method ConnectWithoutLogin | Connects to the specified server without login. Use the ConnectWithoutLoginEx3 method for additional options.
Public Method ConnectWithoutLoginEx | Connects to the specified server without login. Use the ConnectWithoutLoginEx3 method for additional options.
Public Method ConnectWithoutLoginEx2 | Connects to the specified server without login. Use the ConnectWithoutLoginEx3 method for more options.
Public Method ConnectWithoutLoginEx3 | Connects to the specified server without login.
Public Method Disconnect | Disconnects from the server.
Public Method GetAPIVersion | Receives the version of the M-Files API.
Public Method GetAuthenticationPluginInformationEx | Gets the authentication plugin information for the specified authentication request. Returns NULL if no plugin is configured for the request.
Public Method GetAuthenticationPluginsEx | Gets the available authentication plugins.
Public Method GetGroundLinkProxies | Gets the Ground Link proxies that are available on the server.
Public Method GetOnlineGroundLinkProxies | Gets the Ground Link proxies that are online and available for the user on the server.
Public Method GetOnlineVaults | Gets the vaults that are on-line and available for the user on the server.
Public Method GetServerVersion | Receives the version of the M-Files server.
Public Method GetTokenAsAuthenticationData | Gets the specified token as authentication data.
Public Method GetVaults | Gets the vaults that are available on the server.
Public Method LogInAsUserToVault | Logs in to the vault as a user. Must connect to the server first.
Public Method LogInAsUserToVaultEx | Logs in to the vault as a user. Must connect to the server first.
Public Method LogInAsUserToVaultWithSPN | Logs in to the vault as a user with a specific SPN. Must connect to the server first.
Public Method LogInToVault | Logs in to the vault with the same credentials that were used to connect to the server. Must connect to the server first.
Public Method LogInToVaultAdministrative | Logs in to the vault in administrative mode with the same credentials that were used to connect to the server. Must connect to the server first.
Public Method LogInToVaultAdministrativeEx | Logs in to the vault in administrative mode with the same credentials that were used to connect to the server. Must connect to the server first.
Public Method LogInToVaultAdministrativeWithExistingSession | Logs in to the vault in administrative mode as using the existing session from the server connect.
Public Method LogInToVaultEx | Logs in to the vault with the same credentials that were used for connecting to the server. Must connect to the server first.
Public Method LogInToVaultWithExistingSession | Logs in to the vault as using the existing session from the server connect.
Public Method TestConnectionToServerEx | Tests the connection to the specified server.

Public Properties

Public Property LicenseManagementOperations | Gets the license management operations interface.
Public Property LoginAccountOperations | Gets the login account operations interface.
Public Property ScheduledJobManagementOperations | Gets the scheduled job management operations interface.
Public Property ServerManagementOperations | Gets the management operations interface.
Public Property SharedLinkPublicOperations | Gets the shared link public operations interface.
Public Property VaultManagementOperations | Gets the vault management operations interface.
Public Property WOPIOperations | Gets the WOPI operations interface.

Remarks

By using this API interface, you access the M-Files server directly over the network by using RPC protocol. M-Files client services are bypassed, and they are not required to use this interface. Even if the computer using the interface has M-Files client software installed, it is not used. Objects acquired by using this interface use the M-Files server directly for their operations.

Note that features implemented by the M-Files client application are not available when accessing the server interface. This includes the Windows-integrated user interface and the local cache of M-Files data.

You should use either the client or server application interface, but not both of them. Mixing objects from different interfaces may yield unpredictable results.

See Also

MFilesServerApplication Members | MFilesClientApplication Object


%%PageItemTitle%%

Connect Method
AuthType
UserName
User name as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
Password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
Domain for the user. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
Server address as an IP number or computer name. Not used with the LPC protocol.
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

LocalComputerName
Local computer name as reported for the server. Use an empty string to use the computer name provided by the system.
AllowAnonymousConnection
If this parameter is True, an anonymous connection can be created. The user cannot perform vault-specific actions anonymously.
MFilesServerApplication Object : Connect Method

Glossary Item Box

Description

Connects to the specified server. Use the ConnectEx7 method for additional options.

Syntax

Visual Basic
Public Function Connect( _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal AllowAnonymousConnection As Boolean = False _
) As MFServerConnection

Parameters

AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
UserName
User name as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
Password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
Domain for the user. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
Server address as an IP number or computer name. Not used with the LPC protocol.
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

LocalComputerName
Local computer name as reported for the server. Use an empty string to use the computer name provided by the system.
AllowAnonymousConnection
If this parameter is True, an anonymous connection can be created. The user cannot perform vault-specific actions anonymously.

Remarks

Use the more recent ConnectEx method for additional options.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectAdministrativeEx Method
TimeZone
The possible time zone information. In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.
AuthType
UserName
User name as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
Password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
Domain for the user. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
SPN
Service Principal Name.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
Server address as an IP number or computer name. Not used with the LPC protocol.
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether data between M-Files Client and M-Files Server must be encrypted. May apply to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
Local computer name as reported for the server. Use an empty string to use the computer name provided by the system.
MFilesServerApplication Object : ConnectAdministrativeEx Method

Glossary Item Box

Description

Connects to the server in administrative mode. Allows connection without a login account if the user has administrative rights on the server computer. Use the ConnectAdministrativeEx5 method for additional options.

Syntax

Visual Basic
Public Function ConnectAdministrativeEx( _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "" _
) As MFServerConnection

Parameters

TimeZone
The possible time zone information. In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.
AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
UserName
User name as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
Password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
Domain for the user. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
SPN
Service Principal Name.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
Server address as an IP number or computer name. Not used with the LPC protocol.
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether data between M-Files Client and M-Files Server must be encrypted. May apply to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
Local computer name as reported for the server. Use an empty string to use the computer name provided by the system.

Remarks

This connection methods should be used only to administer M-Files Server and document vaults.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectAdministrativeEx3 Method
TimeZone
Optional parameter. The time zone.
AuthType
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
ReturnUnmanagedContent
True if unmanaged content should be returned.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
MFilesServerApplication Object : ConnectAdministrativeEx3 Method

Glossary Item Box

Description

Connects to the server in administrative mode. Allows connection without a login account if the user has administrative rights on the server computer. Use the ConnectAdministrativeEx5 method for additional options.

Syntax

Visual Basic
Public Function ConnectAdministrativeEx3( _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal ReturnUnmanagedContent As Boolean = True, _
   Optional ByVal AllowUsingAuthenticationPlugins As Boolean = True, _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "" _
) As MFServerConnection

Parameters

TimeZone
Optional parameter. The time zone.
AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
ReturnUnmanagedContent
True if unmanaged content should be returned.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectAdministrativeEx4 Method
TimeZone
Optional parameter. The time zone.
AuthType
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
ReturnUnmanagedContent
True if unmanaged content should be returned.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.
MFilesServerApplication Object : ConnectAdministrativeEx4 Method

Glossary Item Box

Description

Connects to the server in administrative mode. Allows connection without a login account if the user has administrative rights on the server computer. Use the ConnectAdministrativeEx5 method for additional options.

Syntax

Visual Basic
Public Function ConnectAdministrativeEx4( _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal ReturnUnmanagedContent As Boolean = True, _
   Optional ByVal AllowUsingAuthenticationPlugins As Boolean = True, _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "", _
   Optional ByVal AdditionalInfoAsJSON As String = "" _
) As MFServerConnection

Parameters

TimeZone
Optional parameter. The time zone.
AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
ReturnUnmanagedContent
True if unmanaged content should be returned.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectAdministrativeEx5 Method
ConnectionData
The connection details.
AuthType
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
MFilesServerApplication Object : ConnectAdministrativeEx5 Method

Glossary Item Box

Description

Connects to the server in administrative mode. Allows connection without a login account if the user has administrative rights on the server computer.

Syntax

Visual Basic
Public Function ConnectAdministrativeEx5( _
   ByVal ConnectionData As ConnectionData, _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant _
) As MFServerConnection

Parameters

ConnectionData
The connection details.
AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectAdministrativeInteractive Method
ServerDisplayName
The display name of the server to connect to. Depending on the authentication type, may appear in the login user interface.
ParentWindow
The parent window for any number of possible dialogs.
ReturnNoneIfCancelledByUser
If this is set to "true" and the user cancels the connection attempt, "None" is returned. Otherwise, an error code is returned.
TimeZone
Optional parameter. The time zone.
DefaultAuthType
Indicates an authentication type as one value of the MFAuthType enumeration. The default value indicates the current logged on Windows user (MFAuthTypeLoggedOnWindowsUser).
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
ReturnUnmanagedContent
If this is set to "true", unmanaged content is returned.
AllowUsingAuthenticationPlugins
If this is set to "true", authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property .
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.
MFilesServerApplication Object : ConnectAdministrativeInteractive Method

Glossary Item Box

Description

Connects to the specified server in administrative mode interactively. Allows connection without a login account if the user has administrative rights on the server computer. Use the ConnectAdministrativeInteractiveEx method for additional options.

Syntax

Visual Basic
Public Function ConnectAdministrativeInteractive( _
   ByVal ServerDisplayName As String, _
   ByVal ParentWindow As Long, _
   ByVal ReturnNoneIfCancelledByUser As Boolean, _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal DefaultAuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal SPN As Variant, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal ReturnUnmanagedContent As Boolean = True, _
   Optional ByVal AllowUsingAuthenticationPlugins As Boolean = True, _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "", _
   Optional ByVal AdditionalInfoAsJSON As String = "" _
) As MFServerConnection

Parameters

ServerDisplayName
The display name of the server to connect to. Depending on the authentication type, may appear in the login user interface.
ParentWindow
The parent window for any number of possible dialogs.
ReturnNoneIfCancelledByUser
If this is set to "true" and the user cancels the connection attempt, "None" is returned. Otherwise, an error code is returned.
TimeZone
Optional parameter. The time zone.
DefaultAuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
Indicates an authentication type as one value of the MFAuthType enumeration. The default value indicates the current logged on Windows user (MFAuthTypeLoggedOnWindowsUser).
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
ReturnUnmanagedContent
If this is set to "true", unmanaged content is returned.
AllowUsingAuthenticationPlugins
If this is set to "true", authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property .
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.

Remarks

Requires M-Files 12.0.6700.0 or later.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectAdministrativeInteractiveEx Method
ConnectionData
The connection details.
ServerDisplayName
The display name of the server to connect to. Depending on the authentication type, may appear in the login user interface.
ParentWindow
The parent window for any number of possible dialogs.
ReturnNoneIfCancelledByUser
If this is set to "true" and the user cancels the connection attempt, "None" is returned. Otherwise, an error code is returned.
DefaultAuthType
Indicates an authentication type as one value of the MFAuthType enumeration. The default value indicates the current logged on Windows user (MFAuthTypeLoggedOnWindowsUser).
SPN
The service principal name (SPN).
MFilesServerApplication Object : ConnectAdministrativeInteractiveEx Method

Glossary Item Box

Description

Connects to the specified server in administrative mode interactively. Allows connection without a login account if the user has administrative rights on the server computer.

Syntax

Visual Basic
Public Function ConnectAdministrativeInteractiveEx( _
   ByVal ConnectionData As ConnectionData, _
   ByVal ServerDisplayName As String, _
   ByVal ParentWindow As Long, _
   ByVal ReturnNoneIfCancelledByUser As Boolean, _
   Optional ByVal DefaultAuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal SPN As Variant _
) As MFServerConnection

Parameters

ConnectionData
The connection details.
ServerDisplayName
The display name of the server to connect to. Depending on the authentication type, may appear in the login user interface.
ParentWindow
The parent window for any number of possible dialogs.
ReturnNoneIfCancelledByUser
If this is set to "true" and the user cancels the connection attempt, "None" is returned. Otherwise, an error code is returned.
DefaultAuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
Indicates an authentication type as one value of the MFAuthType enumeration. The default value indicates the current logged on Windows user (MFAuthTypeLoggedOnWindowsUser).
SPN
The service principal name (SPN).

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectEx3 Method
TimeZone
Optional parameter. The time zone.
AuthType
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
MFilesServerApplication Object : ConnectEx3 Method

Glossary Item Box

Description

Connects to the specified server. Use the ConnectEx7 method for additional options.

Syntax

Visual Basic
Public Function ConnectEx3( _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal AllowAnonymousConnection As Boolean = False, _
   Optional ByVal AllowUsingAuthenticationPlugins As Boolean = True, _
   Optional ByVal LogicalTargetServer As String = "" _
) As MFServerConnection

Parameters

TimeZone
Optional parameter. The time zone.
AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectEx4 Method
TimeZone
Optional parameter. The time zone.
AuthType
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
MFilesServerApplication Object : ConnectEx4 Method

Glossary Item Box

Description

Connects to the specified server. Use the ConnectEx7 method for additional options.

Syntax

Visual Basic
Public Function ConnectEx4( _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal AllowAnonymousConnection As Boolean = False, _
   Optional ByVal AllowUsingAuthenticationPlugins As Boolean = True, _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "" _
) As MFServerConnection

Parameters

TimeZone
Optional parameter. The time zone.
AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectEx5 Method
TimeZone
Optional parameter. The time zone.
AuthType
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
ReturnUnmanagedContent
True if unmanaged content should be returned.
MFilesServerApplication Object : ConnectEx5 Method

Glossary Item Box

Description

Connects to the specified server. Use the ConnectEx7 method for additional options.

Syntax

Visual Basic
Public Function ConnectEx5( _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal AllowAnonymousConnection As Boolean = False, _
   Optional ByVal AllowUsingAuthenticationPlugins As Boolean = True, _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "", _
   Optional ByVal ReturnUnmanagedContent As Boolean = True _
) As MFServerConnection

Parameters

TimeZone
Optional parameter. The time zone.
AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
ReturnUnmanagedContent
True if unmanaged content should be returned.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectEx6 Method
TimeZone
Optional parameter. The time zone.
AuthType
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.
ReturnUnmanagedContent
True if unmanaged content should be returned.
MFilesServerApplication Object : ConnectEx6 Method

Glossary Item Box

Description

Connects to the specified server. Use the ConnectEx7 method for additional options.

Syntax

Visual Basic
Public Function ConnectEx6( _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal AllowAnonymousConnection As Boolean = False, _
   Optional ByVal AllowUsingAuthenticationPlugins As Boolean = True, _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "", _
   Optional ByVal AdditionalInfoAsJSON As String = "", _
   Optional ByVal ReturnUnmanagedContent As Boolean = True _
) As MFServerConnection

Parameters

TimeZone
Optional parameter. The time zone.
AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.
ReturnUnmanagedContent
True if unmanaged content should be returned.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectEx7 Method
ConnectionData
The connection details.
AuthType
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).
MFilesServerApplication Object : ConnectEx7 Method

Glossary Item Box

Description

Connects to the specified server.

Syntax

Visual Basic
Public Function ConnectEx7( _
   ByVal ConnectionData As ConnectionData, _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant _
) As MFServerConnection

Parameters

ConnectionData
The connection details.
AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
Indicates an authentication type as one value of the 'MFAuthType' enumeration. The default value indicates the current logged in Windows user ('MFAuthTypeLoggedOnWindowsUser').
UserName
Optional parameter. The name of the user. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Password
Optional parameter. The password. Used only when 'AuthType' is not 'MFAuthTypeLoggedOnWindowsUser'.
Domain
Optional parameter. The domain name. Used only when 'AuthType' is 'MFAuthTypeSpecificWindowsUser'.
SPN
The service principal name (SPN).

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectInteractive Method
ServerDisplayName
The display name of the server to connect to. Depending on the authentication type, may appear in the login user interface.
ParentWindow
The parent window for any number of possible dialogs.
ReturnNoneIfCancelledByUser
If this is set to "true" and the user cancels the connection attempt, "None" is returned. Otherwise, an error code is returned.
TimeZone
Optional parameter. The time zone.
DefaultAuthType
Indicates an authentication type as one value of the MFAuthType enumeration. The default value indicates the current logged on Windows user (MFAuthTypeLoggedOnWindowsUser).
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
If this is set to "true", anonymous connections can be attempted. This can be used to retrieve replicated vaults.
AllowUsingAuthenticationPlugins
If this is set to "true", authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property .
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.
ReturnUnmanagedContent
If this is set to "true", unmanaged content is returned.
MFilesServerApplication Object : ConnectInteractive Method

Glossary Item Box

Description

Connects to the specified server interactively.

Syntax

Visual Basic
Public Function ConnectInteractive( _
   ByVal ServerDisplayName As String, _
   ByVal ParentWindow As Long, _
   ByVal ReturnNoneIfCancelledByUser As Boolean, _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal DefaultAuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal SPN As Variant, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal AllowAnonymousConnection As Boolean = False, _
   Optional ByVal AllowUsingAuthenticationPlugins As Boolean = True, _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "", _
   Optional ByVal AdditionalInfoAsJSON As String = "", _
   Optional ByVal ReturnUnmanagedContent As Boolean = True _
) As MFServerConnection

Parameters

ServerDisplayName
The display name of the server to connect to. Depending on the authentication type, may appear in the login user interface.
ParentWindow
The parent window for any number of possible dialogs.
ReturnNoneIfCancelledByUser
If this is set to "true" and the user cancels the connection attempt, "None" is returned. Otherwise, an error code is returned.
TimeZone
Optional parameter. The time zone.
DefaultAuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
Indicates an authentication type as one value of the MFAuthType enumeration. The default value indicates the current logged on Windows user (MFAuthTypeLoggedOnWindowsUser).
SPN
The service principal name (SPN).
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
If this is set to "true", anonymous connections can be attempted. This can be used to retrieve replicated vaults.
AllowUsingAuthenticationPlugins
If this is set to "true", authentication plugin configurations are used for authentication.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property .
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.
ReturnUnmanagedContent
If this is set to "true", unmanaged content is returned.

Remarks

Requires M-Files 12.0.6700.0 or later.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectWithAuthenticationDataEx2 Method
PluginInfo
Information about the plugin that produced the authentication data.
AuthenticationData
Specified authentication data.
AttemptIdentifier
Authentication attempt identifier used with multileg authentication protocols.
TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
MFilesServerApplication Object : ConnectWithAuthenticationDataEx2 Method

Glossary Item Box

Description

Connects to a server with the specified authentication data. Use the ConnectWithAuthenticationDataEx6 method for additional options.

Syntax

Visual Basic
Public Function ConnectWithAuthenticationDataEx2( _
   ByVal PluginInfo As PluginInfo, _
   ByVal AuthenticationData As NamedValues, _
   Optional ByVal AttemptIdentifier As String = "", _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal AllowAnonymousConnection As Boolean = False, _
   Optional ByVal LogicalTargetServer As String = "" _
) As AuthenticationResult

Parameters

PluginInfo
Information about the plugin that produced the authentication data.
AuthenticationData
Specified authentication data.
AttemptIdentifier
Authentication attempt identifier used with multileg authentication protocols.
TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
LogicalTargetServer
The name of the computer that the user attempts to connect to.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectWithAuthenticationDataEx3 Method
PluginInfo
Information about the plugin that produced the authentication data.
AuthenticationData
The specified authentication data.
AttemptIdentifier
Authentication attempt identifier used with multileg authentication protocols.
TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
MFilesServerApplication Object : ConnectWithAuthenticationDataEx3 Method

Glossary Item Box

Description

Connects to a server with the specified authentication data. Use the ConnectWithAuthenticationDataEx6 method for additional options.

Syntax

Visual Basic
Public Function ConnectWithAuthenticationDataEx3( _
   ByVal PluginInfo As PluginInfo, _
   ByVal AuthenticationData As NamedValues, _
   Optional ByVal AttemptIdentifier As String = "", _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal AllowAnonymousConnection As Boolean = False, _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "" _
) As AuthenticationResult

Parameters

PluginInfo
Information about the plugin that produced the authentication data.
AuthenticationData
The specified authentication data.
AttemptIdentifier
Authentication attempt identifier used with multileg authentication protocols.
TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectWithAuthenticationDataEx4 Method
PluginInfo
Information about the plugin that produced the authentication data.
AuthenticationData
The specified authentication data.
AttemptIdentifier
Authentication attempt identifier used with multileg authentication protocols.
TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
ReturnUnmanagedContent
True if unmanaged content should be returned.
MFilesServerApplication Object : ConnectWithAuthenticationDataEx4 Method

Glossary Item Box

Description

Connects to a server with the specified authentication data. Use the ConnectWithAuthenticationDataEx6 method for additional options.

Syntax

Visual Basic
Public Function ConnectWithAuthenticationDataEx4( _
   ByVal PluginInfo As PluginInfo, _
   ByVal AuthenticationData As NamedValues, _
   Optional ByVal AttemptIdentifier As String = "", _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal AllowAnonymousConnection As Boolean = False, _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "", _
   Optional ByVal ReturnUnmanagedContent As Boolean = True _
) As AuthenticationResult

Parameters

PluginInfo
Information about the plugin that produced the authentication data.
AuthenticationData
The specified authentication data.
AttemptIdentifier
Authentication attempt identifier used with multileg authentication protocols.
TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
ReturnUnmanagedContent
True if unmanaged content should be returned.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectWithAuthenticationDataEx5 Method
PluginInfo
Information about the plugin that produced the authentication data.
AuthenticationData
The specified authentication data.
AttemptIdentifier
Authentication attempt identifier used with multileg authentication protocols.
TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.
ReturnUnmanagedContent
True if unmanaged content should be returned.
MFilesServerApplication Object : ConnectWithAuthenticationDataEx5 Method

Glossary Item Box

Description

Connects to a server with the specified authentication data. Use the ConnectWithAuthenticationDataEx6 method for additional options.

Syntax

Visual Basic
Public Function ConnectWithAuthenticationDataEx5( _
   ByVal PluginInfo As PluginInfo, _
   ByVal AuthenticationData As NamedValues, _
   Optional ByVal AttemptIdentifier As String = "", _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal AllowAnonymousConnection As Boolean = False, _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "", _
   Optional ByVal AdditionalInfoAsJSON As String = "", _
   Optional ByVal ReturnUnmanagedContent As Boolean = True _
) As AuthenticationResult

Parameters

PluginInfo
Information about the plugin that produced the authentication data.
AuthenticationData
The specified authentication data.
AttemptIdentifier
Authentication attempt identifier used with multileg authentication protocols.
TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
AllowAnonymousConnection
True if anonymous connections can be attempted. This can be used to retrieve replicated vaults.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.
ReturnUnmanagedContent
True if unmanaged content should be returned.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectWithAuthenticationDataEx6 Method
ConnectionData
The connection details.
PluginInfo
Information about the plugin that produced the authentication data.
AuthenticationData
The specified authentication data.
AttemptIdentifier
Authentication attempt identifier used with multileg authentication protocols.
MFilesServerApplication Object : ConnectWithAuthenticationDataEx6 Method

Glossary Item Box

Description

Connects to a server with the specified authentication data.

Syntax

Visual Basic
Public Function ConnectWithAuthenticationDataEx6( _
   ByVal ConnectionData As ConnectionData, _
   ByVal PluginInfo As PluginInfo, _
   ByVal AuthenticationData As NamedValues, _
   Optional ByVal AttemptIdentifier As String = "" _
) As AuthenticationResult

Parameters

ConnectionData
The connection details.
PluginInfo
Information about the plugin that produced the authentication data.
AuthenticationData
The specified authentication data.
AttemptIdentifier
Authentication attempt identifier used with multileg authentication protocols.

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectWithExistingVaultSession Method
SessionID
The ID of the existing vault session.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

MFilesServerApplication Object : ConnectWithExistingVaultSession Method

Glossary Item Box

Description

Connects to the specified server with an existing vault session.

Syntax

Visual Basic
Public Function ConnectWithExistingVaultSession( _
   ByVal SessionID() As Byte, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False _
) As Vault

Parameters

SessionID
The ID of the existing vault session.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

EncryptedConnection

Specifies whether to encrypt data between the M-Files Client service and the M-Files Server service. Applies to certain protocol sequences only.

With non-local gRPC, the value must be true when the server you are connecting to uses TLS and false when the server does not use TLS. With local gRPC, the recommended value is false.

Remarks

Requires M-Files 12.0.6700.0 or later.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectWithoutLogin Method
TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
MFilesServerApplication Object : ConnectWithoutLogin Method

Glossary Item Box

Description

Connects to the specified server without login. Use the ConnectWithoutLoginEx3 method for additional options.

Syntax

Visual Basic
Public Function ConnectWithoutLogin( _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "" _
) As MFServerConnection

Parameters

TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectWithoutLoginEx Method
TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
ReturnUnmanagedContent
True if unmanaged content should be returned.
MFilesServerApplication Object : ConnectWithoutLoginEx Method

Glossary Item Box

Description

Connects to the specified server without login. Use the ConnectWithoutLoginEx3 method for additional options.

Syntax

Visual Basic
Public Function ConnectWithoutLoginEx( _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "", _
   Optional ByVal ReturnUnmanagedContent As Boolean = True _
) As MFServerConnection

Parameters

TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
ReturnUnmanagedContent
True if unmanaged content should be returned.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectWithoutLoginEx2 Method
TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.
ReturnUnmanagedContent
True if unmanaged content should be returned.
MFilesServerApplication Object : ConnectWithoutLoginEx2 Method

Glossary Item Box

Description

Connects to the specified server without login. Use the ConnectWithoutLoginEx3 method for more options.

Syntax

Visual Basic
Public Function ConnectWithoutLoginEx2( _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal LocalComputerName As String = "", _
   Optional ByVal LogicalTargetServer As String = "", _
   Optional ByVal ClientCulture As String = "", _
   Optional ByVal AdditionalInfoAsJSON As String = "", _
   Optional ByVal ReturnUnmanagedContent As Boolean = True _
) As MFServerConnection

Parameters

TimeZone
Optional parameter. The time zone.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. The default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

The default endpoint for the gRPC protocol is 7766. With the local gRPC protocol, use the version of the M-Files Server instance you are connecting to as the endpoint value. For instance, 20.9.9403.0. Use an empty value for referring to the current installation.

LocalComputerName
The name of the client computer (the host name of the client). If empty, the system-supplied name of the local computer is used.
LogicalTargetServer
The name of the computer that the user attempts to connect to.
ClientCulture
The specified client culture information. See also ClientCulture Property.
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.
ReturnUnmanagedContent
True if unmanaged content should be returned.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ConnectWithoutLoginEx3 Method
ConnectionData
The connection details.
MFilesServerApplication Object : ConnectWithoutLoginEx3 Method

Glossary Item Box

Description

Connects to the specified server without login.

Syntax

Visual Basic
Public Function ConnectWithoutLoginEx3( _
   ByVal ConnectionData As ConnectionData _
) As MFServerConnection

Parameters

ConnectionData
The connection details.

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

Disconnect Method
MFilesServerApplication Object : Disconnect Method

Glossary Item Box

Description

Disconnects from the server.

Syntax

Visual Basic
Public Sub Disconnect()

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

GetAPIVersion Method
MFilesServerApplication Object : GetAPIVersion Method

Glossary Item Box

Description

Receives the version of the M-Files API.

Syntax

Visual Basic
Public Function GetAPIVersion() As MFilesVersion

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

GetAuthenticationPluginInformationEx Method
UserName
If not empty, specifies the user name.
Domain
If not empty, specifies the domain name.
VaultGUID
If not empty, specifies the GUID of the target vault.
HostName
If not empty, specifies the target hostname. If provided, acctType must be eatUnknown, and UserName/Domain/VaultGUID must be empty.
AccountType
Specifies the preferred account type.
TargetPluginName
Obsolete. With M-Files 2017 and later, the value must always be empty. Defining a value causes an error to be displayed when this method is used.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. Default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.
EncryptedConnection
Specifies whether data between M-Files Client and M-Files Server must be encrypted. May apply to certain protocol sequences only.
MFilesServerApplication Object : GetAuthenticationPluginInformationEx Method

Glossary Item Box

Description

Gets the authentication plugin information for the specified authentication request. Returns NULL if no plugin is configured for the request.

Syntax

Visual Basic
Public Function GetAuthenticationPluginInformationEx( _
   Optional ByVal UserName As String = "", _
   Optional ByVal Domain As String = "", _
   Optional ByVal VaultGUID As String = "", _
   Optional ByVal HostName As String = "", _
   Optional ByVal AccountType As MFLoginAccountType = MFLoginAccountTypeWindows, _
   Optional ByVal TargetPluginName As String = "", _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False _
) As PluginInfos

Parameters

UserName
If not empty, specifies the user name.
Domain
If not empty, specifies the domain name.
VaultGUID
If not empty, specifies the GUID of the target vault.
HostName
If not empty, specifies the target hostname. If provided, acctType must be eatUnknown, and UserName/Domain/VaultGUID must be empty.
AccountType
Value | Description
MFLoginAccountTypeMFiles | Specifies the login with M-Files credentials.
MFLoginAccountTypeWindows | Specifies the login with Windows credentials.
Specifies the preferred account type.
TargetPluginName
Obsolete. With M-Files 2017 and later, the value must always be empty. Defining a value causes an error to be displayed when this method is used.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. Default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.
EncryptedConnection
Specifies whether data between M-Files Client and M-Files Server must be encrypted. May apply to certain protocol sequences only.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

GetAuthenticationPluginsEx Method
ScopeIndependentOnly
If true, only scope-independent plugins are returned.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. Default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.
EncryptedConnection
Specifies whether data between M-Files Client and M-Files Server must be encrypted. May apply to certain protocol sequences only.
MFilesServerApplication Object : GetAuthenticationPluginsEx Method

Glossary Item Box

Description

Gets the available authentication plugins.

Syntax

Visual Basic
Public Function GetAuthenticationPluginsEx( _
   Optional ByVal ScopeIndependentOnly As Boolean = False, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal NetworkAddress As String = "localhost", _
   Optional ByVal Endpoint As String = 2266, _
   Optional ByVal EncryptedConnection As Boolean = False _
) As PluginInfos

Parameters

ScopeIndependentOnly
If true, only scope-independent plugins are returned.
ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
NetworkAddress
The network address of a server computer. Either a human readable computer name or an IP address in dotted decimal format. Default value is "localhost".
Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.
EncryptedConnection
Specifies whether data between M-Files Client and M-Files Server must be encrypted. May apply to certain protocol sequences only.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

GetGroundLinkProxies Method
MFilesServerApplication Object : GetGroundLinkProxies Method

Glossary Item Box

Description

Gets the Ground Link proxies that are available on the server.

Syntax

Visual Basic
Public Function GetGroundLinkProxies() As VaultsOnServer

Remarks

Supported in M-Files 20.3.8876.4 and newer.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

GetOnlineGroundLinkProxies Method
MFilesServerApplication Object : GetOnlineGroundLinkProxies Method

Glossary Item Box

Description

Gets the Ground Link proxies that are online and available for the user on the server.

Syntax

Visual Basic
Public Function GetOnlineGroundLinkProxies() As VaultsOnServer

Remarks

Supported in M-Files 20.3.8876.4 and newer.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

GetOnlineVaults Method
MFilesServerApplication Object : GetOnlineVaults Method

Glossary Item Box

Description

Gets the vaults that are on-line and available for the user on the server.

Syntax

Visual Basic
Public Function GetOnlineVaults() As VaultsOnServer

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

GetServerVersion Method
MFilesServerApplication Object : GetServerVersion Method

Glossary Item Box

Description

Receives the version of the M-Files server.

Syntax

Visual Basic
Public Function GetServerVersion() As MFilesVersion

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

GetTokenAsAuthenticationData Method
Token
MFilesServerApplication Object : GetTokenAsAuthenticationData Method

Glossary Item Box

Description

Gets the specified token as authentication data.

Syntax

Visual Basic
Public Function GetTokenAsAuthenticationData( _
   ByVal Token As String _
) As NamedValues

Parameters

Token

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

GetVaults Method
MFilesServerApplication Object : GetVaults Method

Glossary Item Box

Description

Gets the vaults that are available on the server.

Syntax

Visual Basic
Public Function GetVaults() As VaultsOnServer

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

LogInAsUserToVault Method
VaultGUID
The GUID of the target vault.
TimeZone

The time zone. In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AuthType
The authentication type.
UserName
The username as a string. Not with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
The password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
The domain for the user. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
MFilesServerApplication Object : LogInAsUserToVault Method

Glossary Item Box

Description

Logs in to the vault as a user. Must connect to the server first.

Syntax

Visual Basic
Public Function LogInAsUserToVault( _
   ByVal VaultGUID As String, _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant _
) As Vault

Parameters

VaultGUID
The GUID of the target vault.
TimeZone

The time zone. In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
The authentication type.
UserName
The username as a string. Not with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
The password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
The domain for the user. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

LogInAsUserToVaultEx Method
VaultGUID
The GUID of the target vault.
TimeZone

The time zone. In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AuthType
The authentication type.
UserName
The username as a string. Not with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
The password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
The domain for the user. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.
MFilesServerApplication Object : LogInAsUserToVaultEx Method

Glossary Item Box

Description

Logs in to the vault as a user. Must connect to the server first.

Syntax

Visual Basic
Public Function LogInAsUserToVaultEx( _
   ByVal VaultGUID As String, _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal AdditionalInfoAsJSON As String = "" _
) As Vault

Parameters

VaultGUID
The GUID of the target vault.
TimeZone

The time zone. In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
The authentication type.
UserName
The username as a string. Not with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
The password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
The domain for the user. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

LogInAsUserToVaultWithSPN Method
VaultGUID
TimeZone

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AuthType
UserName
User name as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
Password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
Domain for the user. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
SPN
The Service Principal Name as a string.
MFilesServerApplication Object : LogInAsUserToVaultWithSPN Method

Glossary Item Box

Description

Logs in to the vault as a user with a specific SPN. Must connect to the server first.

Syntax

Visual Basic
Public Function LogInAsUserToVaultWithSPN( _
   ByVal VaultGUID As String, _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant _
) As Vault

Parameters

VaultGUID
TimeZone

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
UserName
User name as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
Password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
Domain for the user. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
SPN
The Service Principal Name as a string.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

LogInToVault Method
VaultGUID
The GUID of the target vault.
MFilesServerApplication Object : LogInToVault Method

Glossary Item Box

Description

Logs in to the vault with the same credentials that were used to connect to the server. Must connect to the server first.

Syntax

Visual Basic
Public Function LogInToVault( _
   ByVal VaultGUID As String _
) As Vault

Parameters

VaultGUID
The GUID of the target vault.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

LogInToVaultAdministrative Method
VaultGUID
The GUID of the target vault.
MFilesServerApplication Object : LogInToVaultAdministrative Method

Glossary Item Box

Description

Logs in to the vault in administrative mode with the same credentials that were used to connect to the server. Must connect to the server first.

Syntax

Visual Basic
Public Function LogInToVaultAdministrative( _
   ByVal VaultGUID As String _
) As Vault

Parameters

VaultGUID
The GUID of the target vault.

Remarks

Works the same way as "LoginToVault" method, but with this method, login succeeds even when there is no user corresponding to the login account in the target vault. The login account used with this administrative vault login needs to be defined as "System administrator" in the server's login account properties.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

LogInToVaultAdministrativeEx Method
VaultGUID
AllowUsingAuthenticationPlugins
MFilesServerApplication Object : LogInToVaultAdministrativeEx Method

Glossary Item Box

Description

Logs in to the vault in administrative mode with the same credentials that were used to connect to the server. Must connect to the server first.

Syntax

Visual Basic
Public Function LogInToVaultAdministrativeEx( _
   ByVal VaultGUID As String, _
   Optional ByVal AllowUsingAuthenticationPlugins As Boolean = True _
) As Vault

Parameters

VaultGUID
AllowUsingAuthenticationPlugins

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

LogInToVaultAdministrativeWithExistingSession Method
VaultGUID
The GUID of the target vault.
MFilesServerApplication Object : LogInToVaultAdministrativeWithExistingSession Method

Glossary Item Box

Description

Logs in to the vault in administrative mode as using the existing session from the server connect.

Syntax

Visual Basic
Public Function LogInToVaultAdministrativeWithExistingSession( _
   ByVal VaultGUID As String _
) As Vault

Parameters

VaultGUID
The GUID of the target vault.

Remarks

Works the same way as "LogInToVaultWithExistingSession" method, but with this method, login succeeds even when there is no user corresponding to the login account in the target vault. The login account used with this administrative vault login needs to be defined as "System administrator" in the server's login account properties.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

LogInToVaultEx Method
VaultGUID
The vault GUID.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
MFilesServerApplication Object : LogInToVaultEx Method

Glossary Item Box

Description

Logs in to the vault with the same credentials that were used for connecting to the server. Must connect to the server first.

Syntax

Visual Basic
Public Function LogInToVaultEx( _
   ByVal VaultGUID As String, _
   Optional ByVal AllowUsingAuthenticationPlugins As Boolean = True _
) As Vault

Parameters

VaultGUID
The vault GUID.
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

LogInToVaultWithExistingSession Method
VaultGUID
MFilesServerApplication Object : LogInToVaultWithExistingSession Method

Glossary Item Box

Description

Logs in to the vault as using the existing session from the server connect.

Syntax

Visual Basic
Public Function LogInToVaultWithExistingSession( _
   ByVal VaultGUID As String _
) As Vault

Parameters

VaultGUID

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

TestConnectionToServerEx Method
Server
Server address as an IP number or computer name. Not used with the LPC protocol.
Port

Server port for remote protocols. Not used with the LPC protocol.

The default M-Files server port is 2266.

ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
EncryptedConnection
Specifies whether data between M-Files Client and M-Files Server must be encrypted. May apply to certain protocol sequences only.
MFilesServerApplication Object : TestConnectionToServerEx Method

Glossary Item Box

Description

Tests the connection to the specified server.

Syntax

Visual Basic
Public Function TestConnectionToServerEx( _
   Optional ByVal Server As String = "localhost", _
   Optional ByVal Port As String = 2266, _
   Optional ByVal ProtocolSequence As String = "ncacn_ip_tcp", _
   Optional ByVal EncryptedConnection As Boolean = False _
) As Long

Parameters

Server
Server address as an IP number or computer name. Not used with the LPC protocol.
Port

Server port for remote protocols. Not used with the LPC protocol.

The default M-Files server port is 2266.

ProtocolSequence

Protocol sequence name to be used in server communication. Supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
EncryptedConnection
Specifies whether data between M-Files Client and M-Files Server must be encrypted. May apply to certain protocol sequences only.

Return Type

Round-trip time in milliseconds

Remarks

This method tests the end-to-end RPC connection to the server. This method does not require any authentication, and it does not do anything else. It raises an error if the server connection test fail.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

LicenseManagementOperations Property
MFilesServerApplication Object : LicenseManagementOperations Property

Glossary Item Box

Description

Gets the license management operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property LicenseManagementOperations As ServerLicenseManagementOperations

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

LoginAccountOperations Property
MFilesServerApplication Object : LoginAccountOperations Property

Glossary Item Box

Description

Gets the login account operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property LoginAccountOperations As ServerLoginAccountOperations

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ScheduledJobManagementOperations Property
MFilesServerApplication Object : ScheduledJobManagementOperations Property

Glossary Item Box

Description

Gets the scheduled job management operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ScheduledJobManagementOperations As ServerScheduledJobManagementOperations

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

ServerManagementOperations Property
MFilesServerApplication Object : ServerManagementOperations Property

Glossary Item Box

Description

Gets the management operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerManagementOperations As ServerManagementOperations

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

SharedLinkPublicOperations Property
MFilesServerApplication Object : SharedLinkPublicOperations Property

Glossary Item Box

Description

Gets the shared link public operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property SharedLinkPublicOperations As SharedLinkPublicOperations

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

VaultManagementOperations Property
MFilesServerApplication Object : VaultManagementOperations Property

Glossary Item Box

Description

Gets the vault management operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property VaultManagementOperations As ServerVaultManagementOperations

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

WOPIOperations Property
MFilesServerApplication Object : WOPIOperations Property

Glossary Item Box

Description

Gets the WOPI operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property WOPIOperations As ServerWOPIOperations

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

MFilesServerApplication Object | MFilesServerApplication Members


%%PageItemTitle%%

MFilesVersion Object
Members See Also Send comments

Glossary Item Box

Description

The MFilesVersion class.

Public Methods

Public Method Clone | Creates a clone of an object.
Public Method CompareTo | Performs a less-than comparison with the specified object.

Public Properties

Public Property Build | Gets the build version part.
Public Property Display | Version information for display purposes. Does not include the platform
Public Property Major | Gets the major version part.
Public Property Minor | Gets the minor version part.
Public Property Patch | Gets the patch version part.
Public Property SoftwarePlatform | Gets the software platform version part.

Remarks

Encapsulates the M-Files version information.

See Also

MFilesVersion Members


%%PageItemTitle%%

Clone Method
MFilesVersion Object : Clone Method

Glossary Item Box

Description

Creates a clone of an object.

Syntax

Visual Basic
Public Function Clone() As MFilesVersion

See Also

MFilesVersion Object | MFilesVersion Members


%%PageItemTitle%%

CompareTo Method
RightSide
MFilesVersion Object : CompareTo Method

Glossary Item Box

Description

Performs a less-than comparison with the specified object.

Syntax

Visual Basic
Public Function CompareTo( _
   ByVal RightSide As MFilesVersion _
) As Long

Parameters

RightSide

Return Type

Returns a non-zero value if this version is older than the RightSide parameter.

See Also

MFilesVersion Object | MFilesVersion Members


%%PageItemTitle%%

Build Property
MFilesVersion Object : Build Property

Glossary Item Box

Description

Gets the build version part.

Property type

Read-write property

Syntax

Visual Basic
Public Property Build As Long

See Also

MFilesVersion Object | MFilesVersion Members


%%PageItemTitle%%

Display Property
MFilesVersion Object : Display Property

Glossary Item Box

Description

Version information for display purposes. Does not include the platform

Property type

Read-only property

Syntax

Visual Basic
Public Property Display As String

See Also

MFilesVersion Object | MFilesVersion Members


%%PageItemTitle%%

Major Property
MFilesVersion Object : Major Property

Glossary Item Box

Description

Gets the major version part.

Property type

Read-write property

Syntax

Visual Basic
Public Property Major As Long

See Also

MFilesVersion Object | MFilesVersion Members


%%PageItemTitle%%

Minor Property
MFilesVersion Object : Minor Property

Glossary Item Box

Description

Gets the minor version part.

Property type

Read-write property

Syntax

Visual Basic
Public Property Minor As Long

See Also

MFilesVersion Object | MFilesVersion Members


%%PageItemTitle%%

Patch Property
MFilesVersion Object : Patch Property

Glossary Item Box

Description

Gets the patch version part.

Property type

Read-write property

Syntax

Visual Basic
Public Property Patch As Long

See Also

MFilesVersion Object | MFilesVersion Members


%%PageItemTitle%%

SoftwarePlatform Property
MFilesVersion Object : SoftwarePlatform Property

Glossary Item Box

Description

Gets the software platform version part.

Property type

Read-write property

Syntax

Visual Basic
Public Property SoftwarePlatform As MFSoftwarePlatformType

See Also

MFilesVersion Object | MFilesVersion Members


%%PageItemTitle%%

MonthlyDateTrigger Object
Members See Also Send comments

Glossary Item Box

Description

The MonthlyDateTrigger class represents monthly date trigger.

Public Properties

Public Property Days | Specifies the day of the month a scheduled job runs. This value is a bit field that specifies the day(s) the task will run. Bit 0 corresponds to the first of the month, bit 1 to the second, and so forth.
Public Property Months | Specifies the day of the month a scheduled job runs. This value is a bit field that specifies the day(s) the task will run. Bit 0 corresponds to the first of the month, bit 1 to the second, and so forth.

See Also

MonthlyDateTrigger Members


%%PageItemTitle%%

Days Property
MonthlyDateTrigger Object : Days Property

Glossary Item Box

Description

Specifies the day of the month a scheduled job runs. This value is a bit field that specifies the day(s) the task will run. Bit 0 corresponds to the first of the month, bit 1 to the second, and so forth.

Property type

Read-write property

Syntax

Visual Basic
Public Property Days As Long

See Also

MonthlyDateTrigger Object | MonthlyDateTrigger Members


%%PageItemTitle%%

Months Property
MonthlyDateTrigger Object : Months Property

Glossary Item Box

Description

Specifies the day of the month a scheduled job runs. This value is a bit field that specifies the day(s) the task will run. Bit 0 corresponds to the first of the month, bit 1 to the second, and so forth.

Property type

Read-write property

Syntax

Visual Basic
Public Property Months As MFTriggerMonth

See Also

MonthlyDateTrigger Object | MonthlyDateTrigger Members


%%PageItemTitle%%

MonthlyDOWTrigger Object
Members See Also Send comments

Glossary Item Box

Description

The MonthlyDOWTrigger class represents a monthly day-of-the-week trigger.

Public Properties

Public Property DaysOfTheWeek | Specifies the day(s) of the week (specified in WhichWeek) when the scheduled job runs. This value is a combination of the flags.
Public Property Months | Value that describes the month(s) when the scheduled job runs. This value is a combination of the flags.
Public Property WhichWeek | Specifies the week of the month when the scheduled job runs.

See Also

MonthlyDOWTrigger Members


%%PageItemTitle%%

DaysOfTheWeek Property
MonthlyDOWTrigger Object : DaysOfTheWeek Property

Glossary Item Box

Description

Specifies the day(s) of the week (specified in WhichWeek) when the scheduled job runs. This value is a combination of the flags.

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysOfTheWeek As MFTriggerWeekDay

See Also

MonthlyDOWTrigger Object | MonthlyDOWTrigger Members


%%PageItemTitle%%

Months Property
MonthlyDOWTrigger Object : Months Property

Glossary Item Box

Description

Value that describes the month(s) when the scheduled job runs. This value is a combination of the flags.

Property type

Read-write property

Syntax

Visual Basic
Public Property Months As MFTriggerMonth

See Also

MonthlyDOWTrigger Object | MonthlyDOWTrigger Members


%%PageItemTitle%%

WhichWeek Property
MonthlyDOWTrigger Object : WhichWeek Property

Glossary Item Box

Description

Specifies the week of the month when the scheduled job runs.

Property type

Read-write property

Syntax

Visual Basic
Public Property WhichWeek As MFTriggerWeekOfMonth

See Also

MonthlyDOWTrigger Object | MonthlyDOWTrigger Members


%%PageItemTitle%%

NamedACL Object
Members See Also Send comments

Glossary Item Box

Description

The NamedACL class encapsulates the data of a named access control list (ACL).

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AccessControlList | The definition of the access control list.
Public Property GUID | The GUID as a string.
Public Property ID | The ID of the named access control list.
Public Property Name | The name of the named access control list.
Public Property NamedACLType | The type of the named access control list.

Remarks

The named access control list defines a pre-set list of access control values.

Named access control list selector in M-Files Desktop.

See Also

NamedACL Members


%%PageItemTitle%%

Clone Method
NamedACL Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As NamedACL

See Also

NamedACL Object | NamedACL Members


%%PageItemTitle%%

AccessControlList Property
NamedACL Object : AccessControlList Property

Glossary Item Box

Description

The definition of the access control list.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessControlList As AccessControlList

See Also

NamedACL Object | NamedACL Members


%%PageItemTitle%%

GUID Property
NamedACL Object : GUID Property

Glossary Item Box

Description

The GUID as a string.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID As String

See Also

NamedACL Object | NamedACL Members


%%PageItemTitle%%

ID Property
NamedACL Object : ID Property

Glossary Item Box

Description

The ID of the named access control list.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

Remarks

Use the VaultNamedACLOperations interface to get all the NamedACL objects.

The ObjectVersionAndPermissions object contains a named ACL object if the named ACL is used.

See Also

NamedACL Object | NamedACL Members


%%PageItemTitle%%

Name Property
NamedACL Object : Name Property

Glossary Item Box

Description

The name of the named access control list.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

NamedACL Object | NamedACL Members


%%PageItemTitle%%

NamedACLType Property
NamedACL Object : NamedACLType Property

Glossary Item Box

Description

The type of the named access control list.

Property type

Read-only property

Syntax

Visual Basic
Public Property NamedACLType As MFNamedACLType

See Also

NamedACL Object | NamedACL Members


%%PageItemTitle%%

NamedACLAdmin Object
Members See Also Send comments

Glossary Item Box

Description

The NamedACL class encapsulates the data of a named access control list (ACL) (for administrative operations).

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AccessControlListForNamedACL | The definition of the access control list which controls visibility of named ACL.
Public Property NamedACL | The definition of the access control list.
Public Property SemanticAliases | The semantic aliases of this named access control list.

Remarks

The administrative part of a named access control list as seen in M-Files Admin.

See Also

NamedACLAdmin Members


%%PageItemTitle%%

Clone Method
NamedACLAdmin Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As NamedACLAdmin

See Also

NamedACLAdmin Object | NamedACLAdmin Members


%%PageItemTitle%%

AccessControlListForNamedACL Property
NamedACLAdmin Object : AccessControlListForNamedACL Property

Glossary Item Box

Description

The definition of the access control list which controls visibility of named ACL.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessControlListForNamedACL As AccessControlList

See Also

NamedACLAdmin Object | NamedACLAdmin Members


%%PageItemTitle%%

NamedACL Property
NamedACLAdmin Object : NamedACL Property

Glossary Item Box

Description

The definition of the access control list.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamedACL As NamedACL

See Also

NamedACLAdmin Object | NamedACLAdmin Members


%%PageItemTitle%%

SemanticAliases Property
NamedACLAdmin Object : SemanticAliases Property

Glossary Item Box

Description

The semantic aliases of this named access control list.

Property type

Read-write property

Syntax

Visual Basic
Public Property SemanticAliases As SemanticAliases

See Also

NamedACLAdmin Object | NamedACLAdmin Members


%%PageItemTitle%%

NamedACLs Collection
Members See Also Send comments

Glossary Item Box

Description

NamedACLs is a collection of NamedACL objects.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

NamedACLs Members | NamedACL Object


%%PageItemTitle%%

Count Property
NamedACLs Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

NamedACLs Collection | NamedACLs Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
NamedACLs Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As NamedACL

Parameters

Index
Specifies the item's position in the collection.

See Also

NamedACLs Collection | NamedACLs Members


%%PageItemTitle%%

NamedACLsAdmin Collection
Members See Also Send comments

Glossary Item Box

Description

NamedACLsAdmin is a collection of NamedACLAdmin objects.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

NamedACLsAdmin Members


%%PageItemTitle%%

Count Property
NamedACLsAdmin Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

NamedACLsAdmin Collection | NamedACLsAdmin Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
NamedACLsAdmin Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As NamedACLAdmin

Parameters

Index
Specifies the item's position in the collection.

See Also

NamedACLsAdmin Collection | NamedACLsAdmin Members


%%PageItemTitle%%

NamedValueNamespace Object
Members See Also Send comments

Glossary Item Box

Description

The 'NamedValueNamespace' class represents the namespace and its named values.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property NamedValues | Gets the named values of the named value namespace.
Public Property NamespaceName | Gets the namespace of the named values.

See Also

NamedValueNamespace Members


%%PageItemTitle%%

Clone Method
NamedValueNamespace Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As NamedValueNamespace

See Also

NamedValueNamespace Object | NamedValueNamespace Members


%%PageItemTitle%%

NamedValues Property
NamedValueNamespace Object : NamedValues Property

Glossary Item Box

Description

Gets the named values of the named value namespace.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamedValues As NamedValues

See Also

NamedValueNamespace Object | NamedValueNamespace Members


%%PageItemTitle%%

NamespaceName Property
NamedValueNamespace Object : NamespaceName Property

Glossary Item Box

Description

Gets the namespace of the named values.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamespaceName As String

See Also

NamedValueNamespace Object | NamedValueNamespace Members


%%PageItemTitle%%

NamedValueNamespaces Collection
Members See Also Send comments

Glossary Item Box

Description

The 'NamedValueNamespaces' class represents a collection of namespaces.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

NamedValueNamespaces Members


%%PageItemTitle%%

Add Method
Index
The position at which a new collection member is added. Any invalid position implies appending.
NamedValueNamespace
The new member to be added.
NamedValueNamespaces Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal NamedValueNamespace As NamedValueNamespace _
)

Parameters

Index
The position at which a new collection member is added. Any invalid position implies appending.
NamedValueNamespace
The new member to be added.

See Also

NamedValueNamespaces Collection | NamedValueNamespaces Members


%%PageItemTitle%%

Clone Method
NamedValueNamespaces Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As NamedValueNamespaces

See Also

NamedValueNamespaces Collection | NamedValueNamespaces Members


%%PageItemTitle%%

Remove Method
Index
The position of the collection member to be removed.
NamedValueNamespaces Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The position of the collection member to be removed.

See Also

NamedValueNamespaces Collection | NamedValueNamespaces Members


%%PageItemTitle%%

Count Property
NamedValueNamespaces Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

NamedValueNamespaces Collection | NamedValueNamespaces Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection. The first element in the collection has the index of 1.
NamedValueNamespaces Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As NamedValueNamespace

Parameters

Index
Specifies the item's position in the collection. The first element in the collection has the index of 1.

See Also

NamedValueNamespaces Collection | NamedValueNamespaces Members


%%PageItemTitle%%

NamedValues Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of named values.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method Contains | Specifies whether the given name exists in the collection.

Public Properties

Public Property Modified | Specifies whether this value collection has been modified.
Public Property Names | Gets the names of the values in the collection.
Public Property Value | The named value.

See Also

NamedValues Members


%%PageItemTitle%%

Clone Method
NamedValues Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As NamedValues

See Also

NamedValues Collection | NamedValues Members


%%PageItemTitle%%

Contains Method
Name
NamedValues Collection : Contains Method

Glossary Item Box

Description

Specifies whether the given name exists in the collection.

Syntax

Visual Basic
Public Function Contains( _
   ByVal Name As String _
) As Boolean

Parameters

Name

See Also

NamedValues Collection | NamedValues Members


%%PageItemTitle%%

Modified Property
NamedValues Collection : Modified Property

Glossary Item Box

Description

Specifies whether this value collection has been modified.

Property type

Read-write property

Syntax

Visual Basic
Public Property Modified As Boolean

See Also

NamedValues Collection | NamedValues Members


%%PageItemTitle%%

Names Property
NamedValues Collection : Names Property

Glossary Item Box

Description

Gets the names of the values in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Names As Strings

See Also

NamedValues Collection | NamedValues Members


%%PageItemTitle%%

Value Property
ValueName
The name of the named value to access.
NamedValues Collection : Value Property

Glossary Item Box

Description

The named value.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value( _
   ByVal ValueName As String _
) As Variant

Parameters

ValueName
The name of the named value to access.

Remarks

When the NamedValues object is retrieved from the server via an API call, null values are returned as System.DBNull instead of Null.

See Also

NamedValues Collection | NamedValues Members


%%PageItemTitle%%

Number Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents a simple integer value.

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property Value Value.

See Also

Number Members


%%PageItemTitle%%

Clone Method
Number Object : Clone Method

Glossary Item Box

Description

Creates a clone of this object.

Syntax

Visual Basic
Public Function Clone() As Number

See Also

Number Object | Number Members


%%PageItemTitle%%

Value Property
Number Object : Value Property

Glossary Item Box

Description

Value.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value As Long

See Also

Number Object | Number Members


%%PageItemTitle%%

ObjectClass Object
Members See Also Example Send comments

Glossary Item Box

Description

Object classes are used for categorizing objects. The class of an object determines which metadata should be specified for the object. An object class automatically provides the object with certain properties that have been specified for the object class. Some of these properties are obligatory and must be filled in while creating a new M-Files object of this class, whereas others accept an empty (NULL) value.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AccessControlList | The ACL that defines the visibility and other permission settings of this object class. Also specifies who can attach objects to this class.
Public Property AdditionalClassInfo | The additional type-specific class features.
Public Property AssociatedPropertyDefs | The associated property definitions of the class.
Public Property AutomaticPermissionsForObjects | Specifies the automatic permissions for an object for which the user selects this item. If Nothing, no automatic permissions are defined.
Public Property DefaultClass | Specifies whether the object class is the default class of the object type.
Public Property ForceWorkflow | Specifies whether the use of the specified workflow is forced.
Public Property ID | The ID of the class.
Public Property Name | The name of the class.
Public Property NamePropertyDef | The ID of the property definition that represents the name of the document or other object.
Public Property ObjectType | The object type with which this class is used.
Public Property Workflow | The default workflow of the class, or zero if there is no default workflow.

Remarks

Object classes can be accessed by using the VaultClassOperations interface.

The object class of a vault object is part of the object's metadata and it is stored in the object version as a property value. See the example below for resolving the object class for a vault object.

Object classes in M-Files Admin.

Example

Resolving the class of object (Visual Basic) Copy Code
' Identify the object.
Dim oObjVer As MFilesAPI.ObjVer
'...

' Get the value of class property.
Dim oPropertyValues As MFilesAPI.PropertyValues = oVault.ObjectPropertyOperations.GetProperties(oObjVer)
Dim oPropertyValue As MFilesAPI.PropertyValue = oPropertyValues.SearchForProperty( _
    MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefClass)

' As this is class property, the data type is always "Lookup value".
If oPropertyValue.TypedValue.DataType <> MFilesAPI.MFDataType.MFDatatypeLookup Then
    Throw New SystemException("Internal error")
End If

' The value of lookup item is the class id. Resolve the class object.
Dim iClassId As Integer = oPropertyValue.TypedValue.GetLookupID()
Dim oObjectClass As MFilesAPI.ObjectClass = oVault.ClassOperations.GetObjectClass(iClassId)

' Resolve the class name.
Dim szClassName As String = oObjectClass.Name

See Also

ObjectClass Members | ClassGroup Object


%%PageItemTitle%%

Clone Method
ObjectClass Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjectClass

See Also

ObjectClass Object | ObjectClass Members


%%PageItemTitle%%

AccessControlList Property
ObjectClass Object : AccessControlList Property

Glossary Item Box

Description

The ACL that defines the visibility and other permission settings of this object class. Also specifies who can attach objects to this class.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessControlList As AccessControlList

See Also

ObjectClass Object | ObjectClass Members


%%PageItemTitle%%

AdditionalClassInfo Property
ObjectClass Object : AdditionalClassInfo Property

Glossary Item Box

Description

The additional type-specific class features.

Property type

Read-only property

Syntax

Visual Basic
Public Property AdditionalClassInfo As AdditionalClassInfo

See Also

ObjectClass Object | ObjectClass Members


%%PageItemTitle%%

AssociatedPropertyDefs Property
ObjectClass Object : AssociatedPropertyDefs Property

Glossary Item Box

Description

The associated property definitions of the class.

Property type

Read-write property

Syntax

Visual Basic
Public Property AssociatedPropertyDefs As AssociatedPropertyDefs

See Also

ObjectClass Object | ObjectClass Members


%%PageItemTitle%%

AutomaticPermissionsForObjects Property
ObjectClass Object : AutomaticPermissionsForObjects Property

Glossary Item Box

Description

Specifies the automatic permissions for an object for which the user selects this item. If Nothing, no automatic permissions are defined.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutomaticPermissionsForObjects As AutomaticPermissions

Return Type

AutomaticPermissions structure describing the current automatic permission settings or null value (Nothing in Visual Basic) if no automatic permissions are specified.

See Also

ObjectClass Object | ObjectClass Members


%%PageItemTitle%%

DefaultClass Property
ObjectClass Object : DefaultClass Property

Glossary Item Box

Description

Specifies whether the object class is the default class of the object type.

Property type

Read-only property

Syntax

Visual Basic
Public Property DefaultClass As Boolean

See Also

ObjectClass Object | ObjectClass Members


%%PageItemTitle%%

ForceWorkflow Property
ObjectClass Object : ForceWorkflow Property

Glossary Item Box

Description

Specifies whether the use of the specified workflow is forced.

Property type

Read-write property

Syntax

Visual Basic
Public Property ForceWorkflow As Boolean

See Also

ObjectClass Object | ObjectClass Members


%%PageItemTitle%%

ID Property
ObjectClass Object : ID Property

Glossary Item Box

Description

The ID of the class.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

ObjectClass Object | ObjectClass Members


%%PageItemTitle%%

Name Property
ObjectClass Object : Name Property

Glossary Item Box

Description

The name of the class.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

ObjectClass Object | ObjectClass Members


%%PageItemTitle%%

NamePropertyDef Property
ObjectClass Object : NamePropertyDef Property

Glossary Item Box

Description

The ID of the property definition that represents the name of the document or other object.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamePropertyDef As Long

Remarks

The PropertyDef object of the name property can be accessed by using VaultPropertyDefOperations. The PropertyValue of the name property can be accessed by using VaultPropertyOperations or by fetching property values from the ObjectVersionAndProperties object.

See Also

ObjectClass Object | ObjectClass Members


%%PageItemTitle%%

ObjectType Property
ObjectClass Object : ObjectType Property

Glossary Item Box

Description

The object type with which this class is used.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectType As Long

See Also

ObjectClass Object | ObjectClass Members


%%PageItemTitle%%

Workflow Property
ObjectClass Object : Workflow Property

Glossary Item Box

Description

The default workflow of the class, or zero if there is no default workflow.

Property type

Read-write property

Syntax

Visual Basic
Public Property Workflow As Long

See Also

ObjectClass Object | ObjectClass Members


%%PageItemTitle%%

ObjectClassAdmin Object
Members See Also Send comments

Glossary Item Box

Description

The ObjectClassAdmin class represents an object class (for administrative operations).

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AdditionalClassInfo | The additional type-specific class features.
Public Property AssociatedPropertyDefs | The property definitions that are associated with the class.
Public Property AutomaticPermissionsForObjects | Specifies the automatic permissions for an object for which the user selects an item of this class. If Nothing, no automatic permissions are defined.
Public Property ForceWorkflow | Specifies whether the use of the workflow with this class is enforced.
Public Property ID | The ID of the class.
Public Property Name | The name of the class.
Public Property NamePropertyDef | The ID of the property definition that represents the name of the document or other object.
Public Property ObjectType | The object type with which this class is used.
Public Property Predefined | Specifies whether this is a predefined class (cannot be deleted, editing is restricted).
Public Property SemanticAliases | The semantic aliases of this class.
Public Property Workflow | The default workflow of the class, or zero if there is no default workflow.

See Also

ObjectClassAdmin Members


%%PageItemTitle%%

Clone Method
ObjectClassAdmin Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjectClassAdmin

See Also

ObjectClassAdmin Object | ObjectClassAdmin Members


%%PageItemTitle%%

AdditionalClassInfo Property
ObjectClassAdmin Object : AdditionalClassInfo Property

Glossary Item Box

Description

The additional type-specific class features.

Property type

Read-only property

Syntax

Visual Basic
Public Property AdditionalClassInfo As AdditionalClassInfo

See Also

ObjectClassAdmin Object | ObjectClassAdmin Members


%%PageItemTitle%%

AssociatedPropertyDefs Property
ObjectClassAdmin Object : AssociatedPropertyDefs Property

Glossary Item Box

Description

The property definitions that are associated with the class.

Property type

Read-write property

Syntax

Visual Basic
Public Property AssociatedPropertyDefs As AssociatedPropertyDefs

Remarks

A known issue causes this property to not behave as intended. Please use AssociatedPropertyDefs Property of the ObjectClass Object instead.

See Also

ObjectClassAdmin Object | ObjectClassAdmin Members


%%PageItemTitle%%

AutomaticPermissionsForObjects Property
ObjectClassAdmin Object : AutomaticPermissionsForObjects Property

Glossary Item Box

Description

Specifies the automatic permissions for an object for which the user selects an item of this class. If Nothing, no automatic permissions are defined.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutomaticPermissionsForObjects As AutomaticPermissions

Return Type

AutomaticPermissions structure describing the current automatic permission settings or null value (Nothing in Visual Basic) if no automatic permissions are specified.

See Also

ObjectClassAdmin Object | ObjectClassAdmin Members


%%PageItemTitle%%

ForceWorkflow Property
ObjectClassAdmin Object : ForceWorkflow Property

Glossary Item Box

Description

Specifies whether the use of the workflow with this class is enforced.

Property type

Read-write property

Syntax

Visual Basic
Public Property ForceWorkflow As Boolean

See Also

ObjectClassAdmin Object | ObjectClassAdmin Members


%%PageItemTitle%%

ID Property
ObjectClassAdmin Object : ID Property

Glossary Item Box

Description

The ID of the class.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

ObjectClassAdmin Object | ObjectClassAdmin Members


%%PageItemTitle%%

Name Property
ObjectClassAdmin Object : Name Property

Glossary Item Box

Description

The name of the class.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

ObjectClassAdmin Object | ObjectClassAdmin Members


%%PageItemTitle%%

NamePropertyDef Property
ObjectClassAdmin Object : NamePropertyDef Property

Glossary Item Box

Description

The ID of the property definition that represents the name of the document or other object.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamePropertyDef As Long

See Also

ObjectClassAdmin Object | ObjectClassAdmin Members


%%PageItemTitle%%

ObjectType Property
ObjectClassAdmin Object : ObjectType Property

Glossary Item Box

Description

The object type with which this class is used.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectType As Long

See Also

ObjectClassAdmin Object | ObjectClassAdmin Members


%%PageItemTitle%%

Predefined Property
ObjectClassAdmin Object : Predefined Property

Glossary Item Box

Description

Specifies whether this is a predefined class (cannot be deleted, editing is restricted).

Property type

Read-write property

Syntax

Visual Basic
Public Property Predefined As Boolean

See Also

ObjectClassAdmin Object | ObjectClassAdmin Members


%%PageItemTitle%%

SemanticAliases Property
ObjectClassAdmin Object : SemanticAliases Property

Glossary Item Box

Description

The semantic aliases of this class.

Property type

Read-write property

Syntax

Visual Basic
Public Property SemanticAliases As SemanticAliases

See Also

ObjectClassAdmin Object | ObjectClassAdmin Members


%%PageItemTitle%%

Workflow Property
ObjectClassAdmin Object : Workflow Property

Glossary Item Box

Description

The default workflow of the class, or zero if there is no default workflow.

Property type

Read-write property

Syntax

Visual Basic
Public Property Workflow As Long

See Also

ObjectClassAdmin Object | ObjectClassAdmin Members


%%PageItemTitle%%

ObjectClasses Collection
Members See Also Send comments

Glossary Item Box

Description

ObjectClassCollection is a collection of ObjectClass objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectClasses Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectClass
The new member to add.
ObjectClasses Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ObjectClass As ObjectClass _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectClass
The new member to add.

See Also

ObjectClasses Collection | ObjectClasses Members


%%PageItemTitle%%

Clone Method
ObjectClasses Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjectClasses

See Also

ObjectClasses Collection | ObjectClasses Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ObjectClasses Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ObjectClasses Collection | ObjectClasses Members


%%PageItemTitle%%

Count Property
ObjectClasses Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjectClasses Collection | ObjectClasses Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
ObjectClasses Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjectClass

Parameters

Index
Specifies the item's position in the collection.

See Also

ObjectClasses Collection | ObjectClasses Members


%%PageItemTitle%%

ObjectClassesAdmin Collection
Members See Also Send comments

Glossary Item Box

Description

ObjectClassesAdmin is a collection of ObjectClassAdmin objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectClassesAdmin Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectClassAdmin
The new member to add.
ObjectClassesAdmin Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ObjectClassAdmin As ObjectClassAdmin _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectClassAdmin
The new member to add.

See Also

ObjectClassesAdmin Collection | ObjectClassesAdmin Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ObjectClassesAdmin Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ObjectClassesAdmin Collection | ObjectClassesAdmin Members


%%PageItemTitle%%

Count Property
ObjectClassesAdmin Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjectClassesAdmin Collection | ObjectClassesAdmin Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
ObjectClassesAdmin Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjectClassAdmin

Parameters

Index
Specifies the item's position in the collection.

See Also

ObjectClassesAdmin Collection | ObjectClassesAdmin Members


%%PageItemTitle%%

ObjectCreationInfo Object
Members See Also Send comments

Glossary Item Box

Description

The ObjectCreationInfo class is used for specifying the initial state of the new metadata card.

Public Methods

Public Method GetDisableObjectCreation | Specifies whether the object creation is disabled.
Public Method GetExtension | Gets the file extension.
Public Method GetMetadataCardTitle | Gets the metadata card title.
Public Method GetObjectType | Gets the object type.
Public Method GetSelectableFileClasses | Gets the selectable file classes.
Public Method GetSelectedFileClass | Gets the selected file class for the new object.
Public Method GetSingleFileDocument | Specifies whether the single file document is selected.
Public Method GetSourceFiles | Gets all source files.
Public Method GetTemplate | Gets the selected template.
Public Method GetTitle | Gets the object title.
Public Method GetTitleAsText | Gets the title as text.
Public Method GetUseAsDefaults | Gets the state of Use as Defaults selection.
Public Method SetDisableObjectCreation | Prevents the creation of the object when the dialog box is closed.
Public Method SetExtension | Sets the initial file extension.
Public Method SetMetadataCardTitle | Sets the title for the metadata card.
Public Method SetObjectType | Sets the object type for the new object.
Public Method SetSelectableFileClasses | Sets the file classes available to the user when creating the new object.
Public Method SetSelectedFileClass | Sets the selected file class for the new object.
Public Method SetSingleFileDocument | Selects the single file document creation.
Public Method SetSourceFiles | Sets all source files.
Public Method SetTemplate | Selects the template object for the new object.
Public Method SetTitle | Sets an initial object title.
Public Method SetTitleAsDatatypeText | Sets the title as single-line text.
Public Method SetUseAsDefaults | Sets the state of Use as Defaults selection. This option is available in the metadata card when OkToAllButtonVisible Property is set to true.

Public Properties

Public Property DisallowTemplateSelection | Specifies whether the template selection user interface can be shown.
Public Property ExplicitObjectID | Specifies an explicit object ID for the new object. This information is used only when creating a shortcut. The value is typically -1.
Public Property IsObjectShortcut | Specifies whether the new object is a shortcut.
Public Property ObjectGUID | Specifies the Object GUID of the new object. This information is used only when creating a shortcut.
Public Property OkToAllButtonVisible | The visibility of Ok to All button.
Public Property SkipThisButtonVisible | The visibility of Skip This button.

Remarks

This class is used by the user interface methods to display the new object dialog box.

See Also

ObjectCreationInfo Members | ShowBasicNewObjectWindow Method | ShowNewObjectWindow Method


%%PageItemTitle%%

GetDisableObjectCreation Method
ObjectCreationInfo Object : GetDisableObjectCreation Method

Glossary Item Box

Description

Specifies whether the object creation is disabled.

Syntax

Visual Basic
Public Function GetDisableObjectCreation() As Boolean

Return Type

True if object creation is disabled.

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

GetExtension Method
ObjectCreationInfo Object : GetExtension Method

Glossary Item Box

Description

Gets the file extension.

Syntax

Visual Basic
Public Function GetExtension() As String

Return Type

The default extension for the new object.

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

GetMetadataCardTitle Method
ObjectCreationInfo Object : GetMetadataCardTitle Method

Glossary Item Box

Description

Gets the metadata card title.

Syntax

Visual Basic
Public Function GetMetadataCardTitle() As String

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

GetObjectType Method
ObjectCreationInfo Object : GetObjectType Method

Glossary Item Box

Description

Gets the object type.

Syntax

Visual Basic
Public Function GetObjectType() As Long

Return Type

The object type of the new object.

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

GetSelectableFileClasses Method
ObjectCreationInfo Object : GetSelectableFileClasses Method

Glossary Item Box

Description

Gets the selectable file classes.

Syntax

Visual Basic
Public Function GetSelectableFileClasses() As FileClasses

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

GetSelectedFileClass Method
ObjectCreationInfo Object : GetSelectedFileClass Method

Glossary Item Box

Description

Gets the selected file class for the new object.

Syntax

Visual Basic
Public Function GetSelectedFileClass() As FileClass

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

GetSingleFileDocument Method
ObjectCreationInfo Object : GetSingleFileDocument Method

Glossary Item Box

Description

Specifies whether the single file document is selected.

Syntax

Visual Basic
Public Function GetSingleFileDocument() As Boolean

Return Type

True if the single-file document radio button is selected by default.

Remarks

If the object is not a single-file document, it is a multi-file document.

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

GetSourceFiles Method
ObjectCreationInfo Object : GetSourceFiles Method

Glossary Item Box

Description

Gets all source files.

Syntax

Visual Basic
Public Function GetSourceFiles() As SourceObjectFiles

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

GetTemplate Method
ObjectCreationInfo Object : GetTemplate Method

Glossary Item Box

Description

Gets the selected template.

Syntax

Visual Basic
Public Function GetTemplate() As ObjVer

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

GetTitle Method
ObjectCreationInfo Object : GetTitle Method

Glossary Item Box

Description

Gets the object title.

Syntax

Visual Basic
Public Function GetTitle() As TypedValue

Return Type

The default title for the new object.

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

GetTitleAsText Method
ObjectCreationInfo Object : GetTitleAsText Method

Glossary Item Box

Description

Gets the title as text.

Syntax

Visual Basic
Public Function GetTitleAsText() As String

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

GetUseAsDefaults Method
ObjectCreationInfo Object : GetUseAsDefaults Method

Glossary Item Box

Description

Gets the state of Use as Defaults selection.

Syntax

Visual Basic
Public Function GetUseAsDefaults() As Boolean

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

SetDisableObjectCreation Method
Disable
True to prevent the creation of an object.
ObjectCreationInfo Object : SetDisableObjectCreation Method

Glossary Item Box

Description

Prevents the creation of the object when the dialog box is closed.

Syntax

Visual Basic
Public Sub SetDisableObjectCreation( _
   ByVal Disable As Boolean _
)

Parameters

Disable
True to prevent the creation of an object.

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

SetExtension Method
Extension
The extension for the new object.
Editable
True to allow the user to edit the settings in the metadata card.
ObjectCreationInfo Object : SetExtension Method

Glossary Item Box

Description

Sets the initial file extension.

Syntax

Visual Basic
Public Sub SetExtension( _
   ByVal Extension As String, _
   ByVal Editable As Boolean _
)

Parameters

Extension
The extension for the new object.
Editable
True to allow the user to edit the settings in the metadata card.

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

SetMetadataCardTitle Method
MetadataCardTitle
ObjectCreationInfo Object : SetMetadataCardTitle Method

Glossary Item Box

Description

Sets the title for the metadata card.

Syntax

Visual Basic
Public Sub SetMetadataCardTitle( _
   ByVal MetadataCardTitle As String _
)

Parameters

MetadataCardTitle

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

SetObjectType Method
ObjectType
Specifies the object type of the new object.
Editable
True to allow the user to edit the settings in the metadata card. Not supported.
ObjectCreationInfo Object : SetObjectType Method

Glossary Item Box

Description

Sets the object type for the new object.

Syntax

Visual Basic
Public Sub SetObjectType( _
   ByVal ObjectType As Long, _
   ByVal Editable As Boolean _
)

Parameters

ObjectType
Specifies the object type of the new object.
Editable
True to allow the user to edit the settings in the metadata card. Not supported.

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members | VaultObjectTypeOperations Object


%%PageItemTitle%%

SetSelectableFileClasses Method
FileClasses
ObjectCreationInfo Object : SetSelectableFileClasses Method

Glossary Item Box

Description

Sets the file classes available to the user when creating the new object.

Syntax

Visual Basic
Public Sub SetSelectableFileClasses( _
   ByVal FileClasses As FileClasses _
)

Parameters

FileClasses

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

SetSelectedFileClass Method
FileClass
Editable
ObjectCreationInfo Object : SetSelectedFileClass Method

Glossary Item Box

Description

Sets the selected file class for the new object.

Syntax

Visual Basic
Public Sub SetSelectedFileClass( _
   ByVal FileClass As FileClass, _
   ByVal Editable As Boolean _
)

Parameters

FileClass
Editable

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

SetSingleFileDocument Method
SingleFile
True to select the single-file document radio button.
Editable
True to allow the user to edit the settings in the metadata card.
ObjectCreationInfo Object : SetSingleFileDocument Method

Glossary Item Box

Description

Selects the single file document creation.

Syntax

Visual Basic
Public Sub SetSingleFileDocument( _
   ByVal SingleFile As Boolean, _
   ByVal Editable As Boolean _
)

Parameters

SingleFile
True to select the single-file document radio button.
Editable
True to allow the user to edit the settings in the metadata card.

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

SetSourceFiles Method
SourceFiles
ObjectCreationInfo Object : SetSourceFiles Method

Glossary Item Box

Description

Sets all source files.

Syntax

Visual Basic
Public Sub SetSourceFiles( _
   ByVal SourceFiles As SourceObjectFiles _
)

Parameters

SourceFiles

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

SetTemplate Method
Template
ObjectCreationInfo Object : SetTemplate Method

Glossary Item Box

Description

Selects the template object for the new object.

Syntax

Visual Basic
Public Sub SetTemplate( _
   ByVal Template As ObjVer _
)

Parameters

Template

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

SetTitle Method
Title
Specifies the default title for the new object.
Editable
True to allow the user to edit the settings in the metadata card.
ObjectCreationInfo Object : SetTitle Method

Glossary Item Box

Description

Sets an initial object title.

Syntax

Visual Basic
Public Sub SetTitle( _
   ByVal Title As TypedValue, _
   ByVal Editable As Boolean _
)

Parameters

Title
Specifies the default title for the new object.
Editable
True to allow the user to edit the settings in the metadata card.

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

SetTitleAsDatatypeText Method
Title
Editable
ObjectCreationInfo Object : SetTitleAsDatatypeText Method

Glossary Item Box

Description

Sets the title as single-line text.

Syntax

Visual Basic
Public Sub SetTitleAsDatatypeText( _
   ByVal Title As String, _
   ByVal Editable As Boolean _
)

Parameters

Title
Editable

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

SetUseAsDefaults Method
UseAsDefaults
If this parameter is True, the Use as Defaults checkbox is selected.
Editable
If this parameter is True, the Use as Defaults checkbox selection can be modified by the user.
ObjectCreationInfo Object : SetUseAsDefaults Method

Glossary Item Box

Description

Sets the state of Use as Defaults selection.

This option is available in the metadata card when OkToAllButtonVisible Property is set to true.

Syntax

Visual Basic
Public Sub SetUseAsDefaults( _
   ByVal UseAsDefaults As Boolean, _
   ByVal Editable As Boolean _
)

Parameters

UseAsDefaults
If this parameter is True, the Use as Defaults checkbox is selected.
Editable
If this parameter is True, the Use as Defaults checkbox selection can be modified by the user.

Remarks

It is the responsibility of the caller to implement the functionality required to support the Use as Defaults action in the metadata card. The user selection is received via the UseAsDefaults Property.

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

DisallowTemplateSelection Property
ObjectCreationInfo Object : DisallowTemplateSelection Property

Glossary Item Box

Description

Specifies whether the template selection user interface can be shown.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisallowTemplateSelection As Boolean

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

ExplicitObjectID Property
ObjectCreationInfo Object : ExplicitObjectID Property

Glossary Item Box

Description

Specifies an explicit object ID for the new object. This information is used only when creating a shortcut. The value is typically -1.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExplicitObjectID As Long

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

IsObjectShortcut Property
ObjectCreationInfo Object : IsObjectShortcut Property

Glossary Item Box

Description

Specifies whether the new object is a shortcut.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsObjectShortcut As Boolean

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

ObjectGUID Property
ObjectCreationInfo Object : ObjectGUID Property

Glossary Item Box

Description

Specifies the Object GUID of the new object. This information is used only when creating a shortcut.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectGUID As String

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

OkToAllButtonVisible Property
ObjectCreationInfo Object : OkToAllButtonVisible Property

Glossary Item Box

Description

The visibility of Ok to All button.

Property type

Read-write property

Syntax

Visual Basic
Public Property OkToAllButtonVisible As Boolean

Remarks

It is the responsibility of the caller to implement the functionality required to support the Ok to All action in the metadata card. The user selection is received via the Result Property

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

SkipThisButtonVisible Property
ObjectCreationInfo Object : SkipThisButtonVisible Property

Glossary Item Box

Description

The visibility of Skip This button.

Property type

Read-write property

Syntax

Visual Basic
Public Property SkipThisButtonVisible As Boolean

Remarks

It is the responsibility of the caller to implement the functionality required to support the Skip This action in the metadata card. The user selection is received via the Result Property

See Also

ObjectCreationInfo Object | ObjectCreationInfo Members


%%PageItemTitle%%

ObjectFile Object
Members See Also Send comments

Glossary Item Box

Description

The ObjectFile class represents an object file.

Public Methods

Public Method GetNameForFileSystem | Gets the name of the file in a format that is compatible with file systems, such as NTFS. Characters that are illegal in file-system use are encoded.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property ChangeTimeUtc | The time in UTC when the file was last written to or its attributes were changed.
Public Property CreationTimeUtc | The time in UTC when the file was originally created.
Public Property Extension | The extension of the file.
Public Property ExternalRepositoryFileID | The external repository identifier of the file.
Public Property ExternalRepositoryFileVersionID | The external repository version identifier of the file.
Public Property FileGUID | The file GUID as a string.
Public Property FileVer | File ID and version.
Public Property ID | The ID of the file.
Public Property LastAccessTimeUtc | The time in UTC when the file was last accessed (e.g., read).
Public Property LastWriteTimeUtc | The time in UTC when the file was last written to.
Public Property LogicalSize | The logical size of the file.
Public Property LogicalSize_32bit | The logical size of the file (uses 32-bit arguments).
Public Property LogicalSizeEx | The logical size of the file.
Public Property Title | The title of the file.
Public Property Version | The version number of the file.
Public Property VolatileContent | True if the physical file content is volatile, meaning that the physical content can change without the version number changing as long as the logical content stays the same.

Remarks

The ObjectFile class provides a simple set of properties for getting information on an object file. Each object in M-Files can have zero or more object files. Single-file objects have only one file each, whereas multi-file objects can contain zero, one or multiple files.

Use the ObjectVersion object to access the files of an object. You can also use the VaultObjectFileOperations interface to access files and perform object file-related operations.

A file of a multi-file document as seen in the listing area of M-Files Desktop.

See Also

ObjectFile Members


%%PageItemTitle%%

GetNameForFileSystem Method
ObjectFile Object : GetNameForFileSystem Method

Glossary Item Box

Description

Gets the name of the file in a format that is compatible with file systems, such as NTFS. Characters that are illegal in file-system use are encoded.

Syntax

Visual Basic
Public Function GetNameForFileSystem() As String

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

ToJSON Method
ObjectFile Object : ToJSON Method

Glossary Item Box

Description

Converts the data structure to a JSON string.

Syntax

Visual Basic
Public Function ToJSON() As String

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

ChangeTimeUtc Property
ObjectFile Object : ChangeTimeUtc Property

Glossary Item Box

Description

The time in UTC when the file was last written to or its attributes were changed.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChangeTimeUtc As Date

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

CreationTimeUtc Property
ObjectFile Object : CreationTimeUtc Property

Glossary Item Box

Description

The time in UTC when the file was originally created.

Property type

Read-only property

Syntax

Visual Basic
Public Property CreationTimeUtc As Date

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

Extension Property
ObjectFile Object : Extension Property

Glossary Item Box

Description

The extension of the file.

Property type

Read-only property

Syntax

Visual Basic
Public Property Extension As String

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

ExternalRepositoryFileID Property
ObjectFile Object : ExternalRepositoryFileID Property

Glossary Item Box

Description

The external repository identifier of the file.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExternalRepositoryFileID As String

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

ExternalRepositoryFileVersionID Property
ObjectFile Object : ExternalRepositoryFileVersionID Property

Glossary Item Box

Description

The external repository version identifier of the file.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExternalRepositoryFileVersionID As String

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

FileGUID Property
ObjectFile Object : FileGUID Property

Glossary Item Box

Description

The file GUID as a string.

Property type

Read-only property

Syntax

Visual Basic
Public Property FileGUID As String

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

FileVer Property
ObjectFile Object : FileVer Property

Glossary Item Box

Description

File ID and version.

Property type

Read-only property

Syntax

Visual Basic
Public Property FileVer As FileVer

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

ID Property
ObjectFile Object : ID Property

Glossary Item Box

Description

The ID of the file.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID As Long

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

LastAccessTimeUtc Property
ObjectFile Object : LastAccessTimeUtc Property

Glossary Item Box

Description

The time in UTC when the file was last accessed (e.g., read).

Property type

Read-only property

Syntax

Visual Basic
Public Property LastAccessTimeUtc As Date

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

LastWriteTimeUtc Property
ObjectFile Object : LastWriteTimeUtc Property

Glossary Item Box

Description

The time in UTC when the file was last written to.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastWriteTimeUtc As Date

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

LogicalSize Property
ObjectFile Object : LogicalSize Property

Glossary Item Box

Description

The logical size of the file.

Property type

Read-only property

Syntax

Visual Basic
Public Property LogicalSize As Unknown

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

LogicalSize_32bit Property
ObjectFile Object : LogicalSize_32bit Property

Glossary Item Box

Description

The logical size of the file (uses 32-bit arguments).

Property type

Read-only property

Syntax

Visual Basic
Public Property LogicalSize_32bit As Long

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

LogicalSizeEx Property
ObjectFile Object : LogicalSizeEx Property

Glossary Item Box

Description

The logical size of the file.

Property type

Read-only property

Syntax

Visual Basic
Public Property LogicalSizeEx As FileSize

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

Title Property
ObjectFile Object : Title Property

Glossary Item Box

Description

The title of the file.

Property type

Read-only property

Syntax

Visual Basic
Public Property Title As String

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

Version Property
ObjectFile Object : Version Property

Glossary Item Box

Description

The version number of the file.

Property type

Read-only property

Syntax

Visual Basic
Public Property Version As Long

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

VolatileContent Property
ObjectFile Object : VolatileContent Property

Glossary Item Box

Description

True if the physical file content is volatile, meaning that the physical content can change without the version number changing as long as the logical content stays the same.

Property type

Read-only property

Syntax

Visual Basic
Public Property VolatileContent As Boolean

Remarks

The file content is guaranteed to stay physically consistent within a single download session only.

See Also

ObjectFile Object | ObjectFile Members


%%PageItemTitle%%

ObjectFileAndObjVer Object
Members See Also Send comments

Glossary Item Box

Description

The ObjectFileAndObjVer class represents a reference to an object file and an object version.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property ObjectFile | Specifies the object file.
Public Property ObjVer | Specifies the object version.

See Also

ObjectFileAndObjVer Members


%%PageItemTitle%%

Clone Method
ObjectFileAndObjVer Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjectFileAndObjVer

See Also

ObjectFileAndObjVer Object | ObjectFileAndObjVer Members


%%PageItemTitle%%

ToJSON Method
ObjectFileAndObjVer Object : ToJSON Method

Glossary Item Box

Description

Converts the data structure to a JSON string.

Syntax

Visual Basic
Public Function ToJSON() As String

See Also

ObjectFileAndObjVer Object | ObjectFileAndObjVer Members


%%PageItemTitle%%

ObjectFile Property
ObjectFileAndObjVer Object : ObjectFile Property

Glossary Item Box

Description

Specifies the object file.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectFile As ObjectFile

See Also

ObjectFileAndObjVer Object | ObjectFileAndObjVer Members


%%PageItemTitle%%

ObjVer Property
ObjectFileAndObjVer Object : ObjVer Property

Glossary Item Box

Description

Specifies the object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjVer As ObjVer

See Also

ObjectFileAndObjVer Object | ObjectFileAndObjVer Members


%%PageItemTitle%%

ObjectFileAndObjVerOfMultipleFiles Collection
Members See Also Send comments

Glossary Item Box

Description

ObjectFileAndObjVerOfMultipleFiles is a collection of ObjectFileAndObjVer objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectFileAndObjVerOfMultipleFiles Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectFileAndObjVer
The new member to add.
ObjectFileAndObjVerOfMultipleFiles Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ObjectFileAndObjVer As ObjectFileAndObjVer _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectFileAndObjVer
The new member to add.

See Also

ObjectFileAndObjVerOfMultipleFiles Collection | ObjectFileAndObjVerOfMultipleFiles Members


%%PageItemTitle%%

Clone Method
ObjectFileAndObjVerOfMultipleFiles Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjectFileAndObjVerOfMultipleFiles

See Also

ObjectFileAndObjVerOfMultipleFiles Collection | ObjectFileAndObjVerOfMultipleFiles Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ObjectFileAndObjVerOfMultipleFiles Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ObjectFileAndObjVerOfMultipleFiles Collection | ObjectFileAndObjVerOfMultipleFiles Members


%%PageItemTitle%%

Count Property
ObjectFileAndObjVerOfMultipleFiles Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjectFileAndObjVerOfMultipleFiles Collection | ObjectFileAndObjVerOfMultipleFiles Members


%%PageItemTitle%%

Item Property
Index
ObjectFileAndObjVerOfMultipleFiles Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjectFileAndObjVer

Parameters

Index

See Also

ObjectFileAndObjVerOfMultipleFiles Collection | ObjectFileAndObjVerOfMultipleFiles Members


%%PageItemTitle%%

ObjectFiles Collection
Members See Also Send comments

Glossary Item Box

Description

ObjectFiles is a collection of ObjectFile objects.

Public Methods

Public Method GetObjectFileByNameForFileSystem | Gets object file by its name in file system.
Public Method GetObjectFileIndexByNameForFileSystem | Gets object file index by its name in file system. -1 indicates that item was not found.
Public Method Sort | Sorts the objects in this collection using the given comparator.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectFiles Members | ObjectFile Object


%%PageItemTitle%%

GetObjectFileByNameForFileSystem Method
NameForFileSystem
ObjectFiles Collection : GetObjectFileByNameForFileSystem Method

Glossary Item Box

Description

Gets object file by its name in file system.

Syntax

Visual Basic
Public Function GetObjectFileByNameForFileSystem( _
   ByVal NameForFileSystem As String _
) As ObjectFile

Parameters

NameForFileSystem

See Also

ObjectFiles Collection | ObjectFiles Members


%%PageItemTitle%%

GetObjectFileIndexByNameForFileSystem Method
NameForFileSystem
ObjectFiles Collection : GetObjectFileIndexByNameForFileSystem Method

Glossary Item Box

Description

Gets object file index by its name in file system. -1 indicates that item was not found.

Syntax

Visual Basic
Public Function GetObjectFileIndexByNameForFileSystem( _
   ByVal NameForFileSystem As String _
) As Long

Parameters

NameForFileSystem

See Also

ObjectFiles Collection | ObjectFiles Members


%%PageItemTitle%%

Sort Method
ObjectFileComparer
A user-defined comparer object.
ObjectFiles Collection : Sort Method

Glossary Item Box

Description

Sorts the objects in this collection using the given comparator.

Syntax

Visual Basic
Public Sub Sort( _
   ByVal ObjectFileComparer As IObjectFileComparer _
)

Parameters

ObjectFileComparer
A user-defined comparer object.

See Also

ObjectFiles Collection | ObjectFiles Members


%%PageItemTitle%%

ToJSON Method
ObjectFiles Collection : ToJSON Method

Glossary Item Box

Description

Converts the data structure to a JSON string.

Syntax

Visual Basic
Public Function ToJSON() As String

See Also

ObjectFiles Collection | ObjectFiles Members


%%PageItemTitle%%

Count Property
ObjectFiles Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjectFiles Collection | ObjectFiles Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
ObjectFiles Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjectFile

Parameters

Index
Specifies the item's position in the collection.

See Also

ObjectFiles Collection | ObjectFiles Members


%%PageItemTitle%%

ObjectSearchResults Collection
Members See Also Send comments

Glossary Item Box

Description

ObjectSearchResults is a collection of search results represented by ObjectVersion objects.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetAsObjectVersions | Returns the results as an object versions collection. Creates a copy of the contents of this collection.
Public Method GetScoreOfObject | Gets the search result score of the specified object.
Public Method ScoreAt | Gets the search result score of the object at the specified index.
Public Method Sort | Sorts the objects in this collection using the given comparator.
Public Method SortByScore | Sorts the search results in this collection by their score.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.
Public Property MoreResults | Specifies whether the number of search results returned was truncated.

Remarks

The collection object returned by various object-searching methods.

See Also

ObjectSearchResults Members


%%PageItemTitle%%

Clone Method
ObjectSearchResults Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjectSearchResults

See Also

ObjectSearchResults Collection | ObjectSearchResults Members


%%PageItemTitle%%

GetAsObjectVersions Method
ObjectSearchResults Collection : GetAsObjectVersions Method

Glossary Item Box

Description

Returns the results as an object versions collection. Creates a copy of the contents of this collection.

Syntax

Visual Basic
Public Function GetAsObjectVersions() As ObjectVersions

See Also

ObjectSearchResults Collection | ObjectSearchResults Members


%%PageItemTitle%%

GetScoreOfObject Method
ObjVer
ObjectSearchResults Collection : GetScoreOfObject Method

Glossary Item Box

Description

Gets the search result score of the specified object.

Syntax

Visual Basic
Public Function GetScoreOfObject( _
   ByVal ObjVer As ObjVer _
) As Long

Parameters

ObjVer

See Also

ObjectSearchResults Collection | ObjectSearchResults Members


%%PageItemTitle%%

ScoreAt Method
Index
ObjectSearchResults Collection : ScoreAt Method

Glossary Item Box

Description

Gets the search result score of the object at the specified index.

Syntax

Visual Basic
Public Function ScoreAt( _
   ByVal Index As Long _
) As Long

Parameters

Index

See Also

ObjectSearchResults Collection | ObjectSearchResults Members


%%PageItemTitle%%

Sort Method
ObjectComparer
A user-defined comparer object.
ObjectSearchResults Collection : Sort Method

Glossary Item Box

Description

Sorts the objects in this collection using the given comparator.

Syntax

Visual Basic
Public Sub Sort( _
   ByVal ObjectComparer As IObjectComparer _
)

Parameters

ObjectComparer
A user-defined comparer object.

See Also

ObjectSearchResults Collection | ObjectSearchResults Members


%%PageItemTitle%%

SortByScore Method
Ascending
ObjectSearchResults Collection : SortByScore Method

Glossary Item Box

Description

Sorts the search results in this collection by their score.

Syntax

Visual Basic
Public Sub SortByScore( _
   Optional ByVal Ascending As Boolean = False _
)

Parameters

Ascending

See Also

ObjectSearchResults Collection | ObjectSearchResults Members


%%PageItemTitle%%

Count Property
ObjectSearchResults Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjectSearchResults Collection | ObjectSearchResults Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
ObjectSearchResults Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjectVersion

Parameters

Index
Specifies the item's position in the collection.

See Also

ObjectSearchResults Collection | ObjectSearchResults Members


%%PageItemTitle%%

MoreResults Property
ObjectSearchResults Collection : MoreResults Property

Glossary Item Box

Description

Specifies whether the number of search results returned was truncated.

Property type

Read-only property

Syntax

Visual Basic
Public Property MoreResults As Boolean

See Also

ObjectSearchResults Collection | ObjectSearchResults Members


%%PageItemTitle%%

ObjectTypeTargetForBrowsing Object
Members See Also Send comments

Glossary Item Box

Description

The ObjectTypeTargetForBrowsing class represents the target object for showing objects related to another object.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property TargetObjectType | Target object type.
Public Property ViewCollection | Target view collection ID under built-in views.

Remarks

This class is used to define object types that can be browsed to follow object references. It also defines the view in which the browsed objects are displayed.

Single object target for browsing (highlighted with the green rectangle) as seen in M-Files Admin.

See Also

ObjectTypeTargetForBrowsing Members


%%PageItemTitle%%

Clone Method
ObjectTypeTargetForBrowsing Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjectTypeTargetForBrowsing

See Also

ObjectTypeTargetForBrowsing Object | ObjectTypeTargetForBrowsing Members


%%PageItemTitle%%

TargetObjectType Property
ObjectTypeTargetForBrowsing Object : TargetObjectType Property

Glossary Item Box

Description

Target object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetObjectType As Long

See Also

ObjectTypeTargetForBrowsing Object | ObjectTypeTargetForBrowsing Members


%%PageItemTitle%%

ViewCollection Property
ObjectTypeTargetForBrowsing Object : ViewCollection Property

Glossary Item Box

Description

Target view collection ID under built-in views.

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewCollection As Long

See Also

ObjectTypeTargetForBrowsing Object | ObjectTypeTargetForBrowsing Members


%%PageItemTitle%%

ObjectTypeTargetsForBrowsing Collection
Members See Also Send comments

Glossary Item Box

Description

ObjectTypeTargetsForBrowsing is a collection of ObjectTypeTargetForBrowsing objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectTypeTargetsForBrowsing Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectTypeTargetForBrowsing
The new member to add.
ObjectTypeTargetsForBrowsing Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ObjectTypeTargetForBrowsing As ObjectTypeTargetForBrowsing _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectTypeTargetForBrowsing
The new member to add.

See Also

ObjectTypeTargetsForBrowsing Collection | ObjectTypeTargetsForBrowsing Members


%%PageItemTitle%%

Clone Method
ObjectTypeTargetsForBrowsing Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjectTypeTargetsForBrowsing

See Also

ObjectTypeTargetsForBrowsing Collection | ObjectTypeTargetsForBrowsing Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ObjectTypeTargetsForBrowsing Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ObjectTypeTargetsForBrowsing Collection | ObjectTypeTargetsForBrowsing Members


%%PageItemTitle%%

Count Property
ObjectTypeTargetsForBrowsing Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjectTypeTargetsForBrowsing Collection | ObjectTypeTargetsForBrowsing Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
ObjectTypeTargetsForBrowsing Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjectTypeTargetForBrowsing

Parameters

Index
Specifies the item's position in the collection.

See Also

ObjectTypeTargetsForBrowsing Collection | ObjectTypeTargetsForBrowsing Members


%%PageItemTitle%%

ObjectVersion Object
Members See Also Send comments

Glossary Item Box

Description

The ObjectVersionData class represents object version data.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CompareObjectVersionEx | Compares the object version information of this object to that of another one.
Public Method GetNameForFileSystem | Gets the name of the object version in a format that is compatible with file systems, such as NTFS. Characters that are illegal in file-system use are encoded.
Public Method GetNameForFileSystemEx | Gets the name of the object version in a format that is compatible with file systems, such as NTFS. Characters that are illegal in file-system use are encoded.

Public Properties

Public Property AccessedByMeUtc | The last time the object was accessed by the current user, in UTC. Undefined if IsAccessedByMeValid is false.
Public Property AssociatedFolderID | The ID of an associated folder.
Public Property BaseProperties | The base properties of the object version.
Public Property CheckedOutAtUtc | The time in UTC when the object was checked out.
Public Property CheckedOutTo | The user ID to which the object has been checked out.
Public Property CheckedOutToHostName | The computer name to which the object has been checked out.
Public Property CheckedOutToUserName | The username to which the object has been checked out.
Public Property CheckedOutVersion | The identifier of the checked-out version of the object.
Public Property Class | The class of the object version.
Public Property CreatedUtc | The time in UTC when the object version was created.
Public Property CurrentUser | The ID of the current user.
Public Property Deleted | Specifies whether the state of the object is deleted.
Public Property DisplayID | The display ID of the object. This may differ from the numeric internal ID.
Public Property DisplayIDAvailable | Specifies whether the display ID is available.
Public Property Files | The files of the object version.
Public Property FilesCount | The number of files that the object version contains.
Public Property HasAssignments | Specifies whether relationships from one or more assignments to this object exist.
Public Property HasSharedFiles | Specifies whether the object has shared files.
Public Property HostName | The host name of the current session.
Public Property IconID | The ID of the object icon.
Public Property IsAccessedByMeValid | True when the value of AccessedByMeUtc is valid.
Public Property IsObjectConflict | Specifies whether the object is a conflict.
Public Property IsObjectShortcut | Specifies whether the object is a shortcut.
Public Property LastModifiedUtc | The time in UTC when the object version was last modified.
Public Property LatestCheckedInObjVerVersion | The latest checked-in object version.
Public Property LatestCheckedInVersion | The latest object version that is checked in, or zero if the object has no checked-in version.
Public Property LatestCheckedInVersionOrCheckedOutVersion | Specifies whether this object version is either the latest checked-in version of the object, or the checked-out version of the object.
Public Property ObjectCapabilityFlags | Bit flags that describe the capabilities of an object.
Public Property ObjectCheckedOut | Specifies whether the object is checked out to any user on any computer.
Public Property ObjectCheckedOutToThisUserOnAnyComputer | Specifies whether the object is checked out to the current user on any computer.
Public Property ObjectCheckedOutToThisUserOnThisComputer | Specifies whether the object is checked out to the current user on this computer.
Public Property ObjectFlags | Specifies the object flags.
Public Property ObjectGUID | The object GUID as a string.
Public Property ObjectVersionFlags | Bit flags that provide additional information on the object version.
Public Property ObjVer | The object version identifier as an ObjVer object.
Public Property OriginalObjID | The ObjID of the object in the vault in which the object was originally created.
Public Property OriginalVaultGUID | The GUID of the vault in which the object was originally created.
Public Property SingleFile | Specifies whether the object version is a single-file object.
Public Property ThisVersionCheckedOut | Specifies whether this object version is checked out.
Public Property ThisVersionLatestToThisUser | Specifies whether this object version is the latest version from the current user's perspective.
Public Property Title | The title of the object version.
Public Property VersionGUID | The version GUID as a string.
Public Property VisibleAfterOperation | Specifies whether this object version is visible after the operation.

Remarks

This class is for retrieving information on an object version and the whole object. Some values are specific for the object version whose identifier can be accessed by using the ObjVer property. Other values reflect object-level information.

The ObjectVersion object is encapsulated in the ObjectVersionAndProperties object.

See Also

ObjectVersion Members


%%PageItemTitle%%

Clone Method
ObjectVersion Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjectVersion

Return Type

Returns the copied object version data.

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

CompareObjectVersionEx Method
pIObjectVersion
The object version to compare to.
ObjectVersion Object : CompareObjectVersionEx Method

Glossary Item Box

Description

Compares the object version information of this object to that of another one.

Syntax

Visual Basic
Public Function CompareObjectVersionEx( _
   ByVal pIObjectVersion As ObjectVersion _
) As Boolean

Parameters

pIObjectVersion
The object version to compare to.

Remarks

Supported in M-Files 19.4.7683.3 and later.

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

GetNameForFileSystem Method
IncludeID
If this parameter is True, the returned name includes the object ID.
ObjectVersion Object : GetNameForFileSystem Method

Glossary Item Box

Description

Gets the name of the object version in a format that is compatible with file systems, such as NTFS. Characters that are illegal in file-system use are encoded.

Syntax

Visual Basic
Public Function GetNameForFileSystem( _
   Optional ByVal IncludeID As Boolean = True _
) As String

Parameters

IncludeID
If this parameter is True, the returned name includes the object ID.

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

GetNameForFileSystemEx Method
IncludeID
If this parameter is True, the returned name includes the object ID.
UseOriginalID
Determines whether to use the original or internal ID for the object.
ObjectVersion Object : GetNameForFileSystemEx Method

Glossary Item Box

Description

Gets the name of the object version in a format that is compatible with file systems, such as NTFS. Characters that are illegal in file-system use are encoded.

Syntax

Visual Basic
Public Function GetNameForFileSystemEx( _
   Optional ByVal IncludeID As Boolean = True, _
   Optional ByVal UseOriginalID As Boolean = False _
) As String

Parameters

IncludeID
If this parameter is True, the returned name includes the object ID.
UseOriginalID
Determines whether to use the original or internal ID for the object.

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

AccessedByMeUtc Property
ObjectVersion Object : AccessedByMeUtc Property

Glossary Item Box

Description

The last time the object was accessed by the current user, in UTC. Undefined if IsAccessedByMeValid is false.

Property type

Read-only property

Syntax

Visual Basic
Public Property AccessedByMeUtc As Date

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

AssociatedFolderID Property
ObjectVersion Object : AssociatedFolderID Property

Glossary Item Box

Description

The ID of an associated folder.

Property type

Read-only property

Syntax

Visual Basic
Public Property AssociatedFolderID As FolderID

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

BaseProperties Property
ObjectVersion Object : BaseProperties Property

Glossary Item Box

Description

The base properties of the object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property BaseProperties As PropertyValues

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

CheckedOutAtUtc Property
ObjectVersion Object : CheckedOutAtUtc Property

Glossary Item Box

Description

The time in UTC when the object was checked out.

Property type

Read-only property

Syntax

Visual Basic
Public Property CheckedOutAtUtc As Date

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

CheckedOutTo Property
ObjectVersion Object : CheckedOutTo Property

Glossary Item Box

Description

The user ID to which the object has been checked out.

Property type

Read-only property

Syntax

Visual Basic
Public Property CheckedOutTo As Long

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

CheckedOutToHostName Property
ObjectVersion Object : CheckedOutToHostName Property

Glossary Item Box

Description

The computer name to which the object has been checked out.

Property type

Read-only property

Syntax

Visual Basic
Public Property CheckedOutToHostName As String

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

CheckedOutToUserName Property
ObjectVersion Object : CheckedOutToUserName Property

Glossary Item Box

Description

The username to which the object has been checked out.

Property type

Read-only property

Syntax

Visual Basic
Public Property CheckedOutToUserName As String

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

CheckedOutVersion Property
ObjectVersion Object : CheckedOutVersion Property

Glossary Item Box

Description

The identifier of the checked-out version of the object.

Property type

Read-only property

Syntax

Visual Basic
Public Property CheckedOutVersion As Long

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

Class Property
ObjectVersion Object : Class Property

Glossary Item Box

Description

The class of the object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property Class As Long

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

CreatedUtc Property
ObjectVersion Object : CreatedUtc Property

Glossary Item Box

Description

The time in UTC when the object version was created.

Property type

Read-only property

Syntax

Visual Basic
Public Property CreatedUtc As Date

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

CurrentUser Property
ObjectVersion Object : CurrentUser Property

Glossary Item Box

Description

The ID of the current user.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentUser As Long

Remarks

Supported in M-Files 19.4.7683.3 and later.

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

Deleted Property
ObjectVersion Object : Deleted Property

Glossary Item Box

Description

Specifies whether the state of the object is deleted.

Property type

Read-only property

Syntax

Visual Basic
Public Property Deleted As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

DisplayID Property
ObjectVersion Object : DisplayID Property

Glossary Item Box

Description

The display ID of the object. This may differ from the numeric internal ID.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayID As String

Remarks

If the object is imported from an external database, the display ID represents the object's ID in the external database. The display ID is used as the object ID in the user interface, although internally the object is referred to by using its own ID.

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

DisplayIDAvailable Property
ObjectVersion Object : DisplayIDAvailable Property

Glossary Item Box

Description

Specifies whether the display ID is available.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayIDAvailable As Boolean

Remarks

If the object is imported from an external database, the display ID represents the object's ID in the external database. The display ID is used as the object ID in the user interface, although internally object is referred to by using its own ID.

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

Files Property
ObjectVersion Object : Files Property

Glossary Item Box

Description

The files of the object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property Files As ObjectFiles

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

FilesCount Property
ObjectVersion Object : FilesCount Property

Glossary Item Box

Description

The number of files that the object version contains.

Property type

Read-only property

Syntax

Visual Basic
Public Property FilesCount As Long

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

HasAssignments Property
ObjectVersion Object : HasAssignments Property

Glossary Item Box

Description

Specifies whether relationships from one or more assignments to this object exist.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasAssignments As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

HasSharedFiles Property
ObjectVersion Object : HasSharedFiles Property

Glossary Item Box

Description

Specifies whether the object has shared files.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasSharedFiles As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

HostName Property
ObjectVersion Object : HostName Property

Glossary Item Box

Description

The host name of the current session.

Property type

Read-only property

Syntax

Visual Basic
Public Property HostName As String

Remarks

Supported in M-Files 19.4.7683.3 and later.

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

IconID Property
ObjectVersion Object : IconID Property

Glossary Item Box

Description

The ID of the object icon.

Property type

Read-only property

Syntax

Visual Basic
Public Property IconID As String

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

IsAccessedByMeValid Property
ObjectVersion Object : IsAccessedByMeValid Property

Glossary Item Box

Description

True when the value of AccessedByMeUtc is valid.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsAccessedByMeValid As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

IsObjectConflict Property
ObjectVersion Object : IsObjectConflict Property

Glossary Item Box

Description

Specifies whether the object is a conflict.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsObjectConflict As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

IsObjectShortcut Property
ObjectVersion Object : IsObjectShortcut Property

Glossary Item Box

Description

Specifies whether the object is a shortcut.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsObjectShortcut As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

LastModifiedUtc Property
ObjectVersion Object : LastModifiedUtc Property

Glossary Item Box

Description

The time in UTC when the object version was last modified.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastModifiedUtc As Date

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

LatestCheckedInObjVerVersion Property
ObjectVersion Object : LatestCheckedInObjVerVersion Property

Glossary Item Box

Description

The latest checked-in object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property LatestCheckedInObjVerVersion As ObjVerVersion

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

LatestCheckedInVersion Property
ObjectVersion Object : LatestCheckedInVersion Property

Glossary Item Box

Description

The latest object version that is checked in, or zero if the object has no checked-in version.

Property type

Read-only property

Syntax

Visual Basic
Public Property LatestCheckedInVersion As Long

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

LatestCheckedInVersionOrCheckedOutVersion Property
ObjectVersion Object : LatestCheckedInVersionOrCheckedOutVersion Property

Glossary Item Box

Description

Specifies whether this object version is either the latest checked-in version of the object, or the checked-out version of the object.

Property type

Read-only property

Syntax

Visual Basic
Public Property LatestCheckedInVersionOrCheckedOutVersion As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

ObjectCapabilityFlags Property
ObjectVersion Object : ObjectCapabilityFlags Property

Glossary Item Box

Description

Bit flags that describe the capabilities of an object.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectCapabilityFlags As MFObjectCapabilityFlag

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

ObjectCheckedOut Property
ObjectVersion Object : ObjectCheckedOut Property

Glossary Item Box

Description

Specifies whether the object is checked out to any user on any computer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectCheckedOut As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

ObjectCheckedOutToThisUserOnAnyComputer Property
ObjectVersion Object : ObjectCheckedOutToThisUserOnAnyComputer Property

Glossary Item Box

Description

Specifies whether the object is checked out to the current user on any computer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectCheckedOutToThisUserOnAnyComputer As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

ObjectCheckedOutToThisUserOnThisComputer Property
ObjectVersion Object : ObjectCheckedOutToThisUserOnThisComputer Property

Glossary Item Box

Description

Specifies whether the object is checked out to the current user on this computer.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectCheckedOutToThisUserOnThisComputer As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

ObjectFlags Property
ObjectVersion Object : ObjectFlags Property

Glossary Item Box

Description

Specifies the object flags.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectFlags As MFSpecialObjectFlag

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

ObjectGUID Property
ObjectVersion Object : ObjectGUID Property

Glossary Item Box

Description

The object GUID as a string.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectGUID As String

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

ObjectVersionFlags Property
ObjectVersion Object : ObjectVersionFlags Property

Glossary Item Box

Description

Bit flags that provide additional information on the object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectVersionFlags As MFObjectVersionFlag

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

ObjVer Property
ObjectVersion Object : ObjVer Property

Glossary Item Box

Description

The object version identifier as an ObjVer object.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjVer As ObjVer

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

OriginalObjID Property
ObjectVersion Object : OriginalObjID Property

Glossary Item Box

Description

The ObjID of the object in the vault in which the object was originally created.

Property type

Read-only property

Syntax

Visual Basic
Public Property OriginalObjID As ObjID

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

OriginalVaultGUID Property
ObjectVersion Object : OriginalVaultGUID Property

Glossary Item Box

Description

The GUID of the vault in which the object was originally created.

Property type

Read-only property

Syntax

Visual Basic
Public Property OriginalVaultGUID As String

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

SingleFile Property
ObjectVersion Object : SingleFile Property

Glossary Item Box

Description

Specifies whether the object version is a single-file object.

Property type

Read-only property

Syntax

Visual Basic
Public Property SingleFile As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

ThisVersionCheckedOut Property
See Also Example Send comments
ObjectVersion Object : ThisVersionCheckedOut Property

Glossary Item Box

Description

Specifies whether this object version is checked out.

Property type

Read-only property

Syntax

Visual Basic
Public Property ThisVersionCheckedOut As Boolean

Example

Resolve if this object version is checked out for current user (Visual Basic) Copy Code
' Identify the object.
Dim oObjVer As MFilesAPI.ObjVer
'...

' Get the version data and check if the object version is checked out. If the version is checked out, it must be
' checked out for current user -- otherwise the version wouldn't be visible for the user.
Dim oObjectVersionAndProperties As MFilesAPI.ObjectVersionAndProperties = _
    oVault.ObjectOperations.GetObjectVersionAndProperties(oObjVer)

If oObjectVersionAndProperties.VersionData().ThisVersionCheckedOut() Then
'     This object is checked out for current user.
End If

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

ThisVersionLatestToThisUser Property
ObjectVersion Object : ThisVersionLatestToThisUser Property

Glossary Item Box

Description

Specifies whether this object version is the latest version from the current user's perspective.

Property type

Read-only property

Syntax

Visual Basic
Public Property ThisVersionLatestToThisUser As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

Title Property
ObjectVersion Object : Title Property

Glossary Item Box

Description

The title of the object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property Title As String

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

VersionGUID Property
ObjectVersion Object : VersionGUID Property

Glossary Item Box

Description

The version GUID as a string.

Property type

Read-only property

Syntax

Visual Basic
Public Property VersionGUID As String

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

VisibleAfterOperation Property
ObjectVersion Object : VisibleAfterOperation Property

Glossary Item Box

Description

Specifies whether this object version is visible after the operation.

Property type

Read-only property

Syntax

Visual Basic
Public Property VisibleAfterOperation As Boolean

See Also

ObjectVersion Object | ObjectVersion Members


%%PageItemTitle%%

ObjectVersionAndProperties Object
Members See Also Send comments

Glossary Item Box

Description

The ObjectVersionAndProperties class is collection of properties and information on the object.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ObjVer | The object version
Public Property Properties | Properties of this object version.
Public Property Vault | The vault of this object version
Public Property VersionData | Gets the object version data.

Remarks

The M-Files vault object consists of a sequence of object versions. The ObjectVersionAndProperties class encapsulates information on a single object version, including the version metadata. ObjectVersionAndProperties objects are identified by ObjVer objects, and they can be obtained by using the VaultObjectOperations interface. If the object version contains any files, they can be accessed by using the encapsulated version data.

Multi-file object version with two files as seen in M-Files Desktop.

See Also

ObjectVersionAndProperties Members


%%PageItemTitle%%

Clone Method
ObjectVersionAndProperties Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjectVersionAndProperties

See Also

ObjectVersionAndProperties Object | ObjectVersionAndProperties Members


%%PageItemTitle%%

ObjVer Property
ObjectVersionAndProperties Object : ObjVer Property

Glossary Item Box

Description

The object version

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjVer As ObjVer

See Also

ObjectVersionAndProperties Object | ObjectVersionAndProperties Members


%%PageItemTitle%%

Properties Property
ObjectVersionAndProperties Object : Properties Property

Glossary Item Box

Description

Properties of this object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property Properties As PropertyValues

See Also

ObjectVersionAndProperties Object | ObjectVersionAndProperties Members


%%PageItemTitle%%

Vault Property
ObjectVersionAndProperties Object : Vault Property

Glossary Item Box

Description

The vault of this object version

Property type

Read-only property

Syntax

Visual Basic
Public Property Vault As Vault

Remarks

The vault containing this object version.

See Also

ObjectVersionAndProperties Object | ObjectVersionAndProperties Members


%%PageItemTitle%%

VersionData Property
ObjectVersionAndProperties Object : VersionData Property

Glossary Item Box

Description

Gets the object version data.

Property type

Read-only property

Syntax

Visual Basic
Public Property VersionData As ObjectVersion

See Also

ObjectVersionAndProperties Object | ObjectVersionAndProperties Members


%%PageItemTitle%%

ObjectVersionAndPropertiesOfMultipleObjects Collection
Members See Also Send comments

Glossary Item Box

Description

ObjectVersionAndPropertiesOfMultipleObjects is a collection of ObjectVersionAndProperties collections. Each ObjectVersionAndProperties collection represents the property values of one object version.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectVersionAndPropertiesOfMultipleObjects Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectVersionAndProperties
The new member to add.
ObjectVersionAndPropertiesOfMultipleObjects Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ObjectVersionAndProperties As ObjectVersionAndProperties _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectVersionAndProperties
The new member to add.

See Also

ObjectVersionAndPropertiesOfMultipleObjects Collection | ObjectVersionAndPropertiesOfMultipleObjects Members


%%PageItemTitle%%

Clone Method
ObjectVersionAndPropertiesOfMultipleObjects Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjectVersionAndPropertiesOfMultipleObjects

See Also

ObjectVersionAndPropertiesOfMultipleObjects Collection | ObjectVersionAndPropertiesOfMultipleObjects Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ObjectVersionAndPropertiesOfMultipleObjects Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ObjectVersionAndPropertiesOfMultipleObjects Collection | ObjectVersionAndPropertiesOfMultipleObjects Members


%%PageItemTitle%%

Count Property
ObjectVersionAndPropertiesOfMultipleObjects Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjectVersionAndPropertiesOfMultipleObjects Collection | ObjectVersionAndPropertiesOfMultipleObjects Members


%%PageItemTitle%%

Item Property
Index
ObjectVersionAndPropertiesOfMultipleObjects Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjectVersionAndProperties

Parameters

Index

See Also

ObjectVersionAndPropertiesOfMultipleObjects Collection | ObjectVersionAndPropertiesOfMultipleObjects Members


%%PageItemTitle%%

ObjectVersionData Object
Members See Also Send comments

Glossary Item Box

Description

The "ObjectVersionData" class contains the object version data.

Remarks

Supported in M-Files 19.4.7683.3 and later.

See Also

ObjectVersionData Members


%%PageItemTitle%%

ObjectVersionDataRequest Object
Members See Also Send comments

Glossary Item Box

Description

"ObjectVersionDataRequest" class contains the information about which data of the object version is requested.

Public Methods

Public Method SetEx Sets the object version data request.

Remarks

Supported in M-Files 19.4.7683.3 and later.

See Also

ObjectVersionDataRequest Members


%%PageItemTitle%%

SetEx Method
requiredDataFlags
optionalDataFlags
VersionType
ErrorTolerance
ObjectVersionDataRequest Object : SetEx Method

Glossary Item Box

Description

Sets the object version data request.

Syntax

Visual Basic
Public Sub SetEx( _
   ByVal requiredDataFlags As MFObjectDataRequestFlags, _
   ByVal optionalDataFlags As MFObjectDataRequestFlags, _
   ByVal VersionType As MFObjectDataRequestVersionType, _
   ByVal ErrorTolerance As MFObjectDataRequestErrorTolerance _
)

Parameters

requiredDataFlags
Value | Description
MFObjectDataRequestAcl | Access control list information is requested.
MFObjectDataRequestNone | No data is requested.
MFObjectDataRequestObjectInfo | Object information is requested.
MFObjectDataRequestObjectPermissionsForClient | Object permissions for the client are requested.
MFObjectDataRequestProperties | Property values are requested.
MFObjectDataRequestPropertiesForDisplay | Display properties are requested.
optionalDataFlags
Value | Description
MFObjectDataRequestAcl | Access control list information is requested.
MFObjectDataRequestNone | No data is requested.
MFObjectDataRequestObjectInfo | Object information is requested.
MFObjectDataRequestObjectPermissionsForClient | Object permissions for the client are requested.
MFObjectDataRequestProperties | Property values are requested.
MFObjectDataRequestPropertiesForDisplay | Display properties are requested.
VersionType
Value | Description
MFObjectDataRequestLatestCheckedInVersions | Object data is requested for the latest checked-in versions.
MFObjectDataRequestLatestVersions | Object data is requested for the latest versions.
MFObjectDataRequestSpecificVersions | Object data is requested for specific versions.
ErrorTolerance
Value | Description
MFObjectDataRequestAllowMissingObjectVersions | The operation is allowed to continue regardless of missing object versions.
MFObjectDataRequestFailOnAnyError | Any error causes the operation to be stopped.

See Also

ObjectVersionDataRequest Object | ObjectVersionDataRequest Members


%%PageItemTitle%%

ObjectVersionDataResult Object
Members See Also Send comments

Glossary Item Box

Description

"ObjectVersionDataResult" class contains the results of call used to get object data.

Remarks

Supported in M-Files 19.4.7683.3 and later.

See Also

ObjectVersionDataResult Members


%%PageItemTitle%%

ObjectVersionDataResults Collection
Members See Also Send comments

Glossary Item Box

Description

ObjectVersionDataResults is a collection of ObjectVersionDataResult objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

Remarks

Supported in M-Files 19.4.7683.3 and later.

See Also

ObjectVersionDataResults Members


%%PageItemTitle%%

Add Method
Index
The position of the collection member to add.
ObjVer
The new member to add.
ObjectVersionDataResults Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ObjVer As ObjectVersionDataResult _
)

Parameters

Index
The position of the collection member to add.
ObjVer
The new member to add.

See Also

ObjectVersionDataResults Collection | ObjectVersionDataResults Members


%%PageItemTitle%%

Clone Method
ObjectVersionDataResults Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjectVersionDataResults

See Also

ObjectVersionDataResults Collection | ObjectVersionDataResults Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ObjectVersionDataResults Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ObjectVersionDataResults Collection | ObjectVersionDataResults Members


%%PageItemTitle%%

Count Property
ObjectVersionDataResults Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjectVersionDataResults Collection | ObjectVersionDataResults Members


%%PageItemTitle%%

Item Property
Index
Specifies the position of the item in the collection.
ObjectVersionDataResults Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjectVersionDataResult

Parameters

Index
Specifies the position of the item in the collection.

See Also

ObjectVersionDataResults Collection | ObjectVersionDataResults Members


%%PageItemTitle%%

ObjectVersionFile Object
Members See Also Send comments

Glossary Item Box

Description

The ObjectVersionFile class represents a file of an object.

Public Properties

Public Property ObjectFile | Object file.
Public Property ObjectVersion | Object version.

Remarks

The ObjectVersionFile class encapsulates information on a single object file and the parent vault object with metadata. Use the VaultObjectSearchOperations interface to locate an ObjectVersionFile object of a vault. If you are using the M-Files API client interface, you can obtain the ObjectVersionFile objects by locating them with the FindFile method within the client application interface.

See Also

ObjectVersionFile Members


%%PageItemTitle%%

ObjectFile Property
ObjectVersionFile Object : ObjectFile Property

Glossary Item Box

Description

Object file.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectFile As ObjectFile

See Also

ObjectVersionFile Object | ObjectVersionFile Members


%%PageItemTitle%%

ObjectVersion Property
ObjectVersionFile Object : ObjectVersion Property

Glossary Item Box

Description

Object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectVersion As ObjectVersionAndProperties

See Also

ObjectVersionFile Object | ObjectVersionFile Members


%%PageItemTitle%%

ObjectVersionPermissions Object
Members See Also Send comments

Glossary Item Box

Description

The ObjectVersionPermissions class represents the permissions for an object version.

Public Properties

Public Property AccessControlList | The access control list of the object version.
Public Property CustomACL | Specifies whether the object version has a customized access control list.
Public Property NamedACL | The named access control list of the object version.
Public Property ObjVer | The ObjVer identifier of the object version.

Remarks

Represents the permission settings of the vault object. Use the VaultObjectOperations interface to access the permissions of a certain object version.

See Also

ObjectVersionPermissions Members


%%PageItemTitle%%

AccessControlList Property
ObjectVersionPermissions Object : AccessControlList Property

Glossary Item Box

Description

The access control list of the object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property AccessControlList As AccessControlList

See Also

ObjectVersionPermissions Object | ObjectVersionPermissions Members


%%PageItemTitle%%

CustomACL Property
ObjectVersionPermissions Object : CustomACL Property

Glossary Item Box

Description

Specifies whether the object version has a customized access control list.

Property type

Read-only property

Syntax

Visual Basic
Public Property CustomACL As Boolean

Remarks

If a custom ACL is defined, the named ACL is not used.

See Also

ObjectVersionPermissions Object | ObjectVersionPermissions Members


%%PageItemTitle%%

NamedACL Property
ObjectVersionPermissions Object : NamedACL Property

Glossary Item Box

Description

The named access control list of the object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property NamedACL As NamedACL

Remarks

The named ACL is used if no custom ACL is defined.

See Also

ObjectVersionPermissions Object | ObjectVersionPermissions Members


%%PageItemTitle%%

ObjVer Property
ObjectVersionPermissions Object : ObjVer Property

Glossary Item Box

Description

The ObjVer identifier of the object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjVer As ObjVer

See Also

ObjectVersionPermissions Object | ObjectVersionPermissions Members


%%PageItemTitle%%

ObjectVersions Collection
Members See Also Send comments

Glossary Item Box

Description

ObjectVersions is a collection of ObjectVersionData objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method GetAsObjVers | Gets the ObjVers of the object versions in this collection.
Public Method Remove | Removes the item at the specified position.
Public Method Sort | Sorts the objects in this collection using the given comparator.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectVersions Members | ObjectVersion Object


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectVersionData
The new member to add.
ObjectVersions Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ObjectVersionData As ObjectVersion _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectVersionData
The new member to add.

See Also

ObjectVersions Collection | ObjectVersions Members


%%PageItemTitle%%

GetAsObjVers Method
ObjectVersions Collection : GetAsObjVers Method

Glossary Item Box

Description

Gets the ObjVers of the object versions in this collection.

Syntax

Visual Basic
Public Function GetAsObjVers() As ObjVers

See Also

ObjectVersions Collection | ObjectVersions Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ObjectVersions Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ObjectVersions Collection | ObjectVersions Members


%%PageItemTitle%%

Sort Method
ObjectComparer
Specifies the comparer.
ObjectVersions Collection : Sort Method

Glossary Item Box

Description

Sorts the objects in this collection using the given comparator.

Syntax

Visual Basic
Public Sub Sort( _
   ByVal ObjectComparer As IObjectComparer _
)

Parameters

ObjectComparer
Specifies the comparer.

See Also

ObjectVersions Collection | ObjectVersions Members


%%PageItemTitle%%

Count Property
ObjectVersions Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjectVersions Collection | ObjectVersions Members


%%PageItemTitle%%

Item Property
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectVersions Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjectVersion

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.

See Also

ObjectVersions Collection | ObjectVersions Members


%%PageItemTitle%%

ObjectVersionWorkflowState Object
Members See Also Send comments

Glossary Item Box

Description

The ObjectVersionWorkflowState class represents the state of a workflow for an object version.

Public Properties

Public Property State | The workflow state of the object version.
Public Property VersionComment | A version comment for the object version.
Public Property Workflow | The workflow of the object version.

Remarks

The workflow state of an object version encapsulates references to the workflow and workflow state for an object version. It also includes a version comment set for the object version.

Use VaultObjectPropertyOperations to access the workflow state objects of an object version.

Changing the workflow state of an object version in M-Files Desktop.

See Also

ObjectVersionWorkflowState Members


%%PageItemTitle%%

State Property
ObjectVersionWorkflowState Object : State Property

Glossary Item Box

Description

The workflow state of the object version.

Property type

Read-write property

Syntax

Visual Basic
Public Property State As PropertyValue

Remarks

The returned value contains a lookup reference to the state value list item as a TypedValue object. Use the VaultWorkflowOperations interface to get the State object for the state value.

See Also

ObjectVersionWorkflowState Object | ObjectVersionWorkflowState Members | GetWorkflowStates Method


%%PageItemTitle%%

VersionComment Property
ObjectVersionWorkflowState Object : VersionComment Property

Glossary Item Box

Description

A version comment for the object version.

Property type

Read-write property

Syntax

Visual Basic
Public Property VersionComment As PropertyValue

Remarks

The comment text can be extracted from the TypedValue object.

See Also

ObjectVersionWorkflowState Object | ObjectVersionWorkflowState Members


%%PageItemTitle%%

Workflow Property
ObjectVersionWorkflowState Object : Workflow Property

Glossary Item Box

Description

The workflow of the object version.

Property type

Read-write property

Syntax

Visual Basic
Public Property Workflow As PropertyValue

Remarks

The returned value contains a lookup reference to the workflow value list item as a TypedValue object. Use the VaultWorkflowOperations interface to get the workflow value list.

See Also

ObjectVersionWorkflowState Object | ObjectVersionWorkflowState Members


%%PageItemTitle%%

ObjectWindowResult Object
Members See Also Send comments

Glossary Item Box

Description

The ObjectWindowResult class encapsulates the return values of showing the metadata card.

Public Properties

Public Property AccessControlList | Receives the access control list of the object.
Public Property ObjVer | Receives the object version of the object after displaying the metadata card.
Public Property Properties | Current property values of the object displayed in the metadata card.
Public Property Result | The dialog box result code.
Public Property SelectedFileClass | The selected file class for the new object.
Public Property UseAsDefaults | State of Use as Defaults selection. When True the properties the user selected for the created object in the metadata card should be used as a base for new objects when creating multiple object.
Public Property Visible | Specifies whether the object is still visible for the current user.

See Also

ObjectWindowResult Members | VaultObjectOperations Object


%%PageItemTitle%%

AccessControlList Property
ObjectWindowResult Object : AccessControlList Property

Glossary Item Box

Description

Receives the access control list of the object.

Property type

Read-only property

Syntax

Visual Basic
Public Property AccessControlList As AccessControlList

See Also

ObjectWindowResult Object | ObjectWindowResult Members


%%PageItemTitle%%

ObjVer Property
ObjectWindowResult Object : ObjVer Property

Glossary Item Box

Description

Receives the object version of the object after displaying the metadata card.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjVer As ObjVer

See Also

ObjectWindowResult Object | ObjectWindowResult Members


%%PageItemTitle%%

Properties Property
ObjectWindowResult Object : Properties Property

Glossary Item Box

Description

Current property values of the object displayed in the metadata card.

Property type

Read-only property

Syntax

Visual Basic
Public Property Properties As PropertyValues

Return Type

The collection of property values of the new object.

See Also

ObjectWindowResult Object | ObjectWindowResult Members


%%PageItemTitle%%

Result Property
ObjectWindowResult Object : Result Property

Glossary Item Box

Description

The dialog box result code.

Property type

Read-only property

Syntax

Visual Basic
Public Property Result As MFObjectWindowResultCode

Return Type

The status of the operation's success.

See Also

ObjectWindowResult Object | ObjectWindowResult Members


%%PageItemTitle%%

SelectedFileClass Property
ObjectWindowResult Object : SelectedFileClass Property

Glossary Item Box

Description

The selected file class for the new object.

Property type

Read-only property

Syntax

Visual Basic
Public Property SelectedFileClass As FileClass

See Also

ObjectWindowResult Object | ObjectWindowResult Members


%%PageItemTitle%%

UseAsDefaults Property
ObjectWindowResult Object : UseAsDefaults Property

Glossary Item Box

Description

State of Use as Defaults selection.

When True the properties the user selected for the created object in the metadata card should be used as a base for new objects when creating multiple object.

Property type

Read-only property

Syntax

Visual Basic
Public Property UseAsDefaults As Boolean

See Also

ObjectWindowResult Object | ObjectWindowResult Members


%%PageItemTitle%%

Visible Property
ObjectWindowResult Object : Visible Property

Glossary Item Box

Description

Specifies whether the object is still visible for the current user.

Property type

Read-only property

Syntax

Visual Basic
Public Property Visible As Boolean

Return Type

True if the object was visible to the user when the metadata card was closed.

See Also

ObjectWindowResult Object | ObjectWindowResult Members


%%PageItemTitle%%

ObjID Object
Members See Also Send comments

Glossary Item Box

Description

The ObjID class represents an object ID.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method IsManaged | Specifies whether this object ID represents a managed object.
Public Method IsUnmanaged | Specifies whether this object ID represents an unmanaged object.
Public Method Serialize | Serializes the object.
Public Method SetExternalRepositoryIDs | Sets the type and external repository identifiers of the object.
Public Method SetIDs | Sets the type and ID of the object.
Public Method ToJSON | Converts the data structure to a JSON string.
Public Method Unserialize | Unserializes the object.

Public Properties

Public Property ExternalRepositoryName | The external repository name of the object.
Public Property ExternalRepositoryObjectID | The external repository identifier of the object.
Public Property ID | The ID of the object (unique in one object type).
Public Property Type | The object type of the object.

Remarks

The object ID identifies an object in a document vault. The object ID consists of two parts. The first part is the object type and the second part is the ID that is unique within the specified object type. Together these parts define the identifier of an object.

ObjID is part of the ObjVer class, which uniquely identifies a single vault object version.

See Also

ObjID Members


%%PageItemTitle%%

Clone Method
ObjID Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjID

Return Type

Returns the copied object ID.

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

CloneFrom Method
ObjID
The object that is used as the source for cloning.
ObjID Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal ObjID As ObjID _
)

Parameters

ObjID
The object that is used as the source for cloning.

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

IsManaged Method
ObjID Object : IsManaged Method

Glossary Item Box

Description

Specifies whether this object ID represents a managed object.

Syntax

Visual Basic
Public Function IsManaged() As Boolean

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

IsUnmanaged Method
ObjID Object : IsUnmanaged Method

Glossary Item Box

Description

Specifies whether this object ID represents an unmanaged object.

Syntax

Visual Basic
Public Function IsUnmanaged() As Boolean

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

Serialize Method
ObjID Object : Serialize Method

Glossary Item Box

Description

Serializes the object.

Syntax

Visual Basic
Public Function Serialize() As Byte()

Return Type

The return value is a byte array containing the serialized object ID.

Remarks

The serialized object ID can be unserialized with the help of the Unserialize method.

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

SetExternalRepositoryIDs Method
ObjType
The object type to be set for the object.
ExternalRepositoryName
The name of the external repository to be set for the object.
ExternalRepositoryObjectID
The external repository object identifier to be set for the object.
ObjID Object : SetExternalRepositoryIDs Method

Glossary Item Box

Description

Sets the type and external repository identifiers of the object.

Syntax

Visual Basic
Public Sub SetExternalRepositoryIDs( _
   ByVal ObjType As Long, _
   ByVal ExternalRepositoryName As String, _
   ByVal ExternalRepositoryObjectID As String _
)

Parameters

ObjType
The object type to be set for the object.
ExternalRepositoryName
The name of the external repository to be set for the object.
ExternalRepositoryObjectID
The external repository object identifier to be set for the object.

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

SetIDs Method
ObjType
The ID of the object type.
ID
The ID of the object. This is unique to one object type.
ObjID Object : SetIDs Method

Glossary Item Box

Description

Sets the type and ID of the object.

Syntax

Visual Basic
Public Sub SetIDs( _
   ByVal ObjType As Long, _
   ByVal ID As Long _
)

Parameters

ObjType
The ID of the object type.
ID
The ID of the object. This is unique to one object type.

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

ToJSON Method
ObjID Object : ToJSON Method

Glossary Item Box

Description

Converts the data structure to a JSON string.

Syntax

Visual Basic
Public Function ToJSON() As String

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

Unserialize Method
Bytes
The serialized object version to unserialize.
ObjID Object : Unserialize Method

Glossary Item Box

Description

Unserializes the object.

Syntax

Visual Basic
Public Sub Unserialize( _
   ByVal Bytes() As Byte _
)

Parameters

Bytes
The serialized object version to unserialize.

Remarks

The unserialized object version can be serialized with the help of the Serialize method.

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

ExternalRepositoryName Property
ObjID Object : ExternalRepositoryName Property

Glossary Item Box

Description

The external repository name of the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryName As String

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

ExternalRepositoryObjectID Property
ObjID Object : ExternalRepositoryObjectID Property

Glossary Item Box

Description

The external repository identifier of the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryObjectID As String

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

ID Property
ObjID Object : ID Property

Glossary Item Box

Description

The ID of the object (unique in one object type).

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

Type Property
ObjID Object : Type Property

Glossary Item Box

Description

The object type of the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type As Long

See Also

ObjID Object | ObjID Members


%%PageItemTitle%%

ObjIDs Collection
Members See Also Send comments

Glossary Item Box

Description

ObjIDs is a collection of ObjID objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjIDs Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjID
The new member to add.
ObjIDs Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ObjID As ObjID _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjID
The new member to add.

See Also

ObjIDs Collection | ObjIDs Members


%%PageItemTitle%%

Clone Method
ObjIDs Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjIDs

See Also

ObjIDs Collection | ObjIDs Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ObjIDs Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ObjIDs Collection | ObjIDs Members


%%PageItemTitle%%

ToJSON Method
ObjIDs Collection : ToJSON Method

Glossary Item Box

Description

Converts the data structure to a JSON string.

Syntax

Visual Basic
Public Function ToJSON() As String

See Also

ObjIDs Collection | ObjIDs Members


%%PageItemTitle%%

Count Property
ObjIDs Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjIDs Collection | ObjIDs Members


%%PageItemTitle%%

Item Property
Index
ObjIDs Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjID

Parameters

Index

See Also

ObjIDs Collection | ObjIDs Members


%%PageItemTitle%%

ObjOrFileVer Object
Members See Also Send comments

Glossary Item Box

Description

The ObjOrFileVer class represents an object version or file version of an object.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method IsFile | Specifies whether this object represents a file.

Public Properties

Public Property FileVer | The file version.
Public Property ObjVer | The object version.

See Also

ObjOrFileVer Members


%%PageItemTitle%%

Clone Method
ObjOrFileVer Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjOrFileVer

See Also

ObjOrFileVer Object | ObjOrFileVer Members


%%PageItemTitle%%

IsFile Method
ObjOrFileVer Object : IsFile Method

Glossary Item Box

Description

Specifies whether this object represents a file.

Syntax

Visual Basic
Public Function IsFile() As Boolean

See Also

ObjOrFileVer Object | ObjOrFileVer Members


%%PageItemTitle%%

FileVer Property
ObjOrFileVer Object : FileVer Property

Glossary Item Box

Description

The file version.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileVer As FileVer

See Also

ObjOrFileVer Object | ObjOrFileVer Members


%%PageItemTitle%%

ObjVer Property
ObjOrFileVer Object : ObjVer Property

Glossary Item Box

Description

The object version.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjVer As ObjVer

See Also

ObjOrFileVer Object | ObjOrFileVer Members


%%PageItemTitle%%

ObjOrFileVers Collection
Members See Also Send comments

Glossary Item Box

Description

The ObjOrFileVers class represents the collection of ObjOrFileVer objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjOrFileVers Members


%%PageItemTitle%%

Add Method
Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

ObjOrFileVer
The ID of the object.
ObjOrFileVers Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ObjOrFileVer As ObjOrFileVer _
)

Parameters

Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

ObjOrFileVer
The ID of the object.

See Also

ObjOrFileVers Collection | ObjOrFileVers Members


%%PageItemTitle%%

Clone Method
ObjOrFileVers Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjOrFileVers

See Also

ObjOrFileVers Collection | ObjOrFileVers Members


%%PageItemTitle%%

Remove Method
Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

ObjOrFileVers Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

See Also

ObjOrFileVers Collection | ObjOrFileVers Members


%%PageItemTitle%%

Count Property
ObjOrFileVers Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjOrFileVers Collection | ObjOrFileVers Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

ObjOrFileVers Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjOrFileVer

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

ObjOrFileVers Collection | ObjOrFileVers Members


%%PageItemTitle%%

ObjType Object
Members See Also Send comments

Glossary Item Box

Description

The ObjectType class represents an object type.

Public Methods

Public Method CanHaveItemIcons | Can this object type have item icons.
Public Method Clone | Creates a copy of the object.
Public Method GetIconAsPNG | Returns the icon of this object type in PNG format scaled to the specified size.
Public Method IsAddingAllowedForUser | Checks if the user can add new items of this type.

Public Properties

Public Property AccessControlList | The ACL that defines the visibility and other permission settings of this object type. Also specifies who can add new items to this object type.
Public Property AllowAdding | Specifies whether adding a new object is allowed.
Public Property AllowedAsGroupingLevel | Specifies whether to allow using this value list or object type as a grouping level in views.
Public Property CanHaveFiles | Specifies whether the objects of this object type can have files.
Public Property DefaultAccessControlList | Specifies the default ACL for new objects.
Public Property DefaultPropertyDef | The ID of the multi-select lookup property definition that acts as the default property definition for this object type. For example, new relationships to objects of this type are expressed using this property.
Public Property DisableExternalConnection | Specifies whether the external connection is disabled.
Public Property External | Specifies whether the object type is external.
Public Property GUID | The GUID as a string.
Public Property HasOwnerType | Specifies whether this object type is a subtype of another object type.
Public Property Hierarchical | Specifies whether this object type is hierarchical (has an internal hierarchy).
Public Property Icon | The icon of the object type in ICO format.
Public Property ID | The ID of the object type.
Public Property NamePlural | The plural name of the object type.
Public Property NameSingular | The singular name of the object type.
Public Property ObjectTypeTargetsForBrowsing | Object type targets for browsing.
Public Property OwnerPropertyDef | Owner property definition. Subobjects of objects of this object type have this property in their metadata for describing owner relationships.
Public Property OwnerType | The owner object type.
Public Property ReadOnlyPropertiesDuringInsert | Specifies property definition IDs of those properties that cannot be entered during the creation of a new object because they are not included in the INSERT INTO statement.
Public Property ReadOnlyPropertiesDuringUpdate | Specifies property definition IDs of those properties that cannot be entered during the editing of an existing object because they are not included in the UPDATE statement.
Public Property RealObjectType | Specifies whether this object type is a real object type (not just a value list).
Public Property ShowCreationCommandInTaskPane | Specifies whether the creation command is shown for this object type in the task pane.
Public Property TitlePropertyID | The ID of the property that contains the object title in the user's preferred language.
Public Property Translatable | Specifies whether the contents of this value list or object type can be translated.

Remarks

The ObjType class represents an object type or a value list. Use the RealObjectType property to distinguish object types and value lists.

Object type properties (a real object type) as seen in M-Files Admin.

Value list properties as seen in M-Files Admin.

See Also

ObjType Members


%%PageItemTitle%%

CanHaveItemIcons Method
ObjType Object : CanHaveItemIcons Method

Glossary Item Box

Description

Can this object type have item icons.

Syntax

Visual Basic
Public Function CanHaveItemIcons() As Boolean

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

Clone Method
ObjType Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjType

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

GetIconAsPNG Method
Width
Height
ObjType Object : GetIconAsPNG Method

Glossary Item Box

Description

Returns the icon of this object type in PNG format scaled to the specified size.

Syntax

Visual Basic
Public Function GetIconAsPNG( _
   ByVal Width As Long, _
   ByVal Height As Long _
) As Byte()

Parameters

Width
Height

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

IsAddingAllowedForUser Method
SessionInfo
The session info of the user.
ObjType Object : IsAddingAllowedForUser Method

Glossary Item Box

Description

Checks if the user can add new items of this type.

Syntax

Visual Basic
Public Function IsAddingAllowedForUser( _
   ByVal SessionInfo As SessionInfo _
) As Boolean

Parameters

SessionInfo
The session info of the user.

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

AccessControlList Property
ObjType Object : AccessControlList Property

Glossary Item Box

Description

The ACL that defines the visibility and other permission settings of this object type. Also specifies who can add new items to this object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessControlList As AccessControlList

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

AllowAdding Property
ObjType Object : AllowAdding Property

Glossary Item Box

Description

Specifies whether adding a new object is allowed.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowAdding As Boolean

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

AllowedAsGroupingLevel Property
ObjType Object : AllowedAsGroupingLevel Property

Glossary Item Box

Description

Specifies whether to allow using this value list or object type as a grouping level in views.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowedAsGroupingLevel As Boolean

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

CanHaveFiles Property
ObjType Object : CanHaveFiles Property

Glossary Item Box

Description

Specifies whether the objects of this object type can have files.

Property type

Read-write property

Syntax

Visual Basic
Public Property CanHaveFiles As Boolean

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

DefaultAccessControlList Property
ObjType Object : DefaultAccessControlList Property

Glossary Item Box

Description

Specifies the default ACL for new objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultAccessControlList As AccessControlList

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

DefaultPropertyDef Property
ObjType Object : DefaultPropertyDef Property

Glossary Item Box

Description

The ID of the multi-select lookup property definition that acts as the default property definition for this object type. For example, new relationships to objects of this type are expressed using this property.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultPropertyDef As Long

Remarks

If the object type is not a real object type, "DefaultPropertyDef" is zero because simple value lists do not have a default property definition.

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

DisableExternalConnection Property
ObjType Object : DisableExternalConnection Property

Glossary Item Box

Description

Specifies whether the external connection is disabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisableExternalConnection As Boolean

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

External Property
ObjType Object : External Property

Glossary Item Box

Description

Specifies whether the object type is external.

Property type

Read-write property

Syntax

Visual Basic
Public Property External As Boolean

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

GUID Property
ObjType Object : GUID Property

Glossary Item Box

Description

The GUID as a string.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID As String

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

HasOwnerType Property
ObjType Object : HasOwnerType Property

Glossary Item Box

Description

Specifies whether this object type is a subtype of another object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property HasOwnerType As Boolean

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

Hierarchical Property
ObjType Object : Hierarchical Property

Glossary Item Box

Description

Specifies whether this object type is hierarchical (has an internal hierarchy).

Property type

Read-write property

Syntax

Visual Basic
Public Property Hierarchical As Boolean

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

Icon Property
ObjType Object : Icon Property

Glossary Item Box

Description

The icon of the object type in ICO format.

Property type

Read-write property

Syntax

Visual Basic
Public Property Icon As Byte()

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

ID Property
ObjType Object : ID Property

Glossary Item Box

Description

The ID of the object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

NamePlural Property
ObjType Object : NamePlural Property

Glossary Item Box

Description

The plural name of the object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamePlural As String

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

NameSingular Property
ObjType Object : NameSingular Property

Glossary Item Box

Description

The singular name of the object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property NameSingular As String

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

ObjectTypeTargetsForBrowsing Property
ObjType Object : ObjectTypeTargetsForBrowsing Property

Glossary Item Box

Description

Object type targets for browsing.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectTypeTargetsForBrowsing As ObjectTypeTargetsForBrowsing

Remarks

Lists object types.

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

OwnerPropertyDef Property
ObjType Object : OwnerPropertyDef Property

Glossary Item Box

Description

Owner property definition. Subobjects of objects of this object type have this property in their metadata for describing owner relationships.

Property type

Read-write property

Syntax

Visual Basic
Public Property OwnerPropertyDef As Long

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

OwnerType Property
ObjType Object : OwnerType Property

Glossary Item Box

Description

The owner object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property OwnerType As Long

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

ReadOnlyPropertiesDuringInsert Property
ObjType Object : ReadOnlyPropertiesDuringInsert Property

Glossary Item Box

Description

Specifies property definition IDs of those properties that cannot be entered during the creation of a new object because they are not included in the INSERT INTO statement.

Property type

Read-only property

Syntax

Visual Basic
Public Property ReadOnlyPropertiesDuringInsert As IDs

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

ReadOnlyPropertiesDuringUpdate Property
ObjType Object : ReadOnlyPropertiesDuringUpdate Property

Glossary Item Box

Description

Specifies property definition IDs of those properties that cannot be entered during the editing of an existing object because they are not included in the UPDATE statement.

Property type

Read-only property

Syntax

Visual Basic
Public Property ReadOnlyPropertiesDuringUpdate As IDs

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

RealObjectType Property
ObjType Object : RealObjectType Property

Glossary Item Box

Description

Specifies whether this object type is a real object type (not just a value list).

Property type

Read-write property

Syntax

Visual Basic
Public Property RealObjectType As Boolean

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

ShowCreationCommandInTaskPane Property
ObjType Object : ShowCreationCommandInTaskPane Property

Glossary Item Box

Description

Specifies whether the creation command is shown for this object type in the task pane.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowCreationCommandInTaskPane As Boolean

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

TitlePropertyID Property
ObjType Object : TitlePropertyID Property

Glossary Item Box

Description

The ID of the property that contains the object title in the user's preferred language.

Property type

Read-only property

Syntax

Visual Basic
Public Property TitlePropertyID As Long

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

Translatable Property
ObjType Object : Translatable Property

Glossary Item Box

Description

Specifies whether the contents of this value list or object type can be translated.

Property type

Read-write property

Syntax

Visual Basic
Public Property Translatable As Boolean

See Also

ObjType Object | ObjType Members


%%PageItemTitle%%

ObjTypeAdmin Object
Members See Also Send comments

Glossary Item Box

Description

The ObjTypeAdmin class represents an object type (for administrative operations).

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ColumnMappings | Column mappings that specify how each column retrieved from the external database is mapped into a property in M-Files.
Public Property ConnectionString | The OLE DB connection string to the external database that contains the objects (and their properties) of this object type.
Public Property DefaultForAutomaticPermissions | Specifies the default for automatic permissions for the objects.
Public Property DeleteStatement | The SQL statement that deletes an object in an external database.
Public Property InsertIntoStatement | The SQL statement that inserts a new object to an external database.
Public Property NamedValueNamespaces | The custom data for the object type.
Public Property ObjectType | Object type.
Public Property SelectExtIDStatement | The SQL statement that retrieves the ID of the just inserted record in the external database.
Public Property SelectStatement | The SQL statement that retrieves the objects from an external database.
Public Property SelectStatementOneRecord | The SQL statement that retrieves a specific object from an external database.
Public Property SemanticAliases | The semantic aliases of this object type.
Public Property Translatable | Specifies whether the contents of this value list or object type can be translated.
Public Property UpdateStatement | The SQL statement that updates an existing object in an external database.

Remarks

External database connection part of an object type definition as seen in M-Files Admin.

See Also

ObjTypeAdmin Members


%%PageItemTitle%%

Clone Method
ObjTypeAdmin Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjTypeAdmin

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

ColumnMappings Property
ObjTypeAdmin Object : ColumnMappings Property

Glossary Item Box

Description

Column mappings that specify how each column retrieved from the external database is mapped into a property in M-Files.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColumnMappings As ObjTypeColumnMappings

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

ConnectionString Property
ObjTypeAdmin Object : ConnectionString Property

Glossary Item Box

Description

The OLE DB connection string to the external database that contains the objects (and their properties) of this object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectionString As String

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

DefaultForAutomaticPermissions Property
ObjTypeAdmin Object : DefaultForAutomaticPermissions Property

Glossary Item Box

Description

Specifies the default for automatic permissions for the objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultForAutomaticPermissions As AutomaticPermissions

Return Type

AutomaticPermissions structure describing the current default automatic permission settings or null value (Nothing in Visual Basic) if no default automatic permissions are specified.

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

DeleteStatement Property
ObjTypeAdmin Object : DeleteStatement Property

Glossary Item Box

Description

The SQL statement that deletes an object in an external database.

Property type

Read-write property

Syntax

Visual Basic
Public Property DeleteStatement As String

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

InsertIntoStatement Property
ObjTypeAdmin Object : InsertIntoStatement Property

Glossary Item Box

Description

The SQL statement that inserts a new object to an external database.

Property type

Read-write property

Syntax

Visual Basic
Public Property InsertIntoStatement As String

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

NamedValueNamespaces Property
ObjTypeAdmin Object : NamedValueNamespaces Property

Glossary Item Box

Description

The custom data for the object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamedValueNamespaces As NamedValueNamespaces

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

ObjectType Property
ObjTypeAdmin Object : ObjectType Property

Glossary Item Box

Description

Object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectType As ObjType

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

SelectExtIDStatement Property
ObjTypeAdmin Object : SelectExtIDStatement Property

Glossary Item Box

Description

The SQL statement that retrieves the ID of the just inserted record in the external database.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectExtIDStatement As String

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

SelectStatement Property
ObjTypeAdmin Object : SelectStatement Property

Glossary Item Box

Description

The SQL statement that retrieves the objects from an external database.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectStatement As String

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

SelectStatementOneRecord Property
ObjTypeAdmin Object : SelectStatementOneRecord Property

Glossary Item Box

Description

The SQL statement that retrieves a specific object from an external database.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectStatementOneRecord As String

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

SemanticAliases Property
ObjTypeAdmin Object : SemanticAliases Property

Glossary Item Box

Description

The semantic aliases of this object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property SemanticAliases As SemanticAliases

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

Translatable Property
ObjTypeAdmin Object : Translatable Property

Glossary Item Box

Description

Specifies whether the contents of this value list or object type can be translated.

Property type

Read-write property

Syntax

Visual Basic
Public Property Translatable As Boolean

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

UpdateStatement Property
ObjTypeAdmin Object : UpdateStatement Property

Glossary Item Box

Description

The SQL statement that updates an existing object in an external database.

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdateStatement As String

See Also

ObjTypeAdmin Object | ObjTypeAdmin Members


%%PageItemTitle%%

ObjTypeColumnMapping Object
Members See Also Send comments

Glossary Item Box

Description

The ObjTypeColumnMapping class represents a column mapping in an object type definition.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ObjectType | Object type ID.
Public Property Ordinal | One-based source field ordinal.
Public Property PartOfInsert | Specifies whether the source field is a part of insertion operations.
Public Property PartOfUpdate | Specifies whether the source field is a part of update operations.
Public Property SourceField | Source field name.
Public Property TargetPropertyDef | Target property definition.
Public Property Type | Source field's data type.

Remarks

External database table column mapping of an object type definition (highlighted with the green rectangle) as seen in M-Files Admin.

See Also

ObjTypeColumnMapping Members


%%PageItemTitle%%

Clone Method
ObjTypeColumnMapping Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjTypeColumnMapping

See Also

ObjTypeColumnMapping Object | ObjTypeColumnMapping Members


%%PageItemTitle%%

ObjectType Property
ObjTypeColumnMapping Object : ObjectType Property

Glossary Item Box

Description

Object type ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectType As Long

See Also

ObjTypeColumnMapping Object | ObjTypeColumnMapping Members


%%PageItemTitle%%

Ordinal Property
ObjTypeColumnMapping Object : Ordinal Property

Glossary Item Box

Description

One-based source field ordinal.

Property type

Read-write property

Syntax

Visual Basic
Public Property Ordinal As Long

See Also

ObjTypeColumnMapping Object | ObjTypeColumnMapping Members


%%PageItemTitle%%

PartOfInsert Property
ObjTypeColumnMapping Object : PartOfInsert Property

Glossary Item Box

Description

Specifies whether the source field is a part of insertion operations.

Property type

Read-write property

Syntax

Visual Basic
Public Property PartOfInsert As Boolean

See Also

ObjTypeColumnMapping Object | ObjTypeColumnMapping Members


%%PageItemTitle%%

PartOfUpdate Property
ObjTypeColumnMapping Object : PartOfUpdate Property

Glossary Item Box

Description

Specifies whether the source field is a part of update operations.

Property type

Read-write property

Syntax

Visual Basic
Public Property PartOfUpdate As Boolean

See Also

ObjTypeColumnMapping Object | ObjTypeColumnMapping Members


%%PageItemTitle%%

SourceField Property
ObjTypeColumnMapping Object : SourceField Property

Glossary Item Box

Description

Source field name.

Property type

Read-write property

Syntax

Visual Basic
Public Property SourceField As String

See Also

ObjTypeColumnMapping Object | ObjTypeColumnMapping Members


%%PageItemTitle%%

TargetPropertyDef Property
ObjTypeColumnMapping Object : TargetPropertyDef Property

Glossary Item Box

Description

Target property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property TargetPropertyDef As Long

See Also

ObjTypeColumnMapping Object | ObjTypeColumnMapping Members


%%PageItemTitle%%

Type Property
ObjTypeColumnMapping Object : Type Property

Glossary Item Box

Description

Source field's data type.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type As Integer

Remarks

The type indicator is based on the OLE DB data type indicators.

See Also

ObjTypeColumnMapping Object | ObjTypeColumnMapping Members


%%PageItemTitle%%

ObjTypeColumnMappings Collection
Members See Also Send comments

Glossary Item Box

Description

ObjTypeColumnMappings is a collection of ObjTypeColumnMapping objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of column mappings in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjTypeColumnMappings Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectTypeColumnMapping
The new member to add.
ObjTypeColumnMappings Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ObjectTypeColumnMapping As ObjTypeColumnMapping _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjectTypeColumnMapping
The new member to add.

See Also

ObjTypeColumnMappings Collection | ObjTypeColumnMappings Members


%%PageItemTitle%%

Clone Method
ObjTypeColumnMappings Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjTypeColumnMappings

See Also

ObjTypeColumnMappings Collection | ObjTypeColumnMappings Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ObjTypeColumnMappings Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ObjTypeColumnMappings Collection | ObjTypeColumnMappings Members


%%PageItemTitle%%

Count Property
ObjTypeColumnMappings Collection : Count Property

Glossary Item Box

Description

Returns the number of column mappings in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjTypeColumnMappings Collection | ObjTypeColumnMappings Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
ObjTypeColumnMappings Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjTypeColumnMapping

Parameters

Index
Specifies the item's position in the collection.

See Also

ObjTypeColumnMappings Collection | ObjTypeColumnMappings Members


%%PageItemTitle%%

ObjTypes Collection
Members See Also Send comments

Glossary Item Box

Description

ObjTypes is a collection of ObjType objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjTypes Members


%%PageItemTitle%%

Add Method
Index
ObjectType
ObjTypes Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ObjectType As ObjType _
)

Parameters

Index
ObjectType

See Also

ObjTypes Collection | ObjTypes Members


%%PageItemTitle%%

Clone Method
ObjTypes Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjTypes

See Also

ObjTypes Collection | ObjTypes Members


%%PageItemTitle%%

Remove Method
Index
ObjTypes Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

See Also

ObjTypes Collection | ObjTypes Members


%%PageItemTitle%%

Count Property
ObjTypes Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjTypes Collection | ObjTypes Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
ObjTypes Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjType

Parameters

Index
Specifies the item's position in the collection.

See Also

ObjTypes Collection | ObjTypes Members


%%PageItemTitle%%

ObjTypesAdmin Collection
Members See Also Send comments

Glossary Item Box

Description

ObjTypesAdmin is a collection of ObjTypeAdmin objects.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjTypesAdmin Members


%%PageItemTitle%%

Count Property
ObjTypesAdmin Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjTypesAdmin Collection | ObjTypesAdmin Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
ObjTypesAdmin Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjTypeAdmin

Parameters

Index
Specifies the item's position in the collection.

See Also

ObjTypesAdmin Collection | ObjTypesAdmin Members


%%PageItemTitle%%

ObjVer Object
Members See Also Send comments

Glossary Item Box

Description

The ObjVer class represents an object version.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method EqualTo | Checks for equality to the specified object.
Public Method IsLatest | Specifies whether this object represents the latest version.
Public Method IsSpecific | Specifies whether this object version represents a specific version.
Public Method Serialize | Serializes the object.
Public Method Set | Sets the object version to represent a specific version of the object.
Public Method SetIDs | Sets the type, ID and version of the object.
Public Method SetLatestVersion | Sets the object version to represent the latest version of the object.
Public Method SetLatestVersionEx | Sets the object version to represent the latest version of the object.
Public Method SetObjIDAndVersion | Sets the ObjID and version of the object.
Public Method SetSpecificVersion | Sets the object version to represent a specific version of the object.
Public Method ToJSON | Converts the data structure to a JSON string.
Public Method Unserialize | Unserializes the object.

Public Properties

Public Property ExternalRepositoryName | The external repository name of the object.
Public Property ExternalRepositoryObjectID | The external repository identifier of the object.
Public Property ID | The ID of the object (unique in one object type).
Public Property ObjID | The ObjID of the object.
Public Property Type | The object type of the object.
Public Property Version | The version of the object.
Public Property VersionEx | The object version.

Remarks

The object version identifies the specific version of an object in a document vault. The object version includes the object ID and the version number of the object.

The ObjVer object does not contain actual object data, but rather only the identification information. To access the object-specific data, use the ObjVer object to obtain the ObjectVersionAndProperties object.

See Also

ObjVer Members | ObjID Object


%%PageItemTitle%%

Clone Method
ObjVer Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjVer

Return Type

Returns the copied object version.

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

CloneFrom Method
ObjVer
The object that is used as the source for cloning.
ObjVer Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal ObjVer As ObjVer _
)

Parameters

ObjVer
The object that is used as the source for cloning.

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

EqualTo Method
pIObjVer
The object version to compare with.
ObjVer Object : EqualTo Method

Glossary Item Box

Description

Checks for equality to the specified object.

Syntax

Visual Basic
Public Function EqualTo( _
   ByVal pIObjVer As ObjVer _
) As Boolean

Parameters

pIObjVer
The object version to compare with.

Remarks

Supported in M-Files 19.4.7683.3 and later.

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

IsLatest Method
ObjVer Object : IsLatest Method

Glossary Item Box

Description

Specifies whether this object represents the latest version.

Syntax

Visual Basic
Public Function IsLatest() As Boolean

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

IsSpecific Method
ObjVer Object : IsSpecific Method

Glossary Item Box

Description

Specifies whether this object version represents a specific version.

Syntax

Visual Basic
Public Function IsSpecific() As Boolean

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

Serialize Method
ObjVer Object : Serialize Method

Glossary Item Box

Description

Serializes the object.

Syntax

Visual Basic
Public Function Serialize() As Byte()

Return Type

The return value is a byte array containing the serialized object version.

Remarks

The serialized object version can be unserialized with the help of the Unserialize method.

See Also

ObjVer Object | ObjVer Members | Unserialize Method


%%PageItemTitle%%

Set Method
ObjID
The object ID to be set.
ObjVerVersion
The object version to be set.
ObjVer Object : Set Method

Glossary Item Box

Description

Sets the object version to represent a specific version of the object.

Syntax

Visual Basic
Public Sub Set( _
   ByVal ObjID As ObjID, _
   ByVal ObjVerVersion As ObjVerVersion _
)

Parameters

ObjID
The object ID to be set.
ObjVerVersion
The object version to be set.

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

SetIDs Method
ObjType
The ID of the object type.
ID
The ID of the object. This is unique to one object type.
Version
The version of the object.
ObjVer Object : SetIDs Method

Glossary Item Box

Description

Sets the type, ID and version of the object.

Syntax

Visual Basic
Public Sub SetIDs( _
   ByVal ObjType As Long, _
   ByVal ID As Long, _
   ByVal Version As Long _
)

Parameters

ObjType
The ID of the object type.
ID
The ID of the object. This is unique to one object type.
Version
The version of the object.

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

SetLatestVersion Method
ObjType
The type part of an object version.
ID
The ID part of an object version.
ObjVer Object : SetLatestVersion Method

Glossary Item Box

Description

Sets the object version to represent the latest version of the object.

Syntax

Visual Basic
Public Sub SetLatestVersion( _
   ByVal ObjType As Long, _
   ByVal ID As Long _
)

Parameters

ObjType
The type part of an object version.
ID
The ID part of an object version.

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

SetLatestVersionEx Method
ObjID
The object ID.
ObjVer Object : SetLatestVersionEx Method

Glossary Item Box

Description

Sets the object version to represent the latest version of the object.

Syntax

Visual Basic
Public Sub SetLatestVersionEx( _
   ByVal ObjID As ObjID _
)

Parameters

ObjID
The object ID.

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

SetObjIDAndVersion Method
ObjID
The object ID part of an object version.
Version
The version part of an object version.
ObjVer Object : SetObjIDAndVersion Method

Glossary Item Box

Description

Sets the ObjID and version of the object.

Syntax

Visual Basic
Public Sub SetObjIDAndVersion( _
   ByVal ObjID As ObjID, _
   ByVal Version As Long _
)

Parameters

ObjID
The object ID part of an object version.
Version
The version part of an object version.

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

SetSpecificVersion Method
ObjType
The type part of an object version.
ID
The ID part of an object version.
Version
The version part of an object version.
ObjVer Object : SetSpecificVersion Method

Glossary Item Box

Description

Sets the object version to represent a specific version of the object.

Syntax

Visual Basic
Public Sub SetSpecificVersion( _
   ByVal ObjType As Long, _
   ByVal ID As Long, _
   ByVal Version As Long _
)

Parameters

ObjType
The type part of an object version.
ID
The ID part of an object version.
Version
The version part of an object version.

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

ToJSON Method
ObjVer Object : ToJSON Method

Glossary Item Box

Description

Converts the data structure to a JSON string.

Syntax

Visual Basic
Public Function ToJSON() As String

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

Unserialize Method
Bytes
The serialized object version to unserialize.
ObjVer Object : Unserialize Method

Glossary Item Box

Description

Unserializes the object.

Syntax

Visual Basic
Public Sub Unserialize( _
   ByVal Bytes() As Byte _
)

Parameters

Bytes
The serialized object version to unserialize.

Remarks

The unserialized object version can be serialized with the help of the Serialize method.

See Also

ObjVer Object | ObjVer Members | Serialize Method


%%PageItemTitle%%

ExternalRepositoryName Property
ObjVer Object : ExternalRepositoryName Property

Glossary Item Box

Description

The external repository name of the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryName As String

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

ExternalRepositoryObjectID Property
ObjVer Object : ExternalRepositoryObjectID Property

Glossary Item Box

Description

The external repository identifier of the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryObjectID As String

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

ID Property
ObjVer Object : ID Property

Glossary Item Box

Description

The ID of the object (unique in one object type).

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

ObjID Property
ObjVer Object : ObjID Property

Glossary Item Box

Description

The ObjID of the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjID As ObjID

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

Type Property
ObjVer Object : Type Property

Glossary Item Box

Description

The object type of the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type As Long

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

Version Property
ObjVer Object : Version Property

Glossary Item Box

Description

The version of the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Version As Long

Remarks

On some occasions (e.g., when dealing with lookup values), the version number can have value of -1. This indicates the latest version of the object.

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

VersionEx Property
ObjVer Object : VersionEx Property

Glossary Item Box

Description

The object version.

Property type

Read-write property

Syntax

Visual Basic
Public Property VersionEx As ObjVerVersion

See Also

ObjVer Object | ObjVer Members


%%PageItemTitle%%

ObjVers Collection
Members See Also Send comments

Glossary Item Box

Description

ObjVers is a collection of ObjVer objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method GetAllDistinctObjIDs | Gets all distinct object IDs in this collection.
Public Method Remove | Removes the item at the specified position from the collection.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjVers Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjVer
The new member to add.
ObjVers Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ObjVer As ObjVer _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
ObjVer
The new member to add.

See Also

ObjVers Collection | ObjVers Members


%%PageItemTitle%%

Clone Method
ObjVers Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ObjVers

See Also

ObjVers Collection | ObjVers Members


%%PageItemTitle%%

GetAllDistinctObjIDs Method
ObjVers Collection : GetAllDistinctObjIDs Method

Glossary Item Box

Description

Gets all distinct object IDs in this collection.

Syntax

Visual Basic
Public Function GetAllDistinctObjIDs() As ObjIDs

See Also

ObjVers Collection | ObjVers Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ObjVers Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ObjVers Collection | ObjVers Members


%%PageItemTitle%%

ToJSON Method
ObjVers Collection : ToJSON Method

Glossary Item Box

Description

Converts the data structure to a JSON string.

Syntax

Visual Basic
Public Function ToJSON() As String

See Also

ObjVers Collection | ObjVers Members


%%PageItemTitle%%

Count Property
ObjVers Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ObjVers Collection | ObjVers Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
ObjVers Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ObjVer

Parameters

Index
Specifies the item's position in the collection.

See Also

ObjVers Collection | ObjVers Members


%%PageItemTitle%%

ObjVerVersion Object
Members See Also Send comments

Glossary Item Box

Description

The 'ObjVerVersion' class represents an object objVerVersion.

Public Methods

Public Method Clone | Creates a copy of the objVer version.
Public Method Serialize | Serializes the version.
Public Method SetExternalRepositoryVersion | Sets the version to represent a specific version for an external repository object.
Public Method SetExternalRepositoryVersionString | Sets the version to represent a specific version for an external repository object.
Public Method SetLatestVersion | Sets the version to represent the latest version.
Public Method SetVersion | Sets the version to represent a specific version for a managed object.
Public Method ToJSON | Converts the data structure to a JSON string.
Public Method Unserialize | Unserializes the version.

Public Properties

Public Property ExternalRepositoryVersionID | The version identifier of the unmanaged object.
Public Property ExternalRepositoryVersionSortKey | The sort key for the external repository version.
Public Property ExternalRepositoryVersionSortKeyAsString | The sort key for the external repository version.
Public Property Type | The version type of the object.
Public Property Version | The version of the managed object.

See Also

ObjVerVersion Members


%%PageItemTitle%%

Clone Method
ObjVerVersion Object : Clone Method

Glossary Item Box

Description

Creates a copy of the objVer version.

Syntax

Visual Basic
Public Function Clone() As ObjVerVersion

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

Serialize Method
ObjVerVersion Object : Serialize Method

Glossary Item Box

Description

Serializes the version.

Syntax

Visual Basic
Public Function Serialize() As Byte()

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

SetExternalRepositoryVersion Method
ExternalRepositoryVersionID
The version of the unmanaged object.
ExternalRepositoryVersionSortKey
The sort key.
ObjVerVersion Object : SetExternalRepositoryVersion Method

Glossary Item Box

Description

Sets the version to represent a specific version for an external repository object.

Syntax

Visual Basic
Public Sub SetExternalRepositoryVersion( _
   ByVal ExternalRepositoryVersionID As String, _
   Optional ByVal ExternalRepositoryVersionSortKey As Unknown = 0 _
)

Parameters

ExternalRepositoryVersionID
The version of the unmanaged object.
ExternalRepositoryVersionSortKey
The sort key.

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

SetExternalRepositoryVersionString Method
ExternalRepositoryVersionID
The version of the external repository object.
ExternalRepositoryVersionSortKey
The sort key.
ObjVerVersion Object : SetExternalRepositoryVersionString Method

Glossary Item Box

Description

Sets the version to represent a specific version for an external repository object.

Syntax

Visual Basic
Public Sub SetExternalRepositoryVersionString( _
   ByVal ExternalRepositoryVersionID As String, _
   Optional ByVal ExternalRepositoryVersionSortKey As String = 0 _
)

Parameters

ExternalRepositoryVersionID
The version of the external repository object.
ExternalRepositoryVersionSortKey
The sort key.

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

SetLatestVersion Method
ObjVerVersion Object : SetLatestVersion Method

Glossary Item Box

Description

Sets the version to represent the latest version.

Syntax

Visual Basic
Public Sub SetLatestVersion()

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

SetVersion Method
Version
The version of the managed object.
ObjVerVersion Object : SetVersion Method

Glossary Item Box

Description

Sets the version to represent a specific version for a managed object.

Syntax

Visual Basic
Public Sub SetVersion( _
   ByVal Version As Long _
)

Parameters

Version
The version of the managed object.

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

ToJSON Method
ObjVerVersion Object : ToJSON Method

Glossary Item Box

Description

Converts the data structure to a JSON string.

Syntax

Visual Basic
Public Function ToJSON() As String

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

Unserialize Method
Bytes
An array of bytes.
ObjVerVersion Object : Unserialize Method

Glossary Item Box

Description

Unserializes the version.

Syntax

Visual Basic
Public Sub Unserialize( _
   ByVal Bytes() As Byte _
)

Parameters

Bytes
An array of bytes.

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

ExternalRepositoryVersionID Property
ObjVerVersion Object : ExternalRepositoryVersionID Property

Glossary Item Box

Description

The version identifier of the unmanaged object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryVersionID As String

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

ExternalRepositoryVersionSortKey Property
ObjVerVersion Object : ExternalRepositoryVersionSortKey Property

Glossary Item Box

Description

The sort key for the external repository version.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryVersionSortKey As Unknown

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

ExternalRepositoryVersionSortKeyAsString Property
ObjVerVersion Object : ExternalRepositoryVersionSortKeyAsString Property

Glossary Item Box

Description

The sort key for the external repository version.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryVersionSortKeyAsString As String

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

Type Property
ObjVerVersion Object : Type Property

Glossary Item Box

Description

The version type of the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type As MFObjVerVersionType

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

Version Property
ObjVerVersion Object : Version Property

Glossary Item Box

Description

The version of the managed object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Version As Long

See Also

ObjVerVersion Object | ObjVerVersion Members


%%PageItemTitle%%

OCROptions Object
Members See Also Send comments

Glossary Item Box

Description

The OCROptions class represents customizable options for OCR operation.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property PrimaryLanguage | Primary language hint for OCR.
Public Property SecondaryLanguage | Secondary language hint for OCR.

Remarks

Proper language settings may often improve the recognition results in OCR operations. The language settings affect the character set and the basic vocabulary used in recognition.

Any language code from MFOCRLanguage enumeration (except MFOCRLanguageNone) can be used as a primary language hint. The valid set of secondary language hints depends on the group of the selected primary language hint. The following combination rules apply:

  • Languages in group 0 can be combined with any other language.
  • Languages in groups 1..6 can be combined with any other language from the same group.
  • Languages in groups 1..6 can be combined with any language from the group 0.
  • MFOCRLanguageNone can be selected as a secondary language hint, effectively meaning that only the primary language hint is to be used.

The language codes are grouped based on their character sets as follows:

  • Group 0
    • MFOCRLanguageNeutral
    • MFOCRLanguageNumbersOnly
    • MFOCRLanguageEnglishUS
    • MFOCRLanguageEnglishBr
  • Group 1
    • MFOCRLanguageGerman
    • MFOCRLanguageFrench
    • MFOCRLanguageSpanish
    • MFOCRLanguageItalian
    • MFOCRLanguageSwedish
    • MFOCRLanguageDanish
    • MFOCRLanguageNorwegian
    • MFOCRLanguageDutch
    • MFOCRLanguagePortuguese
    • MFOCRLanguageBrazilian
    • MFOCRLanguageIcelandic
    • MFOCRLanguageGalician
    • MFOCRLanguageLuxembourgish
    • MFOCRLanguageFinnish
    • MFOCRLanguageAfrikaans
    • MFOCRLanguageAlbanian
    • MFOCRLanguageCatalan
    • MFOCRLanguageIrishGaelic
    • MFOCRLanguageScottishGaelic
    • MFOCRLanguageBasque
    • MFOCRLanguageSwissGerman
    • MFOCRLanguageWelsh
    • MFOCRLanguageMexican
    • MFOCRLanguageNynorsk
  • Group 2
    • MFOCRLanguageGreek
  • Group 3
    • MFOCRLanguageRomanian
    • MFOCRLanguageSlovak
    • MFOCRLanguageCroatian
    • MFOCRLanguageSlovenian
    • MFOCRLanguageCzech
    • MFOCRLanguageHungarian
    • MFOCRLanguagePolish
  • Group 4
    • MFOCRLanguageSerbian
    • MFOCRLanguageRussian
    • MFOCRLanguageUkrainian
    • MFOCRLanguageBulgarian
    • MFOCRLanguageByeloRussian
  • Group 5
    • MFOCRLanguageTurkish
  • Group 6
    • MFOCRLanguageEstonian
    • MFOCRLanguageLatvian
    • MFOCRLanguageLithuanian

See Also

OCROptions Members


%%PageItemTitle%%

Clone Method
OCROptions Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As OCROptions

See Also

OCROptions Object | OCROptions Members


%%PageItemTitle%%

PrimaryLanguage Property
OCROptions Object : PrimaryLanguage Property

Glossary Item Box

Description

Primary language hint for OCR.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrimaryLanguage As MFOCRLanguage

See Also

OCROptions Object | OCROptions Members


%%PageItemTitle%%

SecondaryLanguage Property
OCROptions Object : SecondaryLanguage Property

Glossary Item Box

Description

Secondary language hint for OCR.

Property type

Read-write property

Syntax

Visual Basic
Public Property SecondaryLanguage As MFOCRLanguage

See Also

OCROptions Object | OCROptions Members


%%PageItemTitle%%

OCRPage Object
Members See Also Send comments

Glossary Item Box

Description

The OCRPage class represents a single page that contains OCR zones to be recognized.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property OCRZones | Collection of OCR zones.
Public Property PageNum | Page number.

See Also

OCRPage Members


%%PageItemTitle%%

Clone Method
OCRPage Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As OCRPage

See Also

OCRPage Object | OCRPage Members


%%PageItemTitle%%

OCRZones Property
OCRPage Object : OCRZones Property

Glossary Item Box

Description

Collection of OCR zones.

Property type

Read-write property

Syntax

Visual Basic
Public Property OCRZones As OCRZones

See Also

OCRPage Object | OCRPage Members


%%PageItemTitle%%

PageNum Property
OCRPage Object : PageNum Property

Glossary Item Box

Description

Page number.

Property type

Read-write property

Syntax

Visual Basic
Public Property PageNum As Long

See Also

OCRPage Object | OCRPage Members


%%PageItemTitle%%

OCRPageResult Object
Members See Also Send comments

Glossary Item Box

Description

The OCRPageResult class represents the result for a single page in OCR operation, containing results for all recognized zones on the page.

Public Properties

Public Property OCRZoneResults | Collection of OCR zone results.
Public Property PageNum | Page number.

See Also

OCRPageResult Members


%%PageItemTitle%%

OCRZoneResults Property
OCRPageResult Object : OCRZoneResults Property

Glossary Item Box

Description

Collection of OCR zone results.

Property type

Read-only property

Syntax

Visual Basic
Public Property OCRZoneResults As OCRZoneResults

See Also

OCRPageResult Object | OCRPageResult Members


%%PageItemTitle%%

PageNum Property
OCRPageResult Object : PageNum Property

Glossary Item Box

Description

Page number.

Property type

Read-only property

Syntax

Visual Basic
Public Property PageNum As Long

See Also

OCRPageResult Object | OCRPageResult Members


%%PageItemTitle%%

OCRPageResults Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of OCR page results.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

OCRPageResults Members


%%PageItemTitle%%

Count Property
OCRPageResults Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

OCRPageResults Collection | OCRPageResults Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
OCRPageResults Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As OCRPageResult

Parameters

Index
Specifies the item's position in the collection.

See Also

OCRPageResults Collection | OCRPageResults Members


%%PageItemTitle%%

OCRPages Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of OCR pages.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

OCRPages Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
OCRPage
The new member to add.
OCRPages Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal OCRPage As OCRPage _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
OCRPage
The new member to add.

See Also

OCRPages Collection | OCRPages Members


%%PageItemTitle%%

Clone Method
OCRPages Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As OCRPages

See Also

OCRPages Collection | OCRPages Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
OCRPages Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

OCRPages Collection | OCRPages Members


%%PageItemTitle%%

Count Property
OCRPages Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

OCRPages Collection | OCRPages Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
OCRPages Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As OCRPage

Parameters

Index
Specifies the item's position in the collection.

See Also

OCRPages Collection | OCRPages Members


%%PageItemTitle%%

OCRZone Object
Members See Also Send comments

Glossary Item Box

Description

The OCRZone class represents a single recognition zone in OCR operation.

Public Methods

Public Method ClearOCROptions | Removes zone-specific OCR options from this OCR zone.
Public Method Clone | Creates a copy of the object.
Public Method SetOCROptions | Sets zone-specific OCR options for this OCR zone.

Public Properties

Public Property Barcode | Specifies whether the zone should be interpreted as a barcode.
Public Property DataType | Data type for the OCR zone recognition result.
Public Property DimensionUnit | Dimension unit for zone coordinates.
Public Property HasOCROptions | Specifies whether the OCR zone has block-specific OCR options set.
Public Property Height | Height of the OCR zone.
Public Property ID | User-defined ID of the OCR zone.
Public Property Left | Left offset of the OCR zone.
Public Property Name | User-defined name of the OCR zone.
Public Property OCROptions | Zone-specific OCR options of the OCR zone.
Public Property Top | Top offset of the OCR zone.
Public Property Width | Width of the OCR zone.

Remarks

An OCR zone definition as seen in the user interface of the M-Files Server Administrator application.

See Also

OCRZone Members


%%PageItemTitle%%

ClearOCROptions Method
OCRZone Object : ClearOCROptions Method

Glossary Item Box

Description

Removes zone-specific OCR options from this OCR zone.

Syntax

Visual Basic
Public Sub ClearOCROptions()

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

Clone Method
OCRZone Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As OCRZone

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

SetOCROptions Method
OCROptions
The OCR options specific to this OCR zone.
OCRZone Object : SetOCROptions Method

Glossary Item Box

Description

Sets zone-specific OCR options for this OCR zone.

Syntax

Visual Basic
Public Sub SetOCROptions( _
   ByVal OCROptions As OCROptions _
)

Parameters

OCROptions
The OCR options specific to this OCR zone.

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

Barcode Property
OCRZone Object : Barcode Property

Glossary Item Box

Description

Specifies whether the zone should be interpreted as a barcode.

Property type

Read-write property

Syntax

Visual Basic
Public Property Barcode As Boolean

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

DataType Property
OCRZone Object : DataType Property

Glossary Item Box

Description

Data type for the OCR zone recognition result.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataType As MFDataType

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

DimensionUnit Property
OCRZone Object : DimensionUnit Property

Glossary Item Box

Description

Dimension unit for zone coordinates.

Property type

Read-write property

Syntax

Visual Basic
Public Property DimensionUnit As MFOCRDimensionUnit

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

HasOCROptions Property
OCRZone Object : HasOCROptions Property

Glossary Item Box

Description

Specifies whether the OCR zone has block-specific OCR options set.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasOCROptions As Boolean

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

Height Property
OCRZone Object : Height Property

Glossary Item Box

Description

Height of the OCR zone.

Property type

Read-write property

Syntax

Visual Basic
Public Property Height As Long

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

ID Property
OCRZone Object : ID Property

Glossary Item Box

Description

User-defined ID of the OCR zone.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

Left Property
OCRZone Object : Left Property

Glossary Item Box

Description

Left offset of the OCR zone.

Property type

Read-write property

Syntax

Visual Basic
Public Property Left As Long

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

Name Property
OCRZone Object : Name Property

Glossary Item Box

Description

User-defined name of the OCR zone.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

OCROptions Property
OCRZone Object : OCROptions Property

Glossary Item Box

Description

Zone-specific OCR options of the OCR zone.

Property type

Read-write property

Syntax

Visual Basic
Public Property OCROptions As OCROptions

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

Top Property
OCRZone Object : Top Property

Glossary Item Box

Description

Top offset of the OCR zone.

Property type

Read-write property

Syntax

Visual Basic
Public Property Top As Long

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

Width Property
OCRZone Object : Width Property

Glossary Item Box

Description

Width of the OCR zone.

Property type

Read-write property

Syntax

Visual Basic
Public Property Width As Long

See Also

OCRZone Object | OCRZone Members


%%PageItemTitle%%

OCRZoneResult Object
Members See Also Send comments

Glossary Item Box

Description

The OCRZoneResult class represents the result for single recognized OCR zone.

Public Properties

Public Property Confidence | Confidence level for the result (0 = most confident, 255 = least confident).
Public Property DimensionUnit | Dimension unit for OCR zone positioning.
Public Property Height | Height of the recognized OCR zone.
Public Property ID | ID of the source OCR zone.
Public Property Left | Left offset of the recognized OCR zone.
Public Property RecognizedOnPage | One-based number of the page on which this result was recognized. 0 means no recognition.
Public Property ResultValue | The recognized value.
Public Property Top | Top offset of the recognized OCR zone.
Public Property Width | Width of the recognized OCR zone.

See Also

OCRZoneResult Members


%%PageItemTitle%%

Confidence Property
OCRZoneResult Object : Confidence Property

Glossary Item Box

Description

Confidence level for the result (0 = most confident, 255 = least confident).

Property type

Read-only property

Syntax

Visual Basic
Public Property Confidence As Long

See Also

OCRZoneResult Object | OCRZoneResult Members


%%PageItemTitle%%

DimensionUnit Property
OCRZoneResult Object : DimensionUnit Property

Glossary Item Box

Description

Dimension unit for OCR zone positioning.

Property type

Read-only property

Syntax

Visual Basic
Public Property DimensionUnit As MFOCRDimensionUnit

See Also

OCRZoneResult Object | OCRZoneResult Members


%%PageItemTitle%%

Height Property
OCRZoneResult Object : Height Property

Glossary Item Box

Description

Height of the recognized OCR zone.

Property type

Read-only property

Syntax

Visual Basic
Public Property Height As Long

See Also

OCRZoneResult Object | OCRZoneResult Members


%%PageItemTitle%%

ID Property
OCRZoneResult Object : ID Property

Glossary Item Box

Description

ID of the source OCR zone.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID As Long

See Also

OCRZoneResult Object | OCRZoneResult Members


%%PageItemTitle%%

Left Property
OCRZoneResult Object : Left Property

Glossary Item Box

Description

Left offset of the recognized OCR zone.

Property type

Read-only property

Syntax

Visual Basic
Public Property Left As Long

See Also

OCRZoneResult Object | OCRZoneResult Members


%%PageItemTitle%%

RecognizedOnPage Property
OCRZoneResult Object : RecognizedOnPage Property

Glossary Item Box

Description

One-based number of the page on which this result was recognized. 0 means no recognition.

Property type

Read-only property

Syntax

Visual Basic
Public Property RecognizedOnPage As Long

See Also

OCRZoneResult Object | OCRZoneResult Members


%%PageItemTitle%%

ResultValue Property
OCRZoneResult Object : ResultValue Property

Glossary Item Box

Description

The recognized value.

Property type

Read-only property

Syntax

Visual Basic
Public Property ResultValue As TypedValue

See Also

OCRZoneResult Object | OCRZoneResult Members


%%PageItemTitle%%

Top Property
OCRZoneResult Object : Top Property

Glossary Item Box

Description

Top offset of the recognized OCR zone.

Property type

Read-only property

Syntax

Visual Basic
Public Property Top As Long

See Also

OCRZoneResult Object | OCRZoneResult Members


%%PageItemTitle%%

Width Property
OCRZoneResult Object : Width Property

Glossary Item Box

Description

Width of the recognized OCR zone.

Property type

Read-only property

Syntax

Visual Basic
Public Property Width As Long

See Also

OCRZoneResult Object | OCRZoneResult Members


%%PageItemTitle%%

OCRZoneResults Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of OCR zone results.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

OCRZoneResults Members


%%PageItemTitle%%

Count Property
OCRZoneResults Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

OCRZoneResults Collection | OCRZoneResults Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
OCRZoneResults Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As OCRZoneResult

Parameters

Index
Specifies the item's position in the collection.

See Also

OCRZoneResults Collection | OCRZoneResults Members


%%PageItemTitle%%

OCRZones Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of OCR zones.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

OCRZones Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
OCRZone
The new member to add.
OCRZones Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal OCRZone As OCRZone _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
OCRZone
The new member to add.

See Also

OCRZones Collection | OCRZones Members


%%PageItemTitle%%

Clone Method
OCRZones Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As OCRZones

See Also

OCRZones Collection | OCRZones Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
OCRZones Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

OCRZones Collection | OCRZones Members


%%PageItemTitle%%

Count Property
OCRZones Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

OCRZones Collection | OCRZones Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
OCRZones Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As OCRZone

Parameters

Index
Specifies the item's position in the collection.

See Also

OCRZones Collection | OCRZones Members


%%PageItemTitle%%

OptimizeVaultJob Object
Members See Also Send comments

Glossary Item Box

Description

The OptimizeVaultJob class represents an optimize vault job on the server.

Public Methods

Public Method GetNumberOfSteps | Gets the number of steps in this job.
Public Method GetOneBasedIndexOfStep | Gets the one based index of the step.
Public Method GetStepProgressText | Gets a progress text regarding a step.
Public Method Set | Sets the job information.

Public Properties

Public Property GarbageCollectFiles | Specifies whether the destruction of garbage-collected data files is allowed.
Public Property Thorough | Is this thorough job.
Public Property VaultGUID | The GUID of the vault.

See Also

OptimizeVaultJob Members


%%PageItemTitle%%

GetNumberOfSteps Method
OptimizeVaultJob Object : GetNumberOfSteps Method

Glossary Item Box

Description

Gets the number of steps in this job.

Syntax

Visual Basic
Public Function GetNumberOfSteps() As Long

See Also

OptimizeVaultJob Object | OptimizeVaultJob Members


%%PageItemTitle%%

GetOneBasedIndexOfStep Method
CurrentStep
OptimizeVaultJob Object : GetOneBasedIndexOfStep Method

Glossary Item Box

Description

Gets the one based index of the step.

Syntax

Visual Basic
Public Function GetOneBasedIndexOfStep( _
   ByVal CurrentStep As Long _
) As Long

Parameters

CurrentStep

See Also

OptimizeVaultJob Object | OptimizeVaultJob Members


%%PageItemTitle%%

GetStepProgressText Method
CurrentStep
OptimizeVaultJob Object : GetStepProgressText Method

Glossary Item Box

Description

Gets a progress text regarding a step.

Syntax

Visual Basic
Public Function GetStepProgressText( _
   ByVal CurrentStep As Long _
) As String

Parameters

CurrentStep

See Also

OptimizeVaultJob Object | OptimizeVaultJob Members


%%PageItemTitle%%

Set Method
GuidVault
Thorough
OptimizeVaultJob Object : Set Method

Glossary Item Box

Description

Sets the job information.

Syntax

Visual Basic
Public Sub Set( _
   ByVal GuidVault As String, _
   ByVal Thorough As Boolean _
)

Parameters

GuidVault
Thorough

See Also

OptimizeVaultJob Object | OptimizeVaultJob Members


%%PageItemTitle%%

GarbageCollectFiles Property
OptimizeVaultJob Object : GarbageCollectFiles Property

Glossary Item Box

Description

Specifies whether the destruction of garbage-collected data files is allowed.

Property type

Read-write property

Syntax

Visual Basic
Public Property GarbageCollectFiles As Boolean

See Also

OptimizeVaultJob Object | OptimizeVaultJob Members


%%PageItemTitle%%

Thorough Property
OptimizeVaultJob Object : Thorough Property

Glossary Item Box

Description

Is this thorough job.

Property type

Read-only property

Syntax

Visual Basic
Public Property Thorough As Boolean

See Also

OptimizeVaultJob Object | OptimizeVaultJob Members


%%PageItemTitle%%

VaultGUID Property
OptimizeVaultJob Object : VaultGUID Property

Glossary Item Box

Description

The GUID of the vault.

Property type

Read-only property

Syntax

Visual Basic
Public Property VaultGUID As String

See Also

OptimizeVaultJob Object | OptimizeVaultJob Members


%%PageItemTitle%%

OwnerPropertyDef Object
Members See Also Send comments

Glossary Item Box

Description

The OwnerPropertyDef class represents an owner property definition of an object type.

Public Properties

Public Property DependencyRelation | The dependency relation type of this owner property definition.
Public Property ID | The ID of the owner property definition.
Public Property IndexForAutomaticFilling | The order number of a member in ValueListItem from which a value is gathered for automatic completion.
Public Property IsRelationFiltering | Specifies whether the relation is a filtering relation.

See Also

OwnerPropertyDef Members


%%PageItemTitle%%

DependencyRelation Property
OwnerPropertyDef Object : DependencyRelation Property

Glossary Item Box

Description

The dependency relation type of this owner property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property DependencyRelation As MFDependencyRelation

See Also

OwnerPropertyDef Object | OwnerPropertyDef Members


%%PageItemTitle%%

ID Property
OwnerPropertyDef Object : ID Property

Glossary Item Box

Description

The ID of the owner property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

OwnerPropertyDef Object | OwnerPropertyDef Members


%%PageItemTitle%%

IndexForAutomaticFilling Property
OwnerPropertyDef Object : IndexForAutomaticFilling Property

Glossary Item Box

Description

The order number of a member in ValueListItem from which a value is gathered for automatic completion.

Property type

Read-write property

Syntax

Visual Basic
Public Property IndexForAutomaticFilling As Long

See Also

OwnerPropertyDef Object | OwnerPropertyDef Members


%%PageItemTitle%%

IsRelationFiltering Property
OwnerPropertyDef Object : IsRelationFiltering Property

Glossary Item Box

Description

Specifies whether the relation is a filtering relation.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsRelationFiltering As Boolean

See Also

OwnerPropertyDef Object | OwnerPropertyDef Members


%%PageItemTitle%%

PluginInfo Object
Members See Also Send comments

Glossary Item Box

Description

The PluginInfo class represents description of a plugin.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AssemblyName | The assembly name of the plugin.
Public Property BridgeClassName | The class name of the plugin COM bridge.
Public Property Configuration | The plugin configuration as name-value pairs. Value type is multiline text.
Public Property ConfigurationScope | The scope description of the plugin configuration.
Public Property ConfigurationSource | The full configuration source description as name-value pairs. Value type is multiline text.
Public Property ConfigurationVaultGUID | The vault GUID of the plugin configuration.
Public Property IsDefault | Specifies whether this plugin is the default one.
Public Property IsScopeIndependent | Specifies whether this plugin is independent of configuration scopes.
Public Property Name | The name of the plugin.

See Also

PluginInfo Members


%%PageItemTitle%%

Clone Method
PluginInfo Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PluginInfo

See Also

PluginInfo Object | PluginInfo Members


%%PageItemTitle%%

AssemblyName Property
PluginInfo Object : AssemblyName Property

Glossary Item Box

Description

The assembly name of the plugin.

Property type

Read-write property

Syntax

Visual Basic
Public Property AssemblyName As String

See Also

PluginInfo Object | PluginInfo Members


%%PageItemTitle%%

BridgeClassName Property
PluginInfo Object : BridgeClassName Property

Glossary Item Box

Description

The class name of the plugin COM bridge.

Property type

Read-write property

Syntax

Visual Basic
Public Property BridgeClassName As String

See Also

PluginInfo Object | PluginInfo Members


%%PageItemTitle%%

Configuration Property
PluginInfo Object : Configuration Property

Glossary Item Box

Description

The plugin configuration as name-value pairs. Value type is multiline text.

Property type

Read-write property

Syntax

Visual Basic
Public Property Configuration As NamedValues

See Also

PluginInfo Object | PluginInfo Members


%%PageItemTitle%%

ConfigurationScope Property
PluginInfo Object : ConfigurationScope Property

Glossary Item Box

Description

The scope description of the plugin configuration.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConfigurationScope As String

See Also

PluginInfo Object | PluginInfo Members


%%PageItemTitle%%

ConfigurationSource Property
PluginInfo Object : ConfigurationSource Property

Glossary Item Box

Description

The full configuration source description as name-value pairs. Value type is multiline text.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConfigurationSource As NamedValues

See Also

PluginInfo Object | PluginInfo Members


%%PageItemTitle%%

ConfigurationVaultGUID Property
PluginInfo Object : ConfigurationVaultGUID Property

Glossary Item Box

Description

The vault GUID of the plugin configuration.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConfigurationVaultGUID As String

See Also

PluginInfo Object | PluginInfo Members


%%PageItemTitle%%

IsDefault Property
PluginInfo Object : IsDefault Property

Glossary Item Box

Description

Specifies whether this plugin is the default one.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsDefault As Boolean

See Also

PluginInfo Object | PluginInfo Members


%%PageItemTitle%%

IsScopeIndependent Property
PluginInfo Object : IsScopeIndependent Property

Glossary Item Box

Description

Specifies whether this plugin is independent of configuration scopes.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsScopeIndependent As Boolean

See Also

PluginInfo Object | PluginInfo Members


%%PageItemTitle%%

Name Property
PluginInfo Object : Name Property

Glossary Item Box

Description

The name of the plugin.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

PluginInfo Object | PluginInfo Members


%%PageItemTitle%%

PluginInfos Collection
Members See Also Send comments

Glossary Item Box

Description

The PluginInfos class represents a collection of plugin descriptions.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PluginInfos Members


%%PageItemTitle%%

Add Method
Index
PluginInfo
PluginInfos Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal PluginInfo As PluginInfo _
)

Parameters

Index
PluginInfo

See Also

PluginInfos Collection | PluginInfos Members


%%PageItemTitle%%

Clone Method
PluginInfos Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PluginInfos

See Also

PluginInfos Collection | PluginInfos Members


%%PageItemTitle%%

Remove Method
Index
PluginInfos Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

See Also

PluginInfos Collection | PluginInfos Members


%%PageItemTitle%%

Count Property
PluginInfos Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

PluginInfos Collection | PluginInfos Members


%%PageItemTitle%%

Item Property
Index
PluginInfos Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As PluginInfo

Parameters

Index

See Also

PluginInfos Collection | PluginInfos Members


%%PageItemTitle%%

PropertyDef Object
Members See Also Send comments

Glossary Item Box

Description

The PropertyDef class represents a property definition.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AccessControlList | The ACL that defines the visibility and editability of this property in objects. It is Nothing if the ACL is not set.
Public Property AllObjectTypes | Specifies whether this property definition can be used with all object types.
Public Property AllowedAsGroupingLevel | Specifies whether to allow using this property as a grouping level in views.
Public Property AutomaticValueDefinition | If not NULL, specifies an automatic value for this property.
Public Property AutomaticValueType | Defines the type of the automatic value of this field, if any.
Public Property BasedOnValueList | Specifies whether this property definition is based on a value list.
Public Property ContentType | The content type of the property definition.
Public Property DataType | The data type of the property definition.
Public Property DependencyPD | The ID of the related property definition. MFPseudoPropertyDefAuto (-106) indicates 'automatic filtering'.
Public Property DependencyRelation | The dependency relation type of this property definition.
Public Property FormattingType | If formatting is used for this field, this property specifies it.
Public Property GUID | The GUID as a string.
Public Property HistoryVersionsSearchableByThisProperty | Specifies whether to allow searching for history versions of objects by this property.
Public Property ID | The ID of the property definition.
Public Property Name | The name of the property definition.
Public Property ObjectsSearchableByThisProperty | Specifies whether to allow searching for objects by this property.
Public Property ObjectType | The object type with which this property definition is used. This is valid only if AllObjectTypes is False.
Public Property OwnerPropertyDef | The owner property definition of this property definition.
Public Property Predefined | Specifies whether this property definition is a predefined property definition.
Public Property SortAscending | True to sort in ascending order, false to sort in descending order.
Public Property StaticFilter | Static filter to apply to the values of the property definition's underlying value list or object type.
Public Property ThisIsConflictPD | Specifies whether this property definition is the conflict property definition of the object type.
Public Property ThisIsDefaultPD | Specifies whether this property definition is the one and only default property definition of the object type.
Public Property ThisIsOwnerPD | Specifies whether this property definition is the one and only owner property definition of the object type.
Public Property UpdateType | The update type of the property definition.
Public Property ValidationType | If validation is used for this field, this property specifies the validation type.
Public Property ValueList | The ID of the value list. This is valid only if this property definition is based on a value list.

Remarks

The property definition declares the type and behavior of the object property. The PropertyValue object defines the actual value of the property.

Use the VaultPropertyDefOperations interface to access PropertyDef objects.

Property definitions in M-Files Admin.

See Also

PropertyDef Members


%%PageItemTitle%%

Clone Method
PropertyDef Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyDef

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

AccessControlList Property
PropertyDef Object : AccessControlList Property

Glossary Item Box

Description

The ACL that defines the visibility and editability of this property in objects. It is Nothing if the ACL is not set.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessControlList As AccessControlList

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

AllObjectTypes Property
PropertyDef Object : AllObjectTypes Property

Glossary Item Box

Description

Specifies whether this property definition can be used with all object types.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllObjectTypes As Boolean

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

AllowedAsGroupingLevel Property
PropertyDef Object : AllowedAsGroupingLevel Property

Glossary Item Box

Description

Specifies whether to allow using this property as a grouping level in views.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowedAsGroupingLevel As Boolean

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

AutomaticValueDefinition Property
PropertyDef Object : AutomaticValueDefinition Property

Glossary Item Box

Description

If not NULL, specifies an automatic value for this property.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutomaticValueDefinition As TypedValue

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

AutomaticValueType Property
PropertyDef Object : AutomaticValueType Property

Glossary Item Box

Description

Defines the type of the automatic value of this field, if any.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutomaticValueType As MFAutomaticValueType

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

BasedOnValueList Property
PropertyDef Object : BasedOnValueList Property

Glossary Item Box

Description

Specifies whether this property definition is based on a value list.

Property type

Read-write property

Syntax

Visual Basic
Public Property BasedOnValueList As Boolean

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

ContentType Property
PropertyDef Object : ContentType Property

Glossary Item Box

Description

The content type of the property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property ContentType As MFContentType

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

DataType Property
PropertyDef Object : DataType Property

Glossary Item Box

Description

The data type of the property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property DataType As MFDataType

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

DependencyPD Property
PropertyDef Object : DependencyPD Property

Glossary Item Box

Description

The ID of the related property definition. MFPseudoPropertyDefAuto (-106) indicates 'automatic filtering'.

Property type

Read-write property

Syntax

Visual Basic
Public Property DependencyPD As Long

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

DependencyRelation Property
PropertyDef Object : DependencyRelation Property

Glossary Item Box

Description

The dependency relation type of this property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property DependencyRelation As MFDependencyRelation

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

FormattingType Property
PropertyDef Object : FormattingType Property

Glossary Item Box

Description

If formatting is used for this field, this property specifies it.

Property type

Read-write property

Syntax

Visual Basic
Public Property FormattingType As MFFormattingType

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

GUID Property
PropertyDef Object : GUID Property

Glossary Item Box

Description

The GUID as a string.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID As String

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

HistoryVersionsSearchableByThisProperty Property
PropertyDef Object : HistoryVersionsSearchableByThisProperty Property

Glossary Item Box

Description

Specifies whether to allow searching for history versions of objects by this property.

Property type

Read-write property

Syntax

Visual Basic
Public Property HistoryVersionsSearchableByThisProperty As Boolean

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

ID Property
PropertyDef Object : ID Property

Glossary Item Box

Description

The ID of the property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

Name Property
PropertyDef Object : Name Property

Glossary Item Box

Description

The name of the property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

ObjectsSearchableByThisProperty Property
PropertyDef Object : ObjectsSearchableByThisProperty Property

Glossary Item Box

Description

Specifies whether to allow searching for objects by this property.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectsSearchableByThisProperty As Boolean

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

ObjectType Property
PropertyDef Object : ObjectType Property

Glossary Item Box

Description

The object type with which this property definition is used. This is valid only if AllObjectTypes is False.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectType As Long

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

OwnerPropertyDef Property
PropertyDef Object : OwnerPropertyDef Property

Glossary Item Box

Description

The owner property definition of this property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property OwnerPropertyDef As OwnerPropertyDef

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

Predefined Property
PropertyDef Object : Predefined Property

Glossary Item Box

Description

Specifies whether this property definition is a predefined property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property Predefined As Boolean

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

SortAscending Property
PropertyDef Object : SortAscending Property

Glossary Item Box

Description

True to sort in ascending order, false to sort in descending order.

Property type

Read-write property

Syntax

Visual Basic
Public Property SortAscending As Boolean

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

StaticFilter Property
PropertyDef Object : StaticFilter Property

Glossary Item Box

Description

Static filter to apply to the values of the property definition's underlying value list or object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property StaticFilter As SearchConditions

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

ThisIsConflictPD Property
PropertyDef Object : ThisIsConflictPD Property

Glossary Item Box

Description

Specifies whether this property definition is the conflict property definition of the object type.

Property type

Read-only property

Syntax

Visual Basic
Public Property ThisIsConflictPD As Boolean

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

ThisIsDefaultPD Property
PropertyDef Object : ThisIsDefaultPD Property

Glossary Item Box

Description

Specifies whether this property definition is the one and only default property definition of the object type.

Property type

Read-only property

Syntax

Visual Basic
Public Property ThisIsDefaultPD As Boolean

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

ThisIsOwnerPD Property
PropertyDef Object : ThisIsOwnerPD Property

Glossary Item Box

Description

Specifies whether this property definition is the one and only owner property definition of the object type.

Property type

Read-only property

Syntax

Visual Basic
Public Property ThisIsOwnerPD As Boolean

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

UpdateType Property
PropertyDef Object : UpdateType Property

Glossary Item Box

Description

The update type of the property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property UpdateType As MFUpdateType

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

ValidationType Property
PropertyDef Object : ValidationType Property

Glossary Item Box

Description

If validation is used for this field, this property specifies the validation type.

Property type

Read-write property

Syntax

Visual Basic
Public Property ValidationType As MFValidationType

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

ValueList Property
PropertyDef Object : ValueList Property

Glossary Item Box

Description

The ID of the value list. This is valid only if this property definition is based on a value list.

Property type

Read-write property

Syntax

Visual Basic
Public Property ValueList As Long

See Also

PropertyDef Object | PropertyDef Members


%%PageItemTitle%%

PropertyDefAdmin Object
Members See Also Send comments

Glossary Item Box

Description

The PropertyDefAdmin class represents a property definition (for administrative operations).

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AllowAutomaticPermissions | Gets the mode of allowing automatic permissions via this property.
Public Property AutomaticValue | The definitions for automatic value generation.
Public Property NamedValueNamespaces | The custom data for the property definition.
Public Property PropertyDef | Basic information on the property definition.
Public Property SemanticAliases | The semantic aliases of this property definition.
Public Property Validation | The definitions for property value validation.

See Also

PropertyDefAdmin Members


%%PageItemTitle%%

Clone Method
PropertyDefAdmin Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyDefAdmin

See Also

PropertyDefAdmin Object | PropertyDefAdmin Members


%%PageItemTitle%%

AllowAutomaticPermissions Property
PropertyDefAdmin Object : AllowAutomaticPermissions Property

Glossary Item Box

Description

Gets the mode of allowing automatic permissions via this property.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowAutomaticPermissions As Boolean

See Also

PropertyDefAdmin Object | PropertyDefAdmin Members


%%PageItemTitle%%

AutomaticValue Property
PropertyDefAdmin Object : AutomaticValue Property

Glossary Item Box

Description

The definitions for automatic value generation.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutomaticValue As AutomaticValue

See Also

PropertyDefAdmin Object | PropertyDefAdmin Members


%%PageItemTitle%%

NamedValueNamespaces Property
PropertyDefAdmin Object : NamedValueNamespaces Property

Glossary Item Box

Description

The custom data for the property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property NamedValueNamespaces As NamedValueNamespaces

See Also

PropertyDefAdmin Object | PropertyDefAdmin Members


%%PageItemTitle%%

PropertyDef Property
PropertyDefAdmin Object : PropertyDef Property

Glossary Item Box

Description

Basic information on the property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyDef As PropertyDef

See Also

PropertyDefAdmin Object | PropertyDefAdmin Members


%%PageItemTitle%%

SemanticAliases Property
PropertyDefAdmin Object : SemanticAliases Property

Glossary Item Box

Description

The semantic aliases of this property definition.

Property type

Read-write property

Syntax

Visual Basic
Public Property SemanticAliases As SemanticAliases

See Also

PropertyDefAdmin Object | PropertyDefAdmin Members


%%PageItemTitle%%

Validation Property
PropertyDefAdmin Object : Validation Property

Glossary Item Box

Description

The definitions for property value validation.

Property type

Read-write property

Syntax

Visual Basic
Public Property Validation As Validation

See Also

PropertyDefAdmin Object | PropertyDefAdmin Members


%%PageItemTitle%%

PropertyDefOrObjectType Object
Members See Also Send comments

Glossary Item Box

Description

PropertyDefOrObjectTypes object that defines an ID of a property def or object type.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetAsExpression | Gets this proeprty def or object type as an expression.

Public Properties

Public Property ID | The ID of the property definition or object type.
Public Property PropertyDef | True if the ID represents property definition ID.

See Also

PropertyDefOrObjectType Members


%%PageItemTitle%%

Clone Method
PropertyDefOrObjectType Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyDefOrObjectType

See Also

PropertyDefOrObjectType Object | PropertyDefOrObjectType Members


%%PageItemTitle%%

GetAsExpression Method
PropertyDefOrObjectType Object : GetAsExpression Method

Glossary Item Box

Description

Gets this proeprty def or object type as an expression.

Syntax

Visual Basic
Public Function GetAsExpression() As Expression

See Also

PropertyDefOrObjectType Object | PropertyDefOrObjectType Members


%%PageItemTitle%%

ID Property
PropertyDefOrObjectType Object : ID Property

Glossary Item Box

Description

The ID of the property definition or object type.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

PropertyDefOrObjectType Object | PropertyDefOrObjectType Members


%%PageItemTitle%%

PropertyDef Property
PropertyDefOrObjectType Object : PropertyDef Property

Glossary Item Box

Description

True if the ID represents property definition ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyDef As Boolean

See Also

PropertyDefOrObjectType Object | PropertyDefOrObjectType Members


%%PageItemTitle%%

PropertyDefOrObjectTypes Collection
Members See Also Send comments

Glossary Item Box

Description

PropertyDefOrObjectTypes is a collection PropertyDefOrObjectType objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyDefOrObjectTypes Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
PropertyDefOrObjectType
The new member to add.
PropertyDefOrObjectTypes Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal PropertyDefOrObjectType As PropertyDefOrObjectType _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
PropertyDefOrObjectType
The new member to add.

See Also

PropertyDefOrObjectTypes Collection | PropertyDefOrObjectTypes Members


%%PageItemTitle%%

Clone Method
PropertyDefOrObjectTypes Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyDefOrObjectTypes

See Also

PropertyDefOrObjectTypes Collection | PropertyDefOrObjectTypes Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
PropertyDefOrObjectTypes Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

PropertyDefOrObjectTypes Collection | PropertyDefOrObjectTypes Members


%%PageItemTitle%%

Count Property
PropertyDefOrObjectTypes Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

PropertyDefOrObjectTypes Collection | PropertyDefOrObjectTypes Members


%%PageItemTitle%%

Item Property
Index
PropertyDefOrObjectTypes Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As PropertyDefOrObjectType

Parameters

Index

See Also

PropertyDefOrObjectTypes Collection | PropertyDefOrObjectTypes Members


%%PageItemTitle%%

PropertyDefs Collection
Members See Also Send comments

Glossary Item Box

Description

PropertyDefs is a collection of PropertyDef objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyDefs Members | PropertyDef Object


%%PageItemTitle%%

Add Method
Index
PropertyDef
PropertyDefs Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal PropertyDef As PropertyDef _
)

Parameters

Index
PropertyDef

See Also

PropertyDefs Collection | PropertyDefs Members


%%PageItemTitle%%

Clone Method
PropertyDefs Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyDefs

See Also

PropertyDefs Collection | PropertyDefs Members


%%PageItemTitle%%

Remove Method
Index
PropertyDefs Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

See Also

PropertyDefs Collection | PropertyDefs Members


%%PageItemTitle%%

Count Property
PropertyDefs Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

PropertyDefs Collection | PropertyDefs Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
PropertyDefs Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As PropertyDef

Parameters

Index
Specifies the item's position in the collection.

See Also

PropertyDefs Collection | PropertyDefs Members


%%PageItemTitle%%

PropertyDefsAdmin Collection
Members See Also Send comments

Glossary Item Box

Description

PropertyDefsAdmin is a collection of PropertyDefAdmin objects.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyDefsAdmin Members


%%PageItemTitle%%

Count Property
PropertyDefsAdmin Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

PropertyDefsAdmin Collection | PropertyDefsAdmin Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
PropertyDefsAdmin Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As PropertyDefAdmin

Parameters

Index
Specifies the item's position in the collection.

See Also

PropertyDefsAdmin Collection | PropertyDefsAdmin Members


%%PageItemTitle%%

PropertyValue Object
Members See Also Send comments

Glossary Item Box

Description

The PropertyValue class represents a property value.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method GetValueAsLocalizedText | Gets the current value as localized text. The value is localized based on the culture of the local computer.
Public Method GetValueAsLocalizedTextEx | Gets the current value as localized text. The value is localized based on the culture of the local computer.
Public Method GetValueAsText | Returns the property value in a human-readable format.
Public Method GetValueAsTextEx | Returns the property value in a human-readable format.
Public Method GetValueAsUnlocalizedText | Gets the current value as unlocalized text.

Public Properties

Public Property PropertyDef | The property definition of the property value.
Public Property Value | The typed value of the property value.

Remarks

The property value object is a high-level container for the property value, encapsulating the property definition and the actual property value. The property value is stored in the TypedValue object. The PropertyDef object represents a more detailed type of definition of the property.

You can access the property values of an object by using the ObjectVersionAndProperties object. Alternatively, you may also perform property value-related operations by using the VaultObjectPropertyOperations interface.

Property values of an object (highlighted with the green rectangle) as seen in M-Files Desktop.

See Also

PropertyValue Members | SearchCondition Object


%%PageItemTitle%%

Clone Method
PropertyValue Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyValue

Return Type

Returns the copied property value.

See Also

PropertyValue Object | PropertyValue Members


%%PageItemTitle%%

CloneFrom Method
PropertyValue
PropertyValue Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal PropertyValue As PropertyValue _
)

Parameters

PropertyValue

See Also

PropertyValue Object | PropertyValue Members


%%PageItemTitle%%

GetValueAsLocalizedText Method
PropertyValue Object : GetValueAsLocalizedText Method

Glossary Item Box

Description

Gets the current value as localized text. The value is localized based on the culture of the local computer.

Syntax

Visual Basic
Public Function GetValueAsLocalizedText() As String

Remarks

This method formats time-based values according to the locale settings of the computer the API client is running on, but does not make any time zone based conversions.

See Also

PropertyValue Object | PropertyValue Members


%%PageItemTitle%%

GetValueAsLocalizedTextEx Method
AllowDigitGrouping
If true, digit grouping (= thousands separator) should be used for integers (eDatatypeInteger) and real numbers (eDatatypeFloating).
PropertyValue Object : GetValueAsLocalizedTextEx Method

Glossary Item Box

Description

Gets the current value as localized text. The value is localized based on the culture of the local computer.

Syntax

Visual Basic
Public Function GetValueAsLocalizedTextEx( _
   ByVal AllowDigitGrouping As Boolean _
) As String

Parameters

AllowDigitGrouping
If true, digit grouping (= thousands separator) should be used for integers (eDatatypeInteger) and real numbers (eDatatypeFloating).

Remarks

This method formats time-based values according to the locale settings of the computer the API client is running on, but does not make any time zone based conversions.

See Also

PropertyValue Object | PropertyValue Members


%%PageItemTitle%%

GetValueAsText Method
Localized
Specifies whether the value is to be localized (for example dates).
NULLAsEmptyString
If this parameter is set to true, a NULL value should be returned as an empty string. Otherwise, it returns the stringified version of NULL, typically (null) or (empty).
EmptyLookupDisplayValuesAsHidden
If the property value is empty, specifies whether the returned value should be treated as a hidden value.
LongDateFormat
True to set the possible timestamp to be presented in the long date format.
NoSeconds
If true, seconds are not included in the formatted string.
NumericValueAsKilobytes
True to return numeric values as kilobytes.
PropertyValue Object : GetValueAsText Method

Glossary Item Box

Description

Returns the property value in a human-readable format.

Syntax

Visual Basic
Public Function GetValueAsText( _
   ByVal Localized As Boolean, _
   ByVal NULLAsEmptyString As Boolean, _
   ByVal EmptyLookupDisplayValuesAsHidden As Boolean, _
   ByVal LongDateFormat As Boolean, _
   ByVal NoSeconds As Boolean, _
   ByVal NumericValueAsKilobytes As Boolean _
) As String

Parameters

Localized
Specifies whether the value is to be localized (for example dates).
NULLAsEmptyString
If this parameter is set to true, a NULL value should be returned as an empty string. Otherwise, it returns the stringified version of NULL, typically (null) or (empty).
EmptyLookupDisplayValuesAsHidden
If the property value is empty, specifies whether the returned value should be treated as a hidden value.
LongDateFormat
True to set the possible timestamp to be presented in the long date format.
NoSeconds
If true, seconds are not included in the formatted string.
NumericValueAsKilobytes
True to return numeric values as kilobytes.

Return Type

Returns the string containing the display value of the property value.

See Also

PropertyValue Object | PropertyValue Members


%%PageItemTitle%%

GetValueAsTextEx Method
Localized
Specifies whether the value is to be localized (for example dates).
NULLAsEmptyString
If this parameter is set to true, a NULL value should be returned as an empty string. Otherwise, it returns the stringified version of NULL, typically (null) or (empty).
EmptyLookupDisplayValuesAsHidden
If the property value is empty, specifies whether the returned value should be treated as a hidden value.
LongDateFormat
True to set the possible timestamp to be presented in the long date format.
NoSeconds
If true, seconds are not included in the formatted string.
NumericValueAsKilobytes
True to return numeric values as kilobytes.
AllowDigitGrouping
If true, digit grouping (= thousands separator) should be used for integers (eDatatypeInteger) and real numbers (eDatatypeFloating).
PropertyValue Object : GetValueAsTextEx Method

Glossary Item Box

Description

Returns the property value in a human-readable format.

Syntax

Visual Basic
Public Function GetValueAsTextEx( _
   ByVal Localized As Boolean, _
   ByVal NULLAsEmptyString As Boolean, _
   ByVal EmptyLookupDisplayValuesAsHidden As Boolean, _
   ByVal LongDateFormat As Boolean, _
   ByVal NoSeconds As Boolean, _
   ByVal NumericValueAsKilobytes As Boolean, _
   ByVal AllowDigitGrouping As Boolean _
) As String

Parameters

Localized
Specifies whether the value is to be localized (for example dates).
NULLAsEmptyString
If this parameter is set to true, a NULL value should be returned as an empty string. Otherwise, it returns the stringified version of NULL, typically (null) or (empty).
EmptyLookupDisplayValuesAsHidden
If the property value is empty, specifies whether the returned value should be treated as a hidden value.
LongDateFormat
True to set the possible timestamp to be presented in the long date format.
NoSeconds
If true, seconds are not included in the formatted string.
NumericValueAsKilobytes
True to return numeric values as kilobytes.
AllowDigitGrouping
If true, digit grouping (= thousands separator) should be used for integers (eDatatypeInteger) and real numbers (eDatatypeFloating).

See Also

PropertyValue Object | PropertyValue Members


%%PageItemTitle%%

GetValueAsUnlocalizedText Method
PropertyValue Object : GetValueAsUnlocalizedText Method

Glossary Item Box

Description

Gets the current value as unlocalized text.

Syntax

Visual Basic
Public Function GetValueAsUnlocalizedText() As String

See Also

PropertyValue Object | PropertyValue Members


%%PageItemTitle%%

PropertyDef Property
PropertyValue Object : PropertyDef Property

Glossary Item Box

Description

The property definition of the property value.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyDef As Long

Return Type

The property definition ID.

Remarks

Use the VaultPropertyDefOperations interface to obtain the PropertyDef object for the ID.

See Also

PropertyValue Object | PropertyValue Members


%%PageItemTitle%%

Value Property
PropertyValue Object : Value Property

Glossary Item Box

Description

The typed value of the property value.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value As TypedValue

See Also

PropertyValue Object | PropertyValue Members


%%PageItemTitle%%

PropertyValueForDisplay Object
Members See Also Send comments

Glossary Item Box

Description

The PropertyValueForDisplay class represents a property value for display purposes.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ContentType | The content type of the property definition.
Public Property DataType | The data type of the property definition.
Public Property DisplayValue | The display value of the property.
Public Property PropertyDef | The property definition of the property value.
Public Property PropertyDefName | The name of the property definition.
Public Property PropertyValue | The associated property value.
Public Property ReadOnly | Specifies whether the property is read-only (i.e., updated by the server.

Remarks

The value of the property is included as a string and cannot be changed. Use the VaultObjectPropertyOperations interface to access objects of this class.

See Also

PropertyValueForDisplay Members


%%PageItemTitle%%

Clone Method
PropertyValueForDisplay Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyValueForDisplay

See Also

PropertyValueForDisplay Object | PropertyValueForDisplay Members


%%PageItemTitle%%

ContentType Property
PropertyValueForDisplay Object : ContentType Property

Glossary Item Box

Description

The content type of the property definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property ContentType As MFContentType

See Also

PropertyValueForDisplay Object | PropertyValueForDisplay Members


%%PageItemTitle%%

DataType Property
PropertyValueForDisplay Object : DataType Property

Glossary Item Box

Description

The data type of the property definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property DataType As MFDataType

See Also

PropertyValueForDisplay Object | PropertyValueForDisplay Members


%%PageItemTitle%%

DisplayValue Property
PropertyValueForDisplay Object : DisplayValue Property

Glossary Item Box

Description

The display value of the property.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayValue As String

See Also

PropertyValueForDisplay Object | PropertyValueForDisplay Members


%%PageItemTitle%%

PropertyDef Property
PropertyValueForDisplay Object : PropertyDef Property

Glossary Item Box

Description

The property definition of the property value.

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyDef As Long

See Also

PropertyValueForDisplay Object | PropertyValueForDisplay Members


%%PageItemTitle%%

PropertyDefName Property
PropertyValueForDisplay Object : PropertyDefName Property

Glossary Item Box

Description

The name of the property definition.

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyDefName As String

See Also

PropertyValueForDisplay Object | PropertyValueForDisplay Members


%%PageItemTitle%%

PropertyValue Property
PropertyValueForDisplay Object : PropertyValue Property

Glossary Item Box

Description

The associated property value.

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyValue As PropertyValue

See Also

PropertyValueForDisplay Object | PropertyValueForDisplay Members


%%PageItemTitle%%

ReadOnly Property
PropertyValueForDisplay Object : ReadOnly Property

Glossary Item Box

Description

Specifies whether the property is read-only (i.e., updated by the server.

Property type

Read-only property

Syntax

Visual Basic
Public Property ReadOnly As Boolean

See Also

PropertyValueForDisplay Object | PropertyValueForDisplay Members


%%PageItemTitle%%

PropertyValueIconClue Object
Members See Also Send comments

Glossary Item Box

Description

PropertyValueIconClue object indicates a property value of an object that has an icon associated with the selected value list item.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property PropertyDef | Property definition
Public Property ValueListItem | Value list item

See Also

PropertyValueIconClue Members


%%PageItemTitle%%

Clone Method
PropertyValueIconClue Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyValueIconClue

See Also

PropertyValueIconClue Object | PropertyValueIconClue Members


%%PageItemTitle%%

PropertyDef Property
PropertyValueIconClue Object : PropertyDef Property

Glossary Item Box

Description

Property definition

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyDef As Long

See Also

PropertyValueIconClue Object | PropertyValueIconClue Members


%%PageItemTitle%%

ValueListItem Property
PropertyValueIconClue Object : ValueListItem Property

Glossary Item Box

Description

Value list item

Property type

Read-only property

Syntax

Visual Basic
Public Property ValueListItem As Long

See Also

PropertyValueIconClue Object | PropertyValueIconClue Members


%%PageItemTitle%%

PropertyValueIconClues Collection
Members See Also Send comments

Glossary Item Box

Description

PropertyValueIconClues is a collection of PropertyValueIconClue objects.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValueIconClues Members


%%PageItemTitle%%

Clone Method
PropertyValueIconClues Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyValueIconClues

See Also

PropertyValueIconClues Collection | PropertyValueIconClues Members


%%PageItemTitle%%

Count Property
PropertyValueIconClues Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

PropertyValueIconClues Collection | PropertyValueIconClues Members


%%PageItemTitle%%

Item Property
Index
PropertyValueIconClues Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As PropertyValueIconClue

Parameters

Index

See Also

PropertyValueIconClues Collection | PropertyValueIconClues Members


%%PageItemTitle%%

PropertyValues Collection
Members See Also Send comments

Glossary Item Box

Description

PropertyValues is a collection of PropertyValue objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method EqualTo | Checks for equality to the specified object.
Public Method IndexOf | Returns the index of the specified property value in the collection, or -1 if the specified property value does not exist in the collection.
Public Method IndexOfByAlias | Returns the index of the specified property value in the collection, or -1 if the specified property value does not exist in the collection. Uses an alias to identify the property.
Public Method Remove | Removes the item at the specified position.
Public Method SearchForProperty | Searches the collection for a specified property value.
Public Method SearchForPropertyByAlias | Searches the collection for a specified property value. Uses an alias to identify the property.
Public Method SearchForPropertyEx | Searches the collection for a specified property value.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValues Members | PropertyValue Object


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
PropertyValue
The new member to add.
PropertyValues Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal PropertyValue As PropertyValue _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
PropertyValue
The new member to add.

See Also

PropertyValues Collection | PropertyValues Members


%%PageItemTitle%%

Clone Method
PropertyValues Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyValues

See Also

PropertyValues Collection | PropertyValues Members


%%PageItemTitle%%

CloneFrom Method
PropertyValues
The object that is used as the source for cloning.
PropertyValues Collection : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal PropertyValues As PropertyValues _
)

Parameters

PropertyValues
The object that is used as the source for cloning.

See Also

PropertyValues Collection | PropertyValues Members


%%PageItemTitle%%

EqualTo Method
pIPropertyValues
The property values to compare to.
PropertyValues Collection : EqualTo Method

Glossary Item Box

Description

Checks for equality to the specified object.

Syntax

Visual Basic
Public Function EqualTo( _
   ByVal pIPropertyValues As PropertyValues _
) As Boolean

Parameters

pIPropertyValues
The property values to compare to.

Remarks

Supported in M-Files 19.4.7683.3 and later.

See Also

PropertyValues Collection | PropertyValues Members


%%PageItemTitle%%

IndexOf Method
PropertyDef
The ID of the property definition to search for.
PropertyValues Collection : IndexOf Method

Glossary Item Box

Description

Returns the index of the specified property value in the collection, or -1 if the specified property value does not exist in the collection.

Syntax

Visual Basic
Public Function IndexOf( _
   ByVal PropertyDef As Long _
) As Long

Parameters

PropertyDef
The ID of the property definition to search for.

See Also

PropertyValues Collection | PropertyValues Members


%%PageItemTitle%%

IndexOfByAlias Method
Vault
The target vault.
PropertyDefAlias
The alias of the property to search for.
PropertyValues Collection : IndexOfByAlias Method

Glossary Item Box

Description

Returns the index of the specified property value in the collection, or -1 if the specified property value does not exist in the collection. Uses an alias to identify the property.

Syntax

Visual Basic
Public Function IndexOfByAlias( _
   ByVal Vault As Vault, _
   ByVal PropertyDefAlias As String _
) As Long

Parameters

Vault
The target vault.
PropertyDefAlias
The alias of the property to search for.

See Also

PropertyValues Collection | PropertyValues Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
PropertyValues Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

PropertyValues Collection | PropertyValues Members


%%PageItemTitle%%

SearchForProperty Method
PropertyDef
The property definition ID to search for.
PropertyValues Collection : SearchForProperty Method

Glossary Item Box

Description

Searches the collection for a specified property value.

Syntax

Visual Basic
Public Function SearchForProperty( _
   ByVal PropertyDef As Long _
) As PropertyValue

Parameters

PropertyDef
The property definition ID to search for.

Remarks

Consider using the more recent SearchForPropertyEx Method instead.

See Also

PropertyValues Collection | PropertyValues Members


%%PageItemTitle%%

SearchForPropertyByAlias Method
Vault
The target vault.
PropertyDefAlias
The alias of the property to search for.
ReturnNULLIfNotFound
If true, the method will return NULL if the specified property is not found. If false, the method raises an error if the specified property is not found.
PropertyValues Collection : SearchForPropertyByAlias Method

Glossary Item Box

Description

Searches the collection for a specified property value. Uses an alias to identify the property.

Syntax

Visual Basic
Public Function SearchForPropertyByAlias( _
   ByVal Vault As Vault, _
   ByVal PropertyDefAlias As String, _
   ByVal ReturnNULLIfNotFound As Boolean _
) As PropertyValue

Parameters

Vault
The target vault.
PropertyDefAlias
The alias of the property to search for.
ReturnNULLIfNotFound
If true, the method will return NULL if the specified property is not found. If false, the method raises an error if the specified property is not found.

Remarks

See also SearchForPropertyEx Method.

See Also

PropertyValues Collection | PropertyValues Members


%%PageItemTitle%%

SearchForPropertyEx Method
PropertyDef
The property to search for.
ReturnNULLIfNotFound
If true, the method will return NULL if the specified property is not found. If false, the method raises an error if the specified property is not found.
PropertyValues Collection : SearchForPropertyEx Method

Glossary Item Box

Description

Searches the collection for a specified property value.

Syntax

Visual Basic
Public Function SearchForPropertyEx( _
   ByVal PropertyDef As Long, _
   ByVal ReturnNULLIfNotFound As Boolean _
) As PropertyValue

Parameters

PropertyDef
The property to search for.
ReturnNULLIfNotFound
If true, the method will return NULL if the specified property is not found. If false, the method raises an error if the specified property is not found.

See Also

PropertyValues Collection | PropertyValues Members


%%PageItemTitle%%

Count Property
PropertyValues Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

PropertyValues Collection | PropertyValues Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
PropertyValues Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As PropertyValue

Parameters

Index
Specifies the item's position in the collection.

See Also

PropertyValues Collection | PropertyValues Members


%%PageItemTitle%%

PropertyValuesForDisplay Collection
Members See Also Send comments

Glossary Item Box

Description

PropertyValuesForDisplay is a collection of PropertyValueForDisplay objects.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValuesForDisplay Members


%%PageItemTitle%%

Count Property
PropertyValuesForDisplay Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

PropertyValuesForDisplay Collection | PropertyValuesForDisplay Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
PropertyValuesForDisplay Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As PropertyValueForDisplay

Parameters

Index
Specifies the item's position in the collection.

See Also

PropertyValuesForDisplay Collection | PropertyValuesForDisplay Members


%%PageItemTitle%%

PropertyValuesOfMultipleObjects Collection
Members See Also Send comments

Glossary Item Box

Description

PropertyValuesOfMultipleObjects is a collection of PropertyValues collections. Each PropertyValues collection represents the property values of one object version. Use PropertyValuesOfMultipleObjectsEx for more options.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

Remarks

Use the VaultObjectPropertyOperations interface for reading properties for multiple object versions.

See Also

PropertyValuesOfMultipleObjects Members


%%PageItemTitle%%

Clone Method
PropertyValuesOfMultipleObjects Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyValuesOfMultipleObjects

See Also

PropertyValuesOfMultipleObjects Collection | PropertyValuesOfMultipleObjects Members


%%PageItemTitle%%

Count Property
PropertyValuesOfMultipleObjects Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

PropertyValuesOfMultipleObjects Collection | PropertyValuesOfMultipleObjects Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
PropertyValuesOfMultipleObjects Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As PropertyValues

Parameters

Index
Specifies the item's position in the collection.

See Also

PropertyValuesOfMultipleObjects Collection | PropertyValuesOfMultipleObjects Members


%%PageItemTitle%%

PropertyValuesOfMultipleObjectsEx Collection
Members See Also Send comments

Glossary Item Box

Description

PropertyValuesOfMultipleObjectsEx is a collection of PropertyValues collections. Each PropertyValues collection represents the property values of one object version.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

PropertyValuesOfMultipleObjectsEx Members


%%PageItemTitle%%

Add Method
Index
PropertyValues
PropertyValuesOfMultipleObjectsEx Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal PropertyValues As PropertyValues _
)

Parameters

Index
PropertyValues

See Also

PropertyValuesOfMultipleObjectsEx Collection | PropertyValuesOfMultipleObjectsEx Members


%%PageItemTitle%%

Clone Method
PropertyValuesOfMultipleObjectsEx Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyValuesOfMultipleObjects

See Also

PropertyValuesOfMultipleObjectsEx Collection | PropertyValuesOfMultipleObjectsEx Members


%%PageItemTitle%%

Remove Method
Index
PropertyValuesOfMultipleObjectsEx Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

See Also

PropertyValuesOfMultipleObjectsEx Collection | PropertyValuesOfMultipleObjectsEx Members


%%PageItemTitle%%

Count Property
PropertyValuesOfMultipleObjectsEx Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

PropertyValuesOfMultipleObjectsEx Collection | PropertyValuesOfMultipleObjectsEx Members


%%PageItemTitle%%

Item Property
Index
PropertyValuesOfMultipleObjectsEx Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As PropertyValues

Parameters

Index

See Also

PropertyValuesOfMultipleObjectsEx Collection | PropertyValuesOfMultipleObjectsEx Members


%%PageItemTitle%%

PropertyValuesOfMultipleObjectsForDisplay Collection
Members See Also Send comments

Glossary Item Box

Description

'PropertyValuesOfMultipleObjectsForDisplay' is a collection of 'PropertyValuesForDisplay' collections.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

Remarks

Each 'PropertyValuesForDisplay' collection represents the property values of one object version that are to be used for display purposes.

See Also

PropertyValuesOfMultipleObjectsForDisplay Members


%%PageItemTitle%%

Clone Method
PropertyValuesOfMultipleObjectsForDisplay Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyValuesOfMultipleObjectsForDisplay

See Also

PropertyValuesOfMultipleObjectsForDisplay Collection | PropertyValuesOfMultipleObjectsForDisplay Members


%%PageItemTitle%%

Count Property
PropertyValuesOfMultipleObjectsForDisplay Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

PropertyValuesOfMultipleObjectsForDisplay Collection | PropertyValuesOfMultipleObjectsForDisplay Members


%%PageItemTitle%%

Item Property
Index
PropertyValuesOfMultipleObjectsForDisplay Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As PropertyValuesForDisplay

Parameters

Index

See Also

PropertyValuesOfMultipleObjectsForDisplay Collection | PropertyValuesOfMultipleObjectsForDisplay Members


%%PageItemTitle%%

PropertyValueSuggestion Object
Members See Also Send comments

Glossary Item Box

Description

The 'PropertyValueSuggestion' class represents the single property value that is a candidate for object metadata.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property DisplayValue | The textual representation of the suggested value.
Public Property IsFact | True if the property value suggestion is understood to be a known fact.
Public Property IsNewValue | True if the suggested value does not already exist in the value lists.
Public Property PropertyDef | The property definition ID.
Public Property Quality | The quality of the property value suggestion.
Public Property TypedValue | The typed value.

See Also

PropertyValueSuggestion Members


%%PageItemTitle%%

Clone Method
PropertyValueSuggestion Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyValueSuggestion

See Also

PropertyValueSuggestion Object | PropertyValueSuggestion Members


%%PageItemTitle%%

DisplayValue Property
PropertyValueSuggestion Object : DisplayValue Property

Glossary Item Box

Description

The textual representation of the suggested value.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayValue As String

See Also

PropertyValueSuggestion Object | PropertyValueSuggestion Members


%%PageItemTitle%%

IsFact Property
PropertyValueSuggestion Object : IsFact Property

Glossary Item Box

Description

True if the property value suggestion is understood to be a known fact.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsFact As Boolean

See Also

PropertyValueSuggestion Object | PropertyValueSuggestion Members


%%PageItemTitle%%

IsNewValue Property
PropertyValueSuggestion Object : IsNewValue Property

Glossary Item Box

Description

True if the suggested value does not already exist in the value lists.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsNewValue As Boolean

See Also

PropertyValueSuggestion Object | PropertyValueSuggestion Members


%%PageItemTitle%%

PropertyDef Property
PropertyValueSuggestion Object : PropertyDef Property

Glossary Item Box

Description

The property definition ID.

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyDef As Long

See Also

PropertyValueSuggestion Object | PropertyValueSuggestion Members


%%PageItemTitle%%

Quality Property
PropertyValueSuggestion Object : Quality Property

Glossary Item Box

Description

The quality of the property value suggestion.

Property type

Read-only property

Syntax

Visual Basic
Public Property Quality As Single

See Also

PropertyValueSuggestion Object | PropertyValueSuggestion Members


%%PageItemTitle%%

TypedValue Property
PropertyValueSuggestion Object : TypedValue Property

Glossary Item Box

Description

The typed value.

Property type

Read-only property

Syntax

Visual Basic
Public Property TypedValue As TypedValue

See Also

PropertyValueSuggestion Object | PropertyValueSuggestion Members


%%PageItemTitle%%

PropertyValueSuggestions Collection
Members See Also Send comments

Glossary Item Box

Description

The 'PropertyValueSuggestions' class represents a collection of property values that are candidates for object metadata.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValueSuggestions Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
IPropertyValueSuggestion
The new member to add.
PropertyValueSuggestions Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal IPropertyValueSuggestion As PropertyValueSuggestion _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
IPropertyValueSuggestion
The new member to add.

See Also

PropertyValueSuggestions Collection | PropertyValueSuggestions Members


%%PageItemTitle%%

Clone Method
PropertyValueSuggestions Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyValueSuggestions

See Also

PropertyValueSuggestions Collection | PropertyValueSuggestions Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
PropertyValueSuggestions Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

PropertyValueSuggestions Collection | PropertyValueSuggestions Members


%%PageItemTitle%%

Count Property
PropertyValueSuggestions Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

PropertyValueSuggestions Collection | PropertyValueSuggestions Members


%%PageItemTitle%%

Item Property
Index
PropertyValueSuggestions Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As PropertyValueSuggestion

Parameters

Index

See Also

PropertyValueSuggestions Collection | PropertyValueSuggestions Members


%%PageItemTitle%%

PropertyValuesWithIconClues Object
Members See Also Send comments

Glossary Item Box

Description

Property values with their icon clues.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property IconClues | The icon clues for the property values.
Public Property ObjVer | The object version the properties are associated with.
Public Property PropertyValues | The property values.

See Also

PropertyValuesWithIconClues Members


%%PageItemTitle%%

Clone Method
PropertyValuesWithIconClues Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyValuesWithIconClues

See Also

PropertyValuesWithIconClues Object | PropertyValuesWithIconClues Members


%%PageItemTitle%%

IconClues Property
PropertyValuesWithIconClues Object : IconClues Property

Glossary Item Box

Description

The icon clues for the property values.

Property type

Read-only property

Syntax

Visual Basic
Public Property IconClues As PropertyValueIconClues

See Also

PropertyValuesWithIconClues Object | PropertyValuesWithIconClues Members


%%PageItemTitle%%

ObjVer Property
PropertyValuesWithIconClues Object : ObjVer Property

Glossary Item Box

Description

The object version the properties are associated with.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjVer As ObjVer

See Also

PropertyValuesWithIconClues Object | PropertyValuesWithIconClues Members


%%PageItemTitle%%

PropertyValues Property
PropertyValuesWithIconClues Object : PropertyValues Property

Glossary Item Box

Description

The property values.

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyValues As PropertyValues

See Also

PropertyValuesWithIconClues Object | PropertyValuesWithIconClues Members


%%PageItemTitle%%

PropertyValuesWithIconCluesOfMultipleObjects Collection
Members See Also Send comments

Glossary Item Box

Description

Property values with their icon clues of multiple objects.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValuesWithIconCluesOfMultipleObjects Members


%%PageItemTitle%%

Clone Method
PropertyValuesWithIconCluesOfMultipleObjects Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As PropertyValuesWithIconCluesOfMultipleObjects

See Also

PropertyValuesWithIconCluesOfMultipleObjects Collection | PropertyValuesWithIconCluesOfMultipleObjects Members


%%PageItemTitle%%

Count Property
PropertyValuesWithIconCluesOfMultipleObjects Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

PropertyValuesWithIconCluesOfMultipleObjects Collection | PropertyValuesWithIconCluesOfMultipleObjects Members


%%PageItemTitle%%

Item Property
Index
PropertyValuesWithIconCluesOfMultipleObjects Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As PropertyValuesWithIconClues

Parameters

Index

See Also

PropertyValuesWithIconCluesOfMultipleObjects Collection | PropertyValuesWithIconCluesOfMultipleObjects Members


%%PageItemTitle%%

ReportAccessCredentials Object
Members See Also Send comments

Glossary Item Box

Description

The ReportAccessCredentials contains the credentials that are used when accessing reports using M-Files user account.

Public Properties

Public Property Domain | The domain.
Public Property ExtAccount | True if the user is authenticated with external user authentication mode.
Public Property Password | The user's password.
Public Property UserName | The username.

See Also

ReportAccessCredentials Members


%%PageItemTitle%%

Domain Property
ReportAccessCredentials Object : Domain Property

Glossary Item Box

Description

The domain.

Property type

Read-only property

Syntax

Visual Basic
Public Property Domain As String

See Also

ReportAccessCredentials Object | ReportAccessCredentials Members


%%PageItemTitle%%

ExtAccount Property
ReportAccessCredentials Object : ExtAccount Property

Glossary Item Box

Description

True if the user is authenticated with external user authentication mode.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExtAccount As Boolean

See Also

ReportAccessCredentials Object | ReportAccessCredentials Members


%%PageItemTitle%%

Password Property
ReportAccessCredentials Object : Password Property

Glossary Item Box

Description

The user's password.

Property type

Read-only property

Syntax

Visual Basic
Public Property Password As String

See Also

ReportAccessCredentials Object | ReportAccessCredentials Members


%%PageItemTitle%%

UserName Property
ReportAccessCredentials Object : UserName Property

Glossary Item Box

Description

The username.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserName As String

See Also

ReportAccessCredentials Object | ReportAccessCredentials Members


%%PageItemTitle%%

RestoreJob Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents a restore job.

Public Properties

Public Property BackupFileDifferential | Full path to the backup file on server (differential backup, optional).
Public Property BackupFileFull | Full path to the backup file on server (full backup).
Public Property Impersonation | Impersonation information to specify the access to the target files.
Public Property OverwriteExistingFiles | Specifies whether existing target files are to be overwritten. If false, restore fails if a target file already exists.
Public Property VaultProperties | Vault information.

Remarks

A vault restore job definition as seen in M-Files Admin.

See Also

RestoreJob Members


%%PageItemTitle%%

BackupFileDifferential Property
RestoreJob Object : BackupFileDifferential Property

Glossary Item Box

Description

Full path to the backup file on server (differential backup, optional).

Property type

Read-write property

Syntax

Visual Basic
Public Property BackupFileDifferential As String

See Also

RestoreJob Object | RestoreJob Members


%%PageItemTitle%%

BackupFileFull Property
RestoreJob Object : BackupFileFull Property

Glossary Item Box

Description

Full path to the backup file on server (full backup).

Property type

Read-write property

Syntax

Visual Basic
Public Property BackupFileFull As String

See Also

RestoreJob Object | RestoreJob Members


%%PageItemTitle%%

Impersonation Property
RestoreJob Object : Impersonation Property

Glossary Item Box

Description

Impersonation information to specify the access to the target files.

Property type

Read-write property

Syntax

Visual Basic
Public Property Impersonation As Impersonation

See Also

RestoreJob Object | RestoreJob Members


%%PageItemTitle%%

OverwriteExistingFiles Property
RestoreJob Object : OverwriteExistingFiles Property

Glossary Item Box

Description

Specifies whether existing target files are to be overwritten. If false, restore fails if a target file already exists.

Property type

Read-write property

Syntax

Visual Basic
Public Property OverwriteExistingFiles As Boolean

See Also

RestoreJob Object | RestoreJob Members


%%PageItemTitle%%

VaultProperties Property
RestoreJob Object : VaultProperties Property

Glossary Item Box

Description

Vault information.

Property type

Read-write property

Syntax

Visual Basic
Public Property VaultProperties As VaultProperties

See Also

RestoreJob Object | RestoreJob Members


%%PageItemTitle%%

ScheduledJob Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents a single scheduled job.

Public Methods

Public Method SetBackupVaultJob | Sets the backup vault job.
Public Method SetExportContentJob | Sets the export content job.
Public Method SetImportContentJob | Sets the import content job.
Public Method SetOptimizeVaultJob | Sets the optimize vault job.

Public Properties

Public Property BackupVaultJob | Description of the actual backup vault job.
Public Property Enabled | Specifies whether the scheduled job is enabled.
Public Property ExportContentJob | Description of the actual export content job.
Public Property ID | The ID of the scheduled job.
Public Property ImportContentJob | Description of the actual import content job.
Public Property JobName | The name of the scheduled job.
Public Property JobType | The type of the scheduled job.
Public Property OptimizeVaultJob | Description of the actual optimize vault job.
Public Property Temporary | Specifies whether the scheduled job is temporary only.
Public Property Triggers | Collection of execution triggers.

Remarks

A scheduled job definition as seen in the user interface of the M-Files Server Administrator application.

See Also

ScheduledJob Members


%%PageItemTitle%%

SetBackupVaultJob Method
BackupVaultJob
ScheduledJob Object : SetBackupVaultJob Method

Glossary Item Box

Description

Sets the backup vault job.

Syntax

Visual Basic
Public Sub SetBackupVaultJob( _
   ByVal BackupVaultJob As BackupJob _
)

Parameters

BackupVaultJob

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

SetExportContentJob Method
ExportContentJob
ScheduledJob Object : SetExportContentJob Method

Glossary Item Box

Description

Sets the export content job.

Syntax

Visual Basic
Public Sub SetExportContentJob( _
   ByVal ExportContentJob As ExportContentJob _
)

Parameters

ExportContentJob

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

SetImportContentJob Method
ImportContentJob
ScheduledJob Object : SetImportContentJob Method

Glossary Item Box

Description

Sets the import content job.

Syntax

Visual Basic
Public Sub SetImportContentJob( _
   ByVal ImportContentJob As ImportContentJob _
)

Parameters

ImportContentJob

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

SetOptimizeVaultJob Method
OptimizeVaultJob
ScheduledJob Object : SetOptimizeVaultJob Method

Glossary Item Box

Description

Sets the optimize vault job.

Syntax

Visual Basic
Public Sub SetOptimizeVaultJob( _
   ByVal OptimizeVaultJob As OptimizeVaultJob _
)

Parameters

OptimizeVaultJob

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

BackupVaultJob Property
ScheduledJob Object : BackupVaultJob Property

Glossary Item Box

Description

Description of the actual backup vault job.

Property type

Read-only property

Syntax

Visual Basic
Public Property BackupVaultJob As BackupJob

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

Enabled Property
ScheduledJob Object : Enabled Property

Glossary Item Box

Description

Specifies whether the scheduled job is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property Enabled As Boolean

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

ExportContentJob Property
ScheduledJob Object : ExportContentJob Property

Glossary Item Box

Description

Description of the actual export content job.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExportContentJob As ExportContentJob

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

ID Property
ScheduledJob Object : ID Property

Glossary Item Box

Description

The ID of the scheduled job.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

ImportContentJob Property
ScheduledJob Object : ImportContentJob Property

Glossary Item Box

Description

Description of the actual import content job.

Property type

Read-only property

Syntax

Visual Basic
Public Property ImportContentJob As ImportContentJob

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

JobName Property
ScheduledJob Object : JobName Property

Glossary Item Box

Description

The name of the scheduled job.

Property type

Read-write property

Syntax

Visual Basic
Public Property JobName As String

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

JobType Property
ScheduledJob Object : JobType Property

Glossary Item Box

Description

The type of the scheduled job.

Property type

Read-write property

Syntax

Visual Basic
Public Property JobType As MFScheduledJobType

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

OptimizeVaultJob Property
ScheduledJob Object : OptimizeVaultJob Property

Glossary Item Box

Description

Description of the actual optimize vault job.

Property type

Read-only property

Syntax

Visual Basic
Public Property OptimizeVaultJob As OptimizeVaultJob

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

Temporary Property
ScheduledJob Object : Temporary Property

Glossary Item Box

Description

Specifies whether the scheduled job is temporary only.

Property type

Read-write property

Syntax

Visual Basic
Public Property Temporary As Boolean

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

Triggers Property
ScheduledJob Object : Triggers Property

Glossary Item Box

Description

Collection of execution triggers.

Property type

Read-write property

Syntax

Visual Basic
Public Property Triggers As ScheduledJobTriggers

See Also

ScheduledJob Object | ScheduledJob Members


%%PageItemTitle%%

ScheduledJobOutputInfo Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents the results of a scheduled job.

Public Properties

Public Property ID | The ID of the scheduled job.
Public Property JobType | The type of the scheduled job.
Public Property Message | The message from the execution of the scheduled job.

See Also

ScheduledJobOutputInfo Members


%%PageItemTitle%%

ID Property
ScheduledJobOutputInfo Object : ID Property

Glossary Item Box

Description

The ID of the scheduled job.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

ScheduledJobOutputInfo Object | ScheduledJobOutputInfo Members


%%PageItemTitle%%

JobType Property
ScheduledJobOutputInfo Object : JobType Property

Glossary Item Box

Description

The type of the scheduled job.

Property type

Read-write property

Syntax

Visual Basic
Public Property JobType As MFScheduledJobType

See Also

ScheduledJobOutputInfo Object | ScheduledJobOutputInfo Members


%%PageItemTitle%%

Message Property
ScheduledJobOutputInfo Object : Message Property

Glossary Item Box

Description

The message from the execution of the scheduled job.

Property type

Read-write property

Syntax

Visual Basic
Public Property Message As String

See Also

ScheduledJobOutputInfo Object | ScheduledJobOutputInfo Members


%%PageItemTitle%%

ScheduledJobRunInfo Object
Members See Also Send comments

Glossary Item Box

Description

The ScheduledJobRunInfo class represents the state of a scheduled job.

Public Properties

Public Property Cancelled | Was the last run cancelled?
Public Property CurrentStep | The current step of the execution of the scheduled job.
Public Property LastRun | The last run time of the scheduled job.
Public Property LastRunErrors | Errors that occurred when the job was run the last time.
Public Property LastRunSucceeded | Was the last run succeeded?
Public Property NextRun | The time when the scheduled job will run next.
Public Property Running | Is the scheduled job running?
Public Property ScheduledJobOutputInfo | Output information on the scheduled job.
Public Property StepCompletionPercent | The progress of the current step.

See Also

ScheduledJobRunInfo Members


%%PageItemTitle%%

Cancelled Property
ScheduledJobRunInfo Object : Cancelled Property

Glossary Item Box

Description

Was the last run cancelled?

Property type

Read-only property

Syntax

Visual Basic
Public Property Cancelled As Boolean

See Also

ScheduledJobRunInfo Object | ScheduledJobRunInfo Members


%%PageItemTitle%%

CurrentStep Property
ScheduledJobRunInfo Object : CurrentStep Property

Glossary Item Box

Description

The current step of the execution of the scheduled job.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentStep As Long

See Also

ScheduledJobRunInfo Object | ScheduledJobRunInfo Members


%%PageItemTitle%%

LastRun Property
ScheduledJobRunInfo Object : LastRun Property

Glossary Item Box

Description

The last run time of the scheduled job.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastRun As Timestamp

See Also

ScheduledJobRunInfo Object | ScheduledJobRunInfo Members


%%PageItemTitle%%

LastRunErrors Property
ScheduledJobRunInfo Object : LastRunErrors Property

Glossary Item Box

Description

Errors that occurred when the job was run the last time.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastRunErrors As String

See Also

ScheduledJobRunInfo Object | ScheduledJobRunInfo Members


%%PageItemTitle%%

LastRunSucceeded Property
ScheduledJobRunInfo Object : LastRunSucceeded Property

Glossary Item Box

Description

Was the last run succeeded?

Property type

Read-only property

Syntax

Visual Basic
Public Property LastRunSucceeded As Boolean

See Also

ScheduledJobRunInfo Object | ScheduledJobRunInfo Members


%%PageItemTitle%%

NextRun Property
ScheduledJobRunInfo Object : NextRun Property

Glossary Item Box

Description

The time when the scheduled job will run next.

Property type

Read-only property

Syntax

Visual Basic
Public Property NextRun As Timestamp

See Also

ScheduledJobRunInfo Object | ScheduledJobRunInfo Members


%%PageItemTitle%%

Running Property
ScheduledJobRunInfo Object : Running Property

Glossary Item Box

Description

Is the scheduled job running?

Property type

Read-only property

Syntax

Visual Basic
Public Property Running As Boolean

See Also

ScheduledJobRunInfo Object | ScheduledJobRunInfo Members


%%PageItemTitle%%

ScheduledJobOutputInfo Property
ScheduledJobRunInfo Object : ScheduledJobOutputInfo Property

Glossary Item Box

Description

Output information on the scheduled job.

Property type

Read-only property

Syntax

Visual Basic
Public Property ScheduledJobOutputInfo As ScheduledJobOutputInfo

See Also

ScheduledJobRunInfo Object | ScheduledJobRunInfo Members


%%PageItemTitle%%

StepCompletionPercent Property
ScheduledJobRunInfo Object : StepCompletionPercent Property

Glossary Item Box

Description

The progress of the current step.

Property type

Read-only property

Syntax

Visual Basic
Public Property StepCompletionPercent As Long

See Also

ScheduledJobRunInfo Object | ScheduledJobRunInfo Members


%%PageItemTitle%%

ScheduledJobs Collection
Members See Also Send comments

Glossary Item Box

Description

The ScheduledJobs class represents a collection of scheduled jobs.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ScheduledJobs Members


%%PageItemTitle%%

Count Property
ScheduledJobs Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ScheduledJobs Collection | ScheduledJobs Members


%%PageItemTitle%%

Item Property
Index
ScheduledJobs Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ScheduledJob

Parameters

Index

See Also

ScheduledJobs Collection | ScheduledJobs Members


%%PageItemTitle%%

ScheduledJobTrigger Object
Members See Also Send comments

Glossary Item Box

Description

The ScheduledJobTrigger class represents a trigger of a scheduled job.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property BeginDay | Day of the month (specified in the BeginMonth member) that the scheduled job trigger activates. The beginning day must be specified when setting a scheduled job.
Public Property BeginMonth | Month of the year (specified in the BeginYear member) that the scheduled job trigger activates. The beginning month must be specified when setting a scheduled job.
Public Property BeginYear | Year that the task trigger activates. This value must be four digits (1997, not 97). The beginning year must be specified when setting a scheduled job.
Public Property EndDay | Day of the month (specified in the EndMonth member) that the scheduled job trigger deactivates.
Public Property EndMonth | Month of the year (specified in the EndYear member) that the scheduled job trigger deactivates.
Public Property EndYear | Year that the scheduled job trigger deactivates. This value must be four digits (1997, not 97).
Public Property StartHour | Hour of the day the scheduled job runs. This value is on a 24-hour clock; hours go from 00 to 23.
Public Property StartMinute | Minute of the hour (specified in the StartHour member) that the scheduled job runs.
Public Property Type | Trigger's type and additional type specific information.
Public Property ValidEndDate | Trigger's end date is valid. If this flag is not set, the end date data is ignored and the trigger will be valid indefinitely.

See Also

ScheduledJobTrigger Members


%%PageItemTitle%%

Clone Method
ScheduledJobTrigger Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ScheduledJobTrigger

See Also

ScheduledJobTrigger Object | ScheduledJobTrigger Members


%%PageItemTitle%%

BeginDay Property
ScheduledJobTrigger Object : BeginDay Property

Glossary Item Box

Description

Day of the month (specified in the BeginMonth member) that the scheduled job trigger activates. The beginning day must be specified when setting a scheduled job.

Property type

Read-write property

Syntax

Visual Basic
Public Property BeginDay As Long

See Also

ScheduledJobTrigger Object | ScheduledJobTrigger Members


%%PageItemTitle%%

BeginMonth Property
ScheduledJobTrigger Object : BeginMonth Property

Glossary Item Box

Description

Month of the year (specified in the BeginYear member) that the scheduled job trigger activates. The beginning month must be specified when setting a scheduled job.

Property type

Read-write property

Syntax

Visual Basic
Public Property BeginMonth As Long

See Also

ScheduledJobTrigger Object | ScheduledJobTrigger Members


%%PageItemTitle%%

BeginYear Property
ScheduledJobTrigger Object : BeginYear Property

Glossary Item Box

Description

Year that the task trigger activates. This value must be four digits (1997, not 97). The beginning year must be specified when setting a scheduled job.

Property type

Read-write property

Syntax

Visual Basic
Public Property BeginYear As Long

See Also

ScheduledJobTrigger Object | ScheduledJobTrigger Members


%%PageItemTitle%%

EndDay Property
ScheduledJobTrigger Object : EndDay Property

Glossary Item Box

Description

Day of the month (specified in the EndMonth member) that the scheduled job trigger deactivates.

Property type

Read-write property

Syntax

Visual Basic
Public Property EndDay As Long

See Also

ScheduledJobTrigger Object | ScheduledJobTrigger Members


%%PageItemTitle%%

EndMonth Property
ScheduledJobTrigger Object : EndMonth Property

Glossary Item Box

Description

Month of the year (specified in the EndYear member) that the scheduled job trigger deactivates.

Property type

Read-write property

Syntax

Visual Basic
Public Property EndMonth As Long

See Also

ScheduledJobTrigger Object | ScheduledJobTrigger Members


%%PageItemTitle%%

EndYear Property
ScheduledJobTrigger Object : EndYear Property

Glossary Item Box

Description

Year that the scheduled job trigger deactivates. This value must be four digits (1997, not 97).

Property type

Read-write property

Syntax

Visual Basic
Public Property EndYear As Long

See Also

ScheduledJobTrigger Object | ScheduledJobTrigger Members


%%PageItemTitle%%

StartHour Property
ScheduledJobTrigger Object : StartHour Property

Glossary Item Box

Description

Hour of the day the scheduled job runs. This value is on a 24-hour clock; hours go from 00 to 23.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartHour As Long

See Also

ScheduledJobTrigger Object | ScheduledJobTrigger Members


%%PageItemTitle%%

StartMinute Property
ScheduledJobTrigger Object : StartMinute Property

Glossary Item Box

Description

Minute of the hour (specified in the StartHour member) that the scheduled job runs.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartMinute As Long

See Also

ScheduledJobTrigger Object | ScheduledJobTrigger Members


%%PageItemTitle%%

Type Property
ScheduledJobTrigger Object : Type Property

Glossary Item Box

Description

Trigger's type and additional type specific information.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type As TriggerType

See Also

ScheduledJobTrigger Object | ScheduledJobTrigger Members


%%PageItemTitle%%

ValidEndDate Property
ScheduledJobTrigger Object : ValidEndDate Property

Glossary Item Box

Description

Trigger's end date is valid. If this flag is not set, the end date data is ignored and the trigger will be valid indefinitely.

Property type

Read-write property

Syntax

Visual Basic
Public Property ValidEndDate As Boolean

See Also

ScheduledJobTrigger Object | ScheduledJobTrigger Members


%%PageItemTitle%%

ScheduledJobTriggers Collection
Members See Also Send comments

Glossary Item Box

Description

The ScheduledJobTriggers class represents a collection of triggers of a scheduled job.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ScheduledJobTriggers Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
ScheduledJobTrigger
The new member to add.
ScheduledJobTriggers Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ScheduledJobTrigger As ScheduledJobTrigger _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
ScheduledJobTrigger
The new member to add.

See Also

ScheduledJobTriggers Collection | ScheduledJobTriggers Members


%%PageItemTitle%%

Clone Method
ScheduledJobTriggers Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ScheduledJobTriggers

See Also

ScheduledJobTriggers Collection | ScheduledJobTriggers Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
ScheduledJobTriggers Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

ScheduledJobTriggers Collection | ScheduledJobTriggers Members


%%PageItemTitle%%

Count Property
ScheduledJobTriggers Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ScheduledJobTriggers Collection | ScheduledJobTriggers Members


%%PageItemTitle%%

Item Property
Index
ScheduledJobTriggers Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ScheduledJobTrigger

Parameters

Index

See Also

ScheduledJobTriggers Collection | ScheduledJobTriggers Members


%%PageItemTitle%%

SearchCondition Object
Members See Also Example Send comments

Glossary Item Box

Description

The SearchCondition class is used for accessing and setting a single search condition.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method Set | Sets the search condition.

Public Properties

Public Property ConditionType | The operator of the search condition.
Public Property Expression | The left side of the search condition.
Public Property TypedValue | The right side of the search condition.

Remarks

A search condition consists of three parts. The left side of the search condition determines which piece of the document's metadata the search condition concerns. The middle part of the search condition is the type of the condition (e.g., "equal" or "not equal"). The right side of the search condition is the desired value of the expression.

The Expression object encapsulates the data required for the expression, including the left operand and possible options for the expression. A TypedValue object is used to define the value (i.e., an operand for the expression). The condition operator is set with the ConditionType member.

Setting search conditions and expressions in M-Files Desktop.

Example

Creating a search condition for a view (Visual Basic) Copy Code
' Construct view object.
Dim oView As New MFilesAPI.View
oView.Common = True
oView.Name = "Test View"
oView.ViewType = MFilesAPI.MFViewType.MFViewTypeNormal

' Create search conditions for the view: object status is not deleted
Dim oExpression As New MFilesAPI.Expression
oExpression.SetStatusValueExpression(MFilesAPI.MFStatusType.MFStatusTypeDeleted)
Dim oTypedValue As New MFilesAPI.TypedValue
oTypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeBoolean, False)
Dim oDeleted As New MFilesAPI.SearchCondition
oDeleted.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeEqual
oDeleted.Set(expression, MFilesAPI.MFConditionType.MFConditionTypeEqual, oTypedValue)
oView.SearchConditions.Add(-1, oDeleted)

' Add the view to client.
oView = oVault.ViewOperations.AddView(oView)

See Also

SearchCondition Members | Expression Object | TypedValue Object


%%PageItemTitle%%

Clone Method
SearchCondition Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SearchCondition

Return Type

Returns the copied search condition.

See Also

SearchCondition Object | SearchCondition Members


%%PageItemTitle%%

Set Method
Expression
ConditionType
TypedValue
SearchCondition Object : Set Method

Glossary Item Box

Description

Sets the search condition.

Syntax

Visual Basic
Public Sub Set( _
   ByVal Expression As Expression, _
   ByVal ConditionType As MFConditionType, _
   ByVal TypedValue As TypedValue _
)

Parameters

Expression
ConditionType
Value | Description
MFConditionTypeContains | Contains the given text string (similar to LIKE 'xyz').
MFConditionTypeContainsAnyBitwise | Contains any of the bits of the given number. Treats its operands as a vector of bits rather than a single number.
MFConditionTypeDoesNotContain | Does not contain the given text string (similar to NOT LIKE 'xyz').
MFConditionTypeDoesNotContainAnyBitwise | Does not contain any of the bits of the given number. Treats its operands as a vector of bits rather than a single number.
MFConditionTypeDoesNotMatchWildcardPattern | Does not match the given DOS-style wildcard pattern (such as '*.txt').
MFConditionTypeDoesNotStartWith | Does not start with the given text string (similar to NOT LIKE 'xyz%').
MFConditionTypeEqual | Must be equal to.
MFConditionTypeGreaterThan | Must be greater than.
MFConditionTypeGreaterThanOrEqual | Must be greater than or equal to.
MFConditionTypeLessThan | Must be less than.
MFConditionTypeLessThanOrEqual | Must be less than or equal to.
MFConditionTypeMatchesWildcardPattern | Matches the given DOS-style wildcard pattern (such as '*.txt').
MFConditionTypeNotEqual | Must not be equal to.
MFConditionTypeStartsWith | Starts with the given text string (similar to LIKE 'xyz%').
MFConditionTypeStartsWithAtWordBoundary | Starts with the given text string at a word boundary. Similar to LIKE 'xyz%', but evaluated at the beginning of each word).
TypedValue

See Also

SearchCondition Object | SearchCondition Members


%%PageItemTitle%%

ConditionType Property
SearchCondition Object : ConditionType Property

Glossary Item Box

Description

The operator of the search condition.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConditionType As MFConditionType

See Also

SearchCondition Object | SearchCondition Members


%%PageItemTitle%%

Expression Property
SearchCondition Object : Expression Property

Glossary Item Box

Description

The left side of the search condition.

Property type

Read-write property

Syntax

Visual Basic
Public Property Expression As Expression

See Also

SearchCondition Object | SearchCondition Members


%%PageItemTitle%%

TypedValue Property
SearchCondition Object : TypedValue Property

Glossary Item Box

Description

The right side of the search condition.

Property type

Read-write property

Syntax

Visual Basic
Public Property TypedValue As TypedValue

See Also

SearchCondition Object | SearchCondition Members


%%PageItemTitle%%

SearchConditionEx Object
Members See Also Send comments

Glossary Item Box

Description

The SearchConditionEx class represents an extended search condition.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method Set | Sets the search condition and other related data.

Public Properties

Public Property Enabled | Specifies whether the search condition is enabled.
Public Property Ignored | Specifies whether the search condition is ignored.
Public Property SearchCondition | The underlying search condition.
Public Property SpecialNULL | Specifies whether this search condition is a special NULL condition. Its meaning depends on the underlying search condition.

See Also

SearchConditionEx Members


%%PageItemTitle%%

Clone Method
SearchConditionEx Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SearchConditionEx

See Also

SearchConditionEx Object | SearchConditionEx Members


%%PageItemTitle%%

Set Method
SearchCondition
Enabled
SpecialNULL
Ignored
SearchConditionEx Object : Set Method

Glossary Item Box

Description

Sets the search condition and other related data.

Syntax

Visual Basic
Public Sub Set( _
   ByVal SearchCondition As SearchCondition, _
   ByVal Enabled As Boolean, _
   ByVal SpecialNULL As Boolean, _
   ByVal Ignored As Boolean _
)

Parameters

SearchCondition
Enabled
SpecialNULL
Ignored

See Also

SearchConditionEx Object | SearchConditionEx Members


%%PageItemTitle%%

Enabled Property
SearchConditionEx Object : Enabled Property

Glossary Item Box

Description

Specifies whether the search condition is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property Enabled As Boolean

See Also

SearchConditionEx Object | SearchConditionEx Members


%%PageItemTitle%%

Ignored Property
SearchConditionEx Object : Ignored Property

Glossary Item Box

Description

Specifies whether the search condition is ignored.

Property type

Read-write property

Syntax

Visual Basic
Public Property Ignored As Boolean

See Also

SearchConditionEx Object | SearchConditionEx Members


%%PageItemTitle%%

SearchCondition Property
SearchConditionEx Object : SearchCondition Property

Glossary Item Box

Description

The underlying search condition.

Property type

Read-write property

Syntax

Visual Basic
Public Property SearchCondition As SearchCondition

See Also

SearchConditionEx Object | SearchConditionEx Members


%%PageItemTitle%%

SpecialNULL Property
SearchConditionEx Object : SpecialNULL Property

Glossary Item Box

Description

Specifies whether this search condition is a special NULL condition. Its meaning depends on the underlying search condition.

Property type

Read-write property

Syntax

Visual Basic
Public Property SpecialNULL As Boolean

See Also

SearchConditionEx Object | SearchConditionEx Members


%%PageItemTitle%%

SearchConditionExs Collection
Members See Also Send comments

Glossary Item Box

Description

SearchConditionExs is a collection of SearchConditionEx objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

SearchConditionExs Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
SearchConditionEx
The new member to add.
SearchConditionExs Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal SearchConditionEx As SearchConditionEx _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
SearchConditionEx
The new member to add.

See Also

SearchConditionExs Collection | SearchConditionExs Members


%%PageItemTitle%%

Clone Method
SearchConditionExs Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SearchConditionExs

See Also

SearchConditionExs Collection | SearchConditionExs Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
SearchConditionExs Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

SearchConditionExs Collection | SearchConditionExs Members


%%PageItemTitle%%

Count Property
SearchConditionExs Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

SearchConditionExs Collection | SearchConditionExs Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
SearchConditionExs Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As SearchConditionEx

Parameters

Index
Specifies the item's position in the collection.

See Also

SearchConditionExs Collection | SearchConditionExs Members


%%PageItemTitle%%

SearchConditions Collection
Members See Also Send comments

Glossary Item Box

Description

SearchConditions is a collection of SearchCondition objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method AppendFromExportedSearchString | Initializes search conditions collection with an exported search string.
Public Method Clone | Creates a copy of the object.
Public Method GetAsExportedSearchString | Gets the search conditions as an exported search string.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

SearchConditions Members | SearchCondition Object


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
SearchCondition
The new member to add.
SearchConditions Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal SearchCondition As SearchCondition _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
SearchCondition
The new member to add.

See Also

SearchConditions Collection | SearchConditions Members


%%PageItemTitle%%

AppendFromExportedSearchString Method
ExportedSearchString
The exported search string to be appended to the search conditions.
SearchConditions Collection : AppendFromExportedSearchString Method

Glossary Item Box

Description

Initializes search conditions collection with an exported search string.

Syntax

Visual Basic
Public Sub AppendFromExportedSearchString( _
   ByVal ExportedSearchString As String _
)

Parameters

ExportedSearchString
The exported search string to be appended to the search conditions.

Remarks

The search flags defined in the search string are ignored.

See Also

SearchConditions Collection | SearchConditions Members


%%PageItemTitle%%

Clone Method
SearchConditions Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SearchConditions

See Also

SearchConditions Collection | SearchConditions Members


%%PageItemTitle%%

GetAsExportedSearchString Method
SearchFlags
SearchConditions Collection : GetAsExportedSearchString Method

Glossary Item Box

Description

Gets the search conditions as an exported search string.

Syntax

Visual Basic
Public Function GetAsExportedSearchString( _
   ByVal SearchFlags As MFSearchFlags _
) As String

Parameters

SearchFlags
Value | Description
MFSearchFlagDisableRelevancyRanking | Search results are not sorted according to their relevancy.
MFSearchFlagIncludeUnmanagedObjects | Include unmanaged objects in the search results.
MFSearchFlagLookAllObjectTypes | Perform a separate search for each object type and merges the results.
MFSearchFlagLookInAllVersions | Orders to look for matches in all object versions. By default, only the latest object versions are included in the search.
MFSearchFlagNone | No flags.
MFSearchFlagResultsFromEachRepository | Limits the search results per search location instead of limiting the total number of results from all vaults and repositories. This ensures that the search results include items from all search locations with search hits.
MFSearchFlagReturnLatestVisibleVersion | Orders to return the latest version for each object, regardless of whether it is an actual matching version. This flag is effective only if MFSearchFlagLookInAllVersions is on.

See Also

SearchConditions Collection | SearchConditions Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
SearchConditions Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

SearchConditions Collection | SearchConditions Members


%%PageItemTitle%%

Count Property
SearchConditions Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

SearchConditions Collection | SearchConditions Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
SearchConditions Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As SearchCondition

Parameters

Index
Specifies the item's position in the collection.

See Also

SearchConditions Collection | SearchConditions Members


%%PageItemTitle%%

SearchCriteria Object
Members See Also Example Send comments

Glossary Item Box

Description

The SearchCriteria class represents search conditions used in searches in Windows Explorer.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method EqualTo | Checks for equality to the specified search criteria.
Public Method GetEffectiveSearchConditions | Gets the effective search conditions of this search criteria. Can be directly used with searches.
Public Method GetEffectiveSearchFlags | Gets the effective search flags of this search criteria.

Public Properties

Public Property AdditionalConditions | The additional conditions.
Public Property ExpandUI | Specifies whether the search user interface is expanded.
Public Property FacetFilterAsJSON | The search refinements as a JSON string.
Public Property FirstCondition | The first search condition.
Public Property FullTextSearchFlags | The full-text search flags.
Public Property FullTextSearchString | The full-text search string.
Public Property ObjectTypeCondition | The object type search condition.
Public Property SearchFlags | The search flags of the criteria.
Public Property SearchWithinThisFolder | Specifies whether the search within this folder flag is enabled.
Public Property SecondCondition | The second search condition.

Remarks

Search criteria is a container object for the set of search conditions.

Example

Building the search criteria for temporary search view (Visual Basic) Copy Code
' Create the view object.
Dim oViewNew As New MFilesAPI.View
oViewNew.Name = "Test view"

' Create the search criteria for the view.
Dim oSc As New MFilesAPI.SearchCriteria
oSc.FullTextSearchString = "demo*"
oSc.FullTextSearchFlags = MFilesAPI.MFFullTextSearchFlags.MFFullTextSearchFlagsStemming Or _
    MFilesAPI.MFFullTextSearchFlags.MFFullTextSearchFlagsLookInMetaData Or _
    MFilesAPI.MFFullTextSearchFlags.MFFullTextSearchFlagsLookInFileData Or _
    MFilesAPI.MFFullTextSearchFlags.MFFullTextSearchFlagsTypeAllWords
oSc.SearchFlags = MFilesAPI.MFSearchFlags.MFSearchFlagNone
oSc.ExpandUI = True

' Create the "not deleted" condition for search criteria.
Dim oExpression As New MFilesAPI.Expression
oExpression.DataStatusValueType = MFilesAPI.MFStatusType.MFStatusTypeDeleted
oExpression.DataStatusValueDataFunction = MFilesAPI.MFDataFunction.MFDataFunctionNoOp
Dim oTypedValue As New MFilesAPI.TypedValue
oTypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeBoolean, False)
Dim oDeletedEx As New MFilesAPI.SearchConditionEx
oDeletedEx.SearchCondition.Set(oExpression, MFilesAPI.MFConditionType.MFConditionTypeEqual, oTypedValue)
oDeletedEx.Enabled = True
oDeletedEx.Ignored = False
oDeletedEx.SpecialNULL = False

' Add the deleted condition.
oSc.AdditionalConditions.Add(-1, oDeletedEx)

' Add the new view.
oViewNew = oVault.ViewOperations.AddTemporarySearchView(oViewNew, oSc)

See Also

SearchCriteria Members


%%PageItemTitle%%

Clone Method
SearchCriteria Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SearchCriteria

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

EqualTo Method
SearchCriteria
SearchCriteria Object : EqualTo Method

Glossary Item Box

Description

Checks for equality to the specified search criteria.

Syntax

Visual Basic
Public Function EqualTo( _
   ByVal SearchCriteria As SearchCriteria _
) As Boolean

Parameters

SearchCriteria

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

GetEffectiveSearchConditions Method
ForceGettingAdvancedSearchConds
SearchCriteria Object : GetEffectiveSearchConditions Method

Glossary Item Box

Description

Gets the effective search conditions of this search criteria. Can be directly used with searches.

Syntax

Visual Basic
Public Function GetEffectiveSearchConditions( _
   ByVal ForceGettingAdvancedSearchConds As Boolean _
) As SearchConditions

Parameters

ForceGettingAdvancedSearchConds

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

GetEffectiveSearchFlags Method
ForceGettingAdvancedSearchConds
SearchCriteria Object : GetEffectiveSearchFlags Method

Glossary Item Box

Description

Gets the effective search flags of this search criteria.

Syntax

Visual Basic
Public Function GetEffectiveSearchFlags( _
   ByVal ForceGettingAdvancedSearchConds As Boolean _
) As MFSearchFlags

Parameters

ForceGettingAdvancedSearchConds

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

AdditionalConditions Property
SearchCriteria Object : AdditionalConditions Property

Glossary Item Box

Description

The additional conditions.

Property type

Read-write property

Syntax

Visual Basic
Public Property AdditionalConditions As SearchConditionExs

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

ExpandUI Property
SearchCriteria Object : ExpandUI Property

Glossary Item Box

Description

Specifies whether the search user interface is expanded.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExpandUI As Boolean

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

FacetFilterAsJSON Property
SearchCriteria Object : FacetFilterAsJSON Property

Glossary Item Box

Description

The search refinements as a JSON string.

Property type

Read-write property

Syntax

Visual Basic
Public Property FacetFilterAsJSON As String

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

FirstCondition Property
SearchCriteria Object : FirstCondition Property

Glossary Item Box

Description

The first search condition.

Property type

Read-write property

Syntax

Visual Basic
Public Property FirstCondition As SearchConditionEx

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

FullTextSearchFlags Property
SearchCriteria Object : FullTextSearchFlags Property

Glossary Item Box

Description

The full-text search flags.

Property type

Read-write property

Syntax

Visual Basic
Public Property FullTextSearchFlags As MFFullTextSearchFlags

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

FullTextSearchString Property
SearchCriteria Object : FullTextSearchString Property

Glossary Item Box

Description

The full-text search string.

Property type

Read-write property

Syntax

Visual Basic
Public Property FullTextSearchString As String

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

ObjectTypeCondition Property
SearchCriteria Object : ObjectTypeCondition Property

Glossary Item Box

Description

The object type search condition.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectTypeCondition As SearchConditionEx

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

SearchFlags Property
SearchCriteria Object : SearchFlags Property

Glossary Item Box

Description

The search flags of the criteria.

Property type

Read-write property

Syntax

Visual Basic
Public Property SearchFlags As MFSearchFlags

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

SearchWithinThisFolder Property
SearchCriteria Object : SearchWithinThisFolder Property

Glossary Item Box

Description

Specifies whether the search within this folder flag is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property SearchWithinThisFolder As Boolean

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

SecondCondition Property
SearchCriteria Object : SecondCondition Property

Glossary Item Box

Description

The second search condition.

Property type

Read-write property

Syntax

Visual Basic
Public Property SecondCondition As SearchConditionEx

See Also

SearchCriteria Object | SearchCriteria Members


%%PageItemTitle%%

SearchDef Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents a search definition.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method IsIndirectionUsed | Is indirection used?

Public Properties

Public Property Conditions | The conditions that limit the object set of this search.
Public Property Levels | View levels that define the display hierarchy of this search.
Public Property LookInAllVersions | Specifies whether the search looks match in all versions or in only the latest versions.
Public Property ReturnLatestVisibleVersion | Specifies whether the search returns the latest visible versions or the latest matching versions.
Public Property SearchFlags | The search flags of the view.

Remarks

Search definitions are used for defining views. In order to perform a search, use SearchCondition class instead.

See Also

SearchDef Members


%%PageItemTitle%%

Clone Method
SearchDef Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SearchDef

See Also

SearchDef Object | SearchDef Members


%%PageItemTitle%%

IsIndirectionUsed Method
SearchDef Object : IsIndirectionUsed Method

Glossary Item Box

Description

Is indirection used?

Syntax

Visual Basic
Public Function IsIndirectionUsed() As Boolean

See Also

SearchDef Object | SearchDef Members


%%PageItemTitle%%

Conditions Property
SearchDef Object : Conditions Property

Glossary Item Box

Description

The conditions that limit the object set of this search.

Property type

Read-write property

Syntax

Visual Basic
Public Property Conditions As SearchConditions

See Also

SearchDef Object | SearchDef Members


%%PageItemTitle%%

Levels Property
SearchDef Object : Levels Property

Glossary Item Box

Description

View levels that define the display hierarchy of this search.

Property type

Read-write property

Syntax

Visual Basic
Public Property Levels As ExpressionExs

See Also

SearchDef Object | SearchDef Members


%%PageItemTitle%%

LookInAllVersions Property
SearchDef Object : LookInAllVersions Property

Glossary Item Box

Description

Specifies whether the search looks match in all versions or in only the latest versions.

Property type

Read-write property

Syntax

Visual Basic
Public Property LookInAllVersions As Boolean

See Also

SearchDef Object | SearchDef Members


%%PageItemTitle%%

ReturnLatestVisibleVersion Property
SearchDef Object : ReturnLatestVisibleVersion Property

Glossary Item Box

Description

Specifies whether the search returns the latest visible versions or the latest matching versions.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReturnLatestVisibleVersion As Boolean

See Also

SearchDef Object | SearchDef Members


%%PageItemTitle%%

SearchFlags Property
SearchDef Object : SearchFlags Property

Glossary Item Box

Description

The search flags of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property SearchFlags As MFSearchFlags

See Also

SearchDef Object | SearchDef Members


%%PageItemTitle%%

SemanticAliases Object
Members See Also Send comments

Glossary Item Box

Description

The SemanticAliases class represents the semantic aliases of a metadata structure element.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Value A semicolon-separated list of semantic aliases.

Remarks

Semantic aliases can be defined for numerous different elements like object types, classes, value lists, property definitions, workflows, states, named access control lists and external sources.

By using semantic aliases, you can identify metadata structure elements with a textual identifier, without relying on the numeric IDs. This is especially useful for applications and scripts that need to work in more than one vault. For example, you could use the API call GetPropertyIDByAlias( "MyApp.CustomerName" ) to find out the ID of the property definition that has "MyApp.CustomerName" as one of its semantic aliases.

An example of the semantic aliases list (highlighted with the green rectangle) for an object type in M-Files Admin.

See Also

SemanticAliases Members


%%PageItemTitle%%

Clone Method
SemanticAliases Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SemanticAliases

See Also

SemanticAliases Object | SemanticAliases Members


%%PageItemTitle%%

Value Property
SemanticAliases Object : Value Property

Glossary Item Box

Description

A semicolon-separated list of semantic aliases.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value As String

See Also

SemanticAliases Object | SemanticAliases Members


%%PageItemTitle%%

ServerLicenseManagementOperations Object
Members See Also Send comments

Glossary Item Box

Description

A group of methods for administering license on the server.

Public Methods

Public Method GetLicenseStatus | Gets the current license code and serial.
Public Method SetLicenseCodeAndSerialNumber | Sets the license code and serial.

Remarks

License information as seen in the user interface of the M-Files Server Administrator application.

See Also

ServerLicenseManagementOperations Members


%%PageItemTitle%%

GetLicenseStatus Method
ServerLicenseManagementOperations Object : GetLicenseStatus Method

Glossary Item Box

Description

Gets the current license code and serial.

Syntax

Visual Basic
Public Function GetLicenseStatus() As LicenseStatus

See Also

ServerLicenseManagementOperations Object | ServerLicenseManagementOperations Members


%%PageItemTitle%%

SetLicenseCodeAndSerialNumber Method
SerialNumber
The serial number.
LicenseCode
The license code.
ServerLicenseManagementOperations Object : SetLicenseCodeAndSerialNumber Method

Glossary Item Box

Description

Sets the license code and serial.

Syntax

Visual Basic
Public Sub SetLicenseCodeAndSerialNumber( _
   ByVal SerialNumber As String, _
   ByVal LicenseCode As String _
)

Parameters

SerialNumber
The serial number.
LicenseCode
The license code.

See Also

ServerLicenseManagementOperations Object | ServerLicenseManagementOperations Members


%%PageItemTitle%%

ServerLoginAccountOperations Object
Members See Also Send comments

Glossary Item Box

Description

The ServerLoginAccountOperations class represents the available login account operations.

Public Methods

Public Method AddLoginAccount | Adds the specified login account to the server.
Public Method ForceLogout | Forcefully logs out the users with the specified login accounts.
Public Method GetLoginAccount | Gets the specified login account.
Public Method GetLoginAccounts | Gets all login accounts on the server.
Public Method GetLoginAccountsWithSessions | Gets the login accounts that have valid sessions established.
Public Method GetPersonalInformationFromDomain | Gets the personal information of the specified login account from the domain.
Public Method GetServerCapabilities | Gets the server capabilities
Public Method ModifyLoginAccount | Modifies the specified login account on the server.
Public Method RemoveLoginAccount | Deletes the specified login account from the server.
Public Method UpdateLoginPassword | Changes the password of the specified M-Files login account.

Remarks

Login accounts as seen in M-Files Admin.

See Also

ServerLoginAccountOperations Members


%%PageItemTitle%%

AddLoginAccount Method
LoginAccount
Password
ServerLoginAccountOperations Object : AddLoginAccount Method

Glossary Item Box

Description

Adds the specified login account to the server.

Syntax

Visual Basic
Public Sub AddLoginAccount( _
   ByVal LoginAccount As LoginAccount, _
   Optional ByVal Password As String = "" _
)

Parameters

LoginAccount
Password

See Also

ServerLoginAccountOperations Object | ServerLoginAccountOperations Members


%%PageItemTitle%%

ForceLogout Method
AccountNames
ServerLoginAccountOperations Object : ForceLogout Method

Glossary Item Box

Description

Forcefully logs out the users with the specified login accounts.

Syntax

Visual Basic
Public Sub ForceLogout( _
   ByVal AccountNames As Strings _
)

Parameters

AccountNames

See Also

ServerLoginAccountOperations Object | ServerLoginAccountOperations Members


%%PageItemTitle%%

GetLoginAccount Method
AccountName
ServerLoginAccountOperations Object : GetLoginAccount Method

Glossary Item Box

Description

Gets the specified login account.

Syntax

Visual Basic
Public Function GetLoginAccount( _
   ByVal AccountName As String _
) As LoginAccount

Parameters

AccountName

See Also

ServerLoginAccountOperations Object | ServerLoginAccountOperations Members


%%PageItemTitle%%

GetLoginAccounts Method
ServerLoginAccountOperations Object : GetLoginAccounts Method

Glossary Item Box

Description

Gets all login accounts on the server.

Syntax

Visual Basic
Public Function GetLoginAccounts() As LoginAccounts

See Also

ServerLoginAccountOperations Object | ServerLoginAccountOperations Members


%%PageItemTitle%%

GetLoginAccountsWithSessions Method
ServerLoginAccountOperations Object : GetLoginAccountsWithSessions Method

Glossary Item Box

Description

Gets the login accounts that have valid sessions established.

Syntax

Visual Basic
Public Function GetLoginAccountsWithSessions() As LoginAccounts

See Also

ServerLoginAccountOperations Object | ServerLoginAccountOperations Members


%%PageItemTitle%%

GetPersonalInformationFromDomain Method
AccountName
ServerLoginAccountOperations Object : GetPersonalInformationFromDomain Method

Glossary Item Box

Description

Gets the personal information of the specified login account from the domain.

Syntax

Visual Basic
Public Function GetPersonalInformationFromDomain( _
   ByVal AccountName As String _
) As LoginAccountPersonalInformation

Parameters

AccountName

See Also

ServerLoginAccountOperations Object | ServerLoginAccountOperations Members


%%PageItemTitle%%

GetServerCapabilities Method
ServerLoginAccountOperations Object : GetServerCapabilities Method

Glossary Item Box

Description

Gets the server capabilities

Syntax

Visual Basic
Public Function GetServerCapabilities() As ServerVaultCapabilities

Remarks

Requires M-Files 19.7.8028.5 or later.

See Also

ServerLoginAccountOperations Object | ServerLoginAccountOperations Members


%%PageItemTitle%%

ModifyLoginAccount Method
LoginAccount
ServerLoginAccountOperations Object : ModifyLoginAccount Method

Glossary Item Box

Description

Modifies the specified login account on the server.

Syntax

Visual Basic
Public Sub ModifyLoginAccount( _
   ByVal LoginAccount As LoginAccount _
)

Parameters

LoginAccount

See Also

ServerLoginAccountOperations Object | ServerLoginAccountOperations Members


%%PageItemTitle%%

RemoveLoginAccount Method
AccountName
ServerLoginAccountOperations Object : RemoveLoginAccount Method

Glossary Item Box

Description

Deletes the specified login account from the server.

Syntax

Visual Basic
Public Sub RemoveLoginAccount( _
   ByVal AccountName As String _
)

Parameters

AccountName

See Also

ServerLoginAccountOperations Object | ServerLoginAccountOperations Members


%%PageItemTitle%%

UpdateLoginPassword Method
AccountName
NewPassword
ServerLoginAccountOperations Object : UpdateLoginPassword Method

Glossary Item Box

Description

Changes the password of the specified M-Files login account.

Syntax

Visual Basic
Public Sub UpdateLoginPassword( _
   ByVal AccountName As String, _
   ByVal NewPassword As String _
)

Parameters

AccountName
NewPassword

See Also

ServerLoginAccountOperations Object | ServerLoginAccountOperations Members


%%PageItemTitle%%

ServerManagementOperations Object
Members See Also Send comments

Glossary Item Box

Description

A group of methods for administering server.

Public Methods

Public Method BackupMasterDB | Creates a backup of the master database.
Public Method ConfigureWebAccessToDefaultWebSite | Configures M-Files Web Access to the default web site.
Public Method ConfigureWebAccessToExistingWebSite | Configures M-Files Web Access to the specified existing web site.
Public Method ConfigureWebAccessToNewVirtualDirectory | Configures M-Files Web Access to a new virtual directory.
Public Method ConfigureWebAccessToNewWebSite | Configures M-Files Web Access to a new web site.
Public Method GetEventHandlers | Gets the event handlers of the server.
Public Method RestoreMasterDB | Restores the specified master database backup.
Public Method SetEventHandlers | Sets the event handlers of the server.

Remarks

Master database operations (highlighted with the green rectangle) as seen in M-Files Admin.

See Also

ServerManagementOperations Members


%%PageItemTitle%%

BackupMasterDB Method
BackupFile
Full path of the backup file on the server.
OverwriteExistingFiles
If this parameter is True, existing backup files is overwritten. If this parameter is False, the operation fails if a backup file already exists.
FileSizeLimitInMB
Maximum size of one backup file in megabytes. If exceeded, backup will continue with a new sequentially numbered file. If this parameter is 0, file size is unlimited and the backup will always consist of a single file only.
Impersonation

Account information for accesing the backup files on the server.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

ServerManagementOperations Object : BackupMasterDB Method

Glossary Item Box

Description

Creates a backup of the master database.

Syntax

Visual Basic
Public Sub BackupMasterDB( _
   ByVal BackupFile As String, _
   ByVal OverwriteExistingFiles As Boolean, _
   Optional ByVal FileSizeLimitInMB As Long = 0, _
   Optional ByVal Impersonation As Impersonation = 0 _
)

Parameters

BackupFile
Full path of the backup file on the server.
OverwriteExistingFiles
If this parameter is True, existing backup files is overwritten. If this parameter is False, the operation fails if a backup file already exists.
FileSizeLimitInMB
Maximum size of one backup file in megabytes. If exceeded, backup will continue with a new sequentially numbered file. If this parameter is 0, file size is unlimited and the backup will always consist of a single file only.
Impersonation

Account information for accesing the backup files on the server.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

See Also

ServerManagementOperations Object | ServerManagementOperations Members


%%PageItemTitle%%

ConfigureWebAccessToDefaultWebSite Method
ServerManagementOperations Object : ConfigureWebAccessToDefaultWebSite Method

Glossary Item Box

Description

Configures M-Files Web Access to the default web site.

Syntax

Visual Basic
Public Sub ConfigureWebAccessToDefaultWebSite()

See Also

ServerManagementOperations Object | ServerManagementOperations Members


%%PageItemTitle%%

ConfigureWebAccessToExistingWebSite Method
WebSite
ServerManagementOperations Object : ConfigureWebAccessToExistingWebSite Method

Glossary Item Box

Description

Configures M-Files Web Access to the specified existing web site.

Syntax

Visual Basic
Public Sub ConfigureWebAccessToExistingWebSite( _
   ByVal WebSite As String _
)

Parameters

WebSite

See Also

ServerManagementOperations Object | ServerManagementOperations Members


%%PageItemTitle%%

ConfigureWebAccessToNewVirtualDirectory Method
WebSite
VirtualDirectory
ServerManagementOperations Object : ConfigureWebAccessToNewVirtualDirectory Method

Glossary Item Box

Description

Configures M-Files Web Access to a new virtual directory.

Syntax

Visual Basic
Public Sub ConfigureWebAccessToNewVirtualDirectory( _
   ByVal WebSite As String, _
   ByVal VirtualDirectory As String _
)

Parameters

WebSite
VirtualDirectory

See Also

ServerManagementOperations Object | ServerManagementOperations Members


%%PageItemTitle%%

ConfigureWebAccessToNewWebSite Method
WebSite
Port
ServerManagementOperations Object : ConfigureWebAccessToNewWebSite Method

Glossary Item Box

Description

Configures M-Files Web Access to a new web site.

Syntax

Visual Basic
Public Sub ConfigureWebAccessToNewWebSite( _
   ByVal WebSite As String, _
   ByVal Port As String _
)

Parameters

WebSite
Port

See Also

ServerManagementOperations Object | ServerManagementOperations Members


%%PageItemTitle%%

GetEventHandlers Method
ServerManagementOperations Object : GetEventHandlers Method

Glossary Item Box

Description

Gets the event handlers of the server.

Syntax

Visual Basic
Public Function GetEventHandlers() As EventHandlers

See Also

ServerManagementOperations Object | ServerManagementOperations Members


%%PageItemTitle%%

RestoreMasterDB Method
BackupFile
Full path of the backup file on the server.
Impersonation

Account information for accesing the backup files on the server.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

ServerManagementOperations Object : RestoreMasterDB Method

Glossary Item Box

Description

Restores the specified master database backup.

Syntax

Visual Basic
Public Sub RestoreMasterDB( _
   ByVal BackupFile As String, _
   Optional ByVal Impersonation As Impersonation = 0 _
)

Parameters

BackupFile
Full path of the backup file on the server.
Impersonation

Account information for accesing the backup files on the server.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

See Also

ServerManagementOperations Object | ServerManagementOperations Members


%%PageItemTitle%%

SetEventHandlers Method
EventHandlers
ServerManagementOperations Object : SetEventHandlers Method

Glossary Item Box

Description

Sets the event handlers of the server.

Syntax

Visual Basic
Public Sub SetEventHandlers( _
   ByVal EventHandlers As EventHandlers _
)

Parameters

EventHandlers

See Also

ServerManagementOperations Object | ServerManagementOperations Members


%%PageItemTitle%%

ServerScheduledJobManagementOperations Object
Members See Also Send comments

Glossary Item Box

Description

The ServerScheduledJobManagementOperations class represents the available scheduled job management operations.

Public Methods

Public Method AddScheduledJob | Add the specified scheduled job to the server.
Public Method CancelScheduledJob | Cancels the execution of the specified scheduled job.
Public Method GetScheduledJob | Gets the specified scheduled job.
Public Method GetScheduledJobRunInfo | Gets run information on the specified scheduled job.
Public Method GetScheduledJobs | Gets all scheduled jobs on the server.
Public Method ModifyScheduledJob | Modifies the specified scheduled job on the server.
Public Method RemoveScheduledJob | Deletes the specified scheduled job from the server.
Public Method StartScheduledJob | Starts the execution of the specified scheduled job.

Remarks

Scheduled jobs in M-Files Admin.

See Also

ServerScheduledJobManagementOperations Members


%%PageItemTitle%%

AddScheduledJob Method
ScheduledJob
ServerScheduledJobManagementOperations Object : AddScheduledJob Method

Glossary Item Box

Description

Add the specified scheduled job to the server.

Syntax

Visual Basic
Public Function AddScheduledJob( _
   ByVal ScheduledJob As ScheduledJob _
) As Long

Parameters

ScheduledJob

See Also

ServerScheduledJobManagementOperations Object | ServerScheduledJobManagementOperations Members


%%PageItemTitle%%

CancelScheduledJob Method
ID
ServerScheduledJobManagementOperations Object : CancelScheduledJob Method

Glossary Item Box

Description

Cancels the execution of the specified scheduled job.

Syntax

Visual Basic
Public Sub CancelScheduledJob( _
   ByVal ID As Long _
)

Parameters

ID

See Also

ServerScheduledJobManagementOperations Object | ServerScheduledJobManagementOperations Members


%%PageItemTitle%%

GetScheduledJob Method
ID
ServerScheduledJobManagementOperations Object : GetScheduledJob Method

Glossary Item Box

Description

Gets the specified scheduled job.

Syntax

Visual Basic
Public Function GetScheduledJob( _
   ByVal ID As Long _
) As ScheduledJob

Parameters

ID

See Also

ServerScheduledJobManagementOperations Object | ServerScheduledJobManagementOperations Members


%%PageItemTitle%%

GetScheduledJobRunInfo Method
ID
ServerScheduledJobManagementOperations Object : GetScheduledJobRunInfo Method

Glossary Item Box

Description

Gets run information on the specified scheduled job.

Syntax

Visual Basic
Public Function GetScheduledJobRunInfo( _
   ByVal ID As Long _
) As ScheduledJobRunInfo

Parameters

ID

See Also

ServerScheduledJobManagementOperations Object | ServerScheduledJobManagementOperations Members


%%PageItemTitle%%

GetScheduledJobs Method
ServerScheduledJobManagementOperations Object : GetScheduledJobs Method

Glossary Item Box

Description

Gets all scheduled jobs on the server.

Syntax

Visual Basic
Public Function GetScheduledJobs() As ScheduledJobs

See Also

ServerScheduledJobManagementOperations Object | ServerScheduledJobManagementOperations Members


%%PageItemTitle%%

ModifyScheduledJob Method
ScheduledJob
ServerScheduledJobManagementOperations Object : ModifyScheduledJob Method

Glossary Item Box

Description

Modifies the specified scheduled job on the server.

Syntax

Visual Basic
Public Sub ModifyScheduledJob( _
   ByVal ScheduledJob As ScheduledJob _
)

Parameters

ScheduledJob

See Also

ServerScheduledJobManagementOperations Object | ServerScheduledJobManagementOperations Members


%%PageItemTitle%%

RemoveScheduledJob Method
ID
ServerScheduledJobManagementOperations Object : RemoveScheduledJob Method

Glossary Item Box

Description

Deletes the specified scheduled job from the server.

Syntax

Visual Basic
Public Sub RemoveScheduledJob( _
   ByVal ID As Long _
)

Parameters

ID

See Also

ServerScheduledJobManagementOperations Object | ServerScheduledJobManagementOperations Members


%%PageItemTitle%%

StartScheduledJob Method
ID
ServerScheduledJobManagementOperations Object : StartScheduledJob Method

Glossary Item Box

Description

Starts the execution of the specified scheduled job.

Syntax

Visual Basic
Public Sub StartScheduledJob( _
   ByVal ID As Long _
)

Parameters

ID

See Also

ServerScheduledJobManagementOperations Object | ServerScheduledJobManagementOperations Members


%%PageItemTitle%%

ServerVaultCapabilities Object
Members See Also Send comments

Glossary Item Box

Description

A data object for specifying the capabilities of an M-Files server and a vault on server.

Public Methods

Public Method Clone Creates a clone of an object.

Public Properties

Public Property ApplicationTaskQueueSupported | The server supports application task queue operations.
Public Property AsyncModifyObjectClassSupported | The server supports asynchronous object class modification.
Public Property AsyncNACLChangePropagationSupported | The server supports asynchronous change propagation of named access control lists.
Public Property AsyncTasksRetrievalSupported | The server supports retrieving asynchronous tasks.
Public Property AutomaticMetadataSupported | The server supports the automatic metadata feature, and metadata extraction is enabled on the server.
Public Property ClientHttpApiSupported | The server supports communication with the client through HTTP API.
Public Property DetectTextLanguageSupported | The server supports detecting the language of plain text.
Public Property EmbeddingToArcGisSupported | The server supports embedding the vNext-based M-Files Web UI to ArcGIS extensions.
Public Property EmbeddingToGoogleGSuiteSupported | The server supports the Google G Suite integration.
Public Property EmbeddingToSalesforceSupported | The server supports embedding the vNext-based M-Files Web UI to Salesforce.
Public Property EmbeddingToSharePointSupported | The server supports embedding the vNext-based M-Files Web UI to SharePoint.
Public Property ExternalRepositoryObjectMigrationSupported | The server supports external repository object migration.
Public Property FacetSearchSupported | Specifies whether facet searches can be executed.
Public Property FavorFullTextSearchSupported | The server supports favoring full-text search.
Public Property FileStreamingSupported | Specifies whether file streaming is supported.
Public Property FindDuplicatesSupported | The server supports finding duplicate files.
Public Property FullControlVaultUserCanModifyCodeSupported | The server supports vault users with full vault control to run code. Requires the server container in the Service Fabric cluster to be a single-tenant service.
Public Property GetTextContentWithOptionsSupported | The server supports option flags when retrieving the text content of a file.
Public Property HierarchicalObjectTypePropertiesSupported | The server supports hierarchical object type properties.
Public Property JSONExtApplicationsSupported | The server supports returning extensibility application structs in JSON format.
Public Property LatestVersionPublicLinkSharingSupported | Specifies whether public links for the latest versions can be shared.
Public Property MdccResolvedOnServer | The metadata card configuration is delivered in preresolved form from a dedicated, virtual NVS namespace.
Public Property NamedValueStorageConflictDetectionSupported | The server supports conflict detection when saving values to the named value storage.
Public Property NewWebWOPICoAuthoringSupported | The server supports WOPI-based co-authoring for the new M-Files Web.
Public Property ObjectDataRetrievalInChunksSupported | The server supports object data retrieval in chunks.
Public Property ObjectPermissionsForClientSupported | The server supports object permissions for clients.
Public Property PropertyDefSearchabilitySupported | Specifies whether property definitions can be set to be searchable or unsearchable.
Public Property PublicLinkSharingSupported | Specifies whether public links can be shared.
Public Property RemoveFromRecentsSupported | The server supports removing objects from the Recently Accessed by Me view.
Public Property ReplicationConfigurationIDSupported | The server supports using configuration IDs with export and import jobs.
Public Property ReverseGroupingLevelSupported | The server supports reversed grouping levels.
Public Property SearchOptionsSupported | The server supports search options.
Public Property SearchReferencedValueListItemsSupported | The server supports searching for value list items referenced by objects.
Public Property SettingsManagerSupported | The server supports settings management.
Public Property SharedLinkBasedWOPIOperationSupported | The server supports WOPI operations based on shared links.
Public Property UndeleteUserAccountByGUIDSupported | The server supports undeleting user accounts.
Public Property UseUserVisibleACLInSearches | The server supports checking users' read access to objects.
Public Property VaultLoginAccountsSupported | The vault supports in-vault login accounts.
Public Property WebClientsProductionTelemetryEnabled | The server supports web telemetry.
Public Property WebUserInterfaceSupported | The server supports web interface.

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ServerVaultCapabilities Members


%%PageItemTitle%%

Clone Method
ServerVaultCapabilities Object : Clone Method

Glossary Item Box

Description

Creates a clone of an object.

Syntax

Visual Basic
Public Function Clone() As ServerVaultCapabilities

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

ApplicationTaskQueueSupported Property
ServerVaultCapabilities Object : ApplicationTaskQueueSupported Property

Glossary Item Box

Description

The server supports application task queue operations.

Property type

Read-only property

Syntax

Visual Basic
Public Property ApplicationTaskQueueSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

AsyncModifyObjectClassSupported Property
ServerVaultCapabilities Object : AsyncModifyObjectClassSupported Property

Glossary Item Box

Description

The server supports asynchronous object class modification.

Property type

Read-only property

Syntax

Visual Basic
Public Property AsyncModifyObjectClassSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

AsyncNACLChangePropagationSupported Property
ServerVaultCapabilities Object : AsyncNACLChangePropagationSupported Property

Glossary Item Box

Description

The server supports asynchronous change propagation of named access control lists.

Property type

Read-only property

Syntax

Visual Basic
Public Property AsyncNACLChangePropagationSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

AsyncTasksRetrievalSupported Property
ServerVaultCapabilities Object : AsyncTasksRetrievalSupported Property

Glossary Item Box

Description

The server supports retrieving asynchronous tasks.

Property type

Read-only property

Syntax

Visual Basic
Public Property AsyncTasksRetrievalSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

AutomaticMetadataSupported Property
ServerVaultCapabilities Object : AutomaticMetadataSupported Property

Glossary Item Box

Description

The server supports the automatic metadata feature, and metadata extraction is enabled on the server.

Property type

Read-only property

Syntax

Visual Basic
Public Property AutomaticMetadataSupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

ClientHttpApiSupported Property
ServerVaultCapabilities Object : ClientHttpApiSupported Property

Glossary Item Box

Description

The server supports communication with the client through HTTP API.

Property type

Read-only property

Syntax

Visual Basic
Public Property ClientHttpApiSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

DetectTextLanguageSupported Property
ServerVaultCapabilities Object : DetectTextLanguageSupported Property

Glossary Item Box

Description

The server supports detecting the language of plain text.

Property type

Read-only property

Syntax

Visual Basic
Public Property DetectTextLanguageSupported As Boolean

Remarks

Requires M-Files 18.12.7201.2 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

EmbeddingToArcGisSupported Property
ServerVaultCapabilities Object : EmbeddingToArcGisSupported Property

Glossary Item Box

Description

The server supports embedding the vNext-based M-Files Web UI to ArcGIS extensions.

Property type

Read-only property

Syntax

Visual Basic
Public Property EmbeddingToArcGisSupported As Boolean

Remarks

Requires M-Files 19.10.8340.0 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

EmbeddingToGoogleGSuiteSupported Property
ServerVaultCapabilities Object : EmbeddingToGoogleGSuiteSupported Property

Glossary Item Box

Description

The server supports the Google G Suite integration.

Property type

Read-only property

Syntax

Visual Basic
Public Property EmbeddingToGoogleGSuiteSupported As Boolean

Remarks

Supported in M-Files 19.9.8227.13 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

EmbeddingToSalesforceSupported Property
ServerVaultCapabilities Object : EmbeddingToSalesforceSupported Property

Glossary Item Box

Description

The server supports embedding the vNext-based M-Files Web UI to Salesforce.

Property type

Read-only property

Syntax

Visual Basic
Public Property EmbeddingToSalesforceSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

EmbeddingToSharePointSupported Property
ServerVaultCapabilities Object : EmbeddingToSharePointSupported Property

Glossary Item Box

Description

The server supports embedding the vNext-based M-Files Web UI to SharePoint.

Property type

Read-only property

Syntax

Visual Basic
Public Property EmbeddingToSharePointSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

ExternalRepositoryObjectMigrationSupported Property
ServerVaultCapabilities Object : ExternalRepositoryObjectMigrationSupported Property

Glossary Item Box

Description

The server supports external repository object migration.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExternalRepositoryObjectMigrationSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

FacetSearchSupported Property
ServerVaultCapabilities Object : FacetSearchSupported Property

Glossary Item Box

Description

Specifies whether facet searches can be executed.

Property type

Read-only property

Syntax

Visual Basic
Public Property FacetSearchSupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

FavorFullTextSearchSupported Property
ServerVaultCapabilities Object : FavorFullTextSearchSupported Property

Glossary Item Box

Description

The server supports favoring full-text search.

Property type

Read-only property

Syntax

Visual Basic
Public Property FavorFullTextSearchSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

FileStreamingSupported Property
ServerVaultCapabilities Object : FileStreamingSupported Property

Glossary Item Box

Description

Specifies whether file streaming is supported.

Property type

Read-only property

Syntax

Visual Basic
Public Property FileStreamingSupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

FindDuplicatesSupported Property
ServerVaultCapabilities Object : FindDuplicatesSupported Property

Glossary Item Box

Description

The server supports finding duplicate files.

Property type

Read-only property

Syntax

Visual Basic
Public Property FindDuplicatesSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

FullControlVaultUserCanModifyCodeSupported Property
ServerVaultCapabilities Object : FullControlVaultUserCanModifyCodeSupported Property

Glossary Item Box

Description

The server supports vault users with full vault control to run code. Requires the server container in the Service Fabric cluster to be a single-tenant service.

Property type

Read-only property

Syntax

Visual Basic
Public Property FullControlVaultUserCanModifyCodeSupported As Boolean

Remarks

Requires M-Files 19.10.8340.0 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

GetTextContentWithOptionsSupported Property
ServerVaultCapabilities Object : GetTextContentWithOptionsSupported Property

Glossary Item Box

Description

The server supports option flags when retrieving the text content of a file.

Property type

Read-only property

Syntax

Visual Basic
Public Property GetTextContentWithOptionsSupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

HierarchicalObjectTypePropertiesSupported Property
ServerVaultCapabilities Object : HierarchicalObjectTypePropertiesSupported Property

Glossary Item Box

Description

The server supports hierarchical object type properties.

Property type

Read-only property

Syntax

Visual Basic
Public Property HierarchicalObjectTypePropertiesSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

JSONExtApplicationsSupported Property
ServerVaultCapabilities Object : JSONExtApplicationsSupported Property

Glossary Item Box

Description

The server supports returning extensibility application structs in JSON format.

Property type

Read-only property

Syntax

Visual Basic
Public Property JSONExtApplicationsSupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

LatestVersionPublicLinkSharingSupported Property
ServerVaultCapabilities Object : LatestVersionPublicLinkSharingSupported Property

Glossary Item Box

Description

Specifies whether public links for the latest versions can be shared.

Property type

Read-only property

Syntax

Visual Basic
Public Property LatestVersionPublicLinkSharingSupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

MdccResolvedOnServer Property
ServerVaultCapabilities Object : MdccResolvedOnServer Property

Glossary Item Box

Description

The metadata card configuration is delivered in preresolved form from a dedicated, virtual NVS namespace.

Property type

Read-only property

Syntax

Visual Basic
Public Property MdccResolvedOnServer As Boolean

Remarks

Supported in M-Files 21.10.10712.0 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

NamedValueStorageConflictDetectionSupported Property
ServerVaultCapabilities Object : NamedValueStorageConflictDetectionSupported Property

Glossary Item Box

Description

The server supports conflict detection when saving values to the named value storage.

Property type

Read-only property

Syntax

Visual Basic
Public Property NamedValueStorageConflictDetectionSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

NewWebWOPICoAuthoringSupported Property
ServerVaultCapabilities Object : NewWebWOPICoAuthoringSupported Property

Glossary Item Box

Description

The server supports WOPI-based co-authoring for the new M-Files Web.

Property type

Read-only property

Syntax

Visual Basic
Public Property NewWebWOPICoAuthoringSupported As Boolean

Remarks

Supported in M-Files 22.1.11017.2 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

ObjectDataRetrievalInChunksSupported Property
ServerVaultCapabilities Object : ObjectDataRetrievalInChunksSupported Property

Glossary Item Box

Description

The server supports object data retrieval in chunks.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectDataRetrievalInChunksSupported As Boolean

Remarks

Supported in M-Files 19.4.7683.3 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

ObjectPermissionsForClientSupported Property
ServerVaultCapabilities Object : ObjectPermissionsForClientSupported Property

Glossary Item Box

Description

The server supports object permissions for clients.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectPermissionsForClientSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

PropertyDefSearchabilitySupported Property
ServerVaultCapabilities Object : PropertyDefSearchabilitySupported Property

Glossary Item Box

Description

Specifies whether property definitions can be set to be searchable or unsearchable.

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyDefSearchabilitySupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

PublicLinkSharingSupported Property
ServerVaultCapabilities Object : PublicLinkSharingSupported Property

Glossary Item Box

Description

Specifies whether public links can be shared.

Property type

Read-only property

Syntax

Visual Basic
Public Property PublicLinkSharingSupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

RemoveFromRecentsSupported Property
ServerVaultCapabilities Object : RemoveFromRecentsSupported Property

Glossary Item Box

Description

The server supports removing objects from the Recently Accessed by Me view.

Property type

Read-only property

Syntax

Visual Basic
Public Property RemoveFromRecentsSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

ReplicationConfigurationIDSupported Property
ServerVaultCapabilities Object : ReplicationConfigurationIDSupported Property

Glossary Item Box

Description

The server supports using configuration IDs with export and import jobs.

Property type

Read-only property

Syntax

Visual Basic
Public Property ReplicationConfigurationIDSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

ReverseGroupingLevelSupported Property
ServerVaultCapabilities Object : ReverseGroupingLevelSupported Property

Glossary Item Box

Description

The server supports reversed grouping levels.

Property type

Read-only property

Syntax

Visual Basic
Public Property ReverseGroupingLevelSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

SearchOptionsSupported Property
ServerVaultCapabilities Object : SearchOptionsSupported Property

Glossary Item Box

Description

The server supports search options.

Property type

Read-only property

Syntax

Visual Basic
Public Property SearchOptionsSupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

SearchReferencedValueListItemsSupported Property
ServerVaultCapabilities Object : SearchReferencedValueListItemsSupported Property

Glossary Item Box

Description

The server supports searching for value list items referenced by objects.

Property type

Read-only property

Syntax

Visual Basic
Public Property SearchReferencedValueListItemsSupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

SettingsManagerSupported Property
ServerVaultCapabilities Object : SettingsManagerSupported Property

Glossary Item Box

Description

The server supports settings management.

Property type

Read-only property

Syntax

Visual Basic
Public Property SettingsManagerSupported As Boolean

Remarks

Supported in M-Files 19.5.7811.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

SharedLinkBasedWOPIOperationSupported Property
ServerVaultCapabilities Object : SharedLinkBasedWOPIOperationSupported Property

Glossary Item Box

Description

The server supports WOPI operations based on shared links.

Property type

Read-only property

Syntax

Visual Basic
Public Property SharedLinkBasedWOPIOperationSupported As Boolean

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

UndeleteUserAccountByGUIDSupported Property
ServerVaultCapabilities Object : UndeleteUserAccountByGUIDSupported Property

Glossary Item Box

Description

The server supports undeleting user accounts.

Property type

Read-only property

Syntax

Visual Basic
Public Property UndeleteUserAccountByGUIDSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

UseUserVisibleACLInSearches Property
ServerVaultCapabilities Object : UseUserVisibleACLInSearches Property

Glossary Item Box

Description

The server supports checking users' read access to objects.

Property type

Read-only property

Syntax

Visual Basic
Public Property UseUserVisibleACLInSearches As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

VaultLoginAccountsSupported Property
ServerVaultCapabilities Object : VaultLoginAccountsSupported Property

Glossary Item Box

Description

The vault supports in-vault login accounts.

Property type

Read-only property

Syntax

Visual Basic
Public Property VaultLoginAccountsSupported As Boolean

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

WebClientsProductionTelemetryEnabled Property
ServerVaultCapabilities Object : WebClientsProductionTelemetryEnabled Property

Glossary Item Box

Description

The server supports web telemetry.

Property type

Read-only property

Syntax

Visual Basic
Public Property WebClientsProductionTelemetryEnabled As Boolean

Remarks

Supported in M-Files 20.9.9430.1 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

WebUserInterfaceSupported Property
ServerVaultCapabilities Object : WebUserInterfaceSupported Property

Glossary Item Box

Description

The server supports web interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property WebUserInterfaceSupported As Boolean

Remarks

Supported in M-Files 19.7.8028.5 and later.

See Also

ServerVaultCapabilities Object | ServerVaultCapabilities Members


%%PageItemTitle%%

ServerVaultManagementOperations Object
Members See Also Send comments

Glossary Item Box

Description

A group of methods for administering vaults.

Public Methods

Public Method AttachVault | Attaches the specified vault to the server. The metadata database and data files must already exist.
Public Method AttachVaultWithOptions | Attaches the specified vault to the server with options. The metadata database and data files must already exist.
Public Method BackupVault | Creates a backup with the specified parameters.
Public Method BringVaultOnline | Bring the vault online.
Public Method CopyVault | Creates a copy of a vault.
Public Method CreateNewGroundLinkProxy | Creates a new Ground Link proxy to the server based on the given vault properties.
Public Method CreateNewVault | Creates a new vault to the server based on the given vault properties.
Public Method DestroyVault | Destroys the specified vault.
Public Method DetachVault | Detaches the specified vault from the server. Removes the vault from the server's list of attached vaults but does not remove the metadata database or data files.
Public Method GetBackupFileContents | Gets information on the specified backup file.
Public Method GetVaultProperties | Gets the properties of the vault
Public Method OptimizeVault | Performs vault structure optimization.
Public Method RestoreVault | Restores the specified backup.
Public Method TakeVaultOffline | Takes the vault offline.

Remarks

Vault management operations (highlighted with the green rectangle) as seen in M-Files Admin.

See Also

ServerVaultManagementOperations Members


%%PageItemTitle%%

AttachVault Method
VaultProperties
UpdateAttachmentGUID
ServerVaultManagementOperations Object : AttachVault Method

Glossary Item Box

Description

Attaches the specified vault to the server. The metadata database and data files must already exist.

Syntax

Visual Basic
Public Function AttachVault( _
   ByVal VaultProperties As VaultProperties, _
   Optional ByVal UpdateAttachmentGUID As Boolean = True _
) As VaultProperties

Parameters

VaultProperties
UpdateAttachmentGUID

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

AttachVaultWithOptions Method
VaultProperties
Contains the vault properties.
Options
Contains the vault attach options.
ServerVaultManagementOperations Object : AttachVaultWithOptions Method

Glossary Item Box

Description

Attaches the specified vault to the server with options. The metadata database and data files must already exist.

Syntax

Visual Basic
Public Function AttachVaultWithOptions( _
   ByVal VaultProperties As VaultProperties, _
   ByVal Options As AttachVaultOptions _
) As VaultProperties

Parameters

VaultProperties
Contains the vault properties.
Options
Contains the vault attach options.

Remarks

Compared with the AttachVault Method, enables you to further define which elements should be disabled when a vault is attached by using the properties in the AttachVaultOptions Object.

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

BackupVault Method
BackupJob
A job object that defines the backup parameters.
ServerVaultManagementOperations Object : BackupVault Method

Glossary Item Box

Description

Creates a backup with the specified parameters.

Syntax

Visual Basic
Public Sub BackupVault( _
   ByVal BackupJob As BackupJob _
)

Parameters

BackupJob
A job object that defines the backup parameters.

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

BringVaultOnline Method
VaultGUID
The GUID of the vault to be brought online.
ServerVaultManagementOperations Object : BringVaultOnline Method

Glossary Item Box

Description

Bring the vault online.

Syntax

Visual Basic
Public Sub BringVaultOnline( _
   ByVal VaultGUID As String _
)

Parameters

VaultGUID
The GUID of the vault to be brought online.

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

CopyVault Method
CopyVaultJob
ServerVaultManagementOperations Object : CopyVault Method

Glossary Item Box

Description

Creates a copy of a vault.

Syntax

Visual Basic
Public Function CopyVault( _
   ByVal CopyVaultJob As CopyVaultJob _
) As CopyVaultJobOutputInfo

Parameters

CopyVaultJob

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

CreateNewGroundLinkProxy Method
VaultProperties
Properties for the new Ground Link proxy.
ServerVaultManagementOperations Object : CreateNewGroundLinkProxy Method

Glossary Item Box

Description

Creates a new Ground Link proxy to the server based on the given vault properties.

Syntax

Visual Basic
Public Function CreateNewGroundLinkProxy( _
   ByVal VaultProperties As VaultProperties _
) As String

Parameters

VaultProperties
Properties for the new Ground Link proxy.

Remarks

Supported in M-Files 20.3.8876.4 and newer.

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

CreateNewVault Method
VaultProperties
ServerVaultManagementOperations Object : CreateNewVault Method

Glossary Item Box

Description

Creates a new vault to the server based on the given vault properties.

Syntax

Visual Basic
Public Function CreateNewVault( _
   ByVal VaultProperties As VaultProperties _
) As String

Parameters

VaultProperties

Remarks

The output string is the GUID of the newly created vault.

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

DestroyVault Method
VaultGUID
The GUID of the vault to be destroyed.
ServerVaultManagementOperations Object : DestroyVault Method

Glossary Item Box

Description

Destroys the specified vault.

Syntax

Visual Basic
Public Sub DestroyVault( _
   ByVal VaultGUID As String _
)

Parameters

VaultGUID
The GUID of the vault to be destroyed.

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

DetachVault Method
VaultGUID
The GUID of the vault to be detached.
ServerVaultManagementOperations Object : DetachVault Method

Glossary Item Box

Description

Detaches the specified vault from the server. Removes the vault from the server's list of attached vaults but does not remove the metadata database or data files.

Syntax

Visual Basic
Public Sub DetachVault( _
   ByVal VaultGUID As String _
)

Parameters

VaultGUID
The GUID of the vault to be detached.

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

GetBackupFileContents Method
BackupFileFull
Path to a full backup file on the server.
BackupFileDifferential
Path to a differential backup file on the server.
Impersonation

Account information for accessing the backup files on the server.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

ServerVaultManagementOperations Object : GetBackupFileContents Method

Glossary Item Box

Description

Gets information on the specified backup file.

Syntax

Visual Basic
Public Function GetBackupFileContents( _
   ByVal BackupFileFull As String, _
   ByVal BackupFileDifferential As String, _
   Optional ByVal Impersonation As Impersonation = 0 _
) As VaultProperties

Parameters

BackupFileFull
Path to a full backup file on the server.
BackupFileDifferential
Path to a differential backup file on the server.
Impersonation

Account information for accessing the backup files on the server.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

GetVaultProperties Method
VaultGUID
The GUID of the vault to retrieve the properties for.
ServerVaultManagementOperations Object : GetVaultProperties Method

Glossary Item Box

Description

Gets the properties of the vault

Syntax

Visual Basic
Public Function GetVaultProperties( _
   ByVal VaultGUID As String _
) As VaultProperties

Parameters

VaultGUID
The GUID of the vault to retrieve the properties for.

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

OptimizeVault Method
OptimizeVaultJob
ServerVaultManagementOperations Object : OptimizeVault Method

Glossary Item Box

Description

Performs vault structure optimization.

Syntax

Visual Basic
Public Sub OptimizeVault( _
   ByVal OptimizeVaultJob As OptimizeVaultJob _
)

Parameters

OptimizeVaultJob

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

RestoreVault Method
RestoreJob
A job object that defines the restore parameters.
ServerVaultManagementOperations Object : RestoreVault Method

Glossary Item Box

Description

Restores the specified backup.

Syntax

Visual Basic
Public Sub RestoreVault( _
   ByVal RestoreJob As RestoreJob _
)

Parameters

RestoreJob
A job object that defines the restore parameters.

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

TakeVaultOffline Method
VaultGUID
The GUID of the vault to be taken offline.
DisconnectUsers
If this parameter is True, any existing sessions are terminated. If this parameter is False, the operation fails if there are open sessions.
ServerVaultManagementOperations Object : TakeVaultOffline Method

Glossary Item Box

Description

Takes the vault offline.

Syntax

Visual Basic
Public Sub TakeVaultOffline( _
   ByVal VaultGUID As String, _
   ByVal DisconnectUsers As Boolean _
)

Parameters

VaultGUID
The GUID of the vault to be taken offline.
DisconnectUsers
If this parameter is True, any existing sessions are terminated. If this parameter is False, the operation fails if there are open sessions.

See Also

ServerVaultManagementOperations Object | ServerVaultManagementOperations Members


%%PageItemTitle%%

ServerWOPIOperations Object
Members See Also Send comments

Glossary Item Box

Description

Methods for accessing the server WOPI operations.

Public Methods

Public Method EndWOPIUserSession | Ends the WOPI user session for the given key.
Public Method GetWOPILock | Gets the WOPI lock.
Public Method GetWOPIUserSession | Gets the WOPI user session information with the given key.
Public Method GetWOPIUserSessionKey | Gets the WOPI user session token with one-time token.
Public Method RemoveWOPILock | Removes the WOPI lock.
Public Method SetWOPILock | Sets the WOPI lock.
Public Method WOPIDownloadFile_Begin | Begins the block-by-block download of a file for WOPI operations.
Public Method WOPIDownloadFile_ReadBlock | Downloads a specific block from a file on the server for WOPI Operations.
Public Method WOPIFileCheckIn | Checks in the file with the given key.
Public Method WOPIFileCheckOut | Checks out the file with the given key.
Public Method WOPIUploadFileBlock | Uploads to the server a block of a file that is edited or co-authored.
Public Method WOPIUploadFileBlockBegin | Begins to upload to the server a file that is edited or co-authored.
Public Method WOPIUploadFileCommit | Commits the upload operation of the specified file edited or co-authored with WOPI.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Members


%%PageItemTitle%%

EndWOPIUserSession Method
WOPIUserSessionToken
The WOPI user session token.
ServerWOPIOperations Object : EndWOPIUserSession Method

Glossary Item Box

Description

Ends the WOPI user session for the given key.

Syntax

Visual Basic
Public Sub EndWOPIUserSession( _
   ByVal WOPIUserSessionToken As String _
)

Parameters

WOPIUserSessionToken
The WOPI user session token.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

GetWOPILock Method
WOPIUserSessionToken
The WOPI user session token.
ServerWOPIOperations Object : GetWOPILock Method

Glossary Item Box

Description

Gets the WOPI lock.

Syntax

Visual Basic
Public Function GetWOPILock( _
   ByVal WOPIUserSessionToken As String _
) As WOPILock

Parameters

WOPIUserSessionToken
The WOPI user session token.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

GetWOPIUserSession Method
WOPIUserSessionToken
The WOPI user session token.
ServerWOPIOperations Object : GetWOPIUserSession Method

Glossary Item Box

Description

Gets the WOPI user session information with the given key.

Syntax

Visual Basic
Public Function GetWOPIUserSession( _
   ByVal WOPIUserSessionToken As String _
) As WOPIUserSession

Parameters

WOPIUserSessionToken
The WOPI user session token.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

GetWOPIUserSessionKey Method
Onetimetoken
The one-time token.
ServerWOPIOperations Object : GetWOPIUserSessionKey Method

Glossary Item Box

Description

Gets the WOPI user session token with one-time token.

Syntax

Visual Basic
Public Function GetWOPIUserSessionKey( _
   ByVal Onetimetoken As String _
) As String

Parameters

Onetimetoken
The one-time token.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

RemoveWOPILock Method
WOPIUserSessionToken
The WOPI user session token.
ServerWOPIOperations Object : RemoveWOPILock Method

Glossary Item Box

Description

Removes the WOPI lock.

Syntax

Visual Basic
Public Sub RemoveWOPILock( _
   ByVal WOPIUserSessionToken As String _
)

Parameters

WOPIUserSessionToken
The WOPI user session token.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

SetWOPILock Method
WOPIUserSessionToken
The WOPI user session token.
LockValue
The lock value.
ServerWOPIOperations Object : SetWOPILock Method

Glossary Item Box

Description

Sets the WOPI lock.

Syntax

Visual Basic
Public Sub SetWOPILock( _
   ByVal WOPIUserSessionToken As String, _
   ByVal LockValue As String _
)

Parameters

WOPIUserSessionToken
The WOPI user session token.
LockValue
The lock value.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

WOPIDownloadFile_Begin Method
WOPIUserSessionToken
The WOPI user session token.
ServerWOPIOperations Object : WOPIDownloadFile_Begin Method

Glossary Item Box

Description

Begins the block-by-block download of a file for WOPI operations.

Syntax

Visual Basic
Public Function WOPIDownloadFile_Begin( _
   ByVal WOPIUserSessionToken As String _
) As FileDownloadSession

Parameters

WOPIUserSessionToken
The WOPI user session token.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

WOPIDownloadFile_ReadBlock Method
WOPIUserSessionToken
The WOPI user session token.
DownloadID
The download session ID.
BlockSize
The number of bytes to download.
Offset
The byte offset from the beginning of the file.
ServerWOPIOperations Object : WOPIDownloadFile_ReadBlock Method

Glossary Item Box

Description

Downloads a specific block from a file on the server for WOPI Operations.

Syntax

Visual Basic
Public Function WOPIDownloadFile_ReadBlock( _
   ByVal WOPIUserSessionToken As String, _
   ByVal DownloadID As Long, _
   ByVal BlockSize As Long, _
   ByVal Offset As Unknown _
) As Byte()

Parameters

WOPIUserSessionToken
The WOPI user session token.
DownloadID
The download session ID.
BlockSize
The number of bytes to download.
Offset
The byte offset from the beginning of the file.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

WOPIFileCheckIn Method
WOPIUserSessionToken
The WOPI user session token.
ServerWOPIOperations Object : WOPIFileCheckIn Method

Glossary Item Box

Description

Checks in the file with the given key.

Syntax

Visual Basic
Public Sub WOPIFileCheckIn( _
   ByVal WOPIUserSessionToken As String _
)

Parameters

WOPIUserSessionToken
The WOPI user session token.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

WOPIFileCheckOut Method
WOPIUserSessionToken
The WOPI user session token.
ServerWOPIOperations Object : WOPIFileCheckOut Method

Glossary Item Box

Description

Checks out the file with the given key.

Syntax

Visual Basic
Public Sub WOPIFileCheckOut( _
   ByVal WOPIUserSessionToken As String _
)

Parameters

WOPIUserSessionToken
The WOPI user session token.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

WOPIUploadFileBlock Method
WOPIUserSessionToken
The WOPI user session token.
UploadID
The upload ID.
TotalSizeInBytes
The total size of the file.
Offset
The byte offset from the beginning of the file.
Block
The block to upload.
ServerWOPIOperations Object : WOPIUploadFileBlock Method

Glossary Item Box

Description

Uploads to the server a block of a file that is edited or co-authored.

Syntax

Visual Basic
Public Function WOPIUploadFileBlock( _
   ByVal WOPIUserSessionToken As String, _
   ByVal UploadID As Long, _
   ByVal TotalSizeInBytes As Unknown, _
   ByVal Offset As Unknown, _
   ByVal Block() As Byte _
) As Long

Parameters

WOPIUserSessionToken
The WOPI user session token.
UploadID
The upload ID.
TotalSizeInBytes
The total size of the file.
Offset
The byte offset from the beginning of the file.
Block
The block to upload.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

WOPIUploadFileBlockBegin Method
WOPIUserSessionToken
The WOPI user session token.
ServerWOPIOperations Object : WOPIUploadFileBlockBegin Method

Glossary Item Box

Description

Begins to upload to the server a file that is edited or co-authored.

Syntax

Visual Basic
Public Function WOPIUploadFileBlockBegin( _
   ByVal WOPIUserSessionToken As String _
) As Long

Parameters

WOPIUserSessionToken
The WOPI user session token.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

WOPIUploadFileCommit Method
WOPIUserSessionToken
The WOPI user session token.
UploadID
The upload ID.
ServerWOPIOperations Object : WOPIUploadFileCommit Method

Glossary Item Box

Description

Commits the upload operation of the specified file edited or co-authored with WOPI.

Syntax

Visual Basic
Public Sub WOPIUploadFileCommit( _
   ByVal WOPIUserSessionToken As String, _
   ByVal UploadID As Long _
)

Parameters

WOPIUserSessionToken
The WOPI user session token.
UploadID
The upload ID.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

ServerWOPIOperations Object | ServerWOPIOperations Members


%%PageItemTitle%%

SessionInfo Object
Members See Also Send comments

Glossary Item Box

Description

The SessionInfo class.

Public Methods

Public Method CheckObjectAccess | Checks object access requirements against the properties of this session.
Public Method CheckObjectTypeAccess | Checks the object type access requirements against the properties of this session.
Public Method CheckPropertyDefAccess | Checks the property definition access requirements against the properties of this session.
Public Method CheckVaultAccess | Checks vault access rights against the properties of this session.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method IsLoggedOnUserSubstituteOfUser | Resolves if the user is the substitute of another user.

Public Properties

Public Property AccountName | The M-Files account name of the logged-in user.
Public Property ACLMode | The ACL mode of the session.
Public Property AuthenticationType | The authentication type.
Public Property AutomaticMetadataEnabled | Specifies if the server supports automatic metadata features.
Public Property CanCreateObjects | Specifies whether the user can create documents and other objects.
Public Property CanForceUndoCheckout | Specifies whether the user can enforce undo checkout operation.
Public Property CanManageCommonUISettings | Specifies whether the user can manage common UI settings.
Public Property CanManageCommonViews | Specifies whether the user can manage common views.
Public Property CanManageTraditionalFolders | Specifies whether the user can manage traditional folders.
Public Property CanMaterializeViews | Specifies whether the user can materialize views.
Public Property CanSeeAllObjects | Specifies whether the user can see and read all documents and other objects (including deleted ones).
Public Property CanSeeDeletedObjects | Specifies whether the user can see and undelete deleted documents. Seeing a document still requires that the user has read access to it or the CanSeeAllObjects vault access right.
Public Property ClientCulture | The client software culture information, such as 'en-US' for American English.
Public Property Deployment | The deployment type of the server to which the user is logged in.
Public Property InternalUser | Specifies whether the user using this session is an internal user.
Public Property IsSharingPublicLinksAllowed | Specifies whether sharing public links is allowed.
Public Property IsSharingPublicLinksToLatestVersionAllowed | Specifies whether sharing public links to the latest version of the object is allowed.
Public Property KeepAliveIntervalInSeconds | The number of seconds that can pass between the client's keep-alive calls before M-Files Server closes the session.
Public Property Language | The user's vault language.
Public Property LicenseAllowsModifications | Specifies whether the license allows modifications.
Public Property LicenseType | The license type of the logged-in user.
Public Property LocalComputerName | The name of the local computer.
Public Property ProductMode | Product mode.
Public Property SerialNumber | The serial number of the server to which the user is logged in.
Public Property ServerVaultCapabilities | The capabilities of the connected server and vault.
Public Property ServerVersion | The version of the M-Files Server on which this vault resides.
Public Property TimeZoneInfo | Time zone information of this session.
Public Property UserAndGroupMemberships | The user ID of this session's account, as well as the groups to which the user belongs either directly or indirectly. The first ID in the vector is the user ID. Others are group IDs.
Public Property UserAndSubstitutedByMe | The user ID of this session's account, as well as the users for which the user is a substitute. The first ID in the vector is the user ID. Others are the IDs of the users for which the user is a substitute.
Public Property UserID | User ID for the session.
Public Property VaultGUID | The vault GUID as string.

Remarks

Session info is valid if the user has logged into the vault.

See Also

SessionInfo Members


%%PageItemTitle%%

CheckObjectAccess Method
ObjectAccessControlList
The access control list (ACL) object to be checked.
DesiredObjectAccess
SessionInfo Object : CheckObjectAccess Method

Glossary Item Box

Description

Checks object access requirements against the properties of this session.

Syntax

Visual Basic
Public Function CheckObjectAccess( _
   ByVal ObjectAccessControlList As AccessControlList, _
   ByVal DesiredObjectAccess As MFObjectAccess _
) As Boolean

Parameters

ObjectAccessControlList
The access control list (ACL) object to be checked.
DesiredObjectAccess
Value | Description
MFObjectAccessAttachObjects | Attach objects.
MFObjectAccessChangePermissions | Change permissions.
MFObjectAccessDelete | Delete.
MFObjectAccessEdit | Edit.
MFObjectAccessNone | No access.
MFObjectAccessRead | Read.

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

CheckObjectTypeAccess Method
ObjectTypeAccessControlList
DesiredObjectTypeAccess
SessionInfo Object : CheckObjectTypeAccess Method

Glossary Item Box

Description

Checks the object type access requirements against the properties of this session.

Syntax

Visual Basic
Public Function CheckObjectTypeAccess( _
   ByVal ObjectTypeAccessControlList As AccessControlList, _
   ByVal DesiredObjectTypeAccess As MFObjectTypeAccess _
) As Boolean

Parameters

ObjectTypeAccessControlList
DesiredObjectTypeAccess
Value | Description
MFObjectTypeAccessAddNewItems | Create objects of this type.
MFObjectTypeAccessNone | No access.
MFObjectTypeAccessSeeName | See the name of this object type.

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

CheckPropertyDefAccess Method
PropertyDefAccessControlList
DesiredPropertyDefAccess
SessionInfo Object : CheckPropertyDefAccess Method

Glossary Item Box

Description

Checks the property definition access requirements against the properties of this session.

Syntax

Visual Basic
Public Function CheckPropertyDefAccess( _
   ByVal PropertyDefAccessControlList As AccessControlList, _
   ByVal DesiredPropertyDefAccess As MFPropertyDefAccess _
) As Boolean

Parameters

PropertyDefAccessControlList
DesiredPropertyDefAccess
Value | Description
MFPropertyDefAccessEdit | Edit values of this property.
MFPropertyDefAccessNone | No access.
MFPropertyDefAccessSee | See this property.

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

CheckVaultAccess Method
DesiredVaultAccess
SessionInfo Object : CheckVaultAccess Method

Glossary Item Box

Description

Checks vault access rights against the properties of this session.

Syntax

Visual Basic
Public Function CheckVaultAccess( _
   ByVal DesiredVaultAccess As MFVaultAccess _
) As Boolean

Parameters

DesiredVaultAccess
Value | Description
MFVaultAccessChangeAssignments | Modify all assignment information.
MFVaultAccessChangeDocSecurity | Change documents' security settings.
MFVaultAccessChangeFullControlRole | Add/remove the full control role.
MFVaultAccessChangeMetaDataStructure | Change metadata structure.
MFVaultAccessChangeObjectStates | Change the state of an object regardless of the state's ACL.
MFVaultAccessCreateDocs | Create documents.
MFVaultAccessDestroyDocs | Destroy documents.
MFVaultAccessEditAllDocs | Modify all documents (excluding changing security settings).
MFVaultAccessExportContent | Export content to a content package or move old versions of objects to a content package.
MFVaultAccessForceUndoCheckout | Force undo check-out.
MFVaultAccessImportContent | Import content from a content package.
MFVaultAccessLicenseAllowsModifications | The license of the user allows modifications.
MFVaultAccessManageCommonNotificationRules | Create, modify, and delete common notification rules.
MFVaultAccessManageCommonUISettings | Manage common display (UI) settings.
MFVaultAccessManageCommonViews | Create, modify, and delete common views.
MFVaultAccessManageEvents | Enable or disable event logging, delete a range of events, and get all events of the vault.
MFVaultAccessManageExternalLocations | Add, modify, or remove external locations.
MFVaultAccessManageTraditionalFolders | Create, modify, and delete traditional folders.
MFVaultAccessManageUserAccounts | Manage user accounts.
MFVaultAccessManageVLItemsFromClient | Manage (for instance add, modify, remove) value list items from client side.
MFVaultAccessMaterializeViews | Materialize views.
MFVaultAccessNone | No vault access.
MFVaultAccessSeeAllDocs | See all documents (including deleted ones).
MFVaultAccessSeeDeletedDocs | See deleted objects. However, seeing a deleted object requires the user to have read access to the object or the vault-level SeeAllDocs access right.
MFVaultAccessUndeleteDocs | Undelete documents.
MFVaultAccessVerifyVault | Verify and fix vault.

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

CloneFrom Method
SessionInfo
SessionInfo Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal SessionInfo As SessionInfo _
)

Parameters

SessionInfo

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

IsLoggedOnUserSubstituteOfUser Method
UserID
The user ID of another user who may be substituted by the current user.
SessionInfo Object : IsLoggedOnUserSubstituteOfUser Method

Glossary Item Box

Description

Resolves if the user is the substitute of another user.

Syntax

Visual Basic
Public Function IsLoggedOnUserSubstituteOfUser( _
   ByVal UserID As Long _
) As Boolean

Parameters

UserID
The user ID of another user who may be substituted by the current user.

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

AccountName Property
SessionInfo Object : AccountName Property

Glossary Item Box

Description

The M-Files account name of the logged-in user.

Property type

Read-only property

Syntax

Visual Basic
Public Property AccountName As String

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

ACLMode Property
SessionInfo Object : ACLMode Property

Glossary Item Box

Description

The ACL mode of the session.

Property type

Read-only property

Syntax

Visual Basic
Public Property ACLMode As MFACLMode

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

AuthenticationType Property
SessionInfo Object : AuthenticationType Property

Glossary Item Box

Description

The authentication type.

Property type

Read-only property

Syntax

Visual Basic
Public Property AuthenticationType As MFAuthType

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

AutomaticMetadataEnabled Property
SessionInfo Object : AutomaticMetadataEnabled Property

Glossary Item Box

Description

Specifies if the server supports automatic metadata features.

Property type

Read-only property

Syntax

Visual Basic
Public Property AutomaticMetadataEnabled As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

CanCreateObjects Property
SessionInfo Object : CanCreateObjects Property

Glossary Item Box

Description

Specifies whether the user can create documents and other objects.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanCreateObjects As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

CanForceUndoCheckout Property
SessionInfo Object : CanForceUndoCheckout Property

Glossary Item Box

Description

Specifies whether the user can enforce undo checkout operation.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanForceUndoCheckout As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

CanManageCommonUISettings Property
SessionInfo Object : CanManageCommonUISettings Property

Glossary Item Box

Description

Specifies whether the user can manage common UI settings.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanManageCommonUISettings As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

CanManageCommonViews Property
SessionInfo Object : CanManageCommonViews Property

Glossary Item Box

Description

Specifies whether the user can manage common views.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanManageCommonViews As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

CanManageTraditionalFolders Property
SessionInfo Object : CanManageTraditionalFolders Property

Glossary Item Box

Description

Specifies whether the user can manage traditional folders.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanManageTraditionalFolders As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

CanMaterializeViews Property
SessionInfo Object : CanMaterializeViews Property

Glossary Item Box

Description

Specifies whether the user can materialize views.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanMaterializeViews As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

CanSeeAllObjects Property
SessionInfo Object : CanSeeAllObjects Property

Glossary Item Box

Description

Specifies whether the user can see and read all documents and other objects (including deleted ones).

Property type

Read-only property

Syntax

Visual Basic
Public Property CanSeeAllObjects As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

CanSeeDeletedObjects Property
SessionInfo Object : CanSeeDeletedObjects Property

Glossary Item Box

Description

Specifies whether the user can see and undelete deleted documents. Seeing a document still requires that the user has read access to it or the CanSeeAllObjects vault access right.

Property type

Read-only property

Syntax

Visual Basic
Public Property CanSeeDeletedObjects As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

ClientCulture Property
SessionInfo Object : ClientCulture Property

Glossary Item Box

Description

The client software culture information, such as 'en-US' for American English.

Property type

Read-only property

Syntax

Visual Basic
Public Property ClientCulture As String

Remarks

See also the "ClientCulture" parameter in ConnectEx6 Method and ConnectWithAuthenticationDataEx4 Method.

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

Deployment Property
SessionInfo Object : Deployment Property

Glossary Item Box

Description

The deployment type of the server to which the user is logged in.

Property type

Read-only property

Syntax

Visual Basic
Public Property Deployment As String

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

InternalUser Property
SessionInfo Object : InternalUser Property

Glossary Item Box

Description

Specifies whether the user using this session is an internal user.

Property type

Read-only property

Syntax

Visual Basic
Public Property InternalUser As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

IsSharingPublicLinksAllowed Property
SessionInfo Object : IsSharingPublicLinksAllowed Property

Glossary Item Box

Description

Specifies whether sharing public links is allowed.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSharingPublicLinksAllowed As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

IsSharingPublicLinksToLatestVersionAllowed Property
SessionInfo Object : IsSharingPublicLinksToLatestVersionAllowed Property

Glossary Item Box

Description

Specifies whether sharing public links to the latest version of the object is allowed.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSharingPublicLinksToLatestVersionAllowed As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

KeepAliveIntervalInSeconds Property
SessionInfo Object : KeepAliveIntervalInSeconds Property

Glossary Item Box

Description

The number of seconds that can pass between the client's keep-alive calls before M-Files Server closes the session.

Property type

Read-only property

Syntax

Visual Basic
Public Property KeepAliveIntervalInSeconds As Long

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

Language Property
SessionInfo Object : Language Property

Glossary Item Box

Description

The user's vault language.

Property type

Read-only property

Syntax

Visual Basic
Public Property Language As Integer

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

LicenseAllowsModifications Property
SessionInfo Object : LicenseAllowsModifications Property

Glossary Item Box

Description

Specifies whether the license allows modifications.

Property type

Read-only property

Syntax

Visual Basic
Public Property LicenseAllowsModifications As Boolean

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

LicenseType Property
pltLicenseTypeAsEnum
Receives the license type as an enumeration.
pbstrLicenseTypeAsString
Receives the license type as a one-word string.
SessionInfo Object : LicenseType Property

Glossary Item Box

Description

The license type of the logged-in user.

Property type

Read-only property

Syntax

Visual Basic
Public Property LicenseType( _
   ByRef pltLicenseTypeAsEnum As MFLicenseType, _
   ByRef pbstrLicenseTypeAsString As String _
)

Parameters

pltLicenseTypeAsEnum
Value | Description
MFLicenseTypeConcurrentUserLicense | Concurrent user license.
MFLicenseTypeNamedUserLicense | Named user license.
MFLicenseTypeNone | No license.
MFLicenseTypeReadOnlyLicense | Read-only license.
Receives the license type as an enumeration.
pbstrLicenseTypeAsString
Receives the license type as a one-word string.

Remarks

Supported in M-Files 21.12.10943.6 and later.

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

LocalComputerName Property
SessionInfo Object : LocalComputerName Property

Glossary Item Box

Description

The name of the local computer.

Property type

Read-only property

Syntax

Visual Basic
Public Property LocalComputerName As String

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

ProductMode Property
SessionInfo Object : ProductMode Property

Glossary Item Box

Description

Product mode.

Property type

Read-only property

Syntax

Visual Basic
Public Property ProductMode As MFProductMode

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

SerialNumber Property
SessionInfo Object : SerialNumber Property

Glossary Item Box

Description

The serial number of the server to which the user is logged in.

Property type

Read-only property

Syntax

Visual Basic
Public Property SerialNumber As String

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

ServerVaultCapabilities Property
SessionInfo Object : ServerVaultCapabilities Property

Glossary Item Box

Description

The capabilities of the connected server and vault.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerVaultCapabilities As ServerVaultCapabilities

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

ServerVersion Property
SessionInfo Object : ServerVersion Property

Glossary Item Box

Description

The version of the M-Files Server on which this vault resides.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerVersion As {Unrecognised type 21}

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

TimeZoneInfo Property
SessionInfo Object : TimeZoneInfo Property

Glossary Item Box

Description

Time zone information of this session.

Property type

Read-only property

Syntax

Visual Basic
Public Property TimeZoneInfo As TimeZoneInformation

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

UserAndGroupMemberships Property
SessionInfo Object : UserAndGroupMemberships Property

Glossary Item Box

Description

The user ID of this session's account, as well as the groups to which the user belongs either directly or indirectly. The first ID in the vector is the user ID. Others are group IDs.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserAndGroupMemberships As UserOrUserGroupIDs

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

UserAndSubstitutedByMe Property
SessionInfo Object : UserAndSubstitutedByMe Property

Glossary Item Box

Description

The user ID of this session's account, as well as the users for which the user is a substitute. The first ID in the vector is the user ID. Others are the IDs of the users for which the user is a substitute.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserAndSubstitutedByMe As UserOrUserGroupIDs

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

UserID Property
SessionInfo Object : UserID Property

Glossary Item Box

Description

User ID for the session.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserID As Long

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

VaultGUID Property
SessionInfo Object : VaultGUID Property

Glossary Item Box

Description

The vault GUID as string.

Property type

Read-only property

Syntax

Visual Basic
Public Property VaultGUID As String

See Also

SessionInfo Object | SessionInfo Members


%%PageItemTitle%%

SetPropertiesParams Object
Members See Also Send comments

Glossary Item Box

Description

SetPropertiesParams collection represents the parameters for setting the properties of one object version.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetWithPermissions | Sets the contents of this object.

Public Properties

Public Property AccessControlListEnforcingMode | Gets the mode of access control list enforcing.
Public Property AccessControlListProvidedForEnforcing | Gets the access control list provided for enforcing.
Public Property AllowModifyingCheckedInObject | Allow the modification of checked in object.
Public Property FailIfNotLatestCheckedInVersion | Should the operation fail of not specifying the latest checked in version.
Public Property FullSet | True if the specified property values specify full set of property values.
Public Property ObjVer | ObjVer.
Public Property PropertyValuesToRemove | The property values that are removed from the object.
Public Property PropertyValuesToSet | The property values to set.

See Also

SetPropertiesParams Members


%%PageItemTitle%%

Clone Method
SetPropertiesParams Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SetPropertiesParams

See Also

SetPropertiesParams Object | SetPropertiesParams Members


%%PageItemTitle%%

SetWithPermissions Method
ObjVer
AllowModifyingCheckedInObject
FailIfNotLatestCheckedInVersion
PropertyValuesToSet
FullSet
PropertyValuesToRemove
ObjectOperationFlags
AccessControlListEnforcingMode
AccessControlListProvidedForEnforcing
SetPropertiesParams Object : SetWithPermissions Method

Glossary Item Box

Description

Sets the contents of this object.

Syntax

Visual Basic
Public Sub SetWithPermissions( _
   ByVal ObjVer As ObjVer, _
   ByVal AllowModifyingCheckedInObject As Boolean, _
   ByVal FailIfNotLatestCheckedInVersion As Boolean, _
   ByVal PropertyValuesToSet As PropertyValues, _
   ByVal FullSet As Boolean, _
   ByVal PropertyValuesToRemove As IDs, _
   Optional ByVal ObjectOperationFlags As MFObjectOperationFlags = MFObjectOperationFlagNone, _
   Optional ByVal AccessControlListEnforcingMode As MFACLEnforcingMode = MFACLEnforcingModeAutomatic, _
   Optional ByVal AccessControlListProvidedForEnforcing As AccessControlList = 0 _
)

Parameters

ObjVer
AllowModifyingCheckedInObject
FailIfNotLatestCheckedInVersion
PropertyValuesToSet
FullSet
PropertyValuesToRemove
ObjectOperationFlags
Value | Description
MFObjectOperationFlagChangeACLInAllVersions | The permissions should be updated for all versions.
MFObjectOperationFlagDisallowNameChange | Changing the object name is not allowed.
MFObjectOperationFlagNone | None
MFObjectOperationFlagRequireChangeSecurityAccess | The current user must have change security access to the modified object after the operation is completed.
MFObjectOperationFlagRequireEditAccess | The current user must have edit access to the modified object after the operation is completed.
MFObjectOperationFlagRequireFullAccess | The current user must have full access to the modified object after the operation is completed.
MFObjectOperationFlagRequireReadAccess | The current user must have read access to the modified object after the operation is completed.
MFObjectOperationFlagRequireSomeAccess | The current user must have access to the modified object after the operation is completed.
AccessControlListEnforcingMode
Value | Description
MFACLEnforcingModeAutomatic | The ACL previously stored for the object is used as the provided ACL.
MFACLEnforcingModeNone | The object ACL remains untouched.
MFACLEnforcingModeProvided | The ACL provided by the caller is used.
MFACLEnforcingModeResetToDefault | The ACL calculated from the properties is used as the provided ACL.
AccessControlListProvidedForEnforcing

See Also

SetPropertiesParams Object | SetPropertiesParams Members


%%PageItemTitle%%

AccessControlListEnforcingMode Property
SetPropertiesParams Object : AccessControlListEnforcingMode Property

Glossary Item Box

Description

Gets the mode of access control list enforcing.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessControlListEnforcingMode As MFACLEnforcingMode

See Also

SetPropertiesParams Object | SetPropertiesParams Members


%%PageItemTitle%%

AccessControlListProvidedForEnforcing Property
SetPropertiesParams Object : AccessControlListProvidedForEnforcing Property

Glossary Item Box

Description

Gets the access control list provided for enforcing.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessControlListProvidedForEnforcing As AccessControlList

See Also

SetPropertiesParams Object | SetPropertiesParams Members


%%PageItemTitle%%

AllowModifyingCheckedInObject Property
SetPropertiesParams Object : AllowModifyingCheckedInObject Property

Glossary Item Box

Description

Allow the modification of checked in object.

Property type

Read-write property

Syntax

Visual Basic
Public Property AllowModifyingCheckedInObject As Boolean

See Also

SetPropertiesParams Object | SetPropertiesParams Members


%%PageItemTitle%%

FailIfNotLatestCheckedInVersion Property
SetPropertiesParams Object : FailIfNotLatestCheckedInVersion Property

Glossary Item Box

Description

Should the operation fail of not specifying the latest checked in version.

Property type

Read-write property

Syntax

Visual Basic
Public Property FailIfNotLatestCheckedInVersion As Boolean

See Also

SetPropertiesParams Object | SetPropertiesParams Members


%%PageItemTitle%%

FullSet Property
SetPropertiesParams Object : FullSet Property

Glossary Item Box

Description

True if the specified property values specify full set of property values.

Property type

Read-write property

Syntax

Visual Basic
Public Property FullSet As Boolean

See Also

SetPropertiesParams Object | SetPropertiesParams Members


%%PageItemTitle%%

ObjVer Property
SetPropertiesParams Object : ObjVer Property

Glossary Item Box

Description

ObjVer.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjVer As ObjVer

See Also

SetPropertiesParams Object | SetPropertiesParams Members


%%PageItemTitle%%

PropertyValuesToRemove Property
SetPropertiesParams Object : PropertyValuesToRemove Property

Glossary Item Box

Description

The property values that are removed from the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyValuesToRemove As IDs

See Also

SetPropertiesParams Object | SetPropertiesParams Members


%%PageItemTitle%%

PropertyValuesToSet Property
SetPropertiesParams Object : PropertyValuesToSet Property

Glossary Item Box

Description

The property values to set.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyValuesToSet As PropertyValues

See Also

SetPropertiesParams Object | SetPropertiesParams Members


%%PageItemTitle%%

SetPropertiesParamsOfMultipleObjects Collection
Members See Also Send comments

Glossary Item Box

Description

SetPropertiesParamsOfMultipleObjects is a collection of SetPropertiesParams collections. Each SetPropertiesParams collection represents the parameters for setting the properties of one object version.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

SetPropertiesParamsOfMultipleObjects Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
SetPropertiesParams
The new member to add.
SetPropertiesParamsOfMultipleObjects Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal SetPropertiesParams As SetPropertiesParams _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
SetPropertiesParams
The new member to add.

See Also

SetPropertiesParamsOfMultipleObjects Collection | SetPropertiesParamsOfMultipleObjects Members


%%PageItemTitle%%

Clone Method
SetPropertiesParamsOfMultipleObjects Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SetPropertiesParamsOfMultipleObjects

See Also

SetPropertiesParamsOfMultipleObjects Collection | SetPropertiesParamsOfMultipleObjects Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
SetPropertiesParamsOfMultipleObjects Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

SetPropertiesParamsOfMultipleObjects Collection | SetPropertiesParamsOfMultipleObjects Members


%%PageItemTitle%%

Count Property
SetPropertiesParamsOfMultipleObjects Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

SetPropertiesParamsOfMultipleObjects Collection | SetPropertiesParamsOfMultipleObjects Members


%%PageItemTitle%%

Item Property
Index
SetPropertiesParamsOfMultipleObjects Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As SetPropertiesParams

Parameters

Index

See Also

SetPropertiesParamsOfMultipleObjects Collection | SetPropertiesParamsOfMultipleObjects Members


%%PageItemTitle%%

SharedFileInfo Object
Members See Also Send comments

Glossary Item Box

Description

The 'SharedFileInfo' class represents a description of a public file.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ChangeTimeUtc | The time in UTC when the file was last written to or its attributes were changed.
Public Property Extension | The extension of the file not including the dot (for instance "doc").
Public Property LogicalSize | The logical size of the file.
Public Property LogicalSize_32bit | The logical size of the file (uses 32-bit arguments).
Public Property Title | The title of the file.

See Also

SharedFileInfo Members


%%PageItemTitle%%

Clone Method
SharedFileInfo Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SharedFileInfo

See Also

SharedFileInfo Object | SharedFileInfo Members


%%PageItemTitle%%

ChangeTimeUtc Property
SharedFileInfo Object : ChangeTimeUtc Property

Glossary Item Box

Description

The time in UTC when the file was last written to or its attributes were changed.

Property type

Read-only property

Syntax

Visual Basic
Public Property ChangeTimeUtc As Date

See Also

SharedFileInfo Object | SharedFileInfo Members


%%PageItemTitle%%

Extension Property
SharedFileInfo Object : Extension Property

Glossary Item Box

Description

The extension of the file not including the dot (for instance "doc").

Property type

Read-only property

Syntax

Visual Basic
Public Property Extension As String

See Also

SharedFileInfo Object | SharedFileInfo Members


%%PageItemTitle%%

LogicalSize Property
SharedFileInfo Object : LogicalSize Property

Glossary Item Box

Description

The logical size of the file.

Property type

Read-only property

Syntax

Visual Basic
Public Property LogicalSize As Unknown

See Also

SharedFileInfo Object | SharedFileInfo Members


%%PageItemTitle%%

LogicalSize_32bit Property
SharedFileInfo Object : LogicalSize_32bit Property

Glossary Item Box

Description

The logical size of the file (uses 32-bit arguments).

Property type

Read-only property

Syntax

Visual Basic
Public Property LogicalSize_32bit As Long

See Also

SharedFileInfo Object | SharedFileInfo Members


%%PageItemTitle%%

Title Property
SharedFileInfo Object : Title Property

Glossary Item Box

Description

The title of the file.

Property type

Read-only property

Syntax

Visual Basic
Public Property Title As String

See Also

SharedFileInfo Object | SharedFileInfo Members


%%PageItemTitle%%

SharedLinkInfo Object
Members See Also Send comments

Glossary Item Box

Description

The 'SharedLinkInfo' class represents a description of a public link.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method Set | Set compulsory fields for creating the link.

Public Properties

Public Property AccessKey | The unique access key of the public link.
Public Property CreatedByUser | The user who created the public link.
Public Property CreationTime | The creation time of the public link.
Public Property Description | The description of the public link.
Public Property ExpirationTime | An optional expiration time for the public link.
Public Property FileVer | The file version referenced with the public link (optional).
Public Property LinkType | The type of the shared link.
Public Property ObjVer | The object version referenced with the public link.

See Also

SharedLinkInfo Members


%%PageItemTitle%%

Clone Method
SharedLinkInfo Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SharedLinkInfo

See Also

SharedLinkInfo Object | SharedLinkInfo Members


%%PageItemTitle%%

Set Method
ObjVer
The object version of the target object.
FileVer
The file version of the target file.
SharedLinkInfo Object : Set Method

Glossary Item Box

Description

Set compulsory fields for creating the link.

Syntax

Visual Basic
Public Sub Set( _
   ByVal ObjVer As ObjVer, _
   ByVal FileVer As FileVer _
)

Parameters

ObjVer
The object version of the target object.
FileVer
The file version of the target file.

See Also

SharedLinkInfo Object | SharedLinkInfo Members


%%PageItemTitle%%

AccessKey Property
SharedLinkInfo Object : AccessKey Property

Glossary Item Box

Description

The unique access key of the public link.

Property type

Read-only property

Syntax

Visual Basic
Public Property AccessKey As String

See Also

SharedLinkInfo Object | SharedLinkInfo Members


%%PageItemTitle%%

CreatedByUser Property
SharedLinkInfo Object : CreatedByUser Property

Glossary Item Box

Description

The user who created the public link.

Property type

Read-only property

Syntax

Visual Basic
Public Property CreatedByUser As Long

See Also

SharedLinkInfo Object | SharedLinkInfo Members


%%PageItemTitle%%

CreationTime Property
SharedLinkInfo Object : CreationTime Property

Glossary Item Box

Description

The creation time of the public link.

Property type

Read-only property

Syntax

Visual Basic
Public Property CreationTime As Timestamp

See Also

SharedLinkInfo Object | SharedLinkInfo Members


%%PageItemTitle%%

Description Property
SharedLinkInfo Object : Description Property

Glossary Item Box

Description

The description of the public link.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description As String

See Also

SharedLinkInfo Object | SharedLinkInfo Members


%%PageItemTitle%%

ExpirationTime Property
SharedLinkInfo Object : ExpirationTime Property

Glossary Item Box

Description

An optional expiration time for the public link.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExpirationTime As Timestamp

See Also

SharedLinkInfo Object | SharedLinkInfo Members


%%PageItemTitle%%

FileVer Property
SharedLinkInfo Object : FileVer Property

Glossary Item Box

Description

The file version referenced with the public link (optional).

Property type

Read-write property

Syntax

Visual Basic
Public Property FileVer As FileVer

See Also

SharedLinkInfo Object | SharedLinkInfo Members


%%PageItemTitle%%

LinkType Property
SharedLinkInfo Object : LinkType Property

Glossary Item Box

Description

The type of the shared link.

Property type

Read-write property

Syntax

Visual Basic
Public Property LinkType As MFSharedLinkType

See Also

SharedLinkInfo Object | SharedLinkInfo Members


%%PageItemTitle%%

ObjVer Property
SharedLinkInfo Object : ObjVer Property

Glossary Item Box

Description

The object version referenced with the public link.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjVer As ObjVer

See Also

SharedLinkInfo Object | SharedLinkInfo Members


%%PageItemTitle%%

SharedLinkInfos Collection
Members See Also Send comments

Glossary Item Box

Description

The 'SharedLinkInfos' class represents a collection of public link descriptions.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

SharedLinkInfos Members


%%PageItemTitle%%

Add Method
Index
The position at which a new collection member is added. Any invalid position implies appending.
SharedLink
The new member to be added.
SharedLinkInfos Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal SharedLink As SharedLinkInfo _
)

Parameters

Index
The position at which a new collection member is added. Any invalid position implies appending.
SharedLink
The new member to be added.

See Also

SharedLinkInfos Collection | SharedLinkInfos Members


%%PageItemTitle%%

Clone Method
SharedLinkInfos Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SharedLinkInfos

See Also

SharedLinkInfos Collection | SharedLinkInfos Members


%%PageItemTitle%%

Remove Method
Index
The position of the collection member to be removed.
SharedLinkInfos Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The position of the collection member to be removed.

See Also

SharedLinkInfos Collection | SharedLinkInfos Members


%%PageItemTitle%%

Count Property
SharedLinkInfos Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

SharedLinkInfos Collection | SharedLinkInfos Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection. The first element in the collection has the index of 1.
SharedLinkInfos Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As SharedLinkInfo

Parameters

Index
Specifies the item's position in the collection. The first element in the collection has the index of 1.

See Also

SharedLinkInfos Collection | SharedLinkInfos Members


%%PageItemTitle%%

SharedLinkPublicOperations Object
Members See Also Send comments

Glossary Item Box

Description

A group of methods for accessing publicly shared files.

Public Methods

Public Method DownloadSharedFileInBlocks_Begin | Begins the block-by-block download of a shared file.
Public Method DownloadSharedFileInBlocks_Begin_32bit | Begins the block-by-block download of a shared file (using 32-bit arguments).
Public Method DownloadSharedFileInBlocks_ReadBlock | Retrieves a specific block of a shared file from the server.
Public Method DownloadSharedFileInBlocks_ReadBlock_32bit | Retrieves a specific block of a shared file from the server (using 32-bit arguments).
Public Method GetSharedLinkInfo | Gets information about a shared file (a file that has been shared with a public link).
Public Method UploadSharedFileBlock | Uploads a block of the file being co-authored to the server.
Public Method UploadSharedFileBlockBegin | Begins uploading a file being co-authored to the server.
Public Method UploadSharedFileCommit | Commits the upload operation of the specified co-authored file.

Remarks

This interface is related to VaultSharedLinkOperations, which is used for controlling public links (for instance by creating and deleting them). The "SharedLinkPublicOperations" interface (this one), in turn, is used for accessing the publicly shared files wihtout logging in to M-Files. To use the "SharedLinkPublicOperations" interface, a server connection needs to be established by using the ConnectWithoutLogin method. To sum up, only M-Files users can create public links, but they can be accessed by others via the "SharedLinkPublicOperations" interface.

The methods of this interface do not work with cached replica vaults.

See Also

SharedLinkPublicOperations Members


%%PageItemTitle%%

DownloadSharedFileInBlocks_Begin Method
VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
AdditionalData
Optional additional data from the caller. Can be NULL.
SharedLinkPublicOperations Object : DownloadSharedFileInBlocks_Begin Method

Glossary Item Box

Description

Begins the block-by-block download of a shared file.

Syntax

Visual Basic
Public Function DownloadSharedFileInBlocks_Begin( _
   ByRef VaultGUID As GUID, _
   ByVal AccessKey As String, _
   Optional ByVal AdditionalData As NamedValues = 0 _
) As FileDownloadSession

Parameters

VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
AdditionalData
Optional additional data from the caller. Can be NULL.

See Also

SharedLinkPublicOperations Object | SharedLinkPublicOperations Members


%%PageItemTitle%%

DownloadSharedFileInBlocks_Begin_32bit Method
VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
AdditionalData
Optional additional data from the caller. Can be NULL.
SharedLinkPublicOperations Object : DownloadSharedFileInBlocks_Begin_32bit Method

Glossary Item Box

Description

Begins the block-by-block download of a shared file (using 32-bit arguments).

Syntax

Visual Basic
Public Function DownloadSharedFileInBlocks_Begin_32bit( _
   ByRef VaultGUID As GUID, _
   ByVal AccessKey As String, _
   Optional ByVal AdditionalData As NamedValues = 0 _
) As FileDownloadSession

Parameters

VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
AdditionalData
Optional additional data from the caller. Can be NULL.

See Also

SharedLinkPublicOperations Object | SharedLinkPublicOperations Members


%%PageItemTitle%%

DownloadSharedFileInBlocks_ReadBlock Method
VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
DownloadID
Download session identifier.
BlockSize
The number of bytes to read.
Offset
The offset from the beginning of the file.
SharedLinkPublicOperations Object : DownloadSharedFileInBlocks_ReadBlock Method

Glossary Item Box

Description

Retrieves a specific block of a shared file from the server.

Syntax

Visual Basic
Public Function DownloadSharedFileInBlocks_ReadBlock( _
   ByRef VaultGUID As GUID, _
   ByVal AccessKey As String, _
   ByVal DownloadID As Long, _
   ByVal BlockSize As Long, _
   ByVal Offset As Unknown _
) As Byte()

Parameters

VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
DownloadID
Download session identifier.
BlockSize
The number of bytes to read.
Offset
The offset from the beginning of the file.

See Also

SharedLinkPublicOperations Object | SharedLinkPublicOperations Members


%%PageItemTitle%%

DownloadSharedFileInBlocks_ReadBlock_32bit Method
VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
DownloadID
Download session identifier.
BlockSize
The number of bytes to read.
Offset
The offset from the beginning of the file.
SharedLinkPublicOperations Object : DownloadSharedFileInBlocks_ReadBlock_32bit Method

Glossary Item Box

Description

Retrieves a specific block of a shared file from the server (using 32-bit arguments).

Syntax

Visual Basic
Public Function DownloadSharedFileInBlocks_ReadBlock_32bit( _
   ByRef VaultGUID As GUID, _
   ByVal AccessKey As String, _
   ByVal DownloadID As Long, _
   ByVal BlockSize As Long, _
   ByVal Offset As Long _
) As Byte()

Parameters

VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
DownloadID
Download session identifier.
BlockSize
The number of bytes to read.
Offset
The offset from the beginning of the file.

See Also

SharedLinkPublicOperations Object | SharedLinkPublicOperations Members


%%PageItemTitle%%

GetSharedLinkInfo Method
VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
AdditionalData
Optional additional data from the caller. Can be NULL.
SharedLinkPublicOperations Object : GetSharedLinkInfo Method

Glossary Item Box

Description

Gets information about a shared file (a file that has been shared with a public link).

Syntax

Visual Basic
Public Function GetSharedLinkInfo( _
   ByRef VaultGUID As GUID, _
   ByVal AccessKey As String, _
   Optional ByVal AdditionalData As NamedValues = 0 _
) As SharedFileInfo

Parameters

VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
AdditionalData
Optional additional data from the caller. Can be NULL.

Remarks

This method returns information about the shared file, not about the shared link. You can use the GetSharedLink method to get information about the shared link, which requires logging in to M-Files Server.

See Also

SharedLinkPublicOperations Object | SharedLinkPublicOperations Members


%%PageItemTitle%%

UploadSharedFileBlock Method
VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
UploadID
The upload session ID.
TotalSizeInBytes
Total size in bytes.
Offset
Offset from the beginning of the file.
Block
The block to upload.
SharedLinkPublicOperations Object : UploadSharedFileBlock Method

Glossary Item Box

Description

Uploads a block of the file being co-authored to the server.

Syntax

Visual Basic
Public Function UploadSharedFileBlock( _
   ByRef VaultGUID As GUID, _
   ByVal AccessKey As String, _
   ByVal UploadID As Long, _
   ByVal TotalSizeInBytes As Unknown, _
   ByVal Offset As Unknown, _
   ByVal Block() As Byte _
) As Long

Parameters

VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
UploadID
The upload session ID.
TotalSizeInBytes
Total size in bytes.
Offset
Offset from the beginning of the file.
Block
The block to upload.

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

SharedLinkPublicOperations Object | SharedLinkPublicOperations Members


%%PageItemTitle%%

UploadSharedFileBlockBegin Method
VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
AdditionalData
Optional additional data from the caller. Can be NULL.
SharedLinkPublicOperations Object : UploadSharedFileBlockBegin Method

Glossary Item Box

Description

Begins uploading a file being co-authored to the server.

Syntax

Visual Basic
Public Function UploadSharedFileBlockBegin( _
   ByRef VaultGUID As GUID, _
   ByVal AccessKey As String, _
   Optional ByVal AdditionalData As NamedValues = 0 _
) As Long

Parameters

VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
AdditionalData
Optional additional data from the caller. Can be NULL.

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

SharedLinkPublicOperations Object | SharedLinkPublicOperations Members


%%PageItemTitle%%

UploadSharedFileCommit Method
VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
UploadID
The upload session ID.
LogicalSize
The logical size of the file.
SharedLinkPublicOperations Object : UploadSharedFileCommit Method

Glossary Item Box

Description

Commits the upload operation of the specified co-authored file.

Syntax

Visual Basic
Public Sub UploadSharedFileCommit( _
   ByRef VaultGUID As GUID, _
   ByVal AccessKey As String, _
   ByVal UploadID As Long, _
   ByVal LogicalSize As Unknown _
)

Parameters

VaultGUID
The vault identifier.
AccessKey
Specifies the access key of the shared link.
UploadID
The upload session ID.
LogicalSize
The logical size of the file.

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

SharedLinkPublicOperations Object | SharedLinkPublicOperations Members


%%PageItemTitle%%

SignaturePromptInfo Object
Members See Also Send comments

Glossary Item Box

Description

The 'SignaturePromptInfo' class contains fixed prompt details of an electronic signature.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Meaning | Specifies the signature meaning.
Public Property Reason | Specifies the signature reason.

See Also

SignaturePromptInfo Members


%%PageItemTitle%%

Clone Method
SignaturePromptInfo Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SignaturePromptInfo

See Also

SignaturePromptInfo Object | SignaturePromptInfo Members


%%PageItemTitle%%

Meaning Property
SignaturePromptInfo Object : Meaning Property

Glossary Item Box

Description

Specifies the signature meaning.

Property type

Read-write property

Syntax

Visual Basic
Public Property Meaning As String

See Also

SignaturePromptInfo Object | SignaturePromptInfo Members


%%PageItemTitle%%

Reason Property
SignaturePromptInfo Object : Reason Property

Glossary Item Box

Description

Specifies the signature reason.

Property type

Read-write property

Syntax

Visual Basic
Public Property Reason As String

See Also

SignaturePromptInfo Object | SignaturePromptInfo Members


%%PageItemTitle%%

SignaturePromptInfoMetadataBased Object
Members See Also Send comments

Glossary Item Box

Description

The 'SignaturePromptInfoMetadataBased' class contains metadata-based prompt details of an electronic signature.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property IsReferencedBySignatureObject | Specifies whether the prompt info lookup property is linked with a signature object.
Public Property MeaningPropertyID | Specifies the property to be used as a source for the signature meaning.
Public Property PromptInfoLookupPropertyID | Specifies the lookup property via which the prompt info details are found.
Public Property ReasonPropertyID | Specifies the property to be used as a source for the signature reason.

See Also

SignaturePromptInfoMetadataBased Members


%%PageItemTitle%%

Clone Method
SignaturePromptInfoMetadataBased Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SignaturePromptInfoMetadataBased

See Also

SignaturePromptInfoMetadataBased Object | SignaturePromptInfoMetadataBased Members


%%PageItemTitle%%

IsReferencedBySignatureObject Property
SignaturePromptInfoMetadataBased Object : IsReferencedBySignatureObject Property

Glossary Item Box

Description

Specifies whether the prompt info lookup property is linked with a signature object.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsReferencedBySignatureObject As Boolean

See Also

SignaturePromptInfoMetadataBased Object | SignaturePromptInfoMetadataBased Members


%%PageItemTitle%%

MeaningPropertyID Property
SignaturePromptInfoMetadataBased Object : MeaningPropertyID Property

Glossary Item Box

Description

Specifies the property to be used as a source for the signature meaning.

Property type

Read-write property

Syntax

Visual Basic
Public Property MeaningPropertyID As Long

See Also

SignaturePromptInfoMetadataBased Object | SignaturePromptInfoMetadataBased Members


%%PageItemTitle%%

PromptInfoLookupPropertyID Property
SignaturePromptInfoMetadataBased Object : PromptInfoLookupPropertyID Property

Glossary Item Box

Description

Specifies the lookup property via which the prompt info details are found.

Property type

Read-write property

Syntax

Visual Basic
Public Property PromptInfoLookupPropertyID As Long

See Also

SignaturePromptInfoMetadataBased Object | SignaturePromptInfoMetadataBased Members


%%PageItemTitle%%

ReasonPropertyID Property
SignaturePromptInfoMetadataBased Object : ReasonPropertyID Property

Glossary Item Box

Description

Specifies the property to be used as a source for the signature reason.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReasonPropertyID As Long

See Also

SignaturePromptInfoMetadataBased Object | SignaturePromptInfoMetadataBased Members


%%PageItemTitle%%

SignaturePromptInfos Collection
Members See Also Send comments

Glossary Item Box

Description

The 'SignaturePromptInfos' class represents a collection of electronic signature prompt information descriptions.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

SignaturePromptInfos Members


%%PageItemTitle%%

Add Method
Index
The position of the item.
SignaturePromptInfo
The signature prompt info to be added.
SignaturePromptInfos Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal SignaturePromptInfo As SignaturePromptInfo _
)

Parameters

Index
The position of the item.
SignaturePromptInfo
The signature prompt info to be added.

See Also

SignaturePromptInfos Collection | SignaturePromptInfos Members


%%PageItemTitle%%

Clone Method
SignaturePromptInfos Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SignaturePromptInfos

See Also

SignaturePromptInfos Collection | SignaturePromptInfos Members


%%PageItemTitle%%

Remove Method
Index
The position of the item.
SignaturePromptInfos Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The position of the item.

See Also

SignaturePromptInfos Collection | SignaturePromptInfos Members


%%PageItemTitle%%

Count Property
SignaturePromptInfos Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

SignaturePromptInfos Collection | SignaturePromptInfos Members


%%PageItemTitle%%

Item Property
Index
The position of the item in the collection.
SignaturePromptInfos Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As SignaturePromptInfo

Parameters

Index
The position of the item in the collection.

See Also

SignaturePromptInfos Collection | SignaturePromptInfos Members


%%PageItemTitle%%

SignaturePromptInfoSelectable Object
Members See Also Send comments

Glossary Item Box

Description

The 'SignaturePromptInfoSelectable' class contains user-selectable prompt details of an electronic signature.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property PromptInfos Specifies the signature prompt infos.

See Also

SignaturePromptInfoSelectable Members


%%PageItemTitle%%

Clone Method
SignaturePromptInfoSelectable Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SignaturePromptInfoSelectable

See Also

SignaturePromptInfoSelectable Object | SignaturePromptInfoSelectable Members


%%PageItemTitle%%

PromptInfos Property
SignaturePromptInfoSelectable Object : PromptInfos Property

Glossary Item Box

Description

Specifies the signature prompt infos.

Property type

Read-write property

Syntax

Visual Basic
Public Property PromptInfos As SignaturePromptInfos

See Also

SignaturePromptInfoSelectable Object | SignaturePromptInfoSelectable Members


%%PageItemTitle%%

SignatureSettings Object
Members See Also Send comments

Glossary Item Box

Description

The SignatureSettings class represents signature settings for a state transition in a workflow.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AdditionalInfo | Specifies additional information for the signature manifestation (not shown to the user when signing).
Public Property FreeFormTextPropertyID | Specifies the property which is filled when a free-form text is prompted with the signature.
Public Property IsFreeFormTextPrompted | Specifies whether a free-form text is prompted with the signature.
Public Property IsRequired | Specifies whether the signature is required.
Public Property IsSeparateSignatureObject | Specifies whether the signature is created as a separate object.
Public Property ManifestationPropertyID | Specifies the property which is filled when the signature is given.
Public Property PromptInfoType | The prompt info type.
Public Property SignatureIdentifier | Specifies the identifier of the signature object.
Public Property SignaturePromptInfoFixed | Information about a task assignment if PromptInfoType is MFSignaturePromptInfoTypeFixed. Otherwise NULL.
Public Property SignaturePromptInfoMetadataBased | Information about a task assignment if PromptInfoType is MFSignaturePromptInfoTypeMetadataBased. Otherwise NULL.
Public Property SignaturePromptInfoSelectable | Information about a task assignment if PromptInfoType is MFSignaturePromptInfoTypeSelectable. Otherwise NULL.

Remarks

The signature settings dialog as seen in M-Files Admin.

See Also

SignatureSettings Members


%%PageItemTitle%%

Clone Method
SignatureSettings Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SignatureSettings

See Also

SignatureSettings Object | SignatureSettings Members


%%PageItemTitle%%

AdditionalInfo Property
SignatureSettings Object : AdditionalInfo Property

Glossary Item Box

Description

Specifies additional information for the signature manifestation (not shown to the user when signing).

Property type

Read-write property

Syntax

Visual Basic
Public Property AdditionalInfo As String

See Also

SignatureSettings Object | SignatureSettings Members


%%PageItemTitle%%

FreeFormTextPropertyID Property
SignatureSettings Object : FreeFormTextPropertyID Property

Glossary Item Box

Description

Specifies the property which is filled when a free-form text is prompted with the signature.

Property type

Read-write property

Syntax

Visual Basic
Public Property FreeFormTextPropertyID As Long

See Also

SignatureSettings Object | SignatureSettings Members


%%PageItemTitle%%

IsFreeFormTextPrompted Property
SignatureSettings Object : IsFreeFormTextPrompted Property

Glossary Item Box

Description

Specifies whether a free-form text is prompted with the signature.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsFreeFormTextPrompted As Boolean

See Also

SignatureSettings Object | SignatureSettings Members


%%PageItemTitle%%

IsRequired Property
SignatureSettings Object : IsRequired Property

Glossary Item Box

Description

Specifies whether the signature is required.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsRequired As Boolean

See Also

SignatureSettings Object | SignatureSettings Members


%%PageItemTitle%%

IsSeparateSignatureObject Property
SignatureSettings Object : IsSeparateSignatureObject Property

Glossary Item Box

Description

Specifies whether the signature is created as a separate object.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsSeparateSignatureObject As Boolean

See Also

SignatureSettings Object | SignatureSettings Members


%%PageItemTitle%%

ManifestationPropertyID Property
SignatureSettings Object : ManifestationPropertyID Property

Glossary Item Box

Description

Specifies the property which is filled when the signature is given.

Property type

Read-write property

Syntax

Visual Basic
Public Property ManifestationPropertyID As Long

See Also

SignatureSettings Object | SignatureSettings Members


%%PageItemTitle%%

PromptInfoType Property
SignatureSettings Object : PromptInfoType Property

Glossary Item Box

Description

The prompt info type.

Property type

Read-only property

Syntax

Visual Basic
Public Property PromptInfoType As MFSignaturePromptInfoType

See Also

SignatureSettings Object | SignatureSettings Members


%%PageItemTitle%%

SignatureIdentifier Property
SignatureSettings Object : SignatureIdentifier Property

Glossary Item Box

Description

Specifies the identifier of the signature object.

Property type

Read-write property

Syntax

Visual Basic
Public Property SignatureIdentifier As String

See Also

SignatureSettings Object | SignatureSettings Members


%%PageItemTitle%%

SignaturePromptInfoFixed Property
SignatureSettings Object : SignaturePromptInfoFixed Property

Glossary Item Box

Description

Information about a task assignment if PromptInfoType is MFSignaturePromptInfoTypeFixed. Otherwise NULL.

Property type

Read-write property

Syntax

Visual Basic
Public Property SignaturePromptInfoFixed As SignaturePromptInfo

See Also

SignatureSettings Object | SignatureSettings Members


%%PageItemTitle%%

SignaturePromptInfoMetadataBased Property
SignatureSettings Object : SignaturePromptInfoMetadataBased Property

Glossary Item Box

Description

Information about a task assignment if PromptInfoType is MFSignaturePromptInfoTypeMetadataBased. Otherwise NULL.

Property type

Read-write property

Syntax

Visual Basic
Public Property SignaturePromptInfoMetadataBased As SignaturePromptInfoMetadataBased

See Also

SignatureSettings Object | SignatureSettings Members


%%PageItemTitle%%

SignaturePromptInfoSelectable Property
SignatureSettings Object : SignaturePromptInfoSelectable Property

Glossary Item Box

Description

Information about a task assignment if PromptInfoType is MFSignaturePromptInfoTypeSelectable. Otherwise NULL.

Property type

Read-write property

Syntax

Visual Basic
Public Property SignaturePromptInfoSelectable As SignaturePromptInfoSelectable

See Also

SignatureSettings Object | SignatureSettings Members


%%PageItemTitle%%

SourceObjectFile Object
Members See Also Send comments

Glossary Item Box

Description

The SourceObjectFile class encapsulates information that is needed when adding a new file to an object.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Extension | The extension of the file when added to M-Files.
Public Property SourceFilePath | Absolute path to the source file.
Public Property Title | The title of the file when added to M-Files.

See Also

SourceObjectFile Members | ObjectCreationInfo Object


%%PageItemTitle%%

Clone Method
SourceObjectFile Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SourceObjectFile

See Also

SourceObjectFile Object | SourceObjectFile Members


%%PageItemTitle%%

Extension Property
SourceObjectFile Object : Extension Property

Glossary Item Box

Description

The extension of the file when added to M-Files.

Property type

Read-write property

Syntax

Visual Basic
Public Property Extension As String

See Also

SourceObjectFile Object | SourceObjectFile Members


%%PageItemTitle%%

SourceFilePath Property
SourceObjectFile Object : SourceFilePath Property

Glossary Item Box

Description

Absolute path to the source file.

Property type

Read-write property

Syntax

Visual Basic
Public Property SourceFilePath As String

See Also

SourceObjectFile Object | SourceObjectFile Members


%%PageItemTitle%%

Title Property
SourceObjectFile Object : Title Property

Glossary Item Box

Description

The title of the file when added to M-Files.

Property type

Read-write property

Syntax

Visual Basic
Public Property Title As String

Remarks

The file title is the file name without the extension.

See Also

SourceObjectFile Object | SourceObjectFile Members


%%PageItemTitle%%

SourceObjectFiles Collection
Members See Also Send comments

Glossary Item Box

Description

SourceObjectFiles is a collection of SourceObjectFile objects.

Public Methods

Public Method Add | Adds a new file to this collection.
Public Method AddEmptyFile | Adds a new empty source file to this collection.
Public Method AddFile | Adds a new source file to this collection.
Public Method Remove | Removes a file from this collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

SourceObjectFiles Members | SourceObjectFile Object


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
SourceObjectFile
The new member to add.
SourceObjectFiles Collection : Add Method

Glossary Item Box

Description

Adds a new file to this collection.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal SourceObjectFile As SourceObjectFile _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
SourceObjectFile
The new member to add.

See Also

SourceObjectFiles Collection | SourceObjectFiles Members


%%PageItemTitle%%

AddEmptyFile Method
Title
The title of the file to append.
Extension
The extension of the file to append.
SourceObjectFiles Collection : AddEmptyFile Method

Glossary Item Box

Description

Adds a new empty source file to this collection.

Syntax

Visual Basic
Public Function AddEmptyFile( _
   ByVal Title As String, _
   ByVal Extension As String _
) As SourceObjectFile

Parameters

Title
The title of the file to append.
Extension
The extension of the file to append.

See Also

SourceObjectFiles Collection | SourceObjectFiles Members


%%PageItemTitle%%

AddFile Method
Title
The title of the file to append.
Extension
The extension of the file to append.
SourcePath
The source path of the file to append.
SourceObjectFiles Collection : AddFile Method

Glossary Item Box

Description

Adds a new source file to this collection.

Syntax

Visual Basic
Public Function AddFile( _
   ByVal Title As String, _
   ByVal Extension As String, _
   ByVal SourcePath As String _
) As SourceObjectFile

Parameters

Title
The title of the file to append.
Extension
The extension of the file to append.
SourcePath
The source path of the file to append.

See Also

SourceObjectFiles Collection | SourceObjectFiles Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
SourceObjectFiles Collection : Remove Method

Glossary Item Box

Description

Removes a file from this collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

SourceObjectFiles Collection | SourceObjectFiles Members


%%PageItemTitle%%

Count Property
SourceObjectFiles Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

SourceObjectFiles Collection | SourceObjectFiles Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
SourceObjectFiles Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As SourceObjectFile

Parameters

Index
Specifies the item's position in the collection.

See Also

SourceObjectFiles Collection | SourceObjectFiles Members


%%PageItemTitle%%

SQLDatabase Object
Members See Also Send comments

Glossary Item Box

Description

The SQLDatabase class represents the SQL Database.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AdminUser | Specifies the username and password for accessing the database engine for administrative purposes. Specify NULL for this property if the database engine is Firebird.
Public Property BasicUser | Specifies the username and password for accessing the database engine in basic user operations. If this property is NULL when creating or attaching a vault, M-Files Server creates a new account with a default username and a random password. If this property is NULL when calling the UpdateVaultProperties method, the previously set username and password remain unchanged. Specify NULL for this property if the database engine is Firebird.
Public Property Engine | Database engine identification.
Public Property Name | The catalog i.e. the database name where the vault's data is residing. Allows the database name to differ from the vault display name. This is not specified in the Firebird case.
Public Property Server | The data source i.e. the database server name where the vault's database is residing. This is specified for data service DB engines only. It is empty or NULL for embedded databases such as Firebird Embedded.

Remarks

Microsoft SQL Server properties in M-Files Admin.

See Also

SQLDatabase Members


%%PageItemTitle%%

Clone Method
SQLDatabase Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As SQLDatabase

See Also

SQLDatabase Object | SQLDatabase Members


%%PageItemTitle%%

AdminUser Property
SQLDatabase Object : AdminUser Property

Glossary Item Box

Description

Specifies the username and password for accessing the database engine for administrative purposes. Specify NULL for this property if the database engine is Firebird.

Property type

Read-write property

Syntax

Visual Basic
Public Property AdminUser As Impersonation

See Also

SQLDatabase Object | SQLDatabase Members


%%PageItemTitle%%

BasicUser Property
SQLDatabase Object : BasicUser Property

Glossary Item Box

Description

Specifies the username and password for accessing the database engine in basic user operations. If this property is NULL when creating or attaching a vault, M-Files Server creates a new account with a default username and a random password. If this property is NULL when calling the UpdateVaultProperties method, the previously set username and password remain unchanged. Specify NULL for this property if the database engine is Firebird.

Property type

Read-write property

Syntax

Visual Basic
Public Property BasicUser As Impersonation

See Also

SQLDatabase Object | SQLDatabase Members


%%PageItemTitle%%

Engine Property
SQLDatabase Object : Engine Property

Glossary Item Box

Description

Database engine identification.

Property type

Read-write property

Syntax

Visual Basic
Public Property Engine As MFDBEngine

See Also

SQLDatabase Object | SQLDatabase Members


%%PageItemTitle%%

Name Property
SQLDatabase Object : Name Property

Glossary Item Box

Description

The catalog i.e. the database name where the vault's data is residing. Allows the database name to differ from the vault display name. This is not specified in the Firebird case.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

SQLDatabase Object | SQLDatabase Members


%%PageItemTitle%%

Server Property
SQLDatabase Object : Server Property

Glossary Item Box

Description

The data source i.e. the database server name where the vault's database is residing. This is specified for data service DB engines only. It is empty or NULL for embedded databases such as Firebird Embedded.

Property type

Read-write property

Syntax

Visual Basic
Public Property Server As String

See Also

SQLDatabase Object | SQLDatabase Members


%%PageItemTitle%%

State Object
Members See Also Send comments

Glossary Item Box

Description

The State class represents a workflow state.

Public Methods

Public Method GetAsLookup | Gets this state as a lookup value.
Public Method GetAsTypedValue | Gets this state as a single-select lookup based typed value.

Public Properties

Public Property ID | The ID of the workflow state.
Public Property Name | The name of the workflow state.
Public Property Selectable | Specifies whether the state is selectable.
Public Property SelectableFlagAffectedByPseudoUsers | Specifies whether the selectable flag is affected by pseudo users. If true, the selectable flag can be trusted only if the available state transitions are requested for a specific objver by using the GetWorkflowStatesEx method.

Remarks

Use the VaultWorkflowOperations interface to retrieve states.

Workflow states as seen in M-Files Desktop.

See Also

State Members


%%PageItemTitle%%

GetAsLookup Method
State Object : GetAsLookup Method

Glossary Item Box

Description

Gets this state as a lookup value.

Syntax

Visual Basic
Public Function GetAsLookup() As Lookup

See Also

State Object | State Members


%%PageItemTitle%%

GetAsTypedValue Method
State Object : GetAsTypedValue Method

Glossary Item Box

Description

Gets this state as a single-select lookup based typed value.

Syntax

Visual Basic
Public Function GetAsTypedValue() As TypedValue

See Also

State Object | State Members


%%PageItemTitle%%

ID Property
State Object : ID Property

Glossary Item Box

Description

The ID of the workflow state.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID As Long

See Also

State Object | State Members


%%PageItemTitle%%

Name Property
State Object : Name Property

Glossary Item Box

Description

The name of the workflow state.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

State Object | State Members


%%PageItemTitle%%

Selectable Property
State Object : Selectable Property

Glossary Item Box

Description

Specifies whether the state is selectable.

Property type

Read-write property

Syntax

Visual Basic
Public Property Selectable As Boolean

See Also

State Object | State Members


%%PageItemTitle%%

SelectableFlagAffectedByPseudoUsers Property
State Object : SelectableFlagAffectedByPseudoUsers Property

Glossary Item Box

Description

Specifies whether the selectable flag is affected by pseudo users. If true, the selectable flag can be trusted only if the available state transitions are requested for a specific objver by using the GetWorkflowStatesEx method.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectableFlagAffectedByPseudoUsers As Boolean

See Also

State Object | State Members


%%PageItemTitle%%

StateAdmin Object
Members See Also Send comments

Glossary Item Box

Description

The StateAdmin class represents a workflow state (for administrative operations).

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ActionAssignToUser | Specifies whether the 'Assign to user' action is enabled.
Public Property ActionAssignToUserDefinition | The definition of the 'Assign to user' action.
Public Property ActionConvertToPDF | Specifies whether the 'Convert to PDF' action is enabled.
Public Property ActionConvertToPDFDefinition | The definition of the 'Convert to PDF' action.
Public Property ActionCreateSeparateAssignment | Specifies whether the 'Create separate assignment' action is enabled.
Public Property ActionDefinitions | The definition of the actions (currently 'Create separate assignment' actions only).
Public Property ActionDelete | Specifies whether the 'Delete' action is enabled.
Public Property ActionMarkForArchiving | Specifies whether the 'Mark for archiving' action is enabled.
Public Property ActionRunVBScript | Specifies whether the 'Run VBScript' action is enabled.
Public Property ActionRunVBScriptDefinition | The definition of the 'Run VBScript' action.
Public Property ActionSendNotification | Specifies whether the 'Send notification' action is enabled.
Public Property ActionSendNotificationDefinition | The definition of the 'Send notification' action.
Public Property ActionSetPermissions | Specifies whether the 'Set permissions' action is enabled.
Public Property ActionSetPermissionsDetailedDefinition | The definition of the 'Set permissions' action.
Public Property ActionSetProperties | Specifies whether the 'Set properties' action is enabled.
Public Property ActionSetPropertiesDefinition | The definition of the 'Set properties' action.
Public Property CheckInOutPermissions | Specifies whether the "move into this state" and "move out of this state" permissions for this state should be checked when performing a state transition that involves this state.
Public Property Description | State description.
Public Property ID | State ID.
Public Property InOutPermissions | The "move into this state" and "move out of this state" permissions for this state.
Public Property Name | State name.
Public Property Postconditions | The conditions that an object must fulfill in order to be moved out of this state.
Public Property Preconditions | The conditions that an object must fulfill in order to be moved into this state.
Public Property SemanticAliases | The semantic aliases of this state.
Public Property TransitionsRequireEditAccessToObject | Specifies whether transitions involving this state require edit access to the object.

Remarks

Workflow state settings in M-Files Admin.

See Also

StateAdmin Members


%%PageItemTitle%%

Clone Method
StateAdmin Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As StateAdmin

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionAssignToUser Property
StateAdmin Object : ActionAssignToUser Property

Glossary Item Box

Description

Specifies whether the 'Assign to user' action is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionAssignToUser As Boolean

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionAssignToUserDefinition Property
StateAdmin Object : ActionAssignToUserDefinition Property

Glossary Item Box

Description

The definition of the 'Assign to user' action.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionAssignToUserDefinition As ActionCreateAssignment

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionConvertToPDF Property
StateAdmin Object : ActionConvertToPDF Property

Glossary Item Box

Description

Specifies whether the 'Convert to PDF' action is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionConvertToPDF As Boolean

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionConvertToPDFDefinition Property
StateAdmin Object : ActionConvertToPDFDefinition Property

Glossary Item Box

Description

The definition of the 'Convert to PDF' action.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionConvertToPDFDefinition As ActionConvertToPDF

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionCreateSeparateAssignment Property
StateAdmin Object : ActionCreateSeparateAssignment Property

Glossary Item Box

Description

Specifies whether the 'Create separate assignment' action is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionCreateSeparateAssignment As Boolean

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionDefinitions Property
StateAdmin Object : ActionDefinitions Property

Glossary Item Box

Description

The definition of the actions (currently 'Create separate assignment' actions only).

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionDefinitions As ActionDefinitions

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionDelete Property
StateAdmin Object : ActionDelete Property

Glossary Item Box

Description

Specifies whether the 'Delete' action is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionDelete As Boolean

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionMarkForArchiving Property
StateAdmin Object : ActionMarkForArchiving Property

Glossary Item Box

Description

Specifies whether the 'Mark for archiving' action is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionMarkForArchiving As Boolean

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionRunVBScript Property
StateAdmin Object : ActionRunVBScript Property

Glossary Item Box

Description

Specifies whether the 'Run VBScript' action is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionRunVBScript As Boolean

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionRunVBScriptDefinition Property
StateAdmin Object : ActionRunVBScriptDefinition Property

Glossary Item Box

Description

The definition of the 'Run VBScript' action.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionRunVBScriptDefinition As String

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionSendNotification Property
StateAdmin Object : ActionSendNotification Property

Glossary Item Box

Description

Specifies whether the 'Send notification' action is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionSendNotification As Boolean

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionSendNotificationDefinition Property
StateAdmin Object : ActionSendNotificationDefinition Property

Glossary Item Box

Description

The definition of the 'Send notification' action.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionSendNotificationDefinition As ActionSendNotification

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionSetPermissions Property
StateAdmin Object : ActionSetPermissions Property

Glossary Item Box

Description

Specifies whether the 'Set permissions' action is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionSetPermissions As Boolean

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionSetPermissionsDetailedDefinition Property
StateAdmin Object : ActionSetPermissionsDetailedDefinition Property

Glossary Item Box

Description

The definition of the 'Set permissions' action.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionSetPermissionsDetailedDefinition As ActionSetPermissions

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionSetProperties Property
StateAdmin Object : ActionSetProperties Property

Glossary Item Box

Description

Specifies whether the 'Set properties' action is enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionSetProperties As Boolean

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ActionSetPropertiesDefinition Property
StateAdmin Object : ActionSetPropertiesDefinition Property

Glossary Item Box

Description

The definition of the 'Set properties' action.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionSetPropertiesDefinition As ActionSetProperties

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

CheckInOutPermissions Property
StateAdmin Object : CheckInOutPermissions Property

Glossary Item Box

Description

Specifies whether the "move into this state" and "move out of this state" permissions for this state should be checked when performing a state transition that involves this state.

Property type

Read-write property

Syntax

Visual Basic
Public Property CheckInOutPermissions As Boolean

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

Description Property
StateAdmin Object : Description Property

Glossary Item Box

Description

State description.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description As String

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

ID Property
StateAdmin Object : ID Property

Glossary Item Box

Description

State ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

InOutPermissions Property
StateAdmin Object : InOutPermissions Property

Glossary Item Box

Description

The "move into this state" and "move out of this state" permissions for this state.

Property type

Read-write property

Syntax

Visual Basic
Public Property InOutPermissions As AccessControlList

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

Name Property
StateAdmin Object : Name Property

Glossary Item Box

Description

State name.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

Postconditions Property
StateAdmin Object : Postconditions Property

Glossary Item Box

Description

The conditions that an object must fulfill in order to be moved out of this state.

Property type

Read-write property

Syntax

Visual Basic
Public Property Postconditions As StateConditions

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

Preconditions Property
StateAdmin Object : Preconditions Property

Glossary Item Box

Description

The conditions that an object must fulfill in order to be moved into this state.

Property type

Read-write property

Syntax

Visual Basic
Public Property Preconditions As StateConditions

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

SemanticAliases Property
StateAdmin Object : SemanticAliases Property

Glossary Item Box

Description

The semantic aliases of this state.

Property type

Read-write property

Syntax

Visual Basic
Public Property SemanticAliases As SemanticAliases

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

TransitionsRequireEditAccessToObject Property
StateAdmin Object : TransitionsRequireEditAccessToObject Property

Glossary Item Box

Description

Specifies whether transitions involving this state require edit access to the object.

Property type

Read-write property

Syntax

Visual Basic
Public Property TransitionsRequireEditAccessToObject As Boolean

See Also

StateAdmin Object | StateAdmin Members


%%PageItemTitle%%

StateConditions Collection
Members See Also Send comments

Glossary Item Box

Description

The StateConditions class represents the conditions of a workflow state.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property PropertyConditions | Specifies whether property conditions are enabled.
Public Property PropertyConditionsDefinition | The property conditions.
Public Property VBScript | Specifies whether VBScript code is used.
Public Property VBScriptDefinition | The VBScript code.

See Also

StateConditions Members


%%PageItemTitle%%

Clone Method
StateConditions Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As StateConditions

See Also

StateConditions Collection | StateConditions Members


%%PageItemTitle%%

PropertyConditions Property
StateConditions Collection : PropertyConditions Property

Glossary Item Box

Description

Specifies whether property conditions are enabled.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyConditions As Boolean

See Also

StateConditions Collection | StateConditions Members


%%PageItemTitle%%

PropertyConditionsDefinition Property
StateConditions Collection : PropertyConditionsDefinition Property

Glossary Item Box

Description

The property conditions.

Property type

Read-write property

Syntax

Visual Basic
Public Property PropertyConditionsDefinition As SearchConditions

See Also

StateConditions Collection | StateConditions Members


%%PageItemTitle%%

VBScript Property
StateConditions Collection : VBScript Property

Glossary Item Box

Description

Specifies whether VBScript code is used.

Property type

Read-write property

Syntax

Visual Basic
Public Property VBScript As Boolean

See Also

StateConditions Collection | StateConditions Members


%%PageItemTitle%%

VBScriptDefinition Property
StateConditions Collection : VBScriptDefinition Property

Glossary Item Box

Description

The VBScript code.

Property type

Read-write property

Syntax

Visual Basic
Public Property VBScriptDefinition As String

See Also

StateConditions Collection | StateConditions Members


%%PageItemTitle%%

States Collection
Members See Also Send comments

Glossary Item Box

Description

States is a collection of State objects.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

States Members | State Object


%%PageItemTitle%%

Count Property
States Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

States Collection | States Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
States Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As State

Parameters

Index
Specifies the item's position in the collection.

See Also

States Collection | States Members


%%PageItemTitle%%

StatesAdmin Collection
Members See Also Send comments

Glossary Item Box

Description

StatesAdmin is a collection of StateAdmin objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

StatesAdmin Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
StateAdmin
The new member to add.
StatesAdmin Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal StateAdmin As StateAdmin _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
StateAdmin
The new member to add.

See Also

StatesAdmin Collection | StatesAdmin Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
StatesAdmin Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

StatesAdmin Collection | StatesAdmin Members


%%PageItemTitle%%

Count Property
StatesAdmin Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

StatesAdmin Collection | StatesAdmin Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
StatesAdmin Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As StateAdmin

Parameters

Index
Specifies the item's position in the collection.

See Also

StatesAdmin Collection | StatesAdmin Members


%%PageItemTitle%%

StateTransition Object
Members See Also Send comments

Glossary Item Box

Description

The StateTransition class represents a state transition in a workflow.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AccessControlList | Transition permissions.
Public Property Description | The description of the state transition.
Public Property EvaluationOrderNumber | The evaluation order number that controls the order in which the triggers of different state transitions are evaluated.
Public Property FromState | The source state.
Public Property ID | The ID of the state transition.
Public Property Name | The name of the state transition.
Public Property SemanticAliases | The semantic aliases of this state transition.
Public Property SignatureSettings | Specifies the state transition signature settings.
Public Property ToState | The target state.
Public Property TriggerAllowedByVBScript | The VBScript code that is executed if the automatic state transition mode is MFASTModeAllowedByScript.
Public Property TriggerCriteria | The conditions that are evaluated if the automatic state transition mode is MFASTModeCriteriaFulfilled.
Public Property TriggerInDays | The number of days before the automatic state transition is triggered. Effective if the automatic state transition mode is 'MFASTModeRelativeTime'.
Public Property TriggerMode | The selected mode for automatic state transition.

See Also

StateTransition Members


%%PageItemTitle%%

Clone Method
StateTransition Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As StateTransition

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

AccessControlList Property
StateTransition Object : AccessControlList Property

Glossary Item Box

Description

Transition permissions.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessControlList As AccessControlList

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

Description Property
StateTransition Object : Description Property

Glossary Item Box

Description

The description of the state transition.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description As String

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

EvaluationOrderNumber Property
StateTransition Object : EvaluationOrderNumber Property

Glossary Item Box

Description

The evaluation order number that controls the order in which the triggers of different state transitions are evaluated.

Property type

Read-write property

Syntax

Visual Basic
Public Property EvaluationOrderNumber As Long

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

FromState Property
StateTransition Object : FromState Property

Glossary Item Box

Description

The source state.

Property type

Read-write property

Syntax

Visual Basic
Public Property FromState As Long

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

ID Property
StateTransition Object : ID Property

Glossary Item Box

Description

The ID of the state transition.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

Name Property
StateTransition Object : Name Property

Glossary Item Box

Description

The name of the state transition.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

SemanticAliases Property
StateTransition Object : SemanticAliases Property

Glossary Item Box

Description

The semantic aliases of this state transition.

Property type

Read-write property

Syntax

Visual Basic
Public Property SemanticAliases As SemanticAliases

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

SignatureSettings Property
StateTransition Object : SignatureSettings Property

Glossary Item Box

Description

Specifies the state transition signature settings.

Property type

Read-write property

Syntax

Visual Basic
Public Property SignatureSettings As SignatureSettings

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

ToState Property
StateTransition Object : ToState Property

Glossary Item Box

Description

The target state.

Property type

Read-write property

Syntax

Visual Basic
Public Property ToState As Long

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

TriggerAllowedByVBScript Property
StateTransition Object : TriggerAllowedByVBScript Property

Glossary Item Box

Description

The VBScript code that is executed if the automatic state transition mode is MFASTModeAllowedByScript.

Property type

Read-write property

Syntax

Visual Basic
Public Property TriggerAllowedByVBScript As String

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

TriggerCriteria Property
StateTransition Object : TriggerCriteria Property

Glossary Item Box

Description

The conditions that are evaluated if the automatic state transition mode is MFASTModeCriteriaFulfilled.

Property type

Read-write property

Syntax

Visual Basic
Public Property TriggerCriteria As SearchConditions

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

TriggerInDays Property
StateTransition Object : TriggerInDays Property

Glossary Item Box

Description

The number of days before the automatic state transition is triggered. Effective if the automatic state transition mode is 'MFASTModeRelativeTime'.

Property type

Read-write property

Syntax

Visual Basic
Public Property TriggerInDays As Long

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

TriggerMode Property
StateTransition Object : TriggerMode Property

Glossary Item Box

Description

The selected mode for automatic state transition.

Property type

Read-write property

Syntax

Visual Basic
Public Property TriggerMode As MFAutoStateTransitionMode

See Also

StateTransition Object | StateTransition Members


%%PageItemTitle%%

StateTransitionForClient Object
Members See Also Send comments

Glossary Item Box

Description

The 'StateTransitionForClient' class represents a state transition in a workflow.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetAsLookup | Gets this state transition as a lookup value.
Public Method GetAsTypedValue | Gets this state transition as a single-select lookup based typed value.

Public Properties

Public Property FromState | The source state.
Public Property ID | The ID of the state transition.
Public Property Name | The name of the state transition.
Public Property Selectable | Specifies whether the state transition is selectable.
Public Property SelectableFlagAffectedByPseudoUsers | Specifies whether the selectable flag is affected by pseudo-users. If true, the selectable flag can be trusted only if the available state transitions are requested for a specific 'ObjVer' by using the 'GetWorkflowStatesEx' method.
Public Property ToState | The target state.

See Also

StateTransitionForClient Members


%%PageItemTitle%%

Clone Method
StateTransitionForClient Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As StateTransitionForClient

See Also

StateTransitionForClient Object | StateTransitionForClient Members


%%PageItemTitle%%

GetAsLookup Method
StateTransitionForClient Object : GetAsLookup Method

Glossary Item Box

Description

Gets this state transition as a lookup value.

Syntax

Visual Basic
Public Function GetAsLookup() As Lookup

See Also

StateTransitionForClient Object | StateTransitionForClient Members


%%PageItemTitle%%

GetAsTypedValue Method
StateTransitionForClient Object : GetAsTypedValue Method

Glossary Item Box

Description

Gets this state transition as a single-select lookup based typed value.

Syntax

Visual Basic
Public Function GetAsTypedValue() As TypedValue

See Also

StateTransitionForClient Object | StateTransitionForClient Members


%%PageItemTitle%%

FromState Property
StateTransitionForClient Object : FromState Property

Glossary Item Box

Description

The source state.

Property type

Read-write property

Syntax

Visual Basic
Public Property FromState As Long

See Also

StateTransitionForClient Object | StateTransitionForClient Members


%%PageItemTitle%%

ID Property
StateTransitionForClient Object : ID Property

Glossary Item Box

Description

The ID of the state transition.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID As Long

See Also

StateTransitionForClient Object | StateTransitionForClient Members


%%PageItemTitle%%

Name Property
StateTransitionForClient Object : Name Property

Glossary Item Box

Description

The name of the state transition.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

StateTransitionForClient Object | StateTransitionForClient Members


%%PageItemTitle%%

Selectable Property
StateTransitionForClient Object : Selectable Property

Glossary Item Box

Description

Specifies whether the state transition is selectable.

Property type

Read-write property

Syntax

Visual Basic
Public Property Selectable As Boolean

See Also

StateTransitionForClient Object | StateTransitionForClient Members


%%PageItemTitle%%

SelectableFlagAffectedByPseudoUsers Property
StateTransitionForClient Object : SelectableFlagAffectedByPseudoUsers Property

Glossary Item Box

Description

Specifies whether the selectable flag is affected by pseudo-users. If true, the selectable flag can be trusted only if the available state transitions are requested for a specific 'ObjVer' by using the 'GetWorkflowStatesEx' method.

Property type

Read-write property

Syntax

Visual Basic
Public Property SelectableFlagAffectedByPseudoUsers As Boolean

See Also

StateTransitionForClient Object | StateTransitionForClient Members


%%PageItemTitle%%

ToState Property
StateTransitionForClient Object : ToState Property

Glossary Item Box

Description

The target state.

Property type

Read-write property

Syntax

Visual Basic
Public Property ToState As Long

See Also

StateTransitionForClient Object | StateTransitionForClient Members


%%PageItemTitle%%

StateTransitions Collection
Members See Also Send comments

Glossary Item Box

Description

StateTransitions is a collection of StateTransition objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

StateTransitions Members


%%PageItemTitle%%

Add Method
Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

StateTransition
The new member to add.
StateTransitions Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal StateTransition As StateTransition _
)

Parameters

Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

StateTransition
The new member to add.

See Also

StateTransitions Collection | StateTransitions Members


%%PageItemTitle%%

Remove Method
Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

StateTransitions Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

See Also

StateTransitions Collection | StateTransitions Members


%%PageItemTitle%%

Count Property
StateTransitions Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

StateTransitions Collection | StateTransitions Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

StateTransitions Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As StateTransition

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

StateTransitions Collection | StateTransitions Members


%%PageItemTitle%%

StateTransitionsForClient Collection
Members See Also Send comments

Glossary Item Box

Description

The 'StateTransitionsForClient' class is a collection of 'StateTransitionForClient' objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

StateTransitionsForClient Members


%%PageItemTitle%%

Add Method
Index
The position of the item.
StateTransitionForClient
The state transition to be added.
StateTransitionsForClient Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal StateTransitionForClient As StateTransitionForClient _
)

Parameters

Index
The position of the item.
StateTransitionForClient
The state transition to be added.

See Also

StateTransitionsForClient Collection | StateTransitionsForClient Members


%%PageItemTitle%%

Clone Method
StateTransitionsForClient Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As StateTransitionsForClient

See Also

StateTransitionsForClient Collection | StateTransitionsForClient Members


%%PageItemTitle%%

Remove Method
Index
The position of the item.
StateTransitionsForClient Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The position of the item.

See Also

StateTransitionsForClient Collection | StateTransitionsForClient Members


%%PageItemTitle%%

Count Property
StateTransitionsForClient Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

StateTransitionsForClient Collection | StateTransitionsForClient Members


%%PageItemTitle%%

Item Property
Index
The position of the item.
StateTransitionsForClient Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As StateTransitionForClient

Parameters

Index
The position of the item.

See Also

StateTransitionsForClient Collection | StateTransitionsForClient Members


%%PageItemTitle%%

StringData Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents structured JSON or XML data as a string.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AsString | The string representation.
Public Property StringDataType | The type of the string representation.

See Also

StringData Members


%%PageItemTitle%%

Clone Method
StringData Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As StringData

See Also

StringData Object | StringData Members


%%PageItemTitle%%

AsString Property
StringData Object : AsString Property

Glossary Item Box

Description

The string representation.

Property type

Read-write property

Syntax

Visual Basic
Public Property AsString As String

See Also

StringData Object | StringData Members


%%PageItemTitle%%

StringDataType Property
StringData Object : StringDataType Property

Glossary Item Box

Description

The type of the string representation.

Property type

Read-only property

Syntax

Visual Basic
Public Property StringDataType As MFStringDataType

See Also

StringData Object | StringData Members


%%PageItemTitle%%

Strings Collection
Members See Also Send comments

Glossary Item Box

Description

The Strings class represents a collection of strings.

Public Methods

Public Method Add | Adds a new item to the collection. If the index is not valid, the item is added at the end.
Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method Join | Concatenates the members of the collection, using the specified separator between each member.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

Strings Members


%%PageItemTitle%%

Add Method
Index
The position of the item.
Item
The item to be added.
Strings Collection : Add Method

Glossary Item Box

Description

Adds a new item to the collection. If the index is not valid, the item is added at the end.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal Item As String _
)

Parameters

Index
The position of the item.
Item
The item to be added.

See Also

Strings Collection | Strings Members


%%PageItemTitle%%

Clone Method
Strings Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As Strings

See Also

Strings Collection | Strings Members


%%PageItemTitle%%

CloneFrom Method
Strings
Input.
Strings Collection : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal Strings As Strings _
)

Parameters

Strings
Input.

See Also

Strings Collection | Strings Members


%%PageItemTitle%%

Join Method
Separator
Separator for the concatenated strings.
Strings Collection : Join Method

Glossary Item Box

Description

Concatenates the members of the collection, using the specified separator between each member.

Syntax

Visual Basic
Public Function Join( _
   ByVal Separator As String _
) As String

Parameters

Separator
Separator for the concatenated strings.

See Also

Strings Collection | Strings Members


%%PageItemTitle%%

Remove Method
Index
The position of the item.
Strings Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
The position of the item.

See Also

Strings Collection | Strings Members


%%PageItemTitle%%

Count Property
Strings Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

Strings Collection | Strings Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

Strings Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As String

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

Strings Collection | Strings Members


%%PageItemTitle%%

StructureAlias Object
Members See Also Send comments

Glossary Item Box

Description

The StructureAlias class.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Alias | The name of a structure item alias.
Public Property ID | The ID of a structure item alias.

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

StructureAlias Members


%%PageItemTitle%%

Clone Method
StructureAlias Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As StructureAlias

See Also

StructureAlias Object | StructureAlias Members


%%PageItemTitle%%

Alias Property
StructureAlias Object : Alias Property

Glossary Item Box

Description

The name of a structure item alias.

Property type

Read-only property

Syntax

Visual Basic
Public Property Alias As String

See Also

StructureAlias Object | StructureAlias Members


%%PageItemTitle%%

ID Property
StructureAlias Object : ID Property

Glossary Item Box

Description

The ID of a structure item alias.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID As Long

See Also

StructureAlias Object | StructureAlias Members


%%PageItemTitle%%

StructureAliases Collection
Members See Also Send comments

Glossary Item Box

Description

The StructureAliases class.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

StructureAliases Members


%%PageItemTitle%%

Clone Method
StructureAliases Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As StructureAliases

See Also

StructureAliases Collection | StructureAliases Members


%%PageItemTitle%%

Count Property
StructureAliases Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

StructureAliases Collection | StructureAliases Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

StructureAliases Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As StructureAlias

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

StructureAliases Collection | StructureAliases Members


%%PageItemTitle%%

TaskAssignmentClassInfo Object
Members See Also Send comments

Glossary Item Box

Description

The 'TaskAssignmentClassInfo' class contains assignment-specific details of a task assignment object class.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AnyAssigneeCompletes | True if any assignee can complete the assignment. This is valid for task type assignments only.
Public Property SignatureForCompletion | Information about signature settings for assignment completion.

Remarks

The "Task assignment" options in M-Files Admin.

See Also

TaskAssignmentClassInfo Members


%%PageItemTitle%%

Clone Method
TaskAssignmentClassInfo Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As TaskAssignmentClassInfo

See Also

TaskAssignmentClassInfo Object | TaskAssignmentClassInfo Members


%%PageItemTitle%%

AnyAssigneeCompletes Property
TaskAssignmentClassInfo Object : AnyAssigneeCompletes Property

Glossary Item Box

Description

True if any assignee can complete the assignment. This is valid for task type assignments only.

Property type

Read-write property

Syntax

Visual Basic
Public Property AnyAssigneeCompletes As Boolean

See Also

TaskAssignmentClassInfo Object | TaskAssignmentClassInfo Members


%%PageItemTitle%%

SignatureForCompletion Property
TaskAssignmentClassInfo Object : SignatureForCompletion Property

Glossary Item Box

Description

Information about signature settings for assignment completion.

Property type

Read-write property

Syntax

Visual Basic
Public Property SignatureForCompletion As SignatureSettings

See Also

TaskAssignmentClassInfo Object | TaskAssignmentClassInfo Members


%%PageItemTitle%%

TemporarySearchView Object
Members See Also Example Send comments

Glossary Item Box

Description

The TemporarySearchView class represents a temporary search view.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property SearchCriteria | The search criteria of the view.
Public Property View | Encapsulated view object.

Remarks

The temporary search view behaves like the quick search result set in the M-Files user interface. The temporary search is removed automatically when M-Files restarts.

Example

Creating a temporary search view (Visual Basic) Copy Code
' Create the view object.
Dim oViewNew As New MFilesAPI.View
oViewNew.Name = "Test view"

' Create the search criteria for the view.
Dim oSc As New MFilesAPI.SearchCriteria
oSc.FullTextSearchString = "demo*"
oSc.FullTextSearchFlags = MFilesAPI.MFFullTextSearchFlags.MFFullTextSearchFlagsStemming Or _
    MFilesAPI.MFFullTextSearchFlags.MFFullTextSearchFlagsLookInMetaData Or _
    MFilesAPI.MFFullTextSearchFlags.MFFullTextSearchFlagsLookInFileData Or _
    MFilesAPI.MFFullTextSearchFlags.MFFullTextSearchFlagsTypeAllWords
oSc.SearchFlags = MFilesAPI.MFSearchFlags.MFSearchFlagNone
oSc.ExpandUI = True

' Create the "not deleted" condition for search criteria.
Dim oExpression As New MFilesAPI.Expression
oExpression.DataStatusValueType = MFilesAPI.MFStatusType.MFStatusTypeDeleted
oExpression.DataStatusValueDataFunction = MFilesAPI.MFDataFunction.MFDataFunctionNoOp
Dim oTypedValue As New MFilesAPI.TypedValue
oTypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeBoolean, False)
Dim oDeletedEx As New MFilesAPI.SearchConditionEx
oDeletedEx.SearchCondition.Set(oExpression, MFilesAPI.MFConditionType.MFConditionTypeEqual, oTypedValue)
oDeletedEx.Enabled = True
oDeletedEx.Ignored = False
oDeletedEx.SpecialNULL = False

' Add the deleted condition.
oSc.AdditionalConditions.Add(-1, oDeletedEx)

' Add the new view.
oViewNew = oVault.ViewOperations.AddTemporarySearchView(oViewNew, oSc)

See Also

TemporarySearchView Members


%%PageItemTitle%%

Clone Method
TemporarySearchView Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As TemporarySearchView

See Also

TemporarySearchView Object | TemporarySearchView Members


%%PageItemTitle%%

SearchCriteria Property
TemporarySearchView Object : SearchCriteria Property

Glossary Item Box

Description

The search criteria of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property SearchCriteria As SearchCriteria

See Also

TemporarySearchView Object | TemporarySearchView Members


%%PageItemTitle%%

View Property
TemporarySearchView Object : View Property

Glossary Item Box

Description

Encapsulated view object.

Property type

Read-only property

Syntax

Visual Basic
Public Property View As View

See Also

TemporarySearchView Object | TemporarySearchView Members


%%PageItemTitle%%

Timestamp Object
Members See Also Send comments

Glossary Item Box

Description

The Timestamp class represents the Timestamp.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetValue | Gets the value as VARIANT of type VT_DATE.
Public Method LocalTimeToUtc | If Timestamp is local time - converts it to UTC and returns new object.
Public Method SetValue | Sets the value from VARIANT of type VT_DATE.
Public Method UtcToLocalTime | If Timestamp is UTC - converts it to a local time and returns new object.

Public Properties

Public Property Day | Day.
Public Property Fraction | Fraction in nanoseconds.
Public Property Hour | Hour.
Public Property Minute | Minute.
Public Property Month | Month.
Public Property Second | Second.
Public Property Year | Year.

See Also

Timestamp Members


%%PageItemTitle%%

Clone Method
Timestamp Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As Timestamp

See Also

Timestamp Object | Timestamp Members


%%PageItemTitle%%

GetValue Method
Timestamp Object : GetValue Method

Glossary Item Box

Description

Gets the value as VARIANT of type VT_DATE.

Syntax

Visual Basic
Public Function GetValue() As Variant

See Also

Timestamp Object | Timestamp Members


%%PageItemTitle%%

LocalTimeToUtc Method
Timestamp Object : LocalTimeToUtc Method

Glossary Item Box

Description

If Timestamp is local time - converts it to UTC and returns new object.

Syntax

Visual Basic
Public Function LocalTimeToUtc() As Timestamp

See Also

Timestamp Object | Timestamp Members


%%PageItemTitle%%

SetValue Method
Value
Timestamp Object : SetValue Method

Glossary Item Box

Description

Sets the value from VARIANT of type VT_DATE.

Syntax

Visual Basic
Public Sub SetValue( _
   ByVal Value As Variant _
)

Parameters

Value

See Also

Timestamp Object | Timestamp Members


%%PageItemTitle%%

UtcToLocalTime Method
Timestamp Object : UtcToLocalTime Method

Glossary Item Box

Description

If Timestamp is UTC - converts it to a local time and returns new object.

Syntax

Visual Basic
Public Function UtcToLocalTime() As Timestamp

See Also

Timestamp Object | Timestamp Members


%%PageItemTitle%%

Day Property
Timestamp Object : Day Property

Glossary Item Box

Description

Day.

Property type

Read-write property

Syntax

Visual Basic
Public Property Day As ULong

See Also

Timestamp Object | Timestamp Members


%%PageItemTitle%%

Fraction Property
Timestamp Object : Fraction Property

Glossary Item Box

Description

Fraction in nanoseconds.

Property type

Read-write property

Syntax

Visual Basic
Public Property Fraction As ULong

See Also

Timestamp Object | Timestamp Members


%%PageItemTitle%%

Hour Property
Timestamp Object : Hour Property

Glossary Item Box

Description

Hour.

Property type

Read-write property

Syntax

Visual Basic
Public Property Hour As ULong

See Also

Timestamp Object | Timestamp Members


%%PageItemTitle%%

Minute Property
Timestamp Object : Minute Property

Glossary Item Box

Description

Minute.

Property type

Read-write property

Syntax

Visual Basic
Public Property Minute As ULong

See Also

Timestamp Object | Timestamp Members


%%PageItemTitle%%

Month Property
Timestamp Object : Month Property

Glossary Item Box

Description

Month.

Property type

Read-write property

Syntax

Visual Basic
Public Property Month As ULong

See Also

Timestamp Object | Timestamp Members


%%PageItemTitle%%

Second Property
Timestamp Object : Second Property

Glossary Item Box

Description

Second.

Property type

Read-write property

Syntax

Visual Basic
Public Property Second As ULong

See Also

Timestamp Object | Timestamp Members


%%PageItemTitle%%

Year Property
Timestamp Object : Year Property

Glossary Item Box

Description

Year.

Property type

Read-write property

Syntax

Visual Basic
Public Property Year As ULong

See Also

Timestamp Object | Timestamp Members


%%PageItemTitle%%

TimeZoneInformation Object
Members See Also Send comments

Glossary Item Box

Description

The TimeZoneInformation class.

Public Methods

Public Method Clone | Creates a clone of an object.
Public Method LoadTimeZoneByName | Loads the time zone of the given name. The names of the available time zones can found from Windows registry under the following key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Time Zones.
Public Method LoadWithCurrentTimeZone | Initializes the time zone with the local time zone.

Public Properties

Public Property StandardName The standard name of the time zone.

See Also

TimeZoneInformation Members


%%PageItemTitle%%

Clone Method
TimeZoneInformation Object : Clone Method

Glossary Item Box

Description

Creates a clone of an object.

Syntax

Visual Basic
Public Function Clone() As TimeZoneInformation

See Also

TimeZoneInformation Object | TimeZoneInformation Members


%%PageItemTitle%%

LoadTimeZoneByName Method
TimeZoneName
TimeZoneInformation Object : LoadTimeZoneByName Method

Glossary Item Box

Description

Loads the time zone of the given name. The names of the available time zones can found from Windows registry under the following key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Time Zones.

Syntax

Visual Basic
Public Sub LoadTimeZoneByName( _
   ByVal TimeZoneName As String _
)

Parameters

TimeZoneName

See Also

TimeZoneInformation Object | TimeZoneInformation Members


%%PageItemTitle%%

LoadWithCurrentTimeZone Method
TimeZoneInformation Object : LoadWithCurrentTimeZone Method

Glossary Item Box

Description

Initializes the time zone with the local time zone.

Syntax

Visual Basic
Public Sub LoadWithCurrentTimeZone()

See Also

TimeZoneInformation Object | TimeZoneInformation Members


%%PageItemTitle%%

StandardName Property
TimeZoneInformation Object : StandardName Property

Glossary Item Box

Description

The standard name of the time zone.

Property type

Read-only property

Syntax

Visual Basic
Public Property StandardName As String

See Also

TimeZoneInformation Object | TimeZoneInformation Members


%%PageItemTitle%%

TraditionalFolder Object
Members See Also Send comments

Glossary Item Box

Description

The TraditionalFolder class represents a traditional folder.

Public Properties

Public Property ID | ID of the traditional folder.
Public Property Name | Name of the traditional folder.

Remarks

A traditional folder (highlighted with the green rectangle) as seen in M-Files Desktop.

See Also

TraditionalFolder Members


%%PageItemTitle%%

ID Property
TraditionalFolder Object : ID Property

Glossary Item Box

Description

ID of the traditional folder.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID As Long

See Also

TraditionalFolder Object | TraditionalFolder Members


%%PageItemTitle%%

Name Property
TraditionalFolder Object : Name Property

Glossary Item Box

Description

Name of the traditional folder.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

TraditionalFolder Object | TraditionalFolder Members


%%PageItemTitle%%

TraditionalFolderContents Object
Members See Also Send comments

Glossary Item Box

Description

The TraditionalFolderContents class represents the contents of a traditional folder.

Public Properties

Public Property ID | The ID of the traditional folder.
Public Property ObjectVersions | Object versions inside this traditional folder.
Public Property TraditionalFolders | Traditional folders inside this traditional folder.

Remarks

A traditional folder can contain other traditional sub-folders and object versions (e.g., documents).

See Also

TraditionalFolderContents Members | TraditionalFolder Object | VaultTraditionalFolderOperations Object


%%PageItemTitle%%

ID Property
TraditionalFolderContents Object : ID Property

Glossary Item Box

Description

The ID of the traditional folder.

Property type

Read-only property

Syntax

Visual Basic
Public Property ID As Long

See Also

TraditionalFolderContents Object | TraditionalFolderContents Members


%%PageItemTitle%%

ObjectVersions Property
TraditionalFolderContents Object : ObjectVersions Property

Glossary Item Box

Description

Object versions inside this traditional folder.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectVersions As ObjectVersions

See Also

TraditionalFolderContents Object | TraditionalFolderContents Members


%%PageItemTitle%%

TraditionalFolders Property
TraditionalFolderContents Object : TraditionalFolders Property

Glossary Item Box

Description

Traditional folders inside this traditional folder.

Property type

Read-only property

Syntax

Visual Basic
Public Property TraditionalFolders As TraditionalFolders

See Also

TraditionalFolderContents Object | TraditionalFolderContents Members


%%PageItemTitle%%

TraditionalFolders Collection
Members See Also Send comments

Glossary Item Box

Description

TraditionalFolders is a collection of TraditionalFolder objects.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

TraditionalFolders Members


%%PageItemTitle%%

Count Property
TraditionalFolders Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

TraditionalFolders Collection | TraditionalFolders Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

TraditionalFolders Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As TraditionalFolder

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

TraditionalFolders Collection | TraditionalFolders Members


%%PageItemTitle%%

TriggerType Object
Members See Also Send comments

Glossary Item Box

Description

The TriggerType class represents the type of a trigger.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetDailyTrigger | The time when the scheduled will run next.
Public Method SetMonthlyDate | The time when the scheduled will run next.
Public Method SetMonthlyDOW | The time when the scheduled will run next.
Public Method SetWeekly | The time when the scheduled will run next.

Public Properties

Public Property Daily | The time when the scheduled will run next.
Public Property MonthlyDate | The time when the scheduled will run next.
Public Property MonthlyDOW | The time when the scheduled will run next.
Public Property Type | An enumerated value that specifies the type of trigger.
Public Property Weekly | The time when the scheduled will run next.

See Also

TriggerType Members


%%PageItemTitle%%

Clone Method
TriggerType Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As TriggerType

See Also

TriggerType Object | TriggerType Members


%%PageItemTitle%%

SetDailyTrigger Method
DailyTrigger
TriggerType Object : SetDailyTrigger Method

Glossary Item Box

Description

The time when the scheduled will run next.

Syntax

Visual Basic
Public Sub SetDailyTrigger( _
   ByVal DailyTrigger As DailyTrigger _
)

Parameters

DailyTrigger

See Also

TriggerType Object | TriggerType Members


%%PageItemTitle%%

SetMonthlyDate Method
MonthlyDateTrigger
TriggerType Object : SetMonthlyDate Method

Glossary Item Box

Description

The time when the scheduled will run next.

Syntax

Visual Basic
Public Sub SetMonthlyDate( _
   ByVal MonthlyDateTrigger As MonthlyDateTrigger _
)

Parameters

MonthlyDateTrigger

See Also

TriggerType Object | TriggerType Members


%%PageItemTitle%%

SetMonthlyDOW Method
MonthlyDOWTrigger
TriggerType Object : SetMonthlyDOW Method

Glossary Item Box

Description

The time when the scheduled will run next.

Syntax

Visual Basic
Public Sub SetMonthlyDOW( _
   ByVal MonthlyDOWTrigger As MonthlyDOWTrigger _
)

Parameters

MonthlyDOWTrigger

See Also

TriggerType Object | TriggerType Members


%%PageItemTitle%%

SetWeekly Method
WeeklyTrigger
TriggerType Object : SetWeekly Method

Glossary Item Box

Description

The time when the scheduled will run next.

Syntax

Visual Basic
Public Sub SetWeekly( _
   ByVal WeeklyTrigger As WeeklyTrigger _
)

Parameters

WeeklyTrigger

See Also

TriggerType Object | TriggerType Members


%%PageItemTitle%%

Daily Property
TriggerType Object : Daily Property

Glossary Item Box

Description

The time when the scheduled will run next.

Property type

Read-only property

Syntax

Visual Basic
Public Property Daily As DailyTrigger

See Also

TriggerType Object | TriggerType Members


%%PageItemTitle%%

MonthlyDate Property
TriggerType Object : MonthlyDate Property

Glossary Item Box

Description

The time when the scheduled will run next.

Property type

Read-only property

Syntax

Visual Basic
Public Property MonthlyDate As MonthlyDateTrigger

See Also

TriggerType Object | TriggerType Members


%%PageItemTitle%%

MonthlyDOW Property
TriggerType Object : MonthlyDOW Property

Glossary Item Box

Description

The time when the scheduled will run next.

Property type

Read-only property

Syntax

Visual Basic
Public Property MonthlyDOW As MonthlyDOWTrigger

See Also

TriggerType Object | TriggerType Members


%%PageItemTitle%%

Type Property
TriggerType Object : Type Property

Glossary Item Box

Description

An enumerated value that specifies the type of trigger.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type As MFTriggerType

See Also

TriggerType Object | TriggerType Members


%%PageItemTitle%%

Weekly Property
TriggerType Object : Weekly Property

Glossary Item Box

Description

The time when the scheduled will run next.

Property type

Read-only property

Syntax

Visual Basic
Public Property Weekly As WeeklyTrigger

See Also

TriggerType Object | TriggerType Members


%%PageItemTitle%%

TypedValue Object
Members See Also Example Send comments

Glossary Item Box

Description

A 'typed value' represents a value, such as text, number, date or a lookup item.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method CompareTo | Compares this typed value to the given typed value.
Public Method GetLookupID | Gets the lookup ID. The typed value must be of the lookup type.
Public Method GetValueAsLocalizedText | Gets the current value as localized text. The value is localized based on the culture of the local computer.
Public Method GetValueAsLocalizedTextEx | Gets the current value as localized text. The value is localized based on the culture setting of the local computer.
Public Method GetValueAsLookup | Gets the value as a lookup.
Public Method GetValueAsLookups | Gets the value as a lookups.
Public Method GetValueAsText | Gets the value of this typed value formatted with the given parameters.
Public Method GetValueAsTextEx | Gets the value of this typed value formatted with the given parameters.
Public Method GetValueAsTextWithExpression | Gets the current value as localized text modified according to the given expression.
Public Method GetValueAsTimestamp | Gets the value as timestamp.
Public Method GetValueAsUnlocalizedText | Gets the current value as unlocalized text.
Public Method IsNULL | Specifies whether the typed value is a NULL value.
Public Method IsUninitialized | Specifies whether the typed value is uninitialized.
Public Method Serialize | Serializes the typed value.
Public Method SetValue | Sets the value of a typed value.
Public Method SetValueToLookup | Set the value to a lookup.
Public Method SetValueToMultiSelectLookup | Sets the value to a multi-select lookup.
Public Method SetValueToNULL | Sets the typed value to NULL of the specified data type.
Public Method Unserialize | Unserializes the typed value.

Public Properties

Public Property DataType | The data type of the typed value.
Public Property DisplayValue | The textual representation of the typed value.
Public Property Value | The value of the type value. If the data type of a typed value is MFDataTypeLookup, only the ID part of the lookup is included.

Remarks

The value and type of the TypedValue object depends on the data type of the property value. The type can be one of the basic types or a lookup reference to an object or value list item.

Example

Extracting data from typed value (Visual Basic) Copy Code
' Identify the object and property.
Dim oObjVer As MFilesAPI.ObjVer
Dim iPropertyId As Integer
'...

' Get the value of property.
Dim oPropertyValues As MFilesAPI.PropertyValues = oVault.ObjectPropertyOperations.GetProperties(oObjVer)
Dim oPropertyValue As MFilesAPI.PropertyValue = oPropertyValues.SearchForProperty(iPropertyId)

' Read the contents of TypedValue, depending on its type.
If oPropertyValue.TypedValue.DataType = MFilesAPI.MFDataType.MFDatatypeText Then

    ' Get the value as unmodified text.
    Dim str As String = oPropertyValue.TypedValue.Value
    ' ...

ElseIf oPropertyValue.TypedValue.DataType = MFilesAPI.MFDataType.MFDatatypeLookup Then

    ' Get the value as lookup reference.
    Dim oLookUpRef As MFilesAPI.Lookup = oPropertyValue.TypedValue.GetValueAsLookup()
    ' Process the lookup item.

ElseIf oPropertyValue.TypedValue.DataType = MFilesAPI.MFDataType.MFDatatypeMultiSelectLookup Then

    ' Multi-select lookup. Loop through all lookup items.
    For Each oLookUpRef As MFilesAPI.Lookup In oPropertyValue.TypedValue.GetValueAsLookups

        ' Process each lookup item.

    Next

Else

    ' Just get the value as string in local format.
    Dim str As String = oPropertyValue.TypedValue.GetValueAsLocalizedText()
    ' ...

End If

See Also

TypedValue Members | SearchCondition Object


%%PageItemTitle%%

Clone Method
TypedValue Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As TypedValue

Return Type

Returns the copied typed value.

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

CloneFrom Method
TypedValue
TypedValue Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal TypedValue As TypedValue _
)

Parameters

TypedValue

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

CompareTo Method
TypedValue
The typed value to compare.
TypedValue Object : CompareTo Method

Glossary Item Box

Description

Compares this typed value to the given typed value.

Syntax

Visual Basic
Public Function CompareTo( _
   ByVal TypedValue As TypedValue _
) As Long

Parameters

TypedValue
The typed value to compare.

Return Type

If the return value is less than zero, the left object version precedes the right one. If the return value is greater than zero, the right object version precedes the left one. If the return value is zero, the object versions have equal order ranking.

Remarks

There is no type coercion before comparison, i.e. the data types of the both typed values should be the same for a proper comparison. If one of the typed values is uninitialized, it is considered to follow the other value. If the data types are different, the precedence order is calculated by using internal constants representing the data types.

If the typed values represent string values the natural case insensitive comparison is used.

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

GetLookupID Method
TypedValue Object : GetLookupID Method

Glossary Item Box

Description

Gets the lookup ID. The typed value must be of the lookup type.

Syntax

Visual Basic
Public Function GetLookupID() As Long

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

GetValueAsLocalizedText Method
TypedValue Object : GetValueAsLocalizedText Method

Glossary Item Box

Description

Gets the current value as localized text. The value is localized based on the culture of the local computer.

Syntax

Visual Basic
Public Function GetValueAsLocalizedText() As String

Remarks

This method formats time-based values according to the locale settings of the computer the API client is running on, but does not make any time zone based conversions.

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

GetValueAsLocalizedTextEx Method
AllowDigitGrouping
If this is set to "true", digit grouping (thousands separator) is used for integers (eDatatypeInteger) and real numbers (eDatatypeFloating).
TypedValue Object : GetValueAsLocalizedTextEx Method

Glossary Item Box

Description

Gets the current value as localized text. The value is localized based on the culture setting of the local computer.

Syntax

Visual Basic
Public Function GetValueAsLocalizedTextEx( _
   ByVal AllowDigitGrouping As Boolean _
) As String

Parameters

AllowDigitGrouping
If this is set to "true", digit grouping (thousands separator) is used for integers (eDatatypeInteger) and real numbers (eDatatypeFloating).

Remarks

This method formats time-based values according to the locale settings of the computer the API client is running on, but does not make any time zone based conversions.

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

GetValueAsLookup Method
TypedValue Object : GetValueAsLookup Method

Glossary Item Box

Description

Gets the value as a lookup.

Syntax

Visual Basic
Public Function GetValueAsLookup() As Lookup

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

GetValueAsLookups Method
TypedValue Object : GetValueAsLookups Method

Glossary Item Box

Description

Gets the value as a lookups.

Syntax

Visual Basic
Public Function GetValueAsLookups() As Lookups

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

GetValueAsText Method
Localized
Specifies whether the value is to be localized (for example dates).
NULLAsEmptyString
True if a NULL value should be returned as an empty string. Otherwise, returns the stringified version of NULL, typically (null) or (empty).
EmptyLookupDisplayValuesAsHidden
If the property value is empty, specifies whether the returned value should be treated as a hidden value.
LongDateFormat
True to set the possible timestamp to be presented in the long date format.
NoSeconds
If true, seconds are not included in the formatted string.
NumericValueAsKilobytes
True to return numeric values as kilobytes.
TypedValue Object : GetValueAsText Method

Glossary Item Box

Description

Gets the value of this typed value formatted with the given parameters.

Syntax

Visual Basic
Public Function GetValueAsText( _
   ByVal Localized As Boolean, _
   ByVal NULLAsEmptyString As Boolean, _
   ByVal EmptyLookupDisplayValuesAsHidden As Boolean, _
   ByVal LongDateFormat As Boolean, _
   ByVal NoSeconds As Boolean, _
   ByVal NumericValueAsKilobytes As Boolean _
) As String

Parameters

Localized
Specifies whether the value is to be localized (for example dates).
NULLAsEmptyString
True if a NULL value should be returned as an empty string. Otherwise, returns the stringified version of NULL, typically (null) or (empty).
EmptyLookupDisplayValuesAsHidden
If the property value is empty, specifies whether the returned value should be treated as a hidden value.
LongDateFormat
True to set the possible timestamp to be presented in the long date format.
NoSeconds
If true, seconds are not included in the formatted string.
NumericValueAsKilobytes
True to return numeric values as kilobytes.

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

GetValueAsTextEx Method
Localized
Specifies whether the value is to be localized (for example dates).
NULLAsEmptyString
True if a NULL value should be returned as an empty string. Otherwise, returns the stringified version of NULL, typically (null) or (empty).
EmptyLookupDisplayValuesAsHidden
If the property value is empty, specifies whether the returned value should be treated as a hidden value.
LongDateFormat
True to set the possible timestamp to be presented in the long date format.
NoSeconds
If true, seconds are not included in the formatted string.
NumericValueAsKilobytes
True to return numeric values as kilobytes.
AllowDigitGrouping
If true, digit grouping (= thousands separator) should be used for integers (eDatatypeInteger) and real numbers (eDatatypeFloating). Effective only if "Localized" is true.
TypedValue Object : GetValueAsTextEx Method

Glossary Item Box

Description

Gets the value of this typed value formatted with the given parameters.

Syntax

Visual Basic
Public Function GetValueAsTextEx( _
   ByVal Localized As Boolean, _
   ByVal NULLAsEmptyString As Boolean, _
   ByVal EmptyLookupDisplayValuesAsHidden As Boolean, _
   ByVal LongDateFormat As Boolean, _
   ByVal NoSeconds As Boolean, _
   ByVal NumericValueAsKilobytes As Boolean, _
   ByVal AllowDigitGrouping As Boolean _
) As String

Parameters

Localized
Specifies whether the value is to be localized (for example dates).
NULLAsEmptyString
True if a NULL value should be returned as an empty string. Otherwise, returns the stringified version of NULL, typically (null) or (empty).
EmptyLookupDisplayValuesAsHidden
If the property value is empty, specifies whether the returned value should be treated as a hidden value.
LongDateFormat
True to set the possible timestamp to be presented in the long date format.
NoSeconds
If true, seconds are not included in the formatted string.
NumericValueAsKilobytes
True to return numeric values as kilobytes.
AllowDigitGrouping
If true, digit grouping (= thousands separator) should be used for integers (eDatatypeInteger) and real numbers (eDatatypeFloating). Effective only if "Localized" is true.

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

GetValueAsTextWithExpression Method
Expression
Locale
TypedValue Object : GetValueAsTextWithExpression Method

Glossary Item Box

Description

Gets the current value as localized text modified according to the given expression.

Syntax

Visual Basic
Public Function GetValueAsTextWithExpression( _
   ByVal Expression As Expression, _
   Optional ByVal Locale As ULong = 0 _
) As String

Parameters

Expression
Locale

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

GetValueAsTimestamp Method
TypedValue Object : GetValueAsTimestamp Method

Glossary Item Box

Description

Gets the value as timestamp.

Syntax

Visual Basic
Public Function GetValueAsTimestamp() As Timestamp

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

GetValueAsUnlocalizedText Method
TypedValue Object : GetValueAsUnlocalizedText Method

Glossary Item Box

Description

Gets the current value as unlocalized text.

Syntax

Visual Basic
Public Function GetValueAsUnlocalizedText() As String

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

IsNULL Method
TypedValue Object : IsNULL Method

Glossary Item Box

Description

Specifies whether the typed value is a NULL value.

Syntax

Visual Basic
Public Function IsNULL() As Boolean

Return Type

Indicates whether the typed value is a null value.

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

IsUninitialized Method
TypedValue Object : IsUninitialized Method

Glossary Item Box

Description

Specifies whether the typed value is uninitialized.

Syntax

Visual Basic
Public Function IsUninitialized() As Boolean

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

Serialize Method
TypedValue Object : Serialize Method

Glossary Item Box

Description

Serializes the typed value.

Syntax

Visual Basic
Public Function Serialize() As Byte()

Return Type

The return value is a byte array containing the serialized typed value.

Remarks

The serialized typed value can be unserialized with the help of the Unserialize method.

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

SetValue Method
DataType
Specifies the data type of the typed value.
Value
Specifies the actual value.
TypedValue Object : SetValue Method

Glossary Item Box

Description

Sets the value of a typed value.

Syntax

Visual Basic
Public Sub SetValue( _
   ByVal DataType As MFDataType, _
   ByVal Value As Variant _
)

Parameters

DataType
Value | Description
MFDatatypeACL | The access control list (ACL).
MFDatatypeBoolean | Boolean.
MFDatatypeDate | Date.
MFDatatypeFILETIME | FILETIME (a 64-bit integer). Not used in the properties.
MFDatatypeFloating | A double-precision floating point.
MFDatatypeInteger | A 32-bit integer.
MFDatatypeInteger64 | A 64-bit integer. Not used in the properties.
MFDatatypeLookup | Lookup (from a value list).
MFDatatypeMultiLineText | Multi-line text.
MFDatatypeMultiSelectLookup | Multiple selection from a value list.
MFDatatypeText | Text.
MFDatatypeTime | Time.
MFDatatypeTimestamp | Timestamp.
MFDatatypeUninitialized | Unknown type (not yet set to any type).
Specifies the data type of the typed value.
Value
Specifies the actual value.

Remarks

If the data type of a typed value is MFDataTypeLookup, a variant given to SetValue can carry either the ID of a lookup as a primitive integer or both the ID and the display value of a lookup as a one-dimensional array.

If the data type of a typed value is MFDataTypeMultiSelectLookup, the caller can supply lookups in one of the following two ways:

1. By passing a single integer. A single primitive integer is interpreted to be the ID part of a lookup. In this case, the multi-select lookup consists of only one lookup.
2. By passing a two-dimensional array containing the IDs and display values of lookups. The IDs must be located in the first column and the display values in the second one.

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

SetValueToLookup Method
Lookup
TypedValue Object : SetValueToLookup Method

Glossary Item Box

Description

Set the value to a lookup.

Syntax

Visual Basic
Public Sub SetValueToLookup( _
   ByVal Lookup As Lookup _
)

Parameters

Lookup

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

SetValueToMultiSelectLookup Method
MultiSelectLookup
TypedValue Object : SetValueToMultiSelectLookup Method

Glossary Item Box

Description

Sets the value to a multi-select lookup.

Syntax

Visual Basic
Public Sub SetValueToMultiSelectLookup( _
   ByVal MultiSelectLookup As Lookups _
)

Parameters

MultiSelectLookup

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

SetValueToNULL Method
DataType
TypedValue Object : SetValueToNULL Method

Glossary Item Box

Description

Sets the typed value to NULL of the specified data type.

Syntax

Visual Basic
Public Sub SetValueToNULL( _
   ByVal DataType As MFDataType _
)

Parameters

DataType
Value | Description
MFDatatypeACL | The access control list (ACL).
MFDatatypeBoolean | Boolean.
MFDatatypeDate | Date.
MFDatatypeFILETIME | FILETIME (a 64-bit integer). Not used in the properties.
MFDatatypeFloating | A double-precision floating point.
MFDatatypeInteger | A 32-bit integer.
MFDatatypeInteger64 | A 64-bit integer. Not used in the properties.
MFDatatypeLookup | Lookup (from a value list).
MFDatatypeMultiLineText | Multi-line text.
MFDatatypeMultiSelectLookup | Multiple selection from a value list.
MFDatatypeText | Text.
MFDatatypeTime | Time.
MFDatatypeTimestamp | Timestamp.
MFDatatypeUninitialized | Unknown type (not yet set to any type).

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

Unserialize Method
Bytes
The serialized typed value to unserialize.
ReadFromOldSerializingFormat
If this parameter is True, the data to be read was written with M-Files 3.0.1627.0 or an older version.
TypedValue Object : Unserialize Method

Glossary Item Box

Description

Unserializes the typed value.

Syntax

Visual Basic
Public Sub Unserialize( _
   ByVal Bytes() As Byte, _
   ByVal ReadFromOldSerializingFormat As Boolean _
)

Parameters

Bytes
The serialized typed value to unserialize.
ReadFromOldSerializingFormat
If this parameter is True, the data to be read was written with M-Files 3.0.1627.0 or an older version.

Remarks

The unserialized typed value can be serialized with the help of the Serialize method.

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

DataType Property
TypedValue Object : DataType Property

Glossary Item Box

Description

The data type of the typed value.

Property type

Read-only property

Syntax

Visual Basic
Public Property DataType As MFDataType

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

DisplayValue Property
TypedValue Object : DisplayValue Property

Glossary Item Box

Description

The textual representation of the typed value.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayValue As String

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

Value Property
TypedValue Object : Value Property

Glossary Item Box

Description

The value of the type value. If the data type of a typed value is MFDataTypeLookup, only the ID part of the lookup is included.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value As Variant

See Also

TypedValue Object | TypedValue Members


%%PageItemTitle%%

TypedValues Collection
Members See Also Send comments

Glossary Item Box

Description

The TypedValue class represents a typed value collection.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

TypedValues Members


%%PageItemTitle%%

Add Method
Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

TypedValue
The new collection member to be added.
TypedValues Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal TypedValue As TypedValue _
)

Parameters

Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

TypedValue
The new collection member to be added.

See Also

TypedValues Collection | TypedValues Members


%%PageItemTitle%%

Remove Method
Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

TypedValues Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

See Also

TypedValues Collection | TypedValues Members


%%PageItemTitle%%

Count Property
TypedValues Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

TypedValues Collection | TypedValues Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

TypedValues Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As TypedValue

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

TypedValues Collection | TypedValues Members


%%PageItemTitle%%

UserAccount Object
Members See Also Send comments

Glossary Item Box

Description

The UserAccount class represents a user account.

Public Methods

Public Method AddVaultRoles | Adds new vault roles for the user.
Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method RemoveVaultRoles | Removes vault roles from the user.

Public Properties

Public Property AccessControlList | The user permissions as an access control list.
Public Property Enabled | The enabled state of the user.
Public Property ID | The ID of the user.
Public Property InternalUser | Specifies whether the user is an internal user.
Public Property LoginName | The login name of the user.
Public Property VaultLanguage | Current vault language for the user.
Public Property VaultRoles | The vault roles of the user.

Remarks

The user account is a vault-specific user identification object, not to be confused with LoginAccount, which contains global settings for the user. The user account maps to the login account by using the login name.

User accounts of a vault in M-Files Admin.

See Also

UserAccount Members


%%PageItemTitle%%

AddVaultRoles Method
VaultRolesToAdd
UserAccount Object : AddVaultRoles Method

Glossary Item Box

Description

Adds new vault roles for the user.

Syntax

Visual Basic
Public Sub AddVaultRoles( _
   ByVal VaultRolesToAdd As MFUserAccountVaultRole _
)

Parameters

VaultRolesToAdd
Value | Description
MFUserAccountVaultRoleAnonymousUser | Anonymous user.
MFUserAccountVaultRoleCannotManagePrivateViews | Cannot manage private views and notification rules.
MFUserAccountVaultRoleChangeMetadataStructure | Change metadata structure.
MFUserAccountVaultRoleChangeObjectSecurity | Change permissions for all objects.
MFUserAccountVaultRoleCreateObjects | Can create documents or other objects.
MFUserAccountVaultRoleDefaultRoles | The default vault roles for a normal user.
MFUserAccountVaultRoleDefineTemplates | Manage templates (obsolete).
MFUserAccountVaultRoleDestroyObjects | Destroy objects.
MFUserAccountVaultRoleForceUndoCheckout | Force undo checkout.
MFUserAccountVaultRoleFullControl | Full control of vault.
MFUserAccountVaultRoleInternalUser | Internal user (as opposed to external user).
MFUserAccountVaultRoleLogIn | Can log into the vault.
MFUserAccountVaultRoleManageCommonViews | Manage common views and notification rules.
MFUserAccountVaultRoleManageTraditionalFolders | Can create and modify traditional folders.
MFUserAccountVaultRoleManageUserAccounts | Manage user accounts.
MFUserAccountVaultRoleManageWorkflows | Manage workflows.
MFUserAccountVaultRoleNone | None.
MFUserAccountVaultRoleSeeAllObjects | See and read all vault content (including deleted objects).
MFUserAccountVaultRoleUndeleteObjects | See and undelete deleted objects.

See Also

UserAccount Object | UserAccount Members


%%PageItemTitle%%

Clone Method
UserAccount Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As UserAccount

See Also

UserAccount Object | UserAccount Members


%%PageItemTitle%%

CloneFrom Method
UserAccount
UserAccount Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal UserAccount As UserAccount _
)

Parameters

UserAccount

See Also

UserAccount Object | UserAccount Members


%%PageItemTitle%%

RemoveVaultRoles Method
VaultRolesToRemove
UserAccount Object : RemoveVaultRoles Method

Glossary Item Box

Description

Removes vault roles from the user.

Syntax

Visual Basic
Public Sub RemoveVaultRoles( _
   ByVal VaultRolesToRemove As MFUserAccountVaultRole _
)

Parameters

VaultRolesToRemove
Value | Description
MFUserAccountVaultRoleAnonymousUser | Anonymous user.
MFUserAccountVaultRoleCannotManagePrivateViews | Cannot manage private views and notification rules.
MFUserAccountVaultRoleChangeMetadataStructure | Change metadata structure.
MFUserAccountVaultRoleChangeObjectSecurity | Change permissions for all objects.
MFUserAccountVaultRoleCreateObjects | Can create documents or other objects.
MFUserAccountVaultRoleDefaultRoles | The default vault roles for a normal user.
MFUserAccountVaultRoleDefineTemplates | Manage templates (obsolete).
MFUserAccountVaultRoleDestroyObjects | Destroy objects.
MFUserAccountVaultRoleForceUndoCheckout | Force undo checkout.
MFUserAccountVaultRoleFullControl | Full control of vault.
MFUserAccountVaultRoleInternalUser | Internal user (as opposed to external user).
MFUserAccountVaultRoleLogIn | Can log into the vault.
MFUserAccountVaultRoleManageCommonViews | Manage common views and notification rules.
MFUserAccountVaultRoleManageTraditionalFolders | Can create and modify traditional folders.
MFUserAccountVaultRoleManageUserAccounts | Manage user accounts.
MFUserAccountVaultRoleManageWorkflows | Manage workflows.
MFUserAccountVaultRoleNone | None.
MFUserAccountVaultRoleSeeAllObjects | See and read all vault content (including deleted objects).
MFUserAccountVaultRoleUndeleteObjects | See and undelete deleted objects.

See Also

UserAccount Object | UserAccount Members


%%PageItemTitle%%

AccessControlList Property
UserAccount Object : AccessControlList Property

Glossary Item Box

Description

The user permissions as an access control list.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessControlList As AccessControlList

See Also

UserAccount Object | UserAccount Members


%%PageItemTitle%%

Enabled Property
UserAccount Object : Enabled Property

Glossary Item Box

Description

The enabled state of the user.

Property type

Read-write property

Syntax

Visual Basic
Public Property Enabled As Boolean

See Also

UserAccount Object | UserAccount Members


%%PageItemTitle%%

ID Property
UserAccount Object : ID Property

Glossary Item Box

Description

The ID of the user.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

UserAccount Object | UserAccount Members


%%PageItemTitle%%

InternalUser Property
UserAccount Object : InternalUser Property

Glossary Item Box

Description

Specifies whether the user is an internal user.

Property type

Read-write property

Syntax

Visual Basic
Public Property InternalUser As Boolean

See Also

UserAccount Object | UserAccount Members


%%PageItemTitle%%

LoginName Property
UserAccount Object : LoginName Property

Glossary Item Box

Description

The login name of the user.

Property type

Read-write property

Syntax

Visual Basic
Public Property LoginName As String

See Also

UserAccount Object | UserAccount Members


%%PageItemTitle%%

VaultLanguage Property
UserAccount Object : VaultLanguage Property

Glossary Item Box

Description

Current vault language for the user.

Property type

Read-write property

Syntax

Visual Basic
Public Property VaultLanguage As Integer

See Also

UserAccount Object | UserAccount Members


%%PageItemTitle%%

VaultRoles Property
UserAccount Object : VaultRoles Property

Glossary Item Box

Description

The vault roles of the user.

Property type

Read-write property

Syntax

Visual Basic
Public Property VaultRoles As MFUserAccountVaultRole

See Also

UserAccount Object | UserAccount Members


%%PageItemTitle%%

UserAccounts Collection
Members See Also Send comments

Glossary Item Box

Description

UserAccounts is a collection of UserAccount objects.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

UserAccounts Members


%%PageItemTitle%%

Count Property
UserAccounts Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

UserAccounts Collection | UserAccounts Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

UserAccounts Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As UserAccount

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

UserAccounts Collection | UserAccounts Members


%%PageItemTitle%%

UserGroup Object
Members See Also Send comments

Glossary Item Box

Description

A user group can contain users and other user groups.

Public Methods

Public Method AddMember | Adds a new member to the user group. Group IDs are negative, user IDs are positive.
Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method RemoveMember | Removes the specified member from the user group. Group IDs are negative, user IDs are positive.

Public Properties

Public Property ID | The ID of the user group.
Public Property Members | Members of the user group. Group IDs are negative, user IDs are positive.
Public Property Name | The name of the user group.
Public Property Predefined | Specifies whether the user group is a built-in user group.

Remarks

A list of user groups in M-Files Admin.

See Also

UserGroup Members


%%PageItemTitle%%

AddMember Method
ID
The ID of a user or a group to add. Group IDs must be entered as negative values.
UserGroup Object : AddMember Method

Glossary Item Box

Description

Adds a new member to the user group. Group IDs are negative, user IDs are positive.

Syntax

Visual Basic
Public Sub AddMember( _
   ByVal ID As Long _
)

Parameters

ID
The ID of a user or a group to add. Group IDs must be entered as negative values.

See Also

UserGroup Object | UserGroup Members


%%PageItemTitle%%

Clone Method
UserGroup Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As UserGroup

See Also

UserGroup Object | UserGroup Members


%%PageItemTitle%%

CloneFrom Method
UserGroup
UserGroup Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal UserGroup As UserGroup _
)

Parameters

UserGroup

See Also

UserGroup Object | UserGroup Members


%%PageItemTitle%%

RemoveMember Method
ID
The ID of a user or a group to remove. Group IDs must be entered as negative values.
UserGroup Object : RemoveMember Method

Glossary Item Box

Description

Removes the specified member from the user group. Group IDs are negative, user IDs are positive.

Syntax

Visual Basic
Public Sub RemoveMember( _
   ByVal ID As Long _
)

Parameters

ID
The ID of a user or a group to remove. Group IDs must be entered as negative values.

See Also

UserGroup Object | UserGroup Members


%%PageItemTitle%%

ID Property
UserGroup Object : ID Property

Glossary Item Box

Description

The ID of the user group.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

UserGroup Object | UserGroup Members


%%PageItemTitle%%

Members Property
UserGroup Object : Members Property

Glossary Item Box

Description

Members of the user group. Group IDs are negative, user IDs are positive.

Property type

Read-write property

Syntax

Visual Basic
Public Property Members As IDs

See Also

UserGroup Object | UserGroup Members


%%PageItemTitle%%

Name Property
UserGroup Object : Name Property

Glossary Item Box

Description

The name of the user group.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

UserGroup Object | UserGroup Members


%%PageItemTitle%%

Predefined Property
UserGroup Object : Predefined Property

Glossary Item Box

Description

Specifies whether the user group is a built-in user group.

Property type

Read-only property

Syntax

Visual Basic
Public Property Predefined As Boolean

See Also

UserGroup Object | UserGroup Members


%%PageItemTitle%%

UserGroupAdmin Object
Members See Also Send comments

Glossary Item Box

Description

A user group can contain users and other user groups (for administrative operations).

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.

Public Properties

Public Property AccessControlList | The definition of the access control list which controls visibility of user group.
Public Property ExternalRepositoryName | The identity of the external repository the group is associated with.
Public Property ExternalRepositorySubjectID | The identity of the external group this group is associated with.
Public Property SemanticAliases | The semantic aliases of this user group.
Public Property UserGroup | The user group.

See Also

UserGroupAdmin Members


%%PageItemTitle%%

Clone Method
UserGroupAdmin Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As UserGroupAdmin

See Also

UserGroupAdmin Object | UserGroupAdmin Members


%%PageItemTitle%%

CloneFrom Method
UserGroupAdmin
UserGroupAdmin Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal UserGroupAdmin As UserGroupAdmin _
)

Parameters

UserGroupAdmin

See Also

UserGroupAdmin Object | UserGroupAdmin Members


%%PageItemTitle%%

AccessControlList Property
UserGroupAdmin Object : AccessControlList Property

Glossary Item Box

Description

The definition of the access control list which controls visibility of user group.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessControlList As AccessControlList

See Also

UserGroupAdmin Object | UserGroupAdmin Members


%%PageItemTitle%%

ExternalRepositoryName Property
UserGroupAdmin Object : ExternalRepositoryName Property

Glossary Item Box

Description

The identity of the external repository the group is associated with.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryName As String

See Also

UserGroupAdmin Object | UserGroupAdmin Members


%%PageItemTitle%%

ExternalRepositorySubjectID Property
UserGroupAdmin Object : ExternalRepositorySubjectID Property

Glossary Item Box

Description

The identity of the external group this group is associated with.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositorySubjectID As String

See Also

UserGroupAdmin Object | UserGroupAdmin Members


%%PageItemTitle%%

SemanticAliases Property
UserGroupAdmin Object : SemanticAliases Property

Glossary Item Box

Description

The semantic aliases of this user group.

Property type

Read-write property

Syntax

Visual Basic
Public Property SemanticAliases As SemanticAliases

See Also

UserGroupAdmin Object | UserGroupAdmin Members


%%PageItemTitle%%

UserGroup Property
UserGroupAdmin Object : UserGroup Property

Glossary Item Box

Description

The user group.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserGroup As UserGroup

See Also

UserGroupAdmin Object | UserGroupAdmin Members


%%PageItemTitle%%

UserGroups Collection
Members See Also Send comments

Glossary Item Box

Description

UserGroups is a collection of UserGroup objects.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

UserGroups Members | UserGroup Object


%%PageItemTitle%%

Count Property
UserGroups Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

UserGroups Collection | UserGroups Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

UserGroups Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As UserGroup

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

UserGroups Collection | UserGroups Members


%%PageItemTitle%%

UserOrUserGroupID Object
Members See Also Send comments

Glossary Item Box

Description

The UserOrUserGroupID class represents a user or user group ID.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property UserOrGroupID | The id of a user or a user group.
Public Property UserOrGroupType | The type of a user or a user group.

See Also

UserOrUserGroupID Members


%%PageItemTitle%%

Clone Method
UserOrUserGroupID Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As UserOrUserGroupID

See Also

UserOrUserGroupID Object | UserOrUserGroupID Members


%%PageItemTitle%%

UserOrGroupID Property
UserOrUserGroupID Object : UserOrGroupID Property

Glossary Item Box

Description

The id of a user or a user group.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserOrGroupID As Long

See Also

UserOrUserGroupID Object | UserOrUserGroupID Members


%%PageItemTitle%%

UserOrGroupType Property
UserOrUserGroupID Object : UserOrGroupType Property

Glossary Item Box

Description

The type of a user or a user group.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserOrGroupType As MFUserOrUserGroupType

See Also

UserOrUserGroupID Object | UserOrUserGroupID Members


%%PageItemTitle%%

UserOrUserGroupIDEx Object
Members See Also Send comments

Glossary Item Box

Description

The UserOrUserGroupIDEx class represents a user or user group ID.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetIndirectPropertyPseudoUser | Sets the object to point to a pseudo-user based on an indirect property definition.
Public Method SetUserAccount | Sets the object to point to a user.
Public Method SetUserGroup | Sets the object to point to a user group.
Public Method SetWorkflowStatePseudoUser | Sets the object to point to a pseudo-user referred to by a workflow state.

Public Properties

Public Property IndirectProperty | Specifies the indirect property ID that specifies the user.
Public Property UserOrGroupID | Specifies the user or user group ID.
Public Property UserOrGroupType | Specifies the type of the contained user or user group ID.
Public Property WorkflowState | Specifies the pseudo-user ID when based on a workflow.

Remarks

Unlike UserOrUserGroupID, the UserOrUserGroupIDEx structure is able to define pseudo users through indirect property definitions and workflow states as well.

Regarding the "WorkflowState" property, the specified user is the user who moved the object to the specified state.

See Also

UserOrUserGroupIDEx Members


%%PageItemTitle%%

Clone Method
UserOrUserGroupIDEx Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As UserOrUserGroupIDEx

See Also

UserOrUserGroupIDEx Object | UserOrUserGroupIDEx Members


%%PageItemTitle%%

SetIndirectPropertyPseudoUser Method
PseudoUserID
UserOrUserGroupIDEx Object : SetIndirectPropertyPseudoUser Method

Glossary Item Box

Description

Sets the object to point to a pseudo-user based on an indirect property definition.

Syntax

Visual Basic
Public Sub SetIndirectPropertyPseudoUser( _
   ByVal PseudoUserID As IndirectPropertyID _
)

Parameters

PseudoUserID

See Also

UserOrUserGroupIDEx Object | UserOrUserGroupIDEx Members


%%PageItemTitle%%

SetUserAccount Method
UserAccount
UserOrUserGroupIDEx Object : SetUserAccount Method

Glossary Item Box

Description

Sets the object to point to a user.

Syntax

Visual Basic
Public Sub SetUserAccount( _
   ByVal UserAccount As Long _
)

Parameters

UserAccount

See Also

UserOrUserGroupIDEx Object | UserOrUserGroupIDEx Members


%%PageItemTitle%%

SetUserGroup Method
UserGroup
UserOrUserGroupIDEx Object : SetUserGroup Method

Glossary Item Box

Description

Sets the object to point to a user group.

Syntax

Visual Basic
Public Sub SetUserGroup( _
   ByVal UserGroup As Long _
)

Parameters

UserGroup

See Also

UserOrUserGroupIDEx Object | UserOrUserGroupIDEx Members


%%PageItemTitle%%

SetWorkflowStatePseudoUser Method
WorkflowState
UserOrUserGroupIDEx Object : SetWorkflowStatePseudoUser Method

Glossary Item Box

Description

Sets the object to point to a pseudo-user referred to by a workflow state.

Syntax

Visual Basic
Public Sub SetWorkflowStatePseudoUser( _
   ByVal WorkflowState As Long _
)

Parameters

WorkflowState

See Also

UserOrUserGroupIDEx Object | UserOrUserGroupIDEx Members


%%PageItemTitle%%

IndirectProperty Property
UserOrUserGroupIDEx Object : IndirectProperty Property

Glossary Item Box

Description

Specifies the indirect property ID that specifies the user.

Property type

Read-only property

Syntax

Visual Basic
Public Property IndirectProperty As IndirectPropertyID

See Also

UserOrUserGroupIDEx Object | UserOrUserGroupIDEx Members


%%PageItemTitle%%

UserOrGroupID Property
UserOrUserGroupIDEx Object : UserOrGroupID Property

Glossary Item Box

Description

Specifies the user or user group ID.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserOrGroupID As Long

See Also

UserOrUserGroupIDEx Object | UserOrUserGroupIDEx Members


%%PageItemTitle%%

UserOrGroupType Property
UserOrUserGroupIDEx Object : UserOrGroupType Property

Glossary Item Box

Description

Specifies the type of the contained user or user group ID.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserOrGroupType As MFUserOrUserGroupType

See Also

UserOrUserGroupIDEx Object | UserOrUserGroupIDEx Members


%%PageItemTitle%%

WorkflowState Property
UserOrUserGroupIDEx Object : WorkflowState Property

Glossary Item Box

Description

Specifies the pseudo-user ID when based on a workflow.

Property type

Read-only property

Syntax

Visual Basic
Public Property WorkflowState As Long

See Also

UserOrUserGroupIDEx Object | UserOrUserGroupIDEx Members


%%PageItemTitle%%

UserOrUserGroupIDExs Collection
Members See Also Send comments

Glossary Item Box

Description

The UserOrUserGroupIDExs class represents a collection of user or user group IDs.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method GetUserOrUserGroupIDEx | Gets user or group ID.
Public Method GetUserOrUserGroupIDExIndex | Gets user or group ID index. -1 indicates that item was not found.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

UserOrUserGroupIDExs Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
UserOrUserGroupIDEx
The new member to add.
UserOrUserGroupIDExs Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal UserOrUserGroupIDEx As UserOrUserGroupIDEx _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
UserOrUserGroupIDEx
The new member to add.

See Also

UserOrUserGroupIDExs Collection | UserOrUserGroupIDExs Members


%%PageItemTitle%%

Clone Method
UserOrUserGroupIDExs Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As UserOrUserGroupIDExs

See Also

UserOrUserGroupIDExs Collection | UserOrUserGroupIDExs Members


%%PageItemTitle%%

GetUserOrUserGroupIDEx Method
UserOrGroupID
UserOrGroupType
UserOrUserGroupIDExs Collection : GetUserOrUserGroupIDEx Method

Glossary Item Box

Description

Gets user or group ID.

Syntax

Visual Basic
Public Function GetUserOrUserGroupIDEx( _
   ByVal UserOrGroupID As Long, _
   ByVal UserOrGroupType As MFUserOrUserGroupType _
) As UserOrUserGroupIDEx

Parameters

UserOrGroupID
UserOrGroupType
Value | Description
MFUserOrUserGroupTypePropertyBasedPseudoUser | Property-based pseudo user. Indirectly specifies a user or users on the basis of a property value (meaning "the user(s) specified in the property X").
MFUserOrUserGroupTypePseudoUser | Worklow state pseudo user. Indirectly specifies a user on the basis of a state ID (meaning "the user who moved the object into state X").
MFUserOrUserGroupTypeUnknown | Unknown user type.
MFUserOrUserGroupTypeUserAccount | User account.
MFUserOrUserGroupTypeUserGroup | User group.

See Also

UserOrUserGroupIDExs Collection | UserOrUserGroupIDExs Members


%%PageItemTitle%%

GetUserOrUserGroupIDExIndex Method
UserOrGroupID
UserOrGroupType
UserOrUserGroupIDExs Collection : GetUserOrUserGroupIDExIndex Method

Glossary Item Box

Description

Gets user or group ID index. -1 indicates that item was not found.

Syntax

Visual Basic
Public Function GetUserOrUserGroupIDExIndex( _
   ByVal UserOrGroupID As Long, _
   ByVal UserOrGroupType As MFUserOrUserGroupType _
) As Long

Parameters

UserOrGroupID
UserOrGroupType
Value | Description
MFUserOrUserGroupTypePropertyBasedPseudoUser | Property-based pseudo user. Indirectly specifies a user or users on the basis of a property value (meaning "the user(s) specified in the property X").
MFUserOrUserGroupTypePseudoUser | Worklow state pseudo user. Indirectly specifies a user on the basis of a state ID (meaning "the user who moved the object into state X").
MFUserOrUserGroupTypeUnknown | Unknown user type.
MFUserOrUserGroupTypeUserAccount | User account.
MFUserOrUserGroupTypeUserGroup | User group.

See Also

UserOrUserGroupIDExs Collection | UserOrUserGroupIDExs Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
UserOrUserGroupIDExs Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

UserOrUserGroupIDExs Collection | UserOrUserGroupIDExs Members


%%PageItemTitle%%

Count Property
UserOrUserGroupIDExs Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

UserOrUserGroupIDExs Collection | UserOrUserGroupIDExs Members


%%PageItemTitle%%

Item Property
Index
UserOrUserGroupIDExs Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As UserOrUserGroupIDEx

Parameters

Index

See Also

UserOrUserGroupIDExs Collection | UserOrUserGroupIDExs Members


%%PageItemTitle%%

UserOrUserGroupIDs Collection
Members See Also Send comments

Glossary Item Box

Description

The UserOrUserGroupIDs class represents a collection of user or user group IDs.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method GetUserOrUserGroupID | Gets user or group ID.
Public Method GetUserOrUserGroupIDIndex | Gets user or group ID index. -1 indicates that item was not found.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

UserOrUserGroupIDs Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
UserOrUserGroupID
UserOrUserGroupIDs Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal UserOrUserGroupID As UserOrUserGroupID _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
UserOrUserGroupID

See Also

UserOrUserGroupIDs Collection | UserOrUserGroupIDs Members


%%PageItemTitle%%

Clone Method
UserOrUserGroupIDs Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As UserOrUserGroupIDs

See Also

UserOrUserGroupIDs Collection | UserOrUserGroupIDs Members


%%PageItemTitle%%

GetUserOrUserGroupID Method
UserOrGroupID
UserOrGroupType
UserOrUserGroupIDs Collection : GetUserOrUserGroupID Method

Glossary Item Box

Description

Gets user or group ID.

Syntax

Visual Basic
Public Function GetUserOrUserGroupID( _
   ByVal UserOrGroupID As Long, _
   ByVal UserOrGroupType As MFUserOrUserGroupType _
) As UserOrUserGroupID

Parameters

UserOrGroupID
UserOrGroupType
Value | Description
MFUserOrUserGroupTypePropertyBasedPseudoUser | Property-based pseudo user. Indirectly specifies a user or users on the basis of a property value (meaning "the user(s) specified in the property X").
MFUserOrUserGroupTypePseudoUser | Worklow state pseudo user. Indirectly specifies a user on the basis of a state ID (meaning "the user who moved the object into state X").
MFUserOrUserGroupTypeUnknown | Unknown user type.
MFUserOrUserGroupTypeUserAccount | User account.
MFUserOrUserGroupTypeUserGroup | User group.

See Also

UserOrUserGroupIDs Collection | UserOrUserGroupIDs Members


%%PageItemTitle%%

GetUserOrUserGroupIDIndex Method
UserOrGroupID
UserOrGroupType
UserOrUserGroupIDs Collection : GetUserOrUserGroupIDIndex Method

Glossary Item Box

Description

Gets user or group ID index. -1 indicates that item was not found.

Syntax

Visual Basic
Public Function GetUserOrUserGroupIDIndex( _
   ByVal UserOrGroupID As Long, _
   ByVal UserOrGroupType As MFUserOrUserGroupType _
) As Long

Parameters

UserOrGroupID
UserOrGroupType
Value | Description
MFUserOrUserGroupTypePropertyBasedPseudoUser | Property-based pseudo user. Indirectly specifies a user or users on the basis of a property value (meaning "the user(s) specified in the property X").
MFUserOrUserGroupTypePseudoUser | Worklow state pseudo user. Indirectly specifies a user on the basis of a state ID (meaning "the user who moved the object into state X").
MFUserOrUserGroupTypeUnknown | Unknown user type.
MFUserOrUserGroupTypeUserAccount | User account.
MFUserOrUserGroupTypeUserGroup | User group.

See Also

UserOrUserGroupIDs Collection | UserOrUserGroupIDs Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
UserOrUserGroupIDs Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

UserOrUserGroupIDs Collection | UserOrUserGroupIDs Members


%%PageItemTitle%%

Count Property
UserOrUserGroupIDs Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

UserOrUserGroupIDs Collection | UserOrUserGroupIDs Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
UserOrUserGroupIDs Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As UserOrUserGroupID

Parameters

Index
Specifies the item's position in the collection.

See Also

UserOrUserGroupIDs Collection | UserOrUserGroupIDs Members


%%PageItemTitle%%

Validation Object
Members See Also Send comments

Glossary Item Box

Description

The Validation class represents the validation specification for, e.g., a property definition.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property RegularExpression | A regular expression for the validation.
Public Property VBScript | VBScript code used in the validation.

Remarks

A property value validation settings.

See Also

Validation Members


%%PageItemTitle%%

Clone Method
Validation Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As Validation

See Also

Validation Object | Validation Members


%%PageItemTitle%%

RegularExpression Property
Validation Object : RegularExpression Property

Glossary Item Box

Description

A regular expression for the validation.

Property type

Read-write property

Syntax

Visual Basic
Public Property RegularExpression As String

See Also

Validation Object | Validation Members


%%PageItemTitle%%

VBScript Property
Validation Object : VBScript Property

Glossary Item Box

Description

VBScript code used in the validation.

Property type

Read-write property

Syntax

Visual Basic
Public Property VBScript As String

See Also

Validation Object | Validation Members


%%PageItemTitle%%

ValueListItem Object
Members See Also Send comments

Glossary Item Box

Description

A value list item is one item in a value list.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method GetIconAsPNG | Returns the icon of this value list item in PNG format scaled to the specified size.

Public Properties

Public Property AutomaticPermissionsForObjects | Specifies the automatic permissions for an object for which the user selects this item. If Nothing, no automatic permissions are defined.
Public Property Deleted | Specifies whether this value list item has been deleted.
Public Property DisplayID | The display ID of the value list item. This may differ from the numeric internal ID.
Public Property DisplayIDAvailable | Specifies whether the display ID is available.
Public Property ExternalRepositoryName | The external repository name of the value list item.
Public Property ExternalRepositoryObjectID | The external repository identifier of the value list item.
Public Property HasOwner | Specifies whether the value list item has an owner item.
Public Property HasParent | Specifies whether the value list item has a parent item.
Public Property Icon | If not NULL, contains the icon of this item in .ICO format.
Public Property ID | The ID of the value list item.
Public Property ItemGUID | The item GUID as a string.
Public Property Name | The name of the value list item.
Public Property ObjID | The object ID of the value list item.
Public Property OwnerID | The owner item ID of the value list item.
Public Property ParentID | The parent item ID of the value list item.
Public Property ValueListID | The ID of the value list.

Remarks

Use the VaultValueListItemOperations interface to access value list item objects.

A list of value list items as seen in M-Files Admin.

See Also

ValueListItem Members


%%PageItemTitle%%

Clone Method
ValueListItem Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ValueListItem

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

CloneFrom Method
ValueListItem
ValueListItem Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal ValueListItem As ValueListItem _
)

Parameters

ValueListItem

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

GetIconAsPNG Method
Width
Height
ValueListItem Object : GetIconAsPNG Method

Glossary Item Box

Description

Returns the icon of this value list item in PNG format scaled to the specified size.

Syntax

Visual Basic
Public Function GetIconAsPNG( _
   ByVal Width As Long, _
   ByVal Height As Long _
) As Byte()

Parameters

Width
Height

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

AutomaticPermissionsForObjects Property
ValueListItem Object : AutomaticPermissionsForObjects Property

Glossary Item Box

Description

Specifies the automatic permissions for an object for which the user selects this item. If Nothing, no automatic permissions are defined.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutomaticPermissionsForObjects As AutomaticPermissions

Return Type

AutomaticPermissions structure describing the current automatic permission settings or null value (Nothing in Visual Basic) if no automatic permissions are specified.

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

Deleted Property
ValueListItem Object : Deleted Property

Glossary Item Box

Description

Specifies whether this value list item has been deleted.

Property type

Read-only property

Syntax

Visual Basic
Public Property Deleted As Boolean

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

DisplayID Property
ValueListItem Object : DisplayID Property

Glossary Item Box

Description

The display ID of the value list item. This may differ from the numeric internal ID.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayID As String

Remarks

If the value list item is imported from an external database, the display ID is the object's ID in the external database.

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

DisplayIDAvailable Property
ValueListItem Object : DisplayIDAvailable Property

Glossary Item Box

Description

Specifies whether the display ID is available.

Property type

Read-only property

Syntax

Visual Basic
Public Property DisplayIDAvailable As Boolean

Remarks

If the value list item is imported from an external database, the display ID is the object's ID in the external database.

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

ExternalRepositoryName Property
ValueListItem Object : ExternalRepositoryName Property

Glossary Item Box

Description

The external repository name of the value list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryName As String

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

ExternalRepositoryObjectID Property
ValueListItem Object : ExternalRepositoryObjectID Property

Glossary Item Box

Description

The external repository identifier of the value list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalRepositoryObjectID As String

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

HasOwner Property
ValueListItem Object : HasOwner Property

Glossary Item Box

Description

Specifies whether the value list item has an owner item.

Property type

Read-write property

Syntax

Visual Basic
Public Property HasOwner As Boolean

Remarks

True if the value list item has an owner item. If the item has an owner, this value list must be a sub-list of another value list or object type.

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

HasParent Property
ValueListItem Object : HasParent Property

Glossary Item Box

Description

Specifies whether the value list item has a parent item.

Property type

Read-write property

Syntax

Visual Basic
Public Property HasParent As Boolean

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

Icon Property
ValueListItem Object : Icon Property

Glossary Item Box

Description

If not NULL, contains the icon of this item in .ICO format.

Property type

Read-write property

Syntax

Visual Basic
Public Property Icon As Byte()

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

ID Property
ValueListItem Object : ID Property

Glossary Item Box

Description

The ID of the value list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

ItemGUID Property
ValueListItem Object : ItemGUID Property

Glossary Item Box

Description

The item GUID as a string.

Property type

Read-only property

Syntax

Visual Basic
Public Property ItemGUID As String

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

Name Property
ValueListItem Object : Name Property

Glossary Item Box

Description

The name of the value list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

ObjID Property
ValueListItem Object : ObjID Property

Glossary Item Box

Description

The object ID of the value list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjID As ObjID

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

OwnerID Property
ValueListItem Object : OwnerID Property

Glossary Item Box

Description

The owner item ID of the value list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property OwnerID As Long

Remarks

The ID of the owner of this value list item refers to a value list item in another value list or object. To resolve the owner item, the owner object type must be resolved first.

Use the ValueListID property to get the ID of the value list and resolve the ObjType object for this value list by using the GetObjectType method. Then use the OwnerType method to resolve the ID of the owner value list or object type.

If the owner type is a real object type, you can use the VaultObjectOperations interface to locate the owner object. If the owner type is a value list, use the VaultValueListItemOperations interface to locate the owner value list item.

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

ParentID Property
ValueListItem Object : ParentID Property

Glossary Item Box

Description

The parent item ID of the value list item.

Property type

Read-write property

Syntax

Visual Basic
Public Property ParentID As Long

Remarks

Available if the value list is hierarchical. The parent ID refers to the parent value list item in the same value list. Use the VaultValueListItemOperations interface to receive the ValueListItem object for the parent ID.

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

ValueListID Property
ValueListItem Object : ValueListID Property

Glossary Item Box

Description

The ID of the value list.

Property type

Read-write property

Syntax

Visual Basic
Public Property ValueListID As Long

Remarks

Value list is an object type. Use the VaultObjectTypeOperations interface to get the ObjType object for the value list ID.

See Also

ValueListItem Object | ValueListItem Members


%%PageItemTitle%%

ValueListItems Collection
Members See Also Send comments

Glossary Item Box

Description

ValueListItems is a collection of ValueListItem objects.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ValueListItems Members | ValueListItem Object


%%PageItemTitle%%

Clone Method
ValueListItems Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ValueListItems

See Also

ValueListItems Collection | ValueListItems Members


%%PageItemTitle%%

Count Property
ValueListItems Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ValueListItems Collection | ValueListItems Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

ValueListItems Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ValueListItem

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

ValueListItems Collection | ValueListItems Members


%%PageItemTitle%%

ValueListItemSearchResults Collection
Members See Also Send comments

Glossary Item Box

Description

The ValueListItemSearchResults class represents value list item search results.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.
Public Property MoreResults | Specifies whether additional results are available.

See Also

ValueListItemSearchResults Members


%%PageItemTitle%%

Add Method
Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

ValueListItem
The value list item to be added.
ValueListItemSearchResults Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal ValueListItem As ValueListItem _
)

Parameters

Index

The position where the new collection member is added. The indexes of the members at and after this position will be increased by one.

The first element in the collection has the index of 1.

Any non-valid position (e.g. -1) implies appending.

ValueListItem
The value list item to be added.

See Also

ValueListItemSearchResults Collection | ValueListItemSearchResults Members


%%PageItemTitle%%

Clone Method
ValueListItemSearchResults Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ValueListItemSearchResults

See Also

ValueListItemSearchResults Collection | ValueListItemSearchResults Members


%%PageItemTitle%%

Remove Method
Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

ValueListItemSearchResults Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index

The position from where the collection member will be removed. The indexes of the members after this position will be decreased by one.

The first element in the collection has the index of 1.

See Also

ValueListItemSearchResults Collection | ValueListItemSearchResults Members


%%PageItemTitle%%

Count Property
ValueListItemSearchResults Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

ValueListItemSearchResults Collection | ValueListItemSearchResults Members


%%PageItemTitle%%

Item Property
Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

ValueListItemSearchResults Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As ValueListItem

Parameters

Index

Specifies the item's position in the collection.

The first element in the collection has the index of 1.

See Also

ValueListItemSearchResults Collection | ValueListItemSearchResults Members


%%PageItemTitle%%

MoreResults Property
ValueListItemSearchResults Collection : MoreResults Property

Glossary Item Box

Description

Specifies whether additional results are available.

Property type

Read-write property

Syntax

Visual Basic
Public Property MoreResults As Boolean

See Also

ValueListItemSearchResults Collection | ValueListItemSearchResults Members


%%PageItemTitle%%

ValueListItemSearchResultsWithPermissions Object
Members See Also Send comments

Glossary Item Box

Description

ValueListItemSearchResultsWithPermissions encapsulates value list item search results and their permissions.

Public Properties

Public Property Permissions | The permissions of the value list items.
Public Property ValueListItemSearchResults | The value list items.

See Also

ValueListItemSearchResultsWithPermissions Members


%%PageItemTitle%%

Permissions Property
ValueListItemSearchResultsWithPermissions Object : Permissions Property

Glossary Item Box

Description

The permissions of the value list items.

Property type

Read-only property

Syntax

Visual Basic
Public Property Permissions As AccessControlLists

See Also

ValueListItemSearchResultsWithPermissions Object | ValueListItemSearchResultsWithPermissions Members


%%PageItemTitle%%

ValueListItemSearchResults Property
ValueListItemSearchResultsWithPermissions Object : ValueListItemSearchResults Property

Glossary Item Box

Description

The value list items.

Property type

Read-only property

Syntax

Visual Basic
Public Property ValueListItemSearchResults As ValueListItemSearchResults

See Also

ValueListItemSearchResultsWithPermissions Object | ValueListItemSearchResultsWithPermissions Members


%%PageItemTitle%%

ValueListItemsWithPermissions Object
Members See Also Send comments

Glossary Item Box

Description

ValueListItemsWithPermissions encapsulates value list items and their permissions.

Public Properties

Public Property Permissions | The permissions of the value list items.
Public Property ValueListItems | The value list items.

See Also

ValueListItemsWithPermissions Members


%%PageItemTitle%%

Permissions Property
ValueListItemsWithPermissions Object : Permissions Property

Glossary Item Box

Description

The permissions of the value list items.

Property type

Read-only property

Syntax

Visual Basic
Public Property Permissions As AccessControlLists

See Also

ValueListItemsWithPermissions Object | ValueListItemsWithPermissions Members


%%PageItemTitle%%

ValueListItems Property
ValueListItemsWithPermissions Object : ValueListItems Property

Glossary Item Box

Description

The value list items.

Property type

Read-only property

Syntax

Visual Basic
Public Property ValueListItems As ValueListItems

See Also

ValueListItemsWithPermissions Object | ValueListItemsWithPermissions Members


%%PageItemTitle%%

Vault Object
Members See Also Send comments

Glossary Item Box

Description

The Vault class represents the document vault.

Public Methods

Public Method ChangePassword | Changes the password of the current user.
Public Method DetachSession | Detaches the current session from this vault object without logging out the session.
Public Method DisconnectDevice | Disconnects the specified device of the logged-in user from the server.
Public Method GetAllTranslations | Gets all vault translations as JSON.
Public Method GetGUID | Gets the GUID of the vault on the server.
Public Method GetMetadataStructureItemIDByAlias | Receives the ID of the metadata structure element with the specified alias.
Public Method GetMetadataStructureItemIDsByAliases | Get the metadata structure item's IDs and aliases.
Public Method GetMetadataStructureVersionID | Receives the metadata structure version ID of the vault. This ID is incremented when the structure of the vault is changed.
Public Method GetMFilesURLForVaultRoot | Gets the URL to the vault root.
Public Method GetServerLicenseStatus | Gets the server license status.
Public Method GetServerVersionOfVault | Receives the version of the server where the vault resides.
Public Method GetVaultServerAttachments | Gets the vault server attachments.
Public Method LogOutSilent | Performs a silent logout.
Public Method LogOutWithDialogs | Logs out from vault. May display dialog boxes during the logout.
Public Method Restart | Restarts the vault.
Public Method TestConnectionToServer | Tests the connection to the server.
Public Method TestConnectionToVault | Tests the connection to the vault.
Public Method TestConnectionToVaultWithTimeout | Tests the connection to the vault.

Public Properties

Public Property AutomaticMetadataOperations | Gets the automatic metadata operations interface.
Public Property ClassGroupOperations | Gets the class group operations interface.
Public Property ClassOperations | Gets the class operations interface.
Public Property ClientOperations | Gets the client operations interface.
Public Property CurrentLoggedInUserID | The ID of the current logged-in user.
Public Property CustomApplicationManagementOperations | Gets the custom application management operations interface.
Public Property DataSetOperations | Gets the data set export operations interface.
Public Property ElectronicSignatureOperations | Gets the electronic signature operations interface.
Public Property EventLogOperations | Gets the event log operations interface.
Public Property ExtensionAuthenticationOperations | Gets the extension authentication operations interface.
Public Property ExtensionMethodOperations | Gets the vault extension method operations interface.
Public Property ExternalObjectOperations | Gets the external object operations interface.
Public Property LoggedIn | Specifies whether a user has logged into the vault.
Public Property LoginAccountOperations | Gets the vault login account operations interface.
Public Property LoginSessionID | The session ID as string.
Public Property ManagementOperations | Gets the management operations interface.
Public Property Name | The name of this vault. In client mode, returns the name of the vault connection. In server mode, returns the name of the vault on server.
Public Property NamedACLOperations | Gets the named access control list operations interface.
Public Property NamedValueStorageOperations | Gets the named value storage interface.
Public Property NotificationOperations | Receives the interface for vault notification operations.
Public Property ObjectFileOperations | Gets the object file operations interface.
Public Property ObjectOperations | Gets the object operations interface.
Public Property ObjectPropertyOperations | Gets the object property operations interface.
Public Property ObjectSearchOperations | Gets the object search operations interface.
Public Property ObjectTypeOperations | Gets the object type operations interface.
Public Property PropertyDefOperations | Gets the property definition operations interface.
Public Property ReadOnlyAccess | Specifies whether the user has read-only access to the vault.
Public Property ScheduledJobManagementOperations | Gets the scheduled job management operations interface.
Public Property ServerDataPushOperations | Receives the interface for vault server data push operations.
Public Property SessionInfo | Information about the current session.
Public Property SharedLinkOperations | Gets the public link operations interface.
Public Property TraditionalFolderOperations | Gets the traditional folder operations interface.
Public Property UserGroupOperations | Gets the user group operations interface.
Public Property UserOperations | Gets the user operations interface.
Public Property UserOperationsEx | Gets the advanced user operations interface.
Public Property UserSettingOperations | Gets the user setting operations interface.
Public Property ValueListItemOperations | Gets the value list item operations interface.
Public Property ValueListOperations | Gets the value list operations interface.
Public Property VaultLanguages | Gets all languages of vault.
Public Property VaultWOPIOperations | Gets the public link operations interface.
Public Property ViewOperations | Gets the view operations interface.
Public Property WorkflowOperations | Gets the workflow operations interface.

Remarks

The vault class interface contains vault-specific methods and properties. In addition, the vault class contains properties for accessing various operation interfaces. The main functionality of M-Files API is grouped into these operation interfaces. Therefore, it is practical to keep the vault object handy, as the operation interfaces are easily referred through the vault object

See Also

Vault Members


%%PageItemTitle%%

ChangePassword Method
OldPassword
NewPassword
Vault Object : ChangePassword Method

Glossary Item Box

Description

Changes the password of the current user.

Syntax

Visual Basic
Public Sub ChangePassword( _
   ByVal OldPassword As String, _
   ByVal NewPassword As String _
)

Parameters

OldPassword
NewPassword

See Also

Vault Object | Vault Members


%%PageItemTitle%%

DetachSession Method
Vault Object : DetachSession Method

Glossary Item Box

Description

Detaches the current session from this vault object without logging out the session.

Syntax

Visual Basic
Public Function DetachSession() As String

Remarks

Requires M-Files 19.3.7499.1 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

DisconnectDevice Method
DeviceToken
The device token of the device to be disconnected from the server.
Vault Object : DisconnectDevice Method

Glossary Item Box

Description

Disconnects the specified device of the logged-in user from the server.

Syntax

Visual Basic
Public Sub DisconnectDevice( _
   ByVal DeviceToken As String _
)

Parameters

DeviceToken
The device token of the device to be disconnected from the server.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

GetAllTranslations Method
Vault Object : GetAllTranslations Method

Glossary Item Box

Description

Gets all vault translations as JSON.

Syntax

Visual Basic
Public Function GetAllTranslations() As String

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

GetGUID Method
Vault Object : GetGUID Method

Glossary Item Box

Description

Gets the GUID of the vault on the server.

Syntax

Visual Basic
Public Function GetGUID() As String

Return Type

The GUID of the vault in the server as a string.

Remarks

The GUID is returned in the following format: "{AD3964E8-8DA2-47a4-9D45-7D9371DFF077}"

See Also

Vault Object | Vault Members


%%PageItemTitle%%

GetMetadataStructureItemIDByAlias Method
MetadataStructureItemType
Metadata structure item type.
Alias
Alias to look for.
Unused
Vault Object : GetMetadataStructureItemIDByAlias Method

Glossary Item Box

Description

Receives the ID of the metadata structure element with the specified alias.

Syntax

Visual Basic
Public Function GetMetadataStructureItemIDByAlias( _
   ByVal MetadataStructureItemType As MFMetadataStructureItem, _
   ByVal Alias As String, _
   Optional ByVal Unused As Boolean = True _
) As Long

Parameters

MetadataStructureItemType
Value | Description
MFMetadataStructureItemClass | Class
MFMetadataStructureItemClassGroup | Class group.
MFMetadataStructureItemNamedACL | Named access control list.
MFMetadataStructureItemNone | None.
MFMetadataStructureItemObjectType | Object type. This can imply either a real object type or a value list.
MFMetadataStructureItemPropertyDef | Property definition.
MFMetadataStructureItemState | State.
MFMetadataStructureItemStateTransition | State transition.
MFMetadataStructureItemUser | User.
MFMetadataStructureItemUserGroup | User group.
MFMetadataStructureItemValueList | Value list.
MFMetadataStructureItemValueListItem | Value list item.
MFMetadataStructureItemVaultEventHandler | Vault-specific event handler.
MFMetadataStructureItemViewDef | View definition.
MFMetadataStructureItemWorkflow | Workflow.
Metadata structure item type.
Alias
Alias to look for.
Unused

Remarks

Returns -1 if a match is not found or if more than one item uses the specified alias.

For named ACLs, -1000 is returned if a match is not found or if more than one item uses the specified alias.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

GetMetadataStructureItemIDsByAliases Method
MetadataStructureItemType
The type of the metadata structure item.
bUnambiguousAliasesOnly
Set to true to get only aliases that map to exactly one item ID.
Vault Object : GetMetadataStructureItemIDsByAliases Method

Glossary Item Box

Description

Get the metadata structure item's IDs and aliases.

Syntax

Visual Basic
Public Function GetMetadataStructureItemIDsByAliases( _
   ByVal MetadataStructureItemType As MFMetadataStructureItem, _
   ByVal bUnambiguousAliasesOnly As Boolean _
) As MetadataStructureAliases

Parameters

MetadataStructureItemType
Value | Description
MFMetadataStructureItemClass | Class
MFMetadataStructureItemClassGroup | Class group.
MFMetadataStructureItemNamedACL | Named access control list.
MFMetadataStructureItemNone | None.
MFMetadataStructureItemObjectType | Object type. This can imply either a real object type or a value list.
MFMetadataStructureItemPropertyDef | Property definition.
MFMetadataStructureItemState | State.
MFMetadataStructureItemStateTransition | State transition.
MFMetadataStructureItemUser | User.
MFMetadataStructureItemUserGroup | User group.
MFMetadataStructureItemValueList | Value list.
MFMetadataStructureItemValueListItem | Value list item.
MFMetadataStructureItemVaultEventHandler | Vault-specific event handler.
MFMetadataStructureItemViewDef | View definition.
MFMetadataStructureItemWorkflow | Workflow.
The type of the metadata structure item.
bUnambiguousAliasesOnly
Set to true to get only aliases that map to exactly one item ID.

Remarks

Supported in M-Files 21.10.10632.0 and later.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

GetMetadataStructureVersionID Method
Vault Object : GetMetadataStructureVersionID Method

Glossary Item Box

Description

Receives the metadata structure version ID of the vault. This ID is incremented when the structure of the vault is changed.

Syntax

Visual Basic
Public Function GetMetadataStructureVersionID() As Long

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

GetMFilesURLForVaultRoot Method
Vault Object : GetMFilesURLForVaultRoot Method

Glossary Item Box

Description

Gets the URL to the vault root.

Syntax

Visual Basic
Public Function GetMFilesURLForVaultRoot() As String

See Also

Vault Object | Vault Members


%%PageItemTitle%%

GetServerLicenseStatus Method
Vault Object : GetServerLicenseStatus Method

Glossary Item Box

Description

Gets the server license status.

Syntax

Visual Basic
Public Function GetServerLicenseStatus() As LicenseStatus

See Also

Vault Object | Vault Members


%%PageItemTitle%%

GetServerVersionOfVault Method
Vault Object : GetServerVersionOfVault Method

Glossary Item Box

Description

Receives the version of the server where the vault resides.

Syntax

Visual Basic
Public Function GetServerVersionOfVault() As MFilesVersion

See Also

Vault Object | Vault Members


%%PageItemTitle%%

GetVaultServerAttachments Method
Vault Object : GetVaultServerAttachments Method

Glossary Item Box

Description

Gets the vault server attachments.

Syntax

Visual Basic
Public Function GetVaultServerAttachments() As VaultServerAttachments

Remarks

Supported in M-Files 20.3.8876.4 and newer.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

LogOutSilent Method
Vault Object : LogOutSilent Method

Glossary Item Box

Description

Performs a silent logout.

Syntax

Visual Basic
Public Sub LogOutSilent()

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

LogOutWithDialogs Method
ParentWindow
Vault Object : LogOutWithDialogs Method

Glossary Item Box

Description

Logs out from vault. May display dialog boxes during the logout.

Syntax

Visual Basic
Public Function LogOutWithDialogs( _
   ByVal ParentWindow As Long _
) As Boolean

Parameters

ParentWindow

Return Type

True if the logout was successful.

Remarks

The user may cancel the logout during offline preparations or if a document is open in a third-party application.

This method is available only if M-Files API is used in the client interface mode.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

Restart Method
Vault Object : Restart Method

Glossary Item Box

Description

Restarts the vault.

Syntax

Visual Basic
Public Sub Restart()

Remarks

Requires M-Files 19.11.8480.0 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

TestConnectionToServer Method
Vault Object : TestConnectionToServer Method

Glossary Item Box

Description

Tests the connection to the server.

Syntax

Visual Basic
Public Sub TestConnectionToServer()

Remarks

This method tests the end-to-end RPC connection to the server. This method does not require any authentication, and it does not do anything else. It raises an error if the server connection test fail.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

TestConnectionToVault Method
Vault Object : TestConnectionToVault Method

Glossary Item Box

Description

Tests the connection to the vault.

Syntax

Visual Basic
Public Sub TestConnectionToVault()

Remarks

This method tests the end-to-end connection to the server vault. Other than validating the session to the server vault, this method does nothing. It raises an error if the vault connection test fail.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

TestConnectionToVaultWithTimeout Method
TimeoutInMilliseconds
Vault Object : TestConnectionToVaultWithTimeout Method

Glossary Item Box

Description

Tests the connection to the vault.

Syntax

Visual Basic
Public Sub TestConnectionToVaultWithTimeout( _
   ByVal TimeoutInMilliseconds As Long _
)

Parameters

TimeoutInMilliseconds

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

AutomaticMetadataOperations Property
Vault Object : AutomaticMetadataOperations Property

Glossary Item Box

Description

Gets the automatic metadata operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property AutomaticMetadataOperations As VaultAutomaticMetadataOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ClassGroupOperations Property
Vault Object : ClassGroupOperations Property

Glossary Item Box

Description

Gets the class group operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ClassGroupOperations As VaultClassGroupOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ClassOperations Property
Vault Object : ClassOperations Property

Glossary Item Box

Description

Gets the class operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ClassOperations As VaultClassOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ClientOperations Property
Vault Object : ClientOperations Property

Glossary Item Box

Description

Gets the client operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ClientOperations As VaultClientOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

CurrentLoggedInUserID Property
Vault Object : CurrentLoggedInUserID Property

Glossary Item Box

Description

The ID of the current logged-in user.

Property type

Read-only property

Syntax

Visual Basic
Public Property CurrentLoggedInUserID As Long

See Also

Vault Object | Vault Members


%%PageItemTitle%%

CustomApplicationManagementOperations Property
Vault Object : CustomApplicationManagementOperations Property

Glossary Item Box

Description

Gets the custom application management operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property CustomApplicationManagementOperations As VaultCustomApplicationManagementOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

DataSetOperations Property
Vault Object : DataSetOperations Property

Glossary Item Box

Description

Gets the data set export operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property DataSetOperations As VaultDataSetOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ElectronicSignatureOperations Property
Vault Object : ElectronicSignatureOperations Property

Glossary Item Box

Description

Gets the electronic signature operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ElectronicSignatureOperations As VaultElectronicSignatureOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

EventLogOperations Property
Vault Object : EventLogOperations Property

Glossary Item Box

Description

Gets the event log operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property EventLogOperations As VaultEventLogOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ExtensionAuthenticationOperations Property
Vault Object : ExtensionAuthenticationOperations Property

Glossary Item Box

Description

Gets the extension authentication operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExtensionAuthenticationOperations As VaultExtensionAuthenticationOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ExtensionMethodOperations Property
Vault Object : ExtensionMethodOperations Property

Glossary Item Box

Description

Gets the vault extension method operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExtensionMethodOperations As VaultExtensionMethodOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ExternalObjectOperations Property
Vault Object : ExternalObjectOperations Property

Glossary Item Box

Description

Gets the external object operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ExternalObjectOperations As VaultExternalObjectOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

LoggedIn Property
Vault Object : LoggedIn Property

Glossary Item Box

Description

Specifies whether a user has logged into the vault.

Property type

Read-only property

Syntax

Visual Basic
Public Property LoggedIn As Boolean

See Also

Vault Object | Vault Members


%%PageItemTitle%%

LoginAccountOperations Property
Vault Object : LoginAccountOperations Property

Glossary Item Box

Description

Gets the vault login account operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property LoginAccountOperations As VaultLoginAccountOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

LoginSessionID Property
Vault Object : LoginSessionID Property

Glossary Item Box

Description

The session ID as string.

Property type

Read-only property

Syntax

Visual Basic
Public Property LoginSessionID As String

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ManagementOperations Property
Vault Object : ManagementOperations Property

Glossary Item Box

Description

Gets the management operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ManagementOperations As VaultManagementOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

Name Property
Vault Object : Name Property

Glossary Item Box

Description

The name of this vault. In client mode, returns the name of the vault connection. In server mode, returns the name of the vault on server.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

Vault Object | Vault Members


%%PageItemTitle%%

NamedACLOperations Property
Vault Object : NamedACLOperations Property

Glossary Item Box

Description

Gets the named access control list operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property NamedACLOperations As VaultNamedACLOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

NamedValueStorageOperations Property
Vault Object : NamedValueStorageOperations Property

Glossary Item Box

Description

Gets the named value storage interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property NamedValueStorageOperations As VaultNamedValueStorageOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

NotificationOperations Property
Vault Object : NotificationOperations Property

Glossary Item Box

Description

Receives the interface for vault notification operations.

Property type

Read-only property

Syntax

Visual Basic
Public Property NotificationOperations As VaultNotificationOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ObjectFileOperations Property
Vault Object : ObjectFileOperations Property

Glossary Item Box

Description

Gets the object file operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectFileOperations As VaultObjectFileOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ObjectOperations Property
Vault Object : ObjectOperations Property

Glossary Item Box

Description

Gets the object operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectOperations As VaultObjectOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ObjectPropertyOperations Property
Vault Object : ObjectPropertyOperations Property

Glossary Item Box

Description

Gets the object property operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectPropertyOperations As VaultObjectPropertyOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ObjectSearchOperations Property
Vault Object : ObjectSearchOperations Property

Glossary Item Box

Description

Gets the object search operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectSearchOperations As VaultObjectSearchOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ObjectTypeOperations Property
Vault Object : ObjectTypeOperations Property

Glossary Item Box

Description

Gets the object type operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjectTypeOperations As VaultObjectTypeOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

PropertyDefOperations Property
Vault Object : PropertyDefOperations Property

Glossary Item Box

Description

Gets the property definition operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property PropertyDefOperations As VaultPropertyDefOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ReadOnlyAccess Property
Vault Object : ReadOnlyAccess Property

Glossary Item Box

Description

Specifies whether the user has read-only access to the vault.

Property type

Read-only property

Syntax

Visual Basic
Public Property ReadOnlyAccess As Boolean

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ScheduledJobManagementOperations Property
Vault Object : ScheduledJobManagementOperations Property

Glossary Item Box

Description

Gets the scheduled job management operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ScheduledJobManagementOperations As VaultScheduledJobManagementOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ServerDataPushOperations Property
Vault Object : ServerDataPushOperations Property

Glossary Item Box

Description

Receives the interface for vault server data push operations.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerDataPushOperations As VaultServerDataPushOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

SessionInfo Property
Vault Object : SessionInfo Property

Glossary Item Box

Description

Information about the current session.

Property type

Read-only property

Syntax

Visual Basic
Public Property SessionInfo As SessionInfo

See Also

Vault Object | Vault Members


%%PageItemTitle%%

SharedLinkOperations Property
Vault Object : SharedLinkOperations Property

Glossary Item Box

Description

Gets the public link operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property SharedLinkOperations As VaultSharedLinkOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

TraditionalFolderOperations Property
Vault Object : TraditionalFolderOperations Property

Glossary Item Box

Description

Gets the traditional folder operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property TraditionalFolderOperations As VaultTraditionalFolderOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

UserGroupOperations Property
Vault Object : UserGroupOperations Property

Glossary Item Box

Description

Gets the user group operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserGroupOperations As VaultUserGroupOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

UserOperations Property
Vault Object : UserOperations Property

Glossary Item Box

Description

Gets the user operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserOperations As VaultUserOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

UserOperationsEx Property
Vault Object : UserOperationsEx Property

Glossary Item Box

Description

Gets the advanced user operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserOperationsEx As VaultUserOperationsEx

Remarks

Requires M-Files 19.1.7279.4 or later.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

UserSettingOperations Property
Vault Object : UserSettingOperations Property

Glossary Item Box

Description

Gets the user setting operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserSettingOperations As VaultUserSettingOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ValueListItemOperations Property
Vault Object : ValueListItemOperations Property

Glossary Item Box

Description

Gets the value list item operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ValueListItemOperations As VaultValueListItemOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ValueListOperations Property
Vault Object : ValueListOperations Property

Glossary Item Box

Description

Gets the value list operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ValueListOperations As VaultValueListOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

VaultLanguages Property
Vault Object : VaultLanguages Property

Glossary Item Box

Description

Gets all languages of vault.

Property type

Read-only property

Syntax

Visual Basic
Public Property VaultLanguages As Languages

See Also

Vault Object | Vault Members


%%PageItemTitle%%

VaultWOPIOperations Property
Vault Object : VaultWOPIOperations Property

Glossary Item Box

Description

Gets the public link operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property VaultWOPIOperations As VaultWOPIOperations

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

Vault Object | Vault Members


%%PageItemTitle%%

ViewOperations Property
Vault Object : ViewOperations Property

Glossary Item Box

Description

Gets the view operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property ViewOperations As VaultViewOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

WorkflowOperations Property
Vault Object : WorkflowOperations Property

Glossary Item Box

Description

Gets the workflow operations interface.

Property type

Read-only property

Syntax

Visual Basic
Public Property WorkflowOperations As VaultWorkflowOperations

See Also

Vault Object | Vault Members


%%PageItemTitle%%

VaultApplicationTaskOperations Object
Members See Also Send comments

Glossary Item Box

Description

The "VaultApplicationTaskOperations" class is an interface for accessing the application task queue operations on the server.

Public Methods

Public Method AddScheduledTask | Adds a scheduled task to a task queue. The "ApplicationTaskInfo" object must contain the ID of the task queue to which the task is to be added.
Public Method AddTask | Adds a task to a task queue. The "ApplicationTaskInfo" object must contain the ID of the task queue to which the task is to be added.
Public Method GetLatestBroadcastMessageIdentifiers | Gets the IDs of the most recent broadcast messages from the given queues.
Public Method GetNewBroadcastMessages | Gets the broadcast messages that have been sent since the specified broadcast message ID.
Public Method GetTaskIDsFromQueue | Gets the list of task IDs from a task queue.
Public Method GetTaskQueues | Gets the list of available task queues from the server.
Public Method GetTasks | Gets task objects from the server. This does not reserve any tasks for processing, meaning that their states can still change on the server.
Public Method OpenTaskQueue | Opens a new task queue. When the application no longer needs the queue, it can simply stop using it. The server automatically closes the queue when instances stop using it.
Public Method ReserveTasksForProcessing | Reserves the next tasks for processing from the task queues.
Public Method SendBroadcastMessage | Sends a broadcast message to a task queue.
Public Method UpdateTask | Updates the task information to the server.

Remarks

Requires M-Files 19.3.7499.1 or later.

See Also

VaultApplicationTaskOperations Members


%%PageItemTitle%%

AddScheduledTask Method
QueueID
The ID of the task queue to which the new task is to be added.
RestoreToWaitingTimeoutInMinutes
The timeout in minutes after which the task is set to the waiting state.
TaskType
The task type. This can be used as an identifier for how the task data should be interpreted.
TaskData
The payload of the task.
ActivationTimestamp
The earliest time the task can be reserved for processing.
VaultApplicationTaskOperations Object : AddScheduledTask Method

Glossary Item Box

Description

Adds a scheduled task to a task queue. The "ApplicationTaskInfo" object must contain the ID of the task queue to which the task is to be added.

Syntax

Visual Basic
Public Function AddScheduledTask( _
   ByVal QueueID As String, _
   ByVal RestoreToWaitingTimeoutInMinutes As Long, _
   ByVal TaskType As String, _
   ByVal TaskData() As Byte, _
   ByVal ActivationTimestamp As Timestamp _
) As String

Parameters

QueueID
The ID of the task queue to which the new task is to be added.
RestoreToWaitingTimeoutInMinutes
The timeout in minutes after which the task is set to the waiting state.
TaskType
The task type. This can be used as an identifier for how the task data should be interpreted.
TaskData
The payload of the task.
ActivationTimestamp
The earliest time the task can be reserved for processing.

Remarks

Supported in M-Files 19.7.8028.5 and later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultApplicationTaskOperations Object | VaultApplicationTaskOperations Members


%%PageItemTitle%%

AddTask Method
QueueID
The ID of the task queue to which the new task is to be added.
RestoreToWaitingTimeoutInMinutes
The number of minutes to wait before moving the task to the waiting state if the instance carrying it out has not reported to the server that it is still in progress. In the waiting state, the task is idle and waits to be selected for processing.
TaskType
The task type can be used as an identifier for how the task data should be interpreted.
TaskData
The payload of the task.
VaultApplicationTaskOperations Object : AddTask Method

Glossary Item Box

Description

Adds a task to a task queue. The "ApplicationTaskInfo" object must contain the ID of the task queue to which the task is to be added.

Syntax

Visual Basic
Public Function AddTask( _
   ByVal QueueID As String, _
   ByVal RestoreToWaitingTimeoutInMinutes As Long, _
   ByVal TaskType As String, _
   ByVal TaskData() As Byte _
) As String

Parameters

QueueID
The ID of the task queue to which the new task is to be added.
RestoreToWaitingTimeoutInMinutes
The number of minutes to wait before moving the task to the waiting state if the instance carrying it out has not reported to the server that it is still in progress. In the waiting state, the task is idle and waits to be selected for processing.
TaskType
The task type can be used as an identifier for how the task data should be interpreted.
TaskData
The payload of the task.

Remarks

Requires M-Files 19.3.7499.1 or later.

See Also

VaultApplicationTaskOperations Object | VaultApplicationTaskOperations Members


%%PageItemTitle%%

GetLatestBroadcastMessageIdentifiers Method
QueueIDCollection
List of queue IDs from which to check the broadcast message IDs.
VaultApplicationTaskOperations Object : GetLatestBroadcastMessageIdentifiers Method

Glossary Item Box

Description

Gets the IDs of the most recent broadcast messages from the given queues.

Syntax

Visual Basic
Public Function GetLatestBroadcastMessageIdentifiers( _
   ByVal QueueIDCollection As Strings _
) As Strings

Parameters

QueueIDCollection
List of queue IDs from which to check the broadcast message IDs.

Remarks

Requires M-Files 19.3.7499.1 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultApplicationTaskOperations Object | VaultApplicationTaskOperations Members


%%PageItemTitle%%

GetNewBroadcastMessages Method
QueueID
The ID of the queue from which to check for the messages.
LatestBroadcastMessageID
The ID of the latest already processed broadcast message from the queue.
VaultApplicationTaskOperations Object : GetNewBroadcastMessages Method

Glossary Item Box

Description

Gets the broadcast messages that have been sent since the specified broadcast message ID.

Syntax

Visual Basic
Public Function GetNewBroadcastMessages( _
   ByVal QueueID As String, _
   ByVal LatestBroadcastMessageID As String _
) As ApplicationBroadcastMessages

Parameters

QueueID
The ID of the queue from which to check for the messages.
LatestBroadcastMessageID
The ID of the latest already processed broadcast message from the queue.

Remarks

Requires M-Files 19.3.7499.1 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultApplicationTaskOperations Object | VaultApplicationTaskOperations Members


%%PageItemTitle%%

GetTaskIDsFromQueue Method
QueueID
The ID of the task queue from which get the task IDs.
States
The task state IDs to be included in the request.
VaultApplicationTaskOperations Object : GetTaskIDsFromQueue Method

Glossary Item Box

Description

Gets the list of task IDs from a task queue.

Syntax

Visual Basic
Public Function GetTaskIDsFromQueue( _
   ByVal QueueID As String, _
   ByVal States As IDs _
) As Strings

Parameters

QueueID
The ID of the task queue from which get the task IDs.
States
The task state IDs to be included in the request.

Remarks

Requires M-Files 19.3.7499.1 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultApplicationTaskOperations Object | VaultApplicationTaskOperations Members


%%PageItemTitle%%

GetTaskQueues Method
VaultApplicationTaskOperations Object : GetTaskQueues Method

Glossary Item Box

Description

Gets the list of available task queues from the server.

Syntax

Visual Basic
Public Function GetTaskQueues() As Strings

Remarks

Requires M-Files 19.3.7499.1 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultApplicationTaskOperations Object | VaultApplicationTaskOperations Members


%%PageItemTitle%%

GetTasks Method
TaskIDCollection
The IDs of the tasks to get from the server.
VaultApplicationTaskOperations Object : GetTasks Method

Glossary Item Box

Description

Gets task objects from the server. This does not reserve any tasks for processing, meaning that their states can still change on the server.

Syntax

Visual Basic
Public Function GetTasks( _
   ByVal TaskIDCollection As Strings _
) As ApplicationTaskInfos

Parameters

TaskIDCollection
The IDs of the tasks to get from the server.

Remarks

Requires M-Files 19.3.7499.1 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultApplicationTaskOperations Object | VaultApplicationTaskOperations Members


%%PageItemTitle%%

OpenTaskQueue Method
QueueID
The ID of the task queue to be opened.
QueueProcessingBehavior
The behavior of new task queue.
VaultApplicationTaskOperations Object : OpenTaskQueue Method

Glossary Item Box

Description

Opens a new task queue. When the application no longer needs the queue, it can simply stop using it. The server automatically closes the queue when instances stop using it.

Syntax

Visual Basic
Public Sub OpenTaskQueue( _
   ByVal QueueID As String, _
   ByVal QueueProcessingBehavior As MFTaskQueueProcessingBehavior _
)

Parameters

QueueID
The ID of the task queue to be opened.
QueueProcessingBehavior
Value | Description
MFProcessingBehaviorConcurrent | Tasks in this queue may be carried out concurrently.
MFProcessingBehaviorSequential | Tasks in this queue are carried out one by one, in the order they have been added to the queue.
The behavior of new task queue.

Remarks

Requires M-Files 19.3.7499.1 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultApplicationTaskOperations Object | VaultApplicationTaskOperations Members


%%PageItemTitle%%

ReserveTasksForProcessing Method
QueueIDCollection
The collection of task queue IDs from which to reserve tasks.
VaultApplicationTaskOperations Object : ReserveTasksForProcessing Method

Glossary Item Box

Description

Reserves the next tasks for processing from the task queues.

Syntax

Visual Basic
Public Function ReserveTasksForProcessing( _
   ByVal QueueIDCollection As Strings _
) As ApplicationTaskInfos

Parameters

QueueIDCollection
The collection of task queue IDs from which to reserve tasks.

Remarks

Requires M-Files 19.3.7499.1 or later.

This method is available only if M-Files API is used in the server interface mode.

The task consumer (for instance an application thread or a background operation carrying out tasks in the task queue) should use this method to check if there are any tasks available for processing in the task queues.

See Also

VaultApplicationTaskOperations Object | VaultApplicationTaskOperations Members


%%PageItemTitle%%

SendBroadcastMessage Method
QueueID
The ID of the queue to which the broadcast message is sent.
TaskType
The task type of the broadcast message.
TaskData
The task data to be set to the broadcast message.
VaultApplicationTaskOperations Object : SendBroadcastMessage Method

Glossary Item Box

Description

Sends a broadcast message to a task queue.

Syntax

Visual Basic
Public Sub SendBroadcastMessage( _
   ByVal QueueID As String, _
   ByVal TaskType As String, _
   ByVal TaskData() As Byte _
)

Parameters

QueueID
The ID of the queue to which the broadcast message is sent.
TaskType
The task type of the broadcast message.
TaskData
The task data to be set to the broadcast message.

Remarks

Requires M-Files 19.3.7499.1 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultApplicationTaskOperations Object | VaultApplicationTaskOperations Members


%%PageItemTitle%%

UpdateTask Method
TaskID
The ID of the task to update.
NewState
The state to set for the task.
Progress
The progress level to set for the task.
VaultApplicationTaskOperations Object : UpdateTask Method

Glossary Item Box

Description

Updates the task information to the server.

Syntax

Visual Basic
Public Sub UpdateTask( _
   ByVal TaskID As String, _
   ByVal NewState As MFTaskState, _
   ByVal Progress As String _
)

Parameters

TaskID
The ID of the task to update.
NewState
Value | Description
MFTaskStateCanceled | Task processing has been canceled.
MFTaskStateCompleted | The task has been successfully processed.
MFTaskStateFailed | Processing the task has failed.
MFTaskStateInProgress | The task is currently being processed.
MFTaskStateNone | State information does not apply to this task.
MFTaskStateWaiting | The initial state. The task is pending for processing.
The state to set for the task.
Progress
The progress level to set for the task.

Remarks

Requires M-Files 19.3.7499.1 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultApplicationTaskOperations Object | VaultApplicationTaskOperations Members


%%PageItemTitle%%

VaultAutomaticMetadataOperations Object
Members See Also Send comments

Glossary Item Box

Description

'VaultAutomaticMetadataOperations' is an interface for working with automatically detected metadata.

Public Methods

Public Method DetectTextLanguage | Detects the language of the specified plain text content.
Public Method DetectTextLanguageEx | Detects the language of the specified plain text content.
Public Method GetAutomaticMetadata | Gets the automatically generated metadata.
Public Method GetAutomaticMetadataForObject | Gets the automatically generated metadata for an existing object.
Public Method GetAutomaticMetadataForTemporaryFile | Gets the automatically generated metadata for a temporary file.
Public Method GetAutomaticMetadataForTemporaryFiles | Gets the automatically generated metadata for temporary files.

See Also

VaultAutomaticMetadataOperations Members


%%PageItemTitle%%

DetectTextLanguage Method
TextContent
The plain text input.
VaultAutomaticMetadataOperations Object : DetectTextLanguage Method

Glossary Item Box

Description

Detects the language of the specified plain text content.

Syntax

Visual Basic
Public Function DetectTextLanguage( _
   ByVal TextContent As String _
) As String

Parameters

TextContent
The plain text input.

Remarks

Requires M-Files 18.12.7201.2 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultAutomaticMetadataOperations Object | VaultAutomaticMetadataOperations Members


%%PageItemTitle%%

DetectTextLanguageEx Method
TextContent
The plain text input.
VaultAutomaticMetadataOperations Object : DetectTextLanguageEx Method

Glossary Item Box

Description

Detects the language of the specified plain text content.

Syntax

Visual Basic
Public Function DetectTextLanguageEx( _
   ByVal TextContent As String _
) As LanguageDetectionResult

Parameters

TextContent
The plain text input.

Remarks

Requires M-Files 18.12.7201.2 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultAutomaticMetadataOperations Object | VaultAutomaticMetadataOperations Members


%%PageItemTitle%%

GetAutomaticMetadata Method
IIDs
The temporary file upload session IDs.
ObjectType
The type of the object for which the suggestions are requested.
ObjVer
The object version.
PropertyValues
The property values of the the object.
SuggestionProviders
A list of requested suggestion providers. Leave this empty if you want all providers to be requested.
CustomData
The custom data for the suggestion providers.
VaultAutomaticMetadataOperations Object : GetAutomaticMetadata Method

Glossary Item Box

Description

Gets the automatically generated metadata.

Syntax

Visual Basic
Public Function GetAutomaticMetadata( _
   ByVal IIDs As IDs, _
   ByVal ObjectType As Long, _
   ByVal ObjVer As ObjVer, _
   ByVal PropertyValues As PropertyValues, _
   ByVal SuggestionProviders As Strings, _
   ByVal CustomData As String _
) As AutomaticMetadataResult

Parameters

IIDs
The temporary file upload session IDs.
ObjectType
The type of the object for which the suggestions are requested.
ObjVer
The object version.
PropertyValues
The property values of the the object.
SuggestionProviders
A list of requested suggestion providers. Leave this empty if you want all providers to be requested.
CustomData
The custom data for the suggestion providers.

See Also

VaultAutomaticMetadataOperations Object | VaultAutomaticMetadataOperations Members


%%PageItemTitle%%

GetAutomaticMetadataForObject Method
ObjVer
The object version for which to resolve the automatic metadata.
VaultAutomaticMetadataOperations Object : GetAutomaticMetadataForObject Method

Glossary Item Box

Description

Gets the automatically generated metadata for an existing object.

Syntax

Visual Basic
Public Function GetAutomaticMetadataForObject( _
   ByVal ObjVer As ObjVer _
) As AutomaticMetadataResult

Parameters

ObjVer
The object version for which to resolve the automatic metadata.

See Also

VaultAutomaticMetadataOperations Object | VaultAutomaticMetadataOperations Members


%%PageItemTitle%%

GetAutomaticMetadataForTemporaryFile Method
UploadSessionID
The temporary file upload session ID.
VaultAutomaticMetadataOperations Object : GetAutomaticMetadataForTemporaryFile Method

Glossary Item Box

Description

Gets the automatically generated metadata for a temporary file.

Syntax

Visual Basic
Public Function GetAutomaticMetadataForTemporaryFile( _
   ByVal UploadSessionID As Long _
) As AutomaticMetadataResult

Parameters

UploadSessionID
The temporary file upload session ID.

See Also

VaultAutomaticMetadataOperations Object | VaultAutomaticMetadataOperations Members


%%PageItemTitle%%

GetAutomaticMetadataForTemporaryFiles Method
IIDs
The temporary file upload session IDs.
VaultAutomaticMetadataOperations Object : GetAutomaticMetadataForTemporaryFiles Method

Glossary Item Box

Description

Gets the automatically generated metadata for temporary files.

Syntax

Visual Basic
Public Function GetAutomaticMetadataForTemporaryFiles( _
   ByVal IIDs As IDs _
) As AutomaticMetadataResult

Parameters

IIDs
The temporary file upload session IDs.

See Also

VaultAutomaticMetadataOperations Object | VaultAutomaticMetadataOperations Members


%%PageItemTitle%%

VaultClassGroupOperations Object
Members See Also Send comments

Glossary Item Box

Description

The VaultClassGroupOperations class represents the available class group operations.

Public Methods

Public Method AddClassGroup | Adds a new class group. Returns the created class group, with the ID property set to the real ID value.
Public Method GetClassGroup | Gets the specified class group.
Public Method GetClassGroupIDByGUID | Gets the ID of the class group with the specified GUID. Returns -1 if a match is not found.
Public Method GetClassGroups | Gets all available class groups.
Public Method RemoveClassGroup | Deletes the class group with the specified ID.
Public Method UpdateClassGroup | Updates the class group. The ID property identifies the class group to modify.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultClassGroupOperations Members


%%PageItemTitle%%

AddClassGroup Method
ClassGroup
The class group object to add.
VaultClassGroupOperations Object : AddClassGroup Method

Glossary Item Box

Description

Adds a new class group. Returns the created class group, with the ID property set to the real ID value.

Syntax

Visual Basic
Public Function AddClassGroup( _
   ByVal ClassGroup As ClassGroup _
) As ClassGroup

Parameters

ClassGroup
The class group object to add.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultClassGroupOperations Object | VaultClassGroupOperations Members


%%PageItemTitle%%

GetClassGroup Method
ObjectType
The object type ID of the class group to retrieve.
ClassGroupID
The ID of the class group to retrieve.
VaultClassGroupOperations Object : GetClassGroup Method

Glossary Item Box

Description

Gets the specified class group.

Syntax

Visual Basic
Public Function GetClassGroup( _
   ByVal ObjectType As Long, _
   ByVal ClassGroupID As Long _
) As ClassGroup

Parameters

ObjectType
The object type ID of the class group to retrieve.
ClassGroupID
The ID of the class group to retrieve.

See Also

VaultClassGroupOperations Object | VaultClassGroupOperations Members


%%PageItemTitle%%

GetClassGroupIDByGUID Method
ClassGroupGUID
The GUID of the class group.
VaultClassGroupOperations Object : GetClassGroupIDByGUID Method

Glossary Item Box

Description

Gets the ID of the class group with the specified GUID. Returns -1 if a match is not found.

Syntax

Visual Basic
Public Function GetClassGroupIDByGUID( _
   ByVal ClassGroupGUID As String _
) As Long

Parameters

ClassGroupGUID
The GUID of the class group.

See Also

VaultClassGroupOperations Object | VaultClassGroupOperations Members


%%PageItemTitle%%

GetClassGroups Method
ObjectType
The object type ID of the class group to retrieve.
VaultClassGroupOperations Object : GetClassGroups Method

Glossary Item Box

Description

Gets all available class groups.

Syntax

Visual Basic
Public Function GetClassGroups( _
   ByVal ObjectType As Long _
) As ClassGroups

Parameters

ObjectType
The object type ID of the class group to retrieve.

See Also

VaultClassGroupOperations Object | VaultClassGroupOperations Members


%%PageItemTitle%%

RemoveClassGroup Method
ClassGroupID
The ID of the class group to remove.
VaultClassGroupOperations Object : RemoveClassGroup Method

Glossary Item Box

Description

Deletes the class group with the specified ID.

Syntax

Visual Basic
Public Sub RemoveClassGroup( _
   ByVal ClassGroupID As Long _
)

Parameters

ClassGroupID
The ID of the class group to remove.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultClassGroupOperations Object | VaultClassGroupOperations Members


%%PageItemTitle%%

UpdateClassGroup Method
ClassGroup
The class group object to update.
VaultClassGroupOperations Object : UpdateClassGroup Method

Glossary Item Box

Description

Updates the class group. The ID property identifies the class group to modify.

Syntax

Visual Basic
Public Sub UpdateClassGroup( _
   ByVal ClassGroup As ClassGroup _
)

Parameters

ClassGroup
The class group object to update.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultClassGroupOperations Object | VaultClassGroupOperations Members


%%PageItemTitle%%

VaultClassOperations Object
Members See Also Send comments

Glossary Item Box

Description

The VaultClassOperations class represents the available class operations.

Public Methods

Public Method AddObjectClassAdmin | Adds a new object class. Returns the created object class, with the ID property set to the real ID value.
Public Method GetAllObjectClasses | Gets all object classes.
Public Method GetAllObjectClassesAdmin | Gets all object classes (for administrative operations).
Public Method GetObjectClass | Gets a single object class.
Public Method GetObjectClassAdmin | Gets the specified object class (for administrative operations).
Public Method GetObjectClasses | Gets object classes for the specified object type.
Public Method GetObjectClassesAdmin | Gets object classes for the specified object type (for administrative operations).
Public Method GetObjectClassIDByAlias | Gets the ID of the object class with the specified alias. Returns -1 if a match is not found or if more than one object class uses the specified alias.
Public Method GetObjectClassIDByGUID | Gets the ID of the object class with the specified GUID. Returns -1 if a match is not found.
Public Method RemoveObjectClassAdmin | Deletes the object class with the specified ID.
Public Method UpdateObjectClassAdmin | Updates the object class. The ID property identifies the object class to modify.
Public Method UpdateObjectNames | Updates the names of all existing objects of the specified class by copying values from the name property of the class to the built-in 'Name or title' property.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultClassOperations Members


%%PageItemTitle%%

AddObjectClassAdmin Method
ObjectClassAdmin
The class object to add.
VaultClassOperations Object : AddObjectClassAdmin Method

Glossary Item Box

Description

Adds a new object class. Returns the created object class, with the ID property set to the real ID value.

Syntax

Visual Basic
Public Function AddObjectClassAdmin( _
   ByVal ObjectClassAdmin As ObjectClassAdmin _
) As ObjectClassAdmin

Parameters

ObjectClassAdmin
The class object to add.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultClassOperations Object | VaultClassOperations Members


%%PageItemTitle%%

GetAllObjectClasses Method
VaultClassOperations Object : GetAllObjectClasses Method

Glossary Item Box

Description

Gets all object classes.

Syntax

Visual Basic
Public Function GetAllObjectClasses() As ObjectClasses

See Also

VaultClassOperations Object | VaultClassOperations Members


%%PageItemTitle%%

GetAllObjectClassesAdmin Method
VaultClassOperations Object : GetAllObjectClassesAdmin Method

Glossary Item Box

Description

Gets all object classes (for administrative operations).

Syntax

Visual Basic
Public Function GetAllObjectClassesAdmin() As ObjectClassesAdmin

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultClassOperations Object | VaultClassOperations Members


%%PageItemTitle%%

GetObjectClass Method
See Also Example Send comments
ObjectClass
The class ID of the class to retrieve.
VaultClassOperations Object : GetObjectClass Method

Glossary Item Box

Description

Gets a single object class.

Syntax

Visual Basic
Public Function GetObjectClass( _
   ByVal ObjectClass As Long _
) As ObjectClass

Parameters

ObjectClass
The class ID of the class to retrieve.

Example

Resolving the class name for an object (Visual Basic) Copy Code
' Identify the object.
Dim oObjVer As MFilesAPI.ObjVer
'...

' Get the value of class property.
Dim oPropertyValues As MFilesAPI.PropertyValues = oVault.ObjectPropertyOperations.GetProperties(oObjVer)
Dim oPropertyValue As MFilesAPI.PropertyValue = oPropertyValues.SearchForProperty( _
    MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefClass)

' As this is class property, the data type is always "Lookup value".
If oPropertyValue.TypedValue.DataType <> MFilesAPI.MFDataType.MFDatatypeLookup Then
    Throw New SystemException("Internal error")
End If

' The value of lookup item is the class id. Resolve the class object.
Dim iClassId As Integer = oPropertyValue.TypedValue.GetLookupID()
Dim oObjectClass As MFilesAPI.ObjectClass = oVault.ClassOperations.GetObjectClass(iClassId)

' Resolve the class name.
Dim szClassName As String = oObjectClass.Name

See Also

VaultClassOperations Object | VaultClassOperations Members


%%PageItemTitle%%

GetObjectClassAdmin Method
Class
VaultClassOperations Object : GetObjectClassAdmin Method

Glossary Item Box

Description

Gets the specified object class (for administrative operations).

Syntax

Visual Basic
Public Function GetObjectClassAdmin( _
   ByVal Class As Long _
) As ObjectClassAdmin

Parameters

Class

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultClassOperations Object | VaultClassOperations Members


%%PageItemTitle%%

GetObjectClasses Method
ObjectType
The object type ID of the classes to retrieve.
VaultClassOperations Object : GetObjectClasses Method

Glossary Item Box

Description

Gets object classes for the specified object type.

Syntax

Visual Basic
Public Function GetObjectClasses( _
   ByVal ObjectType As Long _
) As ObjectClasses

Parameters

ObjectType
The object type ID of the classes to retrieve.

See Also

VaultClassOperations Object | VaultClassOperations Members


%%PageItemTitle%%

GetObjectClassesAdmin Method
ObjectType
VaultClassOperations Object : GetObjectClassesAdmin Method

Glossary Item Box

Description

Gets object classes for the specified object type (for administrative operations).

Syntax

Visual Basic
Public Function GetObjectClassesAdmin( _
   ByVal ObjectType As Long _
) As ObjectClassesAdmin

Parameters

ObjectType

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultClassOperations Object | VaultClassOperations Members


%%PageItemTitle%%

GetObjectClassIDByAlias Method
Alias
VaultClassOperations Object : GetObjectClassIDByAlias Method

Glossary Item Box

Description

Gets the ID of the object class with the specified alias. Returns -1 if a match is not found or if more than one object class uses the specified alias.

Syntax

Visual Basic
Public Function GetObjectClassIDByAlias( _
   ByVal Alias As String _
) As Long

Parameters

Alias

See Also

VaultClassOperations Object | VaultClassOperations Members


%%PageItemTitle%%

GetObjectClassIDByGUID Method
ObjectClassGUID
The GUID of the object class.
VaultClassOperations Object : GetObjectClassIDByGUID Method

Glossary Item Box

Description

Gets the ID of the object class with the specified GUID. Returns -1 if a match is not found.

Syntax

Visual Basic
Public Function GetObjectClassIDByGUID( _
   ByVal ObjectClassGUID As String _
) As Long

Parameters

ObjectClassGUID
The GUID of the object class.

See Also

VaultClassOperations Object | VaultClassOperations Members


%%PageItemTitle%%

RemoveObjectClassAdmin Method
ObjectClassID
The class ID of the class to remove.
VaultClassOperations Object : RemoveObjectClassAdmin Method

Glossary Item Box

Description

Deletes the object class with the specified ID.

Syntax

Visual Basic
Public Sub RemoveObjectClassAdmin( _
   ByVal ObjectClassID As Long _
)

Parameters

ObjectClassID
The class ID of the class to remove.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultClassOperations Object | VaultClassOperations Members


%%PageItemTitle%%

UpdateObjectClassAdmin Method
ObjectClass
The class object to update.
VaultClassOperations Object : UpdateObjectClassAdmin Method

Glossary Item Box

Description

Updates the object class. The ID property identifies the object class to modify.

Syntax

Visual Basic
Public Sub UpdateObjectClassAdmin( _
   ByVal ObjectClass As ObjectClassAdmin _
)

Parameters

ObjectClass
The class object to update.

Remarks

This method is available only if M-Files API is used in the server interface mode.

You have to explicitly set all the AssociatedPropertyDefs properties for the ObjectClassAdmin object as the properties are not directly copied from the corresponding ObjectClass object. In other words, properties not set for the ObjectClassAdmin object are not included in the class. As a test, you can make a working script with a very simple example class that only has the Name and title property definition.

In your solution, always build the entire AssociatedPropertyDefs list during an object class update.

See Also

VaultClassOperations Object | VaultClassOperations Members


%%PageItemTitle%%

UpdateObjectNames Method
ObjectClassID
The class ID of object versions to be updated.
VaultClassOperations Object : UpdateObjectNames Method

Glossary Item Box

Description

Updates the names of all existing objects of the specified class by copying values from the name property of the class to the built-in 'Name or title' property.

Syntax

Visual Basic
Public Sub UpdateObjectNames( _
   ByVal ObjectClassID As Long _
)

Parameters

ObjectClassID
The class ID of object versions to be updated.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultClassOperations Object | VaultClassOperations Members


%%PageItemTitle%%

VaultClientOperations Object
Members See Also Send comments

Glossary Item Box

Description

The VaultClientOperations class represents the available client operations.

Public Methods

Public Method DisableCheckInReminderForCallingProcess | Disables the check-in reminder for the calling process.
Public Method EnableCheckInReminderForCallingProcess | Enables the check-in reminder for the calling process.
Public Method IsOffline | Specifies whether the vault is in offline mode.
Public Method IsOnline | Specifies whether the vault is in online mode.
Public Method SetVaultToOffline | Sets the vault to offline mode.
Public Method SetVaultToOnline | Sets the vault to online mode.

Remarks

This method group interface can be accessed via the Vault object.

Methods of this interface are available only if M-Files API is used in the client interface mode.

See Also

VaultClientOperations Members


%%PageItemTitle%%

DisableCheckInReminderForCallingProcess Method
VaultClientOperations Object : DisableCheckInReminderForCallingProcess Method

Glossary Item Box

Description

Disables the check-in reminder for the calling process.

Syntax

Visual Basic
Public Sub DisableCheckInReminderForCallingProcess()

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultClientOperations Object | VaultClientOperations Members


%%PageItemTitle%%

EnableCheckInReminderForCallingProcess Method
VaultClientOperations Object : EnableCheckInReminderForCallingProcess Method

Glossary Item Box

Description

Enables the check-in reminder for the calling process.

Syntax

Visual Basic
Public Sub EnableCheckInReminderForCallingProcess()

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultClientOperations Object | VaultClientOperations Members


%%PageItemTitle%%

IsOffline Method
VaultClientOperations Object : IsOffline Method

Glossary Item Box

Description

Specifies whether the vault is in offline mode.

Syntax

Visual Basic
Public Function IsOffline() As Boolean

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultClientOperations Object | VaultClientOperations Members


%%PageItemTitle%%

IsOnline Method
VaultClientOperations Object : IsOnline Method

Glossary Item Box

Description

Specifies whether the vault is in online mode.

Syntax

Visual Basic
Public Function IsOnline() As Boolean

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultClientOperations Object | VaultClientOperations Members


%%PageItemTitle%%

SetVaultToOffline Method
ParentWindow
VaultClientOperations Object : SetVaultToOffline Method

Glossary Item Box

Description

Sets the vault to offline mode.

Syntax

Visual Basic
Public Function SetVaultToOffline( _
   ByVal ParentWindow As Long _
) As MFOfflineTransitionResultFlags

Parameters

ParentWindow

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultClientOperations Object | VaultClientOperations Members


%%PageItemTitle%%

SetVaultToOnline Method
ParentWindow
VaultClientOperations Object : SetVaultToOnline Method

Glossary Item Box

Description

Sets the vault to online mode.

Syntax

Visual Basic
Public Function SetVaultToOnline( _
   ByVal ParentWindow As Long _
) As MFOnlineTransitionResultFlags

Parameters

ParentWindow

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultClientOperations Object | VaultClientOperations Members


%%PageItemTitle%%

VaultConnection Object
Members See Also Send comments

Glossary Item Box

Description

The VaultConnection class represents a document vault connection that is available to the current Windows user.

Public Methods

Public Method BindToVault | Binds to the vault identified by this vault connection. The default authentication method is used if the login is allowed.
Public Method Clone | Creates a copy of the object.
Public Method GetGUID | Gets the GUID on the server of the vault identified by this vault connection.
Public Method IsLoggedIn | Checks whether the current user is currently logged into the vault identified by this vault connection.
Public Method LogInAs | Logs in to the vault. Prompts the user for credentials.
Public Method LogInAsUser | Logs in to the vault using the specified credentials.
Public Method TestConnectionToVault | Tests the connection to the vault identified by this vault connection.

Public Properties

Public Property AuthType | The type of the authentication.
Public Property AutoLogin | Specifies if M-Files should automatically log in to this vault when the system is started.
Public Property EncryptedConnection | Specifies if data between M-Files Desktop and M-Files Server must be encrypted. May apply to certain protocol sequences only.
Public Property Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.
Public Property Icon | If not NULL, contains the icon of this item in .ICO format.
Public Property Name | The name of the vault identified by this vault connection.
Public Property NetworkAddress | The network address for connecting to the vault.
Public Property ProtocolSequence | The protocol sequence for connecting to the vault.
Public Property ServerVaultGUID | The GUID of the vault on the server.
Public Property ServerVaultName | The name of the vault on the server.
Public Property UserSpecific | Specifies if this connection is user specific or visible to all users.

Remarks

Vault connections listed in Windows File Explorer.

See Also

VaultConnection Members


%%PageItemTitle%%

BindToVault Method
ParentWindow
CanLogIn
ReturnNULLIfCancelledByUser
VaultConnection Object : BindToVault Method

Glossary Item Box

Description

Binds to the vault identified by this vault connection. The default authentication method is used if the login is allowed.

Syntax

Visual Basic
Public Function BindToVault( _
   ByVal ParentWindow As Long, _
   ByVal CanLogIn As Boolean, _
   ByVal ReturnNULLIfCancelledByUser As Boolean _
) As Vault

Parameters

ParentWindow
CanLogIn
ReturnNULLIfCancelledByUser

Return Type

The vault object if the login is successful.

Remarks

Use this method to log into a document vault identified by this vault connection.

The login is performed using the authentication method defined in the M-Files Client settings.

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

Clone Method
VaultConnection Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As VaultConnection

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

GetGUID Method
VaultConnection Object : GetGUID Method

Glossary Item Box

Description

Gets the GUID on the server of the vault identified by this vault connection.

Syntax

Visual Basic
Public Function GetGUID() As String

Return Type

The GUID of the vault in the server.

Remarks

The GUID is returned in the following format: "{AD3964E8-8DA2-47a4-9D45-7D9371DFF077}"

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

IsLoggedIn Method
VaultConnection Object : IsLoggedIn Method

Glossary Item Box

Description

Checks whether the current user is currently logged into the vault identified by this vault connection.

Syntax

Visual Basic
Public Function IsLoggedIn() As Boolean

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

LogInAs Method
ParentWindow
DefaultAuthType
ReturnNULLIfCancelledByUser
VaultConnection Object : LogInAs Method

Glossary Item Box

Description

Logs in to the vault. Prompts the user for credentials.

Syntax

Visual Basic
Public Function LogInAs( _
   ByVal ParentWindow As Long, _
   ByVal DefaultAuthType As MFAuthType, _
   ByVal ReturnNULLIfCancelledByUser As Boolean _
) As Vault

Parameters

ParentWindow
DefaultAuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
ReturnNULLIfCancelledByUser

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

LogInAsUser Method
AuthType
UserName
The user name as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
The password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
The domain for the user as a string. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
SPN
The Service Principal Name as a string.
VaultConnection Object : LogInAsUser Method

Glossary Item Box

Description

Logs in to the vault using the specified credentials.

Syntax

Visual Basic
Public Function LogInAsUser( _
   ByVal AuthType As MFAuthType, _
   ByVal UserName As String, _
   ByVal Password As String, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant _
) As Vault

Parameters

AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
UserName
The user name as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
The password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
The domain for the user as a string. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
SPN
The Service Principal Name as a string.

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

TestConnectionToVault Method
ParentWindow
VaultConnection Object : TestConnectionToVault Method

Glossary Item Box

Description

Tests the connection to the vault identified by this vault connection.

Syntax

Visual Basic
Public Function TestConnectionToVault( _
   ByVal ParentWindow As Long _
) As MFVaultConnectionTestResult

Parameters

ParentWindow

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

AuthType Property
VaultConnection Object : AuthType Property

Glossary Item Box

Description

The type of the authentication.

Property type

Read-write property

Syntax

Visual Basic
Public Property AuthType As MFAuthType

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

AutoLogin Property
VaultConnection Object : AutoLogin Property

Glossary Item Box

Description

Specifies if M-Files should automatically log in to this vault when the system is started.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoLogin As Boolean

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

EncryptedConnection Property
VaultConnection Object : EncryptedConnection Property

Glossary Item Box

Description

Specifies if data between M-Files Desktop and M-Files Server must be encrypted. May apply to certain protocol sequences only.

Property type

Read-write property

Syntax

Visual Basic
Public Property EncryptedConnection As Boolean

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

Endpoint Property
VaultConnection Object : Endpoint Property

Glossary Item Box

Description

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.

Property type

Read-write property

Syntax

Visual Basic
Public Property Endpoint As String

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

Icon Property
VaultConnection Object : Icon Property

Glossary Item Box

Description

If not NULL, contains the icon of this item in .ICO format.

Property type

Read-write property

Syntax

Visual Basic
Public Property Icon As Byte()

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

Name Property
VaultConnection Object : Name Property

Glossary Item Box

Description

The name of the vault identified by this vault connection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

Return Type

The name of the document vault connection as a string.

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

NetworkAddress Property
VaultConnection Object : NetworkAddress Property

Glossary Item Box

Description

The network address for connecting to the vault.

Property type

Read-write property

Syntax

Visual Basic
Public Property NetworkAddress As String

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

ProtocolSequence Property
VaultConnection Object : ProtocolSequence Property

Glossary Item Box

Description

The protocol sequence for connecting to the vault.

Property type

Read-write property

Syntax

Visual Basic
Public Property ProtocolSequence As String

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

ServerVaultGUID Property
VaultConnection Object : ServerVaultGUID Property

Glossary Item Box

Description

The GUID of the vault on the server.

Property type

Read-write property

Syntax

Visual Basic
Public Property ServerVaultGUID As String

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

ServerVaultName Property
VaultConnection Object : ServerVaultName Property

Glossary Item Box

Description

The name of the vault on the server.

Property type

Read-write property

Syntax

Visual Basic
Public Property ServerVaultName As String

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

UserSpecific Property
VaultConnection Object : UserSpecific Property

Glossary Item Box

Description

Specifies if this connection is user specific or visible to all users.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserSpecific As Boolean

See Also

VaultConnection Object | VaultConnection Members


%%PageItemTitle%%

VaultConnections Collection
Members See Also Send comments

Glossary Item Box

Description

VaultConnections is a collection of VaultConnection objects.

Public Methods

Public Method Add | Adds a new vault connection to this collection.
Public Method GetVaultConnectionByName | Gets vault connection with specified name.
Public Method GetVaultConnectionIndexByName | Gets the index of vault connection in collection using specified name.
Public Method Remove | Removes a vault connection from this collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

VaultConnections Members | VaultConnection Object


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
VaultConnection

The new member to add.

VaultConnections Collection : Add Method

Glossary Item Box

Description

Adds a new vault connection to this collection.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal VaultConnection As VaultConnection _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
VaultConnection

The new member to add.

See Also

VaultConnections Collection | VaultConnections Members


%%PageItemTitle%%

GetVaultConnectionByName Method
VaultConnectionName
The name of the vault connection to retrieve.
VaultConnections Collection : GetVaultConnectionByName Method

Glossary Item Box

Description

Gets vault connection with specified name.

Syntax

Visual Basic
Public Function GetVaultConnectionByName( _
   ByVal VaultConnectionName As String _
) As VaultConnection

Parameters

VaultConnectionName
The name of the vault connection to retrieve.

See Also

VaultConnections Collection | VaultConnections Members


%%PageItemTitle%%

GetVaultConnectionIndexByName Method
VaultConnectionName
The name of the vault connection to retrieve.
VaultConnections Collection : GetVaultConnectionIndexByName Method

Glossary Item Box

Description

Gets the index of vault connection in collection using specified name.

Syntax

Visual Basic
Public Function GetVaultConnectionIndexByName( _
   ByVal VaultConnectionName As String _
) As Long

Parameters

VaultConnectionName
The name of the vault connection to retrieve.

See Also

VaultConnections Collection | VaultConnections Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
VaultConnections Collection : Remove Method

Glossary Item Box

Description

Removes a vault connection from this collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

VaultConnections Collection | VaultConnections Members


%%PageItemTitle%%

Count Property
VaultConnections Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

VaultConnections Collection | VaultConnections Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
VaultConnections Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As VaultConnection

Parameters

Index
Specifies the item's position in the collection.

See Also

VaultConnections Collection | VaultConnections Members


%%PageItemTitle%%

VaultCustomApplicationManagementOperations Object
Members See Also Send comments

Glossary Item Box

Description

VaultCustomApplicationManagementOperations is an interface for managing custom applications in a vault.

Public Methods

Public Method DownloadCustomApplicationBlock | Retrieves a specific block of the specified application file from the server.
Public Method DownloadCustomApplicationBlock_32bit | Retrieves a specific block of the specified application file from the server (uses 32-bit arguments).
Public Method DownloadCustomApplicationBlockBegin | Begins the block-by-block download of the specified application.
Public Method DownloadCustomApplicationBlockBegin_32bit | Begins the block-by-block download of the specified application (uses 32-bit arguments).
Public Method EnableCustomApplication | Enables or disables the specified custom application in current client for this user.
Public Method EnableCustomApplicationInVault | Enables or disables the specified custom application at vault level for all users.
Public Method GetCustomApplication | Gets a single custom application.
Public Method GetCustomApplicationLicenseDetails | Get the license details of the current license for a custom application.
Public Method GetCustomApplicationLicenseStatus | Get the license status enumeration of the current license for a custom application.
Public Method GetCustomApplicationNewLicenseDetails | Get the license details of a new license for a custom application.
Public Method GetCustomApplicationNewLicenseStatus | Get the license status enumeration of a new license for a custom application.
Public Method GetCustomApplications | Gets the custom applications installed in the vault. Use the GetCustomApplicationsEx2 method for additional options.
Public Method GetCustomApplicationsEx | Gets the custom applications installed in the vault. Use the GetCustomApplicationsEx2 method for additional options.
Public Method GetCustomApplicationsEx2 | Gets the custom applications installed in the vault.
Public Method InstallCustomApplication | Installs a custom application from the specified file to the vault.
Public Method InstallCustomApplicationLicense | Install a new license for a custom application.
Public Method UninstallCustomApplication | Uninstalls the specified custom application from the vault.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

DownloadCustomApplicationBlock Method
DownloadID
The download ID.
BlockSize
The size of the block to be downloaded.
Offset
Offset from the beginning of the file.
VaultCustomApplicationManagementOperations Object : DownloadCustomApplicationBlock Method

Glossary Item Box

Description

Retrieves a specific block of the specified application file from the server.

Syntax

Visual Basic
Public Function DownloadCustomApplicationBlock( _
   ByVal DownloadID As Long, _
   ByVal BlockSize As Long, _
   ByVal Offset As Unknown _
) As Byte()

Parameters

DownloadID
The download ID.
BlockSize
The size of the block to be downloaded.
Offset
Offset from the beginning of the file.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

DownloadCustomApplicationBlock_32bit Method
DownloadID
The download ID.
BlockSize
The size of the block to be downloaded.
Offset
Offset from the beginning of the file.
VaultCustomApplicationManagementOperations Object : DownloadCustomApplicationBlock_32bit Method

Glossary Item Box

Description

Retrieves a specific block of the specified application file from the server (uses 32-bit arguments).

Syntax

Visual Basic
Public Function DownloadCustomApplicationBlock_32bit( _
   ByVal DownloadID As Long, _
   ByVal BlockSize As Long, _
   ByVal Offset As Long _
) As Byte()

Parameters

DownloadID
The download ID.
BlockSize
The size of the block to be downloaded.
Offset
Offset from the beginning of the file.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

DownloadCustomApplicationBlockBegin Method
ApplicationID

The application ID.

VaultCustomApplicationManagementOperations Object : DownloadCustomApplicationBlockBegin Method

Glossary Item Box

Description

Begins the block-by-block download of the specified application.

Syntax

Visual Basic
Public Function DownloadCustomApplicationBlockBegin( _
   ByVal ApplicationID As String _
) As FileDownloadSession

Parameters

ApplicationID

The application ID.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

DownloadCustomApplicationBlockBegin_32bit Method
ApplicationID

The application ID.

VaultCustomApplicationManagementOperations Object : DownloadCustomApplicationBlockBegin_32bit Method

Glossary Item Box

Description

Begins the block-by-block download of the specified application (uses 32-bit arguments).

Syntax

Visual Basic
Public Function DownloadCustomApplicationBlockBegin_32bit( _
   ByVal ApplicationID As String _
) As FileDownloadSession

Parameters

ApplicationID

The application ID.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

EnableCustomApplication Method
ApplicationID

The application ID.

Enabled
True to enable the custom application.
VaultCustomApplicationManagementOperations Object : EnableCustomApplication Method

Glossary Item Box

Description

Enables or disables the specified custom application in current client for this user.

Syntax

Visual Basic
Public Sub EnableCustomApplication( _
   ByVal ApplicationID As String, _
   ByVal Enabled As Boolean _
)

Parameters

ApplicationID

The application ID.

Enabled
True to enable the custom application.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

EnableCustomApplicationInVault Method
ApplicationID
The GUID of the target application.
Enabled
Specifies whether the application is enabled or disabled.
VaultCustomApplicationManagementOperations Object : EnableCustomApplicationInVault Method

Glossary Item Box

Description

Enables or disables the specified custom application at vault level for all users.

Syntax

Visual Basic
Public Sub EnableCustomApplicationInVault( _
   ByVal ApplicationID As String, _
   ByVal Enabled As Boolean _
)

Parameters

ApplicationID
The GUID of the target application.
Enabled
Specifies whether the application is enabled or disabled.

Remarks

Supported in M-Files 19.10.8340.0 and later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

GetCustomApplication Method
ApplicationID

The application ID.

VaultCustomApplicationManagementOperations Object : GetCustomApplication Method

Glossary Item Box

Description

Gets a single custom application.

Syntax

Visual Basic
Public Function GetCustomApplication( _
   ByVal ApplicationID As String _
) As CustomApplication

Parameters

ApplicationID

The application ID.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

GetCustomApplicationLicenseDetails Method
ApplicationID
The GUID of the target application.
VaultCustomApplicationManagementOperations Object : GetCustomApplicationLicenseDetails Method

Glossary Item Box

Description

Get the license details of the current license for a custom application.

Syntax

Visual Basic
Public Function GetCustomApplicationLicenseDetails( _
   ByVal ApplicationID As String _
) As String

Parameters

ApplicationID
The GUID of the target application.

Remarks

Requires M-Files 12.0.6700.0 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

GetCustomApplicationLicenseStatus Method
ApplicationID
The GUID of the target application.
VaultCustomApplicationManagementOperations Object : GetCustomApplicationLicenseStatus Method

Glossary Item Box

Description

Get the license status enumeration of the current license for a custom application.

Syntax

Visual Basic
Public Function GetCustomApplicationLicenseStatus( _
   ByVal ApplicationID As String _
) As MFApplicationLicenseStatus

Parameters

ApplicationID
The GUID of the target application.

Remarks

Requires M-Files 12.0.6700.0 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

GetCustomApplicationNewLicenseDetails Method
ApplicationID
The GUID of the target application.
NewLicenseContent
The content of the new license.
VaultCustomApplicationManagementOperations Object : GetCustomApplicationNewLicenseDetails Method

Glossary Item Box

Description

Get the license details of a new license for a custom application.

Syntax

Visual Basic
Public Function GetCustomApplicationNewLicenseDetails( _
   ByVal ApplicationID As String, _
   ByVal NewLicenseContent As String _
) As String

Parameters

ApplicationID
The GUID of the target application.
NewLicenseContent
The content of the new license.

Remarks

Requires M-Files 12.0.6700.0 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

GetCustomApplicationNewLicenseStatus Method
ApplicationID
The GUID of the target application.
NewLicenseContent
The content of the new license.
VaultCustomApplicationManagementOperations Object : GetCustomApplicationNewLicenseStatus Method

Glossary Item Box

Description

Get the license status enumeration of a new license for a custom application.

Syntax

Visual Basic
Public Function GetCustomApplicationNewLicenseStatus( _
   ByVal ApplicationID As String, _
   ByVal NewLicenseContent As String _
) As MFApplicationLicenseStatus

Parameters

ApplicationID
The GUID of the target application.
NewLicenseContent
The content of the new license.

Remarks

Requires M-Files 12.0.6700.0 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

GetCustomApplications Method
VaultCustomApplicationManagementOperations Object : GetCustomApplications Method

Glossary Item Box

Description

Gets the custom applications installed in the vault. Use the GetCustomApplicationsEx2 method for additional options.

Syntax

Visual Basic
Public Function GetCustomApplications() As CustomApplications

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

GetCustomApplicationsEx Method
Platform
The target platform.
VaultCustomApplicationManagementOperations Object : GetCustomApplicationsEx Method

Glossary Item Box

Description

Gets the custom applications installed in the vault. Use the GetCustomApplicationsEx2 method for additional options.

Syntax

Visual Basic
Public Function GetCustomApplicationsEx( _
   ByVal Platform As MFExtApplicationPlatform _
) As CustomApplications

Parameters

Platform
Value | Description
MFExtApplicationPlatformDesktop | Platform is M-Files Desktop.
MFExtApplicationPlatformNone | No platform.
MFExtApplicationPlatformWeb | Platform is M-Files Web.
The target platform.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

GetCustomApplicationsEx2 Method
Type
The type of the application.
Platform
The target platform.
VaultCustomApplicationManagementOperations Object : GetCustomApplicationsEx2 Method

Glossary Item Box

Description

Gets the custom applications installed in the vault.

Syntax

Visual Basic
Public Function GetCustomApplicationsEx2( _
   ByVal Type As MFCustomApplicationType, _
   ByVal Platform As MFExtApplicationPlatform _
) As CustomApplications

Parameters

Type
Value | Description
MFCustomApplicationTypeClient | Client application.
MFCustomApplicationTypeServer | Server application.
MFCustomApplicationTypeUnspecified | Unspecified or unknown application type.
The type of the application.
Platform
Value | Description
MFExtApplicationPlatformDesktop | Platform is M-Files Desktop.
MFExtApplicationPlatformNone | No platform.
MFExtApplicationPlatformWeb | Platform is M-Files Web.
The target platform.

Remarks

Supported in M-Files 19.2.7378.0 and later.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

InstallCustomApplication Method
File
VaultCustomApplicationManagementOperations Object : InstallCustomApplication Method

Glossary Item Box

Description

Installs a custom application from the specified file to the vault.

Syntax

Visual Basic
Public Sub InstallCustomApplication( _
   ByVal File As String _
)

Parameters

File

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

InstallCustomApplicationLicense Method
ApplicationID
The GUID of the target application.
NewLicenseContent
The content of the new license.
VaultCustomApplicationManagementOperations Object : InstallCustomApplicationLicense Method

Glossary Item Box

Description

Install a new license for a custom application.

Syntax

Visual Basic
Public Sub InstallCustomApplicationLicense( _
   ByVal ApplicationID As String, _
   ByVal NewLicenseContent As String _
)

Parameters

ApplicationID
The GUID of the target application.
NewLicenseContent
The content of the new license.

Remarks

Requires M-Files 12.0.6700.0 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

UninstallCustomApplication Method
ApplicationID
The application ID.
VaultCustomApplicationManagementOperations Object : UninstallCustomApplication Method

Glossary Item Box

Description

Uninstalls the specified custom application from the vault.

Syntax

Visual Basic
Public Sub UninstallCustomApplication( _
   ByVal ApplicationID As String _
)

Parameters

ApplicationID
The application ID.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultCustomApplicationManagementOperations Object | VaultCustomApplicationManagementOperations Members


%%PageItemTitle%%

VaultDataSetOperations Object
Members See Also Send comments

Glossary Item Box

Description

VaultDataSetOperations is an interface to get, trigger the refreshing of, and monitor data sets.

Public Methods

Public Method GetDataSetExportingStatus | Gets the exporting status for a data set export operation.
Public Method GetDataSets | Gets all data sets available for export from the vault.
Public Method GetReportAccessCredentials | Gets the report access credentials for this vault.
Public Method StartDataSetExport | Manually trigger a data set export operation.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultDataSetOperations Members


%%PageItemTitle%%

GetDataSetExportingStatus Method
ID
VaultDataSetOperations Object : GetDataSetExportingStatus Method

Glossary Item Box

Description

Gets the exporting status for a data set export operation.

Syntax

Visual Basic
Public Function GetDataSetExportingStatus( _
   ByVal ID As Long _
) As DataSetExportingStatus

Parameters

ID

See Also

VaultDataSetOperations Object | VaultDataSetOperations Members


%%PageItemTitle%%

GetDataSets Method
VaultDataSetOperations Object : GetDataSets Method

Glossary Item Box

Description

Gets all data sets available for export from the vault.

Syntax

Visual Basic
Public Function GetDataSets() As DataSets

See Also

VaultDataSetOperations Object | VaultDataSetOperations Members


%%PageItemTitle%%

GetReportAccessCredentials Method
VaultDataSetOperations Object : GetReportAccessCredentials Method

Glossary Item Box

Description

Gets the report access credentials for this vault.

Syntax

Visual Basic
Public Function GetReportAccessCredentials() As ReportAccessCredentials

Remarks

These credentials can be used to access the reporting server that contains the exported data sets if user's windows credentials are not used.

See Also

VaultDataSetOperations Object | VaultDataSetOperations Members


%%PageItemTitle%%

StartDataSetExport Method
ID
VaultDataSetOperations Object : StartDataSetExport Method

Glossary Item Box

Description

Manually trigger a data set export operation.

Syntax

Visual Basic
Public Sub StartDataSetExport( _
   ByVal ID As Long _
)

Parameters

ID

See Also

VaultDataSetOperations Object | VaultDataSetOperations Members


%%PageItemTitle%%

VaultDocumentComparisonOperations Object
Members See Also Send comments

Glossary Item Box

Description

The "VaultDocumentComparisonOperations" class is an interface for accessing the document comparison operations on the server.

Public Methods

Public Method AllowDocumentComparison | Specifies whether document comparison is allowed.
Public Method Compare | Gets a URL which can be used to display the differences between two documents in the vault.
Public Method CompareWithTemporaryFile | Gets a URL which can be used to display the differences between a document in the vault and a temporarily uploaded file.

Remarks

Supported in M-Files 19.10.8339.0 and later.

See Also

VaultDocumentComparisonOperations Members


%%PageItemTitle%%

AllowDocumentComparison Method
VaultDocumentComparisonOperations Object : AllowDocumentComparison Method

Glossary Item Box

Description

Specifies whether document comparison is allowed.

Syntax

Visual Basic
Public Function AllowDocumentComparison() As Boolean

Remarks

Supported in M-Files 19.10.8339.0 and later.

See Also

VaultDocumentComparisonOperations Object | VaultDocumentComparisonOperations Members


%%PageItemTitle%%

Compare Method
ObjIdOriginal
The ID of the object to compare.
FileVerOriginal
The file version to compare.
ObjIdModified
The ID of the object to compare with.
FileVerModified
The file version to compare with.
Language
The language to use for localization of the compare UI.
AllowDownload
True if the download options should be enabled in the compare UI, false otherwise.
VaultDocumentComparisonOperations Object : Compare Method

Glossary Item Box

Description

Gets a URL which can be used to display the differences between two documents in the vault.

Syntax

Visual Basic
Public Function Compare( _
   ByVal ObjIdOriginal As ObjID, _
   ByVal FileVerOriginal As FileVer, _
   ByVal ObjIdModified As ObjID, _
   ByVal FileVerModified As FileVer, _
   ByVal Language As String, _
   ByVal AllowDownload As Boolean _
) As String

Parameters

ObjIdOriginal
The ID of the object to compare.
FileVerOriginal
The file version to compare.
ObjIdModified
The ID of the object to compare with.
FileVerModified
The file version to compare with.
Language
The language to use for localization of the compare UI.
AllowDownload
True if the download options should be enabled in the compare UI, false otherwise.

Remarks

Supported in M-Files 19.10.8339.0 and later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultDocumentComparisonOperations Object | VaultDocumentComparisonOperations Members


%%PageItemTitle%%

CompareWithTemporaryFile Method
ObjIdOriginal
The ID of the object to compare.
FileVerOriginal
The file version to compare.
UploadSessionID
The temporary file upload session ID.
UploadFileName
The file name to display in the compare UI for the temporarily uploaded file.
Language
The language to use for localization of the compare UI.
AllowDownload
True if the download options should be enabled in the compare UI, false otherwise.
VaultDocumentComparisonOperations Object : CompareWithTemporaryFile Method

Glossary Item Box

Description

Gets a URL which can be used to display the differences between a document in the vault and a temporarily uploaded file.

Syntax

Visual Basic
Public Function CompareWithTemporaryFile( _
   ByVal ObjIdOriginal As ObjID, _
   ByVal FileVerOriginal As FileVer, _
   ByVal UploadSessionID As Long, _
   ByVal UploadFileName As String, _
   ByVal Language As String, _
   ByVal AllowDownload As Boolean _
) As String

Parameters

ObjIdOriginal
The ID of the object to compare.
FileVerOriginal
The file version to compare.
UploadSessionID
The temporary file upload session ID.
UploadFileName
The file name to display in the compare UI for the temporarily uploaded file.
Language
The language to use for localization of the compare UI.
AllowDownload
True if the download options should be enabled in the compare UI, false otherwise.

Remarks

Supported in M-Files 19.10.8339.0 and later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultDocumentComparisonOperations Object | VaultDocumentComparisonOperations Members


%%PageItemTitle%%

VaultElectronicSignatureOperations Object
Members See Also Send comments

Glossary Item Box

Description

VaultElectronicSignatureOperations is an interface for working with electronic signatures.

Public Methods

Public Method AddEmptySignature | Adds an empty placeholder for the specified signature. If the specified signature already exists, it is not replaced.
Public Method AddEmptySignatures | Adds empty placeholders for all signatures. Existing signatures are not replaced.
Public Method DisconnectSignature | Disconnects the specified signature from the object. Valid signatures are marked invalid as they get disconnected.
Public Method DisconnectSignatureEx | Disconnects the specified signature from the object. Valid signatures are optionally marked invalid as they get disconnected.
Public Method DisconnectSignatures | Disconnects all signatures from the object. Valid signatures are marked invalid as they get disconnected.
Public Method DisconnectSignaturesEx | Disconnects all signatures from the object. Valid signatures are optionally marked invalid as they get disconnected.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultElectronicSignatureOperations Members


%%PageItemTitle%%

AddEmptySignature Method
ObjVer
SignatureIdentifier
VaultElectronicSignatureOperations Object : AddEmptySignature Method

Glossary Item Box

Description

Adds an empty placeholder for the specified signature. If the specified signature already exists, it is not replaced.

Syntax

Visual Basic
Public Function AddEmptySignature( _
   ByVal ObjVer As ObjVer, _
   ByVal SignatureIdentifier As String _
) As ObjectVersionAndProperties

Parameters

ObjVer
SignatureIdentifier

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultElectronicSignatureOperations Object | VaultElectronicSignatureOperations Members


%%PageItemTitle%%

AddEmptySignatures Method
ObjVer
VaultElectronicSignatureOperations Object : AddEmptySignatures Method

Glossary Item Box

Description

Adds empty placeholders for all signatures. Existing signatures are not replaced.

Syntax

Visual Basic
Public Function AddEmptySignatures( _
   ByVal ObjVer As ObjVer _
) As ObjectVersionAndProperties

Parameters

ObjVer

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultElectronicSignatureOperations Object | VaultElectronicSignatureOperations Members


%%PageItemTitle%%

DisconnectSignature Method
ObjVer
SignatureIdentifier
VaultElectronicSignatureOperations Object : DisconnectSignature Method

Glossary Item Box

Description

Disconnects the specified signature from the object. Valid signatures are marked invalid as they get disconnected.

Syntax

Visual Basic
Public Function DisconnectSignature( _
   ByVal ObjVer As ObjVer, _
   ByVal SignatureIdentifier As String _
) As ObjectVersionAndProperties

Parameters

ObjVer
SignatureIdentifier

See Also

VaultElectronicSignatureOperations Object | VaultElectronicSignatureOperations Members


%%PageItemTitle%%

DisconnectSignatureEx Method
ObjVer
The object version.
SignatureIdentifier
The identifier of the signature.
InvalidateDisconnectedSignatures
True to invalidate disconnected signatures.
VaultElectronicSignatureOperations Object : DisconnectSignatureEx Method

Glossary Item Box

Description

Disconnects the specified signature from the object. Valid signatures are optionally marked invalid as they get disconnected.

Syntax

Visual Basic
Public Function DisconnectSignatureEx( _
   ByVal ObjVer As ObjVer, _
   ByVal SignatureIdentifier As String, _
   ByVal InvalidateDisconnectedSignatures As Boolean _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version.
SignatureIdentifier
The identifier of the signature.
InvalidateDisconnectedSignatures
True to invalidate disconnected signatures.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultElectronicSignatureOperations Object | VaultElectronicSignatureOperations Members


%%PageItemTitle%%

DisconnectSignatures Method
ObjVer
The object version.
VaultElectronicSignatureOperations Object : DisconnectSignatures Method

Glossary Item Box

Description

Disconnects all signatures from the object. Valid signatures are marked invalid as they get disconnected.

Syntax

Visual Basic
Public Function DisconnectSignatures( _
   ByVal ObjVer As ObjVer _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version.

See Also

VaultElectronicSignatureOperations Object | VaultElectronicSignatureOperations Members


%%PageItemTitle%%

DisconnectSignaturesEx Method
ObjVer
The object version.
InvalidateDisconnectedSignatures
True to invalidate disconnected signatures.
VaultElectronicSignatureOperations Object : DisconnectSignaturesEx Method

Glossary Item Box

Description

Disconnects all signatures from the object. Valid signatures are optionally marked invalid as they get disconnected.

Syntax

Visual Basic
Public Function DisconnectSignaturesEx( _
   ByVal ObjVer As ObjVer, _
   ByVal InvalidateDisconnectedSignatures As Boolean _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version.
InvalidateDisconnectedSignatures
True to invalidate disconnected signatures.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultElectronicSignatureOperations Object | VaultElectronicSignatureOperations Members


%%PageItemTitle%%

VaultEventLogOperations Object
Members See Also Send comments

Glossary Item Box

Description

VaultEventLogOperations is an interface to access event logs.

Public Methods

Public Method AddCustomEventEntry | Adds a custom event entry to the server event log.
Public Method Clear | Clears the event log.
Public Method ClearRange | Clears the specified range of events in the event log.
Public Method ClearRange_32bit | Clears the range of events in log. Compatible with 32-bit development environments.
Public Method ExportAll | Exports all events to XML format.
Public Method ExportRange | Exports the specified range of events to XML format.
Public Method ExportRange_32bit | Exports the specified range of events to XML format. Compatible with 32-bit development environments.
Public Method GetIDRange | Returns the ID range of the events.
Public Method IsLoggingEnabled | Gets the current event logging status.
Public Method SetLoggingEnabled | Enables or disables the logging.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultEventLogOperations Members


%%PageItemTitle%%

AddCustomEventEntry Method
EventType
The identifier of the custom event type.
XmlData
The XML or string event data.
VaultEventLogOperations Object : AddCustomEventEntry Method

Glossary Item Box

Description

Adds a custom event entry to the server event log.

Syntax

Visual Basic
Public Function AddCustomEventEntry( _
   ByVal EventType As String, _
   ByVal XmlData As String _
) As Unknown

Parameters

EventType
The identifier of the custom event type.
XmlData
The XML or string event data.

Return Type

Returns the generated event ID.

Remarks

Requires M-Files 18.12.7201.2 or later.

See Also

VaultEventLogOperations Object | VaultEventLogOperations Members


%%PageItemTitle%%

Clear Method
VaultEventLogOperations Object : Clear Method

Glossary Item Box

Description

Clears the event log.

Syntax

Visual Basic
Public Sub Clear()

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultEventLogOperations Object | VaultEventLogOperations Members


%%PageItemTitle%%

ClearRange Method
FirstEventID
The ID of the first event that should be removed (64-bit integer).
LastEventID
The ID of the last event that should be removed (64-bit integer).
VaultEventLogOperations Object : ClearRange Method

Glossary Item Box

Description

Clears the specified range of events in the event log.

Syntax

Visual Basic
Public Sub ClearRange( _
   ByVal FirstEventID As Unknown, _
   ByVal LastEventID As Unknown _
)

Parameters

FirstEventID
The ID of the first event that should be removed (64-bit integer).
LastEventID
The ID of the last event that should be removed (64-bit integer).

Remarks

This method is available only if M-Files API is used in the server interface mode.

Note

This method requires support for 64-bit data types. Use ClearRange_32bit in development environments such as VBScript that do not support these data types.

"Development environment" should not be confused with "operating system": This method can be used in 32-bit operating systems even though it uses 64-bit data types.

See Also

VaultEventLogOperations Object | VaultEventLogOperations Members


%%PageItemTitle%%

ClearRange_32bit Method
FirstEventID
The ID of the first event that should be removed (text string).
LastEventID
The ID of the last event that should be removed (text string).
VaultEventLogOperations Object : ClearRange_32bit Method

Glossary Item Box

Description

Clears the range of events in log. Compatible with 32-bit development environments.

Syntax

Visual Basic
Public Sub ClearRange_32bit( _
   ByVal FirstEventID As String, _
   ByVal LastEventID As String _
)

Parameters

FirstEventID
The ID of the first event that should be removed (text string).
LastEventID
The ID of the last event that should be removed (text string).

Remarks

This method version is intended to be used in development environments with no support for 64-bit data types.

"Development environment" should not be confused with "operating system": This method can be used on 64-bit computers and operating systems as well.

See Also

VaultEventLogOperations Object | VaultEventLogOperations Members


%%PageItemTitle%%

ExportAll Method
VaultEventLogOperations Object : ExportAll Method

Glossary Item Box

Description

Exports all events to XML format.

Syntax

Visual Basic
Public Function ExportAll() As String

Return Type

Exported events as an XML string.

Remarks

This method is available only if M-Files API is used in the server interface mode.

An XSD schema file describing the returned XML format can be found from the Common folder under the M-Files installation directory, which is by default C:\Program Files\M-Files\[version]\Common\events.xsd.

Note

The XML Schema Definition Tool can be used to generate managed .Net classes from the schema by issuing the command xsd.exe events.xsd /classes.

See Also

VaultEventLogOperations Object | VaultEventLogOperations Members


%%PageItemTitle%%

ExportRange Method
FirstEventID
The ID of the first event that should be exported (64-bit integer).
LastEventID
The ID of the first event that should be exported (64-bit integer).
DeleteEventsAfterExporting
Boolean value of true if the exported events should be removed from the log when they are exported.
VaultEventLogOperations Object : ExportRange Method

Glossary Item Box

Description

Exports the specified range of events to XML format.

Syntax

Visual Basic
Public Function ExportRange( _
   ByVal FirstEventID As Unknown, _
   ByVal LastEventID As Unknown, _
   Optional ByVal DeleteEventsAfterExporting As Boolean = False _
) As String

Parameters

FirstEventID
The ID of the first event that should be exported (64-bit integer).
LastEventID
The ID of the first event that should be exported (64-bit integer).
DeleteEventsAfterExporting
Boolean value of true if the exported events should be removed from the log when they are exported.

Return Type

Exported events as XML string.

Remarks

This method is available only if M-Files API is used in the server interface mode.

An XSD schema file describing the returned XML format can be found from the Common folder under the M-Files installation directory, which is by default C:\Program Files\M-Files\[version]\Common\events.xsd.

Note

The XML Schema Definition Tool can be used to generate managed .Net classes from the schema by issuing the command xsd.exe events.xsd /classes.

Note

This method requires support for 64-bit data types. Use ExportRange_32bit in development environments such as VBScript that do not support these data types.

"Development environment" should not be confused with "operating system": This method can be used in 32-bit operating systems even though it uses 64-bit data types.

See Also

VaultEventLogOperations Object | VaultEventLogOperations Members


%%PageItemTitle%%

ExportRange_32bit Method
FirstEventID
The ID of the first event that should be exported as a text string.
LastEventID
The ID of the last event that should be exported (text string).
DeleteEventsAfterExporting
Boolean value of true if the exported events should be removed from the log when they are exported.
VaultEventLogOperations Object : ExportRange_32bit Method

Glossary Item Box

Description

Exports the specified range of events to XML format. Compatible with 32-bit development environments.

Syntax

Visual Basic
Public Function ExportRange_32bit( _
   ByVal FirstEventID As String, _
   ByVal LastEventID As String, _
   Optional ByVal DeleteEventsAfterExporting As Boolean = False _
) As String

Parameters

FirstEventID
The ID of the first event that should be exported as a text string.
LastEventID
The ID of the last event that should be exported (text string).
DeleteEventsAfterExporting
Boolean value of true if the exported events should be removed from the log when they are exported.

Return Type

Exported events as XML string.

Remarks

An XSD schema file describing the returned XML format can be found from the Common folder under the M-Files installation directory, which is by default C:\Program Files\M-Files\[version]\Common\events.xsd.

Note

The XML Schema Definition Tool can be used to generate managed .Net classes from the schema by issuing the command xsd.exe events.xsd /classes.

This method version is intended to be used in development environments with no support for 64-bit data types.

"Development environment" should not be confused with "operating system": This method can be used on 64-bit computers and operating systems as well.

See Also

VaultEventLogOperations Object | VaultEventLogOperations Members


%%PageItemTitle%%

GetIDRange Method
VaultEventLogOperations Object : GetIDRange Method

Glossary Item Box

Description

Returns the ID range of the events.

Syntax

Visual Basic
Public Function GetIDRange() As IDRange

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultEventLogOperations Object | VaultEventLogOperations Members


%%PageItemTitle%%

IsLoggingEnabled Method
VaultEventLogOperations Object : IsLoggingEnabled Method

Glossary Item Box

Description

Gets the current event logging status.

Syntax

Visual Basic
Public Function IsLoggingEnabled() As Boolean

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultEventLogOperations Object | VaultEventLogOperations Members


%%PageItemTitle%%

SetLoggingEnabled Method
Enabled
VaultEventLogOperations Object : SetLoggingEnabled Method

Glossary Item Box

Description

Enables or disables the logging.

Syntax

Visual Basic
Public Sub SetLoggingEnabled( _
   ByVal Enabled As Boolean _
)

Parameters

Enabled

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultEventLogOperations Object | VaultEventLogOperations Members


%%PageItemTitle%%

VaultExtensionAuthenticationOperations Object
Members See Also Send comments

Glossary Item Box

Description

The 'VaultExtensionAuthenticationOperations' class represents the available extension authentication operations.

Public Methods

Public Method GetExtensionAuthenticationStatus | Gets the extension authentication status for logged-in authentications.
Public Method GetExtensionAuthenticationTargets | Gets the available extension authentication targets.
Public Method LogInWithExtensionAuthentication | Logs in with the provided extension authentication data.
Public Method LogOutWithExtensionAuthentication | Logs out with the existing extension authentication data.
Public Method RemoveExtensionAuthenticationSpecialCredentials | Removes extension authentication data from the server-side cache.
Public Method StoreExtensionAuthenticationSpecialCredentials | Stores extension authentication data in the server-side cache.

See Also

VaultExtensionAuthenticationOperations Members


%%PageItemTitle%%

GetExtensionAuthenticationStatus Method
VaultExtensionAuthenticationOperations Object : GetExtensionAuthenticationStatus Method

Glossary Item Box

Description

Gets the extension authentication status for logged-in authentications.

Syntax

Visual Basic
Public Function GetExtensionAuthenticationStatus() As ExtensionAuthenticationStatuses

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultExtensionAuthenticationOperations Object | VaultExtensionAuthenticationOperations Members


%%PageItemTitle%%

GetExtensionAuthenticationTargets Method
VaultExtensionAuthenticationOperations Object : GetExtensionAuthenticationTargets Method

Glossary Item Box

Description

Gets the available extension authentication targets.

Syntax

Visual Basic
Public Function GetExtensionAuthenticationTargets() As ExtensionAuthenticationTargets

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultExtensionAuthenticationOperations Object | VaultExtensionAuthenticationOperations Members


%%PageItemTitle%%

LogInWithExtensionAuthentication Method
TargetID
The name of the target extension system.
ExtensionAuthenticationResponse
The authentication response data.
VaultExtensionAuthenticationOperations Object : LogInWithExtensionAuthentication Method

Glossary Item Box

Description

Logs in with the provided extension authentication data.

Syntax

Visual Basic
Public Sub LogInWithExtensionAuthentication( _
   ByVal TargetID As String, _
   ByVal ExtensionAuthenticationResponse As ExtensionAuthenticationResponse _
)

Parameters

TargetID
The name of the target extension system.
ExtensionAuthenticationResponse
The authentication response data.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultExtensionAuthenticationOperations Object | VaultExtensionAuthenticationOperations Members


%%PageItemTitle%%

LogOutWithExtensionAuthentication Method
TargetID
The name of the target extension system.
VaultExtensionAuthenticationOperations Object : LogOutWithExtensionAuthentication Method

Glossary Item Box

Description

Logs out with the existing extension authentication data.

Syntax

Visual Basic
Public Sub LogOutWithExtensionAuthentication( _
   ByVal TargetID As String _
)

Parameters

TargetID
The name of the target extension system.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultExtensionAuthenticationOperations Object | VaultExtensionAuthenticationOperations Members


%%PageItemTitle%%

RemoveExtensionAuthenticationSpecialCredentials Method
ExtensionAuthenticationSpecialUserType
Special user type specifying the target identity.
TargetID
The name of the target extension system.
VaultExtensionAuthenticationOperations Object : RemoveExtensionAuthenticationSpecialCredentials Method

Glossary Item Box

Description

Removes extension authentication data from the server-side cache.

Syntax

Visual Basic
Public Sub RemoveExtensionAuthenticationSpecialCredentials( _
   ByVal ExtensionAuthenticationSpecialUserType As MFExtensionAuthenticationSpecialUserType, _
   ByVal TargetID As String _
)

Parameters

ExtensionAuthenticationSpecialUserType
Value | Description
MFExtensionAuthenticationSpecialUserTypeCommon | Common.
MFExtensionAuthenticationSpecialUserTypeIndexer | Indexer.
MFExtensionAuthenticationSpecialUserTypeNone | No special type.
MFExtensionAuthenticationSpecialUserTypePermissions | Permissions.
Special user type specifying the target identity.
TargetID
The name of the target extension system.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultExtensionAuthenticationOperations Object | VaultExtensionAuthenticationOperations Members


%%PageItemTitle%%

StoreExtensionAuthenticationSpecialCredentials Method
ExtensionAuthenticationSpecialUserType
Special user type specifying the target identity.
TargetID
The name of the target extension system.
ExtensionAuthenticationResponse
The authentication response data.
VaultExtensionAuthenticationOperations Object : StoreExtensionAuthenticationSpecialCredentials Method

Glossary Item Box

Description

Stores extension authentication data in the server-side cache.

Syntax

Visual Basic
Public Sub StoreExtensionAuthenticationSpecialCredentials( _
   ByVal ExtensionAuthenticationSpecialUserType As MFExtensionAuthenticationSpecialUserType, _
   ByVal TargetID As String, _
   ByVal ExtensionAuthenticationResponse As ExtensionAuthenticationResponse _
)

Parameters

ExtensionAuthenticationSpecialUserType
Value | Description
MFExtensionAuthenticationSpecialUserTypeCommon | Common.
MFExtensionAuthenticationSpecialUserTypeIndexer | Indexer.
MFExtensionAuthenticationSpecialUserTypeNone | No special type.
MFExtensionAuthenticationSpecialUserTypePermissions | Permissions.
Special user type specifying the target identity.
TargetID
The name of the target extension system.
ExtensionAuthenticationResponse
The authentication response data.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultExtensionAuthenticationOperations Object | VaultExtensionAuthenticationOperations Members


%%PageItemTitle%%

VaultExtensionMethodOperations Object
Members See Also Send comments

Glossary Item Box

Description

The 'VaultExtensionMethodOperations' is an interface for executing vault extension methods.

Public Methods

Public Method DoesActiveVaultExtensionMethodExist | Checks if an active vault extension method with the specified identifer exist.
Public Method ExecuteVaultExtensionMethod | Executes the specified vault extension method.

See Also

VaultExtensionMethodOperations Members


%%PageItemTitle%%

DoesActiveVaultExtensionMethodExist Method
MethodIdentifier
The name of the extension method as seen in the "Event Handlers" dialog of M-Files Admin (under the "VaultExtensionMethod" node). The name is case insensitive.
VaultExtensionMethodOperations Object : DoesActiveVaultExtensionMethodExist Method

Glossary Item Box

Description

Checks if an active vault extension method with the specified identifer exist.

Syntax

Visual Basic
Public Function DoesActiveVaultExtensionMethodExist( _
   ByVal MethodIdentifier As String _
) As Boolean

Parameters

MethodIdentifier
The name of the extension method as seen in the "Event Handlers" dialog of M-Files Admin (under the "VaultExtensionMethod" node). The name is case insensitive.

See Also

VaultExtensionMethodOperations Object | VaultExtensionMethodOperations Members


%%PageItemTitle%%

ExecuteVaultExtensionMethod Method
See Also Example Send comments
MethodIdentifier
The name of the extension method as seen in the "Event Handlers" dialog of M-Files Admin (under the "VaultExtensionMethod" node). The name is case insensitive.
Input
The input parameters given to the extension method. String content specified by the event handler.
VaultExtensionMethodOperations Object : ExecuteVaultExtensionMethod Method

Glossary Item Box

Description

Executes the specified vault extension method.

Syntax

Visual Basic
Public Function ExecuteVaultExtensionMethod( _
   ByVal MethodIdentifier As String, _
   ByVal Input As String _
) As String

Parameters

MethodIdentifier
The name of the extension method as seen in the "Event Handlers" dialog of M-Files Admin (under the "VaultExtensionMethod" node). The name is case insensitive.
Input
The input parameters given to the extension method. String content specified by the event handler.

Remarks

The developer of the vault extension method must make sure that the user can be allowed to execute the method. In other words, the method should check the identity of the calling user and terminate if they do not have the required administrative rights in the vault.

Example

Example usage of the "ExecuteVaultExtensionMethod".
Calling an extension method (Javascript) Copy Code
// Connect to Sample Vault using M-Files Client.
var mfilesClient = new ActiveXObject( "MFilesAPI.MFilesClientApplication" );
var vault = mfilesClient.BindToVault( "Sample Vault", 0, true, false );

// Get the result from the "ObjectTypeIsOK" method.
var result = vault.ExtensionMethodOperations.ExecuteVaultExtensionMethod( "ObjectTypeIsOK", "3" );
if( result )
{
  // OK to proceed.
} else {
  // Display an error.
}
The event handler verifies that the object type ID is either "0" or "9" and returns the result.
The script in the "ObjectTypeIsOK" VaultExtensionMethod event handler (VBScript) Copy Code
If Input = "0" or Input = "9" Then
   Output = True
Else
   Output = False
End If

See Also

VaultExtensionMethodOperations Object | VaultExtensionMethodOperations Members


%%PageItemTitle%%

VaultExternalObjectOperations Object
Members See Also Send comments

Glossary Item Box

Description

A group of methods for handling external objects.

Public Methods

Public Method DemoteObjects | Removes the metadata from previously promoted objects, effectively demoting them back to unmanaged objects.
Public Method PromoteObject | Promotes an unmanaged object to a managed one.
Public Method PromoteObjects | Promotes unmanaged objects to managed objects.
Public Method ResolveManagedIDOfPromotedObject | Resolves the ID of a managed object based on the ID that it had as an unmanaged object before the promotion.

See Also

VaultExternalObjectOperations Members


%%PageItemTitle%%

DemoteObjects Method
ObjIDs
The IDs of the managed objects to be demoted.
VaultExternalObjectOperations Object : DemoteObjects Method

Glossary Item Box

Description

Removes the metadata from previously promoted objects, effectively demoting them back to unmanaged objects.

Syntax

Visual Basic
Public Function DemoteObjects( _
   ByVal ObjIDs As ObjIDs _
) As ObjectVersionAndPropertiesOfMultipleObjects

Parameters

ObjIDs
The IDs of the managed objects to be demoted.

See Also

VaultExternalObjectOperations Object | VaultExternalObjectOperations Members


%%PageItemTitle%%

PromoteObject Method
ObjVer
The unmanaged object to be promoted.
PropertyValues
The new properties for the object version.
ACLEnforcingMode
The ACL enforcing mode.
pACLProvidedCBN
The ACL provided by the user. Can be NULL if the enforcing mode is not set to "MFACLEnforcingModeProvided".
VaultExternalObjectOperations Object : PromoteObject Method

Glossary Item Box

Description

Promotes an unmanaged object to a managed one.

Syntax

Visual Basic
Public Function PromoteObject( _
   ByVal ObjVer As ObjVer, _
   ByVal PropertyValues As PropertyValues, _
   Optional ByVal ACLEnforcingMode As MFACLEnforcingMode = MFACLEnforcingModeAutomatic, _
   Optional ByVal pACLProvidedCBN As AccessControlList = 0 _
) As ObjectVersionAndProperties

Parameters

ObjVer
The unmanaged object to be promoted.
PropertyValues
The new properties for the object version.
ACLEnforcingMode
Value | Description
MFACLEnforcingModeAutomatic | The ACL previously stored for the object is used as the provided ACL.
MFACLEnforcingModeNone | The object ACL remains untouched.
MFACLEnforcingModeProvided | The ACL provided by the caller is used.
MFACLEnforcingModeResetToDefault | The ACL calculated from the properties is used as the provided ACL.
The ACL enforcing mode.
pACLProvidedCBN
The ACL provided by the user. Can be NULL if the enforcing mode is not set to "MFACLEnforcingModeProvided".

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultExternalObjectOperations Object | VaultExternalObjectOperations Members


%%PageItemTitle%%

PromoteObjects Method
ObjVers
The unmanaged objects to promote.
pIPropertyValuesOfMultipleObjects
The new properties for the object versions.
ACLEnforcingMode
The ACL enforcing mode.
pACLProvidedCBN
The ACL provided by the user. Can be NULL if the enforcing mode is not MFACLEnforcingModeProvided.
VaultExternalObjectOperations Object : PromoteObjects Method

Glossary Item Box

Description

Promotes unmanaged objects to managed objects.

Syntax

Visual Basic
Public Function PromoteObjects( _
   ByVal ObjVers As ObjVers, _
   ByVal pIPropertyValuesOfMultipleObjects As PropertyValuesOfMultipleObjectsEx, _
   Optional ByVal ACLEnforcingMode As MFACLEnforcingMode = MFACLEnforcingModeAutomatic, _
   Optional ByVal pACLProvidedCBN As AccessControlList = 0 _
) As ObjectVersionAndPropertiesOfMultipleObjects

Parameters

ObjVers
The unmanaged objects to promote.
pIPropertyValuesOfMultipleObjects
The new properties for the object versions.
ACLEnforcingMode
Value | Description
MFACLEnforcingModeAutomatic | The ACL previously stored for the object is used as the provided ACL.
MFACLEnforcingModeNone | The object ACL remains untouched.
MFACLEnforcingModeProvided | The ACL provided by the caller is used.
MFACLEnforcingModeResetToDefault | The ACL calculated from the properties is used as the provided ACL.
The ACL enforcing mode.
pACLProvidedCBN
The ACL provided by the user. Can be NULL if the enforcing mode is not MFACLEnforcingModeProvided.

Remarks

Supported in M-Files 21.11.10853.5 and later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultExternalObjectOperations Object | VaultExternalObjectOperations Members


%%PageItemTitle%%

ResolveManagedIDOfPromotedObject Method
objIdUnmanaged
The ID of the unmanaged object.
VaultExternalObjectOperations Object : ResolveManagedIDOfPromotedObject Method

Glossary Item Box

Description

Resolves the ID of a managed object based on the ID that it had as an unmanaged object before the promotion.

Syntax

Visual Basic
Public Function ResolveManagedIDOfPromotedObject( _
   ByVal objIdUnmanaged As ObjID _
) As ObjID

Parameters

objIdUnmanaged
The ID of the unmanaged object.

See Also

VaultExternalObjectOperations Object | VaultExternalObjectOperations Members


%%PageItemTitle%%

VaultLoginAccountOperations Object
Members See Also Send comments

Glossary Item Box

Description

The 'VaultLoginAccountOperations' class represents the available login account operations for a vault.

Public Methods

Public Method AddLoginAccount | Adds the specified vault login account.
Public Method ForceLogout | Forcefully logs out the users with the specified vault login accounts.
Public Method GetLoginAccount | Gets the specified vault login account.
Public Method GetLoginAccounts | Gets all vault login accounts.
Public Method GetLoginAccountsWithSessions | Gets the vault login accounts that have valid sessions established.
Public Method GetPersonalInformationFromDomain | Gets the personal information of the specified vault login account from the domain.
Public Method ModifyLoginAccount | Modifies the specified vault login account. Use the 'ModifyLoginAccountEx' method for additional options.
Public Method ModifyLoginAccountEx | Modifies the specified vault login account.
Public Method RemoveLoginAccount | Deletes the specified vault login account.
Public Method UpdateLoginPassword | Changes the password of the specified M-Files vault login account.

See Also

VaultLoginAccountOperations Members


%%PageItemTitle%%

AddLoginAccount Method
LoginAccount
The login account to be added.
Password
Password for M-Files accounts.
VaultLoginAccountOperations Object : AddLoginAccount Method

Glossary Item Box

Description

Adds the specified vault login account.

Syntax

Visual Basic
Public Sub AddLoginAccount( _
   ByVal LoginAccount As LoginAccount, _
   Optional ByVal Password As String = "" _
)

Parameters

LoginAccount
The login account to be added.
Password
Password for M-Files accounts.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultLoginAccountOperations Object | VaultLoginAccountOperations Members


%%PageItemTitle%%

ForceLogout Method
AccountNames
The names of the login accounts.
VaultLoginAccountOperations Object : ForceLogout Method

Glossary Item Box

Description

Forcefully logs out the users with the specified vault login accounts.

Syntax

Visual Basic
Public Sub ForceLogout( _
   ByVal AccountNames As Strings _
)

Parameters

AccountNames
The names of the login accounts.

See Also

VaultLoginAccountOperations Object | VaultLoginAccountOperations Members


%%PageItemTitle%%

GetLoginAccount Method
AccountName
The name of the login account.
VaultLoginAccountOperations Object : GetLoginAccount Method

Glossary Item Box

Description

Gets the specified vault login account.

Syntax

Visual Basic
Public Function GetLoginAccount( _
   ByVal AccountName As String _
) As LoginAccount

Parameters

AccountName
The name of the login account.

See Also

VaultLoginAccountOperations Object | VaultLoginAccountOperations Members


%%PageItemTitle%%

GetLoginAccounts Method
VaultLoginAccountOperations Object : GetLoginAccounts Method

Glossary Item Box

Description

Gets all vault login accounts.

Syntax

Visual Basic
Public Function GetLoginAccounts() As LoginAccounts

See Also

VaultLoginAccountOperations Object | VaultLoginAccountOperations Members


%%PageItemTitle%%

GetLoginAccountsWithSessions Method
VaultLoginAccountOperations Object : GetLoginAccountsWithSessions Method

Glossary Item Box

Description

Gets the vault login accounts that have valid sessions established.

Syntax

Visual Basic
Public Function GetLoginAccountsWithSessions() As LoginAccounts

See Also

VaultLoginAccountOperations Object | VaultLoginAccountOperations Members


%%PageItemTitle%%

GetPersonalInformationFromDomain Method
AccountName
The name of the login account.
VaultLoginAccountOperations Object : GetPersonalInformationFromDomain Method

Glossary Item Box

Description

Gets the personal information of the specified vault login account from the domain.

Syntax

Visual Basic
Public Function GetPersonalInformationFromDomain( _
   ByVal AccountName As String _
) As LoginAccountPersonalInformation

Parameters

AccountName
The name of the login account.

See Also

VaultLoginAccountOperations Object | VaultLoginAccountOperations Members


%%PageItemTitle%%

ModifyLoginAccount Method
LoginAccount
The login account to be modified.
VaultLoginAccountOperations Object : ModifyLoginAccount Method

Glossary Item Box

Description

Modifies the specified vault login account. Use the 'ModifyLoginAccountEx' method for additional options.

Syntax

Visual Basic
Public Sub ModifyLoginAccount( _
   ByVal LoginAccount As LoginAccount _
)

Parameters

LoginAccount
The login account to be modified.

See Also

VaultLoginAccountOperations Object | VaultLoginAccountOperations Members


%%PageItemTitle%%

ModifyLoginAccountEx Method
AccountName
The name of the login account to be modified.
AllowChangingUsername
Specifies whether changing the username and updating the corresponding user account is allowed.
LoginAccount
The new contents of the login account.
VaultLoginAccountOperations Object : ModifyLoginAccountEx Method

Glossary Item Box

Description

Modifies the specified vault login account.

Syntax

Visual Basic
Public Sub ModifyLoginAccountEx( _
   ByVal AccountName As String, _
   ByVal AllowChangingUsername As Boolean, _
   ByVal LoginAccount As LoginAccount _
)

Parameters

AccountName
The name of the login account to be modified.
AllowChangingUsername
Specifies whether changing the username and updating the corresponding user account is allowed.
LoginAccount
The new contents of the login account.

Remarks

Supported in M-Files 19.12.8578.6 and later.

See Also

VaultLoginAccountOperations Object | VaultLoginAccountOperations Members


%%PageItemTitle%%

RemoveLoginAccount Method
AccountName
The login account to be removed.
VaultLoginAccountOperations Object : RemoveLoginAccount Method

Glossary Item Box

Description

Deletes the specified vault login account.

Syntax

Visual Basic
Public Sub RemoveLoginAccount( _
   ByVal AccountName As String _
)

Parameters

AccountName
The login account to be removed.

See Also

VaultLoginAccountOperations Object | VaultLoginAccountOperations Members


%%PageItemTitle%%

UpdateLoginPassword Method
AccountName
The name of the login account.
NewPassword
New password for the login.
VaultLoginAccountOperations Object : UpdateLoginPassword Method

Glossary Item Box

Description

Changes the password of the specified M-Files vault login account.

Syntax

Visual Basic
Public Sub UpdateLoginPassword( _
   ByVal AccountName As String, _
   ByVal NewPassword As String _
)

Parameters

AccountName
The name of the login account.
NewPassword
New password for the login.

See Also

VaultLoginAccountOperations Object | VaultLoginAccountOperations Members


%%PageItemTitle%%

VaultManagementOperations Object
Members See Also Send comments

Glossary Item Box

Description

A group of methods for administering the vault.

Public Methods

Public Method ArchiveOldVersions | Moves old object versions, including both metadata and files, to a content package.
Public Method ExportContent | Exports content, including both metadata and files, to a content package.
Public Method GetEventHandlers | Gets the event handlers of the vault.
Public Method GetVaultProperties | Gets the vault properties.
Public Method ImportContent | Imports content from a content package.
Public Method ImportContentAsync | Imports content from a content package asynchronously.
Public Method IsAsyncJobRunning | Checks if the specified asynchronous job is running.
Public Method IsGroundLinkProxy | Checks if the vault is a Ground Link proxy.
Public Method PreviewImportContent | Previews the results of the import content job. Changes are not written into the target vault, but outputted to the summary file.
Public Method QueueAndWaitForLatestBackgroundTask | Queues and waits for the latest background task, if there are any, to finish.
Public Method RebuildFullTextSearchIndex | Starts rebuilding the full-text search index of the vault.
Public Method SetEventHandlers | Sets the event handlers of the vault.
Public Method UpdateVaultProperties

Updates the vault properties.

The vault must first be detached for the method to work correctly.

Public Method VerifyVault | Performs vault verification.
Public Method WaitAsyncJob | Waits for the specified asynchronous job to finish.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultManagementOperations Members


%%PageItemTitle%%

ArchiveOldVersions Method
ArchiveOldVersionsJob
Information about the job.
VaultManagementOperations Object : ArchiveOldVersions Method

Glossary Item Box

Description

Moves old object versions, including both metadata and files, to a content package.

Syntax

Visual Basic
Public Sub ArchiveOldVersions( _
   ByVal ArchiveOldVersionsJob As ArchiveOldVersionsJob _
)

Parameters

ArchiveOldVersionsJob
Information about the job.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

ExportContent Method
ExportContentJob
Information about the job.
VaultManagementOperations Object : ExportContent Method

Glossary Item Box

Description

Exports content, including both metadata and files, to a content package.

Syntax

Visual Basic
Public Sub ExportContent( _
   ByVal ExportContentJob As ExportContentJob _
)

Parameters

ExportContentJob
Information about the job.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

GetEventHandlers Method
VaultManagementOperations Object : GetEventHandlers Method

Glossary Item Box

Description

Gets the event handlers of the vault.

Syntax

Visual Basic
Public Function GetEventHandlers() As EventHandlers

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

GetVaultProperties Method
VaultManagementOperations Object : GetVaultProperties Method

Glossary Item Box

Description

Gets the vault properties.

Syntax

Visual Basic
Public Function GetVaultProperties() As VaultProperties

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

ImportContent Method
ImportContentJob
Information about the job.
VaultManagementOperations Object : ImportContent Method

Glossary Item Box

Description

Imports content from a content package.

Syntax

Visual Basic
Public Sub ImportContent( _
   ByVal ImportContentJob As ImportContentJob _
)

Parameters

ImportContentJob
Information about the job.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

ImportContentAsync Method
ImportContentJob
Information about the job.
VaultManagementOperations Object : ImportContentAsync Method

Glossary Item Box

Description

Imports content from a content package asynchronously.

Syntax

Visual Basic
Public Function ImportContentAsync( _
   ByVal ImportContentJob As ImportContentJob _
) As Long

Parameters

ImportContentJob
Information about the job.

Remarks

The return value is job token. Use WaitAsyncJob Method to wait until the import job is finished, or IsAsyncJobRunning Method to check if the job is still running.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

IsAsyncJobRunning Method
JobID
The ID for the asynchronous job.
VaultManagementOperations Object : IsAsyncJobRunning Method

Glossary Item Box

Description

Checks if the specified asynchronous job is running.

Syntax

Visual Basic
Public Function IsAsyncJobRunning( _
   ByVal JobID As Long _
) As Boolean

Parameters

JobID
The ID for the asynchronous job.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

IsGroundLinkProxy Method
VaultManagementOperations Object : IsGroundLinkProxy Method

Glossary Item Box

Description

Checks if the vault is a Ground Link proxy.

Syntax

Visual Basic
Public Function IsGroundLinkProxy() As Boolean

Remarks

Requires M-Files 19.8.8114.2 or later.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

PreviewImportContent Method
ImportContentJob
The import content job specification.
SummaryFile
The path to the file that will receive the summary report. If the summary file exists, it will be overwritten.
VaultManagementOperations Object : PreviewImportContent Method

Glossary Item Box

Description

Previews the results of the import content job. Changes are not written into the target vault, but outputted to the summary file.

Syntax

Visual Basic
Public Sub PreviewImportContent( _
   ByVal ImportContentJob As ImportContentJob, _
   ByVal SummaryFile As String _
)

Parameters

ImportContentJob
The import content job specification.
SummaryFile
The path to the file that will receive the summary report. If the summary file exists, it will be overwritten.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

QueueAndWaitForLatestBackgroundTask Method
VaultManagementOperations Object : QueueAndWaitForLatestBackgroundTask Method

Glossary Item Box

Description

Queues and waits for the latest background task, if there are any, to finish.

Syntax

Visual Basic
Public Sub QueueAndWaitForLatestBackgroundTask()

Remarks

Supported in M-Files 19.4.7683.3 and later.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

RebuildFullTextSearchIndex Method
Metadata
If this parameter is True, the full-text search index is rebuilt for metadata.
FileContents
If this parameter is True, the full-text search index is rebuilt for file data.
VaultManagementOperations Object : RebuildFullTextSearchIndex Method

Glossary Item Box

Description

Starts rebuilding the full-text search index of the vault.

Syntax

Visual Basic
Public Sub RebuildFullTextSearchIndex( _
   ByVal Metadata As Boolean, _
   ByVal FileContents As Boolean _
)

Parameters

Metadata
If this parameter is True, the full-text search index is rebuilt for metadata.
FileContents
If this parameter is True, the full-text search index is rebuilt for file data.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

SetEventHandlers Method
EventHandlers
The new event handler collection.
VaultManagementOperations Object : SetEventHandlers Method

Glossary Item Box

Description

Sets the event handlers of the vault.

Syntax

Visual Basic
Public Sub SetEventHandlers( _
   ByVal EventHandlers As EventHandlers _
)

Parameters

EventHandlers
The new event handler collection.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

UpdateVaultProperties Method
VaultProperties
The new collection of vault properties.
RegistrationDataOnly
If this parameter is True, only the registration-specific properties of the vault are modified.
VaultManagementOperations Object : UpdateVaultProperties Method

Glossary Item Box

Description

Updates the vault properties.

The vault must first be detached for the method to work correctly.

Syntax

Visual Basic
Public Sub UpdateVaultProperties( _
   ByVal VaultProperties As VaultProperties, _
   Optional ByVal RegistrationDataOnly As Boolean = False _
)

Parameters

VaultProperties
The new collection of vault properties.
RegistrationDataOnly
If this parameter is True, only the registration-specific properties of the vault are modified.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

VerifyVault Method
VerifyVaultJob
Information about the job.
VaultManagementOperations Object : VerifyVault Method

Glossary Item Box

Description

Performs vault verification.

Syntax

Visual Basic
Public Function VerifyVault( _
   ByVal VerifyVaultJob As VerifyVaultJob _
) As VerifyVaultJobOutput

Parameters

VerifyVaultJob
Information about the job.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

WaitAsyncJob Method
JobID
The ID for the asynchronous job.
VaultManagementOperations Object : WaitAsyncJob Method

Glossary Item Box

Description

Waits for the specified asynchronous job to finish.

Syntax

Visual Basic
Public Sub WaitAsyncJob( _
   ByVal JobID As Long _
)

Parameters

JobID
The ID for the asynchronous job.

See Also

VaultManagementOperations Object | VaultManagementOperations Members


%%PageItemTitle%%

VaultManagementOperationsAccess Object
Members See Also Send comments

Glossary Item Box

Description

A group of methods for administering vaults.

Public Methods

Public Method GetVaultProperties Gets the vault properties.

See Also

VaultManagementOperationsAccess Members


%%PageItemTitle%%

GetVaultProperties Method
VaultManagementOperationsAccess Object : GetVaultProperties Method

Glossary Item Box

Description

Gets the vault properties.

Syntax

Visual Basic
Public Function GetVaultProperties() As VaultProperties

Remarks

Supported in 22.3.11177.0 and later.

See Also

VaultManagementOperationsAccess Object | VaultManagementOperationsAccess Members


%%PageItemTitle%%

VaultNamedACLOperations Object
Members See Also Send comments

Glossary Item Box

Description

The VaultNamedACLOperations class represents the available named access control list operations.

Public Methods

Public Method AddNamedACLAdmin | Adds a new named ACL. Returns the created named ACL, with the ID property set to the real ID value.
Public Method GetMatchingNamedACLForAccessControlList | Returns a named access control list that matches the specified access control list.
Public Method GetMatchingNamedACLForAccessControlListComponent | Returns a named access control list that matches the specified access control list component.
Public Method GetNamedACL | Gets the specified named ACL.
Public Method GetNamedACLAdmin | Gets the specified named ACL (for administrative operations).
Public Method GetNamedACLIDByAlias | Gets the ID of the named ACL with the specified alias. Returns -1000 if a match is not found or if more than one named ACL uses the specified alias.
Public Method GetNamedACLIDByGUID | Gets the ID of the named ACL with the specified GUID. Returns -1000 if a match is not found.
Public Method GetNamedACLs | Gets all named ACLs.
Public Method GetNamedACLsByTypeAdmin | Gets all named ACLs by their type (for administrative operations).
Public Method GetNamedACLsWithRefresh | Gets all named ACLs.
Public Method GetNamedACLWithRefresh | Gets the specified named ACL.
Public Method IsNamedACLUsedInAutomaticPermissionsAdmin | Checks whether the specified named ACL is currently used in automatic permissions.
Public Method RemoveNamedACLWithPropagationAdmin | Deletes the named ACL with the specified ID.
Public Method UpdateNamedACLAdmin | Updates the named ACL. The ID property identifies the named ACL to modify.
Public Method UpdateNamedACLWithPropagationAdmin | Updates the named ACL. The ID property identifies the named ACL to modify.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultNamedACLOperations Members


%%PageItemTitle%%

AddNamedACLAdmin Method
NamedACLAdmin
Named ACL object to add.
VaultNamedACLOperations Object : AddNamedACLAdmin Method

Glossary Item Box

Description

Adds a new named ACL. Returns the created named ACL, with the ID property set to the real ID value.

Syntax

Visual Basic
Public Function AddNamedACLAdmin( _
   ByVal NamedACLAdmin As NamedACLAdmin _
) As NamedACLAdmin

Parameters

NamedACLAdmin
Named ACL object to add.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

GetMatchingNamedACLForAccessControlList Method
AccessControlList
The specified access control list.
ExplicitLinkOnly
If true, the named ACL link is used for matching. If false, the ACE content is compared.
ActiveAccessControlComponentsOnly
If true, any deleted automatic components are ignored. If false, the existence of any automatic component causes a mismatch.
RefreshFromServer
Specifies whether to refresh the NACLs from the server if possible.
VaultNamedACLOperations Object : GetMatchingNamedACLForAccessControlList Method

Glossary Item Box

Description

Returns a named access control list that matches the specified access control list.

Syntax

Visual Basic
Public Function GetMatchingNamedACLForAccessControlList( _
   ByVal AccessControlList As AccessControlList, _
   Optional ByVal ExplicitLinkOnly As Boolean = True, _
   Optional ByVal ActiveAccessControlComponentsOnly As Boolean = False, _
   Optional ByVal RefreshFromServer As Boolean = False _
) As NamedACL

Parameters

AccessControlList
The specified access control list.
ExplicitLinkOnly
If true, the named ACL link is used for matching. If false, the ACE content is compared.
ActiveAccessControlComponentsOnly
If true, any deleted automatic components are ignored. If false, the existence of any automatic component causes a mismatch.
RefreshFromServer
Specifies whether to refresh the NACLs from the server if possible.

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

GetMatchingNamedACLForAccessControlListComponent Method
AccessControlListComponent
The specified access control list component.
ExplicitLinkOnly
If true, the named ACL link is used for matching. If false, the ACE content is compared.
RefreshFromServer
Specifies whether to refresh the NACLs from the server if possible.
VaultNamedACLOperations Object : GetMatchingNamedACLForAccessControlListComponent Method

Glossary Item Box

Description

Returns a named access control list that matches the specified access control list component.

Syntax

Visual Basic
Public Function GetMatchingNamedACLForAccessControlListComponent( _
   ByVal AccessControlListComponent As AccessControlListComponent, _
   Optional ByVal ExplicitLinkOnly As Boolean = True, _
   Optional ByVal RefreshFromServer As Boolean = False _
) As NamedACL

Parameters

AccessControlListComponent
The specified access control list component.
ExplicitLinkOnly
If true, the named ACL link is used for matching. If false, the ACE content is compared.
RefreshFromServer
Specifies whether to refresh the NACLs from the server if possible.

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

GetNamedACL Method
NamedACLID
VaultNamedACLOperations Object : GetNamedACL Method

Glossary Item Box

Description

Gets the specified named ACL.

Syntax

Visual Basic
Public Function GetNamedACL( _
   ByVal NamedACLID As Long _
) As NamedACL

Parameters

NamedACLID

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

GetNamedACLAdmin Method
NamedACLID
VaultNamedACLOperations Object : GetNamedACLAdmin Method

Glossary Item Box

Description

Gets the specified named ACL (for administrative operations).

Syntax

Visual Basic
Public Function GetNamedACLAdmin( _
   ByVal NamedACLID As Long _
) As NamedACLAdmin

Parameters

NamedACLID

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

GetNamedACLIDByAlias Method
Alias
VaultNamedACLOperations Object : GetNamedACLIDByAlias Method

Glossary Item Box

Description

Gets the ID of the named ACL with the specified alias. Returns -1000 if a match is not found or if more than one named ACL uses the specified alias.

Syntax

Visual Basic
Public Function GetNamedACLIDByAlias( _
   ByVal Alias As String _
) As Long

Parameters

Alias

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

GetNamedACLIDByGUID Method
NamedACLGUID
The GUID of the named ACL.
VaultNamedACLOperations Object : GetNamedACLIDByGUID Method

Glossary Item Box

Description

Gets the ID of the named ACL with the specified GUID. Returns -1000 if a match is not found.

Syntax

Visual Basic
Public Function GetNamedACLIDByGUID( _
   ByVal NamedACLGUID As String _
) As Long

Parameters

NamedACLGUID
The GUID of the named ACL.

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

GetNamedACLs Method
VaultNamedACLOperations Object : GetNamedACLs Method

Glossary Item Box

Description

Gets all named ACLs.

Syntax

Visual Basic
Public Function GetNamedACLs() As NamedACLs

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

GetNamedACLsByTypeAdmin Method
Type
VaultNamedACLOperations Object : GetNamedACLsByTypeAdmin Method

Glossary Item Box

Description

Gets all named ACLs by their type (for administrative operations).

Syntax

Visual Basic
Public Function GetNamedACLsByTypeAdmin( _
   Optional ByVal Type As MFNamedACLType = MFNamedACLTypeNormal _
) As NamedACLsAdmin

Parameters

Type
Value | Description
MFNamedACLTypeInternal | Internal named ACLs
MFNamedACLTypeNone | No named ACL.
MFNamedACLTypeNormal | Normal named ACL (available for selection in the UI).

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

GetNamedACLsWithRefresh Method
RefreshFromServer
VaultNamedACLOperations Object : GetNamedACLsWithRefresh Method

Glossary Item Box

Description

Gets all named ACLs.

Syntax

Visual Basic
Public Function GetNamedACLsWithRefresh( _
   Optional ByVal RefreshFromServer As Boolean = False _
) As NamedACLs

Parameters

RefreshFromServer

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

GetNamedACLWithRefresh Method
NamedACLID
RefreshFromServer
VaultNamedACLOperations Object : GetNamedACLWithRefresh Method

Glossary Item Box

Description

Gets the specified named ACL.

Syntax

Visual Basic
Public Function GetNamedACLWithRefresh( _
   ByVal NamedACLID As Long, _
   Optional ByVal RefreshFromServer As Boolean = False _
) As NamedACL

Parameters

NamedACLID
RefreshFromServer

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

IsNamedACLUsedInAutomaticPermissionsAdmin Method
NamedACLID
VaultNamedACLOperations Object : IsNamedACLUsedInAutomaticPermissionsAdmin Method

Glossary Item Box

Description

Checks whether the specified named ACL is currently used in automatic permissions.

Syntax

Visual Basic
Public Function IsNamedACLUsedInAutomaticPermissionsAdmin( _
   ByVal NamedACLID As Long _
) As Boolean

Parameters

NamedACLID

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

RemoveNamedACLWithPropagationAdmin Method
NamedACLID
AllowPropagation
VaultNamedACLOperations Object : RemoveNamedACLWithPropagationAdmin Method

Glossary Item Box

Description

Deletes the named ACL with the specified ID.

Syntax

Visual Basic
Public Sub RemoveNamedACLWithPropagationAdmin( _
   ByVal NamedACLID As Long, _
   Optional ByVal AllowPropagation As Boolean = True _
)

Parameters

NamedACLID
AllowPropagation

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

UpdateNamedACLAdmin Method
NamedACLAdmin
Named ACL object to update.
VaultNamedACLOperations Object : UpdateNamedACLAdmin Method

Glossary Item Box

Description

Updates the named ACL. The ID property identifies the named ACL to modify.

Syntax

Visual Basic
Public Sub UpdateNamedACLAdmin( _
   ByVal NamedACLAdmin As NamedACLAdmin _
)

Parameters

NamedACLAdmin
Named ACL object to update.

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

UpdateNamedACLWithPropagationAdmin Method
NamedACLAdmin
MaintainLinks
AllowPropagation
VaultNamedACLOperations Object : UpdateNamedACLWithPropagationAdmin Method

Glossary Item Box

Description

Updates the named ACL. The ID property identifies the named ACL to modify.

Syntax

Visual Basic
Public Sub UpdateNamedACLWithPropagationAdmin( _
   ByVal NamedACLAdmin As NamedACLAdmin, _
   Optional ByVal MaintainLinks As Boolean = True, _
   Optional ByVal AllowPropagation As Boolean = True _
)

Parameters

NamedACLAdmin
MaintainLinks
AllowPropagation

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultNamedACLOperations Object | VaultNamedACLOperations Members


%%PageItemTitle%%

VaultNamedValueStorageOperations Object
Members See Also Send comments

Glossary Item Box

Description

VaultNamedValueStorageOperations is an interface to get, set and remove stored named values.

Public Methods

Public Method GetNamedValues | Reads the named values with the specified namespace from the vault.
Public Method RemoveNamedValues | Deletes the specified named values from the vault.
Public Method SetNamedValues | Stores the named values to the vault.
Public Method SetNamedValuesIfUnmodified | Stores the named values of the "NamedValues" parameter to the vault if the values of the "ExpectedValues" parameter match the current values in the vault. If the values do not match, the operation fails.

Remarks

The named value storage is a server-side mechanism for persistently storing key-object pairs for custom application-specific purposes. The storage is shared between all the applications, therefore the name of the named values is based on a namespace-name pair for better isolation. The recommended namespace convention follows the Java or .Net package naming convention, e.g., mycompany.myapp.myfeature.

This method group interface can be accessed via the Vault object.

See Also

VaultNamedValueStorageOperations Members


%%PageItemTitle%%

GetNamedValues Method
NamedValueType
Namespace
The recommended namespace convention follows the Java or .Net package naming convention, e.g., mycompany.myapp.myfeature.
VaultNamedValueStorageOperations Object : GetNamedValues Method

Glossary Item Box

Description

Reads the named values with the specified namespace from the vault.

Syntax

Visual Basic
Public Function GetNamedValues( _
   ByVal NamedValueType As MFNamedValueType, _
   ByVal Namespace As String _
) As NamedValues

Parameters

NamedValueType
Value | Description
MFAdminConfiguration | Configuration value type (admin-readable/admin-writable).
MFConfigurationValue | Configuration value type (user readable/admin writable. Writing requires 'change metadata structure' permission).
MFFolderConfiguration | Configuration value type (user readable/admin writable. Writing requires 'manage common views' permission).
MFPrivateUserDefinedValue | Configuration value type for private user data (user readable/writable).
MFRegistryValue | Registry based value type (user readable).
MFSystemAdminConfiguration | Configuration value type (admin-readable/system admin writable).
MFUserDefinedValue | User defined value type (user readable/writable).
Namespace
The recommended namespace convention follows the Java or .Net package naming convention, e.g., mycompany.myapp.myfeature.

Return Type

Returns a collection of named values that match the requested type and namespace. An empty collection is returned if no named value was found.

See Also

VaultNamedValueStorageOperations Object | VaultNamedValueStorageOperations Members


%%PageItemTitle%%

RemoveNamedValues Method
NamedValueType
Namespace
The recommended namespace convention follows the Java or .Net package naming convention, e.g., mycompany.myapp.myfeature.
NamedValueNames
A collection of value names to be removed.
VaultNamedValueStorageOperations Object : RemoveNamedValues Method

Glossary Item Box

Description

Deletes the specified named values from the vault.

Syntax

Visual Basic
Public Sub RemoveNamedValues( _
   ByVal NamedValueType As MFNamedValueType, _
   ByVal Namespace As String, _
   ByVal NamedValueNames As Strings _
)

Parameters

NamedValueType
Value | Description
MFAdminConfiguration | Configuration value type (admin-readable/admin-writable).
MFConfigurationValue | Configuration value type (user readable/admin writable. Writing requires 'change metadata structure' permission).
MFFolderConfiguration | Configuration value type (user readable/admin writable. Writing requires 'manage common views' permission).
MFPrivateUserDefinedValue | Configuration value type for private user data (user readable/writable).
MFRegistryValue | Registry based value type (user readable).
MFSystemAdminConfiguration | Configuration value type (admin-readable/system admin writable).
MFUserDefinedValue | User defined value type (user readable/writable).
Namespace
The recommended namespace convention follows the Java or .Net package naming convention, e.g., mycompany.myapp.myfeature.
NamedValueNames
A collection of value names to be removed.

Return Type

Returns silently even when trying to remove non-existent values.

See Also

VaultNamedValueStorageOperations Object | VaultNamedValueStorageOperations Members


%%PageItemTitle%%

SetNamedValues Method
NamedValueType
Namespace
The recommended namespace convention follows the Java or .Net package naming convention, e.g., mycompany.myapp.myfeature.
NamedValues
A collection of named values to be set in context of the provided type and namespace. Any existing named values that match the criteria are removed first before the given values are stored.
VaultNamedValueStorageOperations Object : SetNamedValues Method

Glossary Item Box

Description

Stores the named values to the vault.

Syntax

Visual Basic
Public Sub SetNamedValues( _
   ByVal NamedValueType As MFNamedValueType, _
   ByVal Namespace As String, _
   ByVal NamedValues As NamedValues _
)

Parameters

NamedValueType
Value | Description
MFAdminConfiguration | Configuration value type (admin-readable/admin-writable).
MFConfigurationValue | Configuration value type (user readable/admin writable. Writing requires 'change metadata structure' permission).
MFFolderConfiguration | Configuration value type (user readable/admin writable. Writing requires 'manage common views' permission).
MFPrivateUserDefinedValue | Configuration value type for private user data (user readable/writable).
MFRegistryValue | Registry based value type (user readable).
MFSystemAdminConfiguration | Configuration value type (admin-readable/system admin writable).
MFUserDefinedValue | User defined value type (user readable/writable).
Namespace
The recommended namespace convention follows the Java or .Net package naming convention, e.g., mycompany.myapp.myfeature.
NamedValues
A collection of named values to be set in context of the provided type and namespace. Any existing named values that match the criteria are removed first before the given values are stored.

See Also

VaultNamedValueStorageOperations Object | VaultNamedValueStorageOperations Members


%%PageItemTitle%%

SetNamedValuesIfUnmodified Method
NamedValueType
The named value type to set.
Namespace
The namespace to which the saved values belong.
NamedValues
The values to set.
ExpectedValues
The values that must exist in the database to allow the method to proceed. An error is raised if the database has an unexpected value.
VaultNamedValueStorageOperations Object : SetNamedValuesIfUnmodified Method

Glossary Item Box

Description

Stores the named values of the "NamedValues" parameter to the vault if the values of the "ExpectedValues" parameter match the current values in the vault. If the values do not match, the operation fails.

Syntax

Visual Basic
Public Sub SetNamedValuesIfUnmodified( _
   ByVal NamedValueType As MFNamedValueType, _
   ByVal Namespace As String, _
   ByVal NamedValues As NamedValues, _
   ByVal ExpectedValues As NamedValues _
)

Parameters

NamedValueType
Value | Description
MFAdminConfiguration | Configuration value type (admin-readable/admin-writable).
MFConfigurationValue | Configuration value type (user readable/admin writable. Writing requires 'change metadata structure' permission).
MFFolderConfiguration | Configuration value type (user readable/admin writable. Writing requires 'manage common views' permission).
MFPrivateUserDefinedValue | Configuration value type for private user data (user readable/writable).
MFRegistryValue | Registry based value type (user readable).
MFSystemAdminConfiguration | Configuration value type (admin-readable/system admin writable).
MFUserDefinedValue | User defined value type (user readable/writable).
The named value type to set.
Namespace
The namespace to which the saved values belong.
NamedValues
The values to set.
ExpectedValues
The values that must exist in the database to allow the method to proceed. An error is raised if the database has an unexpected value.

Remarks

Supported in M-Files 19.4.7683.3 and later.

See Also

VaultNamedValueStorageOperations Object | VaultNamedValueStorageOperations Members


%%PageItemTitle%%

VaultNotificationOperations Object
Members See Also Send comments

Glossary Item Box

Description

The 'VaultNotificationOperations' is an interface for sending notifications to the users of the vault.

Public Methods

Public Method GetNotificationRuleNamesByID | Gets notification rule names by ID.
Public Method SendCustomNotification | Sends a notification for vault users or external parties.

See Also

VaultNotificationOperations Members


%%PageItemTitle%%

GetNotificationRuleNamesByID Method
VaultNotificationOperations Object : GetNotificationRuleNamesByID Method

Glossary Item Box

Description

Gets notification rule names by ID.

Syntax

Visual Basic
Public Function GetNotificationRuleNamesByID() As KeyNamePairs

Remarks

Supported in M-Files 19.12.8578.6 and later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultNotificationOperations Object | VaultNotificationOperations Members


%%PageItemTitle%%

SendCustomNotification Method
UserOrUserGroupIDs
A collection of user and user group IDs.
IncludeSubstituteUsers
If true, the notification message is sent to the substitutes of the receiving users as well.
ExternalRecipients
A collection of external recipient email addresses.
SendWithServerEmailIdentity
True to send with the preconfigured identity on MFServer, false to use caller identity. The sender's identity is used as a reply-to address of the notification email.
Subject
The message subject.
Body
The message body. HTML content is supported.
VaultNotificationOperations Object : SendCustomNotification Method

Glossary Item Box

Description

Sends a notification for vault users or external parties.

Syntax

Visual Basic
Public Sub SendCustomNotification( _
   ByVal UserOrUserGroupIDs As UserOrUserGroupIDs, _
   ByVal IncludeSubstituteUsers As Boolean, _
   ByVal ExternalRecipients As Strings, _
   ByVal SendWithServerEmailIdentity As Boolean, _
   ByVal Subject As String, _
   ByVal Body As String _
)

Parameters

UserOrUserGroupIDs
A collection of user and user group IDs.
IncludeSubstituteUsers
If true, the notification message is sent to the substitutes of the receiving users as well.
ExternalRecipients
A collection of external recipient email addresses.
SendWithServerEmailIdentity
True to send with the preconfigured identity on MFServer, false to use caller identity. The sender's identity is used as a reply-to address of the notification email.
Subject
The message subject.
Body
The message body. HTML content is supported.

Remarks

This method is available only if M-Files API is used in the server interface mode.

If the method does not use the caller's own identity, but instead the "SendWithServerEmailIdentity" argument, the caller is required to have server administrator rights. Sending with the caller's own identity makes the caller email address appear as a 'reply-to' address. The method fails if the sender's email address is not valid.

The notification email is sent only if the notification messages are enabled via the M-Files Server Administrator settings.

See Also

VaultNotificationOperations Object | VaultNotificationOperations Members


%%PageItemTitle%%

VaultObjectFileOperations Object
Members See Also Example Send comments

Glossary Item Box

Description

A group of methods for creating and modifying object files.

Public Methods

Public Method AddEmptyFile | Adds an empty file to an existing object.
Public Method AddFile | Adds a new file to the specified object based on the given path.
Public Method CancelFileDownloadSession | Stops the specified file download.
Public Method CloseUploadSession | Closes the upload session.
Public Method ConvertToPDF | Converts the specified object file to PDF format.
Public Method DownloadFile | Downloads the content of the specified file from the server to the specified path.
Public Method DownloadFileAsDataURI | Downloads the content of the specified file as a data URI.
Public Method DownloadFileAsDataURIEx | Downloads the content of the specified file as a data URI.
Public Method DownloadFileEx | Downloads the content of the specified file from the server to the specified path.
Public Method DownloadFileEx2 | Downloads the content of the specified file from the server to the specified path.
Public Method DownloadFileEx3 | Downloads the content of the specified file from the server to the specified path.
Public Method DownloadFileInBlocks_Begin | Begins the block-by-block download of the specified file.
Public Method DownloadFileInBlocks_Begin_32bit | Begins the block-by-block download of the specified file (uses 32-bit arguments).
Public Method DownloadFileInBlocks_Begin_32bitEx | Begins the block-by-block download of the specified file (using 32-bit arguments).
Public Method DownloadFileInBlocks_BeginEx | Begins the block-by-block download of the specified file.
Public Method DownloadFileInBlocks_BeginEx_32bit | Begins the block-by-block download of the specified file (uses 32-bit arguments).
Public Method DownloadFileInBlocks_BeginEx_32bitEx | Begins the block-by-block download of the specified file (using 32-bit arguments).
Public Method DownloadFileInBlocks_BeginEx2 | Begins the block-by-block download of the specified file.
Public Method DownloadFileInBlocks_BeginEx3 | Begins the block-by-block download of the specified file.
Public Method DownloadFileInBlocks_ReadBlock | Retrieves a specific block of the specified file from the server.
Public Method DownloadFileInBlocks_ReadBlock_32bit | Retrieves a specific block of the specified file from the server (uses 32-bit arguments).
Public Method FindEmailDuplicates | Searches the vault for duplicate emails based on the given message ID.
Public Method FindFileDuplicates | Locates the first 100 duplicates of a specified file version in the vault as a list of ObjIDs.
Public Method FindFileDuplicatesBasedOnPath | Searches the vault for duplicates of a file based on the given path as a list of ObjIDs.
Public Method FindFileDuplicatesOfObjVer | Locates the first 100 duplicates of a specified obj version in the vault as a list of ObjIDs.
Public Method FindFilesByChecksumWithNumericalDigests | Uses a numerical digest to search the vault for file versions with a matching MD5 checksum.
Public Method FindFilesByChecksumWithStringDigests | Uses a string digest to search the vault for file versions with a matching MD5 checksum.
Public Method FindVaultDuplicates | Finds all of the duplicates in the vault.
Public Method GetFiles | Gets all object files of the specified object.
Public Method GetFilesForModificationInEventHandler | Gets all object files of the specified object for modification in event handler.
Public Method GetFileSize | Gets the size of the specified file.
Public Method GetFileSize_32bit | Gets the size of the specified file.
Public Method GetFileSize_32bitEx | Gets the size of the specified file (using 32-bit arguments).
Public Method GetFileSizeEx | Gets the size of the specified file.
Public Method GetLatestFileVersion | Gets the latest version of the specified file.
Public Method GetObjIDOfFile | Retrieves the object of the file.
Public Method GetPathInDefaultView | Gets the path of the file in the ID view.
Public Method GetPathInDefaultViewEx | Gets the path to the file either in the ID view or a traditional folder.
Public Method GetPathInDefaultViewEx2 | Gets the path of the file in the ID view.
Public Method GetPathInDefaultViewEx3 | Gets the path to the file either in the ID view or in a traditional folder.
Public Method GetTextContentForFile | Gets the plain text content of a file in the vault.
Public Method GetTextContentForFileEx | Gets the plain text content of a file in the vault.
Public Method GetTextContentForTemporaryFile | Gets the plain text content of a temporary file.
Public Method HasFileDuplicates | Checks if duplicates of a file exist.
Public Method OpenFileInDefaultApplication | Opens the given object file in the default application as specified.
Public Method PerformOCROperation | Performs an optical character recognition operation for object file.
Public Method RemoveFile | Deletes the specified file from the specified object.
Public Method RenameFile | Renames the given file.
Public Method UpdateMetadataInFile | Updates metadata embedded in the specified file.
Public Method UploadFile | Uploads the new content of the specified file to the server.
Public Method UploadFileBlock | Uploads a block of the specified file.
Public Method UploadFileBlock_32bit | Uploads a block of the specified file (uses 32-bit arguments).
Public Method UploadFileBlockBegin | Begins uploading a file to the server.
Public Method UploadFileBlockBegin_32bit | Begins uploading a file to the server (uses 32-bit arguments).
Public Method UploadFileCommit | Commits the upload operation of the specified file.
Public Method UploadFileCommit_32bit | Commits the upload operation of the specified file (uses 32-bit arguments).
Public Method UploadFileCommit_32bitEx | Commits the upload operation of the specified file (using 32-bit arguments).
Public Method UploadFileCommitEx | Commits the upload operation of the specified file.
Public Method UploadFileEx | Uploads the new content of the specified file to the server.
Public Method UploadFromDataURI | Uploads new content for the specified document file from the specified data URI.
Public Method UploadFromDataURIEx | Uploads new content for the specified document file from the specified data URI.
Public Method UploadTemporaryFile | Uploads the specified file as a temporary file to the server.
Public Method UploadTemporaryFileBlock | Uploads a block of the specified temporary file.
Public Method UploadTemporaryFileBlock_32bit | Uploads a block of the specified temporary file (using 32-bit arguments).
Public Method UploadTemporaryFileBlockBegin | Begins uploading a temporary file to the server.
Public Method UploadTemporaryFileBlockBegin_32bit | Begins uploading a temporary file to the server (using 32-bit arguments).
Public Method UploadTemporaryFileCommit | Commits the upload operation of the specified temporary file.
Public Method UploadTemporaryFileCommit_32bit | Commits the upload operation of the specified temporary file (using 32-bit arguments).

Remarks

This method group interface can be accessed via the Vault object.

Example

Downloading and uploading document files for local file processing (Visual Basic) Copy Code
' Initialize the API and connect to a vault.
Dim oVault As MFilesAPI.Vault
' ...

' We are searching for the document with ID 123.
Dim iDocumentId As Integer
iDocumentId = 123

' Initialize an ObjID object for the search.
Dim oObjId As New MFilesAPI.ObjID
oObjId.SetIDs(MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument, iDocumentId)

' Invoke the search operation.
Dim oObjectVersion As MFilesAPI.ObjectVersion
Dim oObjectVersionAndProperties As MFilesAPI.ObjectVersionAndProperties
oObjectVersionAndProperties = oVault.ObjectOperations.GetLatestObjectVersionAndProperties(oObjId, True)
oObjectVersion = oObjectVersionAndProperties.VersionData

' Download all the files of the object.
Dim oObjectFiles As MFilesAPI.ObjectFiles = oObjectVersion.Files
For Each oObjectFile As MFilesAPI.ObjectFile In oObjectFiles
    ' Construct the target path for downloading the file.
    Dim szTargetPath = "C:\MyWorkFiles\" + oObjectFile.GetNameForFileSystem()
    ' Output the title and the extension of the object file.
    Call Console.WriteLine("Downloading '" + szTargetPath + "'")
    oVault.ObjectFileOperations.DownloadFile(oObjectFile.ID, oObjectFile.Version, szTargetPath)
Next

' Play around with the files here.
' ...

' Start uploading the files back to M-Files.
Dim oObjectVersionCheckedOut As MFilesAPI.ObjectVersion
' This object is not yet checked out for the current user, so try to check it out.
oObjectVersionCheckedOut = oVault.ObjectOperations.CheckOut(oObjId)

' Upload all the files of the object.
Dim oObjectFiles2 As MFilesAPI.ObjectFiles = oVault.ObjectFileOperations.GetFiles(oObjectVersionCheckedOut.ObjVer)
For Each oObjectFile As MFilesAPI.ObjectFile In oObjectFiles2
' Construct the source path for uploading the file.
    Dim szSourcePath = "C:\MyWorkFiles\" + oObjectFile.GetNameForFileSystem()
    ' Output the title and the extension of the object file.
    Call Console.WriteLine("Uploading '" + szSourcePath + "'")
    oVault.ObjectFileOperations.UploadFile(oObjectFile.ID, oObjectFile.Version, szSourcePath)
Next

' Finally, we must check in the changes.
oVault.ObjectOperations.CheckIn(oObjectVersionCheckedOut.ObjVer)
Getting version information about object files (Visual Basic) Copy Code
' Initialize the API and connect to a vault.
Dim oVault As MFilesAPI.Vault
' ...

' We are searching for the document with ID 123.
Dim iDocumentId As Integer
iDocumentId = 123

' Initialize an ObjID object for the search.
Dim oObjId As New MFilesAPI.ObjID
oObjId.SetIDs(MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument, iDocumentId)

' Invoke the search operation.
Dim oObjectVersionCheckedOut As MFilesAPI.ObjectVersion
Dim oObjectVersionAndProperties As MFilesAPI.ObjectVersionAndProperties
oObjectVersionAndProperties = oVault.ObjectOperations.GetLatestObjectVersionAndProperties(oObjId, True)
oObjectVersionCheckedOut = oObjectVersionAndProperties.VersionData

' Get the info for all the versions of this document.
Dim oObjectVersions As MFilesAPI.ObjectVersions
oObjectVersions = oVault.ObjectOperations.GetHistory(oObjId)

' Check if this object version is checked out to the current user.
If oObjectVersionCheckedOut.ThisVersionCheckedOut Then
    Call Console.WriteLine("Document object: '" + oObjectVersionCheckedOut.GetNameForFileSystem() + "' [checked out to me]")
    Call Console.WriteLine("   Current version: " + CStr(oObjectVersionCheckedOut.ObjVer.Version))
    Call Console.WriteLine("   Checked out: " + oObjectVersionCheckedOut.CheckedOutAtUtc + " UTC")
    ' Try to resolve the previous version number before checkout.
    If oObjectVersions.Count > 1 Then
        Dim oObjectVersionOld As MFilesAPI.ObjectVersion = oObjectVersions.Item(oObjectVersions.Count - 1)
        Call Console.WriteLine("      Latest version before checkout identified by: " + CStr(oObjectVersionOld.ObjVer.Version))
    End If
Else
    Call Console.WriteLine("Document object: '" + oObjectVersionCheckedOut.GetNameForFileSystem() + "'")
End If

' Resolve the last modification timestamp of the object.
Dim dtObjectModification As Date = oObjectVersionCheckedOut.LastModifiedUtc
Call Console.WriteLine("   Object modified: " + CStr(dtObjectModification) + " UTC")

' Process the object files.
Dim oObjectFiles As MFilesAPI.ObjectFiles = oObjectVersionCheckedOut.Files
For Each oObjectFile As MFilesAPI.ObjectFile In oObjectFiles
    ' Construct the FileVer string for the file.
    Dim szFileVer = CStr(oObjectFile.ID) + "-" + CStr(oObjectFile.Version)
    ' Output the identification of the object file.
    Call Console.WriteLine("   Document file: '" + oObjectFile.GetNameForFileSystem() + "'")
    ' Resolve the last modification timestamp of the file content.
    Dim dtContentModification As Date = oObjectFile.LastAccessTimeUtc
    Call Console.WriteLine("      Currently identified by: " + szFileVer)
    ' Try to find the previous versions of the object files.
    If oObjectVersionCheckedOut.ThisVersionCheckedOut And oObjectVersions.Count > 1 Then
        Dim oObjectFilesOld As MFilesAPI.ObjectFiles = oObjectVersions.Item(oObjectVersions.Count - 1).Files
        For Each oObjectFileOld As MFilesAPI.ObjectFile In oObjectFilesOld
            If oObjectFileOld.ID = oObjectFile.ID Then
                ' Construct the FileVer string for the previous version of the file.
                Dim szFileVerOld = CStr(oObjectFileOld.ID) + "-" + CStr(oObjectFileOld.Version)
                Call Console.WriteLine("      Latest version before checkout identified by: " + szFileVerOld)
                Call Console.WriteLine("      File content modified: " + CStr(dtContentModification) + " UTC")
            End If
        Next
    End If
Next

See Also

VaultObjectFileOperations Members


%%PageItemTitle%%

AddEmptyFile Method
ObjVer
The object version that identifies the object.
Title
The title of the new file in M-Files.
Extension
The extension of the new file in M-Files.
VaultObjectFileOperations Object : AddEmptyFile Method

Glossary Item Box

Description

Adds an empty file to an existing object.

Syntax

Visual Basic
Public Function AddEmptyFile( _
   ByVal ObjVer As ObjVer, _
   ByVal Title As String, _
   ByVal Extension As String _
) As FileVer

Parameters

ObjVer
The object version that identifies the object.
Title
The title of the new file in M-Files.
Extension
The extension of the new file in M-Files.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

AddFile Method
ObjVer
The object version that identifies the object.
Title
The title of the new file in M-Files.
Extension
The extension of the new file in M-Files.
SourcePath
The absolute path of a source file.
VaultObjectFileOperations Object : AddFile Method

Glossary Item Box

Description

Adds a new file to the specified object based on the given path.

Syntax

Visual Basic
Public Function AddFile( _
   ByVal ObjVer As ObjVer, _
   ByVal Title As String, _
   ByVal Extension As String, _
   ByVal SourcePath As String _
) As FileVer

Parameters

ObjVer
The object version that identifies the object.
Title
The title of the new file in M-Files.
Extension
The extension of the new file in M-Files.
SourcePath
The absolute path of a source file.

Remarks

This method adds a new file to a multi-file object. If the specified object is a single-file object, this method fails.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

CancelFileDownloadSession Method
DownloadID
VaultObjectFileOperations Object : CancelFileDownloadSession Method

Glossary Item Box

Description

Stops the specified file download.

Syntax

Visual Basic
Public Sub CancelFileDownloadSession( _
   ByVal DownloadID As Long _
)

Parameters

DownloadID

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

CloseUploadSession Method
UploadID
VaultObjectFileOperations Object : CloseUploadSession Method

Glossary Item Box

Description

Closes the upload session.

Syntax

Visual Basic
Public Sub CloseUploadSession( _
   ByVal UploadID As Long _
)

Parameters

UploadID

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

ConvertToPDF Method
ObjVer

Object version for the object that contains the file to be converted.

FileID
The ID for the file to be converted.
StoreAsSeparateFile
If true, the converted PDF will be stored as a separate file instead of overwriting the original one. Otherwise the file original file will be replaced with a similarly named file with the .pdf extension.
OverwriteExistingFile
If true, the conversion will overwrite any file that has the same name as the target file.
PDFA1b
If true, the converted file will be in PDF/A1-b format.
FailOnUnsupportedSourceFiles
If true, an error is thrown when trying to convert an unsupported file format. Otherwise the conversion is silently skipped.
VaultObjectFileOperations Object : ConvertToPDF Method

Glossary Item Box

Description

Converts the specified object file to PDF format.

Syntax

Visual Basic
Public Function ConvertToPDF( _
   ByVal ObjVer As ObjVer, _
   ByVal FileID As Long, _
   Optional ByVal StoreAsSeparateFile As Boolean = False, _
   Optional ByVal OverwriteExistingFile As Boolean = False, _
   Optional ByVal PDFA1b As Boolean = False, _
   Optional ByVal FailOnUnsupportedSourceFiles As Boolean = True _
) As ObjectVersion

Parameters

ObjVer

Object version for the object that contains the file to be converted.

FileID
The ID for the file to be converted.
StoreAsSeparateFile
If true, the converted PDF will be stored as a separate file instead of overwriting the original one. Otherwise the file original file will be replaced with a similarly named file with the .pdf extension.
OverwriteExistingFile
If true, the conversion will overwrite any file that has the same name as the target file.
PDFA1b
If true, the converted file will be in PDF/A1-b format.
FailOnUnsupportedSourceFiles
If true, an error is thrown when trying to convert an unsupported file format. Otherwise the conversion is silently skipped.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFile Method
File
The file ID number.
FileVersion
The version number of the file to be downloaded.
FilePath
The full path of the file to be stored.
VaultObjectFileOperations Object : DownloadFile Method

Glossary Item Box

Description

Downloads the content of the specified file from the server to the specified path.

Syntax

Visual Basic
Public Sub DownloadFile( _
   ByVal File As Long, _
   ByVal FileVersion As Long, _
   ByVal FilePath As String _
)

Parameters

File
The file ID number.
FileVersion
The version number of the file to be downloaded.
FilePath
The full path of the file to be stored.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileAsDataURI Method
See Also Example Send comments
ObjVer
The object version.
File
The file ID.
FileVersion
The file version.
VaultObjectFileOperations Object : DownloadFileAsDataURI Method

Glossary Item Box

Description

Downloads the content of the specified file as a data URI.

Syntax

Visual Basic
Public Function DownloadFileAsDataURI( _
   ByVal ObjVer As ObjVer, _
   ByVal File As Long, _
   ByVal FileVersion As Long _
) As String

Parameters

ObjVer
The object version.
File
The file ID.
FileVersion
The file version.

Remarks

The data URI scheme is a URI scheme that encodes content within the URI itself. This is especially useful within the M-Files UI Extensibility Framework. In this context, the data URIs provide a convenient method for displaying, for instance, small images located in the vault in dashboard content.

Only base64-encoded data URIs are supported and MIME-type is not optional. Downloading files larger than 64MB is not supported because the whole data is be kept in the memory of the calling process.

For more information, search MSDN for "data uri".

Example

This example is directly applicable in Internet Explorer browsers only. The sample vault needs to have the name Sample Vault in M-Files Client Settings. The Javascript file needs to be named download.js.
Downloading content from a vault as a data URI and displaying it in an HTML page (Javascript) Copy Code
// Connect to Sample Vault using M-Files Client.
var mfilesClient = new ActiveXObject( "MFilesAPI.MFilesClientApplication" );
var vault = mfilesClient.BindToVault( "Sample Vault", 0, true, false );

// Add event handler which downloads an image from the Sample Vault and displays it in an image tag.
addEventHandler( window, "load", function() {

    // Create MFilesAPI.ObjVer object which represents Arch.jpg in Sample Vault.
    var archJpgObjVer = new ActiveXObject( "MFilesAPI.ObjVer" );
    archJpgObjVer.Type = 0;
    archJpgObjVer.ID = 326;
    archJpgObjVer.Version = 5;

    // Get information about that object in the vault.
    var archJpg = vault.ObjectOperations.GetObjectVersionAndProperties( archJpgObjVer, false );
    var archJpgFile = archJpg.VersionData.Files.Item( 1 );

     // Download the Arch.jpg as a data URI.
    var archAsDataUri = vault.ObjectFileOperations.DownloadFileAsDataURI( archJpg.ObjVer, archJpgFile.ID, archJpgFile.Version );

    // Set the data URI to an image tag within the HTML page.
    var image = document.getElementById( "arch" );
    image.src = archAsDataUri;
} );

/**
* Adds specified event handler to the element.
*/
function addEventHandler( element, evt, handler ) {
    if( element.addEventListener) {
        // W3C method
        element.addEventListener( evt, handler, false );
    } else if( element.attachEvent) {
        // Old IE method.
        element.attachEvent( "on"+evt, handler );
    } else {
        // Legacy method.
        element["on"+evt] = handler;
    }
}
Downloading content from a vault as a data URI and displaying it in an HTML page (HTML) Copy Code
<!DOCTYPE html>
<html>
  <head>
    <title>Arch.jpg Display</title>
    <script type="text/javascript" src="download.js"></script>
    <style>
        #arch {
          height: 250px;
          width: 250px;
        }
    </style>
  </head>
  <body>
    <h1 align=center>File Download Demo</h1>
    <h2>Arch.jpg</h1>
    <img id="arch" />
  </body>
</html>

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileAsDataURIEx Method
ObjVer
The object version.
FileVer
The file version.
VaultObjectFileOperations Object : DownloadFileAsDataURIEx Method

Glossary Item Box

Description

Downloads the content of the specified file as a data URI.

Syntax

Visual Basic
Public Function DownloadFileAsDataURIEx( _
   ByVal ObjVer As ObjVer, _
   ByVal FileVer As FileVer _
) As String

Parameters

ObjVer
The object version.
FileVer
The file version.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileEx Method
File
The file ID number.
FileVersion
The version number of the file to be downloaded.
FilePath
The full path of the file to be stored.
FileFormat
Specifies the file format to download.
VaultObjectFileOperations Object : DownloadFileEx Method

Glossary Item Box

Description

Downloads the content of the specified file from the server to the specified path.

Syntax

Visual Basic
Public Sub DownloadFileEx( _
   ByVal File As Long, _
   ByVal FileVersion As Long, _
   ByVal FilePath As String, _
   ByVal FileFormat As MFFileFormat _
)

Parameters

File
The file ID number.
FileVersion
The version number of the file to be downloaded.
FilePath
The full path of the file to be stored.
FileFormat
Value | Description
MFFileFormatDisplayOnlyPDF | PDF for display purposes only (printing, copying, etc. disabled).
MFFileFormatNative | Native file format.
MFFileFormatPDF | PDF.
Specifies the file format to download.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileEx2 Method
ObjID
The object identifier of the object that contains the file.
FileVer
The file version.
FilePath
The location where the file is stored.
VaultObjectFileOperations Object : DownloadFileEx2 Method

Glossary Item Box

Description

Downloads the content of the specified file from the server to the specified path.

Syntax

Visual Basic
Public Sub DownloadFileEx2( _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer, _
   ByVal FilePath As String _
)

Parameters

ObjID
The object identifier of the object that contains the file.
FileVer
The file version.
FilePath
The location where the file is stored.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileEx3 Method
ObjID
The object identifier of the object that contains the file.
FileVer
The file version.
FilePath
The location where the file is stored.
FileFormat
Specifies the file format to download.
VaultObjectFileOperations Object : DownloadFileEx3 Method

Glossary Item Box

Description

Downloads the content of the specified file from the server to the specified path.

Syntax

Visual Basic
Public Sub DownloadFileEx3( _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer, _
   ByVal FilePath As String, _
   ByVal FileFormat As MFFileFormat _
)

Parameters

ObjID
The object identifier of the object that contains the file.
FileVer
The file version.
FilePath
The location where the file is stored.
FileFormat
Value | Description
MFFileFormatDisplayOnlyPDF | PDF for display purposes only (printing, copying, etc. disabled).
MFFileFormatNative | Native file format.
MFFileFormatPDF | PDF.
Specifies the file format to download.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileInBlocks_Begin Method
File
The ID of the file.
FileVersion
The version of the file.
VaultObjectFileOperations Object : DownloadFileInBlocks_Begin Method

Glossary Item Box

Description

Begins the block-by-block download of the specified file.

Syntax

Visual Basic
Public Function DownloadFileInBlocks_Begin( _
   ByVal File As Long, _
   ByVal FileVersion As Long _
) As FileDownloadSession

Parameters

File
The ID of the file.
FileVersion
The version of the file.

Remarks

This method is available only if M-Files API is used in the server interface mode.

Note

This method requires support for 64-bit data types. Use DownloadFileInBlocks_Begin_32bit in development environments that do not support these data types such as VBScript.

Development environment should not be confused with the operating system: This method can be used in 32-bit operating systems.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileInBlocks_Begin_32bit Method
File
The file ID.
FileVersion
The file version.
VaultObjectFileOperations Object : DownloadFileInBlocks_Begin_32bit Method

Glossary Item Box

Description

Begins the block-by-block download of the specified file (uses 32-bit arguments).

Syntax

Visual Basic
Public Function DownloadFileInBlocks_Begin_32bit( _
   ByVal File As Long, _
   ByVal FileVersion As Long _
) As FileDownloadSession

Parameters

File
The file ID.
FileVersion
The file version.

Remarks

This method version is intended to be used in development environments with no support for 64-bit data types.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileInBlocks_Begin_32bitEx Method
ObjID
The object identifier of an object that contains the file.
FileVer
The file version.
VaultObjectFileOperations Object : DownloadFileInBlocks_Begin_32bitEx Method

Glossary Item Box

Description

Begins the block-by-block download of the specified file (using 32-bit arguments).

Syntax

Visual Basic
Public Function DownloadFileInBlocks_Begin_32bitEx( _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer _
) As FileDownloadSession

Parameters

ObjID
The object identifier of an object that contains the file.
FileVer
The file version.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileInBlocks_BeginEx Method
File
The file ID.
FileVersion
The file version.
FileFormat
Specifies the file format to download.
VaultObjectFileOperations Object : DownloadFileInBlocks_BeginEx Method

Glossary Item Box

Description

Begins the block-by-block download of the specified file.

Syntax

Visual Basic
Public Function DownloadFileInBlocks_BeginEx( _
   ByVal File As Long, _
   ByVal FileVersion As Long, _
   ByVal FileFormat As MFFileFormat _
) As FileDownloadSession

Parameters

File
The file ID.
FileVersion
The file version.
FileFormat
Value | Description
MFFileFormatDisplayOnlyPDF | PDF for display purposes only (printing, copying, etc. disabled).
MFFileFormatNative | Native file format.
MFFileFormatPDF | PDF.
Specifies the file format to download.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileInBlocks_BeginEx_32bit Method
File
The file ID.
FileVersion
The file version.
FileFormat
Specifies the file format to download.
VaultObjectFileOperations Object : DownloadFileInBlocks_BeginEx_32bit Method

Glossary Item Box

Description

Begins the block-by-block download of the specified file (uses 32-bit arguments).

Syntax

Visual Basic
Public Function DownloadFileInBlocks_BeginEx_32bit( _
   ByVal File As Long, _
   ByVal FileVersion As Long, _
   ByVal FileFormat As MFFileFormat _
) As FileDownloadSession

Parameters

File
The file ID.
FileVersion
The file version.
FileFormat
Value | Description
MFFileFormatDisplayOnlyPDF | PDF for display purposes only (printing, copying, etc. disabled).
MFFileFormatNative | Native file format.
MFFileFormatPDF | PDF.
Specifies the file format to download.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileInBlocks_BeginEx_32bitEx Method
ObjID
The object identifier of the object that contains the file.
FileVer
The file version.
FileFormat
Specifies the file format to download.
VaultObjectFileOperations Object : DownloadFileInBlocks_BeginEx_32bitEx Method

Glossary Item Box

Description

Begins the block-by-block download of the specified file (using 32-bit arguments).

Syntax

Visual Basic
Public Function DownloadFileInBlocks_BeginEx_32bitEx( _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer, _
   ByVal FileFormat As MFFileFormat _
) As FileDownloadSession

Parameters

ObjID
The object identifier of the object that contains the file.
FileVer
The file version.
FileFormat
Value | Description
MFFileFormatDisplayOnlyPDF | PDF for display purposes only (printing, copying, etc. disabled).
MFFileFormatNative | Native file format.
MFFileFormatPDF | PDF.
Specifies the file format to download.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileInBlocks_BeginEx2 Method
ObjID
The object identifier of the object that contains the file.
FileVer
The file version.
VaultObjectFileOperations Object : DownloadFileInBlocks_BeginEx2 Method

Glossary Item Box

Description

Begins the block-by-block download of the specified file.

Syntax

Visual Basic
Public Function DownloadFileInBlocks_BeginEx2( _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer _
) As FileDownloadSession

Parameters

ObjID
The object identifier of the object that contains the file.
FileVer
The file version.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileInBlocks_BeginEx3 Method
ObjID
The object identifier of the object that contains the file.
FileVer
The file version.
FileFormat
Specifies the file format to download.
VaultObjectFileOperations Object : DownloadFileInBlocks_BeginEx3 Method

Glossary Item Box

Description

Begins the block-by-block download of the specified file.

Syntax

Visual Basic
Public Function DownloadFileInBlocks_BeginEx3( _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer, _
   ByVal FileFormat As MFFileFormat _
) As FileDownloadSession

Parameters

ObjID
The object identifier of the object that contains the file.
FileVer
The file version.
FileFormat
Value | Description
MFFileFormatDisplayOnlyPDF | PDF for display purposes only (printing, copying, etc. disabled).
MFFileFormatNative | Native file format.
MFFileFormatPDF | PDF.
Specifies the file format to download.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileInBlocks_ReadBlock Method
DownloadID
The identifier of the download operation returned by DownloadFileInBlocks_Begin.
BlockSize
The number of bytes to be read. For the download session to be closed, the combined size of the blocks must exceed the actual size of the file.
Offset
The byte offset from the beginning of the file as a 64-bit integer.
VaultObjectFileOperations Object : DownloadFileInBlocks_ReadBlock Method

Glossary Item Box

Description

Retrieves a specific block of the specified file from the server.

Syntax

Visual Basic
Public Function DownloadFileInBlocks_ReadBlock( _
   ByVal DownloadID As Long, _
   ByVal BlockSize As Long, _
   ByVal Offset As Unknown _
) As Byte()

Parameters

DownloadID
The identifier of the download operation returned by DownloadFileInBlocks_Begin.
BlockSize
The number of bytes to be read. For the download session to be closed, the combined size of the blocks must exceed the actual size of the file.
Offset
The byte offset from the beginning of the file as a 64-bit integer.

Remarks

  • For the download session to be closed, the combined size of the blocks must exceed the actual size of the file.
  • This method is available only if M-Files API is used in the server interface mode.
  • This method requires support for 64-bit data types. Use DownloadFileInBlocks_ReadBlock_32bit in development environments that do not support these data types such as VBScript.

    • Development environment should not be confused with the operating system: This method can be used in 32-bit operating systems.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

DownloadFileInBlocks_ReadBlock_32bit Method
DownloadID
The identifier of the download operation returned by DownloadFileInBlocks_Begin_32bit.
BlockSize
The number of bytes to be read. For the download session to be closed, the combined size of the blocks must exceed the actual size of the file.
Offset
The byte offset from the beginning of the file.
VaultObjectFileOperations Object : DownloadFileInBlocks_ReadBlock_32bit Method

Glossary Item Box

Description

Retrieves a specific block of the specified file from the server (uses 32-bit arguments).

Syntax

Visual Basic
Public Function DownloadFileInBlocks_ReadBlock_32bit( _
   ByVal DownloadID As Long, _
   ByVal BlockSize As Long, _
   ByVal Offset As Long _
) As Byte()

Parameters

DownloadID
The identifier of the download operation returned by DownloadFileInBlocks_Begin_32bit.
BlockSize
The number of bytes to be read. For the download session to be closed, the combined size of the blocks must exceed the actual size of the file.
Offset
The byte offset from the beginning of the file.

Remarks

  • For the download session to be closed, the combined size of the blocks must exceed the actual size of the file.
  • This method version is intended to be used in development environments with no support for 64-bit data types.
  • This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

FindEmailDuplicates Method
MessageID
The ID of the message to find duplicates of.
VaultObjectFileOperations Object : FindEmailDuplicates Method

Glossary Item Box

Description

Searches the vault for duplicate emails based on the given message ID.

Syntax

Visual Basic
Public Function FindEmailDuplicates( _
   ByVal MessageID As String _
) As ObjIDs

Parameters

MessageID
The ID of the message to find duplicates of.

Remarks

Supported in M-Files 20.11.9630.6 and later.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

FindFileDuplicates Method
ObjID
The ID of the object containing the file.
FileVer
The file version of which to find duplicates.
IncludeVersionsOfThisFile
Specifies whether the results should include this file.
ExcludeFilesFromDeletedObjects
Specifies whether the results should include duplicates that belong to deleted objects.
VaultObjectFileOperations Object : FindFileDuplicates Method

Glossary Item Box

Description

Locates the first 100 duplicates of a specified file version in the vault as a list of ObjIDs.

Syntax

Visual Basic
Public Function FindFileDuplicates( _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer, _
   Optional ByVal IncludeVersionsOfThisFile As Boolean = False, _
   Optional ByVal ExcludeFilesFromDeletedObjects As Boolean = True _
) As ObjIDs

Parameters

ObjID
The ID of the object containing the file.
FileVer
The file version of which to find duplicates.
IncludeVersionsOfThisFile
Specifies whether the results should include this file.
ExcludeFilesFromDeletedObjects
Specifies whether the results should include duplicates that belong to deleted objects.

Remarks

Supported in M-Files 20.2.8777.3 and later.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

FindFileDuplicatesBasedOnPath Method
SourceFilePath
The absolute path to the source file.
ExcludeFilesFromDeletedObjects

Specifies whether the results should exclude duplicates that belong to deleted objects.

Supported in M-Files 19.3.7499.1 and later.

VaultObjectFileOperations Object : FindFileDuplicatesBasedOnPath Method

Glossary Item Box

Description

Searches the vault for duplicates of a file based on the given path as a list of ObjIDs.

Syntax

Visual Basic
Public Function FindFileDuplicatesBasedOnPath( _
   ByVal SourceFilePath As String, _
   Optional ByVal ExcludeFilesFromDeletedObjects As Boolean = True _
) As ObjIDs

Parameters

SourceFilePath
The absolute path to the source file.
ExcludeFilesFromDeletedObjects

Specifies whether the results should exclude duplicates that belong to deleted objects.

Supported in M-Files 19.3.7499.1 and later.

Remarks

Supported in M-Files 19.2.7378.0 and later.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

FindFileDuplicatesOfObjVer Method
ObjVer
The object version.
ExcludeFilesFromDeletedObjects
When this is set to "true", the results do not contain duplicates that are part of a deleted object.
VaultObjectFileOperations Object : FindFileDuplicatesOfObjVer Method

Glossary Item Box

Description

Locates the first 100 duplicates of a specified obj version in the vault as a list of ObjIDs.

Syntax

Visual Basic
Public Function FindFileDuplicatesOfObjVer( _
   ByVal ObjVer As ObjVer, _
   Optional ByVal ExcludeFilesFromDeletedObjects As Boolean = True _
) As ObjIDs

Parameters

ObjVer
The object version.
ExcludeFilesFromDeletedObjects
When this is set to "true", the results do not contain duplicates that are part of a deleted object.

Remarks

Supported in M-Files 21.11.10853.5 and later.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

FindFilesByChecksumWithNumericalDigests Method
LowDigest
Specifies the numerical value of the low-order part of the MD5 checksum.
HighDigest
Specifies the numerical value of the high-order part of the MD5 checksum.
ExcludeFilesFromDeletedObjects
When this is set to "true", the results do not contain duplicates that are part of a deleted object.
VaultObjectFileOperations Object : FindFilesByChecksumWithNumericalDigests Method

Glossary Item Box

Description

Uses a numerical digest to search the vault for file versions with a matching MD5 checksum.

Syntax

Visual Basic
Public Function FindFilesByChecksumWithNumericalDigests( _
   ByVal LowDigest As Unknown, _
   ByVal HighDigest As Unknown, _
   Optional ByVal ExcludeFilesFromDeletedObjects As Boolean = False _
) As ObjIDs

Parameters

LowDigest
Specifies the numerical value of the low-order part of the MD5 checksum.
HighDigest
Specifies the numerical value of the high-order part of the MD5 checksum.
ExcludeFilesFromDeletedObjects
When this is set to "true", the results do not contain duplicates that are part of a deleted object.

Remarks

The low and high digest input values are formed by splitting the MD5 checksum into two halves. The hex values are then reversed so that, for example, B888AFC81A099519 becomes 1995091AC8AF88B8. Finally, the resulting hex numbers are converted to signed decimal numbers.

Supported in M-Files 21.11.10853.5 and later.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

FindFilesByChecksumWithStringDigests Method
MD5Digest
Specifies the string value of the MD5 checksum.
ExcludeFilesFromDeletedObjects
When this is set to "true", the results do not contain duplicates that are part of a deleted object.
VaultObjectFileOperations Object : FindFilesByChecksumWithStringDigests Method

Glossary Item Box

Description

Uses a string digest to search the vault for file versions with a matching MD5 checksum.

Syntax

Visual Basic
Public Function FindFilesByChecksumWithStringDigests( _
   ByVal MD5Digest As String, _
   Optional ByVal ExcludeFilesFromDeletedObjects As Boolean = False _
) As ObjIDs

Parameters

MD5Digest
Specifies the string value of the MD5 checksum.
ExcludeFilesFromDeletedObjects
When this is set to "true", the results do not contain duplicates that are part of a deleted object.

Remarks

Supported in M-Files 21.11.10853.5 and later.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

FindVaultDuplicates Method
ExcludeFilesFromDeletedObjects
When this is set to "true", the results do not contain duplicates that are part of a deleted object.
VaultObjectFileOperations Object : FindVaultDuplicates Method

Glossary Item Box

Description

Finds all of the duplicates in the vault.

Syntax

Visual Basic
Public Function FindVaultDuplicates( _
   Optional ByVal ExcludeFilesFromDeletedObjects As Boolean = True _
) As ObjVers

Parameters

ExcludeFilesFromDeletedObjects
When this is set to "true", the results do not contain duplicates that are part of a deleted object.

Remarks

Supported in M-Files 21.11.10853.5 and later.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetFiles Method
ObjVer
VaultObjectFileOperations Object : GetFiles Method

Glossary Item Box

Description

Gets all object files of the specified object.

Syntax

Visual Basic
Public Function GetFiles( _
   ByVal ObjVer As ObjVer _
) As ObjectFiles

Parameters

ObjVer

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetFilesForModificationInEventHandler Method
ObjVer
VaultObjectFileOperations Object : GetFilesForModificationInEventHandler Method

Glossary Item Box

Description

Gets all object files of the specified object for modification in event handler.

Syntax

Visual Basic
Public Function GetFilesForModificationInEventHandler( _
   ByVal ObjVer As ObjVer _
) As ObjectFiles

Parameters

ObjVer

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetFileSize Method
FileVer
VaultObjectFileOperations Object : GetFileSize Method

Glossary Item Box

Description

Gets the size of the specified file.

Syntax

Visual Basic
Public Function GetFileSize( _
   ByVal FileVer As FileVer _
) As Unknown

Parameters

FileVer

Return Type

The file size in bytes, as a signed 64-bit integer.

Remarks

This method is available only if M-Files API is used in the server interface mode.

Note

This method requires support for 64-bit data types. Use GetFileSize_32bit in development environments that do not support these data types such as VBScript.

Development environment should not be confused with the operating system: This method can be used in 32-bit operating systems.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetFileSize_32bit Method
FileVer
VaultObjectFileOperations Object : GetFileSize_32bit Method

Glossary Item Box

Description

Gets the size of the specified file.

Syntax

Visual Basic
Public Function GetFileSize_32bit( _
   ByVal FileVer As FileVer _
) As Long

Parameters

FileVer

Return Type

The file size in bytes, as a signed 32-bit integer.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetFileSize_32bitEx Method
ObjID
The ID of the object containing the file.
FileVer
The file version to examine.
VaultObjectFileOperations Object : GetFileSize_32bitEx Method

Glossary Item Box

Description

Gets the size of the specified file (using 32-bit arguments).

Syntax

Visual Basic
Public Function GetFileSize_32bitEx( _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer _
) As Long

Parameters

ObjID
The ID of the object containing the file.
FileVer
The file version to examine.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetFileSizeEx Method
ObjID
The ID of the object containing the file.
FileVer
The file version to examine.
VaultObjectFileOperations Object : GetFileSizeEx Method

Glossary Item Box

Description

Gets the size of the specified file.

Syntax

Visual Basic
Public Function GetFileSizeEx( _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer _
) As Unknown

Parameters

ObjID
The ID of the object containing the file.
FileVer
The file version to examine.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetLatestFileVersion Method
FileID
The ID of the file.
AllowCheckedOut
True to allow a checked out version to be returned.
VaultObjectFileOperations Object : GetLatestFileVersion Method

Glossary Item Box

Description

Gets the latest version of the specified file.

Syntax

Visual Basic
Public Function GetLatestFileVersion( _
   ByVal FileID As Long, _
   ByVal AllowCheckedOut As Boolean _
) As FileVer

Parameters

FileID
The ID of the file.
AllowCheckedOut
True to allow a checked out version to be returned.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetObjIDOfFile Method
FileID
The ID of the file.
VaultObjectFileOperations Object : GetObjIDOfFile Method

Glossary Item Box

Description

Retrieves the object of the file.

Syntax

Visual Basic
Public Function GetObjIDOfFile( _
   ByVal FileID As Long _
) As ObjID

Parameters

FileID
The ID of the file.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetPathInDefaultView Method
ObjID
The ID of the object containing the file.
ObjectVersion
The object version to target. Use "-1" for the latest version.
FileID
The ID of the file.
FileVersion
The file version. Use "-1" for the latest one.
LatestSpecificBehavior

If the target object exists with versions 1 and 2, the following table summarizes the L or S specific segments of the location path:

Flag value Requested version 1 Requested version 2 Requested version -1

MFLatestSpecificBehaviorNormal

 S/v1 L/L L/L

MFLatestSpecificBehaviorSpecific

 S/v1 S/v2 S/v2

MFLatestSpecificBehaviorLatest

 [error] L/L L/L

MFLatestSpecificBehaviorAutomatic

 S/v1 L/L L/L

UpdateFromServer
True if the information should be always updated from the server.
VaultObjectFileOperations Object : GetPathInDefaultView Method

Glossary Item Box

Description

Gets the path of the file in the ID view.

Syntax

Visual Basic
Public Function GetPathInDefaultView( _
   ByVal ObjID As ObjID, _
   ByVal ObjectVersion As Long, _
   ByVal FileID As Long, _
   ByVal FileVersion As Long, _
   Optional ByVal LatestSpecificBehavior As MFLatestSpecificBehavior = MFLatestSpecificBehaviorAutomatic, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As String

Parameters

ObjID
The ID of the object containing the file.
ObjectVersion
The object version to target. Use "-1" for the latest version.
FileID
The ID of the file.
FileVersion
The file version. Use "-1" for the latest one.
LatestSpecificBehavior
Value | Description
MFLatestSpecificBehaviorAutomatic | Automatically chooses the LatestOnly behavior (L folder) if the object version is the latest version. Otherwise, it chooses the SpecificOnly behavior (S folder). Only one location is ever returned when using this method.
MFLatestSpecificBehaviorLatest | Returns a location in the L (Latest) folder only. (Otherwise the latest version is shown in both the L and S folders.)
MFLatestSpecificBehaviorNormal | Normal behavior can return locations in both the L and S folders.
MFLatestSpecificBehaviorSpecific | Returns a location in the S (Specific) folder only, even if evaluating the latest version.

If the target object exists with versions 1 and 2, the following table summarizes the L or S specific segments of the location path:

Flag value Requested version 1 Requested version 2 Requested version -1

MFLatestSpecificBehaviorNormal

 S/v1 L/L L/L

MFLatestSpecificBehaviorSpecific

 S/v1 S/v2 S/v2

MFLatestSpecificBehaviorLatest

 [error] L/L L/L

MFLatestSpecificBehaviorAutomatic

 S/v1 L/L L/L

UpdateFromServer
True if the information should be always updated from the server.

Return Type

An absolute path of the specified object file.

Remarks

This method returns a non-volatile path to the object; the path does not change even if the object properties change. This is the recommended path for opening an object file in an application, or for storing the path.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetPathInDefaultViewEx Method
ObjID
The ID of the object containing the file.
ObjectVersion
The object version to target. Use "-1" for the latest version.
FileID
The ID of the file.
FileVersion
The file version. Use "-1" for the latest one.
LatestSpecificBehavior

If the target object exists with versions 1 and 2, the following table summarizes the L or S specific segments of the location path:

Flag value Requested version 1 Requested version 2 Requested version -1

MFLatestSpecificBehaviorNormal

 S/v1 L/L L/L

MFLatestSpecificBehaviorSpecific

 S/v1 S/v2 S/v2

MFLatestSpecificBehaviorLatest

 [error] L/L L/L

MFLatestSpecificBehaviorAutomatic

 S/v1 L/L L/L

PreferTraditionalFolderLocation
True if the file location should be in a traditional folder (given that there is one).
UpdateFromServer
True if the information should be always updated from the server.
VaultObjectFileOperations Object : GetPathInDefaultViewEx Method

Glossary Item Box

Description

Gets the path to the file either in the ID view or a traditional folder.

Syntax

Visual Basic
Public Function GetPathInDefaultViewEx( _
   ByVal ObjID As ObjID, _
   ByVal ObjectVersion As Long, _
   ByVal FileID As Long, _
   ByVal FileVersion As Long, _
   Optional ByVal LatestSpecificBehavior As MFLatestSpecificBehavior = MFLatestSpecificBehaviorAutomatic, _
   Optional ByVal PreferTraditionalFolderLocation As Boolean = False, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As String

Parameters

ObjID
The ID of the object containing the file.
ObjectVersion
The object version to target. Use "-1" for the latest version.
FileID
The ID of the file.
FileVersion
The file version. Use "-1" for the latest one.
LatestSpecificBehavior
Value | Description
MFLatestSpecificBehaviorAutomatic | Automatically chooses the LatestOnly behavior (L folder) if the object version is the latest version. Otherwise, it chooses the SpecificOnly behavior (S folder). Only one location is ever returned when using this method.
MFLatestSpecificBehaviorLatest | Returns a location in the L (Latest) folder only. (Otherwise the latest version is shown in both the L and S folders.)
MFLatestSpecificBehaviorNormal | Normal behavior can return locations in both the L and S folders.
MFLatestSpecificBehaviorSpecific | Returns a location in the S (Specific) folder only, even if evaluating the latest version.

If the target object exists with versions 1 and 2, the following table summarizes the L or S specific segments of the location path:

Flag value Requested version 1 Requested version 2 Requested version -1

MFLatestSpecificBehaviorNormal

 S/v1 L/L L/L

MFLatestSpecificBehaviorSpecific

 S/v1 S/v2 S/v2

MFLatestSpecificBehaviorLatest

 [error] L/L L/L

MFLatestSpecificBehaviorAutomatic

 S/v1 L/L L/L

PreferTraditionalFolderLocation
True if the file location should be in a traditional folder (given that there is one).
UpdateFromServer
True if the information should be always updated from the server.

Remarks

This method returns a non-volatile path to the object; the path does not change even if the object properties change. This is the recommended path for opening an object file in an application, or for storing the path.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetPathInDefaultViewEx2 Method
ObjVer
The version of the object containing the file. Use "-1" for the latest version.
FileVer
The file version. Use "-1" for the latest version.
LatestSpecificBehavior

If the target object exists with versions 1 and 2, the following table summarizes the L or S specific segments of the location path:

Flag value Requested version 1 Requested version 2 Requested version -1

MFLatestSpecificBehaviorNormal

 S/v1 L/L L/L

MFLatestSpecificBehaviorSpecific

 S/v1 S/v2 S/v2

MFLatestSpecificBehaviorLatest

 [error] L/L L/L

MFLatestSpecificBehaviorAutomatic

 S/v1 L/L L/L

UpdateFromServer
True if the information should be always updated from the server.
VaultObjectFileOperations Object : GetPathInDefaultViewEx2 Method

Glossary Item Box

Description

Gets the path of the file in the ID view.

Syntax

Visual Basic
Public Function GetPathInDefaultViewEx2( _
   ByVal ObjVer As ObjVer, _
   ByVal FileVer As FileVer, _
   Optional ByVal LatestSpecificBehavior As MFLatestSpecificBehavior = MFLatestSpecificBehaviorAutomatic, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As String

Parameters

ObjVer
The version of the object containing the file. Use "-1" for the latest version.
FileVer
The file version. Use "-1" for the latest version.
LatestSpecificBehavior
Value | Description
MFLatestSpecificBehaviorAutomatic | Automatically chooses the LatestOnly behavior (L folder) if the object version is the latest version. Otherwise, it chooses the SpecificOnly behavior (S folder). Only one location is ever returned when using this method.
MFLatestSpecificBehaviorLatest | Returns a location in the L (Latest) folder only. (Otherwise the latest version is shown in both the L and S folders.)
MFLatestSpecificBehaviorNormal | Normal behavior can return locations in both the L and S folders.
MFLatestSpecificBehaviorSpecific | Returns a location in the S (Specific) folder only, even if evaluating the latest version.

If the target object exists with versions 1 and 2, the following table summarizes the L or S specific segments of the location path:

Flag value Requested version 1 Requested version 2 Requested version -1

MFLatestSpecificBehaviorNormal

 S/v1 L/L L/L

MFLatestSpecificBehaviorSpecific

 S/v1 S/v2 S/v2

MFLatestSpecificBehaviorLatest

 [error] L/L L/L

MFLatestSpecificBehaviorAutomatic

 S/v1 L/L L/L

UpdateFromServer
True if the information should be always updated from the server.

Remarks

This method returns a non-volatile path to the object; the path does not change even if the object properties change. This is the recommended path for opening an object file in an application, or for storing the path.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetPathInDefaultViewEx3 Method
ObjVer
The version of the object containing the file. Use "-1" for the latest version.
FileVer
The file version. Use "-1" for the latest version.
LatestSpecificBehavior

If the target object exists with versions 1 and 2, the following table summarizes the L or S specific segments of the location path:

Flag value Requested version 1 Requested version 2 Requested version -1

MFLatestSpecificBehaviorNormal

 S/v1 L/L L/L

MFLatestSpecificBehaviorSpecific

 S/v1 S/v2 S/v2

MFLatestSpecificBehaviorLatest

 [error] L/L L/L

MFLatestSpecificBehaviorAutomatic

 S/v1 L/L L/L

PreferTraditionalFolderLocation
True if the file location should be in a traditional folder (given that there is one).
UpdateFromServer
True if the information should be always updated from the server.
VaultObjectFileOperations Object : GetPathInDefaultViewEx3 Method

Glossary Item Box

Description

Gets the path to the file either in the ID view or in a traditional folder.

Syntax

Visual Basic
Public Function GetPathInDefaultViewEx3( _
   ByVal ObjVer As ObjVer, _
   ByVal FileVer As FileVer, _
   Optional ByVal LatestSpecificBehavior As MFLatestSpecificBehavior = MFLatestSpecificBehaviorAutomatic, _
   Optional ByVal PreferTraditionalFolderLocation As Boolean = False, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As String

Parameters

ObjVer
The version of the object containing the file. Use "-1" for the latest version.
FileVer
The file version. Use "-1" for the latest version.
LatestSpecificBehavior
Value | Description
MFLatestSpecificBehaviorAutomatic | Automatically chooses the LatestOnly behavior (L folder) if the object version is the latest version. Otherwise, it chooses the SpecificOnly behavior (S folder). Only one location is ever returned when using this method.
MFLatestSpecificBehaviorLatest | Returns a location in the L (Latest) folder only. (Otherwise the latest version is shown in both the L and S folders.)
MFLatestSpecificBehaviorNormal | Normal behavior can return locations in both the L and S folders.
MFLatestSpecificBehaviorSpecific | Returns a location in the S (Specific) folder only, even if evaluating the latest version.

If the target object exists with versions 1 and 2, the following table summarizes the L or S specific segments of the location path:

Flag value Requested version 1 Requested version 2 Requested version -1

MFLatestSpecificBehaviorNormal

 S/v1 L/L L/L

MFLatestSpecificBehaviorSpecific

 S/v1 S/v2 S/v2

MFLatestSpecificBehaviorLatest

 [error] L/L L/L

MFLatestSpecificBehaviorAutomatic

 S/v1 L/L L/L

PreferTraditionalFolderLocation
True if the file location should be in a traditional folder (given that there is one).
UpdateFromServer
True if the information should be always updated from the server.

Remarks

This method returns a non-volatile path to the object; the path does not change even if the object properties change. This is the recommended path for opening an object file in an application, or for storing the path.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetTextContentForFile Method
ObjVer
The object version to retrieve content from.
FileVer
The file version the text content of which to retrieve.
VaultObjectFileOperations Object : GetTextContentForFile Method

Glossary Item Box

Description

Gets the plain text content of a file in the vault.

Syntax

Visual Basic
Public Function GetTextContentForFile( _
   ByVal ObjVer As ObjVer, _
   ByVal FileVer As FileVer _
) As String

Parameters

ObjVer
The object version to retrieve content from.
FileVer
The file version the text content of which to retrieve.

Remarks

Requires M-Files 12.0.6700.0 or later.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetTextContentForFileEx Method
ObjID
The ID of the object containing the file.
FileVer
The file version to get the text content from.
OptionFlags
The option flags.
VaultObjectFileOperations Object : GetTextContentForFileEx Method

Glossary Item Box

Description

Gets the plain text content of a file in the vault.

Syntax

Visual Basic
Public Function GetTextContentForFileEx( _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer, _
   ByVal OptionFlags As MFTextContentExtractionFlags _
) As String

Parameters

ObjID
The ID of the object containing the file.
FileVer
The file version to get the text content from.
OptionFlags
Value | Description
MFTextContentExtractionFlagsNone | None.
MFTextContentExtractionFlagsUnpackContainers | Specifies whether a container object should be unpacked for content extraction.
MFTextContentExtractionFlagsUsePlainTextCache | Use plain text cache. This makes other options, such as "UnpackContainers" ineffective. The operation returns the text content with global defaults in same way it is returned for e.g. search indexing.
The option flags.

Remarks

Requires M-Files 18.10.6895.1 or later.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

GetTextContentForTemporaryFile Method
UploadSessionID
The ID of the upload session.
VaultObjectFileOperations Object : GetTextContentForTemporaryFile Method

Glossary Item Box

Description

Gets the plain text content of a temporary file.

Syntax

Visual Basic
Public Function GetTextContentForTemporaryFile( _
   ByVal UploadSessionID As Long _
) As String

Parameters

UploadSessionID
The ID of the upload session.

Remarks

Requires M-Files build 12.0.6550.8 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

HasFileDuplicates Method
ObjID
The ID of the object containing the file.
FileVer
The file version of which to find duplicates.
VaultObjectFileOperations Object : HasFileDuplicates Method

Glossary Item Box

Description

Checks if duplicates of a file exist.

Syntax

Visual Basic
Public Function HasFileDuplicates( _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer _
) As Boolean

Parameters

ObjID
The ID of the object containing the file.
FileVer
The file version of which to find duplicates.

Remarks

Supported in M-Files 20.1.8669.3 and later.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

OpenFileInDefaultApplication Method
ParentWindow
ObjVer
FileVer
FileOpenMethod
VaultObjectFileOperations Object : OpenFileInDefaultApplication Method

Glossary Item Box

Description

Opens the given object file in the default application as specified.

Syntax

Visual Basic
Public Sub OpenFileInDefaultApplication( _
   ByVal ParentWindow As Long, _
   ByVal ObjVer As ObjVer, _
   ByVal FileVer As FileVer, _
   ByVal FileOpenMethod As MFFileOpenMethod _
)

Parameters

ParentWindow
ObjVer
FileVer
FileOpenMethod
Value | Description
MFFileOpenMethodEdit | Open for editing; the file is automatically checked out.
MFFileOpenMethodOpen | Default file open behavior; a checkout prompt may be displayed.
MFFileOpenMethodShowInShell | Displays the file in the M-Files user interface window.
MFFileOpenMethodView | Open for viewing; no checkout prompt.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

PerformOCROperation Method
See Also Example Send comments
ObjVer
The object identifier for the target document file.
FileVer
The file identifier for the target document file.
OCROptions

Various parameters for the OCR operation, such as languages to be used as recognition hints.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

ZoneRecognitionMode
ZoneRecognitionPages

OCR zones to be recognized as typed values. Zones are organized as a collection of pages to enable zone recognition for multipage images. Valid only if BlockRecognitionMode has value MFOCRBlockRecognitionModeRecognizeSpecifiedBlocks.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

ConvertToSearchablePDF
If this parameter is True, the target file is converted to a searchable PDF file.
VaultObjectFileOperations Object : PerformOCROperation Method

Glossary Item Box

Description

Performs an optical character recognition operation for object file.

Syntax

Visual Basic
Public Function PerformOCROperation( _
   ByVal ObjVer As ObjVer, _
   ByVal FileVer As FileVer, _
   Optional ByVal OCROptions As OCROptions = 0, _
   Optional ByVal ZoneRecognitionMode As MFOCRZoneRecognitionMode = MFOCRZoneRecognitionModeNoZoneRecognition, _
   Optional ByVal ZoneRecognitionPages As OCRPages = 0, _
   Optional ByVal ConvertToSearchablePDF As Boolean = True _
) As OCRPageResults

Parameters

ObjVer
The object identifier for the target document file.
FileVer
The file identifier for the target document file.
OCROptions

Various parameters for the OCR operation, such as languages to be used as recognition hints.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

ZoneRecognitionMode
Value | Description
MFOCRZoneRecognitionModeAutoDetectZones | Recognize all auto-detected zones.
MFOCRZoneRecognitionModeNoZoneRecognition | No zone recognition.
MFOCRZoneRecognitionModeRecognizeSpecifiedZones | Recognize user-defined zones.
ZoneRecognitionPages

OCR zones to be recognized as typed values. Zones are organized as a collection of pages to enable zone recognition for multipage images. Valid only if BlockRecognitionMode has value MFOCRBlockRecognitionModeRecognizeSpecifiedBlocks.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

ConvertToSearchablePDF
If this parameter is True, the target file is converted to a searchable PDF file.

Return Type

OCR zone recognition results are organized as a collection of pages that enable result representation for multipage images. Each page contains a set of OCR zone results that represent recognized values for each requested OCR zone. The ID of each requested zone is copied to the corresponding zone result.

Remarks

The target object must be checked out before using this method. The target file, however, must be available from the latest object version that has been already checked in. Please note that often these preconditions are not satisfied when M-Files event handlers are executed. Therefore, it is not recommended to use this method directly from event handler scripts.

You can, however, call this method from the "Run script" action of a workflow state. This is useful if you need to convert scanned documents to searchable PDF files as part of a workflow state transition. Make sure to call the 'GetFilesForModificationInEventHandler' method prior to calling 'PerformOCROperation' in the "Run script" action of a workflow state. See the code example "Converting scanned files to searchable PDF files in a workflow state action" below.

This method is available only if M-Files API is used in the server interface mode.

The OCR module for M-Files must be installed and activated.

Example

Converting scanned files to searchable PDF files in a workflow state action (VBScript) Copy Code
Option Explicit

' Prepare the files of the object for modification by script.
Dim files
Set files = Vault.ObjectFileOperations.GetFilesForModificationInEventHandler( ObjVer )

' Prepare OCR options.
Dim opts
Set opts = CreateObject( "MFilesAPI.OCROptions" )
opts.PrimaryLanguage = MFOCRLanguageEnglishUS
opts.SecondaryLanguage = MFOCRLanguageFinnish

' Perform OCR on each of the convertible files.
Dim file
For Each file In files

    ' Is the file in a convertible file format?
    If  file.Extension = "tif" Or _
        file.Extension = "tiff" Or _
        file.Extension = "jpg" Or _
        file.Extension = "jpeg" Or _
        file.Extension = "pdf" Then

        ' Convert this file to searchable PDF.
        Vault.ObjectFileOperations.PerformOCROperation ObjVer, file.FileVer, _
                opts, MFOCRZoneRecognitionModeNoZoneRecognition, Nothing, True

    End If

Next
Perform OCR operation (Visual Basic) Copy Code
' Initialize the API and connect to a vault.
Dim oServerApp As MFilesAPI.MFilesServerApplication = New MFilesAPI.MFilesServerApplication
Dim oVault As MFilesAPI.Vault
' ...

' Initialize the object version.
Dim oObjectVersion As MFilesAPI.ObjectVersion
oObjectVersion = ...

' Check out the object first. We assume that initially the object is checked in.
Dim oObjectVersionCheckedOut As MFilesAPI.ObjectVersion
oObjectVersionCheckedOut = oVault.ObjectOperations.CheckOut(oObjectVersion.ObjVer.ObjID)

' Simply process all the files of the object.
Dim oObjectFiles As MFilesAPI.ObjectFiles = oVault.ObjectFileOperations.GetFiles(oObjectVersionCheckedOut.ObjVer)
For Each oObjectFile As MFilesAPI.ObjectFile In oObjectFiles

    ' Specify OCR options.
    Dim oOcrOptions As New MFilesAPI.OCROptions
    oOcrOptions.PrimaryLanguage = MFilesAPI.MFOCRLanguage.MFOCRLanguageFinnish
    oOcrOptions.SecondaryLanguage = MFilesAPI.MFOCRLanguage.MFOCRLanguageEnglishUS

    ' Specify an OCR zone to be recognized.
    Dim oOcrZone As New MFilesAPI.OCRZone
    oOcrZone.DataType = MFilesAPI.MFDataType.MFDatatypeText
    oOcrZone.DimensionUnit = MFilesAPI.MFOCRDimensionUnit.MFOCRDimensionUnitMillimeterX10
    oOcrZone.ID = 1
    oOcrZone.Left = 1650 ' This is interpreted as 165.0 mm.
    oOcrZone.Top = 220 ' This is interpreted as 22.0 mm.
    oOcrZone.Width = 300 ' This is interpreted as 30.0 mm.
    oOcrZone.Height = 100 ' This is interpreted as 10.0 mm.

    ' Construct an OCR page object and add the OCR zone to this OCR page.
    Dim oOcrPage As New MFilesAPI.OCRPage
    oOcrPage.OCRZones.Add(0, oOcrZone)

    ' Indicate that all zones contained by this OCR page are
    ' recognized on the page 1 of the source image.
    oOcrPage.PageNum = 1

    ' Construct an OCR page collection and add the OCR page to this collection.
    Dim oOcrPages As New MFilesAPI.OCRPages
    oOcrPages.Add(0, oOcrPage)

    ' Invoke the OCR operation for the target file by requesting
    ' 1) OCR zone recognition with specific OCR zones, and
    ' 2) conversion to a searchable PDF.
    Dim oOcrPageResults As MFilesAPI.OCRPageResults = _
    oVault.ObjectFileOperations.PerformOCROperation( _
        oObjectVersionCheckedOut.ObjVer, _
        oObjectFile.FileVer, _
        oOcrOptions, _
        MFilesAPI.MFOCRZoneRecognitionMode.MFOCRZoneRecognitionModeRecognizeSpecifiedZones, _
        oOcrPages, _
        True _
    )

    ' Process the OCR zone recognition results.
    For Each oOcrPageResult As MFilesAPI.OCRPageResult In oOcrPageResults
    For Each oOcrZoneResult As MFilesAPI.OCRZoneResult In oOcrPageResult.OCRZoneResults
        Call Console.WriteLine("ID: " + CStr(oOcrZoneResult.ID))
        Call Console.WriteLine("Recognized value: " + oOcrZoneResult.ResultValue.DisplayValue)
    Next
    Next

Next

' Check in the object to finalize.
oVault.ObjectOperations.CheckIn(oObjectVersionCheckedOut.ObjVer)

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

RemoveFile Method
ObjVer
The object version that identifies the object.
FileVer
The file version that identifies the file of the object.
VaultObjectFileOperations Object : RemoveFile Method

Glossary Item Box

Description

Deletes the specified file from the specified object.

Syntax

Visual Basic
Public Function RemoveFile( _
   ByVal ObjVer As ObjVer, _
   ByVal FileVer As FileVer _
) As ObjectVersion

Parameters

ObjVer
The object version that identifies the object.
FileVer
The file version that identifies the file of the object.

Return Type

The ObjectVersion object that contains information on the object after the removal of the file.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

RenameFile Method
ObjVer
The object version identifier.
FileVer
The file version identifier.
Title
The new title (the file name without the extension) for the file.
Extension
The new extension for the file.
UpdateSingleFileDocumentTitle
If this parameter is True, the single-file document object name should be renamed to match the new file name.
VaultObjectFileOperations Object : RenameFile Method

Glossary Item Box

Description

Renames the given file.

Syntax

Visual Basic
Public Function RenameFile( _
   ByVal ObjVer As ObjVer, _
   ByVal FileVer As FileVer, _
   ByVal Title As String, _
   ByVal Extension As String, _
   Optional ByVal UpdateSingleFileDocumentTitle As Boolean = True _
) As ObjectVersion

Parameters

ObjVer
The object version identifier.
FileVer
The file version identifier.
Title
The new title (the file name without the extension) for the file.
Extension
The new extension for the file.
UpdateSingleFileDocumentTitle
If this parameter is True, the single-file document object name should be renamed to match the new file name.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UpdateMetadataInFile Method
ObjVer
The object whose file or files to update.
File

The file to be updated. Specify -1 to update all files in the object.

Note that the method updates the metadata embedded in Microsoft Word and Microsoft Excel files only.
FailOnUnsupportedFiles
If this is set to "true", an error is displayed in cases where files whose embedded metadata cannot be updated are encountered.
VaultObjectFileOperations Object : UpdateMetadataInFile Method

Glossary Item Box

Description

Updates metadata embedded in the specified file.

Syntax

Visual Basic
Public Function UpdateMetadataInFile( _
   ByVal ObjVer As ObjVer, _
   Optional ByVal File As Long = -1, _
   Optional ByVal FailOnUnsupportedFiles As Boolean = False _
) As ObjectVersion

Parameters

ObjVer
The object whose file or files to update.
File

The file to be updated. Specify -1 to update all files in the object.

Note that the method updates the metadata embedded in Microsoft Word and Microsoft Excel files only.
FailOnUnsupportedFiles
If this is set to "true", an error is displayed in cases where files whose embedded metadata cannot be updated are encountered.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadFile Method
See Also Example Send comments
File
The file ID number.
FileVersion
The version number of the file to be uploaded.
FilePath
The full path of the source file to be uploaded from.
VaultObjectFileOperations Object : UploadFile Method

Glossary Item Box

Description

Uploads the new content of the specified file to the server.

Syntax

Visual Basic
Public Sub UploadFile( _
   ByVal File As Long, _
   ByVal FileVersion As Long, _
   ByVal FilePath As String _
)

Parameters

File
The file ID number.
FileVersion
The version number of the file to be uploaded.
FilePath
The full path of the source file to be uploaded from.

Remarks

This method is available only if M-Files API is used in the server interface mode.

Example

Visual Basic Copy Code
' Identify the target document.
Dim oObjID As New MFilesAPI.ObjID
'...

' Check out the target document.
Dim oCheckedOutVersion As MFilesAPI.ObjectVersion
oCheckedOutVersion = oVault.ObjectOperations.CheckOut(oObjID)

' Determine the target file to be uploaded.
Dim oCheckedOutFiles As MFilesAPI.ObjectFiles
Dim oCheckedOutFile As MFilesAPI.ObjectFile
oCheckedOutFiles = oVault.ObjectFileOperations.GetFiles(oCheckedOutVersion.ObjVer)
oCheckedOutFile = oCheckedOutFiles.Item(1)

' Upload the file.
Dim szFile As String = "C:\Temp\File.pdf"
oVault.ObjectFileOperations.UploadFile(oCheckedOutFile.ID, oCheckedOutFile.FileVer.Version, szFile)

' Finalize with check-in.
oVault.ObjectOperations.CheckIn(oCheckedOutVersion.ObjVer)

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadFileBlock Method
UploadID
The identifier of the upload operation returned by UploadFileBlockBegin.
TotalSizeInBytes
The total size of the file as a 64-bit integer.
Offset
The byte offset from the beginning of the file as a 64-bit integer.
Block
The size of the block to be uploaded in bytes. The minimum size is 1 KB and the maximum size is 4 MB. For optimal performance always use multiples of 4096 bytes, the last block being an exception to this.
VaultObjectFileOperations Object : UploadFileBlock Method

Glossary Item Box

Description

Uploads a block of the specified file.

Syntax

Visual Basic
Public Sub UploadFileBlock( _
   ByVal UploadID As Long, _
   ByVal TotalSizeInBytes As Unknown, _
   ByVal Offset As Unknown, _
   ByVal Block() As Byte _
)

Parameters

UploadID
The identifier of the upload operation returned by UploadFileBlockBegin.
TotalSizeInBytes
The total size of the file as a 64-bit integer.
Offset
The byte offset from the beginning of the file as a 64-bit integer.
Block
The size of the block to be uploaded in bytes. The minimum size is 1 KB and the maximum size is 4 MB. For optimal performance always use multiples of 4096 bytes, the last block being an exception to this.

Remarks

This method is available only if M-Files API is used in the server interface mode.

Note

This method requires support for 64-bit data types. Use UploadFileBlock_32bit in development environments that do not support these data types such as VBScript.

Development environment should not be confused with the operating system: This method can be used in 32-bit operating systems.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadFileBlock_32bit Method
UploadID
The identifier of the upload operation returned by UploadFileBlockBegin_32bit.
TotalSizeInBytes
The total size of the file as a 32-bit integer.
Offset
The byte offset from the beginning of the file.
Block
The size of the block to be uploaded in bytes. The minimum size is 1 KB and the maximum size is 4 MB. For optimal performance always use multiples of 4096 bytes, the last block being an exception to this.
VaultObjectFileOperations Object : UploadFileBlock_32bit Method

Glossary Item Box

Description

Uploads a block of the specified file (uses 32-bit arguments).

Syntax

Visual Basic
Public Sub UploadFileBlock_32bit( _
   ByVal UploadID As Long, _
   ByVal TotalSizeInBytes As Long, _
   ByVal Offset As Long, _
   ByVal Block() As Byte _
)

Parameters

UploadID
The identifier of the upload operation returned by UploadFileBlockBegin_32bit.
TotalSizeInBytes
The total size of the file as a 32-bit integer.
Offset
The byte offset from the beginning of the file.
Block
The size of the block to be uploaded in bytes. The minimum size is 1 KB and the maximum size is 4 MB. For optimal performance always use multiples of 4096 bytes, the last block being an exception to this.

Remarks

The UploadFileBlock Method needs to be used for files of over 2 GB in size.

This method version is intended to be used in development environments with no support for 64-bit data types.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadFileBlockBegin Method
VaultObjectFileOperations Object : UploadFileBlockBegin Method

Glossary Item Box

Description

Begins uploading a file to the server.

Syntax

Visual Basic
Public Function UploadFileBlockBegin() As Long

Remarks

This method is available only if M-Files API is used in the server interface mode.

Example

This method is available only if M-Files API is used in the server interface mode.

Note

This method requires support for 64-bit data types. Use UploadFileBlockBegin_32bit in development environments that do not support these data types such as VBScript.

Development environment should not be confused with the operating system: This method can be used in 32-bit operating systems.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadFileBlockBegin_32bit Method
VaultObjectFileOperations Object : UploadFileBlockBegin_32bit Method

Glossary Item Box

Description

Begins uploading a file to the server (uses 32-bit arguments).

Syntax

Visual Basic
Public Function UploadFileBlockBegin_32bit() As Long

Remarks

This method version is intended to be used in development environments with no support for 64-bit data types.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadFileCommit Method
UploadID
The identifier of the upload operation returned by UploadFileBlockBegin.
File
FileVersion
LogicalSize
The total logical size of the file as a 64-bit integer.
VaultObjectFileOperations Object : UploadFileCommit Method

Glossary Item Box

Description

Commits the upload operation of the specified file.

Syntax

Visual Basic
Public Sub UploadFileCommit( _
   ByVal UploadID As Long, _
   ByVal File As Long, _
   ByVal FileVersion As Long, _
   ByVal LogicalSize As Unknown _
)

Parameters

UploadID
The identifier of the upload operation returned by UploadFileBlockBegin.
File
FileVersion
LogicalSize
The total logical size of the file as a 64-bit integer.

Remarks

This method is available only if M-Files API is used in the server interface mode.

Note

This method requires support for 64-bit data types. Use UploadFileBlockCommit_32bit in development environments that do not support these data types such as VBScript.

Development environment should not be confused with the operating system: This method can be used in 32-bit operating systems.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadFileCommit_32bit Method
UploadID
The identifier of the upload operation returned by UploadFileBlockBegin_32bit.
File
FileVersion
LogicalSize
The total logical size of the file.
VaultObjectFileOperations Object : UploadFileCommit_32bit Method

Glossary Item Box

Description

Commits the upload operation of the specified file (uses 32-bit arguments).

Syntax

Visual Basic
Public Sub UploadFileCommit_32bit( _
   ByVal UploadID As Long, _
   ByVal File As Long, _
   ByVal FileVersion As Long, _
   ByVal LogicalSize As Long _
)

Parameters

UploadID
The identifier of the upload operation returned by UploadFileBlockBegin_32bit.
File
FileVersion
LogicalSize
The total logical size of the file.

Remarks

This method version is intended to be used in development environments with no support for 64-bit data types.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadFileCommit_32bitEx Method
UploadID
The upload to commit.
ObjID
The object identifier of an object that contains the file.
FileVer
The file version.
LogicalSize
The logical size for the file.
VaultObjectFileOperations Object : UploadFileCommit_32bitEx Method

Glossary Item Box

Description

Commits the upload operation of the specified file (using 32-bit arguments).

Syntax

Visual Basic
Public Sub UploadFileCommit_32bitEx( _
   ByVal UploadID As Long, _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer, _
   ByVal LogicalSize As Long _
)

Parameters

UploadID
The upload to commit.
ObjID
The object identifier of an object that contains the file.
FileVer
The file version.
LogicalSize
The logical size for the file.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadFileCommitEx Method
UploadID
The upload to commit.
ObjID
The object identifier of an object that contains the file.
FileVer
The file version.
LogicalSize
The logical size for the file.
VaultObjectFileOperations Object : UploadFileCommitEx Method

Glossary Item Box

Description

Commits the upload operation of the specified file.

Syntax

Visual Basic
Public Sub UploadFileCommitEx( _
   ByVal UploadID As Long, _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer, _
   ByVal LogicalSize As Unknown _
)

Parameters

UploadID
The upload to commit.
ObjID
The object identifier of an object that contains the file.
FileVer
The file version.
LogicalSize
The logical size for the file.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadFileEx Method
ObjID
The object identifier of the object that contains the file.
FileVer
The file version.
FilePath
The path of the source file.
VaultObjectFileOperations Object : UploadFileEx Method

Glossary Item Box

Description

Uploads the new content of the specified file to the server.

Syntax

Visual Basic
Public Sub UploadFileEx( _
   ByVal ObjID As ObjID, _
   ByVal FileVer As FileVer, _
   ByVal FilePath As String _
)

Parameters

ObjID
The object identifier of the object that contains the file.
FileVer
The file version.
FilePath
The path of the source file.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadFromDataURI Method
See Also Example Send comments
ObjVer
The object version.
File
The file ID.
FileVersion
The file version.
DataURI
Data URI from which the file content is uploaded.
VaultObjectFileOperations Object : UploadFromDataURI Method

Glossary Item Box

Description

Uploads new content for the specified document file from the specified data URI.

Syntax

Visual Basic
Public Sub UploadFromDataURI( _
   ByVal ObjVer As ObjVer, _
   ByVal File As Long, _
   ByVal FileVersion As Long, _
   ByVal DataURI As String _
)

Parameters

ObjVer
The object version.
File
The file ID.
FileVersion
The file version.
DataURI
Data URI from which the file content is uploaded.

Remarks

The data URI scheme is a URI scheme that encodes content within the URI itself. This is especially useful within the M-Files UI Extensibility Framework. In this context, the data URIs allow content received via HTML5 drag and drop to be uploaded to the vault.

Only base64-encoded data URIs are supported and MIME-type is not optional. Uploading files larger than 64MB is not supported because the whole data is be kept in the memory of the calling process.

For more information, search MSDN for "data uri".

Example

This example is directly applicable in Internet Explorer browsers only. The sample vault needs to have the name Sample Vault in M-Files Client Settings. The Javascript file needs to be named upload.js.
Uploading content to a vault with drag and drop using data URIs (Javascript) Copy Code
// Register for drag-n-drop only if supported by the browser.
if( window.FileReader ) {

    // Connect to Sample Vault using M-Files Client.
    var mfilesClient = new ActiveXObject( "MFilesAPI.MFilesClientApplication" );
    var vault = mfilesClient.BindToVault( "Sample Vault", 0, true, false );

    // Add event handler which registers for listening the drag-n-drop events after the window has loaded.
    addEventHandler( window, "load", function() {

        // Get the drop target.
        var dropTarget = document.getElementById( "drop" );

        // Tells the browser that we *can* drop on this target
        addEventHandler( dropTarget, "dragover", cancel );
        addEventHandler( dropTarget, "dragenter", cancel );

        // Register handler for the actual drop event.
        addEventHandler( dropTarget, "drop", function( evt ) {

            // Get the window.event if the argument missing (in IE).
            evt = evt || window.event;

            // Prevent the browser from invoking the default action such as opening the file.
            cancel( evt );

            // Accept only one file.
            var dt = evt.dataTransfer;
            var inputFiles = dt.files;
            if( inputFiles.length != 1 ) {
                alert( "Only individual files are accepted." );
                return false;
            }

            // Prepare properties for the new document.
            var properties = new ActiveXObject( "MFilesAPI.PropertyValues" );
            var classProperty = new ActiveXObject( "MFilesAPI.PropertyValue" );
            classProperty.PropertyDef = 100;
            classProperty.TypedValue.SetValue( 9, 0 );
            properties.Add( -1, classProperty );

            // Create a new empty single-file document.
            var inputFile = inputFiles[ 0 ];
            var defaultAcl = new ActiveXObject( "MFilesAPI.AccessControlList" );
            var title = getTitle( inputFile );
            var extension = getExtension( inputFile );
            var targetObject = vault.ObjectOperations.CreateNewEmptySingleFileDocument( properties, title, extension, defaultAcl );

            // Read the file from the drag-n-drop source.
            var reader = new FileReader();
            reader.readAsDataURL( inputFile );
            addEventHandler( reader, "loadend", function( evt, loadedFile ) {

                // Upload the file received via drag-n-drop to the created document.
                var targetFile = targetObject.VersionData.Files.Item( 1 );
                vault.ObjectFileOperations.UploadFromDataURI( targetObject.ObjVer, targetFile.ID, targetFile.Version, this.result );

                // Check in the document.
                vault.ObjectOperations.CheckIn( targetObject.ObjVer );
                alert( "Upload complete." );
            } );
            return false;
        } );
    } );
} else {
    alert( "Your browser does not support the HTML5 FileReader." );
}

/**
* Adds specified event handler to the element.
*/
function addEventHandler( element, evt, handler ) {
    if( element.addEventListener) {
        // W3C method
        element.addEventListener( evt, handler, false );
    } else if( element.attachEvent) {
        // Old IE method.
        element.attachEvent( "on"+evt, handler );
    } else {
        // Legacy method.
        element["on"+evt] = handler;
    }
}

/**
* Extracts the title from the given file.
*/
function getTitle( file ) {
    var fileName = file.name;
    var title = fileName.slice( 0, fileName.lastIndexOf( "." ) );
    return title;
}

/**
* Extracts the file extension from the given file.
*/
function getExtension( file ) {
    var fileName = file.name;
    var extension = fileName.slice( fileName.lastIndexOf( "." ) + 1, fileName.length );
    return extension;
}

/**
* Function for canceling the default operation for an event.
*/
function cancel( evt ) {
    if( evt.preventDefault ) { evt.preventDefault(); }
    return false;
}
Uploading content to a vault with drag and drop using data URIs (HTML) Copy Code
<!DOCTYPE html>
<html>
  <head>
    <title>Drag&amp;drop</title>
    <script type="text/javascript" src="upload.js"></script>
    <style>
        #drop {
          height: 250px;
          width: 250px;
          border: 1px solid blue;
          margin: 10px;
          padding: 10px;
        }
    </style>
  </head>
  <body>
    <h1 align=center>File Upload Demo</h1>
    <div id="drop">
      Drop files here to upload them to the vault.
    </div>
  </body>
</html>

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadFromDataURIEx Method
ObjVer
The object version.
FileVer
The file version.
DataURI
The data URI from which the file content is uploaded.
VaultObjectFileOperations Object : UploadFromDataURIEx Method

Glossary Item Box

Description

Uploads new content for the specified document file from the specified data URI.

Syntax

Visual Basic
Public Sub UploadFromDataURIEx( _
   ByVal ObjVer As ObjVer, _
   ByVal FileVer As FileVer, _
   ByVal DataURI As String _
)

Parameters

ObjVer
The object version.
FileVer
The file version.
DataURI
The data URI from which the file content is uploaded.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadTemporaryFile Method
FilePath
Path of the source file.
VaultObjectFileOperations Object : UploadTemporaryFile Method

Glossary Item Box

Description

Uploads the specified file as a temporary file to the server.

Syntax

Visual Basic
Public Function UploadTemporaryFile( _
   ByVal FilePath As String _
) As Long

Parameters

FilePath
Path of the source file.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadTemporaryFileBlock Method
UploadID
The upload ID of the temporary file.
TotalSizeInBytes
The total size in bytes.
Offset
Offset from the beginning of the file.
Block
The block to be uploaded.
VaultObjectFileOperations Object : UploadTemporaryFileBlock Method

Glossary Item Box

Description

Uploads a block of the specified temporary file.

Syntax

Visual Basic
Public Sub UploadTemporaryFileBlock( _
   ByVal UploadID As Long, _
   ByVal TotalSizeInBytes As Unknown, _
   ByVal Offset As Unknown, _
   ByVal Block() As Byte _
)

Parameters

UploadID
The upload ID of the temporary file.
TotalSizeInBytes
The total size in bytes.
Offset
Offset from the beginning of the file.
Block
The block to be uploaded.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadTemporaryFileBlock_32bit Method
UploadID
The upload ID of the temporary file.
TotalSizeInBytes
The total size in bytes.
Offset
Offset from the beginning of the file.
Block
The block to be uploaded.
VaultObjectFileOperations Object : UploadTemporaryFileBlock_32bit Method

Glossary Item Box

Description

Uploads a block of the specified temporary file (using 32-bit arguments).

Syntax

Visual Basic
Public Sub UploadTemporaryFileBlock_32bit( _
   ByVal UploadID As Long, _
   ByVal TotalSizeInBytes As Long, _
   ByVal Offset As Long, _
   ByVal Block() As Byte _
)

Parameters

UploadID
The upload ID of the temporary file.
TotalSizeInBytes
The total size in bytes.
Offset
Offset from the beginning of the file.
Block
The block to be uploaded.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadTemporaryFileBlockBegin Method
FileExtension
The extension of the temporary file.
VaultObjectFileOperations Object : UploadTemporaryFileBlockBegin Method

Glossary Item Box

Description

Begins uploading a temporary file to the server.

Syntax

Visual Basic
Public Function UploadTemporaryFileBlockBegin( _
   ByVal FileExtension As String _
) As Long

Parameters

FileExtension
The extension of the temporary file.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadTemporaryFileBlockBegin_32bit Method
FileExtension
The extension of the temporary file.
VaultObjectFileOperations Object : UploadTemporaryFileBlockBegin_32bit Method

Glossary Item Box

Description

Begins uploading a temporary file to the server (using 32-bit arguments).

Syntax

Visual Basic
Public Function UploadTemporaryFileBlockBegin_32bit( _
   ByVal FileExtension As String _
) As Long

Parameters

FileExtension
The extension of the temporary file.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadTemporaryFileCommit Method
UploadID
The upload to be committed.
LogicalSize
The logical size of the file.
VaultObjectFileOperations Object : UploadTemporaryFileCommit Method

Glossary Item Box

Description

Commits the upload operation of the specified temporary file.

Syntax

Visual Basic
Public Sub UploadTemporaryFileCommit( _
   ByVal UploadID As Long, _
   ByVal LogicalSize As Unknown _
)

Parameters

UploadID
The upload to be committed.
LogicalSize
The logical size of the file.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

UploadTemporaryFileCommit_32bit Method
UploadID
The upload to be committed.
LogicalSize
The logical size of the file.
VaultObjectFileOperations Object : UploadTemporaryFileCommit_32bit Method

Glossary Item Box

Description

Commits the upload operation of the specified temporary file (using 32-bit arguments).

Syntax

Visual Basic
Public Sub UploadTemporaryFileCommit_32bit( _
   ByVal UploadID As Long, _
   ByVal LogicalSize As Long _
)

Parameters

UploadID
The upload to be committed.
LogicalSize
The logical size of the file.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectFileOperations Object | VaultObjectFileOperations Members


%%PageItemTitle%%

VaultObjectOperations Object
Members See Also Example Send comments

Glossary Item Box

Description

A group of methods for creating and modifying objects.

Public Methods

Public Method AddFavorite | Adds the specified object to the 'Favorites' view of the current user.
Public Method AddFavorites | Adds the specified objects to the 'Favorites' view of the current user.
Public Method ChangePermissionsToACL | Changes the permissions for the specified object.
Public Method ChangePermissionsToNamedACL | Changes the permissions for the specified object.
Public Method CheckIn | Checks in the object.
Public Method CheckInMultipleObjects | Checks in multiple objects at once.
Public Method CheckOut | Checks out the object.
Public Method CheckOutMultipleObjects | Checks out multiple objects at once.
Public Method CompareWithAnotherDocument | Compares the content of this document with the content of another one.
Public Method CompareWithAnotherVersion | Compares the content of this document version with the content of another one. Use the CompareWithAnotherVersionEx method for multi-file document support.
Public Method CompareWithAnotherVersionEx | Compares the content of this document version with the content of another one.
Public Method CompareWithPreviousVersion | Compares the content of this document version with the content of the previous one. Use the CompareWithPreviousVersionEx method for multi-file document support.
Public Method CompareWithPreviousVersionEx | Compares the content of this document version with the content of the previous one.
Public Method CopyConflictObjectAsNewVersionToBaseObject | Saves a copy of the deleted conflict object as a new version of the related base object.
Public Method CreateNewAssignment | Creates a new assignment.
Public Method CreateNewEmptySingleFileDocument | Creates a new single-file document based on the specified properties and source files.
Public Method CreateNewObject | Creates a new object based on the specified properties and source files.
Public Method CreateNewObjectEx | Creates a new object based on the specified properties and source files.
Public Method CreateNewObjectExQuick | Creates a new object based on the specified properties and source files.
Public Method CreateNewSFDObject | Creates a new single file object based on the specified properties and source file.
Public Method CreateNewSFDObjectQuick | Creates a new single file object based on the specified properties and source file.
Public Method DelayedCheckIn | Performs check-in operation for the object after any of the object's files are no longer in use.
Public Method DeleteObject | Deletes the specified object.
Public Method DestroyObject | Destroys an object or a specific version of the object. Prefer DestroyObjectEx as its parameter ObjectVersion supports unmanaged external repository objects.
Public Method DestroyObjectEx | Destroys the specified object, or a specific version of the object.
Public Method DestroyObjects | Destroys the specified objects.
Public Method FollowObject | Starts or stops following the specified object. While the object is being followed, the current user will be notified if the object changes.
Public Method ForceUndoCheckout | Performs undo checkout and enforces the operation if the user has permission to perform forced undo checkout.
Public Method GetCollectionMembers | Gets all the collection members of the specified collection.
Public Method GetHistory | Gets the history of the specified object. Use GetHistoryEx for additional options.
Public Method GetHistoryEx | Gets the extended history of the specified object with search parameters.
Public Method GetLatestObjectVersionAndProperties | Gets the latest version and properties of the specified object.
Public Method GetLatestObjVer | Gets the latest version of the specified object.
Public Method GetLatestObjVerEx | Gets the latest version of the specified object. Optionally notifies M-Files windows to update the object in their listings.
Public Method GetMFilesURLForObject | Gets an M-Files URL for the specified object.
Public Method GetMFilesURLForObjectEx | Gets an M-Files URL for the specified object.
Public Method GetMFilesURLForObjectOrFile | Gets an M-Files URL for the specified object or file.
Public Method GetMFilesURLForObjectOrFileEx | Gets an M-Files URL for the specified object or file.
Public Method GetObjectDataOfMultipleObjects | Receives the requested information of the specified objects.
Public Method GetObjectGUID | Gets the Object GUID of the specified object.
Public Method GetObjectInfo | Gets information on the specified object version.
Public Method GetObjectInfoEx | Gets information on the specified object version. Optionally notifies M-Files windows to update the object in their listings.
Public Method GetObjectLocationsInView | Gets the locations of the object in a view.
Public Method GetObjectPermissions | Gets the permissions for the specified object.
Public Method GetObjectVersionAndProperties | Gets the information on and properties of the specfied object version.
Public Method GetObjectVersionAndPropertiesOfMultipleObjects | Gets the object version and properties of the specified objects.
Public Method GetObjIDByGUID | Gets the Object ID of the object that is identified by the specified Object GUID.
Public Method GetObjIDByOriginalObjID | Gets the Object ID of the object that is identified by the specified Original Vault GUID and Original Object ID.
Public Method GetOfflineAvailability | Gets the offline availability of the specified object.
Public Method GetOfflineObjIDs | Gets the IDs of the objects set to be available offline.
Public Method GetRelatedObjectInfo | Gets information related to the specified lookup property.
Public Method GetRelationships | Gets all the relationships of the specified object.
Public Method GetRelationshipsEx | Gets all the relationships of the specified object.
Public Method GetThumbnailAsBytes | Gets the thumbnail for the specified object in PNG format.
Public Method IsObjectCheckedOut | Checks whether the specified object is checked out to any user on any computer.
Public Method IsObjectCheckedOutToThisUserOnThisComputer | Checks whether the specified object is checked out to this user on this computer.
Public Method IsObjectFollowed | Checks whether the specified object is currently followed by the current user.
Public Method IsSingleFileObject | Checks whether the specified object version is a single-file or multi-file document.
Public Method MatchesSearchConditions | Checks whether the specified object matches the search conditions. Any field expression in search conditions is not supported.
Public Method MatchesSearchConditionsEx | Checks whether the specified object and properties match the search conditions. Any field expression in search conditions is not supported.
Public Method NotifyObjectAccess | Notifies M-Files that an object has been accessed. This will add the object to the Recently Accessed by Me view of the user.
Public Method ProposeCheckOutForFile | Proposes checkout operation for the object file. System may prompt for checkout. Returns error on cancel.
Public Method RejectCheckInReminder | Prevents implicitly or explicitly triggered checkin reminder from calling process.
Public Method RemoveFavorite | Removes the specified object from the 'Favorites' view of the current user.
Public Method RemoveFavorites | Removes the specified objects from the 'Favorites' view of the current user.
Public Method ResolveConflict | Resolves a conflict that involves the specified participant object. Returns the affected objects. Do not use this method if the vault uses automatic conflict resolution.
Public Method Rollback | Rolls back the specified object to the specified version. Prefer RollbackEx as its parameter RollbackToVersion supports unmanaged external repository objects.
Public Method RollbackEx | Rolls back the specified object to the specified version.
Public Method SetExternalID | Sets the external ID for an object. The object itself must be internal.
Public Method SetObjectGUID | Sets the Object GUID of the specified object.
Public Method SetOfflineAvailability | Marks the specified object for offline availability, or clears the offline availability marker.
Public Method SetSingleFileObject | Changes the single-file status of the specified object.
Public Method ShowBasicEditObjectWindow | Displays the edit object metadata window.
Public Method ShowBasicNewObjectWindow | Displays the new object metadata window.
Public Method ShowChangeStateDialogModal | Displays the 'Change State' dialog box for the object.
Public Method ShowCheckInReminder | Displays the checkin reminder for the specified object. Can fail if the object is open in another program.
Public Method ShowCheckInReminderDialogModal | Displays a modal checkin reminder dialog for the specified object. Does not perform the actual check in operation. Returns error on cancel.
Public Method ShowCheckoutPrompt | Displays the object checkout prompt for the user.
Public Method ShowCollectionMembersDialog | Displays the collection members dialog box for the object.
Public Method ShowCommentsDialogModal | Displays the comments dialog box for the object.
Public Method ShowEditObjectWindow | Displays the edit object metadata window.
Public Method ShowHistoryDialogModal | Displays the history dialog box for the object.
Public Method ShowNewObjectWindow | Displays the new object metadata window.
Public Method ShowPrefilledNewObjectWindow | Displays a new object metadata window.
Public Method ShowRelatedObjects | Shows related objects for the object by target object type in Windows Explorer.
Public Method ShowRelationshipsDialog | Displays the relationships dialog box for the object.
Public Method ShowSelectObjectHistoryDialogModal | Displays the history dialog box for the object.
Public Method ShowSubObjectsDialogModal | Displays the sub-objects dialog box for the object.
Public Method UndeleteObject | Undeletes the specified object.
Public Method UndoCheckout | Performs undo checkout for the specified object version.
Public Method UndoCheckoutMultipleObjects | Performs undo checkout for the specified object versions.

Remarks

This method group interface can be accessed via the Vault object.

Example

Checking if the object is checked out to the current user (Visual Basic) Copy Code
' Identify the object.
Dim oObjVer As MFilesAPI.ObjVer
'...

' Get the version data and check if the object version is checked out. If the version is checked out, it must be
' checked out for current user -- otherwise the version wouldn't be visible for the user.
Dim oObjectVersionAndProperties As MFilesAPI.ObjectVersionAndProperties = _
    oVault.ObjectOperations.GetObjectVersionAndProperties(oObjVer)

If oObjectVersionAndProperties.VersionData().ThisVersionCheckedOut() Then
'     This object is checked out for current user.
End If
Creating a new object (Visual Basic) Copy Code
' Create property definitions
Dim oPropertyValues As MFilesAPI.PropertyValues = New MFilesAPI.PropertyValues

' Add 'Name and Title' property by creating a new PropertyValue object.
' The PropertyValue object encapsulates the metadata information (PropertyDef)
' and the actual value (TypedValue).
Dim oPropertyValue1 As MFilesAPI.PropertyValue = New MFilesAPI.PropertyValue
oPropertyValue1.PropertyDef = MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefNameOrTitle
oPropertyValue1.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeText, "DemoObject")
oPropertyValues.Add(0, oPropertyValue1)

' Add 'Class' property
Dim oPropertyValue2 As MFilesAPI.PropertyValue = New MFilesAPI.PropertyValue
oPropertyValue2.PropertyDef = MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefClass
oPropertyValue2.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeLookup, _
                                    MFilesAPI.MFBuiltInDocumentClass.MFBuiltInDocumentClassOtherDocument)
oPropertyValues.Add(1, oPropertyValue2)

' Add 'Single file' property
Dim oPropertyValue3 As MFilesAPI.PropertyValue = New MFilesAPI.PropertyValue
oPropertyValue3.PropertyDef = MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefSingleFileObject
oPropertyValue3.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeBoolean, True)
oPropertyValues.Add(2, oPropertyValue3)

' Add source file.
Dim oSourceFiles As MFilesAPI.SourceObjectFiles = New MFilesAPI.SourceObjectFiles
Dim oSourceFile1 As MFilesAPI.SourceObjectFile = New MFilesAPI.SourceObjectFile
oSourceFile1.SourceFilePath = "c:\demo.txt"
oSourceFile1.Title = "demo"
oSourceFile1.Extension = "txt"
oSourceFiles.Add(0, oSourceFile1)

' Create new object.
Dim oObjectVersionAndProperties As MFilesAPI.ObjectVersionAndProperties
oObjectVersionAndProperties = m_vault.ObjectOperations.CreateNewObject( _
                                    MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument, _
                                    oPropertyValues, oSourceFiles)

' Check in the newly created object.
m_vault.ObjectOperations.CheckIn(oObjectVersionAndProperties.ObjVer)
Getting version information about objects (Visual Basic) Copy Code
' Initialize the API and connect to a vault.
Dim oVault As MFilesAPI.Vault
' ...

' We are searching for the document with ID 123.
Dim iDocumentId As Integer
iDocumentId = 123

' Initialize an ObjID object for the search.
Dim oObjId As New MFilesAPI.ObjID
oObjId.SetIDs(MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument, iDocumentId)

' Invoke the search operation.
Dim oObjectVersionCheckedOut As MFilesAPI.ObjectVersion
Dim oObjectVersionAndProperties As MFilesAPI.ObjectVersionAndProperties
oObjectVersionAndProperties = oVault.ObjectOperations.GetLatestObjectVersionAndProperties(oObjId, True)
oObjectVersionCheckedOut = oObjectVersionAndProperties.VersionData

' Get the info for all the versions of this document.
Dim oObjectVersions As MFilesAPI.ObjectVersions
oObjectVersions = oVault.ObjectOperations.GetHistory(oObjId)

' Check if this object version is checked out to the current user.
If oObjectVersionCheckedOut.ThisVersionCheckedOut Then
    Call Console.WriteLine("Document object: '" + oObjectVersionCheckedOut.GetNameForFileSystem() + "' [checked out to me]")
    Call Console.WriteLine("   Current version: " + CStr(oObjectVersionCheckedOut.ObjVer.Version))
    Call Console.WriteLine("   Checked out: " + oObjectVersionCheckedOut.CheckedOutAtUtc + " UTC")
    ' Try to resolve the previous version number before checkout.
    If oObjectVersions.Count > 1 Then
        Dim oObjectVersionOld As MFilesAPI.ObjectVersion = oObjectVersions.Item(oObjectVersions.Count - 1)
        Call Console.WriteLine("      Latest version before checkout identified by: " + CStr(oObjectVersionOld.ObjVer.Version))
    End If
Else
    Call Console.WriteLine("Document object: '" + oObjectVersionCheckedOut.GetNameForFileSystem() + "'")
End If

' Resolve the last modification timestamp of the object.
Dim dtObjectModification As Date = oObjectVersionCheckedOut.LastModifiedUtc
Call Console.WriteLine("   Object modified: " + CStr(dtObjectModification) + " UTC")

' Process the object files.
Dim oObjectFiles As MFilesAPI.ObjectFiles = oObjectVersionCheckedOut.Files
For Each oObjectFile As MFilesAPI.ObjectFile In oObjectFiles
    ' Construct the FileVer string for the file.
    Dim szFileVer = CStr(oObjectFile.ID) + "-" + CStr(oObjectFile.Version)
    ' Output the identification of the object file.
    Call Console.WriteLine("   Document file: '" + oObjectFile.GetNameForFileSystem() + "'")
    ' Resolve the last modification timestamp of the file content.
    Dim dtContentModification As Date = oObjectFile.LastAccessTimeUtc
    Call Console.WriteLine("      Currently identified by: " + szFileVer)
    ' Try to find the previous versions of the object files.
    If oObjectVersionCheckedOut.ThisVersionCheckedOut And oObjectVersions.Count > 1 Then
        Dim oObjectFilesOld As MFilesAPI.ObjectFiles = oObjectVersions.Item(oObjectVersions.Count - 1).Files
        For Each oObjectFileOld As MFilesAPI.ObjectFile In oObjectFilesOld
            If oObjectFileOld.ID = oObjectFile.ID Then
                ' Construct the FileVer string for the previous version of the file.
                Dim szFileVerOld = CStr(oObjectFileOld.ID) + "-" + CStr(oObjectFileOld.Version)
                Call Console.WriteLine("      Latest version before checkout identified by: " + szFileVerOld)
                Call Console.WriteLine("      File content modified: " + CStr(dtContentModification) + " UTC")
            End If
        Next
    End If
Next

See Also

VaultObjectOperations Members


%%PageItemTitle%%

AddFavorite Method
ObjID
VaultObjectOperations Object : AddFavorite Method

Glossary Item Box

Description

Adds the specified object to the 'Favorites' view of the current user.

Syntax

Visual Basic
Public Function AddFavorite( _
   ByVal ObjID As ObjID _
) As ObjectVersionAndProperties

Parameters

ObjID

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

AddFavorites Method
ObjIDs
VaultObjectOperations Object : AddFavorites Method

Glossary Item Box

Description

Adds the specified objects to the 'Favorites' view of the current user.

Syntax

Visual Basic
Public Function AddFavorites( _
   ByVal ObjIDs As ObjIDs _
) As ObjectVersionAndPropertiesOfMultipleObjects

Parameters

ObjIDs

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ChangePermissionsToACL Method
ObjVer
AccessControlList
ChangeAllVersions
VaultObjectOperations Object : ChangePermissionsToACL Method

Glossary Item Box

Description

Changes the permissions for the specified object.

Syntax

Visual Basic
Public Function ChangePermissionsToACL( _
   ByVal ObjVer As ObjVer, _
   ByVal AccessControlList As AccessControlList, _
   ByVal ChangeAllVersions As Boolean _
) As ObjectVersion

Parameters

ObjVer
AccessControlList
ChangeAllVersions

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ChangePermissionsToNamedACL Method
ObjVer
NamedACL
ChangeAllVersions
VaultObjectOperations Object : ChangePermissionsToNamedACL Method

Glossary Item Box

Description

Changes the permissions for the specified object.

Syntax

Visual Basic
Public Function ChangePermissionsToNamedACL( _
   ByVal ObjVer As ObjVer, _
   ByVal NamedACL As Long, _
   ByVal ChangeAllVersions As Boolean _
) As ObjectVersion

Parameters

ObjVer
NamedACL
ChangeAllVersions

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CheckIn Method
ObjVer
The object version that identifies the object.
VaultObjectOperations Object : CheckIn Method

Glossary Item Box

Description

Checks in the object.

Syntax

Visual Basic
Public Function CheckIn( _
   ByVal ObjVer As ObjVer _
) As ObjectVersion

Parameters

ObjVer
The object version that identifies the object.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CheckInMultipleObjects Method
ObjVers
The object versions that identify the objects. One batch can include a maximum of 500 objects.
VaultObjectOperations Object : CheckInMultipleObjects Method

Glossary Item Box

Description

Checks in multiple objects at once.

Syntax

Visual Basic
Public Function CheckInMultipleObjects( _
   ByVal ObjVers As ObjVers _
) As ObjectVersions

Parameters

ObjVers
The object versions that identify the objects. One batch can include a maximum of 500 objects.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CheckOut Method
ObjID
The object ID that identifies the object.
VaultObjectOperations Object : CheckOut Method

Glossary Item Box

Description

Checks out the object.

Syntax

Visual Basic
Public Function CheckOut( _
   ByVal ObjID As ObjID _
) As ObjectVersion

Parameters

ObjID
The object ID that identifies the object.

Return Type

The ObjectVersion object that contains information on the object after checkout.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CheckOutMultipleObjects Method
ObjIDs
The IDs of the objects to be checked out. One batch can include a maximum of 500 objects.
VaultObjectOperations Object : CheckOutMultipleObjects Method

Glossary Item Box

Description

Checks out multiple objects at once.

Syntax

Visual Basic
Public Function CheckOutMultipleObjects( _
   ByVal ObjIDs As ObjIDs _
) As ObjectVersions

Parameters

ObjIDs
The IDs of the objects to be checked out. One batch can include a maximum of 500 objects.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CompareWithAnotherDocument Method
ParentWindow
The parent window for the dialog.
ObjVer
The document the content of which to compare with the content of another one.
FileTitleAndExtension
The filename and extension of the document.
VaultObjectOperations Object : CompareWithAnotherDocument Method

Glossary Item Box

Description

Compares the content of this document with the content of another one.

Syntax

Visual Basic
Public Sub CompareWithAnotherDocument( _
   ByVal ParentWindow As Long, _
   ByVal ObjVer As ObjVer, _
   ByVal FileTitleAndExtension As String _
)

Parameters

ParentWindow
The parent window for the dialog.
ObjVer
The document the content of which to compare with the content of another one.
FileTitleAndExtension
The filename and extension of the document.

Remarks

Supported in M-Files 19.5.7811.5 and later.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CompareWithAnotherVersion Method
ParentWindow
The parent window for the dialog.
ObjVer
The document version the content of which to compare with the content of another version.
VaultObjectOperations Object : CompareWithAnotherVersion Method

Glossary Item Box

Description

Compares the content of this document version with the content of another one. Use the CompareWithAnotherVersionEx method for multi-file document support.

Syntax

Visual Basic
Public Sub CompareWithAnotherVersion( _
   ByVal ParentWindow As Long, _
   ByVal ObjVer As ObjVer _
)

Parameters

ParentWindow
The parent window for the dialog.
ObjVer
The document version the content of which to compare with the content of another version.

Remarks

Supported in M-Files 19.5.7811.5 and later.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CompareWithAnotherVersionEx Method
ParentWindow
The parent window for the dialog.
ObjVer
The document version the content of which to compare with the content of another version.
FileTitleAndExtension
The filename of the document. Specify when you are referring to a file in a multi-file document.
VaultObjectOperations Object : CompareWithAnotherVersionEx Method

Glossary Item Box

Description

Compares the content of this document version with the content of another one.

Syntax

Visual Basic
Public Sub CompareWithAnotherVersionEx( _
   ByVal ParentWindow As Long, _
   ByVal ObjVer As ObjVer, _
   ByVal FileTitleAndExtension As String _
)

Parameters

ParentWindow
The parent window for the dialog.
ObjVer
The document version the content of which to compare with the content of another version.
FileTitleAndExtension
The filename of the document. Specify when you are referring to a file in a multi-file document.

Remarks

Supported in M-Files 20.6.9181.4 and later.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CompareWithPreviousVersion Method
ParentWindow
The parent window for the dialog.
ObjVer
The document version the content of which to compare with the content of the previous version.
VaultObjectOperations Object : CompareWithPreviousVersion Method

Glossary Item Box

Description

Compares the content of this document version with the content of the previous one. Use the CompareWithPreviousVersionEx method for multi-file document support.

Syntax

Visual Basic
Public Sub CompareWithPreviousVersion( _
   ByVal ParentWindow As Long, _
   ByVal ObjVer As ObjVer _
)

Parameters

ParentWindow
The parent window for the dialog.
ObjVer
The document version the content of which to compare with the content of the previous version.

Remarks

Supported in M-Files 19.5.7811.5 and later.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CompareWithPreviousVersionEx Method
ParentWindow
The parent window for the dialog.
ObjVer
The document version the content of which to compare with the content of the previous version.
FileTitleAndExtension
The filename of the document. Specify when you are referring to a file in a multi-file document.
VaultObjectOperations Object : CompareWithPreviousVersionEx Method

Glossary Item Box

Description

Compares the content of this document version with the content of the previous one.

Syntax

Visual Basic
Public Sub CompareWithPreviousVersionEx( _
   ByVal ParentWindow As Long, _
   ByVal ObjVer As ObjVer, _
   ByVal FileTitleAndExtension As String _
)

Parameters

ParentWindow
The parent window for the dialog.
ObjVer
The document version the content of which to compare with the content of the previous version.
FileTitleAndExtension
The filename of the document. Specify when you are referring to a file in a multi-file document.

Remarks

Supported in 20.6.9181.4 and later.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CopyConflictObjectAsNewVersionToBaseObject Method
BaseObjectObjVer
The latest version of the base object for which the new version is created.
ConflictObjectObjVer
The latest version of the related conflict object that is copied.
VaultObjectOperations Object : CopyConflictObjectAsNewVersionToBaseObject Method

Glossary Item Box

Description

Saves a copy of the deleted conflict object as a new version of the related base object.

Syntax

Visual Basic
Public Function CopyConflictObjectAsNewVersionToBaseObject( _
   ByVal BaseObjectObjVer As ObjVer, _
   ByVal ConflictObjectObjVer As ObjVer _
) As ObjectVersion

Parameters

BaseObjectObjVer
The latest version of the base object for which the new version is created.
ConflictObjectObjVer
The latest version of the related conflict object that is copied.

Remarks

Supported in M-Files 21.3.10021.4 and later.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CreateNewAssignment Method
AssignmentName
AssignmentDescription
AssignedToUser
Deadline

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AccessControlList

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultObjectOperations Object : CreateNewAssignment Method

Glossary Item Box

Description

Creates a new assignment.

Syntax

Visual Basic
Public Function CreateNewAssignment( _
   ByVal AssignmentName As String, _
   ByVal AssignmentDescription As String, _
   ByVal AssignedToUser As TypedValue, _
   Optional ByVal Deadline As TypedValue = 0, _
   Optional ByVal AccessControlList As AccessControlList = 0 _
) As ObjectVersionAndProperties

Parameters

AssignmentName
AssignmentDescription
AssignedToUser
Deadline

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AccessControlList

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CreateNewEmptySingleFileDocument Method
PropertyValues
The collection of the property values for the new object.
Title
The object title, which is also used as the file name for the document file.
Extension
The file extension for the document file.
AccessControlList

The access control list for the new object.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultObjectOperations Object : CreateNewEmptySingleFileDocument Method

Glossary Item Box

Description

Creates a new single-file document based on the specified properties and source files.

Syntax

Visual Basic
Public Function CreateNewEmptySingleFileDocument( _
   ByVal PropertyValues As PropertyValues, _
   ByVal Title As String, _
   ByVal Extension As String, _
   Optional ByVal AccessControlList As AccessControlList = 0 _
) As ObjectVersionAndProperties

Parameters

PropertyValues
The collection of the property values for the new object.
Title
The object title, which is also used as the file name for the document file.
Extension
The file extension for the document file.
AccessControlList

The access control list for the new object.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Remarks

Creates a new single-file document as an empty file. At a minimum, the property values collection needs to contain property values and other required property definitions for the object class.

See Also

VaultObjectOperations Object | VaultObjectOperations Members | CreateNewObject Method


%%PageItemTitle%%

CreateNewObject Method
See Also Example Send comments
ObjectType
The object type for the new object as the object type ID number.
PropertyValues
The collection of the property values for the new object.
SourceObjectFiles

The collection of the source files for the new object.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AccessControlList

The access control list for the new object.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultObjectOperations Object : CreateNewObject Method

Glossary Item Box

Description

Creates a new object based on the specified properties and source files.

Syntax

Visual Basic
Public Function CreateNewObject( _
   ByVal ObjectType As Long, _
   ByVal PropertyValues As PropertyValues, _
   Optional ByVal SourceObjectFiles As SourceObjectFiles = 0, _
   Optional ByVal AccessControlList As AccessControlList = 0 _
) As ObjectVersionAndProperties

Parameters

ObjectType
The object type for the new object as the object type ID number.
PropertyValues
The collection of the property values for the new object.
SourceObjectFiles

The collection of the source files for the new object.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AccessControlList

The access control list for the new object.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Return Type

The ObjectVersionAndProperties object that contains information on the new object.

Remarks

At a minimum, the property values collection needs to contain property values and other required property definitions for the object class.

Example

Create new single-file object (Visual Basic) Copy Code
' Create property definitions
Dim oPropertyValues As MFilesAPI.PropertyValues = New MFilesAPI.PropertyValues

' Add 'Name and Title' property by creating a new PropertyValue object.
' The PropertyValue object encapsulates the metadata information (PropertyDef)
' and the actual value (TypedValue).
Dim oPropertyValue1 As MFilesAPI.PropertyValue = New MFilesAPI.PropertyValue
oPropertyValue1.PropertyDef = MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefNameOrTitle
oPropertyValue1.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeText, "DemoObject")
oPropertyValues.Add(0, oPropertyValue1)

' Add 'Class' property
Dim oPropertyValue2 As MFilesAPI.PropertyValue = New MFilesAPI.PropertyValue
oPropertyValue2.PropertyDef = MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefClass
oPropertyValue2.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeLookup, _
                                    MFilesAPI.MFBuiltInDocumentClass.MFBuiltInDocumentClassOtherDocument)
oPropertyValues.Add(1, oPropertyValue2)

' Add 'Single file' property
Dim oPropertyValue3 As MFilesAPI.PropertyValue = New MFilesAPI.PropertyValue
oPropertyValue3.PropertyDef = MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefSingleFileObject
oPropertyValue3.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeBoolean, True)
oPropertyValues.Add(2, oPropertyValue3)

' Add source file.
Dim oSourceFiles As MFilesAPI.SourceObjectFiles = New MFilesAPI.SourceObjectFiles
Dim oSourceFile1 As MFilesAPI.SourceObjectFile = New MFilesAPI.SourceObjectFile
oSourceFile1.SourceFilePath = "c:\demo.txt"
oSourceFile1.Title = "demo"
oSourceFile1.Extension = "txt"
oSourceFiles.Add(0, oSourceFile1)

' Create new object.
Dim oObjectVersionAndProperties As MFilesAPI.ObjectVersionAndProperties
oObjectVersionAndProperties = m_vault.ObjectOperations.CreateNewObject( _
                                    MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument, _
                                    oPropertyValues, oSourceFiles)

' Check in the newly created object.
m_vault.ObjectOperations.CheckIn(oObjectVersionAndProperties.ObjVer)

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CreateNewObjectEx Method
ObjectType
The object type for the new object as the object type ID number.
Properties
The collection of the property values for the new object.
SourceFiles
The collection of the source files for the new object.
SFD
If this parameter is True, the new object is created as a single-file document.
CheckIn
If this parameter is True, the new object should be checked in immediately.
AccessControlList

The access control list for the new object.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultObjectOperations Object : CreateNewObjectEx Method

Glossary Item Box

Description

Creates a new object based on the specified properties and source files.

Syntax

Visual Basic
Public Function CreateNewObjectEx( _
   ByVal ObjectType As Long, _
   ByVal Properties As PropertyValues, _
   Optional ByVal SourceFiles As SourceObjectFiles = 0, _
   Optional ByVal SFD As Boolean = False, _
   Optional ByVal CheckIn As Boolean = True, _
   Optional ByVal AccessControlList As AccessControlList = 0 _
) As ObjectVersionAndProperties

Parameters

ObjectType
The object type for the new object as the object type ID number.
Properties
The collection of the property values for the new object.
SourceFiles
The collection of the source files for the new object.
SFD
If this parameter is True, the new object is created as a single-file document.
CheckIn
If this parameter is True, the new object should be checked in immediately.
AccessControlList

The access control list for the new object.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Remarks

At a minimum, the property values collection needs to contain property values and other required property definitions for the object class.

In the current implementation this method is not fully transactional. For example, if the source file(s) cannot be uploaded the newly created object is left checked out and cannot be found from the M-Files UI.

See Also

VaultObjectOperations Object | VaultObjectOperations Members | CreateNewObject Method


%%PageItemTitle%%

CreateNewObjectExQuick Method
ObjectType
The object type for the new object as the object type ID number.
Properties
The collection of the property values for the new object.
SourceFiles
The collection of the source files for the new object.
SFD
If this parameter is True, the new object is created as a single-file document.
CheckIn
If this parameter is True, the new object should be checked in immediately.
AccessControlList

The access control list for the new object.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultObjectOperations Object : CreateNewObjectExQuick Method

Glossary Item Box

Description

Creates a new object based on the specified properties and source files.

Syntax

Visual Basic
Public Function CreateNewObjectExQuick( _
   ByVal ObjectType As Long, _
   ByVal Properties As PropertyValues, _
   Optional ByVal SourceFiles As SourceObjectFiles = 0, _
   Optional ByVal SFD As Boolean = False, _
   Optional ByVal CheckIn As Boolean = True, _
   Optional ByVal AccessControlList As AccessControlList = 0 _
) As Long

Parameters

ObjectType
The object type for the new object as the object type ID number.
Properties
The collection of the property values for the new object.
SourceFiles
The collection of the source files for the new object.
SFD
If this parameter is True, the new object is created as a single-file document.
CheckIn
If this parameter is True, the new object should be checked in immediately.
AccessControlList

The access control list for the new object.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Return Type

The ID number of the created object.

Remarks

At a minimum, the property values collection needs to contain property values and other required property definitions for the object class.

In the current implementation this method is not fully transactional. For example, if the source file(s) cannot be uploaded the newly created object is left checked out and cannot be accessed from the M-Files UI.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members | CreateNewObject Method


%%PageItemTitle%%

CreateNewSFDObject Method
ObjectType
Properties
SourceFile
CheckIn
AccessControlList

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultObjectOperations Object : CreateNewSFDObject Method

Glossary Item Box

Description

Creates a new single file object based on the specified properties and source file.

Syntax

Visual Basic
Public Function CreateNewSFDObject( _
   ByVal ObjectType As Long, _
   ByVal Properties As PropertyValues, _
   ByVal SourceFile As SourceObjectFile, _
   ByVal CheckIn As Boolean, _
   Optional ByVal AccessControlList As AccessControlList = 0 _
) As ObjectVersionAndProperties

Parameters

ObjectType
Properties
SourceFile
CheckIn
AccessControlList

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

CreateNewSFDObjectQuick Method
ObjectType
Properties
SourceFile
CheckIn
AccessControlList

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultObjectOperations Object : CreateNewSFDObjectQuick Method

Glossary Item Box

Description

Creates a new single file object based on the specified properties and source file.

Syntax

Visual Basic
Public Function CreateNewSFDObjectQuick( _
   ByVal ObjectType As Long, _
   ByVal Properties As PropertyValues, _
   ByVal SourceFile As SourceObjectFile, _
   ByVal CheckIn As Boolean, _
   Optional ByVal AccessControlList As AccessControlList = 0 _
) As Long

Parameters

ObjectType
Properties
SourceFile
CheckIn
AccessControlList

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

DelayedCheckIn Method
ObjVer
The object identifier for the object to be checked in.
VaultObjectOperations Object : DelayedCheckIn Method

Glossary Item Box

Description

Performs check-in operation for the object after any of the object's files are no longer in use.

Syntax

Visual Basic
Public Sub DelayedCheckIn( _
   ByVal ObjVer As ObjVer _
)

Parameters

ObjVer
The object identifier for the object to be checked in.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

DeleteObject Method
ObjID
The ID of the object to be deleted.
VaultObjectOperations Object : DeleteObject Method

Glossary Item Box

Description

Deletes the specified object.

Syntax

Visual Basic
Public Function DeleteObject( _
   ByVal ObjID As ObjID _
) As ObjectVersion

Parameters

ObjID
The ID of the object to be deleted.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

DestroyObject Method
ObjID
The ID of the object to destroy.
DestroyAllVersions
Specifies whether all versions of the object are to be destroyed. If set to "false", only the version defined in the ObjectVersion parameter is destroyed.
ObjectVersion
If "DestroyAllVersions" is false, specifies which version of the object to destroy.
VaultObjectOperations Object : DestroyObject Method

Glossary Item Box

Description

Destroys an object or a specific version of the object. Prefer DestroyObjectEx as its parameter ObjectVersion supports unmanaged external repository objects.

Syntax

Visual Basic
Public Sub DestroyObject( _
   ByVal ObjID As ObjID, _
   ByVal DestroyAllVersions As Boolean, _
   ByVal ObjectVersion As Long _
)

Parameters

ObjID
The ID of the object to destroy.
DestroyAllVersions
Specifies whether all versions of the object are to be destroyed. If set to "false", only the version defined in the ObjectVersion parameter is destroyed.
ObjectVersion
If "DestroyAllVersions" is false, specifies which version of the object to destroy.

Remarks

If you want to destroy the object altogether, in other words set the DestroyAllVersions parameter to "true", the ObjectVersion parameter must be set to "-1".

If DestroyAllVersions is set to "false", ObjectVersion must point to a valid version.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

DestroyObjectEx Method
ObjID
The ID of the object to destroy.
DestroyAllVersions
Specifies whether all versions of the object are to be destroyed. If set to "false", only the version defined in the ObjectVersion parameter is destroyed.
ObjectVersion
If "DestroyAllVersions" is false, specifies which version of the object to destroy.
VaultObjectOperations Object : DestroyObjectEx Method

Glossary Item Box

Description

Destroys the specified object, or a specific version of the object.

Syntax

Visual Basic
Public Sub DestroyObjectEx( _
   ByVal ObjID As ObjID, _
   ByVal DestroyAllVersions As Boolean, _
   ByVal ObjectVersion As ObjVerVersion _
)

Parameters

ObjID
The ID of the object to destroy.
DestroyAllVersions
Specifies whether all versions of the object are to be destroyed. If set to "false", only the version defined in the ObjectVersion parameter is destroyed.
ObjectVersion
If "DestroyAllVersions" is false, specifies which version of the object to destroy.

Remarks

If you want to destroy the object altogether, in other words set the DestroyAllVersions parameter to "true", the ObjectVersion parameter must be set to "-1".

If DestroyAllVersions is set to "false", ObjectVersion must point to a valid version.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

DestroyObjects Method
ObjIDs
The IDs of the objects to be destroyed. One batch can include a maximum of 500 objects.
VaultObjectOperations Object : DestroyObjects Method

Glossary Item Box

Description

Destroys the specified objects.

Syntax

Visual Basic
Public Sub DestroyObjects( _
   ByVal ObjIDs As ObjIDs _
)

Parameters

ObjIDs
The IDs of the objects to be destroyed. One batch can include a maximum of 500 objects.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

FollowObject Method
ObjID
The ID of the object that is to be followed/unfollowed.
Follow
True if the object is to be followed.
VaultObjectOperations Object : FollowObject Method

Glossary Item Box

Description

Starts or stops following the specified object. While the object is being followed, the current user will be notified if the object changes.

Syntax

Visual Basic
Public Sub FollowObject( _
   ByVal ObjID As ObjID, _
   Optional ByVal Follow As Boolean = True _
)

Parameters

ObjID
The ID of the object that is to be followed/unfollowed.
Follow
True if the object is to be followed.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ForceUndoCheckout Method
ObjVer
The object version for which to perform the operation.
VaultObjectOperations Object : ForceUndoCheckout Method

Glossary Item Box

Description

Performs undo checkout and enforces the operation if the user has permission to perform forced undo checkout.

Syntax

Visual Basic
Public Function ForceUndoCheckout( _
   ByVal ObjVer As ObjVer _
) As ObjectVersion

Parameters

ObjVer
The object version for which to perform the operation.

Remarks

If the object is removed via this operation, the method returns null (or another marker for an empty or undefined value).

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetCollectionMembers Method
ObjVer
VaultObjectOperations Object : GetCollectionMembers Method

Glossary Item Box

Description

Gets all the collection members of the specified collection.

Syntax

Visual Basic
Public Function GetCollectionMembers( _
   ByVal ObjVer As ObjVer _
) As ObjectVersions

Parameters

ObjVer

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetHistory Method
ObjID
The ID of the object the history of which to retrieve.
VaultObjectOperations Object : GetHistory Method

Glossary Item Box

Description

Gets the history of the specified object. Use GetHistoryEx for additional options.

Syntax

Visual Basic
Public Function GetHistory( _
   ByVal ObjID As ObjID _
) As ObjectVersions

Parameters

ObjID
The ID of the object the history of which to retrieve.

Remarks

The retrieved history will be ordered so that the latest entry is listed as the first one.

We recommend you to use the more recent GetHistoryEx method with M-Files 19.5.7811.5 and later.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetHistoryEx Method
ObjID
The ID of the object the history of which to retrieve.
HistoryRetrievalMode
Specifies the order in which the results are retrieved.
VaultObjectOperations Object : GetHistoryEx Method

Glossary Item Box

Description

Gets the extended history of the specified object with search parameters.

Syntax

Visual Basic
Public Function GetHistoryEx( _
   ByVal ObjID As ObjID, _
   ByVal HistoryRetrievalMode As MFHistoryRetrievalMode _
) As ObjectVersions

Parameters

ObjID
The ID of the object the history of which to retrieve.
HistoryRetrievalMode
Value | Description
MFHistoryRetrievalAscending | Ascending. The retrieved history will be ordered so that the earliest entry is listed as the first one.
MFHistoryRetrievalDescending | Descending. The retrieved history will be ordered so that the latest entry is listed as the first one.
MFHistoryRetrievalRelaxed | Relaxed. The retrieved history will not be processed.
Specifies the order in which the results are retrieved.

Remarks

Supported in M-Files 19.5.7811.5 and later.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetLatestObjectVersionAndProperties Method
ObjID
The object ID that identifies the object.
AllowCheckedOut
UpdateFromServer
VaultObjectOperations Object : GetLatestObjectVersionAndProperties Method

Glossary Item Box

Description

Gets the latest version and properties of the specified object.

Syntax

Visual Basic
Public Function GetLatestObjectVersionAndProperties( _
   ByVal ObjID As ObjID, _
   ByVal AllowCheckedOut As Boolean, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ObjectVersionAndProperties

Parameters

ObjID
The object ID that identifies the object.
AllowCheckedOut
UpdateFromServer

Return Type

The ObjectVersionAndProperties object that contains information on the latest version of the object.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetLatestObjVer Method
ObjID
The object identifier.
AllowCheckedOut
If this parameter is true, the version that is currently checked out for the user should be considered to be the latest version. If this parameter is false, the latest version on the server is returned. Note that even if this parameter is true, the method never returns a version that is checked out to some other user.
UpdateFromServer
True if the information should be always updated from the server.
VaultObjectOperations Object : GetLatestObjVer Method

Glossary Item Box

Description

Gets the latest version of the specified object.

Syntax

Visual Basic
Public Function GetLatestObjVer( _
   ByVal ObjID As ObjID, _
   ByVal AllowCheckedOut As Boolean, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ObjVer

Parameters

ObjID
The object identifier.
AllowCheckedOut
If this parameter is true, the version that is currently checked out for the user should be considered to be the latest version. If this parameter is false, the latest version on the server is returned. Note that even if this parameter is true, the method never returns a version that is checked out to some other user.
UpdateFromServer
True if the information should be always updated from the server.

Remarks

Consider using the more recent GetLatestObjVerEx Method instead.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetLatestObjVerEx Method
ObjID
The object identifier.
AllowCheckedOut
If this parameter is true, the version that is currently checked out for the user should be considered to be the latest version. If this parameter is false, the latest version on the server is returned. Note that even if this parameter is true, the method never returns a version that is checked out to some other user.
UpdateFromServer
True if the information should be always updated from the server.
NotifyViews
True if M-Files windows should be notified to update the object in their listings.
VaultObjectOperations Object : GetLatestObjVerEx Method

Glossary Item Box

Description

Gets the latest version of the specified object. Optionally notifies M-Files windows to update the object in their listings.

Syntax

Visual Basic
Public Function GetLatestObjVerEx( _
   ByVal ObjID As ObjID, _
   ByVal AllowCheckedOut As Boolean, _
   Optional ByVal UpdateFromServer As Boolean = False, _
   Optional ByVal NotifyViews As Boolean = False _
) As ObjVer

Parameters

ObjID
The object identifier.
AllowCheckedOut
If this parameter is true, the version that is currently checked out for the user should be considered to be the latest version. If this parameter is false, the latest version on the server is returned. Note that even if this parameter is true, the method never returns a version that is checked out to some other user.
UpdateFromServer
True if the information should be always updated from the server.
NotifyViews
True if M-Files windows should be notified to update the object in their listings.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetMFilesURLForObject Method
ObjID
The ID of the object for which the URL is requested.
TargetVersion
The target version of the object. Valid only if "SpecificVersion" is true.
SpecificVersion
Specifies whether to target a specific version of the object. If false, the generated URL points to the latest version. If true, "TargetVersion" must be provided.
URLType
The type of the requested URL.
VaultObjectOperations Object : GetMFilesURLForObject Method

Glossary Item Box

Description

Gets an M-Files URL for the specified object.

Syntax

Visual Basic
Public Function GetMFilesURLForObject( _
   ByVal ObjID As ObjID, _
   ByVal TargetVersion As Long, _
   ByVal SpecificVersion As Boolean, _
   Optional ByVal URLType As MFilesURLType = MFilesURLTypeShow _
) As String

Parameters

ObjID
The ID of the object for which the URL is requested.
TargetVersion
The target version of the object. Valid only if "SpecificVersion" is true.
SpecificVersion
Specifies whether to target a specific version of the object. If false, the generated URL points to the latest version. If true, "TargetVersion" must be provided.
URLType
Value | Description
MFilesURLTypeEdit | Specifies an URL for performing the open-for-edit action for the target file.
MFilesURLTypeOpen | Specifies an URL for performing the default open action for the target file.
MFilesURLTypeShow | Specifies an URL for showing the object version. The URL does not open the target file.
MFilesURLTypeShowMetadata | Specifies an URL for showing the metadata card for the target object.
MFilesURLTypeView | Specifies an URL for performing the read-only open action for the target file.
The type of the requested URL.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetMFilesURLForObjectEx Method
ObjVer
The version of the object for which the URL is requested.
SpecificVersion
This parameter must not be used. The object version is detected via the ObjVer parameter.
URLType
The type of the requested URL.
VaultObjectOperations Object : GetMFilesURLForObjectEx Method

Glossary Item Box

Description

Gets an M-Files URL for the specified object.

Syntax

Visual Basic
Public Function GetMFilesURLForObjectEx( _
   ByVal ObjVer As ObjVer, _
   ByVal SpecificVersion As Boolean, _
   Optional ByVal URLType As MFilesURLType = MFilesURLTypeShow _
) As String

Parameters

ObjVer
The version of the object for which the URL is requested.
SpecificVersion
This parameter must not be used. The object version is detected via the ObjVer parameter.
URLType
Value | Description
MFilesURLTypeEdit | Specifies an URL for performing the open-for-edit action for the target file.
MFilesURLTypeOpen | Specifies an URL for performing the default open action for the target file.
MFilesURLTypeShow | Specifies an URL for showing the object version. The URL does not open the target file.
MFilesURLTypeShowMetadata | Specifies an URL for showing the metadata card for the target object.
MFilesURLTypeView | Specifies an URL for performing the read-only open action for the target file.
The type of the requested URL.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetMFilesURLForObjectOrFile Method
ObjID
The ID of the object for which the URL is requested.
TargetVersion
The target version of the specified object. Valid only if "SpecificVersion" is true.
SpecificVersion
Specifies whether to target a specific version of the object. If false, the generated URL points to the latest version. If true, "TargetVersion" must be provided.
File
The ID of the file for which the URL is requested. Specify -1 if the URL is requested for the object and not for a specific file of the object.
URLType
The type of the requested URL.
VaultObjectOperations Object : GetMFilesURLForObjectOrFile Method

Glossary Item Box

Description

Gets an M-Files URL for the specified object or file.

Syntax

Visual Basic
Public Function GetMFilesURLForObjectOrFile( _
   ByVal ObjID As ObjID, _
   Optional ByVal TargetVersion As Long = -1, _
   Optional ByVal SpecificVersion As Boolean = False, _
   Optional ByVal File As Long = -1, _
   Optional ByVal URLType As MFilesURLType = MFilesURLTypeShow _
) As String

Parameters

ObjID
The ID of the object for which the URL is requested.
TargetVersion
The target version of the specified object. Valid only if "SpecificVersion" is true.
SpecificVersion
Specifies whether to target a specific version of the object. If false, the generated URL points to the latest version. If true, "TargetVersion" must be provided.
File
The ID of the file for which the URL is requested. Specify -1 if the URL is requested for the object and not for a specific file of the object.
URLType
Value | Description
MFilesURLTypeEdit | Specifies an URL for performing the open-for-edit action for the target file.
MFilesURLTypeOpen | Specifies an URL for performing the default open action for the target file.
MFilesURLTypeShow | Specifies an URL for showing the object version. The URL does not open the target file.
MFilesURLTypeShowMetadata | Specifies an URL for showing the metadata card for the target object.
MFilesURLTypeView | Specifies an URL for performing the read-only open action for the target file.
The type of the requested URL.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetMFilesURLForObjectOrFileEx Method
ObjVer
The version of the object for which the URL is requested.
FileVer
The version of the file for which the URL is requested. Specify -1 for internal file ID or non-specific ID for external file if the URL is requested for the object and not for a specific file of the object.
SpecificVersion
True if the URL should always point to a specific version of the object.
URLType
The type of the requested URL.
VaultObjectOperations Object : GetMFilesURLForObjectOrFileEx Method

Glossary Item Box

Description

Gets an M-Files URL for the specified object or file.

Syntax

Visual Basic
Public Function GetMFilesURLForObjectOrFileEx( _
   ByVal ObjVer As ObjVer, _
   ByVal FileVer As FileVer, _
   Optional ByVal SpecificVersion As Boolean = False, _
   Optional ByVal URLType As MFilesURLType = MFilesURLTypeShow _
) As String

Parameters

ObjVer
The version of the object for which the URL is requested.
FileVer
The version of the file for which the URL is requested. Specify -1 for internal file ID or non-specific ID for external file if the URL is requested for the object and not for a specific file of the object.
SpecificVersion
True if the URL should always point to a specific version of the object.
URLType
Value | Description
MFilesURLTypeEdit | Specifies an URL for performing the open-for-edit action for the target file.
MFilesURLTypeOpen | Specifies an URL for performing the default open action for the target file.
MFilesURLTypeShow | Specifies an URL for showing the object version. The URL does not open the target file.
MFilesURLTypeShowMetadata | Specifies an URL for showing the metadata card for the target object.
MFilesURLTypeView | Specifies an URL for performing the read-only open action for the target file.
The type of the requested URL.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetObjectDataOfMultipleObjects Method
IObjVers
The object versions for which the data is requested.
ObjectDataRequest
The object data request.
VaultObjectOperations Object : GetObjectDataOfMultipleObjects Method

Glossary Item Box

Description

Receives the requested information of the specified objects.

Syntax

Visual Basic
Public Function GetObjectDataOfMultipleObjects( _
   ByVal IObjVers As ObjVers, _
   ByVal ObjectDataRequest As ObjectVersionDataRequest _
) As ObjectVersionDataResults

Parameters

IObjVers
The object versions for which the data is requested.
ObjectDataRequest
The object data request.

Remarks

Supported in M-Files 19.5.7811.5 and later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetObjectGUID Method
ObjID
VaultObjectOperations Object : GetObjectGUID Method

Glossary Item Box

Description

Gets the Object GUID of the specified object.

Syntax

Visual Basic
Public Function GetObjectGUID( _
   ByVal ObjID As ObjID _
) As String

Parameters

ObjID

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetObjectInfo Method
ObjVer
The object version identifier.
LatestVersion
If this parameter is True, the latest version available should be returned.
UpdateFromServer
True if the information should be always updated from the server.
VaultObjectOperations Object : GetObjectInfo Method

Glossary Item Box

Description

Gets information on the specified object version.

Syntax

Visual Basic
Public Function GetObjectInfo( _
   ByVal ObjVer As ObjVer, _
   ByVal LatestVersion As Boolean, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ObjectVersion

Parameters

ObjVer
The object version identifier.
LatestVersion
If this parameter is True, the latest version available should be returned.
UpdateFromServer
True if the information should be always updated from the server.

Remarks

Consider using the more recent GetObjectInfoEx Method instead.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetObjectInfoEx Method
ObjVer
The object version identifier.
LatestVersion
True to get the latest version of the object.
UpdateFromServer
True if the information should be always updated from the server.
NotifyViews
True if M-Files windows should be notified to update the object in their listings.
VaultObjectOperations Object : GetObjectInfoEx Method

Glossary Item Box

Description

Gets information on the specified object version. Optionally notifies M-Files windows to update the object in their listings.

Syntax

Visual Basic
Public Function GetObjectInfoEx( _
   ByVal ObjVer As ObjVer, _
   ByVal LatestVersion As Boolean, _
   Optional ByVal UpdateFromServer As Boolean = False, _
   Optional ByVal NotifyViews As Boolean = False _
) As ObjectVersion

Parameters

ObjVer
The object version identifier.
LatestVersion
True to get the latest version of the object.
UpdateFromServer
True if the information should be always updated from the server.
NotifyViews
True if M-Files windows should be notified to update the object in their listings.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetObjectLocationsInView Method
View
LatestSpecificBehavior

If the target object exists with versions 1 and 2, the following table summarizes the L or S specific segments of the returned location paths:

Flag value Requested version 1 Requested version 2 Requested version -1

MFLatestSpecificBehaviorNormal

 S/v1

L/L
S/v2

 L/L
S/v2
S/v1

MFLatestSpecificBehaviorSpecific

 S/v1 S/v2 S/v2
S/v1

MFLatestSpecificBehaviorLatest

 [none] L/L L/L

MFLatestSpecificBehaviorAutomatic

 S/v1 L/L L/L
S/v1

Note that for the requested version -1 this method returns locations for each version when MFLatestSpecificBehaviorNormal or MFLatestSpecificBehaviorSpecific is used. With MFLatestSpecificBehaviorAutomatic, one location is returned for each version.

ObjectVersion
VaultObjectOperations Object : GetObjectLocationsInView Method

Glossary Item Box

Description

Gets the locations of the object in a view.

Syntax

Visual Basic
Public Function GetObjectLocationsInView( _
   ByVal View As Long, _
   ByVal LatestSpecificBehavior As MFLatestSpecificBehavior, _
   ByVal ObjectVersion As ObjVer _
) As Strings

Parameters

View
LatestSpecificBehavior
Value | Description
MFLatestSpecificBehaviorAutomatic | Automatically chooses the LatestOnly behavior (L folder) if the object version is the latest version. Otherwise, it chooses the SpecificOnly behavior (S folder). Only one location is ever returned when using this method.
MFLatestSpecificBehaviorLatest | Returns a location in the L (Latest) folder only. (Otherwise the latest version is shown in both the L and S folders.)
MFLatestSpecificBehaviorNormal | Normal behavior can return locations in both the L and S folders.
MFLatestSpecificBehaviorSpecific | Returns a location in the S (Specific) folder only, even if evaluating the latest version.

If the target object exists with versions 1 and 2, the following table summarizes the L or S specific segments of the returned location paths:

Flag value Requested version 1 Requested version 2 Requested version -1

MFLatestSpecificBehaviorNormal

 S/v1

L/L
S/v2

 L/L
S/v2
S/v1

MFLatestSpecificBehaviorSpecific

 S/v1 S/v2 S/v2
S/v1

MFLatestSpecificBehaviorLatest

 [none] L/L L/L

MFLatestSpecificBehaviorAutomatic

 S/v1 L/L L/L
S/v1

Note that for the requested version -1 this method returns locations for each version when MFLatestSpecificBehaviorNormal or MFLatestSpecificBehaviorSpecific is used. With MFLatestSpecificBehaviorAutomatic, one location is returned for each version.

ObjectVersion

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetObjectPermissions Method
ObjVer
VaultObjectOperations Object : GetObjectPermissions Method

Glossary Item Box

Description

Gets the permissions for the specified object.

Syntax

Visual Basic
Public Function GetObjectPermissions( _
   ByVal ObjVer As ObjVer _
) As ObjectVersionPermissions

Parameters

ObjVer

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetObjectVersionAndProperties Method
ObjVer
The object version that identifies the object.
UpdateFromServer
VaultObjectOperations Object : GetObjectVersionAndProperties Method

Glossary Item Box

Description

Gets the information on and properties of the specfied object version.

Syntax

Visual Basic
Public Function GetObjectVersionAndProperties( _
   ByVal ObjVer As ObjVer, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version that identifies the object.
UpdateFromServer

Return Type

The ObjectVersionAndProperties object that contains information on the specified object version.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetObjectVersionAndPropertiesOfMultipleObjects Method
ObjVers
The object version identifiers of the object versions for which the information is requested.
LatestVersions
True to return the latest available versions of the objects. If 'AllowCheckedOut' is false, the latest checked in version is returned.
AllowCheckedOut
If true, a checked out object version can be returned. If false, only checked in version are allowed.
AllowMissingObjectVersions
True if the method is allowed to return less results than what is requested. This can happen if all object versions could not be found or if the user does not have access to them. If false, the method raises an error if all object versions were not found.
UpdateFromServer
True if the information should always be updated from the server. If false, the client local cache may be used. This flag is relevant only when M-Files API is used in client mode.
VaultObjectOperations Object : GetObjectVersionAndPropertiesOfMultipleObjects Method

Glossary Item Box

Description

Gets the object version and properties of the specified objects.

Syntax

Visual Basic
Public Function GetObjectVersionAndPropertiesOfMultipleObjects( _
   ByVal ObjVers As ObjVers, _
   ByVal LatestVersions As Boolean, _
   ByVal AllowCheckedOut As Boolean, _
   ByVal AllowMissingObjectVersions As Boolean, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ObjectVersionAndPropertiesOfMultipleObjects

Parameters

ObjVers
The object version identifiers of the object versions for which the information is requested.
LatestVersions
True to return the latest available versions of the objects. If 'AllowCheckedOut' is false, the latest checked in version is returned.
AllowCheckedOut
If true, a checked out object version can be returned. If false, only checked in version are allowed.
AllowMissingObjectVersions
True if the method is allowed to return less results than what is requested. This can happen if all object versions could not be found or if the user does not have access to them. If false, the method raises an error if all object versions were not found.
UpdateFromServer
True if the information should always be updated from the server. If false, the client local cache may be used. This flag is relevant only when M-Files API is used in client mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetObjIDByGUID Method
ObjectGUID
VaultObjectOperations Object : GetObjIDByGUID Method

Glossary Item Box

Description

Gets the Object ID of the object that is identified by the specified Object GUID.

Syntax

Visual Basic
Public Function GetObjIDByGUID( _
   ByVal ObjectGUID As String _
) As ObjID

Parameters

ObjectGUID

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetObjIDByOriginalObjID Method
OriginalVaultGUID
OriginalObjID
VaultObjectOperations Object : GetObjIDByOriginalObjID Method

Glossary Item Box

Description

Gets the Object ID of the object that is identified by the specified Original Vault GUID and Original Object ID.

Syntax

Visual Basic
Public Function GetObjIDByOriginalObjID( _
   ByVal OriginalVaultGUID As String, _
   ByVal OriginalObjID As ObjID _
) As ObjID

Parameters

OriginalVaultGUID
OriginalObjID

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetOfflineAvailability Method
ObjID
The ID identifying the object.
VaultObjectOperations Object : GetOfflineAvailability Method

Glossary Item Box

Description

Gets the offline availability of the specified object.

Syntax

Visual Basic
Public Function GetOfflineAvailability( _
   ByVal ObjID As ObjID _
) As Boolean

Parameters

ObjID
The ID identifying the object.

Remarks

The method returns "true" if the object with the specified object ID is available offline.

Objects can be set to be available offline via the SetOfflineAvailability method, via a view that acts as an offline filter, or via checking out them out for editing.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetOfflineObjIDs Method
VaultObjectOperations Object : GetOfflineObjIDs Method

Glossary Item Box

Description

Gets the IDs of the objects set to be available offline.

Syntax

Visual Basic
Public Function GetOfflineObjIDs() As ObjIDs

Remarks

The method returns the IDs of the objects currently available offline in the vault.

Objects can be set to be available offline via the SetOfflineAvailability method, via a view that acts as an offline filter, or via checking out them out for editing.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetRelatedObjectInfo Method
Lookup
UpdateFromServer
VaultObjectOperations Object : GetRelatedObjectInfo Method

Glossary Item Box

Description

Gets information related to the specified lookup property.

Syntax

Visual Basic
Public Function GetRelatedObjectInfo( _
   ByVal Lookup As Lookup, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ObjectVersion

Parameters

Lookup
UpdateFromServer

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetRelationships Method
ObjVer
Mode
VaultObjectOperations Object : GetRelationships Method

Glossary Item Box

Description

Gets all the relationships of the specified object.

Syntax

Visual Basic
Public Function GetRelationships( _
   ByVal ObjVer As ObjVer, _
   ByVal Mode As MFRelationshipsMode _
) As ObjectVersions

Parameters

ObjVer
Mode
Value | Description
MFRelationshipsModeAll | Relationships FROM and TO the specified object.
MFRelationshipsModeFromThisObject | Relationships FROM the specified object.
MFRelationshipsModeToThisObject | Relationships TO the specified object.

Remarks

This method returns the first 500 results only.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetRelationshipsEx Method
ObjVer
The object version the relationships of which to get.
Mode
The relationship direction.
SearchInEachObjectType

If this is set to "true", the retrieved relationships of the specified object are guaranteed to contain a maximum of 50 results from all object types. If this is set to "false", however, and the number of relationships that the object has exceeds the maximum number of allowed results (500 by default), the results may contain only a subset of all the object types. In other words, if set to "true", the relationship retrieval works the same way as M-Files search operations normally do.

However, in some cases, the limits indicated above may slightly vary as they apply only to relationships TO the specified object. In other words, relationship FROM the specified object are not limited. Consequently, if the "MFRelationshipsModeAll" mode is used (combining the TO and FROM results), the overall number of the returned related objects may not exactly match the indicated limits.

VaultObjectOperations Object : GetRelationshipsEx Method

Glossary Item Box

Description

Gets all the relationships of the specified object.

Syntax

Visual Basic
Public Function GetRelationshipsEx( _
   ByVal ObjVer As ObjVer, _
   ByVal Mode As MFRelationshipsMode, _
   ByVal SearchInEachObjectType As Boolean _
) As ObjectVersions

Parameters

ObjVer
The object version the relationships of which to get.
Mode
Value | Description
MFRelationshipsModeAll | Relationships FROM and TO the specified object.
MFRelationshipsModeFromThisObject | Relationships FROM the specified object.
MFRelationshipsModeToThisObject | Relationships TO the specified object.
The relationship direction.
SearchInEachObjectType

If this is set to "true", the retrieved relationships of the specified object are guaranteed to contain a maximum of 50 results from all object types. If this is set to "false", however, and the number of relationships that the object has exceeds the maximum number of allowed results (500 by default), the results may contain only a subset of all the object types. In other words, if set to "true", the relationship retrieval works the same way as M-Files search operations normally do.

However, in some cases, the limits indicated above may slightly vary as they apply only to relationships TO the specified object. In other words, relationship FROM the specified object are not limited. Consequently, if the "MFRelationshipsModeAll" mode is used (combining the TO and FROM results), the overall number of the returned related objects may not exactly match the indicated limits.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

GetThumbnailAsBytes Method
ObjVer
FileVer
Width
Height
GetFileIconThumbnailIfRealThumbnailNotAvailable
When True M-Files is allowed to return the default image representing the file type of the requested file. This may happen if M-Files cannot generate thumbnail representing the real content of the requested file.
VaultObjectOperations Object : GetThumbnailAsBytes Method

Glossary Item Box

Description

Gets the thumbnail for the specified object in PNG format.

Syntax

Visual Basic
Public Function GetThumbnailAsBytes( _
   ByVal ObjVer As ObjVer, _
   ByVal FileVer As FileVer, _
   ByVal Width As Long, _
   ByVal Height As Long, _
   ByVal GetFileIconThumbnailIfRealThumbnailNotAvailable As Boolean _
) As Byte()

Parameters

ObjVer
FileVer
Width
Height
GetFileIconThumbnailIfRealThumbnailNotAvailable
When True M-Files is allowed to return the default image representing the file type of the requested file. This may happen if M-Files cannot generate thumbnail representing the real content of the requested file.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

IsObjectCheckedOut Method
ObjID
The identity of the object to be checked.
UpdateFromServer
True if the information should always be updated from the server. If false, the client local cache may be used. This flag is relevant only when M-Files API is used in client mode.
VaultObjectOperations Object : IsObjectCheckedOut Method

Glossary Item Box

Description

Checks whether the specified object is checked out to any user on any computer.

Syntax

Visual Basic
Public Function IsObjectCheckedOut( _
   ByVal ObjID As ObjID, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As Boolean

Parameters

ObjID
The identity of the object to be checked.
UpdateFromServer
True if the information should always be updated from the server. If false, the client local cache may be used. This flag is relevant only when M-Files API is used in client mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

IsObjectCheckedOutToThisUserOnThisComputer Method
ObjID
The identity of the object to be checked.
UpdateFromServer
True if the information should always be updated from the server. If false, the client local cache may be used. This flag is relevant only when M-Files API is used in client mode.
VaultObjectOperations Object : IsObjectCheckedOutToThisUserOnThisComputer Method

Glossary Item Box

Description

Checks whether the specified object is checked out to this user on this computer.

Syntax

Visual Basic
Public Function IsObjectCheckedOutToThisUserOnThisComputer( _
   ByVal ObjID As ObjID, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As Boolean

Parameters

ObjID
The identity of the object to be checked.
UpdateFromServer
True if the information should always be updated from the server. If false, the client local cache may be used. This flag is relevant only when M-Files API is used in client mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

IsObjectFollowed Method
ObjID
The ID of the object to be checked.
VaultObjectOperations Object : IsObjectFollowed Method

Glossary Item Box

Description

Checks whether the specified object is currently followed by the current user.

Syntax

Visual Basic
Public Function IsObjectFollowed( _
   ByVal ObjID As ObjID _
) As Boolean

Parameters

ObjID
The ID of the object to be checked.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

IsSingleFileObject Method
ObjVer
VaultObjectOperations Object : IsSingleFileObject Method

Glossary Item Box

Description

Checks whether the specified object version is a single-file or multi-file document.

Syntax

Visual Basic
Public Function IsSingleFileObject( _
   ByVal ObjVer As ObjVer _
) As Boolean

Parameters

ObjVer

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

MatchesSearchConditions Method
pIObjVer
The identifier of the object.
pISearchConditions
The conditions used in the search.
VaultObjectOperations Object : MatchesSearchConditions Method

Glossary Item Box

Description

Checks whether the specified object matches the search conditions. Any field expression in search conditions is not supported.

Syntax

Visual Basic
Public Function MatchesSearchConditions( _
   ByVal pIObjVer As ObjVer, _
   ByVal pISearchConditions As SearchConditions _
) As Boolean

Parameters

pIObjVer
The identifier of the object.
pISearchConditions
The conditions used in the search.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

MatchesSearchConditionsEx Method
pIObjectVersion
The identifier of the object.
pISearchConditions
The conditions used in the search.
pIPropertyValues
Optional parameter. The property values of the object version. Can be defined for potentially decreasing the duration of the request. The method assumes that the property values defined in this parameter are the properties of "pIObjectVersion".
pIObjectVersionAndPropertiesOfMultipleObjects

Optional parameter. A set of additional object versions and their properties. Can be defined for potentially decreasing the duration of the request.

VaultObjectOperations Object : MatchesSearchConditionsEx Method

Glossary Item Box

Description

Checks whether the specified object and properties match the search conditions. Any field expression in search conditions is not supported.

Syntax

Visual Basic
Public Function MatchesSearchConditionsEx( _
   ByVal pIObjectVersion As ObjectVersion, _
   ByVal pISearchConditions As SearchConditions, _
   Optional ByVal pIPropertyValues As PropertyValues = 0, _
   Optional ByVal pIObjectVersionAndPropertiesOfMultipleObjects As ObjectVersionAndPropertiesOfMultipleObjects = 0 _
) As Boolean

Parameters

pIObjectVersion
The identifier of the object.
pISearchConditions
The conditions used in the search.
pIPropertyValues
Optional parameter. The property values of the object version. Can be defined for potentially decreasing the duration of the request. The method assumes that the property values defined in this parameter are the properties of "pIObjectVersion".
pIObjectVersionAndPropertiesOfMultipleObjects

Optional parameter. A set of additional object versions and their properties. Can be defined for potentially decreasing the duration of the request.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

NotifyObjectAccess Method
ObjID
VaultObjectOperations Object : NotifyObjectAccess Method

Glossary Item Box

Description

Notifies M-Files that an object has been accessed. This will add the object to the Recently Accessed by Me view of the user.

Syntax

Visual Basic
Public Function NotifyObjectAccess( _
   ByVal ObjID As ObjID _
) As ObjectVersionAndProperties

Parameters

ObjID

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ProposeCheckOutForFile Method
ParentWindow
ObjVersionFile
The file identifier for the file to be checked out.
CanCancel
If this parameter is True, the user is allowed to cancel the check out operation.
VaultObjectOperations Object : ProposeCheckOutForFile Method

Glossary Item Box

Description

Proposes checkout operation for the object file. System may prompt for checkout. Returns error on cancel.

Syntax

Visual Basic
Public Function ProposeCheckOutForFile( _
   ByVal ParentWindow As Long, _
   ByVal ObjVersionFile As ObjectVersionFile, _
   ByVal CanCancel As Boolean _
) As Boolean

Parameters

ParentWindow
ObjVersionFile
The file identifier for the file to be checked out.
CanCancel
If this parameter is True, the user is allowed to cancel the check out operation.

Return Type

Returns True if the user chose to check out the file, False otherwise.

Remarks

This method does not actually check out the file but simply shows the UI dialog asking the user. The API caller can then check the return value and continue with appropriate actions.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

RejectCheckInReminder Method
ObjVer
The object identifier for the object to be checked in.
VaultObjectOperations Object : RejectCheckInReminder Method

Glossary Item Box

Description

Prevents implicitly or explicitly triggered checkin reminder from calling process.

Syntax

Visual Basic
Public Sub RejectCheckInReminder( _
   ByVal ObjVer As ObjVer _
)

Parameters

ObjVer
The object identifier for the object to be checked in.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

RemoveFavorite Method
ObjID
VaultObjectOperations Object : RemoveFavorite Method

Glossary Item Box

Description

Removes the specified object from the 'Favorites' view of the current user.

Syntax

Visual Basic
Public Function RemoveFavorite( _
   ByVal ObjID As ObjID _
) As ObjectVersionAndProperties

Parameters

ObjID

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

RemoveFavorites Method
ObjIDs
VaultObjectOperations Object : RemoveFavorites Method

Glossary Item Box

Description

Removes the specified objects from the 'Favorites' view of the current user.

Syntax

Visual Basic
Public Function RemoveFavorites( _
   ByVal ObjIDs As ObjIDs _
) As ObjectVersionAndPropertiesOfMultipleObjects

Parameters

ObjIDs

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ResolveConflict Method
ParticipantObjID
The ID of the participant object.
KeepThis
If this is set to true, the changes of the participant object are kept.
VaultObjectOperations Object : ResolveConflict Method

Glossary Item Box

Description

Resolves a conflict that involves the specified participant object. Returns the affected objects. Do not use this method if the vault uses automatic conflict resolution.

Syntax

Visual Basic
Public Function ResolveConflict( _
   ByVal ParticipantObjID As ObjID, _
   ByVal KeepThis As Boolean _
) As ObjectVersions

Parameters

ParticipantObjID
The ID of the participant object.
KeepThis
If this is set to true, the changes of the participant object are kept.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

Rollback Method
ObjID
The ID of the object to roll back.
RollbackToVersion
The version of the object to roll back to.
VaultObjectOperations Object : Rollback Method

Glossary Item Box

Description

Rolls back the specified object to the specified version. Prefer RollbackEx as its parameter RollbackToVersion supports unmanaged external repository objects.

Syntax

Visual Basic
Public Function Rollback( _
   ByVal ObjID As ObjID, _
   ByVal RollbackToVersion As Long _
) As ObjectVersion

Parameters

ObjID
The ID of the object to roll back.
RollbackToVersion
The version of the object to roll back to.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

RollbackEx Method
ObjID
The ID of the object to roll back.
RollbackToVersion
The version of the object to roll back to.
VaultObjectOperations Object : RollbackEx Method

Glossary Item Box

Description

Rolls back the specified object to the specified version.

Syntax

Visual Basic
Public Function RollbackEx( _
   ByVal ObjID As ObjID, _
   ByVal RollbackToVersion As ObjVerVersion _
) As ObjectVersion

Parameters

ObjID
The ID of the object to roll back.
RollbackToVersion
The version of the object to roll back to.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

SetExternalID Method
ObjID
The object to set the external ID for.
ExtID
The new external ID.
VaultObjectOperations Object : SetExternalID Method

Glossary Item Box

Description

Sets the external ID for an object. The object itself must be internal.

Syntax

Visual Basic
Public Sub SetExternalID( _
   ByVal ObjID As ObjID, _
   ByVal ExtID As String _
)

Parameters

ObjID
The object to set the external ID for.
ExtID
The new external ID.

Remarks

The maximum lenght of the external ID is 60 characters.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

SetObjectGUID Method
ObjID
ObjectGUID
VaultObjectOperations Object : SetObjectGUID Method

Glossary Item Box

Description

Sets the Object GUID of the specified object.

Syntax

Visual Basic
Public Sub SetObjectGUID( _
   ByVal ObjID As ObjID, _
   ByVal ObjectGUID As String _
)

Parameters

ObjID
ObjectGUID

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

SetOfflineAvailability Method
ObjID
AvailableInOfflineMode
VaultObjectOperations Object : SetOfflineAvailability Method

Glossary Item Box

Description

Marks the specified object for offline availability, or clears the offline availability marker.

Syntax

Visual Basic
Public Sub SetOfflineAvailability( _
   ByVal ObjID As ObjID, _
   ByVal AvailableInOfflineMode As Boolean _
)

Parameters

ObjID
AvailableInOfflineMode

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

SetSingleFileObject Method
ObjVer
SingleFile
VaultObjectOperations Object : SetSingleFileObject Method

Glossary Item Box

Description

Changes the single-file status of the specified object.

Syntax

Visual Basic
Public Sub SetSingleFileObject( _
   ByVal ObjVer As ObjVer, _
   ByVal SingleFile As Boolean _
)

Parameters

ObjVer
SingleFile

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowBasicEditObjectWindow Method
ParentWindow
ObjVer
The object version that identifies the object.
VaultObjectOperations Object : ShowBasicEditObjectWindow Method

Glossary Item Box

Description

Displays the edit object metadata window.

Syntax

Visual Basic
Public Function ShowBasicEditObjectWindow( _
   ByVal ParentWindow As Long, _
   ByVal ObjVer As ObjVer _
) As ObjectWindowResult

Parameters

ParentWindow
ObjVer
The object version that identifies the object.

Return Type

The ObjectWindowResult object that contains the return values of the function. Includes information on the cancellation of the metadata card.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowBasicNewObjectWindow Method
ParentWindow
ObjectType
The type of the new object.
VaultObjectOperations Object : ShowBasicNewObjectWindow Method

Glossary Item Box

Description

Displays the new object metadata window.

Syntax

Visual Basic
Public Function ShowBasicNewObjectWindow( _
   ByVal ParentWindow As Long, _
   ByVal ObjectType As ObjType _
) As ObjectWindowResult

Parameters

ParentWindow
ObjectType
The type of the new object.

Return Type

The ObjectWindowResult object that contains the return values of the function. Includes information on the cancellation of the metadata card.

Remarks

Use the VaultObjectFileOperations interface to add new files to the created object.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members | VaultObjectFileOperations Object


%%PageItemTitle%%

ShowChangeStateDialogModal Method
ParentWindow
Parent window for the dialog.
ObjectID
The identity of the object for which the dialog is shown.
VaultObjectOperations Object : ShowChangeStateDialogModal Method

Glossary Item Box

Description

Displays the 'Change State' dialog box for the object.

Syntax

Visual Basic
Public Sub ShowChangeStateDialogModal( _
   ByVal ParentWindow As Long, _
   ByVal ObjectID As ObjID _
)

Parameters

ParentWindow
Parent window for the dialog.
ObjectID
The identity of the object for which the dialog is shown.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowCheckInReminder Method
ParentWindow
ObjVer
The object identifier for the object to be checked in.
Asynchronous
If this parameter is True, the call can return before the user reacts to the reminder prompt. In this case M-Files Client will invoke the reminder and no further interaction from M-Files API or the hosting application is required.
VaultObjectOperations Object : ShowCheckInReminder Method

Glossary Item Box

Description

Displays the checkin reminder for the specified object. Can fail if the object is open in another program.

Syntax

Visual Basic
Public Function ShowCheckInReminder( _
   ByVal ParentWindow As Long, _
   ByVal ObjVer As ObjVer, _
   ByVal Asynchronous As Boolean _
) As ObjectVersion

Parameters

ParentWindow
ObjVer
The object identifier for the object to be checked in.
Asynchronous
If this parameter is True, the call can return before the user reacts to the reminder prompt. In this case M-Files Client will invoke the reminder and no further interaction from M-Files API or the hosting application is required.

Remarks

Prompts the user to check in the document. If the user accepts the check in reminder, the object will be checked in.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowCheckInReminderDialogModal Method
ParentWindow
ObjVer
The object identifier for the object to be checked in.
ApplyEnvironmentConditions
If this parameter is True, environment conditions are applied regarding the check-in operation, such as pre-configured behavior settings or offline status. Valid for synchronous check in operations only.
VaultObjectOperations Object : ShowCheckInReminderDialogModal Method

Glossary Item Box

Description

Displays a modal checkin reminder dialog for the specified object. Does not perform the actual check in operation. Returns error on cancel.

Syntax

Visual Basic
Public Function ShowCheckInReminderDialogModal( _
   ByVal ParentWindow As Long, _
   ByVal ObjVer As ObjVer, _
   ByVal ApplyEnvironmentConditions As Boolean _
) As Boolean

Parameters

ParentWindow
ObjVer
The object identifier for the object to be checked in.
ApplyEnvironmentConditions
If this parameter is True, environment conditions are applied regarding the check-in operation, such as pre-configured behavior settings or offline status. Valid for synchronous check in operations only.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowCheckoutPrompt Method
ParentWindow
Message
The message to be shown in the checkout prompt.
ObjID
The object identifier for the object to be checked out.
ShowCancel
If this parameter is True, the cancel button is shown.
AutoRejectConsequentPrompts
If true, the object checkout prompt can be rejected automatically without showing the dialog box if the checkout was rejected recently in another application.
VaultObjectOperations Object : ShowCheckoutPrompt Method

Glossary Item Box

Description

Displays the object checkout prompt for the user.

Syntax

Visual Basic
Public Function ShowCheckoutPrompt( _
   ByVal ParentWindow As Long, _
   ByVal Message As String, _
   ByVal ObjID As ObjID, _
   ByVal ShowCancel As Boolean, _
   Optional ByVal AutoRejectConsequentPrompts As Boolean = False _
) As ObjectVersion

Parameters

ParentWindow
Message
The message to be shown in the checkout prompt.
ObjID
The object identifier for the object to be checked out.
ShowCancel
If this parameter is True, the cancel button is shown.
AutoRejectConsequentPrompts
If true, the object checkout prompt can be rejected automatically without showing the dialog box if the checkout was rejected recently in another application.

Return Type

The object version data for the object. If the checkout prompt was cancelled, an empty (null or equivalent) reference is returned.

Remarks

This method displays a checkout prompt for the user. If the user accepts the check out, the object will be checked out. Use the returned object version data to resolve whether the object was checked out.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowCollectionMembersDialog Method
ParentWindow
ObjectVersion
Modeless
VaultObjectOperations Object : ShowCollectionMembersDialog Method

Glossary Item Box

Description

Displays the collection members dialog box for the object.

Syntax

Visual Basic
Public Sub ShowCollectionMembersDialog( _
   ByVal ParentWindow As Long, _
   ByVal ObjectVersion As ObjVer, _
   Optional ByVal Modeless As Boolean = False _
)

Parameters

ParentWindow
ObjectVersion
Modeless

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowCommentsDialogModal Method
ParentWindow
ObjectID
VaultObjectOperations Object : ShowCommentsDialogModal Method

Glossary Item Box

Description

Displays the comments dialog box for the object.

Syntax

Visual Basic
Public Sub ShowCommentsDialogModal( _
   ByVal ParentWindow As Long, _
   ByVal ObjectID As ObjID _
)

Parameters

ParentWindow
ObjectID

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowEditObjectWindow Method
ParentWindow
Mode
ObjVer
VaultObjectOperations Object : ShowEditObjectWindow Method

Glossary Item Box

Description

Displays the edit object metadata window.

Syntax

Visual Basic
Public Function ShowEditObjectWindow( _
   ByVal ParentWindow As Long, _
   ByVal Mode As MFObjectWindowMode, _
   ByVal ObjVer As ObjVer _
) As ObjectWindowResult

Parameters

ParentWindow
Mode
Value | Description
MFObjectWindowModeEdit | The default edit mode.
MFObjectWindowModeEditApplicationModal | The object shown in the object window is currently open in the application, too. Does not allow the file name to change.
MFObjectWindowModeInsert | The default insert mode.
MFObjectWindowModeInsertSaveAsType | Shows file type selection in the metadata card. The selectable file types can be specified using ObjectCreationInfo.
MFObjectWindowModeInsertSourceFiles | The source files specified in ObjectCreationInfo are added to the new object.
ObjVer

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowHistoryDialogModal Method
ParentWindow
ObjectID
VaultObjectOperations Object : ShowHistoryDialogModal Method

Glossary Item Box

Description

Displays the history dialog box for the object.

Syntax

Visual Basic
Public Sub ShowHistoryDialogModal( _
   ByVal ParentWindow As Long, _
   ByVal ObjectID As ObjID _
)

Parameters

ParentWindow
ObjectID

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowNewObjectWindow Method
ParentWindow
Mode
The mode in which the metadata card is opened.
ObjectCreationInfo
The initial state of the new metadata card.
VaultObjectOperations Object : ShowNewObjectWindow Method

Glossary Item Box

Description

Displays the new object metadata window.

Syntax

Visual Basic
Public Function ShowNewObjectWindow( _
   ByVal ParentWindow As Long, _
   ByVal Mode As MFObjectWindowMode, _
   ByVal ObjectCreationInfo As ObjectCreationInfo _
) As ObjectWindowResult

Parameters

ParentWindow
Mode
Value | Description
MFObjectWindowModeEdit | The default edit mode.
MFObjectWindowModeEditApplicationModal | The object shown in the object window is currently open in the application, too. Does not allow the file name to change.
MFObjectWindowModeInsert | The default insert mode.
MFObjectWindowModeInsertSaveAsType | Shows file type selection in the metadata card. The selectable file types can be specified using ObjectCreationInfo.
MFObjectWindowModeInsertSourceFiles | The source files specified in ObjectCreationInfo are added to the new object.
The mode in which the metadata card is opened.
ObjectCreationInfo
The initial state of the new metadata card.

Return Type

The ObjectWindowResult object that contains the return values of the function. Includes information on the cancellation of the metadata card.

Remarks

Use the VaultObjectFileOperations object to add new files to the created object.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members | VaultObjectFileOperations Object


%%PageItemTitle%%

ShowPrefilledNewObjectWindow Method
ParentWindow
Mode
ObjectCreationInfo
PrefilledPropertyValues

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AccessControlList

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultObjectOperations Object : ShowPrefilledNewObjectWindow Method

Glossary Item Box

Description

Displays a new object metadata window.

Syntax

Visual Basic
Public Function ShowPrefilledNewObjectWindow( _
   ByVal ParentWindow As Long, _
   ByVal Mode As MFObjectWindowMode, _
   ByVal ObjectCreationInfo As ObjectCreationInfo, _
   Optional ByVal PrefilledPropertyValues As PropertyValues = 0, _
   Optional ByVal AccessControlList As AccessControlList = 0 _
) As ObjectWindowResult

Parameters

ParentWindow
Mode
Value | Description
MFObjectWindowModeEdit | The default edit mode.
MFObjectWindowModeEditApplicationModal | The object shown in the object window is currently open in the application, too. Does not allow the file name to change.
MFObjectWindowModeInsert | The default insert mode.
MFObjectWindowModeInsertSaveAsType | Shows file type selection in the metadata card. The selectable file types can be specified using ObjectCreationInfo.
MFObjectWindowModeInsertSourceFiles | The source files specified in ObjectCreationInfo are added to the new object.
ObjectCreationInfo
PrefilledPropertyValues

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AccessControlList

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowRelatedObjects Method
ParentWindow
SourceObject
ObjectTypeTargetForBrowsing
Identifies the view where the objects of this type are shown under the built-in views. Only objects related to the object identified by SourceObject are shown in this view.
ViewSelectionDialogInfoText
Title for the possible location selection dialog that is shown if multiple valid locations are available.
VaultObjectOperations Object : ShowRelatedObjects Method

Glossary Item Box

Description

Shows related objects for the object by target object type in Windows Explorer.

Syntax

Visual Basic
Public Sub ShowRelatedObjects( _
   ByVal ParentWindow As Long, _
   ByVal SourceObject As ObjID, _
   ByVal ObjectTypeTargetForBrowsing As ObjectTypeTargetForBrowsing, _
   Optional ByVal ViewSelectionDialogInfoText As String = "" _
)

Parameters

ParentWindow
SourceObject
ObjectTypeTargetForBrowsing
Identifies the view where the objects of this type are shown under the built-in views. Only objects related to the object identified by SourceObject are shown in this view.
ViewSelectionDialogInfoText
Title for the possible location selection dialog that is shown if multiple valid locations are available.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowRelationshipsDialog Method
ParentWindow
ObjectVersion
Modeless
VaultObjectOperations Object : ShowRelationshipsDialog Method

Glossary Item Box

Description

Displays the relationships dialog box for the object.

Syntax

Visual Basic
Public Sub ShowRelationshipsDialog( _
   ByVal ParentWindow As Long, _
   ByVal ObjectVersion As ObjVer, _
   Optional ByVal Modeless As Boolean = False _
)

Parameters

ParentWindow
ObjectVersion
Modeless

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowSelectObjectHistoryDialogModal Method
ParentWindow
ObjectID
WindowTitle
VaultObjectOperations Object : ShowSelectObjectHistoryDialogModal Method

Glossary Item Box

Description

Displays the history dialog box for the object.

Syntax

Visual Basic
Public Function ShowSelectObjectHistoryDialogModal( _
   ByVal ParentWindow As Long, _
   ByVal ObjectID As ObjID, _
   Optional ByVal WindowTitle As String = "" _
) As ObjOrFileVer

Parameters

ParentWindow
ObjectID
WindowTitle

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

ShowSubObjectsDialogModal Method
ParentWindow
ObjectVersion
The object version identifier.
VaultObjectOperations Object : ShowSubObjectsDialogModal Method

Glossary Item Box

Description

Displays the sub-objects dialog box for the object.

Syntax

Visual Basic
Public Sub ShowSubObjectsDialogModal( _
   ByVal ParentWindow As Long, _
   ByVal ObjectVersion As ObjVer _
)

Parameters

ParentWindow
ObjectVersion
The object version identifier.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

UndeleteObject Method
ObjID
VaultObjectOperations Object : UndeleteObject Method

Glossary Item Box

Description

Undeletes the specified object.

Syntax

Visual Basic
Public Function UndeleteObject( _
   ByVal ObjID As ObjID _
) As ObjectVersion

Parameters

ObjID

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

UndoCheckout Method
ObjVer
The object version for which to perform the operation.
VaultObjectOperations Object : UndoCheckout Method

Glossary Item Box

Description

Performs undo checkout for the specified object version.

Syntax

Visual Basic
Public Function UndoCheckout( _
   ByVal ObjVer As ObjVer _
) As ObjectVersion

Parameters

ObjVer
The object version for which to perform the operation.

Remarks

If the object is removed via this operation, the method returns null (or another marker for an empty or undefined value).

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

UndoCheckoutMultipleObjects Method
ObjVers
The ObjVers collection for which to perform this operation.
VaultObjectOperations Object : UndoCheckoutMultipleObjects Method

Glossary Item Box

Description

Performs undo checkout for the specified object versions.

Syntax

Visual Basic
Public Function UndoCheckoutMultipleObjects( _
   ByVal ObjVers As ObjVers _
) As ObjectVersions

Parameters

ObjVers
The ObjVers collection for which to perform this operation.

Remarks

If the objects are removed via this operation, the VisibleAfterOperation field for those objects will be false.

See Also

VaultObjectOperations Object | VaultObjectOperations Members


%%PageItemTitle%%

VaultObjectPropertyOperations Object
Members See Also Example Send comments

Glossary Item Box

Description

A group of methods for updating and modifying the properties of an object.

Public Methods

Public Method ApproveOrRejectAssignment | Marks the assignment as approved or rejected by the logged-in user.
Public Method ApproveOrRejectAssignmentByUser | Marks the assignment as approved or rejected by the specified user.
Public Method ClearArchivingMarker | Clears the archiving marker of the object.
Public Method CreatePropertiesFromFileInformation | Creates properties based on the given file information.
Public Method GenerateAutomaticPermissionsFromPropertyValues | Generates the automatic permissions components from the specifies property values.
Public Method GetProperties | Gets all the properties of the specified object version.
Public Method GetPropertiesAsXML | Gets the properties of the specified object version as XML.
Public Method GetPropertiesForDisplay | Gets the properties of the specified object version for display purposes.
Public Method GetPropertiesForMetadataSync | Gets the direct and indirect properties of the specified object version for the purpose of synchronizing file content with current metadata.
Public Method GetPropertiesForMetadataSyncEx | Gets the direct and indirect properties of the specified object version to synchronize the file content with the current metadata.
Public Method GetPropertiesForMetadataSyncWithMetadataReferenceFilter | Gets the direct and indirect properties of the specified object version to synchronize the file content with the current metadata.
Public Method GetPropertiesOfMultipleObjects | Gets the properties of multiple objects.
Public Method GetPropertiesOfMultipleObjectsForDisplay | Gets the properties of the specified object versions for display purposes.
Public Method GetPropertiesWithIconClues | Gets all the properties of the specified object version with icon clues.
Public Method GetPropertiesWithIconCluesOfMultipleObjects | Gets the properties of multiple objects with icon clues.
Public Method GetProperty | Gets the specified property value of the specified object version.
Public Method GetVersionComment | Gets the version comment of the specified object.
Public Method GetVersionCommentHistory | Gets the version comment history of the specified object.
Public Method GetWorkflowState | Gets the workflow of the specified object.
Public Method MarkAssignmentComplete | Marks the assignment as completed by the logged-in user.
Public Method MarkAssignmentCompleteByUser | Marks the assignment as completed by the specified user.
Public Method MarkForArchiving | Marks the object for archiving.
Public Method RemoveProperty | Removes the specified property value from the specified object version.
Public Method SetAllProperties | Sets all the properties of the specified object.
Public Method SetAllPropertiesEx | Sets all the properties of the specified object.
Public Method SetAllPropertiesWithPermissions | Sets all the properties and permissions of the specified object.
Public Method SetAllPropertiesWithPermissionsEx | Sets all the properties and permissions of the specified object.
Public Method SetCreationInfoAdmin | Sets the creation info of the specified object. Returns the properties of the specified object after modification.
Public Method SetLastModificationInfoAdmin | Sets the last modified info of the specified object version. Returns the properties of the specified object after modification.
Public Method SetProperties | Sets all the properties of the specified object version.
Public Method SetPropertiesEx | Sets the specified properties of the specified object version.
Public Method SetPropertiesOfMultipleObjects | Sets the properties of multiple objects.
Public Method SetPropertiesWithPermissions | Sets all the properties and permissions of the specified object version.
Public Method SetPropertiesWithPermissionsEx | Sets all the properties and permissions of the specified object version.
Public Method SetProperty | Sets the specified property value of the specified object version.
Public Method SetVersionComment | Sets the version comment for the specified object.
Public Method SetWorkflowState | Sets the workflow for the specified object.
Public Method SetWorkflowStateEx | Sets the workflow for the specified object.
Public Method SetWorkflowStateTransition | Sets the workflow state transition for the specified object.
Public Method SetWorkflowStateTransitionEx | Sets the workflow state transition for the specified object with an electronic signature.

Example

This method group interface can be accessed via the Vault object.
Listing property values for an object (Visual Basic) Copy Code
' Initialize the API and connect to a vault.
Dim oVault As MFilesAPI.Vault
' ...

' We are searching for the document with ID 123.
Dim iDocumentId As Integer
iDocumentId = 123

' Initialize an ObjID object.
Dim oObjId As New MFilesAPI.ObjID
oObjId.SetIDs(MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument, iDocumentId)

' Invoke the search operation.
Dim oResult As MFilesAPI.ObjectVersionAndProperties
oResult = oVault.ObjectOperations.GetLatestObjectVersionAndProperties(oObjId, True)

' Resolve the value of the "Name or title" property.
Dim oPropertyValue As MFilesAPI.PropertyValue
oPropertyValue = oResult.Properties.SearchForProperty( _
    MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefNameOrTitle)

' Output the document title.
Call Console.WriteLine("Title: " + oPropertyValue.TypedValue.DisplayValue)
Call Console.WriteLine("Other properties and their values:")

' List all the other properties and their values.
For Each oPropertyValue2 As MFilesAPI.PropertyValue In oResult.Properties

    If oPropertyValue2.PropertyDef <> MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefNameOrTitle Then

        ' Find the property definition for the property.
        Dim oPropertyDef As MFilesAPI.PropertyDef
        oPropertyDef = oVault.PropertyDefOperations.GetPropertyDef(oPropertyValue2.PropertyDef)

        ' Output the name and the value of the property.
        Call Console.WriteLine("   " + oPropertyDef.Name + ": " + oPropertyValue2.TypedValue.DisplayValue)

    End If

Next
Setting a single property value for an object (Visual Basic) Copy Code
' Initialize the API and connect to a vault.
Dim oVault As MFilesAPI.Vault
' ...

' We are searching for the document with ID 123.
Dim iDocumentId As Integer
iDocumentId = 123

' Initialize an ObjID object for the search.
Dim oObjId As New MFilesAPI.ObjID
oObjId.SetIDs(MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument, iDocumentId)

' Get object version properties.
Dim oObjectVersionAndProperties As MFilesAPI.ObjectVersionAndProperties = Nothing
oObjectVersionAndProperties = oVault.ObjectOperations.GetLatestObjectVersionAndProperties(oObjID, True)

' Create new property value.
Dim oPropertyValue As MFilesAPI.PropertyValue = New MFilesAPI.PropertyValue
oPropertyValue.PropertyDef = 1096  ' In this case, represents the "Effective through" property
oPropertyValue.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeDate, DateSerial(2015, 1, 1))

' Modify the object. The object needs to be in checked out state.
oVault.ObjectPropertyOperations.SetProperty(oObjectVersionAndProperties.ObjVer, oPropertyValue)
A more example on setting property values for an object (Visual Basic) Copy Code
' Placeholder for all the property definitions in the system.
Private garrPropertyDefs As MFilesAPI.PropertyDefs
' Placeholder for all the value lists in the system.
Private garrValueLists As MFilesAPI.ObjTypes

Sub SetPropertiesForAnObject

    ' Initialize the API and connect to a vault.
    Dim oVault As MFilesAPI.Vault
    ' ...

    ' Ensure that we are aware of all the property definitions and value lists available. This needs to be done only once.
    LoadPropertyDefs(oVault)
    LoadValueLists(oVault)

    ' We are searching for the document with ID 123.
    Dim iDocumentId As Integer
    iDocumentId = 123

    ' Initialize an ObjID object for the search.
    Dim oObjId As New MFilesAPI.ObjID
    oObjId.SetIDs(MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument, iDocumentId)

    ' Check out the object first. We assume that initially the object is checked in.
    Dim oObjectVersionCheckedOut As MFilesAPI.ObjectVersion
    oObjectVersionCheckedOut = oVault.ObjectOperations.CheckOut(oObjID)

    ' Resolve the property definition IDs.
    Dim iPropDefProject = MF_FindPropertyDefID(oVault, "Project")
    Dim iPropDefJobTitle = MF_FindPropertyDefID(oVault, "Job title")

    ' Resolve the IDs of the project lookup value.
    Dim iProjectValueList = MF_FindValueListID(oVault, "Projects")
    Dim iProjectValueListItem = MF_FindValueListItemID(oVault, iProjectValueList, "Philo District Redevelopment")

    ' Container for the added and/or modified properties.
    Dim oPropertyValues As New MFilesAPI.PropertyValues

    ' Initialize a "Project" property value.
    Dim oPropertyValue1 As New MFilesAPI.PropertyValue
    oPropertyValue1.PropertyDef = iPropDefProject
    oPropertyValue1.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeMultiSelectLookup, iProjectValueListItem)
    oPropertyValues.Add(-1, oPropertyValue1)

    ' Initialize a "Job title" property value.
    Dim oPropertyValue2 As New MFilesAPI.PropertyValue
    oPropertyValue2.PropertyDef = iPropDefJobTitle
    oPropertyValue2.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeText, "My job title")
    oPropertyValues.Add(-1, oPropertyValue2)

    ' Set the properties.
    oVault.ObjectPropertyOperations.SetProperties(oObjectVersionCheckedOut.ObjVer, oPropertyValues)

    ' Finally, we must check in the changes.
    oVault.ObjectOperations.CheckIn(oObjectVersionCheckedOut.ObjVer)

 End Sub

 ' Helper method to load all the property definitions in the system.
Sub LoadPropertyDefs(ByRef oVault As MFilesAPI.Vault)
    garrPropertyDefs = oVault.PropertyDefOperations.GetPropertyDefs
End Sub

' Helper method to load all the value lists in the system.
Sub LoadValueLists(ByRef oVault As MFilesAPI.Vault)
    garrValueLists = oVault.ValueListOperations.GetValueLists
End Sub

' Helper function to find the property definition ID by the property definition name.
Function MF_FindPropertyDefID( _
            ByRef oVault As MFilesAPI.Vault, _
            ByVal szPropDefName As String) As Integer

    MF_FindPropertyDefID = -1
    Dim oPropDef As MFilesAPI.PropertyDef
    For i = 1 To garrPropertyDefs.Count
        oPropDef = garrPropertyDefs.Item(i)
        If oPropDef.Name = szPropDefName Then
            MF_FindPropertyDefID = oPropDef.ID
        End If
    Next
End Function

' Helper function to find the value list ID by the value list name.
Function MF_FindValueListID( _
            ByRef oVault As MFilesAPI.Vault, _
            ByVal szValueListName As String) As Integer

    MF_FindValueListID = -1
    Dim oValList As MFilesAPI.ObjType
    For i = 1 To garrValueLists.Count
        oValList = garrValueLists.Item(i)
        If oValList.NamePlural = szValueListName Then
            MF_FindValueListID = oValList.ID
        End If
    Next
End Function

' Helper function to find the value list item ID by the value list item name.
Function MF_FindValueListItemID( _
            ByRef oVault As MFilesAPI.Vault, _
            ByVal iValueListID As Integer, _
            ByVal szValueListItemName As String) As Integer

    ' Set the search conditions for the value list item.
    Dim oScValueListItem As New MFilesAPI.SearchCondition
    oScValueListItem.Expression.SetValueListItemExpression( _
        MFilesAPI.MFValueListItemPropertyDef.MFValueListItemPropertyDefName, _
        MFilesAPI.MFParentChildBehavior.MFParentChildBehaviorNone)
    oScValueListItem.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeEqual
    oScValueListItem.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeText, szValueListItemName)
    Dim arrSearchConditions As New MFilesAPI.SearchConditions
    arrSearchConditions.Add(-1, oScValueListItem)
    ' Search for the value list item.
    Dim results As MFilesAPI.ValueListItemSearchResults
    results = oVault.ValueListItemOperations.SearchForValueListItemsEx(iValueListID, arrSearchConditions)
    If results.Count > 0 Then
        ' Found.
        MF_FindValueListItemID = results(1).ID
    Else
        ' Not found.
        MF_FindValueListItemID = -1
    End If
End Function

See Also

VaultObjectPropertyOperations Members


%%PageItemTitle%%

ApproveOrRejectAssignment Method
ObjVer
The object version that identifies the object.
Approve
Use "True" to approve the assignment, or "False" to reject the assignment.
VaultObjectPropertyOperations Object : ApproveOrRejectAssignment Method

Glossary Item Box

Description

Marks the assignment as approved or rejected by the logged-in user.

Syntax

Visual Basic
Public Function ApproveOrRejectAssignment( _
   ByVal ObjVer As ObjVer, _
   ByVal Approve As Boolean _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version that identifies the object.
Approve
Use "True" to approve the assignment, or "False" to reject the assignment.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

ApproveOrRejectAssignmentByUser Method
ObjVer
The object version that identifies the object.
Approve
Use "True" to approve the assignment, or "False" to reject the assignment.
UserID
The ID identifying the user that has approved or rejected the assignment.
VaultObjectPropertyOperations Object : ApproveOrRejectAssignmentByUser Method

Glossary Item Box

Description

Marks the assignment as approved or rejected by the specified user.

Syntax

Visual Basic
Public Function ApproveOrRejectAssignmentByUser( _
   ByVal ObjVer As ObjVer, _
   ByVal Approve As Boolean, _
   ByVal UserID As Long _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version that identifies the object.
Approve
Use "True" to approve the assignment, or "False" to reject the assignment.
UserID
The ID identifying the user that has approved or rejected the assignment.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

ClearArchivingMarker Method
ObjID
The object to clear the archiving marker from.
VaultObjectPropertyOperations Object : ClearArchivingMarker Method

Glossary Item Box

Description

Clears the archiving marker of the object.

Syntax

Visual Basic
Public Function ClearArchivingMarker( _
   ByVal ObjID As ObjID _
) As ObjectVersionAndProperties

Parameters

ObjID
The object to clear the archiving marker from.

Remarks

Requires M-Files 18.9.6801.16 or later.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

CreatePropertiesFromFileInformation Method
FileInformation
Information about the file.
VaultObjectPropertyOperations Object : CreatePropertiesFromFileInformation Method

Glossary Item Box

Description

Creates properties based on the given file information.

Syntax

Visual Basic
Public Function CreatePropertiesFromFileInformation( _
   ByVal FileInformation As FileInformation _
) As PropertyValues

Parameters

FileInformation
Information about the file.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GenerateAutomaticPermissionsFromPropertyValues Method
PropertyValues
VaultObjectPropertyOperations Object : GenerateAutomaticPermissionsFromPropertyValues Method

Glossary Item Box

Description

Generates the automatic permissions components from the specifies property values.

Syntax

Visual Basic
Public Function GenerateAutomaticPermissionsFromPropertyValues( _
   ByVal PropertyValues As PropertyValues _
) As AccessControlList

Parameters

PropertyValues

Remarks

This method isn't required when setting properties. M-Files server enforces the automatic permissions in these cases. However this method can be used to inspect the automatic permissions an object would get when the properties are set.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetProperties Method
ObjVer
The object version that identifies the object.
UpdateFromServer
If this is set to True, information is always updated from the server.
VaultObjectPropertyOperations Object : GetProperties Method

Glossary Item Box

Description

Gets all the properties of the specified object version.

Syntax

Visual Basic
Public Function GetProperties( _
   ByVal ObjVer As ObjVer, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As PropertyValues

Parameters

ObjVer
The object version that identifies the object.
UpdateFromServer
If this is set to True, information is always updated from the server.

Return Type

The collection of the property values of the object.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetPropertiesAsXML Method
ObjVer
The object version that identifies the object.
UpdateFromServer
If this is set to True, information is always updated from the server.
VaultObjectPropertyOperations Object : GetPropertiesAsXML Method

Glossary Item Box

Description

Gets the properties of the specified object version as XML.

Syntax

Visual Basic
Public Function GetPropertiesAsXML( _
   ByVal ObjVer As ObjVer, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As String

Parameters

ObjVer
The object version that identifies the object.
UpdateFromServer
If this is set to True, information is always updated from the server.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetPropertiesForDisplay Method
ObjVer
The object version that identifies the object.
UpdateFromServer
If this is set to True, information is always updated from the server.
VaultObjectPropertyOperations Object : GetPropertiesForDisplay Method

Glossary Item Box

Description

Gets the properties of the specified object version for display purposes.

Syntax

Visual Basic
Public Function GetPropertiesForDisplay( _
   ByVal ObjVer As ObjVer, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As PropertyValuesForDisplay

Parameters

ObjVer
The object version that identifies the object.
UpdateFromServer
If this is set to True, information is always updated from the server.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetPropertiesForMetadataSync Method
ObjVer
The object version that identifies the object.
Format
Specifies the property format. The naming conventions and data types depend on the target application.
VaultObjectPropertyOperations Object : GetPropertiesForMetadataSync Method

Glossary Item Box

Description

Gets the direct and indirect properties of the specified object version for the purpose of synchronizing file content with current metadata.

Syntax

Visual Basic
Public Function GetPropertiesForMetadataSync( _
   ByVal ObjVer As ObjVer, _
   ByVal Format As MFMetadataSyncFormat _
) As NamedValues

Parameters

ObjVer
The object version that identifies the object.
Format
Value | Description
MFMetadataSyncFormatExcel | Microsoft Excel
MFMetadataSyncFormatPowerPoint | Microsoft PowerPoint
MFMetadataSyncFormatWord | Microsoft Word
Specifies the property format. The naming conventions and data types depend on the target application.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetPropertiesForMetadataSyncEx Method
ObjVer
The object version for which the properties are fetched.
VaultObjectPropertyOperations Object : GetPropertiesForMetadataSyncEx Method

Glossary Item Box

Description

Gets the direct and indirect properties of the specified object version to synchronize the file content with the current metadata.

Syntax

Visual Basic
Public Function GetPropertiesForMetadataSyncEx( _
   ByVal ObjVer As ObjVer _
) As EmbeddedMetadataProperties

Parameters

ObjVer
The object version for which the properties are fetched.

Remarks

Supported in M-Files 20.3.8876.4 and newer.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetPropertiesForMetadataSyncWithMetadataReferenceFilter Method
See Also Send comments
ObjVer
The object version that identifies the object.
pIStringsMetadataRefs
The array of metadata references that appear in the referred document. This filters the metadata reference traversing and optimizes the performance.
VaultObjectPropertyOperations Object : GetPropertiesForMetadataSyncWithMetadataReferenceFilter Method

Glossary Item Box

Description

Gets the direct and indirect properties of the specified object version to synchronize the file content with the current metadata.

Syntax

Visual Basic
Public Function GetPropertiesForMetadataSyncWithMetadataReferenceFilter( _
   ByVal ObjVer As ObjVer, _
   ByVal pIStringsMetadataRefs As Strings _
) As EmbeddedMetadataProperties

Parameters

ObjVer
The object version that identifies the object.
pIStringsMetadataRefs
The array of metadata references that appear in the referred document. This filters the metadata reference traversing and optimizes the performance.

Remarks

Supported in M-Files 22.3.11168.0 and later.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetPropertiesOfMultipleObjects Method
ObjectVersions
The object versions for which to request the properties.
VaultObjectPropertyOperations Object : GetPropertiesOfMultipleObjects Method

Glossary Item Box

Description

Gets the properties of multiple objects.

Syntax

Visual Basic
Public Function GetPropertiesOfMultipleObjects( _
   ByVal ObjectVersions As ObjVers _
) As PropertyValuesOfMultipleObjects

Parameters

ObjectVersions
The object versions for which to request the properties.

Remarks

The returned property values for each distinct object version appear in the PropertyValuesOfMultipleObjects Object array in the order the object versions were given.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetPropertiesOfMultipleObjectsForDisplay Method
ObjectVersions
The object versions for which to request the properties.
VaultObjectPropertyOperations Object : GetPropertiesOfMultipleObjectsForDisplay Method

Glossary Item Box

Description

Gets the properties of the specified object versions for display purposes.

Syntax

Visual Basic
Public Function GetPropertiesOfMultipleObjectsForDisplay( _
   ByVal ObjectVersions As ObjVers _
) As PropertyValuesOfMultipleObjectsForDisplay

Parameters

ObjectVersions
The object versions for which to request the properties.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetPropertiesWithIconClues Method
ObjVer
The object version that identifies the object.
UpdateFromServer
If this is set to True, information is always updated from the server.
VaultObjectPropertyOperations Object : GetPropertiesWithIconClues Method

Glossary Item Box

Description

Gets all the properties of the specified object version with icon clues.

Syntax

Visual Basic
Public Function GetPropertiesWithIconClues( _
   ByVal ObjVer As ObjVer, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As PropertyValuesWithIconClues

Parameters

ObjVer
The object version that identifies the object.
UpdateFromServer
If this is set to True, information is always updated from the server.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetPropertiesWithIconCluesOfMultipleObjects Method
ObjectVersions
The object versions for which to request the properties.
VaultObjectPropertyOperations Object : GetPropertiesWithIconCluesOfMultipleObjects Method

Glossary Item Box

Description

Gets the properties of multiple objects with icon clues.

Syntax

Visual Basic
Public Function GetPropertiesWithIconCluesOfMultipleObjects( _
   ByVal ObjectVersions As ObjVers _
) As PropertyValuesWithIconCluesOfMultipleObjects

Parameters

ObjectVersions
The object versions for which to request the properties.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetProperty Method
ObjVer
The object version that identifies the object.
Property
The property definition ID number.
VaultObjectPropertyOperations Object : GetProperty Method

Glossary Item Box

Description

Gets the specified property value of the specified object version.

Syntax

Visual Basic
Public Function GetProperty( _
   ByVal ObjVer As ObjVer, _
   ByVal Property As Long _
) As PropertyValue

Parameters

ObjVer
The object version that identifies the object.
Property
The property definition ID number.

Remarks

Returns the property value for a property.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetVersionComment Method
ObjVer
The object version that identifies the object.
VaultObjectPropertyOperations Object : GetVersionComment Method

Glossary Item Box

Description

Gets the version comment of the specified object.

Syntax

Visual Basic
Public Function GetVersionComment( _
   ByVal ObjVer As ObjVer _
) As VersionComment

Parameters

ObjVer
The object version that identifies the object.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetVersionCommentHistory Method
ObjVer
The object version that identifies the object.
VaultObjectPropertyOperations Object : GetVersionCommentHistory Method

Glossary Item Box

Description

Gets the version comment history of the specified object.

Syntax

Visual Basic
Public Function GetVersionCommentHistory( _
   ByVal ObjVer As ObjVer _
) As VersionComments

Parameters

ObjVer
The object version that identifies the object.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

GetWorkflowState Method
ObjVer
The object version that identifies the object.
UpdateFromServer
If this is set to True, information is always updated from the server.
VaultObjectPropertyOperations Object : GetWorkflowState Method

Glossary Item Box

Description

Gets the workflow of the specified object.

Syntax

Visual Basic
Public Function GetWorkflowState( _
   ByVal ObjVer As ObjVer, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ObjectVersionWorkflowState

Parameters

ObjVer
The object version that identifies the object.
UpdateFromServer
If this is set to True, information is always updated from the server.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

MarkAssignmentComplete Method
ObjVer
The object version that identifies the object.
VaultObjectPropertyOperations Object : MarkAssignmentComplete Method

Glossary Item Box

Description

Marks the assignment as completed by the logged-in user.

Syntax

Visual Basic
Public Function MarkAssignmentComplete( _
   ByVal ObjVer As ObjVer _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version that identifies the object.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

MarkAssignmentCompleteByUser Method
ObjVer
The object version that identifies the object.
UserID
The ID identifying the user that has completed the assignment.
VaultObjectPropertyOperations Object : MarkAssignmentCompleteByUser Method

Glossary Item Box

Description

Marks the assignment as completed by the specified user.

Syntax

Visual Basic
Public Function MarkAssignmentCompleteByUser( _
   ByVal ObjVer As ObjVer, _
   ByVal UserID As Long _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version that identifies the object.
UserID
The ID identifying the user that has completed the assignment.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

MarkForArchiving Method
ObjID
The object to mark for archiving.
VaultObjectPropertyOperations Object : MarkForArchiving Method

Glossary Item Box

Description

Marks the object for archiving.

Syntax

Visual Basic
Public Function MarkForArchiving( _
   ByVal ObjID As ObjID _
) As ObjectVersionAndProperties

Parameters

ObjID
The object to mark for archiving.

Remarks

Requires M-Files 18.9.6801.16 or later.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

RemoveProperty Method
ObjVer
The object version from which to remove the property.
Property
The property to be removed.
VaultObjectPropertyOperations Object : RemoveProperty Method

Glossary Item Box

Description

Removes the specified property value from the specified object version.

Syntax

Visual Basic
Public Function RemoveProperty( _
   ByVal ObjVer As ObjVer, _
   ByVal Property As Long _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version from which to remove the property.
Property
The property to be removed.

Remarks

The method is intended primarily to remove the Version Comment property and cannot be used to remove any other properties in the client mode (see Getting Started).

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetAllProperties Method
ObjVer
AllowModifyingCheckedInObject
PropertyValues
VaultObjectPropertyOperations Object : SetAllProperties Method

Glossary Item Box

Description

Sets all the properties of the specified object.

Syntax

Visual Basic
Public Function SetAllProperties( _
   ByVal ObjVer As ObjVer, _
   ByVal AllowModifyingCheckedInObject As Boolean, _
   ByVal PropertyValues As PropertyValues _
) As ObjectVersionAndProperties

Parameters

ObjVer
AllowModifyingCheckedInObject
PropertyValues

Remarks

Unlike SetProperty and SetProperties, this method can be used to change the class of an object.

Note

In case this method modifies the permissions of the object through pseudo users or automatic components it might be possible that the object won't be visible to the user after the operation has completed. This can be prevented by not relying on AllowModifyingCheckedInObject but instead checking the object out before calling the method. Users will always have permissions to objects they have checked out.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetAllPropertiesEx Method
ObjVer
The object version that identifies the object.
AllowModifyingCheckedInObject
If this is set to true, the method can change checked-in objects.
AllowMissingRequiredProperties
If this is set to true, the method can set the properties even when this causes the metadata to have empty values for required properties.
PropertyValues
The property values to set.
VaultObjectPropertyOperations Object : SetAllPropertiesEx Method

Glossary Item Box

Description

Sets all the properties of the specified object.

Syntax

Visual Basic
Public Function SetAllPropertiesEx( _
   ByVal ObjVer As ObjVer, _
   ByVal AllowModifyingCheckedInObject As Boolean, _
   ByVal AllowMissingRequiredProperties As Boolean, _
   ByVal PropertyValues As PropertyValues _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version that identifies the object.
AllowModifyingCheckedInObject
If this is set to true, the method can change checked-in objects.
AllowMissingRequiredProperties
If this is set to true, the method can set the properties even when this causes the metadata to have empty values for required properties.
PropertyValues
The property values to set.

Remarks

Supported in M-Files 22.6.11529.0 and later.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetAllPropertiesWithPermissions Method
ObjVer
The object version for which the properties are updated.
AllowModifyingCheckedInObject
True to allow the modification of the checked in objects.
PropertyValues
The new properties for the object version.
ACLEnforcingMode
The ACL enforcing mode.
ACLProvided
ACL provided by the user. Can be NULL if the enforcing mode != eafmProvided.
VaultObjectPropertyOperations Object : SetAllPropertiesWithPermissions Method

Glossary Item Box

Description

Sets all the properties and permissions of the specified object.

Syntax

Visual Basic
Public Function SetAllPropertiesWithPermissions( _
   ByVal ObjVer As ObjVer, _
   ByVal AllowModifyingCheckedInObject As Boolean, _
   ByVal PropertyValues As PropertyValues, _
   Optional ByVal ACLEnforcingMode As MFACLEnforcingMode = MFACLEnforcingModeAutomatic, _
   Optional ByVal ACLProvided As AccessControlList = 0 _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version for which the properties are updated.
AllowModifyingCheckedInObject
True to allow the modification of the checked in objects.
PropertyValues
The new properties for the object version.
ACLEnforcingMode
Value | Description
MFACLEnforcingModeAutomatic | The ACL previously stored for the object is used as the provided ACL.
MFACLEnforcingModeNone | The object ACL remains untouched.
MFACLEnforcingModeProvided | The ACL provided by the caller is used.
MFACLEnforcingModeResetToDefault | The ACL calculated from the properties is used as the provided ACL.
The ACL enforcing mode.
ACLProvided
ACL provided by the user. Can be NULL if the enforcing mode != eafmProvided.

Remarks

M-Files server will still enforce proper automatic permissions from the property values. ACLProvided can mainly be used to set the custom component and to deactivate some of the automatic permissions.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetAllPropertiesWithPermissionsEx Method
ObjVer
The object version for which the properties are updated.
AllowModifyingCheckedInObject
True to allow the modification of the checked in objects.
PropertyValues
The new properties for the object version.
ACLEnforcingMode
The ACL enforcing mode.
ACLProvided
ACL provided by the user. Can be NULL if the enforcing mode != eafmProvided.
ElectronicSignature
The electronic signature that might be required by a workflow state transition.
VaultObjectPropertyOperations Object : SetAllPropertiesWithPermissionsEx Method

Glossary Item Box

Description

Sets all the properties and permissions of the specified object.

Syntax

Visual Basic
Public Function SetAllPropertiesWithPermissionsEx( _
   ByVal ObjVer As ObjVer, _
   ByVal AllowModifyingCheckedInObject As Boolean, _
   ByVal PropertyValues As PropertyValues, _
   Optional ByVal ACLEnforcingMode As MFACLEnforcingMode = MFACLEnforcingModeAutomatic, _
   Optional ByVal ACLProvided As AccessControlList = 0, _
   Optional ByVal ElectronicSignature As Object _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version for which the properties are updated.
AllowModifyingCheckedInObject
True to allow the modification of the checked in objects.
PropertyValues
The new properties for the object version.
ACLEnforcingMode
Value | Description
MFACLEnforcingModeAutomatic | The ACL previously stored for the object is used as the provided ACL.
MFACLEnforcingModeNone | The object ACL remains untouched.
MFACLEnforcingModeProvided | The ACL provided by the caller is used.
MFACLEnforcingModeResetToDefault | The ACL calculated from the properties is used as the provided ACL.
The ACL enforcing mode.
ACLProvided
ACL provided by the user. Can be NULL if the enforcing mode != eafmProvided.
ElectronicSignature
The electronic signature that might be required by a workflow state transition.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetCreationInfoAdmin Method
ObjVer
The object identification of the target object.
UpdateCreatedBy
Whether the CreatedBy property should be set.
CreatedBy
A lookup value describing the user for the value of the CreatedBy property.
UpdateCreated
Whether the Created property should be set.
CreatedUtc
A new timestamp value of the Created property (in UTC).
VaultObjectPropertyOperations Object : SetCreationInfoAdmin Method

Glossary Item Box

Description

Sets the creation info of the specified object. Returns the properties of the specified object after modification.

Syntax

Visual Basic
Public Function SetCreationInfoAdmin( _
   ByVal ObjVer As ObjVer, _
   ByVal UpdateCreatedBy As Boolean, _
   ByVal CreatedBy As TypedValue, _
   ByVal UpdateCreated As Boolean, _
   ByVal CreatedUtc As TypedValue _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object identification of the target object.
UpdateCreatedBy
Whether the CreatedBy property should be set.
CreatedBy
A lookup value describing the user for the value of the CreatedBy property.
UpdateCreated
Whether the Created property should be set.
CreatedUtc
A new timestamp value of the Created property (in UTC).

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetLastModificationInfoAdmin Method
ObjVer
The object identification of the target object.
UpdateLastModifiedBy
Whether the LastModifiedBy property should be set.
LastModifiedBy
A lookup value describing the user for the value of the LastModifiedBy property.
UpdateLastModified
Whether the LastModified property should be set.
LastModifiedUtc
A new timestamp value of the LastModified property (in UTC).
VaultObjectPropertyOperations Object : SetLastModificationInfoAdmin Method

Glossary Item Box

Description

Sets the last modified info of the specified object version. Returns the properties of the specified object after modification.

Syntax

Visual Basic
Public Function SetLastModificationInfoAdmin( _
   ByVal ObjVer As ObjVer, _
   ByVal UpdateLastModifiedBy As Boolean, _
   ByVal LastModifiedBy As TypedValue, _
   ByVal UpdateLastModified As Boolean, _
   ByVal LastModifiedUtc As TypedValue _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object identification of the target object.
UpdateLastModifiedBy
Whether the LastModifiedBy property should be set.
LastModifiedBy
A lookup value describing the user for the value of the LastModifiedBy property.
UpdateLastModified
Whether the LastModified property should be set.
LastModifiedUtc
A new timestamp value of the LastModified property (in UTC).

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetProperties Method
ObjVer
The object version that identifies the object.
PropertyValues
The properties to set.
VaultObjectPropertyOperations Object : SetProperties Method

Glossary Item Box

Description

Sets all the properties of the specified object version.

Syntax

Visual Basic
Public Function SetProperties( _
   ByVal ObjVer As ObjVer, _
   ByVal PropertyValues As PropertyValues _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version that identifies the object.
PropertyValues
The properties to set.

Remarks

This method cannot be used to change the class of an object. Use SetAllProperties instead if this is needed.

Note

In case this method modifies the permissions of the object through pseudo users or automatic components it might be possible that the object won't be visible to the user after the operation has completed.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetPropertiesEx Method
ObjVer
The object version that identifies the object.
PropertyValues
The property values to set.
AllowMissingRequiredProperties
If this is set to true, the method can set the properties even when this causes the metadata to have empty values for required properties.
VaultObjectPropertyOperations Object : SetPropertiesEx Method

Glossary Item Box

Description

Sets the specified properties of the specified object version.

Syntax

Visual Basic
Public Function SetPropertiesEx( _
   ByVal ObjVer As ObjVer, _
   ByVal PropertyValues As PropertyValues, _
   ByVal AllowMissingRequiredProperties As Boolean _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version that identifies the object.
PropertyValues
The property values to set.
AllowMissingRequiredProperties
If this is set to true, the method can set the properties even when this causes the metadata to have empty values for required properties.

Remarks

Supported in M-Files 22.6.11529.0 and later.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetPropertiesOfMultipleObjects Method
See Also Example Send comments
SetPropertiesParamsOfObjects
VaultObjectPropertyOperations Object : SetPropertiesOfMultipleObjects Method

Glossary Item Box

Description

Sets the properties of multiple objects.

Syntax

Visual Basic
Public Function SetPropertiesOfMultipleObjects( _
   ByVal SetPropertiesParamsOfObjects As SetPropertiesParamsOfMultipleObjects _
) As ObjectVersionAndPropertiesOfMultipleObjects

Parameters

SetPropertiesParamsOfObjects

Example

Setting properties of multiple objects (Visual Basic) Copy Code
Sub SetPropertiesOnMultipleObjects( _
        ByVal vault As MFilesAPI.Vault, _
        ByVal objectVersions As MFilesAPI.ObjectVersions, _
        ByVal propertyValues As MFilesAPI.PropertyValues)

    ' Create parameter collection.
    Dim propertiesOfMultipleObjects As New MFilesAPI.SetPropertiesParamsOfMultipleObjects

    ' Set the properties in the param for each object.
    For Each objVer As MFilesAPI.ObjVer In objectVersions.GetAsObjVers()

        ' Create a parameter representing one object version.
        Dim param As New MFilesAPI.SetPropertiesParams
        param.ObjVer = objVer
        param.PropertyValuesToSet = propertyValues

        ' Add the parameter for one object version to the collection
        ' that defines parameters for multiple objects.
        propertiesOfMultipleObjects.Add(-1, param)

    Next

    ' Push the property assignment to M-Files Vault.
    vault.ObjectPropertyOperations.SetPropertiesOfMultipleObjects(propertiesOfMultipleObjects)

End Sub

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetPropertiesWithPermissions Method
ObjVer
The object version for which the properties are updated.
PropertyValues
The new properties for the object version.
ACLEnforcingMode
The ACL enforcing mode.
ACLProvided
ACL provided by the user. Can be NULL if the enforcing mode != eafmProvided.
VaultObjectPropertyOperations Object : SetPropertiesWithPermissions Method

Glossary Item Box

Description

Sets all the properties and permissions of the specified object version.

Syntax

Visual Basic
Public Function SetPropertiesWithPermissions( _
   ByVal ObjVer As ObjVer, _
   ByVal PropertyValues As PropertyValues, _
   Optional ByVal ACLEnforcingMode As MFACLEnforcingMode = MFACLEnforcingModeAutomatic, _
   Optional ByVal ACLProvided As AccessControlList = 0 _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version for which the properties are updated.
PropertyValues
The new properties for the object version.
ACLEnforcingMode
Value | Description
MFACLEnforcingModeAutomatic | The ACL previously stored for the object is used as the provided ACL.
MFACLEnforcingModeNone | The object ACL remains untouched.
MFACLEnforcingModeProvided | The ACL provided by the caller is used.
MFACLEnforcingModeResetToDefault | The ACL calculated from the properties is used as the provided ACL.
The ACL enforcing mode.
ACLProvided
ACL provided by the user. Can be NULL if the enforcing mode != eafmProvided.

Remarks

M-Files server will still enforce proper automatic permissions from the property values. ACLProvided can mainly be used to set the custom component and to deactivate some of the automatic permissions.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetPropertiesWithPermissionsEx Method
ObjVer
The object version for which the properties are updated.
PropertyValues
The new properties for the object version.
ACLEnforcingMode
The ACL enforcing mode.
ACLProvided
ACL provided by the user. Can be NULL if the enforcing mode != eafmProvided.
ElectronicSignature
The electronic signature that might be required by a workflow state transition.
VaultObjectPropertyOperations Object : SetPropertiesWithPermissionsEx Method

Glossary Item Box

Description

Sets all the properties and permissions of the specified object version.

Syntax

Visual Basic
Public Function SetPropertiesWithPermissionsEx( _
   ByVal ObjVer As ObjVer, _
   ByVal PropertyValues As PropertyValues, _
   Optional ByVal ACLEnforcingMode As MFACLEnforcingMode = MFACLEnforcingModeAutomatic, _
   Optional ByVal ACLProvided As AccessControlList = 0, _
   Optional ByVal ElectronicSignature As Object _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version for which the properties are updated.
PropertyValues
The new properties for the object version.
ACLEnforcingMode
Value | Description
MFACLEnforcingModeAutomatic | The ACL previously stored for the object is used as the provided ACL.
MFACLEnforcingModeNone | The object ACL remains untouched.
MFACLEnforcingModeProvided | The ACL provided by the caller is used.
MFACLEnforcingModeResetToDefault | The ACL calculated from the properties is used as the provided ACL.
The ACL enforcing mode.
ACLProvided
ACL provided by the user. Can be NULL if the enforcing mode != eafmProvided.
ElectronicSignature
The electronic signature that might be required by a workflow state transition.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetProperty Method
See Also Example Send comments
ObjVer
The object version that identifies the object.
PropertyValue
The property value to update.
VaultObjectPropertyOperations Object : SetProperty Method

Glossary Item Box

Description

Sets the specified property value of the specified object version.

Syntax

Visual Basic
Public Function SetProperty( _
   ByVal ObjVer As ObjVer, _
   ByVal PropertyValue As PropertyValue _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version that identifies the object.
PropertyValue
The property value to update.

Remarks

This method cannot be used to change the class of an object. Use SetAllProperties instead if this is needed.

Note

In case this method modifies the permissions of the object through pseudo users or automatic components it might be possible that the object won't be visible to the user after the operation has completed.

Example

Add a new property to the object (Visual Basic) Copy Code
' Initialize the API and connect to a vault.
Dim oVault As MFilesAPI.Vault
' ...

' We are searching for the document with ID 123.
Dim iDocumentId As Integer
iDocumentId = 123

' Initialize an ObjID object for the search.
Dim oObjId As New MFilesAPI.ObjID
oObjId.SetIDs(MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument, iDocumentId)

' Get object version properties.
Dim oObjectVersionAndProperties As MFilesAPI.ObjectVersionAndProperties = Nothing
oObjectVersionAndProperties = oVault.ObjectOperations.GetLatestObjectVersionAndProperties(oObjID, True)

' Create new property value.
Dim oPropertyValue As MFilesAPI.PropertyValue = New MFilesAPI.PropertyValue
oPropertyValue.PropertyDef = 1096  ' In this case, represents the "Effective through" property
oPropertyValue.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeDate, DateSerial(2015, 1, 1))

' Modify the object. The object needs to be in checked out state.
oVault.ObjectPropertyOperations.SetProperty(oObjectVersionAndProperties.ObjVer, oPropertyValue)
Setting property to a specific version (Visual Basic) Copy Code
Sub SetRelationshipToSpecificVersion( _
        ByVal vault As MFilesAPI.Vault, _
        ByVal parentObject As MFilesAPI.ObjectVersion, _
        ByVal relatedObject As MFilesAPI.ObjectVersion)

    ' Create lookup to a specific version.
    Dim lookup As New MFilesAPI.Lookup
    lookup.Item = relatedObject.ObjVer.ID
    lookup.Version = relatedObject.ObjVer.Version

    ' Create multi-select lookup structure.
    Dim lookups As New MFilesAPI.Lookups
    lookups.Add(-1, lookup)

    ' Create property value that includes the previously created
    ' lookup and specifies the property definition.
    Dim propertyValue As New MFilesAPI.PropertyValue
    propertyValue.TypedValue.SetValueToMultiSelectLookup(lookups)
    propertyValue.PropertyDef = 1234

    ' Set property for the object.
    vault.ObjectPropertyOperations.SetProperty(parentObject.ObjVer, propertyValue)

End Sub

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetVersionComment Method
ObjVer
VersionComment
VaultObjectPropertyOperations Object : SetVersionComment Method

Glossary Item Box

Description

Sets the version comment for the specified object.

Syntax

Visual Basic
Public Function SetVersionComment( _
   ByVal ObjVer As ObjVer, _
   ByVal VersionComment As PropertyValue _
) As ObjectVersionAndProperties

Parameters

ObjVer
VersionComment

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetWorkflowState Method
ObjVer
WorkflowState
VaultObjectPropertyOperations Object : SetWorkflowState Method

Glossary Item Box

Description

Sets the workflow for the specified object.

Syntax

Visual Basic
Public Function SetWorkflowState( _
   ByVal ObjVer As ObjVer, _
   ByVal WorkflowState As ObjectVersionWorkflowState _
) As ObjectVersionAndProperties

Parameters

ObjVer
WorkflowState

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetWorkflowStateEx Method
ObjVer
The object version for which the properties are updated.
WorkflowState
The new workflow state for the object.
ElectronicSignature
The electronic signature that might be required by a workflow state transition.
VaultObjectPropertyOperations Object : SetWorkflowStateEx Method

Glossary Item Box

Description

Sets the workflow for the specified object.

Syntax

Visual Basic
Public Function SetWorkflowStateEx( _
   ByVal ObjVer As ObjVer, _
   ByVal WorkflowState As ObjectVersionWorkflowState, _
   Optional ByVal ElectronicSignature As Object _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version for which the properties are updated.
WorkflowState
The new workflow state for the object.
ElectronicSignature
The electronic signature that might be required by a workflow state transition.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetWorkflowStateTransition Method
ObjVer
The object version.
Workflow
The workflow to be used. If the workflow is -1 the current workflow is used. If the workflow changes, you need to provide a state transition that leads to 'no state' of the current workflow.
lStateTransition
The state transition to be used.
lVersionComment
The version comment to be set with the state transition. Note that if the object is checked out, the existing version comment will be overwritten. An empty or a NULL value is ignored.
VaultObjectPropertyOperations Object : SetWorkflowStateTransition Method

Glossary Item Box

Description

Sets the workflow state transition for the specified object.

Syntax

Visual Basic
Public Function SetWorkflowStateTransition( _
   ByVal ObjVer As ObjVer, _
   ByVal Workflow As Long, _
   ByVal lStateTransition As Long, _
   ByVal lVersionComment As String _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version.
Workflow
The workflow to be used. If the workflow is -1 the current workflow is used. If the workflow changes, you need to provide a state transition that leads to 'no state' of the current workflow.
lStateTransition
The state transition to be used.
lVersionComment
The version comment to be set with the state transition. Note that if the object is checked out, the existing version comment will be overwritten. An empty or a NULL value is ignored.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

SetWorkflowStateTransitionEx Method
ObjVer
The object version.
Workflow
The workflow to be used. If the workflow is -1 the current workflow is used. If the workflow changes, you need to provide a state transition that leads to 'no state' of the current workflow.
StateTransition
The state transition to be used.
VersionComment
The version comment to be set with the state transition. Note that if the object is checked out, the existing version comment will be overwritten.
ElectronicSignature
The electronic signature that might be required by a workflow state transition. An empty or a null value is ignored.
VaultObjectPropertyOperations Object : SetWorkflowStateTransitionEx Method

Glossary Item Box

Description

Sets the workflow state transition for the specified object with an electronic signature.

Syntax

Visual Basic
Public Function SetWorkflowStateTransitionEx( _
   ByVal ObjVer As ObjVer, _
   ByVal Workflow As Long, _
   ByVal StateTransition As Long, _
   ByVal VersionComment As String, _
   ByVal ElectronicSignature As Object _
) As ObjectVersionAndProperties

Parameters

ObjVer
The object version.
Workflow
The workflow to be used. If the workflow is -1 the current workflow is used. If the workflow changes, you need to provide a state transition that leads to 'no state' of the current workflow.
StateTransition
The state transition to be used.
VersionComment
The version comment to be set with the state transition. Note that if the object is checked out, the existing version comment will be overwritten.
ElectronicSignature
The electronic signature that might be required by a workflow state transition. An empty or a null value is ignored.

See Also

VaultObjectPropertyOperations Object | VaultObjectPropertyOperations Members


%%PageItemTitle%%

VaultObjectSearchOperations Object
Members See Also Example Send comments

Glossary Item Box

Description

The VaultObjectSearchOperations class represents the available object search operations.

Public Methods

Public Method FindFile | Gets a file based on the specified relative path.
Public Method FindObjectVersionAndProperties | Gets an object based on the specified relative path starting from the vault root.
Public Method GetFacetValues | Retrieves the facet values for the objects that satisfy the specified search conditions.
Public Method GetFacetValuesByPath | Retrieves the facet values for the objects that satisfy the search conditions extracted from the temporary search view specified by the path.
Public Method GetObjectCountInSearch | Gets the number of objects found with the specified search.
Public Method GetObjectsInPath | Gets objects by the path specified. This method can be used in offline mode.
Public Method GetSearchHits | Determines the search hits in the given text input.
Public Method IsObjectPathInMFiles | Checks whether the specified relative path refers to an object in M-Files.
Public Method SearchForObjectsByCondition | Searches the vault for objects that match the specified condition. Only the latest versions are searched for.
Public Method SearchForObjectsByConditions | Searches for objects with the specified search conditions.
Public Method SearchForObjectsByConditionsEx | Searches the vault for objects that match the specified conditions.
Public Method SearchForObjectsByConditionsXML | Searches the vault for objects that match the given search conditions. The results are returned in XML form.
Public Method SearchForObjectsByExportedSearchConditions | Searches the vault for objects that match the specified exported search string.
Public Method SearchForObjectsByExportedSearchConditionsXML | Searches the vault for objects that match the specified search string. The results are returned in XML form.
Public Method SearchForObjectsByString | Searches the vault for objects that match the specified string.

Remarks

This method group interface can be accessed via the Vault object.

Example

Searching for objects by ID (Visual Basic) Copy Code
' Initialize the API and connect to a vault.
Dim oVault As MFilesAPI.Vault
' ...

' Ignore errors here.
On Error Resume Next

' We are searching for the document with ID 123.
Dim iDocumentId As Integer
iDocumentId = 123

' Initialize an ObjID object for the search.
Dim oObjId As New MFilesAPI.ObjID
oObjId.SetIDs(MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument, iDocumentId)

' Invoke the search operation.
Dim oResult As MFilesAPI.ObjectVersionAndProperties
oResult = oVault.ObjectOperations.GetLatestObjectVersionAndProperties(oObjId, True)

' Process the search result.
If oResult Is Nothing Then
    Call Console.WriteLine("Not found")
Else
    ' Resolve the value of the "Name or title" property.
    Dim oPropertyValue As MFilesAPI.PropertyValue
    oPropertyValue = oResult.Properties.SearchForProperty( _
        MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefNameOrTitle)

    ' Output the document name.
    Call Console.WriteLine("Title: " + oPropertyValue.TypedValue.DisplayValue)
End If
Search for objects by free text (Visual Basic) Copy Code
' Initialize the API and connect to a vault.
Dim oVault As MFilesAPI.Vault
' ...

' We are searching for objects with "estt" somewhere in the metadata or file content.
Dim szSearchText As String
szSearchText = "estt" ' This is case insensitive.

' Invoke the search operation.
Dim oObjectVersions As MFilesAPI.ObjectSearchResults = oVault.ObjectSearchOperations.SearchForObjectsByString( _
    szSearchText, False, _
    MFilesAPI.MFFullTextSearchFlags.MFFullTextSearchFlagsLookInMetaData Or _
    MFilesAPI.MFFullTextSearchFlags.MFFullTextSearchFlagsLookInFileData)

' Simply process the search results.
For Each oObjectVersion As MFilesAPI.ObjectVersion In oObjectVersions

    ' Resolve the object type.
    Dim oObjType As MFilesAPI.ObjType
    oObjType = oVault.ObjectTypeOperations.GetObjectType(oObjectVersion.ObjVer.Type)

    ' Output the result.
    Call Console.WriteLine("Title of " + oObjType.NameSingular + ": " + oObjectVersion.Title)

Next
Searching for objects by one property value (Visual Basic) Copy Code
' Initialize the API and connect to a vault.
Dim oVault As MFilesAPI.Vault
' ...

' We are searching for objects with "estt" somewhere in the metadata or file content.
Dim szSearchText As String
szSearchText = "estt" ' This is case insensitive.

' Create a search condition for the object name.
Dim oSearchCondition As MFilesAPI.SearchCondition = New MFilesAPI.SearchCondition
oSearchCondition.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeContains
oSearchCondition.Expression.DataPropertyValuePropertyDef = MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefNameOrTitle
oSearchCondition.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeText, szSearchText)

' Invoke the search operation.
Dim oObjectVersions As MFilesAPI.ObjectSearchResults = oVault.ObjectSearchOperations.SearchForObjectsByCondition( _
        oSearchCondition, False)

' Simply process the search results.
For Each oObjectVersion As MFilesAPI.ObjectVersion In oObjectVersions

    ' Resolve the object type.
    Dim oObjType As MFilesAPI.ObjType
    oObjType = oVault.ObjectTypeOperations.GetObjectType(oObjectVersion.ObjVer.Type)

    ' Output the result.
    Call Console.WriteLine("Title of " + oObjType.NameSingular + ": " + oObjectVersion.Title)

Next
Searching for objects by multiple property values (Visual Basic) Copy Code
' Initialize the API and connect to a vault.
Dim oVault As MFilesAPI.Vault
' ...

' We are searching for the document with ID 123.
Dim iDocumentId As Integer
iDocumentId = 123

' Initialize an array of search conditions.
Dim oSearchConditions As MFilesAPI.SearchConditions = New MFilesAPI.SearchConditions

' Create a search condition for the object class (i.e., document in this case).
Dim oSearchCondition1 As MFilesAPI.SearchCondition = New MFilesAPI.SearchCondition
oSearchCondition1.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeEqual
oSearchCondition1.Expression.SetStatusValueExpression( _
        MFilesAPI.MFStatusType.MFStatusTypeObjectTypeID)
oSearchCondition1.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeLookup, _
        MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument)
oSearchConditions.Add(-1, oSearchCondition1)

' Create a search condition for the object ID.
Dim oSearchCondition2 As MFilesAPI.SearchCondition = New MFilesAPI.SearchCondition
oSearchCondition2.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeEqual
oSearchCondition2.Expression.SetStatusValueExpression( _
        MFilesAPI.MFStatusType.MFStatusTypeObjectID)
oSearchCondition2.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeInteger, _
        iDocumentId)
oSearchConditions.Add(-1, oSearchCondition2)

' Invoke the search operation.
Dim oObjectVersions As MFilesAPI.ObjectSearchResults = oVault.ObjectSearchOperations.SearchForObjectsByConditions( _
        oSearchConditions, MFilesAPI.MFSearchFlags.MFSearchFlagNone, False)

' Simply process the search results.
For Each oObjectVersion As MFilesAPI.ObjectVersion In oObjectVersions

    Call Console.WriteLine("Title: " + oObjectVersion.Title)

Next
Searching for deleted objects (Visual Basic) Copy Code
' Initialize the API and connect to a vault.
Dim oVault As MFilesAPI.Vault
' ...

' Create a search condition for deleted objects.
Dim oSearchCondition As MFilesAPI.SearchCondition = New MFilesAPI.SearchCondition

' Initialize an expression for the search condition.
Dim oExpression As New MFilesAPI.Expression
oExpression.DataStatusValueType = MFilesAPI.MFStatusType.MFStatusTypeDeleted
oExpression.DataStatusValueDataFunction = MFilesAPI.MFDataFunction.MFDataFunctionNoOp

' Initialize a boolean value.
Dim oTypedValue As New MFilesAPI.TypedValue
oTypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeBoolean, True)

' Initialize the search condition.
oSearchCondition.Set(oExpression, MFilesAPI.MFConditionType.MFConditionTypeEqual, oTypedValue)

' Invoke the search operation.
Dim oObjectVersions As MFilesAPI.ObjectSearchResults = oVault.ObjectSearchOperations.SearchForObjectsByCondition( _
        oSearchCondition, False)

' Simply process the search results. Note that in order to have any results here, the
' user must have privileges to see the deleted objects within the vault.
For Each oObjectVersion As MFilesAPI.ObjectVersion In oObjectVersions

    ' Resolve the object type.
    Dim oObjType As MFilesAPI.ObjType
    oObjType = oVault.ObjectTypeOperations.GetObjectType(oObjectVersion.ObjVer.Type)

    ' Output the result.
    Call Console.WriteLine("Title of " + oObjType.NameSingular + ": " + oObjectVersion.Title)

Next
Search for objects by class (Visual Basic) Copy Code
Sub SearchForObjectsByClass

    ' Initialize the API and connect to a vault.
    Dim oVault As MFilesAPI.Vault
    ' ...

    ' We are searching for objects from class "Sales Invoice" (ID is 89 in Sample Vault).
    Dim iClass As Integer
    iClass = 89 ' In this case, this identifies the class "Sales Invoice".

    ' You might also want to use the enclosed helper function to resolve the class ID from the class name:
    iClass = MF_FindClassID(oVault, "Sales Invoice")

    ' Create a search condition for the object class.
    Dim oSearchCondition As MFilesAPI.SearchCondition = New MFilesAPI.SearchCondition
    oSearchCondition.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeEqual
    oSearchCondition.Expression.DataPropertyValuePropertyDef = MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefClass
    oSearchCondition.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeLookup, iClass)

    ' Invoke the search operation.
    Dim oObjectVersions As MFilesAPI.ObjectSearchResults = oVault.ObjectSearchOperations.SearchForObjectsByCondition( _
            oSearchCondition, False)

    ' Simply process the search results.
    For Each oObjectVersion As MFilesAPI.ObjectVersion In oObjectVersions

        ' Resolve the object type.
        Dim oObjType As MFilesAPI.ObjType
        oObjType = oVault.ObjectTypeOperations.GetObjectType(oObjectVersion.ObjVer.Type)

        ' Output the result.
        Call Console.WriteLine("Title of " + oObjType.NameSingular + ": " + oObjectVersion.Title)

    Next

End Sub

' Helper function to find the class ID by a class name.
Function MF_FindClassID( _
            ByRef oVault As MFilesAPI.Vault, _
            ByVal szClassName As String) As Integer

    ' Set the search conditions for the value list item.
    Dim oScValueListItem As New MFilesAPI.SearchCondition
    oScValueListItem.Expression.SetValueListItemExpression( _
        MFilesAPI.MFValueListItemPropertyDef.MFValueListItemPropertyDefName, _
        MFilesAPI.MFParentChildBehavior.MFParentChildBehaviorNone)
    oScValueListItem.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeEqual
    oScValueListItem.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeText, szClassName)
    Dim arrSearchConditions As New MFilesAPI.SearchConditions
    arrSearchConditions.Add(-1, oScValueListItem)

    ' Search for the value list item.
    Dim results As MFilesAPI.ValueListItemSearchResults
    results = oVault.ValueListItemOperations.SearchForValueListItemsEx(MFilesAPI.MFBuiltInValueList.MFBuiltInValueListClasses, arrSearchConditions)
    If results.Count > 0 Then
        ' Found.
        MF_FindClassID = results(1).ID
    Else
        ' Not found.
        MF_FindClassID = -1
    End If
End Function

See Also

VaultObjectSearchOperations Members


%%PageItemTitle%%

FindFile Method
RelativePath
The relative path to the object file.
UpdateFromServer
VaultObjectSearchOperations Object : FindFile Method

Glossary Item Box

Description

Gets a file based on the specified relative path.

Syntax

Visual Basic
Public Function FindFile( _
   ByVal RelativePath As String, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ObjectVersionFile

Parameters

RelativePath
The relative path to the object file.
UpdateFromServer

Remarks

The file name must be encoded with the object ID. The object ID is automatically appended to the file name if the object is opened from M-Files. The disk drive letter and the first folder level (the vault name folder) are left out of the path.

For example: Documents\By Class\Application\Document Template for Word (ID 84).doc

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

FindObjectVersionAndProperties Method
RelativePath
The relative path to the object.
UpdateFromServer
VaultObjectSearchOperations Object : FindObjectVersionAndProperties Method

Glossary Item Box

Description

Gets an object based on the specified relative path starting from the vault root.

Syntax

Visual Basic
Public Function FindObjectVersionAndProperties( _
   ByVal RelativePath As String, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ObjectVersionAndProperties

Parameters

RelativePath
The relative path to the object.
UpdateFromServer

Remarks

The file name must be encoded with the object ID. The object ID is automatically appended to the file name if the object is opened from M-Files. The disk drive letter and the first folder level (the vault name folder) are left out of the path.

For example: Documents\By Class\Application\Document Template for Word (ID 84).doc

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

GetFacetValues Method
SearchConditions
Search conditions.
Facets
Facets as expressions.
FacetValuesMaxCount
The maximum number of facet values returned for each facet. Use 0 to retrieve all facet values.
Flags
Bitwise flags controlling the facet search.
VaultObjectSearchOperations Object : GetFacetValues Method

Glossary Item Box

Description

Retrieves the facet values for the objects that satisfy the specified search conditions.

Syntax

Visual Basic
Public Function GetFacetValues( _
   ByVal SearchConditions As SearchConditions, _
   ByVal Facets As Expressions, _
   ByVal FacetValuesMaxCount As Long, _
   ByVal Flags As MFFacetSearchFlags _
) As StringData

Parameters

SearchConditions
Search conditions.
Facets
Facets as expressions.
FacetValuesMaxCount
The maximum number of facet values returned for each facet. Use 0 to retrieve all facet values.
Flags
Value | Description
MFFacetSearchFlagAscendingOrder | Orders to use an ascending sorting order if the facet values are to be sorted.
MFFacetSearchFlagIgnoreFacetGroupPermissions | Orders to perform no ACL check on facet groups.
MFFacetSearchFlagIgnoreFacetValuePermissions | Orders to perform no ACL check on individual facet values.
MFFacetSearchFlagIgnoreSearchPermissions | Orders to perform no ACL check on the underlying search results.
MFFacetSearchFlagNone | No flags.
MFFacetSearchFlagOverrideByConfiguration | Orders to override the facet search parameters by configuration if available.
MFFacetSearchFlagSortFacetValues | Orders to sort facet values in descending occurrence order within each facet group.
Bitwise flags controlling the facet search.

Remarks

The facet values are provided as JSON string data.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

GetFacetValuesByPath Method
RelativePath
The relative path in the vault.
Facets
The facets as expressions.
FacetValuesMaxCount
The maximum number of facet values returned for each facet. Use 0 to retrieve all facet values.
Flags
VaultObjectSearchOperations Object : GetFacetValuesByPath Method

Glossary Item Box

Description

Retrieves the facet values for the objects that satisfy the search conditions extracted from the temporary search view specified by the path.

Syntax

Visual Basic
Public Function GetFacetValuesByPath( _
   ByVal RelativePath As String, _
   ByVal Facets As Expressions, _
   ByVal FacetValuesMaxCount As Long, _
   ByVal Flags As MFFacetSearchFlags _
) As StringData

Parameters

RelativePath
The relative path in the vault.
Facets
The facets as expressions.
FacetValuesMaxCount
The maximum number of facet values returned for each facet. Use 0 to retrieve all facet values.
Flags
Value | Description
MFFacetSearchFlagAscendingOrder | Orders to use an ascending sorting order if the facet values are to be sorted.
MFFacetSearchFlagIgnoreFacetGroupPermissions | Orders to perform no ACL check on facet groups.
MFFacetSearchFlagIgnoreFacetValuePermissions | Orders to perform no ACL check on individual facet values.
MFFacetSearchFlagIgnoreSearchPermissions | Orders to perform no ACL check on the underlying search results.
MFFacetSearchFlagNone | No flags.
MFFacetSearchFlagOverrideByConfiguration | Orders to override the facet search parameters by configuration if available.
MFFacetSearchFlagSortFacetValues | Orders to sort facet values in descending occurrence order within each facet group.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

GetObjectCountInSearch Method
SearchConditions
The conditions to be used in the search.
SearchFlags
VaultObjectSearchOperations Object : GetObjectCountInSearch Method

Glossary Item Box

Description

Gets the number of objects found with the specified search.

Syntax

Visual Basic
Public Function GetObjectCountInSearch( _
   ByVal SearchConditions As SearchConditions, _
   ByVal SearchFlags As MFSearchFlags _
) As Long

Parameters

SearchConditions
The conditions to be used in the search.
SearchFlags
Value | Description
MFSearchFlagDisableRelevancyRanking | Search results are not sorted according to their relevancy.
MFSearchFlagIncludeUnmanagedObjects | Include unmanaged objects in the search results.
MFSearchFlagLookAllObjectTypes | Perform a separate search for each object type and merges the results.
MFSearchFlagLookInAllVersions | Orders to look for matches in all object versions. By default, only the latest object versions are included in the search.
MFSearchFlagNone | No flags.
MFSearchFlagResultsFromEachRepository | Limits the search results per search location instead of limiting the total number of results from all vaults and repositories. This ensures that the search results include items from all search locations with search hits.
MFSearchFlagReturnLatestVisibleVersion | Orders to return the latest version for each object, regardless of whether it is an actual matching version. This flag is effective only if MFSearchFlagLookInAllVersions is on.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

GetObjectsInPath Method
RelativePath
SortResults
UpdateFromServer
VaultObjectSearchOperations Object : GetObjectsInPath Method

Glossary Item Box

Description

Gets objects by the path specified. This method can be used in offline mode.

Syntax

Visual Basic
Public Function GetObjectsInPath( _
   ByVal RelativePath As String, _
   ByVal SortResults As Boolean, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ObjectSearchResults

Parameters

RelativePath
SortResults
UpdateFromServer

Remarks

If a file name is used in a path, it must be encoded with the object ID. The object ID is automatically appended to the file name if the object is opened from M-Files. The disk drive letter and the first folder level (the vault name folder) are left out of the path.

For example: Documents\By Class\Application\Document Template for Word (ID 84).doc

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

GetSearchHits Method
Input
The source text to search from.
SearchCondition
The search condition to be used for filtering the search.
VaultObjectSearchOperations Object : GetSearchHits Method

Glossary Item Box

Description

Determines the search hits in the given text input.

Syntax

Visual Basic
Public Function GetSearchHits( _
   ByVal Input As String, _
   ByVal SearchCondition As SearchCondition _
) As Strings

Parameters

Input
The source text to search from.
SearchCondition
The search condition to be used for filtering the search.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

IsObjectPathInMFiles Method
RelativePath
VaultObjectSearchOperations Object : IsObjectPathInMFiles Method

Glossary Item Box

Description

Checks whether the specified relative path refers to an object in M-Files.

Syntax

Visual Basic
Public Function IsObjectPathInMFiles( _
   ByVal RelativePath As String _
) As Boolean

Parameters

RelativePath

Remarks

The file name must be encoded with the object ID. The object ID is automatically appended to the file name if the object is opened from M-Files. The disk drive letter and the first folder level (the vault name folder) are left out of the path.

For example: Documents\By Class\Application\Document Template for Word (ID 84).doc

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

SearchForObjectsByCondition Method
See Also Example Send comments
SearchCondition
The search condition to use in the operation.
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.
VaultObjectSearchOperations Object : SearchForObjectsByCondition Method

Glossary Item Box

Description

Searches the vault for objects that match the specified condition. Only the latest versions are searched for.

Syntax

Visual Basic
Public Function SearchForObjectsByCondition( _
   ByVal SearchCondition As SearchCondition, _
   ByVal SortResults As Boolean _
) As ObjectSearchResults

Parameters

SearchCondition
The search condition to use in the operation.
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.

Example

Search for objects by class (Visual Basic) Copy Code
Sub SearchForObjectsByClass

    ' Initialize the API and connect to a vault.
    Dim oVault As MFilesAPI.Vault
    ' ...

    ' We are searching for objects from class "Sales Invoice" (ID is 89 in Sample Vault).
    Dim iClass As Integer
    iClass = 89 ' In this case, this identifies the class "Sales Invoice".

    ' You might also want to use the enclosed helper function to resolve the class ID from the class name:
    iClass = MF_FindClassID(oVault, "Sales Invoice")

    ' Create a search condition for the object class.
    Dim oSearchCondition As MFilesAPI.SearchCondition = New MFilesAPI.SearchCondition
    oSearchCondition.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeEqual
    oSearchCondition.Expression.DataPropertyValuePropertyDef = MFilesAPI.MFBuiltInPropertyDef.MFBuiltInPropertyDefClass
    oSearchCondition.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeLookup, iClass)

    ' Invoke the search operation.
    Dim oObjectVersions As MFilesAPI.ObjectSearchResults = oVault.ObjectSearchOperations.SearchForObjectsByCondition( _
            oSearchCondition, False)

    ' Simply process the search results.
    For Each oObjectVersion As MFilesAPI.ObjectVersion In oObjectVersions

        ' Resolve the object type.
        Dim oObjType As MFilesAPI.ObjType
        oObjType = oVault.ObjectTypeOperations.GetObjectType(oObjectVersion.ObjVer.Type)

        ' Output the result.
        Call Console.WriteLine("Title of " + oObjType.NameSingular + ": " + oObjectVersion.Title)

    Next

End Sub

' Helper function to find the class ID by a class name.
Function MF_FindClassID( _
            ByRef oVault As MFilesAPI.Vault, _
            ByVal szClassName As String) As Integer

    ' Set the search conditions for the value list item.
    Dim oScValueListItem As New MFilesAPI.SearchCondition
    oScValueListItem.Expression.SetValueListItemExpression( _
        MFilesAPI.MFValueListItemPropertyDef.MFValueListItemPropertyDefName, _
        MFilesAPI.MFParentChildBehavior.MFParentChildBehaviorNone)
    oScValueListItem.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeEqual
    oScValueListItem.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeText, szClassName)
    Dim arrSearchConditions As New MFilesAPI.SearchConditions
    arrSearchConditions.Add(-1, oScValueListItem)

    ' Search for the value list item.
    Dim results As MFilesAPI.ValueListItemSearchResults
    results = oVault.ValueListItemOperations.SearchForValueListItemsEx(MFilesAPI.MFBuiltInValueList.MFBuiltInValueListClasses, arrSearchConditions)
    If results.Count > 0 Then
        ' Found.
        MF_FindClassID = results(1).ID
    Else
        ' Not found.
        MF_FindClassID = -1
    End If
End Function

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

SearchForObjectsByConditions Method
SearchConditions
The search conditions to use in the operation.
SearchFlags
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.
VaultObjectSearchOperations Object : SearchForObjectsByConditions Method

Glossary Item Box

Description

Searches for objects with the specified search conditions.

Syntax

Visual Basic
Public Function SearchForObjectsByConditions( _
   ByVal SearchConditions As SearchConditions, _
   ByVal SearchFlags As MFSearchFlags, _
   ByVal SortResults As Boolean _
) As ObjectSearchResults

Parameters

SearchConditions
The search conditions to use in the operation.
SearchFlags
Value | Description
MFSearchFlagDisableRelevancyRanking | Search results are not sorted according to their relevancy.
MFSearchFlagIncludeUnmanagedObjects | Include unmanaged objects in the search results.
MFSearchFlagLookAllObjectTypes | Perform a separate search for each object type and merges the results.
MFSearchFlagLookInAllVersions | Orders to look for matches in all object versions. By default, only the latest object versions are included in the search.
MFSearchFlagNone | No flags.
MFSearchFlagResultsFromEachRepository | Limits the search results per search location instead of limiting the total number of results from all vaults and repositories. This ensures that the search results include items from all search locations with search hits.
MFSearchFlagReturnLatestVisibleVersion | Orders to return the latest version for each object, regardless of whether it is an actual matching version. This flag is effective only if MFSearchFlagLookInAllVersions is on.
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

SearchForObjectsByConditionsEx Method
SearchConditions
The search conditions to use in the operation.
SearchFlags
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.
MaxResultCount

The maximum number of results to return. Use the value "0" to return an unlimited number of results.

SearchTimeoutInSeconds
The timeout in seconds after which the search is canceled if it has not completed. Use the value "0" to wait indefinitely for the search results to be returned.
VaultObjectSearchOperations Object : SearchForObjectsByConditionsEx Method

Glossary Item Box

Description

Searches the vault for objects that match the specified conditions.

Syntax

Visual Basic
Public Function SearchForObjectsByConditionsEx( _
   ByVal SearchConditions As SearchConditions, _
   ByVal SearchFlags As MFSearchFlags, _
   ByVal SortResults As Boolean, _
   Optional ByVal MaxResultCount As Long = 500, _
   Optional ByVal SearchTimeoutInSeconds As Long = 60 _
) As ObjectSearchResults

Parameters

SearchConditions
The search conditions to use in the operation.
SearchFlags
Value | Description
MFSearchFlagDisableRelevancyRanking | Search results are not sorted according to their relevancy.
MFSearchFlagIncludeUnmanagedObjects | Include unmanaged objects in the search results.
MFSearchFlagLookAllObjectTypes | Perform a separate search for each object type and merges the results.
MFSearchFlagLookInAllVersions | Orders to look for matches in all object versions. By default, only the latest object versions are included in the search.
MFSearchFlagNone | No flags.
MFSearchFlagResultsFromEachRepository | Limits the search results per search location instead of limiting the total number of results from all vaults and repositories. This ensures that the search results include items from all search locations with search hits.
MFSearchFlagReturnLatestVisibleVersion | Orders to return the latest version for each object, regardless of whether it is an actual matching version. This flag is effective only if MFSearchFlagLookInAllVersions is on.
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.
MaxResultCount

The maximum number of results to return. Use the value "0" to return an unlimited number of results.

SearchTimeoutInSeconds
The timeout in seconds after which the search is canceled if it has not completed. Use the value "0" to wait indefinitely for the search results to be returned.

Remarks

The memory available in the system limits the maximum number of results even when the value "0" is specified for "MaxResultCount".

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

SearchForObjectsByConditionsXML Method
SearchConditions
The search conditions to use in the operation.
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.
VaultObjectSearchOperations Object : SearchForObjectsByConditionsXML Method

Glossary Item Box

Description

Searches the vault for objects that match the given search conditions. The results are returned in XML form.

Syntax

Visual Basic
Public Function SearchForObjectsByConditionsXML( _
   ByVal SearchConditions As SearchConditions, _
   ByVal SortResults As Boolean _
) As XMLSearchResult

Parameters

SearchConditions
The search conditions to use in the operation.
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

SearchForObjectsByExportedSearchConditions Method
ExportedSearchString
The search string defining the search conditions.
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.
VaultObjectSearchOperations Object : SearchForObjectsByExportedSearchConditions Method

Glossary Item Box

Description

Searches the vault for objects that match the specified exported search string.

Syntax

Visual Basic
Public Function SearchForObjectsByExportedSearchConditions( _
   ByVal ExportedSearchString As String, _
   ByVal SortResults As Boolean _
) As ObjectSearchResults

Parameters

ExportedSearchString
The search string defining the search conditions.
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

SearchForObjectsByExportedSearchConditionsXML Method
SearchString
The search string defining the search conditions.
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.
VaultObjectSearchOperations Object : SearchForObjectsByExportedSearchConditionsXML Method

Glossary Item Box

Description

Searches the vault for objects that match the specified search string. The results are returned in XML form.

Syntax

Visual Basic
Public Function SearchForObjectsByExportedSearchConditionsXML( _
   ByVal SearchString As String, _
   ByVal SortResults As Boolean _
) As XMLSearchResult

Parameters

SearchString
The search string defining the search conditions.
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

SearchForObjectsByString Method
SearchString
The search string defining the search conditions.
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.
FullTextSearchFlags
VaultObjectSearchOperations Object : SearchForObjectsByString Method

Glossary Item Box

Description

Searches the vault for objects that match the specified string.

Syntax

Visual Basic
Public Function SearchForObjectsByString( _
   ByVal SearchString As String, _
   ByVal SortResults As Boolean, _
   ByVal FullTextSearchFlags As MFFullTextSearchFlags _
) As ObjectSearchResults

Parameters

SearchString
The search string defining the search conditions.
SortResults
If this is set to "true", the results are sorted from A to Z based on their display name.
FullTextSearchFlags
Value | Description
MFFullTextSearchFlagsLookInFileData | Looks for matches in the file data of objects.
MFFullTextSearchFlagsLookInMetaData | Looks for matches in the metadata (properties) of objects.
MFFullTextSearchFlagsNone | None (indicates a basic Boolean search).
MFFullTextSearchFlagsStemming | Enables stemming for all words in the search request. This includes inflected forms of the searched word.
MFFullTextSearchFlagsTypeAllWords | Finds all of the words in the search request.
MFFullTextSearchFlagsTypeAnyWords | Finds any of the words in the search request.

See Also

VaultObjectSearchOperations Object | VaultObjectSearchOperations Members


%%PageItemTitle%%

VaultObjectTypeOperations Object
Members See Also Send comments

Glossary Item Box

Description

A group of methods for creating and modifying object types.

Public Methods

Public Method AddObjectTypeAdmin | Adds a new object type or value list. Returns the created object type, with the ID property set to the real ID value.
Public Method GetBuiltInObjectType | Gets an object type representing a built-in real object type.
Public Method GetExternalObjectTypePluginConfigurationDomainIdAdmin | Gets the configuration domain ID of the specified external object type plugin (for administrative operations).
Public Method GetExternalObjectTypePluginConfigurationInfoAdmin | Gets information on the configuration of the specified external object type plugin (for administrative operations).
Public Method GetExternalObjectTypePluginInfosAdmin | Gets all external object type plugins (for administrative operations).
Public Method GetObjectType | Gets information on the specified object type or value list. In the client interface mode, this method supports getting a real object type only. Use the GetValueList method for retrieving a value list.
Public Method GetObjectTypeAdmin | Gets information on the specified object type or value list (for administrative operations).
Public Method GetObjectTypeIDByAlias | Gets the ID of the object type or value list with the specified alias. Returns -1 if a match is not found or if more than one object type or value list uses the specified alias.
Public Method GetObjectTypeIDByGUID | Gets the ID of the object type or value list with the specified GUID. Returns -1 if a match is not found.
Public Method GetObjectTypes | Gets all real object types.
Public Method GetObjectTypesAdmin | Gets all real object types (for administrative operations).
Public Method RefreshExternalObjectType | Refreshes an external object type or value list.
Public Method RefreshExternalObjectTypeColumnMappingsAdmin | Refreshes the column mappings of an external object type. Returns the object type with refreshed column mappings.
Public Method RemoveObjectTypeAdmin | Deletes the specified object type or value list.
Public Method UpdateObjectTypeAdmin | Updates the object type or value list. The ID property identifies the object type to modify. Returns the updated object type.
Public Method UpdateObjectTypeWithAutomaticPermissionsAdmin | Updates the object type or value list. The ID property identifies the object type to modify. Returns the updated object type.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultObjectTypeOperations Members


%%PageItemTitle%%

AddObjectTypeAdmin Method
ObjectType
The object type to be added.
VaultObjectTypeOperations Object : AddObjectTypeAdmin Method

Glossary Item Box

Description

Adds a new object type or value list. Returns the created object type, with the ID property set to the real ID value.

Syntax

Visual Basic
Public Function AddObjectTypeAdmin( _
   ByVal ObjectType As ObjTypeAdmin _
) As ObjTypeAdmin

Parameters

ObjectType
The object type to be added.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

GetBuiltInObjectType Method
ObjectType
Specifies the built-in object type.
VaultObjectTypeOperations Object : GetBuiltInObjectType Method

Glossary Item Box

Description

Gets an object type representing a built-in real object type.

Syntax

Visual Basic
Public Function GetBuiltInObjectType( _
   ByVal ObjectType As MFBuiltInObjectType _
) As ObjType

Parameters

ObjectType
Value | Description
MFBuiltInObjectTypeAssignment | The assignment object type.
MFBuiltInObjectTypeDocument | The document object type.
MFBuiltInObjectTypeDocumentCollection | The document collection type.
MFBuiltInObjectTypeDocumentOrDocumentCollection | A special value that refers to both the document and the document collection types. Can be used in e.g. search conditions.
MFBuiltInObjectTypeEmail | The Email object type.
MFBuiltInObjectTypeEmailConversation | The Email Conversation object type.
Specifies the built-in object type.

Return Type

The ObjType object that contains information on the object type.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

GetExternalObjectTypePluginConfigurationDomainIdAdmin Method
PluginGUID
The GUID of the external object type plugin.
ObjectTypeID
The ID of the object type.
VaultObjectTypeOperations Object : GetExternalObjectTypePluginConfigurationDomainIdAdmin Method

Glossary Item Box

Description

Gets the configuration domain ID of the specified external object type plugin (for administrative operations).

Syntax

Visual Basic
Public Function GetExternalObjectTypePluginConfigurationDomainIdAdmin( _
   ByVal PluginGUID As String, _
   ByVal ObjectTypeID As Long _
) As String

Parameters

PluginGUID
The GUID of the external object type plugin.
ObjectTypeID
The ID of the object type.

Remarks

Supported in M-Files 20.11.9630.6 and later.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

GetExternalObjectTypePluginConfigurationInfoAdmin Method
PluginGUID
The GUID of the external object type plugin.
ObjectTypeID
The ID of the object type.
VaultObjectTypeOperations Object : GetExternalObjectTypePluginConfigurationInfoAdmin Method

Glossary Item Box

Description

Gets information on the configuration of the specified external object type plugin (for administrative operations).

Syntax

Visual Basic
Public Function GetExternalObjectTypePluginConfigurationInfoAdmin( _
   ByVal PluginGUID As String, _
   ByVal ObjectTypeID As Long _
) As String

Parameters

PluginGUID
The GUID of the external object type plugin.
ObjectTypeID
The ID of the object type.

Remarks

Supported in M-Files 20.11.9630.6 and later.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

GetExternalObjectTypePluginInfosAdmin Method
VaultObjectTypeOperations Object : GetExternalObjectTypePluginInfosAdmin Method

Glossary Item Box

Description

Gets all external object type plugins (for administrative operations).

Syntax

Visual Basic
Public Function GetExternalObjectTypePluginInfosAdmin() As ExternalObjectTypePluginInfos

Remarks

Supported in M-Files 20.11.9630.6 and later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

GetObjectType Method
ObjectType
VaultObjectTypeOperations Object : GetObjectType Method

Glossary Item Box

Description

Gets information on the specified object type or value list. In the client interface mode, this method supports getting a real object type only. Use the GetValueList method for retrieving a value list.

Syntax

Visual Basic
Public Function GetObjectType( _
   ByVal ObjectType As Long _
) As ObjType

Parameters

ObjectType

Return Type

The object type ID.

Remarks

This method fails if the object type is a value list. If you don't know whether the object type is a real object type or a value list, use the GetValueList method in the VaultValueListOperation interface instead.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

GetObjectTypeAdmin Method
ObjectType
VaultObjectTypeOperations Object : GetObjectTypeAdmin Method

Glossary Item Box

Description

Gets information on the specified object type or value list (for administrative operations).

Syntax

Visual Basic
Public Function GetObjectTypeAdmin( _
   ByVal ObjectType As Long _
) As ObjTypeAdmin

Parameters

ObjectType

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

GetObjectTypeIDByAlias Method
Alias
VaultObjectTypeOperations Object : GetObjectTypeIDByAlias Method

Glossary Item Box

Description

Gets the ID of the object type or value list with the specified alias. Returns -1 if a match is not found or if more than one object type or value list uses the specified alias.

Syntax

Visual Basic
Public Function GetObjectTypeIDByAlias( _
   ByVal Alias As String _
) As Long

Parameters

Alias

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

GetObjectTypeIDByGUID Method
ObjectTypeGUID
The GUID of the object type.
VaultObjectTypeOperations Object : GetObjectTypeIDByGUID Method

Glossary Item Box

Description

Gets the ID of the object type or value list with the specified GUID. Returns -1 if a match is not found.

Syntax

Visual Basic
Public Function GetObjectTypeIDByGUID( _
   ByVal ObjectTypeGUID As String _
) As Long

Parameters

ObjectTypeGUID
The GUID of the object type.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

GetObjectTypes Method
VaultObjectTypeOperations Object : GetObjectTypes Method

Glossary Item Box

Description

Gets all real object types.

Syntax

Visual Basic
Public Function GetObjectTypes() As ObjTypes

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

GetObjectTypesAdmin Method
VaultObjectTypeOperations Object : GetObjectTypesAdmin Method

Glossary Item Box

Description

Gets all real object types (for administrative operations).

Syntax

Visual Basic
Public Function GetObjectTypesAdmin() As ObjTypesAdmin

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

RefreshExternalObjectType Method
ObjectType
The object type ID of the object type to be refreshed.
RefreshType
VaultObjectTypeOperations Object : RefreshExternalObjectType Method

Glossary Item Box

Description

Refreshes an external object type or value list.

Syntax

Visual Basic
Public Sub RefreshExternalObjectType( _
   ByVal ObjectType As Long, _
   ByVal RefreshType As MFExternalDBRefreshType _
)

Parameters

ObjectType
The object type ID of the object type to be refreshed.
RefreshType
Value | Description
MFExternalDBRefreshTypeFull | The full refresh updates all the changes. This operation can take several minutes.
MFExternalDBRefreshTypeNone | No refresh is performed.
MFExternalDBRefreshTypeQuick | The quick refresh searches for new items and imports them to M-Files.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

RefreshExternalObjectTypeColumnMappingsAdmin Method
ObjectType
The object type the column mappings of which to refresh.
VaultObjectTypeOperations Object : RefreshExternalObjectTypeColumnMappingsAdmin Method

Glossary Item Box

Description

Refreshes the column mappings of an external object type. Returns the object type with refreshed column mappings.

Syntax

Visual Basic
Public Function RefreshExternalObjectTypeColumnMappingsAdmin( _
   ByVal ObjectType As ObjTypeAdmin _
) As ObjTypeAdmin

Parameters

ObjectType
The object type the column mappings of which to refresh.

Remarks

Requires M-Files 18.11.7072.5 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

RemoveObjectTypeAdmin Method
ObjectTypeID
The ID of the object type to remove.
VaultObjectTypeOperations Object : RemoveObjectTypeAdmin Method

Glossary Item Box

Description

Deletes the specified object type or value list.

Syntax

Visual Basic
Public Sub RemoveObjectTypeAdmin( _
   ByVal ObjectTypeID As Long _
)

Parameters

ObjectTypeID
The ID of the object type to remove.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

UpdateObjectTypeAdmin Method
ObjectType
The object type to update.
VaultObjectTypeOperations Object : UpdateObjectTypeAdmin Method

Glossary Item Box

Description

Updates the object type or value list. The ID property identifies the object type to modify. Returns the updated object type.

Syntax

Visual Basic
Public Function UpdateObjectTypeAdmin( _
   ByVal ObjectType As ObjTypeAdmin _
) As ObjTypeAdmin

Parameters

ObjectType
The object type to update.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

UpdateObjectTypeWithAutomaticPermissionsAdmin Method
ObjectType
AutomaticPermissionsForcedActive
VaultObjectTypeOperations Object : UpdateObjectTypeWithAutomaticPermissionsAdmin Method

Glossary Item Box

Description

Updates the object type or value list. The ID property identifies the object type to modify. Returns the updated object type.

Syntax

Visual Basic
Public Function UpdateObjectTypeWithAutomaticPermissionsAdmin( _
   ByVal ObjectType As ObjTypeAdmin, _
   Optional ByVal AutomaticPermissionsForcedActive As Boolean = False _
) As ObjTypeAdmin

Parameters

ObjectType
AutomaticPermissionsForcedActive

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultObjectTypeOperations Object | VaultObjectTypeOperations Members


%%PageItemTitle%%

VaultOnServer Object
Members See Also Send comments

Glossary Item Box

Description

The VaultOnServer class represents a vault in the server.

Public Methods

Public Method LogIn | Logs in to the vault with the same credentials that were used to log in to the server. Use the LogInEx method for additional options.
Public Method LogInAsUser | Logs in to the vault.
Public Method LogInAsUserEx | Logs in to the vault.
Public Method LogInAsUserWithAuthenticationData | Logs in to the vault with the specified authentication data.
Public Method LogInAsUserWithSPN | Logs in to the vault with specified credentials and SPN.
Public Method LogInEx | Logs in to the vault with the same credentials that were used to log in to the server.

Public Properties

Public Property GUID | Gets the GUID of the vault on the server.
Public Property Name | Gets the name of the vault on the server.

Remarks

A server vault as seen in M-Files Admin.

See Also

VaultOnServer Members


%%PageItemTitle%%

LogIn Method
VaultOnServer Object : LogIn Method

Glossary Item Box

Description

Logs in to the vault with the same credentials that were used to log in to the server. Use the LogInEx method for additional options.

Syntax

Visual Basic
Public Function LogIn() As Vault

See Also

VaultOnServer Object | VaultOnServer Members


%%PageItemTitle%%

LogInAsUser Method
AuthType
The authentication type.
UserName
The username as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
The password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
The domain for the user as a string. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
TimeZone

The time zone. In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultOnServer Object : LogInAsUser Method

Glossary Item Box

Description

Logs in to the vault.

Syntax

Visual Basic
Public Function LogInAsUser( _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal TimeZone As TimeZoneInformation = 0 _
) As Vault

Parameters

AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
The authentication type.
UserName
The username as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
The password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
The domain for the user as a string. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
TimeZone

The time zone. In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

See Also

VaultOnServer Object | VaultOnServer Members


%%PageItemTitle%%

LogInAsUserEx Method
AuthType
The authentication type.
UserName
The username as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
The password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
The domain for the user as a string. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
TimeZone

The time zone. In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.
VaultOnServer Object : LogInAsUserEx Method

Glossary Item Box

Description

Logs in to the vault.

Syntax

Visual Basic
Public Function LogInAsUserEx( _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal TimeZone As TimeZoneInformation = 0, _
   Optional ByVal AdditionalInfoAsJSON As String = "" _
) As Vault

Parameters

AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
The authentication type.
UserName
The username as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
The password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
The domain for the user as a string. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
TimeZone

The time zone. In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AdditionalInfoAsJSON
Additional information (such as a client certificate) as JSON.

See Also

VaultOnServer Object | VaultOnServer Members


%%PageItemTitle%%

LogInAsUserWithAuthenticationData Method
PluginInfo
Information about the plugin that produced the authentication data.
AuthenticationData
The specified authentication data.
AttemptIdentifier
Authentication attempt identifier used with multileg authentication protocols.
TimeZone
Optional. The time zone information.
VaultOnServer Object : LogInAsUserWithAuthenticationData Method

Glossary Item Box

Description

Logs in to the vault with the specified authentication data.

Syntax

Visual Basic
Public Function LogInAsUserWithAuthenticationData( _
   ByVal PluginInfo As PluginInfo, _
   ByVal AuthenticationData As NamedValues, _
   Optional ByVal AttemptIdentifier As String = "", _
   Optional ByVal TimeZone As TimeZoneInformation = 0 _
) As AuthenticationResult

Parameters

PluginInfo
Information about the plugin that produced the authentication data.
AuthenticationData
The specified authentication data.
AttemptIdentifier
Authentication attempt identifier used with multileg authentication protocols.
TimeZone
Optional. The time zone information.

See Also

VaultOnServer Object | VaultOnServer Members


%%PageItemTitle%%

LogInAsUserWithSPN Method
AuthType
The authentication type.
UserName
The user name as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
The password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
The domain for the user as a string. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
SPN
The Service Principal Name as a string.
TimeZone

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultOnServer Object : LogInAsUserWithSPN Method

Glossary Item Box

Description

Logs in to the vault with specified credentials and SPN.

Syntax

Visual Basic
Public Function LogInAsUserWithSPN( _
   Optional ByVal AuthType As MFAuthType = MFAuthTypeLoggedOnWindowsUser, _
   Optional ByVal UserName As Variant, _
   Optional ByVal Password As Variant, _
   Optional ByVal Domain As Variant, _
   Optional ByVal SPN As Variant, _
   Optional ByVal TimeZone As TimeZoneInformation = 0 _
) As Vault

Parameters

AuthType
Value | Description
MFAuthTypeLoggedOnWindowsUser | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | Unspecified authentication method.
The authentication type.
UserName
The user name as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Password
The password as a string. Not used with the MFAuthTypeLoggedOnWindowsUser authentication mode.
Domain
The domain for the user as a string. Used only with the MFAuthTypeSpecificWindowsUser authentication mode.
SPN
The Service Principal Name as a string.
TimeZone

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

See Also

VaultOnServer Object | VaultOnServer Members


%%PageItemTitle%%

LogInEx Method
AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.
VaultOnServer Object : LogInEx Method

Glossary Item Box

Description

Logs in to the vault with the same credentials that were used to log in to the server.

Syntax

Visual Basic
Public Function LogInEx( _
   Optional ByVal AllowUsingAuthenticationPlugins As Boolean = True _
) As Vault

Parameters

AllowUsingAuthenticationPlugins
True if authentication plugin configurations are used for authentication.

See Also

VaultOnServer Object | VaultOnServer Members


%%PageItemTitle%%

GUID Property
VaultOnServer Object : GUID Property

Glossary Item Box

Description

Gets the GUID of the vault on the server.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID As String

See Also

VaultOnServer Object | VaultOnServer Members


%%PageItemTitle%%

Name Property
VaultOnServer Object : Name Property

Glossary Item Box

Description

Gets the name of the vault on the server.

Property type

Read-only property

Syntax

Visual Basic
Public Property Name As String

See Also

VaultOnServer Object | VaultOnServer Members


%%PageItemTitle%%

VaultProperties Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents a vault on server.

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property AdvancedEventLog | Specifies whether Advanced Event Log features are enabled in this vault.
Public Property DisplayName | The display name of the vault.
Public Property EncryptionOfFileDataAtRest | Specifies whether encryption of file data at rest is enabled in this vault.
Public Property ExtendedMetadataDrivenPermissions | Specifies whether the extended metadata-driven permissions are used in this vault.
Public Property FileDataConnectionString | The connection string that identifies the location, protocol, and credentials for the file data storage of this vault. For example, this might specify a storage account, a protocol, and a container name for Azure's BLOB Services. Can be NULL or empty.
Public Property FileDataStorageType | File data storage type.
Public Property FullTextSearchLanguage | Specifies the language used in full-text search.
Public Property Icon | If not NULL, contains the icon of this item in .ICO format.
Public Property MainDataFolder | The main physical folder of this vault on the server (e.g. C:\Program Files\M-Files\Server Vaults\MyVault).
Public Property SeparateLocationForFileData | If not empty, specifies a separate location for file data. Currently up to one separate location is supported.
Public Property SQLDatabase | The vault's SQL database.
Public Property VaultGUID | The unique identifier of the vault.

Remarks

Vault properties in M-Files Admin.

See Also

VaultProperties Members


%%PageItemTitle%%

Clone Method
VaultProperties Object : Clone Method

Glossary Item Box

Description

Creates a clone of this object.

Syntax

Visual Basic
Public Function Clone() As VaultProperties

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

AdvancedEventLog Property
VaultProperties Object : AdvancedEventLog Property

Glossary Item Box

Description

Specifies whether Advanced Event Log features are enabled in this vault.

Property type

Read-write property

Syntax

Visual Basic
Public Property AdvancedEventLog As Boolean

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

DisplayName Property
VaultProperties Object : DisplayName Property

Glossary Item Box

Description

The display name of the vault.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayName As String

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

EncryptionOfFileDataAtRest Property
VaultProperties Object : EncryptionOfFileDataAtRest Property

Glossary Item Box

Description

Specifies whether encryption of file data at rest is enabled in this vault.

Property type

Read-write property

Syntax

Visual Basic
Public Property EncryptionOfFileDataAtRest As Boolean

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

ExtendedMetadataDrivenPermissions Property
VaultProperties Object : ExtendedMetadataDrivenPermissions Property

Glossary Item Box

Description

Specifies whether the extended metadata-driven permissions are used in this vault.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExtendedMetadataDrivenPermissions As Boolean

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

FileDataConnectionString Property
VaultProperties Object : FileDataConnectionString Property

Glossary Item Box

Description

The connection string that identifies the location, protocol, and credentials for the file data storage of this vault. For example, this might specify a storage account, a protocol, and a container name for Azure's BLOB Services. Can be NULL or empty.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileDataConnectionString As String

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

FileDataStorageType Property
VaultProperties Object : FileDataStorageType Property

Glossary Item Box

Description

File data storage type.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileDataStorageType As MFFileDataStorage

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

FullTextSearchLanguage Property
VaultProperties Object : FullTextSearchLanguage Property

Glossary Item Box

Description

Specifies the language used in full-text search.

Property type

Read-write property

Syntax

Visual Basic
Public Property FullTextSearchLanguage As String

Remarks

The available values for the property are listed below. The languages marked with an asterisk (*), however, are not fully supported by dtSearch.

Albanian * | sqi
Chinese (Simplified) * | chs
Chinese (Traditional) * | cht
Danish | den
Dutch | ned
English | eng
Finnish | fin
French and English | fra-eng
German | ger
German and English | ger-eng
Italian | ita
Japanese * | jpn
Korean * | kor
Norwegian (Bokmål) | nor
Portuguese | por
Serbian * | srm
Spanish | esp
Swedish | swe
Other languages | other

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

Icon Property
VaultProperties Object : Icon Property

Glossary Item Box

Description

If not NULL, contains the icon of this item in .ICO format.

Property type

Read-write property

Syntax

Visual Basic
Public Property Icon As Byte()

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

MainDataFolder Property
VaultProperties Object : MainDataFolder Property

Glossary Item Box

Description

The main physical folder of this vault on the server (e.g. C:\Program Files\M-Files\Server Vaults\MyVault).

Property type

Read-write property

Syntax

Visual Basic
Public Property MainDataFolder As String

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

SeparateLocationForFileData Property
VaultProperties Object : SeparateLocationForFileData Property

Glossary Item Box

Description

If not empty, specifies a separate location for file data. Currently up to one separate location is supported.

Property type

Read-write property

Syntax

Visual Basic
Public Property SeparateLocationForFileData As AdditionalFolders

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

SQLDatabase Property
VaultProperties Object : SQLDatabase Property

Glossary Item Box

Description

The vault's SQL database.

Property type

Read-write property

Syntax

Visual Basic
Public Property SQLDatabase As SQLDatabase

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

VaultGUID Property
VaultProperties Object : VaultGUID Property

Glossary Item Box

Description

The unique identifier of the vault.

Property type

Read-write property

Syntax

Visual Basic
Public Property VaultGUID As String

See Also

VaultProperties Object | VaultProperties Members


%%PageItemTitle%%

VaultPropertyDefOperations Object
Members See Also Send comments

Glossary Item Box

Description

A group of methods for creating and modifying property definitions.

Public Methods

Public Method AddPropertyDefAdmin | Adds a new property definition. Returns the created property definition, with the ID property set to the real ID value.
Public Method GetBuiltInPropertyDef | Gets the specified built-in property definition from the vault.
Public Method GetPropertyDef | Gets the specified property definition from the vault.
Public Method GetPropertyDefAdmin | Gets the specified property definition from the vault (for administrative operations).
Public Method GetPropertyDefIDByAlias | Gets the ID of the property definition with the specified alias. Returns -1 if a match is not found or if more than one property definition uses the specified alias.
Public Method GetPropertyDefIDByGUID | Gets the ID of the property definition with the specified GUID. Returns -1 if a match is not found.
Public Method GetPropertyDefs | Gets all property definitions in the vault.
Public Method GetPropertyDefsAdmin | Gets all property definitions (for administrative operations).
Public Method Recalculate | Recalculates the automatically generated values for the specified property in all existing objects.
Public Method RemovePropertyDefAdmin | Deletes the property definition with the specified ID.
Public Method UpdatePropertyDefAdmin | Updates the property definition. The ID property identifies the property definition to modify. If ResetLastUsedValue is not NULL, it specifies the new Last Used Value for an autonumbering property.
Public Method UpdatePropertyDefWithAutomaticPermissionsAdmin | Updates the property definition. The ID property identifies the property definition to modify. If ResetLastUsedValue is not NULL, it specifies the new Last Used Value for an autonumbering property.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultPropertyDefOperations Members


%%PageItemTitle%%

AddPropertyDefAdmin Method
PropertyDefAdmin
The property definition object to add.
ResetLastUsedValue

A new Last Used value for an autonumbering property (if not Null).

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultPropertyDefOperations Object : AddPropertyDefAdmin Method

Glossary Item Box

Description

Adds a new property definition. Returns the created property definition, with the ID property set to the real ID value.

Syntax

Visual Basic
Public Function AddPropertyDefAdmin( _
   ByVal PropertyDefAdmin As PropertyDefAdmin, _
   Optional ByVal ResetLastUsedValue As TypedValue = 0 _
) As PropertyDefAdmin

Parameters

PropertyDefAdmin
The property definition object to add.
ResetLastUsedValue

A new Last Used value for an autonumbering property (if not Null).

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultPropertyDefOperations Object | VaultPropertyDefOperations Members


%%PageItemTitle%%

GetBuiltInPropertyDef Method
PropertyDefType
Specifies the built-in property definition.
VaultPropertyDefOperations Object : GetBuiltInPropertyDef Method

Glossary Item Box

Description

Gets the specified built-in property definition from the vault.

Syntax

Visual Basic
Public Function GetBuiltInPropertyDef( _
   ByVal PropertyDefType As MFBuiltInPropertyDef _
) As PropertyDef

Parameters

PropertyDefType
Value | Description
MFBuiltInPropertyDefAccessedByMe | The last time the object was accessed by the current user.
MFBuiltInPropertyDefACLChanged | The date and time of the last change to the ACL of the object version.
MFBuiltInPropertyDefAdditionalClasses | A list of additional classes for the object.
MFBuiltInPropertyDefAssignedTo | A list of users to whom the object version is assigned.
MFBuiltInPropertyDefAssignmentDescription | The assignment description for the current object version assignment.
MFBuiltInPropertyDefClass | The class of the object.
MFBuiltInPropertyDefClassGroups | The class group of the object.
MFBuiltInPropertyDefCollectionMemberCollections | A list of document collections belonging to the document collection.
MFBuiltInPropertyDefCollectionMemberDocuments | A list of documents belonging to the document collection.
MFBuiltInPropertyDefComment | Comment text for the object version. Same as MFBuiltInPropertyDefVersionComment.
MFBuiltInPropertyDefCompleted | Specifies whether or not the assignment has been completed.
MFBuiltInPropertyDefCompletedBy | A list of users who have completed the current assignment.
MFBuiltInPropertyDefConflictResolved | The date and time a conflict was last resolved in favor of the object.
MFBuiltInPropertyDefCreated | The creation date and time of an object.
MFBuiltInPropertyDefCreatedBy | Identifies the user who created the object.
MFBuiltInPropertyDefCreatedFromExternalLocation | The external source from which the object was imported.
MFBuiltInPropertyDefDeadline | The deadline date for the current object version assignment.
MFBuiltInPropertyDefDeleted | The deletion date and time of the object.
MFBuiltInPropertyDefDeletedBy | Identifies the user who deleted the object.
MFBuiltInPropertyDefDeletionStatusChanged | The date and time of the last change to the deletion status of the object.
MFBuiltInPropertyDefFavoriteView | The 'favorite views' where the object should be shown.
MFBuiltInPropertyDefInReplyTo | E-mail in-reply-to internet header value.
MFBuiltInPropertyDefInReplyToReference | E-mail in-reply-to references between documents belonging to the same conversation.
MFBuiltInPropertyDefIsTemplate | A Boolean property identifying whether the object is a template.
MFBuiltInPropertyDefKeywords | Keywords for the object. Not included in the sample vault.
MFBuiltInPropertyDefLastModified | The last modification date and time of an object.
MFBuiltInPropertyDefLastModifiedBy | Identifies the user who performed the last modification for the object.
MFBuiltInPropertyDefLocation | The location in a repository.
MFBuiltInPropertyDefMarkedForArchiving | A Boolean property identifying whether the object is marked for archiving.
MFBuiltInPropertyDefMessageID | E-mail message-id from internet headers.
MFBuiltInPropertyDefMonitoredBy | A list of users who are monitoring the current assignment.
MFBuiltInPropertyDefNameOrTitle | The name or title property definition.
MFBuiltInPropertyDefObjectChanged | The date and time of the last change to the object.
MFBuiltInPropertyDefObjectID | This special value is used for referring to Object ID in ObjectTypeColumnMapping.TargetPropertyDef.
MFBuiltInPropertyDefOriginalPath | The location from which the object was imported to M-Files.
MFBuiltInPropertyDefOriginalPath2 | The location from which the object was imported to M-Files (continued).
MFBuiltInPropertyDefOriginalPath3 | The location from which the object was imported to M-Files (continued).
MFBuiltInPropertyDefReference | A list of referenced documents.
MFBuiltInPropertyDefRejectedBy | A list of users who have rejected the current assignment.
MFBuiltInPropertyDefReportPlacement | Report placement.
MFBuiltInPropertyDefReportURL | Report URL.
MFBuiltInPropertyDefRepository | The repository of an object.
MFBuiltInPropertyDefSharedFiles | The shared location paths of the object's shared files.
MFBuiltInPropertyDefSignatureManifestation | Signature manifestation.
MFBuiltInPropertyDefSingleFileObject | A Boolean property identifying whether the object is a single-file object.
MFBuiltInPropertyDefSizeOnServerAllVersions | The total size of all object versions.
MFBuiltInPropertyDefSizeOnServerThisVersion | The size of this object version.
MFBuiltInPropertyDefState | The workflow state of the object.
MFBuiltInPropertyDefStateEntered | The date when the object state was changed to the current state.
MFBuiltInPropertyDefStateTransition | The workflow state transition of the object.
MFBuiltInPropertyDefStatusChanged | The date and time of the last status change of the object.
MFBuiltInPropertyDefTraditionalFolder | A traditional folder containing this object version.
MFBuiltInPropertyDefVaultGUID | The GUID of the vault that contains or contained the object to which the shortcut object refers to.
MFBuiltInPropertyDefVersionComment | Comment text for the object version. Same as MFBuiltInPropertyDefComment.
MFBuiltInPropertyDefVersionCommentChanged | The date and time of the last change to the comment of the object version.
MFBuiltInPropertyDefVersionLabel | The version label for the object.
MFBuiltInPropertyDefVersionLabelChanged | The date and time of the last change to the version label of the object version.
MFBuiltInPropertyDefWorkflow | The workflow for the object.
MFBuiltInPropertyDefWorkflowAssignment | A property which indicates the assignment related to the workflow of the object.
Specifies the built-in property definition.

Return Type

The PropertDef object that contains information on the built-in property definition.

See Also

VaultPropertyDefOperations Object | VaultPropertyDefOperations Members


%%PageItemTitle%%

GetPropertyDef Method
PropertyDef
Specifies the property definition.
VaultPropertyDefOperations Object : GetPropertyDef Method

Glossary Item Box

Description

Gets the specified property definition from the vault.

Syntax

Visual Basic
Public Function GetPropertyDef( _
   ByVal PropertyDef As Long _
) As PropertyDef

Parameters

PropertyDef
Specifies the property definition.

Return Type

The PropertDef object that contains information on the property definition.

See Also

VaultPropertyDefOperations Object | VaultPropertyDefOperations Members


%%PageItemTitle%%

GetPropertyDefAdmin Method
PropertyDef
VaultPropertyDefOperations Object : GetPropertyDefAdmin Method

Glossary Item Box

Description

Gets the specified property definition from the vault (for administrative operations).

Syntax

Visual Basic
Public Function GetPropertyDefAdmin( _
   ByVal PropertyDef As Long _
) As PropertyDefAdmin

Parameters

PropertyDef

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultPropertyDefOperations Object | VaultPropertyDefOperations Members


%%PageItemTitle%%

GetPropertyDefIDByAlias Method
Alias
VaultPropertyDefOperations Object : GetPropertyDefIDByAlias Method

Glossary Item Box

Description

Gets the ID of the property definition with the specified alias. Returns -1 if a match is not found or if more than one property definition uses the specified alias.

Syntax

Visual Basic
Public Function GetPropertyDefIDByAlias( _
   ByVal Alias As String _
) As Long

Parameters

Alias

See Also

VaultPropertyDefOperations Object | VaultPropertyDefOperations Members


%%PageItemTitle%%

GetPropertyDefIDByGUID Method
PropertyDefGUID
The GUID of the property definition.
VaultPropertyDefOperations Object : GetPropertyDefIDByGUID Method

Glossary Item Box

Description

Gets the ID of the property definition with the specified GUID. Returns -1 if a match is not found.

Syntax

Visual Basic
Public Function GetPropertyDefIDByGUID( _
   ByVal PropertyDefGUID As String _
) As Long

Parameters

PropertyDefGUID
The GUID of the property definition.

See Also

VaultPropertyDefOperations Object | VaultPropertyDefOperations Members


%%PageItemTitle%%

GetPropertyDefs Method
VaultPropertyDefOperations Object : GetPropertyDefs Method

Glossary Item Box

Description

Gets all property definitions in the vault.

Syntax

Visual Basic
Public Function GetPropertyDefs() As PropertyDefs

Return Type

The collection of the property definitions.

See Also

VaultPropertyDefOperations Object | VaultPropertyDefOperations Members


%%PageItemTitle%%

GetPropertyDefsAdmin Method
VaultPropertyDefOperations Object : GetPropertyDefsAdmin Method

Glossary Item Box

Description

Gets all property definitions (for administrative operations).

Syntax

Visual Basic
Public Function GetPropertyDefsAdmin() As PropertyDefsAdmin

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultPropertyDefOperations Object | VaultPropertyDefOperations Members


%%PageItemTitle%%

Recalculate Method
PropertyDef
The property definition the values of which to recalculate.
RecalculateCurrentlyEmptyValuesOnly
True if only the currently empty values should be recalculated. Otherwise all values will be recalculated.
VaultPropertyDefOperations Object : Recalculate Method

Glossary Item Box

Description

Recalculates the automatically generated values for the specified property in all existing objects.

Syntax

Visual Basic
Public Sub Recalculate( _
   ByVal PropertyDef As Long, _
   ByVal RecalculateCurrentlyEmptyValuesOnly As Boolean _
)

Parameters

PropertyDef
The property definition the values of which to recalculate.
RecalculateCurrentlyEmptyValuesOnly
True if only the currently empty values should be recalculated. Otherwise all values will be recalculated.

Remarks

This method is available only if M-Files API is used in the server interface mode.

The method cannot currently be used properly with scripts (such as event handler and workflow state action scripts) due to the following issue:

"Recalculate" in "MFServer" is an asynchronous operation because it might in some cases take a long time to complete. M-Files API hides the asynchrony by monitoring the ending of the background job and returns the control to the caller only after the "Recalculate" operation has finished. To monitor the background job M-Files API needs to perform another login operation to the server. The issue is caused due to the fact that the event handler is executed with a special login and the server does not accept that for the relogin. This means that the "Recalculate" operation basically cannot, for the time being, be used in the event handler. The operation is actually triggered and probably succeeds as well, but an error is however received every time.

See Also

VaultPropertyDefOperations Object | VaultPropertyDefOperations Members


%%PageItemTitle%%

RemovePropertyDefAdmin Method
PropertyDef
The ID of the property definition to remove.
CopyToAnotherPropertyDef
Whether to copy the values of the removed property to another property. If True, TargetPropertyDef must be provided.
TargetPropertyDef
The ID of the property definition that should be used when copying the values from the removed property.
Append
Whether to append the values from the removed property to the TargetPropertyDef. If False, the old target values are overwritten.
DeleteFromClassesIfNecessary
If this parameter is True, the reference to the removed property definition is removed from classes. If this parameter is False, the method returns an error if the property definition is referenced by one or more classes.
VaultPropertyDefOperations Object : RemovePropertyDefAdmin Method

Glossary Item Box

Description

Deletes the property definition with the specified ID.

Syntax

Visual Basic
Public Sub RemovePropertyDefAdmin( _
   ByVal PropertyDef As Long, _
   Optional ByVal CopyToAnotherPropertyDef As Boolean = False, _
   Optional ByVal TargetPropertyDef As Long = 0, _
   Optional ByVal Append As Boolean = False, _
   Optional ByVal DeleteFromClassesIfNecessary As Boolean = False _
)

Parameters

PropertyDef
The ID of the property definition to remove.
CopyToAnotherPropertyDef
Whether to copy the values of the removed property to another property. If True, TargetPropertyDef must be provided.
TargetPropertyDef
The ID of the property definition that should be used when copying the values from the removed property.
Append
Whether to append the values from the removed property to the TargetPropertyDef. If False, the old target values are overwritten.
DeleteFromClassesIfNecessary
If this parameter is True, the reference to the removed property definition is removed from classes. If this parameter is False, the method returns an error if the property definition is referenced by one or more classes.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultPropertyDefOperations Object | VaultPropertyDefOperations Members


%%PageItemTitle%%

UpdatePropertyDefAdmin Method
PropertyDefAdmin
The property definition object to update.
ResetLastUsedValue

A new Last Used value for an autonumbering property (if not Null).

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultPropertyDefOperations Object : UpdatePropertyDefAdmin Method

Glossary Item Box

Description

Updates the property definition. The ID property identifies the property definition to modify. If ResetLastUsedValue is not NULL, it specifies the new Last Used Value for an autonumbering property.

Syntax

Visual Basic
Public Sub UpdatePropertyDefAdmin( _
   ByVal PropertyDefAdmin As PropertyDefAdmin, _
   Optional ByVal ResetLastUsedValue As TypedValue = 0 _
)

Parameters

PropertyDefAdmin
The property definition object to update.
ResetLastUsedValue

A new Last Used value for an autonumbering property (if not Null).

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Remarks

This method is available only if M-Files API is used in the server interface mode.

Note

If the update operation causes the property definition to result in new automatic access control list components and these components allow users to deactivate them, the components are added on objects in inactive state.

Use UpdatePropertyDefWithAutomaticPermissions to modify this default behavior.

See Also

VaultPropertyDefOperations Object | VaultPropertyDefOperations Members


%%PageItemTitle%%

UpdatePropertyDefWithAutomaticPermissionsAdmin Method
PropertyDefAdmin
The property definition object to update.
ResetLastUsedValue

A new Last Used value for an autonumbering property (if not Null).

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AutomaticPermissionsForcedActive
Specifies the default activity state on automatic access control list components if the update operation results in new components on existing objects.
VaultPropertyDefOperations Object : UpdatePropertyDefWithAutomaticPermissionsAdmin Method

Glossary Item Box

Description

Updates the property definition. The ID property identifies the property definition to modify. If ResetLastUsedValue is not NULL, it specifies the new Last Used Value for an autonumbering property.

Syntax

Visual Basic
Public Sub UpdatePropertyDefWithAutomaticPermissionsAdmin( _
   ByVal PropertyDefAdmin As PropertyDefAdmin, _
   Optional ByVal ResetLastUsedValue As TypedValue = 0, _
   Optional ByVal AutomaticPermissionsForcedActive As Boolean = False _
)

Parameters

PropertyDefAdmin
The property definition object to update.
ResetLastUsedValue

A new Last Used value for an autonumbering property (if not Null).

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

AutomaticPermissionsForcedActive
Specifies the default activity state on automatic access control list components if the update operation results in new components on existing objects.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultPropertyDefOperations Object | VaultPropertyDefOperations Members


%%PageItemTitle%%

VaultScheduledJobManagementOperations Object
Members See Also Send comments

Glossary Item Box

Description

VaultScheduledJobManagementOperations is an interface for managing scheduled jobs in a vault.

Public Methods

Public Method AddScheduledJob | Add the specified scheduled job to the vault.
Public Method CancelScheduledJob | Cancels the execution of the specified scheduled job.
Public Method GetScheduledJob | Gets the specified scheduled job.
Public Method GetScheduledJobRunInfo | Gets run information on the specified scheduled job.
Public Method GetScheduledJobs | Gets all scheduled jobs in the vault.
Public Method ModifyScheduledJob | Modifies the specified scheduled job in the vault.
Public Method RemoveScheduledJob | Deletes the specified scheduled job from the vault.
Public Method StartScheduledJob | Starts the execution of the specified scheduled job.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultScheduledJobManagementOperations Members


%%PageItemTitle%%

AddScheduledJob Method
ScheduledJob
The scheduled job to be added.
VaultScheduledJobManagementOperations Object : AddScheduledJob Method

Glossary Item Box

Description

Add the specified scheduled job to the vault.

Syntax

Visual Basic
Public Function AddScheduledJob( _
   ByVal ScheduledJob As ScheduledJob _
) As Long

Parameters

ScheduledJob
The scheduled job to be added.

Remarks

This method is available only if M-Files API is used in the server interface mode.

If the targeted scheduled task is an ExportContentJob or an ImportContentJob and if replication via cloud is enabled (see SetReplicationViaCloud for export jobs and SetReplicationViaCloud for import jobs), the "UseMultipleContentPackages" flag via the "Flags" property must be enabled as well (see Flags for export jobs and for Flags import jobs, and eventually MFExportContentFlag and MFImportContentFlag, respectively).

See Also

VaultScheduledJobManagementOperations Object | VaultScheduledJobManagementOperations Members


%%PageItemTitle%%

CancelScheduledJob Method
ID
The ID of the scheduled job to cancel.
VaultScheduledJobManagementOperations Object : CancelScheduledJob Method

Glossary Item Box

Description

Cancels the execution of the specified scheduled job.

Syntax

Visual Basic
Public Sub CancelScheduledJob( _
   ByVal ID As Long _
)

Parameters

ID
The ID of the scheduled job to cancel.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultScheduledJobManagementOperations Object | VaultScheduledJobManagementOperations Members


%%PageItemTitle%%

GetScheduledJob Method
ID
The ID of the scheduled job to retrieve.
VaultScheduledJobManagementOperations Object : GetScheduledJob Method

Glossary Item Box

Description

Gets the specified scheduled job.

Syntax

Visual Basic
Public Function GetScheduledJob( _
   ByVal ID As Long _
) As ScheduledJob

Parameters

ID
The ID of the scheduled job to retrieve.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultScheduledJobManagementOperations Object | VaultScheduledJobManagementOperations Members


%%PageItemTitle%%

GetScheduledJobRunInfo Method
ID
The ID of the scheduled job to retrieve run info for.
VaultScheduledJobManagementOperations Object : GetScheduledJobRunInfo Method

Glossary Item Box

Description

Gets run information on the specified scheduled job.

Syntax

Visual Basic
Public Function GetScheduledJobRunInfo( _
   ByVal ID As Long _
) As ScheduledJobRunInfo

Parameters

ID
The ID of the scheduled job to retrieve run info for.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultScheduledJobManagementOperations Object | VaultScheduledJobManagementOperations Members


%%PageItemTitle%%

GetScheduledJobs Method
VaultScheduledJobManagementOperations Object : GetScheduledJobs Method

Glossary Item Box

Description

Gets all scheduled jobs in the vault.

Syntax

Visual Basic
Public Function GetScheduledJobs() As ScheduledJobs

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultScheduledJobManagementOperations Object | VaultScheduledJobManagementOperations Members


%%PageItemTitle%%

ModifyScheduledJob Method
ScheduledJob
The scheduled job to be modified.
VaultScheduledJobManagementOperations Object : ModifyScheduledJob Method

Glossary Item Box

Description

Modifies the specified scheduled job in the vault.

Syntax

Visual Basic
Public Sub ModifyScheduledJob( _
   ByVal ScheduledJob As ScheduledJob _
)

Parameters

ScheduledJob
The scheduled job to be modified.

Remarks

This method is available only if M-Files API is used in the server interface mode.

If the targeted scheduled task is an ExportContentJob or an ImportContentJob and if replication via cloud is enabled (see SetReplicationViaCloud for export jobs and SetReplicationViaCloud for import jobs), the "UseMultipleContentPackages" flag via the "Flags" property must be enabled as well (see Flags for export jobs and for Flags import jobs, and eventually MFExportContentFlag and MFImportContentFlag, respectively).

See Also

VaultScheduledJobManagementOperations Object | VaultScheduledJobManagementOperations Members


%%PageItemTitle%%

RemoveScheduledJob Method
ID
The ID of the scheduled job to remove.
VaultScheduledJobManagementOperations Object : RemoveScheduledJob Method

Glossary Item Box

Description

Deletes the specified scheduled job from the vault.

Syntax

Visual Basic
Public Sub RemoveScheduledJob( _
   ByVal ID As Long _
)

Parameters

ID
The ID of the scheduled job to remove.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultScheduledJobManagementOperations Object | VaultScheduledJobManagementOperations Members


%%PageItemTitle%%

StartScheduledJob Method
ID
The ID of the scheduled job to start.
VaultScheduledJobManagementOperations Object : StartScheduledJob Method

Glossary Item Box

Description

Starts the execution of the specified scheduled job.

Syntax

Visual Basic
Public Sub StartScheduledJob( _
   ByVal ID As Long _
)

Parameters

ID
The ID of the scheduled job to start.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultScheduledJobManagementOperations Object | VaultScheduledJobManagementOperations Members


%%PageItemTitle%%

VaultServerAttachment Object
Members See Also Send comments

Glossary Item Box

Description

A data object for storing information about which servers the vault is attached to.

Public Methods

Public Method Clone Makes a copy of the "IVaultServerAttachment" object.

Public Properties

Public Property Address | The host address of the server to which the vault is attached.
Public Property HostName | The host name of the server to which the vault is attached.
Public Property IsCurrent | When this is true, this server is the one the vault is currently attached to.
Public Property LatestTimestamp | The date and time this information was last updated.
Public Property ServerID | The ID of the server to which the vault is attached.

Remarks

Supported in M-Files 20.3.8876.4 and newer.

See Also

VaultServerAttachment Members


%%PageItemTitle%%

Clone Method
VaultServerAttachment Object : Clone Method

Glossary Item Box

Description

Makes a copy of the "IVaultServerAttachment" object.

Syntax

Visual Basic
Public Function Clone() As VaultServerAttachment

See Also

VaultServerAttachment Object | VaultServerAttachment Members


%%PageItemTitle%%

Address Property
VaultServerAttachment Object : Address Property

Glossary Item Box

Description

The host address of the server to which the vault is attached.

Property type

Read-only property

Syntax

Visual Basic
Public Property Address As String

See Also

VaultServerAttachment Object | VaultServerAttachment Members


%%PageItemTitle%%

HostName Property
VaultServerAttachment Object : HostName Property

Glossary Item Box

Description

The host name of the server to which the vault is attached.

Property type

Read-only property

Syntax

Visual Basic
Public Property HostName As String

See Also

VaultServerAttachment Object | VaultServerAttachment Members


%%PageItemTitle%%

IsCurrent Property
VaultServerAttachment Object : IsCurrent Property

Glossary Item Box

Description

When this is true, this server is the one the vault is currently attached to.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsCurrent As Boolean

See Also

VaultServerAttachment Object | VaultServerAttachment Members


%%PageItemTitle%%

LatestTimestamp Property
VaultServerAttachment Object : LatestTimestamp Property

Glossary Item Box

Description

The date and time this information was last updated.

Property type

Read-only property

Syntax

Visual Basic
Public Property LatestTimestamp As Timestamp

See Also

VaultServerAttachment Object | VaultServerAttachment Members


%%PageItemTitle%%

ServerID Property
VaultServerAttachment Object : ServerID Property

Glossary Item Box

Description

The ID of the server to which the vault is attached.

Property type

Read-only property

Syntax

Visual Basic
Public Property ServerID As String

See Also

VaultServerAttachment Object | VaultServerAttachment Members


%%PageItemTitle%%

VaultServerAttachments Collection
Members See Also Send comments

Glossary Item Box

Description

"VaultServerAttachments" is a collection of "VaultServerAttachment" objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

Remarks

Supported in M-Files 20.3.8876.4 and newer.

See Also

VaultServerAttachments Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added.
VaultServerAttachment
A data object for containing information about which servers the vault is attached to.
VaultServerAttachments Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal VaultServerAttachment As VaultServerAttachment _
)

Parameters

Index
Position at which a new collection member is added.
VaultServerAttachment
A data object for containing information about which servers the vault is attached to.

See Also

VaultServerAttachments Collection | VaultServerAttachments Members


%%PageItemTitle%%

Clone Method
VaultServerAttachments Collection : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As VaultServerAttachments

See Also

VaultServerAttachments Collection | VaultServerAttachments Members


%%PageItemTitle%%

Remove Method
Index
Position at which a new collection member is added.
VaultServerAttachments Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position at which a new collection member is added.

See Also

VaultServerAttachments Collection | VaultServerAttachments Members


%%PageItemTitle%%

Count Property
VaultServerAttachments Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

VaultServerAttachments Collection | VaultServerAttachments Members


%%PageItemTitle%%

Item Property
Index
Position at which a new collection member is added.
VaultServerAttachments Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As VaultServerAttachment

Parameters

Index
Position at which a new collection member is added.

See Also

VaultServerAttachments Collection | VaultServerAttachments Members


%%PageItemTitle%%

VaultServerDataPushOperations Object
Members See Also Send comments

Glossary Item Box

Description

The 'VaultServerDataPushOperations' class is an interface for establishing a communication channel to M-Files server that enables the server data push.

Public Methods

Public Method CloneVaultForServerDataPush | Creates a clone of the vault object and registers a data push sink to trigger only for the methods that are used with the cloned vault.
Public Method SendCancel | Informs the server that the client wants to cancel the operation.
Public Method SendError | Informs the server that an error occurred in the client operation.
Public Method SendHeartbeat | Informs the server that the client will provide a response later.
Public Method SendResponse | Sends a response to the server request.
Public Method SetServerDataPushSink | Registers a client listener to receive server data push notifications.

Remarks

Current support extends only to built-in server data push events.

See Also

VaultServerDataPushOperations Members


%%PageItemTitle%%

CloneVaultForServerDataPush Method
ServerDataPushSink
The server data push sink object.
VaultServerDataPushOperations Object : CloneVaultForServerDataPush Method

Glossary Item Box

Description

Creates a clone of the vault object and registers a data push sink to trigger only for the methods that are used with the cloned vault.

Syntax

Visual Basic
Public Function CloneVaultForServerDataPush( _
   ByVal ServerDataPushSink As IServerDataPushSink _
) As Vault

Parameters

ServerDataPushSink
The server data push sink object.

See Also

VaultServerDataPushOperations Object | VaultServerDataPushOperations Members


%%PageItemTitle%%

SendCancel Method
RequestID
The request ID that was received from the server.
VaultServerDataPushOperations Object : SendCancel Method

Glossary Item Box

Description

Informs the server that the client wants to cancel the operation.

Syntax

Visual Basic
Public Sub SendCancel( _
   ByVal RequestID As Long _
)

Parameters

RequestID
The request ID that was received from the server.

See Also

VaultServerDataPushOperations Object | VaultServerDataPushOperations Members


%%PageItemTitle%%

SendError Method
RequestID
The request ID that was received from the server.
Error
A free-form error.
VaultServerDataPushOperations Object : SendError Method

Glossary Item Box

Description

Informs the server that an error occurred in the client operation.

Syntax

Visual Basic
Public Sub SendError( _
   ByVal RequestID As Long, _
   ByVal Error As String _
)

Parameters

RequestID
The request ID that was received from the server.
Error
A free-form error.

See Also

VaultServerDataPushOperations Object | VaultServerDataPushOperations Members


%%PageItemTitle%%

SendHeartbeat Method
RequestID
The request ID that was received from the server.
VaultServerDataPushOperations Object : SendHeartbeat Method

Glossary Item Box

Description

Informs the server that the client will provide a response later.

Syntax

Visual Basic
Public Sub SendHeartbeat( _
   ByVal RequestID As Long _
)

Parameters

RequestID
The request ID that was received from the server.

See Also

VaultServerDataPushOperations Object | VaultServerDataPushOperations Members


%%PageItemTitle%%

SendResponse Method
RequestID
The request ID that was received from the server.
JsonResponseContent
The response content.
VaultServerDataPushOperations Object : SendResponse Method

Glossary Item Box

Description

Sends a response to the server request.

Syntax

Visual Basic
Public Sub SendResponse( _
   ByVal RequestID As Long, _
   ByVal JsonResponseContent As String _
)

Parameters

RequestID
The request ID that was received from the server.
JsonResponseContent
The response content.

See Also

VaultServerDataPushOperations Object | VaultServerDataPushOperations Members


%%PageItemTitle%%

SetServerDataPushSink Method
ServerDataPushSink
The sink interface to be registered. Set NULL to revoke the registration.
VaultServerDataPushOperations Object : SetServerDataPushSink Method

Glossary Item Box

Description

Registers a client listener to receive server data push notifications.

Syntax

Visual Basic
Public Sub SetServerDataPushSink( _
   ByVal ServerDataPushSink As IServerDataPushSink _
)

Parameters

ServerDataPushSink
The sink interface to be registered. Set NULL to revoke the registration.

See Also

VaultServerDataPushOperations Object | VaultServerDataPushOperations Members


%%PageItemTitle%%

VaultSharedLinkOperations Object
Members See Also Send comments

Glossary Item Box

Description

The 'VaultSharedLinkOperations' class represents the available public link operations.

Public Methods

Public Method CreateSharedLink | Create a new public link to the server.
Public Method DeleteSharedLink | Delete a public link.
Public Method GetSharedLink | Gets information on the specified public link.
Public Method GetSharedLinks | Gets all available public links in this vault.
Public Method GetSharedLinksByObject | Gets all the shared links of the given object.

Remarks

M-Files currently supports public links to single-file documents only. This means that "FileVer" must be specified when creating a new link. Even though API allows creating links to objects by omitting "FileVer", these kind of links will not work.

This method group interface can be accessed via the Vault object.

See Also

VaultSharedLinkOperations Members


%%PageItemTitle%%

CreateSharedLink Method
SharedLinkCreationInfo
The information for creating the shared link.
VaultSharedLinkOperations Object : CreateSharedLink Method

Glossary Item Box

Description

Create a new public link to the server.

Syntax

Visual Basic
Public Function CreateSharedLink( _
   ByVal SharedLinkCreationInfo As SharedLinkInfo _
) As SharedLinkInfo

Parameters

SharedLinkCreationInfo
The information for creating the shared link.

Remarks

  • This method is available only if M-Files API is used in the server interface mode.
  • The value of the "Version" property for the associated "FileVer" object must be set to "-1".

See Also

VaultSharedLinkOperations Object | VaultSharedLinkOperations Members


%%PageItemTitle%%

DeleteSharedLink Method
AccessKey
The unique access key of the public link.
VaultSharedLinkOperations Object : DeleteSharedLink Method

Glossary Item Box

Description

Delete a public link.

Syntax

Visual Basic
Public Sub DeleteSharedLink( _
   ByVal AccessKey As String _
)

Parameters

AccessKey
The unique access key of the public link.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultSharedLinkOperations Object | VaultSharedLinkOperations Members


%%PageItemTitle%%

GetSharedLink Method
AccessKey
The unique access key of the public link.
VaultSharedLinkOperations Object : GetSharedLink Method

Glossary Item Box

Description

Gets information on the specified public link.

Syntax

Visual Basic
Public Function GetSharedLink( _
   ByVal AccessKey As String _
) As SharedLinkInfo

Parameters

AccessKey
The unique access key of the public link.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultSharedLinkOperations Object | VaultSharedLinkOperations Members


%%PageItemTitle%%

GetSharedLinks Method
CreatedByUser
Filter the result by a given user.
VaultSharedLinkOperations Object : GetSharedLinks Method

Glossary Item Box

Description

Gets all available public links in this vault.

Syntax

Visual Basic
Public Function GetSharedLinks( _
   Optional ByVal CreatedByUser As Long = -1 _
) As SharedLinkInfos

Parameters

CreatedByUser
Filter the result by a given user.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultSharedLinkOperations Object | VaultSharedLinkOperations Members


%%PageItemTitle%%

GetSharedLinksByObject Method
ObjID
The ID of the object the shared links of which to get.
VaultSharedLinkOperations Object : GetSharedLinksByObject Method

Glossary Item Box

Description

Gets all the shared links of the given object.

Syntax

Visual Basic
Public Function GetSharedLinksByObject( _
   ByVal ObjID As ObjID _
) As SharedLinkInfos

Parameters

ObjID
The ID of the object the shared links of which to get.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultSharedLinkOperations Object | VaultSharedLinkOperations Members


%%PageItemTitle%%

VaultsOnServer Collection
Members See Also Send comments

Glossary Item Box

Description

ventlog

Public Methods

Public Method GetVaultByGUID | Gets vault by GUID.
Public Method GetVaultByName | Gets vault by name.
Public Method GetVaultIndexByGUID | Gets vault index by GUID. -1 indicates that item was not found.
Public Method GetVaultIndexByName | Gets vault index by name. -1 indicates that item was not found.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

VaultsOnServer Members


%%PageItemTitle%%

GetVaultByGUID Method
GUID
VaultsOnServer Collection : GetVaultByGUID Method

Glossary Item Box

Description

Gets vault by GUID.

Syntax

Visual Basic
Public Function GetVaultByGUID( _
   ByVal GUID As String _
) As VaultOnServer

Parameters

GUID

See Also

VaultsOnServer Collection | VaultsOnServer Members


%%PageItemTitle%%

GetVaultByName Method
Name
VaultsOnServer Collection : GetVaultByName Method

Glossary Item Box

Description

Gets vault by name.

Syntax

Visual Basic
Public Function GetVaultByName( _
   ByVal Name As String _
) As VaultOnServer

Parameters

Name

See Also

VaultsOnServer Collection | VaultsOnServer Members


%%PageItemTitle%%

GetVaultIndexByGUID Method
GUID
VaultsOnServer Collection : GetVaultIndexByGUID Method

Glossary Item Box

Description

Gets vault index by GUID. -1 indicates that item was not found.

Syntax

Visual Basic
Public Function GetVaultIndexByGUID( _
   ByVal GUID As String _
) As Long

Parameters

GUID

See Also

VaultsOnServer Collection | VaultsOnServer Members


%%PageItemTitle%%

GetVaultIndexByName Method
Name
VaultsOnServer Collection : GetVaultIndexByName Method

Glossary Item Box

Description

Gets vault index by name. -1 indicates that item was not found.

Syntax

Visual Basic
Public Function GetVaultIndexByName( _
   ByVal Name As String _
) As Long

Parameters

Name

See Also

VaultsOnServer Collection | VaultsOnServer Members


%%PageItemTitle%%

Count Property
VaultsOnServer Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

VaultsOnServer Collection | VaultsOnServer Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
VaultsOnServer Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As VaultOnServer

Parameters

Index
Specifies the item's position in the collection.

See Also

VaultsOnServer Collection | VaultsOnServer Members


%%PageItemTitle%%

VaultTraditionalFolderOperations Object
Members See Also Send comments

Glossary Item Box

Description

The VaultTraditionalFolderOperations class represents the available traditional folder operations.

Public Methods

Public Method GetTraditionalFolderContents Retrieves the traditional folder contents.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultTraditionalFolderOperations Members


%%PageItemTitle%%

GetTraditionalFolderContents Method
Folder
The traditional folder ID.
VaultTraditionalFolderOperations Object : GetTraditionalFolderContents Method

Glossary Item Box

Description

Retrieves the traditional folder contents.

Syntax

Visual Basic
Public Function GetTraditionalFolderContents( _
   ByVal Folder As Long _
) As TraditionalFolderContents

Parameters

Folder
The traditional folder ID.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultTraditionalFolderOperations Object | VaultTraditionalFolderOperations Members


%%PageItemTitle%%

VaultUserGroupOperations Object
Members See Also Send comments

Glossary Item Box

Description

The VaultUserGroupOperations class represents the available user group operations.

Public Methods

Public Method AddOrUndeleteUserGroup | Adds a new user group or undeletes an existing one.
Public Method AddUserGroupAdmin | Adds a new user group. Returns the created user group, with the ID property set to the real ID value.
Public Method GetGroupsOfUserOrGroup | Gets all the groups that the specifed user or group belongs to.
Public Method GetUserContainersAdmin | Gets all user containers.
Public Method GetUserGroup | Gets the specified user group.
Public Method GetUserGroupAdmin | Gets the specified user group (for administrative operations).
Public Method GetUserGroupIDByAlias | Gets the ID of the user group with the specified alias. Returns -1 if a match is not found or if more than one user group uses the specified alias.
Public Method GetUserGroupIDByGUID | Gets the ID of the user group with the specified GUID. Returns -1 if a match is not found.
Public Method GetUserGroupList | Gets the user group listing as key name pairs.
Public Method GetUserGroups | Gets all user groups.
Public Method GetUserGroupsAdmin | Gets all user groups.
Public Method RemoveUserGroupAdmin | Deletes the user group with specified ID.
Public Method UpdateUserGroupAdmin | Updates the user group. The ID property identifies the user group to modify.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultUserGroupOperations Members


%%PageItemTitle%%

AddOrUndeleteUserGroup Method
UserGroup
The user group object to be added.
VaultUserGroupOperations Object : AddOrUndeleteUserGroup Method

Glossary Item Box

Description

Adds a new user group or undeletes an existing one.

Syntax

Visual Basic
Public Function AddOrUndeleteUserGroup( _
   ByVal UserGroup As UserGroupAdmin _
) As UserGroupAdmin

Parameters

UserGroup
The user group object to be added.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

AddUserGroupAdmin Method
UserGroup
The user group object to be added.
VaultUserGroupOperations Object : AddUserGroupAdmin Method

Glossary Item Box

Description

Adds a new user group. Returns the created user group, with the ID property set to the real ID value.

Syntax

Visual Basic
Public Function AddUserGroupAdmin( _
   ByVal UserGroup As UserGroupAdmin _
) As UserGroupAdmin

Parameters

UserGroup
The user group object to be added.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

GetGroupsOfUserOrGroup Method
UserOrGroupID
The ID of the user or the user group.
IsGroup
Specifies whether the target is a user group.
VaultUserGroupOperations Object : GetGroupsOfUserOrGroup Method

Glossary Item Box

Description

Gets all the groups that the specifed user or group belongs to.

Syntax

Visual Basic
Public Function GetGroupsOfUserOrGroup( _
   ByVal UserOrGroupID As Long, _
   ByVal IsGroup As Boolean _
) As UserGroups

Parameters

UserOrGroupID
The ID of the user or the user group.
IsGroup
Specifies whether the target is a user group.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

GetUserContainersAdmin Method
VaultUserGroupOperations Object : GetUserContainersAdmin Method

Glossary Item Box

Description

Gets all user containers.

Syntax

Visual Basic
Public Function GetUserContainersAdmin() As UserGroupsAdmin

Remarks

Supported in M-Files 20.2.8777.3 and later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

GetUserGroup Method
UserGroupID
The ID of the user group.
VaultUserGroupOperations Object : GetUserGroup Method

Glossary Item Box

Description

Gets the specified user group.

Syntax

Visual Basic
Public Function GetUserGroup( _
   ByVal UserGroupID As Long _
) As UserGroup

Parameters

UserGroupID
The ID of the user group.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

GetUserGroupAdmin Method
UserGroupID
The ID of the user group.
VaultUserGroupOperations Object : GetUserGroupAdmin Method

Glossary Item Box

Description

Gets the specified user group (for administrative operations).

Syntax

Visual Basic
Public Function GetUserGroupAdmin( _
   ByVal UserGroupID As Long _
) As UserGroupAdmin

Parameters

UserGroupID
The ID of the user group.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

GetUserGroupIDByAlias Method
Alias
The alias of the user group.
VaultUserGroupOperations Object : GetUserGroupIDByAlias Method

Glossary Item Box

Description

Gets the ID of the user group with the specified alias. Returns -1 if a match is not found or if more than one user group uses the specified alias.

Syntax

Visual Basic
Public Function GetUserGroupIDByAlias( _
   ByVal Alias As String _
) As Long

Parameters

Alias
The alias of the user group.

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

GetUserGroupIDByGUID Method
UserGroupGUID
The GUID of the user group.
VaultUserGroupOperations Object : GetUserGroupIDByGUID Method

Glossary Item Box

Description

Gets the ID of the user group with the specified GUID. Returns -1 if a match is not found.

Syntax

Visual Basic
Public Function GetUserGroupIDByGUID( _
   ByVal UserGroupGUID As String _
) As Long

Parameters

UserGroupGUID
The GUID of the user group.

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

GetUserGroupList Method
VaultUserGroupOperations Object : GetUserGroupList Method

Glossary Item Box

Description

Gets the user group listing as key name pairs.

Syntax

Visual Basic
Public Function GetUserGroupList() As KeyNamePairs

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

GetUserGroups Method
VaultUserGroupOperations Object : GetUserGroups Method

Glossary Item Box

Description

Gets all user groups.

Syntax

Visual Basic
Public Function GetUserGroups() As UserGroups

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

GetUserGroupsAdmin Method
VaultUserGroupOperations Object : GetUserGroupsAdmin Method

Glossary Item Box

Description

Gets all user groups.

Syntax

Visual Basic
Public Function GetUserGroupsAdmin() As UserGroupsAdmin

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

RemoveUserGroupAdmin Method
UserGroupID
The ID of the user group to remove.
VaultUserGroupOperations Object : RemoveUserGroupAdmin Method

Glossary Item Box

Description

Deletes the user group with specified ID.

Syntax

Visual Basic
Public Sub RemoveUserGroupAdmin( _
   ByVal UserGroupID As Long _
)

Parameters

UserGroupID
The ID of the user group to remove.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

UpdateUserGroupAdmin Method
UserGroup
User group object to update.
VaultUserGroupOperations Object : UpdateUserGroupAdmin Method

Glossary Item Box

Description

Updates the user group. The ID property identifies the user group to modify.

Syntax

Visual Basic
Public Sub UpdateUserGroupAdmin( _
   ByVal UserGroup As UserGroupAdmin _
)

Parameters

UserGroup
User group object to update.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserGroupOperations Object | VaultUserGroupOperations Members


%%PageItemTitle%%

VaultUserOperations Object
Members See Also Send comments

Glossary Item Box

Description

The VaultUserOperations class represents the available user operations.

Public Methods

Public Method AddOrUndeleteUserAccount | Adds the given user account to the vault (or undeletes it).
Public Method AddUserAccount | Adds the given user account to the vault. Returns the created user account, with the ID property set to the real ID value.
Public Method GetLoginAccountOfUser | Gets the login account that corresponds to the specified vault user.
Public Method GetLoginAccounts | Gets the login accounts of all vault users.
Public Method GetUserAccount | Retrieves a single user account.
Public Method GetUserAccounts | Gets available user accounts from the vault.
Public Method GetUserIDByGUID | Gets the ID of the user with the specified GUID. Returns -1 if a match is not found.
Public Method GetUserList | Gets all users as key name pairs.
Public Method ModifyUserAccount | Modifies the user account.
Public Method RemoveUserAccount | Deletes the user account from vault.
Public Method UndeleteUserAccountByGUID | Attempts to undelete a user with the specified GUID and to set its account information. Does not create new accounts.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultUserOperations Members


%%PageItemTitle%%

AddOrUndeleteUserAccount Method
User
The user account to be added or undeleted.
VaultUserOperations Object : AddOrUndeleteUserAccount Method

Glossary Item Box

Description

Adds the given user account to the vault (or undeletes it).

Syntax

Visual Basic
Public Function AddOrUndeleteUserAccount( _
   ByVal User As UserAccount _
) As UserAccount

Parameters

User
The user account to be added or undeleted.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserOperations Object | VaultUserOperations Members


%%PageItemTitle%%

AddUserAccount Method
User
User account object to be added.
VaultUserOperations Object : AddUserAccount Method

Glossary Item Box

Description

Adds the given user account to the vault. Returns the created user account, with the ID property set to the real ID value.

Syntax

Visual Basic
Public Function AddUserAccount( _
   ByVal User As UserAccount _
) As UserAccount

Parameters

User
User account object to be added.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserOperations Object | VaultUserOperations Members


%%PageItemTitle%%

GetLoginAccountOfUser Method
UserID
The ID of the user whose login account should be returned.
VaultUserOperations Object : GetLoginAccountOfUser Method

Glossary Item Box

Description

Gets the login account that corresponds to the specified vault user.

Syntax

Visual Basic
Public Function GetLoginAccountOfUser( _
   ByVal UserID As Long _
) As LoginAccount

Parameters

UserID
The ID of the user whose login account should be returned.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserOperations Object | VaultUserOperations Members


%%PageItemTitle%%

GetLoginAccounts Method
VaultUserOperations Object : GetLoginAccounts Method

Glossary Item Box

Description

Gets the login accounts of all vault users.

Syntax

Visual Basic
Public Function GetLoginAccounts() As LoginAccounts

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserOperations Object | VaultUserOperations Members


%%PageItemTitle%%

GetUserAccount Method
UserID
The ID of the user account to be retrieved.
VaultUserOperations Object : GetUserAccount Method

Glossary Item Box

Description

Retrieves a single user account.

Syntax

Visual Basic
Public Function GetUserAccount( _
   ByVal UserID As Long _
) As UserAccount

Parameters

UserID
The ID of the user account to be retrieved.

Remarks

This method is available only if M-Files API is used in the server interface mode.

This method is potentially slow. To retrieve multiple user accounts, use the GetUserAccounts method.

See Also

VaultUserOperations Object | VaultUserOperations Members


%%PageItemTitle%%

GetUserAccounts Method
VaultUserOperations Object : GetUserAccounts Method

Glossary Item Box

Description

Gets available user accounts from the vault.

Syntax

Visual Basic
Public Function GetUserAccounts() As UserAccounts

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserOperations Object | VaultUserOperations Members


%%PageItemTitle%%

GetUserIDByGUID Method
UserGUID
The user's GUID.
VaultUserOperations Object : GetUserIDByGUID Method

Glossary Item Box

Description

Gets the ID of the user with the specified GUID. Returns -1 if a match is not found.

Syntax

Visual Basic
Public Function GetUserIDByGUID( _
   ByVal UserGUID As String _
) As Long

Parameters

UserGUID
The user's GUID.

See Also

VaultUserOperations Object | VaultUserOperations Members


%%PageItemTitle%%

GetUserList Method
VaultUserOperations Object : GetUserList Method

Glossary Item Box

Description

Gets all users as key name pairs.

Syntax

Visual Basic
Public Function GetUserList() As KeyNamePairs

See Also

VaultUserOperations Object | VaultUserOperations Members


%%PageItemTitle%%

ModifyUserAccount Method
User
User account object to be updated.
VaultUserOperations Object : ModifyUserAccount Method

Glossary Item Box

Description

Modifies the user account.

Syntax

Visual Basic
Public Sub ModifyUserAccount( _
   ByVal User As UserAccount _
)

Parameters

User
User account object to be updated.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserOperations Object | VaultUserOperations Members


%%PageItemTitle%%

RemoveUserAccount Method
UserID
The ID of the user account to be removed.
VaultUserOperations Object : RemoveUserAccount Method

Glossary Item Box

Description

Deletes the user account from vault.

Syntax

Visual Basic
Public Sub RemoveUserAccount( _
   ByVal UserID As Long _
)

Parameters

UserID
The ID of the user account to be removed.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserOperations Object | VaultUserOperations Members


%%PageItemTitle%%

UndeleteUserAccountByGUID Method
UserAccountGUIDToUndelete
The GUID of the user to be undeleted.
User
The information to be set for the undeleted user account.
VaultUserOperations Object : UndeleteUserAccountByGUID Method

Glossary Item Box

Description

Attempts to undelete a user with the specified GUID and to set its account information. Does not create new accounts.

Syntax

Visual Basic
Public Function UndeleteUserAccountByGUID( _
   ByVal UserAccountGUIDToUndelete As String, _
   ByVal User As UserAccount _
) As UserAccount

Parameters

UserAccountGUIDToUndelete
The GUID of the user to be undeleted.
User
The information to be set for the undeleted user account.

Remarks

Requires M-Files 19.3.7499.1 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserOperations Object | VaultUserOperations Members


%%PageItemTitle%%

VaultUserOperationsEx Object
Members See Also Send comments

Glossary Item Box

Description

The VaultUserOperationsEx class represents additional user operations.

Public Methods

Public Method AddMemberToUserGroup | Adds a user or a user group to the targeted user group if the item to be added is not yet a member of that group.
Public Method RemoveMemberFromUserGroup | Removes the specified member from the given user group.
Public Method SearchForUserAccount | Retrieves a single user account based on the specified account name.

Remarks

Requires M-Files 19.1.7279.4 or later.

See Also

VaultUserOperationsEx Members


%%PageItemTitle%%

AddMemberToUserGroup Method
UserGroup
The ID of the user group to which to add the specified user or user group.
MemberID
The ID of the user or user group to add.
VaultUserOperationsEx Object : AddMemberToUserGroup Method

Glossary Item Box

Description

Adds a user or a user group to the targeted user group if the item to be added is not yet a member of that group.

Syntax

Visual Basic
Public Sub AddMemberToUserGroup( _
   ByVal UserGroup As Long, _
   ByVal MemberID As Long _
)

Parameters

UserGroup
The ID of the user group to which to add the specified user or user group.
MemberID
The ID of the user or user group to add.

Remarks

Requires M-Files 19.1.7279.4 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserOperationsEx Object | VaultUserOperationsEx Members


%%PageItemTitle%%

RemoveMemberFromUserGroup Method
UserGroup
The ID of the user group from which to remove the specified member.
MemberID
The ID of the user or user group to remove.
VaultUserOperationsEx Object : RemoveMemberFromUserGroup Method

Glossary Item Box

Description

Removes the specified member from the given user group.

Syntax

Visual Basic
Public Sub RemoveMemberFromUserGroup( _
   ByVal UserGroup As Long, _
   ByVal MemberID As Long _
)

Parameters

UserGroup
The ID of the user group from which to remove the specified member.
MemberID
The ID of the user or user group to remove.

Remarks

Requires M-Files 19.1.7279.4 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserOperationsEx Object | VaultUserOperationsEx Members


%%PageItemTitle%%

SearchForUserAccount Method
AccountName
The login account name the search should be based on.
VaultUserOperationsEx Object : SearchForUserAccount Method

Glossary Item Box

Description

Retrieves a single user account based on the specified account name.

Syntax

Visual Basic
Public Function SearchForUserAccount( _
   ByVal AccountName As String _
) As UserAccounts

Parameters

AccountName
The login account name the search should be based on.

Remarks

Requires M-Files 19.1.7279.4 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultUserOperationsEx Object | VaultUserOperationsEx Members


%%PageItemTitle%%

VaultUserSettingOperations Object
Members See Also Send comments

Glossary Item Box

Description

The VaultUserSettingOperations class represents the user setting operations available for the current user.

Public Methods

Public Method ChangeVaultLanguage | Changes the vault language for the current user.
Public Method GetSubstituteUsers | Gets the substitute users of the current user.
Public Method GetSubstituteUsersOfUser | Gets the substitute users of a specific user.
Public Method GetUsersBySubstituteUser | Gets the users for whom the specific user is a substitute.
Public Method GetVaultLanguage | Gets the vault language for the current user.
Public Method GetVaultLanguageCode | Gets the vault language code for the current user.
Public Method SetSubstituteUsers | Sets the substitute users of the current user.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultUserSettingOperations Members


%%PageItemTitle%%

ChangeVaultLanguage Method
Language
The language ID.
VaultUserSettingOperations Object : ChangeVaultLanguage Method

Glossary Item Box

Description

Changes the vault language for the current user.

Syntax

Visual Basic
Public Sub ChangeVaultLanguage( _
   ByVal Language As Integer _
)

Parameters

Language
The language ID.

See Also

VaultUserSettingOperations Object | VaultUserSettingOperations Members


%%PageItemTitle%%

GetSubstituteUsers Method
VaultUserSettingOperations Object : GetSubstituteUsers Method

Glossary Item Box

Description

Gets the substitute users of the current user.

Syntax

Visual Basic
Public Function GetSubstituteUsers() As UserOrUserGroupIDs

See Also

VaultUserSettingOperations Object | VaultUserSettingOperations Members


%%PageItemTitle%%

GetSubstituteUsersOfUser Method
UserID
The ID of the user the substitutes of whom to retrieve.
VaultUserSettingOperations Object : GetSubstituteUsersOfUser Method

Glossary Item Box

Description

Gets the substitute users of a specific user.

Syntax

Visual Basic
Public Function GetSubstituteUsersOfUser( _
   ByVal UserID As Long _
) As UserOrUserGroupIDs

Parameters

UserID
The ID of the user the substitutes of whom to retrieve.

Remarks

Requires M-Files build 12.0.6550.8 or later.

See Also

VaultUserSettingOperations Object | VaultUserSettingOperations Members


%%PageItemTitle%%

GetUsersBySubstituteUser Method
UserID
The ID of the user who is substituting the other users a list of which is to be retrieved.
VaultUserSettingOperations Object : GetUsersBySubstituteUser Method

Glossary Item Box

Description

Gets the users for whom the specific user is a substitute.

Syntax

Visual Basic
Public Function GetUsersBySubstituteUser( _
   ByVal UserID As Long _
) As UserOrUserGroupIDs

Parameters

UserID
The ID of the user who is substituting the other users a list of which is to be retrieved.

Remarks

Requires M-Files build 12.0.6550.8 or later.

See Also

VaultUserSettingOperations Object | VaultUserSettingOperations Members


%%PageItemTitle%%

GetVaultLanguage Method
VaultUserSettingOperations Object : GetVaultLanguage Method

Glossary Item Box

Description

Gets the vault language for the current user.

Syntax

Visual Basic
Public Function GetVaultLanguage() As Integer

See Also

VaultUserSettingOperations Object | VaultUserSettingOperations Members


%%PageItemTitle%%

GetVaultLanguageCode Method
VaultUserSettingOperations Object : GetVaultLanguageCode Method

Glossary Item Box

Description

Gets the vault language code for the current user.

Syntax

Visual Basic
Public Function GetVaultLanguageCode() As String

See Also

VaultUserSettingOperations Object | VaultUserSettingOperations Members


%%PageItemTitle%%

SetSubstituteUsers Method
UserOrUserGroupIDs
The user or user group IDs representing the substitute user of the current user.
VaultUserSettingOperations Object : SetSubstituteUsers Method

Glossary Item Box

Description

Sets the substitute users of the current user.

Syntax

Visual Basic
Public Sub SetSubstituteUsers( _
   ByVal UserOrUserGroupIDs As UserOrUserGroupIDs _
)

Parameters

UserOrUserGroupIDs
The user or user group IDs representing the substitute user of the current user.

See Also

VaultUserSettingOperations Object | VaultUserSettingOperations Members


%%PageItemTitle%%

VaultValueListItemOperations Object
Members See Also Example Send comments

Glossary Item Box

Description

The VaultValueListItemOperations class represents the available value list item operations.

Public Methods

Public Method AddValueListItem | Adds a new value list item to a value list.
Public Method ChangeAutomaticPermissionsToACL | Changes the automatic permissions for the specified value list item. The specified automatic permissions will be applied to an object when the user selects this value list item in the metadata card of the object.
Public Method ChangeAutomaticPermissionsToACLEx | Changes the automatic permissions for the specified value list item.
Public Method ChangeAutomaticPermissionsToItemsOwnPermissions | Changes the automatic permissions for the specified value list item to match those of its own permissions. The specified automatic permissions will be applied to an object when the user selects this value list item in the metadata card of the object.
Public Method ChangeAutomaticPermissionsToItemsOwnPermissionsEx | Changes the automatic permissions for the specified value list item to match those of its own permissions.
Public Method ChangeAutomaticPermissionsToNamedACL | Changes the automatic permissions for the specified value list item. The specified automatic permissions will be applied to an object when the user selects this value list item in the metadata card of the object.
Public Method ChangeAutomaticPermissionsToNamedACLEx | Changes the automatic permissions for the specified value list item.
Public Method ChangePermissionsToACL | Changes the permissions for the specified value list item.
Public Method ChangePermissionsToACLEx | Changes the permissions for the specified value list item.
Public Method ChangePermissionsToNamedACL | Changes the permissions for the specified value list item.
Public Method ChangePermissionsToNamedACLEx | Changes the permissions for the specified value list item.
Public Method ClearAutomaticPermissions | Clears the automatic permissions from the specified value list item. This prevents any permissions from being set to an object as a result of this value list item being selected.
Public Method ClearAutomaticPermissionsEx | Clears the automatic permissions of the specified value list item.
Public Method GetReferencedValueListItemsInIdOrder | Gets value list items that are referenced by one or more documents (possibly limiting the set of documents with conditions) in ID order.
Public Method GetValueListItemByDisplayID | Gets a value list item from the specified value list, using the display ID (external ID) of the item.
Public Method GetValueListItemByDisplayIDEx | Gets a value list item from the specified value list, using the display ID (external ID) of the item.
Public Method GetValueListItemByGUID | Gets a value list item from the specified value list by using the GUID of the item.
Public Method GetValueListItemByID | Gets a value list item from the specified value list, using the internal ID of the item.
Public Method GetValueListItemByIDEx | Gets a value list item from the specified value list, using the internal ID of the item.
Public Method GetValueListItemByIDEx2 | Gets a value list item from the specified value list, using the internal ID of the item.
Public Method GetValueListItemIDByGUID | Gets the ID of the value list item with the specified GUID. Returns -1 if a match is not found.
Public Method GetValueListItems | Gets the value list items of a value list.
Public Method GetValueListItemsEx | Gets the value list items of a value list.
Public Method GetValueListItemsEx2 | Gets the value list items of a value list.
Public Method GetValueListItemsInIdOrder | Gets the items of a value list ordered by ID.
Public Method GetValueListItemsWithPermissions | Gets the value list items of a value list.
Public Method RemoveValueListItem | Deletes a value list item.
Public Method RemoveValueListItemEx | Deletes a value list item.
Public Method SearchForValueListItemsEx | Searches for value list items in the specified value list
Public Method SearchForValueListItemsEx2 | Searches for value list items in the specified value list
Public Method SearchForValueListItemsWithPermissions | Searches for value list items in the specified value list
Public Method UndeleteValueListItem | Undeletes a previously deleted value list item.
Public Method UndeleteValueListItemEx | Undeletes a previously deleted value list item.
Public Method UpdateValueListItem | Updates the value list item.

Remarks

This method group interface can be accessed via the Vault object.

Example

Searching for value list items ( ) Copy Code
' Set the search conditions for the value list item.
Dim oScValueListItem As New MFilesAPI.SearchCondition
oScValueListItem.Expression.SetValueListItemExpression( _
        MFilesAPI.MFValueListItemPropertyDef.MFValueListItemPropertyDefID, _
        MFilesAPI.MFParentChildBehavior.MFParentChildBehaviorNone)
oScValueListItem.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeEqual
oScValueListItem.TypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeLookup, iItem)
Dim arrSearchConditions As New MFilesAPI.SearchConditions
arrSearchConditions.Add(-1, oScValueListItem)

' Search for the value list item.
Dim oResults As MFilesAPI.ValueListItemSearchResults = _
    GetVault().ValueListItemOperations.SearchForValueListItemsEx(iValueList, arrSearchConditions)
If oResults.Count > 0 Then

    ' Items found.
    ' ...

Else

    ' Items not found.
    ' ...

End If

See Also

VaultValueListItemOperations Members


%%PageItemTitle%%

AddValueListItem Method
ValueList
The value list ID of the target value list.
ValueListItem
The value list item to be added.
AdministrativeOperation
When True allows adding new values to value lists where normal users are not allowed to create new values. This option requires that the user has administrative rights in the vault.
VaultValueListItemOperations Object : AddValueListItem Method

Glossary Item Box

Description

Adds a new value list item to a value list.

Syntax

Visual Basic
Public Function AddValueListItem( _
   ByVal ValueList As Long, _
   ByVal ValueListItem As ValueListItem, _
   Optional ByVal AdministrativeOperation As Boolean = False _
) As ValueListItem

Parameters

ValueList
The value list ID of the target value list.
ValueListItem
The value list item to be added.
AdministrativeOperation
When True allows adding new values to value lists where normal users are not allowed to create new values. This option requires that the user has administrative rights in the vault.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

ChangeAutomaticPermissionsToACL Method
ValueList
The value list to look from.
ValueListItemID
The ID of the value list item to apply the changes to.
AccessControlList
See NamedACL on AutomaticPermissions.
NameForAutomaticPermissions
The name for the automatic permissions.
CanDeactivate

True if the automatic component can be bypassed by the user.

See CanDeactivate on AutomaticPermissions.

AutomaticPermissionsOperationOptions
Operation flags.
VaultValueListItemOperations Object : ChangeAutomaticPermissionsToACL Method

Glossary Item Box

Description

Changes the automatic permissions for the specified value list item. The specified automatic permissions will be applied to an object when the user selects this value list item in the metadata card of the object.

Syntax

Visual Basic
Public Sub ChangeAutomaticPermissionsToACL( _
   ByVal ValueList As Long, _
   ByVal ValueListItemID As Long, _
   ByVal AccessControlList As AccessControlList, _
   ByVal NameForAutomaticPermissions As String, _
   Optional ByVal CanDeactivate As Boolean = True, _
   Optional ByVal AutomaticPermissionsOperationOptions As MFAutomaticPermissionsOperationOptions = MFAutomaticPermissionsOperationOptionsNone _
)

Parameters

ValueList
The value list to look from.
ValueListItemID
The ID of the value list item to apply the changes to.
AccessControlList
See NamedACL on AutomaticPermissions.
NameForAutomaticPermissions
The name for the automatic permissions.
CanDeactivate

True if the automatic component can be bypassed by the user.

See CanDeactivate on AutomaticPermissions.

AutomaticPermissionsOperationOptions
Value | Description
MFAutomaticPermissionsOperationOptionsForceActive | The changed automatic permission components are forced active.
MFAutomaticPermissionsOperationOptionsNone | None
Operation flags.

Remarks

This method is available only if M-Files API is used in the server interface mode.

This is an alternative to using AutomaticPermissionsForObject property on ValueListItem.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

ChangeAutomaticPermissionsToACLEx Method
ObjID
The ID of the value list item to apply the changes to.
AccessControlList
The access control list to be applied.
NameForAutomaticPermissions
The name for the automatic permissions.
CanDeactivate

True if the automatic component can be bypassed by the user.

See CanDeactivate on AutomaticPermissions.

AutomaticPermissionsOperationOptions
Operation flags.
VaultValueListItemOperations Object : ChangeAutomaticPermissionsToACLEx Method

Glossary Item Box

Description

Changes the automatic permissions for the specified value list item.

Syntax

Visual Basic
Public Sub ChangeAutomaticPermissionsToACLEx( _
   ByVal ObjID As ObjID, _
   ByVal AccessControlList As AccessControlList, _
   ByVal NameForAutomaticPermissions As String, _
   Optional ByVal CanDeactivate As Boolean = True, _
   Optional ByVal AutomaticPermissionsOperationOptions As MFAutomaticPermissionsOperationOptions = MFAutomaticPermissionsOperationOptionsNone _
)

Parameters

ObjID
The ID of the value list item to apply the changes to.
AccessControlList
The access control list to be applied.
NameForAutomaticPermissions
The name for the automatic permissions.
CanDeactivate

True if the automatic component can be bypassed by the user.

See CanDeactivate on AutomaticPermissions.

AutomaticPermissionsOperationOptions
Value | Description
MFAutomaticPermissionsOperationOptionsForceActive | The changed automatic permission components are forced active.
MFAutomaticPermissionsOperationOptionsNone | None
Operation flags.

Remarks

This method is available only if M-Files API is used in the server interface mode.

The permissions are applied to an object when this value list item is selected on the metadata card of the object.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

ChangeAutomaticPermissionsToItemsOwnPermissions Method
ValueList
The value list to look from.
ValueListItemID
The ID of the value list item to apply the changes to.
CanDeactivate

True if the automatic component can be bypassed by the user.

See CanDeactivate on AutomaticPermissions.

AutomaticPermissionsOperationOptions
Operation flags.
VaultValueListItemOperations Object : ChangeAutomaticPermissionsToItemsOwnPermissions Method

Glossary Item Box

Description

Changes the automatic permissions for the specified value list item to match those of its own permissions. The specified automatic permissions will be applied to an object when the user selects this value list item in the metadata card of the object.

Syntax

Visual Basic
Public Sub ChangeAutomaticPermissionsToItemsOwnPermissions( _
   ByVal ValueList As Long, _
   ByVal ValueListItemID As Long, _
   Optional ByVal CanDeactivate As Boolean = True, _
   Optional ByVal AutomaticPermissionsOperationOptions As MFAutomaticPermissionsOperationOptions = MFAutomaticPermissionsOperationOptionsNone _
)

Parameters

ValueList
The value list to look from.
ValueListItemID
The ID of the value list item to apply the changes to.
CanDeactivate

True if the automatic component can be bypassed by the user.

See CanDeactivate on AutomaticPermissions.

AutomaticPermissionsOperationOptions
Value | Description
MFAutomaticPermissionsOperationOptionsForceActive | The changed automatic permission components are forced active.
MFAutomaticPermissionsOperationOptionsNone | None
Operation flags.

Remarks

This method is available only if M-Files API is used in the server interface mode.

This is an alternative to using AutomaticPermissionsForObject property on ValueListItem.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

ChangeAutomaticPermissionsToItemsOwnPermissionsEx Method
ObjID
The ID of the value list item to apply the changes to.
CanDeactivate

True if the automatic component can be bypassed by the user.

See CanDeactivate on AutomaticPermissions.

AutomaticPermissionsOperationOptions
VaultValueListItemOperations Object : ChangeAutomaticPermissionsToItemsOwnPermissionsEx Method

Glossary Item Box

Description

Changes the automatic permissions for the specified value list item to match those of its own permissions.

Syntax

Visual Basic
Public Sub ChangeAutomaticPermissionsToItemsOwnPermissionsEx( _
   ByVal ObjID As ObjID, _
   Optional ByVal CanDeactivate As Boolean = True, _
   Optional ByVal AutomaticPermissionsOperationOptions As MFAutomaticPermissionsOperationOptions = MFAutomaticPermissionsOperationOptionsNone _
)

Parameters

ObjID
The ID of the value list item to apply the changes to.
CanDeactivate

True if the automatic component can be bypassed by the user.

See CanDeactivate on AutomaticPermissions.

AutomaticPermissionsOperationOptions
Value | Description
MFAutomaticPermissionsOperationOptionsForceActive | The changed automatic permission components are forced active.
MFAutomaticPermissionsOperationOptionsNone | None

Remarks

This method is available only if M-Files API is used in the server interface mode.

The permissions are applied to an object when this value list item is selected on the metadata card of the object.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

ChangeAutomaticPermissionsToNamedACL Method
ValueList
The ID of the value list.
ValueListItemID
The ID of the item to apply the changes to.
NamedACL

The access control list to be applied.

See NamedACL on AutomaticPermissions.

CanDeactivate

True if the automatic component can be bypassed by the user.

See CanDeactivate on AutomaticPermissions.

AutomaticPermissionsOperationOptions
Operation flags.
VaultValueListItemOperations Object : ChangeAutomaticPermissionsToNamedACL Method

Glossary Item Box

Description

Changes the automatic permissions for the specified value list item. The specified automatic permissions will be applied to an object when the user selects this value list item in the metadata card of the object.

Syntax

Visual Basic
Public Sub ChangeAutomaticPermissionsToNamedACL( _
   ByVal ValueList As Long, _
   ByVal ValueListItemID As Long, _
   ByVal NamedACL As Long, _
   Optional ByVal CanDeactivate As Boolean = True, _
   Optional ByVal AutomaticPermissionsOperationOptions As MFAutomaticPermissionsOperationOptions = MFAutomaticPermissionsOperationOptionsNone _
)

Parameters

ValueList
The ID of the value list.
ValueListItemID
The ID of the item to apply the changes to.
NamedACL

The access control list to be applied.

See NamedACL on AutomaticPermissions.

CanDeactivate

True if the automatic component can be bypassed by the user.

See CanDeactivate on AutomaticPermissions.

AutomaticPermissionsOperationOptions
Value | Description
MFAutomaticPermissionsOperationOptionsForceActive | The changed automatic permission components are forced active.
MFAutomaticPermissionsOperationOptionsNone | None
Operation flags.

Remarks

This method is available only if M-Files API is used in the server interface mode.

This is an alternative to using AutomaticPermissionsForObject property on ValueListItem.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

ChangeAutomaticPermissionsToNamedACLEx Method
ObjID
The ID of the value list item to apply the changes to.
NamedACL
The named access control list to be applied.
CanDeactivate

True if the automatic component can be bypassed by the user.

See CanDeactivate on AutomaticPermissions.

AutomaticPermissionsOperationOptions
Operation flags.
VaultValueListItemOperations Object : ChangeAutomaticPermissionsToNamedACLEx Method

Glossary Item Box

Description

Changes the automatic permissions for the specified value list item.

Syntax

Visual Basic
Public Sub ChangeAutomaticPermissionsToNamedACLEx( _
   ByVal ObjID As ObjID, _
   ByVal NamedACL As Long, _
   Optional ByVal CanDeactivate As Boolean = True, _
   Optional ByVal AutomaticPermissionsOperationOptions As MFAutomaticPermissionsOperationOptions = MFAutomaticPermissionsOperationOptionsNone _
)

Parameters

ObjID
The ID of the value list item to apply the changes to.
NamedACL
The named access control list to be applied.
CanDeactivate

True if the automatic component can be bypassed by the user.

See CanDeactivate on AutomaticPermissions.

AutomaticPermissionsOperationOptions
Value | Description
MFAutomaticPermissionsOperationOptionsForceActive | The changed automatic permission components are forced active.
MFAutomaticPermissionsOperationOptionsNone | None
Operation flags.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

ChangePermissionsToACL Method
ValueList
The value list ID of the target value list item.
ValueListItemID
The value list item ID of the target value list item.
AccessControlList
The access control list to be used as new permissions for the specified value list item.
VaultValueListItemOperations Object : ChangePermissionsToACL Method

Glossary Item Box

Description

Changes the permissions for the specified value list item.

Syntax

Visual Basic
Public Sub ChangePermissionsToACL( _
   ByVal ValueList As Long, _
   ByVal ValueListItemID As Long, _
   ByVal AccessControlList As AccessControlList _
)

Parameters

ValueList
The value list ID of the target value list item.
ValueListItemID
The value list item ID of the target value list item.
AccessControlList
The access control list to be used as new permissions for the specified value list item.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

ChangePermissionsToACLEx Method
ObjID
The ID of the value list item to apply the changes to.
AccessControlList
The access control list to be applied.
VaultValueListItemOperations Object : ChangePermissionsToACLEx Method

Glossary Item Box

Description

Changes the permissions for the specified value list item.

Syntax

Visual Basic
Public Sub ChangePermissionsToACLEx( _
   ByVal ObjID As ObjID, _
   ByVal AccessControlList As AccessControlList _
)

Parameters

ObjID
The ID of the value list item to apply the changes to.
AccessControlList
The access control list to be applied.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

ChangePermissionsToNamedACL Method
ValueList
The value list ID of the target value list item.
ValueListItemID
The value list item ID of the target value list item.
NamedACL
The ID of the named ACL to be used as new permissions for the specified value list item.
VaultValueListItemOperations Object : ChangePermissionsToNamedACL Method

Glossary Item Box

Description

Changes the permissions for the specified value list item.

Syntax

Visual Basic
Public Sub ChangePermissionsToNamedACL( _
   ByVal ValueList As Long, _
   ByVal ValueListItemID As Long, _
   ByVal NamedACL As Long _
)

Parameters

ValueList
The value list ID of the target value list item.
ValueListItemID
The value list item ID of the target value list item.
NamedACL
The ID of the named ACL to be used as new permissions for the specified value list item.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

ChangePermissionsToNamedACLEx Method
ObjID
The ID of the value list item to apply the changes to.
NamedACL
The named access control list to be applied.
VaultValueListItemOperations Object : ChangePermissionsToNamedACLEx Method

Glossary Item Box

Description

Changes the permissions for the specified value list item.

Syntax

Visual Basic
Public Sub ChangePermissionsToNamedACLEx( _
   ByVal ObjID As ObjID, _
   ByVal NamedACL As Long _
)

Parameters

ObjID
The ID of the value list item to apply the changes to.
NamedACL
The named access control list to be applied.

Remarks

The permissions are applied to an object when this value list item is selected on the metadata card of the object.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

ClearAutomaticPermissions Method
ValueList
The value list to look from.
ValueListItemID
The ID of the value list item to apply the changes to.
VaultValueListItemOperations Object : ClearAutomaticPermissions Method

Glossary Item Box

Description

Clears the automatic permissions from the specified value list item. This prevents any permissions from being set to an object as a result of this value list item being selected.

Syntax

Visual Basic
Public Sub ClearAutomaticPermissions( _
   ByVal ValueList As Long, _
   ByVal ValueListItemID As Long _
)

Parameters

ValueList
The value list to look from.
ValueListItemID
The ID of the value list item to apply the changes to.

Remarks

This method is available only if M-Files API is used in the server interface mode.

This is an alternative to using AutomaticPermissionsForObject property on ValueListItem.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

ClearAutomaticPermissionsEx Method
ObjID
The ID of the value list item to apply the changes to.
VaultValueListItemOperations Object : ClearAutomaticPermissionsEx Method

Glossary Item Box

Description

Clears the automatic permissions of the specified value list item.

Syntax

Visual Basic
Public Sub ClearAutomaticPermissionsEx( _
   ByVal ObjID As ObjID _
)

Parameters

ObjID
The ID of the value list item to apply the changes to.

Remarks

This method is available only if M-Files API is used in the server interface mode.

This prevents any permissions from being applied to an object as a result of this value list item being selected.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetReferencedValueListItemsInIdOrder Method
ValueList
The ID of the value list the items of which to get.
LastReceivedItemID
The last value list item ID received by the client. Set to 0 for the first call.
BatchSize
The maximum number of results. Set to 0 for no limit.
SearchConditions
The object search conditions.
VaultValueListItemOperations Object : GetReferencedValueListItemsInIdOrder Method

Glossary Item Box

Description

Gets value list items that are referenced by one or more documents (possibly limiting the set of documents with conditions) in ID order.

Syntax

Visual Basic
Public Function GetReferencedValueListItemsInIdOrder( _
   ByVal ValueList As Long, _
   ByVal LastReceivedItemID As ULong, _
   ByVal BatchSize As ULong, _
   ByVal SearchConditions As SearchConditions _
) As ValueListItems

Parameters

ValueList
The ID of the value list the items of which to get.
LastReceivedItemID
The last value list item ID received by the client. Set to 0 for the first call.
BatchSize
The maximum number of results. Set to 0 for no limit.
SearchConditions
The object search conditions.

Remarks

Requires M-Files 18.10.6895.1 or later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetValueListItemByDisplayID Method
ValueList
The value list ID of the item to retrieve.
ValueListItemDisplayID
The external value list item ID of the item to retrieve.
VaultValueListItemOperations Object : GetValueListItemByDisplayID Method

Glossary Item Box

Description

Gets a value list item from the specified value list, using the display ID (external ID) of the item.

Syntax

Visual Basic
Public Function GetValueListItemByDisplayID( _
   ByVal ValueList As Long, _
   ByVal ValueListItemDisplayID As String _
) As ValueListItem

Parameters

ValueList
The value list ID of the item to retrieve.
ValueListItemDisplayID
The external value list item ID of the item to retrieve.

Remarks

When searching for real objects (objects with an actual object type) via this value list, consider using VaultObjectOperations methods instead.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetValueListItemByDisplayIDEx Method
ValueList
ValueListItemDisplayID
ReplaceCurrentUserWithCallersIdentity
When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.
VaultValueListItemOperations Object : GetValueListItemByDisplayIDEx Method

Glossary Item Box

Description

Gets a value list item from the specified value list, using the display ID (external ID) of the item.

Syntax

Visual Basic
Public Function GetValueListItemByDisplayIDEx( _
   ByVal ValueList As Long, _
   ByVal ValueListItemDisplayID As String, _
   Optional ByVal ReplaceCurrentUserWithCallersIdentity As Boolean = True _
) As ValueListItem

Parameters

ValueList
ValueListItemDisplayID
ReplaceCurrentUserWithCallersIdentity
When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetValueListItemByGUID Method
ValueList
The value list.
ItemGUID
The GUID of the item.
AllowDeletedItems
True if deleted items are included in the search. If false, only existing (not deleted) items are searched.
ReplaceCurrentUserWithCallersIdentity
When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.
VaultValueListItemOperations Object : GetValueListItemByGUID Method

Glossary Item Box

Description

Gets a value list item from the specified value list by using the GUID of the item.

Syntax

Visual Basic
Public Function GetValueListItemByGUID( _
   ByVal ValueList As Long, _
   ByVal ItemGUID As String, _
   Optional ByVal AllowDeletedItems As Boolean = False, _
   Optional ByVal ReplaceCurrentUserWithCallersIdentity As Boolean = True _
) As ValueListItem

Parameters

ValueList
The value list.
ItemGUID
The GUID of the item.
AllowDeletedItems
True if deleted items are included in the search. If false, only existing (not deleted) items are searched.
ReplaceCurrentUserWithCallersIdentity
When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetValueListItemByID Method
ValueList
The value list ID of the item to retrieve.
ValueListItemID
The internal value list item ID of the item to retrieve.
VaultValueListItemOperations Object : GetValueListItemByID Method

Glossary Item Box

Description

Gets a value list item from the specified value list, using the internal ID of the item.

Syntax

Visual Basic
Public Function GetValueListItemByID( _
   ByVal ValueList As Long, _
   ByVal ValueListItemID As Long _
) As ValueListItem

Parameters

ValueList
The value list ID of the item to retrieve.
ValueListItemID
The internal value list item ID of the item to retrieve.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetValueListItemByIDEx Method
ValueList
The value list to look the item from.
ValueListItemID
The ID of the value list item to look for.
ReplaceCurrentUserWithCallersIdentity
True if the server should replace the "current user" pseudo identity with the caller's real identity. When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.
VaultValueListItemOperations Object : GetValueListItemByIDEx Method

Glossary Item Box

Description

Gets a value list item from the specified value list, using the internal ID of the item.

Syntax

Visual Basic
Public Function GetValueListItemByIDEx( _
   ByVal ValueList As Long, _
   ByVal ValueListItemID As Long, _
   Optional ByVal ReplaceCurrentUserWithCallersIdentity As Boolean = True _
) As ValueListItem

Parameters

ValueList
The value list to look the item from.
ValueListItemID
The ID of the value list item to look for.
ReplaceCurrentUserWithCallersIdentity
True if the server should replace the "current user" pseudo identity with the caller's real identity. When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetValueListItemByIDEx2 Method
ObjID
The ID of the value list item to look for.
ReplaceCurrentUserWithCallersIdentity
True if the server should replace the "current user" pseudo identity with the caller's real identity. When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.
VaultValueListItemOperations Object : GetValueListItemByIDEx2 Method

Glossary Item Box

Description

Gets a value list item from the specified value list, using the internal ID of the item.

Syntax

Visual Basic
Public Function GetValueListItemByIDEx2( _
   ByVal ObjID As ObjID, _
   Optional ByVal ReplaceCurrentUserWithCallersIdentity As Boolean = True _
) As ValueListItem

Parameters

ObjID
The ID of the value list item to look for.
ReplaceCurrentUserWithCallersIdentity
True if the server should replace the "current user" pseudo identity with the caller's real identity. When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetValueListItemIDByGUID Method
ValueList
The value list.
ItemGUID
The GUID of the item.
AllowDeletedItems
True if deleted items are included in the search. If false, only existing (not deleted) items are searched.
VaultValueListItemOperations Object : GetValueListItemIDByGUID Method

Glossary Item Box

Description

Gets the ID of the value list item with the specified GUID. Returns -1 if a match is not found.

Syntax

Visual Basic
Public Function GetValueListItemIDByGUID( _
   ByVal ValueList As Long, _
   ByVal ItemGUID As String, _
   Optional ByVal AllowDeletedItems As Boolean = False _
) As Long

Parameters

ValueList
The value list.
ItemGUID
The GUID of the item.
AllowDeletedItems
True if deleted items are included in the search. If false, only existing (not deleted) items are searched.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetValueListItems Method
ValueList
The value list ID of the items to retrieve.
UpdateFromServer
RefreshTypeIfExternalValueList
VaultValueListItemOperations Object : GetValueListItems Method

Glossary Item Box

Description

Gets the value list items of a value list.

Syntax

Visual Basic
Public Function GetValueListItems( _
   ByVal ValueList As Long, _
   Optional ByVal UpdateFromServer As Boolean = False, _
   Optional ByVal RefreshTypeIfExternalValueList As MFExternalDBRefreshType = MFExternalDBRefreshTypeNone _
) As ValueListItems

Parameters

ValueList
The value list ID of the items to retrieve.
UpdateFromServer
RefreshTypeIfExternalValueList
Value | Description
MFExternalDBRefreshTypeFull | The full refresh updates all the changes. This operation can take several minutes.
MFExternalDBRefreshTypeNone | No refresh is performed.
MFExternalDBRefreshTypeQuick | The quick refresh searches for new items and imports them to M-Files.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetValueListItemsEx Method
ValueList
UpdateFromServer
RefreshTypeIfExternalValueList
ReplaceCurrentUserWithCallersIdentity
When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.
VaultValueListItemOperations Object : GetValueListItemsEx Method

Glossary Item Box

Description

Gets the value list items of a value list.

Syntax

Visual Basic
Public Function GetValueListItemsEx( _
   ByVal ValueList As Long, _
   Optional ByVal UpdateFromServer As Boolean = False, _
   Optional ByVal RefreshTypeIfExternalValueList As MFExternalDBRefreshType = MFExternalDBRefreshTypeNone, _
   Optional ByVal ReplaceCurrentUserWithCallersIdentity As Boolean = True _
) As ValueListItems

Parameters

ValueList
UpdateFromServer
RefreshTypeIfExternalValueList
Value | Description
MFExternalDBRefreshTypeFull | The full refresh updates all the changes. This operation can take several minutes.
MFExternalDBRefreshTypeNone | No refresh is performed.
MFExternalDBRefreshTypeQuick | The quick refresh searches for new items and imports them to M-Files.
ReplaceCurrentUserWithCallersIdentity
When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetValueListItemsEx2 Method
ValueList
UpdateFromServer
RefreshTypeIfExternalValueList
ReplaceCurrentUserWithCallersIdentity
When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.
PropertyDef
Specifies the property definition the filter of which should be applied to the list (-1 for none).
VaultValueListItemOperations Object : GetValueListItemsEx2 Method

Glossary Item Box

Description

Gets the value list items of a value list.

Syntax

Visual Basic
Public Function GetValueListItemsEx2( _
   ByVal ValueList As Long, _
   Optional ByVal UpdateFromServer As Boolean = False, _
   Optional ByVal RefreshTypeIfExternalValueList As MFExternalDBRefreshType = MFExternalDBRefreshTypeNone, _
   Optional ByVal ReplaceCurrentUserWithCallersIdentity As Boolean = True, _
   Optional ByVal PropertyDef As Long = -1 _
) As ValueListItems

Parameters

ValueList
UpdateFromServer
RefreshTypeIfExternalValueList
Value | Description
MFExternalDBRefreshTypeFull | The full refresh updates all the changes. This operation can take several minutes.
MFExternalDBRefreshTypeNone | No refresh is performed.
MFExternalDBRefreshTypeQuick | The quick refresh searches for new items and imports them to M-Files.
ReplaceCurrentUserWithCallersIdentity
When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.
PropertyDef
Specifies the property definition the filter of which should be applied to the list (-1 for none).

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetValueListItemsInIdOrder Method
ValueList
The ID of the value list.
LastReceivedItemID
The last value list item ID received by the client. Use "0" for the first call.
BatchSize
The maximum number of results to search for. The value must be greater than zero (0).
VaultValueListItemOperations Object : GetValueListItemsInIdOrder Method

Glossary Item Box

Description

Gets the items of a value list ordered by ID.

Syntax

Visual Basic
Public Function GetValueListItemsInIdOrder( _
   ByVal ValueList As Long, _
   ByVal LastReceivedItemID As ULong, _
   ByVal BatchSize As ULong _
) As ValueListItems

Parameters

ValueList
The ID of the value list.
LastReceivedItemID
The last value list item ID received by the client. Use "0" for the first call.
BatchSize
The maximum number of results to search for. The value must be greater than zero (0).

Return Type

The method can only be used in the client mode.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

GetValueListItemsWithPermissions Method
ValueList
UpdateFromServer
RefreshTypeIfExternalValueList
ReplaceCurrentUserWithCallersIdentity
PropertyDef
VaultValueListItemOperations Object : GetValueListItemsWithPermissions Method

Glossary Item Box

Description

Gets the value list items of a value list.

Syntax

Visual Basic
Public Function GetValueListItemsWithPermissions( _
   ByVal ValueList As Long, _
   Optional ByVal UpdateFromServer As Boolean = False, _
   Optional ByVal RefreshTypeIfExternalValueList As MFExternalDBRefreshType = MFExternalDBRefreshTypeNone, _
   Optional ByVal ReplaceCurrentUserWithCallersIdentity As Boolean = True, _
   Optional ByVal PropertyDef As Long = -1 _
) As ValueListItemsWithPermissions

Parameters

ValueList
UpdateFromServer
RefreshTypeIfExternalValueList
Value | Description
MFExternalDBRefreshTypeFull | The full refresh updates all the changes. This operation can take several minutes.
MFExternalDBRefreshTypeNone | No refresh is performed.
MFExternalDBRefreshTypeQuick | The quick refresh searches for new items and imports them to M-Files.
ReplaceCurrentUserWithCallersIdentity
PropertyDef

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

RemoveValueListItem Method
ValueList
The value list ID of the value list item to remove.
Item
The value list item ID of the value list item to be removed.
VaultValueListItemOperations Object : RemoveValueListItem Method

Glossary Item Box

Description

Deletes a value list item.

Syntax

Visual Basic
Public Sub RemoveValueListItem( _
   ByVal ValueList As Long, _
   ByVal Item As Long _
)

Parameters

ValueList
The value list ID of the value list item to remove.
Item
The value list item ID of the value list item to be removed.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

RemoveValueListItemEx Method
ObjID
The ID of the value list item to remove.
VaultValueListItemOperations Object : RemoveValueListItemEx Method

Glossary Item Box

Description

Deletes a value list item.

Syntax

Visual Basic
Public Sub RemoveValueListItemEx( _
   ByVal ObjID As ObjID _
)

Parameters

ObjID
The ID of the value list item to remove.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

SearchForValueListItemsEx Method
ValueList
The value list the items of which to search for.
SearchConditions
The search conditions to be used.
UpdateFromServer
If this is set to "true", the search operation is always carried out on the server-side.
RefreshTypeIfExternalValueList
Specifies how, if at all, external value lists are updated for this operation.
ReplaceCurrentUserWithCallersIdentity
When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.
VaultValueListItemOperations Object : SearchForValueListItemsEx Method

Glossary Item Box

Description

Searches for value list items in the specified value list

Syntax

Visual Basic
Public Function SearchForValueListItemsEx( _
   ByVal ValueList As Long, _
   ByVal SearchConditions As SearchConditions, _
   Optional ByVal UpdateFromServer As Boolean = False, _
   Optional ByVal RefreshTypeIfExternalValueList As MFExternalDBRefreshType = MFExternalDBRefreshTypeNone, _
   Optional ByVal ReplaceCurrentUserWithCallersIdentity As Boolean = True _
) As ValueListItemSearchResults

Parameters

ValueList
The value list the items of which to search for.
SearchConditions
The search conditions to be used.
UpdateFromServer
If this is set to "true", the search operation is always carried out on the server-side.
RefreshTypeIfExternalValueList
Value | Description
MFExternalDBRefreshTypeFull | The full refresh updates all the changes. This operation can take several minutes.
MFExternalDBRefreshTypeNone | No refresh is performed.
MFExternalDBRefreshTypeQuick | The quick refresh searches for new items and imports them to M-Files.
Specifies how, if at all, external value lists are updated for this operation.
ReplaceCurrentUserWithCallersIdentity
When using M-Files API in client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

SearchForValueListItemsEx2 Method
ValueList
The value list the items of which to search for.
SearchConditions
The search conditions to be used.
UpdateFromServer
If this is set to "true", the search operation is always carried out on the server-side.
RefreshTypeIfExternalValueList
Specifies how, if at all, external value lists are updated for this operation.
ReplaceCurrentUserWithCallersIdentity
When using M-Files API in the client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.
PropertyDef
Specifies the property definition the filter of which should be applied to the list (-1 for none).
MaxResults

The maximum number of results to return. By default, no more than 5,000 results are allowed. You can, however, allow more results vault-specifically by changing the value of the Value List Item Count Limit setting via the advanced vault settings:

  1. Open M-Files Admin.
  2. Select a server and a document vault that you want the setting to affect via the left-side tree view.
  3. Select the Configurations node.
  4. Expand Advanced Vault Settings and then select Configuration.
  5. Expand the Search > Limits section and locate the Value List Item Count Limit settings.
  6. Set the value to something larger than the default value of 5000.

Note, however, that setting this parameter value to 0 or 5000 causes the value specified in the above-mentioned setting to be used. If the setting has not been modified when the parameter value is 0 or 5000, the maximum is the default 5,000 results.

The default limit for traditional folders is a maximum of 100,000 results. In other words, if the value is set to 0 or 5000 and the advanced vault setting has not been modified, a maximum of 100,000 traditional folders are returned.
VaultValueListItemOperations Object : SearchForValueListItemsEx2 Method

Glossary Item Box

Description

Searches for value list items in the specified value list

Syntax

Visual Basic
Public Function SearchForValueListItemsEx2( _
   ByVal ValueList As Long, _
   ByVal SearchConditions As SearchConditions, _
   Optional ByVal UpdateFromServer As Boolean = False, _
   Optional ByVal RefreshTypeIfExternalValueList As MFExternalDBRefreshType = MFExternalDBRefreshTypeNone, _
   Optional ByVal ReplaceCurrentUserWithCallersIdentity As Boolean = True, _
   Optional ByVal PropertyDef As Long = -1, _
   Optional ByVal MaxResults As Long = 5000 _
) As ValueListItemSearchResults

Parameters

ValueList
The value list the items of which to search for.
SearchConditions
The search conditions to be used.
UpdateFromServer
If this is set to "true", the search operation is always carried out on the server-side.
RefreshTypeIfExternalValueList
Value | Description
MFExternalDBRefreshTypeFull | The full refresh updates all the changes. This operation can take several minutes.
MFExternalDBRefreshTypeNone | No refresh is performed.
MFExternalDBRefreshTypeQuick | The quick refresh searches for new items and imports them to M-Files.
Specifies how, if at all, external value lists are updated for this operation.
ReplaceCurrentUserWithCallersIdentity
When using M-Files API in the client mode, the "ReplaceCurrentUserWithCallersIdentity" parameter must always be set to true.
PropertyDef
Specifies the property definition the filter of which should be applied to the list (-1 for none).
MaxResults

The maximum number of results to return. By default, no more than 5,000 results are allowed. You can, however, allow more results vault-specifically by changing the value of the Value List Item Count Limit setting via the advanced vault settings:

  1. Open M-Files Admin.
  2. Select a server and a document vault that you want the setting to affect via the left-side tree view.
  3. Select the Configurations node.
  4. Expand Advanced Vault Settings and then select Configuration.
  5. Expand the Search > Limits section and locate the Value List Item Count Limit settings.
  6. Set the value to something larger than the default value of 5000.

Note, however, that setting this parameter value to 0 or 5000 causes the value specified in the above-mentioned setting to be used. If the setting has not been modified when the parameter value is 0 or 5000, the maximum is the default 5,000 results.

The default limit for traditional folders is a maximum of 100,000 results. In other words, if the value is set to 0 or 5000 and the advanced vault setting has not been modified, a maximum of 100,000 traditional folders are returned.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

SearchForValueListItemsWithPermissions Method
ValueList
SearchConditions
UpdateFromServer
RefreshTypeIfExternalValueList
ReplaceCurrentUserWithCallersIdentity
PropertyDef
MaxResults
VaultValueListItemOperations Object : SearchForValueListItemsWithPermissions Method

Glossary Item Box

Description

Searches for value list items in the specified value list

Syntax

Visual Basic
Public Function SearchForValueListItemsWithPermissions( _
   ByVal ValueList As Long, _
   ByVal SearchConditions As SearchConditions, _
   Optional ByVal UpdateFromServer As Boolean = False, _
   Optional ByVal RefreshTypeIfExternalValueList As MFExternalDBRefreshType = MFExternalDBRefreshTypeNone, _
   Optional ByVal ReplaceCurrentUserWithCallersIdentity As Boolean = True, _
   Optional ByVal PropertyDef As Long = -1, _
   Optional ByVal MaxResults As Long = 5000 _
) As ValueListItemSearchResultsWithPermissions

Parameters

ValueList
SearchConditions
UpdateFromServer
RefreshTypeIfExternalValueList
Value | Description
MFExternalDBRefreshTypeFull | The full refresh updates all the changes. This operation can take several minutes.
MFExternalDBRefreshTypeNone | No refresh is performed.
MFExternalDBRefreshTypeQuick | The quick refresh searches for new items and imports them to M-Files.
ReplaceCurrentUserWithCallersIdentity
PropertyDef
MaxResults

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

UndeleteValueListItem Method
ValueList
The value list containing the value list item to be undeleted.
ValueListItemID
The ID of the value list item.
VaultValueListItemOperations Object : UndeleteValueListItem Method

Glossary Item Box

Description

Undeletes a previously deleted value list item.

Syntax

Visual Basic
Public Sub UndeleteValueListItem( _
   ByVal ValueList As Long, _
   ByVal ValueListItemID As Long _
)

Parameters

ValueList
The value list containing the value list item to be undeleted.
ValueListItemID
The ID of the value list item.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

UndeleteValueListItemEx Method
ObjID
The ID of the value list item to be undeleted.
VaultValueListItemOperations Object : UndeleteValueListItemEx Method

Glossary Item Box

Description

Undeletes a previously deleted value list item.

Syntax

Visual Basic
Public Sub UndeleteValueListItemEx( _
   ByVal ObjID As ObjID _
)

Parameters

ObjID
The ID of the value list item to be undeleted.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

UpdateValueListItem Method
ValueListItem
The value list item object to update.
VaultValueListItemOperations Object : UpdateValueListItem Method

Glossary Item Box

Description

Updates the value list item.

Syntax

Visual Basic
Public Sub UpdateValueListItem( _
   ByVal ValueListItem As ValueListItem _
)

Parameters

ValueListItem
The value list item object to update.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListItemOperations Object | VaultValueListItemOperations Members


%%PageItemTitle%%

VaultValueListOperations Object
Members See Also Send comments

Glossary Item Box

Description

The VaultValueListOperations class represents the available value list operations.

Public Methods

Public Method AddValueListAdmin | Adds a new value list or object type. Returns the created value list, with the ID property set to the real ID value.
Public Method GetBuiltInValueList | Gets a built-in value list or object type.
Public Method GetValueList | Gets a single value list or object type.
Public Method GetValueListAdmin | Gets information on the specified value list or object type (for administrative operations).
Public Method GetValueListIDByAlias | Gets the ID of the object type or value list with the specified alias. Returns -1 if a match is not found or if more than one object type or value list uses the specified alias.
Public Method GetValueListIDByGUID | Gets the ID of the object type or value list with the specified GUID. Returns -1 if a match is not found.
Public Method GetValueLists | Gets the value lists and object types of the vault.
Public Method GetValueListsAdmin | Gets all value lists and object types (for administrative operations).
Public Method RefreshExternalValueList | Refreshes an external value list or object type.
Public Method RemoveValueListAdmin | Deletes the specified value list or object type.
Public Method UpdateValueListAdmin | Updates the value list or object type. The ID property identifies the value list to be modified. Returns the updated value list.
Public Method UpdateValueListWithAutomaticPermissionsAdmin | Updates the value list or object type. The ID property identifies the value list to be modified. Returns the updated value list.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultValueListOperations Members


%%PageItemTitle%%

AddValueListAdmin Method
ValueList
The value list to be added.
VaultValueListOperations Object : AddValueListAdmin Method

Glossary Item Box

Description

Adds a new value list or object type. Returns the created value list, with the ID property set to the real ID value.

Syntax

Visual Basic
Public Function AddValueListAdmin( _
   ByVal ValueList As ObjTypeAdmin _
) As ObjTypeAdmin

Parameters

ValueList
The value list to be added.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListOperations Object | VaultValueListOperations Members


%%PageItemTitle%%

GetBuiltInValueList Method
BuiltInValueList
VaultValueListOperations Object : GetBuiltInValueList Method

Glossary Item Box

Description

Gets a built-in value list or object type.

Syntax

Visual Basic
Public Function GetBuiltInValueList( _
   ByVal BuiltInValueList As MFBuiltInValueList _
) As ObjType

Parameters

BuiltInValueList
Value | Description
MFBuiltInValueListAssignments | A value list containing all the assignments.
MFBuiltInValueListClasses | A value list containing all the classes.
MFBuiltInValueListClassGroups | A value list containing all the class groups.
MFBuiltInValueListCollections | A value list containing all the document collections.
MFBuiltInValueListDocuments | A value list containing all the documents of the vault.
MFBuiltInValueListExternalLocations | A value list containing all the external locations.
MFBuiltInValueListSources | A value list containing all object sources (repositories).
MFBuiltInValueListStates | A value list containing all the workflow states. This is a sub-list of the MFBuiltInValueListWorkflows value list.
MFBuiltInValueListStateTransitions | A value list containing all the workflow state transitions. This is a sub-list of the 'MFBuiltInValueListWorkflows' value list.
MFBuiltInValueListTraditionalFolders | A value list containing all the traditional folders. Note: the value list is hierarchical.
MFBuiltInValueListUserGroups | A value list containing all the user groups.
MFBuiltInValueListUsers | A value list containing all the vault users.
MFBuiltInValueListVersionLabels | A value list containing all the version labels.
MFBuiltInValueListWorkflows | A value list containing all the workflows.

See Also

VaultValueListOperations Object | VaultValueListOperations Members


%%PageItemTitle%%

GetValueList Method
ValueList
The value list ID.
VaultValueListOperations Object : GetValueList Method

Glossary Item Box

Description

Gets a single value list or object type.

Syntax

Visual Basic
Public Function GetValueList( _
   ByVal ValueList As Long _
) As ObjType

Parameters

ValueList
The value list ID.

Remarks

Use this method to get the object type for value lists and actual object types. You can determine the actual object types by using the RealObjectType property of the OjbType class.

See Also

VaultValueListOperations Object | VaultValueListOperations Members


%%PageItemTitle%%

GetValueListAdmin Method
ValueListID
The ID of the value list.
VaultValueListOperations Object : GetValueListAdmin Method

Glossary Item Box

Description

Gets information on the specified value list or object type (for administrative operations).

Syntax

Visual Basic
Public Function GetValueListAdmin( _
   ByVal ValueListID As Long _
) As ObjTypeAdmin

Parameters

ValueListID
The ID of the value list.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListOperations Object | VaultValueListOperations Members


%%PageItemTitle%%

GetValueListIDByAlias Method
Alias
The alias of the value list to look for.
VaultValueListOperations Object : GetValueListIDByAlias Method

Glossary Item Box

Description

Gets the ID of the object type or value list with the specified alias. Returns -1 if a match is not found or if more than one object type or value list uses the specified alias.

Syntax

Visual Basic
Public Function GetValueListIDByAlias( _
   ByVal Alias As String _
) As Long

Parameters

Alias
The alias of the value list to look for.

See Also

VaultValueListOperations Object | VaultValueListOperations Members


%%PageItemTitle%%

GetValueListIDByGUID Method
ValueListGUID
The GUID of the value list to look for.
VaultValueListOperations Object : GetValueListIDByGUID Method

Glossary Item Box

Description

Gets the ID of the object type or value list with the specified GUID. Returns -1 if a match is not found.

Syntax

Visual Basic
Public Function GetValueListIDByGUID( _
   ByVal ValueListGUID As String _
) As Long

Parameters

ValueListGUID
The GUID of the value list to look for.

See Also

VaultValueListOperations Object | VaultValueListOperations Members


%%PageItemTitle%%

GetValueLists Method
VaultValueListOperations Object : GetValueLists Method

Glossary Item Box

Description

Gets the value lists and object types of the vault.

Syntax

Visual Basic
Public Function GetValueLists() As ObjTypes

See Also

VaultValueListOperations Object | VaultValueListOperations Members


%%PageItemTitle%%

GetValueListsAdmin Method
VaultValueListOperations Object : GetValueListsAdmin Method

Glossary Item Box

Description

Gets all value lists and object types (for administrative operations).

Syntax

Visual Basic
Public Function GetValueListsAdmin() As ObjTypesAdmin

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListOperations Object | VaultValueListOperations Members


%%PageItemTitle%%

RefreshExternalValueList Method
ValueList
The value list ID.
RefreshType
VaultValueListOperations Object : RefreshExternalValueList Method

Glossary Item Box

Description

Refreshes an external value list or object type.

Syntax

Visual Basic
Public Sub RefreshExternalValueList( _
   ByVal ValueList As Long, _
   ByVal RefreshType As MFExternalDBRefreshType _
)

Parameters

ValueList
The value list ID.
RefreshType
Value | Description
MFExternalDBRefreshTypeFull | The full refresh updates all the changes. This operation can take several minutes.
MFExternalDBRefreshTypeNone | No refresh is performed.
MFExternalDBRefreshTypeQuick | The quick refresh searches for new items and imports them to M-Files.

See Also

VaultValueListOperations Object | VaultValueListOperations Members


%%PageItemTitle%%

RemoveValueListAdmin Method
ValueListID
The ID of the value list to be removed.
VaultValueListOperations Object : RemoveValueListAdmin Method

Glossary Item Box

Description

Deletes the specified value list or object type.

Syntax

Visual Basic
Public Sub RemoveValueListAdmin( _
   ByVal ValueListID As Long _
)

Parameters

ValueListID
The ID of the value list to be removed.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListOperations Object | VaultValueListOperations Members


%%PageItemTitle%%

UpdateValueListAdmin Method
ValueList
The value list to be updated.
VaultValueListOperations Object : UpdateValueListAdmin Method

Glossary Item Box

Description

Updates the value list or object type. The ID property identifies the value list to be modified. Returns the updated value list.

Syntax

Visual Basic
Public Function UpdateValueListAdmin( _
   ByVal ValueList As ObjTypeAdmin _
) As ObjTypeAdmin

Parameters

ValueList
The value list to be updated.

See Also

VaultValueListOperations Object | VaultValueListOperations Members


%%PageItemTitle%%

UpdateValueListWithAutomaticPermissionsAdmin Method
ObjectType
The value list to be updated.
AutomaticPermissionsForcedActive
If true, the propagated automatic permissions are forced active.
VaultValueListOperations Object : UpdateValueListWithAutomaticPermissionsAdmin Method

Glossary Item Box

Description

Updates the value list or object type. The ID property identifies the value list to be modified. Returns the updated value list.

Syntax

Visual Basic
Public Function UpdateValueListWithAutomaticPermissionsAdmin( _
   ByVal ObjectType As ObjTypeAdmin, _
   Optional ByVal AutomaticPermissionsForcedActive As Boolean = False _
) As ObjTypeAdmin

Parameters

ObjectType
The value list to be updated.
AutomaticPermissionsForcedActive
If true, the propagated automatic permissions are forced active.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultValueListOperations Object | VaultValueListOperations Members


%%PageItemTitle%%

VaultViewOperations Object
Members See Also Example Send comments

Glossary Item Box

Description

The VaultViewOperations class represents the available view operations.

Public Methods

Public Method AddOfflineFilter | Adds a new offline filter. Returns the added filter view.
Public Method AddTemporarySearchViewEx | Adds a temporary search view. Returns the added view.
Public Method AddView | Adds a new view. Returns the added view.
Public Method FindPropertyFolderLocationInView | Gets the locations of a property folder in a view.
Public Method GetBuiltInView | Gets a built-in view.
Public Method GetFolder | Gets the specified folder in the vault.
Public Method GetFolderContents | Gets the contents of the specified folder.
Public Method GetFolderNameListing | Gets the folder names inside a folder specified by the property conditions.
Public Method GetFolderUIStateForFolder | Retrieves the UI settings of a specified folder.
Public Method GetFolderUIStateForSpecialLocation | Retrieves the UI settings of a specified folder.
Public Method GetIconAsBytes | Gets the external repository icon in PNG format.
Public Method GetMFilesURLForView | Gets an M-Files URL for a view.
Public Method GetPropertyValuesOfFolder | Extracts as many property values from the given folder location as possible for the purposes of prefilling metadata when creating new objects of the specified type. May return zero or more property values.
Public Method GetPropertyValuesOfPath | Extracts as many property values from the given path string as possible for the purposes of prefilling metadata when creating new objects of the specified type. May return zero or more property values. Does not fail if the path no longer exists.
Public Method GetTemporarySearchByPath | Gets information on the temporary search view specified by the path.
Public Method GetTemporarySearchView | Gets information on the specified temporary search view.
Public Method GetView | Gets the specified view in the vault.
Public Method GetViewIDByGUID | Gets the ID of the metadata structure element with the specified GUID. Returns -1 if a match is not found.
Public Method GetViewLocationInClient | Gets the view locations.
Public Method GetViews | Gets all views of the vault.
Public Method GetViewsAdmin | Gets the common views and/or views for a specific user.
Public Method ModifyTemporarySearch | Modifies the temporary search view.
Public Method RemoveView | Deletes the specified view.
Public Method RequestClientDirectoryRefresh | Requests the client cache refresh for a directory structure.
Public Method ResetFolderUIStateForFolder | Resets the UI settings of a specified folder to program defaults or common defaults.
Public Method ResetFolderUIStateForSpecialLocation | Resets the UI settings of a specified folder to program defaults or common defaults.
Public Method SaveFolderUIStateForFolder | Saves the UI settings of a specified folder.
Public Method SaveFolderUIStateForSpecialLocation | Saves the UI settings of a specified folder.
Public Method SetViewVisibility | Sets the visibility of a view for the user in the default listing of the view.
Public Method ShowViewOrPropertyFolder | Shows the given view or property folder.
Public Method UpdateView | Updates the specified view. Returns the updated view.

Remarks

This method group interface can be accessed via the Vault object.

Example

Adding a new view (Visual Basic) Copy Code
' Construct view object.
Dim oView As New MFilesAPI.View
oView.Common = True
oView.Name = "Test View"
oView.ViewType = MFilesAPI.MFViewType.MFViewTypeNormal

' Create search conditions for the view: object status is not deleted
Dim oExpression As New MFilesAPI.Expression
oExpression.SetStatusValueExpression(MFilesAPI.MFStatusType.MFStatusTypeDeleted)
Dim oTypedValue As New MFilesAPI.TypedValue
oTypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeBoolean, False)
Dim oDeleted As New MFilesAPI.SearchCondition
oDeleted.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeEqual
oDeleted.Set(expression, MFilesAPI.MFConditionType.MFConditionTypeEqual, oTypedValue)
oView.SearchConditions.Add(-1, oDeleted)

' Add the view to client.
oView = oVault.ViewOperations.AddView(oView)

See Also

VaultViewOperations Members


%%PageItemTitle%%

AddOfflineFilter Method
OfflineFilter
The view object to be used as an offline filter.
VaultViewOperations Object : AddOfflineFilter Method

Glossary Item Box

Description

Adds a new offline filter. Returns the added filter view.

Syntax

Visual Basic
Public Function AddOfflineFilter( _
   ByVal OfflineFilter As View _
) As View

Parameters

OfflineFilter
The view object to be used as an offline filter.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

AddTemporarySearchViewEx Method
View
A view object to be used as a basis for a new temporary search view.
SearchCriteria
A container object for the set of search conditions to be used for the new view. The search conditions will be copied over to the view definition.
ForceUsingAdvancedSearchConds

If this is set to "true", advanced search conditions are applied even if the search options section in the user interface is not expanded. If this is set to "false", the search options section in the user interface must be expanded for the advanced search conditions to be applied. In other words, the latter option works the same way as the user interface.

VaultViewOperations Object : AddTemporarySearchViewEx Method

Glossary Item Box

Description

Adds a temporary search view. Returns the added view.

Syntax

Visual Basic
Public Function AddTemporarySearchViewEx( _
   ByVal View As View, _
   ByVal SearchCriteria As SearchCriteria, _
   ByVal ForceUsingAdvancedSearchConds As Boolean _
) As View

Parameters

View
A view object to be used as a basis for a new temporary search view.
SearchCriteria
A container object for the set of search conditions to be used for the new view. The search conditions will be copied over to the view definition.
ForceUsingAdvancedSearchConds

If this is set to "true", advanced search conditions are applied even if the search options section in the user interface is not expanded. If this is set to "false", the search options section in the user interface must be expanded for the advanced search conditions to be applied. In other words, the latter option works the same way as the user interface.

Remarks

This method is the updated version of the now deprecated method "AddTemporarySearchView", and no longer uses the redundant "BaseSearchConditions" parameter.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

AddView Method
See Also Example Send comments
View
The view object to add.
VaultViewOperations Object : AddView Method

Glossary Item Box

Description

Adds a new view. Returns the added view.

Syntax

Visual Basic
Public Function AddView( _
   ByVal View As View _
) As View

Parameters

View
The view object to add.

Example

Adding a new view (Visual Basic) Copy Code
' Construct view object.
Dim oView As New MFilesAPI.View
oView.Common = True
oView.Name = "Test View"
oView.ViewType = MFilesAPI.MFViewType.MFViewTypeNormal

' Create search conditions for the view: object status is not deleted
Dim oExpression As New MFilesAPI.Expression
oExpression.SetStatusValueExpression(MFilesAPI.MFStatusType.MFStatusTypeDeleted)
Dim oTypedValue As New MFilesAPI.TypedValue
oTypedValue.SetValue(MFilesAPI.MFDataType.MFDatatypeBoolean, False)
Dim oDeleted As New MFilesAPI.SearchCondition
oDeleted.ConditionType = MFilesAPI.MFConditionType.MFConditionTypeEqual
oDeleted.Set(expression, MFilesAPI.MFConditionType.MFConditionTypeEqual, oTypedValue)
oView.SearchConditions.Add(-1, oDeleted)

' Add the view to client.
oView = oVault.ViewOperations.AddView(oView)

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

FindPropertyFolderLocationInView Method
View
The view ID of the target view object.
PropertyFolders
A collection of typed values identifying the target property folder. The order of the typed values must match the hierarchy levels of the view.
VaultViewOperations Object : FindPropertyFolderLocationInView Method

Glossary Item Box

Description

Gets the locations of a property folder in a view.

Syntax

Visual Basic
Public Function FindPropertyFolderLocationInView( _
   ByVal View As Long, _
   ByVal PropertyFolders As TypedValues _
) As String

Parameters

View
The view ID of the target view object.
PropertyFolders
A collection of typed values identifying the target property folder. The order of the typed values must match the hierarchy levels of the view.

Return Type

This function returns the full path representing the target property folder (e.g., M:\Sample Vault\1. Documents\By Customer and Class\CBH International\Sales Invoice\). An error is raised if the target property folder does not exist.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetBuiltInView Method
BuiltInView
VaultViewOperations Object : GetBuiltInView Method

Glossary Item Box

Description

Gets a built-in view.

Syntax

Visual Basic
Public Function GetBuiltInView( _
   ByVal BuiltInView As MFBuiltInView _
) As View

Parameters

BuiltInView
Value | Description
MFBuiltInViewAnyView | As any view in the view operations.
MFBuiltInViewAssignedToMe | Assigned-to-me view.
MFBuiltInViewBuiltIn | Built-in view container.
MFBuiltInViewByID | ID view.
MFBuiltInViewCheckedOutToCurrentUser | Checked-out-to-me view.
MFBuiltInViewFavorites | Favorites view.
MFBuiltInViewLatestSearches | Latest-searches view container.
MFBuiltInViewOffline | Offline view container.
MFBuiltInViewOfflineCheckedOut | Checked-out view inside the offline view container.
MFBuiltInViewOfflineMarkedForOfflineAvailability | Marked-for-offline-availability view inside the offline view container.
MFBuiltInViewRecentlyAccessedByMe | Recently Accessed by Me view.
MFBuiltInViewRecentlyModifiedByMe | Recently-modified-by-me view.
MFBuiltInViewTemplates | Templates view.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetFolder Method
FolderID
VaultViewOperations Object : GetFolder Method

Glossary Item Box

Description

Gets the specified folder in the vault.

Syntax

Visual Basic
Public Function GetFolder( _
   ByVal FolderID As FolderID _
) As FolderData

Parameters

FolderID

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetFolderContents Method
FolderLocation
Collection of folder definitions that specify the target folders to retrieve.
VaultViewOperations Object : GetFolderContents Method

Glossary Item Box

Description

Gets the contents of the specified folder.

Syntax

Visual Basic
Public Function GetFolderContents( _
   ByVal FolderLocation As FolderDefs _
) As FolderContentItems

Parameters

FolderLocation
Collection of folder definitions that specify the target folders to retrieve.

Remarks

With builds earlier than 12.0.6606.0, this method can be used in server mode only.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetFolderNameListing Method
ExpressionEx
SearchConditions
SearchFlags
SortResults
VaultViewOperations Object : GetFolderNameListing Method

Glossary Item Box

Description

Gets the folder names inside a folder specified by the property conditions.

Syntax

Visual Basic
Public Function GetFolderNameListing( _
   ByVal ExpressionEx As ExpressionEx, _
   ByVal SearchConditions As SearchConditions, _
   ByVal SearchFlags As MFSearchFlags, _
   ByVal SortResults As Boolean _
) As FolderNameListing

Parameters

ExpressionEx
SearchConditions
SearchFlags
Value | Description
MFSearchFlagDisableRelevancyRanking | Search results are not sorted according to their relevancy.
MFSearchFlagIncludeUnmanagedObjects | Include unmanaged objects in the search results.
MFSearchFlagLookAllObjectTypes | Perform a separate search for each object type and merges the results.
MFSearchFlagLookInAllVersions | Orders to look for matches in all object versions. By default, only the latest object versions are included in the search.
MFSearchFlagNone | No flags.
MFSearchFlagResultsFromEachRepository | Limits the search results per search location instead of limiting the total number of results from all vaults and repositories. This ensures that the search results include items from all search locations with search hits.
MFSearchFlagReturnLatestVisibleVersion | Orders to return the latest version for each object, regardless of whether it is an actual matching version. This flag is effective only if MFSearchFlagLookInAllVersions is on.
SortResults

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetFolderUIStateForFolder Method
CommonState
True to get the common UI state. False to get the user-specific UI state (can also return the common state when there are no user-specific state).
FolderLocation
The folder location.
ObjectFolder
If true, the actual location is actually a object folder in the folder location.
VaultViewOperations Object : GetFolderUIStateForFolder Method

Glossary Item Box

Description

Retrieves the UI settings of a specified folder.

Syntax

Visual Basic
Public Function GetFolderUIStateForFolder( _
   ByVal CommonState As Boolean, _
   ByVal FolderLocation As FolderDefs, _
   ByVal ObjectFolder As Boolean _
) As FolderUIState

Parameters

CommonState
True to get the common UI state. False to get the user-specific UI state (can also return the common state when there are no user-specific state).
FolderLocation
The folder location.
ObjectFolder
If true, the actual location is actually a object folder in the folder location.

Remarks

The method can be targeted to a view location that is addressable as FolderDefs Collection location, or an object content folder under such a location. The "ObjectFolder" flag is set, for example, when pointing inside a multi-file document in a certain view location.

The UI state contains column settings for the view. The columns collection contains all columns that can be displayed in the view, regardless whether they are currently visible or not.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetFolderUIStateForSpecialLocation Method
CommonState
True to get the common UI state. False to get the user-specific UI state (can also return the common state when there are no user-specific state).
LocationType
VaultViewOperations Object : GetFolderUIStateForSpecialLocation Method

Glossary Item Box

Description

Retrieves the UI settings of a specified folder.

Syntax

Visual Basic
Public Function GetFolderUIStateForSpecialLocation( _
   ByVal CommonState As Boolean, _
   ByVal LocationType As MFFolderUIStateLocationType _
) As FolderUIState

Parameters

CommonState
True to get the common UI state. False to get the user-specific UI state (can also return the common state when there are no user-specific state).
LocationType
Value | Description
MFFolderUIStateLocationTypeClearLocalCacheUI | Special folder that displays the non-document files in the local client cache.
MFFolderUIStateLocationTypeCollectionMembersUI | Special folder that displays document collection members.
MFFolderUIStateLocationTypeHistoryUI | Special folder that displays the object history.
MFFolderUIStateLocationTypeLocalTemporaryItemsContainer | Container of local temporary files/folders.
MFFolderUIStateLocationTypeObjectFilesContainer | Object folder, contains object files.
MFFolderUIStateLocationTypeObjectsContainer | View folder that contains objects only.
MFFolderUIStateLocationTypePropertyFoldersContainer | View folder that contains property folders.
MFFolderUIStateLocationTypeRelationshipsUIAllTab | Special folder that displays all relationships of an object.
MFFolderUIStateLocationTypeRelationshipsUIFromTab | Special folder that displays relationships out from the object.
MFFolderUIStateLocationTypeRelationshipsUIToTab | Special folder that displays relationships in to the object.
MFFolderUIStateLocationTypeRootFolder | Folder location type that indicates the vault root folder.
MFFolderUIStateLocationTypeSearchResultsContainer | Search folder.
MFFolderUIStateLocationTypeSubobjectsUI | Special folder that displays subobjects of an object.
MFFolderUIStateLocationTypeTraditionalFolder | Traditional folder.
MFFolderUIStateLocationTypeUnknown | Unknown folder location type.
MFFolderUIStateLocationTypeViewFoldersContainer | View folder that acts as a container for other views.

Remarks

The method can be targeted to a special view that is not addressable via a normal view or folder location path.

The UI state contains column settings for the view. The contained columns collection contains all columns that can be displayed in the view.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetIconAsBytes Method
ExternalRepository
The name of the external repository.
IconID
The ID of the icon.
Size
The size (width or height) of the icon in pixels.
VaultViewOperations Object : GetIconAsBytes Method

Glossary Item Box

Description

Gets the external repository icon in PNG format.

Syntax

Visual Basic
Public Function GetIconAsBytes( _
   ByVal ExternalRepository As String, _
   ByVal IconID As String, _
   ByVal Size As Long _
) As Byte()

Parameters

ExternalRepository
The name of the external repository.
IconID
The ID of the icon.
Size
The size (width or height) of the icon in pixels.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetMFilesURLForView Method
ViewID
PropertyFolders

Identifies a property folder within the view which the URL will open. If SimpleURL is True then only lookup based typed values are allowed.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

SimpleURL
When False the typed values representing the property folders are encoded. Allows specifying an arbitrary property folder within the view.
VaultViewOperations Object : GetMFilesURLForView Method

Glossary Item Box

Description

Gets an M-Files URL for a view.

Syntax

Visual Basic
Public Function GetMFilesURLForView( _
   ByVal ViewID As Long, _
   Optional ByVal PropertyFolders As TypedValues = 0, _
   Optional ByVal SimpleURL As Boolean = True _
) As String

Parameters

ViewID
PropertyFolders

Identifies a property folder within the view which the URL will open. If SimpleURL is True then only lookup based typed values are allowed.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

SimpleURL
When False the typed values representing the property folders are encoded. Allows specifying an arbitrary property folder within the view.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetPropertyValuesOfFolder Method
FolderLocation
The folder location.
ObjectType
The object type for which the properties are retrieved.
VaultViewOperations Object : GetPropertyValuesOfFolder Method

Glossary Item Box

Description

Extracts as many property values from the given folder location as possible for the purposes of prefilling metadata when creating new objects of the specified type. May return zero or more property values.

Syntax

Visual Basic
Public Function GetPropertyValuesOfFolder( _
   ByVal FolderLocation As FolderDefs, _
   ByVal ObjectType As Long _
) As PropertyValues

Parameters

FolderLocation
The folder location.
ObjectType
The object type for which the properties are retrieved.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetPropertyValuesOfPath Method
Path
The path from which to extract property values (for instance "1. Documents\By Customer\A&A Consulting").
ObjectType
The object type for which the properties are retrieved.
VaultViewOperations Object : GetPropertyValuesOfPath Method

Glossary Item Box

Description

Extracts as many property values from the given path string as possible for the purposes of prefilling metadata when creating new objects of the specified type. May return zero or more property values. Does not fail if the path no longer exists.

Syntax

Visual Basic
Public Function GetPropertyValuesOfPath( _
   ByVal Path As String, _
   ByVal ObjectType As Long _
) As PropertyValues

Parameters

Path
The path from which to extract property values (for instance "1. Documents\By Customer\A&A Consulting").
ObjectType
The object type for which the properties are retrieved.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetTemporarySearchByPath Method
RelativePath
The path from which to get the temporary search view.
VaultViewOperations Object : GetTemporarySearchByPath Method

Glossary Item Box

Description

Gets information on the temporary search view specified by the path.

Syntax

Visual Basic
Public Function GetTemporarySearchByPath( _
   ByVal RelativePath As String _
) As TemporarySearchView

Parameters

RelativePath
The path from which to get the temporary search view.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetTemporarySearchView Method
ViewID
VaultViewOperations Object : GetTemporarySearchView Method

Glossary Item Box

Description

Gets information on the specified temporary search view.

Syntax

Visual Basic
Public Function GetTemporarySearchView( _
   ByVal ViewID As Long _
) As TemporarySearchView

Parameters

ViewID

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetView Method
View
VaultViewOperations Object : GetView Method

Glossary Item Box

Description

Gets the specified view in the vault.

Syntax

Visual Basic
Public Function GetView( _
   ByVal View As Long _
) As View

Parameters

View

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetViewIDByGUID Method
ViewGUID
The GUID of the the view object.
VaultViewOperations Object : GetViewIDByGUID Method

Glossary Item Box

Description

Gets the ID of the metadata structure element with the specified GUID. Returns -1 if a match is not found.

Syntax

Visual Basic
Public Function GetViewIDByGUID( _
   ByVal ViewGUID As String _
) As Long

Parameters

ViewGUID
The GUID of the the view object.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetViewLocationInClient Method
View
IncludeViewNameInPath
VaultViewOperations Object : GetViewLocationInClient Method

Glossary Item Box

Description

Gets the view locations.

Syntax

Visual Basic
Public Function GetViewLocationInClient( _
   ByVal View As Long, _
   Optional ByVal IncludeViewNameInPath As Boolean = True _
) As String

Parameters

View
IncludeViewNameInPath

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetViews Method
ViewCategory
AllViews
ParentView
VaultViewOperations Object : GetViews Method

Glossary Item Box

Description

Gets all views of the vault.

Syntax

Visual Basic
Public Function GetViews( _
   Optional ByVal ViewCategory As MFViewCategory = MFViewCategoryNormal, _
   Optional ByVal AllViews As Boolean = True, _
   Optional ByVal ParentView As Long = -1 _
) As Views

Parameters

ViewCategory
Value | Description
MFViewCategoryNormal | Normal view.
MFViewCategoryOfflineFilter | View that acts as an offline filter.
MFViewCategoryTemporarySearch | View that represents a temporary search.
AllViews
ParentView

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

GetViewsAdmin Method
IncludeCommonViews
If this is set to true, common views are included.
UserID
The ID of the user whose views to retrieve.
VaultViewOperations Object : GetViewsAdmin Method

Glossary Item Box

Description

Gets the common views and/or views for a specific user.

Syntax

Visual Basic
Public Function GetViewsAdmin( _
   ByVal IncludeCommonViews As Boolean, _
   ByVal UserID As Long _
) As Views

Parameters

IncludeCommonViews
If this is set to true, common views are included.
UserID
The ID of the user whose views to retrieve.

Remarks

This method is available only if M-Files API is used in the server interface mode.

The user running a script that uses this method must have the Full control of vault administrative rights in the vault.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

ModifyTemporarySearch Method
TemporarySearchView
The temporary search view to be modified.
VaultViewOperations Object : ModifyTemporarySearch Method

Glossary Item Box

Description

Modifies the temporary search view.

Syntax

Visual Basic
Public Sub ModifyTemporarySearch( _
   ByVal TemporarySearchView As TemporarySearchView _
)

Parameters

TemporarySearchView
The temporary search view to be modified.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

RemoveView Method
View
VaultViewOperations Object : RemoveView Method

Glossary Item Box

Description

Deletes the specified view.

Syntax

Visual Basic
Public Sub RemoveView( _
   ByVal View As Long _
)

Parameters

View

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

RequestClientDirectoryRefresh Method
Path
The directory to refresh. This may be either absolute path, or relative for the vault root.
VaultViewOperations Object : RequestClientDirectoryRefresh Method

Glossary Item Box

Description

Requests the client cache refresh for a directory structure.

Syntax

Visual Basic
Public Sub RequestClientDirectoryRefresh( _
   ByVal Path As String _
)

Parameters

Path
The directory to refresh. This may be either absolute path, or relative for the vault root.

Remarks

Supported in M-Files 20.11.9630.6 and later.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

ResetFolderUIStateForFolder Method
ResetToProgramDefaults
True to reset the UI settings to program defaults.
ResetToCommonDefaults
True to reset the UI settings to common defaults defined by an administrator.
FolderLocation
The folder location.
ObjectFolder
If true, the real location is actually an object folder in the folder location.
VaultViewOperations Object : ResetFolderUIStateForFolder Method

Glossary Item Box

Description

Resets the UI settings of a specified folder to program defaults or common defaults.

Syntax

Visual Basic
Public Function ResetFolderUIStateForFolder( _
   ByVal ResetToProgramDefaults As Boolean, _
   ByVal ResetToCommonDefaults As Boolean, _
   ByVal FolderLocation As FolderDefs, _
   ByVal ObjectFolder As Boolean _
) As FolderUIState

Parameters

ResetToProgramDefaults
True to reset the UI settings to program defaults.
ResetToCommonDefaults
True to reset the UI settings to common defaults defined by an administrator.
FolderLocation
The folder location.
ObjectFolder
If true, the real location is actually an object folder in the folder location.

Remarks

The method can be targeted to a view location that is addressable as FolderDefs Collection location, or an object content folder under such a location. The "ObjectFolder" flag is set, for example, when pointing inside a multi-file document in a certain view location.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

ResetFolderUIStateForSpecialLocation Method
ResetToProgramDefaults
True to reset the UI settings to program defaults.
ResetToCommonDefaults
True to reset the UI settings to common defaults defined by an administrator.
LocationType
VaultViewOperations Object : ResetFolderUIStateForSpecialLocation Method

Glossary Item Box

Description

Resets the UI settings of a specified folder to program defaults or common defaults.

Syntax

Visual Basic
Public Function ResetFolderUIStateForSpecialLocation( _
   ByVal ResetToProgramDefaults As Boolean, _
   ByVal ResetToCommonDefaults As Boolean, _
   ByVal LocationType As MFFolderUIStateLocationType _
) As FolderUIState

Parameters

ResetToProgramDefaults
True to reset the UI settings to program defaults.
ResetToCommonDefaults
True to reset the UI settings to common defaults defined by an administrator.
LocationType
Value | Description
MFFolderUIStateLocationTypeClearLocalCacheUI | Special folder that displays the non-document files in the local client cache.
MFFolderUIStateLocationTypeCollectionMembersUI | Special folder that displays document collection members.
MFFolderUIStateLocationTypeHistoryUI | Special folder that displays the object history.
MFFolderUIStateLocationTypeLocalTemporaryItemsContainer | Container of local temporary files/folders.
MFFolderUIStateLocationTypeObjectFilesContainer | Object folder, contains object files.
MFFolderUIStateLocationTypeObjectsContainer | View folder that contains objects only.
MFFolderUIStateLocationTypePropertyFoldersContainer | View folder that contains property folders.
MFFolderUIStateLocationTypeRelationshipsUIAllTab | Special folder that displays all relationships of an object.
MFFolderUIStateLocationTypeRelationshipsUIFromTab | Special folder that displays relationships out from the object.
MFFolderUIStateLocationTypeRelationshipsUIToTab | Special folder that displays relationships in to the object.
MFFolderUIStateLocationTypeRootFolder | Folder location type that indicates the vault root folder.
MFFolderUIStateLocationTypeSearchResultsContainer | Search folder.
MFFolderUIStateLocationTypeSubobjectsUI | Special folder that displays subobjects of an object.
MFFolderUIStateLocationTypeTraditionalFolder | Traditional folder.
MFFolderUIStateLocationTypeUnknown | Unknown folder location type.
MFFolderUIStateLocationTypeViewFoldersContainer | View folder that acts as a container for other views.

Remarks

The method can be targeted to a special view that is not addressable via normal view or folder location path.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

SaveFolderUIStateForFolder Method
SaveAsCommonSettings
True if the UI settings must also be saved as the common settings of the given folder.
ResetCommonSettingsToAllUsers
True if the common settings must be reset to all users. This parameter is meaningful only if "SaveAsCommonSettings" is true, otherwise it is ignored.
FolderLocation
The folder location.
ObjectFolder
If true, the real location is actually an object folder in the folder location.
State
The UI state of the folder.
VaultViewOperations Object : SaveFolderUIStateForFolder Method

Glossary Item Box

Description

Saves the UI settings of a specified folder.

Syntax

Visual Basic
Public Sub SaveFolderUIStateForFolder( _
   ByVal SaveAsCommonSettings As Boolean, _
   ByVal ResetCommonSettingsToAllUsers As Boolean, _
   ByVal FolderLocation As FolderDefs, _
   ByVal ObjectFolder As Boolean, _
   ByVal State As FolderUIState _
)

Parameters

SaveAsCommonSettings
True if the UI settings must also be saved as the common settings of the given folder.
ResetCommonSettingsToAllUsers
True if the common settings must be reset to all users. This parameter is meaningful only if "SaveAsCommonSettings" is true, otherwise it is ignored.
FolderLocation
The folder location.
ObjectFolder
If true, the real location is actually an object folder in the folder location.
State
The UI state of the folder.

Remarks

The method can be targeted to a view location that is addressable as FolderDefs Collection location, or an object content folder under such a location. The "ObjectFolder" flag is set, for example, when pointing inside a multi-file document in a certain view location.

The system may internally rearrange the FolderUIState Object structure, and especially the FolderListingColumns Collection inside it.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

SaveFolderUIStateForSpecialLocation Method
SaveAsCommonSettings
True if the UI settings must also be saved as the common settings of the given folder.
ResetCommonSettingsToAllUsers
True if the common settings must be reset to all users. This parameter is meaningful only if "SaveAsCommonSettings" is true, otherwise it is ignored.
LocationType
State
VaultViewOperations Object : SaveFolderUIStateForSpecialLocation Method

Glossary Item Box

Description

Saves the UI settings of a specified folder.

Syntax

Visual Basic
Public Sub SaveFolderUIStateForSpecialLocation( _
   ByVal SaveAsCommonSettings As Boolean, _
   ByVal ResetCommonSettingsToAllUsers As Boolean, _
   ByVal LocationType As MFFolderUIStateLocationType, _
   ByVal State As FolderUIState _
)

Parameters

SaveAsCommonSettings
True if the UI settings must also be saved as the common settings of the given folder.
ResetCommonSettingsToAllUsers
True if the common settings must be reset to all users. This parameter is meaningful only if "SaveAsCommonSettings" is true, otherwise it is ignored.
LocationType
Value | Description
MFFolderUIStateLocationTypeClearLocalCacheUI | Special folder that displays the non-document files in the local client cache.
MFFolderUIStateLocationTypeCollectionMembersUI | Special folder that displays document collection members.
MFFolderUIStateLocationTypeHistoryUI | Special folder that displays the object history.
MFFolderUIStateLocationTypeLocalTemporaryItemsContainer | Container of local temporary files/folders.
MFFolderUIStateLocationTypeObjectFilesContainer | Object folder, contains object files.
MFFolderUIStateLocationTypeObjectsContainer | View folder that contains objects only.
MFFolderUIStateLocationTypePropertyFoldersContainer | View folder that contains property folders.
MFFolderUIStateLocationTypeRelationshipsUIAllTab | Special folder that displays all relationships of an object.
MFFolderUIStateLocationTypeRelationshipsUIFromTab | Special folder that displays relationships out from the object.
MFFolderUIStateLocationTypeRelationshipsUIToTab | Special folder that displays relationships in to the object.
MFFolderUIStateLocationTypeRootFolder | Folder location type that indicates the vault root folder.
MFFolderUIStateLocationTypeSearchResultsContainer | Search folder.
MFFolderUIStateLocationTypeSubobjectsUI | Special folder that displays subobjects of an object.
MFFolderUIStateLocationTypeTraditionalFolder | Traditional folder.
MFFolderUIStateLocationTypeUnknown | Unknown folder location type.
MFFolderUIStateLocationTypeViewFoldersContainer | View folder that acts as a container for other views.
State

Remarks

The method can be targeted to a special view that is not addressable via normal view or folder location path.

The system may internally rearrange the FolderUIState Object structure, and especially the FolderListingColumns Collection collection inside it.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

SetViewVisibility Method
View
The ID of the view.
IsVisible
When this is set to True, the specified view is visible.
VaultViewOperations Object : SetViewVisibility Method

Glossary Item Box

Description

Sets the visibility of a view for the user in the default listing of the view.

Syntax

Visual Basic
Public Sub SetViewVisibility( _
   ByVal View As Long, _
   ByVal IsVisible As Boolean _
)

Parameters

View
The ID of the view.
IsVisible
When this is set to True, the specified view is visible.

Remarks

Supported in M-Files 22.3.11156.0 and later.

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

ShowViewOrPropertyFolder Method
ParentWindow
View
PropertyFolders

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultViewOperations Object : ShowViewOrPropertyFolder Method

Glossary Item Box

Description

Shows the given view or property folder.

Syntax

Visual Basic
Public Sub ShowViewOrPropertyFolder( _
   ByVal ParentWindow As Long, _
   ByVal View As Long, _
   Optional ByVal PropertyFolders As TypedValues = 0 _
)

Parameters

ParentWindow
View
PropertyFolders

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

Remarks

This method is available only if M-Files API is used in the client interface mode.

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

UpdateView Method
View
VaultViewOperations Object : UpdateView Method

Glossary Item Box

Description

Updates the specified view. Returns the updated view.

Syntax

Visual Basic
Public Function UpdateView( _
   ByVal View As View _
) As View

Parameters

View

See Also

VaultViewOperations Object | VaultViewOperations Members


%%PageItemTitle%%

VaultWOPIOperations Object
Members See Also Send comments

Glossary Item Box

Description

Methods for accessing the vault WOPI operations.

Public Methods

Public Method CreateWOPIUserSession Creates the WOPI user session.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

VaultWOPIOperations Members


%%PageItemTitle%%

CreateWOPIUserSession Method
UserInfo
The user session object.
TokenType
The token type to be used.
VaultWOPIOperations Object : CreateWOPIUserSession Method

Glossary Item Box

Description

Creates the WOPI user session.

Syntax

Visual Basic
Public Function CreateWOPIUserSession( _
   ByVal UserInfo As WOPIUserSession, _
   ByVal TokenType As MFWOPITokenType _
) As String

Parameters

UserInfo
The user session object.
TokenType
Value | Description
MFWOPITokenTypeOneTimeToken | WOPI one time token key.
MFWOPITokenTypeUserAccessKey | WOPI access key.
The token type to be used.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

VaultWOPIOperations Object | VaultWOPIOperations Members


%%PageItemTitle%%

VaultWorkflowOperations Object
Members See Also Send comments

Glossary Item Box

Description

The VaultWorkflowOperations class represents the available workflow operations.

Public Methods

Public Method AddWorkflowAdmin | Adds a new workflow. Returns the created workflow, with the ID property set to the real ID value.
Public Method GetStateTransitionSignatureSettings | Receives the signature settings for a state transition.
Public Method GetStateTransitionSignatureSettingsByID | Receives the signature settings for a state transition.
Public Method GetWorkflowAdmin | Receives the specified workflow (for administrative operations).
Public Method GetWorkflowForClient | Receives the specified workflow in a format suitable for client.
Public Method GetWorkflowIDByAlias | Receives the ID of the workflow with the specified alias. Returns -1 if a match is not found or if more than one workflow uses the specified alias.
Public Method GetWorkflowIDByGUID | Receives the ID of the workflow with the specified GUID. Returns -1 if a match is not found.
Public Method GetWorkflowsAdmin | Receives all workflows (for administrative operations).
Public Method GetWorkflowsAsValueListItems | Receives all workflows.
Public Method GetWorkflowsForClient | Receives all workflows in a format suitable for client.
Public Method GetWorkflowStateIDByAlias | Receives the ID of the workflow state with the specified alias. Returns -1 if a match is not found or if more than one workflow state uses the specified alias.
Public Method GetWorkflowStateIDByGUID | Receives the ID of the workflow state with the specified GUID. Returns -1 if a match is not found.
Public Method GetWorkflowStates | Receives all states of the specified workflow.
Public Method GetWorkflowStatesEx | Receives all states of the specified workflow. The selectable flag of each state is determined based on the specified current state and object version.
Public Method GetWorkflowStateTransitionIDByAlias | Receives the ID of the workflow state transition with the specified alias. Returns -1 if a match is not found or if more than one workflow state transition uses the specified alias.
Public Method GetWorkflowStateTransitionIDByGUID | Receives the ID of the workflow state transition with the specified GUID. Returns -1 if a match is not found.
Public Method GetWorkflowStateTransitions | Receives all state transitions of the specified workflow.
Public Method GetWorkflowStateTransitionsAsJSON | Receives the state transitions as a JSON string. The 'Selectable' flag of each transition is determined based on the specified current state and object version.
Public Method GetWorkflowStateTransitionsEx | Receives all the state transitions of the specified workflow. The 'Selectable' flag of each state transition is determined based on the specified current state and object version.
Public Method RemoveWorkflowAdmin | Deletes the workflow with the specified ID.
Public Method RemoveWorkflowsAdmin | Deletes the workflows with the specified IDs.
Public Method UpdateWorkflowAdmin | Updates the workflow. The ID property identifies the workflow to modify. Returns the updated workflow.

Remarks

This method group interface can be accessed via the Vault object.

See Also

VaultWorkflowOperations Members


%%PageItemTitle%%

AddWorkflowAdmin Method
Workflow
The workflow object to be added.
VaultWorkflowOperations Object : AddWorkflowAdmin Method

Glossary Item Box

Description

Adds a new workflow. Returns the created workflow, with the ID property set to the real ID value.

Syntax

Visual Basic
Public Function AddWorkflowAdmin( _
   ByVal Workflow As WorkflowAdmin _
) As WorkflowAdmin

Parameters

Workflow
The workflow object to be added.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetStateTransitionSignatureSettings Method
FromState
The source state.
ToState
The target state.
VaultWorkflowOperations Object : GetStateTransitionSignatureSettings Method

Glossary Item Box

Description

Receives the signature settings for a state transition.

Syntax

Visual Basic
Public Function GetStateTransitionSignatureSettings( _
   ByVal FromState As Long, _
   ByVal ToState As Long _
) As SignatureSettings

Parameters

FromState
The source state.
ToState
The target state.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetStateTransitionSignatureSettingsByID Method
StateTransitionID
The ID of the state transition.
VaultWorkflowOperations Object : GetStateTransitionSignatureSettingsByID Method

Glossary Item Box

Description

Receives the signature settings for a state transition.

Syntax

Visual Basic
Public Function GetStateTransitionSignatureSettingsByID( _
   ByVal StateTransitionID As Long _
) As SignatureSettings

Parameters

StateTransitionID
The ID of the state transition.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowAdmin Method
WorkflowID
VaultWorkflowOperations Object : GetWorkflowAdmin Method

Glossary Item Box

Description

Receives the specified workflow (for administrative operations).

Syntax

Visual Basic
Public Function GetWorkflowAdmin( _
   ByVal WorkflowID As Long _
) As WorkflowAdmin

Parameters

WorkflowID

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowForClient Method
WorkflowID
UpdateFromServer
VaultWorkflowOperations Object : GetWorkflowForClient Method

Glossary Item Box

Description

Receives the specified workflow in a format suitable for client.

Syntax

Visual Basic
Public Function GetWorkflowForClient( _
   ByVal WorkflowID As Long, _
   Optional ByVal UpdateFromServer As Boolean = False _
) As Workflow

Parameters

WorkflowID
UpdateFromServer

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowIDByAlias Method
Alias
VaultWorkflowOperations Object : GetWorkflowIDByAlias Method

Glossary Item Box

Description

Receives the ID of the workflow with the specified alias. Returns -1 if a match is not found or if more than one workflow uses the specified alias.

Syntax

Visual Basic
Public Function GetWorkflowIDByAlias( _
   ByVal Alias As String _
) As Long

Parameters

Alias

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowIDByGUID Method
WorkflowGUID
The GUID of the workflow.
VaultWorkflowOperations Object : GetWorkflowIDByGUID Method

Glossary Item Box

Description

Receives the ID of the workflow with the specified GUID. Returns -1 if a match is not found.

Syntax

Visual Basic
Public Function GetWorkflowIDByGUID( _
   ByVal WorkflowGUID As String _
) As Long

Parameters

WorkflowGUID
The GUID of the workflow.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowsAdmin Method
VaultWorkflowOperations Object : GetWorkflowsAdmin Method

Glossary Item Box

Description

Receives all workflows (for administrative operations).

Syntax

Visual Basic
Public Function GetWorkflowsAdmin() As WorkflowsAdmin

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowsAsValueListItems Method
UpdateFromServer
VaultWorkflowOperations Object : GetWorkflowsAsValueListItems Method

Glossary Item Box

Description

Receives all workflows.

Syntax

Visual Basic
Public Function GetWorkflowsAsValueListItems( _
   Optional ByVal UpdateFromServer As Boolean = False _
) As ValueListItems

Parameters

UpdateFromServer

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowsForClient Method
UpdateFromServer
VaultWorkflowOperations Object : GetWorkflowsForClient Method

Glossary Item Box

Description

Receives all workflows in a format suitable for client.

Syntax

Visual Basic
Public Function GetWorkflowsForClient( _
   Optional ByVal UpdateFromServer As Boolean = False _
) As Workflows

Parameters

UpdateFromServer

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowStateIDByAlias Method
Alias
VaultWorkflowOperations Object : GetWorkflowStateIDByAlias Method

Glossary Item Box

Description

Receives the ID of the workflow state with the specified alias. Returns -1 if a match is not found or if more than one workflow state uses the specified alias.

Syntax

Visual Basic
Public Function GetWorkflowStateIDByAlias( _
   ByVal Alias As String _
) As Long

Parameters

Alias

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowStateIDByGUID Method
StateGUID
The GUID of the workflow state.
VaultWorkflowOperations Object : GetWorkflowStateIDByGUID Method

Glossary Item Box

Description

Receives the ID of the workflow state with the specified GUID. Returns -1 if a match is not found.

Syntax

Visual Basic
Public Function GetWorkflowStateIDByGUID( _
   ByVal StateGUID As String _
) As Long

Parameters

StateGUID
The GUID of the workflow state.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowStates Method
Workflow
The workflow ID.
CurrentState

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

VaultWorkflowOperations Object : GetWorkflowStates Method

Glossary Item Box

Description

Receives all states of the specified workflow.

Syntax

Visual Basic
Public Function GetWorkflowStates( _
   ByVal Workflow As Long, _
   Optional ByVal CurrentState As TypedValue = 0 _
) As States

Parameters

Workflow
The workflow ID.
CurrentState

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowStatesEx Method
Workflow
Workflow ID.
CurrentState
The object's current workflow state.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.
ObjVer
The object version to search the available states for.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.
VaultWorkflowOperations Object : GetWorkflowStatesEx Method

Glossary Item Box

Description

Receives all states of the specified workflow. The selectable flag of each state is determined based on the specified current state and object version.

Syntax

Visual Basic
Public Function GetWorkflowStatesEx( _
   ByVal Workflow As Long, _
   Optional ByVal CurrentState As TypedValue = 0, _
   Optional ByVal ObjVer As ObjVer = 0 _
) As States

Parameters

Workflow
Workflow ID.
CurrentState
The object's current workflow state.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.
ObjVer
The object version to search the available states for.

In scripting languages, a specific null value (e.g., Nothing in VBScript) should be used to indicate the default value.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowStateTransitionIDByAlias Method
Alias
The alias that is used for identifying the workflow.
VaultWorkflowOperations Object : GetWorkflowStateTransitionIDByAlias Method

Glossary Item Box

Description

Receives the ID of the workflow state transition with the specified alias. Returns -1 if a match is not found or if more than one workflow state transition uses the specified alias.

Syntax

Visual Basic
Public Function GetWorkflowStateTransitionIDByAlias( _
   ByVal Alias As String _
) As Long

Parameters

Alias
The alias that is used for identifying the workflow.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowStateTransitionIDByGUID Method
StateTransitionGUID
The GUID that is used for identifying the workflow.
VaultWorkflowOperations Object : GetWorkflowStateTransitionIDByGUID Method

Glossary Item Box

Description

Receives the ID of the workflow state transition with the specified GUID. Returns -1 if a match is not found.

Syntax

Visual Basic
Public Function GetWorkflowStateTransitionIDByGUID( _
   ByVal StateTransitionGUID As String _
) As Long

Parameters

StateTransitionGUID
The GUID that is used for identifying the workflow.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowStateTransitions Method
Workflow
The ID that identifies the workflow.
CurrentState
The specified current state affects to the returned transitions so that their "Selectable" properties are set according to the rules defined in the workflows and state definitions.
VaultWorkflowOperations Object : GetWorkflowStateTransitions Method

Glossary Item Box

Description

Receives all state transitions of the specified workflow.

Syntax

Visual Basic
Public Function GetWorkflowStateTransitions( _
   ByVal Workflow As Long, _
   Optional ByVal CurrentState As TypedValue = 0 _
) As StateTransitionsForClient

Parameters

Workflow
The ID that identifies the workflow.
CurrentState
The specified current state affects to the returned transitions so that their "Selectable" properties are set according to the rules defined in the workflows and state definitions.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowStateTransitionsAsJSON Method
Workflow
The ID that identifies the workflow.
CurrentState
The specified current state affects to the returned transitions so that their "Selectable" properties are set according to the rules defined in the workflows and state definitions.
ObjVer
If the pointer is not NULL, it points to a struct that specifies the object version for which the state transitions are inquired. If the pointer is NULL, the "bSelectable" flags of all state transitions that involve pseudo-users will be true because transition rights cannot be checked in that case.
VaultWorkflowOperations Object : GetWorkflowStateTransitionsAsJSON Method

Glossary Item Box

Description

Receives the state transitions as a JSON string. The 'Selectable' flag of each transition is determined based on the specified current state and object version.

Syntax

Visual Basic
Public Function GetWorkflowStateTransitionsAsJSON( _
   ByVal Workflow As Long, _
   Optional ByVal CurrentState As TypedValue = 0, _
   Optional ByVal ObjVer As ObjVer = 0 _
) As String

Parameters

Workflow
The ID that identifies the workflow.
CurrentState
The specified current state affects to the returned transitions so that their "Selectable" properties are set according to the rules defined in the workflows and state definitions.
ObjVer
If the pointer is not NULL, it points to a struct that specifies the object version for which the state transitions are inquired. If the pointer is NULL, the "bSelectable" flags of all state transitions that involve pseudo-users will be true because transition rights cannot be checked in that case.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

GetWorkflowStateTransitionsEx Method
Workflow
The ID that identifies the workflow.
CurrentState
The specified current state affects to the returned transitions so that their "Selectable" properties are set according to the rules defined in the workflows and state definitions.
ObjVer
If the pointer is not NULL, it points to a struct that specifies the object version for which the state transitions are inquired. If the pointer is NULL, the "bSelectable" flags of all state transitions that involve pseudo-users will be true because transition rights cannot be checked in that case.
VaultWorkflowOperations Object : GetWorkflowStateTransitionsEx Method

Glossary Item Box

Description

Receives all the state transitions of the specified workflow. The 'Selectable' flag of each state transition is determined based on the specified current state and object version.

Syntax

Visual Basic
Public Function GetWorkflowStateTransitionsEx( _
   ByVal Workflow As Long, _
   Optional ByVal CurrentState As TypedValue = 0, _
   Optional ByVal ObjVer As ObjVer = 0 _
) As StateTransitionsForClient

Parameters

Workflow
The ID that identifies the workflow.
CurrentState
The specified current state affects to the returned transitions so that their "Selectable" properties are set according to the rules defined in the workflows and state definitions.
ObjVer
If the pointer is not NULL, it points to a struct that specifies the object version for which the state transitions are inquired. If the pointer is NULL, the "bSelectable" flags of all state transitions that involve pseudo-users will be true because transition rights cannot be checked in that case.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

RemoveWorkflowAdmin Method
WorkflowID
The ID of the workflow to be removed.
VaultWorkflowOperations Object : RemoveWorkflowAdmin Method

Glossary Item Box

Description

Deletes the workflow with the specified ID.

Syntax

Visual Basic
Public Sub RemoveWorkflowAdmin( _
   ByVal WorkflowID As Long _
)

Parameters

WorkflowID
The ID of the workflow to be removed.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

RemoveWorkflowsAdmin Method
pIIDs
The IDs of the workflows to be removed.
VaultWorkflowOperations Object : RemoveWorkflowsAdmin Method

Glossary Item Box

Description

Deletes the workflows with the specified IDs.

Syntax

Visual Basic
Public Sub RemoveWorkflowsAdmin( _
   ByVal pIIDs As IDs _
)

Parameters

pIIDs
The IDs of the workflows to be removed.

Remarks

Supported in M-Files 20.4.8986.4 and later.

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

UpdateWorkflowAdmin Method
Workflow
Workflow object to update.
VaultWorkflowOperations Object : UpdateWorkflowAdmin Method

Glossary Item Box

Description

Updates the workflow. The ID property identifies the workflow to modify. Returns the updated workflow.

Syntax

Visual Basic
Public Function UpdateWorkflowAdmin( _
   ByVal Workflow As WorkflowAdmin _
) As WorkflowAdmin

Parameters

Workflow
Workflow object to update.

Remarks

This method is available only if M-Files API is used in the server interface mode.

See Also

VaultWorkflowOperations Object | VaultWorkflowOperations Members


%%PageItemTitle%%

VerifyVaultJob Object
Members See Also Send comments

Glossary Item Box

Description

The VerifyVaultJob class represents a vault verification job.

Public Methods

Public Method Clone | Creates a clone of this object.
Public Method GetNumberOfSteps | Gets the number of steps in this job.
Public Method GetOneBasedIndexOfStep | Gets the one-based index of the step.
Public Method GetStepProgressText | Gets the progress text for a step.
Public Method Set | Sets the job information.

Public Properties

Public Property FixErrors | Specifies whether this job should attempt to fix the detected errors.
Public Property VaultGUID | The GUID of the vault.
Public Property VerifyFileContents | Specifies whether this job verifies the integrity of the data files on disk.

See Also

VerifyVaultJob Members


%%PageItemTitle%%

Clone Method
VerifyVaultJob Object : Clone Method

Glossary Item Box

Description

Creates a clone of this object.

Syntax

Visual Basic
Public Function Clone() As VerifyVaultJob

See Also

VerifyVaultJob Object | VerifyVaultJob Members


%%PageItemTitle%%

GetNumberOfSteps Method
VerifyVaultJob Object : GetNumberOfSteps Method

Glossary Item Box

Description

Gets the number of steps in this job.

Syntax

Visual Basic
Public Function GetNumberOfSteps() As Long

See Also

VerifyVaultJob Object | VerifyVaultJob Members


%%PageItemTitle%%

GetOneBasedIndexOfStep Method
CurrentStep
VerifyVaultJob Object : GetOneBasedIndexOfStep Method

Glossary Item Box

Description

Gets the one-based index of the step.

Syntax

Visual Basic
Public Function GetOneBasedIndexOfStep( _
   ByVal CurrentStep As Long _
) As Long

Parameters

CurrentStep

See Also

VerifyVaultJob Object | VerifyVaultJob Members


%%PageItemTitle%%

GetStepProgressText Method
CurrentStep
VerifyVaultJob Object : GetStepProgressText Method

Glossary Item Box

Description

Gets the progress text for a step.

Syntax

Visual Basic
Public Function GetStepProgressText( _
   ByVal CurrentStep As Long _
) As String

Parameters

CurrentStep

See Also

VerifyVaultJob Object | VerifyVaultJob Members


%%PageItemTitle%%

Set Method
GuidVault
FixErrors
VerifyFileContents
VerifyVaultJob Object : Set Method

Glossary Item Box

Description

Sets the job information.

Syntax

Visual Basic
Public Sub Set( _
   ByVal GuidVault As String, _
   ByVal FixErrors As Boolean, _
   ByVal VerifyFileContents As Boolean _
)

Parameters

GuidVault
FixErrors
VerifyFileContents

See Also

VerifyVaultJob Object | VerifyVaultJob Members


%%PageItemTitle%%

FixErrors Property
VerifyVaultJob Object : FixErrors Property

Glossary Item Box

Description

Specifies whether this job should attempt to fix the detected errors.

Property type

Read-only property

Syntax

Visual Basic
Public Property FixErrors As Boolean

See Also

VerifyVaultJob Object | VerifyVaultJob Members


%%PageItemTitle%%

VaultGUID Property
VerifyVaultJob Object : VaultGUID Property

Glossary Item Box

Description

The GUID of the vault.

Property type

Read-only property

Syntax

Visual Basic
Public Property VaultGUID As String

See Also

VerifyVaultJob Object | VerifyVaultJob Members


%%PageItemTitle%%

VerifyFileContents Property
VerifyVaultJob Object : VerifyFileContents Property

Glossary Item Box

Description

Specifies whether this job verifies the integrity of the data files on disk.

Property type

Read-only property

Syntax

Visual Basic
Public Property VerifyFileContents As Boolean

See Also

VerifyVaultJob Object | VerifyVaultJob Members


%%PageItemTitle%%

VerifyVaultJobOutput Object
Members See Also Send comments

Glossary Item Box

Description

The VerifyVaultJobOutput class represents the output of a vault verification job.

Public Properties

Public Property Errors The error output of the verify vault job.

See Also

VerifyVaultJobOutput Members


%%PageItemTitle%%

Errors Property
VerifyVaultJobOutput Object : Errors Property

Glossary Item Box

Description

The error output of the verify vault job.

Property type

Read-only property

Syntax

Visual Basic
Public Property Errors As Strings

See Also

VerifyVaultJobOutput Object | VerifyVaultJobOutput Members


%%PageItemTitle%%

VersionComment Object
Members See Also Send comments

Glossary Item Box

Description

The VersionComment class represents a version comment of an object.

Public Properties

Public Property LastModifiedBy | Last modified by.
Public Property ObjVer | Object version.
Public Property StatusChanged | Status changed.
Public Property VersionComment | Version comment.

See Also

VersionComment Members


%%PageItemTitle%%

LastModifiedBy Property
VersionComment Object : LastModifiedBy Property

Glossary Item Box

Description

Last modified by.

Property type

Read-only property

Syntax

Visual Basic
Public Property LastModifiedBy As PropertyValue

Return Type

Returns a lookup reference to the user's value list.

Remarks

See the TypedValue class for instructions on how to resolve the lookup reference from the returned PropertyValue object.

See Also

VersionComment Object | VersionComment Members


%%PageItemTitle%%

ObjVer Property
VersionComment Object : ObjVer Property

Glossary Item Box

Description

Object version.

Property type

Read-only property

Syntax

Visual Basic
Public Property ObjVer As ObjVer

Return Type

The ID and version number of the parent object version.

See Also

VersionComment Object | VersionComment Members


%%PageItemTitle%%

StatusChanged Property
VersionComment Object : StatusChanged Property

Glossary Item Box

Description

Status changed.

Property type

Read-only property

Syntax

Visual Basic
Public Property StatusChanged As PropertyValue

Remarks

The timestamp can be extracted from the TypedValue object of the returned PropertyValue.

See Also

VersionComment Object | VersionComment Members


%%PageItemTitle%%

VersionComment Property
VersionComment Object : VersionComment Property

Glossary Item Box

Description

Version comment.

Property type

Read-only property

Syntax

Visual Basic
Public Property VersionComment As PropertyValue

Remarks

The comment string can be extracted from the TypedValue object of the returned PropertyValue.

See Also

VersionComment Object | VersionComment Members


%%PageItemTitle%%

VersionComments Collection
Members See Also Send comments

Glossary Item Box

Description

VersionComments is a collection of VersionComment objects.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

VersionComments Members


%%PageItemTitle%%

Count Property
VersionComments Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

VersionComments Collection | VersionComments Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
VersionComments Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As VersionComment

Parameters

Index
Specifies the item's position in the collection.

See Also

VersionComments Collection | VersionComments Members


%%PageItemTitle%%

View Object
Members See Also Send comments

Glossary Item Box

Description

The View class represents a view.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.

Public Properties

Public Property AccessControlList | The access control list of the view.
Public Property Common | Specifies whether the view is a common view.
Public Property GUID | The GUID of the view as a string.
Public Property HasParent | Specifies whether the view has a parent.
Public Property ID | The ID of the view.
Public Property Levels | The hierarchy level definitions of the view.
Public Property LookInAllVersions | Specifies whether the view looks match in all versions or in only the latest versions.
Public Property Name | The name of the view.
Public Property Parent | The parent of the view. This is valid only if the view has a parent.
Public Property ReturnLatestVisibleVersion | Specifies whether the view returns the latest visible versions or the latest matching versions.
Public Property SearchConditions | The search conditions of the view.
Public Property SearchDef | The search definition of the view.
Public Property SearchFlags | The search flags of the view.
Public Property ViewFlags | Bit flags that provide additional information on the view.
Public Property ViewLocation | The view location of the view.
Public Property ViewType | The type of the view.
Public Property Visible | Specifies whether the view is visible.

Remarks

A view represents a view folder as seen in the M-Files client application. The view can be thought of as a "named search" whose results can be displayed hierarchically. Basically, a view consists of two fundamental and important factors. First, each view has a set of conditions that determines which objects can be seen in the view. This is the "filter" of the view. Second, the view may define one or more "hierarchy levels". Each hierarchy level is an expression. The hierarchy-level expressions determine how the objects that fulfill the conditions of the view are divided into subfolders.

The contents of a view in M-Files Desktop.

See Also

View Members


%%PageItemTitle%%

Clone Method
View Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As View

See Also

View Object | View Members


%%PageItemTitle%%

CloneFrom Method
View
View Object : CloneFrom Method

Glossary Item Box

Description

Copies the content to this object from another object.

Syntax

Visual Basic
Public Sub CloneFrom( _
   ByVal View As View _
)

Parameters

View

See Also

View Object | View Members


%%PageItemTitle%%

AccessControlList Property
View Object : AccessControlList Property

Glossary Item Box

Description

The access control list of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessControlList As AccessControlList

See Also

View Object | View Members


%%PageItemTitle%%

Common Property
View Object : Common Property

Glossary Item Box

Description

Specifies whether the view is a common view.

Property type

Read-write property

Syntax

Visual Basic
Public Property Common As Boolean

See Also

View Object | View Members


%%PageItemTitle%%

GUID Property
View Object : GUID Property

Glossary Item Box

Description

The GUID of the view as a string.

Property type

Read-only property

Syntax

Visual Basic
Public Property GUID As String

See Also

View Object | View Members


%%PageItemTitle%%

HasParent Property
View Object : HasParent Property

Glossary Item Box

Description

Specifies whether the view has a parent.

Property type

Read-write property

Syntax

Visual Basic
Public Property HasParent As Boolean

See Also

View Object | View Members


%%PageItemTitle%%

ID Property
View Object : ID Property

Glossary Item Box

Description

The ID of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

View Object | View Members


%%PageItemTitle%%

Levels Property
View Object : Levels Property

Glossary Item Box

Description

The hierarchy level definitions of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property Levels As ExpressionExs

See Also

View Object | View Members


%%PageItemTitle%%

LookInAllVersions Property
View Object : LookInAllVersions Property

Glossary Item Box

Description

Specifies whether the view looks match in all versions or in only the latest versions.

Property type

Read-write property

Syntax

Visual Basic
Public Property LookInAllVersions As Boolean

See Also

View Object | View Members


%%PageItemTitle%%

Name Property
View Object : Name Property

Glossary Item Box

Description

The name of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

View Object | View Members


%%PageItemTitle%%

Parent Property
View Object : Parent Property

Glossary Item Box

Description

The parent of the view. This is valid only if the view has a parent.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent As Long

Return Type

The ID of the parent view.

Remarks

Use the VaultViewOperations interface to turn the view ID to the View object.

See Also

View Object | View Members


%%PageItemTitle%%

ReturnLatestVisibleVersion Property
View Object : ReturnLatestVisibleVersion Property

Glossary Item Box

Description

Specifies whether the view returns the latest visible versions or the latest matching versions.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReturnLatestVisibleVersion As Boolean

See Also

View Object | View Members


%%PageItemTitle%%

SearchConditions Property
View Object : SearchConditions Property

Glossary Item Box

Description

The search conditions of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property SearchConditions As SearchConditions

Remarks

The search conditions are used to define the contents of the view.

See Also

View Object | View Members


%%PageItemTitle%%

SearchDef Property
View Object : SearchDef Property

Glossary Item Box

Description

The search definition of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property SearchDef As SearchDef

See Also

View Object | View Members


%%PageItemTitle%%

SearchFlags Property
View Object : SearchFlags Property

Glossary Item Box

Description

The search flags of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property SearchFlags As MFSearchFlags

See Also

View Object | View Members


%%PageItemTitle%%

ViewFlags Property
View Object : ViewFlags Property

Glossary Item Box

Description

Bit flags that provide additional information on the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewFlags As MFViewFlag

See Also

View Object | View Members


%%PageItemTitle%%

ViewLocation Property
View Object : ViewLocation Property

Glossary Item Box

Description

The view location of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewLocation As ViewLocation

See Also

View Object | View Members


%%PageItemTitle%%

ViewType Property
View Object : ViewType Property

Glossary Item Box

Description

The type of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property ViewType As MFViewType

See Also

View Object | View Members


%%PageItemTitle%%

Visible Property
View Object : Visible Property

Glossary Item Box

Description

Specifies whether the view is visible.

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible As Boolean

See Also

View Object | View Members


%%PageItemTitle%%

ViewLocation Object
Members See Also Send comments

Glossary Item Box

Description

A class representing the location of a view in folder structure.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property OverlappedFolder | Specifies the property folder this view is overlapping. Valid only if this view location is defined to overlap a property folder.
Public Property Overlapping | Specifies whether the view in this location should replace a property folder in the parent folder.
Public Property ParentFolder | The folder path to the parent folder of the view.

See Also

ViewLocation Members


%%PageItemTitle%%

Clone Method
ViewLocation Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As ViewLocation

See Also

ViewLocation Object | ViewLocation Members


%%PageItemTitle%%

OverlappedFolder Property
ViewLocation Object : OverlappedFolder Property

Glossary Item Box

Description

Specifies the property folder this view is overlapping. Valid only if this view location is defined to overlap a property folder.

Property type

Read-write property

Syntax

Visual Basic
Public Property OverlappedFolder As TypedValue

See Also

ViewLocation Object | ViewLocation Members


%%PageItemTitle%%

Overlapping Property
ViewLocation Object : Overlapping Property

Glossary Item Box

Description

Specifies whether the view in this location should replace a property folder in the parent folder.

Property type

Read-write property

Syntax

Visual Basic
Public Property Overlapping As Boolean

See Also

ViewLocation Object | ViewLocation Members


%%PageItemTitle%%

ParentFolder Property
ViewLocation Object : ParentFolder Property

Glossary Item Box

Description

The folder path to the parent folder of the view.

Property type

Read-write property

Syntax

Visual Basic
Public Property ParentFolder As FolderDefs

See Also

ViewLocation Object | ViewLocation Members


%%PageItemTitle%%

Views Collection
Members See Also Send comments

Glossary Item Box

Description

Views is a collection of View objects.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

Views Members | View Object


%%PageItemTitle%%

Count Property
Views Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

Views Collection | Views Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
Views Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As View

Parameters

Index
Specifies the item's position in the collection.

See Also

Views Collection | Views Members


%%PageItemTitle%%

WeeklyTrigger Object
Members See Also Send comments

Glossary Item Box

Description

The WeeklyTrigger class represents weekly trigger.

Public Properties

Public Property DaysOfTheWeek | Value that describes the days of the week the scheduled job runs. The value can be a combination of the values of the enumeration.
Public Property WeeksInterval | Number of weeks between invocations of a scheduled job.

See Also

WeeklyTrigger Members


%%PageItemTitle%%

DaysOfTheWeek Property
WeeklyTrigger Object : DaysOfTheWeek Property

Glossary Item Box

Description

Value that describes the days of the week the scheduled job runs. The value can be a combination of the values of the enumeration.

Property type

Read-write property

Syntax

Visual Basic
Public Property DaysOfTheWeek As MFTriggerWeekDay

See Also

WeeklyTrigger Object | WeeklyTrigger Members


%%PageItemTitle%%

WeeksInterval Property
WeeklyTrigger Object : WeeksInterval Property

Glossary Item Box

Description

Number of weeks between invocations of a scheduled job.

Property type

Read-write property

Syntax

Visual Basic
Public Property WeeksInterval As Long

See Also

WeeklyTrigger Object | WeeklyTrigger Members


%%PageItemTitle%%

WOPIClientAdditionalData Object
Members See Also Send comments

Glossary Item Box

Description

The WOPI client additional data object.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ActionUrl | The ActionUrl data.
Public Property CultureIdentifier | The CultureIdentifier data.
Public Property HostEditUrl | The HostEditUrl data.
Public Property MainAppURL | The MainAppURL part.
Public Property ReturnURI | The ReturnURI data.
Public Property WOPIEndPoint | The WOPIEndPoint data.

Remarks

Supported in M-Files 21.6.10322.0 and later.

HostEditUrl supported in M-Files 21.10.10725.5 and later.

See Also

WOPIClientAdditionalData Members


%%PageItemTitle%%

Clone Method
WOPIClientAdditionalData Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As WOPIClientAdditionalData

See Also

WOPIClientAdditionalData Object | WOPIClientAdditionalData Members


%%PageItemTitle%%

ActionUrl Property
WOPIClientAdditionalData Object : ActionUrl Property

Glossary Item Box

Description

The ActionUrl data.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionUrl As String

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIClientAdditionalData Object | WOPIClientAdditionalData Members


%%PageItemTitle%%

CultureIdentifier Property
WOPIClientAdditionalData Object : CultureIdentifier Property

Glossary Item Box

Description

The CultureIdentifier data.

Property type

Read-write property

Syntax

Visual Basic
Public Property CultureIdentifier As String

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIClientAdditionalData Object | WOPIClientAdditionalData Members


%%PageItemTitle%%

HostEditUrl Property
WOPIClientAdditionalData Object : HostEditUrl Property

Glossary Item Box

Description

The HostEditUrl data.

Property type

Read-write property

Syntax

Visual Basic
Public Property HostEditUrl As String

Remarks

Supported in M-Files 21.10.10725.5 and later.

See Also

WOPIClientAdditionalData Object | WOPIClientAdditionalData Members


%%PageItemTitle%%

MainAppURL Property
WOPIClientAdditionalData Object : MainAppURL Property

Glossary Item Box

Description

The MainAppURL part.

Property type

Read-write property

Syntax

Visual Basic
Public Property MainAppURL As String

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIClientAdditionalData Object | WOPIClientAdditionalData Members


%%PageItemTitle%%

ReturnURI Property
WOPIClientAdditionalData Object : ReturnURI Property

Glossary Item Box

Description

The ReturnURI data.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReturnURI As String

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIClientAdditionalData Object | WOPIClientAdditionalData Members


%%PageItemTitle%%

WOPIEndPoint Property
WOPIClientAdditionalData Object : WOPIEndPoint Property

Glossary Item Box

Description

The WOPIEndPoint data.

Property type

Read-write property

Syntax

Visual Basic
Public Property WOPIEndPoint As String

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIClientAdditionalData Object | WOPIClientAdditionalData Members


%%PageItemTitle%%

WOPILock Object
Members See Also Send comments

Glossary Item Box

Description

The WOPI lock object.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Lock The Lock data.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPILock Members


%%PageItemTitle%%

Clone Method
WOPILock Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As WOPILock

See Also

WOPILock Object | WOPILock Members


%%PageItemTitle%%

Lock Property
WOPILock Object : Lock Property

Glossary Item Box

Description

The Lock data.

Property type

Read-only property

Syntax

Visual Basic
Public Property Lock As String

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPILock Object | WOPILock Members


%%PageItemTitle%%

WOPIUserSession Object
Members See Also Send comments

Glossary Item Box

Description

The WOPI user session object.

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ActionType | The WOPI action type.
Public Property CsrfToken | The CSRF token.
Public Property ExternalUsername | The name of the external user.
Public Property IsCoauthor | Specifies whether the file is co-authored.
Public Property IsEditAllowed | If this is set to true, the file can be edited in this WOPI user session.
Public Property IsSharedFile | Specifies whether the file is shared.
Public Property Onetimetoken | The one-time token.
Public Property UserAccountName | The name of the user account.
Public Property UserID | The user ID.
Public Property WOPIAccesskey | The unique access key of the public link.
Public Property WOPIUserSessionKey | The unique user session key.

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIUserSession Members


%%PageItemTitle%%

Clone Method
WOPIUserSession Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As WOPIUserSession

See Also

WOPIUserSession Object | WOPIUserSession Members


%%PageItemTitle%%

ActionType Property
WOPIUserSession Object : ActionType Property

Glossary Item Box

Description

The WOPI action type.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActionType As MFWOPIActionType

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIUserSession Object | WOPIUserSession Members


%%PageItemTitle%%

CsrfToken Property
WOPIUserSession Object : CsrfToken Property

Glossary Item Box

Description

The CSRF token.

Property type

Read-only property

Syntax

Visual Basic
Public Property CsrfToken As String

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIUserSession Object | WOPIUserSession Members


%%PageItemTitle%%

ExternalUsername Property
WOPIUserSession Object : ExternalUsername Property

Glossary Item Box

Description

The name of the external user.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalUsername As String

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIUserSession Object | WOPIUserSession Members


%%PageItemTitle%%

IsCoauthor Property
WOPIUserSession Object : IsCoauthor Property

Glossary Item Box

Description

Specifies whether the file is co-authored.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsCoauthor As Boolean

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIUserSession Object | WOPIUserSession Members


%%PageItemTitle%%

IsEditAllowed Property
WOPIUserSession Object : IsEditAllowed Property

Glossary Item Box

Description

If this is set to true, the file can be edited in this WOPI user session.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsEditAllowed As Boolean

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIUserSession Object | WOPIUserSession Members


%%PageItemTitle%%

IsSharedFile Property
WOPIUserSession Object : IsSharedFile Property

Glossary Item Box

Description

Specifies whether the file is shared.

Property type

Read-only property

Syntax

Visual Basic
Public Property IsSharedFile As Boolean

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIUserSession Object | WOPIUserSession Members


%%PageItemTitle%%

Onetimetoken Property
WOPIUserSession Object : Onetimetoken Property

Glossary Item Box

Description

The one-time token.

Property type

Read-only property

Syntax

Visual Basic
Public Property Onetimetoken As String

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIUserSession Object | WOPIUserSession Members


%%PageItemTitle%%

UserAccountName Property
WOPIUserSession Object : UserAccountName Property

Glossary Item Box

Description

The name of the user account.

Property type

Read-only property

Syntax

Visual Basic
Public Property UserAccountName As String

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIUserSession Object | WOPIUserSession Members


%%PageItemTitle%%

UserID Property
WOPIUserSession Object : UserID Property

Glossary Item Box

Description

The user ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserID As ULong

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIUserSession Object | WOPIUserSession Members


%%PageItemTitle%%

WOPIAccesskey Property
WOPIUserSession Object : WOPIAccesskey Property

Glossary Item Box

Description

The unique access key of the public link.

Property type

Read-only property

Syntax

Visual Basic
Public Property WOPIAccesskey As String

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIUserSession Object | WOPIUserSession Members


%%PageItemTitle%%

WOPIUserSessionKey Property
WOPIUserSession Object : WOPIUserSessionKey Property

Glossary Item Box

Description

The unique user session key.

Property type

Read-only property

Syntax

Visual Basic
Public Property WOPIUserSessionKey As String

Remarks

Supported in M-Files 21.6.10322.0 and later.

See Also

WOPIUserSession Object | WOPIUserSession Members


%%PageItemTitle%%

Workflow Object
Members See Also Send comments

Glossary Item Box

Description

A class that represents a single workflow.

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetAsLookup | Gets this workflow as a lookup value.
Public Method GetAsTypedValue | Gets this workflow as a single-select lookup based typed value.

Public Properties

Public Property ID | Workflow ID.
Public Property Name | Workflow name.
Public Property ObjectClass | The class this workflow can be used with. Can be MFBuiltInObjectClassAny.

Remarks

This class provides a simple view to workflows. For more administrative purposes, WorkflowAdmin object can be used.

Workflow properties as seen in M-Files Admin.

See Also

Workflow Members


%%PageItemTitle%%

Clone Method
Workflow Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As Workflow

See Also

Workflow Object | Workflow Members


%%PageItemTitle%%

GetAsLookup Method
Workflow Object : GetAsLookup Method

Glossary Item Box

Description

Gets this workflow as a lookup value.

Syntax

Visual Basic
Public Function GetAsLookup() As Lookup

See Also

Workflow Object | Workflow Members


%%PageItemTitle%%

GetAsTypedValue Method
Workflow Object : GetAsTypedValue Method

Glossary Item Box

Description

Gets this workflow as a single-select lookup based typed value.

Syntax

Visual Basic
Public Function GetAsTypedValue() As TypedValue

See Also

Workflow Object | Workflow Members


%%PageItemTitle%%

ID Property
Workflow Object : ID Property

Glossary Item Box

Description

Workflow ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID As Long

See Also

Workflow Object | Workflow Members


%%PageItemTitle%%

Name Property
Workflow Object : Name Property

Glossary Item Box

Description

Workflow name.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name As String

See Also

Workflow Object | Workflow Members


%%PageItemTitle%%

ObjectClass Property
Workflow Object : ObjectClass Property

Glossary Item Box

Description

The class this workflow can be used with. Can be MFBuiltInObjectClassAny.

Property type

Read-write property

Syntax

Visual Basic
Public Property ObjectClass As Long

See Also

Workflow Object | Workflow Members


%%PageItemTitle%%

WorkflowAdmin Object
Members See Also Send comments

Glossary Item Box

Description

The WorkflowAdmin class represents a single workflow (for administrative operations).

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Description | Workflow description.
Public Property Permissions | Permissions.
Public Property SemanticAliases | The semantic aliases of this workflow.
Public Property States | The states of this workflow.
Public Property StateTransitions | The state transitions of this workflow.
Public Property Workflow | Basic information on the workflow.

See Also

WorkflowAdmin Members


%%PageItemTitle%%

Clone Method
WorkflowAdmin Object : Clone Method

Glossary Item Box

Description

Creates a copy of the object.

Syntax

Visual Basic
Public Function Clone() As WorkflowAdmin

See Also

WorkflowAdmin Object | WorkflowAdmin Members


%%PageItemTitle%%

Description Property
WorkflowAdmin Object : Description Property

Glossary Item Box

Description

Workflow description.

Property type

Read-write property

Syntax

Visual Basic
Public Property Description As String

See Also

WorkflowAdmin Object | WorkflowAdmin Members


%%PageItemTitle%%

Permissions Property
WorkflowAdmin Object : Permissions Property

Glossary Item Box

Description

Permissions.

Property type

Read-write property

Syntax

Visual Basic
Public Property Permissions As AccessControlList

See Also

WorkflowAdmin Object | WorkflowAdmin Members


%%PageItemTitle%%

SemanticAliases Property
WorkflowAdmin Object : SemanticAliases Property

Glossary Item Box

Description

The semantic aliases of this workflow.

Property type

Read-write property

Syntax

Visual Basic
Public Property SemanticAliases As SemanticAliases

See Also

WorkflowAdmin Object | WorkflowAdmin Members


%%PageItemTitle%%

States Property
WorkflowAdmin Object : States Property

Glossary Item Box

Description

The states of this workflow.

Property type

Read-write property

Syntax

Visual Basic
Public Property States As StatesAdmin

See Also

WorkflowAdmin Object | WorkflowAdmin Members


%%PageItemTitle%%

StateTransitions Property
WorkflowAdmin Object : StateTransitions Property

Glossary Item Box

Description

The state transitions of this workflow.

Property type

Read-write property

Syntax

Visual Basic
Public Property StateTransitions As StateTransitions

See Also

WorkflowAdmin Object | WorkflowAdmin Members


%%PageItemTitle%%

Workflow Property
WorkflowAdmin Object : Workflow Property

Glossary Item Box

Description

Basic information on the workflow.

Property type

Read-write property

Syntax

Visual Basic
Public Property Workflow As Workflow

See Also

WorkflowAdmin Object | WorkflowAdmin Members


%%PageItemTitle%%

Workflows Collection
Members See Also Send comments

Glossary Item Box

Description

A collection of workflows.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

Workflows Members


%%PageItemTitle%%

Count Property
Workflows Collection : Count Property

Glossary Item Box

Description

The number of items in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

Workflows Collection | Workflows Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
Workflows Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As Workflow

Parameters

Index
Specifies the item's position in the collection.

See Also

Workflows Collection | Workflows Members


%%PageItemTitle%%

WorkflowsAdmin Collection
Members See Also Send comments

Glossary Item Box

Description

WorkflowsAdmin is a collection of WorkflowAdmin objects.

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

WorkflowsAdmin Members


%%PageItemTitle%%

Add Method
Index
Position at which a new collection member is added. Any non-valid position implies appending.
WorkflowAdmin

The new member to add.

WorkflowsAdmin Collection : Add Method

Glossary Item Box

Description

Adds the item to the collection at the specified position.

Syntax

Visual Basic
Public Sub Add( _
   ByVal Index As Long, _
   ByVal WorkflowAdmin As WorkflowAdmin _
)

Parameters

Index
Position at which a new collection member is added. Any non-valid position implies appending.
WorkflowAdmin

The new member to add.

See Also

WorkflowsAdmin Collection | WorkflowsAdmin Members


%%PageItemTitle%%

Remove Method
Index
Position of the collection member to remove.
WorkflowsAdmin Collection : Remove Method

Glossary Item Box

Description

Removes the item at the specified position from the collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Index As Long _
)

Parameters

Index
Position of the collection member to remove.

See Also

WorkflowsAdmin Collection | WorkflowsAdmin Members


%%PageItemTitle%%

Count Property
WorkflowsAdmin Collection : Count Property

Glossary Item Box

Description

Returns the number of items in this collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Count As Long

See Also

WorkflowsAdmin Collection | WorkflowsAdmin Members


%%PageItemTitle%%

Item Property
Index
Specifies the item's position in the collection.
WorkflowsAdmin Collection : Item Property

Glossary Item Box

Description

Accesses the item at the specified position in the collection.

Property type

Read-only property

Syntax

Visual Basic
Public Property Item( _
   ByVal Index As Long _
) As WorkflowAdmin

Parameters

Index
Specifies the item's position in the collection.

See Also

WorkflowsAdmin Collection | WorkflowsAdmin Members


%%PageItemTitle%%

XMLSearchResult Object
Members See Also Send comments

Glossary Item Box

Description

The XMLSearchResult class represents search results in XML format.

Public Properties

Public Property MoreResults | Specifies whether more results are available.
Public Property SearchResult | The search result as XML.

See Also

XMLSearchResult Members


%%PageItemTitle%%

MoreResults Property
XMLSearchResult Object : MoreResults Property

Glossary Item Box

Description

Specifies whether more results are available.

Property type

Read-only property

Syntax

Visual Basic
Public Property MoreResults As Boolean

See Also

XMLSearchResult Object | XMLSearchResult Members


%%PageItemTitle%%

SearchResult Property
XMLSearchResult Object : SearchResult Property

Glossary Item Box

Description

The search result as XML.

Property type

Read-only property

Syntax

Visual Basic
Public Property SearchResult As String

See Also

XMLSearchResult Object | XMLSearchResult Members


%%PageItemTitle%%

IObjectComparer Interface
Members See Also Send comments

Glossary Item Box

Description

An interface for providing a comparison function for sorting object collections.

Public Methods

Public Method Compare Compares given objects.

Remarks

This interface is used to sort the object versions collection, and to sort search results.

See Also

IObjectComparer Members | Sort Method | Sort Method


%%PageItemTitle%% $$Members$$

IObjectComparer Interface Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Compare Compares given objects.

See Also

IObjectComparer Interface | Sort Method | Sort Method


%%PageItemTitle%%

Compare Method
ObjectVersionDataLeft
ObjectVersionDataRight
IObjectComparer Interface : Compare Method

Glossary Item Box

Description

Compares given objects.

Syntax

Visual Basic
Public Function Compare( _
   ByVal ObjectVersionDataLeft As ObjectVersion, _
   ByVal ObjectVersionDataRight As ObjectVersion _
) As Long

Parameters

ObjectVersionDataLeft
ObjectVersionDataRight

Return Type

If the return value is less than zero, the left object version precedes the right one. If the return value is greater than zero, the right object version precedes the left one. If the return value is zero, the object versions have equal order ranking.

See Also

IObjectComparer Interface | IObjectComparer Members | ObjectFiles Object


%%PageItemTitle%%

IObjectFileComparer Interface
Members See Also Send comments

Glossary Item Box

Description

An interface for providing a comparison function for sorting object file collections.

Public Methods

Public Method Compare Compares given objects.

Remarks

This interface is used to sort the object file collection.

See Also

IObjectFileComparer Members | Sort Method


%%PageItemTitle%% $$Members$$

IObjectFileComparer Interface Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Compare Compares given objects.

See Also

IObjectFileComparer Interface | Sort Method


%%PageItemTitle%%

Compare Method
FileLeft
FileRight
IObjectFileComparer Interface : Compare Method

Glossary Item Box

Description

Compares given objects.

Syntax

Visual Basic
Public Function Compare( _
   ByVal FileLeft As ObjectFile, _
   ByVal FileRight As ObjectFile _
) As Long

Parameters

FileLeft
FileRight

Return Type

If the return value is less than zero, the left file version precedes the right one. If the return value is greater than zero, the right file version precedes the left one. If the return value is zero, the file versions have equal order ranking.

See Also

IObjectFileComparer Interface | IObjectFileComparer Members


%%PageItemTitle%%

MFACLComponentOverrideAccess Enumeration

Glossary Item Box

Description

ACL component override access privileges.

Members

Member | Value | Description
MFACLComponentOverrideAccessGranted | 1 | Component overriding is granted.
MFACLComponentOverrideAccessNone | 0 | No access.


%%PageItemTitle%%

MFACLEnforcingMode Enumeration

Glossary Item Box

Description

Defines how the provided ACL is selected as input for ACL enforcing.

Members

Member | Value | Description
MFACLEnforcingModeAutomatic | 0 | The ACL previously stored for the object is used as the provided ACL.
MFACLEnforcingModeNone | 3 | The object ACL remains untouched.
MFACLEnforcingModeProvided | 1 | The ACL provided by the caller is used.
MFACLEnforcingModeResetToDefault | 2 | The ACL calculated from the properties is used as the provided ACL.


%%PageItemTitle%%

MFACLMode Enumeration

Glossary Item Box

Description

Available ACL modes.

Members

Member | Value | Description
MFACLModeAutomaticPermissionsWithComponents | 1 | Automatic permissions with automatic components.
MFACLModeSimple | 0 | Simple mode.


%%PageItemTitle%%

MFActionType Enumeration

Glossary Item Box

Description

Action type values.

Members

Member | Value | Description
MFActionTypeCreateAssignment | 1 | The action is a 'CreateAssignment' action.
MFActionTypeUnknown | 0 | The action type is unknown.


%%PageItemTitle%%

MFAdditionalClassInfoType Enumeration

Glossary Item Box

Description

Additional class information type values.

Members

Member | Value | Description
MFAdditionalClassInfoTypeAssignment | 1 | The class is an assignment class.
MFAdditionalClassInfoTypeUnknown | 0 | The class type is not known.


%%PageItemTitle%%

MFApplicationLicenseStatus Enumeration

Glossary Item Box

Description

Vault application license status values.

Members

Member | Value | Description
MFApplicationLicenseStatusFormatError | 6 | The license is not accepted.
MFApplicationLicenseStatusGracePeriod | 8 | The installed license is about to expire.
MFApplicationLicenseStatusInstalled | 3 | A license is installed.
MFApplicationLicenseStatusInvalid | 5 | An invalid license is installed.
MFApplicationLicenseStatusNotInstalled | 2 | No license installed.
MFApplicationLicenseStatusNotNeeded | 1 | The application does not require a license.
MFApplicationLicenseStatusTrial | 7 | A trial license is installed.
MFApplicationLicenseStatusUnknown | 0 | Unknown license status.
MFApplicationLicenseStatusValid | 4 | A valid license is installed.


%%PageItemTitle%%

MFAssignmentType Enumeration

Glossary Item Box

Description

Assignment types.

Members

Member | Value | Description
MFAssignmentTypeApproval | 1 | The assignment is an approval assignment.
MFAssignmentTypeTask | 0 | The assignment is a task assignment.


%%PageItemTitle%%

MFAttachVaultOptionsFlag Enumeration

Glossary Item Box

Description

Bit flags that provide information about attach vault options.

Members

Member | Value | Description
MFAttachVaultOptionsFlagDisableEventHandlers | 32 | Specifies whether vault attach disables event handlers.
MFAttachVaultOptionsFlagDisableExportedDataSets | 4 | Specifies whether vault attach disables data set exports.
MFAttachVaultOptionsFlagDisableExportImportJobs | 8 | Specifies whether vault attach disables scheduled export/import jobs.
MFAttachVaultOptionsFlagDisableExternalObjectTypes | 1 | Specifies whether vault attach disables external object types.
MFAttachVaultOptionsFlagDisableExternalSources | 2 | Specifies whether vault attach disables external sources (file/mail).
MFAttachVaultOptionsFlagDisableExternalUserGroups | 16 | Specifies whether vault attach disables external user groups.
MFAttachVaultOptionsFlagDisableNone | 0 | Specifies whether vault attach disables no external connections and event handlers.
MFAttachVaultOptionsFlagDisableRemoteIndexes | 128 | Specifies whether vault attach disables remote indexes such as IDOL and Smart Search indexes.
MFAttachVaultOptionsFlagDisableVaultApplications | 64 | Specifies whether vault attach disables vault applications.


%%PageItemTitle%%

MFAuthType Enumeration

Glossary Item Box

Description

Available authentication types for logging into the document vault.

Members

Member | Value | Description
MFAuthTypeLoggedOnWindowsUser | 1 | Windows authentication with current user credentials.
MFAuthTypeSpecificMFilesUser | 3 | M-Files authentication, user needs to specify the credentials.
MFAuthTypeSpecificWindowsUser | 2 | Windows authentication, user needs to specify the credentials.
MFAuthTypeUnknown | 0 | Unspecified authentication method.


%%PageItemTitle%%

MFAutomaticPermissionsOperationOptions Enumeration

Glossary Item Box

Description

Options for change automatic permissions operation.

Members

Member | Value | Description
MFAutomaticPermissionsOperationOptionsForceActive | 1 | The changed automatic permission components are forced active.
MFAutomaticPermissionsOperationOptionsNone | 0 | None


%%PageItemTitle%%

MFAutomaticValueType Enumeration

Glossary Item Box

Description

Available automatic value types.

Members

Member | Value | Description
MFAutomaticValueTypeAutoNumberSimple | 3 | Simple automatic numbering: the last used value and an increment. Calculated once.
MFAutomaticValueTypeCalculatedWithPlaceholders | 1 | Simple concatenation of properties: A string with property definition placeholders, such as 'PROPERTY_1000 - PROPERTY_1001'.
MFAutomaticValueTypeCalculatedWithVBScript | 2 | Calculated value (VBScript): The VBScript code calculates the value.
MFAutomaticValueTypeNone | 0 | No automatic value.
MFAutomaticValueTypeWithVBScript | 4 | Customized automatic numbering (VBScript): The VBScript code produces the automatic number. Calculated once.


%%PageItemTitle%%

MFAutoStateTransitionMode Enumeration

Glossary Item Box

Description

Automatic state transition modes.

Members

Member | Value | Description
MFASTMModeAssignmentComplete | 6 | After the assignment has been marked complete.
MFASTModeAllowedByScript | 5 | Allowed by VBScript.
MFASTModeAssignmentComplete | 6 | After the assignment has been marked complete.
MFASTModeAssignmentRejected | 7 | After the assignment has been marked rejected.
MFASTModeCriteriaFulfilled | 4 | Criteria fulfilled.
MFASTModeNone | 0 | No automatic state transition.
MFASTModeRelativeTime | 1 | After the specified time period.


%%PageItemTitle%%

MFBackupType Enumeration

Glossary Item Box

Description

Available backup types.

Members

Member | Value | Description
MFBackupTypeDifferential | 1 | Differential backup (changes since the last full backup).
MFBackupTypeFull | 0 | Full backup.


%%PageItemTitle%%

MFBuiltInDocumentClass Enumeration

Glossary Item Box

Description

Document classes readily available in the system.

Members

Member | Value | Description
MFBuiltInDocumentClassOtherDocument | 1 | Other document.
MFBuiltInDocumentClassUnclassifiedDocument | 0 | Document.


%%PageItemTitle%%

MFBuiltInMetadataStructureItemID Enumeration

Glossary Item Box

Description

Metadata structure item IDs readily available in the system.

Members

Member | Value | Description
MFBuiltInMetadataStructureItemIDAll | -1000000 | Metadata structure item ID that represents all the metadata structure items.


%%PageItemTitle%%

MFBuiltInObjectClass Enumeration

Glossary Item Box

Description

Generic class identification codes.

Members

Member | Value | Description
MFBuiltInObjectClassAny | -3 | Any class.
MFBuiltInObjectClassGenericAssignment | -100 | Generic assignment.
MFBuiltInObjectClassNotSet | -2 | Class identifier not set.


%%PageItemTitle%%

MFBuiltInObjectType Enumeration

Glossary Item Box

Description

Object types readily available in the system.

Members

Member | Value | Description
MFBuiltInObjectTypeAssignment | 10 | The assignment object type.
MFBuiltInObjectTypeDocument | 0 | The document object type.
MFBuiltInObjectTypeDocumentCollection | 9 | The document collection type.
MFBuiltInObjectTypeDocumentOrDocumentCollection | -102 | A special value that refers to both the document and the document collection types. Can be used in e.g. search conditions.
MFBuiltInObjectTypeEmail | 20 | The Email object type.
MFBuiltInObjectTypeEmailConversation | 21 | The Email Conversation object type.


%%PageItemTitle%%

MFBuiltInPropertyDef Enumeration

Glossary Item Box

Description

Property definitions readily available in the system.

Members

Member | Value | Description
MFBuiltInPropertyDefAccessedByMe | 81 | The last time the object was accessed by the current user.
MFBuiltInPropertyDefACLChanged | 90 | The date and time of the last change to the ACL of the object version.
MFBuiltInPropertyDefAdditionalClasses | 36 | A list of additional classes for the object.
MFBuiltInPropertyDefAssignedTo | 44 | A list of users to whom the object version is assigned.
MFBuiltInPropertyDefAssignmentDescription | 41 | The assignment description for the current object version assignment.
MFBuiltInPropertyDefClass | 100 | The class of the object.
MFBuiltInPropertyDefClassGroups | 101 | The class group of the object.
MFBuiltInPropertyDefCollectionMemberCollections | 47 | A list of document collections belonging to the document collection.
MFBuiltInPropertyDefCollectionMemberDocuments | 46 | A list of documents belonging to the document collection.
MFBuiltInPropertyDefComment | 33 | Comment text for the object version. Same as MFBuiltInPropertyDefVersionComment.
MFBuiltInPropertyDefCompleted | 98 | Specifies whether or not the assignment has been completed.
MFBuiltInPropertyDefCompletedBy | 45 | A list of users who have completed the current assignment.
MFBuiltInPropertyDefConflictResolved | 96 | The date and time a conflict was last resolved in favor of the object.
MFBuiltInPropertyDefCreated | 20 | The creation date and time of an object.
MFBuiltInPropertyDefCreatedBy | 25 | Identifies the user who created the object.
MFBuiltInPropertyDefCreatedFromExternalLocation | 35 | The external source from which the object was imported.
MFBuiltInPropertyDefDeadline | 42 | The deadline date for the current object version assignment.
MFBuiltInPropertyDefDeleted | 27 | The deletion date and time of the object.
MFBuiltInPropertyDefDeletedBy | 28 | Identifies the user who deleted the object.
MFBuiltInPropertyDefDeletionStatusChanged | 93 | The date and time of the last change to the deletion status of the object.
MFBuiltInPropertyDefFavoriteView | 82 | The 'favorite views' where the object should be shown.
MFBuiltInPropertyDefInReplyTo | 84 | E-mail in-reply-to internet header value.
MFBuiltInPropertyDefInReplyToReference | 85 | E-mail in-reply-to references between documents belonging to the same conversation.
MFBuiltInPropertyDefIsTemplate | 37 | A Boolean property identifying whether the object is a template.
MFBuiltInPropertyDefKeywords | 26 | Keywords for the object. Not included in the sample vault.
MFBuiltInPropertyDefLastModified | 21 | The last modification date and time of an object.
MFBuiltInPropertyDefLastModifiedBy | 23 | Identifies the user who performed the last modification for the object.
MFBuiltInPropertyDefLocation | 103 | The location in a repository.
MFBuiltInPropertyDefMarkedForArchiving | 32 | A Boolean property identifying whether the object is marked for archiving.
MFBuiltInPropertyDefMessageID | 83 | E-mail message-id from internet headers.
MFBuiltInPropertyDefMonitoredBy | 43 | A list of users who are monitoring the current assignment.
MFBuiltInPropertyDefNameOrTitle | 0 | The name or title property definition.
MFBuiltInPropertyDefObjectChanged | 89 | The date and time of the last change to the object.
MFBuiltInPropertyDefObjectID | -102 | This special value is used for referring to Object ID in ObjectTypeColumnMapping.TargetPropertyDef.
MFBuiltInPropertyDefOriginalPath | 75 | The location from which the object was imported to M-Files.
MFBuiltInPropertyDefOriginalPath2 | 77 | The location from which the object was imported to M-Files (continued).
MFBuiltInPropertyDefOriginalPath3 | 78 | The location from which the object was imported to M-Files (continued).
MFBuiltInPropertyDefReference | 76 | A list of referenced documents.
MFBuiltInPropertyDefRejectedBy | 97 | A list of users who have rejected the current assignment.
MFBuiltInPropertyDefReportPlacement | 88 | Report placement.
MFBuiltInPropertyDefReportURL | 87 | Report URL.
MFBuiltInPropertyDefRepository | 102 | The repository of an object.
MFBuiltInPropertyDefSharedFiles | 95 | The shared location paths of the object's shared files.
MFBuiltInPropertyDefSignatureManifestation | 86 | Signature manifestation.
MFBuiltInPropertyDefSingleFileObject | 22 | A Boolean property identifying whether the object is a single-file object.
MFBuiltInPropertyDefSizeOnServerAllVersions | 31 | The total size of all object versions.
MFBuiltInPropertyDefSizeOnServerThisVersion | 30 | The size of this object version.
MFBuiltInPropertyDefState | 39 | The workflow state of the object.
MFBuiltInPropertyDefStateEntered | 40 | The date when the object state was changed to the current state.
MFBuiltInPropertyDefStateTransition | 99 | The workflow state transition of the object.
MFBuiltInPropertyDefStatusChanged | 24 | The date and time of the last status change of the object.
MFBuiltInPropertyDefTraditionalFolder | 34 | A traditional folder containing this object version.
MFBuiltInPropertyDefVaultGUID | 94 | The GUID of the vault that contains or contained the object to which the shortcut object refers to.
MFBuiltInPropertyDefVersionComment | 33 | Comment text for the object version. Same as MFBuiltInPropertyDefComment.
MFBuiltInPropertyDefVersionCommentChanged | 92 | The date and time of the last change to the comment of the object version.
MFBuiltInPropertyDefVersionLabel | 29 | The version label for the object.
MFBuiltInPropertyDefVersionLabelChanged | 91 | The date and time of the last change to the version label of the object version.
MFBuiltInPropertyDefWorkflow | 38 | The workflow for the object.
MFBuiltInPropertyDefWorkflowAssignment | 79 | A property which indicates the assignment related to the workflow of the object.

Remarks

Built-in property definitions and their data types can be inspected by using M-Files Admin.


%%PageItemTitle%%

MFBuiltInUserGroup Enumeration

Glossary Item Box

Description

User groups readily available in the system.

Members

Member | Value | Description
MFBuiltInUserGroupAllInternalAndExternalUsers | 2 | All internal and external users.
MFBuiltInUserGroupAllInternalUsers | 1 | All internal users.


%%PageItemTitle%%

MFBuiltInValueList Enumeration

Glossary Item Box

Description

Value lists readily available in the system.

Members

Member | Value | Description
MFBuiltInValueListAssignments | 10 | A value list containing all the assignments.
MFBuiltInValueListClasses | 1 | A value list containing all the classes.
MFBuiltInValueListClassGroups | 2 | A value list containing all the class groups.
MFBuiltInValueListCollections | 9 | A value list containing all the document collections.
MFBuiltInValueListDocuments | 0 | A value list containing all the documents of the vault.
MFBuiltInValueListExternalLocations | 5 | A value list containing all the external locations.
MFBuiltInValueListSources | 18 | A value list containing all object sources (repositories).
MFBuiltInValueListStates | 8 | A value list containing all the workflow states. This is a sub-list of the MFBuiltInValueListWorkflows value list.
MFBuiltInValueListStateTransitions | 17 | A value list containing all the workflow state transitions. This is a sub-list of the 'MFBuiltInValueListWorkflows' value list.
MFBuiltInValueListTraditionalFolders | 4 | A value list containing all the traditional folders. Note: the value list is hierarchical.
MFBuiltInValueListUserGroups | 16 | A value list containing all the user groups.
MFBuiltInValueListUsers | 6 | A value list containing all the vault users.
MFBuiltInValueListVersionLabels | 3 | A value list containing all the version labels.
MFBuiltInValueListWorkflows | 7 | A value list containing all the workflows.


%%PageItemTitle%%

MFBuiltInView Enumeration

Glossary Item Box

Description

Views that are readily available in the system.

Members

Member | Value | Description
MFBuiltInViewAnyView | -1 | As any view in the view operations.
MFBuiltInViewAssignedToMe | 9 | Assigned-to-me view.
MFBuiltInViewBuiltIn | 13 | Built-in view container.
MFBuiltInViewByID | 12 | ID view.
MFBuiltInViewCheckedOutToCurrentUser | 5 | Checked-out-to-me view.
MFBuiltInViewFavorites | 15 | Favorites view.
MFBuiltInViewLatestSearches | 11 | Latest-searches view container.
MFBuiltInViewOffline | 6 | Offline view container.
MFBuiltInViewOfflineCheckedOut | -9000 | Checked-out view inside the offline view container.
MFBuiltInViewOfflineMarkedForOfflineAvailability | -9001 | Marked-for-offline-availability view inside the offline view container.
MFBuiltInViewRecentlyAccessedByMe | 14 | Recently Accessed by Me view.
MFBuiltInViewRecentlyModifiedByMe | 7 | Recently-modified-by-me view.
MFBuiltInViewTemplates | 8 | Templates view.


%%PageItemTitle%%

MFClientType Enumeration

Glossary Item Box

Description

M-Files client application type identifier.

Members

Member | Value | Description
MFClientTypeGenericServerAPI | 3 | Generic M-Files API client connected to server interface.
MFClientTypeGenericWindowsDesktopAPI | 2 | Generic M-Files API client that is using the Windows desktop client.
MFClientTypeMobileAndroid | 5 | Android client.
MFClientTypeMobileIOS | 6 | iOS client.
MFClientTypeUnidentified | 0 | Unidentified or unknown client.
MFClientTypeVNextDesktop | 7 | vNext client in desktop environment.
MFClientTypeVNextHosted | 10 | vNext client in hosted environment (Office 365).
MFClientTypeVNextMobile | 8 | vNext client in mobile environment.
MFClientTypeVNextWeb | 9 | vNext client in web browser environment.
MFClientTypeWeb | 4 | M-Files Web client.
MFClientTypeWindowsDesktop | 1 | Windows/PC desktop client.

Remarks

MFClientTypeInternalProcess supported in and 21.10.10674.0 later.


%%PageItemTitle%%

MFConditionType Enumeration

Glossary Item Box

Description

Available condition types.

Members

Member | Value | Description
MFConditionTypeContains | 7 | Contains the given text string (similar to LIKE 'xyz').
MFConditionTypeContainsAnyBitwise | 16 | Contains any of the bits of the given number. Treats its operands as a vector of bits rather than a single number.
MFConditionTypeDoesNotContain | 8 | Does not contain the given text string (similar to NOT LIKE 'xyz').
MFConditionTypeDoesNotContainAnyBitwise | 17 | Does not contain any of the bits of the given number. Treats its operands as a vector of bits rather than a single number.
MFConditionTypeDoesNotMatchWildcardPattern | 12 | Does not match the given DOS-style wildcard pattern (such as '*.txt').
MFConditionTypeDoesNotStartWith | 10 | Does not start with the given text string (similar to NOT LIKE 'xyz%').
MFConditionTypeEqual | 1 | Must be equal to.
MFConditionTypeGreaterThan | 3 | Must be greater than.
MFConditionTypeGreaterThanOrEqual | 5 | Must be greater than or equal to.
MFConditionTypeLessThan | 4 | Must be less than.
MFConditionTypeLessThanOrEqual | 6 | Must be less than or equal to.
MFConditionTypeMatchesWildcardPattern | 11 | Matches the given DOS-style wildcard pattern (such as '*.txt').
MFConditionTypeNotEqual | 2 | Must not be equal to.
MFConditionTypeStartsWith | 9 | Starts with the given text string (similar to LIKE 'xyz%').
MFConditionTypeStartsWithAtWordBoundary | 15 | Starts with the given text string at a word boundary. Similar to LIKE 'xyz%', but evaluated at the beginning of each word).


%%PageItemTitle%%

MFContentType Enumeration

Glossary Item Box

Description

Content type definitions.

Members

Member | Value | Description
MFContentTypeEmailAddress | 1 | E-mail address.
MFContentTypeGeneric | 0 | Generic.
MFContentTypeHTML | 4 | HTML.
MFContentTypeRTF | 3 | Rich-text format.
MFContentTypeURL | 2 | Hyperlink.


%%PageItemTitle%%

MFCustomApplicationType Enumeration

Glossary Item Box

Description

Custom application type.

Members

Member | Value | Description
MFCustomApplicationTypeClient | 1 | Client application.
MFCustomApplicationTypeServer | 2 | Server application.
MFCustomApplicationTypeUnspecified | 0 | Unspecified or unknown application type.


%%PageItemTitle%%

MFDataFunction Enumeration

Glossary Item Box

Description

Functions that operate on a property value.

Members

Member | Value | Description
MFDataFunctionDate | 4 | Gets the date part of a date or timestamp value (e.g., 2004-02-15).
MFDataFunctionDaysFrom | 5 | Gets the difference between the current timestamp and a specified date or timestamp value as the number of days (e.g., 8 or -10).
MFDataFunctionDaysTo | 6 | Gets the difference between a specified date or timestamp value and the current timestamp as the number of days (e.g., 10 or -8).
MFDataFunctionInitialCharGroup | 9 | Gets an initial character group from text or a typed value.
MFDataFunctionIntegerSegment | 7 | Gets the integer segment of a value (an integer number or a real number) based on a defined segment size.
MFDataFunctionLeftChars | 8 | Gets a defined number of left characters from text or a typed value.
MFDataFunctionMonth | 2 | Gets the month of a date or timestamp value (e.g., 02).
MFDataFunctionNoOp | 0 | Returns the data without modifying it.
MFDataFunctionYear | 1 | Gets the year of a date or timestamp value (e.g., 2004).
MFDataFunctionYearAndMonth | 3 | Gets the year and month of a date or timestamp value (e.g., 2004-02).


%%PageItemTitle%%

MFDataType Enumeration

Glossary Item Box

Description

Data type definitions.

Members

Member | Value | Description
MFDatatypeACL | 14 | The access control list (ACL).
MFDatatypeBoolean | 8 | Boolean.
MFDatatypeDate | 5 | Date.
MFDatatypeFILETIME | 12 | FILETIME (a 64-bit integer). Not used in the properties.
MFDatatypeFloating | 3 | A double-precision floating point.
MFDatatypeInteger | 2 | A 32-bit integer.
MFDatatypeInteger64 | 11 | A 64-bit integer. Not used in the properties.
MFDatatypeLookup | 9 | Lookup (from a value list).
MFDatatypeMultiLineText | 13 | Multi-line text.
MFDatatypeMultiSelectLookup | 10 | Multiple selection from a value list.
MFDatatypeText | 1 | Text.
MFDatatypeTime | 6 | Time.
MFDatatypeTimestamp | 7 | Timestamp.
MFDatatypeUninitialized | 0 | Unknown type (not yet set to any type).


%%PageItemTitle%%

MFDBEngine Enumeration

Glossary Item Box

Description

Database engine type.

Members

Member | Value | Description
MFDBEngineFirebird | 1 | Firebird.
MFDBEngineMSSQLServer | 2 | Microsoft SQL Server (MS SQL Server).
MFDBEngineNone | 0 | None.


%%PageItemTitle%%

MFDefaultPropertyType Enumeration

Glossary Item Box

Description

Available default property types when importing objects from external sources.

Members

Member | Value | Description
MFDefaultPropertyTypeFixedValue | 1 | Fixed value.
MFDefaultPropertyTypeFromEmail | 4 | A field from an e-mail message.
MFDefaultPropertyTypeFromEmailHeader | 5 | A custom header field from an e-mail message.
MFDefaultPropertyTypeFromFile | 7 | A value read from a file property.
MFDefaultPropertyTypeFromHPDSSXML | 2 | A value read from an XML file produced by HP Digital Sending Software (DSS).
MFDefaultPropertyTypeFromOCR | 6 | A value recognized by OCR.
MFDefaultPropertyTypeFromXML | 3 | A value read from a generic XML file.
MFDefaultPropertyTypeStateTransitionTime | 8 | A time value read from the state transition.
MFDefaultPropertyTypeUndefined | 0 | Unknown type (not initialized to any type).


%%PageItemTitle%%

MFDependencyRelation Enumeration

Glossary Item Box

Description

Dependency relation types.

Members

Member | Value | Description
MFDependencyRelationAutomaticFilling | 1 | A dependent field (property) is filled out automatically based on the value of an owner field (property).
MFDependencyRelationFiltering | 2 | The possible property values of a dependent field (property) are determined based on the value shown in an owner field (property).
MFDependencyRelationNothing | 0 | No dependency relation.


%%PageItemTitle%%

MFEmailField Enumeration

Glossary Item Box

Description

E-mail field types.

Members

Member | Value | Description
MFEmailFieldBody | 5 | Message body.
MFEmailFieldCc | 3 | Cc.
MFEmailFieldDate | 6 | Message timestamp.
MFEmailFieldFrom | 1 | Sender.
MFEmailFieldImportance | 7 | Importance.
MFEmailFieldSensitivity | 8 | Sensitivity.
MFEmailFieldSubject | 4 | Message subject.
MFEmailFieldTo | 2 | Recipient.
MFEmailFieldUndefined | 0 | Unknown field (not initialized to any type).


%%PageItemTitle%%

MFEmailImportance Enumeration

Glossary Item Box

Description

E-mail importance values.

Members

Member | Value | Description
MFEmailImportanceHigh | 2 | High importance.
MFEmailImportanceLow | 0 | Low importance.
MFEmailImportanceNormal | 1 | Normal importance.


%%PageItemTitle%%

MFEmailSensitivity Enumeration

Glossary Item Box

Description

E-mail sensitivity values.

Members

Member | Value | Description
MFEmailSensitivityConfidential | 4 | Confidential e-mail sensitivity.
MFEmailSensitivityNone | 0 | No e-mail sensitivity.
MFEmailSensitivityNormal | 1 | Normal e-mail sensitivity.
MFEmailSensitivityPersonal | 2 | Personal e-mail sensitivity.
MFEmailSensitivityPrivate | 3 | Private e-mail sensitivity.


%%PageItemTitle%%

MFEventHandlerType Enumeration

Glossary Item Box

Description

Event handler type.

Members

Member | Value | Description
MFEventHandlerAfterAddUserGroupMember | 75 | An event that is triggered after a member is added to a user group in the vault.
MFEventHandlerAfterBringOnline | 54 | An event that is triggered after the vault has changed to online state.
MFEventHandlerAfterCancelCheckout | 9 | Event executed after the changes made to an object have been cancelled.
MFEventHandlerAfterCancelCheckoutFinalize | 60 | An event triggered after the undo checkout operation is complete and the previous version can be worked on.
MFEventHandlerAfterCancelCreateObject | 30 | Event executed after the creation of a new object has been cancelled.
MFEventHandlerAfterCheckInChanges | 5 | Event executed after an object has been checked in.
MFEventHandlerAfterCheckInChangesFinalize | 56 | An event executed after an object has been checked in and all consequent operations (e.g. state transitions) are complete.
MFEventHandlerAfterCheckOut | 7 | Event executed after the object has been checked out.
MFEventHandlerAfterCreateLoginAccount | 37 | An event that is triggered after a login account is created in the server.
MFEventHandlerAfterCreateNewObjectFinalize | 3 | Event executed after the creation of a new object has been completed.
MFEventHandlerAfterCreateNewValueListItem | 21 | Event executed after the new value list item has been created.
MFEventHandlerAfterCreateUserAccount | 43 | An event that is triggered after a user account is created in the vault.
MFEventHandlerAfterCreateUserGroup | 49 | An event that is triggered after a user group is created in the vault.
MFEventHandlerAfterCreateView | 69 | An event triggered after a view is created.
MFEventHandlerAfterDeleteObject | 11 | Event executed after an object has been deleted.
MFEventHandlerAfterDeleteView | 73 | An event triggered after a view is deleted.
MFEventHandlerAfterDestroyObject | 13 | Event executed after an object has been destroyed.
MFEventHandlerAfterDestroyObjectVersion | 32 | Event executed after a version of an object has been destroyed.
MFEventHandlerAfterFileDownload | 19 | Event executed after a file of an object has been downloaded from the server.
MFEventHandlerAfterFileUpload | 17 | Event executed after a file of an object has been uploaded to the server.
MFEventHandlerAfterLoginToVault | 23 | Event executed after the user has logged into the vault.
MFEventHandlerAfterLogoutFromVault | 25 | Event executed after the user has logged out from the vault.
MFEventHandlerAfterModifyLoginAccount | 39 | An event that is triggered after a login account is modified in the server.
MFEventHandlerAfterModifyMFilesCredentials | 65 | An event triggered after the credentials of the M-Files login account are changed.
MFEventHandlerAfterModifyUserAccount | 45 | An event that is triggered after a user account is modified in the vault.
MFEventHandlerAfterModifyUserGroup | 51 | An event that is triggered after a user group is modified in the vault.
MFEventHandlerAfterModifyView | 71 | An event triggered after a view is modified.
MFEventHandlerAfterRemoveLoginAccount | 41 | An event that is triggered after a login account is removed from the server.
MFEventHandlerAfterRemoveUserAccount | 47 | An event that is triggered after a user account is removed from the vault.
MFEventHandlerAfterRemoveUserGroup | 53 | An event that is triggered after a user group is removed from the vault.
MFEventHandlerAfterRemoveUserGroupMember | 77 | An event that is triggered after a member is removed from a user group in the vault.
MFEventHandlerAfterRunScheduledJob | 27 | Event executed after a scheduled job has been run at the server.
MFEventHandlerAfterSetObjectPermissions | 15 | Event executed after the permissions of an object have been changed.
MFEventHandlerAfterSetProperties | 2 | Event executed after properties have been set for an object.
MFEventHandlerAfterUndeleteObject | 62 | An event triggered after the object is undeleted.
MFEventHandlerAfterUndeleteObjectFinalize | 63 | An event triggered after the object undelete operation is complete and we can work on the undeleted object.
MFEventHandlerBeforeAddUserGroupMember | 74 | An event that is triggered before a member is added to a user group in the vault.
MFEventHandlerBeforeCancelCheckout | 8 | Event executed before the changes made to an object are cancelled.
MFEventHandlerBeforeCancelCreateObject | 29 | Event executed before the creation of a new object is cancelled.
MFEventHandlerBeforeCheckInChanges | 4 | Event executed before an object is checked in.
MFEventHandlerBeforeCheckInChangesFinalize | 67 | Workflow changes are not allowed.
MFEventHandlerBeforeCheckOut | 6 | Event executed before an object is checked out.
MFEventHandlerBeforeCreateLoginAccount | 36 | An event that is triggered before a login account is created in the server.
MFEventHandlerBeforeCreateNewObjectFinalize | 28 | Event executed before the creation of a new object has been completed.
MFEventHandlerBeforeCreateNewValueListItem | 20 | Event executed before a new value list item is created.
MFEventHandlerBeforeCreateUserAccount | 42 | An event that is triggered before a user account is created in the vault.
MFEventHandlerBeforeCreateUserGroup | 48 | An event that is triggered before a user group is created in the vault.
MFEventHandlerBeforeCreateView | 68 | An event triggered before a view is created.
MFEventHandlerBeforeDeleteObject | 10 | Event executed before an object is deleted.
MFEventHandlerBeforeDeleteView | 72 | An event triggered before a view is deleted.
MFEventHandlerBeforeDestroyObject | 12 | Event executed before an object is destroyed.
MFEventHandlerBeforeDestroyObjectVersion | 31 | Event executed before a version of an object is destroyed.
MFEventHandlerBeforeFileDownload | 18 | Event executed before a file of an object is downloaded from the server.
MFEventHandlerBeforeFileUpload | 16 | Event executed before a file of an object is uploaded to the server.
MFEventHandlerBeforeLoginToVault | 22 | Event executed before the user has logged into the vault.
MFEventHandlerBeforeLogoutFromVault | 24 | Event executed before the user has logged out from the vault.
MFEventHandlerBeforeModifyLoginAccount | 38 | An event that is triggered before a login account is modified in the server.
MFEventHandlerBeforeModifyMFilesCredentials | 64 | An event triggered before the credentials of the M-Files login account are changed.
MFEventHandlerBeforeModifyUserAccount | 44 | An event that is triggered before a user account is modified in the vault.
MFEventHandlerBeforeModifyUserGroup | 50 | An event that is triggered before a user group is modified in the vault.
MFEventHandlerBeforeModifyView | 70 | An event triggered before a view is modified.
MFEventHandlerBeforeRemoveLoginAccount | 40 | An event that is triggered before a login account is removed from the server.
MFEventHandlerBeforeRemoveUserAccount | 46 | An event that is triggered before a user account is removed from the vault.
MFEventHandlerBeforeRemoveUserGroup | 52 | An event that is triggered before a user group is removed from the vault.
MFEventHandlerBeforeRemoveUserGroupMember | 76 | An event that is triggered before a member is removed from a user group in the vault.
MFEventHandlerBeforeReturnView | 66 | An event triggered after a view has been retrieved from the vault but before it is returned to the client.
MFEventHandlerBeforeRunScheduledJob | 26 | Event executed before a scheduled job is run at the server.
MFEventHandlerBeforeSetObjectPermissions | 14 | Event executed before the permissions of an object are changed.
MFEventHandlerBeforeSetProperties | 1 | Event executed before properties are set for an object.
MFEventHandlerBeforeTakeOffline | 55 | An event that is triggered before the vault has changed to offline state.
MFEventHandlerBeforeUndeleteObject | 61 | An event triggered before the object is undeleted.
MFEventHandlerReplication_AfterCheckInChanges | 34 | Event executed after check-in has been performed upon importing object versions to an existing object during content import.
MFEventHandlerReplication_AfterCreateNewObjectFinalize | 33 | Event executed after check-in has been performed upon creating a new object during content import.
MFEventHandlerTypeUndefined | 0 | Undefined event handler.
MFEventHandlerVaultAnonymousExtensionMethod | 78 | Event that is executed only as a response to an explicit request.
MFEventHandlerVaultExtensionMethod | 35 | Event that is executed only as a response to an explicit request.


%%PageItemTitle%%

MFExportContentFlag Enumeration

Glossary Item Box

Description

Bit flags that provide information about a content export job.

Members

Member | Value | Description
MFExportContentFlagClearArchivalMarker | 8 | If present, the 'Marked for archiving' property of the exported objects is reset after the export.
MFExportContentFlagDestroyAfterExport | 4 | If present and exporting full objects, the exported objects are destroyed from the vault after the export.
MFExportContentFlagExportInformationOnDestroyedData | 64 | If present, only information on destroyed objects and object versions is exported.
MFExportContentFlagIndicateDropouts | 1024 | If present, dropout information is exported if a previously exported object is no longer part of the export set.
MFExportContentFlagLatestVersionsOnly | 2 | If present, only the latest version of each object is exported.
MFExportContentFlagNone | 0 | None.
MFExportContentFlagSaveFilesAlsoAsPDFA | 32 | If present, files are also saved as PDF/A.
MFExportContentFlagUseMultipleContentPackages | 128 | If present, the target location represents a folder for multiple content packages.


%%PageItemTitle%%

MFExpressionExFlag Enumeration

Glossary Item Box

Description

Flags that provide additional information on the expression in the context of a view definition.

Members

Member | Value | Description
MFExpressionExFlagNone | 0 | None.
MFExpressionExIgnoreAclsForSubfoldersListing | 1 | The subfolders listing ignores object permissions.
MFExpressionExIncompatibleWithFullTextSearch | 2 | The grouping level is not compatible with full-text search.

Remarks

Supported in M-Files 20.1.8669.3 and later.


%%PageItemTitle%%

MFExpressionType Enumeration

Glossary Item Box

Description

Expression type definitions.

Members

Member | Value | Description
MFExpressionTypeAnyField | 6 | Value of any field (any property, file name, etc.).
MFExpressionTypeFileValue | 4 | File value, such as File Size.
MFExpressionTypeObjectIDSegment | 2 | Object ID segment.
MFExpressionTypePermissions | 7 | Permissions.
MFExpressionTypePropertyValue | 1 | Property value.
MFExpressionTypeStatusValue | 3 | Status value, such as Object ID or CheckedOutToUser.
MFExpressionTypeTypedValue | 5 | Value of the specific data type. Lookup-typed values also specify the value list.
MFExpressionTypeUninitialized | 0 | Uninitialized.


%%PageItemTitle%%

MFExtApplicationPlatform Enumeration

Glossary Item Box

Description

Extension application platform values.

Members

Member | Value | Description
MFExtApplicationPlatformDesktop | 1 | Platform is M-Files Desktop.
MFExtApplicationPlatformNone | 0 | No platform.
MFExtApplicationPlatformWeb | 2 | Platform is M-Files Web.


%%PageItemTitle%%

MFExtensionAuthenticationSpecialUserType Enumeration

Glossary Item Box

Description

Special user type for extension authentication.

Members

Member | Value | Description
MFExtensionAuthenticationSpecialUserTypeCommon | 1 | Common.
MFExtensionAuthenticationSpecialUserTypeIndexer | 2 | Indexer.
MFExtensionAuthenticationSpecialUserTypeNone | 0 | No special type.
MFExtensionAuthenticationSpecialUserTypePermissions | 3 | Permissions.


%%PageItemTitle%%

MFExternalDBRefreshType Enumeration

Glossary Item Box

Description

Available refresh methods for refreshing external value lists and object types.

Members

Member | Value | Description
MFExternalDBRefreshTypeFull | 2 | The full refresh updates all the changes. This operation can take several minutes.
MFExternalDBRefreshTypeNone | 0 | No refresh is performed.
MFExternalDBRefreshTypeQuick | 1 | The quick refresh searches for new items and imports them to M-Files.


%%PageItemTitle%%

MFFacetFilterStatusFlags Enumeration

Glossary Item Box

Description

Facet filter status flags (bitfield flags). Affects facet searching.

Members

Member | Value | Description
MFFacetFilterStatusFlagApplied | 2 | Facet filter has been applied to the current search results.
MFFacetFilterStatusFlagAvailable | 1 | Facet values are available for the current search results.
MFFacetFilterStatusFlagNone | 0 | No flags.


%%PageItemTitle%%

MFFacetSearchFlags Enumeration

Glossary Item Box

Description

Facet search flags (bitfield flags). Affects facet searching.

Members

Member | Value | Description
MFFacetSearchFlagAscendingOrder | 32 | Orders to use an ascending sorting order if the facet values are to be sorted.
MFFacetSearchFlagIgnoreFacetGroupPermissions | 4 | Orders to perform no ACL check on facet groups.
MFFacetSearchFlagIgnoreFacetValuePermissions | 8 | Orders to perform no ACL check on individual facet values.
MFFacetSearchFlagIgnoreSearchPermissions | 2 | Orders to perform no ACL check on the underlying search results.
MFFacetSearchFlagNone | 0 | No flags.
MFFacetSearchFlagOverrideByConfiguration | 64 | Orders to override the facet search parameters by configuration if available.
MFFacetSearchFlagSortFacetValues | 16 | Orders to sort facet values in descending occurrence order within each facet group.


%%PageItemTitle%%

MFFileDataStorage Enumeration

Glossary Item Box

Description

File data storage type of a vault.

Members

Member | Value | Description
MFFileDataStorageDB | 2 | Database storage (the file data is stored in a database).
MFFileDataStorageDefault | 0 | Default. Means that the file data storage is automatically selected based on the database engine.
MFFileDataStorageDisk | 1 | On-disk storage (the file data is stored on a local or remote disk).
MFFileDataStorageExternal | 3 | External storage identified by a connection string, e.g., a Windows Azure's BLOB Storage.


%%PageItemTitle%%

MFFileFormat Enumeration

Glossary Item Box

Description

File format for download.

Members

Member | Value | Description
MFFileFormatDisplayOnlyPDF | 2 | PDF for display purposes only (printing, copying, etc. disabled).
MFFileFormatNative | 0 | Native file format.
MFFileFormatPDF | 1 | PDF.


%%PageItemTitle%%

MFFileInformationType Enumeration

Glossary Item Box

Description

File information type values.

Members

Member | Value | Description
MFFileInformationTypeEmailMessage | 1 | The file is an e-mail message.
MFFileInformationTypeUnknown | 0 | The file type is unknown.


%%PageItemTitle%%

MFFileOpenMethod Enumeration

Glossary Item Box

Description

Available methods for opening an object file in an application.

Members

Member | Value | Description
MFFileOpenMethodEdit | 3 | Open for editing; the file is automatically checked out.
MFFileOpenMethodOpen | 1 | Default file open behavior; a checkout prompt may be displayed.
MFFileOpenMethodShowInShell | 0 | Displays the file in the M-Files user interface window.
MFFileOpenMethodView | 2 | Open for viewing; no checkout prompt.


%%PageItemTitle%%

MFFileProperty Enumeration

Glossary Item Box

Description

Windows file properties.

Members

Member | Value | Description
MFFilePropertyArchive | 10 | Archive attribute.
MFFilePropertyCreatedAt | 4 | Created at time.
MFFilePropertyDirectory | 3 | Parent directory.
MFFilePropertyExtension | 2 | File extension.
MFFilePropertyHidden | 9 | Hidden attribute.
MFFilePropertyLastAccessed | 6 | Last accessed time.
MFFilePropertyLastModified | 5 | Last modified time.
MFFilePropertyName | 1 | File name.
MFFilePropertyReadOnly | 8 | Read-only attribute.
MFFilePropertySize | 7 | File size.


%%PageItemTitle%%

MFFileSizePrecision Enumeration

Glossary Item Box

Description

File size precision.

Members

Member | Value | Description
MFFileSizePrecisionEstimate | 1 | The file size is an estimate.
MFFileSizePrecisionExact | 0 | The file size is exact.
MFFileSizePrecisionUnknown | 2 | The file size is unknown.


%%PageItemTitle%%

MFFileValueType Enumeration

Glossary Item Box

Description

Available conditions regarding file information.

Members

Member | Value | Description
MFFileValueTypeChangeTime | 5 | The fileâ€™s change time.
MFFileValueTypeCreationTime | 4 | The fileâ€™s creation time.
MFFileValueTypeDuplicatesOnly | 8 | Specifies whether the object has one or more duplicates.
MFFileValueTypeFileID | 3 | File ID.
MFFileValueTypeFileName | 1 | File name (title + extension), can include DOS wildcards (such as *.txt).
MFFileValueTypeFileSize | 2 | File size in bytes.
MFFileValueTypeHasFiles | 0 | Specifies whether the object contains one or more files.
MFFileValueTypeLinkedToExtLoc | 6 | Specifies whether the file is linked to an external location (Yes/No).
MFFileValueTypeLinkedToExtLocID | 7 | The ID of the external location to which the file is linked. NULL if not linked.

Remarks

MFFileValueTypeDuplicatesOnly supported in M-Files 21.12.10943.6 and later.


%%PageItemTitle%%

MFFileVerVersionType Enumeration

Glossary Item Box

Description

Indirect file version type enumeration.

Members

Member | Value | Description
MFFileVerVersionTypeAny | 2 | A version that represents any file version.
MFFileVerVersionTypeLatest | 1 | A version that represents the latest file version.
MFFileVerVersionTypeSpecific | 3 | A version that represents a reference to a specific version.
MFFileVerVersionTypeUninitialized | 0 | A non-initialized version.


%%PageItemTitle%%

MFFolderColumnId Enumeration

Glossary Item Box

Description

Reserved IDs for folder columns. If the columns represents a true property definition value, the property definition is is used as column id.

Members

Member | Value | Description
MFFolderColumnIdCheckOutAt | -6 | The identifier of the 'Date-Time' column.
MFFolderColumnIdCheckoutTo | -5 | The identifier of the 'Checked Out To' column.
MFFolderColumnIdDateCreated | -13 | The identifier of the 'Date Created' column.
MFFolderColumnIdDateModified | -14 | The identifier of the 'Date Modified' column.
MFFolderColumnIdExportedFile | -1000000 | The identifier of the 'Exported File' column.
MFFolderColumnIdHasAssignments | -22 | The identifier of the 'Has Assignments' column.
MFFolderColumnIdHasRelationships | -17 | The identifier of the 'Has Relationships' column.
MFFolderColumnIdIdSegment | -1000001 | The identifier of the ID Segment column.
MFFolderColumnIdLocation | -11 | The identifier of the 'Location' column.
MFFolderColumnIdName | -1 | The identifier of the 'Name' column.
MFFolderColumnIdObjectDispId | -7 | The identifier of the 'ID' column (for display purposes).
MFFolderColumnIdObjectPermissions | -20 | The identifier of the 'Permissions' column.
MFFolderColumnIdObjectType | -19 | The identifier of the 'Object Type' column.
MFFolderColumnIdObjectVersion | -8 | The identifier of the 'Version' column.
MFFolderColumnIdRelationshipDesc | -16 | The identifier of the 'Description' column of a relationships view.
MFFolderColumnIdRelationshipTargetVer | -18 | The identifier of the 'Target Version' column of a relationships view.
MFFolderColumnIdRelLocation | -12 | The identifier of the 'Relative Location' column. Used for special purposes only.
MFFolderColumnIdScore | -15 | The identifier of the 'Score' column.
MFFolderColumnIdShLastModifiedBy | -10 | The identifier of the 'User' column. Available in History view only.
MFFolderColumnIdShStatusChanged | -9 | The identifier of the 'Date-Time' column. Available in History view only.
MFFolderColumnIdSize | -3 | The identifier of the 'Size' column.
MFFolderColumnIdStatus | -4 | The identifier of the 'Status' column.
MFFolderColumnIdType | -2 | The identifier of the 'Type' column, basic type info.
MFFolderColumnIdTypeEx | -21 | The identifier of the 'Type' column, extended type info.


%%PageItemTitle%%

MFFolderContentItemType Enumeration

Glossary Item Box

Description

Folder content item types.

Members

Member | Value | Description
MFFolderContentItemTypeExternalViewFolder | 5 | External view folder.
MFFolderContentItemTypeObjectVersion | 4 | Object version.
MFFolderContentItemTypePropertyFolder | 2 | Property folder.
MFFolderContentItemTypeTraditionalFolder | 3 | Traditional folder.
MFFolderContentItemTypeUnknown | 0 | Unknown.
MFFolderContentItemTypeViewFolder | 1 | View folder.


%%PageItemTitle%%

MFFolderDefType Enumeration

Glossary Item Box

Description

Folder definition types.

Members

Member | Value | Description
MFFolderDefTypeAnyFolder | 1 | Any type of folder. For example, a view folder or a traditional folder.
MFFolderDefTypeExterViewFolder | 6 | External view folder.
MFFolderDefTypePropertyFolder | 3 | Property folder (virtual folder).
MFFolderDefTypeSearchFolder | 5 | Search folder (extended view folder).
MFFolderDefTypeTraditionalFolder | 4 | Traditional folder.
MFFolderDefTypeUnknown | 0 | Unknown.
MFFolderDefTypeViewFolder | 2 | View folder.


%%PageItemTitle%%

MFFolderListingAlgorithm Enumeration

Glossary Item Box

Description

Folder listing algorithm. Used to optimize property folder listings on intermediate view levels.

Members

Member | Value | Description
MFFolderListingAlgorithmGetValuesByDistinctUse | 2 | Gets matching values (folders) based on their distinct use in the objects.
MFFolderListingAlgorithmNone | 0 | None (no manual determination, use the program's own heuristics). If this is used, a folder listing algorithm is determined automatically.
MFFolderListingAlgorithmTestEachValue | 1 | Tests each value (folder) separately but uses a single SQL query.
MFFolderListingAlgorithmTestEachValueWithSeparateQueries | 3 | Tests each value (folder) separately, uses a separate SQL query for each folder to be tested.


%%PageItemTitle%%

MFFolderListingColumnFlags Enumeration

Glossary Item Box

Description

Folder listing column flags.

Members

Member | Value | Description
MFFolderListingColumnFlagsHideColumnText | 2 | Hides the column text.
MFFolderListingColumnFlagsSelectIfLeftOfSelectedMainColumn | 1 | Displays the column with selected background color if the column on the left is selected.


%%PageItemTitle%%

MFFolderListingItemGroupingMode Enumeration

Glossary Item Box

Description

Folder listing item grouping mode. Some modes can be combined.

Members

Member | Value | Description
MFFolderListingItemGroupingModeGroupObjectsByObjectType | 1 | Group the listing objects by object type.
MFFolderListingItemGroupingModeGroupViewsAndFoldersByType | 1024 | Group the view and folder items by their types.
MFFolderListingItemGroupingModeNoGrouping | 0 | No grouping.
MFFolderListingItemGroupingModeUnspecified | -1 | Unspecified grouping mode.


%%PageItemTitle%%

MFFolderListingViewMode Enumeration

Glossary Item Box

Description

Folder listing view modes.

Members

Member | Value | Description
MFFolderListingViewModeContent | 8 | Listing in content mode.
MFFolderListingViewModeDetails | 4 | Listing in details mode.
MFFolderListingViewModeIcon | 1 | Listing in icon mode.
MFFolderListingViewModeList | 3 | Listing in list mode.
MFFolderListingViewModeSmallIcon | 2 | Listing in small icon mode.
MFFolderListingViewModeThumbnail | 5 | Listing in thumbnail mode.
MFFolderListingViewModeThumbstrip | 7 | Listing in thumbstrip mode.
MFFolderListingViewModeTile | 6 | Listing in tile mode.


%%PageItemTitle%%

MFFolderUIStateLocationType Enumeration

Glossary Item Box

Description

Folder location types for UI state settings.

Members

Member | Value | Description
MFFolderUIStateLocationTypeClearLocalCacheUI | 12 | Special folder that displays the non-document files in the local client cache.
MFFolderUIStateLocationTypeCollectionMembersUI | 10 | Special folder that displays document collection members.
MFFolderUIStateLocationTypeHistoryUI | 8 | Special folder that displays the object history.
MFFolderUIStateLocationTypeLocalTemporaryItemsContainer | 15 | Container of local temporary files/folders.
MFFolderUIStateLocationTypeObjectFilesContainer | 5 | Object folder, contains object files.
MFFolderUIStateLocationTypeObjectsContainer | 4 | View folder that contains objects only.
MFFolderUIStateLocationTypePropertyFoldersContainer | 3 | View folder that contains property folders.
MFFolderUIStateLocationTypeRelationshipsUIAllTab | 14 | Special folder that displays all relationships of an object.
MFFolderUIStateLocationTypeRelationshipsUIFromTab | 9 | Special folder that displays relationships out from the object.
MFFolderUIStateLocationTypeRelationshipsUIToTab | 13 | Special folder that displays relationships in to the object.
MFFolderUIStateLocationTypeRootFolder | 1 | Folder location type that indicates the vault root folder.
MFFolderUIStateLocationTypeSearchResultsContainer | 7 | Search folder.
MFFolderUIStateLocationTypeSubobjectsUI | 11 | Special folder that displays subobjects of an object.
MFFolderUIStateLocationTypeTraditionalFolder | 6 | Traditional folder.
MFFolderUIStateLocationTypeUnknown | 0 | Unknown folder location type.
MFFolderUIStateLocationTypeViewFoldersContainer | 2 | View folder that acts as a container for other views.


%%PageItemTitle%%

MFFormattingType Enumeration

Glossary Item Box

Description

Available formatting types.

Members

Member | Value | Description
MFFormattingTypeNone | 0 | No formatting.


%%PageItemTitle%%

MFFullTextSearchFlags Enumeration

Glossary Item Box

Description

Full-text search flags (bitfield flags).

Members

Member | Value | Description
MFFullTextSearchFlagsLookInFileData | 536870912 | Looks for matches in the file data of objects.
MFFullTextSearchFlagsLookInMetaData | 268435456 | Looks for matches in the metadata (properties) of objects.
MFFullTextSearchFlagsNone | 0 | None (indicates a basic Boolean search).
MFFullTextSearchFlagsStemming | 4 | Enables stemming for all words in the search request. This includes inflected forms of the searched word.
MFFullTextSearchFlagsTypeAllWords | 131072 | Finds all of the words in the search request.
MFFullTextSearchFlagsTypeAnyWords | 262144 | Finds any of the words in the search request.


%%PageItemTitle%%

MFHistoryRetrievalMode Enumeration

Glossary Item Box

Description

The mode of operation while retrieving history information.

Members

Member | Value | Description
MFHistoryRetrievalAscending | 1 | Ascending. The retrieved history will be ordered so that the earliest entry is listed as the first one.
MFHistoryRetrievalDescending | 2 | Descending. The retrieved history will be ordered so that the latest entry is listed as the first one.
MFHistoryRetrievalRelaxed | 0 | Relaxed. The retrieved history will not be processed.

Remarks

Supported in M-Files 19.5.7811.5 and later.


%%PageItemTitle%%

MFilesURLType Enumeration

Glossary Item Box

Description

Available M-Files URL types.

Members

Member | Value | Description
MFilesURLTypeEdit | 3 | Specifies an URL for performing the open-for-edit action for the target file.
MFilesURLTypeOpen | 1 | Specifies an URL for performing the default open action for the target file.
MFilesURLTypeShow | 0 | Specifies an URL for showing the object version. The URL does not open the target file.
MFilesURLTypeShowMetadata | 6 | Specifies an URL for showing the metadata card for the target object.
MFilesURLTypeView | 2 | Specifies an URL for performing the read-only open action for the target file.


%%PageItemTitle%%

MFImpersonationType Enumeration

Glossary Item Box

Description

Enumeration for the impersonation types.

Members

Member | Value | Description
MFImpersonationTypeExtAccount | 2 | Specific account for an external facility or service such as a database server.
MFImpersonationTypeLocalSystem | 0 | Local System account.
MFImpersonationTypeSpecificAccount | 1 | Specific Windows account.


%%PageItemTitle%%

MFImportContentFlag Enumeration

Glossary Item Box

Description

Bit flags that provide information about a content import job.

Members

Member | Value | Description
MFImportContentFlagDeleteContentPackage | 4 | If present, the content package is deleted after the import.
MFImportContentFlagDoNotImportObjectDestructions | 64 | If present, information on object destructions is not imported.
MFImportContentFlagForceNoStructureIdUpdate | 16384 | Forces the target vault to keep existing structure item GUIDs.
MFImportContentFlagImportCheckoutStates | 16 | If present, the checkout states of objects are imported.
MFImportContentFlagNone | 0 | None.
MFImportContentFlagOmitDoneFile | 32768 | Prevents the 'done' file creation.
MFImportContentFlagUseMultipleContentPackages | 1 | If present, the location represents a folder with multiple content packages.
MFImportContentFlagUseNamesAsAliases | 128 | If present, the incoming name of a structure item is used as its alias if no other alias is available.


%%PageItemTitle%%

MFIndirectPropertyIDLevelType Enumeration

Glossary Item Box

Description

Indirect property ID level types.

Members

Member | Value | Description
MFIndirectPropertyIDLevelTypeObjectType | 1 | Object type.
MFIndirectPropertyIDLevelTypePropertyDef | 0 | Property definition.
MFIndirectPropertyIDLevelTypeStateChanger | 2 | State changer.


%%PageItemTitle%%

MFLatestSpecificBehavior Enumeration

Glossary Item Box

Description

Specifies how the object version parameter is treated.

Members

Member | Value | Description
MFLatestSpecificBehaviorAutomatic | 3 | Automatically chooses the LatestOnly behavior (L folder) if the object version is the latest version. Otherwise, it chooses the SpecificOnly behavior (S folder). Only one location is ever returned when using this method.
MFLatestSpecificBehaviorLatest | 2 | Returns a location in the L (Latest) folder only. (Otherwise the latest version is shown in both the L and S folders.)
MFLatestSpecificBehaviorNormal | 0 | Normal behavior can return locations in both the L and S folders.
MFLatestSpecificBehaviorSpecific | 1 | Returns a location in the S (Specific) folder only, even if evaluating the latest version.


%%PageItemTitle%%

MFLicenseType Enumeration

Glossary Item Box

Description

Available license types.

Members

Member | Value | Description
MFLicenseTypeConcurrentUserLicense | 2 | Concurrent user license.
MFLicenseTypeNamedUserLicense | 1 | Named user license.
MFLicenseTypeNone | 0 | No license.
MFLicenseTypeReadOnlyLicense | 3 | Read-only license.


%%PageItemTitle%%

MFLoginAccountType Enumeration

Glossary Item Box

Description

Available account types of logins.

Members

Member | Value | Description
MFLoginAccountTypeMFiles | 1 | Specifies the login with M-Files credentials.
MFLoginAccountTypeWindows | 2 | Specifies the login with Windows credentials.


%%PageItemTitle%%

MFLoginServerRole Enumeration

Glossary Item Box

Description

Flags for various user roles in server operations.

Members

Member | Value | Description
MFLoginServerRoleBackupOperator | 4 | Backup operator.
MFLoginServerRoleLogIn | 8 | Allows login to the server.
MFLoginServerRoleNone | 0 | None.
MFLoginServerRoleSystemAdministrator | 1 | System administrator.
MFLoginServerRoleVaultCreator | 2 | Vault creator.


%%PageItemTitle%%

MFMetadataStructureItem Enumeration

Glossary Item Box

Description

Types of metadata structure elements.

Members

Member | Value | Description
MFMetadataStructureItemClass | 3 | Class
MFMetadataStructureItemClassGroup | 9 | Class group.
MFMetadataStructureItemNamedACL | 6 | Named access control list.
MFMetadataStructureItemNone | 0 | None.
MFMetadataStructureItemObjectType | 1 | Object type. This can imply either a real object type or a value list.
MFMetadataStructureItemPropertyDef | 2 | Property definition.
MFMetadataStructureItemState | 5 | State.
MFMetadataStructureItemStateTransition | 16 | State transition.
MFMetadataStructureItemUser | 7 | User.
MFMetadataStructureItemUserGroup | 8 | User group.
MFMetadataStructureItemValueList | 14 | Value list.
MFMetadataStructureItemValueListItem | 13 | Value list item.
MFMetadataStructureItemVaultEventHandler | 15 | Vault-specific event handler.
MFMetadataStructureItemViewDef | 10 | View definition.
MFMetadataStructureItemWorkflow | 4 | Workflow.


%%PageItemTitle%%

MFMetadataStructureSelectorFlags Enumeration

Glossary Item Box

Description

Metadata structure selector flags.

Members

Member | Value | Description
MFMetadataStructureSelectorFlagsIncludeExistingDependencies | 8 | Selects the existing dependencies of the selected item (the dependencies exist in the target vault).
MFMetadataStructureSelectorFlagsIncludeNewDependencies | 4 | Selects the new dependencies of the selected item (the dependencies do not exist in the target vault).
MFMetadataStructureSelectorFlagsNone | 0 | No metadata selection flags.
MFMetadataStructureSelectorFlagsSelectExisting | 2 | Selects existing items (items that exist in the target vault).
MFMetadataStructureSelectorFlagsSelectNew | 1 | Selects new items (items that do not exist in the target vault).


%%PageItemTitle%%

MFMetadataSyncFormat Enumeration

Glossary Item Box

Description

Property formats in synchronizing file content with current metadata.

Members

Member | Value | Description
MFMetadataSyncFormatExcel | 1 | Microsoft Excel
MFMetadataSyncFormatPowerPoint | 2 | Microsoft PowerPoint
MFMetadataSyncFormatWord | 0 | Microsoft Word


%%PageItemTitle%%

MFNamedACLType Enumeration

Glossary Item Box

Description

Named ACL types.

Members

Member | Value | Description
MFNamedACLTypeInternal | 2 | Internal named ACLs
MFNamedACLTypeNone | 0 | No named ACL.
MFNamedACLTypeNormal | 1 | Normal named ACL (available for selection in the UI).


%%PageItemTitle%%

MFNamedValueType Enumeration

Glossary Item Box

Description

Named value types in named value storage operations.

Members

Member | Value | Description
MFAdminConfiguration | 7 | Configuration value type (admin-readable/admin-writable).
MFConfigurationValue | 3 | Configuration value type (user readable/admin writable. Writing requires 'change metadata structure' permission).
MFFolderConfiguration | 6 | Configuration value type (user readable/admin writable. Writing requires 'manage common views' permission).
MFPrivateUserDefinedValue | 9 | Configuration value type for private user data (user readable/writable).
MFRegistryValue | 5 | Registry based value type (user readable).
MFSystemAdminConfiguration | 8 | Configuration value type (admin-readable/system admin writable).
MFUserDefinedValue | 4 | User defined value type (user readable/writable).


%%PageItemTitle%%

MFObjectAccess Enumeration

Glossary Item Box

Description

Available object access privileges.

Members

Member | Value | Description
MFObjectAccessAttachObjects | 16 | Attach objects.
MFObjectAccessChangePermissions | 4 | Change permissions.
MFObjectAccessDelete | 8 | Delete.
MFObjectAccessEdit | 2 | Edit.
MFObjectAccessNone | 0 | No access.
MFObjectAccessRead | 1 | Read.


%%PageItemTitle%%

MFObjectCapabilityFlag Enumeration

Glossary Item Box

Description

Bit flags that describe the capabilities of an object.

Members

Member | Value | Description
MFObjectCapabilityFlagAddAndRemoveFiles | 8192 | Adding and removing files is allowed.
MFObjectCapabilityFlagAllCapabilities | -1 | All object capabilities.
MFObjectCapabilityFlagCanBeDeleted | 8 | The object can be deleted.
MFObjectCapabilityFlagCanBeDestroyed | 16 | The object can be destroyed.
MFObjectCapabilityFlagCanBeRenamed | 64 | The object can be renamed
MFObjectCapabilityFlagCanBeUndeleted | 32 | The object can be undeleted.
MFObjectCapabilityFlagCanChangeFileType | 16384 | Requires M-Files 19.2.7378.0 or later.
MFObjectCapabilityFlagCanHaveHistory | 1 | The object can have history.
MFObjectCapabilityFlagCanHaveRelationships | 2 | The object can have relationships.
MFObjectCapabilityFlagEditableAssignments | 256 | The assignment functions are available for the object.
MFObjectCapabilityFlagEditableFiles | 1024 | The files of the object can be edited.
MFObjectCapabilityFlagEditableMetadata | 128 | The metadata of the object can be edited.
MFObjectCapabilityFlagEditableOldVersionDetails | 4 | The old version details of the object are editable.
MFObjectCapabilityFlagEditableVersionComments | 2048 | The version comments of the object can be edited.
MFObjectCapabilityFlagEditableWorkflows | 512 | The workflow capabilities are available for the object.
MFObjectCapabilityFlagNone | 0 | No object capabilities.
MFObjectCapabilityFlagSingleFileMultiFileConversion | 4096 | The object can be converted from a single-file document to a multi-file document and conversely from a multi-file document to a single-file document.


%%PageItemTitle%%

MFObjectDataRequestErrorTolerance Enumeration

Glossary Item Box

Description

The available error tolerance modes for object data requests.

Members

Member | Value | Description
MFObjectDataRequestAllowMissingObjectVersions | 1 | The operation is allowed to continue regardless of missing object versions.
MFObjectDataRequestFailOnAnyError | 0 | Any error causes the operation to be stopped.

Remarks

Supported in M-Files 19.6.7900.4 and later.


%%PageItemTitle%%

MFObjectDataRequestFlags Enumeration

Glossary Item Box

Description

Object data request flags (bitfield flags) describe what type of object data is requested.

Members

Member | Value | Description
MFObjectDataRequestAcl | 4 | Access control list information is requested.
MFObjectDataRequestNone | 0 | No data is requested.
MFObjectDataRequestObjectInfo | 1 | Object information is requested.
MFObjectDataRequestObjectPermissionsForClient | 8 | Object permissions for the client are requested.
MFObjectDataRequestProperties | 2 | Property values are requested.
MFObjectDataRequestPropertiesForDisplay | 16 | Display properties are requested.

Remarks

Supported in M-Files 19.4.7683.3 and later.


%%PageItemTitle%%

MFObjectDataRequestVersionType Enumeration

Glossary Item Box

Description

The available version types for object data requests.

Members

Member | Value | Description
MFObjectDataRequestLatestCheckedInVersions | 2 | Object data is requested for the latest checked-in versions.
MFObjectDataRequestLatestVersions | 1 | Object data is requested for the latest versions.
MFObjectDataRequestSpecificVersions | 0 | Object data is requested for specific versions.

Remarks

Supported in M-Files 19.6.7900.4 and later.


%%PageItemTitle%%

MFObjectOperationFlags Enumeration

Glossary Item Box

Description

Object operation flags.

Members

Member | Value | Description
MFObjectOperationFlagChangeACLInAllVersions | 32 | The permissions should be updated for all versions.
MFObjectOperationFlagDisallowNameChange | 4 | Changing the object name is not allowed.
MFObjectOperationFlagNone | 0 | None
MFObjectOperationFlagRequireChangeSecurityAccess | 8 | The current user must have change security access to the modified object after the operation is completed.
MFObjectOperationFlagRequireEditAccess | 2 | The current user must have edit access to the modified object after the operation is completed.
MFObjectOperationFlagRequireFullAccess | 16 | The current user must have full access to the modified object after the operation is completed.
MFObjectOperationFlagRequireReadAccess | 1 | The current user must have read access to the modified object after the operation is completed.
MFObjectOperationFlagRequireSomeAccess | 64 | The current user must have access to the modified object after the operation is completed.


%%PageItemTitle%%

MFObjectTypeAccess Enumeration

Glossary Item Box

Description

Available object type access privileges.

Members

Member | Value | Description
MFObjectTypeAccessAddNewItems | 2 | Create objects of this type.
MFObjectTypeAccessNone | 0 | No access.
MFObjectTypeAccessSeeName | 1 | See the name of this object type.


%%PageItemTitle%%

MFObjectVersionFlag Enumeration

Glossary Item Box

Description

Bit flags that provide additional information on the object version.

Members

Member | Value | Description
MFObjectVersionFlagCompleted | 1 | Completed (e.g., indicates an assignment that has been marked complete).
MFObjectVersionFlagHasFileDuplicates | 8 | HasFileDuplicates (indicates if the object has duplicate file content).
MFObjectVersionFlagHasRelatedObjects | 2 | HasRelatedObjects (indicates if the object has relations to/from other objects).
MFObjectVersionFlagNone | 0 | None.

Remarks

MFObjectVersionFlagHasFileDuplicates supported in M-Files 20.2.8777.3 and later.


%%PageItemTitle%%

MFObjectWindowMode Enumeration

Glossary Item Box

Description

Available metadata card modes.

Members

Member | Value | Description
MFObjectWindowModeEdit | 3 | The default edit mode.
MFObjectWindowModeEditApplicationModal | 4 | The object shown in the object window is currently open in the application, too. Does not allow the file name to change.
MFObjectWindowModeInsert | 0 | The default insert mode.
MFObjectWindowModeInsertSaveAsType | 2 | Shows file type selection in the metadata card. The selectable file types can be specified using ObjectCreationInfo.
MFObjectWindowModeInsertSourceFiles | 1 | The source files specified in ObjectCreationInfo are added to the new object.


%%PageItemTitle%%

MFObjectWindowResultCode Enumeration

Glossary Item Box

Description

The user's response to the metadata card.

Members

Member | Value | Description
MFObjectWindowResultCodeCancel | 1 | The user cancelled the operation.
MFObjectWindowResultCodeOk | 0 | The user applied the changes.
MFObjectWindowResultCodeOkToAll | 2 | The user applied the changes to all objects.
MFObjectWindowResultCodeSkipThis | 3 | The user skipped a single object.


%%PageItemTitle%%

MFObjVerVersionType Enumeration

Glossary Item Box

Description

Indirect version type enumeration.

Members

Member | Value | Description
MFObjVerVersionTypeAll | 3 | A version that represents all object versions.
MFObjVerVersionTypeAny | 2 | A version that represents any object version.
MFObjVerVersionTypeLatest | 1 | A version that represents the latest object version.
MFObjVerVersionTypeSpecific | 4 | A version that represents a reference to a specific version.
MFObjVerVersionTypeUninitialized | 0 | A non-initialized version.


%%PageItemTitle%%

MFOCRDimensionUnit Enumeration

Glossary Item Box

Description

Dimension units in optical character recognition (OCR) operation.

Members

Member | Value | Description
MFOCRDimensionUnitInchX100 | 2 | Inches (100-fold integer representation for 1/100 in precision).
MFOCRDimensionUnitMillimeterX10 | 1 | Millimeters (10-fold integer representation for 1/10 mm precision).
MFOCRDimensionUnitPixel | 0 | Pixels.


%%PageItemTitle%%

MFOCRLanguage Enumeration

Glossary Item Box

Description

Language hints in optical character recognition (OCR) operation.

Members

Member | Value | Description
MFOCRLanguageAfrikaans | 39 |
MFOCRLanguageAlbanian | 40 |
MFOCRLanguageBasque | 45 |
MFOCRLanguageBrazilian | 19 |
MFOCRLanguageBulgarian | 38 |
MFOCRLanguageByeloRussian | 35 |
MFOCRLanguageCatalan | 41 |
MFOCRLanguageCroatian | 28 |
MFOCRLanguageCzech | 23 |
MFOCRLanguageDanish | 11 |
MFOCRLanguageDutch | 17 |
MFOCRLanguageEnglishBr | 4 |
MFOCRLanguageEnglishUS | 3 |
MFOCRLanguageEstonian | 14 |
MFOCRLanguageFinnish | 9 |
MFOCRLanguageFrench | 6 |
MFOCRLanguageGalician | 20 |
MFOCRLanguageGerman | 5 |
MFOCRLanguageGreek | 22 |
MFOCRLanguageHungarian | 24 |
MFOCRLanguageIcelandic | 21 |
MFOCRLanguageIrishGaelic | 42 |
MFOCRLanguageItalian | 8 |
MFOCRLanguageLatvian | 15 |
MFOCRLanguageLithuanian | 16 |
MFOCRLanguageLuxembourgish | 31 |
MFOCRLanguageMacedonian | 37 |
MFOCRLanguageMexican | 46 |
MFOCRLanguageNeutral | 1 | Latin-8 character set without vocabularies.
MFOCRLanguageNone | 0 | No language specified.
MFOCRLanguageNorwegian | 12 |
MFOCRLanguageNumbersOnly | 2 |
MFOCRLanguageNynorsk | 13 |
MFOCRLanguagePolish | 25 |
MFOCRLanguagePortuguese | 18 |
MFOCRLanguageRomanian | 26 |
MFOCRLanguageRussian | 34 |
MFOCRLanguageScottishGaelic | 43 |
MFOCRLanguageSerbian | 29 |
MFOCRLanguageSlovak | 27 |
MFOCRLanguageSlovenian | 30 |
MFOCRLanguageSpanish | 7 |
MFOCRLanguageSwedish | 10 |
MFOCRLanguageSwissGerman | 32 |
MFOCRLanguageTurkish | 33 |
MFOCRLanguageUkrainian | 36 |
MFOCRLanguageWelsh | 44 |


%%PageItemTitle%%

MFOCRZoneRecognitionMode Enumeration

Glossary Item Box

Description

Zone recognition modes in optical character recognition (OCR) operation.

Members

Member | Value | Description
MFOCRZoneRecognitionModeAutoDetectZones | 2 | Recognize all auto-detected zones.
MFOCRZoneRecognitionModeNoZoneRecognition | 0 | No zone recognition.
MFOCRZoneRecognitionModeRecognizeSpecifiedZones | 1 | Recognize user-defined zones.


%%PageItemTitle%%

MFOfflineTransitionResultFlags Enumeration

Glossary Item Box

Description

Status flags for an offline transition.

Members

Member | Value | Description
MFOfflineTransitionResultFlagLoggedOut | 2 | The user logged out during the transition.
MFOfflineTransitionResultFlagNone | 0 | Offline transition was not performed.
MFOfflineTransitionResultFlagStatusChanged | 1 | Offline transition was successful.


%%PageItemTitle%%

MFOnlineTransitionResultFlags Enumeration

Glossary Item Box

Description

Status flags for an online transition.

Members

Member | Value | Description
MFOnlineTransitionResultFlagNone | 0 | Online transition was not performed.
MFOnlineTransitionResultFlagStatusChanged | 1 | Online transition was successful.


%%PageItemTitle%%

MFParentChildBehavior Enumeration

Glossary Item Box

Description

Parent-child behavior enumeration (affects searching and view levels).

Members

Member | Value | Description
MFParentChildBehaviorIncludeChildValues | 1 | Accepts matches to child values as well.
MFParentChildBehaviorIncludeParentValues | 2 | Accepts matches to parent values as well.
MFParentChildBehaviorNone | 0 | No special behavior.


%%PageItemTitle%%

MFPasswordHashAlgorithm Enumeration

Glossary Item Box

Description

Password hash algorithm identifier.

Members

Member | Value | Description
MFMd5 | 0 | MD5 with fixed salt.
MFPbkdf2WithSha512And100000Iters | 2 | PBKDF2 with HMAC-SHA512 as pseudorandom function and iteration count 100000.
MFUndefined | 1 | Algorithm not defined.


%%PageItemTitle%%

MFPermission Enumeration

Glossary Item Box

Description

Access control entry rights.

Members

Member | Value | Description
MFPermissionAllow | 1 | Allowed.
MFPermissionDeny | 0 | Denied.
MFPermissionNotSet | 2 | Not set.


%%PageItemTitle%%

MFPermissionsExpressionType Enumeration

Glossary Item Box

Description

Available types of permission expressions.

Members

Member | Value | Description
MFACL | 0 | The access control list (ACL). Cannot be used as a search criterion.
MFDeletableBy | 5 | Deletable by the user/group.
MFEditableBy | 2 | Editable by the user/group.
MFFullControlBy | 4 | Full control by the user/group.
MFObjectsAttachableToThisItemBy | 6 | Objects attachable to this item by user/group.
MFPermissionsChangeableBy | 3 | Permissions may be changed by the user/group.
MFVisibleTo | 1 | Visible to the user/group.


%%PageItemTitle%%

MFPredefinedSearchFilterType Enumeration

Glossary Item Box

Description

Definition for various predefined filters that the user can select on the search bar.

Members

Member | Value | Description
MFPredefinedSearchFilterTypeDocumentsAccessedByMeLastMonth | 30006 | Search for documents that the user has accessed within the last month.
MFPredefinedSearchFilterTypeDocumentsAccessedByMeLastWeek | 30005 | Search for documents that the user has accessed within the last week.
MFPredefinedSearchFilterTypeDocumentsAccessedByMeLastYear | 30007 | Search for documents that the user has accessed within the last year.
MFPredefinedSearchFilterTypeDocumentsAccessedByMeToday | 30004 | Search for documents that the user has accessed today.
MFPredefinedSearchFilterTypeDocumentsModifiedLastMonth | 30002 | Search for documents that have been modified within the last month.
MFPredefinedSearchFilterTypeDocumentsModifiedLastWeek | 30001 | Search for documents that have been modified within the last week.
MFPredefinedSearchFilterTypeDocumentsModifiedLastYear | 30003 | Search for documents that have been modified within the last year.
MFPredefinedSearchFilterTypeDocumentsModifiedToday | 30000 | Search for documents that have been modified today.
MFPredefinedSearchFilterTypeObjectType | 1 | Explicitly selected object type condition.
MFPredefinedSearchFilterTypeUnspecified | 0 | The filter has not been specified. For backward compatibility the object type condition is used if defined. Otherwise 'All object types' condition is used.


%%PageItemTitle%%

MFProductMode Enumeration

Glossary Item Box

Description

Available product modes.

Members

Member | Value | Description
MFProductModeBusiness | 2 | Paid-for product with some limitations (M-Files Business).
MFProductModeExpress | 1 | Free product (M-Files Express).
MFProductModeFull | 0 | Full product (M-Files Enterprise).


%%PageItemTitle%%

MFPropertyDefAccess Enumeration

Glossary Item Box

Description

Available property definition access privileges.

Members

Member | Value | Description
MFPropertyDefAccessEdit | 2 | Edit values of this property.
MFPropertyDefAccessNone | 0 | No access.
MFPropertyDefAccessSee | 1 | See this property.


%%PageItemTitle%%

MFRelationshipsMode Enumeration

Glossary Item Box

Description

Available relationships modes.

Members

Member | Value | Description
MFRelationshipsModeAll | 3 | Relationships FROM and TO the specified object.
MFRelationshipsModeFromThisObject | 1 | Relationships FROM the specified object.
MFRelationshipsModeToThisObject | 2 | Relationships TO the specified object.


%%PageItemTitle%%

MFScheduledJobType Enumeration

Glossary Item Box

Description

Types of scheduled jobs available for server maintenance.

Members

Member | Value | Description
MFScheduledJobTypeArchiveOldVersions | 6 | Scheduled job for moving old object versions to a content package.
MFScheduledJobTypeBackup | 1 | Scheduled job for making a backup of a vault or master database.
MFScheduledJobTypeCopyVault | 3 | Scheduled job for making a copy of a vault.
MFScheduledJobTypeExportContent | 5 | Scheduled job for content export.
MFScheduledJobTypeImportContent | 7 | Scheduled job for content import.
MFScheduledJobTypeMigrateVault | 10 | Scheduled job for migrating from Firebird to MS SQL Sever.
MFScheduledJobTypeOptimizeVault | 8 | Scheduled job for performing vault optimization.
MFScheduledJobTypeRecalculate | 9 | Scheduled job for recalculating property values.
MFScheduledJobTypeRestore | 2 | Scheduled job for restoring a vault from a backup or restoring a master backup.
MFScheduledJobTypeUninitialized | 0 | An unknown scheduled job type.
MFScheduledJobTypeVerifyVault | 4 | Scheduled job for verifying the vault.
MFScheduledJobUpdateFileEncryptionStatus | 11 | Scheduled job for updating the file encryption statuses.

Remarks

The MFScheduledJobUpdateFileEncryptionStatus field requires M-Files 19.9.8227.1 or later.


%%PageItemTitle%%

MFSearchFlags Enumeration

Glossary Item Box

Description

Search flags (bitfield flags). Affects searching and view levels.

Members

Member | Value | Description
MFSearchFlagDisableRelevancyRanking | 16 | Search results are not sorted according to their relevancy.
MFSearchFlagIncludeUnmanagedObjects | 64 | Include unmanaged objects in the search results.
MFSearchFlagLookAllObjectTypes | 4 | Perform a separate search for each object type and merges the results.
MFSearchFlagLookInAllVersions | 1 | Orders to look for matches in all object versions. By default, only the latest object versions are included in the search.
MFSearchFlagNone | 0 | No flags.
MFSearchFlagResultsFromEachRepository | 128 | Limits the search results per search location instead of limiting the total number of results from all vaults and repositories. This ensures that the search results include items from all search locations with search hits.
MFSearchFlagReturnLatestVisibleVersion | 2 | Orders to return the latest version for each object, regardless of whether it is an actual matching version. This flag is effective only if MFSearchFlagLookInAllVersions is on.


%%PageItemTitle%%

MFServerConnection Enumeration

Glossary Item Box

Description

States of the server connection and authentication.

Members

Member | Value | Description
MFServerConnectionAnonymous | 2 | The connection to the server was successful, but the credentials were incorrect.
MFServerConnectionAuthenticated | 1 | The connection to the server and the authentication was successful.
MFServerConnectionNone | 0 | No connection.


%%PageItemTitle%%

MFSharedLinkType Enumeration

Glossary Item Box

Description

The type of the shared link pointing to a document.

Members

Member | Value | Description
MFSharedLinkTypeCoAuthoring | 1 | A link to a document shared for co-authoring.
MFSharedLinkTypeReadOnly | 0 | A link to a document shared for reading.


%%PageItemTitle%%

MFSignaturePromptInfoType Enumeration

Glossary Item Box

Description

Electronic signature prompt information type values.

Members

Member | Value | Description
MFSignaturePromptInfoTypeFixed | 0 | Prompt information is fixed.
MFSignaturePromptInfoTypeMetadataBased | 2 | Prompt information is based on metadata.
MFSignaturePromptInfoTypeSelectable | 1 | Prompt information is user-selectable.


%%PageItemTitle%%

MFSoftwarePlatformType Enumeration

Glossary Item Box

Description

Platform indicators for the API.

Members

Member | Value | Description
MFSoftwarePlatformTypeWin32 | 0 | 32-bit Windows.
MFSoftwarePlatformTypeX64 | 1 | 64-bit Windows (x64).


%%PageItemTitle%%

MFSpecialObjectFlag Enumeration

Glossary Item Box

Description

Bit flags that indicate special objects such as shortcuts and conflicts.

Members

Member | Value | Description
MFSpecialObjectFlagConflict | 16 | If present, indicates conflict objects.
MFSpecialObjectFlagDeleted | 2 | If present, indicates deleted objects. Not a persistent value.
MFSpecialObjectFlagFolder | 128 | If present, indicates that the object is a folder.
MFSpecialObjectFlagHasExternalData | 256 | If present, indicates that the object has external data.
MFSpecialObjectFlagHasSharedFiles | 8 | If present, indicates that the object has shared files. Not a persistent value.
MFSpecialObjectFlagNone | 0 | None.
MFSpecialObjectFlagNormal | 64 | If present, indicates normal objects. Effectively the same meaning as MFSpecialObjectFlagNone.
MFSpecialObjectFlagRecentlyAccessedByValid | 4 | If present, indicates the Recently Accessed By field being valid. Not a persistent value.
MFSpecialObjectFlagShortcut | 1 | If present, indicates shortcut objects.
MFSpecialObjectFlagUnmanagedReference | 512 | If present, indicates that the object is an unmanaged reference object.


%%PageItemTitle%%

MFStatusType Enumeration

Glossary Item Box

Description

Available conditions related to status information.

Members

Member | Value | Description
MFStatusTypeCheckedOut | 0 | The object's checked-out state.
MFStatusTypeCheckedOutAt | 2 | The date when the object was checked out.
MFStatusTypeCheckedOutTo | 1 | The user who has checked out the object.
MFStatusTypeDeleted | 5 | The deletion state of the object.
MFStatusTypeExtID | 8 | External ID.
MFStatusTypeIsLatestCheckedInVersion | 7 | The version must be the latest checked-in version.
MFStatusTypeLatestOrSpecific | 9 | The latest version / specific version indicator. For the latest version, the indicator yields 'Latest' and 'Specific'. For others, the indicator yields only 'Specific'.
MFStatusTypeObjectFlags | 11 | The object flags of the object. Does not include the deleted flag.
MFStatusTypeObjectID | 3 | The ID of the object.
MFStatusTypeObjectTypeAndID | 10 | The type and ID of the object.
MFStatusTypeObjectTypeID | 6 | The ID of the object type.
MFStatusTypeObjectVersionID | 4 | The ID of the object version.
MFStatusTypeOriginalObjectID | 14 | The ID of the object in the vault in which the object was originally created.
MFStatusTypeOriginalObjectIDSegment | 15 | The ID segment of the object in the vault in which the object was originally created. Segment size is always 1000.
MFStatusTypeOriginalObjectType | 13 | The type of the object in the vault in which the object was originally created.
MFStatusTypeOriginalVaultGUID | 12 | The GUID of the vault in which the object was originally created.


%%PageItemTitle%%

MFStringDataType Enumeration

Glossary Item Box

Description

String data type values.

Members

Member | Value | Description
MFStringDataTypeJSON | 0 | JSON.
MFStringDataTypeXML | 1 | XML.


%%PageItemTitle%%

MFTaskQueueProcessingBehavior Enumeration

Glossary Item Box

Description

Specifies how tasks are processed in a task queue.

Members

Member | Value | Description
MFProcessingBehaviorConcurrent | 1 | Tasks in this queue may be carried out concurrently.
MFProcessingBehaviorSequential | 0 | Tasks in this queue are carried out one by one, in the order they have been added to the queue.

Remarks

Requires M-Files 19.3.7499.1 or later.


%%PageItemTitle%%

MFTaskState Enumeration

Glossary Item Box

Description

The possible states of an asynchronous task.

Members

Member | Value | Description
MFTaskStateCanceled | 4 | Task processing has been canceled.
MFTaskStateCompleted | 2 | The task has been successfully processed.
MFTaskStateFailed | 3 | Processing the task has failed.
MFTaskStateInProgress | 1 | The task is currently being processed.
MFTaskStateNone | 5 | State information does not apply to this task.
MFTaskStateWaiting | 0 | The initial state. The task is pending for processing.

Remarks

Requires M-Files 19.3.7499.1 or later. The MFTaskStateCanceled field requires M-Files 19.7.8028.5 or later.


%%PageItemTitle%%

MFTextContentExtractionFlags Enumeration

Glossary Item Box

Description

Bitfield flags for the content extraction process when retrieving the text content of a file.

Members

Member | Value | Description
MFTextContentExtractionFlagsNone | 0 | None.
MFTextContentExtractionFlagsUnpackContainers | 1 | Specifies whether a container object should be unpacked for content extraction.
MFTextContentExtractionFlagsUsePlainTextCache | 2 | Use plain text cache. This makes other options, such as "UnpackContainers" ineffective. The operation returns the text content with global defaults in same way it is returned for e.g. search indexing.


%%PageItemTitle%%

MFTriggerMonth Enumeration

Glossary Item Box

Description

Defines the months as used in triggers.

Members

Member | Value | Description
MFTriggerMonthApril | 8 | The scheduled job will run in April.
MFTriggerMonthAugust | 128 | The scheduled job will run in August.
MFTriggerMonthDecember | 2048 | The scheduled job will run in December.
MFTriggerMonthEveryMonth | 4095 | The scheduled job will run in every month.
MFTriggerMonthFebruary | 2 | The scheduled job will run in February.
MFTriggerMonthJanuary | 1 | The scheduled job will run in January.
MFTriggerMonthJuly | 64 | The scheduled job will run in July.
MFTriggerMonthJune | 32 | The scheduled job will run in June.
MFTriggerMonthMarch | 4 | The scheduled job will run in March.
MFTriggerMonthMay | 16 | The scheduled job will run in May.
MFTriggerMonthNovember | 1024 | The scheduled job will run in November.
MFTriggerMonthOctober | 512 | The scheduled job will run in October.
MFTriggerMonthSeptember | 256 | The scheduled job will run in September.


%%PageItemTitle%%

MFTriggerType Enumeration

Glossary Item Box

Description

Defines the types of triggers associated with a scheduled job.

Members

Member | Value | Description
MFTriggerTypeDaily | 1 | Trigger is set to run the task on a daily interval.
MFTriggerTypeMonthlyDate | 3 | Trigger is set to run the task on a specific day(s) of the month.
MFTriggerTypeMonthlyDOW | 4 | Trigger is set to run the task on specific days, weeks, and months.
MFTriggerTypeOnce | 0 | Trigger is set to run the task a single time.
MFTriggerTypeWeekly | 2 | Trigger is set to run the work item on specific days of a specific week of a specific month.


%%PageItemTitle%%

MFTriggerWeekDay Enumeration

Glossary Item Box

Description

Defines the weekdays as used in triggers.

Members

Member | Value | Description
MFTriggerWeekDayEveryDay | 125 | The scheduled job will run on every day of the week.
MFTriggerWeekDayFriday | 32 | The scheduled job will run on Friday.
MFTriggerWeekDayMonday | 2 | The scheduled job will run on Monday.
MFTriggerWeekDaySaturday | 64 | The scheduled job will run on Saturday.
MFTriggerWeekDaySunday | 1 | The scheduled job will run on Sunday.
MFTriggerWeekDayThursday | 16 | The scheduled job will run on Thursday.
MFTriggerWeekDayTuesday | 4 | The scheduled job will run on Tuesday.
MFTriggerWeekDayWednesday | 8 | The scheduled job will run on Wednesday.


%%PageItemTitle%%

MFTriggerWeekOfMonth Enumeration

Glossary Item Box

Description

Defines a week of a month as used in triggers.

Members

Member | Value | Description
MFTriggerWeekOfMonthFirstWeek | 1 | The scheduled job will run between the first and seventh day of the month.
MFTriggerWeekOfMonthFourthWeek | 4 | The task will run between the 22nd and 28th of the month.
MFTriggerWeekOfMonthLastWeek | 5 | The task will run between the last seven days of the month.
MFTriggerWeekOfMonthSecondWeek | 2 | The task will run between the eighth and 14th day of the month.
MFTriggerWeekOfMonthThirdWeek | 3 | The task will run between the 15th and 21st day of the month.


%%PageItemTitle%%

MFUpdateType Enumeration

Glossary Item Box

Description

Available update types for property definitions.

Members

Member | Value | Description
MFUpdateTypeClientAuto | 2 | A property that is automatically set and updated by the client. The only difference between this and type eUpdateTypeNormal is that the user should not be prompted to enter the value of this type of property.
MFUpdateTypeNormal | 0 | A normal, user-settable property.
MFUpdateTypeServerAuto | 1 | A property that is automatically set and updated by the server. If a client supplies such properties in the set of operations, they are ignored by the server.


%%PageItemTitle%%

MFUserAccountVaultRole Enumeration

Glossary Item Box

Description

Flags for the various user roles for accessing a vault.

Members

Member | Value | Description
MFUserAccountVaultRoleAnonymousUser | 65536 | Anonymous user.
MFUserAccountVaultRoleCannotManagePrivateViews | 32768 | Cannot manage private views and notification rules.
MFUserAccountVaultRoleChangeMetadataStructure | 256 | Change metadata structure.
MFUserAccountVaultRoleChangeObjectSecurity | 128 | Change permissions for all objects.
MFUserAccountVaultRoleCreateObjects | 4 | Can create documents or other objects.
MFUserAccountVaultRoleDefaultRoles | 3078 | The default vault roles for a normal user.
MFUserAccountVaultRoleDefineTemplates | 4096 | Manage templates (obsolete).
MFUserAccountVaultRoleDestroyObjects | 32 | Destroy objects.
MFUserAccountVaultRoleForceUndoCheckout | 64 | Force undo checkout.
MFUserAccountVaultRoleFullControl | 1 | Full control of vault.
MFUserAccountVaultRoleInternalUser | 1024 | Internal user (as opposed to external user).
MFUserAccountVaultRoleLogIn | 2 | Can log into the vault.
MFUserAccountVaultRoleManageCommonViews | 8192 | Manage common views and notification rules.
MFUserAccountVaultRoleManageTraditionalFolders | 2048 | Can create and modify traditional folders.
MFUserAccountVaultRoleManageUserAccounts | 512 | Manage user accounts.
MFUserAccountVaultRoleManageWorkflows | 16384 | Manage workflows.
MFUserAccountVaultRoleNone | 0 | None.
MFUserAccountVaultRoleSeeAllObjects | 8 | See and read all vault content (including deleted objects).
MFUserAccountVaultRoleUndeleteObjects | 16 | See and undelete deleted objects.

Remarks

MFUserAccountVaultRoleCannotManagePrivateViews supported in M-Files 20.10.9524.7 and later.

MFUserAccountVaultRoleAnonymousUser supported in M-Files 21.12.10943.6 and later.


%%PageItemTitle%%

MFUserOrUserGroupType Enumeration

Glossary Item Box

Description

Types of users or user groups.

Members

Member | Value | Description
MFUserOrUserGroupTypePropertyBasedPseudoUser | 4 | Property-based pseudo user. Indirectly specifies a user or users on the basis of a property value (meaning "the user(s) specified in the property X").
MFUserOrUserGroupTypePseudoUser | 3 | Worklow state pseudo user. Indirectly specifies a user on the basis of a state ID (meaning "the user who moved the object into state X").
MFUserOrUserGroupTypeUnknown | 0 | Unknown user type.
MFUserOrUserGroupTypeUserAccount | 1 | User account.
MFUserOrUserGroupTypeUserGroup | 2 | User group.


%%PageItemTitle%%

MFValidationType Enumeration

Glossary Item Box

Description

Available validation types.

Members

Member | Value | Description
MFValidationTypeNone | 0 | No validation.
MFValidationTypeRegularExpression | 1 | A regular expression string, e.g., for validating a phone number.
MFValidationTypeVBScript | 2 | VBScript code for performing the validation.


%%PageItemTitle%%

MFValueListItemPropertyDef Enumeration

Glossary Item Box

Description

Pseudo property definitions of the value list items.

Members

Member | Value | Description
MFValueListItemPropertyDefDeleted | 5 | Deleted status of the value list item.
MFValueListItemPropertyDefExtID | 7 | External ID (display ID) of the value list item.
MFValueListItemPropertyDefID | 1 | Value list item ID.
MFValueListItemPropertyDefName | 2 | Value list item name.
MFValueListItemPropertyDefObjectType | 6 | Object type of the value list item.
MFValueListItemPropertyDefOwner | 3 | Owner of the value list item.
MFValueListItemPropertyDefParent | 4 | Parent of the value list item.


%%PageItemTitle%%

MFValueListSortingType Enumeration

Glossary Item Box

Description

Available sort modes for value lists.

Members

Member | Value | Description
MFValueListSortingTypeByExtID | 1 | Sort by external ID.
MFValueListSortingTypeByName | 0 | Sort by display name.


%%PageItemTitle%%

MFVaultAccess Enumeration

Glossary Item Box

Description

Available vault access rights.

Members

Member | Value | Description
MFVaultAccessChangeAssignments | 8388608 | Modify all assignment information.
MFVaultAccessChangeDocSecurity | 32 | Change documents' security settings.
MFVaultAccessChangeFullControlRole | 256 | Add/remove the full control role.
MFVaultAccessChangeMetaDataStructure | 64 | Change metadata structure.
MFVaultAccessChangeObjectStates | 4194304 | Change the state of an object regardless of the state's ACL.
MFVaultAccessCreateDocs | 1 | Create documents.
MFVaultAccessDestroyDocs | 8 | Destroy documents.
MFVaultAccessEditAllDocs | 2048 | Modify all documents (excluding changing security settings).
MFVaultAccessExportContent | 8192 | Export content to a content package or move old versions of objects to a content package.
MFVaultAccessForceUndoCheckout | 16 | Force undo check-out.
MFVaultAccessImportContent | 16384 | Import content from a content package.
MFVaultAccessLicenseAllowsModifications | 262144 | The license of the user allows modifications.
MFVaultAccessManageCommonNotificationRules | 134217728 | Create, modify, and delete common notification rules.
MFVaultAccessManageCommonUISettings | 33554432 | Manage common display (UI) settings.
MFVaultAccessManageCommonViews | 16777216 | Create, modify, and delete common views.
MFVaultAccessManageEvents | 524288 | Enable or disable event logging, delete a range of events, and get all events of the vault.
MFVaultAccessManageExternalLocations | 131072 | Add, modify, or remove external locations.
MFVaultAccessManageTraditionalFolders | 1048576 | Create, modify, and delete traditional folders.
MFVaultAccessManageUserAccounts | 128 | Manage user accounts.
MFVaultAccessManageVLItemsFromClient | 65536 | Manage (for instance add, modify, remove) value list items from client side.
MFVaultAccessMaterializeViews | 536870912 | Materialize views.
MFVaultAccessNone | 0 | No vault access.
MFVaultAccessSeeAllDocs | 2 | See all documents (including deleted ones).
MFVaultAccessSeeDeletedDocs | 268435456 | See deleted objects. However, seeing a deleted object requires the user to have read access to the object or the vault-level SeeAllDocs access right.
MFVaultAccessUndeleteDocs | 4 | Undelete documents.
MFVaultAccessVerifyVault | 1024 | Verify and fix vault.


%%PageItemTitle%%

MFVaultConnectionTestResult Enumeration

Glossary Item Box

Description

Result codes of a vault connection test.

Members

Member | Value | Description
MFVaultConnectionTestResultOK | 0 | Connection test was successful.
MFVaultConnectionTestResultUserCancelledLoginAttempt | 1 | User cancelled the login attempt.


%%PageItemTitle%%

MFViewCategory Enumeration

Glossary Item Box

Description

Available view categories.

Members

Member | Value | Description
MFViewCategoryNormal | 0 | Normal view.
MFViewCategoryOfflineFilter | 1 | View that acts as an offline filter.
MFViewCategoryTemporarySearch | 2 | View that represents a temporary search.


%%PageItemTitle%%

MFViewFlag Enumeration

Glossary Item Box

Description

Flags that provide additional information about the view.

Members

Member | Value | Description
MFViewFlagIncompatibleWithFullTextSearch | 2 | The view is not compatible with full-text search (on the view level).
MFViewFlagMaterialized | 1 | The view is materialized.
MFViewFlagsNone | 0 | None.

Remarks

MFViewFlagIncompatibleWithFullTextSearch is supported in M-Files 20.1.8669.3 and later.


%%PageItemTitle%%

MFViewType Enumeration

Glossary Item Box

Description

View types.

Members

Member | Value | Description
MFViewTypeFilterOnly | 1 | Defines only a filter. Does not show objects and cannot have a display hierarchy.
MFViewTypeNormal | 0 | Normal view. Displays objects on the last level and can have a display hierarchy.


%%PageItemTitle%%

MFWOPIActionType Enumeration

Glossary Item Box

Description

The WOPI action type.

Members

Member | Value | Description
MFWOPIActionTypeCoAuthor | 2 | WOPI Co-Author.
MFWOPIActionTypeEdit | 1 | WOPI Edit operation.
MFWOPIActionTypeView | 0 | WOPI View Operation.

Remarks

Supported in M-Files 21.6.10322.0 and later.


%%PageItemTitle%%

MFWOPITokenType Enumeration

Glossary Item Box

Description

The WOPI Token type.

Members

Member | Value | Description
MFWOPITokenTypeOneTimeToken | 1 | WOPI one time token key.
MFWOPITokenTypeUserAccessKey | 0 | WOPI access key.

Remarks

Supported in M-Files 21.6.10322.0 and later.


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started
Send comments

Glossary Item Box

Getting Started with M-Files API

Before you start creating an M-Files API application, make sure you are familiar with M-Files concepts and features. Install the M-Files Desktop and M-Files Server components and examine operations in both the M-Files Desktop and the M-Files Admin applications. Always use a dedicated server for prototyping, developing and testing your application. Do not use production environment for development purposes.

Various development environments and languages can be used to develop M-Files API applications. The main requirement is to have support for COM/ActiveX components. For example, Microsoft's .NET based development tools like C# and Visual Basic .NET can be used, as well as managed and standard C++.

Creating M-Files API Applications

The M-Files API interface needs to be included in your application project in order for you to be able to utilize it. The API is implemented as a COM DLL file, which is placed in the M-Files installation directory. If your computer has M-Files software installed, the M-Files API component should also be installed along with it.

Because the API is registered as a COM component, many application development environments provide a direct reference to the file via their user interface. The picture below shows how to add the M-Files API component to a Visual Basic project. With other languages and environments, refer to the language documentation for details.

Adding M-Files API as a reference to a Visual Basic project.

Choosing Between the Client and the Server Interfaces

You can use the M-Files API to access the M-Files client application, or you can choose to use the API to access the M-Files server directly. By using the client application, you can use client-side features like the Windows-integrated user interface. With the client interface, you will also gain a performance benefit, because the client application has local caches for documents. On the other hand, by using the M-Files Server interface directly you can write applications without the requirement of having the M-Files client application installed.

Getting Started with the M-Files Client Interface

The main high-level object of the M-Files API component is MFilesClientApplication. This is the first object you create when writing an application that uses the M-Files API.

Creating an MFilesClientApplication Object (Visual Basic) Copy Code
' Initialize the MFilesClientApplication object.
Dim oClientApp As New MFilesAPI.MFilesClientApplication
Having created the MFilesClientApplication object, you can bind it to the document vault connection in order to receive the Vault object. In the client component, the document vault connections are identified by the connection name. To log in to a document vault, an appropriate document vault connection must be obtained through the MFilesClientApplication object. You can connect to a known vault connection identified by a connection name, or you can loop through all the available vault connections to find the proper one.
Logging into a Known Document Vault (Visual Basic) Copy Code

' Log into a vault through a document vault connection "Demo".
Dim oVaultConnection As MFilesAPI.VaultConnection = oClientApp.GetVaultConnection("Demo")
Dim oVault As MFilesAPI.Vault = oVaultConnection.BindToVault(Me.Handle, true, false)
If you do not know which vault to use, but you have a file and a path, you can use the client interface to locate the file in any vault accessible on the client computer.
Locating a File in M-Files (Visual Basic) Copy Code

' Locate the object by path from M-Files.
Dim oObjVerAndProp As MFilesAPI.ObjectVersionAndProperties = oClientApp.FindObjectVersionAndProperties( _
      "M:\Sample\1. Documents\By Class\Agenda\Agenda - Project Meeting 4{2}2006 (ID 249).doc")

Getting Started with the M-Files Server Interface

The main M-Files component for accessing the server interface is the MFilesServerApplication interface. After creating the application object, you need to connect it to the server.

Creating an MFilesServerApplication and Connecting it to the Server (Visual Basic) Copy Code
' Create the server component.
Dim oServerApp As New MFilesAPI.MFilesServerApplication

' Connect to M-Files server computer "mfserv" by using M-Files user's credentials.
oServerApp.Connect(MFilesAPI.MFAuthType.MFAuthTypeSpecificMFilesUser, "UserA", "passw0rd", , , "mfserv")

After the application component has been connected to the server, you can log in to the document vault. If you know the GUID of the vault, you can log in directly to the vault. Alternatively, you can loop through all the vaults to find the one you need.

Logging into the Vault (Visual Basic) Copy Code
' Get and loop through all vaults.
Dim oVaultsOnServer As MFilesAPI.VaultsOnServer = oServerApp.GetVaults()
Dim oVault As MFilesAPI.Vault
For Each oVaultOnServer As MFilesAPI.VaultOnServer In oVaultsOnServer

    ' Check the vault's name and log into Sample Vault.
    If oVaultOnServer.Name = "Sample Vault" Then

        oVault = oVaultOnServer.LogIn()
        Exit For

    End If

Next

Using the Vault

Regardless of whether you are accessing M-Files through the client or server interface, operations on the vault are performed with the help of the Vault object. It is the most important high-level object available in the M-Files API.

The vault object itself has just a few vault-related methods and properties. The actual interaction with the contents of a vault is achieved via the operation interfaces provided by the vault object. These operation interfaces are:

  • VaultClassGroupOperations
  • VaultClassOperations
  • VaultClientOperations
  • VaultManagementOperations Object
  • VaultNamedACLOperations
  • VaultNamedValueStorageOperations Object
  • VaultObjectFileOperations
  • VaultObjectOperations
  • VaultObjectPropertyOperations
  • VaultObjectSearchOperations
  • VaultObjectTypeOperations
  • VaultPropertyDefOperations
  • VaultTraditionalFolderOperations
  • VaultUserGroupOperations
  • VaultUserOperations
  • VaultValueListItemOperations
  • VaultValueListOperations
  • VaultViewOperations
  • VaultWorkflowOperations

As a rule of thumb, all vault modifications are performed directly via the operation interfaces. Other objects, obtained via the operation interfaces, are data container objects only. Either they are stateless or they gain their state when they are created without maintaining a connection to the vault. Therefore, modifying the state of a container object does not create a change in the vault.

Identifying Objects, Versions and Files

Each document or other vault object is identified in the vault by an object identifier. At its simplest, this is just an ID number, which is unique for all vault objects within the object type. API methods use ObjID objects consisting of the object identifier number and the object type identifier number.

However, most vault operations are not targeted for the object as a whole, but rather for one particular object version. For example, documents seen in the user interface or referred to in applications are actually versions of vault objects. In order to identify a particular version of an object, we need to add a version number to the identifier. ObjVer consists of the ObjID object and the object version number. The version number has a special value of -1, which identifies the latest version available.

Getting the Latest Object Version Identifier (Visual Basic) Copy Code
Dim oObjID As MFilesAPI.ObjID = New MFilesAPI.ObjID
oObjID.SetIDs(MFilesAPI.MFBuiltInObjectType.MFBuiltInObjectTypeDocument, 123)
Dim oObjVer As MFilesAPI.ObjVer = oVault.ObjectOperations.GetLatestObjVer(oObjID)

Each document or other vault object can have zero or more files. Files have identifiers (unique within the object) and version numbers encapsulated in the FileVer object. The version number of the file is independent of the version number of the vault object.

Working with Vault Objects

Most of the version-related operations and properties of the vault objects are available via the ObjectVersion object. The metadata-related operations and properties of the objects can be accessed via the ObjectVersionAndProperties object. References to these objects can be accessed by using the VaultObjectOperations interface of the vault object.

Working with Object Metadata

The ObjectVersionAndProperties object contains a set of the property values of the object as PropertyValue objects. These objects contain a link to the property definition declaring the actual type of the metadata property as a PropertyDef object as well as a TypedValue object that determines the actual value of the property.

The property value can be one of the basic types or any of the lookup types listed in the MFDataType enumeration. Basic types represent a standalone text or a number as seen in the interface. Lookup or multi-select lookup types are reference types, meaning that they are used to refer to other objects or value list items. See the TypedValue interface for more details.

The object class is also listed among the metadata properties of the object. It can be resolved by using the lookup reference of a class property value. The object class has its own interface object, ObjectClass. See ObjectClass and VaultClassOperations for more details.

Working with Object Files

An object may contain multiple object files, each represented by the ObjectFile interface. The ObjectFile interface actually represents just a single version of the object file. To encapsulate both the file version and the parent object version, use the ObjectVersionFile interface.

The VaultObjectFileOperations interface provides methods for adding and removing object files.

Working with Workflows and Assignments

The VaultWorkflowOperations interface provides access to workflow items and states. Because the workflow and assigment settings of a vault object are part of the metadata of the object, changes in workflows and assignments can be performed by using the VaultObjectPropertyOperations interface.

Working with Views and Searches

Searches can be performed by using the VaultObjectSearchOperations interface. In most cases, the results are provided as an ObjectSearchResults container. The search is defined by using a SearchCondition object or a set of SearchConditions. The SearchCondition is defined by using an Expression object as an operator and a TypedValue object as a right operand. The search results consist of vault objects for which the search conditions are evaluated as true.

Views behave like searches. They consist of a condition for getting the result set and some additional parameters for displaying the result. The View object represents a single view. Views can be managed by using the VaultViewOperations interface.

Using User Interface Components

If the MFiles API is used with a client interface connection (the MFilesClientApplication interface), several UI components can be used via the API. Most of these methods are contained in the VaultObjectOperations interface. The VaultViewOperations interface contains some view-related UI methods. Most of the UI-related operations need to have a parent window handle (HWND) to show a child window.

Deploying M-Files API Applications

In order to use applications utilizing the M-Files API in client mode, the M-Files client software must be installed on the computer and the M-Files Client service must be running.

To use applications with the M-Files API in the server interface mode, the M-Files API component must be installed, which is included in any M-Files software installation. The M-Files client or server services do not need to run on the client computer.

Code Samples

For M-Files API samples, visit https://www.m-files.com/api.


$$GETTING_STARTED$$ - %%projecttitle%%

Introduction
Send comments

Glossary Item Box

M-Files API provides an application programming interface for M-Files. The API makes it possible to access M-Files from within scripting environments. For example, you can use it to generate reports based on the contents of a document vault or to integrate M-Files into your application. The object model of the M-Files API is easier to understand if you are familiar with the key concepts of M-Files. Please refer to the user guide and other software documentation for generic information on M-Files concepts.

With the M-Files API, you can access and manage objects contained in an M-Files document vault. This means that you can create, view, modify and destroy objects as well as control their visibility. M-Files API is an ActiveX/COM DLL and can be used with Visual Basic, VBScript, C++, and all .NET languages such as C#.

For M-Files API samples, visit https://www.m-files.com/api.


%%phrase%%

References
Send comments

Glossary Item Box

© 2022 M-Files Corporation

© 2022 M-Files Corporation. All rights reserved.


%%PageItemTitle%% $$Members$$

AccessControlEntry Object Members
See Also Overview Send comments

Glossary Item Box

See Also

AccessControlEntry Object


%%PageItemTitle%% $$Members$$

AccessControlEntryContainer Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds a new access control entry.
Public Method At | Accesses the specified access control entry.
Public Method Clear | Removes all access control entries.
Public Method Clone | Creates a copy of the object.
Public Method GetKeys | Gets copies of the source keys of the access control entries. Pseudo-user definitions are not included.
Public Method GetKeysWithPseudoUserDefinitions | Gets copies of the source keys of the access control entries.
Public Method HasKey | Checks whether an entry with the provided key exists.
Public Method Remove | Removes an access control entry.

Public Properties

Public Property IsEmpty Specifies whether the collection is empty.

See Also

AccessControlEntryContainer Object


%%PageItemTitle%% $$Members$$

AccessControlEntryData Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetAllPermissions | Sets all permissions of an access control entry to the specified state.

Public Properties

Public Property AttachObjectsPermission | The attach objects permission of an ACE.
Public Property ChangePermissionsPermission | The change permissions permission of an ACE.
Public Property DeletePermission | The delete permission of an ACE.
Public Property EditPermission | The edit permission of an ACE.
Public Property ReadPermission | The read permission of an ACE.

See Also

AccessControlEntryData Object


%%PageItemTitle%% $$Members$$

AccessControlEntryKey Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetResolvedPseudoUserOrGroupIDs | Gets a copy of the collection of the user or group ID for a resolved pseudo-user access control entry key.
Public Method ResetResolvedPseudoUserOrGroupIDs | Removes the information on the resolved user or user group IDs from a access control entry key that specifies pseudo users.
Public Method SetUserOrGroupID | Sets the user or group ID of this access control entry key.

Public Properties

Public Property HasConcreteUserOrGroupID | Specifies whether this ACE represents a concrete identity, either natively or as a resolved pseudo-user.
Public Property IsGroup | Specifies whether this ACE represents a group.
Public Property IsPseudoUser | Specifies whether this ACE represents a pseudo-user.
Public Property PseudoUserID | Specifies the pseudo-user ID of this access control entry key.
Public Property UserOrGroupID | Gets the user or group ID of this access control entry key.

See Also

AccessControlEntryKey Object


%%PageItemTitle%% $$Members$$

AccessControlEntryKeys Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

AccessControlEntryKeys Collection


%%PageItemTitle%% $$Members$$

AccessControlList Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method EqualTo | Checks for equality to the specified object.
Public Method HasIdenticalPermissions | Checks for the permissions identicality with the specified object.

Public Properties

Public Property AutomaticComponents | Accesses the automatic components of this ACL.
Public Property CheckedOutToUserID | Specifies the ID of the user who has extended rights because of the checkout operation performed by her.
Public Property CustomComponent | Accesses the custom component of this ACL.
Public Property HasCheckedOutToUserID | Specifies whether this component has the ID of the user who has extended rights because of the checkout operation performed by her.
Public Property IsFullyAuthoritative | Specifies whether this access control list is set to ignore the secondary permissions that come from the latest checked in version.

See Also

AccessControlList Collection | NamedACL Object


%%PageItemTitle%% $$Members$$

AccessControlListComponent Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetACEByUserOrGroupID | Gets the AccessControlEntryData with the specified user or user group ID.
Public Method GetACEKeyByUserOrGroupID | Gets the AccessControlEntryKey with the specified user or user group ID.
Public Method ResetCurrentUserBinding | Resets the current user binding of this component.
Public Method ResetNamedACLLink | Resets the named ACL link of this component.

Public Properties

Public Property AccessControlEntries | Gets the actual ACEs of this ACL component.
Public Property CanDeactivate | Specifies whether this component can be deactivated by setting IsActive to false.
Public Property CurrentUserBinding | Specifies the user ID used for entries of type "(Current User)".
Public Property HasCurrentUser | Specifies whether this component has a current user access control entry.
Public Property HasCurrentUserBinding | Specifies whether this component has a current user binding.
Public Property HasNamedACLLink | Specifies whether this component has a named ACL link.
Public Property HasPseudoUsers | Specifies whether this component has pseudo-users in its access control entries.
Public Property IsActive | Specifies the activation status of this ACL component.
Public Property NamedACLLink | Specifies the named ACL link of this component.

See Also

AccessControlListComponent Object


%%PageItemTitle%% $$Members$$

AccessControlListComponentContainer Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method At | Accesses the specified automatic access control list component.
Public Method GetKeys | Gets copies of the source keys of the automatic components.
Public Method HasKey | Checks whether a component with the provided key exists.

Public Properties

Public Property Count The number of items in the collection.

See Also

AccessControlListComponentContainer Object


%%PageItemTitle%% $$Members$$

AccessControlListComponentKey Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ItemID | Gets the item ID of this ACL component.
Public Property PropertyDefID | Gets the property def ID of this ACL component.

See Also

AccessControlListComponentKey Object


%%PageItemTitle%% $$Members$$

AccessControlListComponentKeys Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

AccessControlListComponentKeys Collection


%%PageItemTitle%% $$Members$$

AccessControlLists Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

AccessControlLists Collection


%%PageItemTitle%% $$Members$$

ActionConvertToPDF Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property FailOnUnsupportedSourceFiles | Specifies whether the operation fails if the source file is in an unsupported format.
Public Property OverwriteExistingFile | Specifies whether overwriting an existing target file with the same name is allowed.
Public Property PDFA1b | Specifies whether the resulting PDF file should comply with the PDF/A-1b standard.
Public Property StoreAsSeparateFile | Specifies whether the resulting PDF file should be stored as a separate file, with the same title as the original file but with the .pdf extension.

See Also

ActionConvertToPDF Object


%%PageItemTitle%% $$Members$$

ActionCreateAssignment Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AssignedTo | Specifies the Assigned To users.
Public Property Class | The class to use when creating a new assignment.
Public Property Deadline | Specifies whether a deadline is specified for the assignment.
Public Property DeadlineInDays | The number of days until the deadline.
Public Property Description | The description of the assignment.
Public Property MonitoredBy | Specifies the Monitored By users.
Public Property Title | The title of the assignment.

See Also

ActionCreateAssignment Object


%%PageItemTitle%% $$Members$$

ActionDefinition Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clear | Clears all information.
Public Method Clone | Creates a copy of the object.

Public Properties

Public Property ActionCreateSeparateAssignment | Information about an action if 'ActionType' is 'MFActionTypeCreateSeparateAssignment'. Otherwise NULL.
Public Property ActionType | The action type.

See Also

ActionDefinition Object


%%PageItemTitle%% $$Members$$

ActionDefinitions Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ActionDefinitions Collection


%%PageItemTitle%% $$Members$$

ActionSendNotification Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Message | The message text of the notification.
Public Property RecipientsEx | The recipients of the notification.
Public Property Subject | The subject text of the notification.

See Also

ActionSendNotification Object


%%PageItemTitle%% $$Members$$

ActionSetPermissions Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property DiscardsAutomaticPermissions | Specifies whether this action discards the automatic permissions.
Public Property Permissions | Specifies the access control list set by this action.

See Also

ActionSetPermissions Object


%%PageItemTitle%% $$Members$$

ActionSetProperties Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Properties Properties collection.

See Also

ActionSetProperties Collection


%%PageItemTitle%% $$Members$$

AdditionalClassInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clear | Clears all information.
Public Method Clone | Creates a copy of the object.

Public Properties

Public Property AssignmentClassInfo | Information about an assignment class if 'InfoType' is 'MFAdditionalClassInfoTypeAssignment'. Otherwise NULL.
Public Property InfoType | The additional class info type.

See Also

AdditionalClassInfo Object


%%PageItemTitle%% $$Members$$

AdditionalFolder Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Folder | The path to the folder, e.g., \servernamesharenameolder.
Public Property Impersonation | Impersonation information for accessing the folder.
Public Property LimitInMB | Specifies the limit for the data in megabytes, or zero if no limit.

See Also

AdditionalFolder Object


%%PageItemTitle%% $$Members$$

AdditionalFolders Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

AdditionalFolders Collection


%%PageItemTitle%% $$Members$$

ApplicationBroadcastMessage Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Makes a copy of "IApplicationBroadcastMessage" object.

Public Properties

Public Property BroadcastData | The custom broadcast message payload data. The "BroadcastType" property should indentify the format of this payload.
Public Property BroadcastMessageID | The ID of this broadcast message.
Public Property BroadcastType | The custom type of this broadcast message.
Public Property QueueID | The ID of the task queue to which this broadcast message belongs.

See Also

ApplicationBroadcastMessage Object


%%PageItemTitle%% $$Members$$

ApplicationBroadcastMessages Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ApplicationBroadcastMessages Collection


%%PageItemTitle%% $$Members$$

ApplicationTaskInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Makes a copy of the "IApplicationTaskInfo" object.

Public Properties

Public Property ActivationTimestamp | The earliest time when this task can be reserved for processing.
Public Property LatestActivityTimestamp | The last time the task was updated in the database.
Public Property Progress | Any data that describes the progress of the task thus far.
Public Property QueueID | The ID of the task queue this task belongs to or will be added to.
Public Property State | The state of this task.
Public Property TaskData | Custom task data. The task consumer should use the "TaskType" property to detect the custom data format.
Public Property TaskID | The ID of this task. The ID must be unique for all tasks within the same queue.
Public Property TaskType | A custom type for the task. The task consumer can use this information to identify the task type and decode the task data.

See Also

ApplicationTaskInfo Object


%%PageItemTitle%% $$Members$$

ApplicationTaskInfos Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ApplicationTaskInfos Collection


%%PageItemTitle%% $$Members$$

ApprovalAssignmentClassInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AnyAssigneeApproves | True if any assignee can approve the assignment. This is valid for approval type assignments only.
Public Property SignatureForApproval | Information about signature settings for assignment approval.
Public Property SignatureForRejection | Information about signature settings for assignment rejection.

See Also

ApprovalAssignmentClassInfo Object


%%PageItemTitle%% $$Members$$

ArchiveOldVersionsJob Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property AtLeastNDaysOlder | Specifies whether to include only object versions at least N days older than the current version.
Public Property AtLeastNVersionsOlder | Specifies whether to include only object versions at least N versions older than the current version.
Public Property CheckedInBefore | Specifies whether to include only object versions checked in before the specified time.
Public Property Flags | Specifies additional options as bit flags. Only MFExportContentFlagDestroyAfterExport and MFExportContentFlagClearArchivalMarker are supported.
Public Property Impersonation | Impersonation information to specify the access to the target files.
Public Property MarkedForArchiving | Specifies whether to include only objects that are marked for archiving.
Public Property NoVersionTag | Specifies whether to include only object versions that have no version tag.
Public Property TargetLocation | The full path to the target location on server.
Public Property UseAtLeastNDaysOlder | Specifies whether to use the AtLeastNDaysOlder value.
Public Property UseAtLeastNVersionsOlder | Specifies whether to use the AtLeastNVersionsOlder value.
Public Property UseCheckedInBefore | Specifies whether to use the CheckedInBefore value.

See Also

ArchiveOldVersionsJob Object


%%PageItemTitle%% $$Members$$

AssignmentClassInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ApprovalAssignmentClassInfo | Information about an approval assignment if 'AssignmentType' is 'MFAssignmentTypeApproval'. Otherwise NULL.
Public Property AssignmentType | The assignment type.
Public Property TaskAssignmentClassInfo | Information about a task assignment if 'AssignmentType' is 'MFAssignmentTypeTask'. Otherwise NULL.

See Also

AssignmentClassInfo Object


%%PageItemTitle%% $$Members$$

AssociatedPropertyDef Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property PropertyDef | The ID of the associated property definition.
Public Property Required | Specifies whether the associated property definition is required.

See Also

AssociatedPropertyDef Object | ObjectClass Object


%%PageItemTitle%% $$Members$$

AssociatedPropertyDefs Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

AssociatedPropertyDefs Collection


%%PageItemTitle%% $$Members$$

AttachVaultOptions Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method DisableAll | Disables all external connections and event handlers.

Public Properties

Public Property AllowOnlyVaultTempPathForContentReplication | Specifies whether attaching a vault removes working directories of cloud replication jobs and disables other replication jobs.
Public Property DisableAnonymousLogin | Specifies whether attaching a vault disables anonymous login.
Public Property DisableEventHandlers | Specifies whether vault attach disables event handlers.
Public Property DisableExportedDataSets | Specifies whether vault attach disables data set exports.
Public Property DisableExportImportJobs | Specifies whether vault attach disables scheduled export/import jobs.
Public Property DisableExternalObjectTypes | Specifies whether vault attach disables external object types.
Public Property DisableExternalSources | Specifies whether vault attach disables external sources (file/mail).
Public Property DisableExternalUserGroups | Specifies whether vault attach disables external user groups.
Public Property DisableLocalIndexes | Specifies whether attaching a vault disables local indexes if any.
Public Property DisableRemoteIndexes | Specifies whether attaching a vault disables remote indexes such as IDOL and Smart Search indexes.
Public Property DisableVaultApplications | Specifies whether attaching a vault disables vault applications.
Public Property FailAttachIfBringOnlineFails | Specifies whether attaching a vault must fail if its online operations do not start successfully.
Public Property Flags | Flags that control what is disabled with vault attach.
Public Property UpdateAttachmentGUID | Specifies whether to update vault GUID with vault attach.

See Also

AttachVaultOptions Object


%%PageItemTitle%% $$Members$$

AuthenticationResult Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Intermediate | Intermediate authentication result. NULL if the authentication is complete.
Public Property ServerFinal | Final authentication result for a server login. NULL if a vault login, or if the authentication is not complete.
Public Property VaultFinal | Final authentication result for a vault login. NULL if a server login, or if the authentication is not complete.

See Also

AuthenticationResult Object


%%PageItemTitle%% $$Members$$

AuthenticationResultIntermediate Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property AttemptIdentifier | The authentication attempt identifier.
Public Property AuthenticationData | The intermediate authentication data.

See Also

AuthenticationResultIntermediate Object


%%PageItemTitle%% $$Members$$

AuthenticationResultServerFinal Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property ServerConnection The state of the server connection and authentication.

See Also

AuthenticationResultServerFinal Object


%%PageItemTitle%% $$Members$$

AuthenticationResultVaultFinal Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Vault The vault object.

See Also

AuthenticationResultVaultFinal Object


%%PageItemTitle%% $$Members$$

AutomaticMetadataResult Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property PropertyValueSuggestions The property value suggestions.

See Also

AutomaticMetadataResult Object


%%PageItemTitle%% $$Members$$

AutomaticPermissions Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetBasedOnObjectACL | Specifies that the automatic ACL is based on the object's own ACL.
Public Method SetNamedACL | Specifies a new named ACL as the automatic ACL.

Public Properties

Public Property CanDeactivate | Specifies whether a user can deactivate this automatic component.
Public Property IsBasedOnObjectACL | Specifies whether the ACL defined by this automatic ACL is based on the ACL of the object for which it is defined.
Public Property IsDefault | Specifies whether the ACL is the default one, i.e., one that has been inherited from the object type level.
Public Property NamedACL | The named ACL specified by this automatic ACL.

See Also

AutomaticPermissions Object


%%PageItemTitle%% $$Members$$

AutomaticValue Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ANSIncrement | Simple automatic numbering: Increment.
Public Property ANVCode | Customized automatic numbering (VBScript): VBScript code.
Public Property CalculationOrderNumber | A number that specifies calculation order. Properties are calculated from smallest to largest calculation order number.
Public Property CVSExpression | Simple concatenation of properties: Expression.
Public Property CVVCode | Calculated value (VBScript): VBScript code.

See Also

AutomaticValue Object


%%PageItemTitle%% $$Members$$

BackupJob Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property BackupType | Backup type.
Public Property FileSizeLimitInMB | Maximum file size for individual backup files.
Public Property Impersonation | Impersonation information to specify the access to the target files.
Public Property OverwriteExistingFiles | Specifies whether existing files are overwritten.
Public Property TargetFile | Target for the backup file.
Public Property VaultGUID | GUID identifying the vault. Empty for Master backup.

See Also

BackupJob Object


%%PageItemTitle%% $$Members$$

BooleanValue Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property Value Value.

See Also

BooleanValue Object


%%PageItemTitle%% $$Members$$

ClassGroup Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddMember | Adds a member.
Public Method Clone | Creates a copy of the object.
Public Method RemoveMember | Removes the specified member.

Public Properties

Public Property ID | The ID of the class group.
Public Property Members | The members of the class group.
Public Property Name | The name of the class group.
Public Property ObjectType | The object type with which this class group is used.

See Also

ClassGroup Object | ObjectClass Object


%%PageItemTitle%% $$Members$$

ClassGroups Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ClassGroups Collection


%%PageItemTitle%% $$Members$$

ClientCapabilities Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a clone of an object.
Public Method LoadWithBaseCapabilitiesForThisVersion | Initializes the capabilities with the base capabilities for this version.

Public Properties

Public Property PropertyDefSearchabilitySupported | Property definitions can be set to be searchable or unsearchable.
Public Property UnmanagedObjectsSupported | The client is capable of handling unmanaged objects.

See Also

ClientCapabilities Object


%%PageItemTitle%% $$Members$$

ConnectionData Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a clone of an object.

Public Properties

Public Property AllowAnonymousConnection | True to allow an anonymous connection. Not applicable with connections without login.
Public Property AllowUsingAuthenticationPlugins | True if authentication plugin configurations are used for authentication.
Public Property ClientCapabilities | The capabilities of the connected client.
Public Property ClientCertificateValidated | True if the client has prevalidated the client certificate. This value is trusted if the client is physically the same computer as the server (for instance with LRPC connections).
Public Property ClientCulture | The client culture.
Public Property ClientDeviceToken | The device-specific identifier of the client device. Each device should report a globally unique identifier. The identifier can be, for example, the notification push identifier.
Public Property ClientHostPlatform | A free-formatted name for the host device, OS and the platform. For example 'Firefox 56.0', 'Windows 10', 'Android 7.0'.
Public Property ClientType | The type of the client software.
Public Property ClientTypeSpecifier | A more specific and free-formatted name for the user agent, such as 'M-Files Client'.
Public Property EncryptedConnection | True if the connection is encrypted. Not applicable with connections without login.
Public Property Endpoint | The endpoint port.
Public Property LocalComputerName | The local computer name.
Public Property LogicalTargetServer | The logical target server name.
Public Property NetworkAddress | The network address.
Public Property ProtocolSequence

The supported protocols include:

  • "ncacn_ip_tcp" (TCP/IP protocol)
  • "ncacn_spx" (SPX protocol)
  • "ncalrpc" (local interprocess call, LPC)
  • "ncacn_http" (HTTPS)
  • "grpc" (gRPC)
  • "grpc-local" (local gRPC)
Public Property TimeZone | The time zone of the client.

See Also

ConnectionData Object


%%PageItemTitle%% $$Members$$

CopyVaultJob Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property CopyflagAllData | Copy all data. All other flags are ignored.
Public Property CopyflagAllExceptData | Copy all except all data.
Public Property CopyflagApplications | Copy applications.
Public Property CopyflagDataSets | Copy exported data sets.
Public Property CopyflagDocumentProfiles | Copy classes and class groups.
Public Property CopyflagDocuments | Copy documents and other objects.
Public Property CopyflagEventLog | Copy event log.
Public Property CopyflagExternalLocations | Copy connections to external locations.
Public Property CopyflagFiles | Copy document file contents.
Public Property CopyflagInternalEventHandlers | Copy internal event handlers.
Public Property CopyflagLanguagesAndTranslations | Copy languages and translations.
Public Property CopyflagPropertyDefinitions | Copy property definitions.
Public Property CopyflagScheduledExportAndImportJobs | Copy scheduled export and import jobs.
Public Property CopyflagUserAccounts | Copy users and user groups.
Public Property CopyflagUseTargetGUID | Defines whether or not to use the provided target vault GUID.
Public Property CopyflagValueListContent | Copy value list contents.
Public Property CopyflagValueLists | Copy value list definitions.
Public Property CopyflagViews | Copy views.
Public Property CopyflagWorkflows | Copy workflows.
Public Property VaultGUID | The GUID of the vault to copy.
Public Property VaultProperties | The definition of the target vault. The GUID field is ignored unless CopyflagUseTargetGUID is set.

See Also

CopyVaultJob Object


%%PageItemTitle%% $$Members$$

CopyVaultJobOutputInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property VaultProperties VaultProperties

See Also

CopyVaultJobOutputInfo Object


%%PageItemTitle%% $$Members$$

CustomApplication Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ApplicationType | The application type.
Public Property ChecksumHash | The checksum of the application (hash value).
Public Property Description | The description of the application.
Public Property Enabled | Specifies whether the application is enabled.
Public Property ID | The identifier for the application.
Public Property MasterApplication | The GUID for the master application (without curly braces). Empty string if there is no master application.
Public Property MultiServerCompatible | Specifies whether this application is compatible with a multi-server environment.
Public Property Name | The name of the application.
Public Property Optional | Specifies whether the application can be disabled.
Public Property Publisher | The name of the publisher of the application.
Public Property RequireSystemAccess | Specifies whether the application requires system-level access.
Public Property Version | The version of the application (set by author).

See Also

CustomApplication Object


%%PageItemTitle%% $$Members$$

CustomApplications Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

CustomApplications Collection


%%PageItemTitle%% $$Members$$

DailyTrigger Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property DaysInterval Specifies the number of days between scheduled job runs.

See Also

DailyTrigger Object


%%PageItemTitle%% $$Members$$

DataFunctionCall Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method SetDataDate | Sets the date data function.
Public Method SetDataDaysFrom | Sets the days from data function.
Public Method SetDataDaysTo | Sets the days to data function.
Public Method SetDataInitialCharGroup | Sets the integer segment data function.
Public Method SetDataIntegerSegment | Sets the integer segment data function.
Public Method SetDataLeftChars | Sets the integer segment data function.
Public Method SetDataMonth | Sets the month data function.
Public Method SetDataNoOp | Sets the no-op data function.
Public Method SetDataYear | Sets the year data function.
Public Method SetDataYearAndMonth | Sets the year and month data function.

Public Properties

Public Property DataFunction The data function of the call.

See Also

DataFunctionCall Object | SearchCondition Object | Expression Object | TypedValues Object


%%PageItemTitle%% $$Members$$

DataSet Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ID | The ID of the data set.
Public Property Name | The name of the data set.

See Also

DataSet Object


%%PageItemTitle%% $$Members$$

DataSetExportingStatus Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property CurrentServerTime | The server's current time.
Public Property IsExporting | Specifies whether the data set is being exported or not.
Public Property LatestActivity | The time of the latest export operation status update.

See Also

DataSetExportingStatus Object


%%PageItemTitle%% $$Members$$

DataSets Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

DataSets Collection


%%PageItemTitle%% $$Members$$

DefaultProperties Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

DefaultProperties Collection


%%PageItemTitle%% $$Members$$

DefaultProperty Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetFixedValue | Sets the FixedValue data.
Public Method SetFromEmail | Sets the FromEmail data.
Public Method SetFromEmailHeader | Sets the FromEmailHeader data.
Public Method SetFromFile | Sets the FromFile data.
Public Method SetFromHPDSSXML | Sets the FromHPDSSXML data.
Public Method SetFromOCR | Sets the FromOCR data.
Public Method SetFromXML | Sets the FromXML data.
Public Method SetStateTransitionTime | Sets the StateTransitionTime data.

Public Properties

Public Property DataFixedValueValue | The Value field of the FixedValue specification.
Public Property DataFromEmailAddVLItemIfNotFound | Specifies whether a value list item should be added if it is not found.
Public Property DataFromEmailField | E-mail message field.
Public Property DataFromEmailHeaderAddVLItemIfNotFound | Specifies whether a value list item should be added if it is not found.
Public Property DataFromEmailHeaderField | Header field (e.g. X-Mailer).
Public Property DataFromEmailHeaderTreatLookupAsID | Specifies whether lookup values should be treated as item IDs instead of display names.
Public Property DataFromEmailTreatLookupAsID | Specifies whether lookup values should be treated as item IDs instead of display names.
Public Property DataFromFileAddVLItemIfNotFound | Specifies whether a value list item should be added if it is not found.
Public Property DataFromFileProperty | Windows file property.
Public Property DataFromFileTreatLookupAsID | Specifies whether lookup values should be treated as item IDs instead of display names.
Public Property DataFromHPDSSXMLAddVLItemIfNotFound | Specifies whether a value list item should be added if it is not found.
Public Property DataFromHPDSSXMLPromptName | The HPP DSS prompt name.
Public Property DataFromHPDSSXMLTreatLookupAsID | Specifies whether lookup values should be treated as item IDs instead of display names.
Public Property DataFromOCRAddVLItemIfNotFound | Specifies whether a value list item should be added if it is not found.
Public Property DataFromOCRTreatLookupAsID | Specifies whether lookup values should be treated as item IDs instead of display names.
Public Property DataFromOCRZone | OCR zone definition.
Public Property DataFromXMLAddVLItemIfNotFound | Specifies whether a value list item should be added if it is not found.
Public Property DataFromXMLTreatLookupAsID | Specifies whether lookup values should be treated as item IDs instead of display names.
Public Property DataFromXMLXPathExpression | XPath expression.
Public Property PropertyDefID | Property definition ID.
Public Property Type | Default property type.

See Also

DefaultProperty Object


%%PageItemTitle%% $$Members$$

EmailMessageInformation Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.

Public Properties

Public Property Cc | The 'Cc' recipients field.
Public Property From | The 'From' field.
Public Property Importance | Email importance.
Public Property InReplyTo | The 'In-Reply-To' field.
Public Property MessageID | The message ID.
Public Property Received | The 'Received' timestamp field.
Public Property Sensitivity | Email sensitivity.
Public Property Sent | The 'Sent' timestamp field.
Public Property Subject | The subject field.
Public Property To | The 'To' recipients field.

See Also

EmailMessageInformation Object


%%PageItemTitle%% $$Members$$

EventHandler Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetID | Gets the ID of this event handler.

Public Properties

Public Property Active | True if the this event handler is active.
Public Property Description | A short description of this event handler.
Public Property EventType | Specifies the type of the event this handler is associated with.
Public Property GUID | The GUID as a string.
Public Property VBScript | VBScript code of the event handler.

See Also

EventHandler Object


%%PageItemTitle%% $$Members$$

EventHandlers Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method GetIndexByGUID | Gets the index of the event handler with the specified GUID. Returns -1 if no match is found.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

EventHandlers Collection


%%PageItemTitle%% $$Members$$

ExportContentJob Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a clone of this object.
Public Method SetExportAllStructureItems | Configures the export job so that all the metadata structure items are exported.
Public Method SetReplicationViaCloud | Sets the information for replication via cloud storage.

Public Properties

Public Property CombinedConnectionString | The connection string combined from external storage location and target folder name.
Public Property ConfigurationID | The configuration ID of this export job.
Public Property ConnectionString | The external storage location access information.
Public Property ExportContent | Specifies whether to export the vault content.
Public Property ExportStructureItems | Specifies whether to export the metadata structure. The exported structure is defined with the StructureItems value.
Public Property ExternalFolderName | The target folder in the external cloud storage.
Public Property Flags | Specifies additional options as bit flags.
Public Property IgnoreChangesBefore | If not FILETIME_ZERO, any changes older than this timestamp are omitted from the content package.
Public Property Impersonation | Impersonation information to specify the access to the target files.
Public Property IncludePrivateUISettingsWithStructure | Specifies whether to include users' custom display settings when exporting the metadata structure.
Public Property IncludeValueListItemsWithStructure | Specifies whether to export the value list items with the value list structure item.
Public Property SearchConditions | The search conditions that specify the content to be exported.
Public Property StructureItems | Specifies the structure items that are exported.
Public Property TargetLocation | The full path to the target location on server.
Public Property UseIgnoreChangesBefore | Specifies whether to use the IgnoreChangesBefore value.
Public Property UseSearchConditions | Specifies whether to use the SearchConditions value.

See Also

ExportContentJob Object


%%PageItemTitle%% $$Members$$

ExportStructureItem Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property StructureItemGUID | The structure item GUID as a string.
Public Property StructureItemID | The internal ID of the exported structure item.
Public Property StructureItemType | The type of the exported structure item.

See Also

ExportStructureItem Object


%%PageItemTitle%% $$Members$$

ExportStructureItems Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove |

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ExportStructureItems Collection


%%PageItemTitle%% $$Members$$

Expression Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetExpressionAsText | Gets the expression as text.
Public Method GetWholeExpressionAsIndirectionLevels | Gets the whole expression as indirection levels if possible.
Public Method SetAnyFieldExpression | Set the AnyField expression.
Public Method SetFileValueExpression | Sets the FileValue expression.
Public Method SetObjectIDSegmentExpression | Set the ObjectIDSegment expression.
Public Method SetPermissionExpression | Set the Permission expression.
Public Method SetPropertyValueExpression | Sets the PropertyValue expression.
Public Method SetStatusValueExpression | Sets the StatusValue expression.
Public Method SetTypedValueExpression

Sets the TypedValue expressions.

Only works with the data types MFDatatypeLookup and MFDatatypeMultiSelectLookup.
Public Method SetValueListItemExpression | Sets the expression for searching the value list items.

Public Properties

Public Property DataAnyFieldFTSFlags | The data associated with the AnyField expression.
Public Property DataFileValueType | The data associated with the FileValue expression.
Public Property DataObjectIDSegmentSegmentSize | The data associated with the ObjectIDSegment expression.
Public Property DataPermissionsType | The type of the Permissions expression.
Public Property DataPropertyValueDataFunction | The data function of the PropertyValue expression.
Public Property DataPropertyValueParentChildBehavior | The parent-child behavior of the PropertyValue expression.
Public Property DataPropertyValuePropertyDef | The property definition of the PropertyValue expression.
Public Property DataStatusValueDataFunction | The data function of the StatusValue expression.
Public Property DataStatusValueType | The type of the StatusValue expression.
Public Property DataTypedValueDataFunction | The data function of the TypedValue expression.
Public Property DataTypedValueDatatype | The data type of the TypedValue expression.
Public Property DataTypedValueParentChildBehavior | The parent-child behavior of the TypedValue expression.
Public Property DataTypedValueValueList | The value list part of the TypedValue expression.
Public Property IndirectionLevels | Indirection levels of this expression.
Public Property Type | The type of an expression.

See Also

Expression Object | SearchCondition Object


%%PageItemTitle%% $$Members$$

ExpressionEx Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Conditions | The conditions that limit the values (property folders) of this expression.
Public Property Expression | The basic expression.
Public Property ExpressionExFlags | Bit flags that provide additional information on the expression in the context of a grouping level.
Public Property FolderListingAlgorithm | Folder listing algorithm. Used to optimize property folder listings on intermediate view levels.
Public Property NULLFolderName | The name of the folder representing NULL value. If NULL or an empty string, the default localized name is used.
Public Property ObjectTypeToGroupBy | The ID of the object type to group-by in this view level.
Public Property ReferFromViewLevel | True if the result objects are referred from this view level.
Public Property ShowContentsAsJITFolders | True if the contents of this view level should be created on-demand only.
Public Property ShowEmptyFolders | Specifies whether empty folders are shown.
Public Property ShowMatchingObjectsOnThisLevel | Specifies whether the matching objects are displayed on this level.
Public Property ShowNULLFolder | Specifies whether the NULL folder is shown.
Public Property ShowNULLFolderContentsOnThisLevel | Specifies whether the objects with NULL value are displayed on this level.

See Also

ExpressionEx Object | View Object


%%PageItemTitle%% $$Members$$

ExpressionExs Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ExpressionExs Collection


%%PageItemTitle%% $$Members$$

Expressions Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

Expressions Collection


%%PageItemTitle%% $$Members$$

ExtensionAuthenticationResponse Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AuthenticationData | The authentication data.
Public Property ConfigurationName | The authentication plugin configuration name.

See Also

ExtensionAuthenticationResponse Object


%%PageItemTitle%% $$Members$$

ExtensionAuthenticationStatus Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AccountName | The account name in the target system.
Public Property AuthenticationDataMissing | If the value of this property is true, authentication data for the external repository is not available.
Public Property ExtensionAuthenticationSpecialUserType | The special user type.
Public Property TargetID | The target extension ID.
Public Property UserID | The user account ID.

See Also

ExtensionAuthenticationStatus Object


%%PageItemTitle%% $$Members$$

ExtensionAuthenticationStatuses Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ExtensionAuthenticationStatuses Collection


%%PageItemTitle%% $$Members$$

ExtensionAuthenticationTarget Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property DisplayName | The display name in the target system.
Public Property IconID | The icon ID in the target system.
Public Property ID | The target system identifier.
Public Property PluginInfos | Authentication plugin information about the available authentication types.
Public Property RequiresUserSpecificAuthentication | True if this target requires user-specific authentication.

See Also

ExtensionAuthenticationTarget Object


%%PageItemTitle%% $$Members$$

ExtensionAuthenticationTargets Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ExtensionAuthenticationTargets Collection


%%PageItemTitle%% $$Members$$

ExternalObjectTypePluginInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the "IExternalObjectTypePluginInfo" object.

Public Properties

Public Property ConfigurationDomainID | The configuration domain of the external object type plugin.
Public Property Description | The description of the external object type plugin.
Public Property InitialPageToOpen | The initial configuration page of the external object type plugin.
Public Property Name | The name of the external object type plugin.
Public Property ObjectTypes | The IDs of the object types that have a configuration for the external object type plugin.
Public Property Publisher | The publisher of the external object type plugin.
Public Property ServiceGUID | The service GUID of the external object type plugin.
Public Property Version | The version of the external object type plugin.

See Also

ExternalObjectTypePluginInfo Object


%%PageItemTitle%% $$Members$$

ExternalObjectTypePluginInfos Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ExternalObjectTypePluginInfos Collection


%%PageItemTitle%% $$Members$$

ExternalView Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method Set | Sets the specified information for the external view.

Public Properties

Public Property DisplayName | The name of the view.
Public Property ExternalRepositoryName | The name of the system.
Public Property IconID | The ID of the view icon.
Public Property ID | The ID of the view.
Public Property ObjectData | The object data related to the external view.

See Also

ExternalView Object


%%PageItemTitle%% $$Members$$

ExternalViewID Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method Set | Sets the specified information for the external item ID.

Public Properties

Public Property ExternalRepositoryName | The name of the system.
Public Property ID | The ID of the item.

See Also

ExternalViewID Object


%%PageItemTitle%% $$Members$$

FileClass Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method LoadByExtension | Loads and initializes the file class based on a file extension.
Public Method LoadByFileClass | Loads and initializes the file class based on a file class identifier name and the extension.
Public Method SetFileClassInfo | Initializes the file class with the given parameters.

Public Properties

Public Property DisplayName | Display name for the file class.
Public Property DotAndExtension | Extension for the file class. Prefixed with a dot.
Public Property Extension | Extension for the file class.
Public Property FileClass | File class identifier string.

See Also

FileClass Object | ObjectCreationInfo Object | VaultObjectOperations Object


%%PageItemTitle%% $$Members$$

FileClasses Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

FileClasses Collection


%%PageItemTitle%% $$Members$$

FileDownloadSession Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property DownloadID | The download session ID.
Public Property FileSize | The size of the file.
Public Property FileSize32 | The size of the file.
Public Property VersionData | The refreshed document version information.

See Also

FileDownloadSession Object | VaultObjectFileOperations Object


%%PageItemTitle%% $$Members$$

FileInformation Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clear | Clears all information.
Public Method ExtractFromFile | Extracts information from the specified file. Requires .NET Framework 4.0 Client or later.

Public Properties

Public Property EmailMessage | Information about an email if 'FileType' is 'MFFileInformationTypeEmailMessage'. Otherwise NULL.
Public Property FileType | The type of the file.

See Also

FileInformation Object


%%PageItemTitle%% $$Members$$

FileSize Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method EqualTo | Checks for equality to the specified object.

Public Properties

Public Property Precision | The precision part of the file size.
Public Property Size | The size part of the file size.

See Also

FileSize Object


%%PageItemTitle%% $$Members$$

FileVer Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method ConvertToLatestVersion | Sets this file version to represent the latest version of the file. The ID part remains intact.
Public Method EqualTo | Checks for equality to the specified object.
Public Method EqualToIgnoreVersion | Checks for equality to the specified object while ignoring the version part.
Public Method IsLatest | Specifies whether this file represents the latest version.
Public Method IsSpecific | Specifies whether this file version represents a specific version.
Public Method SetLatestExternalRepositoryFileVersion | Sets the file version to represent the latest version of the file in an external repository.
Public Method SetLatestVersion | Sets the file version to represent the latest version of the file.
Public Method SetSpecificExternalRepositoryFileVersion | Sets the file version to represent a specific version of the file in an external repository.
Public Method SetSpecificExternalRepositoryFileVersionString | Sets the file version to represent a specific version of the file in an external repository.
Public Method SetSpecificVersion | Sets the file version to represent a specific version of the file.

Public Properties

Public Property ExternalRepositoryFileID | The external repository identifier of the file.
Public Property ExternalRepositoryFileVersionID | The external repository version identifier of the file.
Public Property ExternalRepositoryFileVersionSortKey | The sort key for the external repository version.
Public Property ExternalRepositoryFileVersionSortKeyAsString | The sort key for the external repository version.
Public Property ID | The ID part of the file version.
Public Property Type | The file version type.
Public Property Version | The version part of the file version.

See Also

FileVer Object


%%PageItemTitle%% $$Members$$

FileVers Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

FileVers Collection


%%PageItemTitle%% $$Members$$

FolderContentItem Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property ExternalView | The folder content item as an external view.
Public Property FolderContentItemType | The type of the folder content item.
Public Property ObjectVersion | The folder content item as a object version.
Public Property PropertyFolder | The folder content item as a typed value identifying a property folders.
Public Property TraditionalFolder | The folder content item as a lookup value identifying a traditional folder.
Public Property View | The folder content item as a view.

See Also

FolderContentItem Object


%%PageItemTitle%% $$Members$$

FolderContentItems Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.
Public Property MoreResults | Specifies whether the number of items was truncated.

See Also

FolderContentItems Collection


%%PageItemTitle%% $$Members$$

FolderData Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ExternalView | The definition of an external view.
Public Property FolderLocation | An array of folders describing the exact location of the folder that the view refers to.
Public Property FolderType | The type of the folder data.
Public Property View | The definition of an internal view.

See Also

FolderData Object


%%PageItemTitle%% $$Members$$

FolderDef Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetPropertyFolder | Sets this folder definition to define a property folder.
Public Method SetSearchDef | Sets this folder definition to define a search folder.
Public Method SetTraditionalFolder | Sets this folder definition to define a traditional folder.
Public Method SetView | Sets this folder definition to define a view folder.

Public Properties

Public Property ExternalFolder | The external folder represented by this folder definition.
Public Property FolderDefType | The type of the folder definition.
Public Property PropertyFolder | The typed value of the property folder referred by this property folder definition.
Public Property SearchDef | The search definition id for this search folder definition.
Public Property TraditionalFolder | The id of the traditional folder referred by this traditional folder definition.
Public Property View | The view id referred by this view folder definition.

See Also

FolderDef Object


%%PageItemTitle%% $$Members$$

FolderDefs Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

FolderDefs Collection


%%PageItemTitle%% $$Members$$

FolderID Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content from another object to this one.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property ExternalViewID | The ID of the external view.
Public Property FolderType | The type of the folder ID.
Public Property ViewID | The ID of the view.

See Also

FolderID Object


%%PageItemTitle%% $$Members$$

FolderListingColumn Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Flags | Column flags.
Public Property ID | The column ID; the property definition ID or a pseudo-ID.
Public Property Name | The column display name.
Public Property Position | Specifies the position for a visible column.
Public Property Visible | Specifies whether the column is visible.
Public Property Width | Specifies the column width.

See Also

FolderListingColumn Object


%%PageItemTitle%% $$Members$$

FolderListingColumns Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

FolderListingColumns Collection


%%PageItemTitle%% $$Members$$

FolderListingColumnSorting Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ID | The column ID to be sorted; the property definition ID or a pseudo-ID.
Public Property Index | The 0-based column index to be sorted.
Public Property SortAscending | True to sort ascending, false to sort descending.

See Also

FolderListingColumnSorting Object


%%PageItemTitle%% $$Members$$

FolderListingColumnSortings Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

FolderListingColumnSortings Collection


%%PageItemTitle%% $$Members$$

FolderListingUIState Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property Columns | The columns of the listing.
Public Property ColumnSortings | The column sorting information for the listing.
Public Property GroupingMode | The listing item grouping mode.
Public Property IconSize | The listing item icon size.
Public Property ViewMode | The listing view mode.

See Also

FolderListingUIState Object


%%PageItemTitle%% $$Members$$

FolderNameListing Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method SortWithExpression Sorts the folders based on the given expression.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.
Public Property MoreValues | Specifies whether additional folders are available on the server with the specified conditions.

See Also

FolderNameListing Collection | GetFolderNameListing Method


%%PageItemTitle%% $$Members$$

FolderUIState Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property BottomPaneBarMinimized | Specifies whether the bottom pane is minimized.
Public Property HitHighlightingEnabled | Specifies whether hit highlighting in file content is enabled.
Public Property ListingUIState | The listing UI state.
Public Property MetadataEditorInRightPane | Specifies whether the metadata editor is displayed in the right pane. If false, the metadata editor appears in the bottom pane.
Public Property RelativeBottomPaneHeight | Specifies the bottom pane height. The height is relative to the size of the frame window holding the bottom pane bar.
Public Property RelativeRightPaneWidth | Specifies the right pane width.
Public Property RightPaneBarMinimized | Specifies whether the right pane is minimized.
Public Property ShowBottomPaneBar | Specifies whether the bottom pane is displayed.
Public Property ShowRightPaneBar | Specifies whether the right pane is displayed.
Public Property ShowTaskPane | Specifies whether the task area is displayed.
Public Property TaskPaneMinimized | Specifies whether the task area is minimized.

See Also

FolderUIState Object


%%PageItemTitle%% $$Members$$

IDRange Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetIDs | Sets the minimum and maximum IDs of the range.
Public Method SetIDs_32bit | Sets the minimum and maximum IDs of the range. Compatible with 32-bit environments.

Public Properties

Public Property MaxID | The maximum ID of the range.
Public Property MaxID_32bit | The maximum ID of the range. Compatible with 32-bit environments.
Public Property MinID | The minimum ID of the range.
Public Property MinID_32bit | The minimum ID of the range. Compatible with 32-bit environments.

See Also

IDRange Object


%%PageItemTitle%% $$Members$$

IDs Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method IndexOf | Returns the index of the specified ID in the collection, or -1 if the specified ID does not exist in the collection.
Public Method Remove | Removes the item at the specified position from the collection.
Public Method RemoveAll | Removes all instances of the specified ID from this collection. Returns the number of items removed.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

IDs Collection


%%PageItemTitle%% $$Members$$

Impersonation Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property Account | Account used in impersonation.
Public Property ImpersonationType | Impersonation type.
Public Property Password | Password used in impersonation.

See Also

Impersonation Object


%%PageItemTitle%% $$Members$$

ImportContentJob Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a clone of this object.
Public Method DisableFeaturesRequiringSystemAdministratorRole | Disables all the features that require the system administrator role for importing. The number of features that are disabled may increase in the future.
Public Method SetReplicationViaCloud | Sets the information for replication via cloud storage.

Public Properties

Public Property ActivateAutomaticPermissionsForNewOrChangedDefinitions | Specifies whether to activate automatic permissions of objects due to new or changed definitions that affect them.
Public Property CombinedConnectionString | The connection string combined from external storage location and target folder name.
Public Property ConfigurationID | The configuration ID of this import job.
Public Property ConnectionString | The external storage location access information.
Public Property DisableCustomCodeInImportedPropertyDefinitions | Specifies whether all the custom code in imported property definitions is deactivated.
Public Property DisableCustomCodeInImportedWorkflows | Specifies whether all the custom code in imported workflows is deactivated.
Public Property DisableImportedExternalObjectTypeConnections | Specifies whether all the external connections of the imported object types are disabled.
Public Property DisableImportedExternalUserGroups | Specifies whether all the external connections of the imported user groups are disabled.
Public Property DisableImportedVaultEventHandlers | Specifies whether the all imported event handlers are deactivated.
Public Property ExternalFolderName | The target folder in the external cloud storage.
Public Property Flags | Specifies additional options as bit flags.
Public Property IgnoreAutomaticPermissionsDefinedByObjects | Specifies whether to ignore the automatic permissions defined by the imported objects.
Public Property Impersonation | Impersonation information to specify the access to the target files.
Public Property MetadataStructureSelectors | Specifies the metadata structure items that should be imported.
Public Property Permissions | Specifies the access control list set by this job.
Public Property SourceLocation | The full path to the source location on server.
Public Property UseDefaultObjectTypePermissions | Specifies whether to use the default permissions of object types. The UsePermissions property has precedence over this property.
Public Property UseNamesAsAliases | Specifies whether the incoming name of a structure item is used as its alias if no other alias is available.
Public Property UsePermissions | Specifies whether to use the Permissions value.

See Also

ImportContentJob Object


%%PageItemTitle%% $$Members$$

IndirectPropertyID Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method EqualTo | Checks for equality to the specified object.
Public Method Remove | Removes the item at the specified position from the collection.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

IndirectPropertyID Collection


%%PageItemTitle%% $$Members$$

IndirectPropertyIDLevel Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property ID | Indirect property ID level reference ID.
Public Property LevelType | Indirect property ID level type.

See Also

IndirectPropertyIDLevel Object


%%PageItemTitle%% $$Members$$

IServerDataPushSink Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method OnServerDataPush Called when M-Files server has provided data for the client.

See Also

IServerDataPushSink Object


%%PageItemTitle%% $$Members$$

KeyNamePair Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Key | The key part.
Public Property Name | The name part.

See Also

KeyNamePair Object


%%PageItemTitle%% $$Members$$

KeyNamePairs Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | Returns the number of key name pairs in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

KeyNamePairs Collection


%%PageItemTitle%% $$Members$$

Language Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property ID | The ID of the language.
Public Property LanguageCode | Language identifier, e.g. the ISO 639-1 or ISO 639-2 language code such as 'en' or 'eng'.
Public Property Name | The name of the language.

See Also

Language Object


%%PageItemTitle%% $$Members$$

LanguageDetectionResult Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Confidence | The confidence value of the detected language.
Public Property Language | The detected language.

See Also

LanguageDetectionResult Object


%%PageItemTitle%% $$Members$$

Languages Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

Languages Collection


%%PageItemTitle%% $$Members$$

LicenseStatus Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method ClearLicenseCode Clears the license code.

Public Properties

Public Property EvaluationDaysLeft | The number of evaluation days left until expiration.
Public Property EvaluationMode | Specifies whether the license is in evaluation mode.
Public Property Expired | Specifies whether the license has expired.
Public Property LicenseCode | The license code.
Public Property NumOfConcurrentUserLicenses | The number of concurrent user licenses.
Public Property NumOfNamedUserLicenses | The number of named user licenses.
Public Property NumOfReadonlyLicenses | The number of read-only user licenses.
Public Property SerialNumber | The serial number.

See Also

LicenseStatus Object


%%PageItemTitle%% $$Members$$

LoginAccount Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method Set | Sets information for the login.

Public Properties

Public Property AccountName | The account name of the login.
Public Property AccountType | The account type of the login.
Public Property DomainName | The domain of the login.
Public Property EmailAddress | The email address of the login.
Public Property Enabled | The enabled state of the login.
Public Property FullName | The full name of the login.
Public Property LicenseType | The license type of the login.
Public Property ServerRoles | The server roles of the login.
Public Property UserName | The username of the login.

See Also

LoginAccount Object


%%PageItemTitle%% $$Members$$

LoginAccountPersonalInformation Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property AccountName | The login account name.
Public Property Email | The email address of the user.
Public Property FullName | The full name of the user.

See Also

LoginAccountPersonalInformation Object | LoginAccount Object


%%PageItemTitle%% $$Members$$

LoginAccounts Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | Returns the number of login accounts in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

LoginAccounts Collection


%%PageItemTitle%% $$Members$$

Lookup Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method GetAsObjVer | Copies the lookup as an ObjVer structure.
Public Method GetFormattedDisplayValue | Gets the formatted display value.
Public Method IsUnmanagedReference | Specifies whether this lookup reference is based on unmanaged data.
Public Method SetLatestVersion | Sets the lookup value to refer to the latest version.

Public Properties

Public Property Deleted | Specifies whether the item is deleted.
Public Property DisplayID | The display ID of the item. This may differ from the numeric internal ID.
Public Property DisplayIDAvailable | Specifies whether the display ID is available.
Public Property DisplayValue | Display value. If not set the value of the lookup may appear as '(hidden)' in M-Files UI.
Public Property ExternalRepositoryIconID | The ID of the external repository icon.
Public Property ExternalRepositoryName | The external repository name of the object.
Public Property ExternalRepositoryObjectID | The external repository identifier of the object.
Public Property Hidden | Hidden.
Public Property Item | Item.
Public Property ItemGUID | The item GUID as a string.
Public Property ObjectFlags | Object flags.
Public Property ObjectType | Object type.
Public Property Version | Version. -1 always refers to the latest version of the lookup item.
Public Property VersionEx | The object version.

See Also

Lookup Object


%%PageItemTitle%% $$Members$$

Lookups Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method GetLookupByItem | Gets lookup by item ID.
Public Method GetLookupIndexByItem | Gets lookup index by item ID. -1 indicates that item was not found.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

Lookups Collection


%%PageItemTitle%% $$Members$$

MetadataStructureAliases Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Class | The structure aliases of a class.
Public Property NamedACL | The structure aliases of a named access control list.
Public Property ObjectType | The structure aliases of an object type.
Public Property PropertyDef | The structure aliases of a property definition.
Public Property StateMetadata | The structure aliases of a workflow state.
Public Property StateTransition | The structure aliases of a workflow state transition.
Public Property UserGroup | The structure aliases of a user group.
Public Property Valuelists | The structure aliases of a value list.
Public Property Workflow | The structure aliases of a workflow.

See Also

MetadataStructureAliases Object


%%PageItemTitle%% $$Members$$

MetadataStructureSelector Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Flags | Flags that control the metadata structure selection.
Public Property ID | The selector ID.
Public Property Name | A friendly name for the selector.
Public Property StructureItemGUID | The GUID of the structure item to be selected. The primary selector.
Public Property StructureItemID | The ID of the structure item to be selected. The tertiary selector.
Public Property StructureItemSemanticAlias | The semantic alias of the structure item to be selected. The secondary selector.
Public Property StructureItemType | The type of the structure item to be selected.

See Also

MetadataStructureSelector Object


%%PageItemTitle%% $$Members$$

MetadataStructureSelectors Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

MetadataStructureSelectors Collection


%%PageItemTitle%% $$Members$$

MFilesClientApplication Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddVaultConnection | Adds a new vault connection to the collection of vaults configured in M-Files Desktop.
Public Method BindToVault | Binds to a vault with the specified name (e.g., 'Sample Vault'). The default authentication method is used if the login is allowed.
Public Method FindFile | Gets a file based on the specified path.
Public Method FindObjectVersionAndProperties | Gets an object based on the specified path.
Public Method GetAPIVersion | Receives the version of the API.
Public Method GetClientLanguage | Returns the current M-Files software language.
Public Method GetClientVersion | Receives the version of the client.
Public Method GetDriveLetter | Gets the drive letter of M-Files Desktop.
Public Method GetVaultConnection | Returns the vault connection with the specified name.
Public Method GetVaultConnections | Returns a collection of vaults configured in M-Files Desktop.
Public Method GetVaultConnectionsWithGUID | Returns a collection of vaults with the specified GUID configured in M-Files Desktop.
Public Method IsObjectPathInMFiles | Checks whether the specified path refers to an object in M-Files.
Public Method LogInAs | Logs in to the vault with the specified name (e.g., 'Sample Vault'). Prompts the user for credentials.
Public Method LogInAsUser | Logs in to the vault with the specified name (e.g., 'Sample Vault') using the specified credentials.
Public Method RemoveVaultConnection | Deletes the vault connection with the specified name from the collection of vaults configured in M-Files Desktop.
Public Method ShowBalloonTip | Displays a tooltip message over M-Files status icon.
Public Method TestConnectionToServerEx | Tests the connection to the specified server.

See Also

MFilesClientApplication Object | MFilesServerApplication Object


%%PageItemTitle%% $$Members$$

MFilesServerApplication Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Connect | Connects to the specified server. Use the ConnectEx7 method for additional options.
Public Method ConnectAdministrativeEx | Connects to the server in administrative mode. Allows connection without a login account if the user has administrative rights on the server computer. Use the ConnectAdministrativeEx5 method for additional options.
Public Method ConnectAdministrativeEx3 | Connects to the server in administrative mode. Allows connection without a login account if the user has administrative rights on the server computer. Use the ConnectAdministrativeEx5 method for additional options.
Public Method ConnectAdministrativeEx4 | Connects to the server in administrative mode. Allows connection without a login account if the user has administrative rights on the server computer. Use the ConnectAdministrativeEx5 method for additional options.
Public Method ConnectAdministrativeEx5 | Connects to the server in administrative mode. Allows connection without a login account if the user has administrative rights on the server computer.
Public Method ConnectAdministrativeInteractive | Connects to the specified server in administrative mode interactively. Allows connection without a login account if the user has administrative rights on the server computer. Use the ConnectAdministrativeInteractiveEx method for additional options.
Public Method ConnectAdministrativeInteractiveEx | Connects to the specified server in administrative mode interactively. Allows connection without a login account if the user has administrative rights on the server computer.
Public Method ConnectEx3 | Connects to the specified server. Use the ConnectEx7 method for additional options.
Public Method ConnectEx4 | Connects to the specified server. Use the ConnectEx7 method for additional options.
Public Method ConnectEx5 | Connects to the specified server. Use the ConnectEx7 method for additional options.
Public Method ConnectEx6 | Connects to the specified server. Use the ConnectEx7 method for additional options.
Public Method ConnectEx7 | Connects to the specified server.
Public Method ConnectInteractive | Connects to the specified server interactively.
Public Method ConnectWithAuthenticationDataEx2 | Connects to a server with the specified authentication data. Use the ConnectWithAuthenticationDataEx6 method for additional options.
Public Method ConnectWithAuthenticationDataEx3 | Connects to a server with the specified authentication data. Use the ConnectWithAuthenticationDataEx6 method for additional options.
Public Method ConnectWithAuthenticationDataEx4 | Connects to a server with the specified authentication data. Use the ConnectWithAuthenticationDataEx6 method for additional options.
Public Method ConnectWithAuthenticationDataEx5 | Connects to a server with the specified authentication data. Use the ConnectWithAuthenticationDataEx6 method for additional options.
Public Method ConnectWithAuthenticationDataEx6 | Connects to a server with the specified authentication data.
Public Method ConnectWithExistingVaultSession | Connects to the specified server with an existing vault session.
Public Method ConnectWithoutLogin | Connects to the specified server without login. Use the ConnectWithoutLoginEx3 method for additional options.
Public Method ConnectWithoutLoginEx | Connects to the specified server without login. Use the ConnectWithoutLoginEx3 method for additional options.
Public Method ConnectWithoutLoginEx2 | Connects to the specified server without login. Use the ConnectWithoutLoginEx3 method for more options.
Public Method ConnectWithoutLoginEx3 | Connects to the specified server without login.
Public Method Disconnect | Disconnects from the server.
Public Method GetAPIVersion | Receives the version of the M-Files API.
Public Method GetAuthenticationPluginInformationEx | Gets the authentication plugin information for the specified authentication request. Returns NULL if no plugin is configured for the request.
Public Method GetAuthenticationPluginsEx | Gets the available authentication plugins.
Public Method GetGroundLinkProxies | Gets the Ground Link proxies that are available on the server.
Public Method GetOnlineGroundLinkProxies | Gets the Ground Link proxies that are online and available for the user on the server.
Public Method GetOnlineVaults | Gets the vaults that are on-line and available for the user on the server.
Public Method GetServerVersion | Receives the version of the M-Files server.
Public Method GetTokenAsAuthenticationData | Gets the specified token as authentication data.
Public Method GetVaults | Gets the vaults that are available on the server.
Public Method LogInAsUserToVault | Logs in to the vault as a user. Must connect to the server first.
Public Method LogInAsUserToVaultEx | Logs in to the vault as a user. Must connect to the server first.
Public Method LogInAsUserToVaultWithSPN | Logs in to the vault as a user with a specific SPN. Must connect to the server first.
Public Method LogInToVault | Logs in to the vault with the same credentials that were used to connect to the server. Must connect to the server first.
Public Method LogInToVaultAdministrative | Logs in to the vault in administrative mode with the same credentials that were used to connect to the server. Must connect to the server first.
Public Method LogInToVaultAdministrativeEx | Logs in to the vault in administrative mode with the same credentials that were used to connect to the server. Must connect to the server first.
Public Method LogInToVaultAdministrativeWithExistingSession | Logs in to the vault in administrative mode as using the existing session from the server connect.
Public Method LogInToVaultEx | Logs in to the vault with the same credentials that were used for connecting to the server. Must connect to the server first.
Public Method LogInToVaultWithExistingSession | Logs in to the vault as using the existing session from the server connect.
Public Method TestConnectionToServerEx | Tests the connection to the specified server.

Public Properties

Public Property LicenseManagementOperations | Gets the license management operations interface.
Public Property LoginAccountOperations | Gets the login account operations interface.
Public Property ScheduledJobManagementOperations | Gets the scheduled job management operations interface.
Public Property ServerManagementOperations | Gets the management operations interface.
Public Property SharedLinkPublicOperations | Gets the shared link public operations interface.
Public Property VaultManagementOperations | Gets the vault management operations interface.
Public Property WOPIOperations | Gets the WOPI operations interface.

See Also

MFilesServerApplication Object | MFilesClientApplication Object


%%PageItemTitle%% $$Members$$

MFilesVersion Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a clone of an object.
Public Method CompareTo | Performs a less-than comparison with the specified object.

Public Properties

Public Property Build | Gets the build version part.
Public Property Display | Version information for display purposes. Does not include the platform
Public Property Major | Gets the major version part.
Public Property Minor | Gets the minor version part.
Public Property Patch | Gets the patch version part.
Public Property SoftwarePlatform | Gets the software platform version part.

See Also

MFilesVersion Object


%%PageItemTitle%% $$Members$$

MonthlyDateTrigger Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Days | Specifies the day of the month a scheduled job runs. This value is a bit field that specifies the day(s) the task will run. Bit 0 corresponds to the first of the month, bit 1 to the second, and so forth.
Public Property Months | Specifies the day of the month a scheduled job runs. This value is a bit field that specifies the day(s) the task will run. Bit 0 corresponds to the first of the month, bit 1 to the second, and so forth.

See Also

MonthlyDateTrigger Object


%%PageItemTitle%% $$Members$$

MonthlyDOWTrigger Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property DaysOfTheWeek | Specifies the day(s) of the week (specified in WhichWeek) when the scheduled job runs. This value is a combination of the flags.
Public Property Months | Value that describes the month(s) when the scheduled job runs. This value is a combination of the flags.
Public Property WhichWeek | Specifies the week of the month when the scheduled job runs.

See Also

MonthlyDOWTrigger Object


%%PageItemTitle%% $$Members$$

NamedACL Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AccessControlList | The definition of the access control list.
Public Property GUID | The GUID as a string.
Public Property ID | The ID of the named access control list.
Public Property Name | The name of the named access control list.
Public Property NamedACLType | The type of the named access control list.

See Also

NamedACL Object


%%PageItemTitle%% $$Members$$

NamedACLAdmin Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AccessControlListForNamedACL | The definition of the access control list which controls visibility of named ACL.
Public Property NamedACL | The definition of the access control list.
Public Property SemanticAliases | The semantic aliases of this named access control list.

See Also

NamedACLAdmin Object


%%PageItemTitle%% $$Members$$

NamedACLs Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

NamedACLs Collection | NamedACL Object


%%PageItemTitle%% $$Members$$

NamedACLsAdmin Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

NamedACLsAdmin Collection


%%PageItemTitle%% $$Members$$

NamedValueNamespace Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property NamedValues | Gets the named values of the named value namespace.
Public Property NamespaceName | Gets the namespace of the named values.

See Also

NamedValueNamespace Object


%%PageItemTitle%% $$Members$$

NamedValueNamespaces Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

NamedValueNamespaces Collection


%%PageItemTitle%% $$Members$$

NamedValues Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method Contains | Specifies whether the given name exists in the collection.

Public Properties

Public Property Modified | Specifies whether this value collection has been modified.
Public Property Names | Gets the names of the values in the collection.
Public Property Value | The named value.

See Also

NamedValues Collection


%%PageItemTitle%% $$Members$$

Number Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property Value Value.

See Also

Number Object


%%PageItemTitle%% $$Members$$

ObjectClass Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AccessControlList | The ACL that defines the visibility and other permission settings of this object class. Also specifies who can attach objects to this class.
Public Property AdditionalClassInfo | The additional type-specific class features.
Public Property AssociatedPropertyDefs | The associated property definitions of the class.
Public Property AutomaticPermissionsForObjects | Specifies the automatic permissions for an object for which the user selects this item. If Nothing, no automatic permissions are defined.
Public Property DefaultClass | Specifies whether the object class is the default class of the object type.
Public Property ForceWorkflow | Specifies whether the use of the specified workflow is forced.
Public Property ID | The ID of the class.
Public Property Name | The name of the class.
Public Property NamePropertyDef | The ID of the property definition that represents the name of the document or other object.
Public Property ObjectType | The object type with which this class is used.
Public Property Workflow | The default workflow of the class, or zero if there is no default workflow.

See Also

ObjectClass Object | ClassGroup Object


%%PageItemTitle%% $$Members$$

ObjectClassAdmin Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AdditionalClassInfo | The additional type-specific class features.
Public Property AssociatedPropertyDefs | The property definitions that are associated with the class.
Public Property AutomaticPermissionsForObjects | Specifies the automatic permissions for an object for which the user selects an item of this class. If Nothing, no automatic permissions are defined.
Public Property ForceWorkflow | Specifies whether the use of the workflow with this class is enforced.
Public Property ID | The ID of the class.
Public Property Name | The name of the class.
Public Property NamePropertyDef | The ID of the property definition that represents the name of the document or other object.
Public Property ObjectType | The object type with which this class is used.
Public Property Predefined | Specifies whether this is a predefined class (cannot be deleted, editing is restricted).
Public Property SemanticAliases | The semantic aliases of this class.
Public Property Workflow | The default workflow of the class, or zero if there is no default workflow.

See Also

ObjectClassAdmin Object


%%PageItemTitle%% $$Members$$

ObjectClasses Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectClasses Collection


%%PageItemTitle%% $$Members$$

ObjectClassesAdmin Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectClassesAdmin Collection


%%PageItemTitle%% $$Members$$

ObjectCreationInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetDisableObjectCreation | Specifies whether the object creation is disabled.
Public Method GetExtension | Gets the file extension.
Public Method GetMetadataCardTitle | Gets the metadata card title.
Public Method GetObjectType | Gets the object type.
Public Method GetSelectableFileClasses | Gets the selectable file classes.
Public Method GetSelectedFileClass | Gets the selected file class for the new object.
Public Method GetSingleFileDocument | Specifies whether the single file document is selected.
Public Method GetSourceFiles | Gets all source files.
Public Method GetTemplate | Gets the selected template.
Public Method GetTitle | Gets the object title.
Public Method GetTitleAsText | Gets the title as text.
Public Method GetUseAsDefaults | Gets the state of Use as Defaults selection.
Public Method SetDisableObjectCreation | Prevents the creation of the object when the dialog box is closed.
Public Method SetExtension | Sets the initial file extension.
Public Method SetMetadataCardTitle | Sets the title for the metadata card.
Public Method SetObjectType | Sets the object type for the new object.
Public Method SetSelectableFileClasses | Sets the file classes available to the user when creating the new object.
Public Method SetSelectedFileClass | Sets the selected file class for the new object.
Public Method SetSingleFileDocument | Selects the single file document creation.
Public Method SetSourceFiles | Sets all source files.
Public Method SetTemplate | Selects the template object for the new object.
Public Method SetTitle | Sets an initial object title.
Public Method SetTitleAsDatatypeText | Sets the title as single-line text.
Public Method SetUseAsDefaults | Sets the state of Use as Defaults selection. This option is available in the metadata card when OkToAllButtonVisible Property is set to true.

Public Properties

Public Property DisallowTemplateSelection | Specifies whether the template selection user interface can be shown.
Public Property ExplicitObjectID | Specifies an explicit object ID for the new object. This information is used only when creating a shortcut. The value is typically -1.
Public Property IsObjectShortcut | Specifies whether the new object is a shortcut.
Public Property ObjectGUID | Specifies the Object GUID of the new object. This information is used only when creating a shortcut.
Public Property OkToAllButtonVisible | The visibility of Ok to All button.
Public Property SkipThisButtonVisible | The visibility of Skip This button.

See Also

ObjectCreationInfo Object | ShowBasicNewObjectWindow Method | ShowNewObjectWindow Method


%%PageItemTitle%% $$Members$$

ObjectFile Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetNameForFileSystem | Gets the name of the file in a format that is compatible with file systems, such as NTFS. Characters that are illegal in file-system use are encoded.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property ChangeTimeUtc | The time in UTC when the file was last written to or its attributes were changed.
Public Property CreationTimeUtc | The time in UTC when the file was originally created.
Public Property Extension | The extension of the file.
Public Property ExternalRepositoryFileID | The external repository identifier of the file.
Public Property ExternalRepositoryFileVersionID | The external repository version identifier of the file.
Public Property FileGUID | The file GUID as a string.
Public Property FileVer | File ID and version.
Public Property ID | The ID of the file.
Public Property LastAccessTimeUtc | The time in UTC when the file was last accessed (e.g., read).
Public Property LastWriteTimeUtc | The time in UTC when the file was last written to.
Public Property LogicalSize | The logical size of the file.
Public Property LogicalSize_32bit | The logical size of the file (uses 32-bit arguments).
Public Property LogicalSizeEx | The logical size of the file.
Public Property Title | The title of the file.
Public Property Version | The version number of the file.
Public Property VolatileContent | True if the physical file content is volatile, meaning that the physical content can change without the version number changing as long as the logical content stays the same.

See Also

ObjectFile Object


%%PageItemTitle%% $$Members$$

ObjectFileAndObjVer Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property ObjectFile | Specifies the object file.
Public Property ObjVer | Specifies the object version.

See Also

ObjectFileAndObjVer Object


%%PageItemTitle%% $$Members$$

ObjectFileAndObjVerOfMultipleFiles Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectFileAndObjVerOfMultipleFiles Collection


%%PageItemTitle%% $$Members$$

ObjectFiles Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetObjectFileByNameForFileSystem | Gets object file by its name in file system.
Public Method GetObjectFileIndexByNameForFileSystem | Gets object file index by its name in file system. -1 indicates that item was not found.
Public Method Sort | Sorts the objects in this collection using the given comparator.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectFiles Collection | ObjectFile Object


%%PageItemTitle%% $$Members$$

ObjectSearchResults Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetAsObjectVersions | Returns the results as an object versions collection. Creates a copy of the contents of this collection.
Public Method GetScoreOfObject | Gets the search result score of the specified object.
Public Method ScoreAt | Gets the search result score of the object at the specified index.
Public Method Sort | Sorts the objects in this collection using the given comparator.
Public Method SortByScore | Sorts the search results in this collection by their score.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.
Public Property MoreResults | Specifies whether the number of search results returned was truncated.

See Also

ObjectSearchResults Collection


%%PageItemTitle%% $$Members$$

ObjectTypeTargetForBrowsing Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property TargetObjectType | Target object type.
Public Property ViewCollection | Target view collection ID under built-in views.

See Also

ObjectTypeTargetForBrowsing Object


%%PageItemTitle%% $$Members$$

ObjectTypeTargetsForBrowsing Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectTypeTargetsForBrowsing Collection


%%PageItemTitle%% $$Members$$

ObjectVersion Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CompareObjectVersionEx | Compares the object version information of this object to that of another one.
Public Method GetNameForFileSystem | Gets the name of the object version in a format that is compatible with file systems, such as NTFS. Characters that are illegal in file-system use are encoded.
Public Method GetNameForFileSystemEx | Gets the name of the object version in a format that is compatible with file systems, such as NTFS. Characters that are illegal in file-system use are encoded.

Public Properties

Public Property AccessedByMeUtc | The last time the object was accessed by the current user, in UTC. Undefined if IsAccessedByMeValid is false.
Public Property AssociatedFolderID | The ID of an associated folder.
Public Property BaseProperties | The base properties of the object version.
Public Property CheckedOutAtUtc | The time in UTC when the object was checked out.
Public Property CheckedOutTo | The user ID to which the object has been checked out.
Public Property CheckedOutToHostName | The computer name to which the object has been checked out.
Public Property CheckedOutToUserName | The username to which the object has been checked out.
Public Property CheckedOutVersion | The identifier of the checked-out version of the object.
Public Property Class | The class of the object version.
Public Property CreatedUtc | The time in UTC when the object version was created.
Public Property CurrentUser | The ID of the current user.
Public Property Deleted | Specifies whether the state of the object is deleted.
Public Property DisplayID | The display ID of the object. This may differ from the numeric internal ID.
Public Property DisplayIDAvailable | Specifies whether the display ID is available.
Public Property Files | The files of the object version.
Public Property FilesCount | The number of files that the object version contains.
Public Property HasAssignments | Specifies whether relationships from one or more assignments to this object exist.
Public Property HasSharedFiles | Specifies whether the object has shared files.
Public Property HostName | The host name of the current session.
Public Property IconID | The ID of the object icon.
Public Property IsAccessedByMeValid | True when the value of AccessedByMeUtc is valid.
Public Property IsObjectConflict | Specifies whether the object is a conflict.
Public Property IsObjectShortcut | Specifies whether the object is a shortcut.
Public Property LastModifiedUtc | The time in UTC when the object version was last modified.
Public Property LatestCheckedInObjVerVersion | The latest checked-in object version.
Public Property LatestCheckedInVersion | The latest object version that is checked in, or zero if the object has no checked-in version.
Public Property LatestCheckedInVersionOrCheckedOutVersion | Specifies whether this object version is either the latest checked-in version of the object, or the checked-out version of the object.
Public Property ObjectCapabilityFlags | Bit flags that describe the capabilities of an object.
Public Property ObjectCheckedOut | Specifies whether the object is checked out to any user on any computer.
Public Property ObjectCheckedOutToThisUserOnAnyComputer | Specifies whether the object is checked out to the current user on any computer.
Public Property ObjectCheckedOutToThisUserOnThisComputer | Specifies whether the object is checked out to the current user on this computer.
Public Property ObjectFlags | Specifies the object flags.
Public Property ObjectGUID | The object GUID as a string.
Public Property ObjectVersionFlags | Bit flags that provide additional information on the object version.
Public Property ObjVer | The object version identifier as an ObjVer object.
Public Property OriginalObjID | The ObjID of the object in the vault in which the object was originally created.
Public Property OriginalVaultGUID | The GUID of the vault in which the object was originally created.
Public Property SingleFile | Specifies whether the object version is a single-file object.
Public Property ThisVersionCheckedOut | Specifies whether this object version is checked out.
Public Property ThisVersionLatestToThisUser | Specifies whether this object version is the latest version from the current user's perspective.
Public Property Title | The title of the object version.
Public Property VersionGUID | The version GUID as a string.
Public Property VisibleAfterOperation | Specifies whether this object version is visible after the operation.

See Also

ObjectVersion Object


%%PageItemTitle%% $$Members$$

ObjectVersionAndProperties Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ObjVer | The object version
Public Property Properties | Properties of this object version.
Public Property Vault | The vault of this object version
Public Property VersionData | Gets the object version data.

See Also

ObjectVersionAndProperties Object


%%PageItemTitle%% $$Members$$

ObjectVersionAndPropertiesOfMultipleObjects Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectVersionAndPropertiesOfMultipleObjects Collection


%%PageItemTitle%% $$Members$$

ObjectVersionData Object Members
See Also Overview Send comments

Glossary Item Box

See Also

ObjectVersionData Object


%%PageItemTitle%% $$Members$$

ObjectVersionDataRequest Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method SetEx Sets the object version data request.

See Also

ObjectVersionDataRequest Object


%%PageItemTitle%% $$Members$$

ObjectVersionDataResult Object Members
See Also Overview Send comments

Glossary Item Box

See Also

ObjectVersionDataResult Object


%%PageItemTitle%% $$Members$$

ObjectVersionDataResults Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectVersionDataResults Collection


%%PageItemTitle%% $$Members$$

ObjectVersionFile Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property ObjectFile | Object file.
Public Property ObjectVersion | Object version.

See Also

ObjectVersionFile Object


%%PageItemTitle%% $$Members$$

ObjectVersionPermissions Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property AccessControlList | The access control list of the object version.
Public Property CustomACL | Specifies whether the object version has a customized access control list.
Public Property NamedACL | The named access control list of the object version.
Public Property ObjVer | The ObjVer identifier of the object version.

See Also

ObjectVersionPermissions Object


%%PageItemTitle%% $$Members$$

ObjectVersions Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method GetAsObjVers | Gets the ObjVers of the object versions in this collection.
Public Method Remove | Removes the item at the specified position.
Public Method Sort | Sorts the objects in this collection using the given comparator.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjectVersions Collection | ObjectVersion Object


%%PageItemTitle%% $$Members$$

ObjectVersionWorkflowState Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property State | The workflow state of the object version.
Public Property VersionComment | A version comment for the object version.
Public Property Workflow | The workflow of the object version.

See Also

ObjectVersionWorkflowState Object


%%PageItemTitle%% $$Members$$

ObjectWindowResult Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property AccessControlList | Receives the access control list of the object.
Public Property ObjVer | Receives the object version of the object after displaying the metadata card.
Public Property Properties | Current property values of the object displayed in the metadata card.
Public Property Result | The dialog box result code.
Public Property SelectedFileClass | The selected file class for the new object.
Public Property UseAsDefaults | State of Use as Defaults selection. When True the properties the user selected for the created object in the metadata card should be used as a base for new objects when creating multiple object.
Public Property Visible | Specifies whether the object is still visible for the current user.

See Also

ObjectWindowResult Object | VaultObjectOperations Object


%%PageItemTitle%% $$Members$$

ObjID Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method IsManaged | Specifies whether this object ID represents a managed object.
Public Method IsUnmanaged | Specifies whether this object ID represents an unmanaged object.
Public Method Serialize | Serializes the object.
Public Method SetExternalRepositoryIDs | Sets the type and external repository identifiers of the object.
Public Method SetIDs | Sets the type and ID of the object.
Public Method ToJSON | Converts the data structure to a JSON string.
Public Method Unserialize | Unserializes the object.

Public Properties

Public Property ExternalRepositoryName | The external repository name of the object.
Public Property ExternalRepositoryObjectID | The external repository identifier of the object.
Public Property ID | The ID of the object (unique in one object type).
Public Property Type | The object type of the object.

See Also

ObjID Object


%%PageItemTitle%% $$Members$$

ObjIDs Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjIDs Collection


%%PageItemTitle%% $$Members$$

ObjOrFileVer Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method IsFile | Specifies whether this object represents a file.

Public Properties

Public Property FileVer | The file version.
Public Property ObjVer | The object version.

See Also

ObjOrFileVer Object


%%PageItemTitle%% $$Members$$

ObjOrFileVers Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjOrFileVers Collection


%%PageItemTitle%% $$Members$$

ObjType Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method CanHaveItemIcons | Can this object type have item icons.
Public Method Clone | Creates a copy of the object.
Public Method GetIconAsPNG | Returns the icon of this object type in PNG format scaled to the specified size.
Public Method IsAddingAllowedForUser | Checks if the user can add new items of this type.

Public Properties

Public Property AccessControlList | The ACL that defines the visibility and other permission settings of this object type. Also specifies who can add new items to this object type.
Public Property AllowAdding | Specifies whether adding a new object is allowed.
Public Property AllowedAsGroupingLevel | Specifies whether to allow using this value list or object type as a grouping level in views.
Public Property CanHaveFiles | Specifies whether the objects of this object type can have files.
Public Property DefaultAccessControlList | Specifies the default ACL for new objects.
Public Property DefaultPropertyDef | The ID of the multi-select lookup property definition that acts as the default property definition for this object type. For example, new relationships to objects of this type are expressed using this property.
Public Property DisableExternalConnection | Specifies whether the external connection is disabled.
Public Property External | Specifies whether the object type is external.
Public Property GUID | The GUID as a string.
Public Property HasOwnerType | Specifies whether this object type is a subtype of another object type.
Public Property Hierarchical | Specifies whether this object type is hierarchical (has an internal hierarchy).
Public Property Icon | The icon of the object type in ICO format.
Public Property ID | The ID of the object type.
Public Property NamePlural | The plural name of the object type.
Public Property NameSingular | The singular name of the object type.
Public Property ObjectTypeTargetsForBrowsing | Object type targets for browsing.
Public Property OwnerPropertyDef | Owner property definition. Subobjects of objects of this object type have this property in their metadata for describing owner relationships.
Public Property OwnerType | The owner object type.
Public Property ReadOnlyPropertiesDuringInsert | Specifies property definition IDs of those properties that cannot be entered during the creation of a new object because they are not included in the INSERT INTO statement.
Public Property ReadOnlyPropertiesDuringUpdate | Specifies property definition IDs of those properties that cannot be entered during the editing of an existing object because they are not included in the UPDATE statement.
Public Property RealObjectType | Specifies whether this object type is a real object type (not just a value list).
Public Property ShowCreationCommandInTaskPane | Specifies whether the creation command is shown for this object type in the task pane.
Public Property TitlePropertyID | The ID of the property that contains the object title in the user's preferred language.
Public Property Translatable | Specifies whether the contents of this value list or object type can be translated.

See Also

ObjType Object


%%PageItemTitle%% $$Members$$

ObjTypeAdmin Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ColumnMappings | Column mappings that specify how each column retrieved from the external database is mapped into a property in M-Files.
Public Property ConnectionString | The OLE DB connection string to the external database that contains the objects (and their properties) of this object type.
Public Property DefaultForAutomaticPermissions | Specifies the default for automatic permissions for the objects.
Public Property DeleteStatement | The SQL statement that deletes an object in an external database.
Public Property InsertIntoStatement | The SQL statement that inserts a new object to an external database.
Public Property NamedValueNamespaces | The custom data for the object type.
Public Property ObjectType | Object type.
Public Property SelectExtIDStatement | The SQL statement that retrieves the ID of the just inserted record in the external database.
Public Property SelectStatement | The SQL statement that retrieves the objects from an external database.
Public Property SelectStatementOneRecord | The SQL statement that retrieves a specific object from an external database.
Public Property SemanticAliases | The semantic aliases of this object type.
Public Property Translatable | Specifies whether the contents of this value list or object type can be translated.
Public Property UpdateStatement | The SQL statement that updates an existing object in an external database.

See Also

ObjTypeAdmin Object


%%PageItemTitle%% $$Members$$

ObjTypeColumnMapping Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ObjectType | Object type ID.
Public Property Ordinal | One-based source field ordinal.
Public Property PartOfInsert | Specifies whether the source field is a part of insertion operations.
Public Property PartOfUpdate | Specifies whether the source field is a part of update operations.
Public Property SourceField | Source field name.
Public Property TargetPropertyDef | Target property definition.
Public Property Type | Source field's data type.

See Also

ObjTypeColumnMapping Object


%%PageItemTitle%% $$Members$$

ObjTypeColumnMappings Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of column mappings in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjTypeColumnMappings Collection


%%PageItemTitle%% $$Members$$

ObjTypes Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjTypes Collection


%%PageItemTitle%% $$Members$$

ObjTypesAdmin Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjTypesAdmin Collection


%%PageItemTitle%% $$Members$$

ObjVer Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method EqualTo | Checks for equality to the specified object.
Public Method IsLatest | Specifies whether this object represents the latest version.
Public Method IsSpecific | Specifies whether this object version represents a specific version.
Public Method Serialize | Serializes the object.
Public Method Set | Sets the object version to represent a specific version of the object.
Public Method SetIDs | Sets the type, ID and version of the object.
Public Method SetLatestVersion | Sets the object version to represent the latest version of the object.
Public Method SetLatestVersionEx | Sets the object version to represent the latest version of the object.
Public Method SetObjIDAndVersion | Sets the ObjID and version of the object.
Public Method SetSpecificVersion | Sets the object version to represent a specific version of the object.
Public Method ToJSON | Converts the data structure to a JSON string.
Public Method Unserialize | Unserializes the object.

Public Properties

Public Property ExternalRepositoryName | The external repository name of the object.
Public Property ExternalRepositoryObjectID | The external repository identifier of the object.
Public Property ID | The ID of the object (unique in one object type).
Public Property ObjID | The ObjID of the object.
Public Property Type | The object type of the object.
Public Property Version | The version of the object.
Public Property VersionEx | The object version.

See Also

ObjVer Object | ObjID Object


%%PageItemTitle%% $$Members$$

ObjVers Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method GetAllDistinctObjIDs | Gets all distinct object IDs in this collection.
Public Method Remove | Removes the item at the specified position from the collection.
Public Method ToJSON | Converts the data structure to a JSON string.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ObjVers Collection


%%PageItemTitle%% $$Members$$

ObjVerVersion Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the objVer version.
Public Method Serialize | Serializes the version.
Public Method SetExternalRepositoryVersion | Sets the version to represent a specific version for an external repository object.
Public Method SetExternalRepositoryVersionString | Sets the version to represent a specific version for an external repository object.
Public Method SetLatestVersion | Sets the version to represent the latest version.
Public Method SetVersion | Sets the version to represent a specific version for a managed object.
Public Method ToJSON | Converts the data structure to a JSON string.
Public Method Unserialize | Unserializes the version.

Public Properties

Public Property ExternalRepositoryVersionID | The version identifier of the unmanaged object.
Public Property ExternalRepositoryVersionSortKey | The sort key for the external repository version.
Public Property ExternalRepositoryVersionSortKeyAsString | The sort key for the external repository version.
Public Property Type | The version type of the object.
Public Property Version | The version of the managed object.

See Also

ObjVerVersion Object


%%PageItemTitle%% $$Members$$

OCROptions Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property PrimaryLanguage | Primary language hint for OCR.
Public Property SecondaryLanguage | Secondary language hint for OCR.

See Also

OCROptions Object


%%PageItemTitle%% $$Members$$

OCRPage Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property OCRZones | Collection of OCR zones.
Public Property PageNum | Page number.

See Also

OCRPage Object


%%PageItemTitle%% $$Members$$

OCRPageResult Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property OCRZoneResults | Collection of OCR zone results.
Public Property PageNum | Page number.

See Also

OCRPageResult Object


%%PageItemTitle%% $$Members$$

OCRPageResults Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

OCRPageResults Collection


%%PageItemTitle%% $$Members$$

OCRPages Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

OCRPages Collection


%%PageItemTitle%% $$Members$$

OCRZone Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method ClearOCROptions | Removes zone-specific OCR options from this OCR zone.
Public Method Clone | Creates a copy of the object.
Public Method SetOCROptions | Sets zone-specific OCR options for this OCR zone.

Public Properties

Public Property Barcode | Specifies whether the zone should be interpreted as a barcode.
Public Property DataType | Data type for the OCR zone recognition result.
Public Property DimensionUnit | Dimension unit for zone coordinates.
Public Property HasOCROptions | Specifies whether the OCR zone has block-specific OCR options set.
Public Property Height | Height of the OCR zone.
Public Property ID | User-defined ID of the OCR zone.
Public Property Left | Left offset of the OCR zone.
Public Property Name | User-defined name of the OCR zone.
Public Property OCROptions | Zone-specific OCR options of the OCR zone.
Public Property Top | Top offset of the OCR zone.
Public Property Width | Width of the OCR zone.

See Also

OCRZone Object


%%PageItemTitle%% $$Members$$

OCRZoneResult Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Confidence | Confidence level for the result (0 = most confident, 255 = least confident).
Public Property DimensionUnit | Dimension unit for OCR zone positioning.
Public Property Height | Height of the recognized OCR zone.
Public Property ID | ID of the source OCR zone.
Public Property Left | Left offset of the recognized OCR zone.
Public Property RecognizedOnPage | One-based number of the page on which this result was recognized. 0 means no recognition.
Public Property ResultValue | The recognized value.
Public Property Top | Top offset of the recognized OCR zone.
Public Property Width | Width of the recognized OCR zone.

See Also

OCRZoneResult Object


%%PageItemTitle%% $$Members$$

OCRZoneResults Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

OCRZoneResults Collection


%%PageItemTitle%% $$Members$$

OCRZones Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

OCRZones Collection


%%PageItemTitle%% $$Members$$

OptimizeVaultJob Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetNumberOfSteps | Gets the number of steps in this job.
Public Method GetOneBasedIndexOfStep | Gets the one based index of the step.
Public Method GetStepProgressText | Gets a progress text regarding a step.
Public Method Set | Sets the job information.

Public Properties

Public Property GarbageCollectFiles | Specifies whether the destruction of garbage-collected data files is allowed.
Public Property Thorough | Is this thorough job.
Public Property VaultGUID | The GUID of the vault.

See Also

OptimizeVaultJob Object


%%PageItemTitle%% $$Members$$

OwnerPropertyDef Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property DependencyRelation | The dependency relation type of this owner property definition.
Public Property ID | The ID of the owner property definition.
Public Property IndexForAutomaticFilling | The order number of a member in ValueListItem from which a value is gathered for automatic completion.
Public Property IsRelationFiltering | Specifies whether the relation is a filtering relation.

See Also

OwnerPropertyDef Object


%%PageItemTitle%% $$Members$$

PluginInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AssemblyName | The assembly name of the plugin.
Public Property BridgeClassName | The class name of the plugin COM bridge.
Public Property Configuration | The plugin configuration as name-value pairs. Value type is multiline text.
Public Property ConfigurationScope | The scope description of the plugin configuration.
Public Property ConfigurationSource | The full configuration source description as name-value pairs. Value type is multiline text.
Public Property ConfigurationVaultGUID | The vault GUID of the plugin configuration.
Public Property IsDefault | Specifies whether this plugin is the default one.
Public Property IsScopeIndependent | Specifies whether this plugin is independent of configuration scopes.
Public Property Name | The name of the plugin.

See Also

PluginInfo Object


%%PageItemTitle%% $$Members$$

PluginInfos Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PluginInfos Collection


%%PageItemTitle%% $$Members$$

PropertyDef Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AccessControlList | The ACL that defines the visibility and editability of this property in objects. It is Nothing if the ACL is not set.
Public Property AllObjectTypes | Specifies whether this property definition can be used with all object types.
Public Property AllowedAsGroupingLevel | Specifies whether to allow using this property as a grouping level in views.
Public Property AutomaticValueDefinition | If not NULL, specifies an automatic value for this property.
Public Property AutomaticValueType | Defines the type of the automatic value of this field, if any.
Public Property BasedOnValueList | Specifies whether this property definition is based on a value list.
Public Property ContentType | The content type of the property definition.
Public Property DataType | The data type of the property definition.
Public Property DependencyPD | The ID of the related property definition. MFPseudoPropertyDefAuto (-106) indicates 'automatic filtering'.
Public Property DependencyRelation | The dependency relation type of this property definition.
Public Property FormattingType | If formatting is used for this field, this property specifies it.
Public Property GUID | The GUID as a string.
Public Property HistoryVersionsSearchableByThisProperty | Specifies whether to allow searching for history versions of objects by this property.
Public Property ID | The ID of the property definition.
Public Property Name | The name of the property definition.
Public Property ObjectsSearchableByThisProperty | Specifies whether to allow searching for objects by this property.
Public Property ObjectType | The object type with which this property definition is used. This is valid only if AllObjectTypes is False.
Public Property OwnerPropertyDef | The owner property definition of this property definition.
Public Property Predefined | Specifies whether this property definition is a predefined property definition.
Public Property SortAscending | True to sort in ascending order, false to sort in descending order.
Public Property StaticFilter | Static filter to apply to the values of the property definition's underlying value list or object type.
Public Property ThisIsConflictPD | Specifies whether this property definition is the conflict property definition of the object type.
Public Property ThisIsDefaultPD | Specifies whether this property definition is the one and only default property definition of the object type.
Public Property ThisIsOwnerPD | Specifies whether this property definition is the one and only owner property definition of the object type.
Public Property UpdateType | The update type of the property definition.
Public Property ValidationType | If validation is used for this field, this property specifies the validation type.
Public Property ValueList | The ID of the value list. This is valid only if this property definition is based on a value list.

See Also

PropertyDef Object


%%PageItemTitle%% $$Members$$

PropertyDefAdmin Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AllowAutomaticPermissions | Gets the mode of allowing automatic permissions via this property.
Public Property AutomaticValue | The definitions for automatic value generation.
Public Property NamedValueNamespaces | The custom data for the property definition.
Public Property PropertyDef | Basic information on the property definition.
Public Property SemanticAliases | The semantic aliases of this property definition.
Public Property Validation | The definitions for property value validation.

See Also

PropertyDefAdmin Object


%%PageItemTitle%% $$Members$$

PropertyDefOrObjectType Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetAsExpression | Gets this proeprty def or object type as an expression.

Public Properties

Public Property ID | The ID of the property definition or object type.
Public Property PropertyDef | True if the ID represents property definition ID.

See Also

PropertyDefOrObjectType Object


%%PageItemTitle%% $$Members$$

PropertyDefOrObjectTypes Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyDefOrObjectTypes Collection


%%PageItemTitle%% $$Members$$

PropertyDefs Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyDefs Collection | PropertyDef Object


%%PageItemTitle%% $$Members$$

PropertyDefsAdmin Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyDefsAdmin Collection


%%PageItemTitle%% $$Members$$

PropertyValue Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method GetValueAsLocalizedText | Gets the current value as localized text. The value is localized based on the culture of the local computer.
Public Method GetValueAsLocalizedTextEx | Gets the current value as localized text. The value is localized based on the culture of the local computer.
Public Method GetValueAsText | Returns the property value in a human-readable format.
Public Method GetValueAsTextEx | Returns the property value in a human-readable format.
Public Method GetValueAsUnlocalizedText | Gets the current value as unlocalized text.

Public Properties

Public Property PropertyDef | The property definition of the property value.
Public Property Value | The typed value of the property value.

See Also

PropertyValue Object | SearchCondition Object


%%PageItemTitle%% $$Members$$

PropertyValueForDisplay Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ContentType | The content type of the property definition.
Public Property DataType | The data type of the property definition.
Public Property DisplayValue | The display value of the property.
Public Property PropertyDef | The property definition of the property value.
Public Property PropertyDefName | The name of the property definition.
Public Property PropertyValue | The associated property value.
Public Property ReadOnly | Specifies whether the property is read-only (i.e., updated by the server.

See Also

PropertyValueForDisplay Object


%%PageItemTitle%% $$Members$$

PropertyValueIconClue Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property PropertyDef | Property definition
Public Property ValueListItem | Value list item

See Also

PropertyValueIconClue Object


%%PageItemTitle%% $$Members$$

PropertyValueIconClues Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValueIconClues Collection


%%PageItemTitle%% $$Members$$

PropertyValues Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method EqualTo | Checks for equality to the specified object.
Public Method IndexOf | Returns the index of the specified property value in the collection, or -1 if the specified property value does not exist in the collection.
Public Method IndexOfByAlias | Returns the index of the specified property value in the collection, or -1 if the specified property value does not exist in the collection. Uses an alias to identify the property.
Public Method Remove | Removes the item at the specified position.
Public Method SearchForProperty | Searches the collection for a specified property value.
Public Method SearchForPropertyByAlias | Searches the collection for a specified property value. Uses an alias to identify the property.
Public Method SearchForPropertyEx | Searches the collection for a specified property value.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValues Collection | PropertyValue Object


%%PageItemTitle%% $$Members$$

PropertyValuesForDisplay Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValuesForDisplay Collection


%%PageItemTitle%% $$Members$$

PropertyValuesOfMultipleObjects Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValuesOfMultipleObjects Collection


%%PageItemTitle%% $$Members$$

PropertyValuesOfMultipleObjectsEx Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValuesOfMultipleObjectsEx Collection


%%PageItemTitle%% $$Members$$

PropertyValuesOfMultipleObjectsForDisplay Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValuesOfMultipleObjectsForDisplay Collection


%%PageItemTitle%% $$Members$$

PropertyValueSuggestion Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property DisplayValue | The textual representation of the suggested value.
Public Property IsFact | True if the property value suggestion is understood to be a known fact.
Public Property IsNewValue | True if the suggested value does not already exist in the value lists.
Public Property PropertyDef | The property definition ID.
Public Property Quality | The quality of the property value suggestion.
Public Property TypedValue | The typed value.

See Also

PropertyValueSuggestion Object


%%PageItemTitle%% $$Members$$

PropertyValueSuggestions Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValueSuggestions Collection


%%PageItemTitle%% $$Members$$

PropertyValuesWithIconClues Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property IconClues | The icon clues for the property values.
Public Property ObjVer | The object version the properties are associated with.
Public Property PropertyValues | The property values.

See Also

PropertyValuesWithIconClues Object


%%PageItemTitle%% $$Members$$

PropertyValuesWithIconCluesOfMultipleObjects Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

PropertyValuesWithIconCluesOfMultipleObjects Collection


%%PageItemTitle%% $$Members$$

ReportAccessCredentials Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Domain | The domain.
Public Property ExtAccount | True if the user is authenticated with external user authentication mode.
Public Property Password | The user's password.
Public Property UserName | The username.

See Also

ReportAccessCredentials Object


%%PageItemTitle%% $$Members$$

RestoreJob Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property BackupFileDifferential | Full path to the backup file on server (differential backup, optional).
Public Property BackupFileFull | Full path to the backup file on server (full backup).
Public Property Impersonation | Impersonation information to specify the access to the target files.
Public Property OverwriteExistingFiles | Specifies whether existing target files are to be overwritten. If false, restore fails if a target file already exists.
Public Property VaultProperties | Vault information.

See Also

RestoreJob Object


%%PageItemTitle%% $$Members$$

ScheduledJob Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method SetBackupVaultJob | Sets the backup vault job.
Public Method SetExportContentJob | Sets the export content job.
Public Method SetImportContentJob | Sets the import content job.
Public Method SetOptimizeVaultJob | Sets the optimize vault job.

Public Properties

Public Property BackupVaultJob | Description of the actual backup vault job.
Public Property Enabled | Specifies whether the scheduled job is enabled.
Public Property ExportContentJob | Description of the actual export content job.
Public Property ID | The ID of the scheduled job.
Public Property ImportContentJob | Description of the actual import content job.
Public Property JobName | The name of the scheduled job.
Public Property JobType | The type of the scheduled job.
Public Property OptimizeVaultJob | Description of the actual optimize vault job.
Public Property Temporary | Specifies whether the scheduled job is temporary only.
Public Property Triggers | Collection of execution triggers.

See Also

ScheduledJob Object


%%PageItemTitle%% $$Members$$

ScheduledJobOutputInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property ID | The ID of the scheduled job.
Public Property JobType | The type of the scheduled job.
Public Property Message | The message from the execution of the scheduled job.

See Also

ScheduledJobOutputInfo Object


%%PageItemTitle%% $$Members$$

ScheduledJobRunInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Cancelled | Was the last run cancelled?
Public Property CurrentStep | The current step of the execution of the scheduled job.
Public Property LastRun | The last run time of the scheduled job.
Public Property LastRunErrors | Errors that occurred when the job was run the last time.
Public Property LastRunSucceeded | Was the last run succeeded?
Public Property NextRun | The time when the scheduled job will run next.
Public Property Running | Is the scheduled job running?
Public Property ScheduledJobOutputInfo | Output information on the scheduled job.
Public Property StepCompletionPercent | The progress of the current step.

See Also

ScheduledJobRunInfo Object


%%PageItemTitle%% $$Members$$

ScheduledJobs Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ScheduledJobs Collection


%%PageItemTitle%% $$Members$$

ScheduledJobTrigger Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property BeginDay | Day of the month (specified in the BeginMonth member) that the scheduled job trigger activates. The beginning day must be specified when setting a scheduled job.
Public Property BeginMonth | Month of the year (specified in the BeginYear member) that the scheduled job trigger activates. The beginning month must be specified when setting a scheduled job.
Public Property BeginYear | Year that the task trigger activates. This value must be four digits (1997, not 97). The beginning year must be specified when setting a scheduled job.
Public Property EndDay | Day of the month (specified in the EndMonth member) that the scheduled job trigger deactivates.
Public Property EndMonth | Month of the year (specified in the EndYear member) that the scheduled job trigger deactivates.
Public Property EndYear | Year that the scheduled job trigger deactivates. This value must be four digits (1997, not 97).
Public Property StartHour | Hour of the day the scheduled job runs. This value is on a 24-hour clock; hours go from 00 to 23.
Public Property StartMinute | Minute of the hour (specified in the StartHour member) that the scheduled job runs.
Public Property Type | Trigger's type and additional type specific information.
Public Property ValidEndDate | Trigger's end date is valid. If this flag is not set, the end date data is ignored and the trigger will be valid indefinitely.

See Also

ScheduledJobTrigger Object


%%PageItemTitle%% $$Members$$

ScheduledJobTriggers Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ScheduledJobTriggers Collection


%%PageItemTitle%% $$Members$$

SearchCondition Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method Set | Sets the search condition.

Public Properties

Public Property ConditionType | The operator of the search condition.
Public Property Expression | The left side of the search condition.
Public Property TypedValue | The right side of the search condition.

See Also

SearchCondition Object | Expression Object | TypedValue Object


%%PageItemTitle%% $$Members$$

SearchConditionEx Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method Set | Sets the search condition and other related data.

Public Properties

Public Property Enabled | Specifies whether the search condition is enabled.
Public Property Ignored | Specifies whether the search condition is ignored.
Public Property SearchCondition | The underlying search condition.
Public Property SpecialNULL | Specifies whether this search condition is a special NULL condition. Its meaning depends on the underlying search condition.

See Also

SearchConditionEx Object


%%PageItemTitle%% $$Members$$

SearchConditionExs Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

SearchConditionExs Collection


%%PageItemTitle%% $$Members$$

SearchConditions Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method AppendFromExportedSearchString | Initializes search conditions collection with an exported search string.
Public Method Clone | Creates a copy of the object.
Public Method GetAsExportedSearchString | Gets the search conditions as an exported search string.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

SearchConditions Collection | SearchCondition Object


%%PageItemTitle%% $$Members$$

SearchCriteria Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method EqualTo | Checks for equality to the specified search criteria.
Public Method GetEffectiveSearchConditions | Gets the effective search conditions of this search criteria. Can be directly used with searches.
Public Method GetEffectiveSearchFlags | Gets the effective search flags of this search criteria.

Public Properties

Public Property AdditionalConditions | The additional conditions.
Public Property ExpandUI | Specifies whether the search user interface is expanded.
Public Property FacetFilterAsJSON | The search refinements as a JSON string.
Public Property FirstCondition | The first search condition.
Public Property FullTextSearchFlags | The full-text search flags.
Public Property FullTextSearchString | The full-text search string.
Public Property ObjectTypeCondition | The object type search condition.
Public Property SearchFlags | The search flags of the criteria.
Public Property SearchWithinThisFolder | Specifies whether the search within this folder flag is enabled.
Public Property SecondCondition | The second search condition.

See Also

SearchCriteria Object


%%PageItemTitle%% $$Members$$

SearchDef Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method IsIndirectionUsed | Is indirection used?

Public Properties

Public Property Conditions | The conditions that limit the object set of this search.
Public Property Levels | View levels that define the display hierarchy of this search.
Public Property LookInAllVersions | Specifies whether the search looks match in all versions or in only the latest versions.
Public Property ReturnLatestVisibleVersion | Specifies whether the search returns the latest visible versions or the latest matching versions.
Public Property SearchFlags | The search flags of the view.

See Also

SearchDef Object


%%PageItemTitle%% $$Members$$

SemanticAliases Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Value A semicolon-separated list of semantic aliases.

See Also

SemanticAliases Object


%%PageItemTitle%% $$Members$$

ServerLicenseManagementOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetLicenseStatus | Gets the current license code and serial.
Public Method SetLicenseCodeAndSerialNumber | Sets the license code and serial.

See Also

ServerLicenseManagementOperations Object


%%PageItemTitle%% $$Members$$

ServerLoginAccountOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddLoginAccount | Adds the specified login account to the server.
Public Method ForceLogout | Forcefully logs out the users with the specified login accounts.
Public Method GetLoginAccount | Gets the specified login account.
Public Method GetLoginAccounts | Gets all login accounts on the server.
Public Method GetLoginAccountsWithSessions | Gets the login accounts that have valid sessions established.
Public Method GetPersonalInformationFromDomain | Gets the personal information of the specified login account from the domain.
Public Method GetServerCapabilities | Gets the server capabilities
Public Method ModifyLoginAccount | Modifies the specified login account on the server.
Public Method RemoveLoginAccount | Deletes the specified login account from the server.
Public Method UpdateLoginPassword | Changes the password of the specified M-Files login account.

See Also

ServerLoginAccountOperations Object


%%PageItemTitle%% $$Members$$

ServerManagementOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method BackupMasterDB | Creates a backup of the master database.
Public Method ConfigureWebAccessToDefaultWebSite | Configures M-Files Web Access to the default web site.
Public Method ConfigureWebAccessToExistingWebSite | Configures M-Files Web Access to the specified existing web site.
Public Method ConfigureWebAccessToNewVirtualDirectory | Configures M-Files Web Access to a new virtual directory.
Public Method ConfigureWebAccessToNewWebSite | Configures M-Files Web Access to a new web site.
Public Method GetEventHandlers | Gets the event handlers of the server.
Public Method RestoreMasterDB | Restores the specified master database backup.
Public Method SetEventHandlers | Sets the event handlers of the server.

See Also

ServerManagementOperations Object


%%PageItemTitle%% $$Members$$

ServerScheduledJobManagementOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddScheduledJob | Add the specified scheduled job to the server.
Public Method CancelScheduledJob | Cancels the execution of the specified scheduled job.
Public Method GetScheduledJob | Gets the specified scheduled job.
Public Method GetScheduledJobRunInfo | Gets run information on the specified scheduled job.
Public Method GetScheduledJobs | Gets all scheduled jobs on the server.
Public Method ModifyScheduledJob | Modifies the specified scheduled job on the server.
Public Method RemoveScheduledJob | Deletes the specified scheduled job from the server.
Public Method StartScheduledJob | Starts the execution of the specified scheduled job.

See Also

ServerScheduledJobManagementOperations Object


%%PageItemTitle%% $$Members$$

ServerVaultCapabilities Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a clone of an object.

Public Properties

Public Property ApplicationTaskQueueSupported | The server supports application task queue operations.
Public Property AsyncModifyObjectClassSupported | The server supports asynchronous object class modification.
Public Property AsyncNACLChangePropagationSupported | The server supports asynchronous change propagation of named access control lists.
Public Property AsyncTasksRetrievalSupported | The server supports retrieving asynchronous tasks.
Public Property AutomaticMetadataSupported | The server supports the automatic metadata feature, and metadata extraction is enabled on the server.
Public Property ClientHttpApiSupported | The server supports communication with the client through HTTP API.
Public Property DetectTextLanguageSupported | The server supports detecting the language of plain text.
Public Property EmbeddingToArcGisSupported | The server supports embedding the vNext-based M-Files Web UI to ArcGIS extensions.
Public Property EmbeddingToGoogleGSuiteSupported | The server supports the Google G Suite integration.
Public Property EmbeddingToSalesforceSupported | The server supports embedding the vNext-based M-Files Web UI to Salesforce.
Public Property EmbeddingToSharePointSupported | The server supports embedding the vNext-based M-Files Web UI to SharePoint.
Public Property ExternalRepositoryObjectMigrationSupported | The server supports external repository object migration.
Public Property FacetSearchSupported | Specifies whether facet searches can be executed.
Public Property FavorFullTextSearchSupported | The server supports favoring full-text search.
Public Property FileStreamingSupported | Specifies whether file streaming is supported.
Public Property FindDuplicatesSupported | The server supports finding duplicate files.
Public Property FullControlVaultUserCanModifyCodeSupported | The server supports vault users with full vault control to run code. Requires the server container in the Service Fabric cluster to be a single-tenant service.
Public Property GetTextContentWithOptionsSupported | The server supports option flags when retrieving the text content of a file.
Public Property HierarchicalObjectTypePropertiesSupported | The server supports hierarchical object type properties.
Public Property JSONExtApplicationsSupported | The server supports returning extensibility application structs in JSON format.
Public Property LatestVersionPublicLinkSharingSupported | Specifies whether public links for the latest versions can be shared.
Public Property MdccResolvedOnServer | The metadata card configuration is delivered in preresolved form from a dedicated, virtual NVS namespace.
Public Property NamedValueStorageConflictDetectionSupported | The server supports conflict detection when saving values to the named value storage.
Public Property NewWebWOPICoAuthoringSupported | The server supports WOPI-based co-authoring for the new M-Files Web.
Public Property ObjectDataRetrievalInChunksSupported | The server supports object data retrieval in chunks.
Public Property ObjectPermissionsForClientSupported | The server supports object permissions for clients.
Public Property PropertyDefSearchabilitySupported | Specifies whether property definitions can be set to be searchable or unsearchable.
Public Property PublicLinkSharingSupported | Specifies whether public links can be shared.
Public Property RemoveFromRecentsSupported | The server supports removing objects from the Recently Accessed by Me view.
Public Property ReplicationConfigurationIDSupported | The server supports using configuration IDs with export and import jobs.
Public Property ReverseGroupingLevelSupported | The server supports reversed grouping levels.
Public Property SearchOptionsSupported | The server supports search options.
Public Property SearchReferencedValueListItemsSupported | The server supports searching for value list items referenced by objects.
Public Property SettingsManagerSupported | The server supports settings management.
Public Property SharedLinkBasedWOPIOperationSupported | The server supports WOPI operations based on shared links.
Public Property UndeleteUserAccountByGUIDSupported | The server supports undeleting user accounts.
Public Property UseUserVisibleACLInSearches | The server supports checking users' read access to objects.
Public Property VaultLoginAccountsSupported | The vault supports in-vault login accounts.
Public Property WebClientsProductionTelemetryEnabled | The server supports web telemetry.
Public Property WebUserInterfaceSupported | The server supports web interface.

See Also

ServerVaultCapabilities Object


%%PageItemTitle%% $$Members$$

ServerVaultManagementOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AttachVault | Attaches the specified vault to the server. The metadata database and data files must already exist.
Public Method AttachVaultWithOptions | Attaches the specified vault to the server with options. The metadata database and data files must already exist.
Public Method BackupVault | Creates a backup with the specified parameters.
Public Method BringVaultOnline | Bring the vault online.
Public Method CopyVault | Creates a copy of a vault.
Public Method CreateNewGroundLinkProxy | Creates a new Ground Link proxy to the server based on the given vault properties.
Public Method CreateNewVault | Creates a new vault to the server based on the given vault properties.
Public Method DestroyVault | Destroys the specified vault.
Public Method DetachVault | Detaches the specified vault from the server. Removes the vault from the server's list of attached vaults but does not remove the metadata database or data files.
Public Method GetBackupFileContents | Gets information on the specified backup file.
Public Method GetVaultProperties | Gets the properties of the vault
Public Method OptimizeVault | Performs vault structure optimization.
Public Method RestoreVault | Restores the specified backup.
Public Method TakeVaultOffline | Takes the vault offline.

See Also

ServerVaultManagementOperations Object


%%PageItemTitle%% $$Members$$

ServerWOPIOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method EndWOPIUserSession | Ends the WOPI user session for the given key.
Public Method GetWOPILock | Gets the WOPI lock.
Public Method GetWOPIUserSession | Gets the WOPI user session information with the given key.
Public Method GetWOPIUserSessionKey | Gets the WOPI user session token with one-time token.
Public Method RemoveWOPILock | Removes the WOPI lock.
Public Method SetWOPILock | Sets the WOPI lock.
Public Method WOPIDownloadFile_Begin | Begins the block-by-block download of a file for WOPI operations.
Public Method WOPIDownloadFile_ReadBlock | Downloads a specific block from a file on the server for WOPI Operations.
Public Method WOPIFileCheckIn | Checks in the file with the given key.
Public Method WOPIFileCheckOut | Checks out the file with the given key.
Public Method WOPIUploadFileBlock | Uploads to the server a block of a file that is edited or co-authored.
Public Method WOPIUploadFileBlockBegin | Begins to upload to the server a file that is edited or co-authored.
Public Method WOPIUploadFileCommit | Commits the upload operation of the specified file edited or co-authored with WOPI.

See Also

ServerWOPIOperations Object


%%PageItemTitle%% $$Members$$

SessionInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method CheckObjectAccess | Checks object access requirements against the properties of this session.
Public Method CheckObjectTypeAccess | Checks the object type access requirements against the properties of this session.
Public Method CheckPropertyDefAccess | Checks the property definition access requirements against the properties of this session.
Public Method CheckVaultAccess | Checks vault access rights against the properties of this session.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method IsLoggedOnUserSubstituteOfUser | Resolves if the user is the substitute of another user.

Public Properties

Public Property AccountName | The M-Files account name of the logged-in user.
Public Property ACLMode | The ACL mode of the session.
Public Property AuthenticationType | The authentication type.
Public Property AutomaticMetadataEnabled | Specifies if the server supports automatic metadata features.
Public Property CanCreateObjects | Specifies whether the user can create documents and other objects.
Public Property CanForceUndoCheckout | Specifies whether the user can enforce undo checkout operation.
Public Property CanManageCommonUISettings | Specifies whether the user can manage common UI settings.
Public Property CanManageCommonViews | Specifies whether the user can manage common views.
Public Property CanManageTraditionalFolders | Specifies whether the user can manage traditional folders.
Public Property CanMaterializeViews | Specifies whether the user can materialize views.
Public Property CanSeeAllObjects | Specifies whether the user can see and read all documents and other objects (including deleted ones).
Public Property CanSeeDeletedObjects | Specifies whether the user can see and undelete deleted documents. Seeing a document still requires that the user has read access to it or the CanSeeAllObjects vault access right.
Public Property ClientCulture | The client software culture information, such as 'en-US' for American English.
Public Property Deployment | The deployment type of the server to which the user is logged in.
Public Property InternalUser | Specifies whether the user using this session is an internal user.
Public Property IsSharingPublicLinksAllowed | Specifies whether sharing public links is allowed.
Public Property IsSharingPublicLinksToLatestVersionAllowed | Specifies whether sharing public links to the latest version of the object is allowed.
Public Property KeepAliveIntervalInSeconds | The number of seconds that can pass between the client's keep-alive calls before M-Files Server closes the session.
Public Property Language | The user's vault language.
Public Property LicenseAllowsModifications | Specifies whether the license allows modifications.
Public Property LicenseType | The license type of the logged-in user.
Public Property LocalComputerName | The name of the local computer.
Public Property ProductMode | Product mode.
Public Property SerialNumber | The serial number of the server to which the user is logged in.
Public Property ServerVaultCapabilities | The capabilities of the connected server and vault.
Public Property ServerVersion | The version of the M-Files Server on which this vault resides.
Public Property TimeZoneInfo | Time zone information of this session.
Public Property UserAndGroupMemberships | The user ID of this session's account, as well as the groups to which the user belongs either directly or indirectly. The first ID in the vector is the user ID. Others are group IDs.
Public Property UserAndSubstitutedByMe | The user ID of this session's account, as well as the users for which the user is a substitute. The first ID in the vector is the user ID. Others are the IDs of the users for which the user is a substitute.
Public Property UserID | User ID for the session.
Public Property VaultGUID | The vault GUID as string.

See Also

SessionInfo Object


%%PageItemTitle%% $$Members$$

SetPropertiesParams Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetWithPermissions | Sets the contents of this object.

Public Properties

Public Property AccessControlListEnforcingMode | Gets the mode of access control list enforcing.
Public Property AccessControlListProvidedForEnforcing | Gets the access control list provided for enforcing.
Public Property AllowModifyingCheckedInObject | Allow the modification of checked in object.
Public Property FailIfNotLatestCheckedInVersion | Should the operation fail of not specifying the latest checked in version.
Public Property FullSet | True if the specified property values specify full set of property values.
Public Property ObjVer | ObjVer.
Public Property PropertyValuesToRemove | The property values that are removed from the object.
Public Property PropertyValuesToSet | The property values to set.

See Also

SetPropertiesParams Object


%%PageItemTitle%% $$Members$$

SetPropertiesParamsOfMultipleObjects Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

SetPropertiesParamsOfMultipleObjects Collection


%%PageItemTitle%% $$Members$$

SharedFileInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ChangeTimeUtc | The time in UTC when the file was last written to or its attributes were changed.
Public Property Extension | The extension of the file not including the dot (for instance "doc").
Public Property LogicalSize | The logical size of the file.
Public Property LogicalSize_32bit | The logical size of the file (uses 32-bit arguments).
Public Property Title | The title of the file.

See Also

SharedFileInfo Object


%%PageItemTitle%% $$Members$$

SharedLinkInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method Set | Set compulsory fields for creating the link.

Public Properties

Public Property AccessKey | The unique access key of the public link.
Public Property CreatedByUser | The user who created the public link.
Public Property CreationTime | The creation time of the public link.
Public Property Description | The description of the public link.
Public Property ExpirationTime | An optional expiration time for the public link.
Public Property FileVer | The file version referenced with the public link (optional).
Public Property LinkType | The type of the shared link.
Public Property ObjVer | The object version referenced with the public link.

See Also

SharedLinkInfo Object


%%PageItemTitle%% $$Members$$

SharedLinkInfos Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

SharedLinkInfos Collection


%%PageItemTitle%% $$Members$$

SharedLinkPublicOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method DownloadSharedFileInBlocks_Begin | Begins the block-by-block download of a shared file.
Public Method DownloadSharedFileInBlocks_Begin_32bit | Begins the block-by-block download of a shared file (using 32-bit arguments).
Public Method DownloadSharedFileInBlocks_ReadBlock | Retrieves a specific block of a shared file from the server.
Public Method DownloadSharedFileInBlocks_ReadBlock_32bit | Retrieves a specific block of a shared file from the server (using 32-bit arguments).
Public Method GetSharedLinkInfo | Gets information about a shared file (a file that has been shared with a public link).
Public Method UploadSharedFileBlock | Uploads a block of the file being co-authored to the server.
Public Method UploadSharedFileBlockBegin | Begins uploading a file being co-authored to the server.
Public Method UploadSharedFileCommit | Commits the upload operation of the specified co-authored file.

See Also

SharedLinkPublicOperations Object


%%PageItemTitle%% $$Members$$

SignaturePromptInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Meaning | Specifies the signature meaning.
Public Property Reason | Specifies the signature reason.

See Also

SignaturePromptInfo Object


%%PageItemTitle%% $$Members$$

SignaturePromptInfoMetadataBased Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property IsReferencedBySignatureObject | Specifies whether the prompt info lookup property is linked with a signature object.
Public Property MeaningPropertyID | Specifies the property to be used as a source for the signature meaning.
Public Property PromptInfoLookupPropertyID | Specifies the lookup property via which the prompt info details are found.
Public Property ReasonPropertyID | Specifies the property to be used as a source for the signature reason.

See Also

SignaturePromptInfoMetadataBased Object


%%PageItemTitle%% $$Members$$

SignaturePromptInfos Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

SignaturePromptInfos Collection


%%PageItemTitle%% $$Members$$

SignaturePromptInfoSelectable Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property PromptInfos Specifies the signature prompt infos.

See Also

SignaturePromptInfoSelectable Object


%%PageItemTitle%% $$Members$$

SignatureSettings Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AdditionalInfo | Specifies additional information for the signature manifestation (not shown to the user when signing).
Public Property FreeFormTextPropertyID | Specifies the property which is filled when a free-form text is prompted with the signature.
Public Property IsFreeFormTextPrompted | Specifies whether a free-form text is prompted with the signature.
Public Property IsRequired | Specifies whether the signature is required.
Public Property IsSeparateSignatureObject | Specifies whether the signature is created as a separate object.
Public Property ManifestationPropertyID | Specifies the property which is filled when the signature is given.
Public Property PromptInfoType | The prompt info type.
Public Property SignatureIdentifier | Specifies the identifier of the signature object.
Public Property SignaturePromptInfoFixed | Information about a task assignment if PromptInfoType is MFSignaturePromptInfoTypeFixed. Otherwise NULL.
Public Property SignaturePromptInfoMetadataBased | Information about a task assignment if PromptInfoType is MFSignaturePromptInfoTypeMetadataBased. Otherwise NULL.
Public Property SignaturePromptInfoSelectable | Information about a task assignment if PromptInfoType is MFSignaturePromptInfoTypeSelectable. Otherwise NULL.

See Also

SignatureSettings Object


%%PageItemTitle%% $$Members$$

SourceObjectFile Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Extension | The extension of the file when added to M-Files.
Public Property SourceFilePath | Absolute path to the source file.
Public Property Title | The title of the file when added to M-Files.

See Also

SourceObjectFile Object | ObjectCreationInfo Object


%%PageItemTitle%% $$Members$$

SourceObjectFiles Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds a new file to this collection.
Public Method AddEmptyFile | Adds a new empty source file to this collection.
Public Method AddFile | Adds a new source file to this collection.
Public Method Remove | Removes a file from this collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

SourceObjectFiles Collection | SourceObjectFile Object


%%PageItemTitle%% $$Members$$

SQLDatabase Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AdminUser | Specifies the username and password for accessing the database engine for administrative purposes. Specify NULL for this property if the database engine is Firebird.
Public Property BasicUser | Specifies the username and password for accessing the database engine in basic user operations. If this property is NULL when creating or attaching a vault, M-Files Server creates a new account with a default username and a random password. If this property is NULL when calling the UpdateVaultProperties method, the previously set username and password remain unchanged. Specify NULL for this property if the database engine is Firebird.
Public Property Engine | Database engine identification.
Public Property Name | The catalog i.e. the database name where the vault's data is residing. Allows the database name to differ from the vault display name. This is not specified in the Firebird case.
Public Property Server | The data source i.e. the database server name where the vault's database is residing. This is specified for data service DB engines only. It is empty or NULL for embedded databases such as Firebird Embedded.

See Also

SQLDatabase Object


%%PageItemTitle%% $$Members$$

State Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetAsLookup | Gets this state as a lookup value.
Public Method GetAsTypedValue | Gets this state as a single-select lookup based typed value.

Public Properties

Public Property ID | The ID of the workflow state.
Public Property Name | The name of the workflow state.
Public Property Selectable | Specifies whether the state is selectable.
Public Property SelectableFlagAffectedByPseudoUsers | Specifies whether the selectable flag is affected by pseudo users. If true, the selectable flag can be trusted only if the available state transitions are requested for a specific objver by using the GetWorkflowStatesEx method.

See Also

State Object


%%PageItemTitle%% $$Members$$

StateAdmin Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ActionAssignToUser | Specifies whether the 'Assign to user' action is enabled.
Public Property ActionAssignToUserDefinition | The definition of the 'Assign to user' action.
Public Property ActionConvertToPDF | Specifies whether the 'Convert to PDF' action is enabled.
Public Property ActionConvertToPDFDefinition | The definition of the 'Convert to PDF' action.
Public Property ActionCreateSeparateAssignment | Specifies whether the 'Create separate assignment' action is enabled.
Public Property ActionDefinitions | The definition of the actions (currently 'Create separate assignment' actions only).
Public Property ActionDelete | Specifies whether the 'Delete' action is enabled.
Public Property ActionMarkForArchiving | Specifies whether the 'Mark for archiving' action is enabled.
Public Property ActionRunVBScript | Specifies whether the 'Run VBScript' action is enabled.
Public Property ActionRunVBScriptDefinition | The definition of the 'Run VBScript' action.
Public Property ActionSendNotification | Specifies whether the 'Send notification' action is enabled.
Public Property ActionSendNotificationDefinition | The definition of the 'Send notification' action.
Public Property ActionSetPermissions | Specifies whether the 'Set permissions' action is enabled.
Public Property ActionSetPermissionsDetailedDefinition | The definition of the 'Set permissions' action.
Public Property ActionSetProperties | Specifies whether the 'Set properties' action is enabled.
Public Property ActionSetPropertiesDefinition | The definition of the 'Set properties' action.
Public Property CheckInOutPermissions | Specifies whether the "move into this state" and "move out of this state" permissions for this state should be checked when performing a state transition that involves this state.
Public Property Description | State description.
Public Property ID | State ID.
Public Property InOutPermissions | The "move into this state" and "move out of this state" permissions for this state.
Public Property Name | State name.
Public Property Postconditions | The conditions that an object must fulfill in order to be moved out of this state.
Public Property Preconditions | The conditions that an object must fulfill in order to be moved into this state.
Public Property SemanticAliases | The semantic aliases of this state.
Public Property TransitionsRequireEditAccessToObject | Specifies whether transitions involving this state require edit access to the object.

See Also

StateAdmin Object


%%PageItemTitle%% $$Members$$

StateConditions Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property PropertyConditions | Specifies whether property conditions are enabled.
Public Property PropertyConditionsDefinition | The property conditions.
Public Property VBScript | Specifies whether VBScript code is used.
Public Property VBScriptDefinition | The VBScript code.

See Also

StateConditions Collection


%%PageItemTitle%% $$Members$$

States Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

States Collection | State Object


%%PageItemTitle%% $$Members$$

StatesAdmin Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

StatesAdmin Collection


%%PageItemTitle%% $$Members$$

StateTransition Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AccessControlList | Transition permissions.
Public Property Description | The description of the state transition.
Public Property EvaluationOrderNumber | The evaluation order number that controls the order in which the triggers of different state transitions are evaluated.
Public Property FromState | The source state.
Public Property ID | The ID of the state transition.
Public Property Name | The name of the state transition.
Public Property SemanticAliases | The semantic aliases of this state transition.
Public Property SignatureSettings | Specifies the state transition signature settings.
Public Property ToState | The target state.
Public Property TriggerAllowedByVBScript | The VBScript code that is executed if the automatic state transition mode is MFASTModeAllowedByScript.
Public Property TriggerCriteria | The conditions that are evaluated if the automatic state transition mode is MFASTModeCriteriaFulfilled.
Public Property TriggerInDays | The number of days before the automatic state transition is triggered. Effective if the automatic state transition mode is 'MFASTModeRelativeTime'.
Public Property TriggerMode | The selected mode for automatic state transition.

See Also

StateTransition Object


%%PageItemTitle%% $$Members$$

StateTransitionForClient Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetAsLookup | Gets this state transition as a lookup value.
Public Method GetAsTypedValue | Gets this state transition as a single-select lookup based typed value.

Public Properties

Public Property FromState | The source state.
Public Property ID | The ID of the state transition.
Public Property Name | The name of the state transition.
Public Property Selectable | Specifies whether the state transition is selectable.
Public Property SelectableFlagAffectedByPseudoUsers | Specifies whether the selectable flag is affected by pseudo-users. If true, the selectable flag can be trusted only if the available state transitions are requested for a specific 'ObjVer' by using the 'GetWorkflowStatesEx' method.
Public Property ToState | The target state.

See Also

StateTransitionForClient Object


%%PageItemTitle%% $$Members$$

StateTransitions Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

StateTransitions Collection


%%PageItemTitle%% $$Members$$

StateTransitionsForClient Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

StateTransitionsForClient Collection


%%PageItemTitle%% $$Members$$

StringData Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AsString | The string representation.
Public Property StringDataType | The type of the string representation.

See Also

StringData Object


%%PageItemTitle%% $$Members$$

Strings Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds a new item to the collection. If the index is not valid, the item is added at the end.
Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method Join | Concatenates the members of the collection, using the specified separator between each member.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

Strings Collection


%%PageItemTitle%% $$Members$$

StructureAlias Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Alias | The name of a structure item alias.
Public Property ID | The ID of a structure item alias.

See Also

StructureAlias Object


%%PageItemTitle%% $$Members$$

StructureAliases Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

StructureAliases Collection


%%PageItemTitle%% $$Members$$

TaskAssignmentClassInfo Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property AnyAssigneeCompletes | True if any assignee can complete the assignment. This is valid for task type assignments only.
Public Property SignatureForCompletion | Information about signature settings for assignment completion.

See Also

TaskAssignmentClassInfo Object


%%PageItemTitle%% $$Members$$

TemporarySearchView Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property SearchCriteria | The search criteria of the view.
Public Property View | Encapsulated view object.

See Also

TemporarySearchView Object


%%PageItemTitle%% $$Members$$

Timestamp Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetValue | Gets the value as VARIANT of type VT_DATE.
Public Method LocalTimeToUtc | If Timestamp is local time - converts it to UTC and returns new object.
Public Method SetValue | Sets the value from VARIANT of type VT_DATE.
Public Method UtcToLocalTime | If Timestamp is UTC - converts it to a local time and returns new object.

Public Properties

Public Property Day | Day.
Public Property Fraction | Fraction in nanoseconds.
Public Property Hour | Hour.
Public Property Minute | Minute.
Public Property Month | Month.
Public Property Second | Second.
Public Property Year | Year.

See Also

Timestamp Object


%%PageItemTitle%% $$Members$$

TimeZoneInformation Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a clone of an object.
Public Method LoadTimeZoneByName | Loads the time zone of the given name. The names of the available time zones can found from Windows registry under the following key: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Time Zones.
Public Method LoadWithCurrentTimeZone | Initializes the time zone with the local time zone.

Public Properties

Public Property StandardName The standard name of the time zone.

See Also

TimeZoneInformation Object


%%PageItemTitle%% $$Members$$

TraditionalFolder Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property ID | ID of the traditional folder.
Public Property Name | Name of the traditional folder.

See Also

TraditionalFolder Object


%%PageItemTitle%% $$Members$$

TraditionalFolderContents Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property ID | The ID of the traditional folder.
Public Property ObjectVersions | Object versions inside this traditional folder.
Public Property TraditionalFolders | Traditional folders inside this traditional folder.

See Also

TraditionalFolderContents Object | TraditionalFolder Object | VaultTraditionalFolderOperations Object


%%PageItemTitle%% $$Members$$

TraditionalFolders Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

TraditionalFolders Collection


%%PageItemTitle%% $$Members$$

TriggerType Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetDailyTrigger | The time when the scheduled will run next.
Public Method SetMonthlyDate | The time when the scheduled will run next.
Public Method SetMonthlyDOW | The time when the scheduled will run next.
Public Method SetWeekly | The time when the scheduled will run next.

Public Properties

Public Property Daily | The time when the scheduled will run next.
Public Property MonthlyDate | The time when the scheduled will run next.
Public Property MonthlyDOW | The time when the scheduled will run next.
Public Property Type | An enumerated value that specifies the type of trigger.
Public Property Weekly | The time when the scheduled will run next.

See Also

TriggerType Object


%%PageItemTitle%% $$Members$$

TypedValue Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method CompareTo | Compares this typed value to the given typed value.
Public Method GetLookupID | Gets the lookup ID. The typed value must be of the lookup type.
Public Method GetValueAsLocalizedText | Gets the current value as localized text. The value is localized based on the culture of the local computer.
Public Method GetValueAsLocalizedTextEx | Gets the current value as localized text. The value is localized based on the culture setting of the local computer.
Public Method GetValueAsLookup | Gets the value as a lookup.
Public Method GetValueAsLookups | Gets the value as a lookups.
Public Method GetValueAsText | Gets the value of this typed value formatted with the given parameters.
Public Method GetValueAsTextEx | Gets the value of this typed value formatted with the given parameters.
Public Method GetValueAsTextWithExpression | Gets the current value as localized text modified according to the given expression.
Public Method GetValueAsTimestamp | Gets the value as timestamp.
Public Method GetValueAsUnlocalizedText | Gets the current value as unlocalized text.
Public Method IsNULL | Specifies whether the typed value is a NULL value.
Public Method IsUninitialized | Specifies whether the typed value is uninitialized.
Public Method Serialize | Serializes the typed value.
Public Method SetValue | Sets the value of a typed value.
Public Method SetValueToLookup | Set the value to a lookup.
Public Method SetValueToMultiSelectLookup | Sets the value to a multi-select lookup.
Public Method SetValueToNULL | Sets the typed value to NULL of the specified data type.
Public Method Unserialize | Unserializes the typed value.

Public Properties

Public Property DataType | The data type of the typed value.
Public Property DisplayValue | The textual representation of the typed value.
Public Property Value | The value of the type value. If the data type of a typed value is MFDataTypeLookup, only the ID part of the lookup is included.

See Also

TypedValue Object | SearchCondition Object


%%PageItemTitle%% $$Members$$

TypedValues Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Remove | Removes the item at the specified position.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

TypedValues Collection


%%PageItemTitle%% $$Members$$

UserAccount Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddVaultRoles | Adds new vault roles for the user.
Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method RemoveVaultRoles | Removes vault roles from the user.

Public Properties

Public Property AccessControlList | The user permissions as an access control list.
Public Property Enabled | The enabled state of the user.
Public Property ID | The ID of the user.
Public Property InternalUser | Specifies whether the user is an internal user.
Public Property LoginName | The login name of the user.
Public Property VaultLanguage | Current vault language for the user.
Public Property VaultRoles | The vault roles of the user.

See Also

UserAccount Object


%%PageItemTitle%% $$Members$$

UserAccounts Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

UserAccounts Collection


%%PageItemTitle%% $$Members$$

UserGroup Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddMember | Adds a new member to the user group. Group IDs are negative, user IDs are positive.
Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method RemoveMember | Removes the specified member from the user group. Group IDs are negative, user IDs are positive.

Public Properties

Public Property ID | The ID of the user group.
Public Property Members | Members of the user group. Group IDs are negative, user IDs are positive.
Public Property Name | The name of the user group.
Public Property Predefined | Specifies whether the user group is a built-in user group.

See Also

UserGroup Object


%%PageItemTitle%% $$Members$$

UserGroupAdmin Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.

Public Properties

Public Property AccessControlList | The definition of the access control list which controls visibility of user group.
Public Property ExternalRepositoryName | The identity of the external repository the group is associated with.
Public Property ExternalRepositorySubjectID | The identity of the external group this group is associated with.
Public Property SemanticAliases | The semantic aliases of this user group.
Public Property UserGroup | The user group.

See Also

UserGroupAdmin Object


%%PageItemTitle%% $$Members$$

UserGroups Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

UserGroups Collection | UserGroup Object


%%PageItemTitle%% $$Members$$

UserOrUserGroupID Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property UserOrGroupID | The id of a user or a user group.
Public Property UserOrGroupType | The type of a user or a user group.

See Also

UserOrUserGroupID Object


%%PageItemTitle%% $$Members$$

UserOrUserGroupIDEx Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method SetIndirectPropertyPseudoUser | Sets the object to point to a pseudo-user based on an indirect property definition.
Public Method SetUserAccount | Sets the object to point to a user.
Public Method SetUserGroup | Sets the object to point to a user group.
Public Method SetWorkflowStatePseudoUser | Sets the object to point to a pseudo-user referred to by a workflow state.

Public Properties

Public Property IndirectProperty | Specifies the indirect property ID that specifies the user.
Public Property UserOrGroupID | Specifies the user or user group ID.
Public Property UserOrGroupType | Specifies the type of the contained user or user group ID.
Public Property WorkflowState | Specifies the pseudo-user ID when based on a workflow.

See Also

UserOrUserGroupIDEx Object


%%PageItemTitle%% $$Members$$

UserOrUserGroupIDExs Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method GetUserOrUserGroupIDEx | Gets user or group ID.
Public Method GetUserOrUserGroupIDExIndex | Gets user or group ID index. -1 indicates that item was not found.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

UserOrUserGroupIDExs Collection


%%PageItemTitle%% $$Members$$

UserOrUserGroupIDs Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method GetUserOrUserGroupID | Gets user or group ID.
Public Method GetUserOrUserGroupIDIndex | Gets user or group ID index. -1 indicates that item was not found.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

UserOrUserGroupIDs Collection


%%PageItemTitle%% $$Members$$

Validation Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property RegularExpression | A regular expression for the validation.
Public Property VBScript | VBScript code used in the validation.

See Also

Validation Object


%%PageItemTitle%% $$Members$$

ValueListItem Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.
Public Method GetIconAsPNG | Returns the icon of this value list item in PNG format scaled to the specified size.

Public Properties

Public Property AutomaticPermissionsForObjects | Specifies the automatic permissions for an object for which the user selects this item. If Nothing, no automatic permissions are defined.
Public Property Deleted | Specifies whether this value list item has been deleted.
Public Property DisplayID | The display ID of the value list item. This may differ from the numeric internal ID.
Public Property DisplayIDAvailable | Specifies whether the display ID is available.
Public Property ExternalRepositoryName | The external repository name of the value list item.
Public Property ExternalRepositoryObjectID | The external repository identifier of the value list item.
Public Property HasOwner | Specifies whether the value list item has an owner item.
Public Property HasParent | Specifies whether the value list item has a parent item.
Public Property Icon | If not NULL, contains the icon of this item in .ICO format.
Public Property ID | The ID of the value list item.
Public Property ItemGUID | The item GUID as a string.
Public Property Name | The name of the value list item.
Public Property ObjID | The object ID of the value list item.
Public Property OwnerID | The owner item ID of the value list item.
Public Property ParentID | The parent item ID of the value list item.
Public Property ValueListID | The ID of the value list.

See Also

ValueListItem Object


%%PageItemTitle%% $$Members$$

ValueListItems Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

ValueListItems Collection | ValueListItem Object


%%PageItemTitle%% $$Members$$

ValueListItemSearchResults Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.
Public Property MoreResults | Specifies whether additional results are available.

See Also

ValueListItemSearchResults Collection


%%PageItemTitle%% $$Members$$

ValueListItemSearchResultsWithPermissions Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Permissions | The permissions of the value list items.
Public Property ValueListItemSearchResults | The value list items.

See Also

ValueListItemSearchResultsWithPermissions Object


%%PageItemTitle%% $$Members$$

ValueListItemsWithPermissions Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Permissions | The permissions of the value list items.
Public Property ValueListItems | The value list items.

See Also

ValueListItemsWithPermissions Object


%%PageItemTitle%% $$Members$$

Vault Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method ChangePassword | Changes the password of the current user.
Public Method DetachSession | Detaches the current session from this vault object without logging out the session.
Public Method DisconnectDevice | Disconnects the specified device of the logged-in user from the server.
Public Method GetAllTranslations | Gets all vault translations as JSON.
Public Method GetGUID | Gets the GUID of the vault on the server.
Public Method GetMetadataStructureItemIDByAlias | Receives the ID of the metadata structure element with the specified alias.
Public Method GetMetadataStructureItemIDsByAliases | Get the metadata structure item's IDs and aliases.
Public Method GetMetadataStructureVersionID | Receives the metadata structure version ID of the vault. This ID is incremented when the structure of the vault is changed.
Public Method GetMFilesURLForVaultRoot | Gets the URL to the vault root.
Public Method GetServerLicenseStatus | Gets the server license status.
Public Method GetServerVersionOfVault | Receives the version of the server where the vault resides.
Public Method GetVaultServerAttachments | Gets the vault server attachments.
Public Method LogOutSilent | Performs a silent logout.
Public Method LogOutWithDialogs | Logs out from vault. May display dialog boxes during the logout.
Public Method Restart | Restarts the vault.
Public Method TestConnectionToServer | Tests the connection to the server.
Public Method TestConnectionToVault | Tests the connection to the vault.
Public Method TestConnectionToVaultWithTimeout | Tests the connection to the vault.

Public Properties

Public Property AutomaticMetadataOperations | Gets the automatic metadata operations interface.
Public Property ClassGroupOperations | Gets the class group operations interface.
Public Property ClassOperations | Gets the class operations interface.
Public Property ClientOperations | Gets the client operations interface.
Public Property CurrentLoggedInUserID | The ID of the current logged-in user.
Public Property CustomApplicationManagementOperations | Gets the custom application management operations interface.
Public Property DataSetOperations | Gets the data set export operations interface.
Public Property ElectronicSignatureOperations | Gets the electronic signature operations interface.
Public Property EventLogOperations | Gets the event log operations interface.
Public Property ExtensionAuthenticationOperations | Gets the extension authentication operations interface.
Public Property ExtensionMethodOperations | Gets the vault extension method operations interface.
Public Property ExternalObjectOperations | Gets the external object operations interface.
Public Property LoggedIn | Specifies whether a user has logged into the vault.
Public Property LoginAccountOperations | Gets the vault login account operations interface.
Public Property LoginSessionID | The session ID as string.
Public Property ManagementOperations | Gets the management operations interface.
Public Property Name | The name of this vault. In client mode, returns the name of the vault connection. In server mode, returns the name of the vault on server.
Public Property NamedACLOperations | Gets the named access control list operations interface.
Public Property NamedValueStorageOperations | Gets the named value storage interface.
Public Property NotificationOperations | Receives the interface for vault notification operations.
Public Property ObjectFileOperations | Gets the object file operations interface.
Public Property ObjectOperations | Gets the object operations interface.
Public Property ObjectPropertyOperations | Gets the object property operations interface.
Public Property ObjectSearchOperations | Gets the object search operations interface.
Public Property ObjectTypeOperations | Gets the object type operations interface.
Public Property PropertyDefOperations | Gets the property definition operations interface.
Public Property ReadOnlyAccess | Specifies whether the user has read-only access to the vault.
Public Property ScheduledJobManagementOperations | Gets the scheduled job management operations interface.
Public Property ServerDataPushOperations | Receives the interface for vault server data push operations.
Public Property SessionInfo | Information about the current session.
Public Property SharedLinkOperations | Gets the public link operations interface.
Public Property TraditionalFolderOperations | Gets the traditional folder operations interface.
Public Property UserGroupOperations | Gets the user group operations interface.
Public Property UserOperations | Gets the user operations interface.
Public Property UserOperationsEx | Gets the advanced user operations interface.
Public Property UserSettingOperations | Gets the user setting operations interface.
Public Property ValueListItemOperations | Gets the value list item operations interface.
Public Property ValueListOperations | Gets the value list operations interface.
Public Property VaultLanguages | Gets all languages of vault.
Public Property VaultWOPIOperations | Gets the public link operations interface.
Public Property ViewOperations | Gets the view operations interface.
Public Property WorkflowOperations | Gets the workflow operations interface.

See Also

Vault Object


%%PageItemTitle%% $$Members$$

VaultApplicationTaskOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddScheduledTask | Adds a scheduled task to a task queue. The "ApplicationTaskInfo" object must contain the ID of the task queue to which the task is to be added.
Public Method AddTask | Adds a task to a task queue. The "ApplicationTaskInfo" object must contain the ID of the task queue to which the task is to be added.
Public Method GetLatestBroadcastMessageIdentifiers | Gets the IDs of the most recent broadcast messages from the given queues.
Public Method GetNewBroadcastMessages | Gets the broadcast messages that have been sent since the specified broadcast message ID.
Public Method GetTaskIDsFromQueue | Gets the list of task IDs from a task queue.
Public Method GetTaskQueues | Gets the list of available task queues from the server.
Public Method GetTasks | Gets task objects from the server. This does not reserve any tasks for processing, meaning that their states can still change on the server.
Public Method OpenTaskQueue | Opens a new task queue. When the application no longer needs the queue, it can simply stop using it. The server automatically closes the queue when instances stop using it.
Public Method ReserveTasksForProcessing | Reserves the next tasks for processing from the task queues.
Public Method SendBroadcastMessage | Sends a broadcast message to a task queue.
Public Method UpdateTask | Updates the task information to the server.

See Also

VaultApplicationTaskOperations Object


%%PageItemTitle%% $$Members$$

VaultAutomaticMetadataOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method DetectTextLanguage | Detects the language of the specified plain text content.
Public Method DetectTextLanguageEx | Detects the language of the specified plain text content.
Public Method GetAutomaticMetadata | Gets the automatically generated metadata.
Public Method GetAutomaticMetadataForObject | Gets the automatically generated metadata for an existing object.
Public Method GetAutomaticMetadataForTemporaryFile | Gets the automatically generated metadata for a temporary file.
Public Method GetAutomaticMetadataForTemporaryFiles | Gets the automatically generated metadata for temporary files.

See Also

VaultAutomaticMetadataOperations Object


%%PageItemTitle%% $$Members$$

VaultClassGroupOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddClassGroup | Adds a new class group. Returns the created class group, with the ID property set to the real ID value.
Public Method GetClassGroup | Gets the specified class group.
Public Method GetClassGroupIDByGUID | Gets the ID of the class group with the specified GUID. Returns -1 if a match is not found.
Public Method GetClassGroups | Gets all available class groups.
Public Method RemoveClassGroup | Deletes the class group with the specified ID.
Public Method UpdateClassGroup | Updates the class group. The ID property identifies the class group to modify.

See Also

VaultClassGroupOperations Object


%%PageItemTitle%% $$Members$$

VaultClassOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddObjectClassAdmin | Adds a new object class. Returns the created object class, with the ID property set to the real ID value.
Public Method GetAllObjectClasses | Gets all object classes.
Public Method GetAllObjectClassesAdmin | Gets all object classes (for administrative operations).
Public Method GetObjectClass | Gets a single object class.
Public Method GetObjectClassAdmin | Gets the specified object class (for administrative operations).
Public Method GetObjectClasses | Gets object classes for the specified object type.
Public Method GetObjectClassesAdmin | Gets object classes for the specified object type (for administrative operations).
Public Method GetObjectClassIDByAlias | Gets the ID of the object class with the specified alias. Returns -1 if a match is not found or if more than one object class uses the specified alias.
Public Method GetObjectClassIDByGUID | Gets the ID of the object class with the specified GUID. Returns -1 if a match is not found.
Public Method RemoveObjectClassAdmin | Deletes the object class with the specified ID.
Public Method UpdateObjectClassAdmin | Updates the object class. The ID property identifies the object class to modify.
Public Method UpdateObjectNames | Updates the names of all existing objects of the specified class by copying values from the name property of the class to the built-in 'Name or title' property.

See Also

VaultClassOperations Object


%%PageItemTitle%% $$Members$$

VaultClientOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method DisableCheckInReminderForCallingProcess | Disables the check-in reminder for the calling process.
Public Method EnableCheckInReminderForCallingProcess | Enables the check-in reminder for the calling process.
Public Method IsOffline | Specifies whether the vault is in offline mode.
Public Method IsOnline | Specifies whether the vault is in online mode.
Public Method SetVaultToOffline | Sets the vault to offline mode.
Public Method SetVaultToOnline | Sets the vault to online mode.

See Also

VaultClientOperations Object


%%PageItemTitle%% $$Members$$

VaultConnection Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method BindToVault | Binds to the vault identified by this vault connection. The default authentication method is used if the login is allowed.
Public Method Clone | Creates a copy of the object.
Public Method GetGUID | Gets the GUID on the server of the vault identified by this vault connection.
Public Method IsLoggedIn | Checks whether the current user is currently logged into the vault identified by this vault connection.
Public Method LogInAs | Logs in to the vault. Prompts the user for credentials.
Public Method LogInAsUser | Logs in to the vault using the specified credentials.
Public Method TestConnectionToVault | Tests the connection to the vault identified by this vault connection.

Public Properties

Public Property AuthType | The type of the authentication.
Public Property AutoLogin | Specifies if M-Files should automatically log in to this vault when the system is started.
Public Property EncryptedConnection | Specifies if data between M-Files Desktop and M-Files Server must be encrypted. May apply to certain protocol sequences only.
Public Property Endpoint

Specifies the communication port on which the server listens for calls.

With the TCP/IP protocol, specify the TCP port that M-Files Server is listening to. Typically this value is 2266.

With the HTTPS protocol, specify the M-Files Server endpoint that will be used between the RPC Proxy and M-Files Server on the server side. Typically this value is 4466. Note that this parameter does not affect the port that the client uses to communicate with the server. Regardless of this setting, the client will always use the standard HTTPS port for communicating with the server.

With the LPC protocol, specify "MFServerCommon_F5EE352D-6A03-4866-9988-C69CEA2C39BF" to connect to the local M-Files Server instance regardless of its version. If multiple versions of M-Files Server are running on the same computer, the first instance that has started has been registered to listen to this endpoint. Alternatively, you can leave this parameter empty in order to connect to the exact same version of M-Files Server as the M-Files API version you are using. If you leave the Endpoint parameter empty with the LPC protocol, M-Files API uses a version-specific endpoint name to connect to M-Files Server.
Public Property Icon | If not NULL, contains the icon of this item in .ICO format.
Public Property Name | The name of the vault identified by this vault connection.
Public Property NetworkAddress | The network address for connecting to the vault.
Public Property ProtocolSequence | The protocol sequence for connecting to the vault.
Public Property ServerVaultGUID | The GUID of the vault on the server.
Public Property ServerVaultName | The name of the vault on the server.
Public Property UserSpecific | Specifies if this connection is user specific or visible to all users.

See Also

VaultConnection Object


%%PageItemTitle%% $$Members$$

VaultConnections Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds a new vault connection to this collection.
Public Method GetVaultConnectionByName | Gets vault connection with specified name.
Public Method GetVaultConnectionIndexByName | Gets the index of vault connection in collection using specified name.
Public Method Remove | Removes a vault connection from this collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

VaultConnections Collection | VaultConnection Object


%%PageItemTitle%% $$Members$$

VaultCustomApplicationManagementOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method DownloadCustomApplicationBlock | Retrieves a specific block of the specified application file from the server.
Public Method DownloadCustomApplicationBlock_32bit | Retrieves a specific block of the specified application file from the server (uses 32-bit arguments).
Public Method DownloadCustomApplicationBlockBegin | Begins the block-by-block download of the specified application.
Public Method DownloadCustomApplicationBlockBegin_32bit | Begins the block-by-block download of the specified application (uses 32-bit arguments).
Public Method EnableCustomApplication | Enables or disables the specified custom application in current client for this user.
Public Method EnableCustomApplicationInVault | Enables or disables the specified custom application at vault level for all users.
Public Method GetCustomApplication | Gets a single custom application.
Public Method GetCustomApplicationLicenseDetails | Get the license details of the current license for a custom application.
Public Method GetCustomApplicationLicenseStatus | Get the license status enumeration of the current license for a custom application.
Public Method GetCustomApplicationNewLicenseDetails | Get the license details of a new license for a custom application.
Public Method GetCustomApplicationNewLicenseStatus | Get the license status enumeration of a new license for a custom application.
Public Method GetCustomApplications | Gets the custom applications installed in the vault. Use the GetCustomApplicationsEx2 method for additional options.
Public Method GetCustomApplicationsEx | Gets the custom applications installed in the vault. Use the GetCustomApplicationsEx2 method for additional options.
Public Method GetCustomApplicationsEx2 | Gets the custom applications installed in the vault.
Public Method InstallCustomApplication | Installs a custom application from the specified file to the vault.
Public Method InstallCustomApplicationLicense | Install a new license for a custom application.
Public Method UninstallCustomApplication | Uninstalls the specified custom application from the vault.

See Also

VaultCustomApplicationManagementOperations Object


%%PageItemTitle%% $$Members$$

VaultDataSetOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetDataSetExportingStatus | Gets the exporting status for a data set export operation.
Public Method GetDataSets | Gets all data sets available for export from the vault.
Public Method GetReportAccessCredentials | Gets the report access credentials for this vault.
Public Method StartDataSetExport | Manually trigger a data set export operation.

See Also

VaultDataSetOperations Object


%%PageItemTitle%% $$Members$$

VaultDocumentComparisonOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AllowDocumentComparison | Specifies whether document comparison is allowed.
Public Method Compare | Gets a URL which can be used to display the differences between two documents in the vault.
Public Method CompareWithTemporaryFile | Gets a URL which can be used to display the differences between a document in the vault and a temporarily uploaded file.

See Also

VaultDocumentComparisonOperations Object


%%PageItemTitle%% $$Members$$

VaultElectronicSignatureOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddEmptySignature | Adds an empty placeholder for the specified signature. If the specified signature already exists, it is not replaced.
Public Method AddEmptySignatures | Adds empty placeholders for all signatures. Existing signatures are not replaced.
Public Method DisconnectSignature | Disconnects the specified signature from the object. Valid signatures are marked invalid as they get disconnected.
Public Method DisconnectSignatureEx | Disconnects the specified signature from the object. Valid signatures are optionally marked invalid as they get disconnected.
Public Method DisconnectSignatures | Disconnects all signatures from the object. Valid signatures are marked invalid as they get disconnected.
Public Method DisconnectSignaturesEx | Disconnects all signatures from the object. Valid signatures are optionally marked invalid as they get disconnected.

See Also

VaultElectronicSignatureOperations Object


%%PageItemTitle%% $$Members$$

VaultEventLogOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddCustomEventEntry | Adds a custom event entry to the server event log.
Public Method Clear | Clears the event log.
Public Method ClearRange | Clears the specified range of events in the event log.
Public Method ClearRange_32bit | Clears the range of events in log. Compatible with 32-bit development environments.
Public Method ExportAll | Exports all events to XML format.
Public Method ExportRange | Exports the specified range of events to XML format.
Public Method ExportRange_32bit | Exports the specified range of events to XML format. Compatible with 32-bit development environments.
Public Method GetIDRange | Returns the ID range of the events.
Public Method IsLoggingEnabled | Gets the current event logging status.
Public Method SetLoggingEnabled | Enables or disables the logging.

See Also

VaultEventLogOperations Object


%%PageItemTitle%% $$Members$$

VaultExtensionAuthenticationOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetExtensionAuthenticationStatus | Gets the extension authentication status for logged-in authentications.
Public Method GetExtensionAuthenticationTargets | Gets the available extension authentication targets.
Public Method LogInWithExtensionAuthentication | Logs in with the provided extension authentication data.
Public Method LogOutWithExtensionAuthentication | Logs out with the existing extension authentication data.
Public Method RemoveExtensionAuthenticationSpecialCredentials | Removes extension authentication data from the server-side cache.
Public Method StoreExtensionAuthenticationSpecialCredentials | Stores extension authentication data in the server-side cache.

See Also

VaultExtensionAuthenticationOperations Object


%%PageItemTitle%% $$Members$$

VaultExtensionMethodOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method DoesActiveVaultExtensionMethodExist | Checks if an active vault extension method with the specified identifer exist.
Public Method ExecuteVaultExtensionMethod | Executes the specified vault extension method.

See Also

VaultExtensionMethodOperations Object


%%PageItemTitle%% $$Members$$

VaultExternalObjectOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method DemoteObjects | Removes the metadata from previously promoted objects, effectively demoting them back to unmanaged objects.
Public Method PromoteObject | Promotes an unmanaged object to a managed one.
Public Method PromoteObjects | Promotes unmanaged objects to managed objects.
Public Method ResolveManagedIDOfPromotedObject | Resolves the ID of a managed object based on the ID that it had as an unmanaged object before the promotion.

See Also

VaultExternalObjectOperations Object


%%PageItemTitle%% $$Members$$

VaultLoginAccountOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddLoginAccount | Adds the specified vault login account.
Public Method ForceLogout | Forcefully logs out the users with the specified vault login accounts.
Public Method GetLoginAccount | Gets the specified vault login account.
Public Method GetLoginAccounts | Gets all vault login accounts.
Public Method GetLoginAccountsWithSessions | Gets the vault login accounts that have valid sessions established.
Public Method GetPersonalInformationFromDomain | Gets the personal information of the specified vault login account from the domain.
Public Method ModifyLoginAccount | Modifies the specified vault login account. Use the 'ModifyLoginAccountEx' method for additional options.
Public Method ModifyLoginAccountEx | Modifies the specified vault login account.
Public Method RemoveLoginAccount | Deletes the specified vault login account.
Public Method UpdateLoginPassword | Changes the password of the specified M-Files vault login account.

See Also

VaultLoginAccountOperations Object


%%PageItemTitle%% $$Members$$

VaultManagementOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method ArchiveOldVersions | Moves old object versions, including both metadata and files, to a content package.
Public Method ExportContent | Exports content, including both metadata and files, to a content package.
Public Method GetEventHandlers | Gets the event handlers of the vault.
Public Method GetVaultProperties | Gets the vault properties.
Public Method ImportContent | Imports content from a content package.
Public Method ImportContentAsync | Imports content from a content package asynchronously.
Public Method IsAsyncJobRunning | Checks if the specified asynchronous job is running.
Public Method IsGroundLinkProxy | Checks if the vault is a Ground Link proxy.
Public Method PreviewImportContent | Previews the results of the import content job. Changes are not written into the target vault, but outputted to the summary file.
Public Method QueueAndWaitForLatestBackgroundTask | Queues and waits for the latest background task, if there are any, to finish.
Public Method RebuildFullTextSearchIndex | Starts rebuilding the full-text search index of the vault.
Public Method SetEventHandlers | Sets the event handlers of the vault.
Public Method UpdateVaultProperties

Updates the vault properties.

The vault must first be detached for the method to work correctly.

Public Method VerifyVault | Performs vault verification.
Public Method WaitAsyncJob | Waits for the specified asynchronous job to finish.

See Also

VaultManagementOperations Object


%%PageItemTitle%% $$Members$$

VaultManagementOperationsAccess Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetVaultProperties Gets the vault properties.

See Also

VaultManagementOperationsAccess Object


%%PageItemTitle%% $$Members$$

VaultNamedACLOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddNamedACLAdmin | Adds a new named ACL. Returns the created named ACL, with the ID property set to the real ID value.
Public Method GetMatchingNamedACLForAccessControlList | Returns a named access control list that matches the specified access control list.
Public Method GetMatchingNamedACLForAccessControlListComponent | Returns a named access control list that matches the specified access control list component.
Public Method GetNamedACL | Gets the specified named ACL.
Public Method GetNamedACLAdmin | Gets the specified named ACL (for administrative operations).
Public Method GetNamedACLIDByAlias | Gets the ID of the named ACL with the specified alias. Returns -1000 if a match is not found or if more than one named ACL uses the specified alias.
Public Method GetNamedACLIDByGUID | Gets the ID of the named ACL with the specified GUID. Returns -1000 if a match is not found.
Public Method GetNamedACLs | Gets all named ACLs.
Public Method GetNamedACLsByTypeAdmin | Gets all named ACLs by their type (for administrative operations).
Public Method GetNamedACLsWithRefresh | Gets all named ACLs.
Public Method GetNamedACLWithRefresh | Gets the specified named ACL.
Public Method IsNamedACLUsedInAutomaticPermissionsAdmin | Checks whether the specified named ACL is currently used in automatic permissions.
Public Method RemoveNamedACLWithPropagationAdmin | Deletes the named ACL with the specified ID.
Public Method UpdateNamedACLAdmin | Updates the named ACL. The ID property identifies the named ACL to modify.
Public Method UpdateNamedACLWithPropagationAdmin | Updates the named ACL. The ID property identifies the named ACL to modify.

See Also

VaultNamedACLOperations Object


%%PageItemTitle%% $$Members$$

VaultNamedValueStorageOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetNamedValues | Reads the named values with the specified namespace from the vault.
Public Method RemoveNamedValues | Deletes the specified named values from the vault.
Public Method SetNamedValues | Stores the named values to the vault.
Public Method SetNamedValuesIfUnmodified | Stores the named values of the "NamedValues" parameter to the vault if the values of the "ExpectedValues" parameter match the current values in the vault. If the values do not match, the operation fails.

See Also

VaultNamedValueStorageOperations Object


%%PageItemTitle%% $$Members$$

VaultNotificationOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetNotificationRuleNamesByID | Gets notification rule names by ID.
Public Method SendCustomNotification | Sends a notification for vault users or external parties.

See Also

VaultNotificationOperations Object


%%PageItemTitle%% $$Members$$

VaultObjectFileOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddEmptyFile | Adds an empty file to an existing object.
Public Method AddFile | Adds a new file to the specified object based on the given path.
Public Method CancelFileDownloadSession | Stops the specified file download.
Public Method CloseUploadSession | Closes the upload session.
Public Method ConvertToPDF | Converts the specified object file to PDF format.
Public Method DownloadFile | Downloads the content of the specified file from the server to the specified path.
Public Method DownloadFileAsDataURI | Downloads the content of the specified file as a data URI.
Public Method DownloadFileAsDataURIEx | Downloads the content of the specified file as a data URI.
Public Method DownloadFileEx | Downloads the content of the specified file from the server to the specified path.
Public Method DownloadFileEx2 | Downloads the content of the specified file from the server to the specified path.
Public Method DownloadFileEx3 | Downloads the content of the specified file from the server to the specified path.
Public Method DownloadFileInBlocks_Begin | Begins the block-by-block download of the specified file.
Public Method DownloadFileInBlocks_Begin_32bit | Begins the block-by-block download of the specified file (uses 32-bit arguments).
Public Method DownloadFileInBlocks_Begin_32bitEx | Begins the block-by-block download of the specified file (using 32-bit arguments).
Public Method DownloadFileInBlocks_BeginEx | Begins the block-by-block download of the specified file.
Public Method DownloadFileInBlocks_BeginEx_32bit | Begins the block-by-block download of the specified file (uses 32-bit arguments).
Public Method DownloadFileInBlocks_BeginEx_32bitEx | Begins the block-by-block download of the specified file (using 32-bit arguments).
Public Method DownloadFileInBlocks_BeginEx2 | Begins the block-by-block download of the specified file.
Public Method DownloadFileInBlocks_BeginEx3 | Begins the block-by-block download of the specified file.
Public Method DownloadFileInBlocks_ReadBlock | Retrieves a specific block of the specified file from the server.
Public Method DownloadFileInBlocks_ReadBlock_32bit | Retrieves a specific block of the specified file from the server (uses 32-bit arguments).
Public Method FindEmailDuplicates | Searches the vault for duplicate emails based on the given message ID.
Public Method FindFileDuplicates | Locates the first 100 duplicates of a specified file version in the vault as a list of ObjIDs.
Public Method FindFileDuplicatesBasedOnPath | Searches the vault for duplicates of a file based on the given path as a list of ObjIDs.
Public Method FindFileDuplicatesOfObjVer | Locates the first 100 duplicates of a specified obj version in the vault as a list of ObjIDs.
Public Method FindFilesByChecksumWithNumericalDigests | Uses a numerical digest to search the vault for file versions with a matching MD5 checksum.
Public Method FindFilesByChecksumWithStringDigests | Uses a string digest to search the vault for file versions with a matching MD5 checksum.
Public Method FindVaultDuplicates | Finds all of the duplicates in the vault.
Public Method GetFiles | Gets all object files of the specified object.
Public Method GetFilesForModificationInEventHandler | Gets all object files of the specified object for modification in event handler.
Public Method GetFileSize | Gets the size of the specified file.
Public Method GetFileSize_32bit | Gets the size of the specified file.
Public Method GetFileSize_32bitEx | Gets the size of the specified file (using 32-bit arguments).
Public Method GetFileSizeEx | Gets the size of the specified file.
Public Method GetLatestFileVersion | Gets the latest version of the specified file.
Public Method GetObjIDOfFile | Retrieves the object of the file.
Public Method GetPathInDefaultView | Gets the path of the file in the ID view.
Public Method GetPathInDefaultViewEx | Gets the path to the file either in the ID view or a traditional folder.
Public Method GetPathInDefaultViewEx2 | Gets the path of the file in the ID view.
Public Method GetPathInDefaultViewEx3 | Gets the path to the file either in the ID view or in a traditional folder.
Public Method GetTextContentForFile | Gets the plain text content of a file in the vault.
Public Method GetTextContentForFileEx | Gets the plain text content of a file in the vault.
Public Method GetTextContentForTemporaryFile | Gets the plain text content of a temporary file.
Public Method HasFileDuplicates | Checks if duplicates of a file exist.
Public Method OpenFileInDefaultApplication | Opens the given object file in the default application as specified.
Public Method PerformOCROperation | Performs an optical character recognition operation for object file.
Public Method RemoveFile | Deletes the specified file from the specified object.
Public Method RenameFile | Renames the given file.
Public Method UpdateMetadataInFile | Updates metadata embedded in the specified file.
Public Method UploadFile | Uploads the new content of the specified file to the server.
Public Method UploadFileBlock | Uploads a block of the specified file.
Public Method UploadFileBlock_32bit | Uploads a block of the specified file (uses 32-bit arguments).
Public Method UploadFileBlockBegin | Begins uploading a file to the server.
Public Method UploadFileBlockBegin_32bit | Begins uploading a file to the server (uses 32-bit arguments).
Public Method UploadFileCommit | Commits the upload operation of the specified file.
Public Method UploadFileCommit_32bit | Commits the upload operation of the specified file (uses 32-bit arguments).
Public Method UploadFileCommit_32bitEx | Commits the upload operation of the specified file (using 32-bit arguments).
Public Method UploadFileCommitEx | Commits the upload operation of the specified file.
Public Method UploadFileEx | Uploads the new content of the specified file to the server.
Public Method UploadFromDataURI | Uploads new content for the specified document file from the specified data URI.
Public Method UploadFromDataURIEx | Uploads new content for the specified document file from the specified data URI.
Public Method UploadTemporaryFile | Uploads the specified file as a temporary file to the server.
Public Method UploadTemporaryFileBlock | Uploads a block of the specified temporary file.
Public Method UploadTemporaryFileBlock_32bit | Uploads a block of the specified temporary file (using 32-bit arguments).
Public Method UploadTemporaryFileBlockBegin | Begins uploading a temporary file to the server.
Public Method UploadTemporaryFileBlockBegin_32bit | Begins uploading a temporary file to the server (using 32-bit arguments).
Public Method UploadTemporaryFileCommit | Commits the upload operation of the specified temporary file.
Public Method UploadTemporaryFileCommit_32bit | Commits the upload operation of the specified temporary file (using 32-bit arguments).

See Also

VaultObjectFileOperations Object


%%PageItemTitle%% $$Members$$

VaultObjectOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddFavorite | Adds the specified object to the 'Favorites' view of the current user.
Public Method AddFavorites | Adds the specified objects to the 'Favorites' view of the current user.
Public Method ChangePermissionsToACL | Changes the permissions for the specified object.
Public Method ChangePermissionsToNamedACL | Changes the permissions for the specified object.
Public Method CheckIn | Checks in the object.
Public Method CheckInMultipleObjects | Checks in multiple objects at once.
Public Method CheckOut | Checks out the object.
Public Method CheckOutMultipleObjects | Checks out multiple objects at once.
Public Method CompareWithAnotherDocument | Compares the content of this document with the content of another one.
Public Method CompareWithAnotherVersion | Compares the content of this document version with the content of another one. Use the CompareWithAnotherVersionEx method for multi-file document support.
Public Method CompareWithAnotherVersionEx | Compares the content of this document version with the content of another one.
Public Method CompareWithPreviousVersion | Compares the content of this document version with the content of the previous one. Use the CompareWithPreviousVersionEx method for multi-file document support.
Public Method CompareWithPreviousVersionEx | Compares the content of this document version with the content of the previous one.
Public Method CopyConflictObjectAsNewVersionToBaseObject | Saves a copy of the deleted conflict object as a new version of the related base object.
Public Method CreateNewAssignment | Creates a new assignment.
Public Method CreateNewEmptySingleFileDocument | Creates a new single-file document based on the specified properties and source files.
Public Method CreateNewObject | Creates a new object based on the specified properties and source files.
Public Method CreateNewObjectEx | Creates a new object based on the specified properties and source files.
Public Method CreateNewObjectExQuick | Creates a new object based on the specified properties and source files.
Public Method CreateNewSFDObject | Creates a new single file object based on the specified properties and source file.
Public Method CreateNewSFDObjectQuick | Creates a new single file object based on the specified properties and source file.
Public Method DelayedCheckIn | Performs check-in operation for the object after any of the object's files are no longer in use.
Public Method DeleteObject | Deletes the specified object.
Public Method DestroyObject | Destroys an object or a specific version of the object. Prefer DestroyObjectEx as its parameter ObjectVersion supports unmanaged external repository objects.
Public Method DestroyObjectEx | Destroys the specified object, or a specific version of the object.
Public Method DestroyObjects | Destroys the specified objects.
Public Method FollowObject | Starts or stops following the specified object. While the object is being followed, the current user will be notified if the object changes.
Public Method ForceUndoCheckout | Performs undo checkout and enforces the operation if the user has permission to perform forced undo checkout.
Public Method GetCollectionMembers | Gets all the collection members of the specified collection.
Public Method GetHistory | Gets the history of the specified object. Use GetHistoryEx for additional options.
Public Method GetHistoryEx | Gets the extended history of the specified object with search parameters.
Public Method GetLatestObjectVersionAndProperties | Gets the latest version and properties of the specified object.
Public Method GetLatestObjVer | Gets the latest version of the specified object.
Public Method GetLatestObjVerEx | Gets the latest version of the specified object. Optionally notifies M-Files windows to update the object in their listings.
Public Method GetMFilesURLForObject | Gets an M-Files URL for the specified object.
Public Method GetMFilesURLForObjectEx | Gets an M-Files URL for the specified object.
Public Method GetMFilesURLForObjectOrFile | Gets an M-Files URL for the specified object or file.
Public Method GetMFilesURLForObjectOrFileEx | Gets an M-Files URL for the specified object or file.
Public Method GetObjectDataOfMultipleObjects | Receives the requested information of the specified objects.
Public Method GetObjectGUID | Gets the Object GUID of the specified object.
Public Method GetObjectInfo | Gets information on the specified object version.
Public Method GetObjectInfoEx | Gets information on the specified object version. Optionally notifies M-Files windows to update the object in their listings.
Public Method GetObjectLocationsInView | Gets the locations of the object in a view.
Public Method GetObjectPermissions | Gets the permissions for the specified object.
Public Method GetObjectVersionAndProperties | Gets the information on and properties of the specfied object version.
Public Method GetObjectVersionAndPropertiesOfMultipleObjects | Gets the object version and properties of the specified objects.
Public Method GetObjIDByGUID | Gets the Object ID of the object that is identified by the specified Object GUID.
Public Method GetObjIDByOriginalObjID | Gets the Object ID of the object that is identified by the specified Original Vault GUID and Original Object ID.
Public Method GetOfflineAvailability | Gets the offline availability of the specified object.
Public Method GetOfflineObjIDs | Gets the IDs of the objects set to be available offline.
Public Method GetRelatedObjectInfo | Gets information related to the specified lookup property.
Public Method GetRelationships | Gets all the relationships of the specified object.
Public Method GetRelationshipsEx | Gets all the relationships of the specified object.
Public Method GetThumbnailAsBytes | Gets the thumbnail for the specified object in PNG format.
Public Method IsObjectCheckedOut | Checks whether the specified object is checked out to any user on any computer.
Public Method IsObjectCheckedOutToThisUserOnThisComputer | Checks whether the specified object is checked out to this user on this computer.
Public Method IsObjectFollowed | Checks whether the specified object is currently followed by the current user.
Public Method IsSingleFileObject | Checks whether the specified object version is a single-file or multi-file document.
Public Method MatchesSearchConditions | Checks whether the specified object matches the search conditions. Any field expression in search conditions is not supported.
Public Method MatchesSearchConditionsEx | Checks whether the specified object and properties match the search conditions. Any field expression in search conditions is not supported.
Public Method NotifyObjectAccess | Notifies M-Files that an object has been accessed. This will add the object to the Recently Accessed by Me view of the user.
Public Method ProposeCheckOutForFile | Proposes checkout operation for the object file. System may prompt for checkout. Returns error on cancel.
Public Method RejectCheckInReminder | Prevents implicitly or explicitly triggered checkin reminder from calling process.
Public Method RemoveFavorite | Removes the specified object from the 'Favorites' view of the current user.
Public Method RemoveFavorites | Removes the specified objects from the 'Favorites' view of the current user.
Public Method ResolveConflict | Resolves a conflict that involves the specified participant object. Returns the affected objects. Do not use this method if the vault uses automatic conflict resolution.
Public Method Rollback | Rolls back the specified object to the specified version. Prefer RollbackEx as its parameter RollbackToVersion supports unmanaged external repository objects.
Public Method RollbackEx | Rolls back the specified object to the specified version.
Public Method SetExternalID | Sets the external ID for an object. The object itself must be internal.
Public Method SetObjectGUID | Sets the Object GUID of the specified object.
Public Method SetOfflineAvailability | Marks the specified object for offline availability, or clears the offline availability marker.
Public Method SetSingleFileObject | Changes the single-file status of the specified object.
Public Method ShowBasicEditObjectWindow | Displays the edit object metadata window.
Public Method ShowBasicNewObjectWindow | Displays the new object metadata window.
Public Method ShowChangeStateDialogModal | Displays the 'Change State' dialog box for the object.
Public Method ShowCheckInReminder | Displays the checkin reminder for the specified object. Can fail if the object is open in another program.
Public Method ShowCheckInReminderDialogModal | Displays a modal checkin reminder dialog for the specified object. Does not perform the actual check in operation. Returns error on cancel.
Public Method ShowCheckoutPrompt | Displays the object checkout prompt for the user.
Public Method ShowCollectionMembersDialog | Displays the collection members dialog box for the object.
Public Method ShowCommentsDialogModal | Displays the comments dialog box for the object.
Public Method ShowEditObjectWindow | Displays the edit object metadata window.
Public Method ShowHistoryDialogModal | Displays the history dialog box for the object.
Public Method ShowNewObjectWindow | Displays the new object metadata window.
Public Method ShowPrefilledNewObjectWindow | Displays a new object metadata window.
Public Method ShowRelatedObjects | Shows related objects for the object by target object type in Windows Explorer.
Public Method ShowRelationshipsDialog | Displays the relationships dialog box for the object.
Public Method ShowSelectObjectHistoryDialogModal | Displays the history dialog box for the object.
Public Method ShowSubObjectsDialogModal | Displays the sub-objects dialog box for the object.
Public Method UndeleteObject | Undeletes the specified object.
Public Method UndoCheckout | Performs undo checkout for the specified object version.
Public Method UndoCheckoutMultipleObjects | Performs undo checkout for the specified object versions.

See Also

VaultObjectOperations Object


%%PageItemTitle%% $$Members$$

VaultObjectPropertyOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method ApproveOrRejectAssignment | Marks the assignment as approved or rejected by the logged-in user.
Public Method ApproveOrRejectAssignmentByUser | Marks the assignment as approved or rejected by the specified user.
Public Method ClearArchivingMarker | Clears the archiving marker of the object.
Public Method CreatePropertiesFromFileInformation | Creates properties based on the given file information.
Public Method GenerateAutomaticPermissionsFromPropertyValues | Generates the automatic permissions components from the specifies property values.
Public Method GetProperties | Gets all the properties of the specified object version.
Public Method GetPropertiesAsXML | Gets the properties of the specified object version as XML.
Public Method GetPropertiesForDisplay | Gets the properties of the specified object version for display purposes.
Public Method GetPropertiesForMetadataSync | Gets the direct and indirect properties of the specified object version for the purpose of synchronizing file content with current metadata.
Public Method GetPropertiesForMetadataSyncEx | Gets the direct and indirect properties of the specified object version to synchronize the file content with the current metadata.
Public Method GetPropertiesForMetadataSyncWithMetadataReferenceFilter | Gets the direct and indirect properties of the specified object version to synchronize the file content with the current metadata.
Public Method GetPropertiesOfMultipleObjects | Gets the properties of multiple objects.
Public Method GetPropertiesOfMultipleObjectsForDisplay | Gets the properties of the specified object versions for display purposes.
Public Method GetPropertiesWithIconClues | Gets all the properties of the specified object version with icon clues.
Public Method GetPropertiesWithIconCluesOfMultipleObjects | Gets the properties of multiple objects with icon clues.
Public Method GetProperty | Gets the specified property value of the specified object version.
Public Method GetVersionComment | Gets the version comment of the specified object.
Public Method GetVersionCommentHistory | Gets the version comment history of the specified object.
Public Method GetWorkflowState | Gets the workflow of the specified object.
Public Method MarkAssignmentComplete | Marks the assignment as completed by the logged-in user.
Public Method MarkAssignmentCompleteByUser | Marks the assignment as completed by the specified user.
Public Method MarkForArchiving | Marks the object for archiving.
Public Method RemoveProperty | Removes the specified property value from the specified object version.
Public Method SetAllProperties | Sets all the properties of the specified object.
Public Method SetAllPropertiesEx | Sets all the properties of the specified object.
Public Method SetAllPropertiesWithPermissions | Sets all the properties and permissions of the specified object.
Public Method SetAllPropertiesWithPermissionsEx | Sets all the properties and permissions of the specified object.
Public Method SetCreationInfoAdmin | Sets the creation info of the specified object. Returns the properties of the specified object after modification.
Public Method SetLastModificationInfoAdmin | Sets the last modified info of the specified object version. Returns the properties of the specified object after modification.
Public Method SetProperties | Sets all the properties of the specified object version.
Public Method SetPropertiesEx | Sets the specified properties of the specified object version.
Public Method SetPropertiesOfMultipleObjects | Sets the properties of multiple objects.
Public Method SetPropertiesWithPermissions | Sets all the properties and permissions of the specified object version.
Public Method SetPropertiesWithPermissionsEx | Sets all the properties and permissions of the specified object version.
Public Method SetProperty | Sets the specified property value of the specified object version.
Public Method SetVersionComment | Sets the version comment for the specified object.
Public Method SetWorkflowState | Sets the workflow for the specified object.
Public Method SetWorkflowStateEx | Sets the workflow for the specified object.
Public Method SetWorkflowStateTransition | Sets the workflow state transition for the specified object.
Public Method SetWorkflowStateTransitionEx | Sets the workflow state transition for the specified object with an electronic signature.

See Also

VaultObjectPropertyOperations Object


%%PageItemTitle%% $$Members$$

VaultObjectSearchOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method FindFile | Gets a file based on the specified relative path.
Public Method FindObjectVersionAndProperties | Gets an object based on the specified relative path starting from the vault root.
Public Method GetFacetValues | Retrieves the facet values for the objects that satisfy the specified search conditions.
Public Method GetFacetValuesByPath | Retrieves the facet values for the objects that satisfy the search conditions extracted from the temporary search view specified by the path.
Public Method GetObjectCountInSearch | Gets the number of objects found with the specified search.
Public Method GetObjectsInPath | Gets objects by the path specified. This method can be used in offline mode.
Public Method GetSearchHits | Determines the search hits in the given text input.
Public Method IsObjectPathInMFiles | Checks whether the specified relative path refers to an object in M-Files.
Public Method SearchForObjectsByCondition | Searches the vault for objects that match the specified condition. Only the latest versions are searched for.
Public Method SearchForObjectsByConditions | Searches for objects with the specified search conditions.
Public Method SearchForObjectsByConditionsEx | Searches the vault for objects that match the specified conditions.
Public Method SearchForObjectsByConditionsXML | Searches the vault for objects that match the given search conditions. The results are returned in XML form.
Public Method SearchForObjectsByExportedSearchConditions | Searches the vault for objects that match the specified exported search string.
Public Method SearchForObjectsByExportedSearchConditionsXML | Searches the vault for objects that match the specified search string. The results are returned in XML form.
Public Method SearchForObjectsByString | Searches the vault for objects that match the specified string.

See Also

VaultObjectSearchOperations Object


%%PageItemTitle%% $$Members$$

VaultObjectTypeOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddObjectTypeAdmin | Adds a new object type or value list. Returns the created object type, with the ID property set to the real ID value.
Public Method GetBuiltInObjectType | Gets an object type representing a built-in real object type.
Public Method GetExternalObjectTypePluginConfigurationDomainIdAdmin | Gets the configuration domain ID of the specified external object type plugin (for administrative operations).
Public Method GetExternalObjectTypePluginConfigurationInfoAdmin | Gets information on the configuration of the specified external object type plugin (for administrative operations).
Public Method GetExternalObjectTypePluginInfosAdmin | Gets all external object type plugins (for administrative operations).
Public Method GetObjectType | Gets information on the specified object type or value list. In the client interface mode, this method supports getting a real object type only. Use the GetValueList method for retrieving a value list.
Public Method GetObjectTypeAdmin | Gets information on the specified object type or value list (for administrative operations).
Public Method GetObjectTypeIDByAlias | Gets the ID of the object type or value list with the specified alias. Returns -1 if a match is not found or if more than one object type or value list uses the specified alias.
Public Method GetObjectTypeIDByGUID | Gets the ID of the object type or value list with the specified GUID. Returns -1 if a match is not found.
Public Method GetObjectTypes | Gets all real object types.
Public Method GetObjectTypesAdmin | Gets all real object types (for administrative operations).
Public Method RefreshExternalObjectType | Refreshes an external object type or value list.
Public Method RefreshExternalObjectTypeColumnMappingsAdmin | Refreshes the column mappings of an external object type. Returns the object type with refreshed column mappings.
Public Method RemoveObjectTypeAdmin | Deletes the specified object type or value list.
Public Method UpdateObjectTypeAdmin | Updates the object type or value list. The ID property identifies the object type to modify. Returns the updated object type.
Public Method UpdateObjectTypeWithAutomaticPermissionsAdmin | Updates the object type or value list. The ID property identifies the object type to modify. Returns the updated object type.

See Also

VaultObjectTypeOperations Object


%%PageItemTitle%% $$Members$$

VaultOnServer Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method LogIn | Logs in to the vault with the same credentials that were used to log in to the server. Use the LogInEx method for additional options.
Public Method LogInAsUser | Logs in to the vault.
Public Method LogInAsUserEx | Logs in to the vault.
Public Method LogInAsUserWithAuthenticationData | Logs in to the vault with the specified authentication data.
Public Method LogInAsUserWithSPN | Logs in to the vault with specified credentials and SPN.
Public Method LogInEx | Logs in to the vault with the same credentials that were used to log in to the server.

Public Properties

Public Property GUID | Gets the GUID of the vault on the server.
Public Property Name | Gets the name of the vault on the server.

See Also

VaultOnServer Object


%%PageItemTitle%% $$Members$$

VaultProperties Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a clone of this object.

Public Properties

Public Property AdvancedEventLog | Specifies whether Advanced Event Log features are enabled in this vault.
Public Property DisplayName | The display name of the vault.
Public Property EncryptionOfFileDataAtRest | Specifies whether encryption of file data at rest is enabled in this vault.
Public Property ExtendedMetadataDrivenPermissions | Specifies whether the extended metadata-driven permissions are used in this vault.
Public Property FileDataConnectionString | The connection string that identifies the location, protocol, and credentials for the file data storage of this vault. For example, this might specify a storage account, a protocol, and a container name for Azure's BLOB Services. Can be NULL or empty.
Public Property FileDataStorageType | File data storage type.
Public Property FullTextSearchLanguage | Specifies the language used in full-text search.
Public Property Icon | If not NULL, contains the icon of this item in .ICO format.
Public Property MainDataFolder | The main physical folder of this vault on the server (e.g. C:\Program Files\M-Files\Server Vaults\MyVault).
Public Property SeparateLocationForFileData | If not empty, specifies a separate location for file data. Currently up to one separate location is supported.
Public Property SQLDatabase | The vault's SQL database.
Public Property VaultGUID | The unique identifier of the vault.

See Also

VaultProperties Object


%%PageItemTitle%% $$Members$$

VaultPropertyDefOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddPropertyDefAdmin | Adds a new property definition. Returns the created property definition, with the ID property set to the real ID value.
Public Method GetBuiltInPropertyDef | Gets the specified built-in property definition from the vault.
Public Method GetPropertyDef | Gets the specified property definition from the vault.
Public Method GetPropertyDefAdmin | Gets the specified property definition from the vault (for administrative operations).
Public Method GetPropertyDefIDByAlias | Gets the ID of the property definition with the specified alias. Returns -1 if a match is not found or if more than one property definition uses the specified alias.
Public Method GetPropertyDefIDByGUID | Gets the ID of the property definition with the specified GUID. Returns -1 if a match is not found.
Public Method GetPropertyDefs | Gets all property definitions in the vault.
Public Method GetPropertyDefsAdmin | Gets all property definitions (for administrative operations).
Public Method Recalculate | Recalculates the automatically generated values for the specified property in all existing objects.
Public Method RemovePropertyDefAdmin | Deletes the property definition with the specified ID.
Public Method UpdatePropertyDefAdmin | Updates the property definition. The ID property identifies the property definition to modify. If ResetLastUsedValue is not NULL, it specifies the new Last Used Value for an autonumbering property.
Public Method UpdatePropertyDefWithAutomaticPermissionsAdmin | Updates the property definition. The ID property identifies the property definition to modify. If ResetLastUsedValue is not NULL, it specifies the new Last Used Value for an autonumbering property.

See Also

VaultPropertyDefOperations Object


%%PageItemTitle%% $$Members$$

VaultScheduledJobManagementOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddScheduledJob | Add the specified scheduled job to the vault.
Public Method CancelScheduledJob | Cancels the execution of the specified scheduled job.
Public Method GetScheduledJob | Gets the specified scheduled job.
Public Method GetScheduledJobRunInfo | Gets run information on the specified scheduled job.
Public Method GetScheduledJobs | Gets all scheduled jobs in the vault.
Public Method ModifyScheduledJob | Modifies the specified scheduled job in the vault.
Public Method RemoveScheduledJob | Deletes the specified scheduled job from the vault.
Public Method StartScheduledJob | Starts the execution of the specified scheduled job.

See Also

VaultScheduledJobManagementOperations Object


%%PageItemTitle%% $$Members$$

VaultServerAttachment Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Makes a copy of the "IVaultServerAttachment" object.

Public Properties

Public Property Address | The host address of the server to which the vault is attached.
Public Property HostName | The host name of the server to which the vault is attached.
Public Property IsCurrent | When this is true, this server is the one the vault is currently attached to.
Public Property LatestTimestamp | The date and time this information was last updated.
Public Property ServerID | The ID of the server to which the vault is attached.

See Also

VaultServerAttachment Object


%%PageItemTitle%% $$Members$$

VaultServerAttachments Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Clone | Creates a copy of the object.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

VaultServerAttachments Collection


%%PageItemTitle%% $$Members$$

VaultServerDataPushOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method CloneVaultForServerDataPush | Creates a clone of the vault object and registers a data push sink to trigger only for the methods that are used with the cloned vault.
Public Method SendCancel | Informs the server that the client wants to cancel the operation.
Public Method SendError | Informs the server that an error occurred in the client operation.
Public Method SendHeartbeat | Informs the server that the client will provide a response later.
Public Method SendResponse | Sends a response to the server request.
Public Method SetServerDataPushSink | Registers a client listener to receive server data push notifications.

See Also

VaultServerDataPushOperations Object


%%PageItemTitle%% $$Members$$

VaultSharedLinkOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method CreateSharedLink | Create a new public link to the server.
Public Method DeleteSharedLink | Delete a public link.
Public Method GetSharedLink | Gets information on the specified public link.
Public Method GetSharedLinks | Gets all available public links in this vault.
Public Method GetSharedLinksByObject | Gets all the shared links of the given object.

See Also

VaultSharedLinkOperations Object


%%PageItemTitle%% $$Members$$

VaultsOnServer Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetVaultByGUID | Gets vault by GUID.
Public Method GetVaultByName | Gets vault by name.
Public Method GetVaultIndexByGUID | Gets vault index by GUID. -1 indicates that item was not found.
Public Method GetVaultIndexByName | Gets vault index by name. -1 indicates that item was not found.

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

VaultsOnServer Collection


%%PageItemTitle%% $$Members$$

VaultTraditionalFolderOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method GetTraditionalFolderContents Retrieves the traditional folder contents.

See Also

VaultTraditionalFolderOperations Object


%%PageItemTitle%% $$Members$$

VaultUserGroupOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddOrUndeleteUserGroup | Adds a new user group or undeletes an existing one.
Public Method AddUserGroupAdmin | Adds a new user group. Returns the created user group, with the ID property set to the real ID value.
Public Method GetGroupsOfUserOrGroup | Gets all the groups that the specifed user or group belongs to.
Public Method GetUserContainersAdmin | Gets all user containers.
Public Method GetUserGroup | Gets the specified user group.
Public Method GetUserGroupAdmin | Gets the specified user group (for administrative operations).
Public Method GetUserGroupIDByAlias | Gets the ID of the user group with the specified alias. Returns -1 if a match is not found or if more than one user group uses the specified alias.
Public Method GetUserGroupIDByGUID | Gets the ID of the user group with the specified GUID. Returns -1 if a match is not found.
Public Method GetUserGroupList | Gets the user group listing as key name pairs.
Public Method GetUserGroups | Gets all user groups.
Public Method GetUserGroupsAdmin | Gets all user groups.
Public Method RemoveUserGroupAdmin | Deletes the user group with specified ID.
Public Method UpdateUserGroupAdmin | Updates the user group. The ID property identifies the user group to modify.

See Also

VaultUserGroupOperations Object


%%PageItemTitle%% $$Members$$

VaultUserOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddOrUndeleteUserAccount | Adds the given user account to the vault (or undeletes it).
Public Method AddUserAccount | Adds the given user account to the vault. Returns the created user account, with the ID property set to the real ID value.
Public Method GetLoginAccountOfUser | Gets the login account that corresponds to the specified vault user.
Public Method GetLoginAccounts | Gets the login accounts of all vault users.
Public Method GetUserAccount | Retrieves a single user account.
Public Method GetUserAccounts | Gets available user accounts from the vault.
Public Method GetUserIDByGUID | Gets the ID of the user with the specified GUID. Returns -1 if a match is not found.
Public Method GetUserList | Gets all users as key name pairs.
Public Method ModifyUserAccount | Modifies the user account.
Public Method RemoveUserAccount | Deletes the user account from vault.
Public Method UndeleteUserAccountByGUID | Attempts to undelete a user with the specified GUID and to set its account information. Does not create new accounts.

See Also

VaultUserOperations Object


%%PageItemTitle%% $$Members$$

VaultUserOperationsEx Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddMemberToUserGroup | Adds a user or a user group to the targeted user group if the item to be added is not yet a member of that group.
Public Method RemoveMemberFromUserGroup | Removes the specified member from the given user group.
Public Method SearchForUserAccount | Retrieves a single user account based on the specified account name.

See Also

VaultUserOperationsEx Object


%%PageItemTitle%% $$Members$$

VaultUserSettingOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method ChangeVaultLanguage | Changes the vault language for the current user.
Public Method GetSubstituteUsers | Gets the substitute users of the current user.
Public Method GetSubstituteUsersOfUser | Gets the substitute users of a specific user.
Public Method GetUsersBySubstituteUser | Gets the users for whom the specific user is a substitute.
Public Method GetVaultLanguage | Gets the vault language for the current user.
Public Method GetVaultLanguageCode | Gets the vault language code for the current user.
Public Method SetSubstituteUsers | Sets the substitute users of the current user.

See Also

VaultUserSettingOperations Object


%%PageItemTitle%% $$Members$$

VaultValueListItemOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddValueListItem | Adds a new value list item to a value list.
Public Method ChangeAutomaticPermissionsToACL | Changes the automatic permissions for the specified value list item. The specified automatic permissions will be applied to an object when the user selects this value list item in the metadata card of the object.
Public Method ChangeAutomaticPermissionsToACLEx | Changes the automatic permissions for the specified value list item.
Public Method ChangeAutomaticPermissionsToItemsOwnPermissions | Changes the automatic permissions for the specified value list item to match those of its own permissions. The specified automatic permissions will be applied to an object when the user selects this value list item in the metadata card of the object.
Public Method ChangeAutomaticPermissionsToItemsOwnPermissionsEx | Changes the automatic permissions for the specified value list item to match those of its own permissions.
Public Method ChangeAutomaticPermissionsToNamedACL | Changes the automatic permissions for the specified value list item. The specified automatic permissions will be applied to an object when the user selects this value list item in the metadata card of the object.
Public Method ChangeAutomaticPermissionsToNamedACLEx | Changes the automatic permissions for the specified value list item.
Public Method ChangePermissionsToACL | Changes the permissions for the specified value list item.
Public Method ChangePermissionsToACLEx | Changes the permissions for the specified value list item.
Public Method ChangePermissionsToNamedACL | Changes the permissions for the specified value list item.
Public Method ChangePermissionsToNamedACLEx | Changes the permissions for the specified value list item.
Public Method ClearAutomaticPermissions | Clears the automatic permissions from the specified value list item. This prevents any permissions from being set to an object as a result of this value list item being selected.
Public Method ClearAutomaticPermissionsEx | Clears the automatic permissions of the specified value list item.
Public Method GetReferencedValueListItemsInIdOrder | Gets value list items that are referenced by one or more documents (possibly limiting the set of documents with conditions) in ID order.
Public Method GetValueListItemByDisplayID | Gets a value list item from the specified value list, using the display ID (external ID) of the item.
Public Method GetValueListItemByDisplayIDEx | Gets a value list item from the specified value list, using the display ID (external ID) of the item.
Public Method GetValueListItemByGUID | Gets a value list item from the specified value list by using the GUID of the item.
Public Method GetValueListItemByID | Gets a value list item from the specified value list, using the internal ID of the item.
Public Method GetValueListItemByIDEx | Gets a value list item from the specified value list, using the internal ID of the item.
Public Method GetValueListItemByIDEx2 | Gets a value list item from the specified value list, using the internal ID of the item.
Public Method GetValueListItemIDByGUID | Gets the ID of the value list item with the specified GUID. Returns -1 if a match is not found.
Public Method GetValueListItems | Gets the value list items of a value list.
Public Method GetValueListItemsEx | Gets the value list items of a value list.
Public Method GetValueListItemsEx2 | Gets the value list items of a value list.
Public Method GetValueListItemsInIdOrder | Gets the items of a value list ordered by ID.
Public Method GetValueListItemsWithPermissions | Gets the value list items of a value list.
Public Method RemoveValueListItem | Deletes a value list item.
Public Method RemoveValueListItemEx | Deletes a value list item.
Public Method SearchForValueListItemsEx | Searches for value list items in the specified value list
Public Method SearchForValueListItemsEx2 | Searches for value list items in the specified value list
Public Method SearchForValueListItemsWithPermissions | Searches for value list items in the specified value list
Public Method UndeleteValueListItem | Undeletes a previously deleted value list item.
Public Method UndeleteValueListItemEx | Undeletes a previously deleted value list item.
Public Method UpdateValueListItem | Updates the value list item.

See Also

VaultValueListItemOperations Object


%%PageItemTitle%% $$Members$$

VaultValueListOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddValueListAdmin | Adds a new value list or object type. Returns the created value list, with the ID property set to the real ID value.
Public Method GetBuiltInValueList | Gets a built-in value list or object type.
Public Method GetValueList | Gets a single value list or object type.
Public Method GetValueListAdmin | Gets information on the specified value list or object type (for administrative operations).
Public Method GetValueListIDByAlias | Gets the ID of the object type or value list with the specified alias. Returns -1 if a match is not found or if more than one object type or value list uses the specified alias.
Public Method GetValueListIDByGUID | Gets the ID of the object type or value list with the specified GUID. Returns -1 if a match is not found.
Public Method GetValueLists | Gets the value lists and object types of the vault.
Public Method GetValueListsAdmin | Gets all value lists and object types (for administrative operations).
Public Method RefreshExternalValueList | Refreshes an external value list or object type.
Public Method RemoveValueListAdmin | Deletes the specified value list or object type.
Public Method UpdateValueListAdmin | Updates the value list or object type. The ID property identifies the value list to be modified. Returns the updated value list.
Public Method UpdateValueListWithAutomaticPermissionsAdmin | Updates the value list or object type. The ID property identifies the value list to be modified. Returns the updated value list.

See Also

VaultValueListOperations Object


%%PageItemTitle%% $$Members$$

VaultViewOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddOfflineFilter | Adds a new offline filter. Returns the added filter view.
Public Method AddTemporarySearchViewEx | Adds a temporary search view. Returns the added view.
Public Method AddView | Adds a new view. Returns the added view.
Public Method FindPropertyFolderLocationInView | Gets the locations of a property folder in a view.
Public Method GetBuiltInView | Gets a built-in view.
Public Method GetFolder | Gets the specified folder in the vault.
Public Method GetFolderContents | Gets the contents of the specified folder.
Public Method GetFolderNameListing | Gets the folder names inside a folder specified by the property conditions.
Public Method GetFolderUIStateForFolder | Retrieves the UI settings of a specified folder.
Public Method GetFolderUIStateForSpecialLocation | Retrieves the UI settings of a specified folder.
Public Method GetIconAsBytes | Gets the external repository icon in PNG format.
Public Method GetMFilesURLForView | Gets an M-Files URL for a view.
Public Method GetPropertyValuesOfFolder | Extracts as many property values from the given folder location as possible for the purposes of prefilling metadata when creating new objects of the specified type. May return zero or more property values.
Public Method GetPropertyValuesOfPath | Extracts as many property values from the given path string as possible for the purposes of prefilling metadata when creating new objects of the specified type. May return zero or more property values. Does not fail if the path no longer exists.
Public Method GetTemporarySearchByPath | Gets information on the temporary search view specified by the path.
Public Method GetTemporarySearchView | Gets information on the specified temporary search view.
Public Method GetView | Gets the specified view in the vault.
Public Method GetViewIDByGUID | Gets the ID of the metadata structure element with the specified GUID. Returns -1 if a match is not found.
Public Method GetViewLocationInClient | Gets the view locations.
Public Method GetViews | Gets all views of the vault.
Public Method GetViewsAdmin | Gets the common views and/or views for a specific user.
Public Method ModifyTemporarySearch | Modifies the temporary search view.
Public Method RemoveView | Deletes the specified view.
Public Method RequestClientDirectoryRefresh | Requests the client cache refresh for a directory structure.
Public Method ResetFolderUIStateForFolder | Resets the UI settings of a specified folder to program defaults or common defaults.
Public Method ResetFolderUIStateForSpecialLocation | Resets the UI settings of a specified folder to program defaults or common defaults.
Public Method SaveFolderUIStateForFolder | Saves the UI settings of a specified folder.
Public Method SaveFolderUIStateForSpecialLocation | Saves the UI settings of a specified folder.
Public Method SetViewVisibility | Sets the visibility of a view for the user in the default listing of the view.
Public Method ShowViewOrPropertyFolder | Shows the given view or property folder.
Public Method UpdateView | Updates the specified view. Returns the updated view.

See Also

VaultViewOperations Object


%%PageItemTitle%% $$Members$$

VaultWOPIOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method CreateWOPIUserSession Creates the WOPI user session.

See Also

VaultWOPIOperations Object


%%PageItemTitle%% $$Members$$

VaultWorkflowOperations Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method AddWorkflowAdmin | Adds a new workflow. Returns the created workflow, with the ID property set to the real ID value.
Public Method GetStateTransitionSignatureSettings | Receives the signature settings for a state transition.
Public Method GetStateTransitionSignatureSettingsByID | Receives the signature settings for a state transition.
Public Method GetWorkflowAdmin | Receives the specified workflow (for administrative operations).
Public Method GetWorkflowForClient | Receives the specified workflow in a format suitable for client.
Public Method GetWorkflowIDByAlias | Receives the ID of the workflow with the specified alias. Returns -1 if a match is not found or if more than one workflow uses the specified alias.
Public Method GetWorkflowIDByGUID | Receives the ID of the workflow with the specified GUID. Returns -1 if a match is not found.
Public Method GetWorkflowsAdmin | Receives all workflows (for administrative operations).
Public Method GetWorkflowsAsValueListItems | Receives all workflows.
Public Method GetWorkflowsForClient | Receives all workflows in a format suitable for client.
Public Method GetWorkflowStateIDByAlias | Receives the ID of the workflow state with the specified alias. Returns -1 if a match is not found or if more than one workflow state uses the specified alias.
Public Method GetWorkflowStateIDByGUID | Receives the ID of the workflow state with the specified GUID. Returns -1 if a match is not found.
Public Method GetWorkflowStates | Receives all states of the specified workflow.
Public Method GetWorkflowStatesEx | Receives all states of the specified workflow. The selectable flag of each state is determined based on the specified current state and object version.
Public Method GetWorkflowStateTransitionIDByAlias | Receives the ID of the workflow state transition with the specified alias. Returns -1 if a match is not found or if more than one workflow state transition uses the specified alias.
Public Method GetWorkflowStateTransitionIDByGUID | Receives the ID of the workflow state transition with the specified GUID. Returns -1 if a match is not found.
Public Method GetWorkflowStateTransitions | Receives all state transitions of the specified workflow.
Public Method GetWorkflowStateTransitionsAsJSON | Receives the state transitions as a JSON string. The 'Selectable' flag of each transition is determined based on the specified current state and object version.
Public Method GetWorkflowStateTransitionsEx | Receives all the state transitions of the specified workflow. The 'Selectable' flag of each state transition is determined based on the specified current state and object version.
Public Method RemoveWorkflowAdmin | Deletes the workflow with the specified ID.
Public Method RemoveWorkflowsAdmin | Deletes the workflows with the specified IDs.
Public Method UpdateWorkflowAdmin | Updates the workflow. The ID property identifies the workflow to modify. Returns the updated workflow.

See Also

VaultWorkflowOperations Object


%%PageItemTitle%% $$Members$$

VerifyVaultJob Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a clone of this object.
Public Method GetNumberOfSteps | Gets the number of steps in this job.
Public Method GetOneBasedIndexOfStep | Gets the one-based index of the step.
Public Method GetStepProgressText | Gets the progress text for a step.
Public Method Set | Sets the job information.

Public Properties

Public Property FixErrors | Specifies whether this job should attempt to fix the detected errors.
Public Property VaultGUID | The GUID of the vault.
Public Property VerifyFileContents | Specifies whether this job verifies the integrity of the data files on disk.

See Also

VerifyVaultJob Object


%%PageItemTitle%% $$Members$$

VerifyVaultJobOutput Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Errors The error output of the verify vault job.

See Also

VerifyVaultJobOutput Object


%%PageItemTitle%% $$Members$$

VersionComment Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property LastModifiedBy | Last modified by.
Public Property ObjVer | Object version.
Public Property StatusChanged | Status changed.
Public Property VersionComment | Version comment.

See Also

VersionComment Object


%%PageItemTitle%% $$Members$$

VersionComments Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

VersionComments Collection


%%PageItemTitle%% $$Members$$

View Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method CloneFrom | Copies the content to this object from another object.

Public Properties

Public Property AccessControlList | The access control list of the view.
Public Property Common | Specifies whether the view is a common view.
Public Property GUID | The GUID of the view as a string.
Public Property HasParent | Specifies whether the view has a parent.
Public Property ID | The ID of the view.
Public Property Levels | The hierarchy level definitions of the view.
Public Property LookInAllVersions | Specifies whether the view looks match in all versions or in only the latest versions.
Public Property Name | The name of the view.
Public Property Parent | The parent of the view. This is valid only if the view has a parent.
Public Property ReturnLatestVisibleVersion | Specifies whether the view returns the latest visible versions or the latest matching versions.
Public Property SearchConditions | The search conditions of the view.
Public Property SearchDef | The search definition of the view.
Public Property SearchFlags | The search flags of the view.
Public Property ViewFlags | Bit flags that provide additional information on the view.
Public Property ViewLocation | The view location of the view.
Public Property ViewType | The type of the view.
Public Property Visible | Specifies whether the view is visible.

See Also

View Object


%%PageItemTitle%% $$Members$$

ViewLocation Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property OverlappedFolder | Specifies the property folder this view is overlapping. Valid only if this view location is defined to overlap a property folder.
Public Property Overlapping | Specifies whether the view in this location should replace a property folder in the parent folder.
Public Property ParentFolder | The folder path to the parent folder of the view.

See Also

ViewLocation Object


%%PageItemTitle%% $$Members$$

Views Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

Views Collection | View Object


%%PageItemTitle%% $$Members$$

WeeklyTrigger Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property DaysOfTheWeek | Value that describes the days of the week the scheduled job runs. The value can be a combination of the values of the enumeration.
Public Property WeeksInterval | Number of weeks between invocations of a scheduled job.

See Also

WeeklyTrigger Object


%%PageItemTitle%% $$Members$$

WOPIClientAdditionalData Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ActionUrl | The ActionUrl data.
Public Property CultureIdentifier | The CultureIdentifier data.
Public Property HostEditUrl | The HostEditUrl data.
Public Property MainAppURL | The MainAppURL part.
Public Property ReturnURI | The ReturnURI data.
Public Property WOPIEndPoint | The WOPIEndPoint data.

See Also

WOPIClientAdditionalData Object


%%PageItemTitle%% $$Members$$

WOPILock Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Lock The Lock data.

See Also

WOPILock Object


%%PageItemTitle%% $$Members$$

WOPIUserSession Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property ActionType | The WOPI action type.
Public Property CsrfToken | The CSRF token.
Public Property ExternalUsername | The name of the external user.
Public Property IsCoauthor | Specifies whether the file is co-authored.
Public Property IsEditAllowed | If this is set to true, the file can be edited in this WOPI user session.
Public Property IsSharedFile | Specifies whether the file is shared.
Public Property Onetimetoken | The one-time token.
Public Property UserAccountName | The name of the user account.
Public Property UserID | The user ID.
Public Property WOPIAccesskey | The unique access key of the public link.
Public Property WOPIUserSessionKey | The unique user session key.

See Also

WOPIUserSession Object


%%PageItemTitle%% $$Members$$

Workflow Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone | Creates a copy of the object.
Public Method GetAsLookup | Gets this workflow as a lookup value.
Public Method GetAsTypedValue | Gets this workflow as a single-select lookup based typed value.

Public Properties

Public Property ID | Workflow ID.
Public Property Name | Workflow name.
Public Property ObjectClass | The class this workflow can be used with. Can be MFBuiltInObjectClassAny.

See Also

Workflow Object


%%PageItemTitle%% $$Members$$

WorkflowAdmin Object Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Clone Creates a copy of the object.

Public Properties

Public Property Description | Workflow description.
Public Property Permissions | Permissions.
Public Property SemanticAliases | The semantic aliases of this workflow.
Public Property States | The states of this workflow.
Public Property StateTransitions | The state transitions of this workflow.
Public Property Workflow | Basic information on the workflow.

See Also

WorkflowAdmin Object


%%PageItemTitle%% $$Members$$

Workflows Collection Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property Count | The number of items in the collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

Workflows Collection


%%PageItemTitle%% $$Members$$

WorkflowsAdmin Collection Members
See Also Overview Send comments

Glossary Item Box

Public Methods

Public Method Add | Adds the item to the collection at the specified position.
Public Method Remove | Removes the item at the specified position from the collection.

Public Properties

Public Property Count | Returns the number of items in this collection.
Public Property Item | Accesses the item at the specified position in the collection.

See Also

WorkflowsAdmin Collection


%%PageItemTitle%% $$Members$$

XMLSearchResult Object Members
See Also Overview Send comments

Glossary Item Box

Public Properties

Public Property MoreResults | Specifies whether more results are available.
Public Property SearchResult | The search result as XML.

See Also

XMLSearchResult Object